Calc Guide

6.2
Copyright

This document is Copyright © 2019 by the LibreOffice Documentation Team. Contributors are listed below. You may distribute it and/or modify it under the terms of either the GNU General Public License (http://www.gnu.org/licenses/gpl.html), version 3 or later, or the Creative Commons Attribution License (http://creativecommons.org/licenses/by/4.0/), version 4.0 or later.

All trademarks within this guide belong to their legitimate owners.

Contributors

This book is adapted and updated from LibreOffice Calc Guide 4.1.

To this edition
Jean Hollis Weber  Dave Barton  Olivier Hallot
Cathy Crumbley  Kees Kriek  Claire Wood
Steve Fanning  Zachary Parliman

To previous editions
John A Smith  Jean Hollis Weber  Martin J Fox
Andrew Pitonyak  Simon Brydon  Gabriel Godoy
Barbara Duprey  Gabriel Godoy  Peter Schofield
John A Smith  Christian Chenal  Laurent Ballard-Poirier
Philippe Clément  Pierre-Yves Samyn  Shelagh Manton
Peter Kupfer  Andy Brown  Stephen Buck
Iain Roberts  Hazel Russman  Barbara M. Tobias
Jared Kobos  Martin Saffron

Feedback

Please direct any comments or suggestions about this document to the Documentation Team’s mailing list: documentation@global.libreoffice.org

Note

Everything you send to a mailing list, including your email address and any other personal information that is written in the message, is publicly archived and cannot be deleted.

Publication date and software version

Published December 2019. Based on LibreOffice 6.2.

Documentation for LibreOffice is available at https://documentation.libreoffice.org/en/
## Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copyright</td>
<td>2</td>
</tr>
<tr>
<td>Preface</td>
<td>8</td>
</tr>
<tr>
<td>Who is this book for?</td>
<td>9</td>
</tr>
<tr>
<td>What's in this book?</td>
<td>9</td>
</tr>
<tr>
<td>Where to get more help</td>
<td>9</td>
</tr>
<tr>
<td>What you see may be different</td>
<td>11</td>
</tr>
<tr>
<td>Using LibreOffice on macOS</td>
<td>12</td>
</tr>
<tr>
<td>What are all these things called?</td>
<td>12</td>
</tr>
<tr>
<td>Frequently asked questions</td>
<td>13</td>
</tr>
<tr>
<td>What's new in LibreOffice Calc 6.2?</td>
<td>14</td>
</tr>
<tr>
<td>Chapter 1 Introducing Calc</td>
<td>15</td>
</tr>
<tr>
<td>What is Calc?</td>
<td>16</td>
</tr>
<tr>
<td>Spreadsheets, sheets, and cells</td>
<td>16</td>
</tr>
<tr>
<td>Calc main window</td>
<td>16</td>
</tr>
<tr>
<td>Creating, opening, and saving spreadsheets</td>
<td>22</td>
</tr>
<tr>
<td>Password protection</td>
<td>26</td>
</tr>
<tr>
<td>Navigating within spreadsheets</td>
<td>26</td>
</tr>
<tr>
<td>Selecting items in a spreadsheet</td>
<td>29</td>
</tr>
<tr>
<td>Working with columns and rows</td>
<td>31</td>
</tr>
<tr>
<td>Working with sheets</td>
<td>33</td>
</tr>
<tr>
<td>Viewing Calc</td>
<td>35</td>
</tr>
<tr>
<td>Using the Navigator</td>
<td>37</td>
</tr>
<tr>
<td>Using document properties</td>
<td>39</td>
</tr>
<tr>
<td>Chapter 2 Entering, Editing, and Formatting Data</td>
<td>41</td>
</tr>
<tr>
<td>Introduction</td>
<td>42</td>
</tr>
<tr>
<td>Entering data</td>
<td>42</td>
</tr>
<tr>
<td>Speeding up data entry</td>
<td>46</td>
</tr>
<tr>
<td>Merging and splitting cells</td>
<td>50</td>
</tr>
<tr>
<td>Sharing content between sheets</td>
<td>50</td>
</tr>
<tr>
<td>Validating cell contents</td>
<td>51</td>
</tr>
<tr>
<td>Editing data</td>
<td>54</td>
</tr>
<tr>
<td>Formatting data</td>
<td>59</td>
</tr>
<tr>
<td>AutoFormat of cells and sheets</td>
<td>64</td>
</tr>
<tr>
<td>Using themes</td>
<td>65</td>
</tr>
<tr>
<td>Value highlighting</td>
<td>65</td>
</tr>
<tr>
<td>Using conditional formatting</td>
<td>66</td>
</tr>
<tr>
<td>Hiding and showing data</td>
<td>70</td>
</tr>
<tr>
<td>Sorting records</td>
<td>77</td>
</tr>
<tr>
<td>Find and replace</td>
<td>79</td>
</tr>
<tr>
<td>Chapter 3 Creating Charts and Graphs</td>
<td>82</td>
</tr>
<tr>
<td>Introduction</td>
<td>83</td>
</tr>
<tr>
<td>Chart Wizard</td>
<td>83</td>
</tr>
</tbody>
</table>
Chapter 7 Using Formulas and Functions .......................................................... 215
  Introduction ................................................................................................. 216
  Setting up a spreadsheet ............................................................................ 216
  Creating formulas ..................................................................................... 217
  Understanding functions ........................................................................... 230
  Strategies for creating formulas and functions ....................................... 235
  Finding and fixing errors .......................................................................... 237
  Examples of functions ............................................................................... 240
  Using wildcards and regular expressions in functions ........................... 243
  Advanced functions ................................................................................ 245

Chapter 8 Using Pivot Tables ........................................................................ 246
  Introduction ............................................................................................... 247
  The Pivot Table Layout dialog .................................................................. 249
  Working with the results of the pivot table ............................................. 260
  Using pivot table results elsewhere ....................................................... 271
  Using pivot charts ................................................................................... 274

Chapter 9 Data Analysis ............................................................................... 279
  Introduction ............................................................................................... 280
  Consolidating data .................................................................................. 280
  Creating subtotals ................................................................................... 283
  Using scenarios ......................................................................................... 288
  Using the Multiple Operations tool ....................................................... 292
  Using Goal Seek ....................................................................................... 298
  Using the Solver ...................................................................................... 300
  Using Statistics tools ............................................................................... 304

Chapter 10 Linking Calc Data ...................................................................... 322
  Copyright .................................................................................................. 323
  Using multiple worksheets ...................................................................... 324
  Referencing other documents .................................................................. 324
  Using hyperlinks and URLs ..................................................................... 332
  Linking to external data ........................................................................... 338
  Linking to registered data sources ......................................................... 345
  Embedding spreadsheets ......................................................................... 351

Chapter 11 Sharing and Reviewing Spreadsheets ....................................... 357
Preface
Who is this book for?

This book is for beginners to advanced user of Calc, the spreadsheet component of LibreOffice. You may be new to spreadsheet software, or you may be familiar with another program. If you have never used LibreOffice before, or you want an introduction to all of its components, you might like to read Getting Started with LibreOffice first. If you have never used spreadsheets before, you might also like to read a book or find some tutorials about the use of spreadsheets.

What's in this book?

This book introduces the features and functions of LibreOffice Calc. It is not a tutorial on using spreadsheets. Some chapters assume familiarity with basic spreadsheet usage when describing how to use Calc.

You can enter data (usually numerical) in a spreadsheet and then manipulate this data to produce certain results. Alternatively, you can enter data and then use Calc in a ‘What if...’ manner by changing some of the data and observing the results without having to retype all of the data. Functions can be used to create formulas to perform complex calculations on data.

Some of the other features provided by Calc include:

- Database functions, to arrange, store, and filter data.
- Dynamic charts: a wide range of 2D and 3D charts.
- Macros, for recording and executing repetitive tasks; scripting languages supported include LibreOffice Basic, Python, BeanShell, and JavaScript.
- Ability to open, edit, and save Microsoft® Excel® and other spreadsheets.
- Import of spreadsheets from multiple formats, including HTML, CSV, and PostScript.
- Export of spreadsheets into multiple formats, including HTML, CSV, and PDF.

Where to get more help

This book, the other LibreOffice user guides, the built-in Help system, and user support systems assume that you are familiar with your computer and basic functions such as starting a program, opening and saving files.

Help system

LibreOffice comes with an extensive Help system. This is the first line of support for using LibreOffice. Windows and Linux users can choose to download and install the offline Help for use when not connected to the Internet; the offline Help is installed with the program on macOS.

To display the Help system, press F1 or select LibreOffice Help from the Help menu (Figure 1). If you do not have the offline help installed on your computer and you are connected to the Internet, your default browser will open the online Help pages on the LibreOffice website.

The Help menu includes links to other LibreOffice information and support facilities.
The following options indicated by a ‡ sign are only accessible if your computer is connected to the Internet.

- **What's This?** For quick tips when a toolbar is visible, place the mouse pointer over any of the icons to see a small box (“tooltip”) with a brief explanation of the icon’s function. For a more detailed explanation, select **Help > What's This?** and hold the pointer over the icon. In addition, you can choose whether to activate Extended Tips using **Tools > Options > LibreOffice > General**.
- **Get Help Online** ‡ Opens your default browser at the Ask LibreOffice forum of questions and answers from the LibreOffice community [https://ask.libreoffice.org/en/questions/](https://ask.libreoffice.org/en/questions/).
- **Send Feedback** ‡ Opens your default browser at the Feedback page of the LibreOffice website [https://www.libreoffice.org/get-help/feedback/](https://www.libreoffice.org/get-help/feedback/). From there you can report bugs, suggest new features and communicate with others in the LibreOffice community.
- **Restart in Safe Mode** Opens a dialog window where you will have the option to restart LibreOffice and reset the software to its default settings.
- **Donate to LibreOffice** ‡ Opens your default browser at the Donation page of the LibreOffice website [https://donate.libreoffice.org/](https://donate.libreoffice.org/). There you can choose to make a donation to support LibreOffice.
- **License Information** outlining the licenses under which LibreOffice is made available.
- **Check for Updates** ‡ Opens a dialog window and checks the LibreOffice website for updates to your version of the software.
- **About LibreOffice** Opens a dialog window and displays information about the version of LibreOffice and the operating system you are using. This information will often be requested if you ask the community for help or assistance with the software.

### Other free online support

The LibreOffice community not only develops software, but provides free, volunteer-based support. In addition to the Help menu links above, there are other online community support options available, see the table below.
Table: Free LibreOffice support

| **FAQs** | Answers to frequently asked questions  
https://wiki.documentfoundation.org/Faq |
| --- | --- |
| **Mailing lists** | Free community support is provided by a network of experienced users  
https://www.libreoffice.org/get-help/mailing-lists/ |
| **Questions & Answers and Knowledge Base** | Free community assistance is provided in a Question & Answer formatted web service. Search similar topics or open a new one in  
https://ask.libreoffice.org/en/questions  
The service is available in several other languages; just replace /en/ with de, es, fr, ja, ko, nl, pt, tr, and many others in the web address above. |
| **Native language support** | The LibreOffice website in various languages  
https://www.libreoffice.org/community/nlc/  
Mailing lists for native languages  
https://wiki.documentfoundation.org/Local_Mailing_Lists  
Information about social networking  
https://wiki.documentfoundation.org/Website/Web_Sites_services |
| **Accessibility options** | Information about available accessibility options  
https://www.libreoffice.org/get-help/accessibility/ |
| **OpenOffice Forum** | Another forum that provides support for LibreOffice, among other open source office suites  
https://forum.openoffice.org/en/forum/ |

**Paid support and training**

You can also pay for support through service contracts from a vendor or consulting firm specializing in LibreOffice. For information about certified professional support, see The Document Foundation’s website: https://www.documentfoundation.org/gethelp/support/

**What you see may be different**

**Illustrations**

LibreOffice runs on Windows, Linux, and macOS operating systems, each of which has several versions and can be customized by users (fonts, colors, themes, window managers). The illustrations in this guide were taken from a variety of computers and operating systems. Therefore, some illustrations will not look exactly like what you see on your computer display.

Also, some of the dialogs may be different because of the settings selected in LibreOffice. You can either use dialogs from your computer’s operating system or from LibreOffice. The differences affect mainly Open, Save, and Print dialogs. To change which dialogs are used, go to **Tools > Options > LibreOffice > General** and select or deselect the option **Use LibreOffice dialogs**.

**Icons**

The LibreOffice community has created icons for several icon sets: Colibre (default set), Breeze, Breeze Dark, Elementary, Karasa Jaga, Sifr, Sifr Dark and Tango. Each user can select a preferred set. The icons in this guide have been taken from a variety of LibreOffice installations that use different sets of icons. The icons for some of the many tools available in LibreOffice may then differ from the ones used in this guide.

To change the icon set used, go to **Tools > Options > LibreOffice > View**. In the **User Interface** section, choose from the drop-down lists under **Toolbar icon size** and **Icon style**.
Note

The Galaxy and Oxygen icon sets are no longer included as part of the standard installation package. They can be added back by downloading and installing the following extensions:

https://extensions.libreoffice.org/extensions/galaxy-icon-theme
https://extensions.libreoffice.org/extensions/oxygen-icon-theme

Some of the previously included gallery backgrounds are now only available as an extension from:

https://extensions.libreoffice.org/extensions/legacy-gallery-backgrounds

Using LibreOffice on macOS

Some keystrokes and menu items are different on macOS from those used in Windows and Linux. The table below gives some common substitutions for the instructions in this book. For a more detailed list, see the application Help.

<table>
<thead>
<tr>
<th>Windows or Linux</th>
<th>macOS equivalent</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tools &gt; Options menu selection</td>
<td>LibreOffice &gt; Preferences</td>
<td>Access setup options</td>
</tr>
<tr>
<td>Right-click</td>
<td>Control+click and/or right-click depending on computer setup</td>
<td>Open a context menu</td>
</tr>
<tr>
<td>Ctrl (Control)</td>
<td>⌘ (Command)</td>
<td>Used with other keys</td>
</tr>
<tr>
<td>F5</td>
<td>Shift+⌘+F5</td>
<td>Open the Navigator</td>
</tr>
<tr>
<td>F11</td>
<td>⌘+T</td>
<td>Open the sidebar Styles deck</td>
</tr>
</tbody>
</table>

What are all these things called?

The terms used in LibreOffice for most parts of the user interface (the parts of the program you see and use, in contrast to the behind-the-scenes code that actually makes it work) are the same as for most other programs.

A dialog is a special type of window. Its purpose is to inform you of something, or request input from you, or both. It provides controls to use to specify how to carry out an action. The technical names for common controls are shown in Figure 2. In most cases the technical terms are not used in this book, but it is useful to know them because the Help and other sources of information often use them.
Figure 2: Dialog showing common controls

1) Tabbed page (not strictly speaking a control).
2) Radio buttons (only one can be selected at a time).
3) Checkbox (more than one can be selected at a time).
4) Spin box (click the up and down arrows to change the number shown in the text box next to it, or type in the text box).
5) Thumbnail or preview.
6) Drop-down list from which to select an item.
7) Push buttons.

In most cases, you can interact only with the dialog (not the document itself) as long as the dialog remains open. When you close the dialog after use (usually, clicking OK or another button saves your changes and closes the dialog), then you can again work with your document.

Some dialogs can be left open as you work, so you can switch back and forth between the dialog and your document. An example of this type is the Find & Replace dialog.

Frequently asked questions

How is LibreOffice Licensed?
LibreOffice is distributed under the Open Source Initiative (OSI) approved Mozilla Public License (MPL). See https://www.libreoffice.org/about-us/licenses/

It is based on code from Apache OpenOffice made available under the Apache License 2.0 but also includes software that differs from version to version under a variety of other Open Source licenses. New code is available under LGPL 3.0 and MPL 2.0.

May I distribute LibreOffice to anyone? May I sell it? May I use it in my business?
Yes.
How many computers may I install it on?
As many as you like.

Is LibreOffice available in my language?
LibreOffice has been translated (localized) into over 40 languages, so your language probably is supported. Additionally, there are over 70 spelling, hyphenation, and thesaurus dictionaries available for languages, and dialects that do not have a localized program interface. The dictionaries are available from the LibreOffice Extension Center: https://extensions.libreoffice.org/extensions?getCategories=Dictionary.

How can you make it for free?
LibreOffice is developed and maintained by volunteers and has the backing of several organizations.

I am writing a software application. May I use programming code from LibreOffice in my program?
You may, within the parameters set out in the licenses: https://www.mozilla.org/MPL/2.0/ https://www.libreoffice.org/about-us/licenses/.

Why do I need Java to run LibreOffice? Is it written in Java?
LibreOffice is not written in Java; it is mostly written in the C++ language. Java is one of several languages that can be used to extend the software. The Java JRE (Java Runtime Environment) is only required for some features. The most notable one is the HSQLDB relational database engine.

Java is available at no cost. More information and download links to the appropriate edition for your operating system can be found at: https://java.com/en/download/manual.jsp

Note
If you want to use LibreOffice features that require Java it is important that the correct 32 bit or 64 bit edition matches the installed version of LibreOffice.

How can I contribute to LibreOffice?
You can help with the development and user support of LibreOffice in many ways, and you do not need to be a programmer. To start, check out this webpage: https://www.libreoffice.org/community/get-involved/

May I distribute the PDF of this book, or print and sell copies?
Yes, as long as you meet the requirements of one of the licenses in the copyright statement at the beginning of this book. You do not have to request special permission. We request that you share with the project some of the profits you make from sales of books, in consideration of all the work we have put into producing them.

Donate to LibreOffice: https://www.libreoffice.org/donate/

What’s new in LibreOffice Calc 6.2?
The LibreOffice 6.2 Release Notes are here: https://wiki.documentfoundation.org/Documentation/Development/Calc/6.x
Chapter 1
Introducing Calc

Using spreadsheets in LibreOffice
What is Calc?

Calc is the spreadsheet component of LibreOffice. You can enter data (usually numerical) in a spreadsheet and then manipulate this data to produce certain results.

Alternatively, you can enter data and then use Calc in a ‘What if...’ manner by changing some of the data and observing the results without having to retype the entire spreadsheet or sheet.

Other features provided by Calc include:

- Functions, which can be used to create formulas to perform complex calculations on data.
- Database functions to arrange, store, and filter data.
- Dynamic charts, including a wide range of 2D and 3D charts.
- Macros for recording and executing repetitive tasks; scripting languages supported include LibreOffice Basic, Python, BeanShell, and JavaScript.
- Ability to open, edit, and save Microsoft Excel spreadsheets.
- Import and export of spreadsheets in multiple formats, including HTML, CSV, PDF, and PostScript.

Note

If you want to use macros written in Microsoft Excel using the VBA macro code in LibreOffice, you must first edit the code in the LibreOffice Basic IDE editor. For more information, see Chapter 12, Calc Macros, in this guide or Chapter 13, Getting Started with Macros, in the Getting Started Guide.

Spreadsheets, sheets, and cells

Calc works with documents called spreadsheets. Spreadsheets consist of a number of individual sheets, each sheet containing cells arranged in rows and columns. A particular cell is identified by its row number and column letter.

Cells hold the individual elements – text, numbers, formulas, and so on – that make up the data to display and manipulate.

Each spreadsheet can have up to 10,000 sheets and each sheet can have a maximum of 1,048,576 rows and 1,024 columns. The maximum number of characters in one cell is 32,767.

Calc main window

When Calc is started, the main window opens (Figure 3). The various parts of this display are explained below.

Note

If any part of the Calc window in Figure 3 is not shown, you can display it using the View menu. For example, View > Status Bar on the Menu bar will toggle (show or hide) the Status Bar. It is not always necessary to display all of the parts shown; you can show or hide any of them as desired.

Title bar

The Title bar, located at the top, shows the name of the current spreadsheet. When the spreadsheet is newly created, its name is Untitled X, where X is a number. When you save a spreadsheet for the first time, you are prompted to enter a name of your choice.
Figure 3: Calc main window

Menu bar

Under the Title bar is the Menu bar. When you choose one of the menus, a list of options appears. You can also modify the Menu bar, as explained in Chapter 14, Setting Up and Customizing Calc.

- **File** – contains commands that apply to the entire document, such as **Open**, **Save**, **Wizards**, **Export as PDF**, **Print**, **Digital Signatures**, **Templates**.
- **Edit** – contains commands for editing the document, such as **Undo**, **Copy**, **Find & Replace**, **Track Changes**.
- **View** – contains commands for modifying how the Calc user interface looks, such as **Toolbars**, **View Headers**, **Full Screen**, **Zoom**.
- **Insert** – contains commands for inserting elements into a spreadsheet, such as **Image**, **Textbox**, **Headers and Footers**.
- **Format** – contains commands for modifying the layout of a spreadsheet, such as **Cells**, **Page**, **AutoFormat Styles**, **Align**.
- **Styles** – contains options for applying and managing styles, such as **Heading 1**, **Footnote**, **Manage Styles**.
- **Sheet** – contains commands for inserting and deleting elements and modifying the entire sheet, such as **Delete Rows**, **Insert Sheet**, **Rename Sheet**, **Navigate**.
- **Data** – contains commands for manipulating data in your spreadsheet, such as **Define Range**, **Sort**, **AutoFilter**, **Consolidate**.
- **Tools** – contains functions to help check and customize a spreadsheet, for example **Spelling**, **Share Spreadsheet**, **Macros**, **Options**.
- **Window** – contains two commands; **New Window** and **Close Window**. Also shows all open windows in other LibreOffice applications.
• **Help** – contains links to [LibreOffice Help](https://www.libreoffice.org) (included with the software), User Guides, and other miscellaneous functions; for example, **Restart in Safe Mode**, **License Information**, **Check for Updates**.

### Toolbars

The default setting when Calc opens is for the Standard and Formatting toolbars to be docked at the top of the workspace (Figure 3).

Calc toolbars can be either docked (fixed in place), or floating, allowing you to move a toolbar to a more convenient location on your workspace. Docked toolbars can be undocked and moved to a different docked location or become floating toolbars. Likewise, floating toolbars can be docked.

You can choose the single-toolbar alternative to the default double toolbar arrangement. It contains the most-used commands. To activate it, enable **View > Toolbars > Standard (Single Mode)** and disable **View > Toolbars > Standard** and **View > Toolbars > Formatting**.

For additional information on toolbars, see Chapter 1, Introducing LibreOffice, of the *Getting Started Guide*.

The default set of icons (sometimes called buttons) on toolbars provides a wide range of common commands and functions. You can also remove or add icons to toolbars. See Chapter 14, Setting Up and Customizing Calc, for more information.

Placing the mouse cursor over an icon, text box, or menu command displays a small box called a tooltip that shows the name of the item's function. To close a tooltip, click once away from the icon or press the *Esc* key.

To see a more detailed explanation of an icon, textbox, or menu command, do one of the following to open extended tips:

- To activate extended tips just once: press *Shift+F1*.
- To activate extended tips from the Menu bar: go to **Help > What's This?** and hover the mouse pointer over the icon.
- To turn extended tips on or off: go to from **Tools > Options > LibreOffice > General** on the Menu bar.

### Formula Bar

The Formula Bar is located at the top of the Calc workspace. It is permanently docked in this position and cannot be used as a floating toolbar. However, it can be hidden or made visible by going to **View > Formula Bar** on the Menu bar.

![Figure 4: Formula bar](image)

From left to right in Figure 4, the Formula Bar consists of the following:

- **Name Box** – gives the current active cell reference using a combination of a letter and number, for example A1. The letter indicates the column and the number indicates the row of the selected cell. If you have selected a range of cells that is also a named range, the name of the range is shown in this box. You can also type a cell reference in the Name Box to jump to the referenced cell. If you type the name of a named range and press the Enter key, the named range is selected and displayed.

- **Function Wizard** – opens a dialog from which you can search through lists of available functions and formulas. This can be very useful because it also shows how the functions are formatted.
• **Sum** – totals the numbers in the cells above the selected cell and then places the total in the selected cell. If there are no numbers above the selected cell, then the cells to the left are totaled.

• **Formula** – inserts an equals (=) sign in the selected cell and the Input line, allowing a formula to be entered.

• **Input line** – displays the contents of the selected cell (data, formula, or function) and allows you to edit the cell contents. To turn the Input line into a multiline input area for very long formulas, click the drop down button on the right. To edit inside the Input line area, click in the area, then type your changes.

You can also directly edit inside the cell by double-clicking on the cell. When you enter new data into a cell, the **Sum** and **Formula** icons change to **Cancel** and **Accept** icons.

---

**Note**

In a spreadsheet, the term “function” covers much more than just mathematical functions. See Chapter 7, Using Formulas and Functions, for more information.

---

**Status Bar**

The Calc status bar at the bottom of the workspace (Figure 5) provides information about the spreadsheet and convenient ways to quickly change some of its features. Most of the fields are similar to those in other components of LibreOffice. See Chapter 1, Introducing LibreOffice, in the Getting Started Guide for more information.

![Figure 5: Calc status bar](image)

The fields on the Status Bar, from left to right, are as follows.

**Sheet number**

Shows the sequence number of the current sheet and the total number of sheets in the spreadsheet. The sequence number may not be the same as the name on the sheet tab if sheets have been moved. Double-click on this zone to open the Navigator.

**Number of selected rows and columns**

Shows how many rows and how many columns are selected.

**Page style**

Shows the page style of the current sheet. To edit the page style, double-click on this field and the Page Style dialog opens.

**Language**

Shows current default language as selected at **Tools > Options > Language Settings > Language**.

**Insert mode**

This field is blank if the program is in insert mode. Press the Ins key to change modes. Overwrite shows when in overwrite mode.

**Selection mode**

Right-click to open a context menu and select **Standard selection**, **Extending selection**, **Adding selection** or **Block selection**. The icon does not change when different selection modes are selected, but the tooltip shows the current status. See Chapter 1, Introducing LibreOffice, in the Getting Started Guide for more information.
Unsaved changes
This icon indicates the spreadsheet contains unsaved changes. Double-click this icon or use File > Save to save the spreadsheet.

Digital signature
If the document has been digitally signed, an icon shows here. You can double-click the icon to view the certificate. See Chapter 6, Printing, Exporting, E-mailing, and Signing for more information about digital signatures.

Cell or object information
Displays information related to the position of the cursor or the selected element of the spreadsheet. When a group of cells is selected, the sum of the contents is displayed by default. Right-click in this field to select other functions, such as the average value, maximum value, minimum value, or count (number of items selected).

Zoom slider
Drag the zoom slider, or click the + and – signs to change the view magnification.

Zoom percentage
Indicates the magnification level of the document. Right-click on the percentage to open a list of magnification values from which to choose. Double-click on the percentage to open the Zoom & View Layout dialog.

Sidebar
The Calc Sidebar (Figure 6) is a mixture of toolbar and dialog. When opened (View > Sidebar or Ctrl+F5), it appears on the right side of the window and consists of five decks: Properties, Styles, Gallery, Navigator, and Functions. Each deck has a corresponding icon on the Tab panel to the right of the sidebar, allowing you to switch between them. The decks are described below.

Properties
This deck includes five content panels. These panels, with the exception of the Style panel, have More Options buttons that open dialogs with additional options. These dialogs lock the document for editing until they are closed.

Style: Options for applying, updating, or creating cell and page styles.

Character: Options for formatting the text, such as font family, size, and color. Some controls, such as superscript, only become active when the text cursor is active in the Input line of the Formula bar or the cell.

Number Format: Options for formatting numbers, including decimals, currency, dates, or numeric text.

Alignment: Options for arranging the text in various ways, including horizontal and vertical alignment, wrapping, indenting, merging, text orientation, and vertical stacking.

Cell Appearance: Options include background color, border formats including line color and style, and grid lines.

Styles
This deck is the same as the dialog opened by selecting Styles > Manage Styles from the Menu bar or F11.

Gallery
This deck is the same as the dialog opened by selecting View > Gallery from the Menu bar.

Navigator
This deck is the same as the Navigator window opened by selecting View > Navigator from the Menu bar or F5. See “Using the Navigator” on page 39.
Functions

This deck contains a list of functions organized by category. It is a simpler version of the Function Wizard, which is opened by selecting Insert > Function... from the Menu bar or Ctrl+F2.

To the right side of the title bar of each open deck is a Close button (X), which closes the deck to leave only the Tab bar open. Clicking on any Tab button reopens the deck.

To hide the Sidebar, or reveal it if already hidden, click on the edge Hide/Show button. To adjust the deck width, drag on the left edge of the sidebar.

Spreadsheet layout

Individual cells

The main section of the screen displays the cells in the form of a grid, with each cell located at the intersection of a column and a row.

At the tops of the columns and the left ends of the rows are a series of header boxes containing letters and numbers. The column headers use alpha characters that start with A and increase to the right. The row headers use numerical characters that start at 1 and increase down.

These column and row headers form the cell references that appear in the Name Box on the Formula Bar (Figure 4). If the headers are not visible on the spreadsheet, go to View > Column & Row Headers on the Menu bar.
**Sheet tabs**

A spreadsheet file can contain many individual sheets. At the bottom of the grid of cells in a spreadsheet are sheet tabs (Figure 3). Each tab represents a sheet in a spreadsheet. Create a new sheet by clicking on the plus sign to the left of the sheet tabs.

Clicking on a tab enables access to an individual sheet. When a sheet is active, the tab is highlighted. Select multiple sheets by holding down the Ctrl key while clicking on the sheet tabs.

To change the default name for a sheet (Sheet1, Sheet2, and so on):

8) Right-click on the sheet tab and select **Rename Sheet** from the context menu. A dialog opens allowing you to type in a new name for the sheet.

9) Click **OK** when finished to close the dialog.

To change the color of a sheet tab:

1) Right-click on the sheet tab and select **Tab Color** from the context menu to open the Tab Color dialog (Figure 7).

2) Select a color and click **OK** when finished to close the dialog.

![Figure 7: Tab Color dialog](image)

To add new colors to this color palette, see “Adding Custom colors” in Chapter 14, Setting up and Customizing Calc.

---

**Creating, opening, and saving spreadsheets**

**Creating and opening**

Creating and opening spreadsheets is identical to creating and opening documents in the other LibreOffice modules. For more information on creating and opening spreadsheets, see Chapter 1, Introducing LibreOffice, in the Getting Started Guide.

**Using templates**

Calc documents can also be created from templates. For information on how to create and use templates, see Chapter 4, Using Styles and Templates, in this guide.

**Opening a CSV file**

Comma-separated-values (CSV) files are spreadsheet files in a text format where cell contents are separated by a character such as a comma or semi-colon. Each line in a CSV text file represents a
row in a spreadsheet. Text is entered between quotation marks; numbers are entered without quotation marks.

To open a CSV file in Calc:

1) Choose **File > Open** on the Menu bar and locate the CSV file that you want to open.
2) Select the file and click **Open**. By default, a CSV file has the extension .csv. However, some CSV files may have a .txt extension.
3) The Text Import dialog (Figure 8) opens. Here you can select options for importing a CSV file into a Calc spreadsheet.
4) Click **OK** to open and import the file.

![Text import dialog](image)

**Figure 8: Text import dialog**

The options for importing CSV files into a Calc spreadsheet are as follows:

**Import**
- **Character Set** – specifies the character set to be used in the imported file.
- **Language** – determines how the number strings are imported. If Language is set to Default, Calc will use the language selected at **Tools > Options > Language Settings > Languages > Default Languages for Document**. If another language is selected, that language will determine how numbers are treated.
- **From Row** – specifies which row the import starts with. The initial rows are visible in the preview window at the bottom of the dialog.

**Separator Options**
- **Fixed width** – separates data into columns by a set number of characters. Click on the ruler that appears in the preview window to set the width.
- **Separated by** – separates data into columns based on the separator defined here. Select other to specify another character used to separate data into columns. This custom separator must also be contained in the data.
- **Merge delimiters** – combines consecutive delimiters and removes blank data fields.
• **Trim spaces** – removes starting and trailing spaces from within fields.
• **String delimiter** – select a character to delimit text data.

**Other options**
• **Format quoted field as text** – when this option is enabled, fields or cells whose values are entirely within quotes are imported as text.
• **Detect special numbers** – when this option is enabled, Calc will automatically detect all number formats, including special number formats such as dates, time, and scientific notation. The selected language influences how such special numbers are detected, since different languages and regions many have different conventions for such special numbers. When this option is disabled, Calc will detect and convert only decimal numbers. The rest, including numbers formatted in scientific notation, will be imported as text. A decimal number string can have digits 0–9, thousands separators, and a decimal separator. Thousands separators and decimal separators may vary with the selected language and region.

**Fields** – shows how your data will look when it is separated into columns.
• **Column type** – select a column in the preview window and select the data type to be applied to the imported data.
  – **Standard** – Calc determines the type of data.
  – **Text** – imported data are treated as text.
  – **Date** – imported data are treated as dates.
  – **US English** – numbers formatted in US English are searched for and included regardless of the system language. A number format is not applied. If there are no US English entries, the Standard format is applied.
  – **Hide** – the data in the column are not imported.

**Saving spreadsheets**
For information on how to save files manually or automatically, see Chapter 1, Introducing LibreOffice, in the *Getting Started Guide*. Calc can save spreadsheets in a range of formats and also export spreadsheets to PDF, HTML and XHTML file formats; see Chapter 6 Printing, Exporting, Emailing, and Signing, for more information.

**Saving in other formats**
If you need to send files to users who are unable to receive spreadsheet files in Open Document Format (ODF) (*.ods), which Calc uses as default format, you can save a spreadsheet in another format.

1) Select **File > Save As** on the Menu bar or **Alt+F,A** to open the Save As dialog (Figure 9).
2) In **File name**, if you wish, enter a new file name for the spreadsheet and select the folder where you want to save the file.
3) In the **Save as type** field, select from the drop-down menu the type of spreadsheet format you want to use. If Automatic file name extension is selected, the correct file extension for the spreadsheet format you have selected will be added to the file name.
4) Click **Save**.
Each time a file is saved in a format other than ODF format, the Confirm File Format dialog opens (Figure 10). Click **Use [xxx] Format** to continue saving in the selected spreadsheet format or click **Use ODF Format** to save the spreadsheet in Calc ODS format.

If you select Text CSV format (*.csv), the Export Text File dialog (Figure 11) opens. Here you can select the character set, field delimiter, text delimiter and so on to be used for the CSV file.
**Note**

Once you have saved a spreadsheet in another format, all changes you make to the spreadsheet will now occur only in the format you are using because you have changed the name and file type of your document. If you want to go back to working with an *.ods version, you must save the file as an *.ods file.

**Tip**

To have Calc save documents by default in a file format other than the default ODF format, go to Tools > Options > Load/Save > General. In the section named Default file format and ODF settings, next to Document type, select Spreadsheet, then next to Always save as, select your preferred file format, for example Microsoft Excel.

---

**Password protection**

To protect a spreadsheet and restrict who can open, read, and make changes to it, you have to use password protection. Password protection is common to all LibreOffice modules; for more information, see Chapter 1, Introducing LibreOffice, in the Getting Started Guide.

**Navigating within spreadsheets**

Calc provides many ways to navigate within a spreadsheet from cell to cell and sheet to sheet. You can generally use the method you prefer.

**Cell navigation**

When a cell is selected or in focus, the cell borders are emphasized. When a group of cells is selected, the cell area is colored. The color of the cell border emphasis and the color of a group of selected cells depends on the operating system being used and how you have set up LibreOffice.

- Using the mouse – place the mouse pointer over the cell and click the left mouse button. To move the focus to another cell using the mouse, move the mouse pointer to the cell and click the left mouse button.
- Using a cell reference – highlight or delete the existing cell reference in the Name Box on the Formula Bar (Figure 4 on page 20). Type the new cell reference of the cell you want to move to and press the Enter key. Cell references are case insensitive. Thus, typing a3 or A3 will move the focus to cell A3.
- Using the Navigator – go to View > Navigator or press the F5 key to open the Navigator dialog (Figure 12). Type the cell references into the Column and Row fields and press the Enter key.
- Using the Enter key – pressing Enter moves the cell focus down one cell. Pressing Shift+Enter moves the focus up one cell.
- Using the Tab key – pressing Tab moves the cell focus one cell to the right. Pressing Shift+Tab moves the focus one cell to the left.
- Using the arrow keys – pressing the arrow keys on the keyboard moves the cell focus in the direction of the arrow pressed.
• Using Home, End, Page Up, and Page Down
  – **Home** moves the cell focus to the start of a row. **Ctrl+Home** moves the cell focus to the first cell in the sheet, A1.
  – **End** moves the cell focus to the last cell in the same row that contains data. **Ctrl+End** moves the cell focus to the last cell in the sheet that contains data.
  – **Page Down** moves the cell focus down one complete screen display.
  – **Page Up** moves the cell focus up one complete screen display.

**Sheet navigation**

Each sheet in a spreadsheet is independent of the other sheets, though references can be linked from one sheet to another. There are three ways to navigate between different sheets in a spreadsheet.

• Using the Navigator – when the Navigator is open (Figure 12), double-clicking on any of the listed sheets selects the sheet.

• Using the keyboard – using key combinations **Ctrl+Page Down** moves one sheet to the right and **Ctrl+Page Up** moves one sheet to the left.

• Using the mouse – clicking on one of the sheet tabs at the bottom of the spreadsheet selects that sheet.

If there are many sheets in the spreadsheet, some of the sheet tabs may be hidden. If this is the case, use the four buttons to the left of the sheet tabs to move the tabs into view (Figure 13).

**Note**

The sheet tab arrows that appear on the left in Figure 13 are only active if there are sheet tabs that cannot be seen.
Note

When you insert a new sheet into a spreadsheet, Calc automatically uses the next number in the numeric sequence as a name. Depending on which sheet is open when you insert a new sheet, your new sheet may not be in numerical order. It is recommended to rename sheets in a spreadsheet to make them more recognizable.

Keyboard navigation

You can navigate a spreadsheet using the keyboard, by pressing a key or a combination of keys at the same time. For example, Ctrl+Home moves the focus to cell A1. Table 1 lists the keys and key combinations you can use for spreadsheet navigation in Calc.

<table>
<thead>
<tr>
<th>Keyboard shortcut</th>
<th>Cell navigation</th>
</tr>
</thead>
<tbody>
<tr>
<td>←/→</td>
<td>Moves cell focus right/left one cell.</td>
</tr>
<tr>
<td>↑/↓</td>
<td>Moves cell focus up/down one cell.</td>
</tr>
<tr>
<td>Ctrl+←/Ctrl→</td>
<td>If focus is on a blank cell, moves focus to the first cell on the right/left that contains data. If focus is on a cell containing data, moves focus to the last/first cell on the right/left containing data. If there are no more cells containing data, moves focus to the last/first cell on the right/left in the spreadsheet.</td>
</tr>
<tr>
<td>Ctrl+↑/Ctrl↓</td>
<td>If focus is on a blank cell, moves focus to the first cell above/below that contains data. If focus is on a cell containing data, moves focus to the cell in Row 1/last cell containing data in the same column. If there are no more cells below containing data in that column, moves focus to the cell in the same column in the last row of the spreadsheet.</td>
</tr>
<tr>
<td>Ctrl+Home/Ctrl+End</td>
<td>Moves focus from anywhere on the spreadsheet to Cell A1/the last cell in the lower right-hand corner of the rectangular area of cells containing data on the same sheet.</td>
</tr>
<tr>
<td>Alt+Page Down/Alt+Page Up</td>
<td>Moves focus one screen to the right/left (if possible).</td>
</tr>
<tr>
<td>Ctrl+Page Down/Ctrl+Page Up</td>
<td>Moves focus to the same cell on the next sheet to the right/left in sheet tabs if there are more sheets in that direction.</td>
</tr>
</tbody>
</table>
### Keyboard shortcut | Cell navigation
--- | ---
Tab / Shift+Tab | Moves focus to the next cell on the right/left.
Enter/ Shift+Enter | Moves focus down/up one cell (unless changed by user).

**Customizing the Enter key**
You can choose the direction in which the Enter key moves the cell focus by going to Tools > Options > LibreOffice Calc > General. Use the first two options under Input settings (Figure 14) to change the Enter key settings. Select the direction cell focus moves from the drop-down list. Depending on the file being used or the type of data being entered, setting a different direction can be useful. The Enter key can also be used to switch into and out of editing mode.

![Figure 14: Customizing the Enter key](image)

**Selecting items in a spreadsheet**

**Selecting cells**

**Single cell**
Left-click in the cell. You can verify the selection by looking in the Name Box on the Formula Bar (Figure 4).

**Range of contiguous cells**
A range of cells can be selected using the keyboard or the mouse.

To select a range of cells by dragging the mouse cursor:

1) Click in a cell.
2) Press and hold down the left mouse button.
3) Move the mouse around the screen.
4) Once the desired block of cells is highlighted, release the left mouse button.

To select a range of cells without dragging the mouse:

1) Click in the cell which is to be one corner of the range of cells.
2) Move the mouse to the opposite corner of the range of cells.
3) Hold down the Shift key and click.

To select a range of cells using Extending selection mode:

1) Click in the cell which is to be one corner of the range of cells.
2) Click in the Selection mode field on the Status Bar (Figure 5 on page 21) and select **Extending selection**.

3) Click in the cell in the opposite corner of the range of cells.

**Tip**

Make sure to change back to **Standard selection** or you may find yourself extending a cell selection unintentionally.

To select a range of cells without using the mouse:

1) Select the cell that will be one of the corners in the range of cells.

2) While holding down the **Shift** key, use the cursor arrows to select the rest of the range.

To select a range of cells using the Name Box:

1) Click in the Name Box on the Formula Bar (Figure 4 on page 20).

2) Enter the cell reference for the upper left-hand cell, followed by a colon (:), and then the lower right-hand cell reference, then press the Enter key. For example, to select the range that would go from A3 to C6, enter A3:C6.

**Range of non-contiguous cells**

To select a range of non-contiguous cells using the mouse:

1) Select the first cell or range of cells using one of the methods above.

2) Move the mouse pointer to the start of the next range or single cell.

3) Hold down the **Ctrl** key and click or click-and-drag to select another range of cells to add to the first range.

4) Repeat as necessary.

5) To select a range of non-contiguous cells using **Adding selection** mode:

6) To select a range of cells using **Adding selection** mode:

7) Click in the cell which is to be one corner of the range of cells.

8) Click in the **Selection mode** field on the Status Bar (Figure 5 on page 21) and select **Extending selection** before clicking in the opposite corner of the range of cells.

**Selecting columns and rows**

**Single column or row**

To select a single column, click on the column header (Figure 3 on page 19). To select a single row, click on the row header.

**Multiple columns or rows**

To select multiple columns or rows that are contiguous:

1) Click on the first column or row in the group.

2) Hold down the **Shift** key.

3) Click the last column or row in the group.

To select multiple columns or rows that are not contiguous:

1) Click on the first column or row in the group.

2) Hold down the **Ctrl** key.

3) Click on all of the subsequent columns or rows while holding down the **Ctrl** key.
**Entire sheet**
To select the entire sheet, click on the small box between the column headers and the row headers (Figure 15), or use the key combination Ctrl+A to select the entire sheet, or go to Edit on the Menu bar and select Select All.

![Figure 15. Select All box](image)

**Selecting sheets**
You can select either one or multiple sheets in Calc. It can be advantageous to select multiple sheets, especially when you want to make changes to many sheets at once.

**Single sheet**
Click on the sheet tab for the sheet you want to select. The tab for the selected sheet becomes white (default Calc setup) or is otherwise highlighted.

**Multiple contiguous sheets**
To select multiple contiguous sheets:
1) Click on the sheet tab for the first desired sheet.
2) While holding down the Shift key, click on the sheet tab for the last desired sheet.
3) All tabs between these two selections will turn white (default Calc setup). Any actions that you perform will now affect all highlighted sheets.

**Multiple non-contiguous sheets**
To select multiple non-contiguous sheets:
1) Click on the sheet tab for the first desired sheet.
2) While holding down the Ctrl key, click on the sheet tabs for other desired sheets.
3) The selected tabs will turn white (default Calc setup). Any actions that you perform will now affect all highlighted sheets.

**All sheets**
Right-click a sheet tab and choose Select All Sheets from the context menu.

**Working with columns and rows**

**Inserting columns and rows**
When you insert columns or rows, the cells take the formatting of the corresponding cells in the column to the left or the row above.

**Single column or row**
Using the Sheet menu:
1) Select a cell, column, or row where you want the new column or row inserted.
2) Go to Sheet on the Menu bar. For columns, select Sheet > Insert Columns and then select Columns Before or Columns After. For rows, select Sheet > Insert Rows and then select Rows Above or Rows Below.
Using the context menu:

1) Select a column or row where you want the new column or row inserted.
2) Right-click the column or row header.
3) Select Insert Columns Before / After or Insert Rows Above / Below from the context menu.

**Multiple columns or rows**

Multiple columns or rows can be inserted at once rather than inserting them one at a time.

1) Highlight the required number of columns or rows by holding down the left mouse button on the first one and then dragging across the required number of identifiers.
2) Proceed as for inserting a single column or row above. The number of columns or rows highlighted will be inserted.

**Deleting columns and rows**

**Single column or row**

To delete a single column or row:

1) Select a cell in the column or row you want to delete.
2) Go to Sheet on the Menu bar and select Delete Columns. Right-click and select Delete Columns from the context menu.
3) Select the option you require from the Delete Cells dialog (Figure 16).

**Multiple columns or rows**

To delete multiple columns or rows:

1) Select the columns or rows. See “Multiple columns or rows” on page 32.
2) Go to Sheet on the Menu bar and select Delete Cells, or right-click and select Delete from the context menu, or right-click in the column or row header and select Delete Columns or Delete Rows from the context menu.

**Deleting cells**

1) Select the cell or cells you want to delete.
2) Go to Sheet > Delete Cells. Or, right-click on the cell and select Delete from the context menu.
3) Select the option you require from the Delete Cells dialog (Figure 16).

Alternatively:

1) Click in the column or header to select the column or row.
2) Go to Sheet on the Menu bar and select Delete Cells or right-click and select Delete Columns or Delete Rows from the context menu.
Working with sheets

Inserting new sheets

Click on the Add Sheet icon 📚 next to the sheet tabs to insert a new sheet after the last sheet in the spreadsheet without opening the Insert Sheet dialog. The following methods open the Insert Sheet dialog (Figure 17) where you can position the new sheet, create more than one sheet, name the new sheet, or select a sheet from a file.

- Select the sheet where you want to insert a new sheet, then go to Sheet > Insert Sheet on the Menu bar or click Alt+S+S.
- Right-click on the sheet tab where you want to insert a new sheet and select Insert Sheet from the context menu.
- Click in the empty space at the end of the sheet tabs.
- Right-click in the empty space at the end of the sheet tabs and select Insert Sheet from the context menu.

Moving and copying sheets

You can move or copy sheets within the same spreadsheet by dragging and dropping or using the Move/Copy Sheet dialog (Figure 18). To move or copy a sheet into a different spreadsheet, use the Move/Copy Sheet dialog.
**Dragging and dropping**

To move a sheet to a different position within the same spreadsheet, click on the sheet tab and drag it to its new position before releasing the mouse button.

To copy a sheet within the same spreadsheet, hold down the Ctrl key (Option key on Mac) then click on the sheet tab and drag it to its new position before releasing the mouse button. The mouse pointer may change to include a plus sign depending on the setup of your operating system.

**Using Move/Copy Sheet dialog**

The Move/Copy Sheet dialog allows you to specify exactly whether you want the sheet in the same or a different spreadsheet, its position within the spreadsheet, and the sheet name when it is moved or copied.

![Move/Copy Sheet dialog](image)

**Figure 18: Move/Copy Sheet dialog**

1) In the current document, right-click on the sheet tab you wish to move or copy and select **Move or Copy Sheet** from the context menu or go to **Sheet > Move or Copy Sheet** on the Menu bar.

2) Select **Move** to move the sheet or **Copy** to copy the sheet.

3) Select the spreadsheet where you want the sheet to be placed from the drop-down list in **To document**. This can be the same spreadsheet, another spreadsheet already open, or you can create a new spreadsheet.

4) Select the position in **Insert before** where you want to place the sheet.

5) Type a name in the **New name** text box if you want to rename the sheet when it is moved or copied. If you do not enter a name, Calc creates a default name (Sheet 2, Sheet 3, and so on).

6) Click **OK** to confirm the move or copy and close the dialog.

**Warning**

When you move or copy to another spreadsheet or to a new one, a conflict may occur if formulas are linked to sheets in the previous location.
Deleting sheets

To delete a single sheet, right-click on the sheet tab you want to delete and select Delete Sheet from the context menu, or go to Sheet > Delete Sheet on the Menu bar. Click Yes to confirm the deletion.

To delete multiple sheets, select the sheets (see “Selecting sheets” on page 33), then right-click one of the sheet tabs and select Delete Sheet from the context menu, or go to Sheet > Delete Sheet on the Menu bar. Click Yes to confirm the deletion.

Renaming sheets

By default, the name for each new sheet added is SheetX, where X is the number of the next sheet to be added. While this works for a spreadsheet with only a few sheets, it can become difficult to identify sheets when a spreadsheet contains many sheets.

You can rename a sheet using one of the following methods:

- Enter the name in the Name text box when you create the sheet using the Insert Sheet dialog (Figure 17 on page 35).
- Right-click on a sheet tab and select Rename Sheet from the context menu to replace the existing name with a different one.
- Double-click on a sheet tab to open the Rename Sheet dialog.

Note

Sheet names must start with either a letter or a number. Other characters, including spaces, are not allowed. Apart from the first character of the sheet name, permitted characters are letters, numbers, spaces, and the underscore character. Attempting to rename a sheet with an invalid name will produce an error message.

Viewing Calc

Changing document view

Use the zoom function to show more or fewer cells in the window when you are working on a spreadsheet. For more about zoom, see Chapter 1, Introducing LibreOffice, in the Getting Started Guide.

Freezing rows and columns

Freezing is used to lock rows across the top of a spreadsheet or to lock columns on the left of a spreadsheet. Then, when moving around within a sheet, the cells in frozen rows and columns always remain in view.

Figure 19 shows some frozen rows and columns. The heavier horizontal line between rows 3 and 23 and the heavier vertical line between columns F and Q indicate that rows 1 to 3 and columns A to F are frozen. The rows between 3 and 23 and the columns between F and Q have been scrolled off the page. To freeze rows or columns:

1) Click on the row header below the rows you want the freeze or click on the column header to the right of the columns where you want the freeze. To freeze both rows and columns, select the cell (not a row or column) that is below the row and to the right of the column that you want to freeze.

2) Go to View on the Menu bar and select Freeze Rows and Columns. Shortcut: Alt V+R. A heavier line appears between the rows or columns indicating where the freeze has been place.
Unfreezing

To unfreeze rows or columns, go to View on the Menu bar and click Freeze Rows and Columns to toggle it off. The heavier lines indicating freezing will disappear.

Splitting the screen

Another way to change the view is by splitting the screen displayed (also known as splitting the window). The screen can be split horizontally, vertically, or both, displaying up to four portions of the spreadsheet at any one time. An example of splitting the screen is shown in Figure 20 where a split is indicated by a gray line.

This could be useful for example, when a large spreadsheet has one cell with a number that is used by three formulas in other cells. Using the split-screen technique, the cell containing the number can be positioned in one section of the view and the cells with formulas can be seen in the other sections. This makes it easy to see how changing the number in one cell affects each of the formulas.

Splitting horizontally or vertically

There are two ways to split a screen horizontally or vertically:

Method One:

1) Click on the row header below the rows where you want to split the screen horizontally or click on the column header to the right of the columns where you want to split the screen vertically.

2) Go to View on the Menu bar and select Split Window. A thick line appears between the rows or columns indicating where the split has been placed. An example of a split line is shown below Row 2 in Figure 20.

Method Two:

For a horizontal split, click on the thick black line at the top of the vertical scroll bar (Figure 21) and drag the split line below the row where you want the horizontal split positioned.

Similarly, for a vertical split, click on the thick black line at the right of the horizontal scroll bar (Figure 21) and drag the split line to the right of the column where you want the vertical split positioned.
Splitting both horizontally and vertically

Method One:
Position both the black horizontal and the black vertical lines as described above and as shown in Figure 21.

Method Two:
1) Click the cell that is immediately below the rows where you want to split the screen horizontally and immediately to the right of the columns where you want to split the screen vertically.
2) Go to View on the Menu bar and select Split Window. Thick lines appear between the rows and columns indicating where the splits have been placed.

Removing split views
To remove a split view, do any of the following:
- Double-click on each split line.
- Click on and drag the split lines back to their places at the ends of the scroll bars.
- Go to View on the Menu bar and click Split Window to toggle it off.

Using the Navigator
The Navigator (Figure 22) is available in all LibreOffice modules. It provides tools and methods to move quickly through a spreadsheet and find specific items.

The Navigator categorizes and groups spreadsheet objects which you can click on to move quickly to that object. If an indicator (plus sign or triangle, dependent on computer setup) appears next to a category, at least one object in this category exists. To open a category and see the list of items,
click on the indicator. When a category is showing the list of objects in it, double-click on an object to jump directly to that object’s location in the spreadsheet.

To open the Navigator, do one of the following:

- Press the F5 key.
- Go to View > Navigator on the Menu bar.
- Click the Navigator icon in the Sidebar.

By default, the Navigator opens in the Sidebar.

The controls and tools available in the Navigator are as follows:

- **Column** – type a column letter and press the Enter key to reposition the cell cursor to the specified column in the same row.
- **Row** – type a row number and press the Enter key to reposition the cell cursor to the specified row in the same column.
- **Data Range** – specifies the current data range denoted by the position of the cell cursor.
- **Start** – moves the cursor to the cell at the beginning of the current data range, which you can highlight using the Data Range icon.
- **End** – moves the cursor to the cell at the end of the current data range, which you can highlight using the Data Range icon.
- **Toggle** – toggles the contents view. Only the selected category and its objects are displayed. Click the icon again to restore all elements for viewing.
- **Scenarios** – displays all available scenarios. See Chapter 9, Data Analysis, for more information about scenarios. Double-click a name to apply that scenario and the result is shown in the sheet. If the Navigator displays scenarios, you can access the following commands when you right-click a scenario entry:
  - **Delete** – deletes the selected scenario.
  - **Properties** – opens the Edit scenario dialog, where you can edit the scenario properties.
- **Drag Mode** – opens a submenu for selecting which action is performed when dragging and dropping an object from the Navigator into a document. Depending on the mode you select, the icon indicates whether a hyperlink, a link, or a copy is created.
  - **Insert as Hyperlink** – hyperlinks the entire item.
  - **Insert as Link** – links the copied item to the original item so that when the original item is changed, that change will be reflected in the current document.
  - **Insert as Copy** – inserts a copy of the selected item.

**Tip**

Ranges, scenarios, pictures, and other objects are much easier to find if you have given them informative names when creating them, instead of keeping the default Calc names, for example Scenario 1, Image 1, Image 2, Object 1, and so on. These default names may not correspond to the position of the object in the document.
Using document properties

To open the Properties dialog for a document, go to File > Properties on the Menu bar. The Properties dialog provides information about the spreadsheet and allows you to set some of its properties. The dialog and its tabs are described below.

General
Contains basic information about the current file.

- The text box at the top of the dialog displays the file name.
- **Change Password** – opens a dialog to change the password. It is only active if a password has been set for the file.
- **Type** – displays the file type of the current document.
- **Location** – displays the path and the name of the directory where the file is stored.
- **Size** – displays the size of the current document in bytes.
- **Created** – displays the date, time, and author when the file was first saved.
- **Modified** – displays the date, time, and author when the file was last saved in a LibreOffice file format.
- **Template** – displays the template that was used to create the file.
- **Digitally signed** – displays the date and time when the file was last signed as well as the name of the author who signed the document.
- **Digital Signatures** – opens the Digital Signatures dialog where you can manage digital signatures for the current document.
- **Last printed** – displays the date, time, and user name when the file was last printed.
- **Total editing time** – displays the amount of time that the file has been open for editing since the file was created. The editing time is updated when you save the file.
- **Revision number** – displays the number of times that the file has been saved.
- **Apply user data** – saves the full name of the user with the file. You can edit the name by going to Tools > Options > LibreOffice > User Data on the Menu bar.
- **Save preview image with this document** – saves a thumbnail.png inside the document. These images may be used by a file manager under certain conditions.
- **Reset Properties** – resets the editing time to zero, the creation date to the current date and time, and the version number to 1. The modification and printing dates are also deleted.

Description
Contains optional editable descriptive information about the spreadsheet.

- **Title** – enter a title for the spreadsheet.
- **Subject** – enter a subject for the spreadsheet. You can use a subject to group documents with similar contents.
- **Keywords** – enter the words that you want to use to index the content of the spreadsheet. Keywords must be separated by commas. A keyword can contain white space characters or semicolons.
- **Comments** – enter comments to help identify the spreadsheet.
Custom Properties

Use this page to assign custom information fields to the spreadsheet. In a new spreadsheet, this page may be blank. If the new spreadsheet is based on a template, this page may contain fields. You can change the name, type, and contents of each row. The information in the fields will be exported as metadata to other file formats.

Click Add Property to add a new custom property. Click Reset to delete all custom properties.

CMIS Properties

Used for spreadsheets stored on remote servers. See the Help or the Getting Started Guide for more information.

Security

Enables two password-protected security options.

- Open file read-only – select to allow this document to be opened only in read-only mode. This file sharing option protects the document against accidental changes. It is still possible to edit a copy of the document and save that copy with the same name as the original.
- Record changes – select to require that all changes be recorded. To protect the recording state with a password, click Protect and enter a password. This is similar to Edit > Track Changes > Record on the Menu bar. However, while other users of this document can apply their changes, they cannot disable change recording without knowing the password.
- Protect or Unprotect – protects the change recording state with a password. If change recording is protected for the current document, the button is named Unprotect. Click Unprotect and type the correct password to disable the protection.

Font

When Embed fonts in the document is selected, any fonts used in the spreadsheet will be embedded into the document when it is saved. This may be useful if you are creating a PDF of the spreadsheet and want to control how it will look on other computer systems.

Only embed fonts that are used in documents – If fonts have been defined for the spreadsheet (for example, in the template), but have not been used, select this option to not embed them.

Font scripts to embed – You can choose which types of fonts are embedded: Latin, Asian, Complex. See the Getting Started Guide for more information.

Statistics

Displays statistics for the current file: the number of sheets, cells, pages, and formula groups.
Chapter 2
Entering, Editing, and Formatting Data
**Introduction**

You can enter data into Calc in several ways: using the keyboard, dragging and dropping, the Fill tool, and selection lists. Calc also provides the ability to enter data into multiple sheets of the same spreadsheet at the same time. After entering data, you can format and display it in various ways.

**Entering data**

Most data entry in Calc can be done using the keyboard.

**Numbers**

Click in the cell and type the number using the number keys on either the main keyboard or the numeric keypad.

**Negative numbers**

To enter a negative number, either type a minus (−) sign in front of the number or enclose the number in parentheses ( ), for example (1234). The result for both methods of entry is the same; for example, −1234.

**Leading zeroes**

If a number is entered with leading zeroes, for example 01481, by default Calc will automatically drop the leading zero. To retain a minimum number of characters in a cell when entering numbers and retain the number format, for example 1234 and 0012, use this method to add leading zeroes:

3) With the cell selected, right-click on the cell and select **Format Cells** from the context menu, or go to **Format > Cells** on the Menu bar, or use the keyboard shortcut **Ctrl+1** to open the Format Cells dialog (Figure 23).

![Format Cells dialog – Numbers tab](image)

*Figure 23: Format Cells dialog – Numbers tab*
4) Make sure the Numbers tab is selected, then select Number in the Category list.

5) In Options > Leading Zeroes, enter the minimum number of characters required. For example, for four characters, enter 4. Any number less than four characters will then have leading zeroes added, for example 12 becomes 0012.

6) Click OK. The number entered retains its number format and any formula used in the spreadsheet will treat the entry as a number in formula functions.

Tip

To format numbers with only decimal places, but without a leading zero, follow steps 1 and 2 above, then in the Format code box type a . (period or full stop) followed by ? (question marks) to represent the number of decimal places required. For example, for 3 decimal places, type .??? and click OK. Any number with only decimal places will then have no leading zero, for example 0.01856 becomes .019.

Numbers as text

Numbers can also be converted into text as follows:

1) With the cell selected, open the Format Cells dialog (Figure 23).
2) Make sure the Numbers tab is selected, then select Text from the Category list.
3) Click OK. The number is converted to text and, by default, is left-aligned. You can change the formatting and alignment of any text numbers just as you would with normal text.

Note

Any numbers formatted as text in a spreadsheet will be treated as a zero value by any formulas used in the spreadsheet. Formula functions will ignore text entries.

Text

Click in a cell and type the text. The text is left-aligned by default. Cells can contain several lines of text. If you want to use paragraphs, press Ctrl+Enter to create another paragraph.

On the Formula Bar, you can extend the Input Line if you are entering several lines of text. Click on the Extend Formula Bar icon located on the right of the Formula Bar and the Input Line becomes multi-line, as shown in Figure 24. Click the Extend Formula Bar icon again to return to a single input line.

Figure 24: Extended input line on Formula Bar

Date and time

Select the cell and type the date or time. You can separate the date elements with a slash (/) or a hyphen (–) or use text, for example 10 Oct 2012. The date format automatically changes to the selected format used by Calc.
When you enter a time, separate time elements with colons, for example 10:43:45. The time format automatically changes to the selected format used by Calc.

To change the date or time format used by Calc:

1) With the cell selected, open the Format Cells dialog (Figure 23).
2) Make sure the Numbers tab is selected, then select Date or Time from the Category list.
3) Select the date or time format you want to use from the Format list.
4) Click OK to save the changes and close the dialog.

**Note**
The date format will be influenced by the system or worksheet language settings.

**Special characters**
A special character is a character not normally found on a standard keyboard; for example, © ¾ æ ç ŋ ø ç. To insert a special character:

1) Place the cursor where you want the character to appear.
2) Go to Insert > Special Character... on the Menu bar to open the Special Characters dialog (Figure 25).
3) From the grid of characters, select the required character. The last character selected is shown on the right of the Special Characters dialog along with its numerical code.

4) Any recently inserted characters are shown below the grid of characters and can be selected in the same way as any other character in the dialog.

5) At the bottom of the dialog there is provision for building a small collection of Favorite Characters. To add a new character to the collection, select the required character and click the Add to Favorites button. To remove an existing character from the collection, select the character and click the Remove from Favorites button.

6) Click Insert to close the dialog and the special character is inserted into the selected cell.

**Note**

Different fonts include different special characters. If you do not find a particular special character you want, try changing the Font and Subset selection.

**AutoCorrect options**

Calc automatically applies many changes during data input using AutoCorrect, unless you have deactivated any AutoCorrect changes. You can also undo any AutoCorrect changes by using the keyboard shortcut Ctrl+Z or manually by going back to the change and replacing the autocorrection with what you want to actually see.

To change the AutoCorrect options, go to Tools > AutoCorrect > AutoCorrect Options on the Menu bar to open the AutoCorrect dialog (Figure 26).

![AutoCorrect dialog](image)

**Figure 26: AutoCorrect dialog**

**Replace**

Edit the replacement table for automatically correcting or replacing words or abbreviations.

**Exceptions**

Specify the abbreviations or letter combinations that you do not want corrected automatically.

**Options**

Select the options for automatically correcting errors as you type and then click OK.
Localized Options
Specify the AutoCorrect options for quotation marks and for options that are specific to the language of the text.

Reset
Reset modified values back to the LibreOffice default values.

Inserting dashes
Calc provides text shortcuts so that you can quickly insert dashes into a cell and these shortcuts are shown in Table 2.

Table 2: Inserting dashes

<table>
<thead>
<tr>
<th>Text that you type</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>A - B (A, space, hyphen, space, B)</td>
<td>A – B (A, space, en-dash, space, B)</td>
</tr>
<tr>
<td>A -- B (A, space, hyphen, hyphen, space, B)</td>
<td>A – B (A, space, en-dash, space, B)</td>
</tr>
<tr>
<td>A--B (A, hyphen, hyphen, B)</td>
<td>A—B (A, em-dash, B)</td>
</tr>
<tr>
<td>A-B (A, hyphen, B)</td>
<td>A-B (unchanged)</td>
</tr>
<tr>
<td>A -B (A, space, hyphen, B)</td>
<td>A -B (unchanged)</td>
</tr>
<tr>
<td>A --B (A, space, hyphen, hyphen, B)</td>
<td>A –B (A, space, en-dash, B)</td>
</tr>
</tbody>
</table>

Speeding up data entry
Entering data into a spreadsheet can be very labor-intensive, but Calc provides tools for removing some of the drudgery from input. These tools include drag and drop to move or copy contents of one cell to another using a mouse, an AutoInput tool, the Fill tool, and selection lists.

The Fill tool and selection lists automate input of repetitive material into cells. Calc also has the ability to input information into multiple sheets of the same spreadsheet at the same time.

AutoInput tool
The AutoInput function in Calc automatically completes entries, based on other entries in the same column. The column is scanned up to a maximum of 2000 cells or 200 different strings.

When text is highlighted in a cell, AutoInput can be used as follows:

1) To accept the completion, press Enter or F2 or click the mouse button.
2) To view more completions, use the key combinations Ctrl+Tab to scroll forward, or Ctrl+Shift+Tab to scroll backward.
3) To see a list of all available AutoInput text items for the current column, use the keyboard combination Alt+Down Arrow.

When typing formulas using characters that match previous entries, a Help tip will appear listing the last ten functions used in the Function Wizard from all defined range names and from the content of all label ranges.

AutoInput ignores the case sensitivity of any data you enter. If, for example, you have written "Total" in a cell, you cannot then enter "total" in another cell of the same column without first deactivating AutoInput.

By default, AutoInput is activated in Calc. To turn it off, go to Tools on the Menu bar and deselected AutoInput.
**Fill tool**

You can use the Fill tool in Calc to duplicate existing content or create a series in a range of cells in the spreadsheet as shown by the examples in Figure 27.

![Figure 27: Examples of using the Fill tool](image)

1) Select the cell containing the contents you want to copy or start the series from.

2) Drag the cursor in any direction or hold down the *Shift* key and click in the last cell you want to fill.

3) Go to **Sheet > Fill Cells** on the Menu bar and select the direction in which you want to copy or create data (*Down*, *Right*, *Up*, *Left*, *Sheets*, *Series* or *Random Number*). A menu option will be grayed out if it is not available.

Alternatively, you can use a shortcut to fill cells:

1) Select the cell containing the contents you want to copy or start the series from.

2) Move the cursor over the small selection handle in the bottom right corner of the selected cell. The cursor will change shape.

3) Click and drag in the direction you want the cells to be filled, vertical or horizontal. If the original cell contained text, then the text will automatically be copied. If the original cell contained a number, a series will be created.

**Caution**

When you are selecting cells so you can use the Fill tool, make sure that none of the cells contain data, except for the cell data you want to use. When you use the Fill tool, any data contained in selected cells is overwritten.

**Using a fill series**

When you select a series fill from **Sheet > Fill Cells > Series** on the Menu bar, the Fill Series dialog (Figure 28) opens. Here you can select the type of series you want or create your own list.

**Direction**

Determines the direction of series creation.

- *Down* – creates a downward series in the selected cell range for the column using the defined increment to the end value.

- *Right* – creates a series running from left to right within the selected cell range using the defined increment to the end value.

- *Up* – creates an upward series in the cell range of the column using the defined increment to the end value.

- *Left* – creates a series running from right to left in the selected cell range using the defined increment to the end value.
Figure 28: Fill Series dialog

Series Type
Defines the series type. These are:

- **Linear** – creates a linear number series using the defined increment and end value.
- **Growth** – creates a growth series using the defined increment and end value.
- **Date** – creates a date series using the defined increment and end date.
- **AutoFill** – forms a series directly in the sheet. The AutoFill function takes account of customized lists. For example, by entering January in the first cell, the series is completed using the list defined in **LibreOffice > Tools > Options > LibreOffice Calc > Sort Lists**. AutoFill tries to complete a value series by using a defined pattern. For example, a numerical series using 1,3,5 is automatically completed with 7,9,11,13; a date and time series using 01.01.99 and 15.01.99, an interval of fourteen days is used.

Time Unit
In this area you specify the desired unit of time. This area is only active if the Date option has been selected in Series Type. These are:

- **Day** – use the Date series type and this option to create a series using seven days.
- **Weekday** – use the Date series type and this option to create a series of five day sets.
- **Month** – use the Date series type and this option to form a series from the names or abbreviations of the months.
- **Year** – use the Date series type and this option to create a series of years.

Start Value
Determines the start value for the series. Use numbers, dates or times.

End Value
Determines the end value for the series. Use numbers, dates or times.

Increment
Determines the value by which the series of the selected type increases by each step. Entries can only be made if the linear, growth or date series types have been selected.
Defining a fill series

To define your own fill series:

1) Go to Tools > Options > LibreOffice Calc > Sort Lists to open the Sort Lists dialog (Figure 29). This dialog shows any previously defined series in the Lists box on the left and the contents of the highlighted list in the Entries box.

2) Click New and the Entries box is cleared.

3) Type the series for the new list in the Entries box (one entry per line) (Figure 30).

4) Click Add and the new list will now appear in the Lists box.

5) Click OK to save the new list and close the dialog.

Selection lists

Selection lists are available only for text and are limited to using only text that has already been entered in the same column.

1) Select a blank cell in a column that contains cells with text entries.

2) Right-click and select Selection Lists from the context menu, or use the keyboard shortcut Alt+I. A drop-down list appears listing any cell in the same column that either has at least one text character or whose format is defined as text.
3) Click on the text entry you require and it is entered into the selected cell.

Merging and splitting cells

Merging
You can select contiguous cells and merge them into one as follows:

1) Select the range of contiguous cells you want merge.
2) Right-click on the selected cells and select **Merge Cells** from the context menu, or go to **Format > Merge cells > Merge cells** or **Merge and Center Cells** on the Menu bar, or click on the **Merge and Center Cells** icon on the Formatting toolbar. Using **Merge and Center Cells** will center align any contents in the cells.
3) If the cells contain any data, a small dialog (Figure 31) opens, showing choices for moving or hiding data in the hidden cells.
4) Make your selection and click **OK**.

![Figure 31: Merge choices for non-empty cells](image)

**Caution**

Merging cells can lead to calculation errors in formulas used in the spreadsheet.

Splitting
You can reverse or split only a cell that was created from several cells by merging.

1) Select a merged cell.
2) Go to **Format > Merge cells > Split cells** on the Menu bar, or right-click and select **Split Cells** from the context menu, or click on the **Merge and Center Cells** icon on the Formatting toolbar.
3) Any data in the cell will remain in the first cell. If the hidden cells did have any contents before the cells were merged, then you have to manually move the contents in to the correct cell.

Sharing content between sheets
You might want to enter the same information in the same cell on multiple sheets, for example to set up standard listings for a group of individuals or organizations. Instead of entering the list on each sheet individually, you can enter the information in several sheets at the same time.
1) Go to **Edit > Select > Select Sheets** on the Menu bar to open the Select Sheets dialog (Figure 32).

2) Select the individual sheets where you want the information to be repeated.

3) Click **OK** to select the sheets and the sheet tabs will change color.

4) Enter the information in the cells on the sheet where you want the information to first appear and the information will be repeated in the selected sheets.

5) Deselect the sheets when you have finished entering the information that you want repeated in the sheets.

**Caution**

This technique automatically overwrites, without any warning, any information that is already in the cells on the selected sheets. Make sure you deselect the additional sheets when you have finished entering the information to be repeated before continuing to enter data into the spreadsheet.

---

**Validating cell contents**

When creating spreadsheets for other people to use, you may want to make sure they enter data that is valid or appropriate for the cell. You can also use validation in your own work as a guide to entering data that is either complex or rarely used.

Fill series and selection lists can handle some types of data, but are limited to predefined information. For example, a cell may require a date or a whole number with no alphabetic characters or decimal points, or a cell may not be left empty.

Depending on how validation is set up, it can also define the range of contents that can be entered, provide help messages explaining the content rules set up for the cell and what users should do when they enter invalid content. You can also set the cell to refuse invalid content, accept it with a warning, or start a macro when an error is entered.

**Defining validation**

To validate any new data entered into a cell:

1) Select a cell and go to **Data > Validity** on the Menu bar to open the Validity dialog.

2) Define the type of contents that can be entered in that cell using the options given on the tabbed pages for **Criteria**, **Input Help**, and **Error Alert**. The options are explained below (Figure 33).
Criteria options

Specify the validation rules for the selected cells using the Criteria page in the Validity dialog as shown in Figure 33. For example, you can define criteria such as: *Numbers between 1 and 10* or *Texts that are no more than 20 characters*.

The options available on the Criteria page will depend on what has been selected in the Allow drop-down list.

- **Allow** – select a validation option for the selected cells from the drop-down list.
  - *All values* – no limitation.
  - *Whole number* – only whole numbers allowed.
  - *Decimal* – all numbers correspond to decimal format.
  - *Date* – all numbers correspond to date format. The entered values are formatted the next time the dialog is called up.
  - *Time* – all numbers correspond to time format. The entered values are formatted the next time the dialog is called up.
  - *Cell range* – allow only values that are given in a cell range. The cell range can be specified explicitly, or as a named database range, or as a named range. The range may consist of one column or one row of cells. If you specify a range of columns and rows, only the first column is used.
  - *List* – allow only values or strings specified in a list. Strings and values can be mixed. Numbers evaluate to their value, so if you enter the number 1 in the list, the entry 100% is also valid.
  - *Text length* – allow entries whose length corresponds to the number of characters that have been set.
  - *Custom* – allow entries that correspond to a formula entered in the Formula box.

- **Allow empty cells** – in conjunction with **Tools > Detective > Mark Invalid Data**, this defines that blank cells are shown as invalid data (disabled) or not shown (enabled).

- **Show selection list** – shows a list of all valid strings or values to select from. The list can also be opened by selecting the cell and pressing \(\text{Ctrl+D}\).

- **Sort entries ascending** – sorts the selection list in ascending order and filters duplicates from the list. If not checked, the order from the data source is taken.

- **Source** – enter the cell range that contains the valid values or text.
• **Entries** – enter the entries that will be valid values or text strings.
• **Data** – select the comparative operator that you want to use from the drop-down list. The available operators depend on what you have selected in the Allow drop-down list. For example, if you select valid range, the **Minimum** and **Maximum** input boxes replace the **Value** box.
• **Value** – enter the value for the data validation option that you selected in the Allow drop-down list.
• **Minimum** – enter the minimum value for the data validation option that you selected in the Allow drop-down list.
• **Maximum** – enter the maximum value for the data validation option that you selected in the Allow drop-down list.

**Input Help options**
Enter the message to be displayed when the cell or cell range is selected in the spreadsheet (Figure 34).
• **Show input help when cell is selected** – displays the message that you enter in the **Title** and **Contents** boxes when the cell or cell range is selected in the sheet. If you enter text in the **Title** and **Contents** boxes and then deselect this option, the text will be lost.
• **Title** – enter the title to be displayed when the cell or cell range is selected.
• **Input help** – enter the message to be displayed when the cell or cell range is selected.

![Figure 34: Validity dialog – Input Help page](image)

**Error Alert options**
Define the error message that is displayed when invalid data is entered in a cell (Figure 35).

![Figure 35: Validity dialog – Error Alert page](image)
• **Show error message when invalid values are entered** – when selected, displays the error message that you enter in the Contents area when invalid data is entered in a cell.

• **Action** – select the action that you want to occur when invalid data is entered in a cell.
  - *Stop* – rejects the invalid entry and displays a dialog that you have to close by clicking **OK**.
  - *Warning* and *Information* – displays a dialog that can be closed by clicking **OK** or **Cancel**. The invalid entry is only rejected when you click **Cancel**.
  - *Macro* – activates the **Browse** button to open the Macro dialog where you can select a macro that is executed when invalid data is entered in a cell. The macro is executed after the error message is displayed.

• **Title** – enter the title of the macro or the error message that you want to display when invalid data is entered in a cell.

• **Error message** – enter the message that you want to display when invalid data is entered in a cell.

**Calc detective**

The Detective is a tool within Calc that you can use to locate any cells in a spreadsheet that contain invalid data if the cells are set to accept invalid data with a warning.

1) Go to **Tools > Detective > Mark Invalid Data** on the Menu bar to locate any cells containing invalid data. The Detective function marks any cells containing invalid data.

2) Correct the data so that it becomes valid.

3) Go to **Tools > Detective > Mark Invalid Data** on the Menu bar again and any cells that were previously marked as containing invalid data have the invalid data mark removed.

**Note**

A validity rule is considered part of the format for a cell. If you select **Delete All** from the Delete Contents dialog (Figure 37), then it is removed. If you want to copy a validity rule with the rest of the cell, use **Edit > Paste Special > Paste Special** to open the Paste Special dialog (Figure 38), then select **Paste All** or **Formats** and click **OK**.

**Editing data**

**Deleting data**

*Deleting cell data only*

Data can be deleted from a cell without deleting any of the cell formatting. Select a cell or a range of cells and then press the **Delete** key.

*Delete Cells*

This option completely deletes selected cells, columns, or rows. The cells below or to the right of the deleted cells will fill the space.

1) Select a cell or a range of cells.

2) Press the Ctrl+- keys, or select **Sheet > Delete Cells** from the Menu bar, or right-click inside the selected cells and choose **Delete** from the context menu.
3) The Delete Cells dialog (Figure 36) provides four options to specify how sheets are displayed after deleting cells:

**Shift cells up**
Fills the space produced by the deleted cells with the cells underneath it.

**Shift cells left**
Fills the resulting space by the cells to the right of the deleted cells.

**Delete entire row(s)**
After selecting at least one cell, deletes the entire row from the sheet.

**Delete entire column(s)**
After selecting at least one cell, deletes the entire column from the sheet.

4) To confirm the selection, click **OK**.

**Note**

The selected delete option is stored and reloaded when the dialog is next called.

**Deleting data and formatting**

Data and cell formatting can be deleted from a cell at the same time. To do this:

1) Select a cell or a range of cells.
2) Press the Backspace key, or right-click inside the selected cells and choose Clear Contents from the context menu, or select Sheet > Clear Cells from the Menu bar.
3) In the Delete Contents dialog (Figure 37), choose any of the options or choose Delete All. Click **OK**.
Replacing data
To completely replace data in a cell and insert new data, select the cell and type in the new data. The new data will replace the data already contained in the cell and will retain the original formatting used in the cell.

Alternatively, click in the Input Line on the Formula Bar, then double-click on the data to highlight it completely and type the new data.

Editing data
Sometimes it is necessary to edit the contents of cell without removing all of the data from the cell. For example, changing the phrase “Sales in Qtr. 2” to “Sales rose in Qtr” can be done as follows.

Using the keyboard
1) Click in the cell to select it.
2) Press the F2 key and the cursor is placed at the end of the cell.
3) Press the Backspace key to delete any data up to the point where you want to enter new data.
4) Alternatively, use the keyboard arrow keys to reposition the cursor where you want to start entering the new data in the cell, then press the Delete key or Backspace key to delete any unwanted data before typing the new data.
5) When you have finished editing, press the Enter key to save the changes.

Note
Each time you select a cell, the contents are displayed in the Input Line on the Formula Bar. Using the Input Line may be easier when editing data.

Using the mouse
1) Double-click on the cell to select it and place the cursor in the cell for editing.
2) Reposition the cursor to where you want to start editing the data in the cell.
3) Alternatively, single-click to select the cell, then move the cursor to the Input Line on the Formula Bar and click at the position where you want to start editing the data in the cell.
4) When you have finished, click away from the cell to deselect it and the editing changes are saved.

Paste Special function
You can use the Paste Special function to paste into another cell selected parts of the data in the original cell or cell range, for example its format or the result of its formula.

Paste Special dialog
1) Select a cell or a cell range.
2) Go to Edit > Copy on the Menu bar, or right-click and select Copy from the context menu.
3) Select the target cell or cell range.
4) Go to Edit > Paste Special > Paste Special from the Menu bar, or use the keyboard shortcut Ctrl+Shift+V, or right-click and select Paste Special > Paste Special from the context menu to open the Paste Special dialog (Figure 38).
5) Select the options for Selection, Operations, Options and Shift cells. The Paste Special options are explained below.
6) Click OK to paste the data into the target cell or range of cells and close the dialog.
Paste Special options

- **Selection** – select a format for the clipboard contents that you want to paste.
  - *Paste all* – pastes all cell contents, comments, formats, and objects into the current document.
  - *Text* – pastes cells containing text.
  - *Numbers* – pastes cells containing numbers.
  - *Date & Time* – pastes cells containing date and time values.
  - *Formulas* – pastes cells containing formulas.
  - *Comments* – pastes comments that are attached to cells. If you want to add the comments to the existing cell content, select the *Add* operation.
  - *Formats* – pastes cell format attributes.
  - *Objects* – pastes objects contained within the selected cell range. These can be OLE objects, chart objects, or drawing objects.
- **Operations** – select the operation to apply when you paste cells into the sheet.
  - *None* – does not apply an operation when you insert the cell range from the clipboard. The contents of the clipboard will replace existing cell contents.
  - *Add* – adds the values in the clipboard cells to the values in the target cells. Also, if the clipboard only contains comments, adds the comments to the target cells.
  - *Subtract* – subtracts the values in the clipboard cells from the values in the target cells.
  - *Multiply* – multiplies the values in the clipboard cells with the values in the target cells.
  - *Divide* – divides the values in the target cells by the values in the clipboard cells.
• **Options** – sets the paste options for the clipboard contents.
  – **Skip empty cells** – empty cells from the clipboard do not replace target cells. If you use this option in conjunction with the *Multiply* or the *Divide* operation, the operation is not applied to the target cell of an empty cell in the clipboard. If you select a mathematical operation and deselect the *Skip empty cells*, empty cells in the clipboard are treated as zeroes. For example, if you apply the *Multiply* operation, the target cells are filled with zeroes.
  – **Transpose** – the rows of the range in the clipboard are pasted to become columns of the output range. The columns of the range in the clipboard are pasted to become rows.
  – **Link** – inserts the cell range as a link, so that changes made to the cells in the source file are updated in the target file. To ensure that changes made to empty cells in the source file are updated in the target file, ensure that *Paste All* is also selected. You can also link sheets within the same spreadsheet. When you link to other files, a DDE link is automatically created. A DDE link is inserted as a matrix formula and can only be modified as a whole.

• **Shift cells** – sets the shift options for the target cells when the clipboard content is inserted.
  – **Don't shift** – inserted cells replace the target cells.
  – **Down** – target cells are shifted downward when you insert cells from the clipboard.
  – **Right** – target cells are shifted to the right when you insert cells from the clipboard.

**Paste Only options**
If you only want to copy text, numbers, or formulas to the target cell or cell range:

1) Select the source cell or cell range and copy the data.
2) Select the target cell or cell range.
3) Right-click on the target cell or cell range and select *Paste Special* from the context menu, then select *Text*, *Number*, or *Formula*.

**Insert cell fields**
You can insert a field linked to the date, sheet name, or document name in a cell.

1) Select a cell and double-click to activate edit mode.
2) Right-click and select **Insert Field > Date** or **Sheet Name** or **Document Title** from the context menu.

**Note**
The **Insert Field > Document Title** command inserts the name of the spreadsheet and not the title defined in the *Description* page in the Properties dialog for the file.

**Tip**
The fields are refreshed when the spreadsheet is saved or recalculated when using the *Ctrl+Shift+F9* shortcut.
Formatting data

Note

All the settings discussed in this section can also be set as a part of the cell style. See Chapter 4, Using Styles and Templates, for more information.

You can format the data in Calc in several ways, either defined as part of a cell style so that it is automatically applied, or applied manually to the cell. For more control and extra options, select a cell or cell range and use the Format Cells dialog. All of the format options are discussed below.

Multiple lines of text

Multiple lines of text can be entered into a single cell using automatic wrapping or manual line breaks. Each method is useful for different situations.

Automatic wrapping

To automatically wrap multiple lines of text in a cell:

1) Select a cell or cell range.
2) Right-click and select Format Cells from the context menu, or go to Format > Cells on the Menu bar, or press Ctrl+1 to open the Format Cells dialog.
3) Click on the Alignment tab (Figure 39).
4) Under Properties, select Wrap text automatically and click OK.

![Format Cells dialog – Alignment page](image)

Manual line breaks

To insert a manual line break while typing in a cell, press Ctrl+Enter. This method does not work with the cursor in the input line. When editing text, double-click the cell, then reposition the cursor to where you want the line break.
When a manual line break is entered, the cell width does not change and the text may still overlap the end of the cell. You have to change the cell width manually or reposition the line break so that the text does not overlap the end of the cell.

**Shrinking text to fit a cell**

The font size of the data in a cell can automatically adjust to fit inside cell borders.

1) Select a cell or cell range.
2) Right-click on the selection and select **Format Cells** from the context menu, or go to **Format > Cells** on the Menu bar, or press **Ctrl+1** to open the Format Cells dialog.
3) Click on the **Alignment** tab (Figure 39).
4) Under **Properties**, select **Shrink to fit cell size** and click **OK**.

**Formatting numbers**

Several different number formats can be applied to cells by using icons on the Formatting toolbar (highlighted in Figure 40). Select the cell, then click the relevant icon to change the number format.

For more control or to select other number formats, use the **Numbers** page of the Format Cells dialog (Figure 23 on page 46):

- Apply any of the data types in the **Category** list to the data.
- Control the number of decimal places and leading zeros in **Options**.
- Enter a custom format code.
- The **Language** setting controls the local settings for the different formats such as the date format and currency symbol.

![Figure 40: Number icons on Formatting toolbar](image)

**Formatting fonts**

To select a font and format it for use in a cell:

1) Select a cell or cell range.
2) Click the small triangle on the right of the Font Name box on the Formatting toolbar (highlighted in Figure 41) and select a font from the drop-down list. The font can also be changed using the Font page on the Format Cells dialog.
3) Click on the small triangle on the right of the Font Size box on the Formatting toolbar and select a font size from the drop-down list. The font size can also be changed using the **Font** page on the Format Cells dialog.
4) To change the character format, click on the **Bold**, **Italic**, or **Underline** icons.
5) To change the paragraph alignment of the font, click on one of the four alignment icons (**Left**, **Center**, **Right**, **Justified**).

![Figure 41: Font Name and Size on Formatting toolbar](image)
Note

To specify the language used in the cell, open the Font page on the Format Cells dialog. Changing language in a cell allows different languages to exist within the same document. For more changes to font characteristics, see “Font effects” below for more information.

Tip

To choose whether to show the font names in their font or in plain text, go to Tools > Options > LibreOffice > View and select or deselect the Show preview of fonts option in the Font Lists section. For more information, see Chapter 14, Setting Up and Customizing Calc.

Font effects

1) Select a cell or cell range.
2) Right-click and select Format Cells from the context menu, or go to Format > Cells on the Menu bar, or press Ctrl+1 to open the Format Cells dialog.
3) Click on the Font Effects tab (Figure 42).
4) Select the font effect you want to use from the options available. The options available are described in Chapter 4, Using Styles and Templates.
5) Click OK to apply the font effects and close the dialog.

![Format Cells dialog – Font Effects page](image)

Figure 42: Format Cells dialog – Font Effects page

Any font effect changes are applied to the current selection, or to the entire word that contains the cursor, or to any new text that you type.

Text direction

To change the text direction within a cell, use the Alignment page on the Format Cells dialog (Figure 39 on page 63).

1) On the Alignment page of the Format Cells dialog, select the Reference edge from which to rotate the text as follows:
– **Text Extension From Lower Cell Border** – writes the rotated text from the bottom cell edge outwards.
– **Text Extension From Upper Cell Border** – writes the rotated text from the top cell edge outwards.
– **Text Extension Inside Cells** – writes the rotated text only within the cell.

2) Click on the small indicator at the edge of the *Text orientation* dial and rotate it until you reach the required degrees.
3) Alternatively, enter the number of degrees to rotate the text in the **Degrees** box.
4) Select **Vertically stacked** to make the text appear vertically in the cell.

**Using the icons on the Formatting toolbar**
The icons on the Formatting toolbar can be used as follows after the cell has been selected:

- To change the text direction from horizontal (default direction) to vertical, click on the **Text direction from top to bottom** icon.
- To change text direction from vertical to horizontal (default), click on the **Text direction from left to right** icon.
- To change text direction from left to right, which is the default direction for Western fonts, to a right to left direction used in some fonts, for example Arabic, the click on the **Right-To-Left** icon. This only works if a font has been used that requires a right to left direction.
- To change text direction back to the default left to right direction used for Western fonts, click on the **Left-To-Right** icon.

**Note**
The text direction icons can only be made available if **Asian** under **Tools > Language Settings > Language > Default Language for Documents** is checked. To make the buttons visible, right-click on the toolbar and select **Visible Buttons** from the context menu, then click on the icon you require and it will be placed on the Formatting toolbar.

**Formatting cell borders**
To format the borders of a cell or a group of selected cells, you can use the border icons on the Formatting toolbar to apply the default styles to borders, or the Format Cells dialog for greater control. See Chapter 4, Using Styles and Templates, for more information on the options.

**Note**
Cell border properties apply only to the selected cells and can only be changed if you are editing those cells. For example, if cell C3 has a top border, that border can only be removed by selecting C3. It cannot be removed in C2 it appears to be the bottom border for cell C2.
1) Select a cell or a range of cells.
2) Right-click and select **Format Cells** from the context menu, or go to **Format > Cells** on the Menu bar, or press **Ctrl+1** to open the Format Cells dialog.
3) On the **Borders** tab (Figure 43), select the options required.
4) Click **OK** to close the dialog and save the changes.

Alternatively, use the icons on the Formatting toolbar to apply default styles to borders:

1) Click the **Borders** icon and select one of the options displayed in the Borders palette.
2) Click the **Border Style** icon and select one of the line styles from the Border Style palette.
3) Click the **Border Color** icon and select a color from Border Color palette.

**Note**

When entering borders with the Border icons on the Formatting toolbar, you have two choices: click the required icon to add a border to the present borders or **Shift-click** to add a border and remove the present borders.

**Formatting cell backgrounds**

To format the background color for a cell or a group of cells (see Chapter 4, Using Styles and Templates, for more information):

1) Select a cell or a range of cells.
2) Right-click and select **Format Cells** from the context menu, or go to **Format > Cells** on the Menu bar, or press **Ctrl+1** to open the Format Cells dialog.
3) On the **Background** tab, select a color from the color palette.
4) Click **OK** to save the changes and close the dialog.
Alternatively, click on the **Background Color** icon on the Formatting toolbar and select a color from the Background color palette.

### AutoFormat of cells and sheets

#### Using AutoFormat

You can use AutoFormat to format a group of cells.

1. Select the cells in at least three columns and rows, including column and row headers, that you want to format.
2. Go to **Format > AutoFormat Styles** on the Menu bar to open the AutoFormat dialog (Figure 44).
3. Select the type of format and format color from the list.
4. Select the formatting properties to be included in the AutoFormat function.
5. Click **OK** to apply the changes and close the dialog.

![AutoFormat dialog](image)

#### Defining a new AutoFormat

You can define a new AutoFormat so that it becomes available for use in all spreadsheets.

1. Format the data type, font, font size, cell borders, cell background, and so on for a group of cells.
2. Go to **Edit > Select All** on the Menu bar to select the whole spreadsheet.
3. Go to **Format > AutoFormat Styles** to open the AutoFormat dialog. The **Add** button is now active.
4. Click **Add**.
5. In the Name box of the Add AutoFormat dialog that opens, type a meaningful name for the new format and click **OK**.
6. Click **OK** to close the dialog. The new AutoFormat is now available in the Format list in the AutoFormat dialog.
Using themes

Calc comes with a predefined set of formatting themes that you can apply to spreadsheets. It is not possible to add new themes to Calc and the predefined styles cannot be modified. You can modify styles after you apply them to a spreadsheet, but the modified styles are only available for use for that spreadsheet.

To apply a theme to a spreadsheet:

1) Go to Format > Spreadsheet Theme on the Menu bar or click the Spreadsheet Theme icon in the Tools toolbar to open the Theme Selection dialog (Figure 45), which lists the available themes for the whole spreadsheet.

2) Select the theme that you want to apply. As soon as you select a theme, the theme styles are applied to the spreadsheet and are immediately visible.

3) Click OK.

If you wish, you can now use the Styles pane on the Sidebar to modify specific styles. These modifications do not modify the theme; they only change the appearance of the style in the spreadsheet you are creating. For more about modifying styles, see Chapter 4, Using Styles and Templates.

Value highlighting

Value highlighting displays cell contents in different colors depending on the type of content. An example of value highlighting is shown in Figure 46.

- Text is shown in black.
- Formulas are shown in green.
- Numbers are shown in blue.
The value highlighting colors override any colors used in formatting. This color change applies only to the colors seen on a display. When a spreadsheet is printed, the original colors used for formatting are printed.

Go to **View > Value Highlighting** on the Menu bar, or use the keyboard shortcut Ctrl+F8 to turn the function on or off. When value highlighting is switched off, the original formatting colors are used for display.

You can make value highlighting the default when opening a spreadsheet in Calc, by selecting **Tools > Options > LibreOffice Calc > View > Value highlighting**. This default mode for value highlighting may not be what you want if you are going to format the cells for printing.

### Using conditional formatting

You can set up cell formats to change depending on conditions that you specify. Conditional formatting is used to highlight data that is outside the specifications that you have set. It is recommended not to overuse conditional formatting as this could reduce the impact of data that falls outside those specifications.

See page 73 for an example of how to use conditional formatting.

**Note**

Conditional formatting depends upon the use of styles and the AutoCalculate feature must be enabled. If you are not familiar with styles, see Chapter 4, Using Styles and Templates, for more information.

### Setting up conditional formatting

1) Ensure that AutoCalculate is enabled: **Data > Calculate > AutoCalculate**.

2) Select the cells where you want to apply conditional formatting.

3) Go to **Format > Conditional > Condition** (Figure 47), **Color Scale** (Figure 48), **Data Bar** (Figure 49), or **Date** on the Menu bar to open the Conditional Formatting dialog. Any conditions already defined are displayed.
4) Click **Add** to create and define a new condition. Repeat this step as necessary.

5) Select a style from the styles already defined in the Apply Style drop-down list. Repeat this step as necessary.
   Alternatively, select **New Style** to open the Cell Style dialog (Figure 50) and create a new cell style. Repeat this step as necessary.

6) Click **OK** to save the conditions and close the dialog. The selected cells are now set to apply a result using conditional formatting.

![Conditional Formatting dialog – Color Scale](Figure 48)

![Conditional Formatting dialog – Data Bar](Figure 49)
Types of conditional formatting

**Condition**
Condition is the starting point when using conditional formatting. Here you can define what formats to use to highlight any data in the spreadsheet that falls outside the specifications that you have defined.

**Color scale**
Use Color scale to set the background color of cells depending on the value of the data in a spreadsheet cell. Color scale can only be used when **All Cells** has been selected for the condition. You can use either two or three colors for the color scale.

**Data bars**
Data bars provide a graphical representation of data in the spreadsheet. The graphical representation is based on the values of data in a selected range. Click on **More Options** in the Conditional Formatting dialog to define how the data bars will look. Data bars can only be used when **All Cells** has been selected for the condition.

**Icon sets**
Icon sets display an icon next to the data in each selected cell to give a visual representation of where the cell data falls within the defined range that you set. The icons sets available are colored arrows, gray arrows, colored flags, colored signs, symbols, bar ratings and quarters. Icon sets can only be accessed when the Conditional Formatting dialog has been opened and **All Cells** has been selected for the condition.

Conditional formatting management
To see all the conditional formatting defined in the spreadsheet and any styles used:

1) Go to **Format > Conditional > Manage** on the Menu bar to open the Manage Conditional Formatting dialog (Figure 51).
2) Select a range from the Range list and click **Edit** to redefine the conditional formatting.
3) Select a range from the Range list and click **Remove** to delete the conditional formatting. The deletion is immediate with no confirmation.
4) Select **Add** to create a new definition of conditional formatting.
5) Click **OK** to save the changes and close the dialog.
**Copying cell styles**

To apply the style used for conditional formatting to other cells later:

1) Click one of the cells that has been assigned conditional formatting and copy the cell to the clipboard.
2) Select the cells that are to receive the same formatting as the copied cell.
3) Go to Edit > Paste Special > Paste Special on the Menu bar to open the Paste Special dialog (Figure 38 on page 61).
4) Make sure that only Formats is selected and click OK to paste the conditional formatting into the cell.

**Conditional formatting example**

With conditional formatting, you can, for example, highlight the totals that exceed the average value of all totals. If the totals change, the formatting changes correspondingly, without having to apply other styles manually. It is recommended that the Styles panel on the Sidebar is open and visible before proceeding.

**Defining conditions**

1) Select the cells where you want to apply a conditional style.
2) Go to Format > Conditional > Condition, Color scale or Data bar from the Menu bar to open the Conditional Formatting dialog.
3) Enter the conditions you want to use for conditional formatting.

**Generating number values**

You may want to give certain values in your tables particular emphasis. For example, in a table of turnovers, you can show all the values above the average in green and all those below the average in red. This is possible with conditional formatting.

1) Create a table in which a few different values occur. For your test you can create tables with any random numbers. In one of the cells enter the formula =RAND(), and you will obtain a random number between 0 and 1. If you want integers of between 0 and 50, enter the formula =INT(RAND()*50).
2) Copy the formula to create a row of random numbers.
3) Click the bottom right corner of the selected cell, and drag to the right and downward until the desired cell range is selected.
**Defining cell styles**

The next step is to apply a cell style to all values that represent above-average turnover and one to cells that are below the average.

1) Right-click in a blank cell and select **Format Cells** in the context menu to open the Format Cells dialog.

2) Click the **Background** tab and select a background color, then click **OK**.

3) In the Conditional Formatting dialog, select **New Style** from the **Apply Style** drop-down list to open the Cell Style dialog.

4) Enter a name of the new style. For this example, name the style **Above**.

5) Define a second style, click again in a blank cell and proceed as described above. Assign a different background color to the cell and assign a name. For this example, name the style **Below**.

**Calculating average**

In our particular example, we are calculating the average of the random values. The result is placed in a cell:

1) Click in a blank cell, for example, J14, and go to **Insert > Function** on the Menu bar, or click the **Function Wizard** icon on the Formula bar to open the Function Wizard dialog.

2) Select **AVERAGE** from the Function list.

3) Use the cursor to select all your random numbers.

4) Click **OK** to close the Function Wizard.

**Applying cell styles**

Now you can apply the conditional formatting to the sheet:

1) Select all cells containing the random numbers.

2) Go to the **Format > Conditional > Condition** on the Menu bar to open the Conditional Formatting dialog.

3) Define the condition for each cell as follows: if cell value is less than J14, format with cell style **Below** OR if cell value is greater than or equal to J14, format with cell style **Above**.

**Hiding and showing data**

In Calc you can hide elements so that they are neither visible on a computer display nor printed when a spreadsheet is printed. However, hidden elements can still be selected for copying if you select the elements around them; for example, if column B is hidden, it is copied when you select columns A and C. When you require a hidden element again, you can reverse the process and show the element.

**Hiding data**

**Sheets**

Right-click on any sheet tab and select **Hide Sheet** from the context menu. Choose which sheet from the list in the popup box.

**Rows and columns**

1) Select the row or column you want to hide.

2) Go to **Format** on the Menu bar and select **Row** or **Column**.
3) Select **Hide** from the menu and the row or column can no longer viewed or printed. Alternatively, right-click on the row or column header and select **Hide Row** or **Hide Column** from the context menu.

**Cells**

Hiding individual cells is more complicated. First you need to define the cells as Protected and Hidden; then you need to protect the sheet.

1) Select the cells you want to hide.
2) Go to **Format > Cells** on the Menu bar, or right-click and select **Format Cells** from the context menu, to open the Format Cells dialog (Figure 52).
3) Click the **Cell Protection** tab and select an option for hiding and printing the cells.
4) Click **OK** to save the changes and close the dialog.
5) Go to **Tools > Protect Sheet** on the Menu bar to open the Protect Sheet dialog (Figure 53).
6) Select **Protect this sheet and the contents of protected cells**.
7) Create a password and then confirm the password.
8) Select or deselect the options for **Allow all users of this sheet to**: so users can select protected or unprotected cells.
9) Click **OK** to save the changes and close the dialog.

![Format Cells dialog – Cell Protection tab](image)

**Figure 52: Format Cells dialog – Cell Protection tab**

![Protect Sheet dialog](image)

**Figure 53: Protect Sheet dialog**
When data in cells are hidden, it is only the data contained in the cells that are hidden and the protected cells cannot be modified. The blank cells remain visible in the spreadsheet.

**Showing data**

**Sheets**
Right-click on any sheet tab and select **Show Sheet** from the context menu. Choose which sheet from the list in the popup box.

**Rows and columns**
1. Select the rows or columns on each side of the hidden row or column.
2. Go to **Format** on the Menu bar and select **Rows** or **Columns**.
3. Select **Show** from the context menu and the row or column will be displayed and can be printed.
Alternatively, right-click on a row or column header and select **Show Rows** or **Show Columns** from the context menu.

**Cells**
1. Go to **Tools > Protect Sheet** on the Menu bar to open the Protect Sheet dialog (Figure 53).
2. Enter the password to unprotect the sheet and click **OK**.
3. Go to **Format > Cells** on the Menu bar, or right-click and select **Format Cells** from the context menu, to open the Format Cells dialog (Figure 52).
4. Click the **Cell Protection** tab and deselect the hide options for the cells. Click **OK**.

**Group and outline**
If you are continually hiding and showing the same cells, you can create an outline of your data and group rows or columns together so that you can collapse a group to hide it or expand a group to show it using a single click.

The basic controls for grouping and outlining show plus (+) or minus (-) signs on the group indicator to show or hide rows or columns. However, if there are groups nested within each other, the basic controls have numbered buttons so you can hide the different levels of nested groups.

**Grouping**
To group rows or columns:
1. Select the cells you want to group in the spreadsheet.
2. Go to **Data > Group and Outline > Group** on the Menu bar, or press the F12 key.
3. In the Group dialog that opens, select either **Rows** or **Columns** and click **OK**. A group indicator appears to the left of any rows grouped or above any columns grouped. Figure 54 shows a group indicator on the left of the first two rows of the spreadsheet have been grouped.

![](Figure_54_Group_Indicator.png)

*Figure 54: Group indicator*
**Hiding details**
To hide the details of any group of rows or columns:

1) Click on the minus (–) sign on the group indicator.
2) Alternatively, select a cell within the group and go to **Data > Group and Outline > Hide Details** on the Menu bar.
3) The rows or columns are hidden and the minus (–) sign becomes a plus (+) sign on the group indicator.

**Showing details**
To show the details of any hidden groups or rows or columns:

1) Click on the plus (+) sign on the group indicator.
2) Alternatively, select a cell on each side of the hidden group and go to **Data > Group and Outline > Show Details** on the Menu bar.
3) The hidden rows or columns are displayed and the plus (+) sign becomes a minus (–) sign on the group indicator.

**Ungrouping**
To ungroup any groups of rows or columns:

1) Make sure the grouped rows or columns are displayed.
2) Go to **Data > Group and Outline > Ungroup** on the Menu bar, or use the keyboard combination `Ctrl+F12`.
3) If only rows or only columns are grouped, they are ungrouped. If both rows and columns are grouped, select either **Rows** or **Columns** to ungroup and click **OK**.

**Note**
Any hidden groups of rows or columns must be displayed. If they are hidden, then the grouped rows or columns are deleted from the spreadsheet.

**Note**
If there are nested groups, only the last group of rows or columns created is ungrouped.

**AutoOutline**
If a selected cell range contains formulas or references, Calc automatically outlines the selection. For example, in Figure 55 the cells for the 1st and 2nd quarters each contain a sum formula for the three cells to their left. If you apply the **AutoOutline** command, the columns are grouped into two quarters.

To apply the AutoOutline function, go to **Data > Group and Outline > AutoOutline** on the Menu bar. Calc will then check for cells that contain formulas or references and automatically group the cells as necessary.

*Figure 55: Example of AutoOutline*
**Removing**

To remove any cell groups of rows or columns, go to **Data > Group and Outline > Remove Outline** on the Menu bar and any groups are removed.

Any cell group of rows or columns that are hidden, the grouping is removed from the cells and the cells are displayed in the spreadsheet.

**Filtering**

A filter is a list of conditions that each entry has to meet to be displayed. Calc provides three types of filter:

- **Standard** – Specifies the logical conditions to filter the data.
- **AutoFilter** – Filters data according to a specific value or string. Automatically filters the selected cell range and creates one-row list boxes where you can choose the items that you want to display.
- **Advanced** – Uses filter criteria from specified cells.

**Applying a standard filter**

A standard filter is more complex than AutoFilter. You can set as many as eight conditions as a filter, combining them with the operators AND or OR. Standard filters are mostly useful for numbers, although a few of the conditional operators can also be used for text.

1) Select a cell range in the spreadsheet.

2) Go to **Data > More Filters > Standard Filter** on the Menu bar to open the Standard Filter dialog (Figure 56).

3) Specify the filter criteria and filtering options that you want to use.

4) Click **OK** to carry out standard filtering and close the dialog. Any records that match the filter criteria and options that you specified are shown.

![Figure 56: Standard Filter dialog](image)

The filter criteria used in standard filtering defines a filter by indicating the type of line, the name of the field, a logical condition and a value or a combination of arguments.

- **Operator** – for the following arguments, you can choose between the logical operators AND / OR.

---

74 | Hiding and showing data
• **Field name** – specifies the field names from the current table to set them in the argument. You will see the column identifiers if no text is available for the field names.

• **Condition** – specifies the comparative operators through which the entries in the Field name and Value fields can be linked.

• **Value** – specifies a value to filter the field. The Value list box contains all possible values for the specified Field name. Select a value to be used in the filter, including Empty and Not Empty entries.

• **Case sensitive** – distinguishes between uppercase and lowercase letters when filtering the data.

• **Range contains column labels** – includes the column labels in the first row of a cell range.

• **Copy results to** – select the check box and then select the cell range where you want to display the filter results. You can also select a named range from the list.

• **Regular expressions** – select to use wildcards in the filter definition. See LibreOffice Help for a list of the regular expressions that LibreOffice supports. If selected, you can use regular expressions in the Value field if the Condition list box is set to ‘=’ EQUAL or ‘<>’ UNEQUAL. This also applies to the respective cells that you reference for an advanced filter.

• **No duplications** – excludes duplicate rows from the list of filtered data.

• **Keep filter criteria** – select Copy results to and then specify the destination range where you want to display the filtered data. If this box is checked, the destination range remains linked to the source range. You must have defined the source range under Data > Define range as a database range. You can also reapply the defined filter at any time by clicking into the source range and then go to Data > Refresh Range.

**Applying an AutoFilter**

An AutoFilter adds a drop-down list to the top row of one or more data columns which lets you select the rows to be displayed. The list includes every unique entry in the selected cells sorted into lexical order (see https://www.dictionary.com/browse/lexical-order for an explanation of lexical order). AutoFilter can be used on multiple sheets without first defining a database range.

1) Click in a cell range on the spreadsheet. If you want to apply multiple AutoFilters to the same sheet, you must first define database ranges, then apply the AutoFilters to the database ranges.

2) Go to Data > AutoFilter on the Menu bar. An arrow button is added to the head of each column in the database range.

3) Click the arrow or small triangle in the column that contains the value or string that you want to set as the filter criteria (shown in Figure 57).

4) Select the value or string that you want to use as the filter criteria. The records that match the filter criteria that you selected are then shown.
Applying an advanced filter

An advanced filter has a structure similar to a standard filter. The difference is that the Advanced Filter arguments are not entered in a dialog. Instead, filters can be entered in a blank area of a spreadsheet, then referenced by the filter dialog to apply the filters.

1) Select a cell range in the spreadsheet.
2) Go to Data > More Filters > Advanced Filter on the Menu bar to open the Advanced Filter dialog (Figure 58).
3) In Read Filter Criteria From, select the named range, or enter the cell range that contains the filter criteria that you want to use.
4) Click OK to carry out advanced filtering and close the dialog. Any records that match the filter criteria and options that you specified are shown.

Note

The options for advanced filtering are the same as those used for standard filtering, see “Applying a standard filter” on page 78 for more information.
Sorting records

Sorting within Calc arranges the cells in a sheet using the sort criteria that you specify. Several criteria can be used and a sort applies each criteria consecutively. Sorts are useful when you are searching for a particular item and become even more useful after you have filtered data.

Also, sorting is useful when you add new information to a spreadsheet. When a spreadsheet is long, it is usually easier to add new information at the bottom of the sheet, rather than adding rows in their correct place. After you have added information, you can then sort the records to update the spreadsheet.

Sort dialog

To sort cells in a spreadsheet using the Sort dialog:

1) Select the cells, rows, or columns to be sorted.
2) Go to Data > Sort on the Menu bar to open the Sort dialog.
3) On the Sort Options page (Figure 60), choose options including whether to sort on rows or columns. See “Sort options” on page 82 for details.
4) On the Sort Criteria page (Figure 59), select the criteria from the drop-down lists. The selection lists are populated from the selected cells.
5) Select either **Ascending** order (A-Z, 1-9) or **Descending** order (Z-A, 9-1).

6) Click **OK** and the sort is carried out on the spreadsheet.

![Sort dialog – Options tab](image)

### Sort options

On the Options page of the Sort dialog (Figure 60), you can set these options:

- **Case sensitive** – sorts first by uppercase letters and then by lowercase letters. For Asian languages, special handling applies.

**Note**

For Asian languages, select **Case Sensitive** to apply multi-level collation. With multi-level collation, entries are first compared in their primitive forms with their cases and diacritics ignored. If they evaluate as the same, their diacritics are taken into account for the second-level comparison. If they still evaluate as the same, their cases, character widths, and Japanese Kana difference are considered for the third-level comparison.

- **Range contains column/row labels** – omits the first column/row in the selection from the sort. The Direction setting at the bottom of the dialog defines the name and function of this check box: if top to bottom, then column labels; if left to right, then row labels.

- **Include formats** – preserves the current cell formatting.

- **Enable natural sort** – natural sorting is a sort algorithm that sorts string-prefixed numbers based on the value of the numerical element in each sorted number, instead of the traditional way of sorting them as ordinary strings. For instance, assume you have a series
of values such as, A1, A2, A3, A4, A5, A6, ..., A19, A20, A21. When you put these values into a range of cells and run the sort, it will become A1, A11, A12, A13, ..., A19, A2, A20, A21, A3, A4, A5, ..., A9. With natural sorting selected, values such as these are sorted correctly.

• **Include boundary columns containing only comments** – keeps these cells associated with the cells being sorted.

• **Include boundary columns containing only images** – keeps these cells associated with the cells being sorted.

• **Copy sort results to** – copies the sorted list to the cell range that you specify. Select a named cell range where you want to display the sorted list, or enter a cell range in the input box.

• **Custom sort order** – select this option and then select the custom sort order that you want to apply. The available selections are defined as “fill series” in Tools > Options > LibreOffice Calc > Sort Lists. See “Defining a fill series” on page 53.

• **Language** – select the language for the sorting rules.

• **Options** – select a sorting option for the language. For example, select the “phonebook” option for German to include the umlaut special character in the sorting.

• **Top to Bottom (sort rows)** – sorts rows by the values in the active columns of the selected range.

• **Left to Right (sort columns)** – sorts columns by the values in the active rows of the selected range.

**Quick sort**

If the columns in the spreadsheet have a header with a text format, you can use a quick sort.

1) Select a cell or a cell range to be sorted.

2) Click the **Sort Ascending** or **Sort Descending** icon on the Standard toolbar.

**Find and replace**

Calc has two ways to find text within a document: the Find toolbar and the Find & Replace dialog. The toolbar is quick and easy to use, but its functions are more limited than using the dialog.

**Find toolbar**

1) Go to View > Toolbars > Find or Edit > Find on the Menu bar, or use the keyboard shortcut Ctrl+F to open the Find toolbar (Figure 61). By default this toolbar is docked in the lower left of the Calc window. You can undock the toolbar and move it.

2) Type a search term in the Find box.

3) To refine the search, you can select the **Match Case** option. For example, if Owner is the search term, selecting **Match Case** will find *Owner* but not *owner*. You can also select the Find All or Formatted Display options.

4) Click the **Find Next** or **Find Previous** icon. To find other occurrences of the same term, continue clicking the icon.
Find & Replace dialog

To open the Find & Replace dialog (Figure 62), go to **Edit > Find & Replace** on the Menu bar, or use the keyboard shortcut **Ctrl+H**, or click the **Find & Replace** icon on the Find toolbar.

![Find & Replace dialog](image)

**Finding**

1) In the Find & Replace dialog (Figure 62), enter the search criteria in the **Find** box.
2) If necessary, click on **Other Options** to increase the number of search filters.
3) Click **Find Next** to locate the first instance of the search criteria.
4) Click **Find Next** again to locate the next instance of the search criteria. Repeat as needed.
5) Or, click **Find All** to locate all cells containing the search criteria. These cells will be highlighted in the spreadsheet. A small dialog will pop up, listing the cell locations.

**Replacing**

1) In the Find & Replace dialog (Figure 62), enter the search criteria in the **Find** box.
2) Enter the replacement contents in the **Replace** box.
3) If necessary, click on **Other Options** to increase the number of search filters.
4) To step through the cells and choose whether to replace the contents:
   a) Click **Find Next** to locate the first instance of the search criteria.
   b) Click **Replace** to replace the search criteria with the contents of the **Replace** box and move to the next instance of the search criteria.
5) Or, to locate and replace the first instance of the search criteria:
   a) Click **Replace**. This does not move to the next instance.
   b) You can now use either **Find Next** or **Replace** to move to the next instance.
6) Or, to locate and replace all instances of the search criteria without stopping at each one, click **Replace All**.
Caution

Use Replace All with caution; otherwise, you may end up with some highly embarrassing mistakes. A mistake with Replace All might require a manual, word-by-word search to fix, if it is not discovered in time to undo it.

Find & Replace options

The options available to refine your find and replace are as follows:

- **Find** – enter the text that you want to search for, or select a previous search from the list.
- **Match case** – distinguishes between uppercase and lowercase characters.
- **Formatted display** – searches for cell contents in a particular format. For example, if a cell has a currency value, say $123.45 and another has the same contents but default formatting (123.45), then searching for “$123.45” will find the currency cell but not the default-formatted cell.
- **Entire cells** – searches for cells with contents that are identical to the search text.
- **All sheets** – Searches through all of the sheets in the current spreadsheet file.
- **Replace** – enter the replacement text, or select a recent replacement text or style from the list.
- **Current selection only** – searches only the selected text or cells.
- **Replace backwards** – search starts at the current cursor position and goes backwards to the beginning of the file.
- **Regular expressions** – select to use wildcards in the search. See LibreOffice Help for more information on the use of regular expressions.
- **Cell Styles** – searches for cell content formatted with the style that you specify. Select this option and then select a style from the Find list. To specify a replacement style, select a style from the Replace list.
- **Similarity search** – find terms that are similar to the Find text. Select this option, and then click the ... button to define the similarity options.
- **Wildcards** – search for a wildcard expression given in the Find text.
- **Diacritic-sensitive** – include diacritics and accents in the search.
- **Direction** – determines the Rows or Columns order for searching the cells.
- **Search in** – select either Formulas, Values, or Notes to search for the characters that you specify in values, in the results of formulas, or in notes.
Chapter 3
Creating Charts and Graphs
Presenting information visually
Introduction

Charts and graphs can be powerful ways to convey information and LibreOffice Calc offers a variety of ways to present data. They can be customized to a considerable extent, enabling information to be shown in the clearest manner.


Chart Wizard

Use Chart Wizard to create an initial chart using data in a spreadsheet. Then use the Chart Wizard options to change the type of chart, adjust data ranges, and edit some chart elements. Each change is immediately seen in the chart.

Overview of Chart Wizard

To demonstrate the process of using Chart Wizard to create charts, the data shown in Figure 63 is used in the following sections. Here is an overview of the basic steps:

7) Select the cells containing all of the data — including names, categories, and labels — to be included in the chart. The selection can be a single block, individual cells, or groups of cells (columns or rows).

Tip

When the data is in one place, the Chart Wizard can guess the range and create an initial chart even if all of the data is not selected. Before opening the Chart Wizard, just place the cursor or select a cell anywhere in the area of the data.

8) Do one of the following. This will cause a chart to be placed on the spreadsheet as an object (Figure 64) and open the Chart Wizard dialog (Figure 66).
   - Go to Insert > Chart on the Menu bar.
   - Click the Chart Type icon on the Standard toolbar.

9) Choose the chart type and make any other selections desired. The options are explained below.

10) Click Finish to save the selections and close the Chart Wizard.
The following sections provide further details about using the Chart Wizard.

Selecting chart type

Calc offers a choice of ten basic chart types. Further options vary according to the type of chart selected. For more information about the different chart types see “Gallery of chart types” on page 143.

To change chart types and options:

1) Select the type of chart from the list under Choose a Chart Type.

2) If needed, select a chart variant in the preview box by clicking on it. The options available depend on the type of chart selected. The chart changes instantly to reflect the selection.

3) To use a 3D chart, select the checkbox 3D Look and select the type of 3D view (Realistic or Simple). This option is available only for Column, Bar, Pie, or Area chart types.

4) Click Next to make changes to Data Range, Data Series, and Chart Elements, explained in greater detail below.

5) When satisfied with the chart, click Finish to close the Chart Wizard.
Note
To recreate the charts shown in the following sections, select the Column chart type, Normal variant, with the 3D Look option unchecked.

Selecting data ranges
The data range contains all of the cells with data (including labels and categories) that should be included in the chart. In the Data Range step of the Chart Wizard (Figure 66), manually correct any mistakes in data selection for the chart.

![Chart Wizard dialog – selecting data range](image)

*Figure 66: Chart wizard dialog – selecting data range*

To use the Data Range page:

1) If necessary, change the rows and columns used as data for the chart by editing the cell references in the Data range text box. Edit the cell references in one of these two ways:
   - Directly modify the text in the Data range text box.
   - Click the Select data range button to the right of the Data range box. Then use the cursor to select the data range(s) on the spreadsheet.

2) Specify whether the data series are arranged in rows or in columns.

3) Select whether to use the first row, or first column, or both, as labels.

4) Click Next > to move to making changes to the data series (Figure 67).

5) When satisfied with the chart, click Finish to close the Chart Wizard.

Note
If the syntax for a data range is not correct, Calc shows the text in red.

Selecting non-adjacent data
To create a complete data range from multiple cells that are not next to each other, use a delimiter between individual ranges. For example, the English (USA) locale uses a comma as a delimiter and "$Sheet1.A1:A5,$Sheet1.D1:D5" is a valid data range. A semi-colon is another commonly used delimiter.

The appropriate delimiter depends on the locale selected at Tools > Options > Language Settings > Languages > Locale setting. See or change the default delimiter for a locale at Tools > Options > LibreOffice Calc > Formula. In the Separators section, Array column shows the default delimiter.

Note
The options under Tools > Options may not be available when the chart is in edit mode. If desired, click outside the chart to leave edit mode and see the options. Click the chart twice to enter edit mode again.
To select non-adjacent data, do one of the following in Step 1 above:

- Manually enter the data ranges in the text box with delimiter(s) between them.
- Select the data with the cursor by first clicking the Select data range button to the right of the Data range box. Place the cursor at the end of the first data range in the text box (otherwise the first range is selected and then deleted) and enter the delimiter. Then drag the cursor in the spreadsheet to select the next data range.

**Note**

When the data is in the same document as the chart, changes to the data are instantly reflected in the chart.

**Linking to external data**

Calc offers several options for linking data to external sources. This enables data (and the chart using the data) to automatically update when the external data changes. The following types of files can be linked: HTML, Calc, Base, CSV, Excel, and registered data sources. For further information, refer to Chapter 10, Linking Calc Data, in this guide.

**Data series**

The Data Series page of the Chart Wizard (Figure 67) enables fine tuning of the data. Each data series contains a set of data that have something in common, such as the types of rental equipment listed in Figure 63. Use the Data Series page to change the source range of each data series and to organize how the data is presented in the chart. This includes removing unnecessary data and specifying how data is plotted along the axes.

**Organizing data series**

**Tip**

The Chart Wizard makes initial assumptions about how the data should be displayed, but the assumptions could be incorrect. If a chart does not look as expected, the first thing to check is if all data series are defined correctly.

Also, check the settings on the Data Range page that define whether the data are in rows or columns and whether the first row or first column should be considered labels.

The names of each data series appear in the Data series list box (the middle box in Figure 67). To organize the data series, select an entry in the Data series list and do one or more of the following:

- To change the name of the data series, select Name in the Data ranges list on the right. Edit the cell references in the Range for name text box that appears.
- To change the cell references for data series categories, edit the cell references in the Categories text box below the Data ranges box.
- Click Add to add another data series below the selected entry. The data ranges for the new data series will then need to be defined.
- Click Remove to remove the selected entry from the Data series list.
- Click the Up or Down button to move the selected entry up or down in the list. This does not change the order in the data source table, but changes only the arrangement in the chart.
Note

Different data series must be in separate columns or rows. Otherwise Calc will assume that they are the same data series.

Setting data series ranges

To understand how Calc treats data in charts, it is important to understand the distinction between values and categories. Values are numeric data that vary continuously. By contrast, categories have no mathematical relationship with each other. For example, the categories for the chart data referred to in Figure 67 and the chart shown in Figure 64 are months of the year.

Most Calc charts require both value and category data, with values plotted along the Y axis and categories plotted along the X axis. The exceptions are XY (scatter) charts and bubble charts, which use only value data along both axes.

Data ranges that may be defined for a specific chart type appear in the Data ranges box on the right side of the Data Series page, shown in Figure 67. Not all data ranges may need to be filled in. The data ranges may include:

Border Color and Fill Color

Border and fill colors for each data point in the data series can be specified here using numeric values for the RGBA color system. If not specified here, Calc will use default colors. Conditional formatting can also be used. This enables data point colors to vary, depending on whether they meet certain conditions or values. For further information, refer to “Assigning colors” on page 110.

Name

When Data series as columns and First row as labels are selected on the Data Range page, Calc assumes that the column labels of the selected data are the data series names. Thus, Calc assumes that the data series names of the data in Figure 63 are “Canoes”, “Boats”, and “Motors”. Similarly, when Data series as rows and First column as labels are selected, Calc assumes that the row labels of the selected data are the data series names.
The only way to change a data series name is by selecting Name in the Data ranges box in the upper right of Figure 67. Then enter a different cell range in the Range for name box that appears below the Data ranges box. (Note that the data series name is often contained in a single cell, rather than a range of cells.)

**Y-Values**
These are numeric values that are often plotted along the vertical axis. However, this is not always the case. For example, while Y-values are plotted on the vertical axis in column charts, they are plotted along the horizontal axis in bar charts.

**Categories**
The range for category data is defined in a separate Categories box below the Data ranges box. Note the difference between categories and data series names. For the data in Figure 63, the categories are the row labels while the data series names are the column labels.

---

**Note**
Category data usually appears along the X axis (except for XY (scatter) and bubble charts, which require value data for the X axis).

Depending on the type of chart, other data ranges may need to be defined in addition to those shown in Figure 67.

**Chart elements**

![Chart Wizard dialog](image)

*Figure 68: Chart Wizard dialog – selecting and changing chart elements*

On the Chart Elements page of the Chart Wizard dialog (Figure 68), add or change the title, subtitle, axes names, and grids. Use titles that draw the attention of viewers to the purpose of the chart and describe what they should focus on.

The chart elements for 2D and 3D charts are illustrated in Figure 69

- The chart wall contains the graphic displaying the data.
- The chart area is the background of the entire chart.
- The chart title and subtitle, chart legend, axes labels and axes names are in the chart area.
- The chart floor is only available for 3D charts.
To add elements to a chart, do one or more of the following on the Chart Elements page (Figure 68):

- Enter a title and subtitle (if desired) in the Title and Subtitle text boxes.
- Enter names to be used in the X- and Y-axis text boxes. The Z-axis text box is only active if creating a 3D chart.
- Select the Display legend checkbox (turned on by default) and choose where to display the legend – Left, Right, Top or Bottom. The names in the legend are the data series names. Specify the names in the Range for name field in the Data Range dialog.
- Under Display grids, select the Y-axis or X-axis check boxes to display horizontal or vertical grid lines. For some charts, the Y-axis grids are displayed by default. Grids are not available for pie charts. The Z-axis checkbox is only active when creating a 3D chart. For further information about grids, refer to Grids on page 123.

### Note

While clicking Finish closes the Chart Wizard, the chart is still in edit mode, indicated by gray borders, and can still be modified. Click outside the chart in any cell to exit the edit mode.

### Sidebar

The Properties deck of the Sidebar (Figure 70) makes some basic options readily available for specifying the appearance of charts. To open the Sidebar, first click outside the chart to deselect it, then go to View > Sidebar on the Menu bar or press Ctrl+F5. By default, the Sidebar opens on the right side of the screen.

### Tip

If you follow the directions above and the Properties deck of the Sidebar does not appear, click the Properties icon on the upper right of the Sidebar. If the Properties deck still does not appear, click the chart again.
The contents of the Sidebar depend on whether the chart is selected or is in edit mode. The Sidebar on the left in Figure 70 shows the Properties deck when a chart is selected (by clicking on it once). When a chart is in edit mode (by clicking on it twice), the Properties deck on the right in Figure 70 appears.

The options available on the Properties deck of the Sidebar are also available elsewhere. They may be found in the Menu bar, the Formatting toolbar, or context menus (made available by right-clicking a chart element).

**Note**

The Sidebar can be quite useful. However, because the options are easy to see and are available elsewhere, further references to it are not included in this chapter.
Modifying charts

The Chart Wizard establishes basic features of a chart. After using it, you may want to change data ranges or modify the look of the chart. Calc provides many options for formatting and fine-tuning the appearance of charts. This includes tools for editing the chart type, chart elements, data ranges, fonts, colors, and many other options.

Modify charts in one of two ways, depending on what you want to change.

Edit object properties
Click a chart once to edit its object properties. These include size, position on the page, alignment, outer borders, copying, exporting, and more. See the sections starting with “Resizing, moving, and positioning charts” on page 136 for more information.

Use edit mode
Use edit mode to change data selection and chart type as well as elements such as axes, titles, backgrounds, grids, data series, data labels, trend lines, and more.

Overview of using edit mode
Here are some general ways to modify charts in edit mode, These are discussed in greater detail in the following sections.

• To add an element not already in the chart, use the Insert menu on the Menu bar. Insert titles, legends, axis labels, grids, data labels, trend lines, mean value lines, and error bars.

• To move or change the size of titles, axis names, chart walls, and legends, click on them once. The cursor changes to a move icon (appearance depends on the system). Drag the element to the new location. To change the size, drag the selection handles.

• Modify elements in a few basic ways. The following methods may open the appropriate dialog or menu. Not all of these methods will work for every element:
  – Double-click the element (see an exception below).
  – Select the element from the Insert menu (Figure 71) or Format menu (Figure 72) on the Menu bar.
  – Click the element once, then click on the Format Selection icon on the Formatting toolbar (Figure 73).
  – Select the element from the Select Chart Element drop-down list, then click the Format Selection icon next to it on the Formatting toolbar.
  – Right-click the element to open the context menu.

• Double-click titles and axis names to change their spelling. To modify the spelling of other text, such as categories, data labels, and legend entries, change the text in the data on the spreadsheet.

• Click once on a data point (such as a column or bar) to select and edit the associated data series.
  – With a data series selected, double-click a single data point to edit its properties (for example, a single column in a column chart).

Note
The next several sections (until “Resizing, moving, and positioning charts” on page 136) require a chart to be in edit mode.
**Entering edit mode**

To edit or format charts, double-click on the chart to place it in edit mode. The chart is now surrounded by a gray border. In edit mode, the Menu bar changes and the Formatting toolbar contains a number of formatting options and icons, as discussed in the following sections.

**Note**

The next several sections (until “Resizing, moving, and positioning charts” on page 136) require a chart to be in edit mode.

**Insert menu**

In edit mode, the **Insert** menu on the Menu bar displays the options shown in Figure 71 and discussed below:

![Insert menu](image)

**Figure 71: Insert menu when chart is in edit mode**

**Titles**

Provides spaces for entering chart title and subtitle as well as titles for X and Y axes, including secondary axes. For more information, see “Titles, subtitles, and axis names” on page 101.

**Legend**

Specifies if a legend should be included and if so, where. For more information, see “Legends” on page 103.

**Axes**

Provides options for showing or not showing axis labels. The chart Wizard automatically shows the labels. For more information, see “Axes” on page 112.

**Grids**

Provides options for showing or not showing major and minor grids for X, Y, and Z axes. To format grids, see “Grids” on page 123.

**Data Labels**

Provides options for text attributes, whether to show categories, and the position and rotation of the labels. These labels appear on each data point. For more information, see “Data labels” on page 119.

**Trend Line**

Specifies the type of regression line to be used, options for extrapolation, where the axes should intersect, the name of the trend line, and whether and how the equation should be displayed. The option is grayed out until a data series is selected. For more information, see “Trend lines” on page 127.
Mean Value Lines
Displays mean value lines for selected or all data series. For more information, see “Mean value lines” on page 131.

X Error Bars and Y Error Bars
Specifies the error category to be used, parameters, and display options for positive and negative indicators.

Format menu
In edit mode, these settings appear on the Format menu (Figure 72) of the Menu bar. Descriptions of the options follow:

Format Selection
Opens a dialog with settings for whatever element is selected. Options may include area fill, borders, positioning, transparency, fonts, labels, scale, and other attributes.

Position and Size
Enables precise specification of the position and size of a selected element. The position is defined in relationship to the chart. See “Position and Size dialog” on page 137 for more information.

Arrangement
Provides two options: Bring Forward and Send Backward. Only one option may be active for some items. Use these options to arrange overlapping data series.

Title
Formats the title and subtitle for the chart as well as axis names. The text must first be entered on the Chart Elements page of the Chart Wizard or by going to Insert > Titles.

Legend
Formats legend appearance and position. The legend must first be turned on by using the Chart Elements page of the Chart Wizard or by going to Insert > Legend.
Axis
Formats properties such as where the axes cross each other, the scale of units, and formatting of the axis labels.

Grid
Formats the grid lines. Use the Chart Elements page of the Chart Wizard to turn on grids or go to Insert > Grids to turn grids on or off.

Chart Wall, Chart Floor, or Chart Area
Formats borders, area, and transparency of these elements. Note that the chart floor is available only for 3D charts. See “Formatting chart backgrounds” on page 104 for more information.

Chart Type
Changes the type of chart and whether it is a 2D or 3D chart. The various chart types are explained in “Gallery of chart types” starting on page 143.

Data Ranges
Sets ranges for all data in the chart and for individual data series, as explained in “Selecting data ranges” on page 90 and “Data series” on page 91.

3D View
Formats 3D charts and is only available for 3D charts. Note that only column, bar, pie, and area charts can be displayed as 3D charts. See “3D charts” on page 124 for information.

Formatting toolbar

![Formatting toolbar when chart is in edit mode](image)

1. Select Chart Element
2. Format Selection
3. Chart Type
4. Chart Area
5. Chart Wall
6. 3D View
7. Data Ranges
8. Data Table
9. Titles
10. Legend On/Off
11. Legend
12. Horizontal Grids
13. Vertical Grids
14. X Axis
15. Y Axis
16. Z Axis
17. All Axes

Figure 73: Formatting toolbar when chart is in edit mode

94 | Modifying charts
In edit mode, the Formatting bar appears as in Figure 73. Click one of the icons to open a dialog or turn an option on or off. The **Insert** and **Format** menus on the Menu bar, described above, contain the same options, with one exception.

The option **Select Chart Element** drop-down list does not appear elsewhere. Use it to easily select individual chart elements. It can be especially helpful when the chart is crowded or it is otherwise difficult to select elements using the cursor. Note that options such as Data Labels or Trend Line do not appear on this list unless they have already been inserted using the Insert menu.

### Note

The next several sections (until “Resizing, moving, and positioning charts” on page 136) require a chart to be in edit mode.

#### Selecting and moving chart elements

**Selecting chart elements**

After double-clicking on the chart to enter edit mode, select chart elements using one of the following methods:

- Click once on the element in the chart (to select individual data points, click twice — but not too quickly — after clicking once on the data series).
- Select the element from the **Select Chart Element** drop-down list that appears on the left of the Formatting toolbar, as shown in Figure 73.

When selected, the chart element will be highlighted with square selection handles.

### Tip

To more easily click on individual elements, consider turning on tooltips in **Tools > Options > LibreOffice > General**. When you hover the cursor over an element, Calc will display the element name, making it easier to select the correct element. The name of the selected element also appears in the Status Bar.

#### Moving chart elements

You may wish to move individual elements of a chart, independent of other chart elements. For example, you may wish to reposition the title or axis names. To do so:

1) Select the element as described above.
2) Keep holding down the mouse button. The cursor changes to the move icon (appearance depends on computer setup).
3) Drag the cursor to move the element.
4) Release the mouse button when the element is in the desired location.

Alternatively, use the Position and Size dialog for some elements, as described on page 137.

Individual points or data series cannot be moved, with the exception of pie charts. Individual wedges of a pie can be moved or the entire pie can be exploded. See “Pie charts” on page 145 for information.

To move axis labels, see “Positioning axis, labels, and interval marks” on page 115. To move data labels, see “Adding and formatting data labels for a data series” on page 119.
Changing chart type

To change the type of chart (bar, column, pie, line, and so on):

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be surrounded by a gray border.

2) Open the Chart Type dialog using one of these methods:
   – Go to Format > Chart Type on the Menu bar.
   – Click the Chart Type icon on the Formatting toolbar.
   – Right-click on the chart and select Chart Type from the context menu.

   The dialog is the same as the first page of the Chart Wizard dialog shown in Figure 66 on page 90.

3) Select the chart type and variant desired.

4) Click OK to close the dialog.

5) If desired, click outside the chart to leave edit mode.

For further information about the types of charts, please refer to the “Gallery of chart types” on page 143.

Titles, subtitles, and axis names

Creating or changing text

To create or change the text of a chart title, subtitle, or axis name:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be surrounded by a gray border.

2) Use one of these methods to open the Titles dialog (Figure 74):
   – Go to Insert > Titles on the Menu bar.
   – Click on the Titles icon on the Formatting toolbar.
   – Right-click in the chart area and select Insert Titles from the context menu.

3) Enter or edit the text in the appropriate text box(es).

4) Click OK to close the dialog.

5) If desired, click outside the chart to leave edit mode.

Tip

The text of a title (but not formatting) can be modified directly. Click on it once in the chart (with the chart in edit mode). Click again inside the selection handles to directly change the text (it may take a few clicks to do this). Use Shift+Enter at the end of the line to create an additional line that splits the text.
Use a more extensive Titles dialog to format the appearance of a chart title, subtitle, or axis name. To access this dialog:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be surrounded by a gray border.

2) Do one of the following to open the Titles dialog for formatting (Figure 75):
   – Click Format > Title and select the desired type of title.
   – Click on the element in the chart, right-click, and select Format Title (or appropriate element) from the context menu.
   – Click on the Titles icon on the Formatting toolbar.
   – Click on the element in the Select Chart Element drop-down list on the Formatting toolbar, then click Format > Format Selection.

3) Format titles or names as needed. The options are self-explanatory or easily researched.

4) Click OK to close the dialog. If desired, click outside the chart to leave edit mode.
Legends

When a legend is displayed, it shows data series names along with their graphical representations, such as bars, lines, or points. It will also show trend lines when those are turned on, as shown in Figure 76.

Figure 76: Example of a chart legend at the bottom of a chart.

Positioning, inserting or deleting legends

Inserting or deleting only

To only insert or delete a legend:

1) Enter edit mode by double-clicking the chart. The chart should now be surrounded by a gray border.
2) Do one of the following:
   – Click on the Legend On/Off icon on the Formatting toolbar. The default position for inserting a legend is on the right side of the chart.
   – Right-click in the chart area and select Insert Legend or Delete Legend from the context menu.
3) Click OK to close the dialog.
4) If desired, click outside the chart to leave edit mode.

Note

The names in the Legend are the data series names. They are taken from the Name data range, discussed in “Data series” on page 91. Change a legend name by changing the text in the spreadsheet.

Positioning, inserting, and deleting

To position a legend using the basic Legend dialog (Figure 77) as well as insert or delete it, follow the same steps as above but do the following instead of Step 2:

1) Go to Insert > Legend on the Menu bar to open the basic Legend dialog.

Figure 77: Basic Legend dialog

2) Select or deselect the Display legend checkbox to either display or not display the legend.
3) Select the desired location for the legends – Left, Right, Top, or Bottom.
Tip

For finer positioning of the Legend, use one of the methods described in “Moving chart elements” on page 100.

Formatting legends

For advanced editing of a legend’s appearance, a more extensive Legend dialog (Figure 78) has several options for formatting borders, fill, fonts, transparency, and position.

1) Enter edit mode by double-clicking the chart. The chart should now be surrounded by a gray border.
2) Do one of the following to open the Legend dialog (Figure 78):
   - Click on the Legend icon on the Formatting toolbar.
   - Click on the legend in the chart to select it, then right-click and select Format Legend from the context menu.
   - Click on Legend in the Select Chart Element drop-down list on the Formatting toolbar then click on the Format Selection icon next to the drop-down list.

![Legend dialog with more extensive options](image)

3) Make any desired changes. The options are self-explanatory or easily researched.
4) Click OK to close the dialog.
5) If desired, click outside the chart to leave edit mode.

Formatting chart backgrounds

The background of a chart is divided into chart area, chart wall, and chart floor, as shown in Figure 69 on page 94. Border, area, and transparency options for these areas are set in the following way:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be surrounded by a gray border.
2) Do one of the following to open the appropriate dialog (such as Figure 79):
   - Go to Format on the Menu bar and select Chart Area, Chart Wall, or Chart Floor.
– Right-click the chart wall, chart floor, or chart area in the chart and select **Format Wall**, **Format Floor**, or **Format Chart Area** from the context menu. (For help with selecting these areas, see “Selecting chart elements” on page 100.)

– In the Formatting toolbar, click on the icon for chart area or chart wall (there is no icon for chart floor).

– Click on **Chart Area**, **Chart Wall**, or **Chart Floor** in the *Select Chart Element* drop-down list on the Formatting toolbar.

![Figure 79: Chart Area dialog – Transparency page](image)

3) Select the desired settings from the Borders, Area, and Transparency pages.
4) Click **OK** to save the changes and close the dialog.

### Data series

The goal of making a chart is to clearly present one or more data series and Calc provides a number of ways to define and present those data. The following sections discuss topics such as defining and changing data ranges, aligning data to a secondary Y axis, and formatting the appearance of the data series.

#### Changing data ranges

When data ranges change in the spreadsheet, modify the chart settings to reflect those changes. Use one of the following methods.

**Note**

The chart automatically reflects changes in the spreadsheet data. Thus, changing a number from 5 to 50 in the data will instantly show the new number in the chart.

**Replacing data by dragging**

It is easy to manually replace one set of data with another set of data. Do this in the following way:

1) Use the mouse to select all of the new data.
2) Drag the data over the chart, then release the mouse. This opens the dialog shown in Figure 80.
3) Specify whether or not the first column or row contains labels, then click **OK**.

---

100 | Formatting chart backgrounds
Modifying the data range
To change the range of a data series, do the following:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be surrounded by a gray border.

2) Open the Data Ranges dialog using one of these methods:
   − Go to Format > Data Ranges on the Menu bar.
   − Click on the Data Ranges icon on the Formatting toolbar.
   − Right-click on the chart and select Data Ranges from the context menu.

3) Edit data ranges on the Data Series page, which is the same as shown in Figure 67 on page 92.

4) Click OK to save changes and close the dialog.

5) If desired, click outside the chart to leave edit mode.

Tip

If Calc is taking a significant amount of time to process a large amount of data for a chart, try this: Select only limited data for each data series to initially organize the chart. Adjust the settings until the chart looks as desired, then select all of the data.

For further information, see “Selecting data ranges” on page 90.

Opening data series dialog
The Data Series dialog offers several options for presenting data in the chart. Note that only one data series can be selected at a time.

To open the Data Series dialog (Figure 81):

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be surrounded by a gray border.

2) Do one of the following to select the data series:
   − Click on the data series in the chart.
   − Click the data series name in the Select Chart Elements drop-down list on the Formatting toolbar.

3) Do one of the following to open the Data Series dialog:
   − Go to Format > Format Selection on the Menu bar.
   − Click on the Format Selection icon on the Formatting toolbar.
   − Right-click on the data series and select Format Data Series.
4) Click the tab of the appropriate page to make the changes needed. The options for each page are explained below.

5) Click **OK** to save changes and close the dialog.

![Data Series dialog – Options page](image)

**Note**

The options that appear on the Options page of the Data Series dialog depend on the type of chart selected.

### Alignment, spacing, and plot options

**Aligning data to secondary Y axis**

![Data series aligned to a secondary Y axis](image)
A secondary axis may be helpful when data differ in units or scale, as in Figure 82. In this case, there are significantly more numbers of one data series (kayaks). To plot all three data series on the same chart, the kayak data series is aligned to a secondary Y axis, which has a wider scale. The color of the secondary Y axis and the axis titles help to show this relationship.

**Note**

A data series can be associated with a secondary Y axis only after Chart Wizard has finished creating the chart.

To align a data series to a secondary Y axis:

1) Select the data series and open the Data Series dialog as described in the previous section.
2) On the Options page, under Align Data Series to, select **Secondary Y axis**.
3) Click OK to close the dialog.
4) If desired, click outside the chart to leave edit mode.

Data can only be aligned to a secondary Y axis, not a secondary X axis. However, it is possible to create secondary X and Y axes that duplicate the primary axes on the opposite sides of a chart. This is described in “Add or remove axis labels” on page 112. It is also possible to show different units or scales on the secondary axis (with or without aligning data to it), as described under “Defining Scales” on page 114.

**Spacing and plot options**

The Options page of the Data Series dialog (Figure 81) contains additional settings that depend on the type of chart. These include:

**Spacing**

Sets the spacing interval of columns or bars between category settings, such as time. Values above 100% increase the spacing while values below 100% decrease the spacing. Maximum spacing is 600%.

**Overlap**

Sets overlap of columns or bars within the same category setting, such as a specific time. The higher the percentage, the greater the overlap. Negative percentages increase the separation.

**Show bars side by side**

When checked, shows no gap in columns or bars in the interval between categories. When this option is not checked, data aligned to a secondary Y axis may hide other data. Enable the option to prevent this.

**Plot missing values**

Specifies handling of missing values, with options depending on the type of chart.

**Include values from hidden cells**

Enables data from hidden cells to be included or not included.

Two additional options (not shown in Figure 81) appear for pie or donut charts:

**Orientation**

Specifies the order of the pie sections (data points) – clockwise or counter-clockwise. The default direction is counterclockwise.

**Starting Angle**

Specifies the starting angle of the first pie section (data point). Drag the small dot around the circle or enter a number for the degrees. Use 0 degrees to start the first section at the 3 o’clock position and 90 degrees to start the first section at 12 o’clock.
Area, transparency, and borders

For chart types other than line and scatter, the Data Series dialog (Figure 83) contains pages for formatting the fill and borders of graphical representations such as columns and bars. The Area tab offers options for selecting color by clicking directly on a color in a palette, adding a custom palette, or by specifying the RGB or Hex color codes. Other pages contain options for gradient, bitmap, pattern, hatch, transparency, and borders. The options are self-explanatory or can be readily researched.

Tip

If applying a gradient does not work as expected, do this: After selecting the desired options on the Gradient page, click **Add**, provide a name for the gradient (or accept the default), and click **OK**.

Lines, areas, and data point icons

For line and XY or scatter charts, the Data Series dialog contains only an Options page and a Line page (Figure 84).

Specify line style, color, width, and transparency of the line on the left side of the Line page. In the Icon section, select an option for the symbol from the drop-down list: No symbol, Automatic, From file, Gallery, or Symbols.

- **From file** opens a browser for selecting the file that contains the desired symbol.
- **Gallery** opens a list of available graphics that can be selected.
- **Symbols** opens a list showing available symbols that can be selected.
Assigning colors

Colors for the display of data series can be specified in three ways: changing the default color scheme, using the data series dialog, or using data ranges to set colors for border and fill.

Changing default color scheme
To modify the default color scheme for data series, go to Tools > Options > Charts > Default Colors to specify colors for up to 12 data series. Changes made here affect the default colors for any future chart.

Using Data Series dialog
As discussed in the previous section, the Data Series dialog has options for assigning colors for lines, areas, and borders. Available options depend on the type of chart.

Using data ranges to assign colors
Use the COLOR function in the Function Wizard (described in Chapter 7, Using Formulas and Functions) to specify colors with numbers based on combined RGB values. Then assign the numbers to data ranges for border and fill colors in the Data series page of the Chart Wizard (see “Data series” on page 91) or in the Data series page of the Data Range dialog (see “Changing data ranges” on page 105).

For example, using the COLOR function in the Function Wizard, enter 255 for R (red), 0 for G (green), and 255 for B (blue). The COLOR function calculates a combined RGB value of 16711935. Then, when defining data ranges, enter the RGB value(s) in the cell range for border or fill color. Optionally, include a value for the alpha channel (A) in the Color function. The value of A can range from 0 (fully transparent) to 255 (fully opaque).

Note

Data ranges for border color and fill can only be specified for column, bar, pie, bubble, and column and line charts.
In addition to directly assigning colors, use conditional formatting to define criteria for when specific colors will be used. (Conditional formatting is described in Chapter 2, Entering, Editing, and Formatting Data.)

Figure 85 shows an example of using conditional formatting to specify colors. The COLOR function in the Formula Wizard was used to create the conditional formula

\[ =\text{IF}(B2>100,\text{COLOR}(240,240,0,20),\text{COLOR}(150,0,150,20)) \]

This formula says that when the value in column B is over 100, the first RGB setting is used to color that data point in the chart. When the value in column B is 100 or less, the default color (150, 0, 150) is used. This formula is in all cells of column C. The numbers appearing in column C are the RGB values calculated using the conditional formula (with cell references changed accordingly).

The chart on the right in Figure 85 shows how the colors change to reflect the conditional formatting.

**Formatting Data Points**

Modify the appearance of an individual data point such as a column or bar using the Data Point dialog. For most chart types, the dialog contains the same Area, Transparency, and Border pages as the Data Series dialog shown in Figure 83 on page 109. For line and scatter charts, the dialog contains the same options as Figure 84 on page 110.

To format data points:

1) Enter edit mode by double-clicking the chart. The chart should now be surrounded by a gray border.

2) Click two times (but not too quickly) on the data point to be formatted. The data point will show square selection handles.

3) To open the Data point dialog, do one of the following:
   - Go to **Format > Format selection**.
   - Right-click on the data point and select **Format data point** on the context menu.
   - Click the **Format selection** icon on the Formatting toolbar.

4) Apply formatting options as desired.

5) Click **OK** to close the dialog.

6) If desired, click outside the chart to leave edit mode.
Figure 86: Tooltip showing information about a data point

**Tip**

As shown in Figure 86, hover the cursor over a data point to show the number of the data point, the number of the series, and the X and Y values of the data point.

**Axes**

**Add or remove axis labels**

Use the basic Axes dialog shown in Figure 87 to add or remove axis labels, such as numbers or categories. (To change the name of an axis, see “Titles, subtitles, and axis names” on page 101).

![Axes dialog – basic version](image)

Figure 87: Axes dialog – basic version

To use the basic Axes dialog:

1) Enter edit mode by double-clicking the chart. The chart should now be surrounded by a gray border.

2) Open the basic Axes dialog by doing one of the following:
   – Go to **Insert > Axes** on the Menu bar.
   – Right-click on the chart and select **Insert/Delete Axes** from the context menu.

3) Select or deselect the check boxes for axis labels. The Z-axis checkbox is only active when a 3D chart has been created.

4) Click **OK** to close the dialog.

5) If desired, click outside the chart to leave edit mode.
Selecting a secondary X axis or a secondary Y axis in this dialog creates duplicate labels on the opposite side of the chart, as shown in Figure 88. To specify different units or intervals for the secondary axis, use the Scale page of the more extensive Axis dialog described in the following section.

It is also possible to align one or more data series to the secondary Y axis. Do this using the Data Series dialog, described in “Aligning data to secondary Y axis” on page 107.

**Edit and format axes**

In addition to the simple dialog above, a more extensive axis dialog contains options for grid intervals, positioning the axis, formatting the axis line and axis labels, and defining the scale, among other settings. Use a dialog for a specific axis, or use a dialog that applies to all axes. The options in the dialog depend on which axis was selected, type of chart, and whether the chart is 2D or 3D.

To open the more extensive axis dialog:

1) Enter edit mode by double-clicking the chart. The chart should now be surrounded by a gray border.

2) Open a specific axis dialog (Figure 89) by doing one of the following (some options do not allow choosing all axes):
   – Go to Format > Axis on the Menu bar and select the desired axis (X, Y, Z, or All).
   – Right-click on the desired axis in the chart to open the context menu. Then select Format axis.
   – Select the axis in the Select Chart Element drop-down list on the Formatting toolbar.
   – Click on the icon for X axis, Y axis, or Z axis on the Formatting toolbar. Or click on All Axes to the right of the icons.

3) Click the tab of the appropriate page to make the changes needed. The options for each page are explained below.

4) Click OK to save changes and close the dialog.

5) If desired, click outside the chart to leave edit mode.

![Figure 88: Both secondary axes enabled.](image)
Defining Scales

Use the Scale page to modify the automatically generated scale for a primary axis. In addition, use the Scale pages for secondary axes to specify scales that are different from the scales for primary axes. This can be quite useful for showing Celsius and Fahrenheit scales on the same chart, for example, or for when data are aligned to a secondary Y axis (see “Aligning data to secondary Y axis” on page 107).

The contents of the Scale page (Figure 89) vary but may contain the following options:

**Reverse direction**
Defines the order of lower and higher values along the axis. When not selected, the X axis shows the lower values on the left and the Y axis shows the lower values at the bottom. When selected, the orientation of the data display is reversed, as in Figure 90.

![Figure 90: Result when direction is reversed on the Y axis](image)

**Logarithmic scale**
Specifies that the axis is to be subdivided logarithmically. Logarithmic scaling makes the grid lines of the axis equidistant from each other, but the values between the lines are not equal. Use this option when working with values that differ sharply from each other.

**Minimum/Maximum**
Sets the first/last value for the axis. Automatic must be deselected to set this option manually.

**Major interval**
Defines the intervals between major divisions of the axis. These intervals will be used for interval marks (specified on the Position page of the Axis dialog) and gridlines. Automatic must be deselected to set this option manually.
Minor interval count
Defines the number of intervals (not the values between intervals) that subdivide the major
intervals. The same as for major intervals, the interval count defined here will be used for
interval marks (specified on the Position page of the Axis dialog) and gridlines. Automatic
must be deselected to set this option manually.

For some types of charts, additional options may be available:

Type
Specifies whether the labels are text, date, or should be detected automatically.

Resolution
For dates, specifies that the interval steps should be days, months, or years.

Tip
If the X axis is not displaying time as expected, manually entering the minimum and
maximum times on the Scale page may solve the problem.

Positioning axis, labels, and interval marks
The Positioning page (Figure 91) controls the position of axis labels and interval marks.

![Figure 91: Axis dialog – Positioning page](image)

Axis line
Sets where the axis crosses the other axis, as shown in Figure 92. The options on the drop-
down list are **Start**, **End**, or a specific value or category.

![Figure 92: Y axis set to cross X axis at specified value](image)

Labels
Sets where axis labels are placed, using the drop-down list. The **Outside end** and **Outside
start** options are useful for positioning labels on axes with negative numbers, as shown in
Figure 93.
Figure 93: Axis label positions

- **Major/Minor** – specifies whether interval marks are displayed for major/minor intervals. These intervals are defined on the Scale page, described above.

- **Inner/Outer** – specifies whether interval marks are placed on the inner or outer side of the axis. The interval marks in Figure 93 are on both sides.

- **Place marks** – specifies where to place the marks: At labels, At axis, or At axis and labels. (The top two charts in Figure 93 show the labels along the axes. The marks are thus both at axis and labels. The marks in the bottom two charts are located at the labels.)

**Line page**

The Line page has options for formatting the axis line style, color, width, and transparency. It has the same contents as the Chart Area dialog shown in Figure 81 on page 107.

**Label page**

On the Label page (Figure 94), choose whether to show or hide the labels and specify how to handle them when they do not fit neatly in the chart. The options are described below.
Show labels
Sets whether to show or hide the axis labels.

Order
Defines the horizontal or vertical alignment of the labels on the X or Y axis. These options are available only for 2D charts.
- **Tile** – arranges labels on the axis side by side.
- **Stagger odd** – stagers labels on the axis, with even numbers lower than odd numbers (even numbers to the left on vertical axis).
- **Stagger even** – stagers labels, with odd numbers lower than even numbers (odd numbers to the left on vertical axis).
- **Automatic** – automatically arranges labels on the axis.

**Note**
Problems may arise in displaying labels if the chart is too small. Avoid this by either enlarging the chart or decreasing the font size.

Text flow
Determines how text flows in axis labels.
- **Overlap** – allows axis labels to overlap.
- **Break** – allows text breaks, enabling text to wrap into new lines in the available space.

Text Orientation
Defines the direction and orientation of label text.

Vertically stacked
Stacks characters vertically so that text is read from top to bottom.

ABCD wheel
Defines text orientation by clicking and dragging the indicator on the wheel. Orientation of the characters "ABCD" on the wheel corresponds to the new setting.

Degrees
Shows the orientation angle of the text as determined by the ABCD wheel or by manually entering the degrees in the spin box.

Text direction
Specifies the direction for any text that uses complex text layout (CTL). CTL is only available if enhanced language support is enabled in **Tools > Options > Language Settings > Languages**. Under Enhanced Language Support, check Ignore system input language.

Numbers
Use the Numbers page (Figure 95) to set the attributes for any numbers used on the axis. When Source format is selected (as it is by default), numbers are formatted exactly as as they are formatted on the spreadsheet. Deselect this option to change number formatting. For information about formatting numbers, see Chapter 2, Entering, Editing, and Formatting Data, in this guide as well as the online Help.
Font and font effects

Use the Font and Font Effects pages to set the font and font effects for the axis labels. These pages are the same as the pages for specifying fonts and font effects in cells. See Chapter 2, Entering, Editing, and Formatting Data for more information.

Asian typography

Sets the Asian typographic options for axis labels. It is only available if enhanced language support is enabled in Tools > Options > Language Settings > Languages. Under Enhanced Language Support, check Ignore system input language. Options on this page include:

- **Apply list of forbidden characters to the beginning and end of line**
  Prevents the characters in the list from starting or ending a line. The characters are relocated to either the previous or the next line. To edit the list of restricted characters, go to Tools > Options > Language Settings > Asian Layout.

- **Allow hanging punctuation**
  Prevents commas and periods from breaking a line. Instead, these characters are added to the end of the line, even in the page margin.

- **Apply spacing between Asian, Latin and Complex text**
  Inserts a space between Asian, Latin, and complex characters.

Hierarchical axis labels

Multiple levels of categories can be displayed in a hierarchical manner along the axis of a chart. Hierarchical axes labels are created automatically if the first column or row defined as data is text (as opposed to the first column or row defined as labels). An example of hierarchical labels is shown in Figure 96. In this case, Calc automatically defines the data range for categories as the first two columns in the spreadsheet. This is reflected in the chart, which shows the hierarchical relationship between quarters and months.
Data labels display information next to data points on the chart. They can be quite useful for highlighting specific data when presenting detailed information, but be careful not to create a chart that is too cluttered to read easily.

**Adding and formatting data labels for a data series**

To add or format data labels for a data series:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be surrounded by a gray border.

2) Do one of the following to select a specific data series:
   - Click once somewhere in the data series.
   - In the *Select Chart Element* drop-down list of the Formatting toolbar, select the data series name.

3) To open the Data Labels dialog (Figure 97), do one of the following:
   - Go to *Insert > Data Labels* on the Formatting toolbar.
   - Right-click on the selected data series in the chart and select *Format Data Labels* from the context menu.
   - Go to *Format > Format Selection*.
   - Click on the *Format Selection* icon on the Formatting toolbar.

4) Select the options as desired. The options are explained below.

5) Click **OK** to close the dialog.

6) If desired, click outside the chart to leave edit mode.

Alternatively, in place of steps 2 and 3 above, right-click on the desired data series and select **Insert Data Labels** from the context menu. This method uses default settings for the data labels.
Tip

Select a data series by clicking once on a column, bar, or other graphic representation of the data series. Select a single data point by pausing, then clicking again.

Most of the pages in the Data Labels dialog are used in other dialogs and can be readily understood or easily researched. The exception is the Data Labels page (Figure 97), which contains the following options:

![Figure 97: Data Labels page of the Data Labels dialog]

**Show value as number**
Displays the numeric value of a data point. When selected, this option activates the **Number format** button.

**Number format**
Opens the Number Format dialog, which is the same as the Numbers page of the Format Cells dialog discussed in Chapter 2, Entering, Editing, and Formatting Data. Deselect **Source format** to activate options on this page.

**Show value as percentage**
Displays the percentage value of the data points in each data series. When selected, this option activates the **Percentage format** button. Note that the percentage referred to is a data point's Y value as a percent of total Y values for a specific X category or value. Thus, in Figure 98, the February canoe value 9 is 10% of the total February value of 94 (the sum of 9, 31, and 54).

**Percentage format**
Opens the Number Format for Percentage Value dialog. Deselect **Source format** to activate options on this page.
Show category
Displays the category next to each data point. This option is activated for all data labels in Figure 98. Thus, all data labels show the month. The text for data labels comes from the category data series and cannot be changed in the chart. It can only be changed in the spreadsheet data.

Show legend key
Displays the legend icon for the data series next to each data point. Figure 98 shows the legend keys for motors and boats, but not for canoes.

Auto text wrap
Wraps data label text if needed.

Separator
Selects what will be used to separate multiple text strings when at least two options above are selected. In Figure 98, the separator is Semi-Colon for the canoes data labels, New line for the motors data labels, and Comma for the boats data labels (with the exception of the June label, which was modified for better fit).

Placement
Specifies the placement of data labels relative to the data point representation. In Figure 98, the placement of data labels is Below for canoes, Above for boats, and Right for motors.

Rotate Text
Sets the text orientation of data labels by using the dial or entering the rotation angle.

Text Direction
Specifies the text direction when Complex Text Layout (CTL) is enabled. (CTL is needed when the shape or position of characters depends on the context, such as in Arabic script).

Data labels for individual data points
Sometimes it is appropriate to apply data labels to one or a few data points rather than all data points. This reduces clutter and highlights the most important data.

Adding a single data label
Insert a data label for a single data point in the following way:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be surrounded by a gray border.

2) Click the data point once, pause, then click again to select it. (Clicking too quickly opens the Data Series dialog.)
3) Right-click on the selected data point and select **Insert Single Data Label** from the context menu. The data label will have the default settings.

4) Click **OK** to close the dialog.

5) If desired, click outside the chart to leave edit mode.

**Formatting a single data point**

To format an existing label for a single data point, follow the directions above but instead of Step 3, do one of the following to open the Data Label dialog (Figure 97):

- Right-click on the data point and select **Format Single Data Label** from the context menu.
- Go to **Format > Format selection**.
- Click on the **Format Selection** icon in the Formatting toolbar.

The options in the Data Label dialog are described above.

**Removing data labels**

Remove labels from a single data point, a single data series, or all data points using one of the methods below.

Before doing any of the following, first select the chart by double-clicking on it to enter edit mode. The chart should now be surrounded by a gray border. When finished, click **OK** to close the dialog and remove the data labels. Then if desired, click outside the chart to leave edit mode.

**Removing all data labels from a single data series**

**Method One**

Right-click somewhere in the data series and select **Delete data labels** from the context menu.

**Method Two**

1) Click somewhere in the data series to select it.

2) Do one of the following to open the Data Labels dialog (Figure 97):
   - Go to **Insert > Data Labels** on the Menu bar.
   - Click the **Format Selection** icon in the Formatting toolbar.
   - Right-click in the data series and select **Format Data Labels** from the context menu.

3) On the Data Labels page, deselect all of the options.

**Removing a data label from a single data point**

1) Click once on the data point, pause, then click again to select it.

2) Right-click to open the context menu and select **Delete Single Data Label**.

**Removing all data labels**

1) Make sure that no data label or data series is selected.

2) Go to **Insert > Data Labels** on the Menu bar.

3) On the Data Labels page, deselect all of the options for the data labels to be removed, then click **OK**.
Grids

Grid lines or grids divide the intervals along axes to help estimate data point values. Major and minor grid lines are shown in Figure 99. The darker lines with numbers are major grid lines while the lighter lines between them are minor grid lines. Note that the Y-axis major grid line is activated by default.

Figure 99: Major and minor gridlines for the X and Y axes

Grids are available for all chart types with the exception of pie charts.

Adding/removing grid lines

1) First select the chart by double-clicking on it to enter edit mode. The chart should now be surrounded by a gray border.

2) Do one of the following:
   - Go to Insert > Grids on the Menu bar to open the basic Grids dialog (Figure 100). Select/deselect the check boxes as needed. The Z-axis checkbox is only active if creating a 3D chart.
   - Click the icon for Y-axis grids or X-axis grids, both located on the Formatting toolbar. Clicking once turns on the major grid lines. Clicking twice turns on the minor grid lines as well. Clicking again turns off the grids.

Figure 100: Basic grids dialog

3) Click OK to close the dialog. If desired, click outside the chart to leave edit mode.

Note

In the Formatting toolbar, the Horizontal Grids icon and the Vertical Grids icon set grid lines for the Y axis and X axis, respectively. This can be misleading because both the Y axis and the X axis can be horizontal or vertical, depending on the type of chart. Thus, for a bar chart, click the Horizontal Grids icon to control the vertical grids.

Formatting grids

In addition to the basic grid dialog shown in Figure 100, there is another dialog for formatting grids. To open the grid formatting dialog:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be surrounded by a gray border.
2) Go to Format > Grid on the Menu bar and click on the appropriate type of grid to open the Grid formatting dialog (Figure 101).

![Figure 101: Grid formatting dialog]

3) Set formatting options for line style, color, width and transparency.
4) Click OK to close the dialog. If desired, click outside the chart to leave edit mode.

---

**Note**

Use the Scale tab of the Axis dialog to specify the intervals between grid lines. This is described in “Defining Scales” on page 114.

---

### 3D charts

#### Setting 3D look

Column, bar, pie, and area charts can be displayed as 3D charts. The setting to make a chart 3D is on the first page of the Chart Wizard. If the chart has already been created, do the following to give it a 3D look:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be surrounded by a gray border.

2) Do one of the following:
   - Go to Format > Chart Type.
   - Click on the Chart Type icon in the Formatting toolbar.

3) Select 3D Look in the Chart Type dialog.

4) Click OK to close the dialog. If desired, click outside the chart to leave edit mode.

To make changes to a 3D chart, use the 3D View dialog (Figure 102).
Formatting 3D view

Use the 3D View dialog to change the 3D appearance, including perspective, formatting scheme, and illumination. Note that the chart must already be set to show a 3D look, as described above. To open the 3D View dialog:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be surrounded by a gray border.

2) Do one of the following:
   – Right-click on the chart and select 3D View from the context menu.
   – Go to Format > 3D View.
   – Click on the 3D View icon in the Formatting toolbar.

3) Click OK to close the dialog. If desired, click outside the chart to leave edit mode.

This dialog has three pages, which are explained below.

### Rotation and perspective

Some hints for using the Perspective page (Figure 102) to rotate a 3D chart or change its perspective view:

- Set all angles to 0 for a front view of the chart. Pie charts and donut charts are shown as circles.
- With Right-angled axes enabled, the chart can be rotated only in the X and Y direction; that is, parallel to the chart borders.
- An X value of 90, with Y and Z set to 0, provides a view from the top of the chart. With X set to –90, the view is from the bottom of the chart.
- Rotation is applied in the following order: X axis first, then Y axis, and Z axis last.
- When shading is enabled and the chart is rotated, the lights are rotated as if they are fixed to the chart.
- The rotation axes always relate to the page, not to the axes of the chart. This is different from some other chart programs.
- Select the Perspective option to view the chart in central perspective as through a camera lens (as opposed to using a parallel projection). Set the focal length with the spin box or type a number in the box. With a 100% setting, a far edge in the chart looks approximately half as big as a near edge.
**Rotating 3D charts interactively**

In addition to using the Perspective page of the 3D View dialog to rotate 3D charts, rotate 3D charts interactively in the following way:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be surrounded by a gray border.
2) Click once on the chart wall to select it, causing round selection handles to appear. The cursor changes to a rotation icon.
3) Press and hold the left mouse button while dragging in the direction desired. A dashed outline of the chart is visible to help see how the result will look.
4) Release the mouse button when satisfied.
5) Click outside the chart to exit edit mode.

**Appearance**

Use the Appearance page of the 3D View dialog (Figure 103) to modify some aspects of the appearance of the data in a 3D chart.

![3D View dialog – Appearance page](image)

First select a scheme from the Scheme drop-down list – Realistic (default) or Simple. The scheme selected sets the options and light sources. Depending on the scheme selected, not all options may be available. To create a custom scheme, select or deselect a combination of Shading, Object borders, and Rounded edges.

Some hints:

- Select **Shading** to use the Gouraud method for rendering the surface. Otherwise, a flat method is used. The flat method sets a single color and brightness for each polygon. The edges are visible but soft gradients and spotlights are not possible. The Gouraud method applies gradients for a smoother, more realistic look. See the *Draw Guide* for more information on the use of shading.
- Select **Object borders** to draw lines along the edges.
- Select **Rounded edges** to smooth the edges of boxy shapes.

**Illumination**

Use the Illumination page (Figure 104) of the 3D View dialog to control light sources for the 3D view.
Here are the options with some hints:

- Click any of the eight buttons to switch a directed light source on or off.
- The first light source projects a specular light with highlights.
- By default, the second light source is switched on. It is the first of seven normal, uniform light sources.
- For the selected light source, select a color from the first drop-down list below the eight light source buttons. Note that the brightness values of all lights are added together, so use dark colors when enabling multiple lights.
- The small preview in the dialog shows the effect of repositioning the light source.
- Each selected light source appears as a small colored sphere in the specified color. The sphere is larger when the light source is actively selected.
- Each light source always points at the middle of the object initially. Move the vertical slider to adjust the lighting angle. The horizontal slider rotates the light around the object. In addition, click the light source and drag it to the desired location.
- Click the button in the bottom right corner of the preview to switch the internal illumination model between a sphere and a cuboid.
- Use the Ambient light drop-down list to define the ambient light, which shines with a uniform intensity from all directions.

See the Draw Guide for more information on setting the illumination.

**Trend lines**

Trend lines help show the relationships among scattered data points of a data series. Calc has a good selection of regression types for creating trend lines: linear, logarithmic, exponential, power, polynomial, and moving average. Choose the type that comes closest to passing through all of the points in a data series.

Trend lines can be added to all 2D chart types except for pie, net, and stock charts. When inserted in the chart, representations of the trend lines are automatically shown in the chart legend.
Note

For chart types that use categories for the X axis, such as column, bar, or line charts, the numbers 1, 2, 3... are used as values for calculating trend lines. By contrast, XY (scatter) chart types (which include bubble charts) show data rather than categories along the X axis. Thus, only XY chart types can show meaningful regression equations.

Adding and modifying trend lines

Trend lines can only be added to one data series at a time. To add a trend line to a data series:

1) Double-click on the chart to enter edit mode. The chart should now be surrounded by a gray border.

2) Select the data series by doing one of the following:
   - Click once on a data series representation such as a bar, column, line, or point.
   - Select the data series from the Select Chart Element drop-down list on the Formatting toolbar.

3) Do one of the following to open the Trend Lines dialog (Figure 105):
   - Go to Insert > Trend Lines on the Menu bar.
   - Click the Format Selection icon.
   - Go to Format > Format Selection.
   - Right-click on the data series and select Insert Trend Line from the context menu.

4) Select the type of regression and choose desired options. These are explained below.

5) Click OK to close the dialog and place the trend line in the chart.

6) If desired, click outside the chart to leave edit mode.

Regression types

By default, x is used for the abscissa variable and f(x) for the ordinate variable. Change the names under X Variable Name and Y Variable Name on the Trend Line dialog.

Linear trend line
Regression through equation y = a \cdot x + b. Intercept b can be forced and only positive x values are considered.

Polynomial trend line
Regression through equation y = \sum_i (a_i \cdot x^i). Intercept a can be forced. Degree of polynomial must be given (at least 2).

Logarithmic trend line
Regression through equation y = a \cdot \ln(x) + b. Only positive x values are used.

Exponential trend line
Regression through equation y = b \cdot \exp(a \cdot x). This equation is equivalent to y = b \cdot m^x, with m = \exp(a). Intercept b can be forced. Only positive y values are considered, except if all y values are negative. In that case, the equation used is y = -b \cdot \exp(a \cdot x).

Power trend line
Regression through equation y = b \cdot x^a. Only positive y values are considered, except if all y values are negative. In that case, the equation used is y = -b \cdot x^a.

Moving average trend line
Simple moving average for n previous y-values, with n being the period. No equation is available for this trend line.
Figure 105: Trend Line dialog – Type page

**Trend line options**

**Trend line Name**

Specifies the name to be used for labeling the equation in the legend; see Figure 106.

**Extrapolate Forward/Backward**

Specifies the number of units the trend line should be extended forward or back. This only works for charts that have numeric values along the X axis rather than categories.

![Trend lines showing various equations](image)

*Figure 106: Trend lines showing various equations*
Force Intercept
Forces the line to cross the Y axis at the specified value.

Show Equation
Displays the equation in the chart, as shown in Figure 106.

Show Coefficient of Determination (R²)
Displays the coefficient of determination in the chart. Shown with the polynomial equation in Figure 106.

X and Y Variable Names
Enables changing the names of X or Y variables for displaying the equation in the chart. The Show Equation option must be checked for these options to be active.

Select a trend line to display information about it in the Status bar, as shown in Figure 107. The Status bar is normally located at the bottom of the spreadsheet.

Figure 107: Equation information displayed in the Status bar

Formatting trend lines
When inserted, a trend line has the same color as the corresponding data series. To change the style, color, width, or transparency of a trend line, use the Line page of the Trend Line dialog (Figure 108). The options are easily understood or researched.

Figure 108: Trend Line dialog – Line page

Formatting trend line equations
Display the equation in the chart by selecting Show Equation in the Trend Lines dialog (Figure 105). Options for the trend line equation include formatting the border around the equation, area fill, transparency, font, and alignment. The number style can also be specified — this may be quite useful, especially for specifying the number of decimal places.

To format trend line equations:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be surrounded by a gray border.
2) Do one of the following to open the Equation dialog:
   – Select the equation on the **Select Chart Element** drop-down list and then click the **Format Selection** icon next to it on the Formatting toolbar.
   – Click once on the equation to select it then click the **Format Selection** icon on the Formatting toolbar.
   – Right-click on the equation and select **Format Trend Line Equation** from the context menu.

3) Select desired options on the dialog. The options are self-explanatory or easily researched. The Numbers page has the same options as the Numbers page of the Axis dialog, Figure 95 on page 118.

4) Click **OK** to close the dialog.

5) If desired, click outside the chart to leave edit mode.

**Deleting trend lines**

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be surrounded by a gray border.

2) Do one of the following:
   – Select the trend line and press the **Delete** key.
   – Right-click on the trend line and select **Delete Trend line** from the context menu.

3) Click **OK** to close the dialog. If desired, click outside the chart to leave edit mode.

**Mean value lines**

Mean value lines are a special type of trend line. To create one, Calc calculates the average of a data series and places a colored line at that value in the chart, as shown in Figure 109. They can only be created for 2D charts and cannot be created for pie, net, or stock charts.

![Mean value lines](image)

**Figure 109: Mean value lines**

**Inserting mean value lines**

For all data series (if no data series is selected, mean value lines are inserted for all data series):

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be surrounded by a gray border.

2) Go to **Insert > Mean Value Lines** on the Menu bar.

3) Click **OK** to close the dialog. If desired, click outside the chart to leave edit mode.
For a single data series:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be surrounded by a gray border.

2) Select a data series by doing one of the following:
   – Click once somewhere in the data series.
   – Select the data series from the Select Chart Element drop-down list on the Formatting toolbar.

3) Add the mean value line by doing one of the following:
   – Go to Insert > Mean Value Lines on the Menu bar.
   – Right-click on the data series and select Insert Mean Value Line from the context menu.

4) Click OK to close the dialog.

5) If desired, click outside the chart to leave edit mode.

**Modifying mean value lines**

When inserted, a trend line has the same color as the corresponding data series. To modify the style, color, width, and transparency of a mean value line:

1) Double-click on the chart to enter edit mode. The chart should now be surrounded by a gray border.

2) Do one of the following to open the Mean Value Line dialog (the dialog has the same options as the Line page of the Trend Line dialog in Figure 108):
   – Right-click on the mean value line and select Format Mean Value Line.
   – Select the appropriate mean value line from the Select Chart Element drop-down list on the Formatting bar, then click the Format Selection icon in the Formatting toolbar.

3) Make desired changes.

4) Click OK to close the dialog.

5) If desired, click outside the chart to leave edit mode.

**Deleting mean value lines**

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be surrounded by a gray border.

2) Do one of the following:
   – Select the mean value line and press the Delete key.
   – Right-click on the data series and select Delete Mean Value Line from the context menu.

3) Click OK to close the dialog.

4) If desired, click outside the chart to leave edit mode.

**Error bars**

Error bars, shown in Figure 110, can be useful for presenting data that has a known possibility of error, such as social surveys using a particular sampling method, or for showing the measuring accuracy of the tool used. They can be created for 2D charts only and cannot be created for pie, net, or stock charts.
Inserting error bars

If no data series is selected, X or Y error bars are inserted for all data series. To add error bars for all data series:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be surrounded by a gray border.

2) Go to Insert > X Error Bars or Insert > Y Error Bars on the Menu bar to open the Error Bars dialog (Figure 111).

3) Select the desired options. See below for more information about the options.

4) Click OK to close the dialog and add the error bars to the chart.

5) If desired, click outside the chart to leave edit mode.

To insert error bars for a single data series:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be surrounded by a gray border.

2) Do one of the following to select the data series:
   - Click once on a bar, column, line, or other graphical representation in the data series.
   - Select the data series from the Select Chart Element drop-down list on the Formatting Toolbar.
3) Do one of the following to open the Error Bars dialog (Figure 111):
   – Go to Insert > X Error Bars or Insert > Y Error Bars on the Menu bar.
   – Right-click on the data series and select Insert X Error Bars or Insert Y Error Bars from the context menu.

4) Select the desired options. See below for more information about these options.

5) Click OK to close the dialog and add the error bars to the chart.

6) If desired, click outside the chart to leave edit mode.

**Error bar dialog options**

Under *Error Category*, only one of the following options can be selected at a time.

- **Constant Value** – shows the error as constant positive and/or negative value(s). Specify these values in the Parameters section.

- **Percentage** – shows the error as a percentage of the data points. Specify this in the Parameters section.

The drop-down list has four measures of the error value:

- **Standard Error**
- **Variance**
- **Standard Deviation**
- **Error Margin** – uses the value for the error margin that is specified in the Parameters section.

- **Cell Range** – uses error values defined in a range of cells. Specify the range in the Parameters section.

Under *Parameters*, specify positive and negative values or ranges for the error bars. Constant Value, Percentage, Error Margin, or Cell Range must be checked for these options to be active.

Under *Error Indicator*, select whether the error graphic shows both positive and negative errors, or only positive errors or only negative errors.

**Modifying error bars**

Error bars can only be changed one data series at a time, using the Error Bar dialog (Figure 111).

Do one of the following to open the Error Bars dialog:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be surrounded by a gray border.

2) Do one of the following to open the Error Bar dialog:
   – Click once on the data series to select it, then go to Insert > X Error Bars or Insert > Y Error Bars on the Menu bar.
   – Select the error bars for the specific data series from the Select Chart Element dropdown list on the Formatting toolbar. Then go to Format > Format Selection or click the Format Selection icon on the Formatting toolbar.
   – Right-click on the data series and select Insert X Error Bars or Insert Y Error Bars from the context menu.

3) Select the desired options. See below for more information about these options.

4) Click OK to close the dialog and add the error bars to the chart.

5) If desired, click outside the chart to leave edit mode.

If needed, modify the appearance of the error bars on the Line page of the Error Bar dialog.

---

*Inserting error bars* | 129
Deleting error bars

To delete error bars for all data series:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be surrounded by a gray border.

2) Go to **Insert > X Error Bars** or **Insert > Y Error Bars** on the Menu bar to open the Error Bars dialog (Figure 111). When no data series has been selected, the dialog also includes the option **None** under **Error Category**.

3) Select **None**.

4) Click **OK** to close the dialog and delete the error bars.

5) If desired, click outside the chart to leave edit mode.

To delete error bars for a single data series, follow the same steps as above but instead of steps 2 and 3, right-click on the data series and select **Delete X Error Bars** or **Delete Y Error Bars** from the context menu.

Adding drawing objects to charts

Use the Drawing toolbar to add shapes such as lines, rectangles, circles, text objects, or more complex shapes such as symbols or block arrows. Use additional shapes to add explanatory notes, highlight places on a chart, or even hide certain data or text.

Open the Drawing toolbar by going to **View > Toolbars > Drawing**. Note that it can be moved around the workspace as needed. For more information on using the Drawing toolbar and drawing shapes, see Chapter 5, Using Graphics in Calc, as well as the **Draw Guide**.

The Drawing toolbar appears as follows when the chart is in edit mode (by clicking on it twice).

---

**Tip**

To place arrows, text, or other drawing objects in a chart, be sure that the chart is in edit mode. Otherwise, an object will not be connected to the chart and will not be moved with it.

---

<table>
<thead>
<tr>
<th>1</th>
<th>2</th>
<th>3</th>
<th>4</th>
<th>5</th>
<th>6</th>
<th>7</th>
<th>8</th>
<th>9</th>
<th>10</th>
<th>11</th>
<th>12</th>
<th>13</th>
<th>14</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select</td>
<td>Insert line</td>
<td>Line ends with arrow</td>
<td>Insert rectangle</td>
<td>Insert ellipse</td>
<td>Freeform line</td>
<td>Text box</td>
<td>Basic shapes</td>
<td>Callout</td>
<td>Callouts</td>
<td>Arrows</td>
<td>Flowchart</td>
<td>Callouts</td>
<td>Stars</td>
</tr>
</tbody>
</table>

*Figure 112: Drawing toolbar when chart is placed in edit mode (by clicking twice on the chart).*

Most of these options are self-evident or can be readily researched, especially by referring to the **Draw Guide**. Clicking on the icon for an option changes the cursor’s appearance, depending on the option. Click and drag the cursor to create the desired drawing object in the chart. Information that may be helpful for charts follows.
**Insert line**
Draws a straight line where dragged. Hold down `Shift` while dragging to constrain angles of the line to multiples of 45 degrees.

Write on the line by double-clicking the line and typing or pasting text. If the text is too low, press `Enter` to raise it above the line.

**Text box**
Draws a text box with horizontal text direction. To place the text at an angle, click once on the text box to select it, right-click, and select **Position and Size** from the context menu. Specify the angle on the Rotation page.

**Callout(s)**
Draws a line that ends in a graphic in which text can be placed. Use a callout to describe or draw attention to a specific point or area. Double-click the callout to write text in it. In Figure 112, Callout option 8 creates a default callout while option 13 opens a tool palette of callout styles.

Clicking the down arrows next to the six options on the right in Figure 112 opens the tool palettes shown in Figure 113.

<table>
<thead>
<tr>
<th>Basic Shapes</th>
<th>Symbols</th>
<th>Arrows</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1" alt="Basic Shapes" /></td>
<td><img src="image2" alt="Symbols" /></td>
<td><img src="image3" alt="Arrows" /></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Flow Charts</th>
<th>Callouts</th>
<th>Stars</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image4" alt="Flow Charts" /></td>
<td><img src="image5" alt="Callouts" /></td>
<td><img src="image6" alt="Stars" /></td>
</tr>
</tbody>
</table>

*Figure 113: Tool palettes that can be opened from the Drawing toolbar.*

**Resizing, moving, and positioning charts**
To resize or move a chart, click it once to put it in selection mode. Resize or move a chart in two ways: interactively, or by using the Position and Size dialog. Combining both methods may be useful. Position a chart interactively for quick and easy changes, then use the Position and Size dialog for precise sizing and positioning.
Changing interactively

**Resizing**

To resize a chart interactively:

1) Click once on the chart to select it. Square selection handles appear around the border of the chart.

2) Click and drag one of the selection handles. The cursor indicates the direction to increase or decrease the chart size. Clicking and dragging a corner preserves the horizontal to vertical size ratio.

**Moving**

Move a chart interactively using one of two methods:

**For small moves**

1) Click once on the chart to select it. Square selection handles appear around the border of the chart.

2) Press $\text{Alt} + \text{an arrow key}$ to move the object one pixel at a time.

3) When finished, click outside the chart to leave selection mode.

**For larger moves**

1) Click once on the chart to select it. Square selection handles appear around the border of the chart.

2) Hover the cursor anywhere over the chart until it changes to a move cursor (shape depends on computer setup).

3) Click and drag the chart to its new location.

4) Release the mouse button when the chart is in the required position.

**Position and Size dialog**

![Position and Size dialog](image)

*Figure 114: Position and Size dialog — Position and Size page*
The Position and Size dialog contains options for defining the position of the chart on the page, specifying its size, and rotating, slanting, or rounding the corners of a chart.

Note

In addition to charts, the Position and Size dialog can also be used to modify and position other graphic elements, such as those available on the Drawing toolbar.

To resize or move a chart using the Position and Size dialog:

1) Click once on the chart to select it. Square selection handles appear around the border of the chart.
2) Right-click and select **Position and Size** from the context menu to open the Position and Size dialog (Figure 114).
3) Select the desired options on the Position and Size, Rotation, and Slant & Corner Radius pages on this dialog. See below for further information about the options on these pages.
4) Click **OK** to close the dialog and save changes.

Click one of the points in the Base point graphic corresponding to the location to use for anchoring either the position of the chart or its size.

Note that either the position or the size can be protected from unwanted changes by clicking the appropriate box in the **Protect** section. Either or both option(s) selected will remain active after the dialog is closed. By contrast, Calc resets the base point to the default position after the dialog is closed.

**Position and Size**

The options available on the Position and Size page (Figure 114) are as follows:

**Position**

Determines the location of the chart on the page. The position of a chart is coordinated relative to a fixed point (the base point). By default, this base point is located at the upper left of a chart. To make positioning of a chart simpler, the base point can be temporarily changed.

- Position X – specifies the horizontal location of the chart relative to the base point.
- Position Y – specifies the vertical location of the chart relative to the base point.
- Base point – specifies a temporary base point for the chart.

**Size**

Specifies the amount by which to resize the selected chart with respect to the selected base point.

- Width – sets a width for the selected object.
- Height – sets a height for the selected object.
- Keep ratio – maintains proportions between width and height when resizing the chart.
- Base point – determines the directions in which the chart size will be increased or decreased.

**Protect**

Prevents unintended changes to the position or the size of the chart.

- Position – prevents unintentionally moving the chart.
- Size – prevents unintentionally resizing the chart.

**Adapt**

Specifies if the size should be adjusted to fit the size of entered text. Availability of these options depends on the context.
– Fit width to text – expands the width of the object to the width of the text, if the object is smaller than the text.
– Fit height to text – expands the height of the object to the height of the text, if the object is smaller than the text.

**Rotation**
The options for the Rotation page (Figure 115) are as follows:

![Position and size dialog – Rotation page](image)

**Figure 115: Position and size dialog – Rotation page**

**Pivot point**
The chart can be rotated around a pivot point. The default pivot point is at the center of the chart. Note that if there is not enough room to rotate the chart, it could be rotated off of the page.

– Position X – specifies the horizontal distance from the left edge of the page to the pivot point.
– Position Y – specifies the vertical distance from the top edge of the page to the pivot point.
– Default settings – sets the location of the pivot point. The pivot point can be temporarily changed. But when the dialog is opened again, the pivot point will be the default location at the center of the chart and the X and Y positions will reflect the default location.

**Rotation angle**
 Specifies the number of degrees that the chart is rotated.

– Angle – shows the number of degrees of rotation. The number can be entered directly or it can be set using the indicator to the right under Default settings.
– Default settings – graphically shows the rotation angle. The angle can be set by clicking and dragging the indicator. The number of degrees rotated is shown in the Angle box.
**Slant & Corner Radius**

The options for the Slant & Corner Radius page (Figure 116) are as follows:

**Corner Radius**
- This option is not available for charts.

**Slant**
- Slants the chart along an axis. Specify the angle of the axis.

![Position and Size dialog – Slant and Corner Radius page](image)

**Selecting multiple charts**

Select multiple charts by clicking once on the first chart then pressing *Shift* while clicking on additional charts. An invisible selection rectangle covers all of the selected charts and selection handles appear at the corners and midway between corners. The multiple charts are now treated as a single object and actions such as the following can be conducted.

- Cut and paste or drag them to new locations.
- Use the Position and Size dialog described in the previous section.
- Use the Drawing Object Properties toolbar to align all of the charts, format the outer borders, or anchor the charts to the same cell or page.

**Changing overall appearance of charts**

When a chart is selected (by clicking on it once) it can be formatted as an object. The Drawing Object Properties toolbar (Figure 117) usually appears below the Standard toolbar (but the location depends on setup) and shows tools available for all objects, including charts.

Most of the options are self-evident or can be easily researched. Please refer to Chapter 5, Using Graphics in Calc, in this guide and the *Draw Guide* for further information. Following are a few tips for using these tools with charts.
<p>| | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Anchor</td>
<td>7</td>
</tr>
<tr>
<td>2</td>
<td>Align</td>
<td>8</td>
</tr>
<tr>
<td>3</td>
<td>Bring to Front</td>
<td>9</td>
</tr>
<tr>
<td>4</td>
<td>Forward One</td>
<td>10</td>
</tr>
<tr>
<td>5</td>
<td>Back One</td>
<td>11</td>
</tr>
<tr>
<td>6</td>
<td>Send to Back</td>
<td>12</td>
</tr>
<tr>
<td>13</td>
<td>Fill Color</td>
<td>14</td>
</tr>
<tr>
<td>15</td>
<td>Rotate</td>
<td>16</td>
</tr>
<tr>
<td>17</td>
<td>Group</td>
<td></td>
</tr>
</tbody>
</table>

Figure 117: Drawing Object Properties toolbar that appears when chart is selected

**Anchor**

Connects a chart to either remain in the same position on a page or to move with a cell (when rows and columns are inserted or deleted). When To cell (resize with cell) is chosen, the chart or object increases or decreases in size when the cell is made larger or smaller.

**Align**

Click the icon to open options for aligning multiple charts horizontally (left, centered, right) or vertically (top, center, or bottom). This option is only active when two or more charts (or other objects) are selected.

**Bring to Front/Forward One/Back One/Send to Back**

Stacks charts or other objects in front of or behind other objects.

**To Foreground/To Background**

Places charts or stacks of objects in either the foreground or the background. In Calc, objects in the background are behind the cell grid and may be difficult to select. Use the Select tool (arrow icon) on the Drawing toolbar (Figure 112) to select them.

**Line Style/Line Width/Line Color**

Formats the outer borders of charts.

**Area Style/Filling and Fill Color**

Colors objects such as arrows, shapes, and callouts. For charts, use the fill options available in edit mode.

**Arrow Style**

Specifies the appearance of line arrows and lines. Does not apply to the block arrows shown in Figures 112 and 113.

**Rotate**

Rotates the chart around a base point. When selected, places round rotation handles at each corner. Move these to rotate the chart. Move the small circle in the center of the chart to change the base point. Move the handles midway between the corners to slant the chart or other object.

**Points**

Changes the shape of curved objects. Move the points to shape curves created with the curve tool on the Drawing toolbar.

**Group**

Groups or ungroups two or more objects. When grouped, the objects can be moved together and global changes can be applied to them.

136 | Changing overall appearance of charts
Copying, exporting, and deleting charts

Copying charts in the same spreadsheet document

When a chart is copied, it retains a connection to the source data it is built on as long as it is in the same document. This means that changes made to the source data will be reflected in the chart.

Copying and pasting the chart is easy. Just click the chart once to select it, then either press Ctrl+C or right-click on the chart and select Copy from the context menu. To paste the chart in the desired location, press Ctrl+V or right-click and select Paste.

Copying to another LibreOffice document

When a chart is copied and pasted into another LibreOffice document, any connection to the data it is based on is lost. The data is kept with the chart and is now called a data table rather than a data range. Figure 118 shows an example of this internal data table.

Note

A copied chart links to or retains its data only when pasted into a LibreOffice document. To retain data or links outside LibreOffice, use embedding or linking, as explained in Chapter 10, Linking Calc Data.

Keeping original data

If the goal is to use the original data for the chart, follow the same procedure as above to copy and paste the chart to another document. Nothing more needs to be done.

Modifying original data

If the original data for the chart needs to be modified, do the following:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be surrounded by a gray border.
2) Right-click on the chart and select Data Table to open the data table shown in Figure 118.
3) Modify the data as desired. In addition to changing numbers in the data, use options to insert, move, or delete columns and rows.
4) Click OK to close the dialog.
5) If desired, click outside the chart to leave edit mode.
**Dragging replacement data**

If the chart is still in Calc and replacement data is in the same spreadsheet, select and drag the new data onto the chart. This is described in “Replacing data by dragging” on page 105.

**Note**

Calc does not provide a direct way to save chart settings for creating another chart in LibreOffice. Here are three options for using the same chart settings: 1) copy and paste the chart into another file; 2) save the file containing the chart as a new file; and 3) save the chart in a template. Depending on the method used, create a new chart by modifying either the data range or the data table.

**Exporting charts**

Charts can be exported in a variety of image formats for use in other documents. File types include BMP, EMF, EPS, GIF, JPEG, PDF, PNG, SVG, SVM, TIFF, and WMF.

To export a chart:

1) Click once on the chart to select it. Square selection handles appear around the border of the chart.

2) Do one of the following to open the Save as Image dialog:
   – Right-click on the selected chart and select **Export as Image** from the context menu.
   – Go to **File > Export**.

3) In the dialog, type a name for the graphic file, select the location for saving the file, and select the desired graphic format.

4) Click **Save** and the chart will be exported to the location specified.

**Deleting charts**

To delete a chart, simply click it once to select it. Square selection handles appear on the borders of the chart. Then press **Delete**.

**Gallery of chart types**

While data can be presented using a variety of charts, focus on the message of the chart to determine which type of chart to use. The following sections present examples of the chart types that Calc provides, with some notes on the uses of each one.

**Column charts**

A column chart shows vertical bars, with the height of each bar proportional to its value. The X axis shows categories and the Y axis shows the value for each category.

Column charts are commonly used for data that show trends over time. They are best for a relatively small number of data points. It is the default chart type provided by Calc, as it is one of the most useful and easy to understand. For a larger time series, a line chart would be more appropriate.
The column chart type has three variants, with a preview pane for each variant as shown in Figure 119. When a preview is clicked, its borders are highlighted and the name appears below. The variants are:

**Normal**
Shows all data values belonging to a category next to each other. The main focus is on the individual absolute values, compared to every other value.

**Stacked**
Shows the data values of each category on top of each other. The main focus is the overall category value and the individual contribution of each value within the category.

**Percent stacked**
Shows the relative percentage of each data value with regard to the total of its category. The main focus is the relative contribution of each value to the category total. (Contrary to the preview picture in Figure 119, the values are stacked, not next to each other.)

Additional options for creating column charts are:

**3D Look**
When this box is checked, two options become available in the drop-down list:
- Realistic 3D chart – tries to give the best 3D look.
- Simple 3D chart – tries to mimic the chart view of other products.

**Shape**
Gives options for the shape of the columns in 3D charts. The choices are: Bar, Cylinder, Cone, and Pyramid.

**Bar charts**
A bar chart is like a column chart that has been shifted 90 degrees. It shows horizontal bars rather than vertical columns. In contrast to some other chart types, the Y axis is horizontal and the X axis is vertical. The Chart Type dialog for a bar chart is essentially the same as for a column chart, described above.

Bar charts can have an immediate visual impact when time is not an important factor — for example, when comparing the popularity of a few products in a marketplace. They may be preferred to column charts when the category names are long or there are a significant number of categories.
In the examples in Figure 120 below:

- To make the first chart after using the chart wizard, go to Insert > Grids, deselect Y axis, and choose Insert > Mean Value Lines. Right-click each mean value line and select Format Mean Value Line to increase the width of the lines. Create rectangles from the Drawing toolbar to cover the mean value line entries in the legend. Make them white by right-clicking and selecting Line and then Area.

- The second chart is a 3D chart created with a simple border and cylinder shape. The chart area is rotated (described under “Rotation and perspective” on page 125).

- The third chart eliminates the legend by using labels with the names of the companies on the Y axis. Whereas the first two charts treat the data as separate data series, this chart treats the data as one data series in order to have category labels for the X axis. Rather than colors, a colored horizontal hatch pattern is used for the bars.

**Pie charts**

A pie chart shows values as circular sections of a circle. The area of each section is proportional to its value.

Pie charts are excellent for comparing proportions — comparisons of departmental spending, for example. They work best with smaller numbers of values, up to about half a dozen; more than this and the visual impact begins to fade.

**Figure 121: Chart Type dialog for pie chart**

Pie variant options, shown in Figure 121, are:

**Normal**

Shows values as sections of a complete pie, with the option of separating out individual pieces. Click the outer edge of a section to separate it from the remaining pie or to join it back.
Exploded pie
Shows all of the sections separated from each other. Click and drag any section to move it along radial lines from the pie center.

Donut
Shows multiple data series. Each data series is shown as one donut shape with a hole inside, where the next data series can be shown. Click and drag an outer section to move it along radial lines from the donut center.

Exploded donut
Shows the outer sections already separated from the remaining donut. Click and drag an outer section to move it along radial lines from the center.

The Chart Wizard initially guesses how the data should be presented in the chart. Adjust this on the Data Ranges page of the Wizard or by using the Data Series dialog (Format > Data Ranges > Data Series).

You can do some interesting things with a pie chart, especially if you make it into a 3D chart. It can be tilted, given shadows, and generally turned into a work of art. Just do not clutter it so much that the message is lost, and be careful that tilting does not distort the relative sizes of the segments.

You can choose in the Chart Wizard to use the exploded pie variant, but this option explodes all of the pieces (contrary to the preview graphic in Figure 121). If the aim is to accentuate just one piece of the pie, separate out a piece by carefully highlighting it and dragging it out of the group. After this, the chart area may need to be enlarged to regain the original size of the pieces.

![Pie chart examples](image)

**Figure 122: Pie chart examples**

The effects achieved in Figure 122 are explained below.

**2D pie chart with one section of the pie exploded**
Select Insert > Legend and deselect the Display legend box. Select Insert > Data Labels. Select Show value as number and also Show category. Click the edge of the section (the section will have highlight squares to mark it), and drag it out from the rest of the sections. The sections will decrease in size. If needed, highlight the chart wall and drag it at a corner to increase the size.

**3D pie chart, exploded variant, with realistic schema and various fill effects**
Go to Format > Chart Type and select 3D look. Go to Insert > Data labels and select Show value as percentage. Then carefully select each section so that it has a wire frame highlight. Right-click and select Format Data Point to get the data point dialog. Choose the Area tab. The illustration in Figure 122 shows one section formatted with bitmap, one with a radial gradient, one with 50% transparency, and one with a pattern.

Donut and exploded donut variants, shown in Figure 123, are used to display two set of related information, such as two years of financial data. This variant can be misleading for comparing numeric data, since inner circles are necessarily smaller. For more variety, use a 3D Look.
Area charts

Like a line or column chart, an area chart shows values as points on the Y axis and categories on the X axis. The Y values of each data series are connected by lines and the areas below the lines are colored.

Area charts emphasize volumes of change from one category to the next. They have greater visual impact than line charts, but the data used will make a difference.

Area chart variants, shown in Figure 124, are:

Normal
Plots all data as absolute Y values. It first plots the area of the last data series in the data range, then the next to last, and so on. Finally the first data series is drawn over the other data. Thus, higher values in the first data series will hide lower values of later data series.

Deep
When 3D Look is selected, this variant shows the first data series in front, with subsequent data series behind.

Stacked
Stacks cumulative values on top of each other. This ensures that all values are visible, and no data set is hidden by others. However, the Y values no longer represent absolute values, except for the first data series, which is shown at the bottom of the stacked areas.

Percent
Stacks cumulative values on each other and also scales the values as percentages of the category total.
Area charts are sometimes tricky to create. Using transparency values may be helpful. To create the charts in Figure 125, first set up the basic chart using the Chart Wizard. The chart on the left shows the result. Because the data overlap, some of it is missing behind the first data series. This is probably not desirable. The other examples are better solutions.

To create the chart in the center:

After deselecting the Y axis grid, right-click on each data series in turn and select **Format Data Series**. On the Transparency tab, set Transparency to 50%. The transparency makes it easy to see the data hidden behind the first data series.

To create the chart on the right:

After doing the steps above, right-click and select **Chart Type**. Select the **3D Look** option and select **Realistic** from the drop-down list. Rotate the chart area using the 3D View dialog. Instead of a legend, use labels on the Z axis.

**Stacked area charts**

Other ways of visualizing the same data series are the stacked area chart and the percentage stacked area chart (Figure 126). In the first example, each point in a data series is added to the other data series to show the total area. The second example shows a percentage stacked chart, showing each value in the series as a percentage of the whole.

A line chart is useful for showing trends or changes over time when you want to emphasize continuity. Values are shown as points on the Y axis and the X axis shows categories — often time series data. The Y values of each data series may be connected by a line.
The difference between line charts, described in this section, and XY (scatter) charts, described in the next section, is this: line charts show categories along the X axis while XY (scatter) charts show values along the X axis.

As shown in Figure 127, four variants are available:

- Points only – plots only points.
- Points and lines – plots points and connects points of the same data series by a line.
- Lines only – plots only lines.
- 3D lines – connects points of the same data series by a 3D line.

When Stack series is selected, it shows cumulative Y values above each other. The options are:

- On top – places the value of each data series above the others. The Y values no longer represent absolute values, except for the first data series, which appears at the bottom of the chart. This is the default setting.
- Percent – scales the Y values as percentages of the category total.

The Line Type drop-down list has three options that determine how the data points are connected:

**Straight**

Draws straight lines between the points.

**Smooth**

Connects the points with curves instead of lines. When this option is selected, click Properties to open the Smooth Lines dialog (Figure 128) and further specify the curves.
For smooth lines, there are two options: Cubic Spline or B-Spline. These are mathematical models that join together segments of polynomials to display the curves. For B-spline lines, there is an option to set the degree of the polynomials. Select a higher resolution for smoother curves.

**Stepped**
Connects points with horizontal and vertical lines only. Click **Properties** to further specify the formatting of the lines (Figure 129). The options are self-explanatory.

![Stepped Lines properties dialog](image)

Figure 129: Stepped Lines properties dialog

Things to do with lines: thicken them, smooth the contours, just use points, or make them 3D. However, 3D lines can confuse the viewer, so just using a thicker line often works better. Figure 130 shows some examples of line charts.

![Trends in Currency Trading and Values](image)

Figure 130: Line chart examples

**Scatter or XY charts**
In contrast to line, column, and bar charts, which contain numeric values on the Y axis and categories on the X axis, scatter or XY charts contain values along both axes. They are quite useful, especially for understanding relationships among data that are precise and complex. An XY chart may contain more than one data series and can perform many tasks, such as generating a parameter curve or drawing the graph of a function.

**Tip**
When plotting time on the X axis, make sure that it is not text and is written in the correct format for your locale. For example, instead of January, use a format such as 1/1/2022. Check locale formats at **Tools > Options > Language Settings > Languages > Date Acceptance Patterns**.

XY charts are most frequently used to explore the statistical associations among quantitative variables. There is often a constant value against which to compare the data — for example, weather data, reactions under different acidity levels, or conditions at various altitudes.
Tip

By custom, if one of the variables is either controlled by an experimenter or it changes consistently (such as time) it is considered an independent variable and plotted on the X axis.

**XY chart variants**

![XY (Scatter) chart options](image)

Figure 131: Chart Type – XY (Scatter) chart options

As shown in Figure 131, when XY (Scatter) chart type is selected, the following options may appear:

- **Points Only**
  Shows an icon for each data point. Calc uses default icons with different forms and colors for each data series. The default colors are set in Tools > Options > Charts > Default Colors. Changing the colors and icons is discussed in “Lines, areas, and data point icons” on page 109.

- **Lines Only**
  Draws straight lines from one data point to the next. The data points are not indicated by icons. By default, the drawing order is the same as the order in the data series, but note the option to sort by X values.

- **Points and Lines**
  Shows both points and lines.

- **3D Lines**
  Makes the lines look like tapes. The data points are not shown by icons. In the finished chart, select 3D View to set properties like illumination and angle of view.

- **Sort by X Values**
  Draws the lines in order of the X values. This can be helpful if the data series on the spreadsheet is not in numeric order.

- **Line Type – Smooth**
  Draws curves instead of straight line segments. Click Properties to set details for the curves.
    - Cubic Spline interpolates the data points with polynomials of degree 3. The transitions between the polynomial pieces are smooth, having the same slope and curvature.
    - Resolution determines how many line segments are calculated to draw a piece of polynomial between two data points. Click any data point to see the intermediate points.
    - B-Spline uses parametric, interpolating B-spline curves. The curves are built from polynomials. Degree of polynomials sets the degree of these polynomials.
Line Type – Stepped
Uses only horizontal and vertical lines.

After a scatter chart is created, its default settings can be changed in ways such as the following. Be sure to first double-click the chart to enter edit mode. Depending on the option, a data point or data series may also need to be double-clicked.

- Line styles and icons – double-click or right-click on a data series in the chart to open the Data Series dialog. See “Lines, areas, and data point icons” on page 109 for further information.
- Error bars – For 2D charts, select Insert > Y Error Bars or X Error Bars to enable the display of error bars. See “Error bars” on page 132 for further information.
- Mean Value Lines and Trend Lines – Enable the display of mean value lines and trend lines with commands on the Insert menu. See “Trend lines” on page 127 for further information.

Examples of XY or scatter charts
By default, the first column or row of data (depending on whether the data is arranged in columns or rows) is represented on the X axis. The rest of the rows of data are then compared against the first row of data.

Scatter charts may surprise those unfamiliar with how they work. This can be seen in examples using the following data, which is organized with data series in rows:

<table>
<thead>
<tr>
<th></th>
<th>Apr</th>
<th>May</th>
<th>Jun</th>
<th>Jul</th>
<th>Aug</th>
<th>Sep</th>
<th>Oct</th>
<th>Nov</th>
</tr>
</thead>
<tbody>
<tr>
<td>Yen</td>
<td>102</td>
<td>105</td>
<td>178</td>
<td>155</td>
<td>122</td>
<td>98</td>
<td>134</td>
<td>97</td>
</tr>
<tr>
<td>Dollar</td>
<td>56</td>
<td>57</td>
<td>67</td>
<td>90</td>
<td>64</td>
<td>56</td>
<td>78</td>
<td>34</td>
</tr>
<tr>
<td>Rupee</td>
<td>209</td>
<td>230</td>
<td>256</td>
<td>231</td>
<td>201</td>
<td>199</td>
<td>230</td>
<td>223</td>
</tr>
<tr>
<td>Yuan</td>
<td>69</td>
<td>78</td>
<td>75</td>
<td>76</td>
<td>69</td>
<td>95</td>
<td>69</td>
<td>70</td>
</tr>
</tbody>
</table>

Figure 132: XY (Scatter) chart examples

The data range for the chart on the left in Figure 132 includes the cells containing the months. However, the months do not appear on the chart because only values can be used in XY charts and Calc substitutes cardinal numbers for them.

The data range for the chart on the right does not include the cells containing the months. Calc assumes that the first row (or column) of data contains values for the X axis. The Y values of the other data series are paired with each of those X values. This means that there are no data points for the Japanese yen but each of the other currencies are shown in comparison to the yen, since it supplies the X values.

Bubble charts
A bubble chart is a variation of a scatter chart that can show three variables in two dimensions. The data points are shown with bubbles. Two variables are plotted along the X and Y axes, while the third variable is represented by the relative size of the bubbles. These charts are often used to present financial data or social/demographic data.
One or more data series can be included in a single chart. The data series dialog for a bubble chart has an entry to define the data range that determines the size of the bubbles.

It may be necessary to build a bubble chart manually in the data series page of the Chart Wizard. Figure 133 shows how the data ranges can be set for a bubble chart.

![Data series entries for bubble chart](image)

Figure 133: Data series entries for bubble chart

The chart in Figure 134 is based on the data in Figure 133. To format the chart, the data series are 50% transparent with a radial gradient. The data labels are formatted to be numbers in the center of the data points (bubbles).

![Bubble chart example](image)

Figure 134: Bubble chart example

**Note**

Remember that bubble charts require numeric data. If the data series for the X axis contains text (or dates not formatted as numbers) cardinal numbers will be used for axis labels.

**Net charts**

Net charts are also known as spider, polar, or radar charts. They display data values as points on radial spokes, with each spoke representing a variable. They compare data that are not time series, but show different circumstances, such as variables in a scientific experiment. They are especially useful for displaying clusters and outliers.

Figure 135 shows an example of a simple net chart. The radial spokes of the net chart are equivalent to the Y-axes of other charts. All data values are shown with the same scale, so all data values should have about the same magnitude.
Generally, between three and eight axes are best; any more and this type of chart becomes confusing. Before and after values can be plotted on the same chart, or perhaps expected and real results, so that differences can be compared.

Figure 136: Net chart variants and options

Figure 136 shows the options for creating a net chart. These are similar to those for area and line charts, described above. However, keep in mind that area increases as the square of the distance along the linear spokes. Therefore, net charts can distort the areas representing the data. Be especially careful about choosing to stack data series. In this case, successive data series show increasingly large areas that are not proportional to their values.

Figure 137 shows examples of two types of net charts.

- The example on the left is a filled net chart. The color of one of the data series is 50% transparent. Partial transparency is often best for showing all of the series.
- The example on the right is a net chart with lines and points. The data point icons are taken from the Gallery and have a 3D look.
Stock charts

A stock chart illustrates the market trends for stock and shares by giving opening price, bottom price, top price, and closing price. The transaction volume can also be shown and the X axis usually represents a time series.

When setting up a stock chart in the Chart Wizard, the data should be arranged as shown in Figure 138. It specifies which columns should be the opening, low, high, and closing prices of the stock as well as the transaction volume. However, manual adjustments may still be needed when defining the data series.

A stock chart organizes data series in two basic ways. The first way is not used in other chart types. In this case, the open, low, high, and closing values of a row create one data unit in the chart and one data series consists of several rows containing such data units. The columns containing transaction volumes are the second way used to organize data series. This is the familiar way used in other chart types.

Thus, Figure 138 shows the data for four data series: 1) the price data for Acme, which contains columns for open, low, high, and closing prices, 2) the price data for Ajax, which contains columns for open, low, high, and closing prices, 3) the Acme transaction volume, which is one column, and 4) the Ajax transaction volume, which is one column.

Stock chart variants

The Chart Wizard offers four stock chart variants, as shown in Figure 139. Note that some of them do not use all of the data columns.

A stock chart organizes data series in two basic ways. The first way is not used in other chart types. In this case, the open, low, high, and closing values of a row create one data unit in the chart and one data series consists of several rows containing such data units. The columns containing transaction volumes are the second way used to organize data series. This is the familiar way used in other chart types.

Thus, Figure 138 shows the data for four data series: 1) the price data for Acme, which contains columns for open, low, high, and closing prices, 2) the price data for Ajax, which contains columns for open, low, high, and closing prices, 3) the Acme transaction volume, which is one column, and 4) the Ajax transaction volume, which is one column.

Stock chart variants

The Chart Wizard offers four stock chart variants, as shown in Figure 139. Note that some of them do not use all of the data columns.

The data table in Figure 138 is used to illustrate the variants, which are as follows:

Stock Chart 1

When based only on data in the low and high columns, this variant shows the distance between bottom price (low) and top price (high) with a vertical line. When the closing column is also included (Figure 140), it shows an additional horizontal mark for the closing price.
Stock Chart 1

Based on the open, low, high, and close columns, this variant generates the traditional candlestick chart (Figure 141). It shows a vertical line between the bottom and top prices and adds a rectangle in front that shows the range between the opening and closing prices. For rising values (the opening price is lower than the closing price), the fill color is white. For falling values, the fill color is black.

Stock Chart 2

Using the low, high, and close columns, draws a chart similar to Stock Chart 1 but with additional columns for transaction volume. As shown in Figure 142, a secondary Y axis enables both transaction volume and price to be shown on vertical axes.
Figure 142: Stock chart variant 3 showing low, high, and closing prices as well as transaction volumes

_Note_

Variants 3 and 4 automatically align data to the secondary Y axis. For more information about a secondary Y axis, see “Aligning data to secondary Y axis” on page 107.

Stock Chart 4

Based on all five data columns (volume, open, low, high, and close), this variant combines Stock Chart 2 with a column chart for the transaction volume (Figure 143).

Figure 143: Stock chart variant 4 showing opening, low, high, and closing prices as well as transaction volumes.

**Column and line charts**

A column and line chart is useful for displaying two or more distinct but related data series, such as sales over time (columns) and profit margin trends (lines). It could also show constant minimum and maximum lines, such as used in medical testing or quality control.
Specify in the Chart Type dialog whether there will be 1, 2, 3, or 4 lines. By default, the first column or row of data is categories and the last columns or rows of data are lines.

Choose between two variants:

**Columns and Lines**
As seen in Figure 144, the columns are drawn side by side to easily compare their values.

![Figure 144: Column and line chart with secondary Y axis](image)

**Stacked Columns and Lines**
The columns are stacked above each other, so that the height of a column shows the sum of the data values.

![Figure 145: Column and line chart with stacked columns](image)

The charts in Figures 144 and 145 show sales and profit data for two firms over a period of time. Note that when first created, the lines were different colors than the columns for the same company. To reflect the company relationships, change the line colors individually by clicking on a line, right-clicking, selecting **Format Data Series**, and formatting the line color and size on the Line page.

For the background, right-click the chart wall, select **Format Wall**, and select desired options on the Gradient page. To align the two data series to the secondary Y axis, see “Aligning data to secondary Y axis” on page 107.

**Pivot charts**
Pivot tables are special types of data tables that simplify the manipulation and analysis of data. They are widely used, especially for processing large amounts of data. Pivot charts are based on pivot tables. They are slightly different from the charts discussed in this chapter and are discussed in the chapter on pivot tables in this user guide.
Chapter 4
Using Styles and Templates
Using consistent formatting in spreadsheets
What are styles? Why use them?

A style is a set of formats that you can apply to selected elements in a document to quickly change their appearance. Applying a style often means applying a group of formats at the same time.

Many people manually format spreadsheet cells and pages without paying any attention to styles and are accustomed to formatting documents according to physical attributes. For example, for the contents of a cell you might specify the font family, font size, and any character formatting such as bold or italic.

Styles are logical attributes. Using styles means that you stop applying attributes and characteristics individually (for example, font size 14pt, Times New Roman, bold, centered) and start using a style, for example Title. Applying attributes and characteristics is time-consuming and prone to errors. In contrast, using a style, which has been defined to include the attributes and characteristics you want, will save you time and give greater consistency in formatting.

Styles also make major formatting changes easy. For example, you may decide to change the appearance of all subtotals in a spreadsheet to be 10 pt Arial instead of 8 pt Times New Roman after you have created a 15-page spreadsheet. You can change all of the subtotals in the document by simply changing the properties for the subtotal style.

Calc also provides page styles, as described below.

You can modify the attributes of the supplied styles and define as many new styles as you require. Creating, modifying, and accessing styles is explained in the following sections.

Direct formatting and Style formatting

Direct formatting (also called manual formatting) overrides styles, and you cannot remove the direct formatting by applying a style to it.

To remove manual formatting, select the text, right-click, and choose Format > Clear Direct Formatting from the context menu, or select the text and press Ctrl+M.

Calc style types

While some components of LibreOffice offer many style types, Calc offers only two: cell styles and page styles. These style types are explained in the following sections.

Cell styles

Cell styles are similar to paragraph styles used in LibreOffice Writer. They are the most basic type of style in Calc. Cell styles are used for applying fonts, alignment, borders, background, number formats (for example, currency, date, number), and cell protection to format the data in the cells.

A basic range of cell styles is supplied with LibreOffice. These styles are shown on the Styles menu on the Menu bar and in the Styles panel of the Sidebar. When you create a new cell style, it is shown in the Sidebar. You can also add it to the Styles menu; see Chapter 14, Setting up and Customizing Calc, for instructions.

Initially, the basic styles are configured so that if you change the font family of Default, then all of the other styles will change to match.

Page styles

Page styles in Calc are applied to sheets. Although one sheet may print on several pages, only one page style can be applied to a sheet. If a spreadsheet file contains more than one sheet, then a different page style can be applied to each sheet. For example, a spreadsheet might contain one sheet to be printed in landscape orientation and the other sheets to be printed in portrait orientation.
Two page styles are supplied with Calc: Default and Report. Page styles allow you to set page size and orientation, page margins, headers and footers, borders and backgrounds, and the sequence for printing sheets.

**Applying cell styles**

To apply cell styles in Calc, you can use the Styles menu on the Menu bar, the Styles panel in the Sidebar, Fill Format mode, the Apply Style list on the Formatting toolbar, and keyboard shortcuts.

**Styles menu**

The Styles menu (Figure 146) lists the cell styles supplied with Calc. To apply a cell style, select the cell or group of cells to be formatted, and then choose **Styles** and click on the required style.

![Figure 146: The Styles menu](image)

**Styles panel in Sidebar**

The Styles panel in the Sidebar lists and shows previews of the styles available. If the Sidebar is not open, choose **View > Styles** or **Styles > Manage Styles** or tap the **F11** function key to open it.

5) Go to the Styles panel in the Sidebar.

6) Click the **Cell Styles** icon on top of the Styles panel to open the list of cell styles. Figure 147 shows the panel with Cell Styles visible.

7) In the spreadsheet, highlight the cell or group of cells where you want to apply a cell style.

8) Double-click on the cell style name in the Styles panel and the formatting attributes for that style are applied to the data contained in the cell or group of cells.
Fill Format mode

Fill Format mode is useful when you want to apply the same style to many scattered cells.

1) Go to the Styles panel in the Sidebar (Figure 147).
2) Select the style you want to apply.
3) Click the Fill Format Mode icon in the top right of the Styles panel. The cursor changes shape.
4) Click in each cell where you want to apply the selected style.
5) When you have finished formatting cells, click the Fill Format Mode icon to disable it.

Note

When Fill Format mode is active, a right-click anywhere in the document cancels the last Fill Format action. Be careful not to accidentally right-click and thus cancel any formatting actions you want to keep.

Apply Style list

The Apply Style list icon is not included by default on the Formatting toolbar in Calc, but you can add it as follows:

1) Right-click on any icon in the Formatting toolbar and select Visible Buttons from the context menu (Figure 148).
2) Click Apply Style. The context menu closes and the Apply Style list appears at the left end of the Formatting toolbar.
To apply a style using the Apply Styles list:

1) Select a cell or a group of cells in the spreadsheet.
2) Click the down arrow by **Apply Styles** to open the drop-down list (Figure 149).
3) Select the required style. The formatting attributes of that style are applied to the selected cells.

![Figure 149: Applying a style from the list](image)

Only the styles that are in use are shown on the list. Click **More Styles** to go to the Styles panel where all cell styles are available.

**Keyboard shortcuts**

You can create keyboard shortcuts to apply commonly-used cell or page styles, including any custom styles that you have created. See Chapter 14, Setting up and Customizing Calc, for more information.

**Applying page styles**

The page style applied to a sheet within a spreadsheet is indicated on the Status Bar, as shown in Figure 150.

![Figure 150: Page style (Default) indicated on Status Bar](image)

To apply a different page style:

1) Select the sheet to be styled by clicking its sheet tab at the bottom of the window.
2) Go to the Styles panel in the Sidebar (Figure 147).
3) In the top of the Styles panel, click the **Page Styles** icon.
4) Double-click on the required page style.

**Creating new (custom) styles**

To create a new (custom) style, follow the procedure described in this section.

**Note**

Any new (custom) styles, and any changes to existing styles, apply only to the spreadsheet in use. To save new styles in a template, see “Creating a template” on page 178 for more information.
1) Go to the Styles panel in the Sidebar (Figure 147).
2) To create a new cell style, click the Cell Styles icon, or to create a new page style, click the Page Styles icon.
3) Right-click in the Styles panel and select New from the context menu to open either the Cell Style dialog or the Page Style dialog.
4) Use the various tabbed pages in the dialogs to set the attributes for the new style. See “Cell style attributes” on page 166 and “Page style attributes” on page 173 for more information.
5) Click OK to close the dialog and save the new style.

Note
Style names are case sensitive. You can define, for example, a style called red and another style called Red. Make sure all style names are sufficiently different to prevent any confusion.

Cell style attributes
The following attributes are available on the tabbed pages of the Cell Style dialog (Figure 152).

Organizer tab

- **Name** – displays the name of the selected style. If you are creating or modifying a custom style, enter a name for the style. You cannot change the name of a predefined style.
- **Inherit from** – you can choose to link the new style to an existing style and then modify some of the attributes. If you do this, any change to the parent style’s attributes will affect the new style. For example, you could make the styles identical except for the font color; if you later change the font family of the parent style, the new style’s family will also change.
- **Category** – displays the category for the current style. If you are creating or modifying a new style, select Custom Styles from the list. You cannot change the category for a predefined style.
- **Contains** – describes the formatting used in the style.

Numbers tab

- **Category** – select a category from the list. Examples: Currency, Date, Number, Text.
- **Format** – select how you want the contents of the selected cell(s) to be displayed.
When you select *Currency* as a category, you need to select a currency from the drop-down list and then select the format to use from the options available for that currency. The currency format is not dependent on the language that you select in the **Language** box. The default currency format for a cell is determined by the regional settings of your operating system.

- **Language** – specifies the language setting for the selected cells. With the language set to the default, LibreOffice automatically applies the number formats associated with the system default language. The language setting ensures that date and currency formats are preserved even when the document is opened in an operating system that uses a different default language setting.

- **Options** – specify the options for the selected format.
  - *Decimal places* – enter the number of decimal places that you want to display.
  - *Leading zeroes* – enter the maximum number of zeroes to display in front of the decimal point.
  - *Negative numbers red* – select to change the font color of negative numbers to red.
  - *Thousands separator* – select to insert a separator between thousands. The type of separator (for example, a comma or a space) depends on your language settings.

- **Format code** – displays the number format code for the selected format. You can also enter a custom format.

- **Preview field** – displays a preview of the current selection.

---

*Figure 152: Cell Style dialog – Numbers tab*
Font tab

Figure 153: Cell Style dialog – Font tab

- **Font** – select a font family from the list.
- **Style** – select the formatting you want to apply, for example **Bold** or **Italic**.
- **Size** – select or enter the font size that you want to apply. For scalable fonts, you can also enter decimal values. If you are creating a style that is based on another style, you can enter a percentage value or a point value (for example, 2pt or 5pt).
- **Language** – sets the language that the spelling checker to use. The spelling checker works only when you have installed the corresponding language module. A language entry has a check mark in front of it if the spelling checker is activated for that language.
- **Features** – some fonts offer special features such as Discretionary ligatures and Horizontal Kerning. Click this button to select those features.
- **Preview** – displays a preview of the current selection.
**Font Effects tab**

![Cell Style dialog – Font Effects tab](image)

- **Font color** – sets the color for the text. If you select *Automatic*, the text color is set to black for light backgrounds and to white for dark backgrounds.
- **Relief** – select a relief effect to apply to the text. The *Embossed* relief makes the characters appear as if they are raised above the page. The *Engraved* relief makes the characters appear as if they are pressed into the page.
- **Outline** – displays the outline of the characters. This effect does not work with every font.
- **Shadow** – adds a shadow that casts below and to the right of the characters.
- **Overlining** – select the overlining style that you want to apply. To apply the overlining to words only (not the spaces between them), select *Individual words*.
- **Overline color** – select the color for the overlining. *Automatic* matches the font color.
- **Strikethrough** – select the strikethrough style for the selected text.
- **Underlining** – select the underlining style that you want to apply. To apply the underlining to words only (not the spaces between them), select *Individual words*.
  
  If you apply underlining to a superscript text, the underlining is raised to the level of the superscript. If the superscript is contained in a word with normal text, the underlining is not raised.
- **Underline color** – select the color for the underlining. *Automatic* matches the font color.
- **Individual words** – applies the selected effect only to words and ignores spaces.
- **Preview** – displays a preview of the current selection.
Alignment tab

Figure 155: Cell Style dialog – Alignment tab

- **Text Alignment** – sets the alignment options for the contents of the current cell, or the selected cells.
  - **Horizontal** – select the horizontal alignment option that you want to apply to the cell contents.
    - **Default** – aligns numbers to the right and text to the left.
    - **Left** – aligns the contents of the cell to the left.
    - **Center** – horizontally centers the contents of the cell.
    - **Right** – aligns the contents of the cell to the right.
    - **Justified** – aligns the contents of the cell to the left and to the right cell borders.
    - **Filled** – repeats the cell contents (number and text) until the visible area of the cell is filled. This feature does not work on text that contains line breaks.
    - **Distributed** – aligns contents evenly across the whole cell. Unlike **Justified**, it also justifies the very last line of text.
  - **Indent** – indents from the left edge of the cell by the amount that you enter.
  - **Vertical** – select the vertical alignment option that you want to apply to the cell contents.
    - **Default** – aligns the cell contents to the bottom of the cell.
    - **Top** – aligns the contents of the cell to the upper edge of the cell.
    - **Bottom** – aligns the contents of the cell to the lower edge of the cell.
    - **Middle** – vertically centers the contents of the cell.
    - **Justified** – aligns the contents of the cell to the top and to the bottom cell borders.
    - **Distributed** – aligns contents evenly across the whole cell. Unlike **Justified**, it also justifies the very last line of text.

164 | Creating new (custom) styles
• **Text Orientation** – defines the text direction of cell contents.
  - *ABCD wheel* – click anywhere in the wheel to define the text orientation. The characters "ABCD" on the wheel correspond to the new setting.
  - *Vertically stacked* – assigns vertical text orientation for cell contents.
  - *Degrees* – allows you to manually enter the orientation angle. A positive number rotates the text to the left and a negative number rotates the text to the right.
  - *Reference edge* – specify the cell edge from which to write the rotated text.
    - *Text Extension From Lower Cell Border* – writes the rotated text from the bottom cell edge outwards.
    - *Text Extension From Upper Cell Border* – writes the rotated text from the top cell edge outwards.
    - *Text Extension Inside Cell* – writes the rotated text only within the cell.

• **Properties** – determine the text flow in a cell.
  - *Wrap text automatically* – wraps text onto another line at the cell border. The number of lines depends on the width of the cell. To enter a manual line break, press Ctrl+Enter in the cell.
  - *Hyphenation active* – enables word hyphenation for text wrapping to the next line.
  - *Shrink to fit cell size* – reduces the apparent size of the font so that the contents of the cell fit into the current cell width. You cannot apply this command to a cell that contains line breaks.
  - *Text direction* – choices are Left-to-right, Right-to-left, and Use superordinate object settings (the settings applied to the preceding cell).

**Borders tab**

![Borders tab](image)

**Figure 156: Cell Style dialog – Borders tab**
Sets the border attributes for the selected cells.

- **Line Arrangement** – select a preset border style or define your own combination by clicking in the diagram.
- **Line** – select the line style, width, and color that you want to apply. The style is applied to the borders selected in the preview.
- **Padding** – specify the amount of space that you want to leave between the border and the contents of the cell. You can set each distance (left, right, top, bottom) individually or select **Synchronize** to apply the same padding to all four borders when you enter a new distance.
- **Shadow Style** – applies a shadow effect to borders. You can specify the position of the shadow (top, bottom, right, or left side), the distance it extends, and its color.

**Background tab**

Click **Color** to select a color to use as a background for the formatted cells. You can choose from several palettes. To change the color, select another one. To remove the background color, select **None**.

---

**Figure 157: Cell Style dialog – Background tab**

---

**Cell Protection tab**

**Protection**

- **Hide all** – hides formulas and contents of the selected cells.
- **Protected** – prevents the selected cells from being modified. This cell protection only takes effect if you also protect the sheet.
- **Hide formula** – hides formulas in the selected cells.

**Print**

- **Hide when printing** – prevents the selected cells from being printed.
Figure 158: Cell Style dialog – Cell protection tab

**Resetting cell style attributes**

The buttons at the bottom of cell style dialog have the following functions:

- **Reset** – returns to last saved settings for all tabs of this dialog.
- **Standard** – returns to the settings in the template for the current dialog tab only.
- **Cancel** – cancels any changes made (to all tabs in the dialog) since the last save of this dialog (by clicking **OK**).
- **OK** – saves all changes made (to all tabs in the dialog).

**Page style attributes**

The following attributes are available on the tabs of the Page Style dialog (Figure 160).

**Organizer tab**

This tab is similar to the Organizer tab for cell styles.

- **Name** – displays the name of the selected style. If you are creating or modifying a custom style, you can enter or change a name of the style. You cannot change the name of a predefined style.
- **Category** – displays the category of the current style. If you are creating a new style, select **Custom Styles** from the list. You cannot change the category for a predefined style.
- **Contains** – describes the formatting used in the current style.

**Page tab**

You can define page layouts for single and multiple-page spreadsheets, as well as page numbering and paper formats.

- **Paper format** – select from a list of predefined paper sizes, or define a custom paper format.
  - **Format** – select a predefined paper size, or create a custom format by entering the dimensions for the paper in the **Height** and **Width** boxes.
  - **Width** – displays the width of the selected paper format. To define a custom (user) format, enter a width here.
  - **Height** – displays the height of the selected paper format. To define a custom (user) format, enter a height here.
  - **Orientation**:  
    - **Portrait** – displays and prints the spreadsheet with the paper oriented vertically.
    - **Landscape** – displays and prints the spreadsheet with the paper oriented horizontally.
Figure 159: Page Style dialog

- **Paper tray** – select the paper source for your printer. You can assign different paper trays to different page styles. For example, you can assign a different tray for the first page style in the spreadsheet and load the tray with your company letterhead paper.

- **Margins** – specify the amount of space to leave between the edges of the paper and the spreadsheet contents.
  - **Left/Inner** – the space between the left edge of the page and the spreadsheet. If you are using *Mirrored* page layout, the space between the inner edge of the paper and the spreadsheet. You may want to have a wider space as the Left/Inner margin if you will be punching or binding the pages.
  - **Right/Outer** – the space between the right edge of the paper and the spreadsheet. If you are using *Mirrored* page layout, the space between the outer edge of the paper and the spreadsheet.
  - **Top** – the space between the upper edge of the paper and the spreadsheet.
  - **Bottom** – the space between the lower edge of the paper and the spreadsheet.

- **Layout settings** – select the page layout style to use for the spreadsheet.
  - **Page layout:**
    - *Right and left* – both odd (right) and even (left) pages have the same margins on all four sides.
    - *Mirrored* – odd and even pages with inner and outer margins as specified. Use this layout if you want to bind the printed pages like a book. Enter the binding space as the Inner margin.
    - *Only right* – To specify different (but not mirrored) layouts for odd and even pages, define separate page styles. This one is for right (odd) pages.
    - *Only left* – To specify the layout for left (even) pages, choose this setting.
– **Page numbers** – select the page numbering format to use for the page style. Typically this will be 1,2,3 or a,b,c or i,ii,iii.

– **Table alignment:**

  * **Horizontal** – centers the cells horizontally on the printed page.
  * **Vertical** – centers the cells vertically on the printed page.

**Borders and Background tabs**
See the Cell styles “Borders tab” and “Background tab” in “Cell style attributes” above for information on how to set the borders and background for page styles. Page styles can have a bitmap background or a color.

**Header and Footer tabs**
Adds a header or footer to the page style. A header is an area in the top page margin where you can add text or graphics. A footer is a similar area in the bottom page margin. See Chapter 6, Printing, Exporting, and Emailing, for details.

**Sheet tab**
Specifies the elements to be included in the printout of all sheets with the page style. Additionally, you can set the print order, the first page number, and the page scale. See Chapter 6, Printing, Exporting, and Emailing, for details.

**Managing styles**

**Modifying styles**

1) Go to the Styles panel in the Sidebar and click the icon for the type of style you want to modify.

2) Right-click on the name of the style and select **Modify** from the context menu to open either the Cell Style dialog (Figure 152) or the Page Style dialog (Figure 154).

3) Make the necessary changes to the style attributes. For more information on style attributes, see “Cell style attributes” on page 166 and “Page style attributes” on page 173.

4) Click **OK** to save the changes and close the dialog.

**Note**

The Modify command is unavailable if one or more sheets are protected, even if the style to be modified is being used in an unprotected sheet.

**Renaming styles**
You can rename custom styles, but not the styles supplied with LibreOffice.

1) Go to the Styles panel in the Sidebar (Figure 147) and click the icon for the type of style you want to rename.

2) Right-click on the style you want to rename and select **Modify** from the context menu. The Styles dialog opens.

3) On the Organizer page, rename the style and click **OK**.

**Deleting styles**
You can delete custom styles, but not the styles supplied with LibreOffice.
1) Go to the Styles panel in the Sidebar (Figure 147) and click the icon for the type of style you want to delete.

2) Right-click on the style you want to delete and select Delete from the context menu.

3) Select Yes on the warning message. Any data in a cell or a sheet in the spreadsheet that used the deleted style will revert to the Default style.

**Hiding and showing cell styles**

You can shorten the list of cell styles by hiding some of them. Only styles that are not being used in the spreadsheet can be hidden.

1) Go to the Styles panel in the Sidebar and click on the Cell Styles icon.

2) Right-click on an unused cell style and select Hide from the context menu. The style is then moved to the Hidden Styles category in the Styles panel.

To show hidden cell styles:

1) Go to the Styles panel in the Sidebar.

2) Click on the drop-down list at the bottom of the panel and select Hidden Styles from the list.

3) Right-click on the hidden style you want to show and select Show from the context menu.

**Filtering the list of styles**

You can filter the list of styles as follows:

1) Go to the Styles panel in the Sidebar.

2) Click on the drop-down list at the bottom of the panel.

3) Select the category of styles to display in the Styles panel:
   - **Hierarchical** – lists the styles in their hierarchical relationship, for example Heading 1 and Heading 2 under Heading, or Accent 1, Accent 2, Accent 3 under Accent.
   - **All Styles** – lists all the styles that are available in Calc and in the spreadsheet, except for Hidden Styles.
   - **Hidden Styles** – lists all the styles that have been hidden in the spreadsheet.
   - **Applied Styles** – lists only the styles that have been applied to the spreadsheet.
   - **Custom Styles** – lists only the user-defined styles defined for the spreadsheet.

**What is a template? Why use one?**

A template is a model that you use to create other documents in a standard format. For example, you can create a template for invoices that has your company logo and address at the top of the page. This means that any new spreadsheets (invoices) created from this template will then have the company logo and address on the first page of the spreadsheet.

Templates can contain anything that regular documents can contain, such as text, graphics, styles, and user-specific setup information such as measurement units, language, default printer, and toolbar and menu customization.

All documents in LibreOffice are based on templates. You can create, or download and install, as many templates as you wish. If you do not specify a template when you start a new spreadsheet, any new spreadsheet is then based on the default template for spreadsheets that is included with LibreOffice Calc. This default template consists of a blank spreadsheet which you can customize to your needs and then, if you wish, use as a basis to create a custom default template.
Using a template to create a spreadsheet

A new installation of LibreOffice may not include any spreadsheet templates, but you can create your own (see “Creating a template” on page 178) or install templates obtained from other sources (see “Adding templates obtained from other sources” on page 179).

When you do have a spreadsheet template available, you can create a new spreadsheet from it using either the Templates dialog or the LibreOffice Start Center.

Creating a spreadsheet from the Templates dialog

To use a template to create a spreadsheet:

1) From the Menu bar, choose File > New > Templates or click the small arrow next to the New icon and select Templates. The Templates dialog (Figure 160) opens.

2) From the Filter list at the top of the Templates dialog, select Spreadsheets and the category of template you want to use. All the templates in that category are then listed on the page, as shown in Figure 160.

3) Select the required template and click Open, or double-click the selected template. A new spreadsheet based on the template opens in LibreOffice.

In the spreadsheet, the template it is based upon is listed in File > Properties > General. The connection between the template and the spreadsheet remains until the template is modified and, the next time that the spreadsheet is opened, you choose not to update it to match the template.

![Figure 160: Templates dialog, showing a selected template](image)

Creating a spreadsheet from a template in the Start Center

You can create a spreadsheet from the Template view of the LibreOffice Start Center, which is visible when no other document is open. (See Chapter 1, Introducing Calc.)

To open the Templates dialog from the Start Center, click the Templates button in the left pane. The button is also a drop-down list to select the templates of a given type of document. The Calc Templates option on the list opens the Templates dialog on the Spreadsheets tab.
Creating a template

You can easily create a template from any spreadsheet:

1) Open a new or existing spreadsheet that you want to use as a base for the template.
2) Add any necessary pre-defined content that you want to appear in a spreadsheet each time you use the new template, for example company logo and name, company information, page numbers, and so on. Delete any information that you do not want in the template.
3) Create or modify the cell and page styles that you want to use in the template.
4) From the Menu bar, choose File > Templates > Save as Template. The Save As Template dialog (Figure 162) opens, displaying the existing template categories and a name box.
5) Type a name for the new template and select the required template category. You can also choose to make this the default template (see “Setting the default template category” on page 180 for more information).
6) Click Save to save the new template.

![Save As Template dialog](image)

**Figure 161: Save As Template dialog**

**Note**

Although the Save as Template dialog shows no document type when saving a new template of any type, the template will appear on the correct tab (Spreadsheets, in this case) when you return to the Templates dialog.

It is unnecessary to save or do anything further with the spreadsheet file you have been using to create the new template. It can be safely closed without saving.

Editing a template

You can edit a template’s styles and content, and then, if you wish, you can reapply the template’s styles to spreadsheets that were created from that template. You cannot reapply content.
To edit a template:

1) From the Menu bar, choose **File > Templates > Manage Templates** to open the Templates dialog.
2) Navigate to the template that you want to edit. Right-click to open the context menu and choose **Edit** (see Figure 162). The template opens in Calc.
3) Edit the template as you would edit any other spreadsheet. To save the changes, choose **File > Save** from the Menu bar, or choose **File > Save As Template** to save the edited template as a new template.

### Updating styles from a changed template

If you make any changes to a template and its styles, the next time you open a spreadsheet that was created before you changed the template, a confirmation message is displayed.

1) Click **Update Styles** to apply the changed styles in the template to the spreadsheet.
2) Click **Keep Old Styles** if you do not want to apply the changed styles in the template to the spreadsheet.

**Caution**

If you select **Keep Old Styles**, the confirmation message will not appear again the next time you open the spreadsheet using the same changed template. Although the template is still listed under **File > Properties > General**, the spreadsheet is no longer connected to the template, so it will not update. You can still import styles manually from the template, but to reconnect the spreadsheet to the template, you will have to copy it into an empty document based on the template.

### Adding templates obtained from other sources

You can get to the official LibreOffice template repository by using the **Browse online templates** button in the lower left of the Templates dialog, as shown in Figure 163, or by typing https://extensions.libreoffice.org/templates in your browser’s address bar.
On other websites you may find collections of templates that have been packaged into extension (.OXT) files. These are installed a little differently, as described below.

![Figure 163: Getting more templates for LibreOffice]

**Installing individual templates**

You can import and add templates to your collection as follows:

1) Find and download the template you want to use, as described in the previous section.
2) Open the Templates dialog and click the **Import** icon near the bottom right.
3) In the pop-up dialog, select the category where you want to store the template. (You can change this later, as described in “Moving a template” on page 183.)
4) A file browser open. Navigate to the location of the downloaded template on your computer.
5) Select the template and click **Open**. After import, the template becomes available in the Templates dialog.

**Tip**

You can manually copy new templates into the template folders. The location varies with your computer’s operating system. To learn where the template folders are stored on your computer, go to **Tools > Options > LibreOffice > Paths**.

**Installing collections of templates**

The Extension Manager provides an easy way to install collections of templates that have been packaged as extensions. Follow these steps:

1) Download the extension package (.OXT file) and save it anywhere on your computer.
2) In LibreOffice, select **Tools > Extension Manager** from the Menu bar. In the Extension Manager dialog, click **Add** to open a file browser window.
3) Find and select the package of templates you want to install and click **Open**. The package begins installing. You may be asked to accept a license agreement.
4) When the package installation is complete, restart LibreOffice. The templates are available for use through **File > Templates > Manage Templates** and **File > New > Templates** and the extension is listed in the Extension Manager.

See Chapter 14, Setting up and Customizing Calc, for more about the Extension Manager.

**Tip**

Some extensions are packaged as .ZIP files.

**Setting the default template**

If you create a new spreadsheet using **File > New > Spreadsheet** on the Menu bar, Calc creates the document from the default template for spreadsheets. You can set any template as the default template. You can also reset the default template to the Calc default template.
Setting a template as the default

Most default settings, such as page size and page margins, can be changed in Tools > Options, but those changes apply only to the spreadsheet you are working on. To make those changes the default settings for spreadsheets, you need to replace the default Calc template with a new one.

You can set any template displayed in the Templates dialog to be the default for that document type:

1) From the Menu bar, choose File > Templates > Manage Templates.
2) In the Templates dialog, open the category containing the template that you want to set as the default, then select the template.
3) Right-click on the selected template and click the Set As Default button (see Figure 162). The template is now indicated by a green check mark in the upper left.

The next time you create a spreadsheet by choosing File > New, it will be created from this template.

Resetting the default template

To set the default spreadsheet template back to the default template supplied with Calc:

1) In the Templates dialog, click the Settings icon on the bottom left (Figure ).
2) Point to Reset Default Template on the drop-down menu, and click Spreadsheet. The green check mark is removed from the template.

This choice does not appear unless a custom template has been set as the default, as described in the previous section.

![Figure 164: Resetting the default template for spreadsheets](image)

You can also reset the default template as follows:

1) Go to the Templates dialog and open the category containing the template you set as default. It is indicated by a green check mark.
2) Right-click on this template and select Reset Default Template > Spreadsheet from the context menu (see Figure 164). The next time that you create a new spreadsheet, it will be created using the Calc default template.

Note

Resetting the default template back to the Calc default template is only available if the default has been changed previously.
Organizing templates

LibreOffice can manage only templates that are in its template folders (categories), although you can create a spreadsheet from a template that is not in one of these folders. You can create new template folders and use them to organize your templates and import templates into these folders. For example, you might have one template folder for sales templates and another for invoice templates. You can also export templates.

Tip

The location of template folders in LibreOffice depends on the operating system of your computer. If you want to know where the template folders are located, go to Tools > Options > LibreOffice > Paths.

To begin, choose File > Templates > Manage Templates to open the Templates dialog.

Creating a template category

1) Click the Settings button in the lower left of the Templates dialog.
2) Click New Category on the context menu (see Figure 165).
3) In the pop-up dialog (not shown), type a name for the new category and click OK. The new category now appears in the list of categories.

Figure 165: Creating a new category

Note

You cannot create a sub-category inside a template category in LibreOffice.

Deleting a template category

You cannot delete template categories supplied with LibreOffice. Nor can you delete any categories added by the Extension Manager unless you first remove the extension that installed them.

However, you can delete a category that you created:

1) Open the Templates dialog and choose the category from the Filter drop-down lists at the top of the dialog.
2) Click the Settings button and select Delete Category from the context menu (see Figure 165). When a message box appears asking you to confirm the deletion, click Yes.
Moving a template

To move a template from one template category to another:

1) Open the Templates dialog and select the template you want to move.
2) Click the Move icon near the bottom of the dialog, select the destination category from the popup dialog (Figure 166), and click OK. The selected template is moved to the folder. You can also create a new category into which to move the template.

![Figure 166: Moving a template to another category](image)

Deleting a template

You cannot delete templates supplied with LibreOffice. Nor can you delete any templates installed by the Extension Manager except by removing the extension that installed them. You can only delete templates that you have created or imported.

1) From the Filter drop-down lists at the top of the Templates dialog, select the category that contains the template you want to delete.
2) Select the template to delete.
3) Right-click on the template to open the context menu and click Delete (Figure 162).
4) A message box appears and asks you to confirm the deletion. Click Yes.

Exporting a template

The easiest way to send a template to someone else, or to store it on a network, is to export it:

1) Open the Templates dialog and find the template that you want to export.
2) Select the template and click the Export icon.
3) The Save As dialog opens. Navigate to the location where you want to export the template and click Save. You can also rename the template.

**Note**

Exporting a template does not remove it from the Templates dialog. The action places a copy of the template in the location you specify.
Chapter 5
Using Graphics in Calc
Introduction

Calc is used to present and analyze data and to make forecasts and predictions. Graphics can turn an average spreadsheet into a more memorable document. Calc can import various vector (line drawing) and raster (bitmap or photo) file formats. The most commonly used graphic formats are GIF, JPG, and PNG. See LibreOffice Help for a full list of the formats that Calc can import.

Graphics in Calc are of three basic types:
- Image files, such as photographs, drawings, and scanned images
- Diagrams created using LibreOffice's drawing tools
- Charts and graphs created using LibreOffice's Chart facility; see Chapter 3, Creating Charts and Graphs, for more information

Using graphics in Calc is similar to using graphics in other components of LibreOffice. For more detailed descriptions, please refer to the Getting Started Guide or the Draw Guide.

Note

In LibreOffice, the terms graphics and images refer to both pictures and drawing objects. Often the word images is used when referring to pictures and other graphics that are not drawing objects.

Adding graphics (images) to a spreadsheet

Graphics or images (sometimes called pictures in LibreOffice), such as corporate logos and photographs, are probably the most common types of graphics added to a spreadsheet. They may be downloaded from the Internet, scanned, created with a graphics program, photographs taken with a digital camera, or clip art in the Gallery.

Inserting an image file

When the image is in a file stored on the computer, you can insert it into a spreadsheet using either of the following methods.

Drag and drop

1) Open a file browser window and locate the image you want to insert.
2) Drag the image into the spreadsheet and drop it where you want it to appear. A faint vertical line marks where the image will be dropped.

This method embeds (saves a copy of) the image file in the document. To link the file instead of embedding it, hold down the Ctrl+Shift keys while dragging the image.

Insert Image dialog

1) Click in the spreadsheet where you want the image to appear.
2) Choose Insert > Image from the Menu bar.
3) On the Insert Image dialog (Figure 167), navigate to the file to be inserted, and select it.
4) At the bottom of the dialog is an Insert as Link option. See page 187 for the use of links.
5) Click Open. The file is inserted into the spreadsheet as a floating image and is anchored to the cell in which the cursor was placed.
The Insert Image dialog may look different from the one shown in Figure 167, depending on your operating system.

**Note**

The Insert Image dialog may look different from the one shown in Figure 167, depending on your operating system.

**Linking or embedding an image file**

Embedding an image into a spreadsheet makes the image a permanent part of the spreadsheet file. Any changes you make to an embedded image will appear only in that spreadsheet; the original image will not be affected.

If you select the **Insert as Link** option in the Insert Image dialog, LibreOffice creates a link to the file containing the image instead of embedding it. The image is displayed in the document, but when the document is saved, it contains only a reference to the image file, not the image itself. The document and the image remain as two separate files, and they are merged together only when you open the document again.

Linking an image has two advantages and one disadvantage:

- **Advantage** – You can modify the image file separately. The modified image will appear when you next open the spreadsheet. This can be a big advantage if you (or someone else, perhaps a graphic artist) is updating images.

- **Advantage** – Linking can reduce the file size of the spreadsheet when it is saved, because the image file itself is not included. However, file size is usually not a problem on modern computers, and Calc can easily handle large files.

- **Disadvantage** – If you send the document to someone else, or move it to a different computer, you must also send the image files and keep the same file structure. For example, you might keep image files in a subfolder named Images inside the same folder containing the Calc document. Any recipient of the spreadsheet needs to put the image files in a subfolder with the same name in the same named folder as the spreadsheet.
When inserting the same image several times in a document, it might appear beneficial to create links. However, this is not necessary, as LibreOffice embeds only one copy of the image file in the document. Deleting one or more of the copies does not affect the other copies of the same file.

**Embedding linked images**

If you originally linked the images, you can easily embed one or more of them later.

1) Open the spreadsheet in Calc.
2) Choose **Edit > Links to External Files** on the Menu bar to open the Edit Links dialog (Figure 168), which shows all the linked files.

1. Source file: `file:///Users/jean/Pictures/2014-01-03/IMG_20140211_165808.jpg`
2. Type: Image

![Edit Links dialog](image)

3) Select the files you want to change from linked to embedded.
4) Click **Break Link** and confirm you want to remove the selected link. The file then becomes embedded into the spreadsheet.

**Note**

Going from embedded to linked images is not so easy. You must replace them one at a time, selecting the **Insert as Link** option when you reinsert each file.

**Inserting an image from the clipboard**

Using the clipboard, you can copy images into a Calc spreadsheet from another LibreOffice document and from other programs. To do this:

1) Open both the source document and the target document.
2) In the source document, right-click on the image to be copied and select **Copy** from the context menu.
3) Switch to the target document. Click to place the cursor in the cell where the image is to be anchored. Right-click and select **Paste** to insert the image.

**Caution**

If the application from which the image was copied is closed before the image is pasted into the target, the image stored on the clipboard could be lost.
Inserting an image using a scanner

If a scanner is connected to your computer, LibreOffice can call the scanning application and insert the scanned item into the LibreOffice document as an image. To start this procedure, choose Insert > Media > Scan > Select Source. After selecting the scanner, place the cursor where you want the image to be inserted, and choose Insert > Media > Scan > Request.

Although this practice is quick and easy, it is unlikely to result in a high-quality image of the correct size. You may get better results by passing scanned material into a graphics program and cleaning it up there before inserting the resulting image into LibreOffice.

Inserting an image from the Gallery

The Gallery (Figure 169) provides a convenient way to group reusable objects such as images and sounds that you can insert into your documents. The Gallery is available in all components of LibreOffice. You can add your own images as well as using the ones supplied with LibreOffice. For more information, see the Getting Started Guide Chapter 11, Graphics, the Gallery, and Fontwork.

![Figure 169: The Gallery in the Sidebar](image)

To insert an image from the Gallery:

1) Click the Gallery icon in the Sidebar.
2) Select a theme.
3) Select an object with a single click.
4) Drag and drop the image into the document.
   
   You can also right-click on the object and choose Insert.

Note

To insert an image as a link, hold down the Shift and Ctrl keys while dragging the object into the document.
Modifying images

When you insert a new image, you may need to modify it to suit the document. Any changes made in Calc do not affect the original image, whether it is an embedded or linked image file.

Calc provides several tools for working with images. These tools are sufficient for most requirements. However, for professional results it is generally better to use LibreOffice Draw or other software designed to modify image files, and then insert the result into Calc.

Using the Image toolbar

When you insert an image or select one already present in the spreadsheet, the Image toolbar replaces the Formatting toolbar. If it does not appear, go to View > Toolbars > Image on the Menu bar. The tools available on the Image toolbar are described below.

Note

Image properties selections affect only the display and printing of the image. The original image file remains unchanged.

- **Anchor** – choose between anchoring the image to a cell or to a page. See “Anchoring images” on page 193.
- **Align** – if two or more images are selected, you can adjust the horizontal and vertical alignment of the images in relation to each other. See “Aligning images” on page 193.
- Six buttons for arrangement (the position of images in the stacking order): **Bring to Front, Forward One, Back One, Send to Back, To Background**. See “Arranging images” on page 192.
- **Line Style, Line Width, Line Color** – set the attributes of the border around the image.
- **Area Style/Filling** – sets the color or other characteristics of the background area that contains the image, not the image itself. To see the background, you must set the transparency of the image to a suitably high value. See the Draw Guide for more information on how to modify areas.
- **Shadow** – sets the default shadow effect around the image. To adjust the shadow effect, open the Area dialog and choose the Shadow tab.
- **Filter** – opens the Image Filter toolbar. See the Draw Guide for details on image filters.
- **Image Mode** – changes the display of the image from color to grayscale, black and white, or a watermark. This setting affects only the display and printing of the image; the original image file remains unchanged.
- **Crop** – places cropping handles around the image. Drag a handle to crop (hide) the edges of the image.
- **Flip Horizontally and Flip Vertically** – changes the orientation of the image.
- **Rotate** – places rotation handles around the image.
- **Transparency** – adjusts the degree of transparency of the picture between 0% (opaque) and 100% (fully transparent).
- **Color** – opens the Color toolbar to adjust the values of the Red, Green, Blue colors, brightness, contrast and Gamma.

Using the Properties pane in the Sidebar

Some of the settings in the Image toolbar are also available in the Properties pane in the Sidebar when an image is selected. These include the **Color, Line, and Transparency** settings.
Adding text

You can add text to an image or drawing object. That text will move with the image when the image is repositioned. For more information on adding text to images, see the Draw Guide.

1) Double-click on the image. The text cursor flashes in the center of the image. The Text Formatting toolbar automatically opens at the top of the spreadsheet.

Figure 170: Text Formatting toolbar for images

2) Type your text and use the tools on the Text Formatting toolbar to format it. Most of the tools are the same as those for formatting text in cells.

3) To adjust the position of the text or how it appears in the image, right-click on the image and select Text from the context menu to open the Text dialog (Figure 171).

Figure 171: Text dialog

4) Make any necessary changes and click OK to close the dialog.

Positioning, resizing, and arranging images

Using the mouse

To move an image to a new position in your spreadsheet, click on the image and drag it to a new position. The image will still be anchored to the cell or page it was originally anchored to.

To resize an image:

1) Click on the image to display the selection handles.

2) Position the cursor over one of the selection handles. The cursor changes shape, giving a graphical representation of the direction of the resizing. The corner handles resize both the width and the height of the image simultaneously. The top, bottom, left and right handles only resize one dimension at a time.

3) Click and drag to resize the image.

Tip

To retain the original proportions of the image, Shift+click one of the corner handles, then drag.
Using the Position and Size dialog

To accurately position and size an image in your spreadsheet, go to **Format > Object > Position and Size** on the Menu bar, or right-click on an image and select **Position and Size** from the context menu.

On the Position and Size tab (Figure 172), you can set these values:

- **Position** – the location of the selected image on the spreadsheet.
  - *Position X* – the horizontal distance from the base point selected in the grid.
  - *Position Y* – the vertical distance from the base point selected in the grid.

- **Size** – the width and height of the image with respect to the selected base point.
- **Protect** – To prevent accidental movement or resizing of the image, select the relevant option.

The units of measurement used for X/Y coordinates and the width and height of the image are set by going to **Tools > Options > LibreOffice Draw > General**.

The default location of the base points for position and size is the upper left corner of the spreadsheet. You can temporarily change this base point to make positioning or dimensioning simpler by clicking on a position corresponding to the location of the base point you want to use. This change in base point is only valid for single use and the base point is reset to the standard position of top left corner when you close the Position and Size dialog.

You can also rotate or slant an image (using the **Rotation** or **Slant & Corner Radius** tabs of the Position and Size dialog). See the **Draw Guide** for details.

Arranging images

Each image that you place in a spreadsheet is successively stacked on the preceding image, whether or not they overlap. Use the arrange commands to change the stacking order of images. You cannot change the stacking order of text.

1) Select the image you want to change.
2) Go to **Format > Arrange** on the Menu bar, or right-click on the image and select one of the arrangement options described below.
3) Alternatively, click on the Bring to Front icon or the Send to Back icon on the Image toolbar to quickly move the image to the front or rear of the stack.

The arrangement options are as follows:

- **Bring to Front** – moves the selected image to the top of the stacking order, so that it is in front of other images.
- **Forward One** – moves the selected image up one level, so that it is closer to top of the stacking order. Not available on the Picture toolbar.
- **Back One** – moves the selected image down one level, so that it is closer to the bottom of the stacking order. Not available on the Image toolbar.
- **Send to Back** – moves the selected image to the bottom of the stacking order, so that it is behind the other images.
- **To Foreground** – moves the selected image in front of text.
- **To Background** – moves the selected image behind text. To select a background image so that you can modify or replace it, you have to use the Navigator. Other methods of selection, such as clicking or double-clicking, do not work.

### Anchoring images

Anchors images so they stay in their position in relation to other items.

- **To Page** – anchor an image to the page to position it in a specific place. The image does not move when cells are added or deleted; it will always stay in the same position on the page where it is placed.
- **To Cell** – anchor an image to a cell to ensure that the image always stays with the content it is originally anchored to. If an image is anchored to cell B10, and a new row is inserted above row 10, the image will then be anchored to cell B11.

To anchor an image or change the type of anchor used:

- Go to **Format > Anchor > To Page** or **To Cell** on the Menu bar, or right-click on the image and select **Anchor > To Page** or **To Cell** from the context menu.
- Alternatively, click on the **Change Anchor** icon on the Image toolbar and the anchor type will toggle between **To Page** or **To Cell**.

### Aligning images

When you have more than one image in your spreadsheet, you can align these images to give your spreadsheet a more professional look. The options include three for aligning the images horizontally (left, centered, right) and three for aligning the images vertically (top, center, bottom).

1) Select all of the images to be aligned.
2) Go to **Format > Align** on the Menu bar, or right-click on the image and select **Align** from the context menu, or click on the **Alignment** icon on the Picture toolbar.
3) Select one of the six options available for alignment.

### Grouping and ungrouping images

To group several images so that they become a single object in the spreadsheet:

1) Select the images you want to group (select one and hold down the Shift key while selecting others).
2) Go to **Format > Group > Group** on the Menu bar, or right-click on the selected images and select **Group** from the context menu.
To ungroup images:
1) Select the image group you want to ungroup.
2) Go to Format > Group > Ungroup on the Menu bar, or right-click on the selected images and select Ungroup from the context menu.

To edit an image in a group:
1) Select the image group where you want to edit an image within the group.
2) Go to Format > Group > Enter Group on the Menu bar, or right-click on the selected images and select Enter Group from the context menu.
3) Select the image you want to make changes to and make the changes.
4) Go to Format > Group > Exit Group on the Menu bar, or right-click on the selected images and select Exit Group from the context menu.

Using LibreOffice’s drawing tools
Calc, like all other components of LibreOffice, has a range of tools to create drawings such as simple diagrams, using rectangles, circles, lines, text, and other shapes. You can group several drawing objects to make sure they maintain their relative position and proportion if you move or resize them.

You can also use the drawing tools to annotate photographs, screen captures, or other illustrations produced by other programs, but this is not recommended because you cannot include images in a group with drawing objects, so they may not remain aligned in the document. If you need to create complex drawings, it is recommended to use LibreOffice Draw and then insert the drawing into your spreadsheet. For a more detailed explanation, see the Draw Guide.

Drawing toolbar
To begin using the drawing tools, go to View > Toolbars > Drawing to open the Drawing toolbar, which appears in its default position at the bottom of the spreadsheet. You can make this toolbar a floating toolbar and move it to a convenient position.

When the Drawing toolbar opens, it opens with a default set of tools as shown in Figure 173. Hover the mouse pointer over a tool to see a tooltip describing its function. Tools with small arrows to the right side open with palettes of tools. To add tools to the Drawing toolbar, right-click in an empty area on the toolbar and select Visible Buttons from the context menu.

Figure 173: Drawing toolbar

To use a drawing tool:
1) Click in the document where you want the drawing to be anchored. You can change the anchor later, if necessary.
2) Choose the tool from the Drawing toolbar (Figure 173). The mouse pointer changes to a drawing-functions pointer and the normal Formatting Toolbar changes to Drawing Object Properties toolbar (Figure 174).
3) Move the cross-hair pointer to the place in the document where you want the drawing object to appear and then click and drag to create the object. Release the mouse button. The selected drawing function remains active, so that you can draw another object of the same type.
4) To cancel the selected drawing function, press the Esc key or click on the Select icon (the arrow) on the Drawing toolbar.
5) You can now change the properties (fill color, line type and weight, anchoring, and others) of the drawing object using the Drawing Object Properties toolbar (Figure 174), the Properties pane in the Sidebar, or the choices reached by right-clicking on the drawing object.

**Setting the properties of drawing objects**

For more information on the properties of drawing objects, see the *Draw Guide*.

You can set some default properties for a drawing object before you draw an object. These default properties are applied only to the current spreadsheet and are not retained when you close the spreadsheet. The properties apply only to drawing objects.

1) Click **Select** on the Drawing toolbar (Figure 173).

2) On the Drawing Object Properties toolbar (Figure 174), set the values you want to use for each property. When you select area or line properties, dialogs open where you can set the values used for area or line.

   ![Drawing Object Properties toolbar](image)

   **Figure 174: Drawing Object Properties toolbar**

3) After you draw an object or group it with another object, more properties become active. These appear on the toolbar (Figure 175) and some are shown in the Properties pane of the Sidebar (Figure 176).

   ![Drawing Object Properties toolbar after inserting an object](image)

   **Figure 175: Drawing Object Properties toolbar after inserting an object**

   ![Drawing Object Properties in Sidebar](image)

   **Figure 176: Drawing Object Properties in Sidebar**

---

188 | Using LibreOffice’s drawing tools
You can change the properties of an existing drawing object (fill color, line type and weight, anchoring, and so on) using the Drawing Object Properties toolbar (Figure 174), the Properties pane in the Sidebar, or the context menu when you right-click on the drawing object.

**Resizing drawing objects**
Select the object and click on one of the selection handles then drag the object to its new size. For a scaled resizing, select one of the corner handles and keep the Shift key pressed while dragging the handle. For more information, see “Positioning, resizing, and arranging images” on page 191.

**Grouping and ungrouping drawing objects**
For grouping, ungrouping, and editing grouped drawing objects, see “Grouping and ungrouping images” on page 193.

**Additional tools**
Some additional tools are available when you right-click on an image or drawing object and open the context menu.

**Description**
You can add metadata in the form of a title and description to an image. This information is used by accessibility tools (such as screen reader software) and as ALT (alternative text) attributes if you export the document to HTML.

**Name**
You can add a custom name to be assigned to an image; this will make the image easier to find in the Navigator. Also, assigning names to images helps identify them when teams of people are working on the same multi-page spreadsheet.

**Rotate or Flip**
You can rotate the image or flip it horizontally or vertically.

**Assign Macro**
Opens the Assign Macro dialog so you can add programmable functionality to the graphic. Calc has a very good macro functionality. For more information, see Chapter 12, Calc Macros.

**Edit Hyperlink**
You can define a hyperlink from an image to another location in your spreadsheet, another document, or a web page. Select Edit Hyperlink from the context menu to open the Hyperlink dialog. See Chapter 10, Linking Calc Data, for more information on hyperlinks.

**Compress**
You can compress images to reduce the file size of the spreadsheet. Select Compress from the context menu to open a dialog where you can set the compression options.

**Edit with external tool**
You can edit an image with an external tool. The dialog that opens will depend on your computer setup.

**Using Fontwork**
With Fontwork, you can create graphical text art objects to make your work more attractive. There are many different settings for text art objects (line, area, position, size, and more), so you have a large choice.

Fontwork is available with each component of LibreOffice, but you will notice small differences in the way that each component displays it.
Creating a Fontwork object

1) On the Fontwork toolbar (View > Toolbars > Fontwork) or the Drawing toolbar (View > Toolbars > Drawing), click the Fontwork icon.

2) In the Fontwork Gallery (Figure 177), select a Fontwork style, then click OK. The Fontwork object will appear in the document.

![Fontwork Gallery](image)

*Figure 177: The Fontwork Gallery*

3) Double-click the object to edit the Fontwork text (see Figure 178). Select the text and type your own text in place of the black Fontwork text that appears over the object.

![Fontwork text](image)

*Figure 178: Editing Fontwork text*

4) Click anywhere in a free space or press Esc to apply your changes.

Editing a Fontwork object

Now that the Fontwork object is created, you can edit some of its attributes. To do this, you can use the Fontwork toolbar, the Formatting toolbar, or menu options. For more information, see Chapter 11, Graphics, Gallery, Fontwork, in the Getting Started Guide.
Chapter 6
Printing, Exporting, E-mailing, and Signing
Printing

Quick printing
To quickly print a spreadsheet, click on the **Print Directly** icon on the Standard toolbar to send the entire spreadsheet to the default printer that is defined for your computer.

**Note**
You can change the action of the **Print Directly** icon to send a document to the printer defined for the document instead of the default printer for the computer. Go to **Tools > Options > Load/Save > General** and select the **Load printer settings with the document** option.

**Tip**
If the **Print Directly** icon is not shown on the toolbar, you can add it. See Chapter 14, Setting Up and Customizing Calc.

Controlling printing
For more control over printing, use **File > Print** or **Ctrl+P** to open the Print dialog (Figure 179).

![Print dialog – General page](image)

**Figure 179: Print dialog – General page**

**Note**
The options selected on the Print dialog apply to this printing of this document only.

To specify default printing settings for LibreOffice, go to **Tools > Options > LibreOffice > Print** and **Tools > Options > LibreOffice Calc > Print**. For details, see Chapter 14, Setting Up and Customizing Calc.
The Print dialog has four tabs where you can choose a range of options, as described in the following sections.

Depending on your computer’s operating system, the layout of these tabs may look different from the illustrations shown in this chapter.

**General page**
On the General page of the Print dialog (Figure 179), you can choose:

- The printer to use from the list printers available in the Printer section.
- Which sheets and pages to print, the number of copies to print, whether to collate multiple copies, and the page order for printing in the Range and Copies section. (See "Selecting what to print" on page 202.)
- Printer-specific properties such as paper size, portrait or landscape orientation, duplex printing if available, and which paper tray to use.

**LibreOffice Calc page**
On the LibreOffice Calc page of the Print dialog (Figure 180), you can select whether to suppress the output of empty pages when you print the spreadsheet.

**Page Layout page**
On the Page Layout page of the Print dialog (Figure 181), you can select how many pages are printed per sheet of paper, the order in which the pages are printed on a sheet, and whether a border is drawn around each page.

**Options page**
On the Options page of the Print dialog (Figure 182), you can choose whether to create separate print jobs for collated output, or use only the paper size specified in the printer preferences.
Printing multiple pages on a single piece of paper

To print multiple pages of a spreadsheet on one piece of paper:

1) Use **File > Print** or **Ctrl+P** to open the Print dialog and then select the **Page Layout** page (Figure 183).

2) In the Layout section, select from the **Pages per sheet** drop-down list the number of spreadsheet pages to print per sheet of paper. The preview panel on the right shows how the pages will look in the printed document.

3) When printing more than two pages per sheet, select the order in which the pages are printed on a sheet from the **Order** drop-down list.

4) To distinguish each page on a sheet, select **Draw a border around each page**.

5) Click **OK**.

---

Selecting what to print

In addition to printing a full spreadsheet document, you can choose single sheets, multiple sheets, and selections of cells for printing.

To print an individual sheet:

1) In the spreadsheet, click on the sheet tab to select the sheet you want to print.

2) Choose **File > Print** from the Menu bar, or press **Ctrl+P**.

3) In the **Range and copies** section of the Print dialog, choose **Selected sheets**.

4) Click **OK**.

To print a range of sheets:

1) In the spreadsheet, select the sheets to print.

2) Choose **File > Print** from the Menu bar, or press **Ctrl+P**.

3) In the **Range and copies** section of the Print dialog, choose **Selected sheets**.

4) Click **OK**.

To print a selection of cells:

1) In the spreadsheet, select the cells to print.

2) Choose **File > Print** from the Menu bar, or press **Ctrl+P**.

3) In the Ranges and copies section of the Print dialog, choose **Selected cells**.

4) In the sub-section From which print, choose **Pages** and type 1 in the box.

5) Click **OK**.
**Printing in grayscale on a color printer**

You may wish to print a spreadsheet in grayscale on a color printer. You can do this in two ways.

**Note**

Some color printers may print in color regardless of the settings you choose.

For an individual file, you can change the printer settings to print in black and white or grayscale:

1) Choose **File > Print**, or press **Ctrl+P**, to open the Print dialog.
2) Click **Properties** to open the Properties dialog for the printer. The available choices vary from one printer to another, but you should find options for the Color settings. See your printer’s help or user manual for more information.
3) The choices for color might include black and white or grayscale. Choose grayscale.
4) Click **OK** to confirm your choice and return to the Print dialog,
5) Click **OK** to print the document.

You can change the LibreOffice settings to print all color text and graphics as grayscale:

1) Choose **Tools > Options > LibreOffice > Print**.
2) Select **Convert colors to grayscale**. Click **OK** to save the change.

**Caution**

This changes the print settings for all components of LibreOffice, not just Calc

**Previewing pages/sheets before printing**

To preview the sheets in Calc before printing:

1) Choose **File > Print Preview** or click the **Toggle Print Preview** icon on the Standard toolbar.

   The Calc window now displays the Print Preview toolbar instead of the Formatting toolbar.

   ![Figure 184: Print Preview toolbar (Calc)](image)

2) To print the document from this view, click the **Print** icon (on the Standard toolbar) to open the Print dialog.
3) Choose the print options and click the **OK** button.
4) Click the **Toggle Print Preview** icon again to return to the normal spreadsheet view.

**Using print ranges**

You can define which range of cells on a spreadsheet are to be printed or exported to a PDF. The cells on the sheet that are not part of the defined print range are not printed or exported. Also, any sheets without a defined print range are not printed or exported.

**Defining and printing a print range**

To set a user-defined print range, which will replace any existing defined print range:

1) Select the range of cells that are to be used in the print range.
2) Go to **Format > Print Ranges > Define** on the Menu bar. Automatic page break lines are then displayed on the screen, defining the cells that are included in the print range.
3) Click on the **Print Directly** icon on the Standard toolbar to print the defined print range, or open the Print dialog and click **OK** to print the defined print range.

**Tip**

You can check the print range by using **Toggle Print Preview** or the Preview pane in the Print dialog. Calc will display only the cells in the print range. See “Viewing print ranges” on page 205.

**Editing a print range**

At any time, you can edit the print range, for example to add or remove cells, or define rows and columns to repeat (such as column or row headings).

![Edit Print Ranges dialog](image)

**Figure 185: Edit Print Ranges dialog**

1) Go to **Format > Print Ranges > Edit** on the Menu bar to open the Edit Print Ranges dialog (Figure 185).

2) If only a single range is defined, then clicking anywhere in the **Print Range** box displays the defined print range bounded in blue, as shown in Figure 186.

![Single print range marked by a bounding box](image)

**Figure 186: Single print range marked by a bounding box**

3) To add new cells to the defined print ranges, type a comma at the end of the displayed data in the **Print range** text box as the separator for the print range to be added. Select the cell range using the cursor, or type in the cell references using the same format of the print ranges already defined in the **Print range** text box. Remember to separate the cell references with a colon.

4) To remove a print range, select the print range in the **Print range** text box and delete it. Make sure the remaining print ranges only have a single comma as a separator and that there is not a comma at the end of the sequence.

5) Click **OK** to save your changes and close the dialog.
Viewing print ranges

After print ranges have been defined, they are formatted with automatic page breaks. To view the page breaks, go to View > Page Break on the Menu bar to open the preview (Figure 187).

![Figure 187: Page break preview](image)

The print ranges are outlined by default with a blue border and contain a pale gray page number in the center of each page. The nonprinting area of the spreadsheet normally has a gray background.

To exit Page Break preview, go to View > Normal on the Menu bar.

Named print ranges

In addition to defining a print range for each print job, you can also define a range of cells to be used repeatedly, without having to select a range of cells every time. This is useful if different areas of a large spreadsheet have to be printed for different reports; several named print ranges can be defined to meet this need.

![Figure 188: Define Names dialog](image)

Defining and naming

1) Select the cells you want to define and name as a print range, then go to Sheet > Named Ranges and Expressions > Define on the Menu bar to open the Define Names dialog (Figure 188). The selected cells are displayed in the Range or formula expression box.

Alternatively, open the Define Names dialog, then select the cells you want to define and name. The selected cells are then displayed in the Range or formula expression box.
2) Type a name for the range in the Name box. Use only letters, numbers, and underscores in the name; no spaces, hyphens, or other characters are allowed.

3) If necessary, you can edit or set the range of selected cells for the print range in the Range or formula expression box. See “Editing a print range” on page 204 for more information.

4) Make sure Document (Global) is selected from the Scope drop-down list.

5) Select Print range from Range Options to define the settings as a print range.

6) Click Add to accept the data and close the dialog.

**Printing a named range**

To select a named range for printing:

1) Go to Format > Print Ranges > Edit on the Menu bar to open the Edit Print Ranges dialog (Figure 189).

2) Select the defined and named print range from the Print range drop-down list.

3) Click OK to close the dialog.

4) Open the Print dialog, which will show only the named range in the Preview. Click OK.

![Figure 189: Choosing a named range for printing](image)

**Deleting a named print range**

To delete a named print range if it is no longer required:

1) Go to Sheet > Named Ranges and Expressions > Manage on the Menu bar to open the Manage Names dialog (Figure 190).

2) Select the named print range you want to delete and confirm it is a print range by checking the options in Range Options.

3) Click Delete and then click OK to close the dialog.

**Removing print ranges**

It may become necessary to remove a defined print range, for example if the whole sheet needs to be printed later, or you no longer want to print some of the added ranges.

Go to Format > Print Ranges > Clear on the Menu bar to remove all of the defined print ranges in the spreadsheet, except for named print ranges. After the print range is removed, the default page break lines for the selected paper size will appear on the screen.

To remove named print ranges, see “Deleting a named print range” above.
Repeat printing of rows or columns

If a spreadsheet is printed on multiple pages, you can define specific rows or columns (for example, headings) to repeat print on each printed page.

**Using print ranges**

1) Go to **Format > Print Ranges > Edit** to open the Edit Print Ranges dialog (Figure 191).

2) In the **Rows to repeat** box, type the references for the rows to be repeat printed. For example, to repeat rows 1, 2 and 3, type $1:$3. This automatically changes **Rows to repeat** from - none - to - user defined -. 

![Figure 190: Manage Names dialog](image)

![Figure 191: Repeat printing of rows and columns](image)
You can also place the cursor in the **Rows to repeat** box and then, using the mouse, select a cell in each row you want to be repeat printed. It is not necessary to select the whole row.

3) In the **Columns to repeat** box, type the references for the columns to be repeat printed. For example, to repeat column A, type $A. This automatically changes **Columns to repeat** from - none - to - user defined -. You can also place the cursor in the **Columns to repeat** box and then, using the mouse, select a cell in each column you want to be repeat printed.

4) Click **OK** to save your changes and close the dialog.

**Using named print ranges**

You can also define named print ranges to use for repeat printing of rows or columns as follows:

1) Define and name the rows and/or columns you want to repeat print. See “Named print ranges” on page 205 for more information.

2) Select **Repeat column** and/or **Repeat row** from **Range Options** to define the columns and/or rows for repeat printing in the Define Names dialog (Figure 188 on page 205).

3) Click **Add** to accept the data and close the dialog.

4) Go to **Format > Print Ranges > Edit** to open the Edit Print Ranges dialog (Figure 191).

5) Select the defined and named print ranges from the **Rows to repeat** and/or **Columns to repeat** drop-down lists.

6) Click **OK** to save your changes and close the dialog.

**Page breaks**

While defining a print range can be a powerful tool, you may sometimes need to manually adjust the page breaks to make sure the spreadsheet prints the way you want it to look. You can insert two types of page breaks into a spreadsheet:

- **Row break** – is a horizontal page break inserted above a selected cell in a row. For example, if the selected cell is H15, then a row break is created between rows 14 and 15.

- **Column break** – is a vertical page break inserted to the left of the selected cell in a column. For example, if the selected cell is H15, then a column break is created between columns G and H.

When a manual break is inserted, it appears as a blue line or as a bold line between the rows or columns on the display. The actual appearance depends on your computer setup. To see manual break lines more easily on your display, you can change their appearance. Go to **Tools > Options > LibreOffice > Application Colors** and scroll down to the **Spreadsheet** section where you can change how page breaks appear.

**Inserting page breaks**

1) Select the cell where you want to insert a manual break in the spreadsheet.

2) Go to **Sheet > Insert Page Break** on the Menu bar.

3) Select **Row Break** to insert a row break above the cell or **Column Break** to insert a column break to the left of the cell.

Alternatively, go to **View > Page Break** on the Menu bar, right-click in the spreadsheet and select **Row Break** or **Column Break** from the context menu. Remember to go to **View > Normal** on the Menu bar and return to the standard spreadsheet view.
Deleting page breaks

1) Select the cell where you want to delete a manual break from the spreadsheet.
2) Go to Sheet > Delete Page Break on the Menu bar.
3) Select Row Break to delete a row break from above the cell or Column Break to delete a column break from the left of the cell.

Deleting multiple page breaks

Multiple manual row and column breaks can exist in the same spreadsheet. If you want to remove all breaks from the spreadsheet:

1) Go to View > Page Break on the Menu bar.
2) Right-click in the spreadsheet and select Delete Page Breaks from the context menu to remove all manual breaks from your spreadsheet.
3) Go to View > Normal on the Menu bar to return to the standard spreadsheet view.

Printing options for page styles

When using page styles for your spreadsheets, you can include printing options within the page style; for example, page order, details, scale to be printed, and so on. Using page styles allows you to quickly set up and change the printing options of different sheets within your spreadsheet. See Chapter 4, Using Styles and Templates, for more information about page styles.

Figure 192. Page Style dialog – Sheet page

Make sure you have selected the correct sheet within the spreadsheet before setting the print options. Go to Format > Page on the Menu bar to open the Page Style dialog, then click on the Sheet tab (Figure 192) to set the printing options for a page style. The dialog indicates which page style you are about to change.
• **Page Order** – defines the order in which data in a sheet is numbered and printed when it does not fit on one printed page. A preview of the page order is shown in the graphic on the top right of the dialog in Figure 192.
  – *Top to bottom, then right* – prints vertically from the left column to the bottom of the sheet.
  – *Left to right, then down* – prints horizontally from the top row of the sheet to the right column.
  – *First page number* – select this option if you want the first page to start with a number other than 1. Enter the number of the first page in the box.

• **Print** – defines which elements of the spreadsheet are to be printed.
  – *Column and row headers* – prints the column and row headers.
  – *Grid* – prints the borders of the individual cells as a grid. For the view on screen, make your selection under LibreOffice > Preferences > LibreOffice Calc > View > Grid lines.
  – *Comments* – prints the comments defined in the spreadsheet. Comments will be printed on a separate page, along with the corresponding cell reference.
  – *Objects/Images* – includes all inserted objects (if printable) and graphics with the printed spreadsheet.
  – *Charts* – prints the charts that have been inserted into your spreadsheet.
  – *Drawing Objects* – includes all drawing objects in the printed spreadsheet.
  – *Formulas* – prints the formulas contained in the cells, instead of the results of any formulas used in the spreadsheet.
  – *Zero Values* – specifies that cells with a zero value are printed with a zero (0) in the cell.

• **Scale** – defines a page scale for the printed spreadsheet.
  – *Scaling mode* – select a scaling mode from the drop-down list. Appropriate controls for the scaling mode selected will be shown below the drop-down list box.
  – *Reduce/enlarge printout* – specifies a scaling factor to scale all printed pages. Enter the scaling factor as a percentage in the box.
  – *Fit print range(s) to width/height* – specifies the maximum number of pages horizontally (width) and vertically (height) on which every sheet with the current Page Style is to be printed.
  – *Width in pages* – enter the maximum number of pages to be printed horizontally across.
  – *Height in pages* – enter the maximum number of pages to be printed vertically stacked.
  – *Fit print range(s) on number of pages* – specifies the maximum number of pages to be printed for each sheet that uses the same Page Style. The scale will be reduced as necessary to fit the defined number of pages.
  – *Number of pages* – enter the maximum number of pages to be printed.
Headers and footers

Headers and footers are predefined pieces of text that are printed at the top or bottom of a sheet outside of the sheet area. Headers and footers are set the same way and you can have different content on left and right pages that use the same page style.

Setting headers and footers

To turn the headers or footers on in your spreadsheet:

1) Select the sheet where you want to turn on the header or footer.
2) Go to Format > Page on the Menu bar to open the Page Style dialog and select the Header (or Footer) tab (Figure 193). The Header and Footer pages in the Page Style dialog are identical.
3) Select the Header on or Footer on option.
4) Enter the values for the other options according to your requirements. These options are described below.
5) Click OK to save your changes and close the dialog.

Figure 193: Page Style dialog – Header page

- **Header on** or **Footer on** – adds a header or footer to the current page style.
- **Same content on left and right pages** – causes left and right pages to share the same header or footer content. To assign a different header or footer to left and right pages, deselect this option and then click Edit. See “Header or footer contents” on page 212 for more information.
- **Left margin** – enter the amount of space to leave between the left page margin and the left edge of the header or footer.
- **Right margin** – enter the amount of space to leave between the right page margin and the right edge of the header or footer.
- **Spacing** – enter the amount of space to maintain between the bottom edge of the header or footer and the top edge of the spreadsheet.
- **Height** – enter the height for the header or footer.
- **AutoFit height** – automatically adjusts the height of the header or footer to fit the content.
- **Preview** – displays a preview of the current selection.
• **More** – opens the Border/Background dialog, where you can define the appearance of borders and background colors or images for headers or footers. See Chapter 4, Using Styles and Templates in Calc, for more information.

• **Edit** – opens the Header or Footer dialog where you can add, edit, or format text that is placed in the header or footer. See “Header or footer contents” below for more information.

![Figure 194: Header dialog](image)

**Header or footer contents**

The headers and footers in a Calc spreadsheet have three columns for text. Each column can either be empty or have different contents from the other columns.

1) Select the sheet where you want to turn on the header or footer.

2) Open the Page Style dialog (Figure 193), then select **Header on or Footer on** and the options for the header or footer. See “Setting headers and footers” above.

3) Click **Edit** to open the Header or Footer dialog (Figure 194). If **Same content on left and right pages** is deselected in the Page Style dialog, the Header or Footer dialog will have tabbed pages where you can set the header or footer contents for right and left pages.

4) To enter standard contents into the header or footer, select an option from the Header or Footer drop-down list.

5) To enter customized contents into the header or footer, click in one of the area boxes and type your text, or click in one of the area boxes and click one of the **Custom header** or **Custom footer** icons. These icons are explained below.

6) To change the appearance of the text in the header or footer, click the **Text Attributes** icon to open the Text Attributes dialog, where you can set the font, font effects and font position.

7) Click **OK** to save the changes to text attributes and close the Text Attributes dialog.

8) Click **OK** to save the changes to the contents of the header or footer and close the Header or Footer dialog.

9) Click **OK** to save the changes to your header or footer and close the Page Style dialog.

The options available for a **Custom header** or **Custom footer** are as follows:

• **Text Attributes** – opens a Text Attributes dialog where you can assign formats to new or selected text. The Text Attributes dialog contains tabbed pages for Font, Font Effects, and Position.
• **Title** – inserts a file name placeholder in the selected area. Click to insert the title. Click and hold to select either Title, File Name or Path/File Name from the context menu that opens. If a title has not been assigned to the spreadsheet, the file name for the spreadsheet will be inserted instead.

• **Sheet Name** – inserts a placeholder in the selected area for the sheet name of the selected sheet in the spreadsheet.

• **Page** – inserts a placeholder in the selected area for the page number. This allows continuous page numbering in a spreadsheet.

• **Pages** – inserts a placeholder in the selected area for the total number of pages in the spreadsheet.

• **Date** – inserts a placeholder in the selected area for the current date which will be repeated in the header/footer on each page of the spreadsheet.

• **Time** – inserts a placeholder in the selected area for the current time which will be repeated in the header/footer on each page of the spreadsheet.

---

**Exporting to PDF**

LibreOffice can export documents to PDF (Portable Document Format). This industry-standard file format is ideal for sending a file for someone else to view using Adobe Reader or other PDF viewers.

---

**Warning**

A document in PDF format is not protected against contents tampering or editing by default. The PDF document contents can be edited by specialized software tools, including LibreOffice Draw.

---

**Tip**

Unlike Save As, the Export command writes a copy of the current document in a new file with the chosen format, but keeps the current document and format open in your session.

---

**Quick export to PDF**

Click the Export as PDF icon on the Standard toolbar to export the entire spreadsheet using the PDF settings most recently selected on the PDF Options dialog (see below). You are asked to enter the file name and location for the PDF, but you do not get a chance to choose a page range, image compression, or other options.

---

**Controlling PDF content and quality**

For more control over the content and quality of the resulting PDF, use File > Export as PDF. The PDF Options dialog opens. This dialog has six pages (General, Initial View, User Interface, Links, Security, and Digital Signatures). Select the appropriate settings, and then click Export. Then enter the location and file name of the PDF to be created, and click Save to export the file.

---

**General page of PDF Options dialog**

On the General page (Figure 191), you can choose which pages to include in the PDF, the type of compression to use for images (which affects the quality of images in the PDF), and other options. For more information, see the Getting Started guide or the Help. In most cases, the defaults will be what you need.
Figure 195: PDF Options dialog – General page

Range section
- **All**: Exports the entire document to PDF.
- **Pages**: To export a range of pages within a selected sheet, use the format 3-6 (pages 3 to 6). To export single pages, use the format 7;9;11 (pages 7, 9, and 11), or a combination of the two formats.
- **Selection/Selected sheet(s)**: Exports the selected material (a sheet or part of a sheet).

Images section
- **Lossless compression**: Images are stored without any loss of quality. Tends to make large files when used with photographs. Recommended for other kinds of images or graphics.
- **JPEG compression**: Allows for varying degrees of quality. A setting of 90% works well with photographs (small file size, little perceptible loss of quality).
- **Reduce image resolution**: Lower DPI (dots per inch) images have lower quality. Higher DPI settings can greatly increase the size of the exported file.

Watermark section
- **Sign with Watermark**: When this option is selected, a transparent overlay of the text you enter into the Text box will appear on each page of the PDF.

General section
- **Hybrid PDF (embed ODF file)**: Use this setting to export the document as a PDF file containing two file formats: PDF and ODF. In PDF viewers it behaves like a normal PDF file, and it remains fully editable in LibreOffice.
- **Archive PDF/A-1a (ISO 19005-1)**: PDF/A is an ISO standard for long-term preservation of documents, by embedding all the information necessary for faithful reproduction (such as fonts) while forbidding other elements (including forms, security, and encryption). PDF tags are written.
- **Tagged PDF**: Tagged PDF contains information about the structure of the document’s contents. This can help to display the document on devices with different screens, and
when using screen reader software. Some tags that are exported are table of contents, hyperlinks, and controls. This option can increase file sizes significantly.

- **Create PDF form – Submit format**: Choose the format of submitting forms from within the PDF file.
- **Allow duplicate field names**: If enabled, the same field name can be used for multiple fields in the generated PDF file. If disabled, field names will be exported using generated unique names.
- **Export bookmarks**: Generally not used in Calc.
- **Export comments**: Exports comments as PDF notes. You may not want this!
- **Export automatically inserted blank pages**: Not available in Calc.
- **View PDF after export**: If selected, your default PDF viewer will open and display the newly exported PDF.
- **Use reference XObjects**: If you don’t know what this means, leave this box unchecked.

**Initial View page of PDF Options dialog**

On the Initial View page (Figure 196), you can select how the PDF file opens by default in a PDF viewer. The options should be self-explanatory.

![Figure 196: PDF Options dialog – Initial View page](image)

**User Interface page of PDF Options dialog**

On the User Interface page (Figure 197), you can select options to control how a PDF viewer displays the file. Some of these options are useful when you are creating a PDF to be used as a presentation or a kiosk-type display.

![Figure 197: PDF Options dialog – User Interface page](image)
Window options

- **Resize window to initial page**: the PDF reader window displays the whole first page.
- **Center window on screen**: the PDF is shown in a reader window centered on screen.
- **Open in full screen mode**: the PDF reader window is in front of all other windows.
- **Display document title**: the PDF is shown with the document title in the reader title bar.

Transitions – not used in Calc.

User interface options

- **Hide menu bar**: hides the reader menu bar when the document is active.
- **Hide toolbar**: hides the reader toolbar when the document is active.
- **Hide window controls**: hides the reader controls when the document is active.

Bookmarks

- **All bookmark levels**: shows all bookmark levels when the reader opens the PDF.
- **Visible bookmark levels**: shows bookmark levels down to the selected level when the reader opens the PDF.

**Links page of PDF Options dialog**

On the Links page (Figure 198) you can select how bookmarks and hyperlinks are exported to PDF.

![PDF Options dialog – Links page](image)

**Export bookmarks as named destinations**

If you have defined Calc sheet names, this option exports them as “named destinations” to which Web pages and PDF documents can link.

**Convert document references to PDF targets**

If you have defined links to other documents with OpenDocument extensions (such as .odt, .ods, and .odp), this option converts the files' extensions to .pdf in the exported PDF document.

**Export URLs relative to file system**

If you have defined relative links in a document, this option exports those links to the PDF. See [Relative hyperlinks](#) in the Calc Help for more information.

**Cross-document links**

Defines the behavior of links clicked in PDF files. Select one among the following alternatives:

- **Default mode**: The PDF links will be handled as specified in your operating system.
- **Open with PDF reader application**: Use the same application used to display the PDF document to open linked PDF documents.
- **Open with Internet browser**: Use the default Internet browser to display linked PDF documents.
**Security page of PDF Options dialog**

Use the Security page (Figure 199) to encrypt and set passwords when you export your spreadsheet and create the PDF file. Setting encryption and passwords also allows you to apply restrictions on printing and if changes or copying can be carried out on the PDF file.

Click the **Set passwords** button to open the Set Passwords dialog (Figure 200) where you enter the passwords. You can enter a password (**Set open password**) to open the file and an optional password (**Set permission password**) to restrict what readers can do with the PDF file.

- With an **open password** set, the PDF can only be opened with the password. Once opened, there are no restrictions on what the user can do with the document (for example, print, copy, or change it).
- With a **permission password** set, the PDF can be opened by anyone, but its permissions can be restricted. See Figure 199. After you set a password for permissions, the other choices on the **Security** page become available.
- With both the open password and permission password set, the PDF can only be opened with the correct password, and its permissions can be restricted.

The options on the **Security** page become available only when passwords have been set.

---

**Note**

Permissions settings are effective only if the user’s PDF viewer respects the settings.

---

![Figure 199: PDF Options dialog – Security page](image-url)
Digital Signatures page of PDF Options dialog

This page contains the options related to exporting a digitally signed PDF.

Digital signatures are used to ensure that the PDF was really created by the original author (that is, you), and that the document has not been modified since it was signed.

The signed PDF export uses the keys and X.509 certificates already stored in your default key store location or on a smartcard. The key store to be used can be selected under Tools > Options > LibreOffice > Security > Certificate Path, (Not available on Microsoft Windows systems, where LibreOffice will access the system certificate storage.) When using a smartcard, it must already be configured for use by your key store. This is usually done during installation of the smartcard software. Details about using these features is outside the scope of this chapter.

Use this certificate to digitally sign PDF documents: Click Select to open the Select Certificate dialog, where all certificates found in your selected key store are displayed. If the key store is protected by a password, you are prompted for it. When using a smartcard that is protected by a PIN, you are also prompted for that.

Select the certificate to use for digitally signing the exported PDF, then click OK. All other fields on the Digital Signatures tab are accessible only after a certificate has been selected.

Certificate password: Enter the password used for protecting the private key associated with the selected certificate. Usually this is the key store password. If the key store password has already been entered in the Select Certificate dialog, the key store may already be unlocked and not require the password again.
When using a smartcard, enter the PIN here. Some smartcard software will prompt you for the PIN again before signing.

- **Location, Contact information, Reason:** Optionally enter additional information about the digital signature that will be applied to the PDF. This information will be embedded in the appropriate PDF fields and will be visible to anyone viewing the PDF. Each or all of the three fields may be left blank.

- **Time Stamp Authority:** Optionally select a Time Stamping Authority (TSA) URL. During the PDF signing process, the TSA will be used to obtain a digitally signed timestamp that is then embedded in the signature. Anyone viewing the PDF can use this timestamp to verify when the document was signed.

The list of TSA URLs that can be selected is maintained under **Tools > Options > LibreOffice > Security > TSAs**. If no TSA URL is selected (the default), the signature will not be timestamped, but will use the current time from your local computer.

---

**Exporting to other formats**

LibreOffice uses the term “export” for some file operations involving a change of file type. If you want to use another spreadsheet file format (for example, Microsoft Excel), use **File > Save As**. If you want to create web pages from your spreadsheet, use **File > Export**.

---

**E-mailing spreadsheets**

LibreOffice provides several ways to send documents quickly and easily as an e-mail attachment in OpenDocument format (LibreOffice default format), other spreadsheet formats, or as a PDF file. You can also email a document to several recipients. For more information, see the **Getting Started Guide**.

To send the spreadsheet as an email:

1) Go to **File > Send** on the Menu bar and select from the following options. LibreOffice opens your default e-mail program with the spreadsheet attached in the selected format.

   - **Email Document:** the spreadsheet is sent in the default ODF format.
   - **E-mail as OpenDocument Spreadsheet:** the spreadsheet is sent in the ODF format.
   - **E-mail as Microsoft Excel:** the spreadsheet is sent in the Excel format.
   - **E-mail as PDF:** The PDF Options dialog opens. Select the parameters to be used for the PDF file. See “Controlling PDF content and quality” on page 213.

2) In your e-mail program, enter the recipient, subject, and any text you want to add, then send the e-mail.

---

**Digital signing of documents**

To sign a document digitally, you need a personal key, also known as a certificate. A personal key is stored on your computer as a combination of a private key, which must be kept secret, and a public key, which you add to your documents when you sign them. You can get a certificate from a certification authority, which may be a private company or a governmental institution.

When you apply a digital signature to a document, a checksum is computed from the document's content plus your personal key. The checksum and your public key are stored together with the document.

When someone later opens the document on any computer with a recent version of LibreOffice, the program will compute the checksum again and compare it with the stored checksum. If both are the same, the program will signal that you see the original, unchanged document. In addition,
the program can show you the public key information from the certificate. You can compare the public key with the public key that is published on the web site of the certificate authority.

Whenever someone changes something in the document, the change breaks the digital signature.

On Windows operating systems, the Windows features for validating a signature are used. On Linux systems, files that are supplied by Mozilla Thunderbird or Firefox are used to validate the signature. For a more detailed description of how to get and manage a certificate, and signature validation, see About Digital Signatures in the LibreOffice Help.

**Applying digital signatures**

The following procedure is only an example of how to digitally sign a document. The actual procedure depends on how your computer is set up and the computer operating system.

1) Open the file that you want to digitally sign.

2) Go to File > Digital Signatures > Digital Signatures on the Menu bar.

   - If you have set LibreOffice to warn you when the document contains comments (see “Removing personal data” on page 222), you may see a message box asking whether you want to want to continue signing the document.
   
   - If the document contains comments, a warning dialog opens asking if you wish to continue. Click Yes to continue, or click No to exit and take appropriate action to remove the comments and restart this procedure.
   
   - If you have not saved the document since the last change, a message box appears. Click Yes to save the file. When you have saved the file, the Digital Signatures dialog opens (Figure 202).

3) Click Sign Document to open the Select Certificate dialog (Figure 203).

   Select the certificate you want to use and click OK to close the Select Certificate dialog.

   The certificate used is displayed in the Digital Certificates dialog with an icon next to its name. This icon indicates the status of the digital signature.

   - An icon with a red seal (貘) indicates that the document was signed and the certificate was validated.
   
   - An icon with a yellow caution triangle overlaying the red seal (貘) indicates that the document is signed but that the certificate could not be validated.
   
   - An icon with a yellow caution triangle by itself (貘) indicates an invalid digital signature.

4) Click Close to close the Digital Signatures dialog and digitally sign your file.

A signed document shows an icon in the status bar. You can double-click the icon to view the certificate. More than one signature can be added to a document.

**Note**

If you make any changes to the document after digitally signing, the digital signature is removed automatically and you have to repeat the above procedure to digitally sign it again.

---

212 | Digital signing of documents
Sign multiple times with same signature

In the past, LibreOffice prohibited creating multiple signatures by the same author on a document, because there was no semantic meaning of signing the same document multiple times. LibreOffice now provides a signature description, so multiple signatures from the same author are now allowed, because each signature can have a different meaning.

When you select File > Digital Signatures > Digital Signatures, the dialog (Figure 202) lists existing signatures together with their description (if they have any).

When you click the Sign Document button, the dialog (Figure 203) for certificate selection now also asks for an optional description.

Changing the value of an existing description invalidates the signature.
**Digitally signing macros**

Normally, macros are part of a document. If you sign a document, the macros inside the document are signed automatically. If you want to sign only the macros, but not the document, go to **Tools > Macros > Digital Signature** on the Menu bar and apply the signature as described above.

**Removing personal data**

You may wish to ensure that personal data, versions, notes, hidden information, or recorded changes are removed from files before you send them to other people or create PDFs from them.

- In **Tools > Options > LibreOffice > Security > Options**, you can set Calc to remind you when files contain certain information and to remove personal information automatically on saving.

- To remove personal and some other data from a file, go to **File > Properties**. On the **General** page, deselect **Apply user data** and then click **Reset Properties**. This removes any names in the created and modified fields, deletes the modification and printing dates, and resets the Total editing time to zero, the creation date to the current date and time, and the Revision number to 1.

- To remove version information, either go to **File > Versions** on the Menu bar, select the versions from the list and click **Delete**, or go to **File > Save As** and save the file with a different name.
Chapter 7
Using Formulas and Functions
Introduction

In previous chapters, we have been entering one of two basic types of data into each cell: numbers and text. However, we will not always know what the contents should be. Often the contents of one cell depends on the contents of other cells. To handle this situation, we use a third type of data: the formula. Formulas are equations using numbers and variables to get a result. In a spreadsheet, the variables are cell locations that hold the data needed for the equation to be completed.

A function is a predefined calculation entered in a cell to help you analyze or manipulate data. All you have to do is add the arguments, and the calculation is made automatically made. Functions help you create the formulas needed to get the results that you are looking for.

Setting up a spreadsheet

If you are setting up more than a simple one-worksheet system in Calc, it is worth planning ahead a little. Avoid the following traps:

- Typing fixed values into formulas
- Not including notes and comments describing what the system does, including what input is required and where the formulas come from (if not created from scratch)
- Not incorporating a system of checking to verify that the formulas do what is intended

The trap of fixed values

Many users set up long and complex formulas with fixed values typed directly into the formula. For example, conversion from one currency to another requires knowledge of the current conversion rate. If you input a formula in cell C1 of =0.75*B1 (for example to calculate the value in Euros of the USD dollar amount in cell B1), you will have to edit the formula when the exchange rate changes from 0.75 to some other value. It is much easier to set up an input cell with the exchange rate and reference that cell in any formula needing the exchange rate. What-if type calculations are also simplified: what if the exchange rate varies from 0.75 to 0.70 or 0.80? No formula editing is needed and it is clear what rate is used in the calculations. Breaking complex formulas down into more manageable parts, described below, also helps to minimize errors and aid troubleshooting.

Lack of documentation

Lack of documentation is a very common failing. Many users prepare a simple worksheet which then develops into something much more complicated over time. Without documentation, the original purpose and methodology is often unclear and difficult to decipher. In this case it is usually easier to start again from the beginning, wasting the work done previously. If you insert comments in cells, and use labels and headings, a spreadsheet can later be modified by you or others and much time and effort will be saved.

Error-checking formulas

Adding up columns of data or selections of cells from a worksheet often results in errors due to omitting cells, wrongly specifying a range, or double-counting cells. It is useful to institute checks in your spreadsheets. For example, set up a spreadsheet to calculate columns of figures, and use SUM to calculate the individual column totals. You can check the result by including (in a non-printing column) a set of row totals and adding these together. The two figures—row total and column total—must agree. If they do not, you have an error somewhere.

You can even set up a formula to calculate the difference between the two totals and report an error in case a non-zero result is returned (see Figure 204).
Creating formulas

You can enter formulas in two ways, either by using the Function Wizard, or by typing directly into the cell or into the input line. A formula must begin with an = symbol, so when typing in directly, you need to start a formula with one of the following symbols: =, + or –. Calc automatically adds the = symbol for the formula, when starting with the + or – character. Starting with anything else causes the formula to be treated as if it were text.

Operators in formulas

Each cell in the worksheet can be used as a data holder or a place for data calculations. To enter data, simply type in the cell and move to the next cell or press Enter. With formulas, the equals sign indicates that the cell will be used for a calculation. An example of a mathematical calculation like 15 + 46 is shown in Figure 205.

While the calculation on the left used only one cell, the real power is shown on the right where the data is placed in cells and the calculation is performed using references to the cells. In this case, cells B3 and B4 were the data holders, with B5 the cell where the calculation was performed. Notice that the formula was shown as =B3+B4. The plus sign indicates that the contents of cells B3 and B4 are to be added together and then have the result in the cell holding the formula. All formulas build upon this concept. Other ways of using formulas are shown in Table 3.

These cell references allow formulas to use data from anywhere in the worksheet being worked on or from any other worksheet in the workbook that is opened. If the data needed was in different worksheets, they would be referenced by referring to the name of the worksheet, for example =SUM(Sheet2.B12+Sheet3.A11).

Note

To enter the = symbol for a purpose other than creating a formula as described in this chapter, type an apostrophe or single quotation mark before the =. For example, in the entry ‘= means different things to different people’, Calc treats everything after the single quotation mark—including the = sign—as text.
### Simple Calculation in 1 Cell

<p>| | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td></td>
<td>=15+46</td>
</tr>
<tr>
<td>4</td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

### Calculation by Reference

<p>| | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td></td>
<td>15</td>
</tr>
<tr>
<td>4</td>
<td></td>
<td>46</td>
</tr>
<tr>
<td>5</td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<p>| | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td></td>
<td>15</td>
</tr>
<tr>
<td>4</td>
<td></td>
<td>46</td>
</tr>
<tr>
<td>5</td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td></td>
<td>=B3+B4</td>
</tr>
</tbody>
</table>

---

**Figure 205:** A simple calculation

**Table 3:** Common ways to use formulas

<table>
<thead>
<tr>
<th><strong>Formula</strong></th>
<th><strong>Description</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>=A1+10</td>
<td>Displays the contents of cell A1 plus 10.</td>
</tr>
<tr>
<td>=A1*16%</td>
<td>Displays 16% of the contents of A1.</td>
</tr>
<tr>
<td>=A1*A2</td>
<td>Displays the result of multiplying the contents of A1 and A2.</td>
</tr>
<tr>
<td>=ROUND(A1,1)</td>
<td>Displays the contents of cell A1 rounded to one decimal place.</td>
</tr>
<tr>
<td>=EFFECTIVE(5%,12)</td>
<td>Calculates the effective interest for 5% annual nominal interest with 12 payments a year.</td>
</tr>
<tr>
<td>=B8-SUM(B10:B14)</td>
<td>Calculates B8 minus the sum of the cells B10 to B14.</td>
</tr>
<tr>
<td>=SUM(B8,SUM(B10:B14))</td>
<td>Calculates the sum of cells B10 to B14 and adds the value to B8.</td>
</tr>
<tr>
<td>=SUM(B1:B1048576)</td>
<td>Sums all numbers in column B.</td>
</tr>
<tr>
<td>=AVERAGE(BloodSugar)</td>
<td>Displays the average of a named range defined under the name BloodSugar.</td>
</tr>
<tr>
<td>=IF(C31&gt;140,”HIGH”, ”OK”)</td>
<td>Displays the results of a conditional analysis of data from two sources. If the contents of C31 is greater than 140, then HIGH is displayed, otherwise OK is displayed.</td>
</tr>
</tbody>
</table>
Functions in Table 3 are identified by a word, for example ROUND, followed by parentheses enclosing references or numbers.

Note

Users of some other spreadsheet software may be familiar with formulas that begin with +, -, =, (, @, ., $, or #. A mathematical formula would look like +D2+C2 or +2*3. Functions begin with the @ symbol such as @SUM(D2..D7), @COS(°DEGTORAD(30)) and @IRR(GUESS,CASHFLOWS). Ranges are identified such as A1..D3.

It is also possible to establish ranges for inclusion by naming them using Insert > Names, for example BloodSugar representing a range such as B3:B10. Logical functions can also be performed as represented by the IF statement which results in a conditional response based upon the data in the identified cell, for example

=IF(A2>=0,"Positive","Negative")

A value of 3 in cell A2 would return the result Positive, a value of –9 the result Negative.

Operator types

You can use the following operator types in Calc: arithmetic, comparative, text, and reference.

Arithmetic operators

The addition, subtraction, multiplication and division operators return numerical results. The Negation and Percent operators identify a characteristic of the number found in the cell, for example -37. The example for Exponentiation illustrates how to enter a number that is being multiplied by itself a certain number of times, for example 2^3 = 2*2*2.

<table>
<thead>
<tr>
<th>Operator</th>
<th>Name</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>+ (Plus)</td>
<td>Addition</td>
<td>=1+1</td>
</tr>
<tr>
<td>– (Minus)</td>
<td>Subtraction</td>
<td>=2–1</td>
</tr>
<tr>
<td>– (Minus)</td>
<td>Negation</td>
<td>–5</td>
</tr>
<tr>
<td>* (asterisk)</td>
<td>Multiplication</td>
<td>=2*2</td>
</tr>
<tr>
<td>/ (Slash)</td>
<td>Division</td>
<td>=10/5</td>
</tr>
<tr>
<td>% (Percent)</td>
<td>Percent</td>
<td>15%</td>
</tr>
<tr>
<td>^ (Caret)</td>
<td>Exponentiation</td>
<td>2^3</td>
</tr>
</tbody>
</table>

Comparative operators

Comparative operators are found in formulas that use the IF function and return either a true or false answer; for example, =IF(B6>G12, 127, 0) which, loosely translated, means if the contents of cell B6 are greater than the contents of cell G12, then return the number 127, otherwise return the number 0.

A direct answer of TRUE or FALSE can be obtained by entering a formula such as =B6>B12. If the numbers found in the referenced cells are accurately represented, the answer TRUE is returned, otherwise FALSE is returned.
### Table 5: Comparative operators

<table>
<thead>
<tr>
<th>Operator</th>
<th>Name</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Equal</td>
<td>A1=B1</td>
</tr>
<tr>
<td></td>
<td>Greater than</td>
<td>A1&gt;B1</td>
</tr>
<tr>
<td></td>
<td>Less than</td>
<td>A1&lt;B1</td>
</tr>
<tr>
<td></td>
<td>Greater than or equal to</td>
<td>A1&gt;=B1</td>
</tr>
<tr>
<td></td>
<td>Less than or equal to</td>
<td>A1&lt;=B1</td>
</tr>
<tr>
<td></td>
<td>Inequality</td>
<td>A1&lt;&gt;B1</td>
</tr>
</tbody>
</table>

If cell A1 contains the numerical value 4 and cell B1 the numerical value 5, the above examples would yield results of FALSE, FALSE, TRUE, FALSE, TRUE, and TRUE.

---

**Text operators**

It is common for users to place text in spreadsheets. To provide for variability in what and how this type of data is displayed, text can be joined together in pieces coming from different places on the spreadsheet. Figure 206 shows an example.

![Image of text concatenation](image)

**Figure 206: Text concatenation**

In this example, specific pieces of the text were found in three different cells. To join these segments together, the formula also adds required spaces and punctuation enclosed within quotation marks, resulting in a formula of =B2 & " " & C2 & ", " & D2. The result is the concatenation into a date formatted in a particular sequence.

Calc has a CONCATENATE function which performs the same operation.

---

**Reference operators**

An individual cell is identified by the column identifier (letter) located along the top of the columns and a row identifier (number) found along the left-hand side of the spreadsheet. On spreadsheets read from left to right, the reference for the upper left cell is A1.

Thus in its simplest form a reference refers to a single cell, but references can also refer to a rectangle or cuboid range or a reference in a list of references. To build such references you need reference operators.

**Range operator**

The range operator is written as a colon. An expression using the range operator has the following syntax:

reference upper left : reference lower right
The range operator builds a reference to the smallest range including both the cells referenced with the left reference and the cells referenced with the right reference.

![Figure 207: Reference Operator for a range](image)

In the upper left corner of Figure 207 the reference A1:D12 is shown, corresponding to the cells included in the drag operation with the mouse to highlight the range.

**Examples**

- **A2:B4**
  Reference to a rectangle range with 6 cells, 2 column width × 3 row height. When you click on the reference in the formula in the input line, a border indicates the rectangle.

- **(A2:B4):C9**
  Reference to a rectangle range with cell A2 top left and cell C9 bottom right. So the range contains 24 cells, 3 column width × 8 row height. This method of addressing extends the initial range from A2:B4 to A2:C9.

- **Sheet1.A3:Sheet3.D4**
  Reference to a cuboid range with 24 cells, 4 column width × 2 row height × 3 sheets depth.

- **B:B**
  Reference to all cells of column B.

- **A:D**
  Reference to all cells of columns A to D.

- **20:20**
  Reference to all cells of row 20.

- **1:20**
  Reference to all cell of rows 1 to 20.

When you enter B4:A2 or A4:B2 directly, then Calc will turn it to A2:B4. So the left top cell of the range is left of the colon and the bottom right cell is right of the colon. But if you name the cell B4 for example with _start and A2 with _end, you can use _start:_end without any error.

**Reference concatenation operator**

The concatenation operator is written as a tilde. An expression using the concatenation operator has the following syntax:

```
reference left ~ reference right
```

The result of such an expression is a reference list, which is an ordered list of references. Some functions can take a reference list as an argument, SUM, MAX or INDEX for example.

The reference concatenation is sometimes called 'union'. But it is not the union of the two sets 'reference left' and 'reference right' as normally understood in set theory. COUNT(A1:C3~B2:D2) returns 12 (=9+3), but it has only 10 cells when considered as the union of the two sets of cells.
Notice that \( \text{SUM}(A1:C3, B2:D2) \) is different from \( \text{SUM}(A1:C3\sim B2:D2) \) although they give the same result. The first is a function call with 2 parameters, each of them is reference to a range. The second is a function call with 1 parameter, which is a reference list.

The reference concatenation also applies to whole rows and whole columns. For example \( \text{SUM}(A:B\sim D:D) \) is the sum of all cells in columns A and B and the column D.

**Intersection operator**

The intersection operator is written as an exclamation mark. An expression using the intersection operator has the following syntax:

\[
\text{reference left} \! \text{ reference right}
\]

If the references refer to single ranges, the result is a reference to a single range, containing all cells, which are both in the left reference and in the right reference.

If the references are reference lists, then each list item from the left is intersected with each one from the right and these results are concatenated to a reference list. The order is to first intersect the first item from the left with all items from the right, then intersect the second item from the left with all items from the right, and so on.

**Examples**

\( A2:B4 \! B3:D6 \)

This results in a reference to the range B3:B4, because these cells are inside A2:B4 and inside B3:D4.

\( (A2:B4\!B1:C2) \! (B2:C6\!C1:D3) \)

First the intersections \( A2:B4\!B2:C6, A2:B4\!C1:D3, B1:C2\!B2:C6 \) and \( B1:C2\!C1:D3 \) are calculated. This results in B2:B4, empty, B2:C2, and C1:C2. Then these results are concatenated, dropping empty parts. So the final result is the reference list B2:B4 \sim B2:C2 \sim C1:C2.

\( A:B \! 10:10 \)

Calculates the intersection of columns A and B with line 10, thus selecting A10 and B10.

You can use the intersection operator to refer a cell in a cross tabulation in an understandable way. If you have columns labeled 'Temperature' and 'Precipitation' and the rows labeled 'January', 'February', 'March', and so on, then the following expression

\( 'February' \! 'Temperature' \)

will reference the cell containing the temperature in February.

The intersection operator (!) has a higher precedence than the concatenation operator (~), but does not rely on precedence.

**Tip**

Always put in parentheses the part that is to be calculated first.

**Relative and absolute references**

References are the way that we refer to the location of a particular cell in Calc and can be either relative (to the current cell) or absolute (a fixed amount).

**Relative referencing**

An example of a relative reference will illustrate the difference between a relative reference and absolute reference using the spreadsheet from Figure 208.

5) Type the numbers 4 and 11 into cells C3 and C4 respectively of that spreadsheet.
6) Copy the formula in cell B5 (\(=B3+B4\)) to cell C5. You can do this by using a simple copy and paste or click and drag B5 to C5 as shown below. The formula in B5 calculates the sum of values in the two cells B3 and B4.

7) Click in cell C5. The formula bar shows \(=C3+C4\) rather than \(=B3+B4\) and the value in C5 is 15, the sum of 4 and 11 which are the values in C3 and C4.

In cell B5 the references to cells B3 and B4 are relative references. This means that Calc interprets the formula in B5, applies it to the cells in the B column, and puts the result in the cell holding the formula. When you copied the formula to another cell, the same procedure was used to calculate the value to put in that cell. This time the formula in cell C5 referred to cells C3 and C4.

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>15</td>
<td>4</td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>46</td>
<td>11</td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td></td>
<td>61</td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Figure 208: Relative references

You can think of a relative address as a pair of offsets to the current cell. Cell B1 is 1 column to the left of Cell C5 and 4 rows above. The address could be written as R[-1]C[-4]. In fact earlier spreadsheets allowed this notation method to be used in formulas.

Whenever you copy this formula from cell B5 to another cell, the result will always be the sum of the two numbers taken from the two cells one and two rows above the cell containing the formula.

Relative addressing is the default method of referring to addresses in Calc.

**Absolute referencing**

You may want to multiply a column of numbers by a fixed amount. A column of figures might show amounts in US Dollars. To convert these amounts to Euros it is necessary to multiply each dollar amount by the exchange rate. $US10.00 would be multiplied by 0.75 to convert to Euros, in this case Eur7.50. The following example shows how to input an exchange rate and use that rate to convert amounts in a column form USD to Euros.

1) Input the exchange rate Eur:USD (0.75) in cell D1. Enter amounts (in USD) into cells D2, D3 and D4, for example 10, 20, and 30.

2) In cell E2 type the formula \(=D2*D1\). The result is 7.5, correctly shown.

3) Copy the formula in cell E2 to cell E3. The result is 200, clearly wrong! Calc has copied the formula using relative addressing: the formula in E3 is \(=D3*D2\) and not what we want, which is \(=D3*D1\).

4) In cell E2 edit the formula to be \(=D2*D$1\). Copy it to cells E3 and E4. The results are now 15 and 22.5 which are correct.

The $ signs before the D and the 1 convert the reference to cell D1 from relative to absolute or fixed. If the formula is copied to another cell the second part will always show $D$1. The
interpretation of this formula is “take the value in the cell one column to the left in the same row and multiply it by the value in cell D1”.

Enter the conversion formula into E2, correct result, then copy it to E3.

E3 result is clearly wrong; change the formula in E2 to read absolute reference.

Apply the correct formula from E2 to E3 to get the correct answer.

Figure 209: Absolute references

Cell references can be shown in four ways.

<table>
<thead>
<tr>
<th>Reference</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>D1</td>
<td>Relative, from cell E3 it is the cell one column to the left and two rows above</td>
</tr>
<tr>
<td>$D$1</td>
<td>Absolute, from cell E3 it is the cell D1</td>
</tr>
<tr>
<td>$D1$</td>
<td>Partially absolute, from cell E3 it is the cell in column D and two rows above</td>
</tr>
<tr>
<td>D$1</td>
<td>Partially absolute, from cell E3 it is the cell one column to the left and in row 1</td>
</tr>
</tbody>
</table>

Tip

To change references in formulas, highlight the cell and press F4 to cycle through the four types of references. To cycle only part of the formula select the cells in the formula bar and cycle with F4.

Knowledge of the use of relative and absolute references is essential if you want to copy and paste formulas and to link spreadsheets.
**Named ranges**

Cells and cell ranges can have a name assigned to them. Naming cells and ranges enhances formula readability and document maintenance. A simple example would be naming a range of cells B1:B10 as “Weight” and sum all weights. The formula is =SUM(B1:B10).

When the range B1:B10 is named as *Weight*, you can transform the formula to =SUM(Weight). The advantage is clear in terms of readability of the formulas.

Another advantage is that all formulas that have the named range as argument are updated when the named range changes location or size. For example, if the range *Weight* is now in cells P10:P30, you do not need to review all the formulas that have *Weight* as an argument; you only need to update the named range *Weight* with the new size and location.

To define a named cell or range select the cell or range and use menu **Sheet > Named Range and Expression > Define**. The dialog in Figure 210 appears with the selected range and you define the name and scope of the named range.

![Figure 210: Named range dialog](image)

You can also define a named range directly in the sheet by selecting the range and typing its name in the name box in the toolbar (Figure 211).

![Figure 211: Inserting name in the range box to define a named range](image)

To quickly access a named range, select the named range in the name box above. The named range is shown on the screen and selected.
**Named expressions**

You also can give a long or complex formula a name. To name a formula, open the Define Names dialog (Figure 210) and enter the formula expression in the **Range or formula expression** box. Name the expression and click **Add**.

As an example, suppose you need to compute in cells C1 to C10 the circumference of a set of circles and you are given their radius in B1 to B10. Define a named expression CIRCUMFERENCE, with expression =2*PI()*B1 and click **Add** to close the dialog. In cell C1, type =CIRCUMFERENCE and press **Enter**. The formula is applied to cell C1. Copy cell C1 and paste in the remaining cells from C2 to C10 and you have the circumferences of all the circles. Alls cell in range C1:C10 have the expression =CIRCUMFERENCE.

Note that the named expression use the same rules for cell addressing, that is, absolute and relative references.

**Order of calculation**

Order of calculation refers to the sequence in which numerical operations are performed. Division and multiplication are performed before addition or subtraction. There is a common tendency to expect calculations to be made from left to right as the equation would be read in English. Calc evaluates the entire formula, then based upon programming precedence breaks the formula down executing multiplication and division operations before other operations. Therefore, when creating formulas you should test your formula to make sure that the correct result is being obtained. Following is an example of the order of calculation in operation.

<table>
<thead>
<tr>
<th>Left To Right Calculation</th>
<th>Ordered Calculation</th>
</tr>
</thead>
<tbody>
<tr>
<td>1+3*2+3 = 11</td>
<td>=1+3*2+3 result 10</td>
</tr>
<tr>
<td>1+3 = 4, then 4 X 2 = 8</td>
<td>3*2 = 6, then 1+6+3 = 10</td>
</tr>
<tr>
<td>1+3 = 4, then 2+3 = 5</td>
<td>The program resolves the multiplication of 3 X 2 before dealing with the numbers being added.</td>
</tr>
<tr>
<td>1+3*2+3 = 20</td>
<td></td>
</tr>
<tr>
<td>1+3 = 4, then 2+3 = 5</td>
<td></td>
</tr>
<tr>
<td>4 X 5=20</td>
<td></td>
</tr>
</tbody>
</table>

If you intend for the result to be either of the two possible solutions on the left, order the formula as:

\[(1+3) * 2+3 = 11\]  \[(1+3) * (2+3) = 20\]

**Note**

Use parentheses to group operations in the order you intend; for example, =B4+G12*C4/M12 might become =((B4+G12)*C4)/M12.

**Calculations linking sheets**

Another powerful feature of Calc is the ability to link data through several worksheets. The naming of worksheets can be helpful to identify where specific data may be found. A name such as Payroll or Boise Sales is much more meaningful than Sheet1. The function named SHEET() returns the sheet number (position) in the collection of worksheets. There may be several worksheets in each book and they may be numbered from the left: Sheet1, Sheet2, and so forth. If you drag the worksheets around to different locations among the tabs, the function returns the number referring to the current position of this worksheet. In a new instance of Calc, the default is a single worksheet.
For example, if the formula =SHEET() is put into A1 on Sheet 1 it returns the value 1. If you drag Sheet 1 to be positioned between sheets 2 and 3 then the value changes to 2; it is now the second sheet in the order.

An example of calculations obtaining data from other work can be seen in a business setting where a business combines revenues and costs of each of its branch operations into a single combined worksheet. See Figure 212 on pages 236 and 237.
Sheet containing combined data for all branches.

Figure 212: Combining data from several sheets into a single sheet

The sheets have been set up with identical structures. The easiest way to do this is to open a new spreadsheet, set up the first Branch sheet, input data, format cells, and prepare the formulas for the various sums of rows and columns.

1) On the worksheet tab, right-click and select Rename Sheet. Type Branch1. Right-click on the tab again and select Move or Copy Sheet.

2) In the Move/Copy Sheet dialog (Figure 213), select the Copy option (automatically selected if there is only one sheet in the spreadsheet) and select -move to end position- in the Insert before window. Change the entry in New name to Branch2. Click OK. Repeat to produce the Branch3 and Combined worksheets.

3) Enter the data for Branch 2 and Branch 3 into the respective sheets. Each sheet stands alone and reports the results for the individual branches.

4) In the Combined worksheet, click on cell K7. Type =, click on the tab Branch1, click on cell K7, press +, repeat for sheets Branch2 and Branch3, and press Enter. You now have a formula in cell K7 which adds the revenue from Greenery Sales for the 3 Branches.

Figure 213: Copying a worksheet

228 | Creating formulas
5) Copy the formula, highlight the range K7:N17, click Edit > Paste Special, uncheck the Paste all and Formats boxes in the Selection area of the dialog, and click OK. You will see the following message:

![Figure 215: Linking sheets: pasting a formula to a cell range]

6) Click Yes. You have now copied the formulas into each cell while maintaining the format set up in the original worksheet. Of course, in this example you would have to tidy up the worksheet by removing the zeros in the non-formatted rows.

![Figure 216: Linking Sheets: Copy Paste Special from K7:N17]

**Note**

LibreOffice default is to paste all the attributes of the original cells: formats, notes, objects, text strings and numbers.
The Function Wizard can also be used to accomplish the linking. Use of this Wizard is described in detail in the section on Functions.

**Understanding functions**

Calc includes over 350 functions to help you analyze and reference data. Many of these functions are for use with numbers, but others are used with dates and times or even text. A function may be as simple as adding two numbers together or finding the average of a list of numbers, or it may be as complex as calculating the standard deviation of a sample or a hyperbolic tangent of a number.

Typically, the name of a function is an abbreviated description of what the function does. For instance, the FV function gives the future value of an investment, while BIN2HEX converts a binary number to a hexadecimial number. By tradition, functions are entered entirely in upper case letters, although Calc will read them correctly if they are in lower or mixed case, too.

A few basic functions are somewhat similar to operators. Examples:

+ This operator adds two numbers together for a result. SUM() on the other hand adds groups of contiguous ranges of numbers together.

* This operator multiplies two numbers together for a result. PRODUCT() does the same for multiplying that SUM() does for adding.

Each function has a number of arguments used in the calculations. These arguments may or may not have their own name. Your task is to enter the arguments needed to run the function. In some cases, the arguments have predefined choices, and you may need to refer to the Help or Appendix B (Description of Functions) in this book to understand them. More often, however, an argument is a value that you enter manually, or one already entered in a cell or range of cells in the spreadsheet. In Calc, you can enter values from other cells by typing in their name or range, or—unlike the case in some spreadsheets—by selecting cells with the mouse. If the values in the cells change, then the result of the function is automatically updated.

**Compatibility with other spreadsheet applications**

The Calc function set implements the ODFF (Open Document Formula Functions) standard published by OASIS and by ISO/IEC 26300. For compatibility, functions and their arguments in Calc have almost identical names to their counterparts in Microsoft Excel. However, both Excel and Calc have functions that the other lacks. Occasionally, functions with the same names in Calc and Excel have different arguments, or slightly different names for the same argument. However, the majority of functions can be used in both Calc and Excel without any change. A comparison list may be found on the LibreOffice wiki, see **Calc Functions Comparison**.

When function arguments or return values are not interoperable with Microsoft Excel, Calc introduce a suffix in the function name to distinguish the internal Calc function from the Excel function.

*function_ADD* and *function_EXCEL2003*

The functions whose names end with _ADD or _EXCEL2003 return the same results as the corresponding Microsoft Excel 2003 functions without the suffix. Use the functions without suffix to get results based on international standards.

*function.XCL*

If the spreadsheet is exported to Microsoft Excel, the function is exported as the equivalent function MATH that exists since Excel 2013. If you plan to use the spreadsheet with earlier Excel versions, use either function PRECISE that exists since Excel 2010, or function XCL that is exported as the function compatible with all Excel versions.

---

2 [https://www.iso.org/standard/66375.html](https://www.iso.org/standard/66375.html)
Understanding the structure of functions

All functions have a similar structure. If you use the right tool for entering a function, you can escape learning this structure, but it is still worth knowing for troubleshooting.

As a typical example, the structure of a function to find cells that match entered search criteria is:

= DCOUNT (Database, Database field, Search criteria)

A function cannot exist on its own; it must always be part of a formula. Consequently, even if the function represents the entire formula, there must be an = sign at the start of the formula.

Regardless of where in the formula a function is, the function will start with its name, such as DCOUNT in the example above. After the name of the function comes its arguments. All arguments are required, unless specifically listed as optional.

Arguments are added within the parentheses and are separated by commas, with no space between the arguments and the commas.

Many arguments are numbers. A Calc function can take up to thirty numbers as an argument. That may not sound like much, but the number can be not only a number or a single cell, but also an array or range of cells that contain several or even hundreds of cells.

Depending on the nature of the function, arguments may be entered as follows:

"text data"  The quotes indicate text or string data is being entered.
9  The number nine is being entered as a number.
"9"  The number nine is being entered as text
A1  The address for whatever is in Cell A1 is being entered

Nested functions

Functions can also be used as arguments within other functions. These are called nested functions.

=SUM(2, PRODUCT(5, 7))

To get an idea of what nested functions can do, imagine that you are designing a self-directed learning module. During the module, students do three quizzes, and enter the results in cells A1, A2, and A3. In A4, you can create a nested formula that begins by averaging the results of the quizzes with the formula =AVERAGE(A1:A3). The formula then uses the IF function to give the student feedback that depends upon the average grade on the quizzes. The entire formula would read:

=IF(AVERAGE(A1:A3) > 85, "Congratulations! You are ready to advance to the next module", "Failed. Please review the material again. If necessary, contact your instructor for help")

Depending on the average, the student would receive the message for either congratulations or failure.

Notice that the nested formula for the average does not require its own equal sign. The one at the start of the equation is enough for both formulas.

If you are new to spreadsheets, the best way to think of functions is as a scripting language. We have used simple examples to explain the concept more clearly, but, through nesting of functions, a Calc formula can quickly become complex.

Note

Calc keeps the syntax of a formula displayed in a tool tip next to the cell as a handy memory aid as you type.
Using the Functions List

A more reliable method is to use the Functions List on the Sidebar (Figure 217).

The Functions List includes a brief description of each function and its arguments. Highlight the function and look at the bottom of the pane to see the description. If necessary, hover the cursor over the division between the list and the description; when the cursor becomes a two-headed arrow, drag it upwards to increase the space for the description. Double-click on a function’s name to add it to the current cell, together with placeholders for each of the function’s arguments.

Using the Functions List is almost as fast as manual entry, and has the advantage of not requiring that you memorize a formula that you want to use. In theory, it should also be less error-prone. In practice, though, some users may fumble when replacing the placeholders with values. Another feature is the ability to display the last formulas used.

Using the Function Wizard

The most commonly used input method is the Function Wizard (Figure 218). To open it, choose Insert > Function, or click the fx button on the Formula bar, or press Ctrl+F2. The Function Wizard provides the same help features as the Functions List, but adds fields in which you can see the result of a completed function, as well as the result of any larger formula of which it is part.

Select a category of functions to shorten the list, then scroll down through the named functions and select the required one by double-clicking on it. When you select a function its description appears on the right-hand side of the dialog. Optionally you can type the function name in the search box and the search narrows on each character inserted (Figure 218).

The Wizard now displays an area to the right where you can enter data manually in text boxes or click the Shrink button to shrink the wizard so you can select cells from the worksheet.
To select cells, either click directly on the cell or hold down the left mouse button and drag to select the required area.

When the area has been selected, click the **Shrink** button again to return to the wizard.

If multiple arguments are needed click in the next text box and repeat the selection process for the next cell or range of cells. Repeat this process as often as required. The Wizard will accept up to 30 ranges or arguments in the SUM function.

Click **OK** to accept the function and add it to the cell and get the result.

**Caution**

If you select a function by double-clicking it in the list, and then change your mind and select a different one by double-clicking again, then the second choice formula is added into the first choice formula in the Formula text box. You must clear the formula box and then double-click the function to add it to the box.

This additive facility allows you to create complex formulas by building them up in the Formula box.

You can also select the Structure tab to see a tree view of the parts of the formula. The main advantage over the Functions List is that each argument is entered in its own field, making it easier to manage. The price of this reliability is slower input, but precision is generally more important than speed when creating a spreadsheet.
The structure view of the wizard is important for debugging and fixing very long, nested, and complex formulas. In this view, the formula is parsed, and each formula component is calculated by a simpler function call or arithmetic operation and then combined following the rules of calculation. It is possible to visualize each parsed element of the formula and check if the intermediate results are correct, until the mistake is found.

Functions can be entered into the Input line. After you enter a function on the Input line, press the Enter key or click the Accept button on the Formula toolbar to add the function to the cell and get its result.

1 Name Box showing list of common functions
2 Function Wizard
3 Cancel
4 Accept
5 Input Line

Figure 220: The Function toolbar

If you see the formula in the cell instead of the result, then Formulas are selected for display in Tools > Options > LibreOffice Calc > View > Display. Deselect Formulas, and the result will display. However, you can still see the formula in the Input line.

**Array formulas**

*What is an array formula?*

A formula in which the individual values in a cell range are evaluated is referred to as an array formula. The difference between an array formula and other formulas is that the array formula deals with several values simultaneously instead of just one.

Not only can an array formula process several values, but it can also return several values. The results of an array formula is also an array.

When Calc updates the formulas, each affected cell is read and its formula is recalculated. If you have a thousand cells in a column with the same formula (the formula expression only changes the data to compute), you end with one thousand identical formulas to interpret and execute.

Array formulas will evaluate the formula once and execute calculations as many time as the size of the array, thus saving the time used to interpret each cell formula. And because Calc stores only one formula for the entire array of data cells, it also save space in the spreadsheet file.

To multiply the values in the individual cells by 10 in the above array (Figure 221), you do not need to apply a formula to each individual cell or value. Instead you just need to use a single array formula. Select a range of 3 x 5 cells on another part of the spreadsheet, enter the formula =10*A1:C5 and confirm this entry using the key combination Ctrl+Shift+Enter. The result is a 3 x 5 array in which the individual values in the cell range (A1:C5) are multiplied by a factor of 10.
In addition to multiplication, you can also use other operators on the reference range (an array). With Calc, you can add (+), subtract (-), multiply (*), divide (/), use exponents (^), concatenation (&) and comparisons (=, <>, <, >, <=, >=). The operators can be used on each individual value in the cell range and return the result as an array if the array formula was entered.

Comparison operators in an array formula treat empty cells in the same way as in a normal formula, that is, either as zero or as an empty string. For example, if cells A1 and A2 are empty the array formulas {=A1:A2=""} and {=A1:A2=0} will both return a 1 column 2 row array of cells containing TRUE.

When do you use array formulas?
Use array formulas if you have to repeat calculations using different values. If you decide to change the calculation method later, you only have to update the array formula. To add an array formula, select the entire array range and then make the required change to the array formula.

Arrays are an essential tool for carrying out complex calculations, because you can have several cell ranges included in your calculations. Calc has different math functions for arrays, such as the MMULT function for multiplying two arrays.

Creating array formulas
If you create an array formula using the Function Wizard, you must mark the Array check box each time so that the results are returned in an array (Figure 218). Otherwise, only the value in the upper-left cell of the array being calculated is returned.

If you enter the array formula directly into the cell, you must use the key combination Shift+Ctrl+Enter instead of the Enter key. Only then does the formula become an array formula.

Note
Array formulas appear in braces (curly brackets) in Calc. You cannot create array formulas by manually entering the braces.

Warning
The cells in a results array are automatically protected against changes. However, you can edit or copy the array formula by selecting the entire array cell range.

Strategies for creating formulas and functions
Formulas that do more than a simple calculation or summation of rows or columns of values usually take a number of arguments. For example, the classic equation of motion

\[ s = s_0 + vt - \frac{1}{2}at^2 \]

calculates the position of a body knowing its original position (s0), its current velocity (v), its acceleration (a), and the time taken to move from the initial state to the final state.

For ease of presentation, it is good practice to set up a spreadsheet in a manner similar to that shown in Figure 222. In this example, the individual variables are input into cells on the sheet and no editing of the formula (in cell B9) is required.
You can take several broad approaches when creating a formula. In deciding which approach to take, consider how many other people will need to use the worksheets, the life of the worksheets, and the variations that could be encountered in use of the formula.

If people other than yourself will use the spreadsheet, make sure that it is easy to see what input is required and where. Explanation of the purpose of the spreadsheet, basis of calculation, input required and output generated are often placed on the first worksheet.

A spreadsheet that you build today, with many complicated formulas, may not be quite so obvious in its function and operation in 6 or 12 months. Use comments and notes liberally to document your work.

You might be aware that you cannot use negative values or zero values for a particular argument, but if someone else inputs such a value, will your formula be robust or simply return a standard (and often not too helpful) Err message? It is a good idea to trap errors using some form of logic statements or with conditional formatting.

**Place a unique formula in each cell**

The most basic strategy is to view whatever formulas are needed as simple and with a limited useful life. The strategy is then to place a unique formula in each appropriate cell. This can be recommended only for very simple or “throw away” (single use) spreadsheets.

**Break formulas into parts and combine the parts**

The second strategy is similar to the first, but instead you break down longer formulas into smaller parts and then combine the parts into the whole. Many examples of this type exist in complex scientific and engineering calculations where interim results are used in a number of places in the worksheet. The result of calculating the flow velocity of water in a pipe may be used in estimating losses due to friction, whether the pipe is flowing full or partially empty, and in optimizing the diameter for the given flow regime.

In all cases you should adopt the basic principles of formula creation described previously.

**Speeding up calculations**

Spreadsheets are often used to process raw data and produce meaningful summaries, consolidation and display of information for the decision maker or to be source for reports. The raw data can be produced by physical measurements, business transactions, or even data gathering of many nature. Computations carried on these raw data can be time consuming and last for minutes, hours and perhaps, days. Sheets with thousands or even hundreds of thousands rows and several columns are frequently found in finance departments or laboratories.

A common mistake is to insert formulas for each cell and perform thousands of formulas interpretation and calculations. Here are some recommendation for speeding up calculations.
Use array formulas on massive data

Array formulas have one formula applied to the mass of data. Computation saving can be significant for large data sets.

Use consolidation functions

Consolidation functions perform calculations on data sets. SUM, SUMIF, SUMPRODUCT are examples of consolidation functions. For example if you have a very long bill of materials, where quantity must be multiplied to unit price and then totaled to produce a cost figure, then instead applying a formula on each entry of the BOM and then sum, you can use the formula SUMPRODUCT(quantity;unitprice), where quantity and unitprice are named ranges representing the BOM. SUMPRODUCT multiplies each cell of quantity data set by its corresponding cell of unitprice and sum all the products.

Similar situation happens when you must sum a subset of the original data set, where you must apply a test on each entry to allow it to be part of the sum. For example, when the value is strictly positive. Use SUMIF(data_to_test;">0";data_to_sum), where data_to_test is the data set where you test the positive values, data_to_sum is the column where the values are to sum depending on the test and ">0" is the test itself.

Other consolidation functions are SUMIFS, AVERAGEIF, COUNTIF, MINIF, MAXIF and more.

Use the Basic editor to create functions

A third strategy is to use the Basic editor and create your own functions and macros. This approach would be used where the result would greatly simplify the use of the spreadsheet by the end user and keep the formulas simple with a better chance of avoiding errors. This approach also can make the maintenance easier by having corrections or updates kept in one central location. The use of macros is described in Chapter 12 of this book and is a specialized topic in itself. The danger of overusing macros and custom functions is that the principles upon which the spreadsheet is based become much more difficult to see by a user other than the original author (and sometimes even by the author!).

Finding and fixing errors

It is common to find situations where errors are displayed. Even with all the tools available in Calc to help you to enter formulas, making mistakes is easy. Many people find inputting numbers difficult and many may make a mistake about the kind of entry that a function's argument needs. In addition to correcting errors, you may want to find the cells used in a formula to change their values or to check the answer.

Calc provides three tools for investigating formulas and the cells that they reference: error messages, color coding, and the Detective.

Error messages

The most basic tool is error messages. Error messages display in a formula's cell or in the Function Wizard instead of the result.

An error message for a formula is usually a three-digit number from 501 to 527, or sometimes an unhelpful piece of text such as #NAME?, #REF, or #VALUE. The error number appears in the cell, and a brief explanation of the error on the right side of the status bar.

Most error messages indicate a problem with how the formula was input, although several indicate that you have run up against a limitation of either Calc or its current settings.

Error messages are not user-friendly, and may intimidate new users. However, they are valuable clues to correcting mistakes. You can find detailed explanations of them in the Help, by searching for Error codes in Calc. A few of the most common are shown in the following table.
Examples of common errors

#DIV/0! Division by zero

This error is the result of dividing a number by either the number zero (0) or a blank cell. There is an easy way to avoid this type of problem. When you have a zero or blank cell displayed, use a conditional function. Figure 223 depicts division of column B by column C yielding 2 errors arising from a zero and a blank cell showing in column C.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Date</td>
<td>Patients</td>
<td>Nursing Staff</td>
</tr>
<tr>
<td>2</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>01/05/2007</td>
<td>24</td>
<td>5</td>
</tr>
<tr>
<td>4</td>
<td>02/05/2007</td>
<td>16</td>
<td>5</td>
</tr>
<tr>
<td>5</td>
<td>03/05/2007</td>
<td>21</td>
<td>3</td>
</tr>
<tr>
<td>6</td>
<td>04/05/2007</td>
<td>17</td>
<td>0</td>
</tr>
<tr>
<td>7</td>
<td>05/05/2007</td>
<td>18</td>
<td>4</td>
</tr>
<tr>
<td>8</td>
<td>06/05/2007</td>
<td>17</td>
<td>0</td>
</tr>
<tr>
<td>9</td>
<td>07/05/2007</td>
<td>19</td>
<td>5</td>
</tr>
<tr>
<td>10</td>
<td>08/05/2007</td>
<td>22</td>
<td>4</td>
</tr>
<tr>
<td>11</td>
<td>09/05/2007</td>
<td>21</td>
<td>4</td>
</tr>
<tr>
<td>12</td>
<td>10/05/2007</td>
<td>18</td>
<td>3</td>
</tr>
<tr>
<td>13</td>
<td>11/05/2007</td>
<td>19</td>
<td>4</td>
</tr>
</tbody>
</table>

Figure 223: Examples of #DIV/0!, Division by zero error

It is very common to find an error such as this arising from a situation where data was not reported or reported incorrectly. When such an occurrence is possible, an IF function can be used to display the data correctly. The formula =IF(C3>0, B3/C3, "No Report") can be entered. The formula is then copied over the remainder of Column D. The meaning of this formula roughly would be: “If C3 is greater than 0, then compute B3 divided by C3, otherwise enter ‘No Report’”.

It is also possible for the last parameter to use double quotes for a blank (no value) to be entered, or a different formula with a standardized number being substituted for the lower number. An example is shown in Figure 224.
#VALUE No result and #REF Incorrect references

The #Value error is also very common.

A common occurrence of this error arises when a cell contains an incorrect value type. In the example of Figure 225, text “None” has been entered in C8, where our formula in column D is expecting a number.

The #REF error is caused by a missing reference. In the example below, the formula references a sheet that has been deleted.

Color coding for input

Another useful tool when reviewing a formula is the color coding for input. When you select a formula that has already been entered, the cells or ranges used for each argument in the formula are outlined in color.
Calc uses eight colors for outlining referenced cells, starting with blue for the first cell, and continuing with red, magenta, green, dark blue, brown, purple and yellow before cycling through the sequence again.

**Value highlighting**

There are situations where the display of cell contents is the same when the data type is different. For example a text contents and a numeric contents can look the same but can produce mistake if both are used in some calculations. To illustrate, the string “10.35” right-aligned in a cell can be confused with the value 10.35. When the cell is used in a formula the string takes value of zero an an error is produced.

The value highlighting will distinguish the text and numeric data types by assigning different color to the contents characters. By default, the text contents is in black characters and the numeric contents is in blue. See Chapter 2 for more information on value highlighting.

**The Detective**

In a long or complicated spreadsheet, color coding becomes less useful. In these cases, consider using the submenu under Tools > Detective. The Detective is a tool for checking which cells are used as arguments by a formula (precedents) and which other formulas it is nested in (dependents), and tracking errors. It can also be used for tracing errors, marking invalid data (that is, information in cells that is not in the proper format for a function’s argument), or even for removing precedents and dependents.

To use the Detective, select a cell with a formula, then start the Detective. On the spreadsheet, you will see lines ending in circles to indicate precedents, and lines ending in arrows for dependents. The lines show the flow of information.

Use the Detective to assist in following the precedents referred to in a formula in a cell. By tracing these precedents, you frequently can find the source of the errors. Place the cursor in the cell in question and then choose Tools > Detective > Trace Precedents from the Menu bar or press Shift+F7. Figure 227 shows a simple example of tracing precedents.

![Figure 227: Tracing precedents using the Detective](image)

This allows us to check the source cells (which may be a range) for any errors which have caused us to query the calculation result. If a source is a range, then that range is highlighted in blue.

In other instances we may have to trace an error. For this we use the Trace Error function, found under Tools > Detective > Trace Error, to find the cells that caused the error.

**Examples of functions**

For novices, functions are one of the most intimidating features of LibreOffice Calc. New users quickly learn that functions are an important feature of spreadsheets, but there are hundreds, and many require input that assumes specialized knowledge. Fortunately, Calc includes dozens of functions that anyone can use.
Basic arithmetic and statistics

The most basic functions create formulas for basic arithmetic or for evaluating numbers in a range of cells.

**Basic arithmetic**

The simple arithmetic functions are addition, subtraction, multiplication, and division. Except for subtraction, each of these operations has its own function:

- **SUM** for addition
- **PRODUCT** for multiplication
- **QUOTIENT** for division

Traditionally, subtraction does not have a function.

SUM, PRODUCT, and QUOTIENT are useful for entering ranges of cells in the same way as any other function, with arguments in brackets after the function name.

However, for basic equations, many users prefer the time-honored computer symbols for these operations, using the plus sign (+) for addition, the hyphen (–) for subtraction, the asterisk (*) for multiplication and the forward slash (/) for division. These symbols are quick to enter without requiring your hands to stray from the keyboard.

A similar choice is also available if you want to raise a number by the power of another. Instead of entering =POWER(A1,2), you can enter =A1^2.

Moreover, they have the advantage that you enter formulas with them in an order that more closely approximates human readable format than the spreadsheet-readable format used by the equivalent function. For instance, instead of entering =SUM (A1:A2), or possibly =SUM (A1,A2), you enter =A1+A2. This almost-human readable format is especially useful for compound operations, where writing =A1*(A2+A3) is briefer and easier to read than =PRODUCT(A1,SUM(A2:A3)).

The main disadvantage of using arithmetical operators is that you cannot directly use a range of cells. In other words, to enter the equivalent of =SUM (A1:A3), you would need to type =A1+A2+A3.

Otherwise, whether you use a function or an operator is largely up to you—except, of course, when you are subtracting. However, if you use spreadsheets regularly in a group setting such as a class or an office, you might want to standardize on an entry format so that everyone who handles a spreadsheet becomes accustomed to a standard input.

**Simple statistics**

Another common use for spreadsheet functions is to pull useful information out of a list, such as a series of test scores in a class, or a summary of earnings per quarter for a company.

You can, of course, scan a list of figures if you want basic information such as the highest or lowest entry or the average. The only trouble is, the longer the list, the more time you waste and the more likely you are to miss what you are looking for. Instead, it is usually quicker and more efficient to enter a function. Such reasons explain the existence of a function like COUNT, which does no more than give the total number of entries in the designated cell range.

Similarly, to find the highest or lowest entry, you can use MIN or MAX. For each of these formulas, all arguments are either a range of cells, or a series of cells entered individually.

Each also has a related function, MINA or MAXA, which performs the same function, but also treats a cell formatted for text as having a value of 0. (The same treatment of text occurs in any variation of another function that adds an "A" to the end.) Either function gives the same result, and could be useful if you used a text notation to indicate, for example, if any students were absent when a test was written, and you wanted to check whether to schedule a makeup exam.
For more flexibility in similar operations, you could use LARGE or SMALL, both of which add a specialized argument of rank. If the rank is 1 used with LARGE, you get the same result as you would with MAX. However, if the rank is 2, then the result is the second largest result. Similarly, a rank of 2 used with SMALL gives you the second smallest number. Both LARGE and SMALL are handy as a permanent control, since, by changing the rank argument, you can quickly scan multiple results.

You would need to be an expert to want to find the Poisson Distribution of a sample, or to find the skew or negative binomial of a distribution (and, if you are, you will find functions in Calc for such things). However, for the rest of us, there are simpler statistical functions that you can quickly learn to use.

In particular, if you need an average, you have a number of functions to choose from. You can find the arithmetical mean—that is, the result when you add all entries in a list then divided by the number of entries, by entering a range of numbers when using AVERAGE, or AVERAGE A to include text entries and to give them a value of zero.

In addition, you can get other information about the data set:

- **MEDIAN**: The entry that is exactly half way between the highest and lowest number in a list.
- **MODE**: The most common entry in a list of numbers.
- **QUARTILE**: The entry at a set position in the array of numbers. Besides the cell range, you enter the type of Quartile: 0 for the lowest entry, 1 for the value of 25%, 2 for the value of 50%, 3 for 75%, and 4 for the highest entry. Note that the result for types 1 through 3 may not represent an actual item entered.
- **RANK**: The position of a given entry in the entire list, measured either from top to bottom or bottom to top. You need to enter the cell address for the entry, the range of entries, and the type of rank (0 for the rank from the highest, or 1 for the rank from the bottom).

Some of these functions overlap; for example, MIN and MAX are both covered by QUARTILE. In other cases, a custom sort or filter might give much the same result. Which you use depends on your temperament and your needs. Some might prefer to use MIN and MAX because they are easy to remember, while others might prefer QUARTILE because it is more versatile.

**Using these functions**

In some cases, you may be able to get similar results to some of these functions by setting up a filter or a custom sort. However, in general, functions are more easily adjusted than filters or sorts, and provide a wide range of possibilities.

At times, you may just want to enter one or more formulas temporarily in a convenient blank cell, and delete it once you have finished. However, if you find yourself using the same functions constantly, you should consider creating a template and including space for all the functions you use, with the cell to their left used as a label for them. Once you have created the template, you can easily update each formula as entries change, either automatically and on-the-fly or pressing the F9 key to update all selected cells.

No matter how you use these functions, you will probably find them simple to use and adaptable for many purposes. By the time you have mastered this handful, you will be ready to try more complex functions.

**Rounding off numbers**

For statistical and mathematical purposes, Calc includes a variety of ways to round off numbers. If you are a programmer, you may also be familiar with some of these methods. However, you do not need to be a specialist to find some of these methods useful. You may want to round off for billing purposes, or because decimal places do not translate well into the physical world—for instance, if the parts you need come in packages of 100, then the fact you only need 66 is irrelevant to you;
you need to round up for ordering. By learning the options for rounding up or down, you can make your spreadsheets more immediately useful.

When you use a rounding function, you have two choices about how to set up your formulas. If you choose, you can nest a calculation within one of the rounding functions. For instance, the formula =ROUND((SUM(A1,A2)) adds the figures in cells A1 and A2, then rounds them off to the nearest whole number. However, even though you do not need to work with exact figures every day, you may still want to refer to them occasionally. If that is the case, then you are probably better off separating the two functions, placing =SUM(A1,A2) in cell A3, and =ROUND(A3) in A4, and clearly labeling each function.

For details on rounding methods, see the Help.

**Using wildcards and regular expressions in functions**

In computing, a wildcard refers to a character that can be substituted for zero or more characters in a string. Wildcards are commonly used in computer programming, search queries, and when navigating through directories using the command prompt. Wildcards are typically either an asterisk (*), which represents one or more characters, or a question mark (?), which represents a single character.

A regular expression (regex or regexp) is a sequence of characters that define a search pattern. Usually this pattern is then used by string searching algorithms for “find” or “find and replace” operations on strings. Regular expressions are more powerful than wildcards for text extraction or replacement.

Calc uses wildcards or regular expressions to search in text arguments of many of its functions. Regular expressions are defined by the ICU project³.

---

**Note**

Regular expressions and wildcards are mutually exclusive; that is, only one can have the value TRUE. Internally, if both are true then wildcards take precedence over regular expressions.

---

A number of functions in Calc allow the use of wildcards or regular expressions: REGEX, SUMIF, COUNTIF, MATCH, SEARCH, LOOKUP, HLOOKUP, VLOOKUP, DCOUNT, DCOUNTA, DSUM, DPRODUCT, DMAX, DMIN, DAVERAGE, DSTDEV, DSTDEVN, DVAR, DVARP, DGET.

Whether or not wildcards and regular expressions are used is selected on the Tools > Options > LibreOffice Calc > Calculate dialog (Figure 228). Wildcards are enabled in a default installation.

For example =COUNTIF(A1:A6,"r.d") with Enable regular expressions in formulas selected will count cells in A1:A6 which contain red and ROD (see Figure 229).

Additionally if Search criteria = and <> must apply to whole cells is not selected, then Fred, bride, and Ridge will also be counted. If that setting is selected, then it can be overcome by wrapping the expression thus: =COUNTIF(A1:A6, ".*r.d.*").
Regular expression searches within functions are always case insensitive, irrespective of the setting of the Case sensitive checkbox on the dialog in Figure 228—so red and ROD will always be matched in the above example. This case-insensitivity also applies to the regular expression structures ([:lower:]) and ([:upper:]), which match characters irrespective of case.

Regular expressions will not work in simple comparisons. For example: A1="r.d" will always return FALSE if A1 contains red, even if regular expressions are enabled. It will only return TRUE if A1 contains r.d (r then a dot then d). If you wish to test using regular expressions, try the COUNTIF function: COUNTIF(A1,"r.d") will return 1 or 0, interpreted as TRUE or FALSE in formulas like =IF(COUNTIF(A1,"r.d"),"hooray","boo").

Activating the **Enable regular expressions in formulas** option means all the above functions will require any regular expression special characters (such as parentheses) used in strings within formulas, to be preceded by a backslash, despite not being part of a regular expression. These backslashes will need to be removed if the setting is later deactivated.
Advanced functions

As is common with other spreadsheet programs, Calc can be enhanced by user-defined functions or add-ins. Setting up user-defined functions can be done either by using the Basic IDE or by writing separate add-ins or extensions.

The basics of writing and running macros is covered in Chapter 12, Calc Macros. Macros can be linked to menus or toolbars for ease of operation or stored in template modules to make the functions available in other documents.

Calc Add-ins are specialized office extensions which can extend the functionality of LibreOffice with new built-in Calc functions. A number of extensions for Calc have been written; these can be found on the extensions site at https://extensions.libreoffice.org/. Refer to Chapter 14, Setting Up and Customizing Calc, for more details.
Chapter 8
Using Pivot Tables
Introduction

Many requests for spreadsheet support are the result of using complicated formulas and solutions to solve simple day-to-day problems. For more efficient and effective solutions, use the pivot table, a tool for combining, comparing, and analyzing large amounts of data easily. Using pivot tables, you can view different summaries of the source data, display the details of areas of interest, and create reports, whether you are a beginner, an intermediate user, or an advanced user. In addition you can create a pivot chart to view a graphical representation of the data in a pivot table.

Database preconditions

To work with a pivot table, you need a list of raw data, similar to a database table, consisting of rows (data sets) and columns (data fields). The field names are in the first row above the list.

The data source could be an external file or database. For the simplest case, where data is contained in a Calc spreadsheet, Calc offers sorting functions that do not require the pivot table.

For processing data in lists, Calc needs to know where in the spreadsheet the list is. The list can be anywhere in the sheet, in any position. A spreadsheet can contain several unrelated lists.

Calc recognizes your lists automatically. It uses the following logic: Starting from the cell you have selected (which must be within the list), Calc checks the surrounding cells in all four directions (left, right, above, below). The border is recognized if the program discovers an empty row or column, or if it hits the left or upper border of the spreadsheet. This means that the described functions can only work correctly if there are no empty rows or columns in the list. Avoid empty lines (for example for formatting). You can format the list by using cell formats.

Note

To make sure that Calc automatically recognizes a list correctly, check that there are no empty rows or empty columns within the list.

If you select more than one cell before you start sorting, filtering, or creating the pivot table, then the automatic list recognition is switched off. Calc assumes that the list matches exactly the cells you have selected.

Tip

For sorting, filtering, or using the pivot table, always select only one cell to allow Calc to determine the scope of the list.

A relatively common source of errors is to inadvertently declare a list by mistake and then to sort that list. If you select multiple cells—for example, a whole column—then the sorting mixes up the data that should be together in one row.

In addition to these formal aspects, the logical structure of the list is also very important.

Note

Calc lists must have the normal form; that is, they must have a simple linear structure.

When entering the data, do not add outlines, groups, or summaries. Here are some mistakes commonly made by inexperienced spreadsheet users:

- You made several unnecessary sheets; for example, a sheet for each group of articles. In this case, analyses are then possible only within each group.
- In a Sales list, instead of only one column for the amount, you made a column for the amounts for each employee. In this case, the system will have difficulty grouping data from
the various columns together. Thus, an analysis with the pivot table would no longer be possible. All data must be entered into the same column for the pivot table to be able to analyze it.

- You entered the amounts in chronological order. At the end of each month, you made a sum total. In this case, sorting the list for different criteria is not possible because the pivot table will treat the sum totals the same as any other value. Getting monthly results is one of the very fast and easy features of the pivot table.

**Data sources**

The possible data sources for the pivot table are a Calc spreadsheet or an external data source that is registered in LibreOffice.

**Calc spreadsheet**

Analyzing a list in a Calc spreadsheet is the simplest and most often used case. Lists might be updated regularly or the data might be imported from a different application.

The list data might be entered directly into the spreadsheet or copied from another file or application. You can also use a Web Page Query input filter to insert data from a HTML file, a CSV file, a Calc spreadsheet, or a Microsoft Excel spreadsheet. See Chapter 10, Linking Calc Data, for more information.

The behavior of Calc while inserting data from a different application depends on the format of the data. If the data is in a common spreadsheet format, it is copied directly into Calc. However, if the data is in plain text format, the Text Import dialog appears after you select the file containing the data; see Chapter 1, Introducing Calc, for more information about this dialog.

**Registered data source**

A registered data source is a connection to data held in a database outside of LibreOffice. When using a registered data source, the data to be analyzed will not be saved in Calc; Calc always uses the data from the original source. Calc is able to use many different data sources in addition to databases that are created and maintained with LibreOffice Base. For more information, see Chapter 10, Linking Calc Data.

**Using shortcuts**

If you use pivot tables often in Calc, you might find the frequent use of the built-in menu paths inconvenient.

In some cases built-in keyboard shortcuts are already defined; see Appendix A, Keyboard Shortcuts. An example is the F12 function key, which groups a selected data range. In some other cases, the built-in toolbars already provide relevant icons. An example is the Insert Pivot Table icon on the Standard toolbar.

In addition to using the built-in keyboard shortcuts and toolbar icons, you can also define your own. See Chapter 14, Setting Up and Customizing Calc, for instructions.

**Creating a pivot table**

If you want Calc to automatically determine the full extent of the raw data list, then select a single cell within this list. If you want to explicitly define the extent of the raw data list then select all relevant cells.

Create the pivot table by selecting Data > Pivot Table > Create from the Menu bar, selecting Insert > Pivot Table from the Menu bar, or clicking the Insert Pivot Table icon in the Standard toolbar.
Calc displays the Select Source dialog (Figure 230), where you can choose between using the selected data cells, a range of cells that has already been named, or a data source that has already been registered with LibreOffice.

**Note**

See Chapter 13, Calc as a Simple Database, for more information about named ranges. See Chapter 10, Linking Calc Data, for more information about linking to registered data sources.

Click **OK** on the Select Source dialog to display the Pivot Table Layout dialog, which is described in the next section.

**The Pivot Table Layout dialog**

The function of the pivot table is managed in two places: first, in the Pivot Table Layout dialog; and second, through manipulations of the result in the spreadsheet. This section describes the Pivot Table Layout dialog in detail.

**Tip**

To access the Pivot Table Layout dialog again after initial creation of the pivot table, right-click in the results area of the pivot table and select the **Edit Layout** option from the context menu. Alternatively left-click in the results area and select the **Insert Pivot Table** icon in the Standard toolbar.
Basic layout

In the Pivot Table Layout dialog (Figure 231) are four areas that show the layout of the resulting pivot table:

- **Page Fields**
- **Column Fields**
- **Row Fields**
- **Data Fields**

Beside these four areas is another area labeled **Available Fields** that contains the names of the fields in the source data list. To choose a layout, drag and drop the fields from the **Available Fields** area to the other four areas.

The **Data Fields** area must contain at least one field. Advanced users can use more than one field here. For the fields in the **Data Fields** area, an aggregate function is used. For example, if you move the **Sales Value** field into the **Data Fields** area, it initially appears there as **Sum – Sales Value**.

![Figure 231: Pivot Table Layout dialog](image-url)
Row and column fields indicate from which groups the result will be sorted. Often more than one field is used at a time to get partial sums for rows or columns. The order of the fields gives the order of the sums from overall to specific.

For example, if you drag Region and Employee into the Row Fields area, the sum will be divided into the regions. Within the regions will be the listing for the different employees (Figure 232).

![Figure 232: Field order for analysis and resulting layout of pivot table](image)

Fields that are placed into the Page Fields area appear at the top of the resulting pivot table as a drop-down list. The summary in the result takes into account only that part of the base data that you have selected. For example, if you include Employee in the Page Fields area, you can filter the result shown for each employee.

To move a field from an area, just drag it to a new area. To remove a field from the Page Fields, Column Fields, Row Fields, or Data Fields areas, drag it to the Available Fields area.

**Tip**

To rapidly move a selected field from one area of the Pivot Table Layout dialog to another, press the letter on the keyboard that corresponds to the underlined letter in the target area’s label.

**More options**

To expand the Pivot Table Layout dialog and show more options, click the plus signs adjacent to the Options and Source and Destination labels (Figure 233).

**Ignore empty rows**

If the source data is not in the recommended form, this option tells the pivot table to ignore empty rows.
Identify categories

With this option selected, if the source data has missing entries in a list and does not meet the recommended data structure (as in Figure 234 for example), the pivot table adds it to the listed category above it. If this option is not chosen, then the pivot table inserts (empty) (Figure 236).

![Figure 234: Example of data with missing entries in Column A](image)

The option **Identify categories** ensures that in this example rows 3 and 4 are included for Apples and that row 6 is included for Pears (Figure 235).

![Figure 235: Pivot table result with Identify categories selected](image)

Without category recognition, the pivot table shows an (empty) category (Figure 236).

![Figure 236: Pivot table result without Identify categories selected](image)
Logically, the behavior with category recognition is better. A list showing missing entries is also less useful, because you cannot use functions such as sorting or filtering.

**Total columns, Total rows**
With these options you can decide if the pivot table shows an extra row with the sums of each column, or if it adds on the very right a column with the sums of each row. In some cases, an added total sum is meaningless, for example if the entries are accumulated or the result of comparisons.

**Add filter**
Use this option to add or hide the cell labeled Filter above the pivot table results. This conveniently provides additional filtering options within the pivot table. For more information, see “Filtering” on page 278.

**Enable drill to details**
With this option enabled, if you double-click on a single data cell in the pivot table result, including a cell produced from Total columns or Total rows, a new sheet opens giving a detailed listing of the individual entry. If you double-click on a cell in either a row or column field area, then the Show Detail dialog opens (Figure 267). If this function is disabled, the double-click will keep its usual edit function within a spreadsheet. For more information, see “Drilling (showing details)” on page 277.

**Source**
The Selection field in this area shows the sheet name and the range of cells containing the raw data for the pivot table. If the source spreadsheet contains any named ranges, these can be selected through the Named range option.

**Destination**
The controls in this area define where the result will be shown.

Selecting New sheet adds a new sheet to the spreadsheet file and places the results there. The new sheet is named using the format Pivot Table_sheetname_X; where X is the number of the table created, 1 for first, 2 for second and so on. For a sheet named Sales List, the new sheet for the first pivot table produced would be named Pivot Table_Sales List_1. Each new sheet is inserted next to the source sheet.

If the target spreadsheet contains any named ranges, these can be selected with the Named range option.

The Selection field in this area shows the sheet name and the range of cells for the pivot table’s results.

**Tip**
To display the pivot table on the same sheet as the raw data, check the Selection option in the Destination area, click in the Selection field, click the Shrink button to the right of the Selection field, click at an appropriate cell in an empty area of the sheet, click the Expand button, and click OK on the Pivot Table Layout dialog.

**More settings for the fields: Field options**
The options discussed in the previous section are valid for the pivot table in general. You can also change settings for any field that is currently included in the pivot table layout (that is, fields within the Page, Column, Row, and Data Fields areas). Change a field’s settings by double-clicking that field within the Page, Column, Row, or Data Fields areas of the Pivot Table Layout dialog. Double-clicking a field within the Available Fields area has no effect. The options available for fields in the Data Fields area differ from those for fields in the other three areas.
Options for data fields

Double-click a field in the Data Fields area of the Pivot Table Layout dialog to access the Data Field dialog shown in Figure 237.

In the Data Field dialog, you can select the function to be used to accumulate the values from the data source. While you often use the Sum function, other functions (like standard deviation or a counting function) are also available. For example, the counting function can be useful for non-numerical data fields.

Select the Show items without data option to include empty columns and rows in the results table.

Click the expansion symbol (plus sign or triangle) to expand the Displayed value section of the dialog.

![Figure 237: Expanded dialog for a data field](image)

In the Displayed value section, you can choose other possibilities for analysis using the aggregate function. Depending on the setting for Type, you may have to choose definitions for Base field and Base item.

![Figure 238: Example choices for Base field and Base item](image)
The table below lists the possible types of displayed value and associated base field and base item, together with a note on usage.

<table>
<thead>
<tr>
<th>Type</th>
<th>Base field</th>
<th>Base item</th>
<th>Analysis</th>
</tr>
</thead>
<tbody>
<tr>
<td>Normal</td>
<td>—</td>
<td>—</td>
<td>Simple use of the chosen aggregate function (for example, Sum).</td>
</tr>
<tr>
<td>Difference from</td>
<td>Selection of a field from the data source of the pivot table (for example, Employee).</td>
<td>Selection of an element from the selected base field (for example, Brigitte)</td>
<td>The result is the difference between the result of the base field and the base item (for example, sales volume of the other employees against the sales volume of Brigitte; see Figure 239). If previous item or next item is specified as the Base item, the reference value is the result for the next visible member of the base field, in the base field’s sort order.</td>
</tr>
<tr>
<td>% of</td>
<td>Selection of a field from the data source of the pivot table (for example, Employee)</td>
<td>Selection of an element from the selected base field (for example, Brigitte)</td>
<td>The result is a percentage ratio of the value of the base field to the base item (for example, sales result of the other employees relative to the sales result of Brigitte; see Figure 240). If previous item or next item is specified as the Base item, the reference value is the result for the next visible member of the base field, in the base field’s sort order.</td>
</tr>
<tr>
<td>% difference from</td>
<td>Selection of a field from the data source of the pivot table (for example, Employee)</td>
<td>Selection of an element from the selected base field (for example, Brigitte)</td>
<td>From each result, its reference value is subtracted, and the difference is divided by the reference value (for example, sales of the other employees as relative difference from the sales of Brigitte; see Figure 241). If previous item or next item is specified as the Base item, the reference value is the result for the next visible member of the base field, in the base field’s sort order.</td>
</tr>
<tr>
<td>Running total in</td>
<td>Selection of a field from the data source of the pivot table (for example, Date)</td>
<td>—</td>
<td>Each result is added to the sum of the results for preceding items in the base field, in the base field’s sort order, and the total sum is shown. Results are always summed, even if a different summary function was used to get each result.</td>
</tr>
<tr>
<td>% of row</td>
<td>—</td>
<td>—</td>
<td>The result is a percentage of the value of the whole row (for example, the row sum).</td>
</tr>
</tbody>
</table>
### Analysis Types

<table>
<thead>
<tr>
<th>Type</th>
<th>Base field</th>
<th>Base item</th>
<th>Analysis</th>
</tr>
</thead>
<tbody>
<tr>
<td>% of column</td>
<td>—</td>
<td>—</td>
<td>The result is a percentage of the total column value (for example, the column sum).</td>
</tr>
<tr>
<td>% of total</td>
<td>—</td>
<td>—</td>
<td>The result is a percentage of the overall result (for example, the total sum).</td>
</tr>
<tr>
<td>Index</td>
<td>—</td>
<td>—</td>
<td>(Default result x total result) / (row total x column total)</td>
</tr>
</tbody>
</table>

#### Figures

- **Figure 239**: Original pivot table (top) and a *Difference from* example (bottom)
- **Figure 240**: Example of a % of analysis
- **Figure 241**: Example of % *difference from* analysis

### Options for row and column fields

Double-click a field in the *Row* or *Column Fields* areas of the Pivot Table Layout dialog to access the Data Field dialog shown in Figure 242.

In the Data Field dialog for a row or column field, you can choose to show subtotals for each category. Subtotals are deactivated by default. Subtotals are useful only if the values in one row or column field can be divided into subtotals for another (sub)field.
Some examples are shown in Figures 243, 244, and 245.

![Data Field dialog for a row or column field](image)

**Figure 242: Data Field dialog for a row or column field**

![No subdivision with only one row or column field](image)

**Figure 243: No subdivision with only one row or column field**

![Division of the regions for employees (two row fields) without subtotals](image)

**Figure 244: Division of the regions for employees (two row fields) without subtotals**

*More settings for the fields: Field options* | 257
To calculate subtotals that can also be used for the data fields (see above), select the **Automatic** option in the **Subtotals** section of the Data Field dialog.

You can choose the type of subtotal to use by selecting **User-defined** and then clicking the type of subtotal you want to calculate from the list. Functions in this list are only available when **User-defined** is selected.

Normally, the pivot table does not show a row or column for categories that have no entries in the underlying database. By choosing the **Show items without data** option, you can force these to be displayed.

For illustration purposes, the data was manipulated in such a way that the employee Brigitte has no sales values for the Golf category.
Click the Options button on the Data Field dialog to access the Data Field Options dialog (Figure 248). Use this dialog to specify additional options for fields in the Column and Row Fields areas of the Pivot Table Layout dialog.

The following options are provided:

- **Sort by.** Select the data field that you want to sort columns or rows by. **Ascending** sorts the values from the lowest value to the highest value. If the selected field is the field for which the dialog was opened, the items are sorted by name. If a data field was selected, the items are sorted by the resultant value of the selected data field. Similarly **Descending** sorts the values descending from the highest value to the lowest value. **Manual** sorts values alphabetically.

- **Display Options.** You can specify the display options for all row fields except for the last, innermost row field. Select from the Layout drop-down list to select the layout mode for the field in the list box. Select the **Empty line after each item** option to add an empty row after the data for each item in the pivot table. Select or deselect the **Repeat item labels** option as required.
• **Show Automatically.** This feature displays the top or bottom \( nn \) items when you sort by a specified field. Click the **Show** option to turn on the automatic show feature and enter the maximum number of items that you want to show automatically. The **From** drop-down list selects to show the top or bottom items in the specified sort order. The **Using field** drop-down list selects the data field by which to sort the data.

• **Hide Items.** Use these options to select the items to hide from the calculations.

• **Hierarchy.** Select the hierarchy to use. The pivot table must be based on external source data that contains data hierarchies.

**Options for page fields**

The Data Field dialog for fields in the **Page Fields** area is the same as for fields in the **Row** and **Column Fields** areas, even though it appears to be useless to have the same settings as described for the row and column fields. With the flexibility of the pivot table, you can switch the different fields between pages, columns, or rows. The fields keep the settings that you made for them. The page field has the same properties as a row or column field. These settings only take effect when you use the field not as a page field but as a row or column field.

**Working with the results of the pivot table**

The Pivot Table Layout dialog is very flexible and a pivot table can be totally restructured with only a few mouse clicks.

**Changing the layout**

The layout of the pivot table can be changed quickly and easily by using drag-and-drop. With the Pivot Table Layout dialog open, fields can be dragged around from **Row**, **Column**, **Page**, and **Data Fields** areas to any position you want to put them, and then dropped. Unused fields can also be added, and fields removed in error can be replaced by dragging and dropping them into the positions required.

Some manipulation can also be carried out in the results view of the pivot table. Within the results of the pivot table, drag one of the page, column, or row fields to a different position. The cursor will change shape from its starting shape (horizontal or vertical block on the arrow head) to the opposite if moving to a different field, such as from row to column, where it can be dropped.

![Figure 249: Drag a column field - note the cursor shape](image)

![Figure 250: Drag a row field - note the cursor shape](image)

You can remove a column, row, or page field from the pivot table by clicking on it and dragging it out of the table. The cursor changes to that shown in Figure 251. A field removed in error cannot be recovered, without returning to the Pivot Table Layout dialog to replace it.
Grouping rows or columns

For many analyses or summaries, the categories have to be grouped. You can merge the results in classes. You can only carry out grouping on an ungrouped pivot table.

After selecting the correct cell area, select Data > Group and Outline > Group from the Menu bar, or press F12 on the keyboard. The type of values to be grouped is what mainly determines how the grouping function works. You need to distinguish between scalar values, or other values, such as text, that you want grouped.

Note

Before you can group, you have to produce a pivot table with ungrouped data. The time needed for creating a pivot table depends mostly on the number of columns and rows and not on the size of the basic data. Through grouping you can produce the pivot table with a small number of rows and columns. The pivot table can contain a lot of categories, depending on your data source.

To remove grouping again, click inside the group, then choose Data > Group and Outline > Ungroup.

Grouping of categories with scalar values

For grouping scalar values, select a single cell in the row or column of the category to be grouped. Choose Data > Group and Outline > Group from the Menu bar or press F12 on the keyboard; Calc displays the Grouping dialog shown in Figure 252.

You can define in which value range (Start / End) the grouping should take place. The default setting is the whole range, from the smallest to the largest value. In the field Group by, you can enter the class size, also known as the interval size.
Figure 253 shows part of a pivot table created from a list containing speed measurements as a function of time. This pivot table shows the count of km/h speed measurements in the raw data.

The pivot table in Figure 254 is based on the same raw data. However in this case the speed measurements are grouped into intervals if 10 km/h.

Grouping of categories with date / time values
For grouping date / time values, select a single cell in the row or column of the category to be grouped. Choose Data > Group and Outline > Group from the Menu bar or press F12 on the keyboard; Calc displays the Grouping dialog shown in Figure 255.

You can define in which value range (Start / End) the grouping should take place. The default setting is the whole range, from the smallest to the largest value. In the field Group by, you can enter the class size, also known as the interval size. In this case you can select one of the predefined time intervals (Seconds, Minutes, Hours, Days, Months, Quarters, or Years) as an alternative to explicitly specifying a time interval in days.
Figure 256 shows a pivot table configured to show the daily sales in the North region.

![Figure 256: Pivot table without grouping](image)

Figure 257 shows the same data but configured to show the monthly sales in the North region.

![Figure 257: Pivot table with grouping](image)

**Grouping without automatic creation of intervals**

It is not possible to create intervals for some categories (for example, those containing text fields). However, for such fields it is possible to define which values are put together in one group.

For grouping of these categories, select in the results of the pivot table all the individual field values that you want to put together in the group. With more than one cell selected, choose **Data > Group and Outline > Group** from the Menu bar, or press F12 on the keyboard, to group the selected cells.
Given the input data shown in Figure 258, create a pivot table with Department in the Row Fields area and Sum - Sick days in the Data Fields area. The result should be as shown in Figure 259.

In the results of the pivot table select Accounting, Purchasing, and Sales in the Department column. Select Data > Group and Outline > Group from the Menu bar or press F12 on the keyboard. The pivot table result updates to reflect the new group, as shown in Figure 260.

In the updated pivot table result, select Assembly, Production, and Warehouse in the Department column. Select Data > Group and Outline > Group from the Menu bar or press F12 on the keyboard. The pivot table updates again to reflect the new group, as shown in Figure 261.

You can change the default names for the groups and the newly created group field by editing the name in the input field (for example changing Group2 to Technical). The pivot table will remember these settings, even if you change the layout later on.
To add partial sums for the groups, right-click the results of the pivot table and select the **Edit Layout** option. Double-click the **Department2** entry in the **Row Fields** area and select the **Automatic** option on the Data Field dialog (Figure 242). Click the two **OK** buttons and the pivot table is updated to include the partial sums for the groups, as shown in Figure 262.

If it is not enabled already, select the **Enable drill to details** option on the Pivot Table Layout dialog. Double-click the Group 1 and Technical entries in the Department2 column to collapse/expand the group entries (for example, Figure 263 shows both groups collapsed).

---

**Note**

A well-structured database makes manual sorting within the pivot table obsolete. In the example shown, you could add another column with the name **Department**, that has the correct entry for each person based on whether the employee's department belongs to the group **Office** or **Technical**. The mapping for this (1:n relationship) can be done easily with the VLOOKUP() function from Calc.

---

### Sorting the result

The results of a pivot table are by default sorted so that categories in columns and rows are presented in ascending order. There are three ways to change the sorting order:

- Select a sort order from the drop-down menu on a column’s heading.
- Sort manually by using drag and drop.
- Select a sort order through the Data Field Options dialog for the appropriate row or column field (Figure 248).

---

**Figure 261: Grouping finished**

**Figure 262: Renamed group and partial results**

**Figure 263: Reduced to the new groups**
Select sort order from drop-down menus on each column heading

The simplest way to sort entries is to click the arrow on the right side of the column heading for a row or column field, and select one of the three sorting options (Figure 264):

- Sort Ascending
- Sort Descending
- Custom Sort

Selecting the Custom Sort option sorts according to one of the predefined custom sorts defined in Tools > Options > LibreOffice Calc > Sort Lists. See Chapter 2, Entering, Editing, and Formatting Data for more information about creating and using sort lists.

This dialog also provides facilities for simple filtering of the data in the pivot table. Check the required individual boxes to select the data displayed in the results of the pivot table. Options are provided to show all, show only the current item, or hide only the current item. Click OK to activate the selected filtering. Once filtering has been carried out, the color of the arrow changes from black to blue, and a small square of matching color is added to the bottom right of the arrow button (Figure 265).

Sort manually by using drag and drop

You can change the order within the categories by moving the cells with the category values in the results of the pivot table. The dragged cell is inserted above the cell on which you drop it.
Be aware that in Calc, a cell must be selected, it is not enough that the cursor is in the cell. The background of a selected cell is marked with a different color. To mark a single cell do one of the following:

- Click, then *Shift*+click the cell.
- Press the mouse button, drag a range across two cells, do not release the mouse button, and then drag back to the first cell. Release the mouse button. You can now move the individual cell by drag and drop.

To select several cells, mark one cell with no extra key pressed, then press the *Shift* or *Ctrl* key while clicking in other cells.

**Sort automatically**

To sort automatically, right-click within the pivot table and choose *Edit Layout*. This will open the Pivot Table Layout dialog (Figure 231). Double-click the row or column field you want to sort. In the Data Field dialog which opens (Figure 242), click *Options* to display the Data Field Options dialog (Figure 248).

For *Sort by*, choose either *Ascending*, *Descending*, or *Manual*. *Ascending* sorts the values from the lowest value to the highest value. If the selected field is the field for which the dialog was opened, the items are sorted by name. If a data field was selected, the items are sorted by the resultant value of the selected data field. Similarly *Descending* sorts the values descending from the highest value to the lowest value. *Manual* sorts values alphabetically.

**Drilling (showing details)**

Use Drill to show the related detailed data for a single, compressed value in the pivot table result. This facility is available only if you selected the *Enable drill to details* option on the Pivot Table Layout dialog.

To activate a drill, double-click on the cell or choose *Data > Group and Outline > Show Details*. There are two possibilities:

- The active cell is a row or column field. In this case, drill means an additional breakdown into the categories of another field. For example, double-click on the cell with the value Golf. In this instance the values that are aggregated within Golf can be subdivided using another field.

```
<table>
<thead>
<tr>
<th>Sum - Sales Value</th>
<th>Region</th>
</tr>
</thead>
<tbody>
<tr>
<td>Category</td>
<td>East</td>
</tr>
<tr>
<td>Golf</td>
<td>$41,971</td>
</tr>
<tr>
<td>Sailing</td>
<td>$22,484</td>
</tr>
<tr>
<td>Tennis</td>
<td>$35,966</td>
</tr>
<tr>
<td><strong>Total Result</strong></td>
<td><strong>$100,421</strong></td>
</tr>
</tbody>
</table>
```

*Figure 266: Before the drill down for Golf*

The Show Detail dialog appears allowing you to select the field to use for further subdivision. In this example, *Employee*.

*Figure 267: Selecting the field for the subdivision*
To hide the details again, double-click on the cell Golf or choose Data > Group and Outline > Hide Details.

The pivot table remembers your selection (in our example the field Employee) by adding and hiding the selected field, so that for the next drill down for a field in the Category column the dialog does not appear. To remove the selection Employee, open the Pivot Table Layout dialog by right-clicking and choosing Edit Layout, then delete the unwanted selection in the Row or Column Fields area.

- The active cell is a data field. In this case, drill down results in a listing of all data entries of the data source that aggregate to this value.

In our example, if we double-click on the cell with the value $18,741 from Figure 266, we would have a new list of all data sets that are included in this value. This list is displayed in a new sheet.

Filtering

To limit the pivot table analysis to a subset of the information that is contained in the data basis, you can filter with the pivot table.

An autofilter or default filter used on the sheet containing the raw data has no effect on the pivot table analysis process. The pivot table always uses the complete list that was selected when it was started.

To do this, click the Filter button at the top left above the results, or click in the results and select Filter from the context menu.

The Filter button is available only if you selected the Add filter option on the Pivot Table Layout dialog.
In the Filter dialog (Figure 271), you can define up to three filter options that are used in the same way as Calc’s default filter.

The data presented in a pivot table can also be filtered using the drop-downs on the right hand side of column headings or by using page fields. Filtering through column headings is described in “Select sort order from drop-down menus on each column heading” on page 276.

Even if they are not called a filter, page fields are another practical way to filter the results of the pivot table. The advantage is that the filtering criteria used are clearly visible. Click the arrow on the right side of the page field button to access the associated filtering dialog (Figure 272).
Updating (refreshing) changed values

After you have created the pivot table, changes in the source data do not cause an automatic update in the resulting table. You must update (refresh) the pivot table manually after changing any of the underlying data values.

Changes in the source data could appear in two ways:

- The content of existing data sets has been changed. For example, you might have changed a sales value. To update the pivot table, click in the result area and choose Refresh from the context menu, or choose Data > Pivot Table > Refresh from the Menu bar.
- You have added or deleted data sets in the original list. In this case the change means that the pivot table has to use a different area of the spreadsheet for its analysis. Fundamental changes to the data set collection means you must redo the pivot table from the beginning.

Cell formatting

The cells in the results area of the pivot table are automatically formatted by Calc. You can change this formatting using all the tools in Calc. However if you make any change in the design of the pivot table using direct formatting, the formatting will return to that applied automatically by Calc when the table is next refreshed.

On creating a pivot table, six standard cell styles are added to the list of styles in the document if they are not included already. Each of these styles is applied to part of the pivot table. You can customize these pivot table styles. The pivot table styles are:

- Pivot Table Category
- Pivot Table Corner
- Pivot Table Field
- Pivot Table Result
- Pivot Table Title
- Pivot Table Value

Tip

Use the pivot table styles to make sure that the format of your pivot table is not unexpectedly changed during updates and that all pivot tables in your document have the same appearance.

Note

Direct formatting of pivot table cells is not retained during updates.

For the number format in the data field, Calc uses the number format that is used in the corresponding cell in the source list. In most cases, this is useful (for example, if the values are in the currency format, then the corresponding cell in the result area is also formatted as currency). However, if the result is a fraction or a percentage, the pivot table does not recognize that this might be a problem; such results must either be without a unit or be displayed as a percentage.
Although you can correct the number format manually, the correction stays in effect only until the next update.

Deleting a pivot table

To delete a pivot table, click in the result area and choose Delete from the context menu, or choose Data > Pivot Table > Delete from the Menu bar.

**Warning**

If you delete a pivot table with an associated pivot chart, the pivot chart is also deleted. Calc opens a dialog box to confirm the pivot chart deletion.

Using pivot table results elsewhere

**The problem**

Normally, you create a reference to a value by entering the address of the cell that contains the value. For example, the formula =C6*2 creates a reference to cell C6 and returns the doubled value. If this cell is located in the results area of the pivot table, it contains the result that was calculated by referencing specific categories of the row and column fields. In Figure 273, the cell C6 contains the sum of the sales values of the employee Hans in the category Sailing. The formula in the cell C12 uses this value.

If the underlying data or the layout of the pivot table changes, then you must take into account that the sales value for Hans in the Sailing category might appear in a different cell. Your formula still references the cell C6 and therefore uses a wrong value. The correct value is in a different location. For example, in Figure 274, the location is now C7.
The solution: Function GETPIVOTDATA()

Use the function GETPIVOTDATA() to have a reference to a value inside the pivot table by using the specific identifying categories for this value. This function can be used with formulas in Calc if you want to reuse the results from the pivot table elsewhere in your spreadsheet.

Syntax

The syntax has two variations:

```
GETPIVOTDATA(target field, Pivot Table, [ Field name / Element, ... ])
GETPIVOTDATA(Pivot Table, specification)
```

First syntax variation

The target field specifies which data field of the pivot table is used within the function. If your pivot table has only one data field, this entry is ignored, but you must enter it anyway.

If your pivot table has more than one data field, then you have to enter the field name from the underlying data source (for example “Sales Value”) or the field name of the data field itself (for example “Sum – Sales Value”).

The argument Pivot Table specifies the pivot table that you want to use. It is possible that your document contains more than one pivot table. Enter here a cell reference that is inside the area of your pivot table. It might be a good idea to always use the upper left corner cell of your pivot table, so that you can be sure that the cell will always be within your pivot table, even if the layout changes.

Example: GETPIVOTDATA("Sales Value",A1)

If you enter only the first two arguments, then the function returns the total result of the pivot table (“Sum – Sales Value” entered as the field, will return a value of 408,765).

You can add more arguments as pairs with Field name and Element to retrieve specific partial sums. In the example in Figure 275, where we want to get the partial sum of Hans for Sailing, the formula in cell C12 would look like this:

```
=GETPIVOTDATA("Sales Value",A1,"Employee","Hans","Category","Sailing")
```
Second syntax variation

The argument **Pivot Table** has to be given in the same way as for the first syntax variation.

For the **specification**, enter a list separated by spaces to specify the value you want from the pivot table. This list must contain the name of the data field, if there is more than one data field; otherwise it is not required. To select a specific partial result, add more entries in the form of Field name[Element].

In the example in Figure 276, where we want to get the partial sum of Hans for Sailing, the formula in cell C12 would look like this:

```plaintext
=GETPIVOTDATA(A1,"Sales Value Employee[Hans] Category[Sailing]"
```

When working with data sets containing date information, you must take care if you use the date information in the **GETPIVOTDATA()** function. The function will only recognize the date entry if it is entered into the formula in exactly the same way that it appears in the data set from which the pivot table is produced. In the example of Figure 277, an error is returned when the date format does not match that of the data. Only with the correct format is the result returned.
Using pivot charts

Introduction

A pivot table is a powerful tool to reorganize, manipulate and summarize data. A pivot chart provides a visual representation of the information in a pivot table. You can create a pivot chart from the output of a pivot table and, if the pivot table gets changed, so does the pivot chart.

Pivot charts are a special case of the more general Calc charts described in Chapter 3, Creating Charts and Graphs. The main differences between pivot charts and other charts in Calc are as follows:

- A pivot chart tracks the changes in the data issued from a pivot table and Calc automatically adjusts the data series and data range of the pivot chart accordingly.
- Pivot chart buttons are provided on pivot charts. These buttons are unique to pivot charts and are not provided on Calc’s normal charts. An important purpose of the buttons is to represent the layout of the underlying pivot table and they show the pivot table’s fields. Buttons representing the page fields (if present) are provided at the top of the pivot chart. Buttons representing the row fields are provided at the bottom of the pivot chart. Buttons representing the column fields are stacked in the legend at the right of the pivot chart. You can also use pivot chart buttons to filter the data displayed in the pivot chart.
Creating a pivot chart

To create a pivot chart, click inside the pivot table and select **Insert > Chart** on the Menu bar or click the **Insert Chart** icon on the Standard toolbar.

Calc automatically detects the pivot table and opens the chart wizard. Through the chart wizard you can select the chart type and chart elements for the pivot chart. The wizard is similar to the corresponding wizard for normal charts but for pivot charts, the steps to define data range and data series are disabled.

The first step in the wizard is to select the chart type and the same options are available as for a normal chart (Figure 279).
The second step is to select the chart elements and these are similar to those for normal charts (Figure 280).

Click **Finish** to close the wizard and create the pivot chart.

**Editing a pivot chart**

After you have created a pivot chart, you may find that you would like to move it, change its size or improve its appearance. Calc provides tools for changing the chart type, chart elements, fonts, colors, and many other options. The facilities provided for pivot charts are the same as those available for normal charts; see Chapter 3, Creating Charts and Graphs.

**Updating a pivot chart**

If the source data of the pivot table changes, refresh the pivot table and the pivot chart is also updated accordingly. To refresh the pivot table (and thus the pivot chart), click in any cell within the
pivot table and select **Data > Pivot Table > Refresh** from the Menu bar or select **Refresh** from the context menu.

**Filtering a pivot chart**

Use filters to remove unwanted data from a pivot chart.

All filters applied to a pivot table affect any linked pivot chart equally, since the table and chart show exactly the same data. The various pivot table filtering mechanisms are described in “Filtering” on page 278.

Pivot chart buttons include a down arrow to indicate that there is an associated pop-up action. If any filtering is applied, then this arrow turns from black to blue.

Click a page field button located at the top of a pivot chart to access a filtering dialog similar to that shown in Figure 272. Change the filtering applied to the pivot table and pivot chart through this dialog. The right-hand section of the button’s legend indicates the filtering status, that is ”- all -“ when nothing is filtered, ”- multiple -“ when multiple but not all items are filtered, or the value when only that value is not filtered.

Buttons located at the bottom and right of a pivot chart that include a downward pointing arrow provide access to a sorting and filtering dialog similar to the shown in Figure 264. Change the sorting and filtering applied to the pivot table and pivot chart through this dialog.

![Filtering applied to page and row fields](image)

**Deleting a pivot chart**

To delete a pivot chart, select the chart and press *Del* on the keyboard.

**Note**

When you delete a pivot chart, the associated pivot table is not affected.

**Warning**

If you delete a pivot table with an associated pivot chart, the pivot chart is also deleted. Calc opens a dialog box to confirm the pivot chart deletion.
Chapter 9
Data Analysis
Using Scenarios, Goal Seek, Solver, Statistics, others
Introduction

Once you are familiar with functions and formulas, the next step is to learn how to use Calc's automated processes to perform useful analysis of your data quickly.

In addition to formulas and functions, Calc includes several tools for processing your data. These tools include features for copying and reusing data, creating subtotals, running what-if analysis, and performing statistical analysis. They can be found under the Tools and Data menus in the Menu bar. While they are not necessary to using Calc, they can help you save time and effort with handling large data sets or preserving your work for future review.

Note

A related tool, the Pivot Table, is not mentioned here, as it is complex enough to require its own chapter. See Chapter 8, Using Pivot Tables, for more information.

Consolidating data

The Consolidate tool allows you to combine and aggregate data spread across one or more worksheets into one place. This tool is useful if you need to quickly summarize a large, scattered set of data for review. For example, you could use it to consolidate multiple department budgets from different worksheets into a single company-wide budget contained in a master worksheet.

To access the Consolidate tool dialog, select Data > Consolidate from the Menu bar (Figure 282).

![Consolidate tool dialog](Figure 282: Consolidate tool dialog)
Consolidating data example

To consolidate data:

7) Open the document containing the cell ranges to be consolidated.
8) Select Data > Consolidate from the Menu bar to open the Consolidate dialog (Figure 283).
9) Click on the Source data ranges field, then type a reference to a source data range, a named range or select it with the mouse. Use the associated Shrink / Expand button if you need to minimize the dialog while you select the range. Alternatively, select a named range from the drop-down list to the left of the field.
10) Click Add. The selected range is added to the Consolidation ranges list.
11) Repeat steps 9 and 10 to add additional source ranges.
12) To delete an entry in the Consolidation ranges list, select it and click Delete. The deletion is carried out without further confirmation.
13) Click on the Copy results to field, then type a reference to the first cell of the target range or select it with your mouse. You can also select a named range from the drop-down list to the left of the field.
14) Select a function to aggregate your data from the Function drop-down list. The default is Sum. Other available functions include Count, Average, Max, Min, Product, Count (numbers only), StdDev (sample), StDevP (population), Var (sample), and VarP (population).
15) Click OK to consolidate the ranges. Calc runs the function from step 14 on your source data ranges and populates the target range with the results.

Tip

If you are consolidating the same cell ranges repeatedly, consider converting them into reusable named ranges to make the process easier. For more information about named ranges, see Chapter 13, Calc as a Simple Database.

Consolidation settings

In the Consolidate dialog, click on the ‘+’ sign next to Options to access the following settings (Figure 283):

- **Consolidate by**
  - **Row labels** – Consolidates rows by matching label. If this option is unchecked, the tool will consolidate rows by position instead.
  - **Column labels** – Works the same as Row labels, but with columns instead.

Figure 283: Consolidate tool options
Options
In this section, select *Link to source data* to add formulas in the target range that link back to values in the source ranges. When you select this option, any changes you make in the source ranges will automatically update values in the target range.

**Note**
If you use the *Link to source data* option, each source link is inserted into the target range, then ordered and hidden from view. Only the final results of consolidation are displayed by default.

Consolidation example
Figures 284, 285, and 286 show a simple example of consolidation using a spreadsheet with the worksheets *Year 1*, *Year 2*, and *Consolidated Sales*. Figure 284 shows the contents of the *Year 1* worksheet, with sales figures by region for each of the four product colors.

![Figure 284: Year 1 sales by region]

Figure 285 shows the *Year 2* worksheet, sales figures by region for each of four product colors. Note the different ordering of row and column labels between the two figures.

![Figure 285: Year 2 sales by region]

Figure 286 shows the consolidated sales data, created by using the Consolidate dialog settings shown in Figure 283. Note that because the *Link to source data* option was selected, clicking on the plus sign (+) indicators to the left of the data will reveal formula links back to the source ranges.
The source ranges and target range are saved as part of the document. If you later open a document with consolidated ranges, they will still be available in the *Consolidation ranges* list of the Consolidate dialog.

### Creating subtotals

Calc offers two methods of creating subtotals: the SUBTOTAL function and the Subtotals tool.

#### Using the SUBTOTAL function

The SUBTOTAL function is listed under the Mathematical category of the Function Wizard, which is described in Chapter 7, Using Formulas and Functions. SUBTOTAL is a relatively limited method for generating a subtotal, and works best if used with only a few categories.

**A SUBTOTAL example**

To illustrate how to use the SUBTOTAL function, we use the sales data worksheet shown in Figure 287. The AutoFilter function is already applied to the sales data, and are indicated by the down arrow buttons at the head of each column. AutoFilters are described in Chapter 2, Entering, Editing, and Formatting Data.

![Figure 286: Consolidated sales by region](image)

**Figure 286: Consolidated sales by region**

To create a summation subtotal for the *Sales Value* field:

1) Select the cell to contain a subtotal. Typically, this cell is at the bottom of the column being subtotaled, which, for our example, is the *Sales Value* column.

2) Use one of the following methods to open the Function Wizard dialog:
   - The **Function Wizard** icon from the Formula bar
   - **Insert > Function** from the Menu bar
   - **Ctrl+F2** key combination

To create a summation subtotal for the *Sales Value* field:

1) Select the cell to contain a subtotal. Typically, this cell is at the bottom of the column being subtotaled, which, for our example, is the *Sales Value* column.

2) Use one of the following methods to open the Function Wizard dialog:
   - The **Function Wizard** icon from the Formula bar
   - **Insert > Function** from the Menu bar
   - **Ctrl+F2** key combination
3) Select SUBTOTAL from the *Function* list in the Function Wizard dialog and click **Next**.

4) Enter the numeric code of a function into the *Function* field of the dialog. This code must be a value in the range 1 to 11 or 101 to 111, with the meaning of each value shown in Table 7.

![Image showing the Function Wizard dialog with the Function index set to 9 for SUBTOTAL]

**Note**

Values 1 to 11 include hidden values in the calculated subtotal, while values 101 to 111 do not. Hiding and showing data is described in Chapter 2, Entering, Editing, and Formatting Data. Filtered-out cells are always excluded by the SUBTOTAL function.

<table>
<thead>
<tr>
<th>Function index (includes hidden values)</th>
<th>Function index (ignores hidden values)</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>101</td>
<td>AVERAGE</td>
</tr>
<tr>
<td>2</td>
<td>102</td>
<td>COUNT</td>
</tr>
<tr>
<td>3</td>
<td>103</td>
<td>COUNTA</td>
</tr>
<tr>
<td>4</td>
<td>104</td>
<td>MAX</td>
</tr>
<tr>
<td>5</td>
<td>105</td>
<td>MIN</td>
</tr>
<tr>
<td>6</td>
<td>106</td>
<td>PRODUCT</td>
</tr>
<tr>
<td>7</td>
<td>107</td>
<td>STDEV</td>
</tr>
<tr>
<td>8</td>
<td>108</td>
<td>STDEVP</td>
</tr>
<tr>
<td>9</td>
<td>109</td>
<td>SUM</td>
</tr>
<tr>
<td>10</td>
<td>110</td>
<td>VAR</td>
</tr>
<tr>
<td>11</td>
<td>111</td>
<td>VARP</td>
</tr>
</tbody>
</table>

5) Click on the *Range* field, then type a reference to the *Sales Value* range or select the cells with your mouse (Figure 288). Use the **Shrink / Expand** button if you need to temporarily minimize the dialog while selecting the cells.

![Figure 288: Function Wizard dialog]

6) Click **OK** to close the Function Wizard dialog. The cell you selected in step 1 now contains the total sales value.
Click on the AutoFilter down arrow button at the top of the Employee column and remove all marks from the Standard Filter area except those next to Brigitte and (empty). The cell that you selected in step 1 should now reflect the sum of all of Brigitte's sales (Figure 289).

<table>
<thead>
<tr>
<th>Date</th>
<th>Value 1</th>
<th>Type</th>
<th>Region</th>
<th>Employee</th>
</tr>
</thead>
<tbody>
<tr>
<td>05/15/08</td>
<td>$520</td>
<td>Sailing</td>
<td>North</td>
<td>Brigitte</td>
</tr>
<tr>
<td>05/16/08</td>
<td>$575</td>
<td>Golf</td>
<td>West</td>
<td>Brigitte</td>
</tr>
<tr>
<td>06/02/08</td>
<td>$2,213</td>
<td>Golf</td>
<td>East</td>
<td>Brigitte</td>
</tr>
<tr>
<td>06/03/08</td>
<td>$1,819</td>
<td>Golf</td>
<td>East</td>
<td>Brigitte</td>
</tr>
<tr>
<td>04/18/08</td>
<td>$3,060</td>
<td>Golf</td>
<td>West</td>
<td>Brigitte</td>
</tr>
<tr>
<td>02/20/08</td>
<td>$1,660</td>
<td>Golf</td>
<td>South</td>
<td>Brigitte</td>
</tr>
<tr>
<td>04/02/08</td>
<td>$1,356</td>
<td>Sailing</td>
<td>North</td>
<td>Brigitte</td>
</tr>
<tr>
<td>02/27/08</td>
<td>$4,433</td>
<td>Sailing</td>
<td>West</td>
<td>Brigitte</td>
</tr>
<tr>
<td>01/25/08</td>
<td>$3,116</td>
<td>Sailing</td>
<td>West</td>
<td>Brigitte</td>
</tr>
<tr>
<td>06/20/08</td>
<td>$3,617</td>
<td>Sailing</td>
<td>North</td>
<td>Brigitte</td>
</tr>
<tr>
<td>05/12/08</td>
<td>$1,790</td>
<td>Golf</td>
<td>East</td>
<td>Brigitte</td>
</tr>
</tbody>
</table>

**Note**

If the cell range used to calculate a subtotal contains other subtotals, these subtotals will not be counted in the final one. Similarly, if you use this function with AutoFilters, only the data satisfying the current filter selections will be displayed. Any filtered-out data is ignored.

**Using Data > Subtotals**

Calc offers the Subtotals tool as a more comprehensive alternative to the SUBTOTAL function. In contrast to SUBTOTAL, which only works on a single array, the Subtotals tool can create subtotals for up to three arrays arranged in labeled columns. It also groups subtotals by category and sorts them automatically, thereby eliminating the need to apply AutoFilters and filter categories by hand.

To use this tool, select **Data > Subtotals** from the Menu bar, which opens the Subtotals dialog.

![Subtotals dialog](Figure 290 Subtotals dialog)
Using the Subtotals tool

To insert subtotal values into a worksheet:

1) Select the cell range for the subtotals that you want to calculate, and remember to include the column heading labels. Alternatively, click on a single cell within your data to allow Calc to automatically identify the range.

2) Select Data > Subtotals from the Menu bar to open the Subtotals dialog (Figure 290).

3) In the Group by drop-down list on the 1st Group page, select a column by its label. Entries in the cell range from step 1 will be grouped and sorted by matching values in this column.

4) In the Calculate subtotals for box on the 1st Group page, select a column containing values to be subtotaled. If you later change values in this column, Calc will automatically recalculate the subtotals.

5) In the Use function box on the 1st Group page, select a function to calculate the subtotals for the column selected in step 4.

6) Repeat steps 4 and 5 to create subtotals for other columns on the 1st Group page.

7) You can create two more subtotal categories by using the 2nd Group and 3rd Group pages and repeating steps 3 to 6. If you do not want to add more groups, then leave the Group by list for each page set to "- none -".

8) Click OK. Calc will add subtotal and grand total rows to your cell range.

For our sales data example, a partial view of the results is shown in Figure 291. The group settings are identified in Table 8.

Table 8: Group settings used on Subtotals dialog for example sales data

<table>
<thead>
<tr>
<th>Tab</th>
<th>Group by</th>
<th>Calculate subtotals for</th>
<th>Use function</th>
</tr>
</thead>
<tbody>
<tr>
<td>1st Group</td>
<td>Employee</td>
<td>Sales Value</td>
<td>Sum</td>
</tr>
<tr>
<td>2nd Group</td>
<td>Category</td>
<td>Sales Value</td>
<td>Sum</td>
</tr>
<tr>
<td>3rd Group</td>
<td>- none -</td>
<td>-</td>
<td>-</td>
</tr>
</tbody>
</table>

Subtotal outline

When you use the Subtotals tool, Calc inserts an outline to the left of the row number column. This outline represents the hierarchical structure of your subtotals, and can be used to hide or show data at different levels in the hierarchy using the numbered column indicators at the top of the outline or the group indicators, denoted by plus (+) and minus (-) signs.

This feature is useful if you have many subtotals, as you can simply hide low-level details, such as individual entries, to produce a high-level summary of your data. For more information on how to use outlines, see Chapter 2, Entering, Editing, and Formatting Data.

To turn off outlines, select Data > Group and Outline > Remove Outline from the Menu bar. To reinstate them, select Data > Group and Outline > AutoOutline.

Figure 291 shows the outline for our sales data example. Column 1 represents the highest group level, the grand total over all employees. Columns 2 to 5 show descending group levels as follows:

- Column 2 represents the grand total over all categories.
- Column 3 represents the total for each employee.
- Column 4 represents the total for each category for an individual employee.
- Column 5 shows individual entries.
### Subtotals tool options

Click on the Options tab of the Subtotals dialog to access the following settings:

#### Groups

Defines how subtotal data is organized.

- **Page break between groups** – inserts page breaks between each subtotal group so that each group displays on a separate page when you print the data.

- **Case sensitive** – prevents the tool from grouping entries by data labels that differ by case. In our sales data example, entries with "Brigitte" and "brigitte" under the Employee column will not match if this option is selected.

- **Pre-sort area according to groups** – sorts entries by group before calculating subtotals. Disabling this option prevents the tool from grouping matching entries together. As a result, distinct subtotals will be created for matching entries if they do not appear on consecutive rows. For example, two entries under the “Golf” category will not count towards the same group subtotal if there is an entry for “Tennis” in between them.

---

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Date</td>
<td>Sales Value</td>
<td>Category</td>
<td>Region</td>
<td>Employee</td>
</tr>
<tr>
<td>2</td>
<td>01/19/08</td>
<td>$2,032</td>
<td>Golf</td>
<td>West</td>
<td>Brigitte</td>
</tr>
<tr>
<td>3</td>
<td>01/29/08</td>
<td>$3,491</td>
<td>Golf</td>
<td>South</td>
<td>Brigitte</td>
</tr>
<tr>
<td>4</td>
<td>02/20/08</td>
<td>$1,660</td>
<td>Golf</td>
<td>South</td>
<td>Brigitte</td>
</tr>
<tr>
<td>5</td>
<td>02/27/08</td>
<td>$1,146</td>
<td>Golf</td>
<td>West</td>
<td>Brigitte</td>
</tr>
<tr>
<td>6</td>
<td>02/27/08</td>
<td>$1,790</td>
<td>Golf</td>
<td>East</td>
<td>Brigitte</td>
</tr>
<tr>
<td>7</td>
<td>03/18/08</td>
<td>$3,814</td>
<td>Golf</td>
<td>North</td>
<td>Brigitte</td>
</tr>
<tr>
<td>8</td>
<td>04/04/08</td>
<td>$4,045</td>
<td>Golf</td>
<td>West</td>
<td>Brigitte</td>
</tr>
<tr>
<td>9</td>
<td>04/18/08</td>
<td>$3,060</td>
<td>Golf</td>
<td>West</td>
<td>Brigitte</td>
</tr>
<tr>
<td>10</td>
<td>04/29/08</td>
<td>$1,316</td>
<td>Golf</td>
<td>West</td>
<td>Brigitte</td>
</tr>
<tr>
<td>11</td>
<td>05/06/08</td>
<td>$575</td>
<td>Golf</td>
<td>West</td>
<td>Brigitte</td>
</tr>
<tr>
<td>12</td>
<td>06/02/08</td>
<td>$2,213</td>
<td>Golf</td>
<td>East</td>
<td>Brigitte</td>
</tr>
<tr>
<td>13</td>
<td>06/03/08</td>
<td>$1,819</td>
<td>Golf</td>
<td>East</td>
<td>Brigitte</td>
</tr>
</tbody>
</table>

**$26,961** **Golf Sum**

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
</tr>
</thead>
<tbody>
<tr>
<td>14</td>
<td></td>
<td>$3,116</td>
<td>Sailing</td>
<td>West</td>
<td>Brigitte</td>
</tr>
<tr>
<td>15</td>
<td>01/25/08</td>
<td>$3,116</td>
<td>Sailing</td>
<td>West</td>
<td>Brigitte</td>
</tr>
<tr>
<td>16</td>
<td>01/27/08</td>
<td>$2,095</td>
<td>Sailing</td>
<td>North</td>
<td>Brigitte</td>
</tr>
<tr>
<td>17</td>
<td>01/28/08</td>
<td>$155</td>
<td>Sailing</td>
<td>West</td>
<td>Brigitte</td>
</tr>
<tr>
<td>18</td>
<td>02/27/08</td>
<td>$4,433</td>
<td>Sailing</td>
<td>West</td>
<td>Brigitte</td>
</tr>
<tr>
<td>19</td>
<td>04/02/08</td>
<td>$1,355</td>
<td>Sailing</td>
<td>North</td>
<td>Brigitte</td>
</tr>
<tr>
<td>20</td>
<td>04/25/08</td>
<td>$2,564</td>
<td>Sailing</td>
<td>North</td>
<td>Brigitte</td>
</tr>
<tr>
<td>21</td>
<td>05/12/08</td>
<td>$3,887</td>
<td>Sailing</td>
<td>South</td>
<td>Brigitte</td>
</tr>
<tr>
<td>22</td>
<td>05/15/08</td>
<td>$520</td>
<td>Sailing</td>
<td>North</td>
<td>Brigitte</td>
</tr>
<tr>
<td>23</td>
<td>06/04/08</td>
<td>$2,135</td>
<td>Sailing</td>
<td>East</td>
<td>Brigitte</td>
</tr>
<tr>
<td>24</td>
<td>06/20/08</td>
<td>$3,617</td>
<td>Sailing</td>
<td>North</td>
<td>Brigitte</td>
</tr>
<tr>
<td>25</td>
<td>06/28/08</td>
<td>$545</td>
<td>Sailing</td>
<td>South</td>
<td>Brigitte</td>
</tr>
</tbody>
</table>

**$24,422** **Sailing Sum**

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
</tr>
</thead>
<tbody>
<tr>
<td>26</td>
<td></td>
<td>$4,872</td>
<td>Tennis</td>
<td>East</td>
<td>Brigitte</td>
</tr>
<tr>
<td>27</td>
<td>01/03/08</td>
<td>$4,872</td>
<td>Tennis</td>
<td>East</td>
<td>Brigitte</td>
</tr>
<tr>
<td>28</td>
<td>02/02/08</td>
<td>$1,218</td>
<td>Tennis</td>
<td>East</td>
<td>Brigitte</td>
</tr>
<tr>
<td>29</td>
<td>02/11/08</td>
<td>$2,565</td>
<td>Tennis</td>
<td>East</td>
<td>Brigitte</td>
</tr>
<tr>
<td>30</td>
<td>02/28/08</td>
<td>$3,145</td>
<td>Tennis</td>
<td>East</td>
<td>Brigitte</td>
</tr>
<tr>
<td>31</td>
<td>03/03/08</td>
<td>$3,985</td>
<td>Tennis</td>
<td>North</td>
<td>Brigitte</td>
</tr>
<tr>
<td>32</td>
<td>06/07/08</td>
<td>$769</td>
<td>Tennis</td>
<td>West</td>
<td>Brigitte</td>
</tr>
<tr>
<td>33</td>
<td>06/08/08</td>
<td>$1,167</td>
<td>Tennis</td>
<td>West</td>
<td>Brigitte</td>
</tr>
<tr>
<td>34</td>
<td></td>
<td>$17,721</td>
<td>Tennis</td>
<td>East</td>
<td>Brigitte</td>
</tr>
<tr>
<td>35</td>
<td></td>
<td>$69,104</td>
<td>Brigitte</td>
<td>East</td>
<td>Brigitte</td>
</tr>
</tbody>
</table>
Sort
Defines how subtotal data is sorted. This section is disabled if the Pre-sort area according to groups is unchecked.

- **Ascending or Descending** – sorts entries by value from lowest to highest and highest to lowest, respectively. You can modify these sort rules by using Data > Sort in the Menu bar. For more detail, see Chapter 2, Entering, Editing, and Formatting Data.
- **Include formats** – carries over formatting, such as the currency format, from the data to the corresponding subtotals.
- **Custom sort order** – sorts your data according to one of the predefined custom sorts defined in Tools > Options > LibreOffice Calc > Sort Lists in the Menu bar. For more details about custom sort lists, see Chapter 2, Entering, Editing, and Formatting Data.

Reset and Remove
In the Subtotals dialog, use the Reset button to undo any changes made on the current tab page. Use the Remove button to remove any subtotals that have already been created using the Subtotals tool. Use these features with care, as no confirmation dialogs will be displayed.

Using scenarios
Scenarios are saved, named cell ranges that you can use to answer “what-if” questions about your data. You can create multiple scenarios for the same calculation set, then quickly swap between them to view the outcomes of each. This feature is useful if you need to test the effects of different conditions on your calculations, but do not want to deal with repetitive manual data entry. For example, if you wanted to test different interest rates for an investment, you could create scenarios for each rate, then switch between them to find out which rates work the best for you.

To use the Scenarios tool, select Tools > Scenarios from the Menu bar to open the Create Scenario dialog (Figure 293).
Creating scenarios

To create a new scenario:

1) Select the cells that contain the values that will change between scenarios. To select multiple ranges, hold down the Ctrl key as you click. You must select at least two cells.

2) Choose Tools > Scenarios from the Menu bar to open the Create Scenario dialog.

3) Enter a name for the new scenario in the Name of Scenario field.

4) Optionally, add information to the Comment field. The example in Figure 293 shows the default comment.

5) Click OK to close the dialog. The new scenario is automatically activated upon creation.

6) Repeat steps 1 to 5 to create additional scenarios. Select the same cell range that you used for the first scenario to have multiple scenarios for the same calculations.

Tip

For each scenario you create, use a unique name that clearly identifies and distinguishes it. This practice will save you time and headache if you have to work with a large set of scenarios.

Tip

To keep track of what calculations are dependent on your scenarios, use Tools > Detective > Trace Dependents from the Menu bar on your scenario cells. Arrows will point from your scenario cells to the dependent formula cells. For more information about the Detective tool, see Chapter 7, Using Formulas and Functions.
Scenario settings

The Settings sections of the Create Scenario dialog contains the following options:

![Create Scenario settings](image)

**Display border**
Places a colored border around the cell range that contains your scenario (Figure 295). To choose the color of the border, use the drop-down field to the right of this option. The border has a title bar displaying the name of the active scenario and a down arrow button that opens a drop-down list of all the scenarios defined for the current cell range. You can swap to a scenario by selecting it from this list.

![Scenario cell range with border](image)

**Copy back**
Copies any changes made to a scenario’s cell values back into the active scenario. If you uncheck this option, then the scenario’s initial values cannot be overwritten. The actual behavior of the Copy back setting depends on the current cell and sheet protections and the Prevent changes setting (see Table 10 on page 302).

**Caution**
When creating a new scenario from the cells of a scenario with Copy back enabled, be careful not to overwrite the old scenario. To avoid this situation, create the new scenario with Copy back enabled first, then change its values only once it is active.

**Copy entire sheet**
Creates a copy of the sheet with the new active scenario. The sheet is named after this scenario. Note that changing scenario values in the copy sheet will not affect the active scenario, even if it has Copy back enabled.
Prevent changes
Prevents changes to a scenario with Copy back enabled when the sheet is protected but the cells are not. Also prevents changes to the scenario's settings while the sheet is protected. This option and its effects are more fully explained in the next section.

Changing scenarios
Scenarios have two aspects that can be altered independently:
- Scenario properties (that is, its settings)
- Scenario cell values

The extent to which these aspects can be changed depends on the active scenario's properties and the current sheet and cell protections. For more detail about sheet and cell protections, see Chapter 2, Entering, Editing, and Formatting Data.

Changing scenario properties
Table 9 summarizes how sheet protection and the Prevent changes option affect your ability to change scenario properties.

Table 9: Changing scenario properties

<table>
<thead>
<tr>
<th>Sheet protection</th>
<th>Prevent changes</th>
<th>Property changes</th>
</tr>
</thead>
<tbody>
<tr>
<td>On</td>
<td>On</td>
<td>No scenario properties can be changed.</td>
</tr>
<tr>
<td>On</td>
<td>Off</td>
<td>Display border and Copy back can be changed. Prevent changes and Copy entire sheet cannot be changed.</td>
</tr>
<tr>
<td>Off</td>
<td>Any setting</td>
<td>All scenario parameters except for Copy entire sheet can be changed. In this case, the Prevent changes option has no effect.</td>
</tr>
</tbody>
</table>

Changing scenario cell values
Table 10 summarizes the interaction of various settings in making changes to scenario cell values.

Table 10: Changing scenario cell values

<table>
<thead>
<tr>
<th>Sheet protection</th>
<th>Scenario cell protection</th>
<th>Prevent changes</th>
<th>Copy back</th>
<th>Change allowed</th>
</tr>
</thead>
<tbody>
<tr>
<td>On</td>
<td>Off</td>
<td>On</td>
<td>On</td>
<td>Scenario cell values cannot be changed.</td>
</tr>
<tr>
<td>On</td>
<td>Off</td>
<td>Off</td>
<td>On</td>
<td>Scenario cell values can be changed, and the scenario is updated.</td>
</tr>
<tr>
<td>On</td>
<td>Off</td>
<td>Any setting</td>
<td>Off</td>
<td>Scenario cell values can be changed, but the scenario is not updated due to the Copy back setting.</td>
</tr>
<tr>
<td>On</td>
<td>Any setting</td>
<td>Any setting</td>
<td>Any setting</td>
<td>Scenario cell values cannot be changed.</td>
</tr>
<tr>
<td>Off</td>
<td>Any setting</td>
<td>Any setting</td>
<td>Any setting</td>
<td>Scenario cell values can be changed and the scenario is updated or not, depending on the Copy back setting.</td>
</tr>
</tbody>
</table>
Working with scenarios using the Navigator

After you add scenarios to a spreadsheet, you can view a particular scenario by using the Navigator. Open it by selecting **View > Navigator** from the Menu bar, then click on the **Scenarios** icon in the Navigator and select a scenario from the list (Figure 296). Any defined scenarios are listed along with the comments that were entered when each scenario was created. For more information about the Navigator, see Chapter 1, Introducing Calc.

![Navigator](image)

*Figure 296: Scenarios in the Navigator*

To apply a scenario to the current sheet, double-click the scenario name in the Navigator.

To delete a scenario, right-click the name in the Navigator and choose **Delete**. A confirmation dialog will be displayed.

To edit a scenario, right-click the name in the Navigator and choose **Properties**. Calc displays the Edit Scenario dialog, which is similar to the Create Scenario dialog (Figure 293) except for the **Copy entire sheet** option, which is disabled.

Using the Multiple Operations tool

Like scenarios, the Multiple Operations tool performs what-if analysis on your calculations. Unlike scenarios, which represent individual sets of values for multiple formula variables, this tool uses a whole range of values for just one or two variables. It then uses one or more formulas to create a matching range of solutions. Since each solution corresponds to one or two variable values, both the variable and solution ranges can be easily arrayed in tabular format. As a result, the Multiple Operations tool is well-suited to generating data that easy to read and share or visualize using graphs.

Tip

Exercising good organization can make using this tool relatively painless. For example, we recommend keeping your data together on one sheet and using labels to identify your formulas, variables, and table ranges.
To use this tool, select Data > Multiple Operations from the Menu bar to open the Multiple Operations dialog (Figure 297).

**Multiple Operations with one formula and one variable**

The easiest way to learn how to use the Multiple Operations tool is with one formula and one variable. To learn how to use the tool with multiple formulas or with two variables, see “Calculating with several formulas simultaneously” (page 306) and “Multiple operations with two variables” (page 308), respectively.

To use the Multiple Operations tool with one formula and one variable:

1. In the cells of a worksheet, enter a formula and at least one variable that it uses.
2. In the same worksheet, enter values into a cell range that occupies a single column or row. These values will be used for one of variables of the formula that you defined in step 1.
3. With the mouse, select the range containing both the variable range that you defined in step 2 and the adjacent empty cells that follow it. Depending on how your variable range is arrayed, these empty cells will either be in the column to the right (if the range is in a column) or in the row immediately below (if it is in a row).
4. Select Data > Multiple Operations to open the Multiple Operations dialog.
5. Click on the Formulas field and type a cell reference to the formula you defined in step 1 or select the cell with the mouse. Use the associated Shrink / Expand button if you need to minimize the dialog while selecting the cell.
6. If the range from step 2 is arrayed in a column, then click on the Column input cell field and type a cell reference to the variable that you want to use or select the cell with the mouse. If the range is in a row, then use the Row input cell field instead.
7. Click OK to run the tool. The Multiple Operations tool will generate its results in the empty cells that you selected in step 3. Each result value corresponds to the variable value adjacent to it, and together they form the entries of a results table.

**An example with one formula and one variable**

Using the Multiple Operations tool is best explained by example. Suppose that you produce toys that you sell for $10 each (cell B1 of a worksheet). Each toy costs $2 to make (B2), and you have a fixed annual cost of $10,000 (B3). What is the minimum number of toys that you must sell to break even? Suppose that our initial estimate of quantity sold is 2,000 (B4).

To answer this question:

1. Enter the following formula into B5: =B4*(B1-B2)-B3. This formula represents the equation Profit = Quantity * (Selling price – Direct costs) – Fixed costs. With this equation, our initial quantity produces a $6,000 profit, which is higher than the break-even point.
2) In D2:D11, enter a range of alternate quantities from 500 to 5000 in steps of 500.

3) Select the range D2:E11 to define the results table. This range includes the alternate quantity values (column D) and the empty results cells (column E).

4) Select **Data > Multiple Operations** to open the Multiple Operations dialog.

5) Using the **Formulas** field, select the cell B5.

6) Using the **Column input cell** field, select the cell B4 to set the quantity as the variable for our calculations. Figure 298 shows the worksheet and Multiple Operations dialog at this point.

7) Click **OK**. The profits for the different quantities are now shown in column E (Figure 299). We can see that the break-even point is between 1000 and 1500 toys sold – namely, 1250.

---

**Figure 298**: Inputs to Multiple Operations tool for one formula, one variable

**Figure 299**: Results of Multiple Operations tool for one formula and one variable
Calculating with several formulas simultaneously

Using the Multiple Operations tool with multiple formulas follows nearly the same process as with one formula, but with two important differences:

1) For each formula that you add, you must also add a corresponding column or row to the results table to contain the output of that formula.

2) How you initially arrange your formulas determines how their results will be displayed in the results table. For example, if you arrange the formulas $A$, $B$, and $C$ in a single row in that order, then Calc will generate the results of $A$ in the first results table column, the results of $B$ in the second column, and the results of $C$ in the third.

**Note**

The Multiple Operations tool only accepts formulas arranged in a single row or column, depending on how your results table is oriented. If the table is column-oriented – that is, the way it is in our sales data example – then your formulas must be arranged in a row. If the table is row-oriented, then your formulas must be in a column.

**Caution**

Be careful not to add empty cells between formulas, as they will create gaps in the results table and may cause some results not to appear if you don't select enough rows or columns for the table.

*An example with two formulas and one variable*

Using our sales data example, suppose that we want to calculate the annual profit per item sold in addition to the annual overall profit. To calculate the results:

1) In the sheet from the previous example, delete the results in column E.

2) Enter the following formula in C5: `=B5/B4`. You are now calculating the annual profit per item sold.

3) Select the range D2:F11 for the results table. Column F will contain the results of the annual profit per item formula in C5.
4) Select **Data > Multiple Operations** from the Menu bar to open the Multiple Operations dialog.

5) Using the **Formulas** field, select the range B5:C5.

6) Using the **Column input cell** field, select the cell B4. Figure 301 shows the worksheet and the dialog at this point.

![Figure 301: Inputs to Multiple Operations tool for one variable and two formulas](image)

7) Click **OK**. Now the profits are listed in column E and the annual profit per item in column F.

![Figure 302: Results of Multiple Operations tool for one variable and two formulas](image)
Multiple operations with two variables

When you use the Multiple Operations tool with two variables, it creates a two-dimensional results table. Each variable defines one of the table’s dimensions such that the alternate values for both variables serve as the table’s row and column headings, respectively. Each cell in the table corresponds to a distinct pair of row and column heading values. In turn, the results in each cell are created from these values for both variables.

Since you are using two variables, you must use both the Column input cell and Row input cell dialog fields to define them. The order is important; the Column input cell field corresponds to the row heading values, while the Row input cell field corresponds to the column heading values.

Tip

A good guideline to remember is that since column headings are in a row at the top of the table, they correspond to the Row input cell field. Likewise, row headings are in a column, so they correspond to the Column input cell field.

Note

If you use two variables, the Multiple Operations tool will not work with multiple formulas. It will allow you to enter the extra formulas, but will not generate the expected results for any formula beyond the first.

Calculating with two variables

Using our sales example, suppose that in addition to varying the quantity of toys sold, you also want to vary the unit sale price as well. To calculate the results:

1) Expand the sales data table by entering $8, $10, $15 and $20 in the range E1:H1.
2) Select the range D1:H11 for the results table.
3) Select Data > Multiple Operations from the Menu bar to open the Multiple Operations dialog.
4) Using the Formulas field, select cell B5.
5) Using the Row input cell field, select cell B1. The column headings – $8, $10, $15 and $20 – are now linked to the unit sale price variable defined in cell B1.
6) Using the Column input cell field, select cell B4. The row headings – 500, 1000, …, 5000 – are now linked to the quantity sold variable defined in cell B4. Figure 303 shows the worksheet and dialog at this point.
7) Click OK. The profits for the different sale prices and quantities are now shown in the range E2:H11 (Figure 309).
Using Goal Seek

In addition to scenarios and the Multiple Operations tool, Calc has a third “what-if” analysis tool: Goal Seek. Usually, you use a formula to calculate a result from existing values. In contrast, with Goal Seek, you work backwards from a result to discover what values produce it. This feature is useful if you already know the outcome you want, but need to answer questions such as how to reach it or how it could be changed if you altered conditions.

To use this tool, select **Tools > Goal Seek** from the Menu bar to open the Goal Seek dialog (Figure 305).

**Note**

Only one argument can be altered at a time in a single goal seek. If you need to test multiple arguments, then you must run a separate goal seek on each one.
Goal Seek example

To illustrate how to use Goal Seek, suppose that we want to calculate the annual interest return for an account. To calculate annual interest (I), we must create a table with values for the capital (C), the interest period length in years (n), and the interest rate (i). The formula is \( I = C \times n \times i \).

Suppose that the interest rate \( i = 7.5\% \) (cell B3 of a worksheet) and the period length \( n = 1 \) (B2) remain constant. We want to know how much investment capital \( C \) is needed to achieve a return of \( I = \$15,000 \). Assume that our initial capital estimate is \( C = \$100,000 \) (B1).

To calculate the return:

1) Enter the return formula (=B1*B2*B3) into B4 and select the cell with the mouse.

2) Select Tools > Goal Seek from the Menu bar to open the Goal Seek dialog.

3) B4 should already be entered in the Formula cell field. However, if you want to select a different cell, use the associated Shrink / Expand button to minimize the dialog while you select the required cell.

4) Click on the Variable cell field, then type a reference to cell B1 or select it with the mouse to make the capital the variable in the current Goal Seek.

5) Enter the desired formula result in the Target value field. In this example, the value is 15000. Figure 306 shows the cells and dialog fields at this point.

6) Click OK. A dialog appears informing you that the goal seek was successful (Figure 307).
7) Click Yes to enter the goal value into the variable cell. The result is shown in Figure 308, indicating that a capital requirement of $200,000 is needed to achieve a $15,000 return.

<p>| | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>B</td>
</tr>
<tr>
<td>1</td>
<td>Capital</td>
</tr>
<tr>
<td>2</td>
<td>Years</td>
</tr>
<tr>
<td>3</td>
<td>Interest rate</td>
</tr>
<tr>
<td>4</td>
<td>Annual return</td>
</tr>
</tbody>
</table>

Figure 308: Result of goal seek in worksheet

Note
Not every goal seek problem succeeds in returning a good result. It depends on the formula used, goal value, and initial value. The goal seek algorithm iterates internally several times converging to the goal.

Using the Solver

The Solver amounts to a more elaborate form of goal seek, which allows you to solve linear programming or optimization problems. A linear programming problem is concerned with minimizing or maximizing a linear function subject to a set of linear constraints. Such problems arise in many scientific, engineering, business, and other disciplines. A full discussion of linear programming is beyond the scope of this guide and the interested reader is referred to relevant Operations Research websites or text books for more information.

Currently, in version 6.2, LibreOffice offers the following linear solvers:

- The open source lp_solve solver (prior to version 4.3)
- The open source CoinMP (CLP) linear solver (since 4.3; default)

A benchmark study involving both linear solvers suggests that CLP is faster and more efficient than lp_solve. In general, however, either engine will produce an accurate solution relatively quickly.

Note
For more information on Calc's linear solvers, see the following links:

lp_solve – [http://lpsolve.sourceforge.net/5.5/](http://lpsolve.sourceforge.net/5.5/)

CLP and the COIN-OR Foundation – [https://www.coin-or.org/](https://www.coin-or.org/)

Benchmark study including both lp_solve and CLP: [https://prod-ng.sandia.gov/techlib-noauth/access-control.cgi/2013/138847.pdf](https://prod-ng.sandia.gov/techlib-noauth/access-control.cgi/2013/138847.pdf)
Caution

LibreOffice 6.2 offers a third solver engine: the LibreOffice Swarm Non-Linear Solver (experimental). As it is an experimental tool, it may not be supported in future versions of Calc, and we recommend that you do not use this option unless you are familiar with nonlinear programming concepts.

In order to use the Solver to solve a linear programming problem, you must formulate the problem as follows:

- **Decision variables** – a set of $n$ non-negative variables $x_1, \ldots, x_n$. Decision variables may be real numbers, but generally tend to be integers in many real-world problems.
- **Constraints** – a set of linear equalities or inequalities involving the $n$ decision variables.
- **Objective function** – a linear expression involving the $n$ decision variables.

The goal is usually to find values of the decision variables that satisfy the constraints and maximize or minimize the result of the objective function.

**Solver dialog**

After setting up the data for the problem in your Calc spreadsheet, select **Tools > Solver** from the Menu bar to open the Solver dialog (Figure 309).

![Solver dialog](image)
Note

Depending on the configuration of your computer, a message may be displayed the first time that you select Tools > Solver after starting Calc. The message will contain the text LibreOffice requires a 64-bit Java runtime environment (JRE) to perform this task. Please install a JRE and restart LibreOffice. Click the OK button to dismiss this dialog – the message does not affect operation of the two linear solvers.

Target cell
Type a cell reference to the objective function or select it with the mouse.

Optimize result to
Select Maximum to find the maximum result for the objective function, Minimum to find the minimum result, or Value of to set it to a specific value. If you select Value of, enter the required value or a reference to the cell containing that value.

By changing cells
Enter the locations of any cells that define your decision variables.

Limiting Conditions
Enter your constraints in the fields in this area:
- Cell reference – enter a cell reference to a decision variable.
- Operator – defines a parameter for a constraint. Available options include <= (less than or equal to), = (equal to), => (greater than or equal to), Integer (values without decimals), and Binary (only 0 or 1).
- Value – enter a value or a cell reference to a constraint formula.
- Remove button – deletes the currently-defined constraint.

Tip
Remember that for any of these options, you can minimize the Solver dialog using the associated Shrink / Expand buttons if you need to select cells with the mouse.

Once you have finished setting up the Solver, click the Solve button to begin the process of adjusting values and calculating results. Depending on the complexity of the task, this may take some time. On successful completion, Calc presents a Solving Result dialog (Figure 310). This dialog includes buttons to save (Keep Result) or discard (Restore Previous) your results.

Figure 310: Solving Result dialog

The Solver dialog also has an Options button, which opens the Options dialog shown in Figure 311.
Solver options

![Solver Options dialog](image)

**Solver engine**

With the standard LibreOffice 6.2 download, the Solver engine drop-down list provides three options:

- **LibreOffice CoinMP Linear Solver** (default)
- **LibreOffice Linear Solver** (*lp_solve*)
- **LibreOffice Swarm Non-Linear Solver** (experimental)

**Settings**

This area enables the user to adjust the detailed processing parameters of the selected solver engine. For the two linear solvers, these parameters include:

- **Assume variables are integers**
- **Assume variables are non-negative**
- **Epsilon level (0-3)** – This parameter determines the upper bound on relative error due to floating-point rounding. Value 0 corresponds to very tight epsilon values (default); value 3 corresponds to very loose epsilon values.
- **Limit branch-and-bound depth**
- **Solving time limit (secs)** – 100 seconds is the default.

**Solver example**

Suppose that you have $10,000 that you want to invest in two mutual funds for one year. Fund X is a low risk fund with an 8% interest rate and Fund Y is a higher risk fund with a 12% interest rate. How much money should be invested in each fund to earn a total interest of $1,000?

To find the answer using the Solver:

1. Enter the following labels and data into a worksheet:
   - **Row labels:** Fund X, Fund Y, and Total in cells A2, A3, and A4.
   - **Column labels:** Interest earned, Amount invested, Interest rate, and Time period in cells B1 thru E1.
   - Interest rates: 8% and 12% in cells D2 and D3.
   - Time period: 1 in cells E2 and E3.
– Total amount invested: $10000 in cell C4.
– Enter an arbitrary value ($0 or leave blank) in cell C2 as the amount invested in Fund X.

2) Enter the following formulas:
– In cell C3, enter the formula =C4–C2 (total amount – amount invested in Fund X) as the amount invested in Fund Y.
– In cells B2 and B3, enter the formulas =C2*D2*E2 (B2) and =C3*D3*E3 (B3).
– In cell B4, enter the formula =B2+B3 as the total interest earned. Figure 312 shows the worksheet at this point.

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Fund X</td>
<td>$0</td>
<td>$0</td>
<td>8%</td>
<td>1</td>
</tr>
<tr>
<td>2</td>
<td>Fund Y</td>
<td>$1,200</td>
<td>$10,000</td>
<td>12%</td>
<td>1</td>
</tr>
<tr>
<td>3</td>
<td>Total</td>
<td>$1,200</td>
<td>$10,000</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Figure 312: Solver example setup

3) Select **Tools > Solver** from the Menu bar to open the Solver dialog (Figure 309).
4) Using the **Target cell** field, select the cell that contains the target value. In this example, it is B4, which contains the total interest value.
5) Select **Value of** and enter 1000 in the field next to it. In this example, the target cell value is 1000 because your target is a total interest earned of $1,000.
6) Using the **By changing cells** field, select cell C2 in the sheet. In this example, you need to find the amount invested in Fund X (cell C2).
7) Enter the following limiting conditions for the variables by using the **Cell reference**, **Operator**, and **Value** fields:
   – C2 <= C4 – the amount invested in Fund X cannot exceed the total amount available.
   – C2 => 0 – the amount invested in Fund X cannot be negative.
   – C2 is an **Integer** – specified for convenience.
8) Click **OK**. The result is shown in Figure 313.

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Interest earned</td>
<td>$400</td>
<td>$5,000</td>
<td>8%</td>
<td>1</td>
</tr>
<tr>
<td>2</td>
<td>Fund X</td>
<td>$600</td>
<td>$5,000</td>
<td>12%</td>
<td>1</td>
</tr>
<tr>
<td>3</td>
<td>Total</td>
<td>$1,000</td>
<td>$10,000</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Figure 313: Solver example result

### Using Statistics tools

Under **Data > Statistics** in the Menu bar, Calc features several tools for quick and easy statistical analysis of your data. These tools include:

- Sampling
- Descriptive Statistics
- Analysis of Variance (ANOVA)
- Correlation
The Sampling tool creates a target table with data sampled from a source table. The sampling tool can pick samples randomly or on a periodic basis. Sampling is done row-wise, with whole rows of the source table copied into rows of the target table. To use this tool, select **Data > Statistics > Sampling** from the Menu bar to access the Sampling dialog (Figure 314).

**Input range**
Specifies the cell range containing the source table.

**Results to**
Specifies the top left cell of the target table. When you run the tool, it will fill out the rest of the target table starting from this cell.

**Random**
Enables random sampling mode when selected.

**Sample size**
Defines the number of lines to be sampled from the source table during random sampling. Only available if the **Random** option is selected.

**Periodic**
Enables periodic sampling mode when selected.
**Period**
Defines the number of lines to skip between samples during periodic sampling. For example, a value of 2 will cause alternate lines to be sampled from the source table, starting with the second line. Only available if the Periodic option is selected.

**Tip**
Use the Shrink / Expand buttons next to the Input range and Results to fields if you need to shrink the dialog while selecting cells with the mouse.

Figure 315 shows the source table (below the Source Data heading) and the corresponding target table (under the Target Data heading), sampled using the settings shown in Figure 314.

![Figure 315: Example data for the Sampling tool](image)

**Descriptive Statistics tool**
Given a set of data, the Descriptive Statistics tool creates a tabular report of a data set's primary statistical properties, such as information about its central tendency and variability. Select Data > Statistics > Descriptive Statistics in the Menu bar to access the Descriptive Statistics dialog (Figure 316).

![Figure 316: Descriptive Statistics dialog](image)
**Input range**
Specifies the cell range containing the source data.

**Results to**
Specifies the top left cell of the results area. When you run the tool, it will fill out the rest of the report table starting at this cell.

**Columns / Rows**
Specifies whether the data to be analyzed is organized in columns or rows.

---

**Tip**
Use the **Shrink / Expand** buttons next to the **Input range** and **Results to** fields if you need to shrink the dialog while selecting cells with the mouse.

---

Figure 317 shows a small data set comprising student examination results in three subjects.

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Maths</td>
<td>Physics</td>
<td>Biology</td>
</tr>
<tr>
<td>2</td>
<td>47</td>
<td>67</td>
<td>33</td>
</tr>
<tr>
<td>3</td>
<td>36</td>
<td>68</td>
<td>42</td>
</tr>
<tr>
<td>4</td>
<td>40</td>
<td>65</td>
<td>44</td>
</tr>
<tr>
<td>5</td>
<td>39</td>
<td>64</td>
<td>60</td>
</tr>
<tr>
<td>6</td>
<td>38</td>
<td></td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>47</td>
<td>84</td>
<td>62</td>
</tr>
<tr>
<td>8</td>
<td>29</td>
<td>80</td>
<td>51</td>
</tr>
<tr>
<td>9</td>
<td>27</td>
<td>49</td>
<td>40</td>
</tr>
<tr>
<td>10</td>
<td>57</td>
<td>49</td>
<td>12</td>
</tr>
<tr>
<td>11</td>
<td>56</td>
<td>33</td>
<td>60</td>
</tr>
<tr>
<td>12</td>
<td>57</td>
<td></td>
<td></td>
</tr>
<tr>
<td>13</td>
<td>26</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

*Figure 317: Input data for descriptive statistics analysis*

---

Figure 318 shows the statistics report generated for this input data using the settings shown in Figure 316.

<table>
<thead>
<tr>
<th></th>
<th>F</th>
<th>G</th>
<th>H</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Column 1</td>
<td>Column 2</td>
<td>Column 3</td>
</tr>
<tr>
<td>Mean</td>
<td>41.909091</td>
<td>59.7</td>
<td>44.7</td>
</tr>
<tr>
<td>St. Error</td>
<td>3.561038</td>
<td>5.358379</td>
<td>4.758065</td>
</tr>
<tr>
<td>Mode</td>
<td>47</td>
<td>49</td>
<td>60</td>
</tr>
<tr>
<td>Median</td>
<td>40</td>
<td>64.5</td>
<td>43.5</td>
</tr>
<tr>
<td>1st Quartile</td>
<td>32.5</td>
<td>49</td>
<td>40.5</td>
</tr>
<tr>
<td>3rd Quartile</td>
<td>51.5</td>
<td>67.75</td>
<td>57.75</td>
</tr>
<tr>
<td>Variance</td>
<td>139.490909</td>
<td>287.122222</td>
<td>227.344444</td>
</tr>
<tr>
<td>St. Deviation</td>
<td>11.810627</td>
<td>16.944681</td>
<td>15.077946</td>
</tr>
<tr>
<td>Kurtosis</td>
<td>-1.452168</td>
<td>-0.941599</td>
<td>1.418053</td>
</tr>
<tr>
<td>Skewness</td>
<td>0.015241</td>
<td>-0.222643</td>
<td>-0.976680</td>
</tr>
<tr>
<td>Range</td>
<td>51</td>
<td>12</td>
<td></td>
</tr>
<tr>
<td>Minimum</td>
<td>26</td>
<td>33</td>
<td>12</td>
</tr>
<tr>
<td>Maximum</td>
<td>57</td>
<td>84</td>
<td>62</td>
</tr>
<tr>
<td>Sum</td>
<td>461</td>
<td>597</td>
<td>447</td>
</tr>
<tr>
<td>Count</td>
<td>11</td>
<td>10</td>
<td>10</td>
</tr>
</tbody>
</table>

*Figure 318: Results from Descriptive Statistics tool*
Tip


Analysis of Variance (ANOVA) tool

The Analysis of Variance (ANOVA) tool compares the means of two or more groups in a sample. Select **Data > Statistics > Analysis of Variance (ANOVA)** in the Menu bar to access the Analysis of Variance (ANOVA) dialog (Figure 319).

![Figure 319: Analysis of Variance (ANOVA) dialog](image)

**Input range**
- Specifies the cell range containing the source data.

**Results to**
- Specifies the top left cell of the results area. When you run the tool, it will fill out the analysis of variance report table starting at this cell.

**Single / Two factor**
- Determines whether the analysis is for single factor or two factor ANOVA.

**Columns / Rows**
- Specifies whether the data to be analyzed is organized in columns or rows. Only available if **Single factor** is selected.

**Alpha**
- In this field, enter a significance level in the range 0.01 to 0.99. The default is 0.05.

**Rows per sample**
- Defines how many rows a sample has. This option is always set to 1 in this version of Calc.
To illustrate how to use this tool, we use the input data set from Figure 317. Figure 320 shows the analysis of variance results generated for this data using the settings shown in Figure 319.

<table>
<thead>
<tr>
<th>E</th>
<th>F</th>
<th>G</th>
<th>H</th>
<th>I</th>
<th>J</th>
<th>K</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>ANOVA - Single Factor</strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Alpha</td>
<td>0.05</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Groups</strong></td>
<td><strong>Count</strong></td>
<td><strong>Sum</strong></td>
<td><strong>Mean</strong></td>
<td><strong>Variance</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Column 1</td>
<td>11</td>
<td>451</td>
<td>41.900001</td>
<td>139.490909</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Column 2</td>
<td>10</td>
<td>597</td>
<td>59.7</td>
<td>287.122222</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Column 3</td>
<td>10</td>
<td>447</td>
<td>44.7</td>
<td>227.344444</td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Source of Variation</strong></td>
<td><strong>SS</strong></td>
<td><strong>df</strong></td>
<td><strong>MS</strong></td>
<td><strong>F</strong></td>
<td><strong>P-value</strong></td>
<td><strong>F critical</strong></td>
</tr>
<tr>
<td>Between Groups</td>
<td>1876568328</td>
<td>2</td>
<td>938.284164</td>
<td>4.360412</td>
<td>0.022461</td>
<td>3.340386</td>
</tr>
<tr>
<td>Within Groups</td>
<td>6025109091</td>
<td>28</td>
<td>215.182468</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Total</td>
<td>7901677419</td>
<td>30</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

*Figure 320: Results from Analysis of Variance (ANOVA) tool*

**Tip**

**Correlation tool**
The Correlation tool calculates the correlation of two sets of numeric data and generates the resulting correlation coefficient. This coefficient is a value between -1 and +1 that indicates how strongly two variables are related to each other. A correlation coefficient of +1 indicates a perfect positive correlation (the data sets match) and a coefficient of -1 indicates a perfect negative correlation (the data sets are inverse to each other). Select **Data > Statistics > Correlation** in the Menu bar to access the Correlation dialog (Figure 321).

**Input range**
- Specifies the cell range containing the source data.

**Results to**
- Specifies the top left cell of the results area. When you run the tool, it will fill out the correlation coefficient table starting at this cell.

**Columns / Rows**
- Specifies whether the data to be analyzed is organized in columns or rows.
To illustrate how to use this tool, we again use the data set from Figure 317. Figure 322 shows the six correlation coefficients generated for this input data using the settings shown in Figure 321.

<table>
<thead>
<tr>
<th></th>
<th>E</th>
<th>F</th>
<th>G</th>
<th>H</th>
</tr>
</thead>
<tbody>
<tr>
<td>Correlations</td>
<td>Column 1</td>
<td>Column 2</td>
<td>Column 3</td>
<td></td>
</tr>
<tr>
<td>Column 1</td>
<td>1</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Column 2</td>
<td>-0.402925</td>
<td>1</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Column 3</td>
<td>-0.210764</td>
<td>0.230971</td>
<td>1</td>
<td></td>
</tr>
</tbody>
</table>

Figure 322: Correlation results

Tip

For more information on statistical correlation, refer to the corresponding Wikipedia article at https://en.wikipedia.org/wiki/Correlation_and_dependence.

Covariance tool

The Covariance tool measures how much two sets of numeric data vary together. Select Data > Statistics > Covariance in the Menu bar to access the Covariance dialog (Figure 323).

Input range

Specifies the cell range containing the source data.

Results to

Specifies the top left cell of the results area. When you run the tool, it will fill out the covariance table starting at this cell.

Columns / Rows

Specifies whether the data to be analyzed is organized in columns or rows.

To illustrate how to use this tool, we again use the data set from Figure 317. Figure 324 shows the six covariance values generated for this input data using the settings shown in Figure 323.

<table>
<thead>
<tr>
<th></th>
<th>E</th>
<th>F</th>
<th>G</th>
<th>H</th>
</tr>
</thead>
<tbody>
<tr>
<td>Covariances</td>
<td>Column 1</td>
<td>Column 2</td>
<td>Column 3</td>
<td></td>
</tr>
<tr>
<td>Column 1</td>
<td>126.809917</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Column 2</td>
<td>-61.444444</td>
<td>258.41</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Column 3</td>
<td>-32</td>
<td>53.11</td>
<td>204.61</td>
<td></td>
</tr>
</tbody>
</table>

Figure 324: Covariance results
Exponential Smoothing tool

The Exponential Smoothing tool filters a data set to produce smoothed results. It is used in domains such as stock market analysis and in sampled measurements. Select Data > Statistics > Exponential Smoothing in the Menu bar to access the Exponential Smoothing dialog (Figure 325).

![Exponential Smoothing dialog](image)

**Input range**

Specifies the cell range containing the source data.

**Results to**

Specifies the top left cell of the results area. When you run the tool, it will generate smoothed results starting at this cell.

**Columns / Rows**

Specifies whether the data to be analyzed is organized in columns or rows.

**Smoothing factor**

Enter a value here between 0 and 1 (default is 0.2) that represents the damping factor alpha in the smoothing equation.

To illustrate how to use this tool, we use the data set shown in Figure 326. The table has two time series representing impulse functions at times $t=0$ and $t=2$. 

Figure 326: Input data set for exponential smoothing example

Figure 327 shows the smoothed results for this input data using the settings shown in Figure 325.

<table>
<thead>
<tr>
<th>D</th>
<th>E</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alpha</td>
<td>0.5</td>
</tr>
<tr>
<td>Column 1</td>
<td>Column 2</td>
</tr>
<tr>
<td>1</td>
<td>0</td>
</tr>
<tr>
<td>1</td>
<td>0</td>
</tr>
<tr>
<td>0.5</td>
<td>0.25</td>
</tr>
<tr>
<td>0.25</td>
<td>0.5</td>
</tr>
<tr>
<td>0.125</td>
<td>0.125</td>
</tr>
<tr>
<td>0.0625</td>
<td>0.0625</td>
</tr>
<tr>
<td>0.03125</td>
<td>0.03125</td>
</tr>
<tr>
<td>0.015625</td>
<td>0.015625</td>
</tr>
<tr>
<td>0.0078125</td>
<td>0.0078125</td>
</tr>
<tr>
<td>0.00390625</td>
<td>0.00390625</td>
</tr>
<tr>
<td>0.001953125</td>
<td>0.001953125</td>
</tr>
<tr>
<td>0.0009765625</td>
<td>0.0009765625</td>
</tr>
<tr>
<td>0.00048828125</td>
<td>0.00048828125</td>
</tr>
</tbody>
</table>

Figure 327: Results from Exponential Smoothing tool

For more information on exponential smoothing, refer to the corresponding Wikipedia article at https://en.wikipedia.org/wiki/Exponential_smoothing.

Tip

Moving Average tool

The Moving Average tool calculates the moving average of a time series data set. Select Data > Statistics > Moving Average in the Menu bar to access the Moving Average dialog (Figure 328).
Input range  
Specifies the cell range containing the source data.

Results to  
Specifies the top left cell of the results area. When you run the tool, it will generate the moving average results starting at this cell.

Columns / Rows  
Specifies whether the data to be analyzed is organized in columns or rows.

Interval  
Specifies the number of samples used in the moving average calculation.

To illustrate how to use this tool, we again use the data set from Figure 326. Figure 329 shows the moving averages calculated for this input data using the settings shown in Figure 328.
Tip

For more information on the moving average, refer to the corresponding Wikipedia article at https://en.wikipedia.org/wiki/Moving_average.

Regression tool

The Regression tool analyzes the relationship in a data set between one or more independent variables and a dependent variable. Select **Data > Statistics > Regression** in the Menu bar to access the Regression dialog (Figure 330).

**Figure 330: Regression dialog**

**Independent variable(s) (X) range**
Specifies the cell range containing the independent variables in the source data.

**Dependent variable (Y) range**
Specifies the cell range containing the dependent variable in the source data.

**Both X and Y ranges have labels**
Specifies whether the ranges above include data labels.

**Results to**
Specifies the top left cell of the results area. When you run the tool, it will generate the regression analysis table starting at this cell.
Columns / Rows
Specifies whether the data to be analyzed is organized in columns or rows.

Linear Regression
Select this option to use linear regression. Linear regression finds a straight line in the form of \( y = (a \times x) + b \) that best fits the data, where \( a \) is the slope and \( b \) is the intercept.

Logarithmic Regression
Select this option to use logarithmic regression. Logarithmic regression finds a logarithmic curve in the form of \( y = (a \times \ln(x)) + b \) that best fits the data, where \( a \) is the slope, \( b \) is the intercept and \( \ln(x) \) is the natural logarithm of \( x \).

Power Regression
Select this option to use power regression. Power regression finds a power curve in the form of \( y = (a \times x)^b \) that best fits the data, where \( a \) is the coefficient and \( b \) is the exponent.

Confidence level
Specifies the confidence level, which is a value between 0 and 1. The default value is 0.95.

Calculate residuals
Specifies whether to calculate residuals.

Force intercept to be zero
Specifies whether to force the regression intercept to be 0.

Tip
Use the Shrink / Expand buttons next to the Independent variable(s) (X) range, Dependent variable (Y) range, and Results to fields if you need to shrink the dialog while selecting cells with the mouse.

To illustrate how to use this tool, we use the data set shown in Figure 331. This table contains measurements taken at 1 second intervals.

```
<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Time</td>
<td>Measurement</td>
</tr>
<tr>
<td>2</td>
<td>1</td>
<td>2.7</td>
</tr>
<tr>
<td>3</td>
<td>2</td>
<td>4.0</td>
</tr>
<tr>
<td>4</td>
<td>3</td>
<td>4.4</td>
</tr>
<tr>
<td>5</td>
<td>4</td>
<td>7.1</td>
</tr>
<tr>
<td>6</td>
<td>5</td>
<td>4.9</td>
</tr>
<tr>
<td>7</td>
<td>6</td>
<td>3.6</td>
</tr>
<tr>
<td>8</td>
<td>7</td>
<td>4.0</td>
</tr>
<tr>
<td>9</td>
<td>8</td>
<td>0.6</td>
</tr>
<tr>
<td>10</td>
<td>9</td>
<td>1.0</td>
</tr>
<tr>
<td>11</td>
<td>10</td>
<td>4.3</td>
</tr>
</tbody>
</table>
```

Figure 331: Input data set for regression analysis

Figure 332 shows the regression outputs calculated for this input data using the settings shown in Figure 330.
Tip

For more information on regression analysis, refer to the corresponding Wikipedia article at https://en.wikipedia.org/wiki/Regression_analysis.

Paired T-test tool

The Paired T-test tool compares the population means of two related sample sets and determines the difference between the two. Select Data > Statistics > Paired t-test in the Menu bar to access the Paired t-test dialog (Figure 333).
Variable 1 range
Specifies the cell range containing the first set of input data.

Variable 2 range
Specifies the cell range containing the second set of input data.

Results to
Specifies the top left cell of the results area. When you run the tool, it will generate the paired t-test table starting at this cell.

Columns / Rows
Specifies whether the data to be analyzed is organized in columns or rows.

To provide an example of using this tool, we make use of the input data set shown in Figure 334. The data sets in columns A and B represent two sets of paired values referred to as Variable 1 and Variable 2.

```
<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>28</td>
<td>19</td>
</tr>
<tr>
<td>2</td>
<td>26</td>
<td>13</td>
</tr>
<tr>
<td>3</td>
<td>31</td>
<td>12</td>
</tr>
<tr>
<td>4</td>
<td>23</td>
<td>5</td>
</tr>
<tr>
<td>5</td>
<td>20</td>
<td>34</td>
</tr>
<tr>
<td>6</td>
<td>27</td>
<td>31</td>
</tr>
<tr>
<td>7</td>
<td>28</td>
<td>31</td>
</tr>
<tr>
<td>8</td>
<td>14</td>
<td>12</td>
</tr>
<tr>
<td>9</td>
<td>4</td>
<td>24</td>
</tr>
<tr>
<td>10</td>
<td>0</td>
<td>23</td>
</tr>
<tr>
<td>11</td>
<td>2</td>
<td>19</td>
</tr>
<tr>
<td>12</td>
<td>8</td>
<td>10</td>
</tr>
<tr>
<td>13</td>
<td>9</td>
<td>33</td>
</tr>
</tbody>
</table>
```

Figure 334: Input data for paired t-test example

Figure 335 shows the paired t-test results calculated for this input data using the settings shown in Figure 333.
F-test tool

The F-test tool calculates the F-Test of two data samples. The tool is used to test the hypothesis that the variance of two populations are equal. Click Data > Statistics > F-test in the Menu bar to access the F-test dialog shown in Figure 336 and define the required inputs to the tool.

Variable 1 range
Specifies the cell range containing the first set of input data.

Variable 2 range
Specifies the cell range containing the second set of input data.
Results to
   Specifies the top left cell of the results area. When you run the tool, it will generate the F-test table starting at this cell.

Columns / Rows
   Specifies whether the data to be analyzed is organized in columns or rows.

Tip
   Use the Shrink / Expand buttons next to the Variable 1 range, Variable 2 range, and Results to fields if you need to shrink the dialog while selecting cells with the mouse.

To illustrate how to use this tool, we again use the data set from Figure 334. In this case, the data in columns A and B represent two independent sample sets, referred to as Variable 1 and Variable 2. Figure 337 shows the F-test results calculated for this input data using the settings shown in Figure 336.

<table>
<thead>
<tr>
<th>D</th>
<th>E</th>
<th>F</th>
</tr>
</thead>
<tbody>
<tr>
<td>F-test</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Alpha</td>
<td>0.05</td>
<td></td>
</tr>
<tr>
<td>Mean</td>
<td>Variable 1</td>
<td>Variable 2</td>
</tr>
<tr>
<td>Variance</td>
<td>16.923077</td>
<td>20.461538</td>
</tr>
<tr>
<td>Observations</td>
<td>13</td>
<td>13</td>
</tr>
<tr>
<td>df</td>
<td>12</td>
<td>12</td>
</tr>
<tr>
<td>F</td>
<td>1.324464</td>
<td></td>
</tr>
<tr>
<td>P (F&lt;=f) right-tail</td>
<td>0.317061</td>
<td></td>
</tr>
<tr>
<td>F Critical right-tail</td>
<td>2.686637</td>
<td></td>
</tr>
<tr>
<td>P (F&lt;=f) left-tail</td>
<td>0.682939</td>
<td></td>
</tr>
<tr>
<td>F Critical left-tail</td>
<td>0.372213</td>
<td></td>
</tr>
<tr>
<td>P two-tail</td>
<td>0.634123</td>
<td></td>
</tr>
<tr>
<td>F Critical two-tail</td>
<td>0.305131</td>
<td>3.277277</td>
</tr>
</tbody>
</table>

Figure 337: Results from F-test tool

Tip
   For more information on F-tests, refer to the corresponding Wikipedia article at https://en.wikipedia.org/wiki/F-test.

Z-test tool

The Z-test tool calculates the Z-test of two data samples. The tool performs a two sample Z-test to test the null hypothesis that there is no difference between the means of the two data sets. Click Data > Statistics > Z-test in the Menu bar to access the z-test dialog shown in Figure 338 and define the required inputs to the tool.

Variable 1 range
   Specifies the cell range containing the first set of input data.

Variable 2 range
   Specifies the cell range containing the second set of input data.

Results to
   Specifies the top left cell of the results area. When you run the tool, it will generate the Z-test table starting at this cell.
Columns / Rows
Specifies whether the data to be analyzed is organized in columns or rows.

Tip
Use the Shrink / Expand buttons next to the Variable 1 range, Variable 2 range, and Results to fields if you need to shrink the dialog while selecting cells with the mouse.

To provide an example of using this tool, we again make use of the input data set shown in Figure 334. In this case the data in columns A and B represent two data sets, referred to as Variable 1 and Variable 2. Figure 339 shows the Z-test results calculated for this input data using the settings shown in Figure 338.

<table>
<thead>
<tr>
<th></th>
<th>E</th>
<th>F</th>
</tr>
</thead>
<tbody>
<tr>
<td>z-test</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Alpha</td>
<td>0.05</td>
<td></td>
</tr>
<tr>
<td>Hypothesised Mean Difference</td>
<td>0</td>
<td></td>
</tr>
<tr>
<td>Known Variance</td>
<td>0.000000</td>
<td>0.000000</td>
</tr>
<tr>
<td>Mean</td>
<td>16.923077</td>
<td>20.461538</td>
</tr>
<tr>
<td>Observations</td>
<td>13</td>
<td>13</td>
</tr>
<tr>
<td>Observed Mean Difference</td>
<td>-3.538462</td>
<td></td>
</tr>
<tr>
<td>z</td>
<td></td>
<td>#DIV/0!</td>
</tr>
<tr>
<td>P (Z&lt;=z) one-tail</td>
<td></td>
<td>#DIV/0!</td>
</tr>
<tr>
<td>z Critical one-tail</td>
<td>1.644854</td>
<td></td>
</tr>
<tr>
<td>P (Z&lt;=z) two-tail</td>
<td></td>
<td>#DIV/0!</td>
</tr>
<tr>
<td>z Critical two-tail</td>
<td>1.959964</td>
<td></td>
</tr>
</tbody>
</table>

Tip
Test of Independence (Chi-Square) tool

The Test of Independence (Chi-Square) tool calculates the chi-square test of a data sample, which determines how well a set of measured values fit a corresponding set of expected values. Select Data > Statistics > Chi-square Test in the Menu bar to access the Test of Independence (Chi-Square) dialog (Figure 340).

**Input range**
- Specifies the cell range containing the source data.

**Results to**
- Specifies the top left cell of the results area. When you run the tool, it will generate the Chi-square table starting at this cell.

**Columns / Rows**
- Specifies whether the data to be analyzed is organized in columns or rows.

To provide an example of using this tool, we again make use of the input data set shown in Figure 334. In this case the data in column A is the observed data while the data in column B are the corresponding expected values. Figure 341 shows the chi-square results calculated for this input data using the settings shown in Figure 340.

![Figure 341: Results of chi-square test](image)

**Tip**

Chapter 10
Linking Calc Data
Sharing data in and out of Calc
Copyright
This document is Copyright © 2018 by the LibreOffice Documentation Team. Contributors are listed below. You may distribute it and/or modify it under the terms of either the GNU General Public License (http://www.gnu.org/licenses/gpl.html), version 3 or later, or the Creative Commons Attribution License (http://creativecommons.org/licenses/by/4.0/), version 4.0 or later.

All trademarks within this guide belong to their legitimate owners.

Contributors
This book is adapted and updated from the *LibreOffice 4.1 Calc Guide*.

To this edition
Steve Fanning  
Kees Kriek  
Jean Hollis Weber

To previous editions
Barbara Duprey  
Jean Hollis Weber  
John A Smith

Feedback
Please direct any comments or suggestions about this document to the Documentation Team’s mailing list: documentation@global.libreoffice.org

Note
Everything you send to a mailing list, including your email address and any other personal information that is written in the message, is publicly archived and cannot be deleted.

Publication date and software version
Published December 2019. Based on LibreOffice 6.2.

Using LibreOffice on macOS
Some keystrokes and menu items are different on macOS from those used in Windows and Linux. The table below gives some common substitutions for the instructions in this chapter. For a more detailed list, see the application Help.

<table>
<thead>
<tr>
<th>Windows or Linux</th>
<th>macOS equivalent</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tools &gt; Options menu</td>
<td>LibreOffice &gt; Preferences</td>
<td>Access setup options</td>
</tr>
<tr>
<td>Right-click</td>
<td><em>Control</em> + click or right-click depending on computer setup</td>
<td>Open a context menu</td>
</tr>
<tr>
<td><em>Ctrl</em> (Control)</td>
<td><em>Command</em></td>
<td>Used with other keys</td>
</tr>
<tr>
<td><em>F5</em></td>
<td><em>Shift</em> + <em>Command</em> + <em>F5</em></td>
<td>Open the Navigator</td>
</tr>
<tr>
<td><em>F11</em></td>
<td><em>Command</em> + <em>T</em></td>
<td>Open the sidebar Styles panel</td>
</tr>
</tbody>
</table>

Documentation for LibreOffice is available at https://documentation.libreoffice.org/en/
Using multiple worksheets

Why use multiple sheets?

Chapter 1, Introducing Calc, introduced the concept of multiple sheets (also called worksheets) in a spreadsheet. Multiple sheets help keep information organized; once you link those sheets together, you unleash the full power of Calc. Consider this case.

John is having trouble keeping track of his personal finances. He has several bank accounts and the information is scattered and disorganized. He can’t get a good grasp on his finances until he can see everything at once.

To resolve this, John decides to track his finances in LibreOffice Calc. John knows Calc can do simple mathematical computations to help him keep a running tab of his accounts, and he wants to set up a summary sheet so that he can see all of his account balances at once.

Note

For users with experience of using Microsoft Excel: what Excel calls a workbook, Calc calls a spreadsheet (the whole document). Both Excel and Calc use the terms sheet and worksheet.

Setting up multiple sheets

Chapter 1, Introducing Calc, gives a detailed explanation of how to set up multiple sheets in a spreadsheet. Here is a quick review.

Identifying sheets

When you open a new spreadsheet it has, by default, one sheet named Sheet1. You can specify a different number of worksheets to be created in a new document, or a different prefix name for new worksheets, by using the Options – LibreOffice Calc – Defaults dialog (Figure 342). To access this dialog, select Tools > Options > LibreOffice Calc > Defaults from the Menu bar.

Worksheets in Calc are managed using tabs located at the bottom of the spreadsheet.
**Inserting new sheets**

There are several ways to insert a new sheet. The fastest method is to click on the Add Sheet button, which has a + icon and is located to the left of the sheet tabs at the bottom of the spreadsheet. This inserts one new sheet without opening any dialog, with a default name (Sheet2, for example) and with the new sheet's tab positioned at the right hand end of the sheet tabs.

Use one of these other methods to insert more than one sheet, to rename the sheet at the same time, or to insert the sheet somewhere else in the sequence.

- Left-click a sheet tab and then select **Sheet > Insert Sheet** from the Menu bar. Calc displays the Insert Sheet dialog with the **Before current sheet** and **New sheet** options preselected.
- Select **Sheet > Insert Sheet at End** from the Menu bar. Calc displays the Append Sheet dialog.
- Select **Sheet > Insert Sheet from File** from the Menu bar. Calc displays the Insert Sheet dialog with the **Before current sheet** and **From file** options preselected. It also displays a file browser dialog on top of the Insert Sheet dialog to enable you to first select the source file containing the sheet to be inserted.
- Right-click on a sheet tab and select **Insert Sheet** from the context menu (Figure 343). Calc displays the Insert Sheet dialog with the **Before current sheet** and **New sheet** options preselected.
- Left-click in the empty space at the right end of the line of sheet tabs (Figure 343). Calc displays the Insert Sheet dialog with the **Before current sheet** and **New sheet** options preselected.
- Right-click in the empty space at the right end of the line of sheet tabs and select **Insert Sheet** from the context menu (Figure 343). Calc displays the Insert Sheet dialog with the **Before current sheet** and **New sheet** options preselected.

The above methods use either the Insert Sheet dialog (Figure 344) or the Append Sheet dialog (Figure 345).
On the Insert Sheet dialog you can:

- Choose whether to put the new sheet before or after the currently selected sheet tab.
- Choose how many sheets to insert.
- Choose the name for a single sheet (the Name field is unavailable if more than one sheet is to be inserted).

The From file option is described in "Inserting sheets from a different spreadsheet" (page 338).

For John’s spreadsheet we need six sheets, one for each of his five accounts and one as a summary sheet. We also want to name each of these sheets for the account they represent: Summary, Checking Account, Savings Account, Credit Card 1, Credit Card 2, and Car Loan.

After creating a new spreadsheet with one sheet, we could:

- Insert five new sheets and rename all six sheets afterwards; or
- Rename the existing sheet, then insert the five new sheets one at a time, renaming each new sheet during the insert step.
To insert sheets and rename them afterwards:

9) Make sure that the correct sheet tab is selected and open the Insert Sheet dialog.
10) Choose the position for the new sheets (in this example, we use After current sheet).
11) Choose New sheet and enter 5 as the No. of sheets. Because you are inserting more than one sheet, the Name box is not available.
12) Click OK to insert the sheets.

For the subsequent steps to rename the sheets, see “Renaming sheets” (page 339).

To insert sheets and name them at the same time:

1) Rename the existing sheet as Summary, as described in “Renaming sheets” (page 339).
2) Make sure that the correct sheet tab is selected and open the Insert Sheet dialog.
3) Choose the sheet tab position for the new sheet (Before current sheet or After current sheet, as applicable).
4) Choose New sheet and enter 1 in the No. of sheets field. The Name box is now available.
5) In the Name box, type a name for this new sheet, for example Checking Account.
6) Click OK to insert the sheet.
7) Repeat steps 2 to 6 for each new sheet, giving them the names Savings Account, Credit Card 1, Credit Card 2, and Car Loan.

**Inserting sheets from a different spreadsheet**

On the Insert Sheet dialog, you can also add a sheet from a different spreadsheet (for example, another Calc or Microsoft Excel file), by choosing the From file option. Click Browse, select the file using the file browser dialog, and click Open. A list of the available sheets in that file appears in the adjacent list box (Figure 346). Select the sheet to import. If, after you select the file, no sheets appear, you probably selected an invalid file type (not a spreadsheet, for example).

![Figure 346: From file area of Insert Sheet dialog showing file path and names of available sheets](image)

If you prefer, select the Link option to insert the external sheet as a link instead of as a copy. This is one of several ways to include “live” data from another spreadsheet; see also “Linking to external data” (page 349). The links can be updated manually to show the current contents of the external file using Edit > Links to External Files from the Menu bar. Alternatively the links can be updated automatically whenever the file is opened, depending on the options set on the dialog accessed by selecting Tools > Options > LibreOffice Calc > General > Updating from the Menu bar. The three options available to update links automatically when opening are Always (from trusted locations), On request, and Never.

To define trusted file locations, select Tools > LibreOffice > Security > Macro Security (Trusted Sources tab) from the Menu bar.
Renaming sheets

Sheets can be renamed at any time. To give a sheet a more meaningful name:

- Enter the name in the Name box when you create the sheet, or
- Double-click on the relevant sheet tab and replace the existing name through the Rename Sheet dialog, or
- Right-click on the relevant sheet tab, select Rename Sheet from the context menu, and replace the existing name through the Rename Sheet dialog, or
- Left-click on the relevant sheet tab, select Sheet > Rename Sheet from the Menu bar, and replace the existing name through the Rename Sheet dialog.

![Image of Rename Sheet dialog]

Figure 347: Rename Sheet dialog

A sheet name cannot be empty and must not be a duplicate of an existing name.

**Note**

The following characters are not allowed in sheet names: colon (:), back slash (\), forward slash (/), question mark (?), asterisk (*), left square bracket ([), right square bracket (]), and apostrophe (’) as the first or last character of the name.

**Tip**

In some LibreOffice Calc installations you can hold down the Alt key, click on the sheet name, and enter the new name directly.

Your sheet tab area should now look like this.

![Image of six renamed sheets]

Figure 348: Six renamed sheets

Now we will set up the account ledgers. This is just a simple summary that includes the previous balance plus the amount of the current transaction. For withdrawals, we enter the current transaction as a negative number so the balance gets smaller. A basic ledger is shown in Figure 349.

This ledger is set up in the sheet named Checking Account. The total balance is added up in cell F3. You can see the equation for it in the Formula bar. It is the summary of the opening balance, cell C3, and all of the subsequent transactions.
Referencing other sheets

On the Summary sheet we display the balance from each of the other sheets. If you copy the example in Figure 349 onto each of the five account sheets, the current balances will be in cell F3 of each sheet.

There are two ways to reference cells in other sheets: by entering the formula directly using the keyboard or by using the mouse. We will look at the mouse method first.

Creating the reference with the mouse

On the Summary sheet, set up a place for all five account balances, so we know where to put the cell reference. Figure 350 shows the Summary sheet with a blank Balance column. We want to place the reference for the Checking Account balance in cell B3.

To make the cell reference in cell B3, select the cell and follow these steps:

1) Click on the = icon next to the input line in the Formula bar. The icons in the Formula bar change and an equals character appears in the input line (Figure 351).
2) Now, click on the sheet tab for the sheet containing the cell to be referenced. In this case, that is the *Checking Account* sheet (Figure 352).

![Figure 352: Click on the Checking Account tab](image)

3) Click on cell F3 (where the balance is) in the *Checking Account* sheet. The phrase $'Checking Account'.F3 should appear in the input line (Figure 353) and the selected cell is surrounded by a colored border.

![Figure 353: Cell reference selected](image)

4) Click the Accept icon in the input line of the Formula bar, or press the Enter key to finish.

5) The *Summary* sheet should now look like Figure 354.

![Figure 354: Finished Checking Account reference](image)

**Creating the reference with the keyboard**

From Figure 354, you can deduce how the cell reference is constructed. The reference has two parts: the sheet name prefixed by a dollar symbol ($'Checking Account'), and the cell reference (F3). Notice that they are separated by a period. The default behavior of Calc is to insert the dollar symbol to form an absolute sheet reference while giving a relative cell reference.

**Note**

The sheet name is in single quotation marks because it contains a space, and the mandatory period (.) always falls outside any quotation marks.

So, you can fill in the *Savings Account* cell reference by just typing it in. Assuming that the balance is in the same cell (F3) in the *Savings Account* sheet, the cell reference should be =$'Savings Account'.F3 (Figure 355).
Referencing other documents

John decides to keep his family account information in a different spreadsheet file from his own summary. Fortunately Calc can link different files together. The process is the same as described for different sheets in a single spreadsheet, but we add one more step to indicate which file the sheet is in.

Creating the reference with the mouse

To create the reference with the mouse, both spreadsheets need to be open.

1) If necessary, switch to the spreadsheet containing the cell in which the formula is going to be entered.
2) Select the cell in which the formula is going to be entered.
3) Click the \( = \) icon next to the input line in the Formula bar.
4) Switch to the other spreadsheet (the process to do this may vary depending on which operating system you are using).
5) Select the sheet (Savings Account) and then the reference cell (F3); see Figure 356. You can press the keyboard \( \text{Enter} \) key at this point, or continue with steps 6 and 7.

6) Switch back to the original spreadsheet.
7) Click the Accept icon in the Formula bar.

Your spreadsheet should now resemble Figure 357.

You will get a good feel for the format of the reference if you look closely at the input line in the Formula bar. Based on the contents of this line, you can create the reference using the keyboard.
Creating the reference with the keyboard

Typing the reference is simple once you know the format the reference takes. The reference has three parts to it:

- Path and file name
- Sheet name
- Cell reference

From Figure 357, you can see that the general format for the reference is:

```
=file:///Path & File Name'#$SheetName.CellReference
```

Note

The reference for a file has three forward slashes ///, while the reference for a hyperlink has two forward slashes //. See “Using hyperlinks and URLs” below.

Using hyperlinks and URLs

Hyperlinks can be used in Calc to jump to a different location from within a spreadsheet and can lead to other parts of the current file, to different files, or even to web pages.

Relative and absolute hyperlinks

Hyperlinks stored within a file can be either relative or absolute.

A relative hyperlink says, *Here is how to get there starting from where you are now* (meaning from the folder in which your current document is saved), while an absolute hyperlink says, *Here is how to get there no matter where you start from*.

An absolute link will stop working if the target is moved. A relative link will stop working if the start and target locations change relative to each other. For instance, if you have two spreadsheets in the same folder linked to each other and you move the entire folder to a new location, an absolute hyperlink will break but a relative one will not.

To change the way that Calc stores the hyperlinks in your file, select **Tools > Options > Load/Save > General** and choose if you want URLs (Universal Resource Locators) saved relatively when referencing the file system, or the Internet, or both.

An absolute path such as `c:\homepage\graphics\picture.gif` would no longer function on a web server. Neither a web server nor the computer of a reader needs to have a c: hard drive, operating systems such as Unix or macOS do not recognize drive letters, and even if the folder `homepage\graphics` existed, your picture would not be available. It is better to use relative linking for file links. Relative linking is only possible when the document you are working on is on the same drive as the link destination.

Calc will always display an absolute hyperlink. Do not be alarmed when it does this even when you have saved a relative hyperlink. This ‘absolute’ target address will be updated if you move the file.
Note

HTML (Hypertext Markup Language) files containing links as relative to the file system that are to be uploaded to a web server require the files be in a file structure matching that of the web server. Otherwise, the links will point to the wrong folder.

Tip

When you rest the mouse pointer on a hyperlink, a help tip displays the absolute reference, because Calc uses absolute path names internally. The complete path and address can only be seen when you view the result of the HTML export (saving a spreadsheet as an HTML file), by loading the HTML file as text, or by opening it with a text editor.

Creating hyperlinks

You can insert a hyperlink into a Calc spreadsheet using any of several methods:

• Place the text cursor at the point where you want to insert the hyperlink, or select the text that you want to put the hyperlink on. Select Insert > Hyperlink from the Menu bar or click the Insert Hyperlink icon in the Standard toolbar to access the Hyperlink dialog; see “Hyperlink dialog” (page 345).
• Drag-and-drop an item from the Navigator to the point where you want to insert the hyperlink (for example, a sheet or cell name).
• Type the target web address or URL at the point where you want to insert the hyperlink. When you type text that can be used as a hyperlink (such as a website address or URL), Calc formats it automatically, creating the hyperlink and applying color to the text. If this does not happen, you can enable this feature using Tools > AutoCorrect Options > Options from the Menu bar and selecting URL Recognition.

When you use the Hyperlink dialog to insert a hyperlink, you can select either a text hyperlink (Figure 358) or a button hyperlink (Figure 359). In both cases, the visible text can be different from the linked URL.

![Figure 358: Example text hyperlink](image)

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td></td>
<td>Calc Guide</td>
</tr>
<tr>
<td>4</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Figure 358: Example text hyperlink

![Figure 359: Example button hyperlink](image)

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td></td>
<td>Calc Guide</td>
</tr>
<tr>
<td>5</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Figure 359: Example button hyperlink

To change the color of text hyperlinks, go to Tools > Options > LibreOffice > Application Colors from the Menu bar, scroll to Unvisited links and/or Visited links, pick the new colors and click OK.
A button hyperlink is a type of form control. As with all form controls, it can be anchored or positioned by right-clicking on the button in design mode. More information about forms can be found in Chapter 18, Forms, of the Writer Guide.

Opening hyperlinks

To open a text hyperlink carry out one of the following actions:

- Ctrl-click with the cursor positioned over the hyperlink.
- Left-click with the cursor positioned over the hyperlink. This option is only available if the Tools > Options > LibreOffice > Security > Security Options and Warnings > Options > Ctrl-click required to follow hyperlinks option is not selected.
- Right-click with the cursor positioned immediately in front of the hyperlink and select the Open Hyperlink option from the context menu. This option is only available if the Tools > Options > LibreOffice > Security > Security Options and Warnings > Options > Ctrl-click required to follow hyperlinks option is not selected.

To open a button hyperlink, left-click the button. This option is only available when the form design mode is deactivated; the status of this mode is controlled by pressing the Toggle Design Mode button in either the Form Controls toolbar or the Form Design toolbar.

Hyperlink dialog

You can insert and modify hyperlinks using the Hyperlink dialog. To display this dialog, click the Insert Hyperlink icon in the Standard toolbar or choose Insert > Hyperlink from the Menu bar.

On the left side of the dialog, select one of the four categories of hyperlink:

- **Internet.** The hyperlink points to a WWW (World Wide Web) or FTP (File Transfer Protocol) address.
- **Mail.** The hyperlink points to an email address.
- **Document.** The hyperlink points to a location in either the current document or another existing document.
- **New Document.** Opening the hyperlink creates a new document.

Figure 360 shows the Hyperlink dialog with the Internet category and the Web hyperlink type selected.

The Further Settings area is provided for all four hyperlink categories. The controls above the Further Settings area vary dependent on which of the four hyperlink categories is selected on the left side of the dialog.
A full description of all the choices, and their interactions, is beyond the scope of this chapter. The following is a summary of the most common choices used in Calc spreadsheets.

**Internet**

- **Web / FTP.** Select the type of hyperlink. On selection of the FTP option, the controls above the Further Settings area change to those shown in Figure 361.

![Hyperlink dialog](image)

*Figure 360: Hyperlink dialog showing details for the Internet category*

*Figure 361: FTP specific controls on the Hyperlink dialog*

- **URL.** Enter the required web address.
- **Login name.** Only applicable for FTP hyperlinks.
- **Password.** Only applicable for FTP hyperlinks.
- **Anonymous user.** Only applicable for FTP hyperlinks.
Mail

For Mail hyperlinks, the controls above the Further Settings area change to those shown in Figure 362.

Figure 362: Mail controls on the Hyperlink dialog

- **Recipient.** Enter the email address of the recipient, or select the address from an existing database accessed by pressing the Data Sources button.
- **Subject.** Enter the text to be used as the subject line of the message.

Document

For document hyperlinks, the controls above the Further Settings area change to those shown in Figure 363.

Figure 363: Document controls on the Hyperlink dialog

- **Path.** Specify the path of the file to be opened. Leave this blank if you want to link to a target in the same spreadsheet. The Open File icon opens a file browser for you to locate the document to be opened.
- **Target.** Optionally specify the target in the document (for example a specific sheet). Click on the Target in Document icon to open a Navigator window where you can select the target, or if you know the name of the target, you can type it into the box.

New Document

For New Document hyperlinks, the controls above the Further Settings area change to those shown in Figure 364.

- **Edit now / Edit Later.** Specify whether to edit the newly created document immediately or just create it.
- **File.** Enter the name of the file to be created. The Select Path icon opens a directory picker dialog.
- **File type.** Select the type of document to be created (for example, text document, spreadsheet, or drawing).
The Further Settings area at the bottom of the right side of the Hyperlink dialog is common to all the hyperlink categories, although some choices are more relevant to some types of links.

- Set the value of Frame to determine how the hyperlink will open. This applies to documents that open in a web browser. Options are _top, _parent, _blank, and _self.
- Form specifies if the link is to be presented as text or as a button.
- Text specifies the text that will be visible to the user. If you do not enter anything here, Calc will use the full URL or path as the link text. Note that if the link is relative and you move the file, this text will not change, though the target will.
- Name is applicable to HTML documents. It specifies text that will be added as a NAME attribute in the HTML code behind the hyperlink.
- Events button: this button will be activated to allow Calc to react to events for which the user has written some code (macro). This function is not covered further in this chapter.

Editing hyperlinks

To edit an existing text hyperlink, double-click the cell containing the hyperlink and move the input cursor until it is directly in front of the hyperlink. Click the Insert Hyperlink icon in the Standard toolbar or select Insert > Hyperlink from the Menu bar. Calc opens the Hyperlink dialog, enabling you to modify the characteristics of the hyperlink.

For a button hyperlink, the spreadsheet must have the form design mode enabled in order to edit the hyperlink. With the button selected, click the Insert Hyperlink icon in the Standard toolbar or select Insert > Hyperlink from the Menu bar. Make your changes and click OK.

If you need to edit several hyperlinks, you can leave the Hyperlink dialog open until you have edited all of them. Be sure to click Apply after each one. When you are finished, click Close.

You can also edit a button hyperlink by selecting the button (with form design mode enabled), right-clicking, and selecting Control from the context menu. Calc displays the Properties dialog. Modify the button text by editing the Label field and modify the link address by editing the URL field.

Removing hyperlinks

To remove a text or button hyperlink from the document completely, select it and use one of the many available deletion mechanisms (for example, press Backspace or Delete on the keyboard; right-click on the hyperlink and select Cut from the context menu; select Cut from the Standard toolbar or Edit > Cut from the Menu bar).
You can insert data from another document into a Calc spreadsheet as a link.

Two methods are described in this section: using the External Data dialog and using the Navigator. If your file has named ranges, database ranges, or named tables, and you know the name of the range or table you want to link to, using the External Data dialog is quick and easy. However, if the file has several ranges and tables, and you want to pick only one of them, you may not be able to easily determine which is which; in that case, the Navigator method may be easier.

Calc provides other methods for including linked data from external sources, see for example “Linking to registered data sources” (page 356) and “Dynamic Data Exchange (DDE)” (page 365).

**Note**

When you open a file that contains links to external data, depending on your settings you may be prompted to update the links or they may be updated automatically. Depending on where the linked files are stored, the update process can take several minutes to complete.

### Using the External Data dialog

The External Data dialog inserts data from an HTML, Calc, CSV (Comma-Separated Values), or Microsoft Excel file into the current sheet as a link. Calc utilizes a Web Page Query import filter, enabling you to insert tables from HTML documents. The External Data dialog is accessed by selecting **Sheet > Link to External Data** from the Menu bar.

To insert a link to external data using the External Data dialog:

1. Open the Calc document where the external data is to be inserted. This is the target document.
2. Select the cell where the upper left cell of the external data is to be inserted.
3. Choose **Sheet > Link to External Data** from the Menu bar. Calc displays the External Data dialog (Figure 365).

![External Data dialog](image)

**Figure 365: External Data dialog**

4. Type the URL of a web resource that is to be used as a data source, or type the address of a source file, or select an entry in the drop-down list, or select a source file from the file selection dialog accessed through the **Browse** button. For entries typed in, press **Enter** on completion.
5) If you selected an HTML file as the data source at step 4, Calc displays the Import Options dialog (Figure 366). On this dialog you can choose the import language of the site. Select **Automatic** to let Calc import the data directly, or select **Custom** and choose from the drop-down list of languages available. You can also select the option to have Calc recognize special numbers, such as dates, on import.

![Figure 366: Import Options dialog](image)

- Click **OK** on the Import Options dialog. Calc loads the list of available tables/ranges into the **Available Tables/Ranges** area of the External Data dialog. The Web Page Query import filter can create names for cell ranges as they are imported. As much formatting as possible is retained while the filter intentionally does not import any images. The filter additionally creates two additional entries in the list: **HTML_all** to permit selection of the entire document and **HTML_tables** to permit selection of all the tables.

- In the **Available Tables/Ranges** area, select the named ranges or tables you want to insert (hold **Ctrl** to select multiple entries). The **OK** button then becomes available.

6) If you selected a CSV file as the data source at step 4, Calc displays the Text Import dialog (Figure 367). This dialog is described in detail in Chapter 1, Introducing Calc. Click **OK** on the Text Import dialog and select **CSV_all** in the **Available Tables/Ranges** area of the External Data dialog. The **OK** button then becomes available.

7) If you selected a Calc or Microsoft Excel file as the data source at step 4, Calc populates the **Available Tables/Ranges** area of the External Data dialog with the list of range names and database ranges that are defined in the source file. Select the range names and database ranges that you want to insert (hold **Ctrl** to select multiple entries) and the **OK** button then becomes available.

**Note**

If the source Calc or Microsoft Excel spreadsheet contains no range names or database ranges, then you cannot use that document as the source file in the External Data dialog.

8) For all external data source file types, you can also specify that the data is refreshed at a specific frequency, defined in seconds.

9) Click **OK** to close the External Data dialog and insert the linked data.
Calc adds the new entry to the *Linked areas* list in the Navigator (Figure 368). If you double-click this entry, Calc highlights the linked data within the sheet. When you hover the cursor over the entry, a tooltip indicates the file location of the linked data.
To view a list of all external data links in the spreadsheet, select **Edit > Links to External Files** from the Menu bar. Calc displays the Edit Links dialog (Figure 369).

![Figure 369: Edit Links dialog](image)

**Note**

The Edit Links dialog can display information about other links that were not created using the External Data dialog.

For links that have been created using the External Data dialog, you can access that dialog again by selecting the link and clicking the **Modify** button, or double-clicking the link. If you click **Break Link** and confirm that you want to remove the selected link, the previously-linked data becomes embedded in the spreadsheet. Click **Update** to refresh the linked data in the target file so that it matches that in the source file.
The Status column on the Edit Links dialog always shows the string *Manual* for a link created using the External Data dialog. The string in this column does not reflect the setting of the *Update every … seconds* option on the External Data dialog.

**Using the Navigator**

You can also use the Navigator to link external data. Access the Navigator by selecting **View > Navigator** on the Menu bar. See Chapter 1, Introducing Calc, for more details about the Navigator.

To insert a link to external data using the Navigator:

1) Open the Calc spreadsheet in which the external data is to be inserted (target document).

2) Open the document from which the external data is to be taken (source document) in Calc. The source document does not need to be a Calc file; it could, for example, be a Microsoft Excel file, an HTML file, or a CSV file. In the case of an HTML file, Calc displays the Import Options dialog (Figure 366) before opening the file.

3) In the target document, open the Navigator (Figure 370). This illustration shows the Navigator for a new file called *Untitled 1*, which currently has no range names, database ranges, or linked areas.

![Navigator for target file](image)

4) At the bottom of the Navigator, select the source document from the drop-down menu (Figure 371). In this case the source is called *summary-indices-constituents* and the file contains three range names which are highlighted with a red box. You may need to click the + icon at the left of the *Range names* field to view the names. It would not be possible to use a file as the source for an external link if it contains no range names or database ranges.
5) In the Navigator, select the **Insert as Link** option from the Drag Mode menu, as shown in Figure 372.

You can also change the drag mode by right-clicking on a range name and selecting the required option from the context menu.
6) Select the required Range names or Database ranges entry and drag it from the Navigator into the target document, to the cell where you want the upper left cell of the data range to be.

7) Re-select the target document in the drop-down menu at the bottom of the Navigator. Instead of a + icon next to Range names, it shows a + icon next to Linked areas. Click the + icon to see the entry dragged across from the source document, similar to Figure 368.

How to find the required data range or table

Calc’s Web Page Query import filter gives names to the data ranges (tables) it finds in a web page, starting from HTML_1. It also creates two additional range names:

- **HTML_all** – designates the entire document
- **HTML_tables** – designates all HTML tables in the document

If any of the data tables in the source HTML document have been given meaningful names (using the **ID** attribute on the **TABLE** tag), those names appear in the Range names list, along with the ranges Calc has sequentially numbered.

If the data range or table you want is not meaningfully named, how can you tell which one to select?

Go to the source document, which you opened in Calc. In the Navigator, double-click on a range name: that range is highlighted on the sheet. The example in Figure 373 shows a table of best-selling albums of recorded music by year worldwide and was extracted from Wikipedia’s List of best-selling albums page (https://en.wikipedia.org/wiki/List_of_best-selling_albums).

![Figure 373: Using the Navigator to find a data range name](image)

If the Formula bar is visible, the range name is also displayed in the Name box at the left end (Figure 374). The range name can be selected from the drop-down list to highlight it on the page.
Linking to registered data sources

You can access a variety of databases and other data sources and link them into Calc documents. First you need to register the data source with LibreOffice. To register means to tell LibreOffice what type of data source it is and where the file is located. The way to do this depends on whether or not the data source is a database in *.odb format.

To register a data source that is in *.odb format:

1) Choose **Tools > Options > LibreOffice Base > Databases**. Calc displays the Options – LibreOffice Base – Databases dialog (Figure 375).

![Options – LibreOffice Base – Databases dialog](image)

2) Click the **New** button to open the Create Database Link dialog (Figure 376).

![Create Database Link dialog](image)
3) Enter the location of the database file, select a database file from the drop-down list, or click Browse to open a file browser and select the database file.

4) Type a name to use as the registered name for the database and click OK. The database is added to the list of registered databases and LibreOffice uses the registered name to access the database.

**Note**

The OK button on the Create Database Link dialog is enabled only when both the Database file and Registered name fields are filled in.

To register a data source that is not in *.odb format:

1) Choose File > New > Database from the Menu bar to open the Database Wizard (Figure 377). For more about the Database Wizard, see Chapter 2, Creating a Database, of the Base Handbook.

2) Select Connect to an existing database and select the appropriate database type from the drop-down menu. The choices for database type depend on your operating system. For example, Microsoft Access and other Microsoft products are not among the choices if you are using Linux. The example database type menu shown in Figure 377 relates to a Windows 10 installation.

**Note**

The exact interactions required to connect to a database vary depending on the type of database. Steps 3 and 4 assume that you selected a dBASE database type at step 2.

3) Click Next >. Type the path to the folder where the dBase files are stored or click Browse and use the folder selection dialog to navigate to the relevant folder before pressing the Select Folder button.

4) Click Next >. Select Yes, register the database for me, but clear the Open the database for editing checkbox.

5) Click Finish. Name and save the database in the location of your choice.

**Note**

The above steps create a *.odb format database based on the content of the original dBASE database. The original dBASE database remains unchanged.
Once a data source has been registered, it can be used by any LibreOffice component (for example, Calc or Writer).

**Viewing data sources**

Open a document in Calc. To view the data sources available, select **View > Data Sources** on the Menu bar. Calc opens the Data Source window above the spreadsheet.

The Data Source window has three main components:

- The Table Data bar (Figure 378), which is by default located at the top of the Data Source window.

**Figure 378: Table Data bar**

The Table Data bar provides the following icons, from left to right:

- **Save Current Record**
- **Edit Data**
- **Cut**
- **Copy**
– Paste
– Undo
– Find Record
– Refresh
– Sort
– Sort Ascending
– Sort Descending
– AutoFilter
– Apply Filter
– Standard Filter
– Reset Filter/Sort
– Data to Text
– Data to Fields
– Mail Merge
– Data Source of Current Document
– Explorer On/Off

• The Data Source Explorer (Figure 379), which by default is located on the left side of the Data Source window, below the Table Data bar.

![Figure 379: Data Source Explorer](image)

The Data Source Explorer provides a list of the registered databases, which by default includes the built-in Bibliography database.

To view each database, click on the + icon to the left of the name of the database. This has already been done for the Automobiles database in Figure 379. Click on the + icon left of Tables to view the individual tables within the selected database; similarly you can click on the + icon left of Queries to view the individual queries within the selected database. Click on the name of a table to view all the records held in that table.

• The data records for the selected table are displayed in the area at the right side of the Data Source window, below the Table Data bar.

![Figure 380: Data Source window records](image)
To see more columns in this area, you can click the **Explorer On/Off** icon in the Table Data bar to temporarily hide the Data Source Explorer.

Below the data records is a navigation bar, which shows which record is selected and the total number of records. This provides the following buttons, from left to right:

- **First record**
- **Previous record**
- **Next record**
- **Last record**
- **Add new record**

A horizontal scroll bar appears when the available columns do not all fit in the visible area. A vertical scroll bar appears when the available data records do not all fit in the visible area.

At the bottom center of the Data Source window is an additional control to temporarily hide the entire window. This control is highlighted with a red box in Figure 380.

## Editing data sources

Some data sources (such as spreadsheets) cannot be edited in the Data Source window. In editable data sources, records can be edited, added, or deleted. If you cannot save your edits, you need to open the database in Base and edit it there; see “Launching Base to work on data sources” (page 360). You can also hide columns and make other changes to the display.

## Launching Base to work on data sources

You can launch LibreOffice Base at any time from the Data Source View pane. Right-click on a database, **Tables**, a table name, **Queries**, or a query name, and then select **Edit Database File** from the context menu. Once in Base, you can edit, add, and delete tables, queries, forms, and reports.

For more about using Base, see Chapter 8, Getting Started with Base, in the **Getting Started Guide**, or the **Base Handbook**.

## Using data sources in Calc spreadsheets

Data from a table displayed on the right side of the Data Source window can be placed into a Calc document in a variety of ways.

You can select a single cell, a single row, or multiple rows in the Data Source window and drag and drop the data into the spreadsheet. The data is inserted at the place where you release the mouse button. If you selected one or more rows, Calc will also include the column headings above the data you insert. To select the rows of data you want to add to the spreadsheet:

1) Click the gray box to the left of the first row you want to select. That row is highlighted.

2) To select multiple adjacent rows, hold down the **Shift** key while clicking the gray box of the last row you need.

3) To select multiple separate rows, hold down the **Control** key while selecting each row. The selected rows are highlighted.

4) To select all the rows, click the gray box in the upper left corner. All rows are highlighted.

An alternative method uses the **Data to Text** icon in the Table Data bar and will include the column headings above the data you insert:

1) Click the cell of the spreadsheet which you want to be the top left of your data, including the column names.
2) Select the rows of data you want to add to the spreadsheet, as described in the previous paragraph.

3) Click the **Data to Text** icon in the Table Data bar to insert the data into the spreadsheet cells.

You can also drag the data source column headings (field names) onto your spreadsheet to create a form for viewing and editing individual records one at a time. Follow these steps:

1) Drag and drop the gray box at the top of the column (containing the field name you wish to use) to where you want the record to appear in the spreadsheet.

2) Repeat step 1 until you have moved all of the fields you need to where you want them.

3) Close the Data Source window by selecting **View > Data Sources** from the Menu bar.

4) Save the spreadsheet and select **Edit > Edit Mode** from the Menu bar, to make the spreadsheet read-only.

5) Select **File > Reload** from the Menu bar. All of the fields will show the value for the data of the first record of the data source that you selected.

6) Select **View > Toolbars > Form Navigation** to show the Form Navigation toolbar. By default, this toolbar opens at the bottom of the Calc window, just above the Status bar.

7) Click the arrows on the Form Navigation toolbar to view the different records of the table. The toolbar indicates which record is currently displayed and the total number of records available. The current record number changes as you move through the records and the data in the spreadsheet fields updates to correspond to the data for that particular record number.

From left to right, the Form Navigation toolbar provides the following interactions:

- Find Record
- First Record
- Previous Record
- Next Record
- Last Record
- New Record
- Save Record
- Undo
- Delete Record
- Refresh
- Refresh Control
- Sort
- Sort Ascending
- Sort Descending
- AutoFilter
- Apply Filter
- Form-Based Filters
- Reset Filter/Sort
- Data Source as Table
**Embedding spreadsheets**

Spreadsheets can be embedded in other LibreOffice files and vice versa. This is often used in Writer or Impress documents so that Calc data can be used in a text document. You can embed the spreadsheet as either an OLE (Object Linking and Embedding) or DDE (Dynamic Data Exchange) object. The difference between a DDE object and a Linked OLE object is that a linked OLE object can be edited from the document in which it is added as a link, but a DDE object cannot.

For example, if a Calc spreadsheet is pasted into a Writer document as a DDE object, then the spreadsheet cannot be edited in the Writer document. But if the original Calc spreadsheet is updated, the changes are automatically made in the Writer document. If the spreadsheet is inserted as a Linked OLE object into the Writer document, then the spreadsheet can be edited in Writer as well as in the Calc document and both documents are in sync with each other.

**Object Linking and Embedding (OLE)**

The major benefit of an OLE object is that it is quick and easy to edit its contents just by double-clicking on it. You can also insert a link to the object that will appear as an icon rather than an area showing the contents itself.

OLE objects can be linked to a target document or embedded in the target document. Linking inserts information which will be updated with any subsequent changes to the original file, while embedding inserts a static copy of the data. If you want to edit the embedded spreadsheet, double-click on the object.

**Note**

If your OLE object is empty, inactive, and not displayed as an icon, then it will be transparent.

To embed a spreadsheet as an OLE object in a presentation:

1) Place the cursor in the document at the location where you want the OLE object to be.

2) Select **Insert > Object > OLE Object** from the Menu bar. Calc opens the Insert OLE Object dialog shown in Figure 381, with the **Create new** option selected by default.

![Insert OLE Object dialog](Image)

**Figure 381: Insert OLE Object dialog with Create new option selected**

You can either create a new OLE object or create the OLE object from an existing file.
To create a new object:

1) Select the **Create new** option and select the required option from those available in the **Object Type** list. In this example, you would select *LibreOffice 6.2 Spreadsheet*.

2) Click the **OK** button.

3) LibreOffice places an empty container in the slide, ready for you to enter information. By default the Menu bar changes to reflect the Calc Menu bar; when you click on the slide, anywhere outside the spreadsheet area, the Menu bar reverts to the Impress Menu bar.

After clicking outside the spreadsheet area, double-click on the OLE object to re-enter the edit mode of the object. The application devoted to handling that type of file (Calc in our example) will open the object.

**Note**

If the object inserted is handled by LibreOffice, then the transition to the program to manipulate the object will be seamless; in other cases the object opens in a new window and an option in the File menu becomes available to update the object you inserted.

To insert an existing object:

1) To create an OLE object from an existing file, select the **Create from file** option. The format of the Insert OLE Object dialog changes to that shown in Figure 382.

![Figure 382: Insert OLE Object dialog with Create from file option selected](image)

2) Click **Search**, select the required file in the file browser dialog, and then click the **Open** button.

**Note**

This facility is not limited to LibreOffice files; you can create OLE objects using existing files from many other applications.

3) To insert the object as a link to the original file, select the **Link to file** option. Otherwise, the object will be embedded in your document.

4) If you want the object to appear as a selectable icon, rather than a section of your file, select the **Display as icon** option.

5) Click the **OK** button. A section of the inserted file is shown in the document.
Other OLE objects
Under Windows, when you select the Create new option on the Insert OLE Object dialog, there is an extra entry Further objects in the Object Type list.

1) Double-click on the entry Further objects to open the Insert Object dialog (Figure 383).

![Insert Object dialog](image)
*Figure 383: Inserting an OLE object under Windows*

2) Select Create New to insert a new object of the type selected in the Object Type list, or select Create from File to create a new object from an existing file.

3) If you choose Create from File, the dialog shown in Figure 384 opens. Click Browse and choose the file to insert. The inserted file object is editable by the Windows program that created it.

   If instead of inserting an object, you want to insert a link to an object, select the Display As Icon option.

![Insert Object dialog](image)
*Figure 384: Insert OLE object from a file under Windows*

4) Click the OK button.

Non-linked OLE object
If the OLE object is not linked, it can be edited in the new document. For instance, if you insert a spreadsheet into a Writer document, you can essentially treat it as a Writer table (with a little more power). To edit it, double-click on it.
**Linked OLE object**

When the spreadsheet OLE object is linked, if you change it in Writer it will change in Calc; if you change it in Calc, it will change in Writer. This can be a very powerful tool if you create reports in Writer using Calc data, and want to make a quick change without opening Calc.

---

**Note**

You can only edit one copy of a spreadsheet at a time. If you have a linked OLE spreadsheet object in an open Writer document and then open the same spreadsheet in Calc, the Calc spreadsheet will be a read-only copy.

---

**Dynamic Data Exchange (DDE)**

DDE is an acronym for Dynamic Data Exchange, a mechanism whereby selected data in document A can be pasted into document B as a linked, ‘live’ copy of the original. It would be used, for example, in a report written in Writer containing time-varying data, such as sales results sourced from a Calc spreadsheet. The DDE link ensures that, as the source spreadsheet is updated so is the report, thus reducing the scope for error and reducing the work involved in keeping the Writer document up to date.

DDE is a predecessor of OLE. With DDE, objects are linked through file reference, but not embedded. You can create DDE links either within Calc cells in a Calc sheet, or in Calc cells in another LibreOffice doc such as in Writer.

**DDE link in Calc**

Creating a DDE link in Calc is similar to creating a cell reference. The process is a little different, but the result is the same. Carry out the following steps to create a DDE link from one Calc spreadsheet to another:

1) In Calc, open the spreadsheet that contains the original data that you want to link to.
2) Select the cells that you want to make the DDE link to.
3) Copy the cells to the clipboard by, for example, selecting Edit > Copy from the Menu bar, clicking the Copy icon on the Standard toolbar, or right-clicking the selected area and selecting Copy from the context menu.
4) Open the second spreadsheet that will contain the linked data.
5) Click in the top left cell of the area in the second spreadsheet where you want the linked data to appear.
6) Select Edit > Paste Special > Paste Special from the Menu bar of the second spreadsheet.
7) Calc displays the Paste Special dialog (Figure 385).
Select the Link option on the Paste Special dialog (highlighted with a red box on Figure 385) and then click the OK button.

If you now click on one of the linked cells you will see that the Formula bar shows a reference beginning with the characters `{='`. See Figure 386 for an example, highlighted with a red box.

Save and close both spreadsheets.

If you subsequently edit the original cells in their spreadsheet and save the changes, next time you open the spreadsheet containing the linked cells, the values in those linked cells will update to reflect the latest values of the original cells.
Note

When you open a spreadsheet containing linked data, you may get a warning message indicating that automatic update of external links has been disabled. You will need to click the Enable Content button to update the linked cells. You can avoid this message and interaction by making sure that the spreadsheet containing the original data is in a trusted file location and that the option is selected to always update links from trusted locations when opening. Check these settings via **Tools > Options > LibreOffice > Security > Macro Security** *(Trusted Sources tab)* and **Tools > Options > LibreOffice Calc > General > Updating** respectively.

**DDE link in Writer**

The process for creating a DDE link from Calc to Writer is similar to creating a link within Calc.

1) In Calc, select the cells to make the DDE link to. Copy them.
2) Go to the place in your Writer document where you want the DDE link. Select **Edit > Paste Special > Paste Special**.
3) Writer displays its Paste Special dialog (Figure 387).
4) Select the **Dynamic Data Exchange (DDE link)** option in the **Selection** list.
5) Click the **OK** button.
6) Now the link has been created in Writer. When the Calc spreadsheet is updated, the table in Writer is automatically updated.

![Paste Special dialog in Writer, with DDE link selected](image)

Figure 387: Paste Special dialog in Writer, with DDE link selected

356 | Embedding spreadsheets
Chapter 11
Sharing and Reviewing Spreadsheets
Introduction

This chapter covers methods for collaboration through sharing and reviewing spreadsheets: simultaneous editing, recording changes, adding comments, reviewing changes, merging and comparing documents, saving, and using document versions.

Some menu commands are not available (grayed out) when sharing or change tracking are active.

Sharing spreadsheets

Sharing a spreadsheet allows several users to open the same file for editing at the same time. The spreadsheet needs to be on a shared drive, server, website, or similar. Some conditions must be met on operating systems with user permission management:

- The shared file needs to reside in a location which is accessible by all collaborators.
- The file permissions for both the document and the corresponding lock file need to be set so that all collaborators can create, delete, and change the files.

Consult your operating system’s documentation for details on setting file permissions. See also “Opening and saving files on remote servers” in Chapter 1, Introducing LibreOffice, in the Getting Started Guide.

Tip

Each collaborator should enter their name in Tools > Options > LibreOffice > User Data.

Setting up a spreadsheet for sharing

With the spreadsheet open, choose Tools > Share Spreadsheet to enable or disable sharing.

![Figure 388: Choosing to share a spreadsheet](image)

To enable sharing, select the box at the top of the dialog (Figure 388) and click OK. If the spreadsheet has been saved previously, a message appears stating that you must save it to activate shared mode; click Yes to continue. If the spreadsheet has not been saved previously, the Save dialog opens. After saving, the word (shared) is shown on the title bar after the title.
**Tools > Share Spreadsheet** can also be used to switch a spreadsheet from shared to unshared. However, this means that other users can no longer edit it. Instead, you may wish to save a copy of the shared spreadsheet using another name or path, thus creating a copy of the shared spreadsheet, and then switch the copy to unshared.

**Opening a shared spreadsheet**

When you open a shared spreadsheet, a message appears stating that some features are not available in this mode. Click **OK** to open the document. You can select the option to not show the warning again.

The following features are disabled in a shared spreadsheet:

- **Edit > Track Changes**, except for **Merge Document**
  - Insert > Media > Audio or Video
  - Insert > Comment
  - Insert > Object
  - Insert > Chart
  - Insert > Named Range or Expression
  - Insert > Pivot Table
  - Insert > Floating Frame
  - Insert > Fontwork
  - Insert > Signature Line
- Format > Merge Cells
- Format > Print Ranges
- Sheet > Move or Copy Sheet
- Sheet > Delete Sheet
- Sheet > Insert Sheet from File
- Sheet > Named Ranges and Expressions
- Sheet > Rename Sheet
- Sheet > Sheet Tab Color
- Data > Define Range
- Data > Sort
- Data > Subtotals
- Data > Validity
- Data > Multiple Operations
- Data > Consolidate
- Data > Group and Outline
- Data > Pivot Table
- Tools > Protect Sheet

**Saving a shared spreadsheet**

When you save a shared spreadsheet, if it has not been modified and saved by another user since you opened it, it is saved as usual.

If the spreadsheet has been modified and saved by another user since you opened it, one of the following will occur:

- If the changes do not conflict, the document is saved, the message “Your spreadsheet has been updated with changes saved by other users” appears, and any cells modified by the other user are shown with a red border.
Figure 389: Resolve Conflicts dialog

- If the changes conflict, the Resolve Conflicts dialog (Figure 389) is shown. You must decide for each conflict which version to keep, yours or the other person's. When all conflicts are resolved, the document is saved. While you are resolving the conflicts, no other user can save the shared document.
- If another user is trying to save the shared spreadsheet and resolve conflicts, they see a message that the file is locked due to a merge in progress. They can cancel the Save command and retry saving later.

When you successfully save a shared spreadsheet, the document shows the latest version of all changes saved by all users.

Reviewing documents

You can use several methods to review, edit, and comment on a spreadsheet. Each reviewer works on a separate copy of the document.

- You can use change marks to show added and deleted material. Later, you or another person can review the document and accept or reject each change.
- You can make changes to a copy of the document (stored in a different folder, under a different name, or both), then use Calc to compare the files and show the changes. See page 378.
- You can save versions that are stored as part of the original file. See page 378.

Reviewers can leave comments in the document, either attached to specific changes or standalone.

Preparing a document for review (optional)

Before you send a spreadsheet to someone else to review or edit, you may want to set it up so that the editor or reviewer does not have to remember to turn on the revision marks.

After you have turned on revision marks, you can optionally password protect the spreadsheet so that any user must enter the correct password in order to accept or reject changes.

1) Open the spreadsheet and select Edit > Track Changes > Record from the Menu bar. You can also use File > Properties > Security and select Record changes.

2) (Optional) Click Edit > Track Changes > Protect. On the Protect Records dialog, type a password (twice) and click OK. You can also use File > Properties > Security and click the Protect button to open the Enter Password dialog.
Recording changes

To record changes, open the spreadsheet and make sure that the Edit > Track Changes > Record menu item has a check mark next to it, indicating that change recording is active.

**Caution**

After making some changes, do not turn off change recording. Turning off change recording in Calc causes all the recorded changes to be accepted and no longer shown as changes. A message box will warn you if you try to do this.

When changes are made in a cell, a colored border with a dot in the upper left-hand corner appears around the cell (Figure 390). A deleted column or row is marked by a heavy colored bar.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
</tr>
</thead>
<tbody>
<tr>
<td>Item Description</td>
<td>Quantity</td>
<td>Cost/Item</td>
<td>Total</td>
<td>Comments</td>
</tr>
<tr>
<td>Uniforms</td>
<td>10</td>
<td>$50.00</td>
<td>$500.00</td>
<td>Need to update the text</td>
</tr>
<tr>
<td>Baseballs</td>
<td>250</td>
<td>$2.00</td>
<td>$500.00</td>
<td>We need 10 per game</td>
</tr>
<tr>
<td>Umpire fees</td>
<td>25</td>
<td>$50.00</td>
<td>$1,250.00</td>
<td>1 umpire per game</td>
</tr>
<tr>
<td>Bats</td>
<td>5</td>
<td>$35.00</td>
<td>$175.00</td>
<td>Need bats of various sizes</td>
</tr>
<tr>
<td>Snacks</td>
<td>0</td>
<td>$15.00</td>
<td>$0.00</td>
<td>Max cost per game for refreshments</td>
</tr>
<tr>
<td>Batting helmets</td>
<td>5</td>
<td>$40.00</td>
<td>$200.00</td>
<td>We need a minimum of 10</td>
</tr>
<tr>
<td>Catching gear</td>
<td>1</td>
<td>$300.00</td>
<td>$300.00</td>
<td>Need to protect catchers</td>
</tr>
<tr>
<td>Spare gloves</td>
<td>2</td>
<td>$45.00</td>
<td>$90.00</td>
<td>Just in case someone needs them</td>
</tr>
<tr>
<td><strong>Total</strong></td>
<td></td>
<td></td>
<td><strong>$3,015.00</strong></td>
<td></td>
</tr>
</tbody>
</table>

Figure 390: Edited document with red border on changed cells

To see the changed information, hover the mouse pointer over the changed cell. See Figure 391.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
</tr>
</thead>
<tbody>
<tr>
<td>Item Description</td>
<td>Quantity</td>
<td>Cost/Item</td>
<td>Total</td>
<td>Comments</td>
</tr>
<tr>
<td>Uniforms</td>
<td>10</td>
<td>$50.00</td>
<td>$500.00</td>
<td>Need to update the text</td>
</tr>
<tr>
<td>Baseballs</td>
<td>250</td>
<td>$2.00</td>
<td>$500.00</td>
<td>We need 10 per game</td>
</tr>
<tr>
<td>Umpire fees</td>
<td>25</td>
<td>$50.00</td>
<td>$1,250.00</td>
<td>1 umpire per game</td>
</tr>
<tr>
<td>Bats</td>
<td>5</td>
<td>$35.00</td>
<td>$175.00</td>
<td>Need bats of various sizes</td>
</tr>
<tr>
<td>Snacks</td>
<td>0</td>
<td>$15.00</td>
<td>$0.00</td>
<td>Max cost per game for refreshments</td>
</tr>
<tr>
<td>Batting helmets</td>
<td>5</td>
<td>$40.00</td>
<td>$200.00</td>
<td>We need a minimum of 10</td>
</tr>
<tr>
<td>Catching gear</td>
<td>1</td>
<td>$300.00</td>
<td>$300.00</td>
<td>Need to protect catchers</td>
</tr>
<tr>
<td>Spare gloves</td>
<td>2</td>
<td>$45.00</td>
<td>$90.00</td>
<td>Just in case someone needs them</td>
</tr>
<tr>
<td><strong>Total</strong></td>
<td></td>
<td></td>
<td><strong>$3,015.00</strong></td>
<td></td>
</tr>
</tbody>
</table>

Figure 391: Showing details of the change

**Note**

Some changes, for example cell formatting, are not recorded and marked.

**Tip**

To change the color that indicates a changed cell, select Tools > Options > LibreOffice Calc > Changes.

You may want to explain your rationale for the changes. You can do this by adding comments to the changes you made or by adding general comments to the spreadsheet.

**Adding comments to changes**

Calc automatically adds to any recorded change a comment that describes what was changed (for example, Cell B4 changed from ‘9’ to ‘4’). Reviewers and authors can add their own comments to explain their reasons for the changes.
To add a comment to a change:

1) Make the change to the spreadsheet.
2) Select the cell with the change.
3) Choose **Edit > Track Changes > Comment** from the Menu bar. A small dialog opens. Type your comment and click **OK**. See Figure 392.

**Note**

Do not use **Insert > Comment** from the Menu bar or the context menu for this purpose. Comments inserted using that method are handled differently (see page 375) and do not appear in the Manage Changes dialog.

![Figure 392: Entering a comment associated with a change](image)

After you have added a comment to a changed cell, you can see the change and the comment by hovering the mouse pointer over the cell, as shown in Figure 393.

![Figure 393: Comment added to cell B3](image)

The comment also appears in the dialog when you are accepting and rejecting changes, as shown in the first line of Figure 397 on page 377.

### Editing comments on changes

1) Select the cell with the change comment that you want to edit.
2) Choose **Edit > Track Changes > Comment** from the Menu bar. The box shown in Figure 392 opens.
3) Edit the comment and click **OK**.

The automatically-added comment provided by Calc cannot be edited.

You can move through the comments by using the arrows at the bottom of the dialog.
Adding other (general) comments

Calc provides another type of comments, which authors and reviewers often use to exchange ideas or ask for suggestions.

To add a general comment:

1) Select the cell that the comment applies to.
2) Select Insert > Comment or right-click and select Insert Comment. The box shown in Figure 394 appears.

3) Type your comment in the box, then click outside the box to close it.

Now the cell to which you added the comment has a colored dot in the upper right-hand corner, as shown in Figure 395. It does not have a colored border, unless the cell was also changed.

Tip

You can change the colors Calc uses for notes by selecting Tools > Options > LibreOffice > Application Colors.

To view the comment you just added, hover the mouse pointer over the cell that has a comment; the comment appears, as shown below.

Editing general comments

You can edit and format the text of a general comment, just as you do for any other text.

1) Right-click on the cell containing the comment marker and choose Show comment from the context menu.
2) Select the comment, then double-click on it. The cursor changes to the usual text-entry cursor, and the Formatting toolbar changes to show text attributes.
3) When done editing, click outside the comment to deselect it. To hide the comment again, right-click on the cell and select Hide Comment on the context menu.
Formatting general comments
You can change the background color, border style, transparency, and other attributes of a comment.

1) Right-click on the cell containing the comment marker, and choose Show comment from the context menu.
2) Click on the comment itself. The Formatting toolbar changes to show many of the comment formatting options. These are the same as the options for formatting graphics; see Chapter 5, Using Graphics in Calc, for more information.
   You can also right-click on the comment to see a menu of choices, some of which lead to dialogs in which you can fine-tune the formatting; these dialogs are also discussed in Chapter 5.
3) When done, click outside the comment to deselect it. To hide the comment again, right-click on the cell and choose Hide Comment on the context menu.

Finding general comments
The small comment markers in the corners of cells can be difficult to see, so Calc provides two other ways to find them: by showing all comments and by using the Navigator. To show all general comments, choose View > Comments from the Menu bar. To hide all comments, choose View Comments again.

If any general comments are in the spreadsheet, the Navigator shows a mark (usually a + or an arrow) next to the word Comments. Click on this mark to display a list of comments. Double-click on a comment in the list to jump directly to the cell it is associated with.

Note
View > Comments and the Navigator show general comments but not the comments associated with tracked changes.

Accepting or rejecting changes
When you receive a document with changes, you can step through each change and decide how to proceed. To begin this process:

1) Open the edited document.
2) Select Edit > Track Changes > Manage. The dialog shown in Figure 397 appears.
3) You can step through the changes one at a time, choosing to accept or reject each change as you go through. You can also accept or reject all changes at one time.

The Comment column by default contains an explanation of the change that was made. If the reviewer added a comment to the change, it is displayed, followed by the description of the change.

If a change has been superseded by a later change (by either the same person or another person), the changes are hierarchically arranged with an expansion symbol for opening up the hierarchy.

Below the list of changes to be accepted or rejected are shown any changes that have previously been dealt with.

On the Filter tab of this dialog (Figure 398), you can choose how to filter the list of changes: by date, author, cell range, or comments containing specific terms. After selecting the filter criteria, switch back to the List tab to see the results.
Merging documents

The processes discussed to this point are effective when you have one reviewer at a time. Sometimes, however, multiple reviewers all return edited versions of a document at the same time. In this case, it may be faster to review all of the changes at once, rather than one review at a time. For this purpose, you can merge documents in Calc.

To merge documents, all of the edited documents need to have recorded changes in them.

1) Open the original document.
2) Select Edit > Track Changes > Merge Document.
3) A file selection dialog opens. Select a file you want to merge and click OK.

4) After the documents merge, the Manage Changes dialog opens, showing changes by more than one reviewer. If you want to merge more documents, close the dialog and then repeat steps 2 and 3.

Now all of the changes are combined into one document and you can accept or reject the changes. Changes from different authors appear in cells outlined in different colors.

Comparing documents

Sometimes reviewers may not record the changes they make. Calc can find the changes by comparing documents.

In order to compare documents you need to have the original document and the one that is edited. To compare them:

1) Open the edited document that you want to compare with the original document.
2) Select Edit > Track Changes > Compare Document.
3) An open document dialog appears. Select the original document and click Open.

Calc finds and marks the changes as follows:

- All data that occurs in the edited document but not in the original is identified as inserted.
- All data in the original document that is not in the edited document is identified as deleted.
- All data that is changed is marked as changed.

From this point you can go through and accept or reject changes as described earlier.

Saving versions

For auditing and other purposes, you may need to save new versions of a spreadsheet. You can do this by saving a copy of the spreadsheet (under a different name) after each revision, or by using Calc’s version feature.

Caution

If you do a Save As... of a document with different versions stored in it, the old versions are not saved in the new file.

To use version management in Calc:

1) Choose File > Versions from the Menu bar. The Versions dialog (Figure 399) opens, showing a list of the existing versions saved in this file.

![Figure 399: Version management dialog](image)

366 | Merging documents
2) Click the **Save New Version** button to save a new version. A dialog (Figure 400) opens where you can enter comments about this version.

![Insert Version Comment dialog](image)

*Figure 400: Insert Version Comment dialog*

3) After you enter your comment and click **OK**, the new version is included in the version list (Figure 401).

![Updated version list](image)

*Figure 401: Updated version list*

4) Save the file. Both versions are now included in the same file.

From this point you can:

- View an old version – Select the version and click **Open**: a read-only copy of a previous version opens.
- Compare all versions – Clicking **Compare** performs an action similar to merging documents. A Manage Changes dialog opens, showing all of the changes through the different versions.
- Review the version comments – Select a version and click **Show** to display the full comments made by yourself or other reviewers.
- Delete a version – Select a version and click **Delete**.
Chapter 12
Calc Macros
Automating repetitive tasks
**Introduction**

Chapter 13 of the *Getting Started Guide* (entitled *Getting Started with Macros*) is an introduction to the macro facilities that are available in LibreOffice. The current chapter provides further introductory information about the use of macros within a Calc spreadsheet.

A macro is a set of commands or keystrokes that are stored for later use. An example of a simple macro is one that enters your address into the current cell of an open spreadsheet. You can use macros to automate both simple and complex tasks, and they enable you to introduce new features that are not built into Calc.

The simplest way to create a macro is to record a series of actions through Calc’s user interface. Calc saves recorded macros using the open source LibreOffice Basic scripting language, which is a dialect of the well-known BASIC programming language. Such macros can be edited and enhanced after recording using the built-in LibreOffice Basic Integrated Development Environment (IDE).

The most powerful macros in Calc are created by writing code using one of the four supported scripting languages (LibreOffice Basic, BeanShell, JavaScript, and Python). This chapter provides an overview of Calc’s macro facilities, mostly focused on its default macro scripting language, LibreOffice Basic. Some examples are included for the BeanShell, JavaScript and Python scripting languages but fuller descriptions of the facilities for these languages are beyond the scope of this document.

**Using the macro recorder**

Chapter 13 of the *Getting Started Guide* includes examples showing how to use the macro recorder and understand the generated LibreOffice Basic scripts. The following steps give a further example, specific to a Calc spreadsheet, without the more detailed explanations of the *Getting Started Guide*. A macro is created and saved which performs a paste special with multiply operation across a range of spreadsheet cells.

3) Use **Tools > Options > LibreOffice > Advanced** from the Menu bar and select the **Enable macro recording** option to enable the macro recorder.

4) Use **File > New > Spreadsheet** from the Menu bar to create a new spreadsheet.

5) Enter the numbers shown in Figure 402 into cells A1:C3 of the first sheet in the new spreadsheet.

   ![Figure 402: Enter numbers into cells A1:C3](image)

6) Select cell A3, which contains the number 3, and use **Edit > Copy** from the Menu bar to copy the value to the clipboard.

7) Select all cells in the range A1:C3.

8) Use **Tools > Macros > Record Macro** from the Menu bar to start the macro recorder. Calc displays the Record Macro dialog, which includes a **Stop Recording** button (Figure 403).

   ![Figure 403: Record Macro dialog with Stop Recording button](image)
9) Use Edit > Paste Special > Paste Special from the Menu bar to open the Paste Special dialog (Figure 404).

![Paste Special dialog](image)

Figure 404: Paste Special dialog

10) Select the Paste all option in the Selection area and the Multiply option in the Operations area, and click OK. The values in cells A1:C3 are now multiplied by 3 (Figure 405).

![Cells A1:C3 multiplied by 3](image)

Figure 405: Cells A1:C3 multiplied by 3

11) Click the Stop Recording button to stop the macro recorder. Calc displays a variant of the LibreOffice Basic Macros dialog (Figure 406).

Caution

An earlier bug caused versions of LibreOffice 6.2 to crash when you clicked the Stop Recording button, but this bug is fixed in LibreOffice 6.3. See entry #122598 in The Document Foundation's Bugzilla defect tracking system for more details.
The Save macro in area of the LibreOffice Basic Macros dialog shows the existing LibreOffice Basic macros, hierarchically structured into library containers, libraries, modules, and macros as described in Chapter 13 of the Getting Started Guide. Figure 406 shows the My Macros library container, the LibreOffice Macros library container, the library container for the open Balance.ods file, and the library container for the untitled file created at step 4. Use the expand / collapse icons to the left of each library container name to view the libraries, modules and macros within that container.

12) Select the entry for the current document in the Save macro in area. As the current document in this example has not been saved, it is referred to by its default name Untitled 1.

Documents that have been saved include a macro library named Standard. This library is not created until the document is saved or the library is needed, so at this point in the example procedure your new document does not contain a library. You can create a new library to contain the macro you have just created, but this is not necessary.

13) Click the New Module button. Calc displays the New Module dialog (Figure 407). Type a name for the new module or leave the name as the default Module1.
The libraries, modules and macro names must follow some strict rules. Following the main rules, the names must:

- Begin with a letter
- Comprise lower case letters (a..z), upper case letters (A..Z), digits (0..9), and underscore characters (_)
- Not contain any other spaces, punctuation symbols, or special characters (including accents)

14) Click the OK button to create a new module. As no macro libraries exist in our current document, Calc automatically creates and uses a Standard library.

15) On the LibreOffice Basic Macros dialog, select the entry for the newly created module in the Save macro in area, type the text PasteMultiply in the Macro Name box, and click the Save button (Figure 408).

The macro is saved with the name PasteMultiply in the newly created module within the Standard library of the Untitled 1 document. Listing 1 shows the contents of the macro.
Listing 1. Paste special with multiply macro

sub PasteMultiply
    rem --------------------------------------------------------------
    rem define variables
    dim document as object
    dim dispatcher as object
    rem --------------------------------------------------------------
    rem get access to the document
    document = ThisComponent.CurrentController.Frame
    dispatcher = createUnoService("com.sun.star.frame.DispatchHelper")

    rem --------------------------------------------------------------
    dim args1(5) as new com.sun.star.beans.PropertyValue
    args1(0).Name = "Flags"
    args1(0).Value = "A"
    args1(1).Name = "FormulaCommand"
    args1(1).Value = 3
    args1(2).Name = "SkipEmptyCells"
    args1(2).Value = false
    args1(3).Name = "Transpose"
    args1(3).Value = false
    args1(4).Name = "AsLink"
    args1(4).Value = false
    args1(5).Name = "MoveMode"
    args1(5).Value = 4

    dispatcher.executeDispatch(document, ".uno:InsertContents", ",", 0, args1())
end sub

Write your own functions

Create function macro

You can write a macro and then call it as you would call a Calc function. Use the following steps to create a simple function macro:

1) Create a new spreadsheet, save it with the name CalcTestMacros.ods, and leave it open in Calc.

2) Use Tools > Macros > Organize Macros > LibreOffice Basic from the Menu bar to open the LibreOffice Basic Macros dialog (Figure 409). Note that the layout of the LibreOffice Basic Macros dialog in this circumstance is different from the version that Calc displays when the user clicks the Stop Recording button on the Record Macro dialog (see Figure 406).

The Macro From area lists the available macro library containers, including those relating to any LibreOffice documents that are currently open. My Macros contains macros that you write or add to LibreOffice and are available to more than one document. LibreOffice Macros contains macros that were included with your LibreOffice installation and should not be changed.
3) Click **Organizer** to open the LibreOffice Basic Macro Organizer dialog (Figure 410).

![Figure 409: LibreOffice Basic Macros dialog](image)

![Figure 410: LibreOffice Basic Macro Organizer](image)

Click on the **Libraries** tab and, in the **Location:** area, select the entry for the name of the current document. The **Library:** area updates to show the name of the empty **Standard** library.

---

374 | **Write your own functions**
4) Click **New** to open the New Library dialog to create a new library for this document (Figure 411).

![New Library dialog](image)

*Figure 411: New Library dialog*

5) Enter a descriptive library name (such as *AuthorsCalcMacros*) and click **OK** to create the library. The **Library** area of the LibreOffice Basic Macro Organizer dialog updates to include the name of the newly created library. A library name can comprise up to 30 characters. Note that in some cases, the dialog may show only a portion of the name.

![LibreOffice Basic Macro Organizer dialog](image)

*Figure 412: The new library is shown in the Library: area*

Select the *AuthorsCalcMacros* entry in the **Library**: area and click **Edit** to edit the library. Calc automatically creates a module named *Module1* and a macro named *Main*. Calc displays the LibreOffice Basic Integrated Development Environment (IDE), shown in Figure 413.
Figure 413: LibreOffice Basic Integrated Development Environment

Figure 413 shows the default configuration for the LibreOffice Basic IDE. This comprises:

- A menu bar.
- Three toolbars (Language, Macro, and Standard). The Macro toolbar provides various icons for editing and testing programs.
- The Object Catalog, enabling selection of the required library container, library, module, and macro.
- The Editor Window, in which you can edit the LibreOffice Basic program code. The column on the left side is used to set breakpoints in the program code.
- The Watch Window (located at the left, below the Object Catalog and Editor Window) displays the contents of variables or arrays during a single step process.
- The Call Stack Window (located to the right, below the Object Catalog and Editor Window) provides information about the call stack of procedures and functions when a program runs.
- A tab control area.
- A status bar.

The LibreOffice Basic IDE provides powerful facilities for the development and debugging of LibreOffice Basic macros. A fuller description of this facility is beyond the scope of this document.

6) In the Editor Window, modify the code so that it is the same as that shown in Listing 2. The important addition is the creation of the NumberFive function, which returns the value 5.

376 | Write your own functions
Tip

The Option Explicit statement forces all variables to be declared before they are used. If Option Explicit is omitted, variables are automatically defined at first use as type Variant.

Listing 2. Function that returns the value 5

REM ***** BASIC *****
Option Explicit

Sub Main

End Sub

Function NumberFive ()
    NumberFive = 5
End Function

7) Use the Save button of the Standard toolbar within the LibreOffice Basic IDE to save the modified Module1.

Using a macro as a function

Using your newly created CalcTestMacros.ods spreadsheet, select a cell and enter the formula =NumberFive() (Figure 414). Calc finds the macro, calls it, and displays the result (5) in that cell.

![Figure 414: Use the NumberFive macro as a Calc function](image)

Tip

Function names are not case sensitive. In Figure 414, the function name was entered as NumberFive() but Calc displays it as NUMBERFIVE() in the Formula bar.

Macro security warnings

You should now save the Calc document, close it, and open it again. Depending on your settings in the Macro Security dialog accessed using Tools > Options > LibreOffice > Security > Macro Security from the Menu bar, Calc may display one of the warnings shown in Figures 415 and 416.

In the case of the warning shown in Figure 415, you will need to click Enable Macros, or Calc will not allow any macros to be run in the document. If you do not expect a document to contain a macro, it is safer to click Disable Macros in case the macro is a virus.
In the case of the warning shown in Figure 416, Calc will not allow any macros to be run in the document and you should click the **OK** button to remove the warning from the screen.

When the document loads with macros disabled, Calc will not be able to find any macro functions and will indicate an error in any affected cell by displaying the text `#NAME?` in that cell.

### Loaded / unloaded libraries

When it opens a spreadsheet, Calc does not open all macro libraries that it can find in the available library containers because this would be a waste of resources. Instead Calc automatically loads just the **Standard** library within the **My Macros** library container and the document's own **Standard** library. No other libraries are automatically loaded.

When you re-open your CalcTestMacros.ods spreadsheet, Calc does not contain a function named `NumberFive()`, so it checks all visible, loaded macro libraries for the function. Loaded libraries in **LibreOffice Macros**, **My Macros**, and the document are checked for an appropriately named function. In our initial implementation, the `NumberFive()` function is stored in the **AuthorsCalcMacros** library, which is not automatically loaded when the document is opened. Hence the `NumberFive()` function is not found and an error condition appears in the cell where it is called (Figure 417).
Use **Tools > Macros > Organize Macros > LibreOffice Basic** from the Menu bar to open the LibreOffice Basic Macros dialog (Figure 418). The icon for a loaded library (for example, *Standard*) has a different appearance to the icon for a library that is not loaded (for example, *AuthorsCalcMacros*).

[![LibreOffice Basic Macros dialog](image)](image)

*Figure 418: Different symbols for loaded and unloaded libraries*

Click the expand icon next to *AuthorsCalcMacros* to load the library. The icon changes appearance to indicate that the library is now loaded. Click **Close** to close the LibreOffice Basic Macros dialog.

Unfortunately, the cell containing `=NumberFive()` in our initial implementation is still in error. Calc does not recalculate cells in error unless you edit them or somehow change them. The usual solution is to store macros used as functions in the *Standard* library. If the macro is large or if there are many macros, a stub with the desired name is stored in the *Standard* library. The stub macro loads the library containing the implementation and then calls the implementation. The following steps illustrate this method.

1) **Use Tools > Macros > Organize Macros > LibreOffice Basic** in the Menu bar to open the LibreOffice Basic Macros dialog. Select the *NumberFive* macro and click **Edit** to open the macro for editing (Figure 419).

[![LibreOffice Basic Macros dialog](image)](image)

*Figure 419: Select a macro and click Edit*

2) Calc displays the LibreOffice Basic IDE (Figure 413), with the input cursor in the Editor Window at the line `Function NumberFive ()`. Change the name of *NumberFive* to *NumberFive_Implementation* so that the function’s code matches Listing 3.
Listing 3. Change the name of NumberFive to NumberFiveIMPLEMENTATION

Function NumberFiveIMPLEMENTATION()  
    NumberFiveIMPLEMENTATION = 5  
End Function

3) Click the Select Macro button in the Standard toolbar of the LibreOffice Basic IDE to open the LibreOffice Basic Macros dialog (Figure 419).

4) Select the Standard library in the CalcTestMacros.ods document and click the New button to create a new module. Enter a meaningful name such as CalcFunctions and click OK. Calc automatically creates a macro named Main and opens the module for editing.

5) Create a macro in the CalcFunctions module of the Standard library that loads the AuthorsCalcMacros library if it is not already loaded, and then calls the implementation function. See Listing 4.

Listing 4. Create a new NumberFive function to call the NumberFiveIMPLEMENTATION function

Function NumberFive()  
    If NOT BasicLibraries.isLibraryLoaded("AuthorsCalcMacros") Then  
        BasicLibraries.LoadLibrary("AuthorsCalcMacros")  
    End If  
    NumberFive = NumberFiveIMPLEMENTATION()  
End Function

6) Save, close, and reopen the Calc document. This time, if macros are enabled, the NumberFive() function works as expected.

Passing arguments to a macro

To illustrate a function that accepts arguments, we will write a macro that calculates the sum of its arguments that are positive. It will ignore arguments that are less than zero (see Listing 5).

Listing 5. PositiveSum calculates the sum of its positive arguments

Function PositiveSum(Optional x)  
    Dim TheSum As Double  
    Dim iRow As Integer  
    Dim iCol As Integer  
    TheSum = 0.0  
    If NOT IsMissing(x) Then  
        If NOT IsArray(x) Then  
            If x > 0 Then TheSum = x  
        Else  
            For iRow = LBound(x, 1) To UBound(x, 1)  
                For iCol = LBound(x, 2) To UBound(x, 2)  
                    If x(iRow, iCol) > 0 Then TheSum = TheSum + x(iRow, iCol)  
                Next  
            Next  
        End If  
    End If  
    PositiveSum = TheSum  
End Function

380 | Write your own functions
The macro in Listing 5 demonstrates some important techniques:

1) The argument $x$ is Optional. When an argument is not Optional and the function is called without it, Calc outputs a warning message every time the macro is called. If Calc calls the function many times, then the error is displayed many times.

2) The function IsMissing checks that an argument was passed before it is used.

3) The function IsArray checks to see if the argument is a single value, or an array. For example, =PositiveSum(7) or =PositiveSum(A4). In the first case, the number 7 is passed as an argument, and in the second case, the value of cell A4 is passed to the function. In both these cases, IsArray returns the value False.

4) If a range is passed to the function, it is passed as a two-dimensional array of values; for example, =PositiveSum(A2:B5). The functions LBound and UBound are used to determine the array bounds that are used. Although the lower bound is one, it is considered safer to use LBound in case it changes in the future.

### Tip

The macro in Listing 5 is careful and checks to see if the argument is an array or a single argument. The macro does not verify that each value is numeric. You may be as careful as you like. The more things you check, the more robust the macro is, but the slower it runs.

Passing one argument is as easy as passing two: add another argument to the function definition (see Listing 6). When calling a function with two arguments, separate the arguments with a comma; for example, =TestMax(3, -4).

Listing 6. TestMax accepts two arguments and returns the larger

Function TestMax(x, y)
   If x >= y Then
      TestMax = x
   Else
      TestMax = y
   End If
End Function

Arguments are passed as values

Arguments passed to a macro from Calc are always values. It is not possible to know what cells, if any, are used. For example, =PositiveSum(A3) passes the value of cell A3, and PositiveSum has no way of knowing that cell A3 was used. If you must know which cells are referenced rather than the values in the cells, pass the range as a string, parse the string, and obtain the values in the referenced cells.

Writing macros that act like built-in functions

Although Calc finds and calls macros as normal functions, they do not really behave as built-in functions. For example, macros do not appear in the function lists. It is possible to write functions that behave as regular functions by writing an Add-In. However, this is an advanced topic that is for experienced programmers and is beyond the scope of this guide.
Accessing cells directly

You can access the LibreOffice internal objects directly to manipulate a Calc document. For example, the macro in Listing 7 adds the values in cell A2 from every sheet in the current document. ThisComponent is automatically set to reference the current document when the macro starts. A Calc document contains sheets and the macro accesses these via a call to ThisComponent.getSheets(). Use getCellByPosition(col, row) to return a cell at a specific row and column.

Listing 7. SumCellsAllSheets adds the values in cell A2 of every sheet

Function SumCellsAllSheets()
    Dim TheSum As Double
    Dim i As integer
    Dim oSheets
    Dim oSheet
    Dim oCell

    TheSum = 0
    oSheets = ThisComponent.getSheets()
    For i = 0 To oSheets.getCount() - 1
        oSheet = oSheets.getByIndex(i)
        oCell = oSheet.getCellByPosition(0, 1) ' GetCell A2
        TheSum = TheSum + oCell.getValue()
    Next
    SumCellsAllSheets = TheSum
End Function

Tip

A cell object supports the methods getValue(), getString(), and getFormula() to get the numerical value, the string value, or the formula used in a cell. Use the corresponding set functions to set appropriate values.

Use oSheet.getCellRangeByName("A2") to return a range of cells by name. If a single cell is referenced, then a cell object is returned. If a cell range is given, then an entire range of cells is returned (see Listing 8). Notice that a cell range returns data as an array of arrays, which is more cumbersome than treating it as an array with two dimensions as is done in Listing 5.

Listing 8. SumCellsAllSheets adds the values in cells A2:C5 of every sheet

Function SumCellsAllSheets()
    Dim TheSum As Double
    Dim iRow As Integer, iCol As Integer, i As Integer
    Dim oSheets, oSheet, oCells
    Dim oRow(), oRows()

    TheSum = 0
    oSheets = ThisComponent.getSheets()
    For i = 0 To oSheets.getCount() - 1
        oSheet = oSheets.getByIndex(i)
        oCells = oSheet.getCellRangeByName("A2:C5")
        REM The getDataArray() method returns strings and numbers
        REM but is not used in this function.
REM The getData() method returns only numbers and is applicable
REM to this function.

oRows() = oCells.getData()
For iRow = LBound(oRows()) To UBound(oRows())
    oRow() = oRows(iRow)
    For iCol = LBound(oRow()) To UBound(oRow())
        TheSum = TheSum + oRow(iCol)
    Next
Next
Next
SumCellsAllSheets = TheSum
End Function

Tip

When a macro is called as a Calc function, the macro cannot modify any value in the
sheet from which the macro was called, except the value of the cell that contains the
function.

Sorting

Consider sorting the data shown in Figure 420. First, sort on column B descending and then on
column A ascending.

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1</td>
<td>5</td>
<td>One</td>
</tr>
<tr>
<td>2</td>
<td>4</td>
<td>1</td>
<td>Two</td>
</tr>
<tr>
<td>3</td>
<td>3</td>
<td>1</td>
<td>Three</td>
</tr>
<tr>
<td>4</td>
<td>7</td>
<td>8</td>
<td>Four</td>
</tr>
<tr>
<td>5</td>
<td>4</td>
<td>2</td>
<td>Five</td>
</tr>
</tbody>
</table>

Becomes

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>7</td>
<td>8</td>
<td>Four</td>
</tr>
<tr>
<td>2</td>
<td>1</td>
<td>5</td>
<td>One</td>
</tr>
<tr>
<td>3</td>
<td>4</td>
<td>2</td>
<td>Five</td>
</tr>
<tr>
<td>4</td>
<td>3</td>
<td>1</td>
<td>Three</td>
</tr>
<tr>
<td>5</td>
<td>4</td>
<td>1</td>
<td>Two</td>
</tr>
</tbody>
</table>

Figure 420: Sort column B descending and column A ascending

The example in Listing 9 demonstrates how to sort on these two columns.

Listing 9. SortRange sorts cells A1:C5 of Sheet 1

Sub SortRange
    Dim oSheet ' Calc sheet containing data to sort.
    Dim oCellRange ' Data range to sort.

REM An array of sort fields determines the columns that are
REM sorted. This is an array with two elements, 0 and 1.
REM To sort on only one column, use:
REM Dim oSortFields(0) As New com.sun.star.util.SortField
REM Dim oSortFields(1) As New com.sun.star.util.SortField

REM The sort descriptor is an array of properties.
REM The primary property contains the sort fields.
Dim oSortDesc(0) As New com.sun.star.beans.PropertyValue

REM Get the sheet named "Sheet1"
oSheet = ThisComponent.Sheets.getByIndex("Sheet1")
Overview of BeanShell, JavaScript, and Python macros

Introduction

Many programmers may not be familiar with LibreOffice Basic and so Calc supports macros written in three other languages that may be more familiar. These are BeanShell, JavaScript, and Python.

The primary macro scripting language for Calc is LibreOffice Basic and the standard LibreOffice installation provides a powerful integrated development environment (IDE) together with more options for this language.

Macros are organized in the same way for all four scripting languages. The LibreOffice Macros container holds all the macros that are supplied in the LibreOffice installation. The My Macros library container holds your macros that are available to any of your LibreOffice documents. Each document can also contain your macros that are not available to any other document.

When you use the macro recording facility, Calc creates the macro in LibreOffice Basic. To use the other available scripting languages you must write the code yourself.

When you select to run a macro using Tools > Macros > Run Macro from the Menu bar, Calc displays the Macro Selector dialog. This dialog enables selection and running of any available macro, coded in any of the available languages (Figure 421).

When you select to edit a macro using Tools > Macros > Edit Macros from the Menu bar, Calc displays the LibreOffice Basic IDE. This dialog enables selection and editing of any available LibreOffice Basic macro, but not macros in other languages.
The component model used in LibreOffice is known as Universal Network Objects or UNO. LibreOffice macros in any scripting language use a UNO runtime application programming interface (API). The XSCRIPTCONTEXT interface is provided to macro scripts in all four languages, and provides a means of access to the various interfaces which they might need to perform some action on a document.

**BeanShell macros**

BeanShell is a Java-like scripting language that was first released in 1999.

When you select **Tools > Macros > Organize Macros > BeanShell** from the Menu bar, Calc displays the BeanShell Macros dialog (Figure 422).
Click the Edit button on the BeanShell Macros dialog to access the BeanShell Debug Window (Figure 423).

Figure 423: BeanShell Debug Window
Listing 10 is an example of a BeanShell macro that inserts the text “Hello World from BeanShell” in cell A1 of the active Calc spreadsheet.

Listing 10. Sample BeanShell macro

```java
import com.sun.star.uno.UnoRuntime;
import com.sun.star.sheet.XSpreadsheetView;
import com.sun.star.text.XText;
model = XSCRIPTCONTEXT.getDocument();
controller = model.getCurrentController();
view = UnoRuntime.queryInterface(XSpreadsheetView.class, controller);
sheet = view.getActiveSheet();
cell = sheet.getCellByPosition(0, 0);
cellText = UnoRuntime.queryInterface(XText.class, cell);
textCursor = cellText.createTextCursor();
cellText.insertString(textCursor, "Hello World from BeanShell", true);
return 0;
```

**JavaScript macros**

JavaScript is a high-level scripting language that was first released in 1995.

When you select **Tools > Macros > Organize Macros > JavaScript** from the Menu bar, Calc displays the JavaScript Macros dialog (Figure 424).
Click the **Edit** button on the JavaScript Macros dialog to access the Rhino JavaScript Debugger (Figure 425). Detailed instructions for using this tool can be found on Mozilla’s website at [https://developer.mozilla.org/en-US/docs/Mozilla/Projects/Rhino/Debugger](https://developer.mozilla.org/en-US/docs/Mozilla/Projects/Rhino/Debugger).

![Rhino JavaScript Debugger](image)

**Figure 425: Rhino JavaScript Debugger**

Listing 11 is an example of a JavaScript macro that inserts the text “Hello World from JavaScript” in cell A1 of the first sheet in a Calc spreadsheet.

```javascript
// Hello World in JavaScript
importClass(Packages.com.sun.star.uno.UnoRuntime);
importClass(Packages.com.sun.star.text.XTextDocument);
importClass(Packages.com.sun.star.text.XText);
importClass(Packages.com.sun.star.text.XTextRange);

// get the document from the scripting context
oDoc = XSCRIPTCONTEXT.getDocument();
// get the XTextDocument interface
xTextDoc = UnoRuntime.queryInterface(XTextDocument, oDoc);
// get the XText interface
xText = xTextDoc.getText();
// get an (empty) XTextRange interface at the end of the text
```
Listing 11. Sample JavaScript macro

```javascript
importClass(Packages.com.sun.star.uno.UnoRuntime);
importClass(Packages.com.sun.star.sheet.XSpreadsheetDocument);
importClass(Packages.com.sun.star.container.XIndexAccess);
importClass(Packages.com.sun.star.table.XCellRange);
importClass(Packages.com.sun.star.table.XCell);

documentRef = XSCRIPTCONTEXT.getDocument();

spreadsheetInterface = UnoRuntime.queryInterface(XSpreadsheetDocument, documentRef);

allSheets = UnoRuntime.queryInterface(XIndexAccess, spreadsheetInterface.getSheets());

theSheet = allSheets.getByIndex(0);

Cells = UnoRuntime.queryInterface(XCellRange, theSheet);

cellA1 = Cells.getCellByPosition(0, 0);

theCell = UnoRuntime.queryInterface(XCell, cellA1);

theCell.setFormula("Hello World from JavaScript");
```

**Python macros**

Python is a high-level, general-purpose programming language that was first released in 1991. When you select **Tools > Macros > Organize Macros > Python** from the Menu bar, Calc displays the Python Macros dialog (Figure 426).

![Python Macros dialog](image_url)
Facilities to edit and debug Python scripts are not currently integrated into the standard LibreOffice user interface. However you can edit Python scripts with your preferred text editor or an external IDE. The Alternative Python Script Organizer (APSO) extension eases the editing of Python scripts, in particular when embedded in a document. Using APSO you can configure your preferred source code editor, start the integrated Python shell and debug Python scripts. For more information search for Python in the LibreOffice Help system and visit the *Designing & Developing Python Applications* section of The Document Foundation’s wiki (https://wiki.documentfoundation.org/Macros/Python_Design_Guide).

Listing 12 is an example of a Python macro that sets cell A1 of the first sheet in a Calc spreadsheet to the text “Hello World from Python”.

**Listing 12. Sample Python macro**

```python
import uno
def HelloWorld():
    doc = XSCRIPTCONTEXT.getDocument()
    cell = doc.Sheets[0]['A1']
    cell.setString('Hello World from Python')
    return
```

**Conclusion**

This chapter provides an overview of how to create libraries and modules, using the macro recorder, using macros as Calc functions, and writing your own macros without the macro recorder. Each topic deserves at least one chapter, and writing your own macros for Calc could easily fill an entire book. In other words, this is just the beginning of what you can learn.

Additional detail about Calc's macro facilities can be obtained from the Help system, The Document Foundation’s wiki pages (for example https://wiki.documentfoundation.org/Macros) and other Internet sources (for example the http://ask.libreoffice.org/ Q&A site).
Chapter 13
Calc as a Simple Database
A guide for users and macro programmers
Introduction

Though it is a spreadsheet program, Calc has sufficient functionality to act as a simple yet capable database-like platform. This chapter presents an overview of these capabilities and explains them using macros and GUI (Graphical User Interface) examples.

Note

Though it was created for macro programmers, this guide is meant to be accessible for all users. If you do not want to use macros, simply skip the sections that deal with them. However, if you are interested in learning more about them, see Chapter 12, Calc Macros, in this book, and Andrew Pitonyak’s book, OpenOffice.org Macros Explained (OOME).

All the macro information in this chapter is drawn or adapted from the OOME and LibreOffice’s API reference at https://api.libreoffice.org/docs/idl/ref/index.html.

A database primer

In a typical database, related data is organized into tables, which are arranged in a grid-like series of rows and columns similar to a spreadsheet. Each row of a table represents a data record, while each column represents a field within each record. Each cell in a field contains an individual data item or attribute, such as a name, while each record consists of related attributes that correspond to a single entity, like a person. A database table tends to have a fixed number of fields, but can have an indefinite number of records.

While a table may have hundreds or thousands of rows, individual records can be easily found, retrieved, and updated using information requests, called queries, that search for records that meet a specified set of criteria. It is this ease of access that makes a database table more useful than simply filing away information in an unordered spreadsheet.

To illustrate this concept of a database table, consider the example of a class grading sheet (Figure 427). In this sheet, each row represents individual students taking the class, while each column contains their names and grades. With this table, you can quickly look up individual students' grades simply by searching for their names, and you can determine which students are passing the class by filtering out records with failing average scores.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
<th>H</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Student</td>
<td>HW #1</td>
<td>HW #2</td>
<td>HW #3</td>
<td>Quiz #1</td>
<td>Quiz #2</td>
<td>Test #1</td>
</tr>
<tr>
<td>2</td>
<td>Andrew</td>
<td>90</td>
<td>100</td>
<td>82</td>
<td>90</td>
<td>88</td>
<td>92</td>
</tr>
<tr>
<td>3</td>
<td>Bethany</td>
<td>95</td>
<td>100</td>
<td>82</td>
<td>80</td>
<td>88</td>
<td>93</td>
</tr>
<tr>
<td>4</td>
<td>Charles</td>
<td>80</td>
<td>93</td>
<td>73</td>
<td>80</td>
<td>75</td>
<td>84</td>
</tr>
<tr>
<td>5</td>
<td>David</td>
<td>75</td>
<td>86</td>
<td>91</td>
<td>40</td>
<td>88</td>
<td>79</td>
</tr>
<tr>
<td>6</td>
<td>Emily</td>
<td>100</td>
<td>100</td>
<td>81</td>
<td>100</td>
<td>75</td>
<td>94</td>
</tr>
<tr>
<td>7</td>
<td>Ferdinand</td>
<td>85</td>
<td>93</td>
<td>73</td>
<td>60</td>
<td>50</td>
<td>72</td>
</tr>
<tr>
<td>8</td>
<td>Georgia</td>
<td>70</td>
<td>80</td>
<td>55</td>
<td>39</td>
<td>75</td>
<td>67</td>
</tr>
<tr>
<td>9</td>
<td>Haley</td>
<td>85</td>
<td>93</td>
<td>82</td>
<td>70</td>
<td>75</td>
<td>76</td>
</tr>
<tr>
<td>10</td>
<td>Ian</td>
<td>100</td>
<td>100</td>
<td>91</td>
<td>90</td>
<td>100</td>
<td>96</td>
</tr>
<tr>
<td>11</td>
<td>Jennifer</td>
<td>85</td>
<td>93</td>
<td>73</td>
<td>80</td>
<td>100</td>
<td>90</td>
</tr>
</tbody>
</table>

Figure 427: Grading sheet example

Note

This simple tabular design is based on the relational database model, which is one of the most common and well-known design models used in modern databases.
Calc as a database-like program

As mentioned, a database table is similar to a spreadsheet, and can even be contained within one. Additionally, as a spreadsheet program, Calc offers several features, particularly sorting and filtering, that allow users to search tables similar to how one would in a database program such as LibreOffice Base or Microsoft Access. While this does not make Calc a replacement for either of those programs, it is nevertheless still useful for managing data in a small-scale personal or professional context without having to learn how to use a dedicated database system.

Associating a range with a name

In order to set up a database table in a Calc worksheet, you first need to set up an area for it to occupy. This is necessary since some of Calc's database-like features depend on accessing or modifying a table's location. Such an area is represented by a range, which is a contiguous group of one or more cells. To make the range for a table easy to access, you can assign a meaningful name to it. Doing this has four particular benefits:

- Giving a range a name makes it easier to identify, especially if you are working with multiple ranges in a document.
- A named range can be referenced by its name rather than just by its address. For example, if you have a range named Scores, you can simply reference it in a cell with an equation like =SUM(Scores).
- References by name to a named range are automatically updated every time the range's address is changed. This prevents the need to change individual references every time a range's location is modified.
- All named ranges can be quickly viewed and accessed through the Navigator, which is opened by pressing the F5 key or clicking on the icon in the Sidebar panel.

Two types of named range exist in Calc: database ranges, which store settings for database-like operations, and standard named ranges, which do not.

Named ranges

Standard named ranges are created using the Define Names dialog (Figure 428), which is opened by selecting Sheet > Named Ranges and Expressions > Define from the Menu bar.

![Define Names dialog](image)

Figure 428: Define Names dialog
To create a named range, select a range of cells from a worksheet, then open the dialog. Next, give the range a meaningful name, and click on **Add** to add it to the current document’s list of named ranges. You can then access and modify these ranges using the **Manage Names** dialog, which is opened by selecting **Sheet > Named Ranges and Expressions** from the Menu bar (Figure 429). For more detail about to create and manage ranges, see Chapter 6, Printing, Exporting, E-mailing, and Signing, and Chapter 7, Formulas and Functions.

### Figure 429: Manage Names dialog

<table>
<thead>
<tr>
<th>Name</th>
<th>Range or formula expression</th>
<th>Scope</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Creating named ranges with macros**

In a macro, a named range is accessed, created, and deleted using the **NamedRanges** service of a Calc document. This service has a number of methods associated with it, the following of which are particularly useful for creating named ranges:

- **getName(Name)**
  - Returns the range or expression with the specified name.

- **getElementNames()**
  - Returns an array of all named ranges in the current document.

- **hasByName(Name)**
  - Returns a boolean: TRUE if a range with this name is in the current document, and FALSE otherwise.

- **addNewByName(Name, Content, Position, Type)**
  - Adds a new named range to the current document. This method has four arguments:
    - **Name** – A string that contains the name of the new range
– **Content** – A string that contains the range address or formula expression being named
– **Position** – The base address for relative cell references
– **Type** – A combination of flags that specify the type of named range being defined. These flags are listed in Table 11. This parameter defaults to zero for any common named range.

Table 11: com.sun.star.sheet.NamedRangeFlag constant group reference

<table>
<thead>
<tr>
<th>Value</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>FILTER_CRITERIA</td>
<td>The range contains filter criteria.</td>
</tr>
<tr>
<td>2</td>
<td>PRINT_AREA</td>
<td>The range can be used as a print range.</td>
</tr>
<tr>
<td>4</td>
<td>COLUMN_HEADER</td>
<td>The range can be used as column headers for printing.</td>
</tr>
<tr>
<td>8</td>
<td>ROW_HEADER</td>
<td>The range can be used as row headers for printing.</td>
</tr>
</tbody>
</table>

As an example, the macro in Listing 13 uses the above methods to check if a range with a given name exists. If it does not exist, then the macro creates a range with the name and sets it to access the cell range B3:D6.

**Listing 13: AddNamedRange creates a new named range that references $Sheet1.$B$3:$D$6**

Sub AddNamedRange()
    Dim oRange    ' The created range.
    Dim oRanges   ' All named ranges.
    Dim sName$    ' Name of the named range to be created.
    Dim oCell     ' Cell object.
    Dim s$

    sName$ = "MyNRange"
    oRanges = ThisComponent.NamedRanges
    If NOT oRanges.hasByName(sName$) Then
        REM Setting the base address for relative cell references
        Dim oCellAddress As new com.sun.star.table.CellAddress
        oCellAddress.Sheet = 0     'The first sheet.
        oCellAddress.Column = 1   'Column B.
        oCellAddress.Row = 2      'Row 3.

        REM The first argument is the range name.
        REM The second argument is a string that defines the formula
        REM or expression to be used.
        REM The third argument specifies the base address for
        REM relative cell references.
        REM The fourth argument is a set of flags that define
        REM how the range is used, but most ranges use 0.
REM The fourth argument uses values from the 
REM NamedRangeFlag constants.
s$ = "$Sheet1.$B$3:$D$6"
oRanges.addNewByName(sName$, s$, oCellAddress, 0)
End If
REM Get the created named range.
oRange = ThisComponent.NamedRanges.getByName(sName$)
REM Print the string contained in cell $Sheet1.$B$3
oCell = oRange.getReferredCells().getCellByPosition(0,0)
Print oCell.getString()
End Sub

Using relative references with named expressions

If a named range uses any cell addresses that are not absolute, then these addresses will be
referenced relative to the range's base address, which is defined by the third argument of the
addNewByName method, Position. This behavior is illustrated in Listing 14, where the macro
AddNamedFunction creates the named expression AddLeft. This expression references the
equation A3+B3 with C3 as its base address. Because relative references are being used, AddLeft
sums the values of the two cells directly to the left of any cell containing the equation =AddLeft.
For example, if AddLeft is referenced in cell E5, then it will sum the values in C5 and D5 (Figure
430).

Note

For more information about absolute and relative references, see Chapter 7, Formulas
and Functions.

Listing 14: AddNamedFunction creates the AddLeft named formula expression

Sub AddNamedFunction()
    Dim oSheet          'Sheet that contains the range oRange.
    Dim oCellAddress    'Address for relative references.
    Dim oRanges         'The NamedRanges property.
    Dim oRange          'Single cell range.
    Dim sName As String 'Name of the equation to create.

    sName = "AddLeft"
    oRanges = ThisComponent.NamedRanges
    If NOT oRanges.hasByName(sName) Then
        oSheet = ThisComponent.getSheets().getByIndex(0)
        oRange = oSheet.getCellRangeByName("C3")
        oCellAddress = oRange.getCellAddress()
        oRanges.addNewByName(sName, "A3+B3", oCellAddress, 0)
    End If
End Sub
End If
End Sub

<p>| | | | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>E5</td>
<td></td>
<td></td>
<td>=AddLeft</td>
<td></td>
</tr>
</tbody>
</table>

<p>| | | | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>5</td>
<td>12</td>
<td>30</td>
<td></td>
<td>42</td>
</tr>
</tbody>
</table>

Figure 430: AddLeft sums the values from C5 and D5 in E5

Listing 14 illustrates another little-known attribute of Calc: named ranges are a subset of named expressions, which can include formulas as well.

**Creating named ranges using row or column headers**

With the *Create Names* tool, which is accessed by selecting **Sheet > Named Ranges and Expressions > Create** from the Menu bar (Figure 431), you can create multiple named ranges simultaneously from the headers of a table. These headers can be drawn from the table’s borders – top and bottom rows and left and right columns – and each row or column that corresponds to each header are used to create the named ranges themselves. For example, if you choose to create ranges from headers contained in the top row of a table, each range will be generated from the individual columns that correspond to each header label.

**Note**

Header cells are not included in the named ranges generated using the *Create Names* tool. This is because the labels in each of these cell are used to name the ranges.

**Creating named ranges from labels using macros.**

In addition to the *Create Names* dialog, named ranges can be generated from labels using the macro method *addNewFromTitles*:
addNewFromTitles(Source, Border)

Creates named ranges from column or row headers. This method has two arguments:

- **Source** – The cell range address of the named range to be created
- **Border** – Is a enumeration value that specifies the location of the header labels. This enumeration has one of four possible values (Table 12):

<table>
<thead>
<tr>
<th>Enumerator</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>TOP</td>
<td>Selects the top border row.</td>
</tr>
<tr>
<td>BOTTOM</td>
<td>Selects the bottom border row.</td>
</tr>
<tr>
<td>RIGHT</td>
<td>Selects the right border column.</td>
</tr>
<tr>
<td>LEFT</td>
<td>Selects the left border column.</td>
</tr>
</tbody>
</table>

**Table 12**: com.sun.star.sheet.Border enumeration values

To generate names from multiple borders, you must call `addNewFromTitles` for each header row or column that you wish to use.

The macro in Listing 15 creates three named ranges using headers from the top row of the range A1:C20 (Figure 432). Figure 433 shows the resulting ranges listed in the Manage Names dialog, which is accessed by selecting **Sheet > Named Ranges and Expressions > Manage**.

![Table](image)

**Listing 15**: AddManyNamedRanges creates named ranges using labeled columns

```vba
Sub AddManyNamedRanges()
    Dim oSheet    'Sheet that contains the named range.
    Dim oAddress  'Range address.
    Dim oRanges   'The NamedRanges property.
```

398 | Associating a range with a name
Dim oRange 'Single cell range.

oRanges = ThisComponent.NamedRanges
oS = ThisComponent.getSheets().getByIndex(0)

oRange = oS.getCellRangeByName("A1:C20")
oAddress = oRange.getRangeAddress()
oRanges.addNewFromTitles(oAddress, com.sun.star.sheet.Border.TOP)
End Sub

<table>
<thead>
<tr>
<th>Name</th>
<th>Range or formula expression</th>
<th>Scope</th>
</tr>
</thead>
<tbody>
<tr>
<td>X</td>
<td>$Sheet1:$A2:$F$33</td>
<td>Document (Global)</td>
</tr>
<tr>
<td>X_2</td>
<td>$Sheet1:$BS2:$BS20</td>
<td>Document (Global)</td>
</tr>
<tr>
<td>X_3</td>
<td>$Sheet1:$C$2:$C$20</td>
<td>Document (Global)</td>
</tr>
</tbody>
</table>

Figure 433: Manage Names dialog with generated named ranges

Caution

Avoid giving multiple rows or columns the same label, as the ranges generated from them will likewise share the same name, and can end up being overwritten by Calc.

Database ranges

Although it can be used like a regular named range, a database range is, unsurprisingly, meant to be used like a database table, with each row representing a record and each cell as fields within each record. Specifically, a database range differs from a named range in the following ways:

- A database range cannot be a formula expression, only a cell range. This range can be formatted as a table, with the first row reserved for headings and the last row for subtotals. Cell formatting can also be preserved for each field in the table.
- Database ranges cannot be referenced relative to a base address within a worksheet.
- Database ranges store sorting, filtering, subtotaling, and data import settings in data structures called descriptors, which can be retrieved and accessed using macros.
- A database range can be linked to an external database source, and can be refreshed by selecting Data > Refresh Range from the Menu bar. Registering and linking to external database sources are explained in more detail in Chapter 10, Linking Calc Data.
- Database ranges can be created, modified, and deleted using the Define Database Range dialog, which is opened by selecting Data > Define Range from the Menu bar (Figure 434).
To create a database range:

1) Select a range of cells from a worksheet.

2) Open the Define Database Range dialog by using Data > Define Range.

3) Type a name for the range in the Name field. Only use letters, numbers, and underscores; spaces, hyphens, and other characters are not allowed.

4) Click on the plus (+) sign next to the Options to expand this section and view and select the following options:
   - Contains column labels – Denotes whether the top row is reserved for field headings.
   - Insert or delete cells – If active, this option will insert new rows and columns into the database range when new records are added to its source. Only works if an external database source is linked to the range. To manually update the database range, use Data > Refresh Range.
   - Keep formatting – Applies the existing cell formats of the first data row to the whole database range.
   - Don’t save imported data – If selected, this option only saves a reference to the source database; the contents of the range’s cells are not preserved.
   - Source – Displays information about the current database source, if one exists.
   - Operations – Denotes what operations, such as sorting or filtering, have been applied to the database range.

5) Click Add to add a range to the database range list under the Name field.

To modify an existing database range:
1) Select a range from the range list under the Name field or type its name into the Name field. The Add button will change to Modify at this point.

2) Make any modifications in the Range field and the Options section.

3) Click Modify to update the range.

To delete an existing database range, select it from the range list, then click Delete.

To select an existing database range from the current document, open the Select Database Range dialog by choosing Data > Select Range from the Menu bar (Figure 435). Next, select a range from the Ranges list and click OK. Calc will automatically highlight the range’s position in the worksheet in which it is located.

![Figure 435: Select DB Range dialog](image)

**Creating database ranges with macros**

In a macro, a database range is created, accessed, and deleted using the DatabaseRanges service. This service has many of the same methods as the NamedRanges service, but lacks the addNewFromTitles method. DatabaseRanges also uses a reduced version of the addNewByName method that lacks arguments for a relative base address and range type:

```
addNewByName(Name, Range)
```

Adds a new database range to the current document.

As an example of creating a range using this method, the macro in Listing 16 creates a database range named MyName and automatically applies auto filters to each of the range’s columns:

**Listing 16: AddNewDatabaseRange creates a database range and applies an auto filter**

```
Sub AddNewDatabaseRange()
    Dim oRange 'DatabaseRange object.
    Dim oAddr  'Cell address range for the database range.
    Dim oSheet 'First sheet, which will contain the range.
    Dim oDoc   'Reference ThisComponent with a shorter name.

    oDoc = ThisComponent
    If NOT oDoc.DatabaseRanges.hasByName("MyName") Then
        oSheet = ThisComponent.getSheets().getByIndex(0)
        oRange = oSheet.getCellRangeByName("A1:F10")
        oAddr = oRange.getRangeAddress()
```

*Database ranges | 401*
Sorting

Sorting is the process of rearranging data in a range or a worksheet according to a specified sort order. In Calc, sorting is commonly done using the Sort dialog, which is accessed by selecting Data > Sort from the Menu bar. How to use this dialog and its options is described in further detail in Chapter 2, Entering, Editing, and Formatting Data. Here, we present how to sort data in the context of macros.

Sorting a table using one column with a macro

In a Calc macro, data within a range is sorted by calling the sort() method on the range object. When a sort operation is called on a range, an array of properties known as a sort descriptor, is passed to the sort routine. Contained within a descriptor’s properties are sort fields, which are structures that inform Calc how to sort a range according to the data contained within one of its rows or columns.

As an example, the macro in Listing 17 sorts the grade sheet from Figure 427 according to average grade in descending order. The results are shown in Figure 437.

Listing 17: SortAverageGrade sorts the grade sheet data range (A1:H11) using a single column

```
Sub SortAverageGrade
    Dim oSheet
    Dim oRange
    Dim oSortFields(0) as new com.sun.star.util.SortField
    Dim oSortDesc(0) as new com.sun.star.beans.PropertyValue

    oSheet = ThisComponent.Sheets(0)
```
REM Set the range on which to sort
oRange = oSheet.getCellRangeByName("A1:H11")

REM Sort by the Average grade field in the range in descending order
oSortFields(0).Field = 7
oSortFields(0).SortAscending = FALSE

REM Set the sort fields to use
oSortDesc(0).Name = "SortFields"
oSortDesc(0).Value = oSortFields()

REM Now sort the range!
oRange.Sort(oSortDesc())

End Sub

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
<th>H</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Student</td>
<td>HW #1</td>
<td>HW #2</td>
<td>HW #3</td>
<td>Quiz #1</td>
<td>Quiz #2</td>
<td>Test #1</td>
<td>Average</td>
</tr>
<tr>
<td>2</td>
<td>Ian</td>
<td>100</td>
<td>100</td>
<td>91</td>
<td>90</td>
<td>100</td>
<td>96</td>
<td>96.17</td>
</tr>
<tr>
<td>3</td>
<td>Emily</td>
<td>100</td>
<td>100</td>
<td>81</td>
<td>100</td>
<td>75</td>
<td>94</td>
<td>91.67</td>
</tr>
<tr>
<td>4</td>
<td>Andrew</td>
<td>90</td>
<td>100</td>
<td>82</td>
<td>90</td>
<td>88</td>
<td>92</td>
<td>90.33</td>
</tr>
<tr>
<td>5</td>
<td>Bethany</td>
<td>95</td>
<td>100</td>
<td>82</td>
<td>80</td>
<td>88</td>
<td>93</td>
<td>89.67</td>
</tr>
<tr>
<td>6</td>
<td>Jennifer</td>
<td>85</td>
<td>93</td>
<td>73</td>
<td>80</td>
<td>100</td>
<td>90</td>
<td>86.83</td>
</tr>
<tr>
<td>7</td>
<td>Charles</td>
<td>80</td>
<td>93</td>
<td>73</td>
<td>80</td>
<td>75</td>
<td>84</td>
<td>80.83</td>
</tr>
<tr>
<td>8</td>
<td>Haley</td>
<td>85</td>
<td>93</td>
<td>82</td>
<td>70</td>
<td>75</td>
<td>76</td>
<td>80.17</td>
</tr>
<tr>
<td>9</td>
<td>David</td>
<td>75</td>
<td>86</td>
<td>91</td>
<td>40</td>
<td>88</td>
<td>79</td>
<td>76.50</td>
</tr>
<tr>
<td>10</td>
<td>Ferdinand</td>
<td>85</td>
<td>93</td>
<td>73</td>
<td>60</td>
<td>50</td>
<td>72</td>
<td>72.17</td>
</tr>
<tr>
<td>11</td>
<td>Georgia</td>
<td>70</td>
<td>80</td>
<td>55</td>
<td>30</td>
<td>75</td>
<td>67</td>
<td>64.33</td>
</tr>
<tr>
<td>12</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Figure 437: Grading sheet after sorting by average grade in descending order

**Sorting a table using multiple columns**

As with the *Sort* dialog, a range can be sorted using up to three columns or rows in a macro. Sorting with extra columns or rows is as easy as adding extra sort fields to a sort descriptor. The macro in Listing 18 again uses the grade sheet example from Figure 427 to illustrate how to sort by two columns. Figure 438 shows the results of this operation – note that records are sorted first by Quiz #1 scores, then Quiz #2 scores.

**Listing 18: SortByQuizScores sorts the grade sheet data range (A1:H11) using two columns**

Sub SortByQuizScores
    Dim oSheet
    Dim oRange
    Dim oSortFields(1) as new com.sun.star.util.SortField
    Dim oSortDesc(0) as new com.sun.star.beans.PropertyValue

    oSheet = ThisComponent.Sheets(0)
REM Set the range on which to sort
oRange = oSheet.getCellRangeByName("A1:H11")

REM Sort by the Quiz #1 field in the range
oSortFields(0).Field = 4
oSortFields(0).SortAscending = True
oSortFields(0).FieldType = com.sun.star.util.SortFieldDataType.NUMERIC

REM Sort by the Quiz #2 field in the range
oSortFields(1).Field = 5
oSortFields(1).SortAscending = True
oSortFields(1).FieldType = com.sun.star.util.SortFieldDataType.ALPHANUMERIC

REM Set the sort fields to use
oSortDesc(0).Name = "SortFields"
oSortDesc(0).Value = oSortFields()

REM Now sort the range!
oRange.Sort(oSortDesc())
End Sub

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
<th>H</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Student</td>
<td>HW #1</td>
<td>HW #2</td>
<td>HW #3</td>
<td>Quiz #1</td>
<td>Quiz #2</td>
<td>Test #1</td>
<td>Average</td>
</tr>
<tr>
<td>2</td>
<td>Georgia</td>
<td>70</td>
<td>80</td>
<td>55</td>
<td>39</td>
<td>75</td>
<td>67</td>
<td>64.33</td>
</tr>
<tr>
<td>3</td>
<td>David</td>
<td>75</td>
<td>86</td>
<td>91</td>
<td>40</td>
<td>88</td>
<td>79</td>
<td>76.50</td>
</tr>
<tr>
<td>4</td>
<td>Ferdinand</td>
<td>85</td>
<td>93</td>
<td>73</td>
<td>60</td>
<td>50</td>
<td>72</td>
<td>72.17</td>
</tr>
<tr>
<td>5</td>
<td>Haley</td>
<td>85</td>
<td>93</td>
<td>82</td>
<td>70</td>
<td>75</td>
<td>76</td>
<td>80.17</td>
</tr>
<tr>
<td>6</td>
<td>Charles</td>
<td>80</td>
<td>93</td>
<td>73</td>
<td>80</td>
<td>75</td>
<td>84</td>
<td>80.83</td>
</tr>
<tr>
<td>7</td>
<td>Bethany</td>
<td>95</td>
<td>100</td>
<td>82</td>
<td>80</td>
<td>88</td>
<td>93</td>
<td>89.67</td>
</tr>
<tr>
<td>8</td>
<td>Jennifer</td>
<td>85</td>
<td>93</td>
<td>73</td>
<td>80</td>
<td>100</td>
<td>90</td>
<td>86.83</td>
</tr>
<tr>
<td>9</td>
<td>Andrew</td>
<td>90</td>
<td>100</td>
<td>82</td>
<td>90</td>
<td>88</td>
<td>92</td>
<td>90.33</td>
</tr>
<tr>
<td>10</td>
<td>Ian</td>
<td>100</td>
<td>100</td>
<td>91</td>
<td>90</td>
<td>100</td>
<td>96</td>
<td>96.17</td>
</tr>
<tr>
<td>11</td>
<td>Emily</td>
<td>100</td>
<td>100</td>
<td>81</td>
<td>100</td>
<td>75</td>
<td>94</td>
<td>91.67</td>
</tr>
<tr>
<td>12</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Figure 438: Grading sheet sorted by quiz scores in ascending order

Retrieving sorting information from a range

You can use the method `createSortDescriptor()` to retrieve the sorting information for a given cell range. If this method is called on a database range, it will create a sort descriptor using the sorting information stored with that range. On the other hand, if `createSortDescriptor` is called on a standard named range or an unnamed range, it will generate a sort descriptor with default properties. In either case, the newly-generated sort descriptor can be modified and passed as an argument to a sort routine called on a given range.
The macro in Listing 19 demonstrates how to generate and display the sorting information associated with a range. The output of this macro is displayed in Figure 439.

Listing 19: DisplaySortDescriptor displays sort descriptor properties in a dialog

Sub DisplaySortDescriptor
    On Error Resume Next
    Dim oSheet
    Dim oRange       ' A range is needed to create the sort descriptor.
    Dim oSortDescript
    Dim i%
    Dim s$
    Dim oDoc          'Reference newly created calc document.
    oDoc = StarDesktop.loadComponentFromURL("private:factor/scalc", "_default", 0, Array())
    oSheet = oDoc.Sheets(0)
    oRange = oSheet.getCellRangeByName("B28:D33")
    oSortDescript = oRange.createSortDescriptor()
    For i = LBound(oSortDescript) To UBound(oSortDescript)
        s = s & oSortDescript(i).Name & " = 
        s = s & oSortDescript(i).Value
        s = s & CHR$(10)
    Next
    MsgBox s, 0, "Sort Descriptor"
End Sub

Figure 439: Sort descriptor info

Filtering

A filter is a tool that hides or displays records within a worksheet based on a set of filtering criteria. Similar to sorting, filters are useful for narrowing down long lists of data in order to find particular data items. In Calc, three types of filter exist:
• AutoFilters
• Standard filters
• Advanced filters.

Filters are also described in Chapter 2, Entering, Editing, and Formatting Data.

**AutoFilter**

AutoFilters are the most straightforward of the three filter types, and work by inserting a combo box into one or more data columns (Figure 440). To add an AutoFilter to one or more columns, simply select the columns, then select Data > AutoFilter from the Menu bar. To access the AutoFilter combo box for a column, click on the down-arrow button in the first cell of that column.

![AutoFilter combo box](image)

To remove an AutoFilter, select the columns again and click on Data > AutoFilter. Each combo box and down-arrow button will disappear. In this way, the menu option acts like a toggle for AutoFilters.

Each AutoFilter combo box has the following set up of criteria:

- A basic sort can be applied using the Sort Ascending or Sort Descending options.
- The Standard Filter option opens the Standard Filter dialog (Figure 441) and automatically sets the current field as the field for the first condition in the dialog.
- Selecting Empty hides all non-empty rows that contain a value in the current column. Likewise, selecting Non-Empty hides all non-empty rows that lack a value in the current column. Entirely empty rows are ignored.
- Selecting the Top 10 filter causes the ten rows with the largest value to be displayed. More than ten rows may be displayed if there are more than ten instances of the largest value in a column. For example, if there are eleven students with a perfect score of 100, then the filter will display all eleven instances.
- Check the All box to display or hide all values in the current column.
The auto filter creates entries for each unique value in the current column. These values can be filtered simply by checking off any of the check boxes next to each entry.

**Toggling AutoFilters with a macro**

Database ranges in Calc contain an AutoFilter boolean flag that allows you to toggle auto filters on or off. The macro from Listing 16 demonstrates how to do this.

**Standard filters**

Standard filters are more complex than AutoFilters, and allow for up to eight filter conditions. Also, unlike AutoFilters, standard filters use a dialog (Figure 441), which is accessed by selecting Data > Filter > Standard Filter from the Menu bar.

![Figure 441: Standard Filter dialog](image)

For more information on how to use this dialog and its options, see Chapter 2, Entering, Editing, and Formatting Data.

**Creating standard filters with macros**

In a macro, filtering a data range is performed by calling the `filter()` routine either on range or the worksheet in which the range is contained. Like a sort descriptor, a filter descriptor contains the filter settings for the current worksheet, such as whether the first row or column in the sheet contains headers which should not be filtered. A filter descriptor can be generated by calling the `createFilterDescriptor()` method on a worksheet or on a cell range:

```vba
createFilterDescriptor(Empty)
```

Creates a filter descriptor. If the boolean flag `Empty` is set to TRUE, then an empty filter descriptor is created. If `Empty` is FALSE, then the descriptor is filled with the previous settings of the current object (such as a database range).

As with sort descriptors, filter descriptors can be created using this method, then modified and passed as an argument to the `filter` method. The macro in Listing 20 demonstrates this process by creating a simple standard filter for the first worksheet in a workbook. Figure 442 display the results of filtering the grading sheet example in Figure 427:

**Listing 20: SimpleSheetFilter creates a simple standard filter**

```vba
Sub SimpleSheetFilter()
```
Dim oSheet ' Sheet that will contain the filter.
Dim oFilterDesc ' Filter descriptor.
Dim oFields(0) As New com.sun.star.sheet.TableFilterField

oSheet = ThisComponent.getSheets().getByIndex(0)

REM If argument is True, creates an empty filter descriptor. If argument is False, create a
REM descriptor with the previous settings.
oFilterDesc = oSheet.createFilterDescriptor(True)

With oFields(0)
    REM You could use the Connection property to indicate
    REM how to connect to the previous field. This is
    REM the first field, so this is not required.
    '.Connection = com.sun.star.sheet.FilterConnection.AND
    '.Connection = com.sun.star.sheet.FilterConnection.OR

    REM The Field property is the zero based column
    REM number to filter. If you have the cell, you
    .Field = 5 ' The Quiz #2 grades field

    REM Compare using a numeric or a string?
    .IsNumeric = True

    REM The NumericValue property is used
    REM because .IsNumeric = True from above.
    .NumericValue = 80

    REM If IsNumeric was False, then the
    REM StringValue property would be used.
    REM .StringValue = "what ever"

    REM Valid operators include EMPTY, NOT_EMPTY, EQUAL,
    REM NOT_EQUAL, GREATER, GREATER_EQUAL, LESS,
    REM LESS_EQUAL, TOP_VALUES, TOP_PERCENT,
    REM BOTTOM_VALUES, and BOTTOM_PERCENT
End With
REM The filter descriptor supports the following properties: IsCaseSensitive, SkipDuplicates,
REM UseRegularExpressions,
REM SaveOutputPosition, Orientation, ContainsHeader,
REM CopyOutputData, OutputPosition, and MaxFieldCount.

oFilterDesc.setFilterFields(oFields())
oFilterDesc.ContainsHeader = True
oSHEET.filter(oFilterDesc)

End Sub

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
<th>H</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Student</td>
<td>HW #1</td>
<td>HW #2</td>
<td>HW #3</td>
<td>Quiz #1</td>
<td>Quiz #2</td>
<td>Test #1</td>
<td>Average</td>
</tr>
<tr>
<td>7</td>
<td>Bethany</td>
<td>95</td>
<td>100</td>
<td>82</td>
<td>80</td>
<td>88</td>
<td>93</td>
<td>89.67</td>
</tr>
<tr>
<td>8</td>
<td>Jennifer</td>
<td>85</td>
<td>93</td>
<td>73</td>
<td>80</td>
<td>100</td>
<td>90</td>
<td>86.83</td>
</tr>
<tr>
<td>10</td>
<td>Ian</td>
<td>100</td>
<td>100</td>
<td>91</td>
<td>90</td>
<td>100</td>
<td>96</td>
<td>96.17</td>
</tr>
</tbody>
</table>

Figure 442: Grading sheet filtered by Quiz #2 values greater than 80

Note
When the filter method is called on a sheet, every empty row in the sheet is hidden. When filter is called on a range, only empty rows in the range itself are hidden.

Clearing all filters for a worksheet
When a filter is applied to a worksheet, it replaces any existing filter for that sheet. Therefore, to remove a filter in a sheet, simply create and set an empty filter for that sheet (Listing 21).

Listing 21: RemoveSheetFilter removes the current sheet filter by setting an empty filtered sheet

Sub RemoveSheetFilter()
    Dim oSheet ' Sheet to filter.
    Dim oFilterDesc ' Filter descriptor.

    oSheet = ThisComponent.getSheets().getByIndex(0)
oFilterDesc = oSheet.createFilterDescriptor(True)
oSheet.filter(oFilterDesc)
End Sub

Filtering multiple columns and filtering with regular expressions
The macro in Listing 22 demonstrates a filter that filters two columns and uses regular expressions. Note that the filter method is called on a range rather than its worksheet in this example. Figure 443 displays the results of this macro on the grading sheet example in Figure 427.

Listing 22: SimpleRangeFilter uses two columns

Sub SimpleRangeFilter()
    Dim oSheet ' Sheet to filter.

Dim oRange          ' Range to be filtered.
Dim oFilterDesc     ' Filter descriptor.
Dim oFields(1) As New com.sun.star.sheet.TableFilterField

oSheet = ThisComponent.getSheets().getByIndex(0)
oRange = oSheet.getCellRangeByName("A1:H11")

REM If argument is True, creates an
REM empty filter descriptor.
oFilterDesc = oRange.createFilterDescriptor(True)

REM Setup a field to view cells with content that
REM start with the letter B.
With oFields(0)
    .Field = 0              ' Filter column A (Student names).
    .IsNumeric = False      ' Use a string, not a number.
    .StringValue = "b.*"    ' Every name starting with a B.
End With

REM Set up a field that requires at least one of the conditions.
REM This new condition requires a value less than or
REM equal to 90.
With oFields(1)
    .Connection = com.sun.star.sheet.FilterConnection.OR
    .Field = 6              ' Filter column G (Test #1 grades).
    .IsNumeric = True       ' Use a number
    .NumericValue = 90      ' Scores less than 90
End With

oFilterDesc.setFilterFields(oFields())
oFilterDesc.ContainsHeader = True
oFilterDesc.UseRegularExpressions = True
oRange.filter(oFilterDesc)
End Sub
Advanced filters

In Calc, the criteria for an advanced filter are stored in a worksheet rather than entered into a dialog. As a result, you must first set up a cell range that contains the criteria before you use the Advanced Filter dialog (Figure 444).

To set up a criteria range:

1) Copy the column headings of the range to be filtered to an empty space in a worksheet. It does not need to be the same worksheet as the one with the source range.

2) Enter filter criteria underneath the column headings in the criteria range. Each individual criterion in the same row is connected with AND, while the criteria groups from each row are connected with OR. Empty cells are ignored. Up to eight criteria rows may be defined for a filter.

After creating a criteria range, set up an advanced filter as follows:

1) Select the cell range that you wish to filter.

2) Go to Data > More Filters > Advanced Filter in the Menu bar to open the Advanced Filter dialog (Figure 444).

3) In the Read Filter Criteria From field, enter the address for a named range, either by selecting a named range from the drop-down box, typing in a reference, or selecting cells from a worksheet. Remember to use the Shrink / Expand button if you need to temporarily minimize the dialog while selecting cells.

4) Click OK to apply the filter and close the dialog.

Advanced filter options are the same as standard filter options, and are described in further detail in Chapter 2, Entering, Editing, and Formatting Data.
**Advanced filter example**

Figure 445 demonstrates an example filter range for the grading sheet example in Figure 427:

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
<th>H</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Student</td>
<td>HW #1</td>
<td>HW #2</td>
<td>HW #3</td>
<td>Quiz #1</td>
<td>Quiz #2</td>
<td>Test #1</td>
<td>Average</td>
</tr>
<tr>
<td>2</td>
<td>Ferdinand</td>
<td>&gt;75</td>
<td>&gt;75</td>
<td>&gt;75</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>Ferdinand</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Figure 445: Advanced filter criteria range (in Sheet 2)

In this range, there are two criteria groups: the first displays the records of students who scored above a 75% in every homework, and the second displays records of any student named Ferdinand. Figure 446 displays the result of this filter operation using these criteria:

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
<th>H</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Student</td>
<td>HW #1</td>
<td>HW #2</td>
<td>HW #3</td>
<td>Quiz #1</td>
<td>Quiz #2</td>
<td>Test #1</td>
<td>Average</td>
</tr>
<tr>
<td>2</td>
<td>Andrew</td>
<td>90</td>
<td>100</td>
<td>82</td>
<td>90</td>
<td>88</td>
<td>92</td>
<td>90.33</td>
</tr>
<tr>
<td>3</td>
<td>Bethany</td>
<td>95</td>
<td>100</td>
<td>82</td>
<td>80</td>
<td>88</td>
<td>93</td>
<td>89.67</td>
</tr>
<tr>
<td>6</td>
<td>Emily</td>
<td>100</td>
<td>100</td>
<td>81</td>
<td>100</td>
<td>75</td>
<td>94</td>
<td>91.67</td>
</tr>
<tr>
<td>7</td>
<td>Ferdinand</td>
<td>85</td>
<td>93</td>
<td>73</td>
<td>60</td>
<td>50</td>
<td>72</td>
<td>72.17</td>
</tr>
<tr>
<td>9</td>
<td>Haley</td>
<td>85</td>
<td>93</td>
<td>82</td>
<td>70</td>
<td>75</td>
<td>76</td>
<td>80.17</td>
</tr>
<tr>
<td>10</td>
<td>Ian</td>
<td>100</td>
<td>100</td>
<td>91</td>
<td>90</td>
<td>100</td>
<td>96</td>
<td>96.17</td>
</tr>
<tr>
<td>12</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Figure 446: Grading sheet example filtered using an advanced filter

**Using an advanced filter with macros**

Applying an advanced filter with a macro works similarly to setting up a standard filter. The key difference is that the cell range containing the filter criteria is used to create the filter descriptor. The macro in Listing 23 demonstrates how this is done using the `createFilterDescriptorByObject` method. It uses the grading sheet example in Figure 427 as the data range and the range in Figure 445 as the criteria range. The results should be the same as those found in Figure 446:

**Listing 23: AdvancedRangeFilter creates a file descriptor from the filter criteria range**

```
Sub AdvancedRangeFilter()
    Dim oSheet 'A sheet from the Calc document.
    Dim oRanges 'The NamedRanges property.
    Dim oCritRange 'Range that contains the filter criteria.
    Dim oDataRange 'Range that contains the data to filter.
    Dim oFiltDesc 'Filter descriptor.

    REM Range that contains the filter criteria
    oSheet = ThisComponent.getSheets().getIndex(1)
    oCritRange = oSheet.getCellRangeByName("A1:H3")

    REM You can also obtain the range containing the
    REM filter criteria from a named range.
    REM oRanges = ThisComponent.NamedRanges
    REM oRange = oRanges.getByName("AverageLess80")
    REM oCritRange = oRange.getReferredCells()
```

412 | Filtering
The data that you want to filter

```vba
oSHEET = ThisComponent.getSheets().getByIndex(0)
oDataRange = oSheet.getCellRangeByName("A1:H11")

oFiltDesc = oCritRange.createFilterDescriptorByObject(oDataRange)
oDataRange.filter(oFiltDesc)
```

End Sub

Table 13 contains a list of properties that correspond to advanced (and standard) filter settings:

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ContainsHeader</td>
<td>Boolean (TRUE/FALSE) that specifies if the first row or column contains headers which should not be filtered.</td>
</tr>
<tr>
<td>CopyOutputData</td>
<td>Boolean that specifies if the filtered data should be copied to another position in the document.</td>
</tr>
<tr>
<td>IsCaseSensitive</td>
<td>Boolean that specifies if the case of letters is important when comparing entries.</td>
</tr>
<tr>
<td>Orientation</td>
<td>An enumeration that specifies if a range is filtered by column or row: Column – com.sun.star.table.TableOrientation.COLUMNS Row – com.sun.star.table.TableOrientation.ROWS</td>
</tr>
<tr>
<td>OutputPosition</td>
<td>If CopyOutputData is TRUE, this property specifies the position where filtered data are to be copied.</td>
</tr>
<tr>
<td>SaveOutputPosition</td>
<td>Boolean that specifies if the OutputPosition position is saved for future calls.</td>
</tr>
<tr>
<td>SkipDuplicates</td>
<td>Boolean that specifies if duplicate entries are left out of the result.</td>
</tr>
<tr>
<td>UseRegularExpressions</td>
<td>Boolean that specifies if the filter strings are interpreted as regular expressions.</td>
</tr>
</tbody>
</table>

**Copy advanced filter results to a different location**

The results of an advanced filter can be extracted to a different position using the OutputPosition property. Copying results in this way eliminates the need for Calc to hide rows that do not match search criteria, which it would normally do if you filter in-place.

The macro code snippet in Listing 24 demonstrates how to copy filter results to a different location, and Figure 447 shows the results when this snippet is applied to the macro in Listing 23 just before the filter method is called. Note that the filter descriptor must first be modified before these filter settings are applied.

**Listing 24: A code snippet that copies filtered results to a different locations**

```vba
REM Copy the output data rather than filter in place.
oFiltDesc.CopyOutputData = True

REM Create a CellAddress and set it for Sheet1
REM Column B, Row 13 (remember, start counting with 0)
Dim outputCell As New com.sun.star.table.CellAddress
```

*Advanced filters* | 413
outputCell.Sheet = 0
outputCell.Column = 1
outputCell.Row = 12
oFiltDesc.OutputPosition = outputCell

**Note**

The *OutputPosition* property returns a copy of a struct. As a result, it is not possible to set individual values, such as the row or column, directly through this property. For example, `oFilterDesc.OutputPosition.Row = 2` will not work, since it is the Row property on the copy, not the original, that changes.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
<th>H</th>
<th>I</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td><strong>Student</strong></td>
<td><strong>HW #1</strong></td>
<td><strong>HW #2</strong></td>
<td><strong>HW #3</strong></td>
<td><strong>Quiz #1</strong></td>
<td><strong>Quiz #2</strong></td>
<td><strong>Test #1</strong></td>
<td><strong>Average</strong></td>
</tr>
<tr>
<td>1</td>
<td>Andrew</td>
<td>90</td>
<td>100</td>
<td>82</td>
<td>90</td>
<td>82</td>
<td>90</td>
<td>90.33</td>
</tr>
<tr>
<td>2</td>
<td>Bethany</td>
<td>95</td>
<td>100</td>
<td>82</td>
<td>80</td>
<td>88</td>
<td>92</td>
<td>89.67</td>
</tr>
<tr>
<td>3</td>
<td>Charles</td>
<td>80</td>
<td>93</td>
<td>73</td>
<td>80</td>
<td>75</td>
<td>84</td>
<td>80.83</td>
</tr>
<tr>
<td>4</td>
<td>David</td>
<td>75</td>
<td>86</td>
<td>91</td>
<td>40</td>
<td>88</td>
<td>79</td>
<td>76.50</td>
</tr>
<tr>
<td>5</td>
<td>Emily</td>
<td>100</td>
<td>100</td>
<td>81</td>
<td>100</td>
<td>75</td>
<td>94</td>
<td>91.67</td>
</tr>
<tr>
<td>6</td>
<td>Ferdinand</td>
<td>85</td>
<td>93</td>
<td>73</td>
<td>60</td>
<td>50</td>
<td>72</td>
<td>72.17</td>
</tr>
<tr>
<td>7</td>
<td>Georgia</td>
<td>70</td>
<td>80</td>
<td>55</td>
<td>39</td>
<td>75</td>
<td>67</td>
<td>64.33</td>
</tr>
<tr>
<td>8</td>
<td>Haley</td>
<td>85</td>
<td>93</td>
<td>82</td>
<td>70</td>
<td>75</td>
<td>76</td>
<td>80.17</td>
</tr>
<tr>
<td>9</td>
<td>Ian</td>
<td>100</td>
<td>100</td>
<td>91</td>
<td>90</td>
<td>100</td>
<td>96</td>
<td>96.17</td>
</tr>
<tr>
<td>10</td>
<td>Jennifer</td>
<td>85</td>
<td>93</td>
<td>73</td>
<td>80</td>
<td>100</td>
<td>90</td>
<td>88.83</td>
</tr>
<tr>
<td>11</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>12</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>13</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>14</td>
<td>Andrew</td>
<td>90</td>
<td>100</td>
<td>82</td>
<td>90</td>
<td>88</td>
<td>92</td>
<td>90.33</td>
</tr>
<tr>
<td>15</td>
<td>Bethany</td>
<td>95</td>
<td>100</td>
<td>82</td>
<td>80</td>
<td>88</td>
<td>93</td>
<td>89.67</td>
</tr>
<tr>
<td>16</td>
<td>Emily</td>
<td>100</td>
<td>100</td>
<td>81</td>
<td>100</td>
<td>75</td>
<td>94</td>
<td>91.67</td>
</tr>
<tr>
<td>17</td>
<td>Ferdinand</td>
<td>85</td>
<td>93</td>
<td>73</td>
<td>60</td>
<td>50</td>
<td>72</td>
<td>72.17</td>
</tr>
<tr>
<td>18</td>
<td>Haley</td>
<td>85</td>
<td>93</td>
<td>82</td>
<td>70</td>
<td>75</td>
<td>76</td>
<td>80.17</td>
</tr>
<tr>
<td>19</td>
<td>Ian</td>
<td>100</td>
<td>100</td>
<td>91</td>
<td>90</td>
<td>100</td>
<td>96</td>
<td>96.17</td>
</tr>
</tbody>
</table>

![Figure 447](image)

**Useful database-like functions**

Calc has many functions that are often used in the context of databases. Some of these functions are straightforward to use (like SUM) or are familiar in the context in which they are typically used (like STDEV for statistics). A few, like the LOOKUP functions, are somewhat more infrequently used, but are nevertheless useful to know if you plan to use Calc for database tables. This section provides a condensed list of these functions. Further reference material for them can be found in Chapter 18, *Description of Functions*, and in the online Help at [http://help.libreoffice.org/](http://help.libreoffice.org/).

**Note**

Functions with the suffix -A treat text values as a number with the value of zero. Blank cells are still ignored by these functions.
<table>
<thead>
<tr>
<th>Function</th>
<th>Category</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>AVERAGE</td>
<td>Statistical</td>
<td>Returns the average of its arguments. Ignores empty cells and cells that contain text.</td>
</tr>
<tr>
<td>AVERAGEA</td>
<td>Statistical</td>
<td>Returns the average of its arguments, but only ignores empty cells. The value of text is 0.</td>
</tr>
<tr>
<td>AVERAGEIF</td>
<td>Statistical</td>
<td>Returns the arithmetic mean of all cells in a range that satisfy a given condition.</td>
</tr>
<tr>
<td>AVERAGEIFS</td>
<td>Statistical</td>
<td>Returns the arithmetic mean of all cells in a range that satisfy given multiple criteria.</td>
</tr>
<tr>
<td>COUNT</td>
<td>Statistical</td>
<td>Counts the number of numeric values in a list of arguments. Ignores empty cells and cells that contain text.</td>
</tr>
<tr>
<td>COUNTA</td>
<td>Statistical</td>
<td>Counts the number of values in a list of arguments, but counts both numeric and text arguments. Empty cells are still ignored.</td>
</tr>
<tr>
<td>COUNTBLANK</td>
<td>Statistical</td>
<td>Returns the number of empty cells within a range.</td>
</tr>
<tr>
<td>COUNTIF</td>
<td>Statistical</td>
<td>Returns the number of cells in a range that meet the specified search criteria.</td>
</tr>
<tr>
<td>COUNTIFS</td>
<td>Statistical</td>
<td>Returns the number of cells that meet criteria in multiple ranges.</td>
</tr>
<tr>
<td>HLOOKUP</td>
<td>Spreadsheet</td>
<td>Searches for a “look-up” value in the first row of an array and returns a value from a different row in the same column.</td>
</tr>
<tr>
<td>INDEX</td>
<td>Spreadsheet</td>
<td>Returns the contents of a cell at a specified index (denoted by row and column numbers) within a range.</td>
</tr>
<tr>
<td>INDIRECT</td>
<td>Spreadsheet</td>
<td>Returns the reference specified by a text string.</td>
</tr>
<tr>
<td>LOOKUP</td>
<td>Spreadsheet</td>
<td>Returns the contents of a cell contained within a single row or column of a range or from an array.</td>
</tr>
<tr>
<td>MATCH</td>
<td>Spreadsheet</td>
<td>Searches an array for an item and returns its relative position in the array.</td>
</tr>
<tr>
<td>MAX</td>
<td>Statistical</td>
<td>Returns the largest value in a list of arguments.</td>
</tr>
<tr>
<td>MAXA</td>
<td>Statistical</td>
<td>Returns the largest value in a list of arguments. The value of text is 0.</td>
</tr>
<tr>
<td>MAXIFS</td>
<td>Statistical</td>
<td>Returns the largest value in the cells of a range that meet multiple criteria in multiple ranges.</td>
</tr>
<tr>
<td>MEDIAN</td>
<td>Statistical</td>
<td>Returns the median of a list of numbers.</td>
</tr>
<tr>
<td>MIN</td>
<td>Statistical</td>
<td>Returns the smallest value in a list of arguments.</td>
</tr>
<tr>
<td>MINA</td>
<td>Statistical</td>
<td>Returns the smallest value in a list of arguments. The value of text is 0.</td>
</tr>
<tr>
<td>MINIFS</td>
<td>Statistical</td>
<td>Returns the smallest value in the cells of a range that meet multiple criteria in multiple ranges.</td>
</tr>
<tr>
<td>MODE</td>
<td>Statistical</td>
<td>Returns the most common value in a list of values.</td>
</tr>
<tr>
<td>Function</td>
<td>Category</td>
<td>Description</td>
</tr>
<tr>
<td>------------</td>
<td>----------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>OFFSET</td>
<td>Spreadsheet</td>
<td>Return the value of a cell offset by certain number of rows and columns from a given reference point.</td>
</tr>
<tr>
<td>PRODUCT</td>
<td>Mathematical</td>
<td>Multiples all the numbers in a list of arguments and returns the product.</td>
</tr>
<tr>
<td>STDEV</td>
<td>Statistical</td>
<td>Calculates the standard deviation of a population sample.</td>
</tr>
<tr>
<td>STDEV.S</td>
<td>Statistical</td>
<td>Calculates the standard deviation of a population sample. The value of text is 0.</td>
</tr>
<tr>
<td>STDEVA</td>
<td>Statistical</td>
<td>Calculates the standard deviation of a population sample. The value of text is 0.</td>
</tr>
<tr>
<td>STDEVP</td>
<td>Statistical</td>
<td>Calculates the standard deviation of an entire population.</td>
</tr>
<tr>
<td>STDEVPA</td>
<td>Statistical</td>
<td>Calculates the standard deviation of an entire population. The value of text is 0.</td>
</tr>
<tr>
<td>SUBTOTAL</td>
<td>Mathematical</td>
<td>Calculates the total of a subset of an array that is created using AutoFilters.</td>
</tr>
<tr>
<td>SUM</td>
<td>Statistical</td>
<td>Returns the sum of a list of values.</td>
</tr>
<tr>
<td>SUMIF</td>
<td>Statistical</td>
<td>Calculates the sum of values from cells that meet the specified search criteria.</td>
</tr>
<tr>
<td>SUMIFS</td>
<td>Statistical</td>
<td>Returns the sum of values from cells in a range that meet multiple criteria in multiple ranges.</td>
</tr>
<tr>
<td>VAR</td>
<td>Statistical</td>
<td>Calculates the variance of a population sample.</td>
</tr>
<tr>
<td>VAR.S</td>
<td>Statistical</td>
<td>Calculates the variance of a population sample. The value of text is 0.</td>
</tr>
<tr>
<td>VARA</td>
<td>Statistical</td>
<td>Calculates the variance of a population sample. The value of text is 0.</td>
</tr>
<tr>
<td>VARP</td>
<td>Statistical</td>
<td>Calculates the variance of an entire population.</td>
</tr>
<tr>
<td>VARP.P</td>
<td>Statistical</td>
<td>Calculates the variance of an entire population.</td>
</tr>
<tr>
<td>VARPA</td>
<td>Statistical</td>
<td>Calculates the variance of an entire population. The value of text is 0.</td>
</tr>
<tr>
<td>VLOOKUP</td>
<td>Spreadsheet</td>
<td>Searches for a “look-up” value in the first column of an array and returns a value from a different column in the same row.</td>
</tr>
</tbody>
</table>

**Database-specific functions**

Some Calc functions are specifically designed for use with a database table. With one exception (DGET), these functions are specialized forms of commonly-used functions such as COUNT, and all are denoted with the D- prefix (such as DAVERAGE). A brief list of these functions is given in Table 14, while more detailed descriptions are presented in Chapter 18, Description of Functions.

**Note**

Table 14 uses the following terms interchangeably: row and record; column and field.

**Table 14: Database functions in a Calc document**

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DAVERAGE</td>
<td>Returns the average of all fields that match the search criteria.</td>
</tr>
<tr>
<td>DCOUNT</td>
<td>Counts the number of records containing numeric data that match the search criteria.</td>
</tr>
</tbody>
</table>

416 | Useful database-like functions
<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DCOUNTA</td>
<td>Counts the number of records containing numeric or alphanumeric data that match the search criteria.</td>
</tr>
<tr>
<td>DGET</td>
<td>Returns the contents of a field that matches the specified search criteria.</td>
</tr>
<tr>
<td>DMAX</td>
<td>Returns the maximum value in a field for every record that matches the specified search criteria.</td>
</tr>
<tr>
<td>DMIN</td>
<td>Returns the minimum value in a field for every record that matches the specified search criteria.</td>
</tr>
<tr>
<td>DPRODUCT</td>
<td>Returns the product of all values in a field that match the search criteria.</td>
</tr>
<tr>
<td>DSTDEV</td>
<td>Calculates the standard deviation of all values in a field that match the search criteria. The values are treated as a sample.</td>
</tr>
<tr>
<td>DSTDEVP</td>
<td>Calculates the standard deviation of all values in a field that match the search criteria. The values are treated as an entire population.</td>
</tr>
<tr>
<td>DSUM</td>
<td>Sums all values in a field that match the search criteria.</td>
</tr>
<tr>
<td>DVAR</td>
<td>Calculates the variance of all values in a field that match the search criteria. The values are treated as a sample.</td>
</tr>
<tr>
<td>DVARP</td>
<td>Calculates the variance of all values in a field that match the search criteria. The values are treated as an entire population.</td>
</tr>
</tbody>
</table>
Chapter 14
Setting up and Customizing Calc
Copyright

This document is Copyright © 2018 by the LibreOffice Documentation Team. Contributors are listed below. You may distribute it and/or modify it under the terms of either the GNU General Public License (http://www.gnu.org/licenses/gpl.html), version 3 or later, or the Creative Commons Attribution License (http://creativecommons.org/licenses/by/4.0/), version 4.0 or later.

All trademarks within this guide belong to their legitimate owners.

Contributors

This book is adapted and updated from LibreOffice 4.1 Calc Guide.

To this edition
Jean Hollis Weber  Kees Kriek  Steve Fanning

To previous editions
Barbara Duprey  Jean Hollis Weber  Simon Brydon

Feedback

Please direct any comments or suggestions about this document to the Documentation Team’s mailing list: documentation@global.libreoffice.org

Note

Everything you send to a mailing list, including your email address and any other personal information that is written in the message, is publicly archived and cannot be deleted.

Publication date and software version

Published December 2019. Based on LibreOffice 6.2.

Note for macOS users

Some keystrokes and menu items are different on macOS from those used in Windows and Linux. The table below gives some common substitutions for the instructions in this book. For a more detailed list, see the application Help.

<table>
<thead>
<tr>
<th>Windows or Linux</th>
<th>macOS equivalent</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tools &gt; Options menu selection</td>
<td>LibreOffice &gt; Preferences</td>
<td>Access setup options</td>
</tr>
<tr>
<td>Right-click</td>
<td>Control+click and/or right-click depending on computer setup</td>
<td>Open a context menu</td>
</tr>
<tr>
<td>Ctrl (Control)</td>
<td>⌘ (Command)</td>
<td>Used with other keys</td>
</tr>
<tr>
<td>F5</td>
<td>⌘ +F5</td>
<td>Open the Navigator</td>
</tr>
<tr>
<td>F11</td>
<td>⌘ +T</td>
<td>Open the sidebar Styles deck</td>
</tr>
</tbody>
</table>
Introduction

This chapter briefly presents some of the setup options found under Tools > Options on the Menu bar. Additional options, and more details about the ones given here, are covered in the Help and in Chapter 2, Setting up LibreOffice, in the Getting Started Guide.

This chapter also describes some common customizations to menus, toolbars, and keyboard shortcuts. Other customizations are made easy by extensions that you can install from the LibreOffice website or from other providers.

LibreOffice options

This section covers some of the settings that apply to all the components of LibreOffice and are of particular interest to users of Calc. Other general options are discussed in Chapter 2, Setting Up LibreOffice, in the Getting Started Guide.

5) Choose Tools > Options (LibreOffice > Preferences on a Mac) to open the Options dialog. The list on the left-hand side varies depending on which LibreOffice component is open. The illustrations in this chapter show the list as it appears when Calc is open.

6) Click the expansion symbol (+ or triangle) next to LibreOffice. A list of subsections drops down.

![Figure 448: LibreOffice options](image)

Note

The Reset button, located in the lower right of the full Options dialog, has the same effect on all pages of the dialog. It resets the options to the values that were in place when you opened the dialog.

User data

User data is used by templates and Wizards in LibreOffice. For example, Calc uses the first and last name stored here to fill in the Created and Modified fields in the document properties, the optional Author field often used in the footer of a printed spreadsheet, and the name associated with comments. If you want your name to appear, then fill in the form on the LibreOffice – User Data page.
View

The options on the *LibreOffice – View* page affect how the document window looks and behaves, including the size and style of toolbar and sidebar icons. Set these options to suit your personal preferences.

Print

On the *LibreOffice – Print* page, you can set the print options to suit your default printer and your most common printing method. You can change these settings at any time, either through this dialog or during the printing process (through the Print dialog).

Calc-specific print options are described in “Print options” on page 451.

See Chapter 6, Printing, Exporting, E-mailing, and Signing, for more about these options.

Paths

On the *LibreOffice – Paths* page, you can change the location of files associated with, or used by, LibreOffice to suit your needs. For example, you might want to store spreadsheets by default on a shared server. Some items can have at least two paths listed: one to a shared folder (which might be on a network) and one to a user-specific folder (normally on the user’s personal computer).

Security

Use the *LibreOffice – Security* page to choose security options for saving documents and for opening documents that contain macros.

Security Options and Warnings

Adjust security related options and define warnings for hidden information in documents.

Passwords for Web Connections

- Persistently save passwords for web connections
- Protected by a master password (recommended)

Passwords are protected by a master password. You will be asked to enter it once per session, if LibreOffice retrieves a password from the protected password list.

Macro Security

Adjust the security level for executing macros and specify trusted macro developers.

TSAs

Maintain a list of Time Stamping Authority (TSA) URLs to be used for digital signatures in PDF export.

Figure 449: Choosing security options for opening and saving documents

Security Options and Warnings

If you record changes, save multiple versions, or include hidden information or notes in your documents, and you do not want some of the recipients to see that information, you can set warnings to remind you to remove this information, or you can have LibreOffice remove some information automatically. Note that (unless removed) much of this information is retained in a file whether the file is in LibreOffice’s default OpenDocument Format, or has been saved to other formats, including PDF.

Click the **Options** button to open a separate dialog with specific choices (see page 436).
Passwords for Web Connections
You can enter a master password to enable easy access to websites that require a user name and password. If you select the Persistently save passwords for web connections option, the Set Master Password dialog (not shown here) opens. LibreOffice will securely store all passwords that you use to access files from web servers. You can retrieve the passwords from the list after you enter the master password.

Macro Security
Click the Macro Security button to open the Macro Security dialog (not shown here), where you can adjust the security level for executing macros and specify trusted sources.

Certificate Path
Users can digitally sign documents using LibreOffice. A digital signature requires a personal signing certificate. Most operating systems can generate a self-signed certificate. However, a personal certificate issued by an outside agency (after verifying an individual's identity) has a higher degree of trust associated with it than does a self-signed certificate. LibreOffice does not provide a secure method of storing these certificates, but it can access certificates that have been saved using other programs. Click the Certificate button and select which certificate store to use.

Note
The Certificate Path option appears only on Linux and Mac systems. On Windows, LibreOffice uses the default Windows location for storing and retrieving certificates.

TSAs – Time Stamping Authorities
Allows you to optionally select a Time Stamping Authority (TSA) URL for PDF documents created by LibreOffice. Adding a trusted timestamp to an electronic signature on a PDF provides a digital seal of data integrity and a trusted date and time of when the file was signed. Recipients of PDF documents with a trusted timestamp can verify when the document was digitally or electronically signed, as well as verify that the document was not altered after the date the timestamp vouches for.

Security Options and Warnings
The following options are on the Security Options and Warnings dialog (Figure 450).

**Figure 450: Security Options and Warnings dialog**
Remove personal information on saving
Select this option to always remove user data from the file properties when saving the file. To manually remove personal information from specific documents, deselect this option and then use the Reset Properties button under File > Properties > General.

Ctrl-click required to follow hyperlinks
The default behavior in most components of LibreOffice is to Ctrl+click on a hyperlink to open the linked document, but you can choose to open hyperlinks using a single click.

The other options on this dialog should be self-explanatory.

Application colors
On the LibreOffice – Application Colors page (Figure 451), you can specify which user interface elements are visible and the colors used to display them. Scroll down the list until you find the section headed Spreadsheet. To change the default color for Grid lines or other on-screen indicators, click the down-arrow by the color and select a new color from the drop-down list.

![Figure 451: Changing the color of elements in Calc](image)

If you wish to save your color changes as a color scheme, click Save, type a name in the Name of color scheme box in the pop-up dialog, and then click OK.

Advanced options
Two items of interest on this page are found under Optional Features:

Enable experimental features (may be unstable)
Selecting this option enables features that are not yet complete or contain known bugs. The list of these features is different version by version.
Enable macro recording (may be limited)
This option enables macro recording, with some limitations. For more about macro recording, see Chapter 13, Getting Started with Macros, in the Getting Started Guide, and Chapter 12, Calc Macros, in this book.

Options for loading and saving documents
You can set the Load/Save options to suit the way you work. This chapter describes only a few of the options, those most relevant to working with Calc. See Chapter 2, Setting Up LibreOffice, in the Getting Started Guide for a description of the other options.

If the Options dialog is not already open, click Tools > Options. Click the expansion symbol (+ or triangle) by Load/Save on the left-hand side to display the list of load/save options pages.

General
Many of the choices on the Load/Save – General page (Figure 452) are familiar to users of other office suites. Those of most interest to Calc users are in the Default File Format and ODF Settings section.

![Figure 452: Choosing Load and Save general options](image)

**Default File Format and ODF Settings**

- **ODF format version**: LibreOffice by default saves documents in OpenDocument Format (ODF) version 1.2 Extended. You will rarely need to change this for compatibility when exchanging files with other people.

- **Document type**: If you routinely share documents with users of Microsoft Excel, you might want to change the **Always save as** option to one of the Excel formats, including XLSX. However, you can choose an Excel format when you save any individual file.

  However, we recommend that you always save a working copy in ODS format and only create an Excel version if necessary for sharing. Also, note that recent and current versions of Microsoft Excel can open ODS files, so this may no longer be needed.
VBA Properties

On the Load/Save – VBA Properties page (Figure 453), you can choose whether to keep any VBA (Visual Basic for Applications) macros in Microsoft Office documents that are opened in LibreOffice.

If you choose Load Basic code, you can edit the macros in LibreOffice. The changed code is saved in an ODF document but is not retained if you save into a Microsoft Office format.

If you choose Save original Basic code, the macros will not work in LibreOffice but are retained unchanged if you save the file into Microsoft Office format.

If you are importing a Microsoft Word or Excel file containing VBA code, you can select the option Executable code. Whereas normally the code is preserved but rendered inactive (if you inspect it with the Basic IDE you will notice that it is all commented), with this option the code is ready to be executed.

Save original Basic code takes precedence over Load Basic code. If both options are selected and you edit the disabled code in LibreOffice, the original Microsoft Basic code will be saved when saving in a Microsoft Office format.

To remove any possible macro viruses from the Microsoft Office document, deselect Save original Basic code. The document will be saved without the Microsoft Basic code.

Microsoft Office

On the Load/Save – Microsoft Office page (Figure 454), you can choose what to do when importing and exporting Microsoft Office OLE objects (linked or embedded objects or documents such as spreadsheets or equations): convert them into or from the corresponding LibreOffice OLE object or load and save them in their original format.

Select the [L] options to convert Microsoft OLE objects into the corresponding LibreOffice OLE objects when a Microsoft document is loaded into LibreOffice.

Select the [S] options to convert LibreOffice OLE objects into the corresponding Microsoft OLE objects when a document is saved in a Microsoft format.
Figure 454: Choosing Load/Save Microsoft Office options

**HTML Compatibility**

Choices made on the *Load/Save – HTML Compatibility* page (Figure 455) affect HTML pages imported into LibreOffice and those exported from LibreOffice. See Chapter 2, Setting up LibreOffice, in the *Getting Started Guide*, and HTML documents; importing/exporting in the Help, for more information.

The main items of interest for Calc users are in the *Export* section.

**Export - LibreOffice Basic**

Select this option to include LibreOffice Basic macros (scripts) when exporting to HTML format. You must activate this option before you create the LibreOffice Basic macro; otherwise the script will not be inserted. LibreOffice Basic macros must be located in the header of the HTML document. Once you have created the macro in the LibreOffice Basic IDE, it appears in the source text of the HTML document in the header.
If you want the macro to run automatically when the HTML document is opened, choose Tools > Customize > Events. See Chapter 12, Calc Macros, for more information.

Export - Display warning
When the LibreOffice Basic option (see above) is not selected, the Display warning option becomes available. If the Display warning option is selected, then when exporting to HTML a warning is shown that LibreOffice Basic macros will be lost.

Export – Print layout
Select this option to export the print layout of the current document as well. The HTML filter supports CSS2 (Cascading Style Sheets Level 2) for printing documents. These capabilities are only effective if print layout export is activated.

Export – Copy local images to Internet
Select this option to automatically upload the embedded pictures to the Internet server when uploading using FTP.

Export – Character set
Select the appropriate character set for the export.

Calc-specific options
Calc must be open in order for the LibreOffice Calc options to be displayed in the Options dialog. Click the expansion symbol (+ or triangle) by LibreOffice Calc. A list of subsections drops down.

General
The choices on the LibreOffice Calc – General page (Figure 457) affect the units used for rulers and other measurements, the default tab stop positions, the updating of links and fields, and various input settings.

Metrics
Choose the unit of measurement used in spreadsheets and the default tab stops distance.

Updating
Choose whether to update links when opening a document: Always, On request, or Never. Spreadsheets that include many or large charts or graphics may load slowly if this option is set to Always.
Input Settings section

**Press Enter to move selection**
Specifies that pressing `Enter` moves the cursor to another cell. You can also choose the direction the cursor moves: Up, Down, Left, or Right. If this option is not selected, pressing `Enter` places the data into the cell but does not move the cursor.

**Press Enter to switch to edit mode**
Specifies that pressing `Enter` puts the selected cell into edit mode. To end edit mode and move the cursor in the desired direction, press `Enter` again.

**Expand formatting**
Specifies whether to automatically apply the formatting attributes of the selected cell to empty adjacent cells. If, for example, a selected cell has the bold attribute, this attribute will also apply to empty adjacent cells. However, cells that already have a special format will not be modified by this function. To see the affected range, press `Ctrl`+*(multiplication sign on the number pad). The format will also apply to all new values inserted within this range.

**Expand references when new columns/rows are inserted**
Specifies whether to expand references when inserting columns or rows adjacent to the reference range. This is only possible if the reference range, where the column or row is inserted, originally spanned at least two cells in the desired direction.

Example: If the range A1:B1 is referenced in a formula and you insert a new column after column B, the reference is expanded to A1:C1. If the range A1:B1 is referenced and a new row is inserted under row 1, the reference is not expanded, since there is only a single cell in the vertical direction.

If you insert rows or columns in the middle of a reference area, the reference is always expanded.

**Update references when sorting range of cells**
When selected, references to cells are updated when a range of cells is sorted. If not selected, the references are unchanged.
Highlight selection in column/row headers
   Specifies whether to highlight column and row headers in the selected columns or rows.

Use printer metrics for text formatting
   Select this option to use the properties of the default printer to format the display of a
   spreadsheet. Those properties can be found by choosing File > Printer Settings and then
   select the Properties button for the default printer. If the printer has options for page setup,
   those settings will be applied to Calc documents. If this option is not selected, pages will be
   configured for a generic printer.

Show overwrite warning when pasting data
   Pasting contents of the clipboard into a cell will replace the contents of that cell with what is
   in the clipboard. Select this option to be alerted to a possible loss of data when pasting.

Position cell reference with selection
   With this option set, expanding a selection (with Ctrl+Shift+Down/Up) jumps to the end of the
   range in the column that was added as last to the initial selection. When the option is not set,
   expanding a selection (with Ctrl+Shift +Down/Up) jumps to the end of the range in the
   column where selecting the cell range was started. The same applies when extending a
   selection on rows, with Ctrl+ Shift+Left/Right.

Defaults

Enter the number of worksheets to be opened by default when you start a new spreadsheet and
either accept the default sheet prefix or type a new one. After a spreadsheet has been created, you
can add new sheets and change the label of any tab; see Chapter 1, Introducing Calc, for more
information.

View

The options on the LibreOffice Calc – View page (Figure 458) affect the way the document window
looks and behaves when viewed onscreen.

![Figure 458: Selecting view options for Calc](image)

Display section

Select various options for the onscreen display.
Formulas
Display the content of a cell as a formula or as the results of that formula.

Zero values
Display a zero in a cell when the cell has a value of zero, or display an empty cell.

Comment indicator
Select this option to show a small symbol in the top right corner of a cell that contains a comment.

To always display a comment, right-click on the cell and select Show comment from the context menu.

Value highlighting
Select this option to highlight all values, or results of formulas, in the sheet. Text is highlighted in black; numbers in blue; and formulas, logical values, dates, and so on, in green. When this option is active, any colors assigned in the document are not displayed.

Anchor
If an inserted object, such as a picture, is anchored to a cell, an image of an anchor will appear in the cell to which the object is anchored.

Text overflow
If a cell contains text that is wider than the width of the cell, the text is displayed over empty neighboring cells in the same row. If there is no empty neighboring cell, a small triangle at the cell border indicates that the text continues. If this option is selected, text will wrap inside the cell and the height of the row will expand to accommodate the height of the expanded cell.

Show references in color
Select this option to provide a visual aid to assist the editing of a formula. Each reference is then highlighted in color in the formula, and the referenced cell range is enclosed by a colored border as soon as the cell containing the reference is selected for editing.

Window section
The following elements of the spreadsheet window can be made visible or invisible: column and row headers, horizontal and vertical scroll bars, sheet tabs, and, if an outline has been defined, outline symbols.

If the Sheet tabs option is not selected, you can only switch between the sheets by using the Navigator.

Visual Aids section
Grid lines
Grid lines are the borders around the cells of a spreadsheet when viewed onscreen. The options are: Show, Show on colored cells, or Hide. If grid lines are hidden, tables will be displayed on a solid background with no grid around cells. The color choice overrides the selection made in Tools > Options > LibreOffice > Application Colors > Spreadsheet > Grid lines.

Note
To print grid lines, choose Format > Page > Sheet > Print > Grid.

Page breaks
Specifies whether to view the page breaks within a defined print area.
Helplines while moving
Specifies whether to view helplines when moving drawings, frames, graphics, and other objects. These lines help you align objects.

In Figure 460, the graph with the dark background represents the image in its original location. The lighter area represents the position of the image as it is being moved. Helplines are the horizontal and vertical dotted lines at the corners of the lighter object.

![Figure 460: Helplines visible when moving a graphic](image)

Objects section
Choose whether to show or hide graphics, charts, and drawing objects.

Zoom section
Select the Synchronize sheets option to apply any selected zoom (magnification) factor to all sheets in the spreadsheet. If this option is not selected, separate zoom factors can be applied to individual sheets.

Calculate
Use the LibreOffice Calc – Calculate page (Figure 461) to define the calculation settings for spreadsheets.
Iterative References section
Iterative references are formulas that are continuously repeated until the problem is solved. In this section you can choose the number of approximation steps carried out during iterative calculations and the degree of precision of the answer.

Iterations
Select this option to enable iterations. If this options is not selected, an iterative reference causes an error message.

Steps
Sets the maximum number of iteration steps.

Minimum Change
Specifies the difference between two consecutive iteration step results. If the result of the iteration is lower than the minimum change value, then the iteration will stop.

Date section
Select the start date for the internal conversion from days to numbers.

12/30/1899 (default) – Sets December 30, 1899 as day zero.

01/01/1900 (StarCalc 1.0) – Sets January 1, 1900 as day zero. Use this setting for StarCalc 1.0 spreadsheets containing date entries.

01/01/1904 – Sets January 1, 1904 as day zero. Use this setting for spreadsheets that are imported from foreign formats.

General Calculations
Specify a variety of options relevant to spreadsheet calculation.

Case sensitive
Specifies whether to distinguish between upper and lower case in texts when comparing cell contents. For example: type 'Test' in cell A1; and 'test' in B1. Then type the formula "=A1=B1" in cell C1. If the Case sensitive option is checked, FALSE will appear in the cell; if the
analysis was case insensitive, TRUE will appear in the cell. This option is not applied to the EXACT text function, which is always case-sensitive.

**Precision as shown**
Specifies whether to make calculations using the rounded values displayed in the sheet. Charts will be shown with the displayed values. If the **Precision as shown** option is not marked, the displayed numbers are rounded, but they are calculated internally using the non-rounded number.

**Search criteria = and <> must apply to whole cells**
The default search method in Calc is to search for any instance of the target regardless of the position of the target within a word. For example, when searching for day, Calc will match Friday, Sunday, and days. Select this option to search an exact occurrence of the target. Wild card symbols can be used to expand the search to match the default condition. That is, searching for *day* will match Friday, Sunday, and days.

**Enable wildcards in formulas**
**Enable regular expressions in formulas**
**No wildcards or regular expressions in formulas**
These three options are mutually exclusive.

- **Enable wildcards in formulas** specifies that wildcards are enabled when searching and also for character string comparisons. This relates to the database functions, and to VLOOKUP, HLOOKUP, MATCH, AVERAGEIF, AVERAGEIFS, COUNTIF, COUNTIFS, SUMIF, SUMIFS, and SEARCH. Select this option for spreadsheets that need to be interoperable with Microsoft Excel.

- **Enable regular expressions in formulas** specifies that regular expressions instead of simple wildcards are enabled when searching and also for character string comparisons. This relates to the database functions, and to VLOOKUP, HLOOKUP, MATCH, AVERAGEIF, AVERAGEIFS, COUNTIF, COUNTIFS, SUMIF, SUMIFS and SEARCH. Do not enable regular expressions in formulas for spreadsheets that need to be interoperable with Microsoft Excel.

- **No wildcards or regular expressions in formulas** specifies that only literal strings are used when searching and also for character string comparisons. This relates to the database functions, and to VLOOKUP, HLOOKUP, MATCH, AVERAGEIF, AVERAGEIFS, COUNTIF, COUNTIFS, SUMIF, SUMIFS and SEARCH. Do not disable wildcards in formulas for spreadsheets that need to be interoperable with Microsoft Excel.

**Automatically find column and row labels**
Calc will name the range of data, under a column heading or to the right of a row heading, using the text in those headings.

Example: Cell E5 contains the text Europe. Below, in cell E6, is the value 100 and in cell E7 the value 200. If the **Automatically find column and row labels** option is selected, you can write the following formula in cell A1: =SUM(Europe).

**Limit decimals for general number format**
Limits the number of decimals to be displayed for numbers with the general number format. This overrides the setting applied in **Format > Cells > Numbers > Number > General**. This setting refers to how numbers are displayed. When decimal places are limited, calculations are not affected because of rounding.

**CPU threading settings section**
**Enable multi-threaded calculation** controls the use of multi-threading / parallelism, which can be used to speed up LibreOffice Calc calculations on computers with multiple processing cores.
Caution

When calculations involve a range that includes an empty cell, take note of the setting for Zero values in the LibreOffice Calc > View options. If this option is not selected, a value of zero will display as an empty cell. Empty cells and the value zero are treated differently by many functions. For example, Count would not include an empty cell as an item to be counted. The average of eight cells, one of which contains the value zero, is not the same as the average of seven cells (an empty cell is not included in determining the average).

Formula

Use the LibreOffice Calc – Formula page (Figure 462) to specify whether to use Calc or Excel syntax, as well as choosing which separators you prefer to use in formulas. The separators choices override the defaults in Calc and Excel syntax.

![Figure 462: Formula options](image)

Formula syntax

Syntax is the format in which formulas are written. Choose the syntax most appropriate for your work. If you regularly open or save to Microsoft Excel formats, you may wish to use one of the Excel syntaxes.

To illustrate the differences between syntaxes, assume a spreadsheet contains two sheets. The cell C4 can be referenced in three ways:

- Calc A1 =Sheet2.C4 – the default syntax for Calc.
- Excel A1 =Sheet2!C4 – the default of Microsoft Excel.

Use English function names

The default names for functions in Calc are those for the user's locale. For English users, the localized names are the same as the English names. When the language set by locale is not
English, you may wish to express functions in English; if so, select this option to change formula input and display, function wizard, and formula tips.

**Separators**
Separators are used in functions to distinguish points in the range used in the function: the symbols used between elements. Enter the separator character to be used for functions, row arrays, and column arrays. For example, a comma can be used as a separator in functions and instead of writing \( =\text{SUM}(A1;B1;C1) \) the function would be expressed as \( =\text{SUM}(A1,B1,C1) \).

**Detailed calculation settings**
Most users will not need to change the default setting. For custom settings, select **Custom** and click **Details** to choose reference syntax and whether to treat empty strings as zero.

**Recalculation on File Load**
Recalculating formulas can take significant time while loading very large files.

*Excel 2007 and newer.* Loading a large spreadsheet file can take a long time. If you don't need to update your large spreadsheet data immediately, you can postpone the recalculation to a better time. Calc allows you to defer recalculation of Excel 2007 (and more recent) spreadsheets to speed up loading time.

*ODF spreadsheet (not saved by Office).* Recent versions of Calc cache spreadsheet formula results in its ODF file. This feature helps Calc to recalculate a large ODF spreadsheet saved by Calc faster. For ODF spreadsheets saved by other programs, where such cached formula results may not exist, recalculation can be deferred to speed up file loading as with Excel 2007 files.

For each of these two options, the following choices are possible: *Never recalculate* (no formulas will be recalculated on loading the file), *Always recalculate* (all formulas will be recalculated on file load), and *Prompt user* (prompt user for action).

Calc saved ODF spreadsheets will honor *Never recalculate* and *Always recalculate* options.

**Sort lists**
Sort lists are used for more than sorting, for example filling a series of cells during data entry. They are lists that are sorted in a particular order but not alphabetically or numerically; for example, days of the week. In addition to the supplied lists, you can define and edit your own lists, as described in “Defining a fill series” in Chapter 2, Entering, Editing, and Formatting Data.

![Figure 463: Defining sorting lists in Calc](image)

---

*Sort lists* | 435
Changes

In the Options dialog, choose LibreOffice Calc > Changes.

![Calc options for highlighting changes](image)

On this page you can specify options for highlighting recorded changes in spreadsheets. You can assign specific colors for insertions, deletions, and other changes, or you can let Calc assign colors based on the author of the change; in the latter case, one color will apply to all changes made by that author. The selections made here are applied when change recording is enabled under Edit > Track Changes > Record.

Compatibility

In the Options dialog, choose LibreOffice Calc > Compatibility. This page provides a quick way to switch between LibreOffice's default key bindings and OpenOffice.org's legacy default key bindings for Calc. Most of the defaults are identical, but there are some differences.

The actions associated with the two key binding choices are shown in the table below.

<table>
<thead>
<tr>
<th>Key Binding</th>
<th>Default</th>
<th>OpenOffice.org legacy</th>
</tr>
</thead>
<tbody>
<tr>
<td>Backspace</td>
<td>Opens Delete Contents dialog</td>
<td>Immediately deletes contents</td>
</tr>
<tr>
<td>Delete</td>
<td>Immediately deletes contents</td>
<td>Opens Delete Contents dialog</td>
</tr>
<tr>
<td>Control+D (Command+D on Mac)</td>
<td>Fills cell content down within selection</td>
<td>Opens the Selection List dialog</td>
</tr>
<tr>
<td>Alt+DownArrow (Option+DownArrow on Mac)</td>
<td>Select header of range; no action in empty cell</td>
<td>Increases row height</td>
</tr>
</tbody>
</table>
Grid options

The Grid page defines the grid settings for spreadsheets. Using a grid helps you determine the exact position of any charts or other objects you may add to a spreadsheet. You can also set this grid in line with the snap grid.

If you have activated the snap grid but wish to move or create individual objects without snap positions, you can press the Ctrl key to deactivate the snap grid for as long as needed.

In the Options dialog, choose LibreOffice Calc > Grid.

Grid section

Snap to grid activates the snap function.

Visible grid displays grid points on the screen. These points are not printed.

Resolution section

Here you can set the unit of distance for the spacing between horizontal and vertical grid points and subdivisions (intermediate points) of the grid.

Synchronize axes changes the current grid settings symmetrically.

Print options

In the Options dialog, choose LibreOffice Calc > Print to choose defaults for printing spreadsheets. You can override these for individual print jobs.

Default colors for charts

Use Tools > Options > Charts > Default Colors to change the default colors used for charts or to add new data series to the list provided.

To add new colors to the choices, see “Adding custom colors” on page 461.
To change the default color for a data series, select it in the left-hand column and then click on the required color in the color table.

To add another data series, click Add, then select the new series and click on the required color.

AutoCorrect functions

Some people find some or all of the items in LibreOffice’s AutoCorrect function annoying because they change what you type when you do not want it changed. Many people find some of the AutoCorrect functions quite helpful; if you do, then select the relevant options. But if you find unexplained changes appearing in your document, this is a good place to look to find the cause.

To open the AutoCorrect dialog, click Tools > AutoCorrect Options. You need to have a document open for this menu item to appear.

In Calc, this dialog has four tabs, as shown in Figure 468. Options are described in the Help; many will be familiar to users of other office suites.
Customizing the user interface

You can customize menus, toolbars, and keyboard shortcuts in LibreOffice, add new menus and toolbars, and assign macros to events.

Tip

Changes to menus and toolbars can be saved in a template. First, save the document that was open when these changes were made. Then, save that document as a template, as described in Chapter 4, Using Styles and Templates.

Menu content

You can add and rearrange menus on the Menu bar or context (right-click) menus; add, rearrange, and remove commands on menus; and make other changes.

To customize menus, choose Tools > Customize. On the Customize dialog, go to the Menus page (Figure 469) or the Context Menus page.
Modifying an existing menu

1) In the Scope drop-down list in the upper right of the Customize dialog, choose whether to save this changed menu for Calc or for a selected document.

2) In the Target drop-down list, select the menu that you want to customize. The list includes all the sub-menus as well as the main menus. The commands on the selected menu are shown in the right-hand Function list below.

3) To add a command to the selected menu, click on a command in the left-hand Function list and then click the large right arrow. You can narrow the search by using the Search box on the top left or selecting the Category in the drop-down list. Use the up and down arrows on the far right-hand side to move the command into the place where you want it in the list.

4) To remove a command from the selected menu, click on it in the right-hand Function list and then click the large left arrow.

5) To insert a separator or submenu, use the commands in the Insert drop-down under Customize at the bottom right.

6) To rename a menu item, select it in the right-hand Function list and choose Rename from the Modify drop-down below.
7) When you have finished making all your changes, click **OK** to save them.

**Creating a new menu**

On the Menus page of the Customize dialog, click the symbol next to *Target* and select **Add** from the list, to display the New Menu dialog shown in Figure 471.

![Figure 470: Location of command to add a new menu](image)

![Figure 471: Adding a new menu](image)

1) Type a name for the new menu in the *Menu name* box.

2) Use the up and down arrow buttons to move the new menu into the required position on the Menu bar. Click **OK** to save and return to the Customize dialog.

The new menu now appears on the list of menus in the Customize dialog. It will appear on the Menu bar itself after you save your customizations.

After creating a new menu, you need to add some commands to it, as described above for modifying a menu.
Creating an accelerator

You can allocate a letter in a custom menu’s name to be used as a keyboard shortcut. (That letter will become underlined.) When you press Alt+that letter, that menu or command will be invoked. Existing submenus can also be edited to change the letter which is used to select them using the keyboard when the menu is open.

To create an accelerator:

1) Select a menu item from the right-hand Function list.
2) Click the Modify button and select Rename.
3) Add a tilde (~) in front of the letter to use as an accelerator.
4) Click OK to save the change.

The A in the menu item Art is now underlined. Press Alt+A and the Art menu will open.

Caution

When assigning an accelerator, be careful not to use a letter that is already assigned to a menu or command associated with a menu item. The same letter-key combinations can be used for commands associated with different menu items but not for those associated with the same menu or menu item.

Toolbars

You can customize toolbars in several ways, including choosing which icons are visible and locking the position of a docked toolbar, as described in Chapter 1, Introducing LibreOffice, of the Getting Started Guide. This section describes how to create new toolbars and add or delete icons (commands) on a toolbar.

To get to the toolbar customization dialog (Figure 472), do any of the following:

- On the toolbar, right-click in the toolbar and choose Customize Toolbar.
- Choose View > Toolbars > Customize on the Menu bar.
- Choose Tools > Customize on the Menu bar and go to the Toolbars page.

To customize a toolbar:

1) In the Scope drop-down list on the upper right, choose whether to save this changed toolbar for Calc or for a selected document.
2) In the Target drop-down list, select the toolbar that you want to customize. The current toolbar content is displayed in the right pane below.
3) Select the commands in the Function list on the left. You can narrow your search by using the Search box on the top left or choosing a category in the drop-down list just below.
4) Click on the large right arrow to add the command to the Function list for the toolbar (on the right). Use the up and down arrows in the far right to position the command in the bar.
5) To remove a command from a toolbar, select it in the Function list on the right and click the large left arrow.
6) To show or hide a command assigned to a toolbar, select or clear the checkbox by its icon in the Function list on the right.
7) To insert a separator, use the command in the Insert drop-down under Customize at the bottom right.
8) To rename a toolbar item or change its icon, select it in the right-hand Function list and choose Rename from the Modify drop-down.
9) When you have finished making all your changes, click OK to save them.
To create a new toolbar:

1) Choose Tools > Customize on the Menu bar.
2) On the Toolbars page of the Customize dialog, click the symbol next to Target and select Add from the list, to display the Name dialog.
3) On the Name dialog, type the new toolbar's name and choose from the Save In drop-down list where to save this new toolbar: for Calc or for the open document.

The new toolbar now appears on the list of toolbars in the Customize dialog.

To add commands to the new toolbar, follow the instructions earlier for modifying a toolbar.

**Choosing icons for toolbar commands**

Toolbar buttons can be displayed with *Icon only*, *Text only*, or *Icon and text*. This selection is made through the menu that drops down from the button to the right of the Target field. However, not all of the commands have associated icons.

To choose an icon for a command, select the command and click Modify > Change Icon. On the Change Icon dialog (Figure 473), scroll through the available icons, select one, and click OK to assign it to the command.

*Figure 472: The Toolbars page of the Customize dialog*
To use a custom icon, create it in a graphics program and import it into LibreOffice by clicking the Import button on the Change Icon dialog. For best quality, custom icons should be 26 x 26 pixels in size; other sizes will be scaled automatically.

**Keyboard shortcuts**

In addition to using the built-in keyboard shortcuts (listed in Chapter 17), you can define your own. You can assign shortcuts to standard LibreOffice functions or your own macros and save them for use with the entire LibreOffice suite or only for Calc.

**Caution**

Avoid reassigning your operating system’s predefined shortcut keys.

**Note**

Shortcut keys that are grayed out in the listing on the Customize dialog, such as F1 and F10, are not available for reassignment.

To adapt shortcut keys to your needs, use the Customize dialog, as described below.

1. Select **Tools > Customize** and select the **Keyboard** page. (Figure 474).
2. To have the shortcut key assignment available only with Calc, select **Calc** in the upper right corner of the page; otherwise select **LibreOffice** to make it available to every component.
3. Next select the required function from the **Category** and **Function** lists.
4. Now select the desired shortcut keys in the **Shortcut Keys** list and click the **Modify** button at the upper right.
5. Click **OK** to accept the change. Now the chosen shortcut keys will execute the function chosen in step 3 above whenever they are pressed.
Note

All existing shortcut keys for the currently selected Function are listed in the Keys selection box. If the Keys list is empty, it indicates that the chosen key combination is free for use. If it were not, and you wanted to reassign a shortcut key combination that is already in use, you must first delete the existing key.

Figure 474: Customizing a keyboard shortcut

Saving changes to a file

Changes to the shortcut key assignments can be saved in a keyboard configuration file for use at a later time, thus permitting you to create and apply different configurations as the need arises. To save keyboard shortcuts to a file:

1) After making your keyboard shortcut assignments, click the Save button on the right of the Customize dialog (Figure 474).

2) In the Save Keyboard Configuration dialog, enter a name for the keyboard configuration file in the File name box, or select an existing file (the file extension is .cfg for Configuration).

3) Click Save. A confirmation dialog appears if you are about to overwrite an existing file, otherwise there will be no feedback and the file will be saved.
Loading a saved keyboard configuration
To load a saved keyboard configuration file and replace your existing configuration, click the **Load** button on the right of the Customize dialog, and then select the configuration file from the Load Keyboard Configuration dialog.

Resetting the shortcut keys
To reset all of the keyboard shortcuts to their default values, click the **Reset** button on the right of the Customize dialog. Use this feature with care as no confirmation dialog will be displayed; the defaults will be set without any further notice or user input.

Running macros from key combinations
You can also define shortcut key combinations that will run macros. These shortcut keys are strictly user-defined; none are built in. For more information on macros, see Chapter 12, Calc Macros.

Assigning macros to events
In LibreOffice, when something happens, we say that an event occurred. For example, a document was opened, a key was pressed, or the mouse moved. You can associate a macro with an event, so the macro is run when the event occurs. A common use is to assign the “open document” event to run a macro that performs certain setup tasks for the document.

To associate a macro with an event, use the Events page of the Customize dialog. For more information, see Chapter 13, Getting Started with Macros, in the *Getting Started Guide*.

Adding functionality with extensions
An extension is a package that can be installed into LibreOffice to add new functionality.

Although individual extensions can be found in different places, the official LibreOffice extension repository is at [https://extensions.libreoffice.org/](https://extensions.libreoffice.org/). These extensions are free of charge. Extensions from other sources may be free or may be available for a fee. Check the descriptions to see what licenses and fees apply to the ones that interest you.

Installing extensions
To install an extension that is listed in the repository, follow these steps:

1. In LibreOffice, select **Tools > Extension Manager** on the Menu bar. In the Extension Manager dialog, click the **Get more extensions online** link.
2. A browser window will open. Find the extension you want and download it to your computer.
3. After the extension is downloaded and saved, return to the Extension Manager dialog and click **Add**. Find and select the extension you want to install and click **Open**. The extension begins installing. You may be asked to accept a license agreement.
4. When the installation is complete, the extension is listed in the Extension Manager dialog.

To install an extension that is not listed in the repository, download the extension, then continue with step 3 above.

Updating extensions
Click the **Check for Updates** button on the Extension Manager dialog to check for updates to installed extensions.
Removing and disabling extensions

To remove (uninstall) an extension that you installed, select the extension in the main window of the Extension Manager dialog and click the **Remove** button.

To disable an extension without removing (uninstalling) it, select the extension in the main window of the Extension Manager dialog and click the **Disable** button, which then changes to **Enable**.

![Extension Manager dialog](image)

**Figure 475: The Extension Manager dialog**

Adding custom colors

Versions of LibreOffice before 5.3 had a Colors page in **Tools > Options**, where you could add custom colors to a color palette, for example to exactly match a corporate color scheme. This page has been removed. The method for defining a custom color is now as follows:

1) Insert any drawing object, such as a square, into any document.

2) Right-click on the object and choose **Area** from the context menu.

3) Go to the **Color** tab (Figure 476). From the **Palette** drop-down in the **Colors** area, choose which palette you wish to add the new color to. Under **New**, define the new color using RGB or Hex notation, or click the **Pick** button to select the color on the Pick a Color dialog (Figure 477).

4) Click **Add** in the lower left corner, enter a name for the new color in the pop-up dialog, and click **OK** to save.
5) Delete the drawing object from the document, if it is not needed.
Appendix A
Keyboard Shortcuts
Introduction

In this chapter, you will find a set of keyboard shortcuts for LibreOffice Calc. These shortcuts allow you to quickly execute commands without using a pointing device such as a mouse or a trackball. Many of these shortcuts can also be found in LibreOffice Help, which is accessed online at http://help.libreoffice.org/.

You can define your own shortcuts or change existing shortcuts by going to Tools > Customize > Keyboard in the Menu bar. See Chapter 14, Setting up and Customizing Calc, for further instructions. Some of the formatting and editing shortcuts listed here are described in Chapter 2, Entering, Editing, and Formatting Data.

⚠️ Caution

Be careful when reassigning predefined shortcuts. Although you can reset shortcut keys back to LibreOffice defaults, changing common hotkeys, such as F1 for Help, can cause confusion and frustration, especially if other users share your computer.

Using LibreOffice on macOS

Some keystrokes and menu items are different on macOS from those used in Windows and Linux. Table 15 gives some common substitutions for the instructions in this chapter. For a more detailed list, see the application Help.

Table 15: macOS shortcut substitutions

<table>
<thead>
<tr>
<th>Windows or Linux</th>
<th>macOS equivalent</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tools &gt; Options menu</td>
<td>LibreOffice &gt; Preferences</td>
<td>Access setup options</td>
</tr>
<tr>
<td>Right-click</td>
<td>Control + click or right-click, depending on computer setup</td>
<td>Open a context menu</td>
</tr>
<tr>
<td>Ctrl (Control)</td>
<td>⌘ (Command)</td>
<td>Used with other keys</td>
</tr>
<tr>
<td>F5</td>
<td>Shift + ⌘ + F5</td>
<td>Open the Navigator</td>
</tr>
<tr>
<td>F11</td>
<td>⌘ + T</td>
<td>Open the sidebar Styles panel</td>
</tr>
</tbody>
</table>

Insertion and editing shortcuts

Table 16: Insertion and editing shortcuts

<table>
<thead>
<tr>
<th>Shortcut Keys</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Esc</td>
<td>Cancels the current cell edit.</td>
</tr>
<tr>
<td>Backspace</td>
<td>Opens the Delete Contents dialog.</td>
</tr>
<tr>
<td>Delete</td>
<td>Deletes cell contents without a dialog. Does not remove formatting.</td>
</tr>
<tr>
<td>Insert</td>
<td></td>
</tr>
<tr>
<td>Ctrl+Shift+V (after copying data)</td>
<td>Opens the Paste Special dialog.</td>
</tr>
<tr>
<td>Alt+Enter (after selecting a range)</td>
<td>Fills the selected cell range with the formula that you entered on the input line.</td>
</tr>
<tr>
<td>Ctrl+Enter (while editing a cell)</td>
<td>Inserts a manual line break in the current cell.</td>
</tr>
</tbody>
</table>
**Shortcut Keys** | **Effect**
--- | ---
Ctrl+Shift+Enter (after selecting a cell range) | Creates a matrix in the current range using the information entered on the input line. You cannot make edits to the individual matrix range cells.

Ctrl+D (after selecting a cell range) | Fills the selected range with the contents of its top-most cells.

Ctrl+; | Inserts the current date into the cursor cell. If the time has already been added, then it is changed to a combined date and time stamp.

Ctrl+Shift+; | Inserts the local time into the current cell. If the date has already been added, then it is changed to a combined date and time stamp.

Ctrl+’ (single apostrophe) | Copies the contents of the cell above the cursor into the current cell, but remains in Edit mode so that you can make further changes.

Ctrl++ | Opens the Insert Cells dialog. The plus sign (+) is the one on the number pad, **not** the main keyboard.

Ctrl+- | Opens the Delete Cells dialog.

### Navigation and selection shortcuts

**Note**

In Table 17 and following, the term *data range* refers specifically to a contiguous cell range that contains data and is bounded by empty rows and columns.

**Arrow key shortcuts**

*Table 17: Arrow key shortcuts*

| Shortcut Keys | Effect |
--- | ---|
Arrow keys (Down, Up, Left, Right) | Moves the cursor one cell in the direction of the arrow. |
Alt+Down Arrow | Opens a drop-down selection list of text items that have been previously typed into other cells in the same column. |
Alt+Left Arrow | Decreases the width of the current column. |
Alt+Right Arrow | Increases the width of the current column. |
Alt+Shift+Arrow | Optimizes the column width or row height based on the current cell. |
Ctrl+Arrow | Moves the cursor in the direction of the arrow to the edge of the current data range. If the cell adjacent to the cursor is empty, the cursor will move to the next cell that contains data. |
Shift+Arrow | Selects the adjacent cell or cells (if multiple are selected) located in the direction of the arrow. Pressing this shortcut again will extend the selection by one more cell. |
Ctrl+Shift+Arrow | Selects all cells containing data from the cursor to the edge of the current data range in the direction of the arrow. Can be used to select multiple rows or columns at once. |

**Home and End key shortcuts**

*Table 18: Home and End key shortcuts*
<table>
<thead>
<tr>
<th><strong>Shortcut Keys</strong></th>
<th><strong>Effect</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Home</td>
<td>Moves the cursor to the first cell of the current row.</td>
</tr>
<tr>
<td>End</td>
<td>Moves the cursor along the current row to the cell in the last column containing data in the sheet.</td>
</tr>
<tr>
<td>Ctrl+Home</td>
<td>Moves the cursor to the first cell (A1) in the current sheet.</td>
</tr>
<tr>
<td>Ctrl+End</td>
<td>Moves the cursor to the cell in the last column and row that contain data in the sheet.</td>
</tr>
<tr>
<td>Shift+Home</td>
<td>Selects cells from the cursor to the first cell of the current row.</td>
</tr>
<tr>
<td>Shift+End</td>
<td>Selects cells along the current row from the cursor to the cell in the last column containing data in the sheet.</td>
</tr>
<tr>
<td>Ctrl+Shift+Home</td>
<td>Selects all cells from the cursor to the first cell (A1) in the current sheet.</td>
</tr>
<tr>
<td>Ctrl+Shift+End</td>
<td>Selects all cells from the cursor to the cell in the last column and row that contain data in the current sheet.</td>
</tr>
</tbody>
</table>

**Page key shortcuts**

*Table 19: Page key shortcuts*

<table>
<thead>
<tr>
<th><strong>Shortcut Keys</strong></th>
<th><strong>Effect</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Page Up</td>
<td>Moves up one screen page.</td>
</tr>
<tr>
<td>Page Down</td>
<td>Moves down one screen page.</td>
</tr>
<tr>
<td>Alt+Page Up</td>
<td>Moves one screen page to the left.</td>
</tr>
<tr>
<td>Alt+Page Down</td>
<td>Moves one screen page to the right.</td>
</tr>
<tr>
<td>Ctrl+Page Up</td>
<td>Moves to the previous sheet or to the previous page if you are in the print preview.</td>
</tr>
<tr>
<td>Ctrl+Shift+Tab</td>
<td>Moves to the next sheet or to the next page if you are in the print preview.</td>
</tr>
<tr>
<td>Shift+Page Up</td>
<td>Selects cells from the cursor to the row one page up. If the shortcut is used again, it extends the existing selection up one more page.</td>
</tr>
<tr>
<td>Shift+Page Down</td>
<td>Selects cells from the cursor to the row one page down. If the shortcut is used again, it extends the existing selection down one more page.</td>
</tr>
<tr>
<td>Alt+Shift+Page Up</td>
<td>Selects cells from the cursor to the column one page to the left. If the shortcut is used again, it extends the existing selection by one more page.</td>
</tr>
<tr>
<td>Alt+Shift+Page Down</td>
<td>Selects cells from the cursor to the column one page to the right. If the shortcut is used again, it extends the existing selection by one more page.</td>
</tr>
<tr>
<td>Ctrl+Shift+Page Up</td>
<td>Moves to the previous sheet and adds it to the current sheet selection. If every sheet in the document is already selected, then only this sheet will remain selected.</td>
</tr>
<tr>
<td>Ctrl+Shift+Page Down</td>
<td>Moves to the next sheet and adds it to the current sheet selection. If every sheet in the document is already selected, then only this sheet will remain selected.</td>
</tr>
</tbody>
</table>

**Other hotkey shortcuts**

*Table 20: Other hotkey shortcuts*
<table>
<thead>
<tr>
<th>Shortcut Keys</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enter (while in a selected range)</td>
<td>Moves the cursor to the next cell in the selected range, from top to bottom, then left to right. To specify in which direction the cursor moves, go to <strong>Tools &gt; Options &gt; LibreOffice Calc &gt; General</strong> in the Menu bar.</td>
</tr>
<tr>
<td>Ctrl+Space</td>
<td>Selects the current column or extends the existing selection to all respective columns.</td>
</tr>
<tr>
<td>Shift+Space</td>
<td>Selects the current row or extends the existing selection to all respective rows.</td>
</tr>
<tr>
<td>Ctrl+Shift+Space</td>
<td>Selects all cells in the current sheet.</td>
</tr>
<tr>
<td>Ctrl+]</td>
<td>Selects the cells that are dependent on the current cell.</td>
</tr>
<tr>
<td>Ctrl+[</td>
<td>Selects the cells on which the current cell is dependent.</td>
</tr>
<tr>
<td>Shift+Backspace</td>
<td>Deselects the current cell selection without deleting contents.</td>
</tr>
<tr>
<td>Ctrl+Backspace</td>
<td>Refocuses the view back on the cursor if it is not currently in view.</td>
</tr>
<tr>
<td>Ctrl+*</td>
<td>Selects the data range that contains the cursor. The asterisk (*) is the multiplication sign on the number pad, <strong>not</strong> the one on the main keyboard.</td>
</tr>
<tr>
<td>Ctrl+/</td>
<td>Selects the matrix formula range that contains the cursor.</td>
</tr>
<tr>
<td>Ctrl+`</td>
<td>Shows or hides formulas instead of values in all formula cells. The ` key is next to the 1 key on most English keyboards.</td>
</tr>
</tbody>
</table>

**Mouse selection shortcuts**

Table 21: Mouse selection shortcuts

<table>
<thead>
<tr>
<th>Shortcut Keys</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Hold Ctrl and select cells with the mouse</td>
<td>Allows you to select multiple cell ranges in different areas of the current sheet.</td>
</tr>
<tr>
<td>Hold Ctrl and select sheet tabs</td>
<td>Allows you to select multiple sheets in the current document. Clicking on a sheet that is not in view, but is selected, will remove it from the current sheet selection.</td>
</tr>
<tr>
<td>Hold Shift and select a sheet tab</td>
<td>Adds all sheets from the sheet in view to the selected sheet into the current sheet selection.</td>
</tr>
</tbody>
</table>

**Function key shortcuts**

Table 22: Function key shortcuts

<table>
<thead>
<tr>
<th>Shortcut Keys</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>F1</td>
<td>Displays the LibreOffice help browser.</td>
</tr>
<tr>
<td>Shift+F1</td>
<td>Displays context help.</td>
</tr>
<tr>
<td>Ctrl+F1</td>
<td>Displays the comment attached to the current cell.</td>
</tr>
<tr>
<td>F2</td>
<td>Switches to Edit mode and places the cursor at the end of the current cell's contents. If the cursor is in a dialog input box that has a minimize button associated with it, the dialog will be hidden while the input box remains visible. Press F2 again to show the whole dialog.</td>
</tr>
<tr>
<td>Ctrl+F2</td>
<td>Opens the Function Wizard.</td>
</tr>
<tr>
<td>Ctrl+Shift+F2</td>
<td>Moves the cursor to the input line, where you can enter a formula for the current cell.</td>
</tr>
<tr>
<td>Ctrl+F3</td>
<td>Opens the <strong>Manage Names</strong> dialog.</td>
</tr>
<tr>
<td>Shortcut Keys</td>
<td>Effect</td>
</tr>
<tr>
<td>--------------------</td>
<td>------------------------------------------------------------------------</td>
</tr>
<tr>
<td>F4</td>
<td>Cycles through relative and absolute references in the input field (for example, A1, $A$1, $A$1, or A$1).</td>
</tr>
<tr>
<td>Ctrl+Shift+F4</td>
<td>Hides or shows the Data Sources explorer.</td>
</tr>
<tr>
<td>F5</td>
<td>Hides or shows the Navigator.</td>
</tr>
<tr>
<td>Shift+F5</td>
<td>Traces dependents. Arrows will point from source cells to dependent formula cells.</td>
</tr>
<tr>
<td>Shift+F9</td>
<td>Traces precedents. Arrows will point from source cells to dependent formula cells.</td>
</tr>
<tr>
<td>Ctrl+F5</td>
<td>Hides or shows the Sidebar.</td>
</tr>
<tr>
<td>Ctrl+Shift+F5</td>
<td>Moves the cursor to the sheet area drop-down box.</td>
</tr>
<tr>
<td>Ctrl+Shift+T</td>
<td>Moves the cursor to the sheet area drop-down box.</td>
</tr>
<tr>
<td>F7</td>
<td>Checks spelling in the current sheet.</td>
</tr>
<tr>
<td>Ctrl+F7</td>
<td>Opens the Thesaurus if the current cell contains text.</td>
</tr>
<tr>
<td>F8</td>
<td>Switches between the standard and extended selection modes. In this mode, you can use the arrow keys to extend a selection of cells. You can also click in another cell to extend the selection.</td>
</tr>
<tr>
<td>Ctrl+F8</td>
<td>Highlights cells using different font colors. Text is black, formulas are green, and numbers are blue.</td>
</tr>
<tr>
<td>Shift+F8</td>
<td>Switches between the standard and add selection modes. In this mode, you can add individual cells to a range with the mouse.</td>
</tr>
<tr>
<td>F9</td>
<td>Recalculates changed formulas in the current sheet. If AutoCalculate is enabled, then this shortcut will only affect functions like RAND and NOW. To toggle AutoCalculate, click on Data &gt; Calculate &gt; AutoCalculate in the Menu bar.</td>
</tr>
<tr>
<td>Ctrl+F9</td>
<td>Updates the selected chart.</td>
</tr>
<tr>
<td>Ctrl+Shift+F9</td>
<td>Recalculates all formulas in all sheets. If AutoCalculate is enabled, then this shortcut will only affect functions like RAND and NOW.</td>
</tr>
<tr>
<td>F11</td>
<td>Opens the Styles window, where you can apply a formatting style to the contents of the cell or to the current sheet.</td>
</tr>
<tr>
<td>Shift+F11</td>
<td>Opens the Save As Template dialog, where you can create a document template.</td>
</tr>
<tr>
<td>Ctrl+Shift+F11</td>
<td>Updates the templates.</td>
</tr>
<tr>
<td>F12</td>
<td>Groups the selected data range as part of an outline.</td>
</tr>
<tr>
<td>Ctrl+F12</td>
<td>Ungroups the selected data range from an outline.</td>
</tr>
</tbody>
</table>

### Cell formatting shortcuts

**Note**

The numbered shortcut keys in Table 23, apart from Ctrl+1, do not use the number keys on the number pad, but rather those on the main keyboard.

*Table 23: Cell formatting shortcuts*
**Shortcut Keys** | **Effect**
---|---
Ctrl+1 | Opens the Format Cells dialog.
Ctrl+Shift+1 | Number format with two decimal places and the thousands separator
Ctrl+Shift+2 | Standard exponential format
Ctrl+Shift+3 | Standard date format
Ctrl+Shift+4 | Standard currency format
Ctrl+Shift+5 | Standard percentage format with two decimal places
Ctrl+Shift+6 | Standard format
Ctrl+M | Clears all formatting in the current cell.

**Pivot table shortcuts**

**Shortcut Keys** | **Effect**
---|---
Tab | Changes the focus by moving forwards through the elements of the Pivot Table Layout dialog.
Shift+Tab | Changes the focus by moving backwards through the elements of the Pivot Table Layout dialog.
Arrow keys | Moves the focus one item in the direction of the arrow in the current dialog area.
Home | Selects the first item in the current dialog area.
End | Selects the last item in the current dialog area.
Alt and the underlined character in one of the dialog field names. | Copies or moves the current field into the Row (Alt+R), Column (Alt+F), Data (Alt+D), Page (Alt+P), or Available (Alt+A) Fields areas, depending on which one you select.
Alt+O | Opens / closes the Options area on the Pivot Table Layout dialog.
Alt+S | Opens / closes the Source and Destination area on the Pivot Table Layout dialog.
Delete | Removes the current field from the area.

**Chart shortcuts**

**Tip**

You can use the Alt keys with the Arrow keys and plus (+) and minus (-) keys to move elements with a finer degree of movement for more accuracy.

**Table 24: Chart shortcuts**

**Shortcut Keys** | **Effect**
---|---
Tab | Selects the next chart element.
Shift+Tab | Selects the previous chart element.
Home | Selects the first chart element.
End | Selects the last chart element.
Esc | Cancels selection.
<table>
<thead>
<tr>
<th>Shortcut Keys</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Arrow keys</td>
<td>Moves the element in the direction of the arrow.</td>
</tr>
<tr>
<td>Arrow keys in pie charts</td>
<td>Moves the selected pie segment in the direction of the arrow.</td>
</tr>
<tr>
<td>F2 in titles</td>
<td>Enters text input mode.</td>
</tr>
<tr>
<td>F3 in legends and data series</td>
<td>Opens groups so that you can edit the individual components.</td>
</tr>
<tr>
<td>Ctrl+F3 in legends and data series</td>
<td>Exits groups.</td>
</tr>
<tr>
<td>+/-</td>
<td>Enlarges or shrinks the chart.</td>
</tr>
<tr>
<td>+/- in pie charts</td>
<td>Moves the selected pie segment off or into the pie chart.</td>
</tr>
</tbody>
</table>

### Outline accessibility shortcuts

To use these shortcuts, press F6 or Shift+F6 until the vertical or horizontal outline window has the focus.

**Table 25: Outline accessibility shortcuts**

<table>
<thead>
<tr>
<th>Shortcut Keys</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tab</td>
<td>Cycles through each outline indicator from top to bottom or left to right.</td>
</tr>
<tr>
<td>Shift+Tab</td>
<td>Cycles through each outline indicator in the opposite direction.</td>
</tr>
<tr>
<td>Ctrl+1 to Ctrl+8</td>
<td>Show all levels up to the specified number while hiding all higher-numbered levels in the outline.</td>
</tr>
<tr>
<td>+/-</td>
<td>Shows (+) or hides (-) the focused outline group.</td>
</tr>
<tr>
<td>Enter</td>
<td>Activates the focused indicator button.</td>
</tr>
<tr>
<td>Arrow keys</td>
<td>Cycles through indicator buttons in the direction of the arrow.</td>
</tr>
</tbody>
</table>
Appendix B
Description of Functions
Functions available in Calc

Calc provides all of the commonly used functions found in modern spreadsheet applications. Since many of Calc's functions require very specific and carefully calculated input arguments, the descriptions in this chapter should not be considered complete references for each function. Refer to the application Help or the LibreOffice wiki for details and examples of all functions.

Over 500 functions are available in Calc. More can be added through extensions to Calc (see Chapter 14). The following tables list Calc's functions organized into eleven categories.

![Note]

Functions whose names end with _ADD or _EXCEL2003 are provided for compatibility with Microsoft Excel 2003 functions. They return the same results as the corresponding functions in Excel 2003 (without the suffix), which though they may be correct, are not based on international standards. Calc automatically changes the function to _ADD or _EXCEL2003 for relevant functions in imported Excel 2003 spreadsheets.

Terminology: numbers and arguments

Some of the descriptions in this chapter define limitations on the number of values or arguments that can be passed to the function. Specifically, functions that refer to the following arguments may lead to confusion:

- **Number_1, number_2, ... number_30**
- Number 1 to 30
- a list of up to 30 numbers

There is a significant difference between a list of numbers (or integers) and the number of arguments a function will accept. For example, the SUM function will only accept a maximum of 30 arguments. This limit does not mean that you can only sum 30 numbers, but that you can only pass 30 separate arguments to the function.

Arguments are values separated by commas, and can include ranges which often refer to multiple values. Therefore one argument can refer to several values, and a function that limits input to 30 arguments may in fact accept more than 30 separate numerical values.

This chapter attempts to clarify this situation by using the term **arguments**, rather than any of the other phrases.

In the LibreOffice Calc functions, arguments marked as "optional" can be left out only when no argument follows. For example, in a function with four arguments, where the last two arguments are marked as "optional", you can leave out argument 4 or arguments 3 and 4, but you cannot leave out argument 3 alone.
# Mathematical functions

## Table 26: Mathematical functions

<table>
<thead>
<tr>
<th>Syntax</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ABS(Number)</td>
<td>Returns the absolute value of the given Number.</td>
</tr>
<tr>
<td>ACOS(Number)</td>
<td>Returns the inverse cosine of the given Number in radians.</td>
</tr>
<tr>
<td>ACOSH(Number)</td>
<td>Returns the inverse hyperbolic cosine of the given Number in radians.</td>
</tr>
<tr>
<td>ACOT(Number)</td>
<td>Returns the inverse cotangent of the given Number in radians.</td>
</tr>
<tr>
<td>ACOTH(Number)</td>
<td>Returns the inverse hyperbolic cotangent of the given Number in radians.</td>
</tr>
<tr>
<td>AGGREGATE(Function, Option, Ref1, Ref2, …) or AGGREGATE(Function, Option, Array, k)</td>
<td>Returns an aggregate result across the specified cells. The user can select the aggregation function to be used and which data to be ignored during the aggregation. The AGGREGATE function was designed for vertical ranges of data with the AutoFilter function activated. If AutoFilter is not activated, the AGGREGATE function's results will not be automatically recalculated to reflect newly hidden rows. It is possible to apply the AGGREGATE function to horizontal ranges but there are limitations – in particular, the function will not recognize hiding columns. The Function argument is a value, or a reference to a cell containing a value, in the range 1 to 19. This enables the user to select the aggregation function (for example, AVERAGE, COUNT, MAX, or MIN) with the mapping of values to functions described in the Help system. The Option argument is a value, or a reference to a cell containing a value, in the range 0 to 7. This enables the user to select the type of data that should be ignored during the aggregation, with the meaning of each value described in the Help system. Ref1, Ref2, …, Ref253 are numeric arguments or references to cells that contain them. This syntax variant is only intended for use with Function values in the range 1 to 13. The Array argument can be specified by the boundaries of the range, the name of the named range, or the column label. k is a numeric argument for certain functions and must correspond to the second argument of these functions (for example, the LARGE function requires a value for its Rank_c argument). k should be omitted for Function values 1 to 13, but should be included for those in the range 14 to 19.</td>
</tr>
<tr>
<td>ASIN(Number)</td>
<td>Returns the inverse sine of the given Number in radians.</td>
</tr>
<tr>
<td>ASINH(Number)</td>
<td>Returns the inverse hyperbolic sine of the given Number in radians.</td>
</tr>
<tr>
<td>ATAN(Number)</td>
<td>Returns the inverse tangent of the given Number in radians.</td>
</tr>
<tr>
<td>ATAN2(number_x, number_y)</td>
<td>Returns the inverse tangent of the specified x and y coordinates in radians. This is the angle between the x-axis and a line from the origin to the point (number_x, number_y).</td>
</tr>
<tr>
<td>Syntax</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>ATANH(Number)</td>
<td>Returns the inverse hyperbolic tangent of the given <strong>Number</strong> in radians.</td>
</tr>
<tr>
<td>BITAND(Number1, Number2)</td>
<td>This is the bitwise “AND” of two positive integers whose values are less than $2^{48}$.</td>
</tr>
<tr>
<td>BITLSHIFT(Number, Shift)</td>
<td>The bitwise left shift of a positive integer value. <strong>Number</strong> is an integer less than $2^{48}$. <strong>Shift</strong> is the number of bits to move by.</td>
</tr>
<tr>
<td>BITOR(Number1, Number2)</td>
<td>This is the bitwise “OR” of two positive integers whose values are less than $2^{48}$.</td>
</tr>
<tr>
<td>BITRSHIFT(Number, Shift)</td>
<td>The bitwise right shift of a positive integer value. <strong>Number</strong> is an integer less than $2^{48}$. <strong>Shift</strong> is the number of bits to move by.</td>
</tr>
<tr>
<td>BITXOR(number1, number2)</td>
<td>This is the bitwise “exclusive OR” of two positive integers whose values are less than $2^{48}$.</td>
</tr>
<tr>
<td>CEILING(Number, Significance, Mode)</td>
<td>Rounds up the given <strong>Number</strong> to the nearest multiple of the value of <strong>Significance</strong>. <strong>Significance</strong> is an optional value that defaults to -1 or +1, depending on the sign of <strong>Number</strong>. <strong>Mode</strong> is an optional value. If the <strong>Mode</strong> value is given and not equal to zero, and if <strong>Number</strong> and <strong>Significance</strong> are negative, then rounding is done based on the absolute value of <strong>Number</strong> so that negative numbers are rounded away from zero. If the <strong>Mode</strong> value is equal to zero or is not given, negative numbers are rounded towards zero. If the spreadsheet is exported to MS Excel, the CEILING function is exported as the equivalent CEILING.MATH function that has existed since Excel 2013. If you plan to use the spreadsheet with earlier Excel versions, use either CEILING.PRECISE that has existed since Excel 2010, or CEILING.XCL that is exported as the CEILING function compatible with all Excel versions.</td>
</tr>
<tr>
<td>CEILING.MATH(Number, Significance, Mode)</td>
<td>Rounds up the given <strong>Number</strong> to the nearest multiple of the value of <strong>Significance</strong>. <strong>Significance</strong> is an optional value that defaults to 1. <strong>Mode</strong> is an optional value. If the <strong>Mode</strong> value is given and not equal to zero, negative numbers are rounded away from zero. If the <strong>Mode</strong> value is equal to zero or is not given, negative numbers are rounded towards zero.</td>
</tr>
<tr>
<td>CEILING.PRECISE(Number; Significance)</td>
<td>Rounds the given <strong>Number</strong> up to the nearest multiple of <strong>Significance</strong>, regardless of the sign of <strong>Significance</strong>. <strong>Significance</strong> is an optional value.</td>
</tr>
<tr>
<td>CEILING.XCL(Number, Significance)</td>
<td>Rounds the given <strong>Number</strong> away from zero to the nearest multiple of <strong>Significance</strong>.</td>
</tr>
<tr>
<td>Syntax</td>
<td>Description</td>
</tr>
<tr>
<td>--------</td>
<td>-------------</td>
</tr>
<tr>
<td>COLOR(Red, Green, Blue, Alpha)</td>
<td>Returns a numeric value calculated by a combination of three colors (red, green, and blue) and the alpha channel, in the RGBA color system. The result depends on the color system used by your computer. The values for the Red, Green and Blue components of the color must be between 0 and 255. Alpha is an optional integer argument, with a value between 0 and 255. An Alpha value of 0 means the color is fully transparent, whereas a value of 255 gives a fully opaque color.</td>
</tr>
<tr>
<td>COMBIN(count_1, count_2)</td>
<td>Returns the number of combinations for elements without repetition. count_1 is the total number of elements. count_2 is the number to be combined from the elements. This is the same as the nCr function on a calculator.</td>
</tr>
<tr>
<td>COMBINA(count_1, count_2)</td>
<td>Returns the number of combinations for a given number of objects (repetition included). count_1 is the total number of elements. count_2 is the number to choose from the elements.</td>
</tr>
<tr>
<td>CONVERT_OOO(Value, From Unit, To Unit)</td>
<td>Converts a Value in Euros to another pre-Euro European currency, and vice versa. Enter the From Unit and To Unit directly as text in quotation marks or as a reference. If you enter the currencies in cells, they must correspond exactly with the list of allowed currencies, which is case sensitive. The list of allowed currencies and the conversion factors are defined in the configuration file main.xcd. The standard main.xcd file distributed with LibreOffice 6.2 includes conversion factors between Euros (“EUR”) and 19 other currencies (for example “ATS”, “BEF”, “CYP”, “DEM”, and so on).</td>
</tr>
<tr>
<td>COS(Number)</td>
<td>Returns the cosine of the Number (the angle in radians).</td>
</tr>
<tr>
<td>COSH(Number)</td>
<td>Returns the hyperbolic cosine of the Number (the angle in radians).</td>
</tr>
<tr>
<td>COT(Number)</td>
<td>Returns the cotangent of the Number (the angle in radians).</td>
</tr>
<tr>
<td>COTH(Number)</td>
<td>Returns the hyperbolic cotangent of the Number (the angle in radians).</td>
</tr>
<tr>
<td>CSC(Angle)</td>
<td>Returns the cosecant of an angle given in radians (1/SIN(X)).</td>
</tr>
<tr>
<td>CSCH(Angle)</td>
<td>Returns the hyperbolic cosecant of a hyperbolic angle (1/SINH(X)).</td>
</tr>
<tr>
<td>DEGREES(Number)</td>
<td>Converts the given Number in radians to degrees.</td>
</tr>
<tr>
<td>Syntax</td>
<td>Description</td>
</tr>
<tr>
<td>--------</td>
<td>-------------</td>
</tr>
<tr>
<td>EUROCONVERT(value, from_currency, to_currency, full_precision, triangulation_precision)</td>
<td>Converts from one pre-Euro currency to another, using conversion rates set by the European Commission. <strong>value</strong> is the value to be converted. <strong>from_currency</strong> is the ISO 4217 code of the currency from which <strong>value</strong> is to be converted. <strong>to_currency</strong> is the ISO 4217 code of the currency to which <strong>value</strong> is to be converted. <strong>from_currency</strong> and <strong>to_currency</strong> are not case sensitive. <strong>full_precision</strong> is optional. If omitted or set to 0, the result is rounded according to the decimals of the <strong>to_currency</strong>. For other values, the result is not rounded. <strong>triangulation_precision</strong> is optional. If <strong>triangulation_precision</strong> is given and &gt;=3, the intermediate result of a triangular conversion (currency1 -&gt; Euro -&gt; currency2) is rounded to that precision. If <strong>triangulation_precision</strong> is omitted, the intermediate result is not rounded. Also if <strong>to_currency</strong> is &quot;EUR&quot;, <strong>triangulation_precision</strong> is used as if triangulation was needed and conversion from Euro to Euro was applied. The following currency codes are recognized: &quot;ATS&quot;, &quot;BEF&quot;, &quot;CYP&quot;, &quot;DEM&quot;, &quot;ESP&quot;, &quot;EUR&quot;, &quot;FIM&quot;, &quot;FRF&quot;, &quot;GRD&quot;, &quot;IEP&quot;, &quot;ITL&quot;, &quot;LUF&quot;, &quot;NLG&quot;, &quot;PTE&quot;, &quot;SIT&quot;.</td>
</tr>
<tr>
<td>EVEN(Number)</td>
<td>Rounds a positive <strong>Number</strong> up to the next even integer, and a negative <strong>Number</strong> down to the next even integer.</td>
</tr>
<tr>
<td>EXP(Number)</td>
<td>Returns the constant e raised to the power of the given <strong>Number</strong>.</td>
</tr>
<tr>
<td>FACT(Number)</td>
<td>Returns the factorial of the given <strong>Number</strong>.</td>
</tr>
<tr>
<td>FLOOR(Number, Significance, Mode)</td>
<td>Rounds down the given <strong>Number</strong> to the nearest multiple of the value of <strong>Significance</strong>. <strong>Significance</strong> is an optional value that defaults to -1 or +1, depending on the sign of <strong>Number</strong>. <strong>Mode</strong> is an optional value. If the <strong>Mode</strong> value is given and not equal to zero, and if <strong>Number</strong> and <strong>Significance</strong> are negative, then rounding is done based on the absolute value of <strong>Number</strong> so that negative numbers are rounded towards zero. If the <strong>Mode</strong> value is equal to zero or omitted, negative numbers are rounded away from zero. If the spreadsheet is exported to MS Excel, the FLOOR function is exported as the equivalent FLOOR.MATH function that has existed since Excel 2013. If you plan to use the spreadsheet with earlier Excel versions, use either FLOOR.PRECISE that has existed since Excel 2010, or FLOOR.XCL that is exported as the FLOOR function compatible with all Excel versions.</td>
</tr>
<tr>
<td>FLOOR.MATH(Number, Significance, Mode)</td>
<td>Rounds down the given <strong>Number</strong> to the nearest multiple of the value of <strong>Significance</strong>. <strong>Significance</strong> is an optional value that defaults to 1. <strong>Mode</strong> is an optional value. If the <strong>Mode</strong> value is given and not equal to zero, negative numbers are rounded towards zero. If the <strong>Mode</strong> value is equal to zero or is not given, negative numbers are rounded away from zero.</td>
</tr>
<tr>
<td>Syntax</td>
<td>Description</td>
</tr>
<tr>
<td>------------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>FLOOR.PRECISE(Number, Significance)</td>
<td>Rounds the given <strong>Number</strong> down to the nearest multiple of the value of <strong>Significance</strong>, regardless of the sign of <strong>Significance</strong>. <strong>Significance</strong> is an optional value.</td>
</tr>
<tr>
<td>FLOOR.XCL(Number, Significance)</td>
<td>Rounds the given <strong>Number</strong> towards zero to the nearest multiple of the absolute value of <strong>Significance</strong>.</td>
</tr>
<tr>
<td>GCD(Integer1, Integer2, ..., Integer30)</td>
<td>Returns the greatest common divisor of one or more positive integers. <strong>Integers</strong>X is a list of up to 30 integers, at least one of which must be greater than zero, whose greatest common divisor is to be calculated. This gives a result based on international standards.</td>
</tr>
<tr>
<td>GCD_EXCEL2003(Number1, Number 2, ..., Number 30)</td>
<td>Returns the greatest common divisor of a list of up to 30 numbers. This function returns the same result as the corresponding Microsoft Excel 2003 GCD function. Use Calc's GCD function to get results based on international standards.</td>
</tr>
<tr>
<td>INT(Number)</td>
<td>Rounds the given <strong>Number</strong> down to the nearest integer.</td>
</tr>
<tr>
<td>ISO.CEILING(Number, Significance)</td>
<td>Rounds a number up to the nearest multiple of the value of <strong>Significance</strong>, regardless of the sign of <strong>Significance</strong>. <strong>Significance</strong> is an optional value.</td>
</tr>
<tr>
<td>LCM(Integer1, Integer2, ..., Integer30)</td>
<td>Returns the lowest common multiple of one or more integers. <strong>Integer 1</strong>, <strong>Integer 2</strong>, ..., <strong>Integer 30</strong> are integers whose lowest common multiple is to be calculated.</td>
</tr>
<tr>
<td>LCM_EXCEL2003(Number1, Number2, ..., Number30)</td>
<td>Returns the lowest common multiple of a list of up to 30 numbers. This function returns the same result as the corresponding Microsoft Excel 2003 LCM function. Use Calc's LCM function to get results based on international standards.</td>
</tr>
<tr>
<td>LN(Number)</td>
<td>Returns the natural logarithm, based on the constant e, of the given <strong>Number</strong> &gt;0.</td>
</tr>
<tr>
<td>LOG(Number, Base)</td>
<td>Returns the logarithm of the given <strong>Number</strong> (value &gt;0) to the specified base. <strong>Base</strong> is the base for the logarithm calculation. If omitted, 10 is assumed.</td>
</tr>
<tr>
<td>LOG10(Number)</td>
<td>Returns the base-10 logarithm of a <strong>Number</strong> &gt;0.</td>
</tr>
<tr>
<td>MOD(Dividend, Divisor)</td>
<td>Returns the remainder after a number is divided by a divisor. <strong>Dividend</strong> is the number to be divided. <strong>Divisor</strong> is the number by which <strong>Dividend</strong> is divided.</td>
</tr>
<tr>
<td>MROUND(Number, Multiple)</td>
<td>Returns <strong>Number</strong> rounded to the nearest multiple of <strong>Multiple</strong>.</td>
</tr>
<tr>
<td>MULTINOMIAL (Number(s)1, ..., Number(s)30)</td>
<td>Returns the factorial of the sum of the arguments divided by the product of the factorials of the arguments. <strong>Number(s)X</strong> is a list of up to 30 numbers.</td>
</tr>
<tr>
<td>ODD(Number)</td>
<td>Rounds <strong>Number</strong> up if positive and down if negative, to the nearest odd integer.</td>
</tr>
<tr>
<td>PI()</td>
<td>Returns the value of the constant pi (π) to fourteen decimal places.</td>
</tr>
<tr>
<td>Syntax</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>--------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>POWER(Base, Exponent)</td>
<td>Returns the result of a number raised to a power. <strong>Base</strong> is the number that is to be raised to the given power. <strong>Exponent</strong> is the exponent by which <strong>Base</strong> is to be raised.</td>
</tr>
<tr>
<td>PRODUCT(Number1, Number2, ..., Number30)</td>
<td>Multiplies all the numbers given as arguments and returns the product. <strong>Number 1 to Number 30</strong> are up to 30 arguments whose product is to be calculated.</td>
</tr>
<tr>
<td>QUOTIENT(Numerator, Denominator)</td>
<td>Returns the integer result of a division operation. <strong>Numerator</strong> is the number that will be divided. <strong>Denominator</strong> is the number <strong>Numerator</strong> will be divided by.</td>
</tr>
<tr>
<td>RADIANS(Number)</td>
<td>Converts the given <strong>Number</strong> in degrees to radians.</td>
</tr>
<tr>
<td>RAND()</td>
<td>Returns a random number between 0 and 1. This number will recalculate every time <strong>F9</strong> is pressed.</td>
</tr>
<tr>
<td>RANDBETWEEN (Bottom, Top)</td>
<td>Returns an integer random number between <strong>Bottom</strong> and <strong>Top</strong> (inclusive). This number will recalculate every time <strong>F9</strong> is pressed.</td>
</tr>
<tr>
<td>RAWSUBTRACT(Minuend, Subtrahend1, Subtrahend2, ...)</td>
<td>Subtracts the <strong>Subtrahend(s)</strong> from the <strong>Minuend</strong> without eliminating roundoff errors. The function should be called with at least two arguments.</td>
</tr>
<tr>
<td>ROUND(number, count)</td>
<td>Rounds the given <strong>number</strong> to <strong>count</strong> (optional) decimal places. If the <strong>count</strong> argument is omitted or zero, <strong>number</strong> rounds to the nearest integer. If <strong>count</strong> is negative, the function rounds to the nearest 10, 100, 1000 and so on.</td>
</tr>
<tr>
<td>ROUNDDOWN(number, count)</td>
<td>Rounds the given <strong>number</strong> down (toward zero), to <strong>count</strong> (optional) decimal places. If <strong>count</strong> is omitted or zero, the function rounds down to an integer. If <strong>count</strong> is negative, the function rounds down to the next 10, 100, 1000 and so on.</td>
</tr>
<tr>
<td>ROUNDSIG(Value, Digits)</td>
<td>Rounds a <strong>Value</strong> to a defined number of significant <strong>Digits</strong>.</td>
</tr>
<tr>
<td>ROUNDUP(number, count)</td>
<td>Rounds the given <strong>number</strong> up (away from zero), to <strong>count</strong> (optional) decimal places. If <strong>count</strong> is omitted or zero, the function rounds up to an integer. If <strong>count</strong> is negative, the function rounds up to the nearest 10, 100, 1000 and so on.</td>
</tr>
<tr>
<td>SEC(Angle)</td>
<td>Returns the secant of an <strong>Angle</strong> given in radians. <strong>SEC(x)=1/COS(x).</strong></td>
</tr>
<tr>
<td>SECH(Angle)</td>
<td>Returns the hyperbolic secant of an <strong>Angle</strong> given in radians. <strong>SECH(x)=1/COSH(x).</strong></td>
</tr>
<tr>
<td>SERIESSUM(X, N, M, Coefficients)</td>
<td>Returns the sum of the initial terms in a power series. <strong>X</strong> is the number as an independent variable. <strong>N</strong> is the starting power. <strong>M</strong> is the increment. <strong>Coefficients</strong> is a series of coefficients. For each coefficient the series sum is extended by one section. You can only enter coefficients using a cell range.</td>
</tr>
<tr>
<td>SIGN(Number)</td>
<td>Returns the sign of the given <strong>Number</strong>. The function returns the result 1 for a positive sign, –1 for a negative sign, and 0 for zero.</td>
</tr>
<tr>
<td>SIN(number)</td>
<td>Returns the sine of the given <strong>number</strong> (angle in radians).</td>
</tr>
<tr>
<td>Syntax</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>SINH(number)</td>
<td>Returns the hyperbolic sine of the given number (angle in radians).</td>
</tr>
<tr>
<td>SQRT(number)</td>
<td>Returns the positive square root of the given positive number.</td>
</tr>
<tr>
<td>SQRTPI(Number)</td>
<td>Returns the square root of the product of the given Number and the constant pi (π).</td>
</tr>
<tr>
<td>SUBTOTAL(Function, range)</td>
<td>Calculates subtotals. If a range already contains subtotals, these are not used for further calculations. Use this function with AutoFilters activated to take only the filtered records into account. Function is a value that selects which function should be used to create the subtotal (for example, Average, Count, Min, Sum, or Var) and also determines whether manually hidden rows should be included. The set of allowed Function values is listed in the Help system. range is the range of cells included.</td>
</tr>
<tr>
<td>SUM(number 1, number 2, ..., number 30)</td>
<td>Adds all the numbers in a range of cells. number 1, number 2, ..., number 30 are up to 30 arguments whose sum is to be calculated. You can also enter a range using cell references.</td>
</tr>
<tr>
<td>SUMIF(range, criteria, sum_range)</td>
<td>Adds the cells specified by the given criteria. The search supports regular expressions. range is the range to which the criteria are to be applied. criteria is the cell in which the search criterion is shown, or the search criterion itself (in double quotes). sum_range (optional) is the range from which values are summed; if it has not been entered, the values found in the range are summed. If supplied, sum_range must be the same size and shape as range.</td>
</tr>
<tr>
<td>SUMIFS(sum_range, range 1, criteria 1, range 2, criteria 2, ..., range 127, criteria 127)</td>
<td>Totals the values of cells in a range that meet multiple criteria in multiple ranges. sum_range is the cell range from which the values are to be totaled. range 1 is the cell range to be evaluated by criteria 1, range 2 (optional) by criteria 2 (optional), and so on. All ranges must have the same size and shape. The function can have up to 255 arguments, meaning that you can specify 127 criteria ranges and criteria for them.</td>
</tr>
<tr>
<td>SUMSQ(number 1, number 2, ..., number 30)</td>
<td>Calculates the sum of the squares of numbers (totaling up of the squares of the arguments). number 1, number 2, ..., number 30 are up to 30 arguments, the sum of whose squares is to be calculated.</td>
</tr>
<tr>
<td>TAN(number)</td>
<td>Returns the tangent of the given number (angle in radians).</td>
</tr>
<tr>
<td>TANH(number)</td>
<td>Returns the hyperbolic tangent of the given number (angle in radians).</td>
</tr>
<tr>
<td>TRUNC(number, count)</td>
<td>Truncates a number by removing decimal places. number is the number whose decimal places are to be trimmed. count is the number of decimal places which are retained. If count is zero, it effectively truncates to a decimal integer. If count is negative, it truncates to the left of the decimal point.</td>
</tr>
</tbody>
</table>
Financial analysis functions

A note about dates

Date values used as arguments for Calc’s financial functions must comply with ISO8601 and be entered surrounded by double quotes. For example, a date representing August 6, 2004, must be entered “2004-08-06”, single digits are padded with leading zeroes. If you do not enter the date values as required by the function, you will not get the correct results. Date formats are locale specific and will allow other formats to be used. Among others, the en_US locale allows “2004/08/06” and “08/06/2004” for example. Check the Help for the acceptable formatting.

A note about interest rates

You can enter interest rates in either of two ways:

- As a decimal. To enter an interest rate as a decimal, divide it by 100 before entering it into a function. For example, to compute a loan with a 3.25% interest rate, enter .0325 into the function.
- As a percentage. To enter an interest rate as a percentage, type in the interest rate followed by the % key. For example, to compute a loan with a 3.25% interest rate, enter 3.25% into the function.

If you enter it as 3.25, the function will treat it as a 325% interest rate.

Accounting systems vary in the number of days in a month or a year used in calculations. The following table gives the integers used for the Basis argument used in some of the financial analysis functions.

<table>
<thead>
<tr>
<th>Basis</th>
<th>Calculation</th>
</tr>
</thead>
<tbody>
<tr>
<td>0 or missing</td>
<td>US method (NASD), 12 months of 30 days each.</td>
</tr>
<tr>
<td>1</td>
<td>Exact number of days in months, exact number of days in year.</td>
</tr>
<tr>
<td>2</td>
<td>Exact number of days in month, year has 360 days.</td>
</tr>
<tr>
<td>3</td>
<td>Exact number of days in month, year has 365 days.</td>
</tr>
<tr>
<td>4</td>
<td>European method, 12 months of 30 days each.</td>
</tr>
</tbody>
</table>

Table 27: Basis calculation types

Table 28: Financial analysis functions

<table>
<thead>
<tr>
<th>Syntax</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ACRINT(Issue, First interest, Settlement, Rate, Par, Frequency, Basis)</td>
<td>Calculates the accrued interest of a security in the case of periodic payments. <strong>Issue</strong> is the issue date of the security. <strong>First interest</strong> is the first interest date of the security. <strong>Settlement</strong> is the date at which the interest accrued up until then is to be calculated. <strong>Rate</strong> is the annual nominal rate of interest (coupon interest rate). <strong>Par</strong> (optional) is the par value of the security. <strong>Frequency</strong> is the number of interest payments per year (1, 2 or 4). <strong>Basis</strong> (optional) indicates how the year is to be calculated.</td>
</tr>
<tr>
<td><strong>Syntax</strong></td>
<td><strong>Description</strong></td>
</tr>
<tr>
<td>------------</td>
<td>----------------</td>
</tr>
<tr>
<td>ACCRINTM(Issue, Settlement, Rate, Par, Basis)</td>
<td>Calculates the accrued interest of a security in the case of one-off payment at the settlement date. <strong>Issue</strong> is the issue date of the security. <strong>Settlement</strong> is the maturity date. <strong>Rate</strong> is the annual nominal rate of interest (coupon interest rate). <strong>Par</strong> (optional) is the par value of the security. <strong>Basis</strong> (optional) indicates how the year is to be calculated.</td>
</tr>
<tr>
<td>AMORDEGRC(Cost, Date purchased, First period, Salvage, Period, Rate, Basis)</td>
<td>Calculates the amount of depreciation for a settlement period as degressive amortization. Unlike AMORLINC, a depreciation coefficient that is independent of the depreciable life is used here. <strong>Cost</strong> is the acquisition cost. <strong>Date purchased</strong> is the date of acquisition. <strong>First period</strong> is the end date of the first settlement period. <strong>Salvage</strong> is the salvage value of the capital asset at the end of the depreciable life. <strong>Period</strong> is the settlement period to be considered. <strong>Rate</strong> is the rate of depreciation. <strong>Basis</strong> (optional) indicates how the year is to be calculated.</td>
</tr>
<tr>
<td>AMORLINC(Cost, Date purchased, First period, Salvage, Period, Rate, Basis)</td>
<td>Calculates the amount of depreciation for a settlement period as linear amortization. If the capital asset is purchased during the settlement period, the proportional amount of depreciation is considered. <strong>Cost</strong> is the acquisition cost. <strong>Date purchased</strong> is the date of acquisition. <strong>First period</strong> is the end date of the first settlement period. <strong>Salvage</strong> is the salvage value of the capital asset at the end of the depreciable life. <strong>Period</strong> is the settlement period to be considered. <strong>Rate</strong> is the rate of depreciation. <strong>Basis</strong> (optional) indicates how the year is to be calculated.</td>
</tr>
<tr>
<td>COUPDAYBS(Settlement, Maturity, Frequency, Basis)</td>
<td>Returns the number of days from the first day of interest payment on a security until the settlement date. <strong>Settlement</strong> is the date of purchase of the security. <strong>Maturity</strong> is the date on which the security matures (expires). <strong>Frequency</strong> is the number of interest payments per year (1, 2 or 4). <strong>Basis</strong> (optional) indicates how the year is to be calculated.</td>
</tr>
<tr>
<td>COUPDAYS(Settlement, Maturity, Frequency, Basis)</td>
<td>Returns the number of days in the current interest period in which the settlement date falls. <strong>Settlement</strong> is the date of purchase of the security. <strong>Maturity</strong> is the date on which the security matures (expires). <strong>Frequency</strong> is the number of interest payments per year (1, 2 or 4). <strong>Basis</strong> (optional) indicates how the year is to be calculated.</td>
</tr>
<tr>
<td>COUPDAYSNC(Settlement, Maturity, Frequency, Basis)</td>
<td>Returns the number of days from the settlement date until the next interest date. <strong>Settlement</strong> is the date of purchase of the security. <strong>Maturity</strong> is the date on which the security matures (expires). <strong>Frequency</strong> is the number of interest payments per year (1, 2 or 4). <strong>Basis</strong> (optional) indicates how the year is to be calculated.</td>
</tr>
<tr>
<td>COUPNCD(Settlement, Maturity, Frequency, Basis)</td>
<td>Returns the date of the first interest date after the settlement date, and formats the result as a date. <strong>Settlement</strong> is the date of purchase of the security. <strong>Maturity</strong> is the date on which the security matures (expires). <strong>Frequency</strong> is the number of interest payments per year (1, 2 or 4). <strong>Basis</strong> (optional) indicates how the year is to be calculated.</td>
</tr>
</tbody>
</table>

*A note about interest rates*
<table>
<thead>
<tr>
<th>Syntax</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>COUPNUM(Settlement, Maturity, Frequency, Basis)</td>
<td>Returns the number of coupons (interest payments) between the settlement date and the maturity date. <strong>Settlement</strong> is the date of purchase of the security. <strong>Maturity</strong> is the date on which the security matures (expires). <strong>Frequency</strong> is the number of interest payments per year (1, 2 or 4). <strong>Basis</strong> (optional) indicates how the year is to be calculated.</td>
</tr>
<tr>
<td>COUPPCD(Settlement, Maturity, Frequency, Basis)</td>
<td>Returns the date of the interest date prior to the settlement date, and formats the result as a date. <strong>Settlement</strong> is the date of purchase of the security. <strong>Maturity</strong> is the date on which the security matures (expires). <strong>Frequency</strong> is the number of interest payments per year (1, 2 or 4). <strong>Basis</strong> (optional) indicates how the year is to be calculated.</td>
</tr>
<tr>
<td>CUMIPMT(Rate, NPER, pv, S, E, Type)</td>
<td>Calculates the cumulative interest payments (the total interest) for an investment based on a constant interest rate. <strong>Rate</strong> is the periodic interest rate. <strong>NPER</strong> is the payment period with the total number of periods. <strong>NPER</strong> can also be a non-integer value. The <strong>Rate</strong> and <strong>NPER</strong> must refer to the same unit, and thus both must be calculated annually or monthly. <strong>pv</strong> is the current value in the sequence of payments. <strong>S</strong> is the first period. <strong>E</strong> is the last period. <strong>Type</strong> is the due date of the payment at the beginning (1) or end (0) of each period.</td>
</tr>
<tr>
<td>CUMIPMT_ADD(Rate, Nper, Pv, Start period, End period, Type)</td>
<td>Calculates the accumulated interest for a period. <strong>Rate</strong> is the interest rate for each period. <strong>Nper</strong> is the total number of payment periods. The <strong>Rate</strong> and <strong>Nper</strong> must refer to the same unit, and thus both must be calculated annually or monthly. <strong>Pv</strong> is the current value. <strong>Start period</strong> must refer to the same unit, and thus both must be calculated annually or monthly. <strong>End period</strong> is the last payment period for the calculation. <strong>Type</strong> is the due date of the payment at the beginning (1) or end (0) of each period.</td>
</tr>
<tr>
<td>CUMPRINC(Rate, NPER, PV, S, E, Type)</td>
<td>Returns the cumulative interest paid for an investment period with a constant interest rate. <strong>Rate</strong> is the periodic interest rate. <strong>NPER</strong> is the payment period with the total number of periods. <strong>NPER</strong> can also be a non-integer value. The <strong>Rate</strong> and <strong>NPER</strong> must refer to the same unit, and thus both must be calculated annually or monthly. <strong>PV</strong> is the current value in the sequence of payments. <strong>S</strong> is the first period. <strong>E</strong> is the last period. <strong>Type</strong> is the due date of the payment at the beginning (1) or end (0) of each period.</td>
</tr>
<tr>
<td>CUMPRINC_ADD(Rate, Nper, Pv, Start period, End period, Type)</td>
<td>Calculates the cumulative redemption of a loan in a period. <strong>Rate</strong> is the interest rate for each period. <strong>Nper</strong> is the total number of payment periods. The <strong>Rate</strong> and <strong>Nper</strong> must refer to the same unit, and thus both must be calculated annually or monthly. <strong>Pv</strong> is the current value. <strong>Start period</strong> is the first payment period for the calculation. <strong>End period</strong> is the last payment period for the calculation. <strong>Type</strong> is the due date of the payment at the beginning (1) or end (0) of each period.</td>
</tr>
<tr>
<td>Syntax</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>DB(Cost, Salvage, Life, Period, month)</td>
<td>Returns the depreciation of an asset for a specified period using the fixed-declining balance method. <strong>Cost</strong> is the initial cost of an asset. <strong>Salvage</strong> is the value of an asset at the end of the depreciation. <strong>Life</strong> defines the period over which an asset is depreciated. <strong>Period</strong> is the length of each period. The life must be entered in the same date unit as the depreciation period. <strong>month</strong> (optional) denotes the number of months for the first year of depreciation (defaults to 12).</td>
</tr>
<tr>
<td>DDB(Cost, Salvage, Life, Period, Factor)</td>
<td>Returns the depreciation of an asset for a specified period using the arithmetic-declining method. Note that the book value will never reach zero under this calculation type. <strong>Cost</strong> fixes the initial cost of an asset. <strong>Salvage</strong> fixes the value of an asset at the end of its life. <strong>Life</strong> is the number of periods defining how long the asset is to be used. <strong>Period</strong> defines the length of the period. The period must be entered in the same time unit as the life. <strong>Factor</strong> (optional) is the factor by which depreciation decreases. If no value is entered, a value of 2 is assumed, making this double declining.</td>
</tr>
<tr>
<td>DISC(Settlement, Maturity, Price, Redemption, Basis)</td>
<td>Calculates the allowance (discount) of a security as a percentage. <strong>Settlement</strong> is the date of purchase of the security. <strong>Maturity</strong> is the date on which the security matures (expires). <strong>Price</strong> is the price of the security per 100 currency units of par value. <strong>Redemption</strong> is the redemption value of the security per 100 currency units of par value. <strong>Basis</strong> (optional) indicates how the year is to be calculated.</td>
</tr>
<tr>
<td>DOLLARDE(Fractional dollar, Fraction)</td>
<td>Converts a quotation that has been given as a decimal fraction into a decimal number. <strong>Fractional dollar</strong> is a number given as a decimal fraction. (In this number, the decimal value is the numerator of the fraction.) <strong>Fraction</strong> is a whole number that is used as the denominator of the decimal fraction.</td>
</tr>
<tr>
<td>DOLLARFR(Decimal dollar, Fraction)</td>
<td>Converts a quotation that has been given as a decimal number into a mixed decimal fraction. The decimal of the result is the numerator of the fraction that would have <strong>Fraction</strong> as the denominator. <strong>Decimal dollar</strong> is a decimal number. <strong>Fraction</strong> is a whole number that is used as the denominator of the decimal fraction.</td>
</tr>
<tr>
<td>DURATION(Settlement, Maturity, Coupon, Yield, Frequency, Basis)</td>
<td>Calculates the duration of a fixed interest security in years. <strong>Settlement</strong> is the date of purchase of the security. <strong>Maturity</strong> is the date on which the security matures (expires). <strong>Coupon</strong> is the annual coupon interest rate (nominal rate of interest). <strong>Yield</strong> is the annual yield of the security. <strong>Frequency</strong> is the number of interest payments per year (1, 2 or 4). <strong>Basis</strong> (optional) indicates how the year is to be calculated.</td>
</tr>
<tr>
<td>EFFECT(NOM, P)</td>
<td>Calculates the effective annual rate of interest on the basis of the nominal interest rate and the number of interest payments per annum. Nominal interest rate refers to the amount of interest due at the end of a calculation period. <strong>NOM</strong> is the nominal interest rate. <strong>P</strong> is the number of interest payment periods per year.</td>
</tr>
<tr>
<td>Syntax</td>
<td>Description</td>
</tr>
<tr>
<td>--------</td>
<td>-------------</td>
</tr>
<tr>
<td>EFFECT_ADD(Nominal rate, Npery)</td>
<td>Calculates the effective annual rate of interest on the basis of the nominal interest rate and the number of interest payments per annum. Nominal interest rate refers to the amount of interest due at the end of a calculation period. <strong>Nominal rate</strong> is the nominal interest rate. <strong>Npery</strong> is the number of interest payments per year. This function returns the same result as the corresponding Microsoft Excel 2003 function without the suffix. Use the Calc function without a suffix to get results based on international standards.</td>
</tr>
<tr>
<td>FV(Rate, NPER, PMT, PV, Type)</td>
<td>Returns the future value of an investment based on periodic, constant payments and a constant interest rate. <strong>Rate</strong> is the periodic interest rate. <strong>NPER</strong> is the total number of periods. <strong>PMT</strong> is the annuity paid regularly per period. <strong>PV</strong> (optional) is the present cash value of an investment. <strong>Type</strong> (optional) defines whether the payment is due at the beginning (1) or the end (0) of a period.</td>
</tr>
<tr>
<td>FVSCHEDULE(Principal, Schedule)</td>
<td>Calculates the accumulated value of the starting capital for a series of periodically varying interest rates. <strong>Principal</strong> is the starting capital. <strong>Schedule</strong> is a series of interest rates. <strong>Schedule</strong> has to be entered with cell references, or with a list.</td>
</tr>
<tr>
<td>INTRATE(Settlement, Maturity, Investment, Redemption, Basis)</td>
<td>Calculates the annual interest rate that results when a security (or other item) is purchased at an investment value and sold at a redemption value with no interest being paid. <strong>Settlement</strong> is the date of purchase of the security. <strong>Maturity</strong> is the date on which the security is sold. <strong>Investment</strong> is the purchase price. <strong>Redemption</strong> is the selling price. <strong>Basis</strong> (optional) indicates how the year is to be calculated.</td>
</tr>
<tr>
<td>IPMT(Rate, Period, NPER, pv, FV, Type)</td>
<td>Calculates the periodic amortization for an investment with regular payments and a constant interest rate. <strong>Rate</strong> is the periodic interest rate. <strong>Period</strong> is the period for which the compound interest is calculated. <strong>NPER</strong> is the total number of periods during which annuity is paid. <strong>Period=NPER</strong>, if compound interest for the last period is calculated. <strong>pv</strong> is the present cash value in a sequence of payments. <strong>FV</strong> (optional) is the desired value (future value) at the end of the periods. <strong>Type</strong> (optional) defines whether the payment is due at the beginning (1) or the end (0) of a period.</td>
</tr>
<tr>
<td>IRR(Values, Guess)</td>
<td>Calculates the internal rate of return for an investment. The values represent cash flow values at regular intervals; at least one value must be negative (payments), and at least one value must be positive (income). <strong>Values</strong> is an array or cell range containing the values. <strong>Guess</strong> (optional) is the estimated value. If you can provide only a few values, you should provide an initial guess to enable the iteration.</td>
</tr>
<tr>
<td>ISPMT(rate, Period, total_periods, invest)</td>
<td>Calculates the level of interest for unchanged amortization installments. <strong>rate</strong> sets the periodic interest rate. <strong>Period</strong> is the number of installments for calculation of interest. <strong>total_periods</strong> is the total number of installment periods. <strong>invest</strong> is the amount of the investment.</td>
</tr>
<tr>
<td>Syntax</td>
<td>Description</td>
</tr>
<tr>
<td>--------</td>
<td>-------------</td>
</tr>
<tr>
<td>MDURATION(Settlement, Maturity, Coupon, Yield, Frequency, Basis)</td>
<td>Calculates the modified Macauley duration for a security with an assumed par value of 100 currency units. <strong>Settlement</strong> is the date of purchase of the security. <strong>Maturity</strong> is the date on which the security matures (expires). <strong>Coupon</strong> is the annual nominal rate of interest (coupon interest rate). <strong>Yield</strong> is the annual yield of the security. <strong>Frequency</strong> is the number of interest payments per year (1, 2 or 4). <strong>Basis</strong> (optional) indicates how the year is to be calculated.</td>
</tr>
<tr>
<td>MIRR(Values, investment, reinvest_rate)</td>
<td>Calculates the modified internal rate of return of a series of investments. <strong>Values</strong> corresponds to the array or the cell reference for cells whose content corresponds to the payments. <strong>investment</strong> is the rate of interest of the investments (the negative values of the array). <strong>reinvest_rate</strong> is the rate of interest of the reinvestment (the positive values of the array).</td>
</tr>
<tr>
<td>NOMINAL(effect_rate, npery)</td>
<td>Calculates the yearly nominal interest rate, given the effective rate and the number of compounding periods per year. <strong>effect_rate</strong> is the effective interest rate. <strong>npery</strong> is the number of periodic interest payments per year. Returns a percentage.</td>
</tr>
<tr>
<td>NOMINAL_ADD(Effective_rate, Npery)</td>
<td>Calculates the yearly nominal rate of interest, given the effective rate and the number of compounding periods per year. <strong>Effective_rate</strong> is the effective annual rate of interest. <strong>Npery</strong> is the number of interest payments per year. Returns a number.</td>
</tr>
<tr>
<td>NPER(Rate, PMT, PV, FV, Type)</td>
<td>Returns the number of periods for an investment based on periodic, constant payments and a constant interest rate. <strong>Rate</strong> is the periodic interest rate. <strong>PMT</strong> is the constant annuity paid in each period. <strong>PV</strong> is the present value (cash value) in a sequence of payments. <strong>FV</strong> (optional, default 0) is the future value, which is reached at the end of the last period. <strong>Type</strong> (optional) defines whether the payment is due at the beginning (1) or the end (0) of a period.</td>
</tr>
<tr>
<td>NPV(Rate, value 1, value 2, ..., value 30)</td>
<td>Returns the net present value of an investment based on a series of periodic cash flows and a discount rate. <strong>Rate</strong> is the discount rate for a period. <strong>value 1, value 2, ..., value 30</strong> are values representing deposits or withdrawals.</td>
</tr>
<tr>
<td>ODDFPRICE(Settlement, Maturity, Issue, First coupon, Rate, Yield, Redemption, Frequency, Basis)</td>
<td>Calculates the price per 100 currency units par value of a security, having an odd (short or long) first period. <strong>Settlement</strong> is the date of purchase of the security. <strong>Maturity</strong> is the date on which the security matures (expires). <strong>Issue</strong> is the date of issue of the security. <strong>First coupon</strong> is the first interest date of the security. <strong>Rate</strong> is the annual rate of interest. <strong>Yield</strong> is the annual yield of the security. <strong>Redemption</strong> is the redemption value per 100 currency units of par value. <strong>Frequency</strong> is the number of interest payments per year (1, 2 or 4). <strong>Basis</strong> (optional) indicates how the year is to be calculated.</td>
</tr>
<tr>
<td>Syntax</td>
<td>Description</td>
</tr>
<tr>
<td>--------</td>
<td>-------------</td>
</tr>
<tr>
<td>ODDFYIELD(Settlement, Maturity, Issue, First coupon, Rate, Price, Redemption, Frequency, Basis)</td>
<td>Calculates the yield of a security that has an odd (short or long) first period. Settlement is the date of purchase of the security. Maturity is the date on which the security matures (expires). Issue is the date of issue of the security. First coupon is the first interest date of the security. Rate is the annual rate of interest. Price is the price of the security. Redemption is the redemption value per 100 currency units of par value. Frequency is the number of interest payments per year (1, 2 or 4). Basis (optional) indicates how the year is to be calculated.</td>
</tr>
<tr>
<td>ODDLPRICE(Settlement, Maturity, Last interest, Rate, Yield, Redemption, Frequency, Basis)</td>
<td>Calculates the price per 100 currency units par value of a security, that has an odd (short or long) last period. Settlement is the date of purchase of the security. Maturity is the date on which the security matures (expires). Last interest is the last interest date of the security. Rate is the annual rate of interest. Yield is the annual yield of the security. Redemption is the redemption value per 100 currency units of par value. Frequency is the number of interest payments per year (1, 2 or 4). Basis (optional) indicates how the year is to be calculated.</td>
</tr>
<tr>
<td>ODDLYIELD(Settlement, Maturity, Last interest, Rate, Price, Redemption, Frequency, Basis)</td>
<td>Calculates the yield of a security that has an odd (short or long) last period. Settlement is the date of purchase of the security. Maturity is the date on which the security matures (expires). Last interest is the last interest date of the security. Rate is the annual rate of interest. Price is the price of the security. Redemption is the redemption value per 100 currency units of par value. Frequency is the number of interest payments per year (1, 2 or 4). Basis (optional) indicates how the year is to be calculated.</td>
</tr>
</tbody>
</table>
### Syntax

<table>
<thead>
<tr>
<th>Syntax</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>OPT_BARRIER(Spot, Volatility, Rate, Foreign Rate, Maturity, Strike, Lower Barrier, Upper Barrier, Rebate, Put or Call, In or Out, Barrier Monitoring, Greek)</td>
<td>Returns the pricing for a barrier option, calculated using the Black-Scholes option pricing model. <strong>Spot</strong> is the price / value of the underlying asset and should be greater than 0.0. <strong>Volatility</strong> is the annual percentage volatility of the underlying asset expressed as a decimal. The value should be greater than 0.0. <strong>Rate</strong> is the continuously compounded interest rate. This is a percentage expressed as a decimal. <strong>Foreign Rate</strong> is the continuously compounded foreign interest rate. This is a percentage expressed as a decimal. <strong>Maturity</strong> is the time to maturity of the option, in years, and should be non-negative. <strong>Strike</strong> is the strike price of the option and should be non-negative. <strong>Lower Barrier</strong> is the predetermined lower barrier price; set to zero for no lower barrier. <strong>Upper Barrier</strong> is the predetermined upper barrier price; set to zero for no upper barrier. <strong>Rebate</strong> is the amount of money to be paid at maturity if the barrier is hit. <strong>Put or Call</strong> is a string that defines whether the option is a put (“p”) or a call (“c”). <strong>In or Out</strong> is a string that defines whether the option is knock-in (“i”) or knock-out (“o”). <strong>Barrier Monitoring</strong> is a string that defines whether the barrier is monitored continuously (“c”) or only at the end / maturity (“e”). <strong>Greek</strong> (optional) is a string argument. If omitted or set to &quot;value&quot;, &quot;v&quot;, &quot;price&quot;, or &quot;p&quot;, then the function simply returns the option price. If another valid string is entered (see Help files), the function returns price sensitivities (Greeks) to one of the input arguments.</td>
</tr>
</tbody>
</table>

| OPT_PROB_HIT(Spot, Volatility, Drift, Maturity, Lower Barrier, Upper Barrier) | Returns the probability that an asset hits a predetermined barrier price, assuming that the stock price can be modeled as a process S that follows the stochastic differential equation, as follows. $ \frac{dS}{S} = \mu dt + \sigma dW $ See the Help files for an explanation of the parameters appearing in this equation. **Spot** is the price / value of the underlying asset and should be greater than 0.0. **Volatility** is the annual percentage volatility of the underlying asset expressed as a decimal. The value should be greater than 0.0. **Drift** is the annual stock price percentage drift rate, expressed as a decimal. **Maturity** is the time to maturity of the option, in years, and should be non-negative. **Lower Barrier** is the predetermined lower barrier price; set to zero for no lower barrier. **Upper Barrier** is the predetermined upper barrier price; set to zero for no upper barrier. |

---

*A note about interest rates* | 473
**Syntax**

OPT_PROB_INMONEY(Spot, Volatility, Drift, Maturity, Lower Barrier, Upper Barrier, Strike, Put or Call)

**Description**

Returns the probability that an asset will end up between two barrier levels at maturity, assuming that the stock price can be modeled as a process $S$ that follows the stochastic differential equation, as follows.

$$\frac{dS}{S} = \mu dt + \nu dW$$

See the Help files for an explanation of the parameters appearing in this equation.

If the optional **Strike** and **Put or Call** arguments are included, then

- For a call option, the function returns the probability that the asset will end up between **Strike** and **Upper Barrier**.
- For a put option, the function returns the probability that the asset will end up between **Lower Barrier** and **Strike**.

The function ignores the possibility of knock-out before maturity.

**Spot** is the price / value of the underlying asset and should be greater than 0.0. **Volatility** is the annual percentage volatility of the underlying asset expressed as a decimal. The value should be greater than 0.0. **Drift** is the annual stock price percentage drift rate, expressed as a decimal. **Maturity** is the time to maturity of the option, in years, and should be non-negative. **Lower Barrier** is the predetermined lower barrier price; set to zero for no lower barrier. **Upper Barrier** is the predetermined upper barrier price; set to zero for no upper barrier. **Strike** (optional) is the strike price of the option and should be non-negative. The default is -1.0 (to indicate that a value has not been set). **Put or Call** (optional) is a string that defines whether the option is a put ("p") or a call ("c"). The default is “c”.

---

<table>
<thead>
<tr>
<th>Syntax</th>
<th>Description</th>
</tr>
</thead>
</table>
| OPT_PROB_INMONEY(Spot, Volatility, Drift, Maturity, Lower Barrier, Upper Barrier, Strike, Put or Call) | Returns the probability that an asset will end up between two barrier levels at maturity, assuming that the stock price can be modeled as a process $S$ that follows the stochastic differential equation, as follows. $\frac{dS}{S} = \mu dt + \nu dW$

See the Help files for an explanation of the parameters appearing in this equation.

If the optional **Strike** and **Put or Call** arguments are included, then

- For a call option, the function returns the probability that the asset will end up between **Strike** and **Upper Barrier**.
- For a put option, the function returns the probability that the asset will end up between **Lower Barrier** and **Strike**.

The function ignores the possibility of knock-out before maturity.

**Spot** is the price / value of the underlying asset and should be greater than 0.0. **Volatility** is the annual percentage volatility of the underlying asset expressed as a decimal. The value should be greater than 0.0. **Drift** is the annual stock price percentage drift rate, expressed as a decimal. **Maturity** is the time to maturity of the option, in years, and should be non-negative. **Lower Barrier** is the predetermined lower barrier price; set to zero for no lower barrier. **Upper Barrier** is the predetermined upper barrier price; set to zero for no upper barrier. **Strike** (optional) is the strike price of the option and should be non-negative. The default is -1.0 (to indicate that a value has not been set). **Put or Call** (optional) is a string that defines whether the option is a put ("p") or a call ("c"). The default is “c”. |
<table>
<thead>
<tr>
<th>Syntax</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>OPT_TOUCH(Spot, Volatility, Rate, Foreign Rate, Maturity, Lower Barrier, Upper Barrier, Domestic or Foreign, In or Out, Barrier Monitoring, Greek)</td>
<td>Returns the pricing of a touch / no-touch option, calculated using the Black-Scholes option pricing model. <strong>Spot</strong> is the price / value of the underlying asset and should be greater than 0.0. <strong>Volatility</strong> is the annual percentage volatility of the underlying asset expressed as a decimal. The value should be greater than 0.0. <strong>Rate</strong> is the continuously compounded interest rate. This is a percentage expressed as a decimal. <strong>Foreign Rate</strong> is the continuously compounded foreign interest rate. This is a percentage expressed as a decimal. <strong>Maturity</strong> is the time to maturity of the option, in years, and should be non-negative. <strong>Lower Barrier</strong> is the predetermined lower barrier price; set to zero for no lower barrier. <strong>Upper Barrier</strong> is the predetermined upper barrier price; set to zero for no upper barrier. <strong>Domestic or Foreign</strong> is a string that defines whether the option pays domestic (&quot;d&quot;) or foreign (&quot;f&quot;) currency. <strong>In or Out</strong> is a string that defines whether the option is knock-in (&quot;i&quot;) or knock-out (&quot;o&quot;). <strong>Barrier Monitoring</strong> is a string that defines whether the barrier is monitored continuously (&quot;c&quot;) or only at the end / maturity (&quot;e&quot;). <strong>Greek</strong> (optional) is a string argument. If omitted or set to &quot;value&quot;, &quot;v&quot;, &quot;price&quot;, or &quot;p&quot;, then the function simply returns the option price. If another valid string is entered (see Help files), the function returns price sensitivities (Greeks) to one of the input arguments.</td>
</tr>
<tr>
<td>PDURATION(Rate, PV, FV)</td>
<td>Calculates the number of periods required by an investment to attain a desired value. <strong>Rate</strong> is the constant rate of interest. <strong>PV</strong> is the present value of the investment. <strong>FV</strong> is the desired future value of the investment.</td>
</tr>
<tr>
<td>PMT(Rate, NPER, PV, FV, Type)</td>
<td>Returns the periodic payment for an annuity with constant interest rates. <strong>Rate</strong> is the periodic interest rate. <strong>NPER</strong> is the number of periods in which the annuity is paid. <strong>PV</strong> is the present value (cash value) in a sequence of payments. <strong>FV</strong> (optional) is the desired value (future value) to be reached at the end of the periodic payments. <strong>Type</strong> (optional) defines whether the payment is due at the beginning (1) or the end (0) of a period.</td>
</tr>
<tr>
<td>PPMT(Rate, Period, NPER, PV, FV, Type)</td>
<td>Returns for a given period the payment on the principal for an investment that is based on periodic and constant payments and a constant interest rate. <strong>Rate</strong> is the periodic interest rate. <strong>Period</strong> is the amortization period. <strong>NPER</strong> is the total number of periods during which the annuity is paid. <strong>Period</strong> = 1 for the first period and <strong>Period</strong> = <strong>NPER</strong> for the last period. <strong>PV</strong> is the present value in the sequence of payments. <strong>FV</strong> (optional) is the desired (future) value. <strong>Type</strong> (optional) defines whether the payment is due at the beginning (1) or the end (0) of a period.</td>
</tr>
<tr>
<td>Syntax</td>
<td>Description</td>
</tr>
<tr>
<td>--------</td>
<td>-------------</td>
</tr>
<tr>
<td>PRICE(Settlement, Maturity, Rate, Yield, Redemption, Frequency, Basis)</td>
<td>Calculates the price per 100 currency units of par value of an interest-bearing security. <strong>Settlement</strong> is the date of purchase of the security. <strong>Maturity</strong> is the date on which the security matures (expires). <strong>Rate</strong> is the annual nominal rate of interest (coupon interest rate). <strong>Yield</strong> is the annual yield of the security. <strong>Redemption</strong> is the redemption value per 100 currency units of par value. <strong>Frequency</strong> is the number of interest payments per year (1, 2 or 4). <strong>Basis</strong> (optional) indicates how the year is to be calculated.</td>
</tr>
<tr>
<td>PRICEDISC(Settlement, Maturity, Discount, Redemption, Basis)</td>
<td>Calculates the price per 100 currency units of par value of a discounted security. <strong>Settlement</strong> is the date of purchase of the security. <strong>Maturity</strong> is the date on which the security matures (expires). <strong>Discount</strong> is the discount of a security as a percentage. <strong>Redemption</strong> is the redemption value per 100 currency units of par value. <strong>Basis</strong> (optional) indicates how the year is to be calculated.</td>
</tr>
<tr>
<td>PRICEMAT(Settlement, Maturity, Issue, Rate, Yield, Basis)</td>
<td>Calculates the price per 100 currency units of par value of a security, that pays interest on the maturity date. <strong>Settlement</strong> is the date of purchase of the security. <strong>Maturity</strong> is the date on which the security matures (expires). <strong>Issue</strong> is the date of issue of the security. <strong>Rate</strong> is the interest rate of the security on the issue date. <strong>Yield</strong> is the annual yield of the security. <strong>Basis</strong> (optional) indicates how the year is to be calculated.</td>
</tr>
<tr>
<td>PV(Rate, NPER, PMT, FV, Type)</td>
<td>Returns the present value of an investment resulting from a series of regular payments. <strong>Rate</strong> defines the interest rate per period. <strong>NPER</strong> is the total number of payment periods. <strong>PMT</strong> is the regular payment made per period. <strong>FV</strong> (optional) defines the future value remaining after the final installment has been made. <strong>Type</strong> (optional) defines whether the payment is due at the beginning (1) or the end (0) of a period.</td>
</tr>
<tr>
<td>RATE(NPER, PMT, PV, FV, Type, Guess)</td>
<td>Returns the constant interest rate per period of an annuity. <strong>NPER</strong> is the total number of periods, during which payments are made (payment period). <strong>PMT</strong> is the constant payment (annuity) paid during each period. <strong>PV</strong> is the cash value in the sequence of payments. <strong>FV</strong> (optional) is the future value, which is reached at the end of the periodic payments. <strong>Type</strong> (optional) defines whether the payment is due at the beginning (1) or the end (0) of a period. <strong>Guess</strong> (optional) determines the estimated value of the interest with iterative calculation.</td>
</tr>
<tr>
<td>RECEIVED(Settlement, Maturity, Investment, Discount, Basis)</td>
<td>Calculates the amount paid out at maturity for a fully invested security. <strong>Settlement</strong> is the date of purchase of the security. <strong>Maturity</strong> is the date on which the security matures. <strong>Investment</strong> is the purchase sum. <strong>Discount</strong> is the percentage discount on acquisition of the security. <strong>Basis</strong> (optional) indicates how the year is to be calculated.</td>
</tr>
<tr>
<td>RRI(P, pv, FV)</td>
<td>Calculates the interest rate resulting from the profit (return) of an investment. <strong>P</strong> is the number of periods used for calculating the interest rate. <strong>pv</strong> is the present value (must be &gt;0). <strong>FV</strong> is the final value of the security.</td>
</tr>
<tr>
<td>Syntax</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>SLN(Cost, Salvage, Life)</td>
<td>Returns the straight-line depreciation of an asset for one period. <strong>Cost</strong> is the initial cost of an asset. <strong>Salvage</strong> is the value of an asset at the end of the depreciation. <strong>Life</strong> is the number of periods in the useful life of the asset.</td>
</tr>
<tr>
<td>SYD(Cost, Salvage, Life, Period)</td>
<td>Returns the arithmetically declining value of an asset (depreciation) for a specified period. It uses the Sum-of-Years'-Digits method. <strong>Cost</strong> is the initial cost of an asset. <strong>Salvage</strong> is the value of an asset after depreciation. <strong>Life</strong> is the period fixing the time span over which an asset is depreciated. <strong>Period</strong> defines the period for which the depreciation is to be calculated. Must use the same units as <strong>Life</strong>.</td>
</tr>
<tr>
<td>TBILLEQ(Settlement, Maturity, Discount)</td>
<td>Calculates the bond equivalent yield for a treasury bill. <strong>Settlement</strong> is the date of purchase of the security. <strong>Maturity</strong> is the date on which the security matures (expires). The settlement and maturity date must be within a year of each other. <strong>Discount</strong> is the percentage discount on acquisition of the security. Calculated using the 360 days in a year basis (basis 2).</td>
</tr>
<tr>
<td>TBILLPRICE(Settlement, Maturity, Discount)</td>
<td>Calculates the price per 100 currency units face value of a treasury bill. <strong>Settlement</strong> is the date of purchase of the security. <strong>Maturity</strong> is the date on which the security matures (expires). The settlement and maturity date must be within a year of each other. <strong>Discount</strong> is the percentage discount upon acquisition of the security.</td>
</tr>
<tr>
<td>TBILLYIELD(Settlement, Maturity, Price)</td>
<td>Calculates the yield of a treasury bill. <strong>Settlement</strong> is the date of purchase of the security. <strong>Maturity</strong> is the date on which the security matures (expires). The settlement and maturity date must be within a year of each other. <strong>Price</strong> is the price (purchase price) of the treasury bill per 100 currency units of par value.</td>
</tr>
<tr>
<td>VDB(Cost, Salvage, Life, S, end, Factor, Type)</td>
<td>Returns the depreciation of an asset for a specified or partial period using a variable declining balance method. <strong>Cost</strong> is the initial value of an asset. <strong>Salvage</strong> is the value of an asset at the end of the depreciation. <strong>Life</strong> is the depreciation duration of the asset. <strong>S</strong> is the start period of the depreciation, entered in the same date unit as <strong>Life</strong>. <strong>end</strong> is the last period of the depreciation, entered in the same date unit as <strong>Life</strong>. <strong>Factor</strong> (optional) is the depreciation factor. If factor is omitted, a factor of two is assumed (the double-declining balance method). <strong>Type</strong> is an optional argument. Type = 0 means a switch to linear depreciation. In Type = 1, no switch is made.</td>
</tr>
</tbody>
</table>

*A note about interest rates | 477*
### Syntax | Description
--- | ---
XIRR(Values, Dates, Guess) | Calculates the internal rate of return for a list of payments which take place on different dates. The calculation is based on a 365 days per year basis, ignoring leap years. If the payments take place at regular intervals, use the IRR function. **Values** and **Dates** are a series of payments and a series of associated date values entered as cell references. **Values** shall include at least one negative value and one positive value. **Guess** (optional) is a guess for the internal rate of return. If omitted, the value 10% is assumed.

XNPV(Rate, Values, Dates) | Calculates the capital value (net present value) for a list of payments which take place on different dates. The calculation is based on a 365 days per year basis, ignoring leap years. If the payments take place at regular intervals, use the NPV function. **Rate** is the internal rate of return for the payments. **Values** and **Dates** are a series of payments and a series of associated date values entered as cell references. The first value-date pair indicates the start of the payments, other dates can be in any order. Values shall include at least one negative value and one positive value.

YIELD(Settlement, Maturity, Rate, Price, Redemption, Frequency, Basis) | Calculates the yield of a security that pays periodic interest. **Settlement** is the date of purchase of the security. **Maturity** is the date on which the security matures (expires). **Rate** is the annual rate of interest. **Price** is the price (purchase price) of the security per 100 currency units of par value. **Redemption** is the redemption value per 100 currency units of par value. **Frequency** is the number of interest payments per year (1, 2 or 4). **Basis** (optional) indicates how the year is to be calculated.

YIELDDISC(Settlement, Maturity, Price, Redemption, Basis) | Calculates the annual yield of a non-interest-bearing security. **Settlement** is the date of purchase of the security. **Maturity** is the date on which the security matures (expires). **Price** is the price (purchase price) of the security per 100 currency units of par value. **Redemption** is the redemption value per 100 currency units of par value. **Basis** (optional) indicates how the year is to be calculated.

YIELDMAT(Settlement, Maturity, Issue, Rate, Price, Basis) | Calculates the annual yield of a security, the interest of which is paid on the date of maturity. **Settlement** is the date of purchase of the security. **Maturity** is the date on which the security matures (expires). **Issue** is the date of issue of the security. **Rate** is the interest rate of the security on the issue date. **Price** is the price (purchase price) of the security per 100 currency units of par value. **Basis** (optional) indicates how the year is to be calculated.

### Statistical analysis functions

Calc includes over 150 statistical functions which enable the evaluation of data from simple arithmetic calculations, such as averaging, to advanced distribution and probability computations. Several other statistics-based functions are available through the Add-ins which are noted at the end of this chapter.
<table>
<thead>
<tr>
<th>Syntax</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>AVEDEV(number 1, number 2, …, number 30)</td>
<td>Returns the average of the absolute deviations of data points from their mean. Displays the diffusion in a data set. <strong>number 1, number 2, …, number 30</strong> are values or ranges that represent a sample. Each number can also be replaced by a reference.</td>
</tr>
<tr>
<td>AVERAGE(number 1, number 2, …, number 30)</td>
<td>Returns the average of the arguments. <strong>number 1, number 2, …, number 30</strong> are numerical values or ranges.</td>
</tr>
<tr>
<td>AVERAGEA(value 1, value 2, …, value 30)</td>
<td>Returns the average of the arguments. The value of text is taken to be 0. <strong>value 1, value 2, …, value 30</strong> are values or ranges.</td>
</tr>
<tr>
<td>AVERAGEIF(range, criterion, average_range)</td>
<td>Returns the arithmetic mean of all cells in a range that satisfy a given condition. Sums up all the results that match a logical test and divides this sum by the number of selected values. <strong>range</strong> is an array, a named range, or the label of a column or a row. It should contain numbers for averaging, or numbers or text for the condition. <strong>criterion</strong> is a condition in the form of an expression, or a cell reference with expression, that defines which cells should be used to calculate the mean. The expression can contain text, numbers, regular expressions, or wildcards (if enabled). <strong>criterion</strong> should be a string expression and should be enclosed in quotation marks, except for the names of functions, cell references, and string concatenation (&amp;). <strong>average_range</strong> is an optional argument that gives a range of values for calculating the mean. If <strong>average_range</strong> is not specified, <strong>range</strong> is used for both the calculation of the mean and the search according to the condition. If <strong>average_range</strong> is specified, <strong>range</strong> is used only for the condition test, while <strong>average_range</strong> is used for the mean calculation. If a cell in a range of values for calculating the mean is empty or contains text, the cell is ignored. If the whole range is empty, contains only text, or includes no values that satisfy the condition, the function returns an error.</td>
</tr>
<tr>
<td>Syntax</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>SINH(number)</td>
<td>Returns the hyperbolic sine of the given number (angle in radians).</td>
</tr>
<tr>
<td>SQRT(number)</td>
<td>Returns the positive square root of the given positive number.</td>
</tr>
<tr>
<td>SQRTPI(Number)</td>
<td>Returns the square root of the product of the given Number and pi (π).</td>
</tr>
<tr>
<td>SUBTOTAL(Function, range)</td>
<td>Calculates subtotals. If a range already contains subtotals, these are not used for further calculations. Use this function with AutoFilters activated to take only the filtered records into account. <strong>Function</strong> is a value that selects which function should be used to create the subtotal (for example, Average, Count, Min, Sum, or Var) and also determines whether manually hidden rows should be included. The set of allowed <strong>Function</strong> values is listed in the Help system. <strong>range</strong> is the range of cells included.</td>
</tr>
<tr>
<td>SUM(number 1, number 2, ..., number 30)</td>
<td>Adds all the numbers in a range of cells. <strong>number 1, number 2, ..., number 30</strong> are up to 30 arguments whose sum is to be calculated. You can also enter a range using cell references.</td>
</tr>
<tr>
<td>SUMIF(range, criteria, sum_range)</td>
<td>Adds the cells specified by the given criteria. The search supports regular expressions. <strong>range</strong> is the range to which the criteria are to be applied. <strong>criteria</strong> is the cell in which the search criterion is shown, or the search criterion itself (in double quotes). <strong>sum_range</strong> (optional) is the range from which values are summed; if it has not been entered, the values found in the <strong>range</strong> are summed. If supplied, <strong>sum_range</strong> must be the same size and shape as <strong>range</strong>.</td>
</tr>
<tr>
<td>SUMIFS(sum_range, range 1, criteria 1, range 2, criteria 2, ..., range 127, criteria 127)</td>
<td>Totals the values of cells in a range that meet multiple criteria in multiple ranges. <strong>sum_range</strong> is the cell range from which the values are to be totaled. <strong>range 1</strong> is the cell range to be evaluated by <strong>criteria 1</strong>, <strong>range 2</strong> (optional) by <strong>criteria 2</strong> (optional), and so on. All ranges must have the same size and shape. The function can have up to 255 arguments, meaning that you can specify 127 criteria ranges and criteria for them.</td>
</tr>
<tr>
<td>SUMSQ(number 1, number 2, ..., number 30)</td>
<td>Calculates the sum of the squares of numbers (totaling up of the squares of the arguments). <strong>number 1, number 2, ..., number 30</strong> are up to 30 arguments, the sum of whose squares is to be calculated.</td>
</tr>
<tr>
<td>TAN(number)</td>
<td>Returns the tangent of the given number (angle in radians).</td>
</tr>
<tr>
<td>TANH(number)</td>
<td>Returns the hyperbolic tangent of the given number (angle in radians).</td>
</tr>
<tr>
<td>TRUNC(number, count)</td>
<td>Truncates a number by removing decimal places. <strong>number</strong> is the number whose decimal places are to be trimmed. <strong>count</strong> is the number of decimal places which are retained. If <strong>count</strong> is zero, it effectively truncates to a decimal integer. If <strong>count</strong> is negative, it truncates to the left of the decimal point.</td>
</tr>
</tbody>
</table>

**480 | Mathematical functions**
Financial analysis functions

A note about dates

Date values used as arguments for Calc's financial functions must comply with ISO8601 and be entered surrounded by double quotes. For example, a date representing August 6, 2004, must be entered “2004-08-06”, single digits are padded with leading zeroes. If you do not enter the date values as required by the function, you will not get the correct results. Date formats are locale specific and will allow other formats to be used. Among others, the en_US locale allows “2004/08/06” and “08/06/2004” for example. Check the Help for the acceptable formatting.

A note about interest rates

You can enter interest rates in either of two ways:

- As a decimal. To enter an interest rate as a decimal, divide it by 100 before entering it into a function. For example, to compute a loan with a 3.25% interest rate, enter .0325 into the function.
- As a percentage. To enter an interest rate as a percentage, type in the interest rate followed by the % key. For example, to compute a loan with a 3.25% interest rate, enter 3.25% into the function.

If you enter it as 3.25, the function will treat it as a 325% interest rate.

Accounting systems vary in the number of days in a month or a year used in calculations. The following table gives the integers used for the Basis argument used in some of the financial analysis functions.

<table>
<thead>
<tr>
<th>Basis</th>
<th>Calculation</th>
</tr>
</thead>
<tbody>
<tr>
<td>0 or missing</td>
<td>US method (NASD), 12 months of 30 days each.</td>
</tr>
<tr>
<td>1</td>
<td>Exact number of days in months, exact number of days in year.</td>
</tr>
<tr>
<td>2</td>
<td>Exact number of days in month, year has 360 days.</td>
</tr>
<tr>
<td>3</td>
<td>Exact number of days in month, year has 365 days.</td>
</tr>
<tr>
<td>4</td>
<td>European method, 12 months of 30 days each.</td>
</tr>
</tbody>
</table>

Table 28: Financial analysis functions

<table>
<thead>
<tr>
<th>Syntax</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ACRINT(Issue, First interest, Settlement, Rate, Par, Frequency, Basis)</td>
<td>Calculates the accrued interest of a security in the case of periodic payments. <strong>Issue</strong> is the issue date of the security. <strong>First interest</strong> is the first interest date of the security. <strong>Settlement</strong> is the date at which the interest accrued up until then is to be calculated. <strong>Rate</strong> is the annual nominal rate of interest (coupon interest rate). <strong>Par</strong> (optional) is the par value of the security. <strong>Frequency</strong> is the number of interest payments per year (1, 2 or 4). <strong>Basis</strong> (optional) indicates how the year is to be calculated.</td>
</tr>
<tr>
<td>Syntax</td>
<td>Description</td>
</tr>
<tr>
<td>--------</td>
<td>-------------</td>
</tr>
<tr>
<td>ACCRINTM(Issue, Settlement, Rate, Par, Basis)</td>
<td>Calculates the accrued interest of a security in the case of one-off payment at the settlement date. <strong>Issue</strong> is the issue date of the security. <strong>Settlement</strong> is the maturity date. <strong>Rate</strong> is the annual nominal rate of interest (coupon interest rate). <strong>Par</strong> (optional) is the par value of the security. <strong>Basis</strong> (optional) indicates how the year is to be calculated.</td>
</tr>
<tr>
<td>AMORDEGRC(Cost, Date purchased, First period, Salvage, Period, Rate, Basis)</td>
<td>Calculates the amount of depreciation for a settlement period as degressive amortization. Unlike AMORLINC, a depreciation coefficient that is independent of the depreciable life is used here. <strong>Cost</strong> is the acquisition cost. <strong>Date purchased</strong> is the date of acquisition. <strong>First period</strong> is the end date of the first settlement period. <strong>Salvage</strong> is the salvage value of the capital asset at the end of the depreciable life. <strong>Period</strong> is the settlement period to be considered. <strong>Rate</strong> is the rate of depreciation. <strong>Basis</strong> (optional) indicates how the year is to be calculated.</td>
</tr>
<tr>
<td>AMORLINC(Cost, Date purchased, First period, Salvage, Period, Rate, Basis)</td>
<td>Calculates the amount of depreciation for a settlement period as linear amortization. If the capital asset is purchased during the settlement period, the proportional amount of depreciation is considered. <strong>Cost</strong> is the acquisition cost. <strong>Date purchased</strong> is the date of acquisition. <strong>First period</strong> is the end date of the first settlement period. <strong>Salvage</strong> is the salvage value of the capital asset at the end of the depreciable life. <strong>Period</strong> is the settlement period to be considered. <strong>Rate</strong> is the rate of depreciation. <strong>Basis</strong> (optional) indicates how the year is to be calculated.</td>
</tr>
<tr>
<td>COUPDAYBS(Settlement, Maturity, Frequency, Basis)</td>
<td>Returns the number of days from the first day of interest payment on a security until the settlement date. <strong>Settlement</strong> is the date of purchase of the security. <strong>Maturity</strong> is the date on which the security matures (expires). <strong>Frequency</strong> is the number of interest payments per year (1, 2 or 4). <strong>Basis</strong> (optional) indicates how the year is to be calculated.</td>
</tr>
<tr>
<td>COUPDAYS(Settlement, Maturity, Frequency, Basis)</td>
<td>Returns the number of days in the current interest period in which the settlement date falls. <strong>Settlement</strong> is the date of purchase of the security. <strong>Maturity</strong> is the date on which the security matures (expires). <strong>Frequency</strong> is the number of interest payments per year (1, 2 or 4). <strong>Basis</strong> (optional) indicates how the year is to be calculated.</td>
</tr>
<tr>
<td>COUPDAYSNC(Settlement, Maturity, Frequency, Basis)</td>
<td>Returns the number of days from the settlement date until the next interest date. <strong>Settlement</strong> is the date of purchase of the security. <strong>Maturity</strong> is the date on which the security matures (expires). <strong>Frequency</strong> is the number of interest payments per year (1, 2 or 4). <strong>Basis</strong> (optional) indicates how the year is to be calculated.</td>
</tr>
<tr>
<td>COUPNCD(Settlement, Maturity, Frequency, Basis)</td>
<td>Returns the date of the first interest date after the settlement date, and formats the result as a date. <strong>Settlement</strong> is the date of purchase of the security. <strong>Maturity</strong> is the date on which the security matures (expires). <strong>Frequency</strong> is the number of interest payments per year (1, 2 or 4). <strong>Basis</strong> (optional) indicates how the year is to be calculated.</td>
</tr>
<tr>
<td>Syntax</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>COUPNUM(Settlement, Maturity, Frequency, Basis)</td>
<td>Returns the number of coupons (interest payments) between the settlement date and the maturity date. <strong>Settlement</strong> is the date of purchase of the security. <strong>Maturity</strong> is the date on which the security matures (expires). <strong>Frequency</strong> is the number of interest payments per year (1, 2 or 4). <strong>Basis</strong> (optional) indicates how the year is to be calculated.</td>
</tr>
<tr>
<td>COUPPCD(Settlement, Maturity, Frequency, Basis)</td>
<td>Returns the date of the interest date prior to the settlement date, and formats the result as a date. <strong>Settlement</strong> is the date of purchase of the security. <strong>Maturity</strong> is the date on which the security matures (expires). <strong>Frequency</strong> is the number of interest payments per year (1, 2 or 4). <strong>Basis</strong> (optional) indicates how the year is to be calculated.</td>
</tr>
<tr>
<td>CUMIPMT(Rate, NPER, pv, S, E, Type)</td>
<td>Calculates the cumulative interest payments (the total interest) for an investment based on a constant interest rate. <strong>Rate</strong> is the periodic interest rate. <strong>NPER</strong> is the payment period with the total number of periods. <strong>NPER</strong> can also be a non-integer value. The <strong>Rate</strong> and <strong>NPER</strong> must refer to the same unit, and thus both must be calculated annually or monthly. <strong>pv</strong> is the current value in the sequence of payments. <strong>S</strong> is the first period. <strong>E</strong> is the last period. <strong>Type</strong> is the due date of the payment at the beginning (1) or end (0) of each period.</td>
</tr>
<tr>
<td>CUMIPMT_ADD(Rate, Nper, Pv, Start period, End period, Type)</td>
<td>Calculates the accumulated interest for a period. <strong>Rate</strong> is the interest rate for each period. <strong>Nper</strong> is the total number of payment periods. The <strong>Rate</strong> and <strong>Nper</strong> must refer to the same unit, and thus both must be calculated annually or monthly. <strong>Pv</strong> is the current value. <strong>Start period</strong> is the first payment period for the calculation. <strong>End period</strong> the last payment period for the calculation. <strong>Type</strong> is the due date of the payment at the beginning (1) or end (0) of each period.</td>
</tr>
<tr>
<td>CUMPRINC(Rate, NPER, PV, S, E, Type)</td>
<td>Returns the cumulative interest paid for an investment period with a constant interest rate. <strong>Rate</strong> is the periodic interest rate. <strong>NPER</strong> is the payment period with the total number of periods. <strong>NPER</strong> can also be a non-integer value. The <strong>Rate</strong> and <strong>NPER</strong> must refer to the same unit, and thus both must be calculated annually or monthly. <strong>PV</strong> is the current value in the sequence of payments. <strong>S</strong> is the first period. <strong>E</strong> is the last period. <strong>Type</strong> is the due date of the payment at the beginning (1) or end (0) of each period.</td>
</tr>
<tr>
<td>CUMPRINC_ADD(Rate, Nper, Pv, Start period, End period, Type)</td>
<td>Calculates the cumulative redemption of a loan in a period. <strong>Rate</strong> is the interest rate for each period. <strong>Nper</strong> is the total number of payment periods. The <strong>Rate</strong> and <strong>Nper</strong> must refer to the same unit, and thus both must be calculated annually or monthly. <strong>Pv</strong> is the current value. <strong>Start period</strong> is the first payment period for the calculation. <strong>End period</strong> is the last payment period for the calculation. <strong>Type</strong> is the due date of the payment at the beginning (1) or end (0) of each period.</td>
</tr>
<tr>
<td>Syntax</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------------------</td>
<td>-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td><strong>DB(Cost, Salvage, Life, Period, month)</strong></td>
<td>Returns the depreciation of an asset for a specified period using the fixed-declining balance method. <strong>Cost</strong> is the initial cost of an asset. <strong>Salvage</strong> is the value of an asset at the end of the depreciation. <strong>Life</strong> defines the period over which an asset is depreciated. <strong>Period</strong> is the length of each period. The life must be entered in the same date unit as the depreciation period. <strong>month</strong> (optional) denotes the number of months for the first year of depreciation (defaults to 12).</td>
</tr>
<tr>
<td><strong>DDB(Cost, Salvage, Life, Period, Factor)</strong></td>
<td>Returns the depreciation of an asset for a specified period using the arithmetic-declining method. Note that the book value will never reach zero under this calculation type. <strong>Cost</strong> fixes the initial cost of an asset. <strong>Salvage</strong> fixes the value of an asset at the end of its life. <strong>Life</strong> is the number of periods defining how long the asset is to be used. <strong>Period</strong> defines the length of the period. The period must be entered in the same time unit as the life. <strong>Factor</strong> (optional) is the factor by which depreciation decreases. If no value is entered, a value of 2 is assumed, making this double declining.</td>
</tr>
<tr>
<td><strong>DISC(Settlement, Maturity, Price, Redemption, Basis)</strong></td>
<td>Calculates the allowance (discount) of a security as a percentage. <strong>Settlement</strong> is the date of purchase of the security. <strong>Maturity</strong> is the date on which the security matures (expires). <strong>Price</strong> is the price of the security per 100 currency units of par value. <strong>Redemption</strong> is the redemption value of the security per 100 currency units of par value. <strong>Basis</strong> (optional) indicates how the year is to be calculated.</td>
</tr>
<tr>
<td><strong>DOLLARDE(Fractional dollar, Fraction)</strong></td>
<td>Converts a quotation that has been given as a decimal fraction into a decimal number. <strong>Fractional dollar</strong> is a number given as a decimal fraction. (In this number, the decimal value is the numerator of the fraction.) <strong>Fraction</strong> is a whole number that is used as the denominator of the decimal fraction.</td>
</tr>
<tr>
<td><strong>DOLLARFR(Decimal dollar, Fraction)</strong></td>
<td>Converts a quotation that has been given as a decimal number into a mixed decimal fraction. The decimal of the result is the numerator of the fraction that would have <strong>Fraction</strong> as the denominator. <strong>Decimal dollar</strong> is a decimal number. <strong>Fraction</strong> is a whole number that is used as the denominator of the decimal fraction.</td>
</tr>
<tr>
<td><strong>DURATION(Settlement, Maturity, Coupon, Yield, Frequency, Basis)</strong></td>
<td>Calculates the duration of a fixed interest security in years. <strong>Settlement</strong> is the date of purchase of the security. <strong>Maturity</strong> is the date on which the security matures (expires). <strong>Coupon</strong> is the annual coupon interest rate (nominal rate of interest). <strong>Yield</strong> is the annual yield of the security. <strong>Frequency</strong> is the number of interest payments per year (1, 2 or 4). <strong>Basis</strong> (optional) indicates how the year is to be calculated.</td>
</tr>
<tr>
<td><strong>EFFECT(NOM, P)</strong></td>
<td>Calculates the effective annual rate of interest on the basis of the nominal interest rate and the number of interest payments per annum. Nominal interest rate refers to the amount of interest due at the end of a calculation period. <strong>NOM</strong> is the nominal interest rate. <strong>P</strong> is the number of interest payment periods per year.</td>
</tr>
<tr>
<td>Syntax</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>EFFECT_ADD(Nominal rate,</td>
<td>Calculates the effective annual rate of interest on the basis of the nominal interest rate and the number of interest payments per annum. Nominal interest rate refers to the amount of interest due at the end of a calculation period. <strong>Nominal rate</strong> is the nominal interest rate. <strong>Npery</strong> is the number of interest payments per year. This function returns the same result as the corresponding Microsoft Excel 2003 function without the suffix. Use the Calc function without a suffix to get results based on international standards.</td>
</tr>
<tr>
<td>Npery)</td>
<td></td>
</tr>
<tr>
<td>FV(Rate, NPER, PMT, PV,</td>
<td>Returns the future value of an investment based on periodic, constant payments and a constant interest rate. <strong>Rate</strong> is the periodic interest rate. <strong>NPER</strong> is the total number of periods. <strong>PMT</strong> is the annuity paid regularly per period. <strong>PV</strong> (optional) is the present cash value of an investment. <strong>Type</strong> (optional) defines whether the payment is due at the beginning (1) or the end (0) of a period.</td>
</tr>
<tr>
<td>Type)</td>
<td></td>
</tr>
<tr>
<td>FVSCHEDULE(Principal,</td>
<td>Calculates the accumulated value of the starting capital for a series of periodically varying interest rates. <strong>Principal</strong> is the starting capital. <strong>Schedule</strong> is a series of interest rates. <strong>Schedule</strong> has to be entered with cell references, or with a list.</td>
</tr>
<tr>
<td>Schedule)</td>
<td></td>
</tr>
<tr>
<td>INTRATE(Settlement,</td>
<td>Calculates the annual interest rate that results when a security (or other item) is purchased at an investment value and sold at a redemption value with no interest being paid. <strong>Settlement</strong> is the date of purchase of the security. <strong>Maturity</strong> is the date on which the security is sold. <strong>Investment</strong> is the purchase price. <strong>Redemption</strong> is the selling price. <strong>Basis</strong> (optional) indicates how the year is to be calculated.</td>
</tr>
<tr>
<td>Maturity, Investment,</td>
<td></td>
</tr>
<tr>
<td>Redemption, Basis)</td>
<td></td>
</tr>
<tr>
<td>IPMT(Rate, Period, NPER,</td>
<td>Calculates the periodic amortization for an investment with regular payments and a constant interest rate. <strong>Rate</strong> is the periodic interest rate. <strong>Period</strong> is the period for which the compound interest is calculated. <strong>NPER</strong> is the total number of periods during which annuity is paid. <strong>Period=NPER</strong>, if compound interest for the last period is calculated. <strong>Pv</strong> is the present cash value in a sequence of payments. <strong>FV</strong> (optional) is the desired value (future value) at the end of the periods. <strong>Type</strong> (optional) defines whether the payment is due at the beginning (1) or the end (0) of a period.</td>
</tr>
<tr>
<td>pv, FV, Type)</td>
<td></td>
</tr>
<tr>
<td>IRR(Values, Guess)</td>
<td>Calculates the internal rate of return for an investment. The values represent cash flow values at regular intervals; at least one value must be negative (payments), and at least one value must be positive (income). <strong>Values</strong> is an array or cell range containing the values. <strong>Guess</strong> (optional) is the estimated value. If you can provide only a few values, you should provide an initial guess to enable the iteration.</td>
</tr>
<tr>
<td>ISPMT(rate, Period, total_periods, invest)</td>
<td>Calculates the level of interest for unchanged amortization installments. <strong>Rate</strong> sets the periodic interest rate. <strong>Period</strong> is the number of installments for calculation of interest. <strong>Total_periods</strong> is the total number of installment periods. <strong>Invest</strong> is the amount of the investment.</td>
</tr>
<tr>
<td>Syntax</td>
<td>Description</td>
</tr>
<tr>
<td>--------</td>
<td>-------------</td>
</tr>
<tr>
<td><strong>MDURATION(Settlement, Maturity, Coupon, Yield, Frequency, Basis)</strong></td>
<td>Calculates the modified Macauley duration for a security with an assumed par value of 100 currency units. <strong>Settlement</strong> is the date of purchase of the security. <strong>Maturity</strong> is the date on which the security matures (expires). <strong>Coupon</strong> is the annual nominal rate of interest (coupon interest rate). <strong>Yield</strong> is the annual yield of the security. <strong>Frequency</strong> is the number of interest payments per year (1, 2 or 4). <strong>Basis</strong> (optional) indicates how the year is to be calculated.</td>
</tr>
<tr>
<td><strong>MIRR(Values, investment, reinvest_rate)</strong></td>
<td>Calculates the modified internal rate of return of a series of investments. <strong>Values</strong> corresponds to the array or the cell reference for cells whose content corresponds to the payments. <strong>investment</strong> is the rate of interest of the investments (the negative values of the array). <strong>reinvest_rate</strong> is the rate of interest of the reinvestment (the positive values of the array).</td>
</tr>
<tr>
<td><strong>NOMINAL(effect_rate, npery)</strong></td>
<td>Calculates the yearly nominal interest rate, given the effective rate and the number of compounding periods per year. <strong>effect_rate</strong> is the effective interest rate. <strong>npery</strong> is the number of periodic interest payments per year. Returns a percentage.</td>
</tr>
<tr>
<td><strong>NOMINAL_ADD(Effective_rate, Npery)</strong></td>
<td>Calculates the yearly nominal rate of interest, given the effective rate and the number of compounding periods per year. <strong>Effective_rate</strong> is the effective annual rate of interest. <strong>Npery</strong> is the number of interest payments per year. Returns a number.</td>
</tr>
<tr>
<td><strong>NPER(Rate, PMT, PV, FV, Type)</strong></td>
<td>Returns the number of periods for an investment based on periodic, constant payments and a constant interest rate. <strong>Rate</strong> is the periodic interest rate. <strong>PMT</strong> is the constant annuity paid in each period. <strong>PV</strong> is the present value (cash value) in a sequence of payments. <strong>FV</strong> (optional, default 0) is the future value, which is reached at the end of the last period. <strong>Type</strong> (optional) defines whether the payment is due at the beginning (1) or the end (0) of a period.</td>
</tr>
<tr>
<td><strong>NPV(Rate, value 1, value 2, ..., value 30)</strong></td>
<td>Returns the net present value of an investment based on a series of periodic cash flows and a discount rate. <strong>Rate</strong> is the discount rate for a period. <strong>value 1</strong>, <strong>value 2</strong>, ..., <strong>value 30</strong> are values representing deposits or withdrawals.</td>
</tr>
<tr>
<td><strong>ODDFPRICE(Settlement, Maturity, Issue, First coupon, Rate, Yield, Redemption, Frequency, Basis)</strong></td>
<td>Calculates the price per 100 currency units par value of a security, having an odd (short or long) first period. <strong>Settlement</strong> is the date of purchase of the security. <strong>Maturity</strong> is the date on which the security matures (expires). <strong>Issue</strong> is the date of issue of the security. <strong>First coupon</strong> is the first interest date of the security. <strong>Rate</strong> is the annual rate of interest. <strong>Yield</strong> is the annual yield of the security. <strong>Redemption</strong> is the redemption value per 100 currency units of par value. <strong>Frequency</strong> is the number of interest payments per year (1, 2 or 4). <strong>Basis</strong> (optional) indicates how the year is to be calculated.</td>
</tr>
<tr>
<td>Syntax</td>
<td>Description</td>
</tr>
<tr>
<td>--------</td>
<td>-------------</td>
</tr>
<tr>
<td>ODDFYIELD(Settlement, Maturity, Issue, First coupon, Rate, Price, Redemption, Frequency, Basis)</td>
<td>Calculates the yield of a security that has an odd (short or long) first period. Settlement is the date of purchase of the security. Maturity is the date on which the security matures (expires). Issue is the date of issue of the security. First coupon is the first interest date of the security. Rate is the annual rate of interest. Price is the price of the security. Redemption is the redemption value per 100 currency units of par value. Frequency is the number of interest payments per year (1, 2 or 4). Basis (optional) indicates how the year is to be calculated.</td>
</tr>
<tr>
<td>ODDLPRICE(Settlement, Maturity, Last interest, Rate, Yield, Redemption, Frequency, Basis)</td>
<td>Calculates the price per 100 currency units par value of a security, that has an odd (short or long) last period. Settlement is the date of purchase of the security. Maturity is the date on which the security matures (expires). Last interest is the last interest date of the security. Rate is the annual rate of interest. Yield is the annual yield of the security. Redemption is the redemption value per 100 currency units of par value. Frequency is the number of interest payments per year (1, 2 or 4). Basis (optional) indicates how the year is to be calculated.</td>
</tr>
<tr>
<td>ODDLYIELD(Settlement, Maturity, Last interest, Rate, Price, Redemption, Frequency, Basis)</td>
<td>Calculates the yield of a security that has an odd (short or long) last period. Settlement is the date of purchase of the security. Maturity is the date on which the security matures (expires). Last interest is the last interest date of the security. Rate is the annual rate of interest. Price is the price of the security. Redemption is the redemption value per 100 currency units of par value. Frequency is the number of interest payments per year (1, 2 or 4). Basis (optional) indicates how the year is to be calculated.</td>
</tr>
<tr>
<td><strong>Syntax</strong></td>
<td><strong>Description</strong></td>
</tr>
<tr>
<td>------------</td>
<td>----------------</td>
</tr>
<tr>
<td>OPT_BARRIER(Spot, Volatility, Rate, Foreign Rate, Maturity, Strike, Lower Barrier, Upper Barrier, Rebate, Put or Call, In or Out, Barrier Monitoring, Greek)</td>
<td>Returns the pricing for a barrier option, calculated using the Black-Scholes option pricing model. <strong>Spot</strong> is the price / value of the underlying asset and should be greater than 0.0. <strong>Volatility</strong> is the annual percentage volatility of the underlying asset expressed as a decimal. The value should be greater than 0.0. <strong>Rate</strong> is the continuously compounded interest rate. This is a percentage expressed as a decimal. <strong>Foreign Rate</strong> is the continuously compounded foreign interest rate. This is a percentage expressed as a decimal. <strong>Maturity</strong> is the time to maturity of the option, in years, and should be non-negative. <strong>Strike</strong> is the strike price of the option and should be non-negative. <strong>Lower Barrier</strong> is the predetermined lower barrier price; set to zero for no lower barrier. <strong>Upper Barrier</strong> is the predetermined upper barrier price; set to zero for no upper barrier. <strong>Rebate</strong> is the amount of money to be paid at maturity if the barrier is hit. <strong>Put or Call</strong> is a string that defines whether the option is a put (“p”) or a call (“c”). <strong>In or Out</strong> is a string that defines whether the option is knock-in (“i”) or knock-out (“o”). <strong>Barrier Monitoring</strong> is a string that defines whether the barrier is monitored continuously (“c”) or only at the end / maturity (“e”). <strong>Greek</strong> (optional) is a string argument. If omitted or set to “value”, “v”, “price”, or “p”, then the function simply returns the option price. If another valid string is entered (see Help files), the function returns price sensitivities (Greeks) to one of the input arguments.</td>
</tr>
</tbody>
</table>
| OPT_PROB_HIT(Spot, Volatility, Drift, Maturity, Lower Barrier, Upper Barrier) | Returns the probability that an asset hits a predetermined barrier price, assuming that the stock price can be modeled as a process S that follows the stochastic differential equation, as follows. \[
\frac{dS}{S} = \mu \, dt + vol \, dW
\] See the Help files for an explanation of the parameters appearing in this equation. **Spot** is the price / value of the underlying asset and should be greater than 0.0. **Volatility** is the annual percentage volatility of the underlying asset expressed as a decimal. The value should be greater than 0.0. **Drift** is the annual stock price percentage drift rate, expressed as a decimal. **Maturity** is the time to maturity of the option, in years, and should be non-negative. **Lower Barrier** is the predetermined lower barrier price; set to zero for no lower barrier. **Upper Barrier** is the predetermined upper barrier price; set to zero for no upper barrier. |
<table>
<thead>
<tr>
<th>Syntax</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>OPT_PROB_INMONEY(Spot, Volatility, Drift, Maturity, Lower Barrier, Upper Barrier, Strike, Put or Call)</td>
<td>Returns the probability that an asset will end up between two barrier levels at maturity, assuming that the stock price can be modeled as a process S that follows the stochastic differential equation, as follows. $\frac{dS}{S} = \mu dt + vol dW$ See the Help files for an explanation of the parameters appearing in this equation. If the optional Strike and Put or Call arguments are included, then - For a call option, the function returns the probability that the asset will end up between Strike and Upper Barrier. - For a put option, the function returns the probability that the asset will end up between Lower Barrier and Strike. The function ignores the possibility of knock-out before maturity. Spot is the price/value of the underlying asset and should be greater than 0.0. Volatility is the annual percentage volatility of the underlying asset expressed as a decimal. The value should be greater than 0.0. Drift is the annual stock price percentage drift rate, expressed as a decimal. Maturity is the time to maturity of the option, in years, and should be non-negative. Lower Barrier is the predetermined lower barrier price; set to zero for no lower barrier. Upper Barrier is the predetermined upper barrier price; set to zero for no upper barrier. Strike (optional) is the strike price of the option and should be non-negative. The default is -1.0 (to indicate that a value has not been set). Put or Call (optional) is a string that defines whether the option is a put (&quot;p&quot;) or a call (&quot;c&quot;). The default is “c”.</td>
</tr>
<tr>
<td>Syntax</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
</tbody>
</table>
| OPT_TOUCH(Spot, Volatility, Rate, Foreign Rate, Maturity, Lower Barrier, Upper Barrier, Domestic or Foreign, In or Out, Barrier Monitoring, Greek) | Returns the pricing of a touch / no-touch option, calculated using the Black-Scholes option pricing model. 
**Spot** is the price / value of the underlying asset and should be greater than 0.0. **Volatility** is the annual percentage volatility of the underlying asset expressed as a decimal. The value should be greater than 0.0. **Rate** is the continuously compounded interest rate. This is a percentage expressed as a decimal. **Foreign Rate** is the continuously compounded foreign interest rate. This is a percentage expressed as a decimal. **Maturity** is the time to maturity of the option, in years, and should be non-negative. **Lower Barrier** is the predetermined lower barrier price; set to zero for no lower barrier. **Upper Barrier** is the predetermined upper barrier price; set to zero for no upper barrier. **Domestic or Foreign** is a string that defines whether the option pays domestic ("d") or foreign ("f") currency. **In or Out** is a string that defines whether the option is knock-in ("i") or knock-out ("o"). **Barrier Monitoring** is a string that defines whether the barrier is monitored continuously ("c") or only at the end / maturity ("e"). **Greek** (optional) is a string argument. If omitted or set to "value", "v", "price", or "p", then the function simply returns the option price. If another valid string is entered (see Help files), the function returns price sensitivities (Greeks) to one of the input arguments. |
<p>| PDURATION(Rate, PV, FV)   | Calculates the number of periods required by an investment to attain a desired value. <strong>Rate</strong> is the constant rate of interest. <strong>PV</strong> is the present value of the investment. <strong>FV</strong> is the desired future value of the investment. |
| PMT(Rate, NPER, PV, FV, Type) | Returns the periodic payment for an annuity with constant interest rates. <strong>Rate</strong> is the periodic interest rate. <strong>NPER</strong> is the number of periods in which the annuity is paid. <strong>PV</strong> is the present value (cash value) in a sequence of payments. <strong>FV</strong> (optional) is the desired value (future value) to be reached at the end of the periodic payments. <strong>Type</strong> (optional) defines whether the payment is due at the beginning (1) or the end (0) of a period. |
| PPMT(Rate, Period, NPER, PV, FV, Type) | Returns for a given period the payment on the principal for an investment that is based on periodic and constant payments and a constant interest rate. <strong>Rate</strong> is the periodic interest rate. <strong>Period</strong> is the amortization period. <strong>NPER</strong> is the total number of periods during which the annuity is paid. <strong>Period</strong> = 1 for the first period and <strong>Period</strong> = <strong>NPER</strong> for the last period. <strong>PV</strong> is the present value in the sequence of payments. <strong>FV</strong> (optional) is the desired (future) value. <strong>Type</strong> (optional) defines whether the payment is due at the beginning (1) or the end (0) of a period. |</p>
<table>
<thead>
<tr>
<th>Syntax</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>PRICE(Settlement, Maturity, Rate, Yield, Redemption, Frequency, Basis)</td>
<td>Calculates the price per 100 currency units of par value of an interest-bearing security. <strong>Settlement</strong> is the date of purchase of the security. <strong>Maturity</strong> is the date on which the security matures (expires). <strong>Rate</strong> is the annual nominal rate of interest (coupon interest rate). <strong>Yield</strong> is the annual yield of the security. <strong>Redemption</strong> is the redemption value per 100 currency units of par value. <strong>Frequency</strong> is the number of interest payments per year (1, 2 or 4). <strong>Basis</strong> (optional) indicates how the year is to be calculated.</td>
</tr>
<tr>
<td>PRICEDISC(Settlement, Maturity, Discount, Redemption, Basis)</td>
<td>Calculates the price per 100 currency units of par value of a discounted security. <strong>Settlement</strong> is the date of purchase of the security. <strong>Maturity</strong> is the date on which the security matures (expires). <strong>Discount</strong> is the discount of a security as a percentage. <strong>Redemption</strong> is the redemption value per 100 currency units of par value. <strong>Basis</strong> (optional) indicates how the year is to be calculated.</td>
</tr>
<tr>
<td>PRCEMAT(Settlement, Maturity, Issue, Rate, Yield, Basis)</td>
<td>Calculates the price per 100 currency units of par value of a security, that pays interest on the maturity date. <strong>Settlement</strong> is the date of purchase of the security. <strong>Maturity</strong> is the date on which the security matures (expires). <strong>Issue</strong> is the date of issue of the security. <strong>Rate</strong> is the interest rate of the security on the issue date. <strong>Yield</strong> is the annual yield of the security. <strong>Basis</strong> (optional) indicates how the year is to be calculated.</td>
</tr>
<tr>
<td>PV(Rate, NPER, PMT, FV, Type)</td>
<td>Returns the present value of an investment resulting from a series of regular payments. <strong>Rate</strong> defines the interest rate per period. <strong>NPER</strong> is the total number of payment periods. <strong>PMT</strong> is the regular payment made per period. <strong>FV</strong> (optional) defines the future value remaining after the final installment has been made. <strong>Type</strong> (optional) defines whether the payment is due at the beginning (1) or the end (0) of a period.</td>
</tr>
<tr>
<td>RATE(NPER, PMT, PV, FV, Type, Guess)</td>
<td>Returns the constant interest rate per period of an annuity. <strong>NPER</strong> is the total number of periods, during which payments are made (payment period). <strong>PMT</strong> is the constant payment (annuity) paid during each period. <strong>PV</strong> is the cash value in the sequence of payments. <strong>FV</strong> (optional) is the future value, which is reached at the end of the periodic payments. <strong>Type</strong> (optional) defines whether the payment is due at the beginning (1) or the end (0) of a period. <strong>Guess</strong> (optional) determines the estimated value of the interest with iterative calculation.</td>
</tr>
<tr>
<td>RECEIVED(Settlement, Maturity, Investment, Discount, Basis)</td>
<td>Calculates the amount paid out at maturity for a fully invested security. <strong>Settlement</strong> is the date of purchase of the security. <strong>Maturity</strong> is the date on which the security matures. <strong>Investment</strong> is the purchase sum. <strong>Discount</strong> is the percentage discount on acquisition of the security. <strong>Basis</strong> (optional) indicates how the year is to be calculated.</td>
</tr>
<tr>
<td>RRI(P, pv, FV)</td>
<td>Calculates the interest rate resulting from the profit (return) of an investment. <strong>P</strong> is the number of periods used for calculating the interest rate. <strong>pv</strong> is the present value (must be &gt;0). <strong>FV</strong> is the final value of the security.</td>
</tr>
<tr>
<td>Syntax</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>SLN(Cost, Salvage, Life)</td>
<td>Returns the straight-line depreciation of an asset for one period. <strong>Cost</strong> is the initial cost of an asset. <strong>Salvage</strong> is the value of an asset at the end of the depreciation. <strong>Life</strong> is the number of periods in the useful life of the asset.</td>
</tr>
<tr>
<td>SYD(Cost, Salvage, Life, Period)</td>
<td>Returns the arithmetically declining value of an asset (depreciation) for a specified period. It uses the Sum-of-Years'-Digits method. <strong>Cost</strong> is the initial cost of an asset. <strong>Salvage</strong> is the value of an asset after depreciation. <strong>Life</strong> is the period fixing the time span over which an asset is depreciated. <strong>Period</strong> defines the period for which the depreciation is to be calculated. Must use the same units as <strong>Life</strong>.</td>
</tr>
<tr>
<td>TBILLEQ(Settlement, Maturity, Discount)</td>
<td>Calculates the bond equivalent yield for a treasury bill. <strong>Settlement</strong> is the date of purchase of the security. <strong>Maturity</strong> is the date on which the security matures (expires). The settlement and maturity date must be within a year of each other. <strong>Discount</strong> is the percentage discount on acquisition of the security. Calculated using the 360 days in a year basis (basis 2).</td>
</tr>
<tr>
<td>TBILLPRICE(Settlement, Maturity, Discount)</td>
<td>Calculates the price per 100 currency units face value of a treasury bill. <strong>Settlement</strong> is the date of purchase of the security. <strong>Maturity</strong> is the date on which the security matures (expires). The settlement and maturity date must be within a year of each other. <strong>Discount</strong> is the percentage discount upon acquisition of the security.</td>
</tr>
<tr>
<td>TBILLYIELD(Settlement, Maturity, Price)</td>
<td>Calculates the yield of a treasury bill. <strong>Settlement</strong> is the date of purchase of the security. <strong>Maturity</strong> is the date on which the security matures (expires). The settlement and maturity date must be within a year of each other. <strong>Price</strong> is the price (purchase price) of the treasury bill per 100 currency units of par value.</td>
</tr>
<tr>
<td>VDB(Cost, Salvage, Life, S, end, Factor, Type)</td>
<td>Returns the depreciation of an asset for a specified or partial period using a variable declining balance method. <strong>Cost</strong> is the initial value of an asset. <strong>Salvage</strong> is the value of an asset at the end of the depreciation. <strong>Life</strong> is the depreciation duration of the asset. <strong>S</strong> is the start period of the depreciation, entered in the same date unit as <strong>Life</strong>. <strong>end</strong> is the last period of the depreciation, entered in the same date unit as <strong>Life</strong>. <strong>Factor</strong> (optional) is the depreciation factor. If factor is omitted, a factor of two is assumed (the double-declining balance method). <strong>Type</strong> is an optional argument. Type = 0 means a switch to linear depreciation. In Type = 1, no switch is made.</td>
</tr>
<tr>
<td>Syntax</td>
<td>Description</td>
</tr>
<tr>
<td>-------------------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>XIRR(Values, Dates, Guess)</td>
<td>Calculates the internal rate of return for a list of payments which take place on different dates. The calculation is based on a 365 days per year basis, ignoring leap years. If the payments take place at regular intervals, use the IRR function. <strong>Values</strong> and <strong>Dates</strong> are a series of payments and a series of associated date values entered as cell references. <strong>Values</strong> shall include at least one negative value and one positive value. <strong>Guess</strong> (optional) is a guess for the internal rate of return. If omitted, the value 10% is assumed.</td>
</tr>
<tr>
<td>XNPV(Rate, Values, Dates)</td>
<td>Calculates the capital value (net present value) for a list of payments which take place on different dates. The calculation is based on a 365 days per year basis, ignoring leap years. If the payments take place at regular intervals, use the NPV function. <strong>Rate</strong> is the internal rate of return for the payments. <strong>Values</strong> and <strong>Dates</strong> are a series of payments and a series of associated date values entered as cell references. The first value-date pair indicates the start of the payments, other dates can be in any order. Values shall include at least one negative value and one positive value.</td>
</tr>
<tr>
<td>YIELD(Settlement, Maturity, Rate, Price, Redemption, Frequency, Basis)</td>
<td>Calculates the yield of a security that pays periodic interest. <strong>Settlement</strong> is the date of purchase of the security. <strong>Maturity</strong> is the date on which the security matures (expires). <strong>Rate</strong> is the annual rate of interest. <strong>Price</strong> is the price (purchase price) of the security per 100 currency units of par value. <strong>Redemption</strong> is the redemption value per 100 currency units of par value. <strong>Frequency</strong> is the number of interest payments per year (1, 2 or 4). <strong>Basis</strong> (optional) indicates how the year is to be calculated.</td>
</tr>
<tr>
<td>YIELDDISC(Settlement, Maturity, Price, Redemption, Basis)</td>
<td>Calculates the annual yield of a non-interest-bearing security. <strong>Settlement</strong> is the date of purchase of the security. <strong>Maturity</strong> is the date on which the security matures (expires). <strong>Price</strong> is the price (purchase price) of the security per 100 currency units of par value. <strong>Redemption</strong> is the redemption value per 100 currency units of par value. <strong>Basis</strong> (optional) indicates how the year is to be calculated.</td>
</tr>
<tr>
<td>YIELDMAT(Settlement, Maturity, Issue, Rate, Price, Basis)</td>
<td>Calculates the annual yield of a security, the interest of which is paid on the date of maturity. <strong>Settlement</strong> is the date of purchase of the security. <strong>Maturity</strong> is the date on which the security matures (expires). <strong>Issue</strong> is the date of issue of the security. <strong>Rate</strong> is the interest rate of the security on the issue date. <strong>Price</strong> is the price (purchase price) of the security per 100 currency units of par value. <strong>Basis</strong> (optional) indicates how the year is to be calculated.</td>
</tr>
</tbody>
</table>

### Statistical analysis functions

Calc includes over 150 statistical functions which enable the evaluation of data from simple arithmetic calculations, such as averaging, to advanced distribution and probability computations. Several other statistics-based functions are available through the Add-ins which are noted at the end of this chapter.
### Table 29: Statistical analysis functions

<table>
<thead>
<tr>
<th>Syntax</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>AVEDEV(number 1, number 2, ..., number 30)</td>
<td>Returns the average of the absolute deviations of data points from their mean. Displays the diffusion in a data set. <code>number 1, number 2, ..., number 30</code> are values or ranges that represent a sample. Each number can also be replaced by a reference.</td>
</tr>
<tr>
<td>AVERAGE(number 1, number 2, ..., number 30)</td>
<td>Returns the average of the arguments. <code>number 1, number 2, ..., number 30</code> are numerical values or ranges.</td>
</tr>
<tr>
<td>AVERAGEA(value 1, value 2, ..., value 30)</td>
<td>Returns the average of the arguments. The value of text is taken to be 0. <code>value 1, value 2, ..., value 30</code> are values or ranges.</td>
</tr>
<tr>
<td>AVERAGEIF(range, criterion, average_range)</td>
<td>Returns the arithmetic mean of all cells in a range that satisfy a given condition. Sums up all the results that match a logical test and divides this sum by the number of selected values. <code>range</code> is an array, a named range, or the label of a column or a row. It should contain numbers for averaging, or numbers or text for the condition. <code>criterion</code> is a condition in the form of an expression, or a cell reference with expression, that defines which cells should be used to calculate the mean. The expression can contain text, numbers, regular expressions, or wildcards (if enabled). <code>criterion</code> should be a string expression and should be enclosed in quotation marks, except for the names of functions, cell references, and string concatenation (&amp;). <code>average_range</code> is an optional argument that gives a range of values for calculating the mean. If <code>average_range</code> is not specified, <code>range</code> is used for both the calculation of the mean and the search according to the condition. If <code>average_range</code> is specified, <code>range</code> is used only for the condition test, while <code>average_range</code> is used for the mean calculation. If a cell in a range of values for calculating the mean is empty or contains text, the cell is ignored. If the whole range is empty, contains only text, or includes no values that satisfy the condition, the function returns an error.</td>
</tr>
<tr>
<td>Syntax</td>
<td>Description</td>
</tr>
<tr>
<td>--------</td>
<td>-------------</td>
</tr>
</tbody>
</table>
| AVERAGEIFS(average_range, range 1, criterion 1, range 2, criterion 2, ..., range 127, criterion 127) | Returns the arithmetic mean of all cells in a range that satisfy given multiple criteria. Sums up all the results that match the logical tests and divides this sum by the number of selected values.  
**average_range** is a range of cells, a name of a named range, or a label of a column or a row containing values for calculating the mean.  
**range1** is an array, a named range, or the label of a column or a row. It should contain numbers or text for the condition.  
**range2, range3, ...,** and so on are optional but have the same meaning as **range1**.  
**average_range, range1, range2, ...,** and so on must have the same size, otherwise the function returns an invalid argument error.  
**criterion 1** is a string expression representing a logical condition, or a cell reference to such a string expression. The expression can contain text, numbers, regular expressions, or wildcards (if enabled). **criterion 1, criterion 2, ...,** and so on are optional but have the same meaning as **criterion 1**. The logical relation between criteria can be defined as logical AND (conjunction). In other words, a value from the corresponding cell of the given **average_range** is taken into the calculation if and only if all given criteria are met.  
The function can have up to 255 arguments, meaning that you can specify up to 127 range and criterion combinations. |
| B(trials, SP, T_1, T_2) | Returns the probability of a specified number of successes in a binomial experiment. **trials** is the number of independent trials. **SP** is the probability of success on each trial. **T_1** defines the lower limit for the number of successful trials. **T_2** (optional) defines the upper limit for the number of successful trials. |
| BETA.DIST(Number, Alpha, Beta, Cumulative, Start, End) | Calculates either the cumulative distribution function or the probability density function for the given arguments, based on a Beta distribution.  
**Number** is the value at which to evaluate the function and should lie between **Start** and **End**. **Alpha** and **Beta** are the positive shape parameters of the Beta distribution. Set **Cumulative** to 0 or False to calculate the probability density function; set to any other value to calculate the cumulative distribution function. **Start** is the lower bound for the value interval of the distribution and **End** is the upper bound. **Start** and **End** are optional, defaulting to 0 and 1 respectively. |
| BETA.INV(Number, Alpha, Beta, Start, End) | Returns the inverse of the cumulative distribution function, based on a Beta distribution.  
**Number** is the probability value for which to evaluate the function and should lie between **Start** and **End**. **Alpha** and **Beta** are the positive shape parameters of the Beta distribution. **Start** is the lower bound for the value interval of the distribution and **End** is the upper bound. **Start** and **End** are optional, defaulting to 0 and 1 respectively. |
<table>
<thead>
<tr>
<th>Syntax</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>MINIFS(Func_Range, Range1,</td>
<td>Returns the minimum of the values of cells in a range that meet multiple criteria in multiple ranges.</td>
</tr>
<tr>
<td>Criterion1, Range2, Criterion2, ...)</td>
<td><strong>Func_Range</strong> is a range of cells, a name of a named range or a label of a column or a row containing values for calculating the minimum. <strong>Range1</strong> is a range of cells, a named range, or a row / column label, containing the data to be evaluated against <strong>Criterion1</strong>. <strong>Criterion1</strong> is a string expression representing a logical condition or a cell reference to such string expression. The expression can contain text, numbers, regular expressions, or wildcards (if enabled). <strong>Range2</strong> ... <strong>Range127</strong> are optional arguments and all mean the same as <strong>Range1</strong>. <strong>Criterion2</strong> ... <strong>Criterion127</strong> are optional arguments and all mean the same as <strong>Criterion1</strong>. The function can have up to 255 arguments, meaning that you can specify 127 range / criterion pairs. <strong>Func_Range</strong>, <strong>Range1</strong>, and <strong>Range2</strong> ... <strong>Range127</strong> (where present) must have the same dimensions. The logical relation between criteria can be defined as logical AND (conjunction). In other words, if and only if all given criteria are met, a value from the corresponding cell of the given <strong>Func_Range</strong> is taken into calculation.</td>
</tr>
<tr>
<td>MODE(number 1, number 2, ..., number 30)</td>
<td>Returns the most common value in a data set. <strong>number 1</strong>, <strong>number 2</strong>, ..., <strong>number 30</strong> are numerical values or ranges. If several values have the same frequency, it returns the smallest value. An error occurs if no value appears more than once.</td>
</tr>
<tr>
<td>MODE.MULT(Number1, Number2, ..., Number30)</td>
<td>Returns a vertical array of the statistical modes (the most frequently occurring values) within a list of supplied numbers. <strong>Number1</strong>, <strong>Number2</strong>, ..., <strong>Number30</strong> are numeric values or ranges. As the MODE.MULT function returns an array of values, it must be entered as an array formula. If the function is not entered as an array formula, only the first mode is returned, which is the same as using the MODE.SNGL function.</td>
</tr>
<tr>
<td>MODE.SNGL(Number1, Number2, ..., Number30)</td>
<td>Returns the most frequently occurring, or repetitive, value in an array or range of data. If there are several values with the same frequency, it returns the smallest value. An error occurs when a value doesn't appear twice. <strong>Number1</strong>, <strong>Number2</strong>, ..., <strong>Number30</strong> are numeric values or ranges.</td>
</tr>
<tr>
<td>NEGBINOM.DIST(X, R, SP, Cumulative)</td>
<td>Returns values of the probability density function or cumulative distribution function for the negative binomial distribution. <strong>X</strong> is the value returned for unsuccessful tests. <strong>R</strong> is the value returned for successful tests. <strong>SP</strong> is the probability of the success of an attempt. <strong>Cumulative</strong> = 0 calculates the density probability density function, <strong>Cumulative</strong> = 1 calculates the cumulative distribution function.</td>
</tr>
<tr>
<td>Syntax</td>
<td>Description</td>
</tr>
<tr>
<td>--------</td>
<td>-------------</td>
</tr>
<tr>
<td>NEGBINOMDIST(X, R, SP)</td>
<td>Returns the negative binomial distribution. X is the value returned for unsuccessful tests. R is the value returned for successful tests. SP is the probability of the success of an attempt. NEGBINOMDIST returns the probability that there will be x failures before the r-th success, when the constant probability of a success is SP.</td>
</tr>
<tr>
<td>NORM.DIST(Number, Mean, StDev, C)</td>
<td>Returns values of the probability density function or the cumulative distribution function for the normal distribution. Number is the value for which the normal distribution is to be calculated. Mean is the mean value of the distribution. StDev is the standard deviation of the distribution. C = 0 calculates the probability density function, C = 1 calculates the cumulative distribution function.</td>
</tr>
<tr>
<td>NORM.INV(Number, Mean, StDev)</td>
<td>Returns values of the inverse of the normal cumulative distribution. Number represents the probability value used to determine the inverse normal distribution. Mean represents the mean value of the normal distribution. StDev represents the standard deviation of the normal distribution.</td>
</tr>
<tr>
<td>NORM.S.DIST(Number; Cumulative)</td>
<td>Returns values of the probability density function or the cumulative distribution function for the standard normal distribution. This distribution has a mean of 0 and a standard deviation of 1. Number is the value to which the standard normal cumulative distribution is calculated. Cumulative 0 or FALSE calculates the probability density function. Any other value calculates the cumulative distribution function.</td>
</tr>
<tr>
<td>NORM.S.INV(Number)</td>
<td>Returns values of the inverse of the standard normal distribution. Number is the probability for which the inverse standard normal distribution is calculated.</td>
</tr>
<tr>
<td>NORMDIST(Number, Mean, STDEV, C)</td>
<td>Returns the value of the probability density function or the cumulative distribution function for the normal distribution with the mean and standard deviation given. Number is the value for which the normal distribution is to be calculated. Mean is the mean value of the normal distribution. STDEV is the standard deviation of the normal distribution. If C = 0 or FALSE it calculates the probability density function, and if C = any other value or is omitted, it calculates the cumulative distribution function.</td>
</tr>
<tr>
<td>NORMINV(number, mean, STDEV)</td>
<td>Returns the inverse of the normal distribution for the given probability value, number, in the distribution. mean is the mean value of the normal distribution. STDEV is the standard deviation of the normal distribution.</td>
</tr>
</tbody>
</table>

Statistical analysis functions | 497
<table>
<thead>
<tr>
<th>Syntax</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>NORMSDIST(Number)</td>
<td>Returns the standard normal cumulative distribution for the given Number. This function is defined as LEGACY.NORMSDIST in the ODF v1.2 specification. This is exactly NORMDIST(x,0,1,TRUE()).</td>
</tr>
<tr>
<td>NORMSINV(number)</td>
<td>Returns the inverse of the standard normal distribution for the given probability value, number. number must be in the range 0 &lt; number &lt; 1. This function is defined as LEGACY.NORMSINV in the ODF v1.2 specification.</td>
</tr>
<tr>
<td>PEARSON(Data_1, Data_2)</td>
<td>Returns the Pearson correlation coefficient, r, of two data sets. Data_1 is the array of the first data set. Data_2 is the array of the second data set. For an empty element or an element of type Text or Boolean in Data_1 the element at the corresponding position of Data_2 is ignored, and vice versa. Both arrays must be the same size and shape.</td>
</tr>
<tr>
<td>PERCENTILE(data, Alpha)</td>
<td>Returns the alpha-percentile of data values in an array. data is the array of data. Alpha is the percentile value between 0 and 1. If Alpha is not a multiple of 1/(n - 1), PERCENTILE interpolates to determine the value between two data points.</td>
</tr>
<tr>
<td>PERCENTILE.EXC(Data, Alpha)</td>
<td>Returns a percentile value for a set of data based on the given value of alpha, which lies within the range 0 to 1 (exclusive). A percentile returns the scale value for a data series which goes from the smallest (alpha=0) to the largest (alpha=1) value. For alpha = 25%, the percentile means the first quartile; alpha = 50% is the median. Data is the array of data. Alpha represents the percentage of the scale between 0 and 1. If Alpha is not a multiple of 1/(n+1), (where n is the number of values in the supplied array), the function interpolates between the values in the supplied array, to calculate the percentile value. However, if Alpha is less than 1/(n+1) or Alpha is greater than n/(n+1), the function is unable to interpolate, and so returns an error.</td>
</tr>
<tr>
<td>PERCENTILE.INC(Data, Alpha)</td>
<td>Returns a percentile value for a set of data based on the given value of alpha, which lies within the range 0 to 1 (inclusive). A percentile returns the scale value for a data series which goes from the smallest (alpha=0) to the largest (alpha=1) value. For alpha = 25%, the percentile means the first quartile; alpha = 50% is the median. Data is the array of data. Alpha represents the percentage of the scale between 0 and 1.</td>
</tr>
<tr>
<td>PERCENTRANK(data, value, Significance)</td>
<td>Returns the percentage rank (percentile) of the given value in a sample. data is the array of data in the sample. Significance is an optional argument that specifies the number of significant digits for rounding the returned percentage value.</td>
</tr>
<tr>
<td>Syntax</td>
<td>Description</td>
</tr>
<tr>
<td>--------</td>
<td>-------------</td>
</tr>
<tr>
<td>PERCENTRANK.EXC(Data, Value, Significance)</td>
<td>Returns the relative position, between 0 and 1 (exclusive), of a specified value within a supplied array. <strong>Data</strong> is the array of data in the sample. <strong>Value</strong> represents the value whose percentile rank must be determined. <strong>Significance</strong> is an optional argument that specifies the number of significant digits for rounding the returned percentage value.</td>
</tr>
<tr>
<td>PERCENTRANK.INC(Data, Value, Significance)</td>
<td>Returns the relative position, between 0 and 1 (inclusive), of a specified value within a supplied array. <strong>Data</strong> is the array of data in the sample. <strong>Value</strong> represents the value whose percentile rank must be determined. <strong>Significance</strong> is an optional argument that specifies the number of significant digits for rounding the returned percentage value.</td>
</tr>
<tr>
<td>PERMUT(Count_1, Count_2)</td>
<td>Returns the number of permutations for a given number of objects without repetition. <strong>Count_1</strong> is the total number of objects. <strong>Count_2</strong> is the number of objects in each permutation.</td>
</tr>
<tr>
<td>PERMUTATIONA(Count_1, Count_2)</td>
<td>Returns the number of permutations for a given number of objects (repetition allowed, meaning an object can combine with itself). <strong>Count_1</strong> is the total number of objects. <strong>Count_2</strong> is the number of objects in each permutation.</td>
</tr>
<tr>
<td>PHI(number)</td>
<td>Returns the values of the distribution function for a standard normal distribution for the given number. PHI(number) is a synonym for NORMDIST(number,0,1,FALSE()).</td>
</tr>
<tr>
<td>POISSON(Number, mean, Cumulative)</td>
<td>Returns the probability density function or the cumulative distribution function for the Poisson distribution. <strong>Number</strong> represents the value for which the Poisson distribution is calculated. <strong>Mean</strong> is the middle value of the Poisson distribution. <strong>Cumulative</strong> = 0 or False calculates the probability density function, and <strong>Cumulative</strong> = 1 or True calculates the cumulative distribution function. When <strong>Cumulative</strong> is omitted, the default value True is inserted when you save the document, for best compatibility with other programs and older versions of LibreOffice.</td>
</tr>
<tr>
<td>POISSON.DIST(Number, Mean, C)</td>
<td>Returns a probability for the Poisson distribution, using either the probability density function or the cumulative distribution function. <strong>Number</strong> represents the value for which the Poisson distribution is calculated. <strong>Mean</strong> represents the middle value of the Poisson distribution. <strong>C</strong> is an optional argument. When <strong>C</strong> is set to 0 or False, the function calculates the probability density function. When <strong>C</strong> is set to 1 or True, the function calculates the cumulative distribution function. When <strong>C</strong> is omitted, the default value True is inserted when you save the document, for best compatibility with other programs and older versions of LibreOffice.</td>
</tr>
<tr>
<td>Syntax</td>
<td>Description</td>
</tr>
<tr>
<td>------------------------</td>
<td>------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>PROB(data, probability, Start, End)</td>
<td>Returns the probability that values in a range are between two limits. <strong>data</strong> is the array or range of data in the sample. <strong>probability</strong> is the array or range of the corresponding probabilities. <strong>Start</strong> is the start value of the interval whose probabilities are to be summed. <strong>End</strong> (optional) is the end value of the interval whose probabilities are to be summed. If this argument is missing, then <strong>End = Start</strong> value is assumed.</td>
</tr>
<tr>
<td>QUARTILE(data, Type)</td>
<td>Returns the quartile of a data set. <strong>data</strong> is the array of data in the sample. <strong>Type</strong> is the number of the quartile to return. (0 = Min, 1 = 25%, 2 = 50% (Median), 3 = 75% and 4 = Max). Based on the statistical rank of the data points in <strong>data</strong>, <strong>QUARTILE</strong> returns the percentile value indicated by <strong>Type</strong>. The percentile is calculated as <strong>Type</strong> divided by 4. The same algorithm used in <strong>PERCENTILE</strong> is used here to interpolate between two data points.</td>
</tr>
<tr>
<td>QUARTILE.EXC(Data, Type)</td>
<td>Returns a requested quartile of a supplied range of values, based on a percentile range of 0 to 1 exclusive. <strong>Data</strong> represents the range of data values for which you want to calculate the specified quartile. <strong>Type</strong> is an integer between 1 and 3, representing the required quartile. If <strong>Type</strong> = 1 or 3, the supplied array must contain more than two values.</td>
</tr>
</tbody>
</table>
| QUARTILE.INC(Data, Type) | Returns a requested quartile of a supplied range of values, based on a percentile range of 0 to 1 inclusive. **Data** is the array of data in the sample. **Type** represents the quartile required, that is:  
  - 0 – minimum value  
  - 1 – first quartile  
  - 2 – second quartile (median)  
  - 3 – third quartile  
  - 4 – maximum value |
<p>| RANK(value, Data, Type) | Returns the rank of the given <strong>value</strong> in a sample. <strong>Data</strong> is the array or range of data in the sample. <strong>Type</strong> (optional) is the ranking order. <strong>Type</strong> = 0 means descending from the last item of the array to the first (this is the default). <strong>Type</strong> = 1 means ascending from the first item of the range to the last. |
| RANK.AVG(Value, Data, Type) | Returns the statistical rank of a given value, within a supplied array of values. If there are duplicate values in the list, the average rank is returned. <strong>Value</strong> is the value whose rank is to be determined. <strong>Data</strong> is the array or range of data in the sample. <strong>Type</strong> is an optional argument defining the sequence order. A <strong>Type</strong> value of 0 means descending from the last item of the array to the first and this is the default. A <strong>Type</strong> value of 1 means ascending from the first item of the range to the last. |</p>
<table>
<thead>
<tr>
<th>Syntax</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>RANK.EQ(Value, Data, Type)</td>
<td>Returns the statistical rank of a given value, within a supplied array of values. If there are duplicate values in the list, these are given the same rank. Value is the value whose rank is to be determined. Data is the array or range of data in the sample. Type is an optional argument defining the sequence order. A Type value of 0 means descending from the last item of the array to the first and this is the default. A Type value of 1 means ascending from the first item of the range to the last.</td>
</tr>
<tr>
<td>RSQ(data_Y, data_X)</td>
<td>Returns the square of the Pearson correlation coefficient based on the given values. RSQ (also called the coefficient of determination) is a measure for the accuracy of an adjustment and can be used to produce a regression analysis. data_Y is an array or range of data points. data_X is an array or range of data points.</td>
</tr>
<tr>
<td>SKEW(number 1, number 2, ..., number 30)</td>
<td>Returns the skewness of a distribution. number 1, number 2, ..., number 30 are numerical values or ranges. There must be a minimum of three numbers.</td>
</tr>
<tr>
<td>SKEWP(number 1, number 2, ..., number 30)</td>
<td>Calculates the skewness of a distribution using the population of a random variable. number 1, number 2, ..., number 30 are numerical values or ranges. There must be a minimum of three numbers.</td>
</tr>
<tr>
<td>SLOPE(data_Y, data_X)</td>
<td>Returns the slope of the linear regression line. data_Y is the array or matrix of Y data. data_X is the array or matrix of X data. Both arrays must have the same size and shape. For an empty element or an element of type Text or Boolean in y the element at the corresponding position of x is ignored, and vice versa.</td>
</tr>
<tr>
<td>SMALL(data, Rank_c)</td>
<td>Returns the rank_c-th smallest value in a data set. data is the cell range of data. Rank_c is the rank of the value (2nd smallest, 3rd smallest, etc.) written as an integer.</td>
</tr>
<tr>
<td>STANDARDIZE(Number, mean, STDEV)</td>
<td>Converts a random variable to a normalized value. Number is the value to be standardized. mean is the arithmetic mean of the distribution. STDEV is the standard deviation of the distribution.</td>
</tr>
<tr>
<td>STDEV(number 1, number 2, ..., number 30)</td>
<td>Computes the sample standard deviation of a set of numbers. number 1, number 2, ..., number 30 are numerical values or ranges representing a sample based on an entire population.</td>
</tr>
<tr>
<td>STDEV.P(Number1, Number2, ..., Number30)</td>
<td>Calculates the standard deviation based on the entire population. Number1, Number2, ..., Number30 are numeric values or ranges representing an entire population. Number2, ..., Number30 are optional.</td>
</tr>
<tr>
<td>Syntax</td>
<td>Description</td>
</tr>
<tr>
<td>--------</td>
<td>-------------</td>
</tr>
<tr>
<td>STDEV.S(Number1, Number2, ..., Number30)</td>
<td>Calculates the standard deviation based on sample of the population. <strong>Number1</strong>, <strong>Number2</strong>, ..., <strong>Number30</strong> are numeric values or ranges representing a sample of the population. <strong>Number2</strong>, ..., <strong>Number30</strong> are optional.</td>
</tr>
<tr>
<td>STDEVA(value 1, value 2, ..., value 30)</td>
<td>Calculates the standard deviation using a sample set of values, including values of type Text and Logical. <strong>value 1</strong>, <strong>value 2</strong>, ..., <strong>value 30</strong> are values or ranges representing a sample derived from an entire population. Text has the value 0.</td>
</tr>
<tr>
<td>STDEVVP(number 1, number 2, ..., number 30)</td>
<td>Calculates the standard deviation using the population of a random variable, including values of type Text and Logical. <strong>number 1</strong>, <strong>number 2</strong>, ..., <strong>number 30</strong> are numerical values or ranges representing an entire population.</td>
</tr>
<tr>
<td>STDEVPA(value 1, value 2, ..., value 30)</td>
<td>Calculates the standard deviation based on the entire population. <strong>value 1</strong>, <strong>value 2</strong>, ..., <strong>value 30</strong> are values or ranges representing a sample derived from an entire population. Text has the value 0. Logical FALSE is 0 and logical TRUE is 1.</td>
</tr>
<tr>
<td>STEYX(data_Y, data_X)</td>
<td>Returns the standard error of the predicted y value for each x in the regression. <strong>data_Y</strong> is the array or matrix of Y data. <strong>data_X</strong> is the array or matrix of X data. Both arrays must have the same size and shape and contain at least three numbers.</td>
</tr>
<tr>
<td>T.DIST(Number, Degrees of Freedom, Cumulative)</td>
<td>Returns values from the one-tailed Student's t-distribution, using either the probability density function or the cumulative distribution function. <strong>Number</strong> is the value for which the t-distribution is calculated. <strong>Degrees of Freedom</strong> is the number of degrees of freedom for the t-distribution. Set <strong>Cumulative</strong> to 0 or FALSE to return values of the probability density function. Set <strong>Cumulative</strong> to 1 or TRUE to return values of the cumulative distribution function.</td>
</tr>
<tr>
<td>T.DIST.2T(Number, Degrees of Freedom)</td>
<td>Calculates values of the two-tailed Student's t-distribution, which is a continuous probability distribution that is frequently used for testing hypotheses on small sample data sets. <strong>Number</strong> is the value for which the t-distribution is calculated. <strong>Degrees of Freedom</strong> is the number of degrees of freedom for the t-distribution.</td>
</tr>
<tr>
<td>T.DIST.RT(Number, Degrees of Freedom)</td>
<td>Calculates the right-tailed Student's t-distribution, which is a continuous probability distribution that is frequently used for testing hypotheses on small sample data sets. <strong>Number</strong> is the value for which the t-distribution is calculated. <strong>Degrees of Freedom</strong> is the number of degrees of freedom for the t-distribution.</td>
</tr>
<tr>
<td>T.INV(Number, Degrees of Freedom)</td>
<td>Returns the one tailed inverse of the Student's t-distribution. <strong>Number</strong> is the probability associated with the one-tailed t-distribution. <strong>Degrees of Freedom</strong> is the number of degrees of freedom for the t-distribution.</td>
</tr>
<tr>
<td>Syntax</td>
<td>Description</td>
</tr>
<tr>
<td>--------</td>
<td>-------------</td>
</tr>
<tr>
<td>T.INV.2T(Number, Degrees of Freedom)</td>
<td>Calculates the inverse of the two-tailed Student's t-distribution, which is a continuous probability distribution that is frequently used for testing hypotheses on small sample data sets. <strong>Number</strong> is the probability associated with the two-tailed t-distribution. <strong>Degrees of Freedom</strong> is the number of degrees of freedom for the t-distribution.</td>
</tr>
</tbody>
</table>
| T.TEST(Data1, Data2, Mode, Type) | Returns the probability associated with a Student's t-Test. **Data1** is the dependent array or range of data for the first record. **Data2** is the dependent array or range of data for the second record. The value of **Mode** determines whether a one-tailed test (set to 1) or a two-tailed test (set to 2) is performed. **Type** specifies the type of t-test to perform, as follows:  
  - 1 means paired.  
  - 2 means two samples, equal variance (homoscedastic).  
  - 3 means two samples, unequal variance (heteroscedastic). |
<p>| TDIST(Number, degrees_freedom, mode) | Returns the t-distribution for the given <strong>Number</strong>. <strong>degrees_freedom</strong> is the number of degrees of freedom for the t-distribution. <strong>mode</strong> = 1 returns the one-tailed test, <strong>mode</strong> = 2 returns the two-tailed test. This function is named LEGACY.TDIST in the ODF v1.2 specification. |
| TINV(number, degrees_freedom) | Returns the inverse of the t-distribution, for the given <strong>number</strong> associated with the two-tailed t-distribution. <strong>degrees_freedom</strong> is the number of degrees of freedom for the t-distribution. |
| TRIMMEAN(data, Alpha) | Returns the mean of a data set, ignoring a proportion of high and low values. <strong>data</strong> is the array of data in the sample. <strong>Alpha</strong> is the fractional number of data points to exclude from the calculation. For example, if <strong>Alpha</strong> = 0.2, 4 points are trimmed from a data set of 20 points (20 x 0.2): 2 from the top and 2 from the bottom of the set. |
| TTEST(data_1, data_2, mode, Type) | Returns the probability associated with a Student's t-Test. <strong>data_1</strong> is the dependent array or range of data for the first record. <strong>data_2</strong> is the dependent array or range of data for the second record. <strong>mode</strong> = 1 calculates the one-tailed distribution, <strong>mode</strong> = 2 the two-tailed distribution. <strong>Type</strong> of t-Test to perform: paired (1), equal variance (homoscedastic) (2), or unequal variance (heteroscedastic) (3). |
| VAR(number 1, number 2, ..., number 30) | Calculates the variance based on a sample. <strong>number 1, number 2, ..., number 30</strong> are numerical values or ranges representing a sample based on an entire population. Requires at least two numbers. |
| VAR.P(Number1, Number2, ..., Number30) | Calculates a variance based on the entire population. <strong>Number1, Number2, ..., Number30</strong> are numeric values or ranges representing an entire population. <strong>Number2, ..., Number30</strong> are optional. |</p>
<table>
<thead>
<tr>
<th>Syntax</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>VAR.S(Number1, Number2, ..., Number30)</td>
<td>Estimates the variance based on a sample. <strong>Number1, Number2, ..., Number30</strong> are numeric values or ranges representing a sample based on an entire population. <strong>Number2, ..., Number30</strong> are optional.</td>
</tr>
<tr>
<td>VARA(value 1, value 2, ..., value 30)</td>
<td>Estimates a variance based on a sample. <strong>value 1, value 2, ..., value 30</strong> are values or ranges representing a sample derived from an entire population. Text is evaluated as 0. Logical TRUE is evaluated as 1 and FALSE as 0.</td>
</tr>
<tr>
<td>VARP(number 1, number 2, ..., number 30)</td>
<td>Calculates a variance based on the entire population. <strong>number 1, number 2, ..., number 30</strong> are numerical values or ranges representing an entire population.</td>
</tr>
<tr>
<td>VARPA(value 1, value 2, ..., value 30)</td>
<td>Calculates the variance based on the entire population. The value of text is 0. <strong>value 1, value 2, ..., value 30</strong> are values or ranges representing an entire population. Text is evaluated as 0. Logical TRUE is evaluated as 1 and FALSE as 0.</td>
</tr>
<tr>
<td>WEIBULL(Number, Alpha, beta, C)</td>
<td>Returns values of the Weibull distribution, from either the probability density function or the cumulative distribution function. <strong>Number</strong> is the value at which to calculate the Weibull distribution. <strong>Alpha</strong> is the shape parameter of the Weibull distribution. <strong>beta</strong> is the scale parameter of the Weibull distribution. <strong>C</strong> indicates the type of function: If <strong>C</strong>= 0 the probability density function is calculated, if <strong>C</strong>=1 the cumulative distribution function is calculated.</td>
</tr>
<tr>
<td>WEIBULL.DIST(Number, Alpha, Beta, C)</td>
<td>Returns values of the Weibull distribution, from either the probability density function or the cumulative distribution function. <strong>Number</strong> is the value at which to calculate the Weibull distribution. <strong>Alpha</strong> is the shape parameter of the Weibull distribution. <strong>Beta</strong> is the scale parameter of the Weibull distribution. <strong>C</strong> indicates the type of function. If <strong>C</strong> is set to 0, the probability density function is calculated. If <strong>C</strong> is set to 1, the cumulative distribution is calculated.</td>
</tr>
<tr>
<td>Z.TEST(Data, mu, Sigma)</td>
<td>Calculates the probability of observing a z-statistic greater than the one computed based on a sample. <strong>Data</strong> is the given sample, drawn from a normally distributed population. <strong>mu</strong> is the known mean of the population. <strong>Sigma</strong> is an optional argument which specifies the known standard deviation of the population. If omitted, the standard deviation of the given sample is used.</td>
</tr>
<tr>
<td>ZTEST(data, mu, sigma)</td>
<td>Calculates the probability of observing a z-statistic greater than the one computed based on a sample. <strong>data</strong> is the given sample, drawn from a normally distributed population. <strong>mu</strong> is the known mean of the population. <strong>sigma</strong> (optional) is the known standard deviation of the population. If omitted, the standard deviation of the given sample is used.</td>
</tr>
</tbody>
</table>
Use these functions for inserting, editing, and manipulating dates and times. LibreOffice handles and computes a date/time value as a number. When you assign the number format “Number” to a date or time value, it is displayed as a number. For example, 01/01/2000 12:00 PM, converts to 36526.5. This is just a matter of formatting; the actual value is always stored and manipulated as a number. To see the date or time displayed in a standard format, change the number format (date or time) accordingly.

To select the start date for the internal conversion from days to numbers used by Calc, go to Tools > Options > LibreOffice Calc > Calculate. The initial default start date is 1899-12-30.

Calc stores time internally as a decimal fraction in the range 0 to 1. A value of 0.0 represents 00:00:00 (midnight) and a value of 0.5 represents 12:00:00 (noon).

**Caution**

When entering dates as part of formulas, slashes or dashes used as date separators are interpreted as arithmetic operators. Therefore, dates entered in this format are not recognised as dates and result in erroneous calculations. To keep dates from being interpreted as parts of formulas use the DATE function, for example, DATE(1954;7;20), or place the date in quotation marks and use the ISO 8601 notation, for example, "1954-07-20". Avoid using locale dependent date formats such as "07/20/54"; the calculation may produce errors if the document is loaded under different locale settings. See also A note about dates on page 481.

**Note**

Unambiguous conversion is possible for ISO 8601 dates and times in their extended formats with separators. If a #VALUE! error occurs, then select Tools > Options > LibreOffice Calc > Formula > Custom > Details and deselect the Generate #VALUE! error option in the Conversion from text to number menu on the Detailed Calculation Settings dialog.

### Table 30: Data and time functions

<table>
<thead>
<tr>
<th>Syntax</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DATE(year, month, day)</td>
<td>Converts a date written as year, month, day to an internal date number and displays it in the cell’s formatting. <strong>year</strong> is an integer between 1583 and 9956, or 0 and 99. An option accessed through Tools &gt; Options &gt; LibreOffice &gt; General enables the user to control how Calc handles two-digit year values. <strong>month</strong> is an integer between 1 and 12. <strong>day</strong> is an integer between 1 and 31.</td>
</tr>
<tr>
<td>DATEDIF(Start date, End date, Interval)</td>
<td>Returns the difference in years, months, or days of two dates, <strong>Start date</strong> and <strong>End date</strong>. <strong>Interval</strong> is a string, accepted values are &quot;d&quot;, &quot;m&quot;, &quot;y&quot;, &quot;ym&quot;, &quot;md&quot; or &quot;yd&quot;. The meanings associated with these strings are described in the Help system. <strong>Start date</strong> and <strong>End date</strong> must be entered using double quotes.</td>
</tr>
<tr>
<td>DATEVALUE(text)</td>
<td>Returns the internal date number for text in double quotes using the current locale. <strong>text</strong> is a valid date expression.</td>
</tr>
<tr>
<td>Syntax</td>
<td>Description</td>
</tr>
<tr>
<td>------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>DAY(Number)</td>
<td>Returns the day, as an integer in the range 1 to 31, of the given date value. Number is the internal date number (a negative date/time value can be entered) or a date value entered in double quotes.</td>
</tr>
<tr>
<td>DAYS(Date_2, Date_1)</td>
<td>Calculates the difference, in days, between two date values. Date_1 is the start date. Date_2 is the end date. If Date_2 is an earlier date than Date_1, the result is a negative number. Dates can be entered as numbers or text.</td>
</tr>
<tr>
<td>DAYS360(Date_1, Date_2, Type)</td>
<td>Returns the difference between two dates based on the 360 day year used in interest calculations. If Date_2 is earlier than Date_1, the function will return a negative number. Type (optional) determines the type of difference calculation: the US NASD method (0) or the European method (otherwise). Dates can be entered as numbers or text.</td>
</tr>
<tr>
<td>DAYSINMONTH(Date)</td>
<td>Calculates the number of days in the month of the given Date. Date can be entered as a number or text.</td>
</tr>
<tr>
<td>DAYSINYEAR(Date)</td>
<td>Calculates the number of days in the year of the given Date. Date can be entered as a number or text.</td>
</tr>
<tr>
<td>EASTERSUNDAY(year)</td>
<td>Returns the date of Easter Sunday for the entered year. year is an integer between 1583 and 9956 or 0 and 99. An option accessed through Tools &gt; Options &gt; LibreOffice &gt; General enables the user to control how Calc handles two-digit year values.</td>
</tr>
<tr>
<td>EDATE(Start date, Months)</td>
<td>Returns the internal date number of the date a number of Months away from the given Start date. Only months are considered; days are not used for calculation. Months is the number of months before (negative) or after (positive) the start date. Start date may be entered as text or a number.</td>
</tr>
<tr>
<td>EOMONTH(Start date, Months)</td>
<td>Returns the internal date number of the last day of a month which falls Months away from the given Start date. Months is the number of months before (negative) or after (positive) the start date. Start date may be entered as text or a number.</td>
</tr>
<tr>
<td>HOUR(Number)</td>
<td>Returns the hour, as an integer in the range 0 to 23, for the given time value. Number is a time value and can be either text or an internal time number.</td>
</tr>
<tr>
<td>ISLEAPYEAR(Date)</td>
<td>Determines whether a given Date falls within a leap year. Returns either 1 (true) or 0 (false). Date must be a full date for text, a reference to a date value or an internal date number.</td>
</tr>
<tr>
<td>ISOWEEKNUM(Number)</td>
<td>Calculates the ISO 8601 week number of the year for the internal date number. ISO 8601 defines that Monday shall be the first day of the week. A week that lies partly in one year and partly in another is assigned a number in the year in which most of its days lie. That means that week number 1 of any year is the week that contains January 4th. Number is text or an internal date number.</td>
</tr>
<tr>
<td>Syntax</td>
<td>Description</td>
</tr>
<tr>
<td>--------------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>MINUTE(Number)</td>
<td>Returns the minute, as an integer in the range 0 to 59, for the given time value. <strong>Number</strong> is text or an internal date number.</td>
</tr>
<tr>
<td>MONTH(Number)</td>
<td>Returns the month, as an integer in the range 1 to 12, for the given date value. <strong>Number</strong> is text or an internal date number.</td>
</tr>
<tr>
<td>MONTHS(Start date, End date, Type)</td>
<td>Calculates the difference, in months, between two date values. <strong>Start date</strong> is the start date. <strong>End date</strong> is the end date. Type determines the type of calculation and is one of two possible values; 1 returns the difference between the calendar month values in the two dates, disregarding the day values; 0 returns the number of months that separate the dates taking into account the day values of the two dates. If <strong>End date</strong> is an earlier date than <strong>Start date</strong>, the result is a negative number.</td>
</tr>
<tr>
<td>NETWORKDAYS(Start date, End date, Holidays, Workdays)</td>
<td>Returns the number of workdays between <strong>Start date</strong> and <strong>End date</strong>. Holidays can be deducted. <strong>Start date</strong> is the date from which the calculation is carried out. <strong>End date</strong> is the date up to which the calculation is carried out. If the <strong>Start</strong> or <strong>End</strong> date is a workday, the day is included in the calculation. <strong>Holidays</strong> (optional) is a list of holidays / non-workdays. Enter a cell range in which the holidays are listed individually. <strong>Workdays</strong> is an optional list of number values defining the standard work week. This list starts with Sunday, workdays are indicated by zero and non-working days by non-zero value.</td>
</tr>
<tr>
<td>NETWORKDAYS.INTL(StartDate, EndDate, Weekend, Holidays)</td>
<td>Returns the number of workdays between a start date and an end date. There are options to define weekend days and holidays. The optional weekend argument (or a string) can be used to define the weekend days (or the non-working days in each week). Also, optionally, the user can define a holiday list. The weekend days and user-defined holidays are not counted as working days. <strong>StartDate</strong> is the date from when the calculation is carried out. If the start date is a workday, the day is included in the calculation. <strong>EndDate</strong> is the date up until when the calculation is carried out. If the end date is a workday, the day is included in the calculation. <strong>Weekend</strong> is an optional argument – a number or a string used to specify the days of the week that are weekend days and are not considered working days. <strong>Weekend</strong> number values are in the range 1 … 17, with the meaning of each code defined in the Help system. The <strong>Weekend</strong> string provides another way to define the weekly non-working days. It must have seven characters – zeroes (0) for working day and ones (1) for non-working day. Each character represents a day of the week, starting with Monday. Only 1 and 0 are valid. “1111111” is an invalid string and should not be used. For example, the weekend string “0000011” defines Saturday and Sunday as non-working days. <strong>Holidays</strong> is an optional list of dates that must be counted as non-working days. The list can be given in a cell range.</td>
</tr>
<tr>
<td>Syntax</td>
<td>Description</td>
</tr>
<tr>
<td>--------</td>
<td>-------------</td>
</tr>
<tr>
<td>NETWORKDAYS_EXCEL2003 (Start date, End date, Holidays)</td>
<td>Returns the number of workdays between a start date and an end date. Holidays can be deducted. <strong>Start date</strong> is the date from which the calculation is carried out. <strong>End date</strong> is the date up to which the calculation is carried out. If the start or end date is a workday, the day is included in the calculation. <strong>Holidays</strong> is an optional list of holidays. Enter a cell range in which the holidays are listed individually. Saturdays and Sundays are considered non-workdays.</td>
</tr>
<tr>
<td>NOW()</td>
<td>Returns the computer system date and time. The value is updated when your document recalculates or each time a cell value is modified.</td>
</tr>
<tr>
<td>SECOND( Number )</td>
<td>Returns the second, as an integer in the range 0 to 59, for the given time value. <strong>Number</strong> is text or an internal date number.</td>
</tr>
<tr>
<td>TIME( hour, minute, second )</td>
<td>Returns the time value from values for hours, minutes and seconds. This function can be used to convert a time based on these three elements to a correctly formatted time string. <strong>hour</strong>, <strong>minute</strong> and <strong>second</strong> must all be integers.</td>
</tr>
<tr>
<td>TIMEVALUE( text )</td>
<td>Returns the internal time number value from <strong>text</strong> enclosed by quotes in a time entry format.</td>
</tr>
<tr>
<td>TODAY()</td>
<td>Returns the current computer system date. The value is updated when your document recalculates or each time a cell value is modified.</td>
</tr>
<tr>
<td>WEEKDAY( Number, Type )</td>
<td>Returns the day of the week for the given <strong>Number</strong> (date value). The day is returned as an integer based on the <strong>Type</strong>, which determines the type of calculation. The possible values of <strong>Type</strong> and their associated meanings are listed in the Help system.</td>
</tr>
<tr>
<td>WEEKNUM( Number, mode )</td>
<td>Calculates the number of the calendar week of the year for the given internal date <strong>Number</strong>. <strong>mode</strong> sets the start of the week and the calculation type. The possible values of <strong>mode</strong> and their associated meanings are listed in the Help system.</td>
</tr>
<tr>
<td>WEEKNUM_EXCEL2003(Date, Return type)</td>
<td>Calculates the calendar week of the year for a <strong>Date</strong>. <strong>Date</strong> is the date within the calendar week. <strong>Return type</strong> sets the start of the week and the calculation type: 1 = Sunday, 2 = Monday.</td>
</tr>
<tr>
<td>WEEKS(Start date, End date, Type)</td>
<td>Calculates the difference in weeks between two dates, <strong>Start date</strong> and <strong>End date</strong>. <strong>Type</strong> is one of two possible values, 0 (number of whole weeks in the interval) or 1 (returns the number of different weeks in which the two dates appear).</td>
</tr>
<tr>
<td>WEEKSINYEAR(Date)</td>
<td>Calculates the number of weeks in a year for a given <strong>Date</strong>. A week that spans two years is added to the year in which most days of that week occur (so any week containing four or more days in the calendar year of <strong>Date</strong> is counted).</td>
</tr>
<tr>
<td><strong>Syntax</strong></td>
<td><strong>Description</strong></td>
</tr>
<tr>
<td>-------------------------------</td>
<td>------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>WORKDAY(Start date, Days, Holidays)</td>
<td>Returns an internal date number which is a specified number of work days (Days) before or after an input date, <strong>Start date</strong>. <strong>Holidays</strong> (optional) is a list of holidays. Enter a cell range in which the holidays are listed individually.</td>
</tr>
</tbody>
</table>
| WORKDAY.INTL(Start Date, Days, Weekend, Holidays) | Returns an internal date number that can be formatted as a date. The user can see the date of a day that is a certain number of workdays away from the start date (before or after).  
**Start Date** is the date from when the calculation is carried out. If the start date is a workday, the day is included in the calculation. **Days** is the number of workdays. Enter a positive value for a result after the **Start date**, a negative value for a result before the **Start date**.  
**Weekend** is an optional argument – a number or a string used to specify the days of the week that are weekend days and are not considered working days. **Weekend** is a weekend number or string that specifies when weekends occur. **Weekend** number values are in the range 1 ... 17, with the meaning of each code defined in the Help system. The **Weekend** string provides another way to define the weekly non-working days. It must have seven characters – zeroes (0) for working day and ones (1) for non-working day. Each character represents a day of the week, starting with Monday. Only 1 and 0 are valid. “1111111” is an invalid string and should not be used. For example, the weekend string “0000011” defines Saturday and Sunday as non-working days.  
**Holidays** is an optional list of dates that must be counted as non-working days. The list can be given in a cell range. |
| YEAR(Number)                  | Returns the calendar year as an integer according to the internal calculation rules. **Number** is the date value in internal date number format or as a text date, for which the year is to be returned. |
| YEARFRAC(Start date, End date, Basis) | Extracts the number of years (including fractional part) between two date values, **Start date** and **End date**. **Basis** is a value chosen from a list of options and indicates how the year is to be calculated (see Help system for more details). |
| YEARS(Start date, End date, Type) | Calculates the difference in years between the **Start date** and the **End date**. **Type** calculates the type of difference. Possible values are 0 (interval) and 1 (in calendar years). |

**Logical functions**

Use the logical functions to test values and produce results based on the result of the test. These functions are conditional and provide the ability to write longer formulas based on input or output.
### Table 31: Logical functions

<table>
<thead>
<tr>
<th>Syntax</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>AND(Logical value 1, Logical value 2, ..., Logical value 30)</td>
<td>Returns TRUE if all arguments are TRUE and, if any element is FALSE, returns FALSE. <strong>Logical value 1, Logical value 2, ..., Logical value 30</strong> are conditions to be checked. All conditions can be either TRUE or FALSE. If a range is entered as an argument, the function uses all values in the range. The result is TRUE if the logical value in all cells within the cell range is TRUE.</td>
</tr>
<tr>
<td>FALSE()</td>
<td>Returns the logical value FALSE.</td>
</tr>
<tr>
<td>IF(Test, Then_value, Otherwise_value)</td>
<td>Specifies a logical test to be performed. <strong>Test</strong> is any value or expression that can be TRUE or FALSE. <strong>Then_value</strong> (optional) is the value that is returned if the logical test is TRUE. <strong>Otherwise_value</strong> (optional) is the value that is returned if the logical test is FALSE.</td>
</tr>
</tbody>
</table>
| IFS(expression1, result1, expression2, result2, ...) | IFS is a multiple IF-function. **expression1, expression2, ...** are any boolean values or expressions that can be TRUE or FALSE. **result1, result2, ...** are the values that are returned if the logical test is TRUE. IFS(expression1, result1, expression2, result2, expression3, result3) is executed as

\[
\text{IF expression1 is TRUE} \\
\text{THEN result1} \\
\text{ELSE IF expression2 is TRUE} \\
\text{THEN result2} \\
\text{ELSE IF expression3 is TRUE} \\
\text{THEN result3}
\]

To get a default result should no expression be TRUE, add a last expression that is always TRUE, like TRUE or 1=1 followed by the default result. If there is a result missing for an expression or if no expression is TRUE, a #N/A error is returned. If expression is neither TRUE nor FALSE, a #VALUE error is returned. |
| NOT(Logical value) | Reverses the logical value. **Logical value** is the TRUE or FALSE value to be reversed (complemented). |
| OR(Logical value 1, Logical value 2, ..., Logical value 30) | Returns TRUE if at least one argument is TRUE or returns FALSE if all the arguments have the logical value FALSE. **Logical value 1, Logical value 2, ..., Logical value 30** are conditions to be checked. All conditions can be either TRUE or FALSE. If a range is entered as an argument, the function uses all values of the range. |
### Syntax

<table>
<thead>
<tr>
<th>Syntax</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>SWITCH(Expression, Value1, Result1, Value2, Result2, …, Default Result)</td>
<td>Compares an expression with a number of values and returns the result corresponding to the first value that equals the expression. If there is no match and a default result is given, that will be returned. <strong>Expression</strong> is a text, numeric, logical or date input or reference to a cell. <strong>Value1, Value2, …</strong> are any values or references to cells. Each value must have a result given. <strong>Result1, Result2, …</strong> are any values or references to cells. <strong>Value2, …</strong> and <strong>Result2, …</strong> are optional arguments. <strong>Default Result</strong> is optional and is any value or reference to a cell that is returned when there is no match. If no value equals <strong>Expression</strong> and no default result is given, a #N/A error is returned.</td>
</tr>
<tr>
<td>TRUE()</td>
<td>Returns the logical value TRUE.</td>
</tr>
<tr>
<td>XOR(Logical value 1, Logical value 2, …, Logical value 30)</td>
<td>Computes the logical XOR of the arguments. If an even number of arguments are TRUE it returns FALSE, if an odd number of arguments are TRUE it returns TRUE.</td>
</tr>
</tbody>
</table>

### Information functions

These functions provide information (or feedback) regarding the results of a test for a specific condition, or a test for the type of data or content a cell contains.

#### Table 32: Information functions

<table>
<thead>
<tr>
<th>Syntax</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>CELL(info_type, Reference)</td>
<td>Returns information about a cell such as its address, formatting or contents, depending on the value of the <strong>info_type</strong> argument. <strong>info_type</strong> is a text string that specifies the type of information to be returned and comes from a list of available options which are listed in the Help files. <strong>info_type</strong> is not case sensitive, but it must be enclosed within quotes. <strong>Reference</strong> (optional) is the address of the cell to be examined. If <strong>Reference</strong> is a range, the cell reference moves to the top left of the range. If <strong>Reference</strong> is missing, Calc uses the position of the cell in which this formula is located.</td>
</tr>
<tr>
<td>CURRENT()</td>
<td>Returns the result to date of evaluating the formula of which it is a part (in other words the result as far as that evaluation has got). Its main use is together with the STYLE() function to apply selected styles to a cell depending on the cell content.</td>
</tr>
<tr>
<td>FORMULA(Reference)</td>
<td>Returns the formula of a formula cell as a text string. <strong>Reference</strong> is a reference to a cell containing a formula. An invalid reference or a reference to a cell with no formula results in the error value #N/A.</td>
</tr>
<tr>
<td>INFO(Text)</td>
<td>Returns information about the current working environment. <strong>Text</strong> is a string constant entered in double quotes taken from a list of available options which are listed in the Help files. These strings are case insensitive.</td>
</tr>
<tr>
<td>Syntax</td>
<td>Description</td>
</tr>
<tr>
<td>----------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>ISBLANK(value)</td>
<td>Returns TRUE if the reference to a cell is blank, FALSE otherwise. This function is used to determine if the cell is empty. A cell containing a formula is not empty. If an error occurs, the function returns a logical or numerical value. <strong>value</strong> is the content to be tested.</td>
</tr>
<tr>
<td>ISERR(value)</td>
<td>Returns TRUE if the value refers to any error value except #N/A, FALSE otherwise. If an error occurs, the function returns a logical or numerical value. <strong>value</strong> is any value or expression which is tested to determine whether an error value not equal to #N/A is present.</td>
</tr>
<tr>
<td>ISERROR(value)</td>
<td>Returns TRUE if the value refers to any error value (including #N/A), FALSE otherwise. If an error occurs, the function returns a logical or numerical value. <strong>value</strong> is, or refers to, the value to be tested to determine whether it is an error value.</td>
</tr>
<tr>
<td>ISEVEN(value)</td>
<td>Returns TRUE if the given <strong>value</strong> is even, or FALSE if the <strong>value</strong> is odd. If the <strong>value</strong> is not an integer, the function evaluates only the integer part of the value.</td>
</tr>
<tr>
<td>ISEVEN_ADD(Number)</td>
<td>Tests for even numbers. Returns 1 if <strong>Number</strong> divided by 2 gives a whole number, 0 otherwise.</td>
</tr>
<tr>
<td>ISFORMULA(reference)</td>
<td>Returns TRUE if a cell is a formula cell. If an error occurs, the function returns a logical or numerical value. <strong>reference</strong> indicates the reference to a cell in which the test will be performed.</td>
</tr>
<tr>
<td>ISLOGICAL(value)</td>
<td>Returns TRUE if the cell contains a logical value. The function is used in order to check for both TRUE and FALSE values in certain cells. If an error occurs, the function returns FALSE. <strong>value</strong> is the cell reference to be tested for logical number format.</td>
</tr>
<tr>
<td>ISNA(value)</td>
<td>Returns TRUE if <strong>value</strong> contains the #N/A error value, FALSE otherwise. If an error occurs, the function returns FALSE. <strong>value</strong> is the cell, value or expression to be tested.</td>
</tr>
<tr>
<td>ISNONTEXT(value)</td>
<td>Return TRUE if the value is non-text, else returns FALSE. If an error occurs, the function returns TRUE. <strong>value</strong> is any value or expression where a test is performed to determine whether it is a text string, or numbers, or a Boolean value. Empty cells are considered non-text and will return TRUE.</td>
</tr>
<tr>
<td>ISNUMBER(value)</td>
<td>Returns TRUE if the cell content is, or refers to, a number. If an error occurs, the function returns a logical or numerical value. <strong>value</strong> is any expression to be tested to determine whether it is a number or text. TRUE and FALSE are evaluated as numbers.</td>
</tr>
<tr>
<td>ISODD(value)</td>
<td>Returns TRUE if <strong>value</strong> evaluates as an odd integer, else FALSE. <strong>value</strong> is truncated to an integer before evaluation. TRUE (1) and FALSE (0) are evaluated as numbers. Text returns an error. Zero is evaluated FALSE.</td>
</tr>
<tr>
<td><strong>Syntax</strong></td>
<td><strong>Description</strong></td>
</tr>
<tr>
<td>--------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>ISODD_ADD(Number)</td>
<td>Returns 1 if <em>Number</em> does not return a whole number when divided by 2, else 0. <em>Number</em> is the number to be tested but is truncated to an integer before evaluation. Does not return logical type TRUE/FALSE like ISODD; it returns a number.</td>
</tr>
<tr>
<td>ISREF(value)</td>
<td>Returns TRUE if <em>value</em> is of type reference (including a reference list), else returns FALSE. If an error occurs, the function returns a logical or numerical value. It does not evaluate the content of the reference.</td>
</tr>
<tr>
<td>ISTEKT(value)</td>
<td>Returns TRUE if <em>value</em> is, or refers to, a text string, else FALSE. If an error occurs, the function returns FALSE. <em>value</em> is a value, number, Boolean value, or error value to be tested.</td>
</tr>
<tr>
<td>N(value)</td>
<td>Returns the numeric value of the given argument. Returns 0 if the argument is text or FALSE. If an error occurs the function returns the error value. <em>value</em> is the argument to be converted into a number. N() returns the numeric value if it can. It returns the logical values TRUE and FALSE as 1 and 0 respectively. It returns text as 0.</td>
</tr>
<tr>
<td>NA()</td>
<td>Returns the error value #N/A.</td>
</tr>
<tr>
<td>TYPE(value)</td>
<td>Evaluates <em>value</em> and returns a number indicating its type. If an error occurs, the function returns a logical or numeric value. The numerical value from which the data type is determined is; 1 = number, 2 = text, 4 = Boolean value, 8 = formula, 16 = error value, 64 = array.</td>
</tr>
</tbody>
</table>

**Database functions**

This section deals with functions used with data organized as one row of data for one record. The *Database* category in Calc should not be confused with the Base database component in LibreOffice. A Calc database is simply a range of cells that comprises a block of related data where each row contains a separate record. There is no connection between a database in LibreOffice Base and the *Database* category in LibreOffice Calc.

The database functions use the following common arguments:

- **Database** is a range of cells which define the database.
- **Database field** specifies the column where the function operates after the search criteria is applied and the data rows are selected. It is not related to the search criteria itself. For the **Database field** argument you can enter a reference to a header cell or a number to specify the column within the *Database* area, starting with 1. To reference a column by means of the literal column header name, place quotation marks around the header name.
- **Search criteria** is the cell range containing search criteria. If you write several criteria in one row they are connected by AND. If you write the criteria in different rows they are connected by OR. Empty cells in the search criteria range will be ignored.

*Database functions* | 513
Note

All of the search criteria arguments for the database functions support regular expressions. For example, "all.*" can be entered to find the first location of "all" followed by any characters. To search for text that is also a regular expression, precede every character with a \ character. You can switch the automatic evaluation of regular expressions on and off in Tools > Options > LibreOffice Calc > Calculate.

Table 33: Database functions

<table>
<thead>
<tr>
<th>Syntax</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DAVVERAGE(Database, Database field, Search criteria)</td>
<td>Returns the average of the values in a given database field from the records (rows) in a database that match the search criteria. Database field cannot be 0 or empty.</td>
</tr>
<tr>
<td>DCOUNT(Database, Database field, Search criteria)</td>
<td>Counts the number of records (rows) in a database that match the search criteria and contain numerical values. Database field can be empty or 0.</td>
</tr>
<tr>
<td>DCOUNTA(Database, Database field, Search criteria)</td>
<td>Counts the number of rows (records) in a database that match the specified search criteria and contain numeric or alphanumeric values. Database field can be empty or 0.</td>
</tr>
<tr>
<td>DGET(Database, Database field, Search criteria)</td>
<td>Returns the field value from a record in a database, which matches the search criteria. The search criteria must return a single value. In case of an error, the function returns either #VALUE! for no row found, or Err502 for more than one cell found.</td>
</tr>
<tr>
<td>DMAX(Database, Database field, Search criteria)</td>
<td>Returns the maximum value of a field in a database that matches the specified Search criteria.</td>
</tr>
<tr>
<td>DMIN(Database, Database field, Search criteria)</td>
<td>Returns the minimum value of a field in a database that matches the specified Search criteria.</td>
</tr>
<tr>
<td>DPRODUCT(Database, Database field, Search criteria)</td>
<td>Multiplies all cells of a data range where the cell content matches the Search criteria.</td>
</tr>
<tr>
<td>DSTDEV(Database, Database field, Search criteria)</td>
<td>Finds the sample standard deviation in a given field from the records (rows) in a database that match a search criteria.</td>
</tr>
<tr>
<td>DSTDEVP(Database, Database field, Search criteria)</td>
<td>Finds the population standard deviation in a given field from the records (rows) in a database that match a search criteria.</td>
</tr>
<tr>
<td>DSUM(Database, Database field, Search criteria)</td>
<td>Finds the sum of values in a given field from the records (rows) in a database that match a search criteria.</td>
</tr>
<tr>
<td>DVAR(Database, Database field, Search criteria)</td>
<td>Finds the sample variance in a given field from the records (rows) in a database that match a search criteria.</td>
</tr>
<tr>
<td>DVARP(Database, Database field, Search criteria)</td>
<td>Finds the population variance in a given field from the records (rows) in a database that match a search criteria.</td>
</tr>
</tbody>
</table>

Array functions

When using the Function Wizard for array functions, those returning an array result have the Array check-box automatically selected.
Table 34: Array functions

<table>
<thead>
<tr>
<th>Syntax</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>FREQUENCY(data, classes)</td>
<td>Categorizes values into intervals and counts the number of values in each interval. Returns the results as a vertical array containing one more result than the number of classes. data is the data that should be categorized and counted according to the given intervals. classes is the array containing the upper boundaries determining the intervals the values in data should be grouped by.</td>
</tr>
<tr>
<td>GROWTH(data_Y, data_X, new_data_X, Function_type)</td>
<td>Calculates predicted exponential growth by using existing data. data_Y is the Y data array. data_X (optional) is the X data array. new_data_X (optional) is the X data array, for which the values are to be calculated. If new_data_X is omitted it is assumed to be the same size as data_X. If both arrays are omitted, they are assumed to be the array {1,2,3,...} that is the same size as the Y data array. Function_type is optional. If Function_type = 0 then (y = m^x) functions are calculated, otherwise functions of the form (y = b \cdot m^x).</td>
</tr>
<tr>
<td>LINEST(data_Y, data_X, Linear_type, stats)</td>
<td>Returns the parameters of the (simple or multiple) linear regression equation for the given data and, optionally, statistics on this regression. The equation for the line is (y = mx + c), or (y = m1x1 + m2x2 + ... + c) for multiple ranges of x-values, where the dependent y-values are a function of the independent x-values. The m-values are coefficients corresponding to each x-value, and c is a constant value. data_Y is a single row or column range specifying the y coordinates in a set of data points. data_X (optional) is a corresponding single row or column range specifying the x coordinates. If data_X is omitted it defaults to {1,2,3,..., n}. If there is more than one set of variables data_X may be a range with corresponding multiple rows or columns. Linear_type (optional): if FALSE the straight line found is forced to pass through the origin (the constant c is zero; (y = mx)). If omitted, Linear_type defaults to TRUE (the line is not forced through the origin). stats (optional): if stats = TRUE the entire table is returned, otherwise just the regression coefficient. See the Help files for full information.</td>
</tr>
<tr>
<td>LOGEST(data_Y, data_X, Function_type, stats)</td>
<td>Calculates the adjustment of the entered data as an exponential regression curve (y=b \cdot m^x). data_Y is the Y data array. data_X (optional) is the X data array. Function_type (optional): If Function_type = 0, functions in the form (y = m^x) are calculated. Otherwise, (y = b \cdot m^x) functions are calculated. stats (optional): If stats = TRUE the entire table is returned, otherwise just the regression coefficient. See the Help files for full information.</td>
</tr>
<tr>
<td>MDETERM(array)</td>
<td>Returns the determinant of a square array. This function returns a value in the current cell; it is not necessary to define a range for the results. array is an array for which the determinant is required. The Array check-box is not automatically selected in this case.</td>
</tr>
<tr>
<td>MINVERSE(array)</td>
<td>Returns the inverse array. array is a square array that is to be inverted.</td>
</tr>
<tr>
<td>MMULT(array1, array2)</td>
<td>Calculates the array product of two arrays. array1 is the first array used in the array product. array2 is the second array with the same number of rows as the first array has columns.</td>
</tr>
<tr>
<td>Syntax</td>
<td>Description</td>
</tr>
<tr>
<td>------------------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>MUNIT(Dimensions)</td>
<td>Returns the unitary square array of a certain size. The unitary array is a square array where the main diagonal (top left to bottom right) elements are set to 1 and all other array elements are set to 0. <strong>Dimensions</strong> refers to the column and row size of the array.</td>
</tr>
<tr>
<td>SUMPRODUCT(Array 1, Array 2, ..., Array 30)</td>
<td>Multiplies corresponding elements in the given arrays, and returns the sum of those products. <strong>Array 1, Array 2, ..., Array 30</strong> are arrays whose corresponding elements are to be multiplied. At least one array must be part of the argument list. If only one array is given, the array elements are summed. Arrays must have the same size and shape. Non numeric elements are treated as 0. The <strong>Array</strong> check-box is not automatically selected in this case.</td>
</tr>
<tr>
<td>SUMX2MY2(array_x, array_y)</td>
<td>Returns the sum of the difference of the squares of corresponding values in two arrays. <strong>array_x</strong> is the first array whose elements are to be squared and added. <strong>array_y</strong> is the second array whose elements are to be squared and subtracted. Arrays must have the same size and shape. The <strong>Array</strong> check-box is not automatically selected in this case.</td>
</tr>
<tr>
<td>SUMX2PY2(array_x, array_y)</td>
<td>Returns the sum of the sum of the squares of the individual values in each array. <strong>array_x</strong> is the first array whose arguments are to be squared and summed. <strong>array_y</strong> is the second array, whose arguments are to be squared and summed and then summed with the result from the first array. Arrays must have the same size and shape. The <strong>Array</strong> check-box is not automatically selected in this case.</td>
</tr>
<tr>
<td>SUMXMY2(array_x, array_y)</td>
<td>Adds the squares of the difference between corresponding values in two arrays. <strong>array_x</strong> is the first array from whose elements the corresponding elements of <strong>array_y</strong> are to be subtracted. The results of each subtraction are summed and the results squared. Arrays must have the same size and shape. The <strong>Array</strong> check-box is not automatically selected in this case.</td>
</tr>
<tr>
<td>TRANSPOSE(array)</td>
<td>Transposes the rows and columns of an array. <strong>array</strong> is the array in the spreadsheet that is to be transposed.</td>
</tr>
<tr>
<td>TREND(data_Y, data_X, new_data_X, Linear_type)</td>
<td>Returns values along a linear trend. <strong>data_Y</strong> is the Y data array. <strong>data_X</strong> (optional) is the X data array. <strong>new_data_X</strong> (optional) is the array of the X data, which are used for recalculating values. If <strong>new_data_X</strong> is omitted it is assumed to be the same size as <strong>data_X</strong>. If both arrays are omitted, they are assumed to be the array {1,2,3,...} that is the same size as the Y data array. <strong>Linear_type</strong> is optional. If <strong>Linear_type</strong> = 0, y = mx functions are calculated. Otherwise functions of the form y = mx + c are calculated.</td>
</tr>
</tbody>
</table>

**Spreadsheet functions**

Use spreadsheet functions to search and address cell ranges and provide feedback regarding the contents of a cell or range of cells. You can use functions such as HYPERLINK() and DDE() to connect to other documents or data sources.
### Table 35: Spreadsheet functions

<table>
<thead>
<tr>
<th>Syntax</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ADDRESS(row, column, ABS, A1, sheet)</td>
<td>Returns a cell address (reference) as a text string, according to the specified row and column numbers. <strong>row</strong> is the row number for the cell reference. <strong>column</strong> is the column number for the cell reference (the number, not the letter). <strong>ABS</strong> (optional) determines the type of reference and is a value between 1 and 4. See the Help files for details of the available options. Optional <strong>A1</strong> if set to 0 uses the R1C1 notation, else it uses the A1 notation. Optional <strong>sheet</strong> is the name of the sheet entered in double quotes. If using R1C1 notation, ADDRESS returns address strings using the exclamation mark ‘!’ as the sheet name separator. The function still uses the dot ‘.’ sheet name separator with A1 notation. When opening documents from ODF 1.0/1.1 format, the ADDRESS functions that show a sheet name as the fourth argument will shift that sheet name to become the fifth argument. A new fourth argument with the value 1 will be inserted. When saving a document in ODF 1.0/1.1 format, if the ADDRESS function has a fourth argument, that argument will be removed. A spreadsheet should not be saved in the old ODF 1.0/1.1 format if <strong>A1</strong> is set to 0.</td>
</tr>
<tr>
<td>AREAS(reference)</td>
<td>Returns the number of individual ranges that belong to a multiple range. A range can consist of contiguous cells or a single cell. The function expects a single argument. If you state multiple ranges, you must enclose them within additional parentheses (round brackets). Multiple ranges can be entered using the semicolon (;) as divider, but this gets automatically converted to the tilde (~) operator. The tilde is used to join ranges. <strong>reference</strong> is the reference to a cell or cell range.</td>
</tr>
<tr>
<td>CHOOSE(Index, value1, ..., value30)</td>
<td>Returns a value from a list of up to 30 values. <strong>Index</strong> is a reference or number between 1 and 30 indicating which value is to be taken from the list. <strong>value1, ..., value30</strong> is the list of values entered as a reference to a cell or as individual values. Only the selected value from the list is evaluated, any other formulas in the list are not checked for validity.</td>
</tr>
<tr>
<td>COLUMN(reference)</td>
<td>Returns the column number of a <strong>reference</strong> (optional). If the reference is a single cell, the column number of the cell is returned; if the argument is a cell range containing more than one column, the corresponding column numbers are returned in a single-row array, if the formula is entered as an array formula. If the cell range is not entered as an array formula, only the column number of the first cell within the range is determined. If no reference is entered, the column number of the cell in which the formula is entered is returned as Calc automatically sets the reference to the current cell.</td>
</tr>
<tr>
<td><strong>Syntax</strong></td>
<td><strong>Description</strong></td>
</tr>
<tr>
<td>--------------------</td>
<td>--------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>COLUMNS(array)</td>
<td>Returns the number of columns in the given reference. <strong>array</strong> is the reference to a cell range whose total number of columns is to be found. The argument can also be a single cell.</td>
</tr>
<tr>
<td>DDE(server, File, range, mode)</td>
<td>Returns the result of a Dynamic Data Exchange (DDE) request. If the contents of the linked range or section changes, the returned value will also change. The spreadsheet can be reloaded, or <strong>Edit &gt; Links</strong> selected, to see the updated links. Cross-platform links, for example from a LibreOffice installation running on a Windows machine to a document created on a Linux machine, are not supported. <strong>server</strong> is the name of a server application. LibreOffice applications have the server name “soffice”. <strong>File</strong> is the complete file name, including path. <strong>range</strong> is the area containing the data to be evaluated. <strong>mode</strong> is an optional argument that controls the method by which the DDE server converts its data into numbers. See the Help files for more information on the available options.</td>
</tr>
<tr>
<td>ERROR.TYPE(Error Value)</td>
<td>Returns a number representing a specific error type, or the error value #N/A, if there is no error. <strong>Error Value</strong> is the error value or a reference to a cell, whose value needs to be processed. For each possible <strong>Error Value</strong>, the function returns a value in the range 1 to 7 or #N/A. The meanings of these numeric values are given in the Help system.</td>
</tr>
<tr>
<td>ERRORTYPE(reference)</td>
<td>Evaluates the cell value at <strong>reference</strong> location. If the cell contains an error then a logical or numerical value is returned. The numerical value is the error number (see Help for full listing of possible error numbers).</td>
</tr>
</tbody>
</table>
### Syntax

**GETPIVOTDATA(Data Field, Pivot Table, Field Name1/Item1, Field Name2/Item2, ..., Field Name30/Item30)**

The GETPIVOTDATA function returns a calculated result value from a pivot table. The value is addressed using field and item names, so it remains valid if the layout of the pivot table changes.

For the first syntax (which is used in the Function Wizard); **Data Field** is a string that selects one of the pivot table’s data fields. The string can be the name of the source column, or the data field name as shown in the table (like “Sum – Sales”). **Pivot Table** is a reference to a cell or cell range that is positioned within a pivot table or contains a pivot table. If the cell range contains several pivot tables, the table that was created last is used. If no **Field NameX/ItemX** pairs are given, the grand total is returned. Otherwise, each pair adds a constraint that the result must satisfy. **Field NameX** is the name of a field from the pivot table. **ItemX** is the name of an item from that field. A maximum of 30 **Field NameX/ItemX** pairs can be entered.

The second syntax is assumed if exactly two arguments are given, **Pivot Table** has the same meaning as in the first syntax. **Constraints** is a space-separated list. Entries can be quoted (single quotes). The whole string must be enclosed in quotes (double quotes), unless you reference the string from another cell.

See the Help system for more detailed information.

**GETPIVOTDATA(Pivot Table, Constraints)**

Detected missing content or formatting issues.

<table>
<thead>
<tr>
<th>Syntax</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>GETPIVOTDATA(Data Field, Pivot Table, Field Name1/Item1, Field Name2/Item2, ..., Field Name30/Item30)</strong></td>
<td>The GETPIVOTDATA function returns a calculated result value from a pivot table. The value is addressed using field and item names, so it remains valid if the layout of the pivot table changes. For the first syntax (which is used in the Function Wizard); <strong>Data Field</strong> is a string that selects one of the pivot table’s data fields. The string can be the name of the source column, or the data field name as shown in the table (like “Sum – Sales”). <strong>Pivot Table</strong> is a reference to a cell or cell range that is positioned within a pivot table or contains a pivot table. If the cell range contains several pivot tables, the table that was created last is used. If no <strong>Field NameX/ItemX</strong> pairs are given, the grand total is returned. Otherwise, each pair adds a constraint that the result must satisfy. <strong>Field NameX</strong> is the name of a field from the pivot table. <strong>ItemX</strong> is the name of an item from that field. A maximum of 30 <strong>Field NameX/ItemX</strong> pairs can be entered. The second syntax is assumed if exactly two arguments are given, <strong>Pivot Table</strong> has the same meaning as in the first syntax. <strong>Constraints</strong> is a space-separated list. Entries can be quoted (single quotes). The whole string must be enclosed in quotes (double quotes), unless you reference the string from another cell. See the Help system for more detailed information.</td>
</tr>
</tbody>
</table>

**HLOOKUP(search_criteria, array, Index, sorted)**

Searches for a value given in **search_criteria** in the first row of the given **array**, and returns the value from the row given in **Index** for the column in which the search item was found. If **sorted** is 0 or FALSE the first row of array need not be sorted, else the first row of **array** must be sorted in ascending order. Searching is faster for sorted columns.

**HYPERLINK(URL, CellText)**

When you press Ctrl+click over the text in a cell that contains the HYPERLINK function (the cursor becomes a pointing hand when correctly positioned), the hyperlink opens. **URL** specifies the link target. The optional **CellText** argument is the text displayed in the cell. If either argument is a text string, it must be entered in double quotes. If the **CellText** argument is not specified, the **URL** text is displayed.
<table>
<thead>
<tr>
<th>Syntax</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>INDEX(reference, row, column, range)</td>
<td>Given a reference, returns the value at the given row and column intersection (starting numbering at 1, relative to the top left of the reference) of the given area range. If range is not given, it is assumed to be 1 (the first and possibly only area). If row is omitted, or empty, or 0, an entire column of the given area range in reference is returned. If column is omitted, or empty, or 0, an entire row of the given area range in reference is returned. If both, row and column, are omitted, or empty, or 0, the entire given area range is returned. If reference is a one-dimensional column vector, column is optional or can be omitted. If reference is a one-dimensional row vector, row is optional, which effectively makes row act as the column offset into the vector, or can be omitted. If row or column have a value greater than the dimension of the corresponding given area range, an error is returned. The Array checkbox must be selected in this function unless row and column are both included.</td>
</tr>
<tr>
<td>INDIRECT(ref, A1)</td>
<td>Returns a reference given a string representation of a reference as ref. This function can also be used to return the area of a corresponding string. ref is a reference to a cell or an area (in text form) from which to return the contents. Unless ref refers to a cell containing a reference, ref must be entered in double quotes. A1 (optional) - if set to 0, the R1C1 notation is used. Otherwise, the A1 notation is used. If you open an Excel spreadsheet that uses indirect addresses calculated from string functions, the sheet addresses will not be translated automatically. For example, the Excel address in INDIRECT(&quot;[filename]sheetname!&quot;&amp;B1) is not converted into the Calc address in INDIRECT(&quot;filename#sheetname.&quot;&amp;B1). The INDIRECT function is saved without conversion to ODF 1.0/1.1 format. If the second argument was present, an older version of Calc will return an error for that function.</td>
</tr>
<tr>
<td>Syntax</td>
<td>Description</td>
</tr>
<tr>
<td>--------</td>
<td>-------------</td>
</tr>
<tr>
<td>LOOKUP(\text{Search criterion}, \text{Search vector}, \text{result}_\text{vector})</td>
<td>Returns the contents of a cell either from a one-row or one-column range. Optionally, the assigned value (of the same index) is returned in a different column and row. As opposed to VLOOKUP and HLOOKUP, search and result vectors may be at different positions; they do not have to be adjacent. Additionally, the search vector for the LOOKUP must be sorted ascending, otherwise the search will not return any usable results. \textbf{Search criterion} is the value to be searched for; entered either directly or as a reference. \textbf{Search vector} is the single-row or single-column area to be searched. \textbf{result}_\text{vector} is another single-row or single-column range from which the result of the function is taken. The result is the cell of the result vector with the same index as the instance found in the search vector.</td>
</tr>
<tr>
<td>MATCH(\text{Search criterion}, \text{lookup}_\text{array}, \text{Type})</td>
<td>Returns the relative position of an item in an array that matches a specified value. The function returns the position of the value found in \textbf{lookup}<em>\text{array} as a number. \textbf{Search criterion} is the value which is to be searched for. \textbf{lookup}</em>\text{array} is the vector to be searched. A lookup array can be a single row or column, or part of a single row or column. \textbf{Type} may take the values 1, 0, –1 or be omitted. If \textbf{Type} = 1 or if this optional argument is omitted, it is assumed that the first column of the search array is sorted in ascending order. If \textbf{Type} = -1 it is assumed that the column is sorted in descending order. This corresponds to the same function in Microsoft Excel. If \textbf{Type} = 0, only exact matches are found. If the search criterion is found more than once, the function returns the index of the first matching value. Only if \textbf{Type} = 0 can you search for regular expressions (if enabled in calculation options) or wildcards (if enabled in calculation options). If \textbf{Type} = 1 or the third argument is omitted, the index of the last value that is smaller than or equal to the search criterion is returned. This applies even when the search array is not sorted. For \textbf{Type} = -1, the index of the first value that is larger than or equal is returned.</td>
</tr>
<tr>
<td>OFFSET(\text{reference}, \text{rows}, \text{columns}, \text{height}, \text{width})</td>
<td>Returns the value of a cell offset by a certain number of rows and columns from a given reference point. \textbf{reference} is the cell from which the function searches for the new reference. \textbf{rows} is the number of rows by which the reference was corrected up (negative value) or down. \textbf{columns} is the number of columns by which the reference was corrected to the left (negative value) or to the right. \textbf{height} is the optional vertical height for an area that starts at the new reference position. \textbf{width} is the optional horizontal width for an area that starts at the new reference position. If the width or height is included, the OFFSET function returns a range and thus must be entered as an array formula. If both the width and height are missing, a cell reference is returned.</td>
</tr>
<tr>
<td>Syntax</td>
<td>Description</td>
</tr>
<tr>
<td>-------------</td>
<td>-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>ROW(reference)</td>
<td>Returns the row number of a cell reference. If the reference is a cell, it returns the row number of the cell. If the reference is a cell range, it returns the corresponding row numbers in a one-column array if the formula is entered as an array formula. If the ROW function with a range reference is not used in an array formula, only the row number of the first range cell will be returned. reference (optional) is a cell, an area, or the name of an area. If a reference is not indicated, Calc automatically sets the reference to the current cell.</td>
</tr>
<tr>
<td>ROWS(array)</td>
<td>Returns the number of rows in a reference or array. array is the reference or named area whose total number of rows is to be determined.</td>
</tr>
<tr>
<td>SHEET(reference)</td>
<td>Returns the sheet number of a reference or a string representing a sheet name. If no arguments are entered, the result is the sheet number of the spreadsheet containing the formula. reference (optional) is the reference to a cell, an area, or a sheet name string.</td>
</tr>
<tr>
<td>SHEETS(reference)</td>
<td>Determines the number of sheets in a reference. If no arguments are entered, the result is the number of sheets in the current document. reference (optional) is the reference to a sheet or an area.</td>
</tr>
<tr>
<td>STYLE(Style, Time, Style2)</td>
<td>Applies a style Style to the cell containing the formula for a length of time Time, after which the final style Style2 is applied. Styles are text entries entered in double quotes. The initial style is applied for Time seconds after the cell itself is recalculated. Time and Style2 may together be omitted; Style is then applied permanently. This function always returns the value 0, allowing it to be added to another function without changing the value.</td>
</tr>
<tr>
<td>VLOOKUP(Search criterion, array, Index, sort order)</td>
<td>Searches the first column of an array for the value given by Search criterion and if found returns the cell value at the intersection of the row in which it is found and the column index given by Index. Search criterion is the value searched for in the first column of the array. array is the reference, which must include at least two columns. Index is the number of the column in the array that contains the value to be returned. The first column has the number 1. If the sort order argument is omitted, or set to TRUE, or not 0, it is assumed that the data is sorted in ascending order. If the exact Search criterion is not found, the last value that is smaller than the criterion will be returned. If the sort order argument is set to FALSE or zero, an exact match must be found, otherwise the error Error: Value Not Available will be the result. Thus with a value of zero the data does not need to be sorted in ascending order.</td>
</tr>
</tbody>
</table>
Use Calc’s text functions to search and manipulate text strings or character codes.

The following text functions are provided in two related forms:

- FIND / FINDB
- LEFT / LEFTB
- LEN / LENB
- MID / MIDB
- REPLACE / REPLACEB
- RIGHT / RIGHTB
- SEARCH / SEARCHB

In each case the first named function is intended for use with languages that use the single-byte character set (SBCS), whereas the second named function (name ending “B”) is intended for use with languages that use the double-byte character set (DBCS).

<table>
<thead>
<tr>
<th>Syntax</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ARABIC(Text)</td>
<td>Calculates the value of a Roman numeral. The value range must be between 0 and 3999 (“MMMIM”). <strong>Text</strong> is the text that represents a Roman numeral. It is not case sensitive and is entered in double quotes.</td>
</tr>
<tr>
<td>ASC(text)</td>
<td>The ASC function converts full-width to half-width ASCII and katakana characters. Returns a text string. <strong>text</strong> is the text that contains characters to be converted. This is the complementary function to JIS.</td>
</tr>
<tr>
<td>BAHTTEXT(Number)</td>
<td>Converts a number to Thai text, including the Thai currency names. <strong>Number</strong> is any number. “Baht” is appended to the integral part of the number, and “Satang” is appended to the decimal part of the number.</td>
</tr>
<tr>
<td>BASE(number, radix, Minimum length)</td>
<td>Converts a positive integer to a specified base into text using the characters from the base’s numbering system (decimal, binary, hexadecimal, etc.). Only the digits 0-9 and the letters A-Z are used. <strong>number</strong> is the positive integer to be converted. <strong>radix</strong> is the base of the number system. It may be any positive integer in the range 2 to 36. <strong>Minimum length</strong> (optional) is the minimum length of the character sequence that has been created. If the text is shorter than the indicated minimum length, zeroes are added to the left of the string.</td>
</tr>
<tr>
<td>CHAR(number)</td>
<td>Converts a number into a character according to the current code table. The number can be a two-digit or three-digit integer number. <strong>number</strong> is a number in the range 1 to 255 representing the code value for the character. Codes greater than 127 may depend on your system’s character mapping (for example iso-8859-1, iso-8859-2, Windows-1252, Windows-1250) and hence may not be portable.</td>
</tr>
<tr>
<td>CLEAN(text)</td>
<td>Removes all non-printing characters from the string entered into <strong>text</strong>. Text is entered using double quotes.</td>
</tr>
<tr>
<td>Syntax</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------</td>
<td>-------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>CODE(text)</td>
<td>Returns a numeric code for the first character in a text string. <strong>text</strong> is the text for which</td>
</tr>
<tr>
<td></td>
<td>the code of the first character is to be found and is entered in double quotes. The code used</td>
</tr>
<tr>
<td></td>
<td>here does not refer to ASCII, but to the code table currently loaded. Codes greater than 127</td>
</tr>
<tr>
<td></td>
<td>may depend on your system's character mapping (for example iso-8859-1, iso-8859-2, Windows-1252,</td>
</tr>
<tr>
<td></td>
<td>Windows-1250) and hence may not be portable.</td>
</tr>
<tr>
<td>CONCAT(String1,</td>
<td>Concatenates one or more strings. The CONCAT function is an enhancement of CONCATENATE, as</td>
</tr>
<tr>
<td>String2, ...</td>
<td>CONCAT also accepts ranges as arguments, such as B2:E5, K:K or K:M. When ranges are used, the</td>
</tr>
<tr>
<td></td>
<td>cells are traversed row by row (from top to bottom) to concatenate. <strong>String1, String2, ...</strong></td>
</tr>
<tr>
<td></td>
<td>are strings or references to cells or ranges that contain strings to concatenate. <strong>String2</strong></td>
</tr>
<tr>
<td></td>
<td>onward are optional.</td>
</tr>
<tr>
<td>CONCATENATE(text</td>
<td>Combines several text strings into one string. <strong>text 1, text 2, ..., text 30</strong> are text</td>
</tr>
<tr>
<td>1, text 2, ...,</td>
<td>passages that are to be combined into one string. <strong>text 2</strong> onward are optional.</td>
</tr>
<tr>
<td>text 30)</td>
<td></td>
</tr>
<tr>
<td>DECIMAL(text,</td>
<td>Converts a text string with characters from a number system to a positive integer in the base</td>
</tr>
<tr>
<td>radix)</td>
<td>radix given. Spaces and tabs are ignored. The text field is not case-sensitive. If the radix is</td>
</tr>
<tr>
<td></td>
<td>16, a leading x or X or 0x or 0X, and an appended h or H, is disregarded. If the radix is 2, an</td>
</tr>
<tr>
<td></td>
<td>appended b or B is disregarded. Other characters that do not belong to the number system</td>
</tr>
<tr>
<td></td>
<td>generate an error. <strong>text</strong> is the text string to be converted. To differentiate between a</td>
</tr>
<tr>
<td></td>
<td>hexadecimal number, such as A1 and the reference to cell A1, you must place the number in</td>
</tr>
<tr>
<td></td>
<td>quotation marks, for example, &quot;A1&quot; or &quot;FACE&quot;. <strong>radix</strong> indicates the base of the number system.</td>
</tr>
<tr>
<td></td>
<td>It may be any positive integer in the range 2 to 36.</td>
</tr>
<tr>
<td>DOLLAR(value,</td>
<td>Converts a number to text in the locale currency format, rounded to a specified decimal place.</td>
</tr>
<tr>
<td>decimals)</td>
<td><strong>value</strong> is the number to be converted; it can be a number, a reference to a cell containing</td>
</tr>
<tr>
<td></td>
<td>a number, or a formula which returns a number. <strong>decimals</strong> (optional) is the number of decimal</td>
</tr>
<tr>
<td></td>
<td>places to be used. If no <strong>decimals</strong> value is specified, all numbers in currency format will be</td>
</tr>
<tr>
<td></td>
<td>displayed with two decimal places. The currency format is set in the system settings.</td>
</tr>
<tr>
<td>ENCODEURL(Text)</td>
<td>Returns a URL-encoded string. Use this function to transform text with symbols of national</td>
</tr>
<tr>
<td></td>
<td>alphabets (for example accented characters, non-ASCII alphabets, or Asian words) to a string</td>
</tr>
<tr>
<td></td>
<td>of URL-standard symbols. <strong>Text</strong> is a string to encode to a sequence of URL-standard symbols.</td>
</tr>
<tr>
<td>Syntax</td>
<td>Description</td>
</tr>
<tr>
<td>--------</td>
<td>-------------</td>
</tr>
<tr>
<td>EXACT(text_1, text_2)</td>
<td>Compares two text strings and returns TRUE if they are identical. This function is case-sensitive. text_1 is the first text to compare. text_2 is the second text to compare. Both arguments if entered directly must be in double quotes.</td>
</tr>
<tr>
<td>FILTERXML(XML Document, XPath Expression)</td>
<td>Applies an XPath expression to an XML document and returns the relevant XML content. XML Document is a string containing a valid XML stream. XPath Expression is a string containing a valid XPath expression.</td>
</tr>
<tr>
<td>FIND(find_text, text, position)</td>
<td>Looks for a string of text within another string and returns the position in the searched text where the searched-for text begins. Where to begin the search can also be defined. The search term can be a number or any string of characters. The search is case-sensitive. find_text is the text to be found. text is the text which is being searched. position (optional) is the position in the text from which the search starts. Text must be entered in double quotes.</td>
</tr>
<tr>
<td>FINDB(Find Text, Search Text, Position)</td>
<td>Returns the starting position of a given text string within another text string, using byte positions. Where to begin the search can also be defined. The search is case sensitive. Find Text is the text to be found. Search Text is the text to be searched. Position is optional and specifies the position in Start Text from which the search should start. Position defaults to the first character of the string to be searched. Text strings must be entered in double quotation marks.</td>
</tr>
<tr>
<td>FIXED(number, Decimals, No thousands separator)</td>
<td>Returns a number, displayed as text, with a fixed number of decimal places and with or without a thousands separator. This function can be used to apply a uniform format to a column of numbers. number is the number to be formatted. Decimals is the number of decimal places to be displayed. If Decimals is negative, the number is rounded to ABS(number) Decimals places to the left from the decimal point. No thousands separator (optional) determines whether the thousands separator is used or not. If the argument is equal to 0 or omitted, the thousands separators of the current locale setting are displayed, else the separators are suppressed.</td>
</tr>
<tr>
<td>JIS(text)</td>
<td>The JIS function converts half-width to full-width ASCII and katakana characters. Returns a text string. text is the text that contains characters to be converted. This is the complementary function to ASC.</td>
</tr>
<tr>
<td>LEFT(text, number)</td>
<td>Returns the number of characters from the left of a text string text determined by number. If this argument is omitted, one character is returned. If number is greater than the length of the string, the whole string is returned.</td>
</tr>
<tr>
<td>Syntax</td>
<td>Description</td>
</tr>
<tr>
<td>--------</td>
<td>-------------</td>
</tr>
<tr>
<td>LEFTB(Text, Number of Bytes)</td>
<td>Returns the first character(s) of a DBCS text string. <strong>Text</strong> is the text string from which the initial partial words are to be determined. <strong>Number of Bytes</strong> is optional and specifies the number of characters to be extracted, expressed as bytes (two bytes constitute one complete DBCS character). If this argument is not defined, one character is returned.</td>
</tr>
<tr>
<td>LEN(text)</td>
<td>Returns the length of a string including spaces. <strong>text</strong> is the text whose length is to be determined.</td>
</tr>
<tr>
<td>LENO(Text)</td>
<td>Returns the number of bytes used to represent the characters in a DBCS text string. <strong>Text</strong> is the text whose length is to be determined.</td>
</tr>
<tr>
<td>LOWER(text)</td>
<td>Converts all uppercase letters in a text string to lowercase. <strong>text</strong> is the text to be converted.</td>
</tr>
<tr>
<td>MID(text, start, number)</td>
<td>Returns a text segment of a character string. The arguments specify the starting position and the number of characters to return. <strong>text</strong> is the text containing the characters from which to extract. <strong>start</strong> is the position marking the beginning of the text to extract. <strong>number</strong> is the number of characters from that point on to be returned. If <strong>number</strong> is greater than LEN(text) minus <strong>start</strong>, then the text from <strong>start</strong> to the end of <strong>text</strong> is returned.</td>
</tr>
<tr>
<td>MIDB(Text, Start, Number of Bytes)</td>
<td>Returns a sub-string from a DBCS text string. The arguments specify the starting position and the number of characters. <strong>Text</strong> is the text containing the characters to extract. <strong>Start</strong> is the position of the first character in the text to extract. <strong>Number of Bytes</strong> specifies the number of characters to be returned, in bytes.</td>
</tr>
<tr>
<td>NUMBERVALUE(text, decimal_separator, group_separator)</td>
<td>Converts text to number, in a locale-independent way. <strong>text</strong> is a valid number expression and must be entered with quotation marks. <strong>decimal_separator</strong> (optional) defines the character used as the decimal separator. <strong>group_separator</strong> (optional) defines the character(s) used as the group separator. The length of the <strong>decimal_separator</strong> must be 1 and the <strong>decimal_separator</strong> should not appear in <strong>group_separator</strong>.</td>
</tr>
<tr>
<td>PROPER(text)</td>
<td>Capitalizes the first letter in all words of a text string. <strong>text</strong> is the text to be converted.</td>
</tr>
<tr>
<td>Syntax</td>
<td>Description</td>
</tr>
<tr>
<td>--------</td>
<td>-------------</td>
</tr>
<tr>
<td>REGEX(Text, Expression, Replacement, Flags or Occurrence)</td>
<td>Matches and extracts or optionally replaces text using regular expressions. <strong>Text</strong> is a text string or reference to a cell where the regular expression is to be applied. <strong>Expression</strong> is text representing the regular expression, using International Components for Unicode (ICU) regular expressions. If there is no match and <strong>Replacement</strong> is not given, #N/A is returned. <strong>Replacement</strong> is optional and gives the replacement text and references to capture groups. If there is no match, <strong>Text</strong> is returned unmodified. <strong>Flags</strong> is optional. “g” replaces all matches of <strong>Expression</strong> in <strong>Text</strong>, not extracted. If there is no match, <strong>Text</strong> is returned unmodified. <strong>Occurrence</strong> is optional and gives a number to indicate which match of <strong>Expression</strong> in <strong>Text</strong> is to be extracted or replaced. If there is no match and <strong>Replacement</strong> is not given, #N/A is returned. If there is no match and <strong>Replacement</strong> is given, <strong>Text</strong> is returned unmodified. If <strong>Occurrence</strong> is 0, <strong>Text</strong> is returned unmodified.</td>
</tr>
<tr>
<td>REPLACE(Text, position, length, new text)</td>
<td>Replaces part of a text string with a different text string. This function can be used to replace both characters and numbers (which are automatically converted to text). The result of the function is always displayed as text. To perform further calculations with a number which has been replaced by text, convert it back to a number using the VALUE function. Any text containing numbers must be enclosed in quotation marks so it is not interpreted as a number and automatically converted to text. <strong>Text</strong> is text, a part of which will be replaced. <strong>position</strong> is the position within the text where the replacement will begin. <strong>length</strong> is the number of characters in <strong>text</strong> to be replaced. <strong>new text</strong> is the text which replaces <strong>text</strong>.</td>
</tr>
<tr>
<td>REPLACEB(Text, Position, Length, New Text)</td>
<td>Replaces part of a text string, based on the number of bytes you specify, with a different text string. <strong>Text</strong> is a text string, a part of which will be replaced. <strong>Position</strong> is the position of the character within the text where the replacement will begin. <strong>Length</strong> is the number of bytes in <strong>Text</strong> to be replaced. <strong>New Text</strong> is replacement text.</td>
</tr>
<tr>
<td>REPT(text, number)</td>
<td>Repeats a character string by the given <strong>number</strong> of copies. <strong>text</strong> is the text to be repeated. <strong>number</strong> is the number of repetitions. The result can be a maximum of 255 characters.</td>
</tr>
<tr>
<td>RIGHT(text, number)</td>
<td>Returns the right-most <strong>number</strong> of characters of a <strong>text</strong> string. If optional <strong>number</strong> is omitted, 1 is assumed and the right-most character is returned. If <strong>number</strong> is greater than the length of <strong>text</strong>, the whole text is returned.</td>
</tr>
<tr>
<td>RIGHTB(Text, Number of Bytes)</td>
<td>Returns the last character(s) of a DBCS text string. <strong>Text</strong> is the text string of which the right part is to be determined. <strong>Number of Bytes</strong> is optional and specifies the number of characters you want to extract, expressed as bytes (two bytes constitute one complete DBCS character).</td>
</tr>
<tr>
<td>Syntax</td>
<td>Description</td>
</tr>
<tr>
<td>------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>ROMAN(Number, Mode)</td>
<td>Converts a number into a Roman numeral. The value range must be between 0 and 3999; the modes can be integers from 0 to 4. Number is the number that is to be converted into a Roman numeral. Mode (optional) indicates the degree of simplification. The higher the value, the greater is the simplification of the Roman numeral.</td>
</tr>
<tr>
<td>ROT13(Text)</td>
<td>Encrypts a character string by moving the characters 13 positions in the alphabet. After the letter Z, the alphabet begins again (rotation). Entering text previously encrypted by this function decrypts the text. Text is the character string to be encrypted/decrypted.</td>
</tr>
<tr>
<td>SEARCH(find_text, text, position)</td>
<td>Returns the start position of a text string within a larger string. The start position for the search can be set as an option. The search text can be a number or any sequence of characters. The search is not case-sensitive. The search supports regular expressions. find_text is the text to be searched for. text is the text where the search will take place. position (optional) is the position in the text where the search is to start.</td>
</tr>
<tr>
<td>SEARCHB(Find Text, Search Text, Position)</td>
<td>Returns the start position of a text string within a larger DBCS text string. The start position for the search can be set as an option. The search text can be a number or any sequence of characters. The search is not case-sensitive. Find Text is the text to be searched for. Search Text is the text where the search will take place. Position is optional and defines the position in the text where the search is to start.</td>
</tr>
<tr>
<td>SUBSTITUTE(text, search_text, new text, occurrence)</td>
<td>Substitutes new text for old text in a string. text is the text in which text segments are to be exchanged. search_text is the text segment that is to be replaced (a number of times). new text is the text that is to replace the text segment. occurrence (optional) indicates which occurrence of the search text is to be replaced. If this argument is missing, the search text is replaced throughout.</td>
</tr>
<tr>
<td>T(value)</td>
<td>Returns the target text, or a blank text string if the target is not a text string. value is the value to be evaluated. A reference can be used as an argument. If the dereferenced value is not of type text, the result will be an empty string.</td>
</tr>
<tr>
<td>TEXT(number, Format)</td>
<td>Converts a number into text according to a given format. number is the numerical value to be converted. Format is the text which defines the format. Use decimal and thousands separators according to the language set in the cell format. More information on number format codes is available in the Help system.</td>
</tr>
</tbody>
</table>
### Syntax

<table>
<thead>
<tr>
<th>Syntax</th>
<th>Description</th>
</tr>
</thead>
</table>
| TEXTJOIN(Delimiter, Skip Empty, String1, String2, …) | Concatenates one or more strings, and inserts delimiters between them.  
**Delimiter** is a text string and can be a range. **Skip Empty** is a logical (TRUE or FALSE, 1 or 0) argument. When TRUE, empty strings will be ignored. **String1, String2, …** are strings or references to cells or ranges that contain text to join. **String2 onward** are optional. Ranges are traversed row by row (from top to bottom).  
If **Delimiter** is a range, the range need not be of the same size as the number of strings to be joined. If there are more delimiters than strings to be joined, not all delimiters will be used. If there are fewer delimiters than strings to be joined, the delimiters will be used again from the start. |
| TRIM(text)                                      | Returns a text string from which leading and trailing spaces have been removed, and replaces all internal multiple spaces with a single space. **text** is the text from which spaces are to be removed. |
| UNICHAR(number)                                 | Returns the character represented by the given number according to the [UNICODE] standard. **number** is a decimal integer value between 0 and 1114111. |
| UNICODE(text)                                   | Returns the [UNICODE] code corresponding to the first character of the text value. **text** is a string from which the code number is returned. |
| UPPER(text)                                     | Converts the string specified in the **text** argument to uppercase characters. |
| VALUE(text)                                     | Converts a text string into a number. **text** is the text to be converted to a number. |
| WEBSERVICE(URI)                                 | Get some web content from a Uniform Resource Identifier (URI).  
**URI** is the URI text of the web service. |

### Add-in functions

**Table 37: Add-in functions**

<table>
<thead>
<tr>
<th>Syntax</th>
<th>Description</th>
</tr>
</thead>
</table>
| BESSELI(X, N) | Calculates the modified Bessel function of the first kind In(x). **X** is the value on which the function will be calculated.  
**N** is a positive integer giving the order of the Bessel function. |
| BESSELJ(X, N) | Calculates the Bessel function of the first kind Jn(x) (cylinder function). **X** is the value on which the function will be calculated.  
**N** is a positive integer giving the order of the Bessel function. |
<table>
<thead>
<tr>
<th><strong>Syntax</strong></th>
<th><strong>Description</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>BESSELK(X, N)</td>
<td>Calculates the modified Bessel function of the second kind Kn(x). X (&gt;0) is the value on which the function will be calculated. N is a positive integer giving the order of the Bessel function.</td>
</tr>
<tr>
<td>BESSELY(X, N)</td>
<td>Calculates the modified Bessel function of the second kind Yn(x), also known as the Weber or Neumann function. X (&gt;0) is the value on which the function will be calculated. N is a positive integer giving the order of the Bessel function.</td>
</tr>
<tr>
<td>BIN2DEC(Number)</td>
<td>Returns the decimal number for the binary number entered. Number is the binary value entered as a number or as text. The number can have a maximum of 10 places (bits). The most significant bit is the sign bit. Negative numbers are entered as two's complement.</td>
</tr>
<tr>
<td>BIN2HEX(Number, Places)</td>
<td>Returns the hexadecimal number for the binary number entered. Number is the binary value entered as a number or text. The number can have a maximum of 10 places (bits). The most significant bit is the sign bit. Negative numbers are entered as two's complement. Places (optional) is the number of places to be output.</td>
</tr>
<tr>
<td>BIN2OCT(Number, Places)</td>
<td>Returns the octal number for the binary number entered. Number is the binary value entered as a number or text. The number can have a maximum of 10 places (bits). The most significant bit is the sign bit. Negative numbers are entered as two's complement. Places (optional) is the number of places to be output.</td>
</tr>
<tr>
<td>COMPLEX(Real num, I num, Suffix)</td>
<td>Returns a complex number from a real coefficient and an imaginary coefficient. Real num is the real coefficient of the complex number. I num is the imaginary coefficient of the complex number. Suffix is optional, and may be &quot;i&quot; or &quot;j&quot;. If omitted, &quot;i&quot; is assumed. Suffix must be lowercase.</td>
</tr>
<tr>
<td>CONVERT(Number, From Unit, To Unit)</td>
<td>Converts a value from one unit of measure to the corresponding value in another unit of measure. Enter the units of measure directly as text in quotation marks or as a reference. Number is the number to be converted. From Unit is the unit from which conversion is taking place. To Unit is the unit to which conversion is taking place. Both units must be of the same type. If you enter the units of measure in cells, they must correspond exactly with the list of allowed units, which is case-sensitive. For example, in order to enter a lower-case &quot;l&quot; (for litre) in a cell, enter the apostrophe (') immediately followed by l. Some units of measure can be preceded by a prefix character. For example, use prefix M (mega) for 10^6. The information units &quot;bit&quot; and &quot;byte&quot; may also be prefixed by one of the IEC 60027-2 / IEEE 1541 prefixes. More information on all these aspects can be found in the Help system.</td>
</tr>
<tr>
<td>Syntax</td>
<td>Description</td>
</tr>
<tr>
<td>--------</td>
<td>-------------</td>
</tr>
<tr>
<td>DEC2BIN(Number, Places)</td>
<td>Returns the binary number for the decimal number entered between –512 and 511. Number is the decimal number. If Number is negative, the function returns a binary number with 10 characters. The most significant bit is the sign bit, the other 9 bits return the value. Places (optional) is the number of places to be output.</td>
</tr>
<tr>
<td>DEC2HEX(Number, Places)</td>
<td>Returns the hexadecimal number for the decimal number entered. Number is the decimal number. If Number is negative, the function returns a hexadecimal number with 10 characters (40 bits). The most significant bit is the sign bit, the other 39 bits return the value. Places (optional) is the number of places to be output.</td>
</tr>
<tr>
<td>DEC2OCT(Number, Places)</td>
<td>Returns the octal number for the decimal number entered. Number is the decimal number. If Number is negative, the function returns an octal number with 10 characters (30 bits). The most significant bit is the sign bit, the other 29 bits return the value. Places (optional) is the number of places to be output.</td>
</tr>
<tr>
<td>DELTA(Number 1, Number 2)</td>
<td>Returns TRUE (1) if both numbers are equal, otherwise returns FALSE (0). Number 2 is optional and assumes a value of 0 if omitted.</td>
</tr>
<tr>
<td>ERF(Lower limit, Upper limit)</td>
<td>Returns values of the Gaussian error integral. Lower limit is the lower limit of integral. Upper limit (optional) is the upper limit of the integral. If this value is missing, the calculation takes places between 0 and the lower limit.</td>
</tr>
<tr>
<td>ERFC(Lower limit)</td>
<td>Returns complementary values of the Gaussian error integral between a given lower limit and infinity. Lower limit is the lower limit of the integral.</td>
</tr>
<tr>
<td>FACTDOUBLE(Number)</td>
<td>Returns the double factorial of a number. Number is an integer greater than or equal to zero. For even numbers FACTDOUBLE(n) returns: [2^*4^*6^<em>8^</em> ... *(n-2)^n] For odd numbers FACTDOUBLE(n) returns: [1^*3^*5^<em>7^</em> ... *(n-2)^n] FACTDOUBLE(0) returns 1 by definition.</td>
</tr>
<tr>
<td>GESTEP(Number, Step)</td>
<td>Returns 1 if Number is greater than or equal to Step (optional, default 0), 0 otherwise.</td>
</tr>
<tr>
<td>HEX2BIN(Number, Places)</td>
<td>Returns the binary number for the hexadecimal number entered. Number is a hexadecimal number or a string that represents a hexadecimal number. It can have a maximum of 10 places. The most significant bit is the sign bit, the following bits return the value. Negative numbers are entered as two's complement. Places (optional) is the number of places to be output.</td>
</tr>
<tr>
<td>Syntax</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------------</td>
<td>---------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>HEX2DEC(Number)</td>
<td>Returns the decimal number for the hexadecimal number entered. <strong>Number</strong> is is a hexadecimal number or a string that represents a hexadecimal number. It can have a maximum of 10 places. The most significant bit is the sign bit, the following bits return the value. Negative numbers are entered as two's complement.</td>
</tr>
<tr>
<td>HEX2OCT(Number, Places)</td>
<td>Returns the octal number for the hexadecimal number entered. <strong>Number</strong> is a hexadecimal number or a string that represents a hexadecimal number. It can have a maximum of 10 places. The most significant bit is the sign bit, the following bits return the value. Negative numbers are entered as two's complement. <strong>Places</strong> (optional) is the number of places to be output.</td>
</tr>
<tr>
<td>IMABS(Complex number)</td>
<td>Returns the absolute value (modulus) of the entered <strong>Complex number</strong>. The complex number is entered in the form &quot;x + yi&quot; or &quot;x + yj&quot;.</td>
</tr>
<tr>
<td>IMAGINARY(Complex number)</td>
<td>Returns the imaginary coefficient of the entered <strong>Complex number</strong>. The complex number is entered in the form &quot;x + yi&quot; or &quot;x + yj&quot;.</td>
</tr>
<tr>
<td>IMARGUMENT(Complex number)</td>
<td>Returns the argument (the phi angle) of the entered <strong>Complex number</strong>. The complex number is entered in the form &quot;x + yi&quot; or &quot;x + yj&quot;.</td>
</tr>
<tr>
<td>IMCONJUGATE(Complex number)</td>
<td>Returns the conjugated complex complement to the entered <strong>Complex number</strong> as a text string. The complex number is entered in the form &quot;x + yi&quot; or &quot;x + yj&quot;.</td>
</tr>
<tr>
<td>IMCOS(Complex number)</td>
<td>Returns the cosine of the entered <strong>Complex number</strong> as a text string. The complex number is entered in the form &quot;x + yi&quot; or &quot;x + yj&quot;.</td>
</tr>
<tr>
<td>IMCOSH(Complex number)</td>
<td>Returns the hyperbolic cosine of the entered <strong>Complex number</strong> as a text string. The complex number is entered in the form &quot;x + yi&quot; or &quot;x + yj&quot;.</td>
</tr>
<tr>
<td>IMCOT(Complex number)</td>
<td>Returns the cotangent of the entered <strong>Complex number</strong> as a text string. The complex number is entered in the form &quot;x + yi&quot; or &quot;x + yj&quot;.</td>
</tr>
<tr>
<td>IMCSC(Complex number)</td>
<td>Returns the cosecant of the entered <strong>Complex number</strong> as a text string. The complex number is entered in the form &quot;x + yi&quot; or &quot;x + yj&quot;.</td>
</tr>
<tr>
<td>IMCSCH(Complex number)</td>
<td>Returns the hyperbolic cosecant of the entered <strong>Complex number</strong> as a text string. The complex number is entered in the form &quot;x + yi&quot; or &quot;x + yj&quot;.</td>
</tr>
<tr>
<td>IMDIV(Numerator, Denominator)</td>
<td>Returns the division of two complex numbers as a text string. <strong>Numerator</strong> and <strong>Denominator</strong> are entered in the form &quot;x + yi&quot; or &quot;x + yj&quot;.</td>
</tr>
<tr>
<td>IMEXP(Complex number)</td>
<td>Returns the power of e (the Eulerian number) to the complex number as a text string. <strong>Complex number</strong> is entered in the form &quot;x + yi&quot; or &quot;x + yj&quot;.</td>
</tr>
<tr>
<td>Syntax</td>
<td>Description</td>
</tr>
<tr>
<td>---------------------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>IMLN(Complex number)</td>
<td>Returns the natural logarithm of the entered Complex number as a text string. The complex number is entered in the form &quot;x + yi&quot; or &quot;x + yj&quot;.</td>
</tr>
<tr>
<td>IMLOG10(Complex number)</td>
<td>Returns the common logarithm of the entered Complex number as a text string. The complex number is entered in the form &quot;x + yi&quot; or &quot;x + yj&quot;.</td>
</tr>
<tr>
<td>IMLOG2(Complex number)</td>
<td>Returns the binary logarithm of the entered Complex number as a text string. The complex number is entered in the form &quot;x + yi&quot; or &quot;x + yj&quot;.</td>
</tr>
<tr>
<td>IMPOWNER(Complex number, Number)</td>
<td>Returns the entered Complex number raised to the power Number as a text string. The complex number is entered in the form &quot;x + yi&quot; or &quot;x + yj&quot;.</td>
</tr>
<tr>
<td>IMPRODUCT(Complex number1, Complex number2, ..., Complex number29)</td>
<td>Returns the product of up to 29 entered Complex numbers as a text string. The complex numbers are entered in the form &quot;x + yi&quot; or &quot;x + yj&quot;.</td>
</tr>
<tr>
<td>IMREAL(Complex number)</td>
<td>Returns the real coefficient of the entered Complex number. The complex number is entered in the form &quot;x + yj&quot; or &quot;x + yj&quot;.</td>
</tr>
<tr>
<td>IMSEC(Complex Number)</td>
<td>Returns the secant of the entered Complex Number as a text string. The complex number is entered in the form &quot;x + yi&quot; or &quot;x + yj&quot;.</td>
</tr>
<tr>
<td>IMSECH(Complex Number)</td>
<td>Returns the hyperbolic secant of the entered Complex Number as a text string. The complex number is entered in the form &quot;x + yi&quot; or &quot;x + yj&quot;.</td>
</tr>
<tr>
<td>IMSIN(Complex number)</td>
<td>Returns the sine of the entered Complex number as a text string. The complex number is entered in the form &quot;x + yi&quot; or &quot;x + yj&quot;.</td>
</tr>
<tr>
<td>IMSINH(Complex number)</td>
<td>Returns the hyperbolic sine of the entered Complex number as a text string. The complex number is entered in the form &quot;x + yi&quot; or &quot;x + yj&quot;.</td>
</tr>
<tr>
<td>IMSQRT(Complex number)</td>
<td>Returns the square root of the entered Complex number as a text string. The complex numbers are entered in the form &quot;x + yi&quot; or &quot;x + yj&quot;.</td>
</tr>
<tr>
<td>IMSUB(Complex number 1, Complex number 2)</td>
<td>Returns the difference of two complex numbers as a text string. The complex numbers are entered in the form &quot;x + yi&quot; or &quot;x + yj&quot;.</td>
</tr>
<tr>
<td>IMSUM(Complex number1, Complex number2, ..., Complex number29)</td>
<td>Returns the sum of up to 29 entered Complex numbers. The complex numbers are entered in the form &quot;x + yi&quot; or &quot;x + yj&quot;.</td>
</tr>
<tr>
<td>IMTAN(Complex number)</td>
<td>Returns the tangent of the entered Complex number as a text string. The complex number is entered in the form &quot;x + yi&quot; or &quot;x + yj&quot;.</td>
</tr>
<tr>
<td>Syntax</td>
<td>Description</td>
</tr>
<tr>
<td>------------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>OCT2BIN(Number, Places)</td>
<td>Returns the binary number for the octal value entered. <strong>Number</strong> is the octal number. The number can have a maximum of 10 places. The most significant bit is the sign bit, the following bits return the value. Negative numbers are entered as two's complement. <strong>Places</strong> (optional) is the number of places to be output.</td>
</tr>
<tr>
<td>OCT2DEC(Number)</td>
<td>Returns the decimal number for the octal value entered. <strong>Number</strong> is the octal number. The number can have a maximum of 10 places. The most significant bit is the sign bit, the following bits return the value. Negative numbers are entered as two's complement.</td>
</tr>
<tr>
<td>OCT2HEX(Number, Places)</td>
<td>Returns the hexadecimal number for the octal value entered. <strong>Number</strong> is the octal number. The number can have a maximum of 10 places. The most significant bit is the sign bit, the following bits return the value. Negative numbers are entered as two's complement. <strong>Places</strong> (optional) is the number of places to be output.</td>
</tr>
</tbody>
</table>
Calc Guide
Working with spreadsheets

About this book:
This book is for beginners to advanced users of Calc, the spreadsheet component of LibreOffice. It covers the main features of Calc, including: - Entering, editing, and formatting data - Functions and formulas to perform complex calculations on data - Statistic analysis, pivot tables and goal seek for decision making - Database functions to arrange, store, and filter data - A wide range of 2D and 3D charts - Macros - And much more.

If you have never used LibreOffice before, or you want an introduction to all of its components, you might like to read Getting Started with LibreOffice first.

About the authors:
This book was written by volunteers from the LibreOffice community. Profits from sales of the printed edition will be used to benefit the community.

A PDF version of this book can be downloaded free from: https://documentation.libreoffice.org/en/

About LibreOffice:
LibreOffice is the free, libre, and open source personal productivity suite from The Document Foundation. It runs on Windows, macOS, and GNU/Linux. Support and documentation is free from our large, dedicated community of users, contributors, and developers. You too can get involved with volunteer work in many areas: development, quality assurance, documentation, translation, user support, and more.

You can download LibreOffice free from https://libreoffice.org/download/