LibreOffice Online

6.3

Writer  Calc  Impress
Contents

Copyright ................................................................................................................................. 2
Preface ....................................................................................................................................... 5
  Who is this book for? ........................................................................................................... 6
  What's in this book? ........................................................................................................... 6
  Where to get more help .................................................................................................... 6
  What you see may be different ........................................................................................ 7
  What are all these things called? ....................................................................................... 8
  Frequently Asked Questions ............................................................................................ 10
  What's new in LibreOffice Online 6.3? ........................................................................... 11
Chapter 1 Introducing LibreOffice Online ............................................................................. 12
  What is LibreOffice Online? ............................................................................................ 13
  What does LibreOffice Online include? .......................................................................... 13
Chapter 2 Installing LibreOffice Online ................................................................................ 17
  Structure of an LOOL Installation .................................................................................. 18
  Requirements to Install LibreOffice Online ..................................................................... 19
  Installing LibreOffice Online through Docker .............................................................. 20
Chapter 3 Setting Up to Use LibreOffice Online .................................................................. 22
  Your LibreOffice Online Installation ............................................................................. 23
Chapter 4 Navigating Your LibreOffice Online Files ............................................................. 26
  LibreOffice Online Files ................................................................................................ 27
  Managing Your LibreOffice Files in the Cloud ............................................................... 30
Chapter 5 Multi-Editing, Sharing, Exporting and Printing Documents ............................... 32
  LibreOffice Online Document Files .............................................................................. 33
  Sharing Files in LibreOffice Online ............................................................................... 33
  Multi-User Editing in LibreOffice Online ...................................................................... 35
  Exporting Your LibreOffice Online Files ...................................................................... 36
  Printing from LibreOffice Online ................................................................................... 37
Chapter 6 The Text Documents Module ............................................................................... 38
  What is the Text Documents Module Used For? ............................................................ 39
  The Text Documents Module Interface .......................................................................... 39
  Working with Text ............................................................................................................ 42
  Direct Formatting vs. Styles Formatting ......................................................................... 43
  Structuring Your Documentation .................................................................................... 52
  Inserting Graphics & Other Items ................................................................................... 53
  Specifying Your Document's Layout ............................................................................. 56
  References ......................................................................................................................... 59
  Writing Tools .................................................................................................................... 60
Chapter 7 The Spreadsheets Module ..................................................................................... 64
  What is the Spreadsheets Module Used For? .................................................................. 65
  The Spreadsheet Module Interface ................................................................................ 65
  Navigating in the Spreadsheets Module ....................................................................... 68
<table>
<thead>
<tr>
<th>Chapter</th>
<th>Title</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>8</td>
<td>The Presentations Module</td>
<td>78</td>
</tr>
<tr>
<td></td>
<td>The Presentation Module Interface</td>
<td>79</td>
</tr>
<tr>
<td></td>
<td>Opening, Saving, and Exporting Files</td>
<td>81</td>
</tr>
<tr>
<td></td>
<td>Viewing the Presentation</td>
<td>81</td>
</tr>
<tr>
<td></td>
<td>Adding to the Slides in a Presentation</td>
<td>81</td>
</tr>
<tr>
<td></td>
<td>Adding Other Objects to a Slide</td>
<td>83</td>
</tr>
<tr>
<td>9</td>
<td>Integrating LibreOffice Online with Other Applications</td>
<td>86</td>
</tr>
<tr>
<td></td>
<td>Integrating LibreOffice Online with Other Applications</td>
<td>87</td>
</tr>
<tr>
<td></td>
<td>The Cloud Sync Desktop Applications</td>
<td>92</td>
</tr>
<tr>
<td></td>
<td>Mobile Applications</td>
<td>93</td>
</tr>
</tbody>
</table>
LibreOffice Online 6.3 Guide

Preface
Who is this book for?

LibreOffice is a free and open-source office suite with features comparable to proprietary alternatives. It includes applications for word processing, spreadsheets, presentations, and other functions, and is available to install on your Mac or PC running Windows or Linux. You may also be able to use it on other operating systems either through dedicated viewer applications (such as the one for Android) or through emulation (e.g. the Linux emulation layer in FreeBSD).

LibreOffice Online (hereafter also LOOL) is a web-based office suite compatible with the desktop version of LibreOffice. It offers word processor (Documents), spreadsheet (Spreadsheets), and presentation (Presentations) modules. It also allows you to keep your documents safely in a cloud- or network-based location you control. You can even open one of your LOOL documents in a desktop version of LibreOffice, edit it, and save it back to the remote server.

This book is for users who want any of the benefits a personal cloud affords: increased privacy, lower (free!) costs, or better ability to customize. That said, installing and maintaining LibreOffice Online for yourself is not a “point-and-click” process. You should be comfortable with networking concepts (domain management, hosting services, etc.), the Linux operating system in general, and working from its command-line in order to be able to use LibreOffice Online.

What's in this book?

This book will help you get LibreOffice installed, introduce it's browser-based interface, and highlight the major features of its modules.

1. Preface (this chapter)
2. Introduction to LibreOffice Online
3. Installation of LibreOffice Online
4. Configuring LibreOffice Online
5. Navigating Your LibreOffice Online Files
6. Editing, Saving, and Exporting Files in LibreOffice Online Applications
7. Using the Documents Module
8. Using the Spreadsheets Module
9. Using the Presentations Module
10. Integrating Other Applications with LibreOffice Online

Where to get more help

There are plenty of resources you can use to get help while using LibreOffice Online. These include not only this guide and others specific to LibreOffice Online, but also the materials created for LibreOffice. The two systems share a great deal of functionality, and answers to one are often just as applicable to the other.

Help system

LibreOffice Online is fairly new, and does not yet have an online Help system like the desktop version. While a Help item exists in the main menu, it contains only two items: Keyboard Shortcuts, and About.

However, if you have the desktop software, many of the functions are similar between the two. You can (and should) check the desktop software's help system to see if it contains a suggestion that solves your issue.
Other free online support

The LibreOffice project supports its users in many ways, including the following:

- **Ask.LibreOffice** is a question-and-answer forum where you can post your issue and get a reply from either a member of the project, or one of the other community members.
- **The LibreOffice Wiki** contains documentation about the software, as well as collaboration areas for groups within the project. If you’re looking for answers to software-related questions, try the Wiki’s Documentation Page as a starting point.
- Mailing lists are a traditional help resource in open source projects, and LibreOffice is no different. There are many people on the LibreOffice mailing lists who will respond to questions.
- In addition to the online help, there is also official documentation available in the form of books and guides—this guide is in fact a member of that group. But you can also find guides on the other modules available in LibreOffice Online (Writer, Calc, and Impress), as well as other components of the LibreOffice suite (e.g. Base, Math, and Draw).
- Finally, if you’re familiar with Internet Chat Relay (IRC), there are LibreOffice channels available on the freenode.net server. You can jump right in and interact with community members from your browser by visiting https://irc.documentfoundation.org/, or you can use some of the tips on the Users/IRC Wiki page to get an IRC client set up.

Paid Support and Training

You can also pay for support through service contracts from a vendor or consulting firm specializing in LibreOffice. For information about certified professional support, see The Document Foundation’s website: https://www.libreoffice.org/get-help/professional-support/

What you see may be different

Browser-based Controls

Unlike LibreOffice, which is a “stand-alone” application, you will be accessing LibreOffice through a browser. As a result, the fine details of how LibreOffice looks and behaves is dependent on the browser, which is in turn dependent on which browsers are available for your operating system.

For a consistent experience using LibreOffice Online, you should use a cross-platform browser like Mozilla Firefox or Google Chrome. The browser controls, such as bookmarks or the start page, will differ between these various browsers. However, the controls you see within LibreOffice Online will remain consistent.

Icons, Fonts, and Look-and-Feel

Desktop operating systems each have their own aesthetics. As a result there may be very slight differences what you see between OSes, or even between browsers on the same OS. These may appear slightly different throughout this text depending on which OS appears in a given screenshot. But these should be mostly confined to elements like the menu or status bar. As with the desktop software, some elements such as fonts, colors, themes, etc., of the browser are also customizable by users, and may appear different in screenshots throughout this book.
What it will not affect is the look and feel of your documents. These should remain consistent regardless of what operating system you’re using, and even whether you’re using LibreOffice Online or the desktop version of LibreOffice.

**What are all these things called?**

The terms used in LibreOffice Online for most parts of the user interface (the parts of the program you see and use, in contrast to the behind-the-scenes code that actually makes it work) are the same as for most web-based programs.
Shell Application:
This is the application that “hosts” LibreOffice Online (more information on in the Chapter 2, Introducing LibreOffice Online). In this example, LibreOffice Online is integrated with a popular cloud service, and the top row of controls actually have nothing to do with LOOL at all.

Main Menu:
The main menu of LOOL looks very similar to its desktop counterpart, with main entries such as File, Edit, and Tools.

Button Bar:
Also like desktop versions, the Button Bar contains buttons for common operations like saving the current document, bolding text, or creating a list out of highlighted.

Ruler:
In some modules, beneath the Button Bar is a Ruler showing the width of your document.
Workspace:
Your document takes up most of the screen, and is where you can place the cursor and add content to your documents.

Status Bar:
Finally, the bottom of the application window shows a variety of current, useful information such as Current Page/Total Pages, Word/Character count, and current selected Language.

You may also see dialogs, which are a window that appears over the main items listed above. Its purpose is to inform you of something, or request input from you, or both. It provides controls to use to specify how to carry out an action. The technical names for common controls are shown in Figure 2. In most cases the technical terms are not used in this book, but it is useful to know them because the Help and other sources of information often use them.

Frequently Asked Questions

May I use LibreOffice Online in my own business?
Yes.

May I distribute LibreOffice Online to anyone?
Yes.
May I sell it, either directly or as part of a subscription service?
Yes.

How many computers may I install it on?
LibreOffice Online is installed on a server, not individual PCs. That said, you may install it on as many servers as you like. However, if you engage the services of a company who installs it for you, they will likely install it on one server.

How can I contribute to LibreOffice?
You can help with the development and user support of LibreOffice in many ways, and you do not need to be a programmer. To start, check out this web page: https://www.libreoffice.org/community/get-involved/

May I distribute the PDF of this book, or print and sell copies?
Yes, as long as you meet the requirements of one of the licenses in the copyright statement at the beginning of this book. You do not have to request special permission. We request that you share with the project some of the profits you make from sales of books, in consideration of all the work we have put into producing them. https://www.libreoffice.org/donate/

What is LibreOffice Online? Is it different than LibreOffice?
LibreOffice Online is an online office suite installed on a server you control. You then access it by pointing your browser to a URL on that server. You will need to make sure that server has all the prerequisite software (more on this in Chapter 2, Installing LibreOffice Online) before you install it, and troubleshoot it if something goes wrong. However, you only need to do so once, after which you can access it via a browser on just about any machine you have, including PCs, Macs, and mobile devices. You need to have a steady connection to a network to use LibreOffice Online.

Do I need to choose between LibreOffice and LibreOffice Online?
Only in terms of what you want to use right now. But the two are created from the same core functionality, and are in fact designed to work together. You can easily create a file in LibreOffice Online, then open it in LibreOffice on your PC to edit it, and finally save the changes back to LOOL.

I don't see the files on my computer, where are they?
When you create content in LOOL, the files are stored on the server machine, not your local computer. You can freely download them, open them directly on the server machine, or sync them with your local computer using freely-available applications (more on this in Chapter 9, Integrating with LibreOffice Online).

What's new in LibreOffice Online 6.3?
All new versions of LibreOffice applications come with new features and bug fixes, and LOOL is no exception. Additions to the most recent version of LibreOffice Online can be found on the TDF Wiki.
Chapter 1
Introducing LibreOffice Online
What is LibreOffice Online?

Like many competing productivity suites, the LibreOffice project has created a version of the desktop software that’s available over the Internet. **LibreOffice Online** is the system that allows users to log into a supported system via a browser and work with their documents. In addition to being open source software, it’s free for both personal and professional use with no license fees. Some advantages include:

**Cross-platform:**
You can use LibreOffice Online across all your devices running Windows, macOS, or Linux, or any operating system with a supported browser (even mobile devices).

**File Compatibility:**
Files created in LibreOffice are highly compatible with alternatives such as Microsoft Office, Google Docs, and others.

**Multi-User:**
You can also invite collaborators to work on your files with you, over the network. You can even edit a file together at the same time!

**Multi-lingual:**
LibreOffice has support for many languages, with features like spell-checking, thesauri, and complex layout for the locales which require it.

**Community-Driven:**
A community of users and developers drives the development of LibreOffice, and everyone is encouraged to participate in plotting its future.

Instead of installing LOOL on each of the computers with which you want to use it, you'll install (or access) it on a server located somewhere else. This could be either on your local (e.g. home) network, or over the Internet.

To use LOOL you’ll visit an address in your browser, which corresponds to a hosting application. LibreOffice Online doesn’t typically exist by itself. Instead, it’s installed alongside another application that will host files. This hosting application will then allow you to open compatible files in LOOL, usually in addition to other options like downloading or deleting them.

What does LibreOffice Online include?

While the goal of LibreOffice Online is to support all the same features as its desktop counterpart. But as a fairly new addition to the LibreOffice family, LOOL currently has the following components:

- **Documents**, a word processor and counterpart to LibreOffice Writer
- **Spreadsheets**, a spreadsheet application and counterpart to LibreOffice Calc
- **Presentations**, a multimedia presentation program and counterpart to LibreOffice Impress
LibreOffice Online Documents is an online word processor capable of producing nicely-formatted written papers, reports, or books (among other things). It is a counterpart of LibreOffice Writer, and it creates its files in the same OpenDocument Text (.ODT) format. It can also open and save files in Microsoft Word (.DOCX/.DOC) format.

Some of the features it includes are:

- A selection of Fonts, text color, and text decoration (Bold, Italics, Strikethrough, etc.), and more.
- Styles to allow easy application of all the above formatting options.
- Review tools, including Track Changes.
- Document elements like Headers, Footers, Tables of Contents, and Indices.
- Fields that can be inserted into documents.
- Easy creation of Tables.
- Tools for language like spell checkers, word count, and a thesaurus.

Figure 4: LibreOffice Online Documents

Welcome to LibreOffice Online, your self-hosted office suite. LOOL is the open source web-based office suite for everyone from individuals to large enterprises and service providers. It provides a safe, secure and compliant file sync and share solution on servers you control.
LibreOffice Online Spreadsheets

LOOL Spreadsheets is the online counterpart to LibreOffice Calc, and allows you to collaborate on spreadsheets through your browser. It uses the same “workbook-and-tab” concepts as the desktop version, and shares the same OpenDocument Spreadsheet (.ODS) file format. It can also open and save files in Microsoft Excel (.XLSX/.XLS) format.

A sample of features available in Spreadsheets is as follows:

- **Basic arithmetic functions** such as addition, subtraction, multiplication, and division.
- **Cell formatting including** text decoration, cell background/borders, numerical formatting, and conditional formatting.
- **Formulas and functions**.
- **Data** tools such as sorting, filtering, grouping, and validation.
- **Charts** and **Graphs** that can be inserted into a spreadsheet tab.

Figure 5: LibreOffice Online Spreadsheets
LibreOffice Online Presentations

Figure 6: LibreOffice Online Presentations

The Presentations module in LibreOffice Online is the counterpart of LibreOffice Impress, and allows you to create rich, multimedia presentations in OpenDocument Presentation (.ODP) format. It can also open and save files in Microsoft Powerpoint (.PPTX/.PPT) format.

Some of the features supported in this online version include:

- Creating presentation **text and graphics**.
- **Styles** for easy decoration of slide elements.
- Adding **Shapes, Charts** and **Tables** to presentations.
- **Presenting** the file in fullscreen mode with animations and transitions.
Chapter 2
Installing LibreOffice Online
Structure of an LOOL Installation

As mentioned in previous sections, installing LOOL is a bit different from installing LibreOffice proper. With the latter, you install the software to your local machine. Then, when you launch one of the applications, all the processing and display also happens locally.

With LibreOffice Online, you install your application to a server. It will handle functions like the storage of files and the processing of input into formatted text or spreadsheet formulas, which are displayed on your PC through a browser. The process looks like the following:

1. You contact the server by pointing your browser at a specified URL.
2. The URL is for the hosting application, which is responsible for storing your files.
3. When you open a supported document type in the hosting application, it will call LOOL via a plugin to display it.
4. The results of this are sent back to your PC to display in the browser window.

While you don’t need anything special on your PC to use LibreOffice Online, you’ll need some software on the server where you plan to install it.

**Note**

The browser displays an image of the document, created in the server. This image is composed of many square tiles, which are updated automatically each time the document area changes, and with a smart strategy to update only the tiles that are affected by the change. For example, changing the text on the top of a document will affect more tiles than changing the text in the bottom.
Requirements to Install LibreOffice Online

Web Server

As mentioned, LibreOffice Online requires a hosting application that will store your files and display them using LOOL as needed. These host systems are web-based applications, and as such there are three main components they require in order to provide the features LOOL needs:

- A web server, which sends web-based content to browsers
- A database, which is used to store the information in the system (even when it looks like “files” to you)
- A programming language that allows the server to display dynamic information, in this case a full-fledged web application

Fortunately, Linux has these three components in abundance. There's a selection of different stacks you could use to host LOOL, but of these the LAMP (Linux, Apache, MySQL, PHP) stack or the WAMP (Windows, Apache, MySQL, PHP) are the most common. While installing and configuring a LAMP (WAMP) stack is beyond the scope of this guide, there are plenty of resources available online to get one up and running on your server.

Note: Confirming an Operational LAMP Stack

Before moving beyond this section, you should be able to visit your server with your web browser and be greeted with some sort of welcome page or message that the web server is running.

Hosting Application

Once your web server is in place, you can install one of the supported hosting applications that will hold the files for LOOL. There are a number of compatible applications, including ownCloud, NextCloud, e-Groupware and many others. These systems offer a number of functions, including file synchronization, calendaring, contact management, and collaboration and are thereafter referred to Cloud Service.

Again, the detailed instructions to install of one of these systems is outside the scope of this guide. Out of necessity, the below sections may include commands to quickly get a hosting application set up. But check some of the many resources online that will help you to fully administer your system.

Note: Confirming an Operational Cloud Service Instance

Before moving beyond this section, you should be able to visit your server with your browser, see the Cloud login page, and sign into the application.

Selecting a LOOL Version

Finally, before you start to install LOOL itself, you'll need to make a decision as to which version you want. LibreOffice Online is an open source, collaborative project, meaning anyone is free to take the code and create a product based on it. As a result, there are a couple of different options you have to install LOOL:

LibreOffice Project:

The Document Foundation itself produces an instance of LOOL you can run using the Docker container system. This is taken directly from the project's code and could be considered the “upstream” version of LOOL.
Commercial products:
There are several companies providing installation and support services for LOOL and the list can be obtained in the Document Foundation website at https://www.libreoffice.org/get-help/professional-support/

In this guide, we’ll focus on installing and configuring the LibreOffice Project’s Docker container as our version of choice, and use a popular hosting application.

Installing LibreOffice Online through Docker

Installing the LibreOffice Online application as published by The Document Foundation is easy using the Docker Container they provide. Docker is a system that runs applications for you in containers, which are like little sealed off sections of your computer. This means if there’s something wrong with a Docker application it can’t (normally) affect the rest of your system. It also means that you can’t normally access the contents of these containers through your operating system’s normal tools—at least not without some prior configuration. The purpose of containers is to provide security while also being resource efficient. Getting Docker installed is beyond the scope of this book, but you can find plenty of installation resources on the Docker website to install the Community Edition of Docker Engine.

The actual command to install LOOL from The Document Foundation is easy:

docker pull libreoffice/online

This will download LOOL from the Docker Hub repository and install it for you.

```
$ sudo docker pull libreoffice/online:master
master: Pulling from libreoffice/online
6abc03819f3e: Extracting 13.57MB/26.86MB
05731eb3f211: Download complete
00d67c50c6be: Download complete
c2c077db2545: Downloading 30.34MB/31.67MB
f637ff9d6954: Downloading 40.04MB/43.20MB
c2ea45f1478a: Downloading 35.93MB/91.03MB
74024ade1d3e: Waiting
13634c08b590: Waiting
9062c552795e: Waiting
d76c76ca6fab: Waiting
fe2c06a1406: Waiting
d321a50a7b56: Waiting
758271c083a10: Waiting
6a45d2a71af0: Waiting
252fa0b2621: Waiting
449d9e4e56e1: Waiting
e5f285680c236: Waiting
cc0817b52567: Waiting
```

Figure 8: Installing LibreOffice Online from Docker Hub

You’ll need to modify the application’s configuration file (/etc/loolwsd/loolwsd.xml) to include the hosting application’s domain name and the username/password for the administration console. You can then start the container up with the following command, where `abcd123` is the name of your Docker container.

docker run abcd123

---

20 Requirements to Install LibreOffice Online
If you find your LibreOffice Online container starts correctly, but you’re not able to open any files (as described later in Chapter 5, Editing, Saving, and Exporting Your LibreOffice Online Files), make sure you’ve entered the right configuration values for your hosting application in the loolwsd.xml file. Additionally, make sure you’re completed the steps described in Chapter 3, Setting Up to Use LibreOffice Online, to make sure that the set-up is complete on the hosting application’s side.
Chapter 3
Setting Up to Use
LibreOffice Online
Your LibreOffice Online Installation

At this point LibreOffice is installed, but it’s not yet connected to your hosting application. We need to set up that hosting application to use LOOL when you take the action of opening a compatible OpenDocument format file for editing.

Note: Applicability

Note that the following sections will only apply if you’ve installed using the Docker or Linux Package methods. If you’re using the VM appliance, everything should be set up for you already.

Log Into the cloud service

Visit your cloud service installation with a web browser—you can use the IP address of the server where you installed it. If you’re using a cloud service install you already have, you can use your existing username and password.

If you followed the instructions in the last chapter and your cloud service instance is brand new, you'll need to complete a short setup process. On the first screen you'll provide the name for your administrative account, and set that account's password.

![Figure 9: the very short setup for cloud service docker installation](image)

Once you’re logged in, you'll land on Cloud Service Home screen.

Install the Cloud Service / LibreOffice Online Integration Plugin

The next step is to connect your cloud service instance with LibreOffice. First, you'll need to install the necessary cloud service application, normally using the Market feature of the cloud service, by opening the account menu in the upper-right of the screen, and selecting + Apps. Click on Office...
& text and search the list for the Collabora Online app. Click the **Download & enable** button to get it installed.

![Figure 10: the Collabora Online app in a popular cloud app store](image)

Once it’s installed, you won’t see any immediate change. Click the account menu again, and select **Settings**. There, you’ll see a new entry for **Collabora Online** in the **Administration** section of the **Settings** screen. Select this, then enter the URL and port for your LibreOffice installation. You can leave the remainder of the settings as they are.
Now, go back to the Files app, and select an .ODT file (there should be one in the Documents folder). If the LOOL Documents app doesn’t display your selected file, and/or it displays an error, go back and make sure the value you entered in the Settings screen is correct.

**Tip: Troubleshooting**

If you’re sure your LibreOffice Online URL is correct in Settings, and you still can’t connect, there are a couple of other items you should check. Is the LOOL instance actually running? If you installed via Docker, are the two containers on the same network? If your URL contains “https,” are you sure your certificates are valid? There are a few different ways the connection can break down between the two systems. Some savvy Internet searching can likely find a solution to your particular problem.
Chapter 4
Navigating Your LibreOffice Online Files
LibreOffice Online Files

As mentioned in prior chapters, when using LibreOffice Online you won’t go to it “directly,” in the sense of pointing your browser to the LOOL installation. Instead, you’ll interact with a **hosting application** which will open compatible files in LOOL. In this chapter we'll look at how you get around in a hosting application or cloud service. Other applications won’t look identical, but the concepts will be very similar.

The Files Application in the Cloud Service

The popular cloud services supports a number of functions including calendar, contacts, and a large selection of add-ons. Its file management is one of the core features, which allows a user to synchronize files and folders among multiple devices.

When logging into most cloud services, you are often sent to the **Files** screen by default. This screen consists of three main sections: a **Toolbar** at the top, a **Sidebar** to the left, and a list of files and folders stored in your account in the cloud server in the center.

![example of a cloud service files screen](image)

**Figure 12:** example of a cloud service files screen

The Cloud Service Toolbar

Often the top toolbar of the cloud service is common throughout its applications, and allows users to switch between them. The icons on the left represent these applications enabled in the system, which in the above screenshot are as follows:

- **Home**, which takes the user back to the default screen (in this case, **Files**).

*Documentation for LibreOffice is available at [http://documentation.libreoffice.org/en/](http://documentation.libreoffice.org/en/)*
• **Files**, which as mentioned shows the files stored in the user’s account.
• **Gallery**, which presents a browsable view of media files in the user’s account.
• **Calendar**, for keeping appointments and tasks.
• **Polls**, where users can set up questionnaires for other users to vote on.

The right side of the Toolbar contains items related to the user’s account, including:

• **Notifications**, where the system will show alerts.
• **Contacts**, which allows users to search for or message other members of the cloud instance.
• **Account**, which is a sub-menu allows users to update their profile and other settings, see system info (i.e. **About**), get help, or log out.

---

**Note**

The actual list of cloud applications depends on the server installation.

---

**The Files Sidebar**

The left-hand Sidebar is, in contrast, specific to the Files application. It contains several items at the top, as follows:

• All files
• Recent
• Favorites
• Shares
• Tags

The bottom entries of the Sidebar include the following:

• Deleted files
• Space Usage
• Settings
The Files List

Figure 13: cloud files list

The main area of the screen displays a list of files and folders in your account. As you’d expect from working with desktop file managers, clicking on a folder allows you to enter it and view its contents. Your location is shown in the upper-left corner of the pane in “breadcrumb” style, starting with an icon that will return you to your Home (or the root of your account's file storage).

To the right of the breadcrumbs is a + button. Clicking this will give you the option to create a new file in the current directory. You can switch the view of the files list from the default, a details list, to one that displays thumbnails, by clicking the button at the top-right of the list screen.

The left-most column in the list displays checkboxes which allow you to select multiple files. You’re able to drag-and-drop these to move them around your account. Clicking on a file name will do one of two things:

- If the file’s type has a supported viewer/app in cloud, it will be opened. For example, .PNG files will open in an image previewer, while plain text files open in a pop-up text editor.
- If the file’s type doesn’t have a supported app, the file will begin downloading to your local machine.

Next to the file’s name is a Share button. Clicking on this button will open the file’s Details pane to the Share tab. Here you can share the file with others by entering either the usernames of other users in the hosting application, or email addresses of external people.

The overflow menu to the right of the Sharing button has options to allow you to:

- Add the files to your Favorites list of files.
- View the Details of the file, which will open a Details pane to the containing tabs showing the files Activity (e.g. changes made), any Comments users have made on the file, and the aforementioned Sharing tab.
- Rename the file.
- Move or copy the file.
- Download the file.
- Delete the file.
Finally, the last columns in the list show the Size and Modified date of the file. You can sort the list of files by these two values (along with Name).

**Note: File Navigation in Other Applications**

The screens for other supported cloud services application may look different. However, the basic concepts should be similar.

Managing Your LibreOffice Files in the Cloud

With the above in mind, there are five main tasks involved in managing your LOOL files in the cloud service application.

**Creating a New LOOL File in the Cloud**

To create a brand new LOOL file (either document, spreadsheet, or presentation) in cloud, click the + button at the top of the files list. Then, select your desired file, and provide it a name when prompted.

![Figure 14: creating a new .ODS File in the cloud](image)

**Adding an Existing LOOL File in the Cloud**

Click the + button and select Upload file to choose a file from your local computer to send to the cloud. Make sure the one you upload is a supported file type.

**Editing an LOOL File in the Cloud**

To edit one of your files, simply click it. Provided LOOL in installed correctly, the cloud service will open your desired file in the appropriate LOOL application (Documents, Spreadsheets, or Presentations). See Chapter 5, Editing, Saving, and Exporting Your LibreOffice Online Files for more details on how this operates.
Moving an LOOL File in the Cloud

Drag-and-drop folders and/or files into folders in the list or in the breadcrumbs to move them. If you wish to copy them instead, use the overflow menu’s Move or copy option on your selected item(s), and make sure to click the Copy button in the dialog that appears.

Deleting an LOOL File in the Cloud

To remove a file from your list, click the overflow menu, then select the Delete file option it provides. Bear in mind that your deleted files will still be available in the Deleted Files signified by the trash bin in the lower-right corner of the screen.
Chapter 5
Multi-Editing, Sharing, Exporting and Printing Documents
LibreOffice Online Document Files

Once you open a file from the hosting application, it will open in the appropriate LOOL application. The specifics of editing these files in each application will be presented in more detail in following chapters. However, there are some aspects of working in LibreOffice Online that are the same across the apps.

Sharing Files in LibreOffice Online

When you receive an account in LibreOffice Online, it will include a personal area for your to store your files, i.e. your “home.” But since LOOL is a multi-user application, it’s much more valuable if you can collaborate on the documents you store here. If there’s a file in your account you’d like to work on together with a colleague, you can Share that file and grant that person access to it.

There are two ways to Share a file with a colleague, although all of them have the same affect.

- You can also use the hosting application’s controls for sharing. For example, in the cloud there’s a Share button included in directory listings, as well as one in the hosting application’s top menu when a file is open for editing.
- In addition, when a file is open you can use the application’s File > Share menu item.

Any of these methods will display the Sharing pane, which will prompt you to enter a name, ID, or email address for the desired user. As you type, LOOL will begin searching the directories to which it has access and display any matching names.

Figure 16: selecting the share button in the cloud's files listing
Clicking on the user’s name will add him/her to the document. By default, new collaborators are granted the following permissions:

- *Can edit*
- *Can re-share*
- *Set expiration date*

You’ll also have the ability to leave a *Note* to recipient, or remove the user by selecting *Unshare*.
Multi-User Editing in LibreOffice Online

In addition to merely editing files by yourself, LOOL gives you the ability to collaborate with others on files in real time. When you and a colleague open the same file together on different computers, you’re able to edit the file simultaneously. This multi-user editing is unique to LOOL as an online application and isn’t available in the desktop software.

You don’t need to do anything special to start editing files in a multi-user context. When the user B opens the file in question, the user A will notice another cursor appear. If user A hovers over that cursor with their own cursor, the name of user B will appear at the top.

Multi-editing text documents

![Image of two users editing a text document in LibreOffice Online Documents module]

This is a file in LibreOffice Online Documents. I’m editing this, you can tell by the “regular” cursor.

Another user is editing this file as well. You can tell because the cursor here is a different style, colored and labeled with the user’s name. You can also see this user’s initial in the upper right-corner of the screen.

*Figure 19: Two users editing the same file in the Documents Module*

Multi-editing Spreadsheets

![Image of two users editing a spreadsheet in LibreOffice Online Spreadsheets module]

*Figure 20: Two users editing the same file in the Spreadsheets Module*
Multi-editing presentations

When in multi-editing mode, there are a few important things to bear in mind.

- Multi-editing only works when all users are using LibreOffice Online. In fact, it's not advisable for any users to be working on files in the desktop software while users are making changes in LOOL. This is because the content in LibreOffice proper will reflect it's state when the file was first opened, and it's possible that LOOL users have made changes since then. Then, when the desktop user saves the file, it may contain outdated content that will be written back to the file along with any other changes made.

- If both users are permitted to edit the file (i.e. no one is restricted to “read-only”), then it's entirely possible for them to overwrite each other's changes.

- You'll need to continue to save the file in the normal way... and one user saving the file will also save the other user's edits.

But if you're heedful of these caveats, LOOL provides a very convenient way for a group of collaborators to quickly and easily make changes to documents without the hassle of moving or emailing files back and forth.

Exporting Your LibreOffice Online Files

The File menu in applications also contains the option to export the current file into a variety of formats, dependent on the application:
• You can export files open in the Documents module to .PDF, .ODT, .DOC, .DOCX, or .RTF formats.
• You can export files open in the Spreadsheets module to .PDF, .ODS, .XLS, or .XLSX formats.
• You can export files open in the Presentations module to .PDF, .ODP, .PPT, or .PPTX formats.

![Figure 22: Download as options in the Spreadsheets module](image)

**Note: Revising exported files**

Note that once you export a file in a particular format, it is separated from its source document in LOOL. You can make revisions to it in other software (including LibreOffice, a competing desktop office suite, or another online application), but these changes will not be reflected in the file in LOOL unless you re-upload it and overwrite the existing file.

### Printing from LibreOffice Online

You can print a file from LibreOffice Online using one of two methods:

- You can use LOOL’s built-in printing function, or;
- You can download the file in a suitable format and print it using a desktop application.

If you choose the former, it’s important that you access this function through either the Print button on the main Toolbar, or the File > Print menu item.

**Warning: Using the Browser’s Print Function**

If you use the popular Ctrl-p keystroke to print a particular document, it's possible you'll actually invoke your browser's print function. The purpose of this function is to print the entire web page, which as it pertains to LOOL includes not only your document's content, but also elements like menus and headers. Your Print Preview should tell you whether you've accidentally printed this way so you can cancel the operation.
What is the Text Documents Module Used For?

The Text Documents module is an online word processor, which you can use to create all sorts of text-based works. These include letters, reports for school or business, novels, essays, and other works of non-fiction. In fact, this very book was created in part in LibreOffice Online!

In a more technical sense, your hosting application will use the Text Documents module to display supported word processing file formats including the following:

- The OpenDocument Text file formats (including documents, .ODT, and templates, .OTT)
- Microsoft Word file formats (including documents, .DOCX/.DOC, and templates, .DOTX/.DOT)
- Rich Text file format (.RTF)

The Text Documents Module Interface

The main Text Documents Module workspace is shown below. The menus and toolbars are described in Chapter 1, Introducing LibreOffice Online. Some other features of the Text Documents interface are covered in this chapter.

![Figure 23: the text documents module window](image)

The Documents window has two main sections: the **Toolbar** at the top, and the **Status Bar** at the bottom.
Documents Toolbar

The Toolbar appears at the very top of the application window, just under the hosting application’s icons.

![Document Toolbar Image]

**Figure 24: The Documents Module Toolbar**

The Toolbar contains the following entries:

**File:**
Contains commands that apply to the entire document; for example, Save, Download As, Print, See Revision History, and Close Document.

**Edit:**
Contains commands for editing the document; for example, Undo, Copy, Paste, Track Changes, Find and Replace, and Edit Style.

**View:**
Contains commands for modifying how the Documents user interface looks; for example, Full Screen, Zoom, and Formatting Marks.

**Insert:**
Contains commands for inserting elements into a document; for example, Image, Special Characters, Charts, Comments, Hyperlinks, Headers and Footers, Fields, Page/Section/Column Breaks, Links, and more.

**Format:**
Contains commands for modifying the layout of a document; for example, Text and its Orientation, Spacing and Alignment, Lists, Character/Paragraph/Page/Bullets and Numbering styling, Watermarks, and Columns.

**Table:**
Contains commands to Insert, Delete, or Select Tables/Columns/Rows/Cells, Merge Cells, or adjust a Table’s Properties.

**Tools:**
Contains various functions to help you check and customize the Document; for example, Spelling, Language settings, and a Word Count function.

**Help:**
Contains a list of the LibreOffice Online Keyboard Shortcuts and information About the application, such as version number.
**Documents Status Bar**

The Writer Status Bar provides information about the document and convenient ways to change some document features quickly.

*Figure 25: the documents module status bar*

**Search**

The lower-left corner has a search box. Typing a search term will highlight its first occurrence, and provide a count of any additional occurrences.

**Page number**

Shows the current page number, the sequence number of the current page (if different), and the total number of pages in the document. For example, if you restarted page numbering at 1 on the third page, its page number is 1 and its sequence number is 3.

If any bookmarks have been defined in the document, a right-click on this field pops up a list of bookmarks; click on one to go to that location.

To jump to a specific page in the document, double-click on this field. The Navigator opens. Click in the Page Number field and type the *sequence* number of the required page and press Enter.

**Word and character count**

The word and character count of the document is shown in the Status Bar, and is kept up to date as you edit. When text is selected, the word and character counts for the selection will appear here.

To display extended statistics such as character counts that exclude spaces, double-click the word count in the Status Bar, or choose **Tools > Word Count**.

**Selection mode**

Displays the current selection mode.

**Language**

Shows the language at the cursor position, or for the selected text, that is used for checking spelling and grammar as well as for hyphenation and thesaurus dictionaries.

**Zoom**

To change the view magnification, drag the Zoom slider, or click on the + and – signs, or right-click on the zoom level percent to pop up a list of magnification values from which to choose. Zoom interacts with the selected view layout to determine how many pages are visible in the document window.
Adjusting the View of the Document

As mentioned, the Status Bar contains controls to zoom into and out of the document, set the Zoom level to a specific level (e.g. 150%, 200%, etc.), and reset it to its default level. You can also Zoom In, Zoom Out, and Reset zoom from the View menu.

This menu has two additional options, the first of which is Full Screen. While the desktop version of LibreOffice has a similar function, in LOOL this will instead invoke the Full Screen mode of the browser you're using. In order to return to the normal viewing mode, you should use whichever command your browser requires (for example, in Google Chrome it's the Esc key).

The other View option in LOOL is Formatting Marks. This will display non-printing characters such as spaces, line returns, and section breaks in your document. Showing Formatting Marks can be useful while troubleshooting layout issues.

![Figure 26: Formatting marks for paragraphs, tabs and spaces. Page margins are also displayed.](image)

Note: No View Controls on the Main Toolbar

Like the desktop version of LibreOffice, LOOL doesn't include View-related buttons on the Toolbar by default. However, LOOL cannot be customized to include them in the same way LibreOffice can.

Working with Text

The following sections will describe some of LOOL's basic text editing and formatting features. By and large, tasks you can accomplish in the desktop version of LibreOffice or other comparable programs will function the same way in LOOL. The main difference is that LibreOffice Online supports only a subset of the features of desktop applications.

Cutting, copying, and moving text

Selecting, copying, pasting, or moving text in Writer is similar to working with text in other programs. LibreOffice also has some convenient ways to select items that are not next to each other.

Cutting and copying text in Documents is similar to cutting and copying text in other applications. You can use the mouse or the keyboard for these operations. You can copy or move text within a document, or between documents, by dragging or by using menu selections, toolbar buttons, or keyboard shortcuts. You can also copy text from other sources such as Web pages and paste it into a Writer document.

To move (drag and drop) selected text using the mouse, drag it to the new location and release it. To copy selected text, hold down the Ctrl key while dragging. To move (cut and paste) selected
text, use Ctrl+X to cut the text, insert the cursor at the paste-in point and use Ctrl+V to paste. Alternatively, use the buttons on the Edit menu to Cut, Copy, and Paste text.

⚠️ Warning: Pasting from external sources may not retain all formatting

As with many web-based applications, when you paste content that you copied from external sources (whether other applications or even other browser tabs or LOOL documents), not all of your formatting may carry over. While some simple styling such as bolding or italics may show up properly, other more important styling like font may default to LibreOffice Online’s current configuration.

One difference you may notice is the inclusion of handles on either side of the selected content. These help users on mobile devices by long-pressing to select an initial word, then dragging the handles to surround the desired content. You can also use the mouse to click-and-drag handles once you’ve selected some text.

Direct Formatting vs. Styles Formatting

There are two basic ways to format text. Understanding these two alternatives is essential for unlocking the power of LibreOffice:

**Direct (or Manual) formatting**
- Applies formatting directly to specific paragraphs, characters, pages, frames, lists, or tables. For example, you can select a word, then click on a button on the Formatting toolbar to format the text as bold or italics.

**Styles**
- Bundles formatting options under one name. For example, a paragraph style defines numerous settings for options such as font type and size, whether paragraphs should be indented, the space between lines, how paragraphs should be aligned on the page, and many others.

LOOL Documents is modeled after LibreOffice’s Writer application, which is designed to be a style-based program. This means that it may work somewhat differently from other word processing programs you are familiar with. It requires some planning but the time spent in planning can save time and frustration over the longer term.

Because styles apply whole groups of formats at the same time, they enable you to easily format a document consistently and to change the formatting of an entire document with minimal effort. In addition, styles are used by LibreOffice for many processes, even if you are not aware of them. For example, Writer relies on heading styles (or other styles you specify) when it compiles a table of contents.
**Styles support in LOOL**

There are a couple of important gaps between LibreOffice Writer and LOOL Documents with regard to Style management. Firstly, support for paragraph and page styles—there is not yet support for character or list styles—is limited to the existing styles in the document. You cannot create a new paragraph or page style:

- To edit a paragraph style: use the menu **Edit > Edit styles**
- To edit a page style: use menu **Format > Page**

![Note: Documents' Styles Functionality is a Subset of Writer's](image)

While it is still recommended that you use Styles in your LOOL Documents files, it's important to keep in mind that the Styles capabilities of LOOL Documents are a subset of those available in LibreOffice. You should plan out and implement your styles in LibreOffice prior to uploading and opening your document with LOOL.

**Direct Formatting**

If you’re looking to get started quickly with simple documents, you can just use Direct Formatting on your text.

**Formatting Paragraphs directly**

To manually apply many direct formats to paragraphs, use the buttons on the Toolbar or the entries in the **Format** menu.

![Figure 28: paragraph options in the format > spacing sub-menu](image)

These buttons and formats include:

- Set Paragraph Style (Toolbar drop-down list)
- Bullets On/Off (Toolbar button or **Format > Lists**)
- Numbering On/Off (Toolbar button or **Format > Lists**)
- Align Left, Center Horizontally, Align Right, or Justified (Toolbar button or **Format > Align**)
- Align Top, Center Vertically, Align Bottom (Toolbar button or **Format > Align**)
- Line Spacing (choose from 1, 1.15, 1.5, 2, or custom spacing (Toolbar button or **Format > Spacing**)

44 | Direct Formatting vs. Styles Formatting
• Increase Paragraph Spacing, Decrease Paragraph Spacing (Toolbar button or Format > Spacing)
• Increase Indent, Decrease Indent (Toolbar button or Format > Spacing)

The Format menu also contains a Paragraph entry. Selecting this will display a dialog with a large range of formatting options.

![Figure 29: LOOL documents’ paragraph formatting dialog](image)

**Formatting Characters Directly**
As with Paragraphs, the text itself can be styled using Toolbar buttons or entries in the Format menu.
These buttons and formats include:

- Font Name, Font Size (Toolbar controls, or Increase/Decrease Size in Format > Text)
- Bold, Italic, Underline, Overline, Double Underline, Strikethrough, Outline (Toolbar controls, or Format > Text)
- Superscript, Subscript (Format > Text)
- Uppercase, Lowercase (Format > Text)
- Font Color (Toolbar control)
- Background Color (Toolbar control)

The Format menu also contains a Character entry. Selecting this will display a dialog with a large range of formatting options.
Figure 31: LOOL documents' character formatting dialog

**Formatting Bulleted/Numbered Lists Directly**

Options for formatting Bulleted or Numbers Lists are set in using the **Bullets and Numbering** entry in the **Format** menu.
This displays a dialog with options, including:

- **Setting the symbol used for the Bullets**
- **Numbering** format (e.g. letters, Roman numerals, etc.)
- **Outline** format (e.g. “1.(a).i,” “1.2.5.3,” etc.)
- **Image**-based bullets
- **Position** settings (e.g. Level 1 has a 0.5” indent, Level 2 a 1.0” indent, etc.)
- The ability to completely **Customize** the current list (such as with text to come before or after the number)

**Formatting Pages Directly**

Page-related options are available from the Page dialog in the **Format** menu.
Figure 33: LOOL documents’ page formatting dialog

The Page Formatting Dialog contains options for:

- Selecting the Page Style from the Organizer
- Setting standard Page options (e.g. size, margins, orientation, etc.)
- Setting Area background, e.g. a color, gradient, or bitmap image
- Setting the Transparency for the Area
- Enabling/disabling the Header and Footer, and setting height, margins, and spacing
- Configuring the Borders for Pages
- Setting the number of Columns (also available from Format > Columns)
- Configuring Footnotes, such as position, alignment, and spacing

The Format menu also contains one other Page-related setting, Watermark. This allows you to configure an image to be shown as though imprinted in the page.
Welcome to Nextcloud, your self-hosted file sync and share solution.

Nextcloud is the open source file sync and share software for everyone from individuals to large enterprises and service providers. Nextcloud provides a safe, secure and compliant file sync and share solution on servers you control.

With Nextcloud you can share one or more folders on your PC, and sync them with your Nextcloud server. Place files in your local shared directories, and those files are immediately synced to the server, and then to other PCs via the desktop client. Not near a desktop client? No problem, simply log in with the web client and manage your files there. The Android and iOS mobile apps allow you to browse, download and upload photos and videos.

Whether using a mobile device, a workstation, or a web client, Nextcloud provides the ability to put the right files in the right hands at the right time on any device in one simple-to-use, secure, private and controlled solution.

All example pictures & music are licensed under Creative Commons Attribution.

Figure 34: document watermarked with the word “draft”

Removing direct formatting

To remove direct formatting, select the text and choose Format > Clear Direct Formatting from the Menu bar, or Clear Direct Formatting button on the Formatting toolbar, or press Ctrl+M on the keyboard.

Note

When clearing direct formatting, the text formatting will return to the applied paragraph and character style and not the Default paragraph style or Default character style (unless these styles are actually applied to the text).

Revisiting Styles

In general, Styles in the LibreOffice applications are collections of formatting applied together. Desktop LibreOffice programs have six types of styles: Paragraph, Character, Page, Frame, List, and Table. However, LOOL currently supports only page and paragraph styles, which affects blocks of text between line returns. You can adjust the elements used in the other types of Styles within LOOL Documents where they exist, but you must do so using Direct Formatting.
Tip: Paragraph Styles Contain Character and List Elements

While you can't create stand-alone Styles for passages of text (Character Styles) or bulleted/numbered lists (List Styles), you can use Paragraph Styles to apply your desired font, bolding/italics, or outline numbering. But note it will apply to the entire block of text (until the next line return) unless you adjust the formatting directly.

Applying (Paragraph) Styles

You can apply styles to paragraphs using the Styles drop-down selection list at the left end of the Toolbar.

Figure 35: Styles Selection in the Toolbar

Tip

You can use keyboard shortcuts Ctrl+1 to Ctrl+3 to apply paragraph styles Heading 1 to Heading 3, just like LibreOffice Writer. You can also use Ctrl+0 to return to the default style (usually Text Body).

Modifying Styles

You can adjust the settings for the Style of the current paragraph by selecting the Edit > Edit Style menu item. This will display a multi-tabbed dialog that will be familiar to users of the desktop programs.
The options in this dialog are identical to those available in Writer’s dialog. And like Writer, updating a Style here will apply those changes everywhere the Style is used throughout the current document.

Tip: Some Unavailable Style Options Are Available as Part of a Style

Another reason to favor Styles over Direct Formatting in LOOL Documents is that the former actually provides more options. A number of the options within the tabs in the above screenshot aren’t available from the Main Menu. For example, you cannot configure a Paragraph to Keep with next paragraph anywhere in the Format menu in LOOL, you can set this as part of a Style in the Text Flow tab in the Edit Style dialog.

Structuring Your Documentation

There are several Styles in default LOOL Documents that deserve special attention: Headings. While these are Paragraph Styles in the sense they are applied to blocks of text, they also have some other specific properties.

They will include not only text (e.g. font, color, spacing, etc.) properties, but also Numbering properties. The below screenshot shows the default **Heading 1** Style, which includes an increased (130%) font size and bold decoration, as well as a **Numbering(Outline)** Style. Outline is specified here so sub-headings (i.e. Heading 2 and Heading 3) can be set as children of the top-level Heading 1.
Once you've applied some Heading Styles to your document, you can very easily generate a Table of Contents. It will follow the structure you created by using first, second, and third level Heading Styles, and will automatically update based on changes you may make.

**Inserting Graphics & Other Items**

Cover inserting pictures, tables, special characters, shapes, and fields.

**Inserting Special Characters**

A special character is one not found on a basic English keyboard. For example, © ¾ æ ç Ł Ń ō ø ç are all special characters. To insert one or more special characters:

1) Place the cursor in the document where you want the characters to appear.
2) Click **Insert > Special Character** or click the Special Character icon in the main toolbar to open the Special Characters dialog.
3) Double-click the characters (from any font or mixture of fonts) you wish to insert, in order; they appear in the document as you select them. The selected characters are also added to the Recent Characters list on the lower left of the dialog.

**Tips**

To view details of a character, single-click it; it is then shown on the right, along with its numerical codes.
To insert a character and leave the dialog open, double-click the character. To insert a character and close the dialog, click it and then click the **Insert** button.

Different fonts include different special characters. If you do not find a particular special character you want, try changing the **Font** selection.

**Inserting and Styling Tables**

Before you insert a table into a document, it helps to have an idea of the visual result you want to obtain as well as an estimate of the number of rows and columns required. Every parameter can be changed at a later stage; however, thinking ahead can save a large amount of time as changes to fully formatted tables often require a significant effort.

![Figure 38: the insert table button on the toolbar](image)

To directly insert a table with the default properties, click the **Table** icon on the Standard toolbar. On the drop-down graphic, choose the size of the table (up to fifteen rows and up to ten columns). To create the table, click the cell that you want to be on the last row of the last column. Holding down the mouse button over the Table icon will also display the graphic.

To use a dialog where you can refine the properties for the table, position the cursor within the table to appear, then choose **Table > Properties** from the Menu bar to open the dialog.
This dialog contains the following tabs:

- **Table:** This allows you to change the name and adjust the spacing or alignment of the table overall.
- **Text Flow:** The Text Flow tab allows you to control options such as whether the table is allowed to break across pages.
- **Columns:** You can specify the width of columns on this tab.
- **Borders:** Set the borders as well as their styling (e.g. color) and spacing on this tab.
- **Background:** A Background can be a color or picture, and can apply to the current cell, row, or entire table.

**Inserting Pictures and Graphics**

You might create images (also called 'pictures' in LOOL) using a graphics program, scan them, or download them from the Internet (make sure you have permission to use them), or use photos.
taken with a digital camera. LOOL supports raster (bitmap) file formats, the most common of which are GIF, JPG, PNG, and BMP.

You can insert an image into your document in one of two ways:

- To use an image that's already in the hosting application, use the Insert Local Image option (either the Toolbar, or the Insert > Insert Local Image menu option).
- Alternately, upload it directly from your PC (by using the Insert Image option from the Toolbar, or the Insert > Insert Image menu option)

For best results:

- Create images that have the exact dimensions required for the document, or use an appropriate graphics package to scale photographs and large drawings to the required dimensions. Do not scale images with Writer, even though Writer has tools for doing this, because the results might not be as clear as you would like.
- Do any other required image manipulation (brightness and contrast, color balance, cropping, conversion to grayscale, and so on) in a graphics package, not in Writer, even though Writer has the tools to do a lot of these things too.
- If the document is meant for screen use only, there is no need to use high resolution images of 300 or more dpi (dots per inch). Most computer monitors work at between 72 and 96 dpi; reducing the resolution (and the file size) has no negative impact on what is displayed.

You can also insert charts into your document using the Insert Chart Toolbar button (or the Insert > Chart menu option) or a selection of shapes using the Insert Shapes Toolbar button.

Inserting and Controlling Fields

Fields are data elements you can insert into your document that will get updated automatically. For example, if you insert the Date field, it will automatically display the current date (as opposed to inserting a date like “Nov. 29, 2019” manually, which will not update on a later date.

You can use the Insert > More Fields menu option to insert one of the following elements into your document:

- Page Number (the auto-calculated number of the current page)
- Page Count (the auto-calculated number of total pages in the document)
- Date (the current date)
- Time (the current time)
- Title (the title of the document, as configured in its Properties)
- First Author (the name of the first author listed in the document’s Properties)
- Subject (the subject of the document, as configured in its Properties)

Specifying Your Document’s Layout

Page Properties

Every page in LOOL Documents is based on a page style. Pages styles define basic layout, including page size, margins, headers and footers, borders, backgrounds, etc. Changes to these settings automatically change the page style. This means that, in contrast to paragraph styles, these settings cannot be used to directly format individual pages.

To adjust the style of the current Page, select the Format > Page option from the Menu. This will display the Page Style dialog.
As with other styles, Writer comes with a number of page styles. You can modify these styles or create new ones. The Default page style is used when no other page style has been specified.

**Tip**

Page layout is usually easier if you show text, object, table, and section boundaries in View > Formatting Marks.

**Headers and Footers**

You can insert a header in several ways. The easiest is to select one of the options in the Insert > Headers and Footers > Header sub-menu. One of these will be All, meaning all your Page Styles will receive a Header. The other will be the name of the Style of the current Page, and Headers will only appear on Pages using that Style. You can likewise insert a Footer by selecting one of the options in Insert > Headers and Footers > Footer.
Figure 41: the headers and footers sub-menu

After a Header/Footer has been created, you can click inside it to edit its content. You'll be able to tell you're in the region when the markers appear at all four corners, as shown in Figure

This is some header text.  
This is some text.

Figure 42: Header menu

Determining Header and Footer appearance

To format a Header (use similar settings for a Footer), you can go to the Header or Footer tab in the Format > Page dialog. Both methods take you to the same place.

Here you can specify if Headings on Pages using the Left and Right Page Styles should be the same or different. You can also specify whether the First Page will have no header or a different header than other pages. Finally, in this dialog you can turn the Header on or off, set the margins, and set the spacing between the Header and document text.

Numbering Pages

To display page numbers automatically:

1) Insert a header or footer, as described in “Headers and Footers” above.
2) Place the cursor in the header or footer where you want the page number to appear and choose Insert > More Fields > Page Number.
Footnotes/Endnotes

LibreOffice Online Documents supports both types of citations: Footnotes (which appear at the bottom of the current page) and Endnotes (which appear together at the end of the document). You can insert them by placing the cursor at the end of the passage of text you'd like to cite (or select it), and select Insert > Endnote or Insert > Footnote from the Menu.

Footnotes will go on the same page

Figure 43: Footnotes versus Endnotes

Hyperlinks

The Documents module supports creating Hyperlinks to external resources, such as web pages or email addresses. You can insert a Hyperlink by optionally selecting some existing text, but otherwise placing your cursor where you'd like the link to appear, then pressing Ctrl-k on the keyboard or selecting the Insert > Hyperlink option from the Menu.

Figure 44: The Hyperlink Dialog
Writing Tools

Spell Checking & Autocorrect

LOOL has support for spell-checking, which you can run by selecting the Tools > Spelling option from the main Menu. There is an option to automatically identify misspelled words (Tools > Automatic Spell Checking) as well.

Language Setup

Many of the features in the following sections rely on your document’s Language. So be sure you’ve set it correctly. You can change the Language for selected text, the paragraph containing the cursor, or the current document in its entirety using the options in the Tools > Language sub-menu.

Tip: Checking the Current Language

You can check the Language in use where the cursor currently resides by looking in the Status Bar at the bottom of the screen, next to the Selection Type.
**Word Count**

The Documents module will keep track of the number of words in the current file, which you can see by selecting the **Tools > Word Count** option from the Menu.

![Word Count Menu](image)

This total is also available in the Status Bar, to the right of the Page Number.

**Tip: Word Count of Selected Text.**

If there is text currently selected, the Word Count Dialog will also display this, while the Status Bar will show the stats for the selection instead of the entire document.

**Review & Comments**

Authors and reviewers often use Comments to exchange ideas, ask for suggestions, or mark items needing attention.

You can connect a Comment to multiple paragraphs or a single point. To insert a Comment, select the text, or place the cursor in the place the comment refers to. Then either choose **Insert > Comment**, click the **Insert Comment** button on the Toolbar, or press `Ctrl+Alt+C`. The anchor point of the Comment is connected by a line to a box on the right-hand side of the page where you can type the text of the Comment.
Figure 48: The Insert Comment button and Comment overflow menu

You can navigate through the comments using the keyboard. Use Ctrl+Alt+Page Down to move to the next comment and Ctrl+Alt+Page Up to move to the previous comment. For each Comment, you have the option to Modify it, Reply to it, or Remove it from the file by using the overflow menu (the three vertical dots) in its upper-right corner.

Tracking changed in the document

You can use the Document Module’s change marks (often called “redlines” or “revision marks”) to show added or deleted material or changed formatting. Later, you or another person can review and accept or reject each change.

Note

Not all changes are recorded. For example, changing a tab stop from align left to align right and changes in formulas (equations) or linked graphics are not recorded.

When you send a document to someone else to review or edit, you may want to prepare it first so that the editor or reviewer does not have to remember to turn on the revision marks. After you have protected the document, any subsequent user must enter the correct password in order to turn off protection or accept or reject changes.

1) Open the document. Check whether it contains multiple versions by clicking File > Versions. If multiple versions are listed, save the current version as a separate document with a different name and use this new document as the review copy.

2) With the review copy open, make sure that change recording is turned on. The Edit > Track Changes > Record menu item has a check mark next to it when recording is turned on.
Now, when you make a change such as removing text, it isn’t deleted immediately. It will be marked with colored text. In addition, a box will appear in the right-hand margin (much like comments) describing what change was made, and by whom.

To accept or reject recorded changes, use any of these tools:

- The Previous, Next, Accept All, and Reject All entries in the Edit > Track Changes sub-menu
- Manage Changes dialog (accessible from Edit > Track Changes > Manage)
- The Accept and Reject buttons in the boxes in the right-hand margin

The results of accepting or rejecting a change are as follows:

- Accept: incorporates the alteration into the document and removes the change indication marking.
- Reject: reverts the document to its original state and removes the change indication marking.

**Figure 49: A Tracked Change, and its accompanying details**
Chapter 7
The Spreadsheets Module
What is the Spreadsheets Module Used For?

The Spreadsheets module in LOOL allows you enter data (usually numerical) and then manipulate this data to produce certain results. This includes changing the data in a “What if...” manner and observing the results.

Other features provided by the Spreadsheets module include:

- Functions, which can be used to create formulas to perform complex calculations on data.
- Database functions, to arrange, store, and filter data.
- Dynamic charts; a wide range of 2D and 3D charts.

The Spreadsheet Module Interface

The Spreadsheets window has five main sections: the Toolbar at the top, the Formula Bar just beneath it, the main Workspace grid, the Sheet Tabs beneath the main spreadsheet table, and the Status Bar at the very bottom.

Toolbar

The Spreadsheets Toolbar contains the following entries:

File:

- Contains commands that apply to the entire document; for example, Save/Save As, Share, Print, See Revision History, and the Download as sub-menu.
**Edit:**
Contains commands for editing the document; for example, *Undo/Redo, Copy, Paste, Select All,* and *Find and Replace.*

**View:**
Contains a command to view Spreadsheets in *Full Screen.*

**Insert:**
Contains commands for inserting elements into a spreadsheet; for example, *Images (Local or within the hosting application), Special Characters, Charts, Comments, Hyperlinks,* and *Headers and Footers.*

**Format:**
Contains commands for modifying the layout of a spreadsheet; for example, *Cell styling, Page styling,* and *Conditional Formatting* (in addition to the option to *Clear Direct Formatting*).

**Sheet:**
Contains the most often used commands for handling sheets, such as *Insert* and *Delete Columns, Rows and Page Breaks,* in addition to deleting these same items.

**Data:**
Contains commands for manipulating data in the spreadsheet; for example, *Sort, Filters,* and *Groups and Outlines.*

**Tools:**
Contains various functions to help you check and customize the spreadsheet; for example, *Spelling, Language,* and *Goal Seek.*

**Help:**
Contains a list of the LibreOffice Online *Keyboard Shortcuts* and information *About* the application, such as version number.

**Formula Bar**
The Formula Bar (Figure 51) is located at the top of the sheet in the Calc workspace. The Formula Bar is permanently docked in this position and cannot be used as a floating toolbar. If the Formula Bar is not visible, go to *View* on the Menu bar and select *Formula Bar.*

![Figure 51: the spreadsheets module formula bar](image)

From left to right, the Formula Bar consists of the following:

**Name Box:**
This gives the current active cell reference using a combination of a letter and number, for example A1. The letter indicates the column and the number indicates the row of the selected cell. If you have selected a range of cells that is also a named range, the name of the range is shown in this box. You can also type a cell reference in the Name Box to jump to the referenced cell. If you type the name of a named range and press the *Enter* key, the named range is selected and displayed.

**Sum:**
Clicking on the Sum icon totals the numbers in the cells above the selected cell and then places the total in the selected cell. If there are no numbers above the selected cell, then the cells to the left are totaled. When the Sum icon is used, Calc suggest the range to sum with a colored box, but does not insert the formula. You need to confirm the suggested range by...
typing Enter, or reject pressing Esc. You can also adjust the range with the mouse by dragging the colored box or its edges to adjust the range.

**Function:**
Clicking on the Function icon inserts an equals (=) sign into the selected cell and the Input line, allowing a formula to be entered. When in this mode, the Sum button above will change to a Cancel button with red “x” clear the formula entry, and this Function button will change to an Accept button with a check mark to accept it.

**Input line:**
Displays the contents of the selected cell (data, formula, or function) and allows you to edit the cell contents.

You can also edit the contents of a cell directly in the cell itself by double-clicking on the cell.

---

**Note**

In a spreadsheet the term “function” covers much more than just mathematical functions. See the *Calc Guide Chapter 7 Using Formulas and Functions* for more information.

---

**Sheet navigation/Sheet Tabs**

Each sheet in a spreadsheet is independent of the other sheets, though references can be linked from one sheet to another. There are three ways to navigate between sheets in a spreadsheet:

- **Using the keyboard:** Use key combinations Ctrl+Page Down to move one sheet to the right and Ctrl+Page Up to move one sheet to the left.
- **Using the mouse:** Click on one of the sheet tabs at the bottom of the spreadsheet to select that sheet.
- Using the pager buttons: There are four buttons to the left of the Sheet Tabs that can move the tabs into view (Figure 54).
  - The left-most button moves you to the first Sheet in the spreadsheet.
  - The second button moves you one Sheet back in the spreadsheet.
  - The third button moves you one Sheet forward in the spreadsheet.
  - The fourth button moves you to the last Sheet forward in the spreadsheet.

---

*Figure 52: the spreadsheet module’s sheet tabs*

**Note**

When you insert a new sheet into a spreadsheet, Spreadsheets automatically uses the next number in the numeric sequence as a name. Depending on which sheet is open when you insert a new sheet, and the insertion method you use, the new sheet may not be in its correct numerical position. It is recommended to rename sheets in a spreadsheet to make them more recognizable.

---
Spreadsheets Status Bar

Search
The lower-left corner has a search box. Typing a search term will highlight its first occurrence, and provide a count of any additional occurrences.

To jump to a specific page in the document, double-click on this field. The Navigator opens. Click in the Page Number field and type the sequence number of the required page and press Enter.

Sheet location and count
The total number of Sheets, as well as the current active Sheet shown in the Status Bar and kept up to date as you edit.

Selection count
When cells are selected, the column and row counts for the selection will appear here.

Language
Shows the language at the cursor position, or for the selected text, that is used for checking spelling and grammar as well as for hyphenation and thesaurus dictionaries.

Click to open a menu where you can choose another language for the selected text or for the paragraph where the cursor is located. You can also choose None (Do not check spelling) to exclude the text from a spelling check or choose More to open the Character dialog. Any directly formatted language settings can be reset to the default language from this menu.

Selection mode
In the future you'll click to choose different selection modes here. But these are not yet supported as of the current version of LOOL (6.3).

Zoom
To change the view magnification click on the + and – signs, or right-click on the zoom level percent to pop up a list of magnification values from which to choose. You can reset the zoom level with the left-most button (the magnifying glass).

Navigating in the Spreadsheets Module

Cell navigation

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td>12</td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td>23</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td></td>
<td>34</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td></td>
<td>45</td>
<td></td>
</tr>
<tr>
<td>5</td>
<td></td>
<td>56</td>
<td></td>
</tr>
<tr>
<td>6</td>
<td></td>
<td>170</td>
<td></td>
</tr>
<tr>
<td>7</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>8</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Figure 53: A selected cell in the Spreadsheets Module

When a cell is selected or in focus, the cell borders are emphasized. When a group of cells is selected, the cell area is colored. The color of the cell border emphasis and the color of a group of selected cells depends on the operating system being used and how you have set up LibreOffice.

Using the mouse:
Place the mouse pointer over the cell and click the left mouse button. To move the focus to another cell using the mouse, simply move the mouse pointer to the cell where you want the focus to be and click the left mouse button.
Using a cell reference:
Highlight or delete the existing cell reference in the Name Box on the Formula Bar. Type the new cell reference of the cell you want to move to and press Enter key. Cell references are case-insensitive: for example, typing either a3 or A3 will move the focus to cell A3.

Using the Enter key:
Pressing Enter moves the cell focus down in a column to the next row. Pressing Shift+Enter moves the focus up in a column to the previous row.

Using the Tab key:
Pressing Tab moves the cell focus right in a row to the next column. Pressing Shift+Tab moves the focus to the left in a row to the previous column.

Using the arrow keys:
Pressing the arrow keys on the keyboard moves the cell focus in the direction of the arrow pressed.

Using Home, End, Page Up and Page Down
- Home moves the cell focus to the start of a row.
- End moves the cell focus to the last cell on the right in the row in the right-most column that contains data.
- Page Down moves the cell focus down one complete screen display.
- Page Up moves the cell focus up one complete screen display.

Keyboard navigation
To navigate a spreadsheet using the keyboard, pressing a key or a combination of keys. For a key combination, press more than one key at the same time. The table below lists the keys and key combinations you can use for spreadsheet navigation in Calc.

Table 1. Keyboard cell navigation

<table>
<thead>
<tr>
<th>Keyboard shortcut</th>
<th>Cell navigation</th>
</tr>
</thead>
<tbody>
<tr>
<td>→</td>
<td>Moves cell focus right one cell.</td>
</tr>
<tr>
<td>←</td>
<td>Moves cell focus left one cell.</td>
</tr>
<tr>
<td>↑</td>
<td>Moves cell focus up one cell.</td>
</tr>
<tr>
<td>↓</td>
<td>Moves cell focus down one cell</td>
</tr>
<tr>
<td>Ctrl+→</td>
<td>Moves cell focus to the first column on the right containing data in that row if cell focus is on a blank cell.</td>
</tr>
<tr>
<td></td>
<td>Moves cell focus to the last column on the right in the same range of occupied cells in that row if cell focus is on a cell containing data.</td>
</tr>
<tr>
<td></td>
<td>Moves cell focus to the last column on the right in the spreadsheet if there are no more cells containing data.</td>
</tr>
<tr>
<td>Ctrl+←</td>
<td>Moves cell focus to the last column on the left containing data in that row if cell focus is on a blank cell.</td>
</tr>
<tr>
<td></td>
<td>Moves cell focus to the first column on the left in the same range of occupied cells in that row if cell focus is on a cell containing data.</td>
</tr>
<tr>
<td></td>
<td>Moves cell focus to the first column in that row if there are no more cells containing data.</td>
</tr>
<tr>
<td>Key Combination</td>
<td>Description</td>
</tr>
<tr>
<td>-----------------</td>
<td>-------------</td>
</tr>
<tr>
<td>Ctrl+↑</td>
<td>Moves cell focus from a blank cell to the first cell above containing data in the same column. Moves cell focus to the first row in the same range of occupied cells if cell focus is on a cell containing data. Moves cell focus from the last cell containing data to the cell in the same column in the first row of the spreadsheet.</td>
</tr>
<tr>
<td>Ctrl+↓</td>
<td>Moves cell focus from a blank cell to the first cell below containing data in the same column. Moves cell focus to the last row in the same range of occupied cells in that column if cell focus is on a cell containing data. Moves cell focus from the last cell containing data to the cell in the same column in the last row of the spreadsheet.</td>
</tr>
<tr>
<td>Ctrl+Home</td>
<td>Moves cell focus from anywhere on the spreadsheet to Cell A1 on the same sheet.</td>
</tr>
<tr>
<td>Ctrl+End</td>
<td>Moves cell focus from anywhere on the spreadsheet to the last cell in the lower right-hand corner of the rectangular area of cells containing data on the same sheet.</td>
</tr>
<tr>
<td>Alt+Page Down</td>
<td>Moves cell focus one screen to the right (if possible).</td>
</tr>
<tr>
<td>Alt+Page Up</td>
<td>Moves cell focus one screen to the left (if possible).</td>
</tr>
<tr>
<td>Ctrl+Page Down</td>
<td>Moves cell focus to the cell on the next sheet to the right in sheet tabs where the focus was there before; if the spreadsheet has more than one sheet.</td>
</tr>
<tr>
<td>Ctrl+Page Up</td>
<td>Moves cell focus to the cell on the next sheet to the left in sheet tabs where the focus was there before; if the spreadsheet has more than one sheet.</td>
</tr>
<tr>
<td>Tab</td>
<td>Moves cell focus to the next cell on the right.</td>
</tr>
<tr>
<td>Shift+Tab</td>
<td>Moves cell focus to the next cell on the left.</td>
</tr>
<tr>
<td>Enter</td>
<td>Moves cell focus down one cell (unless changed by user). See the next topic.</td>
</tr>
<tr>
<td>Shift+Enter</td>
<td>Moves cell focus up one cell (unless changed by user).</td>
</tr>
</tbody>
</table>

## Adjusting the View of the Spreadsheet

There are two primary ways to adjust the view within the Spreadsheets module. The first is to use the View > Full screen menu option.

The second is to use the Zoom controls at the bottom-right of the application window (the right-side of the Status Bar).

### Application Zoom vs. Browser Zoom

In many applications, the Ctrl+ and Ctrl-- keystrokes will zoom the application in and out, respectively. However, since LibreOffice Online is a web application, using these keystrokes will adjust the browser’s zoom level, not LOOL’s. While the affect may be similar, it can also cause inconsistent behavior. For a more consistent experience, consider using just the commands described above.
Working with Sheets and Cells

Individual cells

The main section of the workspace in the Spreadsheets Module displays the cells in the form of a grid. Each cell is formed by the intersection of one column and one row in the spreadsheet.

At the top of the columns and the left end of the rows are a series of header boxes containing letters and numbers. The column headers use an alpha character starting at A and go on to the right. The row headers use a numerical character starting at 1 and go down.

These column and row headers form the cell references that appear in the Name Box on the Formula Bar. If the headers are not visible on the spreadsheet, go to View on the Menu bar and select Column & Row Headers.

Sheet tabs

In Calc, you can have more than one sheet in a spreadsheet. At the bottom of the grid of cells in a spreadsheet are Sheet Tabs indicating how many sheets there are in the spreadsheet. Clicking on a tab enables access to each individual sheet and displays that sheet. An active sheet is indicated with a white tab.

Right-clicking on the tab gives you a number of options, as follows:

- Insert sheet before this
- Insert sheet after this
- Delete Sheet
- Rename Sheet
- Show Sheet
- Hide Sheet

When selecting Hide Sheet, the tab representing the sheet will disappear. However the sheet, and all the data it contains, still exists. You can select Show Sheet and select the desired sheet to make it appear among the tabs again.

Basic Formulas

In addition to entering data values into cells, you can also enter formulas that perform calculations for you. For example, to add the contents of cells A1 and A2, you'd take the following steps:

1. Place the cursor in another cell, e.g. A3.
2. In the Formula Bar, type the following: “=A1+A2”

Beginning a cell’s contents with the equals sign signifies it’s a formula. The remainder of content can contain standard mathematical operators, including:

• Addition (+), subtraction (-), multiplication (*), division (/), and exponents (^)
• Nested statements (i.e. calculations within parentheses) with regular order of operations

The values in a basic formula can be a mix of values and cell references. For example, all of the following are valid cell entries:

• =A3+A4+5
• =(C7-2)*4
• =(A14*(4*D12))^2

When you've finished entering your formula value into the cell, press Enter, or click into another cell. The formula will be updated with its calculated value (or an error, if there’s something wrong). However, when you click back into the cell, you'll notice the formula (not the value) displayed in the Formula Bar, where you can adjust it as needed.

**Updating Formula Results**

When you use cell references within your formulas, you gain the benefit of updating your results automatically when the cell changes. For example:

1. Enter the value “12” in cell A1.
2. Enter the value “15” in cell A2.
3. Enter the formula “=A1+A2” in cell A3. This will give you a result of 27.
4. Change the value of A1 to “15.” You'll see the value in A3 update automatically to “30.”

![Figure 55: the formula bar with cell displaying results](image)

**Copying/Pasting Formulas**

When copying and pasting direct cell values in Spreadsheets, the value pasted is the same as the value copied. However, formulas get modified to match their destination.

For example, if you copy the three cells you entered above and pasted them into Column B, the formula in cell B3 would be “=B1+B2.” Why is this? The intent of this cell is to add the two values above it. So when you paste it into Column B, Spreadsheets saves you the work of having to change the Column references to “B” in this formula.

This is done relative to the source as well. For example, if you had a formula in Cell C3 that contained “=A1/A2,” then if you copied and pasted it to Cell D3 it would contain “=B1/B2.” As the destination is moving one column over, so too will the source data be taken from one column over as well.
Sorting and Filtering Data

One of the main uses of spreadsheets is to take large quantities of data and put them in order (alphabetical or numerical), or to filter out undesired values.

Sorting Data

Several criteria can be used and a sort applies each criteria consecutively. Sorts are useful when you are searching for a particular item and become even more useful after you have filtered data.

Also, sorting is useful when you add new information to your spreadsheet. When a spreadsheet is long, it is usually easier to add new information at the bottom of the sheet, rather than adding rows in their correct place. After you have added information, you then carry out a sort to update the spreadsheet.

Formatting Cells

There are two different ways of formatting cells in LOOL Spreadsheets. You can either format them directly by applying fonts, background colors, etc. Or, you can make their formatting dependent on their contents.

Note: Cell Styles in LibreOffice Online

While LOOL itself doesn’t yet support using Cell Styles, the ones contained in .ODS files you upload will remain intact.

Direct Formatting

You can quickly apply styling changes such as the following by using the buttons on the Toolbar:

- Font face/size
- Bold/italics/underline/strikethrough text
- Font color
- Background color
- Borders
- Merging cells
- Text alignment
- Text Wrapping

Figure 56: direct formatting buttons on the lool spreadsheets toolbar

You can also select Format > Cells from the Menu. This will display a dialog containing all the relevant options for formatting cells, including not only aesthetic styling but also content:

- **Numbers**: This tab allows you to format the content of cells, e.g. to format numbers as a percentage or a date and time, or to simply designate everything as plain text.
- **Font**: Allows you to change the font, size, and language.
- **Font Effects**: Lets you apply decorations such as over/underlining, strikethrough, outlines, Shadow, and font color.
• **Alignment:** You can control the horizontal and vertical alignment, orientation, and wrapping properties of text here.

• **Borders:** Designate borders around and in between cells and set their style, width, color, padding, and shadow on this tab.

• **Background:** You can set a cell's background to be a color from the standard palette, or a custom color in RGB format.

• **Cell Protection:** This tab lets you protect (hide) cells and formulae from display and/or printing.

### Conditional Formatting

You can set up cell formats to change depending on conditions that you specify. Conditional formatting is used to highlight data that is outside the specifications that you have set. It is recommended not to overuse conditional formatting as this could reduce the impact of data that falls outside the specifications that you have set.

#### Note: Conditional Formatting and Autocalculate

Conditional formatting depends upon the use of styles and the AutoCalculate feature must be enabled. If you are not familiar with styles, see Chapter 4 Using Styles and Templates in the Calc Guide for more information.

### Types of conditional formatting

#### Condition

Condition is the starting point when using conditional formatting. Here you can define what formats to use to highlight any data in your spreadsheet that falls outside the specifications that you have defined.

#### Color scale

Use Color scale to set the background color of cells depending on the value of the data in a spreadsheet cell. Color scale can only be used when All Cells has been selected for the condition. You can use either two or three colors for your color scale.

#### Data bars

Data bars provide a graphical representation of data in your spreadsheet. The graphical representation is based on the values of data in a selected range. Click on More Options in the Conditional Formatting dialog to define how your data bars will look. Data bars can only be used when All Cells has been selected for the condition.

#### Icon sets

Icon sets display an icon next to your data in each selected cell to give a visual representation of where the cell data falls within the defined range that you set. The icons sets available are colored arrows, gray arrows, colored flags, colored signs, symbols, bar ratings and quarters. Icon sets can only be accessed when the Conditional Formatting dialog has been opened and All Cells has been selected for the condition.

### Conditional formatting management

You can manage the conditional formatting rules and styles by selecting **Formatting > Conditional Formatting > Manage** from the Menu. This displays a dialog containing all the rulesets you've made, and provides the ability to edit or delete them.
Functions and Advanced Formulas

The simple arithmetic described in the earlier section is only the start of what the Spreadsheets module can do. Much of the power of Spreadsheets is in its Functions, which you can use to build very advanced Formulas.

The basic format of a Function is: FUNCTION(PARAMETER1,PARAMETER2). Here “FUNCTION” is the name of the function, which is usually a short-hand notation for what it does. Within the parentheses are PARAMETERS. Which ones are required, their format, their order, any optional parameters, etc. is specific to the function. A full list of functions supported in LibreOffice Calc can be found in Chapter 17 of the Calc Guide.

Note: LibreOffice Online Function Support

As LOOL is a newer application than LibreOffice Calc, there may be some functions that are supported in the desktop software that aren’t (yet) supported in the online version.

Page Formatting and Printing

As with cell contents the layout for pages in Spreadsheets doesn't yet have full support for the same Style mechanisms as LibreOffice proper. However, you can adjust the format of your files in Spreadsheets by using direct formatting.

Selecting the Format > Page option from the Menu will display a dialog with all the relevant options for formatting pages, including:

Organizer:
This shows you the name of the Style in use at the moment. Note, however, that controls related to this style, i.e. Inherit From, Category, and Edit Style aren’t enabled.

Page:
This tab allows you to adjust the Paper Format (size and orientation), Margins on all sides, the printer’s Paper Tray, Page Layout (e.g. left and right pages, or mirrored layout), Page Numbers, and Table Alignment (i.e. how the table of cells is aligned on the page).

Borders:
Designate borders around the outline of the page and set their style, width, color, padding, and shadow on this tab.

Background:
You can set a cell's background to be a color from the standard palette, or a custom color in RGB format. You can also select an image to serve as the background.

Header:
Set the options for Headers on this page, including whether they appear and where (e.g. left pages, right pages, or both), their margins, spacing, height, and content.

Footer:
As above, but for pages' footers.

Sheet:
Here you can set options for Page Order (i.e. if a sheet is larger than one printed page will allow, if it prints top to bottom or left to right first), as well as Print options such as displaying column/row headers, comments, charts and other objects, or formulae.
Adding Charts and Drawings to Spreadsheets

You can create engaging charts from the data within Spreadsheets, and in addition you can add graphics and other visual aids.

Adding Charts

Charts are built off data in the Spreadsheet, so the first step in inserting a Chart is selecting that data. If you're selecting data that has column and row headers, you can include them in the selection. Then, select Insert > Chart from the main Menu. The Chart Wizard will walk you through the following steps of the process:

1. **Chart Type**: You can pick the type of Chart you want on this step, such as *Column, Pie, Line*, or *XY (Scatter)*.

2. **Data Range**: If you've already selected data prior to launching the Wizard, it should be preselected here. Otherwise you'll be returned to the cell grid where you can select a range, or simply type the range into the *Data Range* box. You can also indicate whether your selected data has labels, and define the series (i.e. is the main axis of your data the columns or the rows?) here.

3. **Data Series**: Based on your selection above, you can customize each series.

4. **Chart Elements**: Select whether you want auto-generated items like a *Title/Subtitle*, labels on the *X axis/Y axis*, grids, and legends here.
5. Click *Finish* to insert your chart.

![Chart Wizard](image1)

**Figure 58**: the chart wizard in the spreadsheets module

**Inserting Graphics**

You can insert graphics in a similar way to Charts, and similar to the way described in the Chapter 5, The Documents Module. Select either **Insert > Local Image** to upload and use an image on your PC, or **Insert > Image** if the image is already uploaded to the hosting application.

![Insert from The Document Foundation Nextcloud](image2)

**Figure 59**: inserting an image from the hosting application
Chapter 8
The Presentations Module
The Presentation Module Interface

The Spreadsheets window has four main sections (Figure 60): the Toolbar at the top, the Slides Pane to the left, the main Workspace, and the Status Bar at the very bottom.

Toolbar

![Image of the Presentations module window]

Figure 60: the presentations module window

The Presentations toolbar contains the following entries:

File:
Contains commands that apply to the entire presentation; for example, Save/Save As, Share, Print, See Revision History, and the Download as sub-menu.

Edit:
Contains commands for editing the presentation; for example, Undo/Redo, Copy, Paste, Select All, and Find and Replace.

View:
Contains commands for modifying how the Presentations user interface looks; for example, Full Screen, Zoom In/Out, and Reset Zoom.

Insert:
Contains commands for inserting elements into a presentation; for example, Images (Local or within the hosting application), Charts, Comments, Hyperlinks, and Headers and Footers.

Format:
Contains commands for modifying the layout of a presentation; for example, Character/Paragraph/Bullets and Numbering styling, Position and Size of inserted objects, and Line and Area styling.
Table:
Contains commands to Insert or Delete Tables/Columns/Rows/Cells and Merge Cells.

Slide:
Contains the most often used commands for handling slides, such as New Slide, Delete Slide, Duplicate Slide, and putting the application into Fullscreen Presentation mode.

Tools:
Contains various functions to help you check and check the presentation; for example, Spelling, and Language.

Help:
Contains a list of the LibreOffice Online Keyboard Shortcuts and information About the application, such as version number.

Slides Pane

The Slides Pane at the left of the application window provides both navigation among the presentation’s slides as well as the ability to add, remove, and duplicate them. Clicking on a slide to make it active and display it in the main Workspace (it will be bordered in black within the Slides Pane).

You can click the buttons at the bottom of the Slides Pane to:

- Put the application into Fullscreen Presentation mode
- Insert Slide after the current slide
- Duplicate Slide, again the currently-selected one
- Delete Slide

Figure 61: The Slide Pane and its controls
Note: Re-Ordering Slides

LibreOffice Online doesn't yet support the ability to re-order slides. If you have a presentation and find you need to re-order your slides, you can open it in LibreOffice Impress on a PC, re-order them, then upload it back to LOOL.

The Presentation Module Status Bar

Search
The lower-left corner has a search box. Typing a search term will highlight its first occurrence, and provide a count of any additional occurrences.

To jump to a specific page in the document, double-click on this field. The Navigator opens. Click in the Page Number field and type the sequence number of the required page and press Enter.

Slide location and count
The total number of Slides, as well as the number of the current active Sheet shown in the Status Bar and kept up to date as you edit.

Language
Shows the language at the cursor position, or for the selected text, that is used for checking spelling and grammar as well as for hyphenation and thesaurus dictionaries.

Click to open a menu where you can choose another language for the selected text or for the paragraph where the cursor is located. You can also choose None (Do not check spelling) to exclude the text from a spelling check or choose More to open the Character dialog. Any directly formatted language settings can be reset to the default language from this menu.

Zoom
To change the view magnification click on the + and – signs, or right-click on the zoom level percent to pop up a list of magnification values from which to choose. You can reset the zoom level with the left-most button (the magnifying glass).

Opening, Saving, and Exporting Files

As with the other LOOL modules, files operations are gathered in File menu.

Viewing the Presentation

In addition to the controls in the Status Bar, the entries in the View menu allow you to Zoom In, Zoom Out, and Reset Zoom level. In addition, Presentations offers a Fullscreen Presentation mode.

In this mode, each slide will take up the entire screen; if the slide’s dimensions are such that it doesn’t fit exactly, it will be displayed re-sized and centered. While in Fullscreen Presentation mode, the following will navigate you through the presentation:

- The Space or the Right Arrow keys will move the presentation forward one slide.
- The Left Arrow key will move the presentation back one slide.
- The Esc key will exit Fullscreen Presentation mode.

Adding to the Slides in a Presentation

When adding a new slide to a presentation In LOOL, it will by default contain two layout items:

- A Text Box at the top where you can add a Title
• A Text Box covering the majority of the screen for your content. By default, it will contain a bulleted list with one blank entry.

Figure 62: the contents of a default new slide

You can select objects within a slide by clicking on them; you’ll know they’re selected when they display handles for resizing and rotation.
You can adjust the width of an object by clicking and dragging one of the handles to the left or right, and the height by moving one of the handles at top or bottom. The handles at the corners will adjust size in both dimensions simultaneously. Pressing the Del key will delete the currently-selected object.

Once an object is selected, pressing the F2 key will put it into editing mode (alternately, you can just begin typing). As you type, the size of the object will grow to accommodate your text. Once you’re finished, click outside the bounds of the object (or press F2 again) to commit the change.

**Adding Other Objects to a Slide**

The Text Box is one of the basic building blocks of a presentation. But LOOL’s Presentations module supports other items you can use to build your presentation, as follows:

- Graphics
- Charts
- Shapes

Graphics and Charts operate just as they do in the Documents and Spreadsheets Modules. Shapes are a type of built-in graphic commonly used in presentations. You can use the Insert Shape button on the main Toolbar to select from among Shapes in the following categories:

- Basic
- Symbols
- Block Arrows
- Stars
- Callouts
- Flowchart
To insert one of these items, select the *Insert Shape* button, then select the Shape you want.

**Figure 64: Insert Shape Options in Presentations**

It will appear on the currently active slide, where you can adjust its properties:

- To move the object, click and drag it with the mouse, or use the **Format > Position and Size** menu item.
- To change the object's *Area* color, *Shadow* style, and *Transparency* settings, use the **Format > Area** menu item.
- To change the color and style of the object’s outline, including width, pattern, arrows, and rounded corners, use the **Format > Line** menu item.
Figure 65: The Area Dialog in the Presentations Module
Chapter 9

Integrating LibreOffice Online with Other Applications
Integrating LibreOffice Online with Other Applications

LibreOffice Online is designed to provide you a functional office package that’s easy to use through your web browser. However, this isn’t the only way you can interact with your LOOL documents. The below sections will detail some of the other protocols available to you.

Warning: Modify Documents Through Multiple Methods

While the below methods provide additional convenience in working with the documents you have stored in LOOL using other tools, some care is required. Some of these will cache or otherwise take the LOOL document’s content “offline,” at least temporarily. If you modify the document using one method without saving it, then modify it using a different method, there is a chance changes will be overwritten. Take care that anyone no one else is editing your documents via WebDAV at the same time you’re editing with LOOL in the browser, for example.

Direct LO Access (Remote Open/Remote Save)

LibreOffice applications have a feature available to set up Remote document repositories, through FTP, WebDAV, and the CMIS open standard services. You can then browse these repositories and open one of the files they contain. We will continue with our use of the cloud as the Remote repository for the below examples.

Warning: Remote Repositories are the Hosting Applications

When you’re working with Remote repositories, you’re interacting with the hosting application for LibreOffice Online. As described earlier in Chapter 1, Introducing LibreOffice Online, the other applications can use LOOL to display the files they contain, but the files themselves reside in that hosting application. If you’re using an application other than the one described below, the precise way to configure your connection may differ.

Configuring a Remote Repository in LibreOffice Desktop

You can start setting up a Remote repository in LibreOffice by selecting either the Open Remote or Save Remote options from the File menu in LibreOffice.
This will launch the *Remote Files* dialog. The first time you launch it, the *Service* drop-down in this dialog will be blank. You can start adding your repositories to LibreOffice by clicking the *Add service* button, then selecting one of the available options:

- Google Drive
- Alfresco
- IBM FileNet
- IBM Connections Cloud
- Lotus Quickr Domino
- Nuxeo
- OpenDataSpace
- OpenTextELS
- SharePoint
- Other CMIS-compatible systems
- WebDAV
- FTP
- SSH
- Windows File Sharing protocol
You can use the WebDAV protocol to connect with the cloud. Note that the other services may have different fields to provide or different/additional steps to complete.

1. First, enter the hostname of your cloud instance in the Host field. This is typically the URL of the host without any sub-directory information.

2. If you'll be connecting to the cloud securely (and you should, unless you're only working inside a private network), mark the Secure connection checkbox. **Note:** this will change your Port by default to 443.

3. You can provide the repository with a name that's easy for you to identify by entering it in the Label field.

4. Finally, you'll need to identify the endpoint for your hosting application. For example, with NextCloud or ownCloud it's "www.example.com/remote.php/webdav/." Since you've already provided the hostname, you'll need to enter just the part that comes after that ("/remote.php/webdav/" in this example) into the Root field.

5. Click OK to create your repository.
Opening/Saving a LOOL Document with LibreOffice

Once your repository is created, you can use the File > Open Remote menu item to browse it and select a file to edit. The Remote Files dialog will display a familiar file-and-folders interface when a repository is selected. You can also switch between repositories using the Service drop-down.
Figure 69: The Remote Files Dialog in LibreOffice

If you begin a file in LibreOffice and want to save it in your hosting application, you can use the File > Save Remote in a similar fashion. Note that files you open from a repository will be saved back there as you work by default, unless you use the Save as option from the File menu.

WebDAV

Use an application like your system file manager to access the WebDAV share for the LOOL's hosting application, and see how to interact with the files there.

In addition to accessing LibreOffice Online files directly, you can set up access to some hosting applications via WebDAV with a file management application.

Note: File Manager WebDAV Support

You will have to confirm that your preferred file manager includes support for the WebDAV protocol to use the method described in this section. The default file managers for desktop operating systems (Windows, macOS, and Linux with the KDE or GNOME desktop) allow you to set up “servers” or other designations for remote file repositories. Refer to the instructions for your preferred file manager to configure this access.

As is the case when accessing directly from LibreOffice, when you use this method you're interacting directly with the selected file on the remote server. When you save changes, they are updated immediately and will overwrite the version of the file currently stored in the repository. You should take the same care to avoid conflicts using this method as you do when you use the Remote Files function in LibreOffice.
The Cloud Sync Desktop Applications

You can use the above methods with any hosting applications you happen to select for use with LibreOffice Online. Some of the hosting apps may also have support for unique ways of interacting with files as well, and most cloud services falls into that category. It offers an application that will synchronize files between the server and our local machine. When you make changes to these, the app will push them to the server. Likewise, if changes are detected on the server, the app will copy them down to your local device.

Installing the Cloud Sync Application

You can download the cloud's application from its website for desktop or mobile OSes and install it in the standard way on your operating system. Installing these applications is outside the scope of this guide, but you can find instructions on the cloud website.

Synchronizing Your Files with the Cloud

Once installed, you can begin syncing files to your local machine by adding a Folder Sync Connection. This is a link between one folder on your local device and your cloud account. Whenever you add, edit, or delete files on one, those changes will be replicated in the other. To add a Folder Sync Connection:

1. If you've just installed the cloud server, you'll be prompted to log in to your first server. Immediately be prompted to add a connection.
   a. If you already have the cloud client installed, you can right-click on the app's system tray icon and select the Settings option. Then click the Add Folder Sync Connection button.

2. Next, you'll select the files you want to sync, and where you want to store them. You can elect to sync everything in your cloud account, or only specified sub-folders.

3. Once you finalize your choices, your local device will begin syncing with the cloud server.

Synchronization means there are copies of the file stored on your device, so you can open and modify them using the LibreOffice desktop suite, or other applications that can read and write OpenDocument Formats. The same caveats that applied to other access methods also apply here as well—take care when modifying files on more than one device using more than one method at the same time.
Mobile Applications

Explore different ways users can access LOOL with mobile devices: in mobile browsers, through LibreOffice Viewer, etc.

Of course, chances are you don’t do all your computing on a computer anymore. You can still work with your LibreOffice Online files on a mobile phone, tablet, or other portable device running iOS or Android. However, it will be in a somewhat more limited capacity.

LibreOffice File Viewer

The Document Foundation has made an official LibreOffice Viewer application available in the Google Play store for Android devices. This app will allow you to view OpenDocument Text (.ODT), OpenDocument Spreadsheet (.ODS), and OpenDocument Presentation (.ODP) files on your device.
This is the Heading 1

This is Heading 2

Welcome to LibreOffice Online, your self-hosted office suite. LOOL is the open source web-based office office suite for everyone from individuals to large enterprises and service providers. It provides a safe, secure and compliant file sync and share solution on servers you control.

*Figure 71: The LibreOffice View Application on Android*

Note, however, that this is a viewer only. You won’t be able to make any edits using this application.

**LibreOffice Impress Remote**

Another application developed by TDF is the Impress Remote. This handy app (available for both Android and iOS) is designed to help you during presentations you make with the Impress component of LibreOffice on the desktop. Once you install it and make the connection to your desktop application, you can use Impress Remote to swipe through your slides as well as view any notes you’ve made for yourself on the current page.
As a web application, you're entirely able to log into your hosting application using your mobile device’s browser (provided it's supported) and use the web interface to edit your files. You may find yourself a little limited in terms of screen real estate, but from a functionality perspective everything that works on a PC should also work on a mobile browser.

Finally, there are applications available for both Android and iOS that allow you to browse WebDAV shares. You can use these to interact with your LOOL files in the same way you can with a desktop machine. Setting up these applications is beyond the scope of this guide, but a search in the Apple or Google stores will provide a list of apps that can connect you to a WebDAV server with your mobile device.
LibreOffice Online

Introduction to LibreOffice Online

About this book:

If you have never used LibreOffice Online before, or you want an introduction to all of its components, this book is for you. Anyone who wants to get up to speed quickly with LibreOffice Online will find this book valuable. You may be new to office software, or you may be familiar with another office suite.

This book introduces LibreOffice Online and its components:
Writer (word processing) - Calc (spreadsheet) - Impress (presentations)

It also covers features common to all components, including styles, templates, printing. Multi user editing, file sharing in the cloud and more.

About the authors:

This book was written by Aaron Peters from the LibreOffice community under the Google Seasons of Documentation program.

A PDF version of this book can be downloaded free from:

About LibreOffice and LibreOffice Online:

LibreOffice is the free, libre, and open source personal productivity suite from The Document Foundation. It runs on Windows, Macintosh, and GNU/Linux. Support and documentation is free from our large, dedicated community of users, contributors, and developers. You too can get involved with volunteer work in many areas: development, quality assurance, documentation, translation, user support, and more.

You can download LibreOffice free from http://libreoffice.org/download/