Draw Guide

6.4
Copyright

This document is Copyright © 2012–2020 by the LibreOffice Documentation Team. Contributors are listed below. You may distribute it and/or modify it under the terms of either the GNU General Public License (http://www.gnu.org/licenses/gpl.html), version 3 or later, or the Creative Commons Attribution License (http://creativecommons.org/licenses/by/4.0/), version 4.0 or later.

All trademarks within this guide belong to their legitimate owners.

Contributors

This book is adapted and updated from Draw Guide OpenOffice.org 3.3.

Contributors

To this edition
Peter Schofield  Claire Wood  Regina Henschel

To previous editions
Martin Fox  John Cleland  Jean Hollis Weber
John A Smith  Peter Schofield  Hazel Russman
Michele Zarri  T. Elliot Turner  Low Song Chuan
Ron Faile Jr.

Feedback

Please direct any comments or suggestions about this document to the Documentation Team’s mailing list: documentation@global.libreoffice.org

Note:

Everything sent to a mailing list, including your email address and any other personal information that is written in the message, is publicly archived and cannot be deleted.

Publication date and software version

Published June 2020. Based on LibreOffice 6.4.

Documentation for LibreOffice is available at http://documentation.libreoffice.org/en/
Contents

Copyright ................................................................................................................................. 2
Preface ...................................................................................................................................... 6
  Who is this book for? ........................................................................................................... 7
  What is in this book? .......................................................................................................... 7
  Where to get more help? .................................................................................................. 7
  What you see may be different ....................................................................................... 9
  Using LibreOffice on macOS ......................................................................................... 10
  What are all these things called? .................................................................................... 10
  Who wrote this book? ....................................................................................................... 11
  Frequently asked questions ............................................................................................ 11
  What’s new in LibreOffice 6.4? ....................................................................................... 12
Chapter 1 Introducing Draw ................................................................................................. 13
  Introduction ....................................................................................................................... 14
  Draw main window .......................................................................................................... 14
  Choosing and defining colors ......................................................................................... 21
  Grid, snap, and help lines ............................................................................................... 23
Chapter 2 Drawing Basic Shapes ......................................................................................... 24
  Introduction ....................................................................................................................... 25
  Drawing basic shapes ....................................................................................................... 25
  Glue points and connectors ............................................................................................. 34
  Drawing geometric shapes ............................................................................................... 35
  Adding text ......................................................................................................................... 37
Chapter 3 Working with Objects .......................................................................................... 38
  Introduction ....................................................................................................................... 39
  Selecting objects ............................................................................................................... 39
  Positioning and adjusting objects .................................................................................... 40
  Using grid and snap functions ......................................................................................... 50
  Using Helplines ................................................................................................................ 55
  Changing form of regular shapes ..................................................................................... 56
  Curves and polygons ........................................................................................................ 57
Chapter 4 Changing Object Attributes ............................................................................... 65
  Formatting lines ............................................................................................................... 66
  Formatting fill areas ........................................................................................................ 73
  Working with area fills ...................................................................................................... 79
  Using drawing object styles ............................................................................................ 92
  Applying special effects .................................................................................................. 96
Chapter 5 Combining Multiple Objects ................................................................................. 103
  Grouping objects ............................................................................................................. 104
  Combining objects .......................................................................................................... 106
  Merging, subtracting, or intersecting objects .................................................................. 108
  Duplication and cross fading ........................................................................................ 110
Chapter 6 Editing Pictures ......................................................... 116
  Introduction .............................................................................. 117
  Importing graphics ................................................................. 117
  Exporting graphics ................................................................. 122
  Formatting raster objects ....................................................... 122
  Cropping ................................................................................ 125
  Image filter toolbar ................................................................. 128
  Replacing colors .................................................................... 133
  Conversion .............................................................................. 135
  Print options .......................................................................... 138

Chapter 7 Working with 3D Objects .......................................... 140
  Introduction .............................................................................. 141
  3D object types ..................................................................... 141
  Drawing toolbar .................................................................... 142
  Creating 3D objects ............................................................. 144
  Editing 3D objects ............................................................... 147
  Combining objects ............................................................... 158
  Assembling 3D objects ........................................................ 159

Chapter 8 Connections, Flowcharts, and Organization Charts .... 160
  Introduction .............................................................................. 161
  Connectors and glue points .................................................. 161
  Flowcharts ............................................................................ 169
  Organization charts .............................................................. 170

Chapter 9 Adding and Formatting Text ................................... 171
  Introduction .............................................................................. 172
  Text ...................................................................................... 172
  Using text with Draw objects .............................................. 177
  Inserting text ........................................................................ 179
  Formatting text ...................................................................... 180
  Using graphic styles ............................................................ 185
  Creating bulleted and numbered lists .................................. 189
  Using tables ............................................................................ 192
  Using fields .......................................................................... 199
  Using hyperlinks ................................................................. 200
  Fontwork .............................................................................. 203

Chapter 10 Printing, Exporting and E-mailing ......................... 206
  Printing ............................................................................... 207
  Exporting .............................................................................. 213
  E-mailing documents .......................................................... 215

Chapter 11 Advanced Draw Techniques ................................ 217
  Multi-page documents ........................................................ 218
  Templates .............................................................................. 225
Preface
Who is this book for?

Anyone who wants to get up to speed quickly with LibreOffice Draw will find this guide valuable. You may be new to drawing software, or you may be familiar with another program.

What is in this book?

This book introduces the main features of LibreOffice Draw. Draw is a vector graphics drawing tool, although it can also perform some operations on raster graphics (pixels) such as photographs. Using Draw, you can quickly create a wide variety of graphical images.

A few examples of the drawing functions are: layer management, snap functions and grid-point system, dimensions and measurement display, connectors for making organization charts, 3D functions that enable small three-dimensional drawings to be created (with texture and lighting effects), drawing and page-style integration, and Bézier curves.

The Draw Guide is not a course book to be worked through from beginning to end. Rather, it is a reference work in which you can browse for guidance on particular topics.

Where to get more help?

This guide, the other LibreOffice user guides, the built-in Help system, and user support systems assume that you are familiar with your computer and basic functions such as starting a program, opening and saving files.

Help system

LibreOffice comes with an extensive Help system. This is the first line of support for using LibreOffice. Windows and Linux users can choose to download and install the offline Help for use when not connected to the Internet; the offline Help is installed with the program on macOS.

To display the Help system, press $F1$ or select LibreOffice Help from the Help menu. If you do not have the offline help installed on your computer and you are connected to the Internet, your default browser will open the online Help pages on the LibreOffice website.

The Help menu also includes links to other LibreOffice information and support facilities.

Note

The following options shown here prefixed by a ‡ sign are only accessible if your computer is connected to the Internet.

- **What's This?** – for quick tips when a toolbar is visible, place the mouse pointer over any of the icons to see a small box (“tooltip”) with a brief explanation of the icon’s function. For a more detailed explanation, select Help > What's This? and hold the pointer over the icon. In addition, you can choose whether to activate Extended Tips using Tools > Options > LibreOffice > General.
- **Show Tip-of-the-Day** – opens a small window with a random tip on how to use LibreOffice.
- **Get Help Online** – opens your default browser at the Ask LibreOffice forum of questions and answers from the LibreOffice community, [https://ask.libreoffice.org/en/questions/](https://ask.libreoffice.org/en/questions/).
• **Send Feedback** – opens your default browser at the Feedback page of the LibreOffice website, [https://www.libreoffice.org/get-help/feedback/](https://www.libreoffice.org/get-help/feedback/). From there you can report bugs, suggest new features and communicate with others in the LibreOffice community.

• **Restart in Safe Mode** – opens a dialog window where you will have the option to restart LibreOffice and reset the software to its default settings.

• **Get Involved** – opens your default browser at the Get Involved page of the LibreOffice website, [https://www.libreoffice.org/community/get-involved/](https://www.libreoffice.org/community/get-involved/). There you can choose a topic of interest to help improve the program.

• **Donate to LibreOffice** – opens your default browser at the Donation page of the LibreOffice website, [https://donate.libreoffice.org/](https://donate.libreoffice.org/). There you can choose to make a donation to support LibreOffice.

• **License Information** – outlines the licenses under which LibreOffice is made available.

• **Check for Updates** – opens a dialog window and checks the LibreOffice website for updates to your version of the software.

• **About LibreOffice** – opens a dialog window and displays information about the version of LibreOffice and the operating system you are using. This information will often be requested if you ask the community for help or assistance with the software. (On macOS this item is under the LibreOffice menu.)

**Other free online support**

The LibreOffice community not only develops software, but provides free, volunteer-based support. In addition to the Help menu links above, there are other online community support options available, see the table below.

<table>
<thead>
<tr>
<th><strong>Free LibreOffice support</strong></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>FAQs</strong></td>
<td>Answers to frequently asked questions</td>
</tr>
<tr>
<td></td>
<td><a href="https://wiki.documentfoundation.org/Faq">https://wiki.documentfoundation.org/Faq</a></td>
</tr>
<tr>
<td><strong>Mailing lists</strong></td>
<td>Free community support is provided by a network of experienced users</td>
</tr>
<tr>
<td></td>
<td><a href="https://www.libreoffice.org/get-help/mailing-lists/">https://www.libreoffice.org/get-help/mailing-lists/</a></td>
</tr>
<tr>
<td><strong>Questions &amp; Answers and Knowledge Base</strong></td>
<td>Free community assistance is provided in a Question &amp; Answer formatted web service. Search similar topics or open a new one in</td>
</tr>
<tr>
<td></td>
<td><a href="https://ask.libreoffice.org/en/questions">https://ask.libreoffice.org/en/questions</a></td>
</tr>
<tr>
<td></td>
<td>The service is available in several other languages; just replace /en/ with de, es, fr, ja, ko, nl, pt, tr, and many others in the web address above.</td>
</tr>
<tr>
<td><strong>Native language support</strong></td>
<td>The LibreOffice website in various languages</td>
</tr>
<tr>
<td></td>
<td><a href="https://www.libreoffice.org/community/nlc/">https://www.libreoffice.org/community/nlc/</a></td>
</tr>
<tr>
<td></td>
<td>Mailing lists for native languages</td>
</tr>
<tr>
<td></td>
<td><a href="https://wiki.documentfoundation.org/Local_Mailing_Lists">https://wiki.documentfoundation.org/Local_Mailing_Lists</a></td>
</tr>
<tr>
<td></td>
<td>Information about social networking</td>
</tr>
<tr>
<td></td>
<td><a href="https://wiki.documentfoundation.org/Website/Web_Sites_services">https://wiki.documentfoundation.org/Website/Web_Sites_services</a></td>
</tr>
<tr>
<td><strong>Accessibility options</strong></td>
<td>Information about available accessibility options</td>
</tr>
<tr>
<td></td>
<td><a href="https://www.libreoffice.org/get-help/accessibility/">https://www.libreoffice.org/get-help/accessibility/</a></td>
</tr>
<tr>
<td><strong>OpenOffice Forum</strong></td>
<td>Another forum that provides support for LibreOffice, among other open source office suites <a href="https://forum.openoffice.org/en/forum/">https://forum.openoffice.org/en/forum/</a></td>
</tr>
</tbody>
</table>
Paid support and training

You can also pay for support through service contracts from a vendor or consulting firm specializing in LibreOffice. For information about certified professional support, see The Document Foundation’s website: https://www.documentfoundation.org/gethelp/support/

What you see may be different

Illustrations

LibreOffice runs on Windows, Linux, and macOS operating systems, each of which has several versions and can be customized by users (fonts, colors, themes, window managers). The illustrations in this guide were taken from a variety of computers and operating systems. Therefore, some illustrations will not look exactly like what you see on your computer display.

Also, some of the dialogs may be differ because of the settings selected in LibreOffice. You can either use dialogs from your computer system (default) or dialogs provided by LibreOffice. To change to using LibreOffice dialogs:

1) On Linux and Windows operating systems, go to Tools > Options > LibreOffice > General on the main menu bar to open the dialog for general options.

2) On a Mac operating system, go to LibreOffice > Preferences > General on the main menu bar to open the dialog for general options.

3) Select Use LibreOffice dialogs in Open/Save dialogs to display the LibreOffice dialogs on your computer display.

4) Click OK to save your settings and close the dialog.

Icons

The icons used to illustrate some of the many tools available in LibreOffice may differ from the ones used in this guide. The icons in this guide have been taken from a LibreOffice installation that has been set to display the Colibre (SVG) set of icons.

If you wish, you can change your LibreOffice software package to display Colibre (SVG) icons as follows:

1) On Linux and Windows operating systems, go to Tools > Options > LibreOffice > View on the main menu bar to open the dialog for view options.

2) On a Mac operating system, go to LibreOffice > Preferences > LibreOffice > View on the main menu bar to open the dialog for view options.

3) In User interface > Icon size and style select Tango from the options available in the drop down list.

4) Click OK to save your settings and close the dialog.

Notes

Some Linux operating systems, for example Ubuntu, include LibreOffice as part of the installation and may not include the Colibre (SVG) icon set. You should be able to download the Colibre (SVG) icons from the software repository for your Linux operating system.
Using LibreOffice on macOS

Some keystrokes and menu items are different on macOS from those used in Windows and Linux. The table below gives some common substitutions for the instructions in this book. For a more detailed list, see the application Help.

<table>
<thead>
<tr>
<th>Windows or Linux</th>
<th>macOS equivalent</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tools &gt; Options</td>
<td>LibreOffice &gt; Preferences</td>
<td>Access setup options</td>
</tr>
<tr>
<td>Right-click</td>
<td>Control+click and/or right-click depending on computer setup</td>
<td>Open a context menu</td>
</tr>
<tr>
<td>Ctrl (Control)</td>
<td>⌘ (Command)</td>
<td>Used with other keys</td>
</tr>
<tr>
<td>F5</td>
<td>Shift+⌘+F5</td>
<td>Open the Navigator</td>
</tr>
<tr>
<td>F11</td>
<td>⌘+T</td>
<td>Open the sidebar Styles deck</td>
</tr>
</tbody>
</table>

What are all these things called?

The terms used in LibreOffice for most parts of the user interface are the same as for most other programs (the parts of the program you see and use, in contrast to the behind-the-scenes code that actually makes it work).

A dialog is a special type of window. Its purpose is to inform you of something, or request input from you, or both. It provides controls to use to specify how to carry out an action. The technical names for common controls are shown in Figure 1. In most cases the technical terms are not used in this book, but it is useful to know them because the Help and other sources of information often use them.

Figure 1: Dialog showing common tools

10 | What are all these things called?
In most cases, you can interact only with the dialog (not the document itself) as long as the dialog remains open. When you close the dialog after use (usually, clicking OK or another button saves your changes and closes the dialog), then you can again work with your document.

Some dialogs can be left open as you work, so you can switch back and forth between the dialog and the document. An example of this type is the **Find & Replace** dialog.

1) Tabbed page – not strictly speaking a control.
2) Radio buttons – only one can be selected at a time.
3) Checkbox – more than one can be selected at a time.
4) Spin box – click the up and down arrows to change the number shown in the adjacent text box, or type in the text box.
5) Thumbnail or preview.
6) Drop-down list from which to select an item.
7) Push buttons.

**Who wrote this book?**

This book was written by volunteers from the LibreOffice community. Profits from sales of the printed edition will be used to benefit the community.

**Frequently asked questions**

**How is LibreOffice licensed?**

LibreOffice is distributed under the Open Source Initiative (OSI) approved Mozilla Public License (MPL). See [https://www.libreoffice.org/about-us/licenses/](https://www.libreoffice.org/about-us/licenses/)

It is based on code from Apache OpenOffice made available under the Apache License 2.0 but also includes software that differs from version to version under a variety of other Open Source licenses. New code is available under LGPL 3.0 and MPL 2.0.

**May I distribute LibreOffice to anyone?**

Yes

**May I sell it?**

Yes

**May I use it in my business?**

Yes.

**How many computers may I install it on?**

As many as you like.

**Is LibreOffice available in my language?**

LibreOffice has been translated (localized) into over 40 languages, so your language probably is supported. Additionally, there are over 70 spelling, hyphenation, and thesaurus dictionaries available for languages, and dialects that do not have a localized program interface. The dictionaries are available from the LibreOffice website at: [www.libreoffice.org](http://www.libreoffice.org).

**How can you make it for free?**

LibreOffice is developed and maintained by volunteers and has the backing of several organizations.
I am writing a software application. May I use programming code from LibreOffice in my program?

You may, within the parameters set in the MPL and/or LGPL. Read the licenses: https://www.mozilla.org/MPL/2.0/.

Why do I need Java to run LibreOffice? Is it written in Java?

LibreOffice is not written in Java; it is written in the C++ language. Java is one of several languages that can be used to extend the software. The Java JDK/JRE is only required for some features. The most notable one is the HSQLDB relational database engine.

Java is available at no cost. More information and download links to the appropriate edition for your operating system can be found at: https://java.com/en/download/manual.jsp

Note

If you want to use LibreOffice features that require Java, it is important that the correct 32-bit or 64-bit edition matches the installed version of LibreOffice. See Chapter 2 Advanced Options of the Getting Started Guide. If you do not want to use Java, you can still use nearly all of the LibreOffice features.

How can I contribute to LibreOffice?

You can help with the development and user support of LibreOffice in many ways, and you do not need to be a programmer. To start, check out this webpage: https://www.libreoffice.org/community/get-involved/

May I distribute the PDF of this book, or print and sell copies?

Yes, as long as you meet the requirements of one of the licenses in the copyright statement at the beginning of this book. You do not have to request special permission. We request that you share with the project some of the profits you make from sales of books, in consideration of all the work we have put into producing them.

Donate to LibreOffice: https://www.libreoffice.org/donate/

What’s new in LibreOffice 6.4?

The LibreOffice 6.4 Release Notes (changes from version 6.3) are available at the following links: https://wiki.documentfoundation.org/ReleaseNotes/6.4 and https://www.libreoffice.org/download/release-notes/

You may also want to read the LibreOffice 6.3 Release Notes (changes from previous versions) are available at the following links: https://wiki.documentfoundation.org/ReleaseNotes/6.3 and https://www.libreoffice.org/download/release-notes/
Chapter 1
Introducing Draw
Introduction

LibreOffice Draw is a vector graphics drawing program, although it can also perform some operations on raster graphics (pixels). Using Draw, you can quickly create a wide variety of graphical images.

Vector graphics store and display an image as an assembly of simple geometric elements such as lines, circles, and polygons, rather than a collection of pixels (points on the screen). Vector graphics allow for easier storage and scaling of the image.

Draw is fully integrated into the LibreOffice suite, and this simplifies exchanging graphics with all components of the suite. For example, if you create an image in Draw, reusing it in a Writer document is as simple as copying and pasting the image. You can also work with drawings directly from within Writer or Impress, using a subset of the functions and tools from Draw.

The functionality of LibreOffice Draw is extensive and, even though it was not designed to rival high-end graphics applications, it possesses more functionality than the drawing tools that are generally integrated with most office productivity suites.

A few examples of the drawing functions are: layer management, magnetic grid-point system, dimensions and measurement display, connectors for making organization charts, 3D functions that enable small three-dimensional drawings to be created (with texture and lighting effects), drawing and page-style integration, and Bézier curves.

This Draw Guide is not a course book to be worked through from beginning to end. Rather, it is a reference work in which you can browse for guidance on particular topics.

This document describes only the functions associated with Draw. Some concepts, such as file management or the way the LibreOffice environment works, are mentioned only briefly and are covered in more detail in the Getting Started Guide.

Draw main window

The main components of the Draw main window are shown in Figure 2.

Workspace

The large area in the center of the Draw main window (Workspace) is where you create your drawings. This drawing area can be surrounded with toolbars and information areas. The number and position of the visible tools vary with the task in hand and user preferences, therefore your setup may look different from Figure 2.

The maximum size of a drawing page in LibreOffice Draw is limited by your computer setup and the page size that you can set and use in your printer.

By default, the Workspace consists of three layers (Layout, Controls and Dimension Lines) and the tabs for these default layers appear in the bottom left corner of the Workspace. The default layers cannot be deleted or renamed, but you can add layers as and when necessary.

Pages pane

You can split drawings in Draw over several pages. Multi-page drawings are used mainly for presentations. The Pages pane, on the left side of the Draw main window, gives an overview of the pages that you create in your drawing. If the Pages pane is not visible, go to View on the Menu bar and select Page Pane. To make changes to the page order, drag and drop one or more pages.
Layers bar
A layer is a workspace where you insert your drawings elements and objects. The Layers bar is located on the bottom of the workplace and contains the guides for layer selection and layer command. For more information on layers, see Chapter 11 Advanced Draw Techniques.

Sidebar
The Sidebar has five main decks in Draw. To expand a deck, click on its icon or click on the small triangle at the top of the icons and select a deck from the drop-down list. If the Sidebar is not visible, go to View on the Menu bar and select Sidebar from the submenu.

Properties
Contains panes for object properties: Page, Character, Paragraph, Lists, Area, Shadow, Line, and Position and Size. The visible panes change depending on the object selected.

Shapes
Provides quick selection of most items on the Drawing toolbar: Lines & Arrows, Curves, Connectors, Basic Shapes, Symbols, Block Arrows, Flowchart symbols, Callouts, Stars, and 3D Objects.

Styles
Here you can edit and apply Drawing styles to objects within your drawing. When you edit a style, the changes are automatically applied to all of the elements formatted with this style in your drawing. (In Draw, Presentation styles are not available.)
**Gallery**

Opens the Drawing gallery where you can insert an object into your drawing either as a copy or as a link. A copy of an object is independent of the original object. Changes to the original object have no effect on the copy. A link remains dependent on the original object. Changes to the original object are also reflected in the link.

**Navigator**

Opens the Draw Navigator, in which you can quickly move between pages in your drawing or select an object on the drawing. It is recommended to give pages and objects in your drawing meaningful names so that you can easily identify them when using the Navigator.

**Rulers**

You should see rulers (bars with numbers) on the upper and left-hand sides of the workspace. If they are not visible, you can enable them by selecting **View > Rulers** in the Menu bar. The rulers show the size of a selected object on the page using double lines (highlighted in Figure 3). When no object is selected, they show the location of the mouse pointer, which helps to position drawing objects more accurately.

You can also use the rulers to manage object handles and guide lines when positioning objects.

The page margins in the drawing area are also represented on the rulers. You can change the margins directly on the rulers by dragging them with the mouse. The margin area is indicated by the grayed out area on the rulers as shown in Figure 3.

To change the measurement units of the rulers, which can be defined independently, right-click on a ruler and select the measurement unit from the drop down list, as illustrated for the horizontal ruler in Figure 4.

![Figure 3: Rulers showing object size](image1)

![Figure 4: Ruler units](image2)
Status bar

The Status Bar (Figure 5) is located at the bottom of the Draw window and includes several Draw specific fields. You can hide the Status Bar by going to View on the Menu bar and deselecting Status Bar.

Note

The sizes are given in the current measurement unit. They might not be the same as the ruler units. The measurement unit on the Status bar is defined in Tools > Options > LibreOffice Draw > General, where you can also change the scale of the page.

• Slide number – shows the number of the drawing pane that is selected.
• Information area – shows which action is being carried out, or which object type is selected.
• Cursor position and Object size – show different information depending on whether objects are selected or not.
  – When no object is selected, the position numbers show the current position (X and Y coordinates) of the mouse cursor.
  – When an object is selected and being resized with the mouse, the object size numbers show the size of the object (width and height).
  – If an object is selected, the position numbers show the X and Y coordinates of the upper-left corner and the object size number pair displays the size of the object. These numbers do not relate to the object itself, but to the selection outline, which is the smallest possible rectangle that can contain the visible part or parts of the object; see Chapter 3 Working with Objects and Object Points for more information.
  – When an object is selected, clicking in either of these areas opens the Position and Size dialog; see Chapter 4 Changing Object Attributes for more information.
• Unsaved changes – a flag indicating that the file needs saving. Clicking on this flag opens the Save as dialog if the file is new and has not been saved before. If the file has been saved before any changes, then clicking on this flag after any changes automatically saves the file.
• Digital signature – a flag indicating whether the document is digitally signed. After the file has been saved, double-clicking on this flag opens the digital signatures dialog.
• Fit drawing – resizes the drawing so that you can see the whole drawing in the Workspace.
• Zoom slider and Zoom percentage – adjusts and indicates the zoom percentage of the Workspace displayed. Double-clicking on zoom percentage opens the Zoom & View Layout dialog.
Toolbars

To display or hide the various Draw toolbars, go to View > Toolbars on the main menu bar and select from the drop down menu that appears which toolbars you want to display. For example, the Standard and Drawing toolbars are shown by default, but the Line and Filling, Text Formatting, and Options toolbars are not shown.

The appearance of the toolbar icons may vary depending on your operating system and the selection of icon size and style in Tools > Options > LibreOffice > View. For more information about working with toolbars, see the Getting Started Guide.

You can also select the icons or buttons that you want to appear on toolbars. To change the visible icons or buttons on any toolbar, right-click in an empty area on the toolbar and select Visible Buttons from the context menu. Visible icons or buttons are indicated by a shaded outline around the icon as shown by the icons in Figure 6. Click on an icon to hide or show it in the toolbar.

The tools available in Draw toolbars are described as follows:

**Standard toolbar**

The Standard toolbar (Figure 7) is the same for all LibreOffice components and is not described in detail in this chapter. By default, it is located just under the Main menu bar.

**Drawing toolbar**

The Drawing toolbar (Figure 8) is the most important toolbar in Draw. It contains all the necessary functions for drawing various geometric and freehand shapes, and for organizing them in the drawing. It is described in detail in Chapter 2 Drawing Basic Shapes.

**Line and Filling toolbar**

The Line and Filling toolbar (Figure 9) lets you modify the main properties of a drawing object. The icons and pull-down lists vary according to the type of object selected. For example, to change the style of a line, click on the up and down arrows for Line Style and select the required style.
The functions on the **Line and Filling** toolbar (Figure 9) let you change the color, style, and width of the line drawn, the fill color and style, and other properties of an object. The object must first be selected with a mouse click. If the selected object is a text frame, the **Line and Filling** toolbar changes to the **Text Formatting** toolbar (Figure 10).

**Text Formatting toolbar**

The **Text Formatting** toolbar (Figure 10) is similar to the Formatting toolbar in Writer and only appears when a text object has been selected in your drawing. For an explanation of the functions on this toolbar, see *Chapter 4 Changing Object Attributes*. For information on adding and formatting text, see *Chapter 9 Adding and Formatting Text*.

**Options toolbar**

Use the **Options** toolbar (Figure 11) to activate or deactivate various drawing aids. The **Options** toolbar is not displayed by default. To display it, go to **View > Toolbars > Options** on the main menu bar. The tools available on this toolbar are described in greater detail in other chapters of this *Draw Guide*.

**Floating and moving toolbars**

**Available toolsets**

Many icons have a small triangle pointing downward to the right side of the icon. This triangle indicates that the icon has additional tools available. Click on the triangle to display the full set of tools (Figure 12).

You can “tear off” this toolset so it becomes a floating toolbar. Click the area at the top of the toolset as shown in Figure 12, drag it across the screen to a location you want and then release the mouse button. To close a floating toolbar, click on the X on the right of the toolbar title.
Note

When a toolset is made into a floating toolbar, the icon on the existing toolbar remains in the toolbar and always shows the last tool you used. This means that the icon you see on your screen may differ from the icon shown in this guide.

Tip

When you double-click on an icon in a toolbar, the command corresponding to that icon will become active and remain active. You can then repeat this action as often as you like. To exit from this mode, press the Esc key or click on another icon. Please note that this may not work for every icon on every toolbar.

Default toolbars

When you open Draw, the default set of toolbars are already docked or fixed in their positions at the top and bottom of the workspace. This default set of toolbars normally consist of the Standard and Drawing toolbars. These toolbars can be undocked and become floating toolbars.

- To undock a toolbar, move the mouse cursor to the far left of the toolbar and over the toolbar handle (Figure 13). The cursor will change shape, normally a grabbing hand, but this is dependent on computer setup and operating system. Click and drag on the toolbar handle to move the toolbar until it becomes a floating toolbar. This floating toolbar capability is common to all components of LibreOffice.
- To dock a floating toolbar at the top of the Draw workspace, press and hold the Ctrl key then double click on the title of the toolbar. The toolbar will move into available space at the top of the Draw workspace.
- An alternative method of docking a toolbar is to click in the toolbar title and drag the toolbar to the docked position that you require. This can be the top, bottom or one of the sides of the Draw workspace.

![Figure 13: Toolbar handles](image)

Customizing toolbars

You can customize toolbars in several ways to show or hide icons defined for a toolbar, see “Toolbars” and Figure 6 on page 18 for more information.

To add functions to a toolbar, move tools between toolbars, or create new toolbars:

1) Select View > Toolbars > Customize on the main menu bar, or right click in an empty area on a toolbar and select Customize Toolbar from the context menu to open the Customize dialog (Figure 14).
2) Select the Toolbars tab, then select the toolbar you want to change from the Target drop-down list.
3) Select the desired function from the Assigned Commands list and that function will be added to the selected toolbar.
4) If you want to add a new function to the selected toolbar, click on the new function in the Available Commands list and then click on the right facing arrow ➔ to add the new function to your selected toolbar.
5) Click on the Settings icon next to the Target drop down list and select how you want the toolbar to appear in Draw from the context menu – Icon and text, Icon only, or Text only.

6) To create a new toolbar, click on the Settings icon next to the Target drop down list and select Add. A dialog opens so you can give your new toolbar a name and where you want to save the new toolbar.

7) To change the selected toolbar back to the default set of tools, click on the Defaults button. Any additional functions that had been added will be removed and the default functions added back to the selected toolbar.

8) Click OK to save your changes and close the dialog.

For more information when adding a new function, or modifying a toolbar, see the Getting Started Guide.

Choosing and defining colors

To display the Color Palette currently in use (Figure 15), select View > Color Bar on the main menu bar. To close the Color Palette, go to View on the main menu bar and deselect Color Bar. Using the Color Palette, you can rapidly choose the color of objects in your drawing (lines, areas, and 3D effects). The box with the X at the bottom left of the Color Palette corresponds to none (no color).

You can also access several specialized color palettes in Draw, as well as change individual colors to your own taste. To do this, go to Format > Area on the main menu bar to open the Area dialog and click on Color to open the Color page (Figure 16). In the Colors option, click on the Palette drop down list and select one of the palettes available in LibreOffice.
Alternatively, when an object in your drawing is selected, you change the area or line color of your object as follows:

- For the object area color, click on **Area** in the **Properties** deck on the Sidebar and select **Color** from the **Fill** drop down list to change the area color of your object (Figure 17).
- For the object line color, click on **Line** in the **Properties** deck on the Sidebar and select your color from the **Line Color** pop up dialog. This is similar to the color palette displayed in the **Area** dialog.

For a more detailed description of color palettes and their options, as well as more on the difference between the CMYK and RGB color schemes, refer to *Chapter 11, Advanced Draw Techniques*.
Grid, snap, and help lines

Draw provides a grid and snap lines as drawing aids and these can be turned on or off by clicking on the Display Grid or Display Snap Guides icons on the Line and Filling or Options toolbars. The grid and snap lines are displayed only on the screen and are not shown on a printed drawing or when the drawing is used in another LibreOffice module. The color, spacing and resolution of the grid points can be individually chosen for each axis.

Help lines when moving objects can be displayed and these are turned on or off by clicking on the Helplines While Moving icon on the Line and Filling or Options toolbars. Showing the position of the object while moving makes positioning the object much easier. If this function is activated, pairs of vertical and horizontal lines enclosing the object are shown while moving the object. These lines extend to the edges of the drawing area.

Draw also offers several snap functions to help you can position objects exactly in a drawing.

For more information on the grid, snap lines, snap functions, and help lines, see Chapter 3 Working with Objects and Object Points.
Chapter 2
Drawing Basic Shapes
Introduction

You can create 2D and 3D objects in Draw. This chapter shows how to draw simple 2D objects. The following chapters describe how to work with and edit such objects. For more information on 3D objects, see Chapter 7 Working with 3D Objects.

All shapes, whether they are lines, rectangles, or more complicated shapes, are called objects. This is common notation in vector drawing software.

The drawing tools are found on the Drawing toolbar (Figure 18). This toolbar is normally located at the bottom of the workspace. If you do not see it, you can activate it by going to View > Toolbars on the Menu bar.

As with all the components of LibreOffice, you can undock the Drawing toolbar and place it wherever you want to on the Draw workspace as a floating toolbar. You can also configure toolbars by adding, moving, hiding, or deleting toolbar icons. See Chapter 1 Introducing Draw for more information.

When you draw a shape, select an object for editing or add text to the drawing, the information field in the Status bar (Figure 19) changes to reflect the action taken or in progress. See Chapter 1 Introducing Draw for more information on the Status bar.

Figure 18: Drawing toolbar

<table>
<thead>
<tr>
<th>Slide (Drawing) number</th>
<th>Master drawing</th>
<th>Object size</th>
<th>Digital signature</th>
</tr>
</thead>
<tbody>
<tr>
<td>Slide 1 of 1 (layout)</td>
<td>Shape selected</td>
<td>Default</td>
<td>2.50 x 2.35</td>
</tr>
</tbody>
</table>

Figure 19: Status bar

Drawing basic shapes

Basic shapes, including text, are treated as objects in Draw. The standard set of tools available for drawing basic shapes on the Drawing toolbar are shown in Figure 18. Click on the small triangle on the right of the Drawing toolbar, then select Visible Buttons from the drop down menu to open a list of available tools (Figure 20).

The tools that are already placed on the Drawing toolbar are indicated by a check mark (√) next to the icon in the Visible Buttons list, for example Select, Line and so on. The tools without a check mark (√), for example To Curve, To Polygon, and so on, are not installed on the Drawing toolbar.

Please note that some of the icons on the Drawing toolbar will change shape according to the last tool used from the selection of available tools. The icons that have a small triangle to the right of the icon indicates that more tools are available. See “Drawing geometric shapes” on page 35 for information on the available shapes.
Note

When you draw a basic shape or select one for editing, the information area at the left side in the status bar changes to reflect the present action: for example *Line created, Text frame xxyy selected*, and so on.

**Straight lines**

A straight line is the simplest element or object in Draw to create.

1) Use one of the following options to start drawing a line:
   - Click the **insert Line** icon in the **Drawing** toolbar.
   - Click the small triangle on the right of the **Lines and Arrows** icon in the **Drawing** toolbar and select the **Insert Line** icon from the drop down list.
   - Click the **Insert Line** icon in the **Lines and Arrows** section of the **Shapes** deck on the Sidebar.

![Figure 21: Line starting point](image)
2) Place the cursor at the point where you want to start the line (Figure 21) and drag the mouse while keeping the mouse button pressed.

3) Release the mouse button at the point where you want to end the line. A selection handle appears at each end of the line, showing that this object is the currently selected object. The selection handle at the starting point of the line is slightly larger than the other selection handle.

4) Keep the Ctrl key pressed while drawing a line to enable the end of the line to snap to the nearest grid point.

Note

This is the default behavior of the Ctrl key. However, if the Snap to Grid option on the View > Grid menu has been selected, the Ctrl key deactivates the snap to grid activity.

5) Keep the Shift key pressed while drawing a line to restrict the drawing angle of the line to a multiple of 45 degrees (0, 45, 90, 135, and so on).

Note

This is the default behavior of the Shift key. However, if the option When creating or moving objects in the Constrain Objects section of Tools > Options > LibreOffice Draw > Grid has been selected, the action of the Shift key is the opposite. Lines will automatically be drawn at a multiple of 45 degrees unless the Shift key is pressed.

6) Keep the Alt key pressed while drawing a line to cause the line to extend outwards symmetrically in both directions from the start point. This lets you draw lines by starting from the middle of the line.

When a line is drawn, it uses default attributes. To change any of these attributes, select a line by clicking on it, then use one of the following methods to change the properties:

- Go to the Properties deck on the Sidebar and open the Line pane (Figure 22).
- Right-click on the line and select Line from the context menu to open the Line dialog (Figure 23).

![Figure 22: Line section in Properties deck on Sidebar](image-url)
Go to **Format > Line** on the main menu bar to open the **Line** dialog (Figure 23).

Use the controls in the **Line and Filling** toolbar (Figure 24). If the **Line and Filling** toolbar is not visible, go to **View > Toolbars** on the main menu bar and select **Line and Filling** from the drop down menu.

**Arrows**

Arrows are drawn like lines. Draw classifies arrows as a subgroup of lines, that is lines with arrowheads. Hovering the mouse cursor over each of the type of arrows available will tell you the type of line endings each icon will draw.

**Note**

The icon for the tool used most recently will already be selected on the Drawing toolbar to make it easier to use the same tool again.

The line endings available are lines, arrows, circles, squares, dimension lines and 45 degree lines. The information field on the Status bar shows them only as lines.

1) Use one of the following options to start drawing an arrow:

- Click the **Lines and Arrows** icon in the **Drawing** toolbar to draw the type of arrow indicated by the icon.
- Click the small triangle on the right of the **Lines and Arrows** icon in the **Drawing** toolbar and select the type of arrow you require from the drop down list (Figure 25).
- Click the icon of the type of arrow you require in the **Lines and Arrows** section of the **Shapes** deck on the Sidebar (Figure 26).
2) Place the cursor at the point where you want to start the arrow and drag the mouse while keeping the mouse button pressed. The arrowhead is drawn at the end point of the arrow when you release the mouse button.

**Note**

After drawing the line, you can change the arrow style by opening the Line dialog (Figure 23 on page 28) and going to the Arrow Styles page. Here you will find a larger selection of line endings to use in your drawing.
Note

You can also select the arrow style using the left or right drop down list in the Line section on the Properties deck (Figure 22 on page 27). The left drop down list places an arrowhead at the start of a line. The right drop down list places an arrowhead at the end of a line.

Rectangles or squares

• Drawing a rectangle or a square is similar to drawing a straight line using one of the following methods:
  – Click on the Rectangle icon in the Drawing toolbar (Figure 18 on page 25).
  – Select Rectangle icon in Basic Shapes on the Shapes deck in the Sidebar (Figure 26 on page 29).
  – Select the icon for the type of rectangle or square from the Legacy Rectangles toolbar (Figure 27). To display the Legacy Rectangles toolbar, go to View > Toolbars on the main menu bar and select it.

![Legacy Rectangles toolbar]

Figure 27: Legacy Rectangles toolbar

  • As you draw the rectangle with the mouse cursor, the rectangle appears with its bottom right corner attached to the cursor.
  • Squares are rectangles with all sides of equal length. To draw a square, click on the Rectangle icon and hold down the Shift key while you draw a square.
  • To draw a rectangle or square from its center rather than the bottom right corner, position your cursor on the drawing, press the mouse button and then hold down the Alt key while dragging with the cursor. The rectangle or square uses the start point (where you first clicked the mouse button) as the center.

Note

If the option When creating or moving objects has been selected in the Constrain Object section of Tools > Options > LibreOffice Draw > Grid, the action of the Shift key is reversed: the Rectangle tool draws a square. To draw a rectangle, press the Shift key. This Shift key reversal also applies when drawing ellipses and circles.

Ellipses or circles

• Draw an ellipse (also called an oval) or a circle using one of the following methods:
  – Click on the Ellipse icon in the Drawing toolbar (Figure 18 on page 25).
  – Select Ellipse icon in Basic Shapes on the Shapes deck in the Sidebar (Figure 26 on page 29).
  – Select the icon for the type of ellipse or circle from the Legacy Circles and Ovals toolbar (Figure 28). To display the Legacy Circles and Ovals toolbar, go to View > Toolbars on the main menu bar and select it.
Figure 28: Legacy Circles and Ovals toolbar

- As you draw the ellipse with the mouse cursor, the ellipse or circle appears with its bottom right corner attached to the cursor.
- A circle is an ellipse with both axes the same length. To draw a circle, click on the Ellipse icon and hold down the Shift key while you draw a circle.
- To draw an ellipse or circle from its center, position the cursor on the drawing, press the mouse button and then hold down the Alt key while dragging with the cursor. The ellipse or circle uses the start point (where you first clicked the mouse button) as the center.

Tip

To quickly insert a line, rectangle, ellipse, or text, press and hold down the Ctrl key and then click on one of the icons for Line, Rectangle, Ellipse, or Text and a standard sized object is drawn automatically in the work area. The size, shape, and color are all standard values. These attributes can be changed later, if desired. See Chapter 4 Changing Object Attributes for more information.

Dimension lines

Dimension lines display a measurement of an object in the drawing (Figure 29). The dimension line does not belong to the object itself, but it is usually placed close to it. An object can have as many dimension lines as necessary to indicate measures of its sides, edges, and distances.

You can control the display of a dimension line components and appearance by selecting it, right-clicking, and choosing Dimensions in the context menu to display the Dimension line dialog (Figure 30).

1) Use one of the following options to start drawing a dimension line:
   - Click the small triangle on the right of the Lines and Arrows icon in the Drawing toolbar and select Dimension Line from the drop down list (Figure 18 on page 25).
   - Click the Dimension Line icon in the Lines and Arrows section of the Shapes deck on the Sidebar (Figure 26 on page 29).
2) Place the cursor at the point where you want to start the dimension line and drag the mouse while keeping the mouse button pressed. The dimension line is drawn and automatically calculates and displays the linear dimension.

3) To adjust the settings of a dimension line, right click on the dimension line and select Dimension from the context menu to open the Dimension Line dialog (Figure 30).

4) Change the dimension settings using the various options in the Dimension Line dialog, then click OK to save your changes and close the dialog.

**Arcs and segments**

If you regularly draw arcs or segments (partial circles or ellipses), then you can use the optional Legacy Circles and Ovals toolbar (Figure 28 on page 31). Go to View > Toolbar on the main menu bar and select Legacy Circles and Ovals to open the toolbar.

- When you hover the cursor over an icon on this toolbar, the name of the object you are selecting is displayed.
- Click on the required icon in the Legacy Circles and Ovals toolbar. As you draw your object with the mouse cursor, the object appears with its bottom right corner attached to the cursor.
- To draw an object from its center, position the cursor on the drawing, press the mouse button and then hold down the [Alt] key while dragging with the cursor. The object uses the start point (where you first clicked the mouse button) as the center.

An arc or segment is drawn as follows:

1) Select the appropriate icon in the Legacy Circles and Ovals toolbar (Figure 28 on page 31), then click and drag with the cursor to start creating your arc or segment.

2) Release the mouse button then move the cursor to the position where you want the arc or segment to start and click to start drawing the arc or segment. The status bar indicates the angle in degrees.
3) Release the mouse button then move the cursor to the position where you want the arc or segment to finish. The status bar shows the angle in degrees.
4) When you have drawn the arc or segment you require, click again to complete the arc or segment.

Curves, polygons or freeform lines
Use one of the following options to start drawing a curve, polygon or freeform line. Moving the mouse cursor over one of the icons shows a tooltip giving the type of curve, polygon or freeform line:

- Click the small triangle on the right of the Curve and Polygons icon in the Drawing toolbar and select the type of curve, polygon or freeform line from the drop down list (Figure 18 on page 25).
- Select and click the type of curve, polygon or freeform line in the Curve and Polygons section of the Shapes deck on the Sidebar (Figure 26 on page 29).

Notes
The icon for the tool used most recently is shown on the Drawing toolbar to make it easier to use the same tool again.

Curves
1) Click and hold the left mouse button to create the starting point of the curve, then drag from the starting point drawing a line. Release the mouse button and continue to drag the cursor to bend the line into the required curve shape.
2) Click to set the end point of the curve and fix it on the page.
3) Continue dragging the cursor to draw straight lines at the end of your curve. Each mouse click sets a corner point and allows you to continue drawing another straight line from the corner point.
4) Double-click to end the drawing of your curve and lines.

Notes
A filled curve automatically joins the last point to the first point to close off the object and fills it with the selected fill color. A curve without filling will not be closed at the end of the drawing.

Polygons
1) Click and draw the first line from the start point while holding down the left mouse button. As soon as you release the mouse button, a line between the first and second points is drawn.
2) Move the cursor to draw the next line. Each mouse click sets a corner point and allows you to draw another line.
3) Double-click to end the drawing of your polygon.
Notes

A filled polygon automatically joins the last point to the first point to close off the figure and fills it with the selected fill color. A polygon without filling will not be closed at the end of the drawing.

Polygons 45°
Like ordinary polygons, these are formed from lines, but the angles between lines are restricted to 45 or 90 degrees. If required, hold down the Shift key as you draw the line so that the line is drawn at an angle other than 45 or 90 degrees.

Freeform lines
Using the freeform line tools is similar to drawing with a pencil on paper.

1) Click and drag the cursor to the line shape you require.
2) Release the mouse button when you are satisfied with your freeform line and the drawing is completed.
3) If Freeform Line Filled is selected, the end point is joined automatically to the start point and the object is filled with the selected color.

Glue points and connectors

Glue points
All Draw objects have glue points, which are not normally displayed. Glue points become visible when the Connectors icon is selected on the Drawing toolbar (Figure 18 on page 25) or when an icon in the Connectors section on the Shapes deck in the Sidebar (Figure 26 on page 29).

Most objects have four glue points (Figure 32). You can add more glue points and customize them, using the Glue Points toolbar (Figure 33). Go to View > Toolbars > Glue Points to open the toolbar.

Glue points are not the same as the selection handles of an object. Selection handles are for moving or changing the shape of an object. Glue points are used to fix or glue a connector to an object so that when the object moves, the connector stays fixed to the object. For a more detailed description on the use of glue points, see Chapter 3, Working with Objects and Object Points and Chapter 8, Connections, Flowcharts, and Organization Charts.

Figure 32: Glue points
Connectors

Connectors are lines or arrows whose ends automatically snap to a glue point of an object. Connectors are especially useful in drawing organization charts, flow diagrams, and mind-maps. When objects are moved or reordered, the connectors remain attached to a glue point. Figure 34 shows an example of two objects and a connector. Draw offers a range of different connectors and connector functions. On the Drawing toolbar (Figure 18 on page 25), click on the triangle next to the Connector icon to open the Connectors toolbar (Figure 35), or select a connector from Connectors section in the Shapes deck in the Sidebar (Figure 26 on page 29). For a more detailed description of the use of connectors, see Chapter 8, Connections, Flowcharts, and Organization Charts.

Drawing geometric shapes

The icons for drawing geometric shapes are located on the Drawing toolbar (Figure 18 on page 25) and on the Shapes deck in the Sidebar (Figure 26 on page 29). Clicking on the triangle to the right of an icon on the Drawing toolbar opens a floating toolbar giving access to the tools for that shape.

The use of these tools for geometric shapes is similar to the tool used for drawing rectangles and squares. For more information, see “Rectangles or squares” on page 30.

The icons used on the Drawing toolbar for drawing geometric shapes always indicates the last tool used and may not be the same as the icons shown in the following sections.

You can add text to all of these geometric shapes. For more information, see Chapter 11 Advanced Draw Techniques.
Basic shapes

Click on the triangle to the right of the Basic Shapes icon to open the Basic Shapes toolbar (Figure 36) for drawing basic shapes. This toolbar also includes a rectangle tool identical to the one already displayed on the Drawing toolbar. Alternatively, select the required icon in the Basic Shapes section in the Shapes deck on the Sidebar (Figure 26 on page 29).

Symbol shapes

Click on the triangle to the right of the Symbol Shapes icon to open the Symbol Shapes toolbar (Figure 37) for drawing symbols. Alternatively, select the required icon in the Symbol Shapes section in the Shapes deck on the Sidebar (Figure 26 on page 29).

Block arrows

Click on the triangle to the right of the Block Arrows icon to open the Block Arrows toolbar (Figure 38) for drawing block arrows. Alternatively, select the required icon in the Block Arrows section in the Shapes deck on the Sidebar (Figure 26 on page 29).

Flowcharts

Click on the triangle to the right of the Flowchart icon to open the Flowchart toolbar (Figure 39) for symbols used in drawing flowcharts. Alternatively, select the required icon in the Flowchart section in the Shapes deck on the Sidebar (Figure 26 on page 29).

The creation of flowcharts, organization charts, and similar planning tools are further described in Chapter 8 Connections, Flowcharts and Organization Charts.

Callouts

Click on the triangle to the right of the Callout icon to open the Callouts toolbar (Figure 40) for drawing callouts. Alternatively, select the required icon in the Callouts section on the Shapes deck on the Sidebar (Figure 26 on page 29).
Stars and banners

Click on the triangle to the right of the **Star** icon to open the **Stars and Banners** toolbar (Figure 41) for drawing stars and banners. Alternatively, select the required icon in the **Stars and Banners** section in the **Shapes** deck on the Sidebar (Figure 26 on page 29).

3D Objects

Click on the triangle to the right of the 3D icon to open the **3D-Objects** toolbar (Figure 42) for drawing 3D objects. Alternatively, select the required icon in the **3D-Objects** section in the **Shapes** deck on the Sidebar (Figure 26 on page 29).

Adding text

In Draw you can add, insert, and format text to a drawing, objects, and shapes as follows:

- As a dynamic text frame, which is an independent Draw object and expands as you add more text within the frame.
- Text within a previously drawn object. This integrates text within the object and is placed within the boundary rectangle that surrounds an object. This boundary rectangle is not dynamic and care must be taken so that your text does not go outside of the object boundaries.

For more information on how to add, insert, and format text in a drawing or drawing objects, see *Chapter 9 Adding and Formatting Text*. 
Chapter 3
Working with Objects
Introduction

This chapter looks at the tools and functions that let you modify existing drawings. All of the functions apply to a selected object or a group of selected objects, which can be distinguished by selection handles on a rectangular frame that is large enough to contain the object. Where several objects are selected, the frame around the objects corresponds to the smallest rectangle that can contain all of the objects. This frame is called the selection rectangle.

Note

The color and shape of the selection handles will change depending on the tool and function that has been selected to change the object properties. The color of the selection handles also depends on the computer operating system and how the computer has been set up.

Selecting objects

Direct selection

The easiest way to select an object is to click directly on it. For objects that are not filled, click on the object outline to select it. One click selects; a second click deselects. To select or deselect more than one object, hold the Shift key down while clicking.

Selection by framing

You can also select several objects at once by dragging the mouse cursor around the objects. This draws a rectangle around the objects, and only objects that lie entirely within the rectangle will be selected. To select multiple objects by framing, the Select icon on the Drawing toolbar (Figure 43) must be active.

Figure 43: Drawing toolbar

Note

When you drag the mouse cursor to select multiple objects, the selection rectangle being drawn is also known as a marquee.

Selecting hidden objects

If objects are located behind others and not visible, they can still be selected. When you select a hidden object, its selection handles will appear through the objects covering it.

• Windows or Mac operating system – select the object in front of the hidden objects, then press the Alt key and click to select the hidden object. If there are several hidden objects, keep holding down the Alt key and clicking until you reach the object you want. To cycle through the objects in reverse order, hold down the Alt+Shift keys and click.
• **Linux operating system** – press the `Tab` key to cycle selection through the objects in your drawing, stopping at the hidden object you want to select. To cycle through the objects in reverse order, press `Shift+Tab`. This is a very quick way to reach an object, but it may not be practical if there a large number of objects in a drawing.

**Arranging objects**

In a complex drawing, several objects may be stacked on top of one another. You can rearrange the stacking order by moving an object forward or backward using one of the following methods:

- Select an object, go to **Shape > Arrange** on the main menu bar, or right-click on the object and select **Arrange** from the drop down menu, then select one of the following options:
  - Bring to Front
  - Bring Forward
  - Send Backward
  - Send to Back
  - In Front of Object
  - Behind Object

- Select an object, then use one of the following keyboard shortcuts:
  - `Ctrl+Shift++` (bring to front)
  - `Ctrl++` (bring forward)
  - `Ctrl+-` (send backward)
  - `Ctrl+Shift+-` (send to back)

- Select an object, then select one of the **Arrange** icons (Figure 44) on left of the **Line and Filling** toolbar on the main menu bar. When you hover the mouse cursor over one of the icons, its function will be indicated.

**Positioning and adjusting objects**

**Using zoom**

To help in the positioning and adjustment of objects, Draw has a zoom function that reduces or enlarges the screen display of the current drawing. For example, zoom in to place objects onto your drawing with greater position; zoom out to see the complete drawing. You can control zooming using the **Status Bar**, **Zoom & View Layout** dialog, or **Zoom** toolbar.

**Note**

Zooming is handled differently on Linux and Windows operating systems. A drawing saved with a 100% zoom factor in Windows is displayed at a larger zoom factor in Linux.
Figure 45: Zoom controls on Status bar

Figure 46: Zoom & View Layout dialog

**Status bar**
The zoom controls are located on the right side of the Status Bar (Figure 45) and these controls give you quick and easy access to zooming.

- Click on the Fit slide to current window icon to fit your drawing to the open window.
- Click on the minus sign (-) to reduce the zoom factor.
- Click on the plus sign (+) to increase the zoom factor.
- Click and hold on the zoom slider and move it to increase or decrease the zoom factor.
- Right-click on the zoom percentage number and select a zoom factor from the context menu that opens.
- Go to View > Zoom > Zoom on the main menu bar or double-click on the zoom percentage number and select a zoom factor from the Zoom & View Layout dialog (Figure 46).

**Zoom & View Layout dialog**
The Zoom & View Layout dialog (Figure 46) provides the following options to control how your drawing is viewed on your monitor.

- **Zoom Factor** – sets the zoom factor at which to display the current document and all documents of the same type that you open thereafter.
  - *Optimal* – resizes the display to fit the width of the text in the document.
  - *Fit width and height* – displays the entire page on your screen.
  - *Fit width* – displays the complete width of the document page. The top and bottom edges of the page may not be visible.
  - *100%* – displays the document at its actual size.
  - *Variable* – enter a percentage in the box for the zoom factor at which you want to display the document.
• **View Layout** – used to set the view layout. Reduce the zoom factor to see the effects of different view layout settings.
  – **Automatic** – automatic view layout displays pages side by side, as many as the zoom factor allows.
  – **Single page** – single page view layout displays pages beneath each other, but never side by side.
  – **Columns** – in columns view layout you see pages in a given number of columns side by side. Enter the number of columns.
  – **Book mode** – in book mode view layout you see two pages side by side as in an open book. The first page is a right page with an odd page number.

**Zoom toolbar**

Go to **View > Toolbars > Zoom** on the main menu bar to open the **Zoom** toolbar (Figure 47). The tools available on this toolbar are as follows:

*Zoom toolbar*

- **Zoom In** – displays the slide at two times its current size. Click once on the tool, then move the cursor onto the object and click again. You can also select the Zoom In tool and drag a rectangular frame around the area you want to enlarge.
- **Zoom Out** – displays the drawing at half its current size each time the tool is clicked.
- **100%** – displays the drawing at its actual size.
- **Zoom Previous** – returns the display of the drawing to the previous zoom factor you applied. You can also use the keyboard shortcut [Ctrl +,] (Comma).
- **Zoom Next** – undoes the action of the Previous Zoom command. You can also the keyboard shortcut [Ctrl +.] (period).
- **Entire Page** – displays the whole drawing on your screen.
- **Page Width** – displays the complete width of the drawing. The top and bottom edges of the slide may not be visible.
- **Optimal** – resizes the display to include all of the objects on the slide.
- **Object Zoom** – resizes the display to fit the object(s) you selected.
• **Zoom & Pan** – zooms in for each mouse click. **Ctrl+click** zooms out for each click. **Shift+click** lets you move (pan) around the drawing.

• **Shift** – moves the drawing within the Draw workspace. Place the cursor on the drawing and drag to move the drawing. When you release the cursor, the last tool you used is automatically selected.

### Moving and adjusting object size

When moving an object or changing its size, check the left-hand area of the **Status Bar** at the bottom of the Draw workspace (Figure 48). From left to right, this area shows that a shape is selected, its position on the drawing in X/Y coordinates and dimensions of the object. The units of measurement are those selected in **Tools > Options > LibreOffice Draw > General** on the main menu bar.

![Figure 48: Left end of Status Bar when working with objects](image)

**Moving objects**

To move an object (or a group of objects), select it and then click within the object borders and hold down the left mouse button while dragging the mouse. During movement, a ghost image of the object appears to help with repositioning (Figure 49). When the object reaches its new location, release the mouse button.

![Figure 49: Moving objects](image)

**Adjusting object size**

To change the size of a selected object (or a group of selected objects), move the mouse cursor to one of the selection handles. The mouse cursor will change shape to indicate the direction of movement for that selection handle. As you change the size of the object, a ghosted outline of the object appears (Figure 50). When you have reached the desired size of the object, release the mouse button.

The results depend on which selection handle you use. To resize an object along one axis, use a side, top, or bottom handle. To resize along both axes, use a corner handle.
Note

If you press the Shift key while resizing an object, the change in size will be carried out symmetrically with respect to the two axes so that the aspect ratio of the object remains the same. This Shift key behavior works on all selection handles.

This is the default behavior of the Shift key. However, if When creating or moving objects has been selected in the Constrain Objects section of Tools > Options > LibreOffice Draw > Grid, the action of the Shift key is reversed and the aspect ratio will be preserved unless the Shift key is pressed.

Modifying arcs

The size of an arc can be changed by adjusting the positions of the start and end points of an arc. Select an arc, then right click on the arc and select Points from the drop down menu or press the F8 key. Two handles appear at the start and end of the arc (Figure 51). Click on one of these handles and drag it to a new position to change the shape of the arc.

Rotating and slanting objects

Rotating objects

To rotate an object (or a group of objects), select the object, then go to rotation mode using one of the following methods:

- Click on the triangle on the right of the Transformations icon on the Line and Filling toolbar and select the Rotate icon from the pop up menu. The Transformations icon displayed on the Line and Filling toolbar will be the last transformations tool used.
- Go to View > Toolbars > Transformations on the main menu bar and select the Rotate icon on the Transformations toolbar (Figure 52).
The object selection handles will change shape and color (Figure 53). Also a center of rotation indicator will appear in the center of the object. As you move the cursor over the handles, the cursor changes shape. The corner handles are for rotating the object, and the top, bottom and side handles are to shear or slant the object.

The rotation center is normally located at the center of an object. To change the position of the rotation center, click on the rotation center and drag until it is at the desired position. This rotation center can even be outside of the object.

**Note**

Rotation works in a slightly different way for 3D objects because it occurs in a three dimensional space and not in a single plane. See Chapter 7 Working with 3D Objects for more information.

**Note**

If you press the Shift key while rotating an object, rotation will be restricted to 15° of movement.

This is the default behavior of the Shift key. However, if When creating or moving objects has been selected in Tools > Options > LibreOffice Draw > Grid, the action of the Shift key is reversed: that is rotation will be restricted to 15° of movement unless the Shift key is pressed.
**Slanting objects**

To slant an object, select the object and click on the Rotate icon (see “Rotating objects” above), then use the handles located at the midpoints on the top, bottom and sides of a selected object. The cursor changes shape when it hovers over one of these midpoint handles indicating the direction of slanting.

The axis used for slanting an object is the object edge directly opposite the midpoint handle being used to slant the object. This axis stays fixed in location while the other sides of the object move in relation to it as you drag the mouse cursor (Figure 54).

Click and hold the mouse button, then start to move the cursor to slant the object. A ghosted outline of the object being slanted appears and the current angle of slanting is shown in the status bar.

**Note**

If you press the Shift key while slanting an object, slanting will be restricted to 15° of movement.

This is the default behavior of the Shift key. However, if When creating or moving objects has been selected in Tools > Options > LibreOffice Draw > Grid, the action of the Shift key is reversed: that is rotation will be restricted to 15° of movement unless the Shift key is pressed.

**Setting exact position, size, rotation and slant**

You can position and resize objects with the mouse, but this method is not exact. If you want to accurately position and size an object, you have to use the Position and Size dialog (Figure 55) or the Position and Size section (Figure 56) in the Properties deck on the Sidebar.

- To open the Position and Size dialog, select the object, then go to Format > Position and Size on the main menu bar, or right-click on the object and select Position and Size from the context menu, or press the F4 key.

- To open the Position and Size section in the Properties deck on the Sidebar, select the object, then click on the Properties icon on the Sidebar and click on the down arrow next to the Position and Size title bar to open the section.

The options available in the Position and Size dialog and Position and Size section in the Properties deck on the Sidebar are similar. However, on the Sidebar, you cannot protect the position and size of an object or adapt an object to fit any text or set the base point position for position and size.
Position and Size

- **Position** – specify the location of the selected object on the page.
  - *Position X* – enter the horizontal distance that you want to move the object relative to the base point selected in the grid.
– **Position Y** – enter the vertical distance that you want to move the object relative to the base point selected in the grid.

– **Base point** – select a base point in the grid and then enter the amount that you want to shift the object relative to the base point that you selected in the **Position Y** and **Position X** boxes. The base points correspond to the selection handles on an object. This option is only available in the **Position and Size** dialog (Figure 55 on page 47).

• **Size** – specify the amount by which you want to resize the selected object with respect to the selected base point.
  – **Width** – enter a width for the selected object.
  – **Height** – enter a height for the selected object.
  – **Keep ratio** – maintains proportions when you resize the selected object.
  – **Base point** – select a base point in the grid, and then enter the new size dimensions for the selected object in the **Width** and **Height** boxes. This option is only available in the **Position and Size** dialog.

• **Protect** – this option is only available in the **Position and Size** dialog.
  – **Position** – prevents changes to the position or the size of the selected object.
  – **Size** – prevents you from resizing the object.

• **Adapt** – specifies, if the size of a drawing object should be adjusted to fit the size of entered text. This option is only available in the **Position and Size** dialog.
  – **Fit width to text** – expands the width of the object to the width of the text, if the object is smaller than the text.
  – **Fit height to text** – expands the height of the object to the height of the text, if the object is smaller than the text.

The units of measurement used for X/Y coordinates and the width and height of the object are set by going to **Tools > Options > LibreOffice Draw > General**.

The default location of the base points for position and size is the upper left corner of the drawing area. You can temporarily change this base point to make positioning or dimensioning simpler by clicking on a position corresponding to the location of the base point you want to use. This change in base point is only valid for single use and the base point is reset to the standard position of top left corner when you close the **Position and Size** dialog (Figure 55 on page 47).

**Rotating objects**

To accurately rotate an object, click on the **Rotation** tab of the **Position and Size** dialog (Figure 57). Use this dialog to define the rotation angle and the location of the pivot point. Alternatively, use the available options on the **Position and Size** section (Figure 56 on page 47) in the **Properties** deck on the Sidebar.

• **Pivot point** – the selected object is rotated around a pivot point that you specify. The default pivot point is at the center of the object. If you set a pivot point too far outside of the object boundaries, the object could be rotated off of the page. This option is only available in the **Position and Size** dialog (Figure 57).
  – **Position X** – enter horizontal distance from the left edge of the page to the pivot point.
  – **Position Y** – enter vertical distance from the top edge of the page to the pivot point.
  – **Default settings** – select where you want to place the pivot point. Default position is the center of the object. Changing the rotation pivot point is only valid for single use. The pivot point is reset to default settings when you close the **Position and Size** dialog (Figure 57).
• **Rotation** – specify the number of degrees that you want to rotate the selected object, or click in the rotation grid.
  
  – **Angle** – enter the number of degrees that you want to rotate the selected object. This option is only available in the Position and Size dialog.
  
  – **Default settings** – click on the indicator to rotate the object. The number of degrees is shown in the Angle box as you rotate the indicator. This option is only available in the Position and Size dialog (Figure 57).
  
  – **Rotation** – click on the indicator to rotate the selected object, or set the angle in the text box, or select a predetermined angle from the drop down list. This option is only available in the Position and Size section (Figure 56 on page 47) in the Properties deck on the Sidebar.
  
  – **Flip** – flip the selected object either vertically or horizontally about its central axis. This option is only available in the Position and Size section (Figure 56 on page 47) in the Properties deck on the Sidebar.

### Slant and corner radius

To accurately set the corner radius or slant angle of an object, click on the **Slant & Corner Radius** tab of the Position and Size dialog (Figure 58). Options for slant and corner radius are only available in the Position and Size dialog.

• **Corner Radius** – you can only round the corners of a rectangular object. If this section is grayed out, then you cannot set a corner radius.
  
  – **Radius** – enter the radius of the circle that you want to use to round the corners. The larger the value for corner radius set, the rounder the corners of an object become.

• **Slant** – slants the selected object along the bottom edge of the object.
  
  – **Angle** – enter the angle of the slant axis. The slant angle relates to how much an object inclines or slants from its normal vertical position on a drawing.
• **Control Point 1 and 2** – enter a value to set the X and Y coordinates of the top left corner of the object. If these sections are grayed out, then you cannot set any coordinates.

### Using grid and snap functions

In Draw, you can also position objects accurately and consistently using grid points, snap points and lines, object frames, individual points on objects, or page edges. This function is known as **Snap**.

It is easier to use snap functions at the highest practical zoom value for your drawing. You can use two different snap functions at the same time. For example, snapping to a guide line and the page edge. However, it is recommended to activate only those snap functions that you really need.

### Configuring grid and snap functions

To configure the grid and snap functions in your drawing, go to **Tools > Options > LibreOffice Draw > Grid** on the main menu bar to display the **Grid** dialog (Figure 59). The grid and snap functions can also be displayed and switched on or off using this dialog, right-clicking on your drawing and using the options in the context menu, or using the icons in the **Options** toolbar (Figure 60). If the **Options** toolbar is not open, go to **View > Toolbars > Options** on the main menu bar.

![Figure 58: Position and Size dialog - Slant & Corner Radius page](image1)

![Figure 59: LibreOffice Draw Grid and Snap options](image2)
Figure 60: Options toolbar

- **Grid** – specifies the settings for the configurable grid on your document pages. This grid helps you determine the exact position of your objects. You can also set this grid in line with the magnetic snap grid. If you have activated the snap grid but wish to move or create individual objects without snap positions, keep the \[Shift\] key pressed to deactivate this function for as long as needed.
  - **Snap to grid** – specifies whether to move frames, drawing elements, and controls only between grid points. To change the status of the snap grip only for the current action, drag an object while holding down the \[Ctrl\] key.
  - **Visible grid** – specifies whether to display the grid.

- **Resolution**
  - **Horizontal** – defines the unit of measure for the spacing between grid points on the X-axis.
  - **Vertical** – defines the grid points spacing in the desired unit of measurement on the Y-axis.

- **Subdivision**
  - **Horizontal** – specify the number of intermediate spaces between grid points on the X-axis.
  - **Vertical** – specify the number of intermediate spaces between grid points on the Y-axis.

- **Synchronize axes** – specifies whether to change the current grid settings symmetrically. The resolution and subdivision for the X and Y axes remain the same.

- **Snap**
  - **To snap lines** – snaps the edge of a dragged object to the nearest snap line when you release the mouse button. You can also define this setting by using the **Snap to Snap Guides** icon on the Options toolbar.
  - **To the page margins** – specifies whether to align the contour of the graphic object to the nearest page margin. The cursor or a contour line of the graphics object must be in the snap range. In a drawing, this function can also be accessed with the **Snap to Page Margins** icon in the Options toolbar.
– **To object frame** – specifies whether to align the contour of the graphic object to the border of the nearest graphic object. The cursor or a contour line of the graphics object must be in the snap range. In drawing, this function can also be accessed with the **Snap to Object Border** icon in the Options toolbar.

– **To object points** – specifies whether to align the contour of the graphic object to the points of the nearest graphic object. This only applies if the cursor or a contour line of the graphics object is in the snap range. In a drawing, this function can also be accessed with the **Snap to Object Points** icon in the Options toolbar.

– **Snap range** – defines the snap distance between the mouse pointer and the object contour. Snaps to a snap point if the mouse pointer is closer than the distance selected.

**Constrain Objects**

– **When creating or moving objects** – specifies that graphic objects are restricted vertically, horizontally or diagonally (45°) when creating or moving them. You can temporarily deactivate this setting by pressing the **Shift** key.

– **Extend edges** – specifies that a square is created based on the longer side of a rectangle when the **Shift** key is pressed before you release the mouse button. This also applies to an ellipse (a circle will be created based on the longest diameter of the ellipse). When **Extend edges** is not selected, a square or a circle will be created based on the shorter side or diameter.

– **When rotating** – specifies that graphic objects can only be rotated within the rotation angle that you selected. If you want to rotate an object outside the defined angle, press the **Shift** key when rotating. Release the key when the desired rotation angle is reached.

– **Point reduction** – defines the angle for point reduction. When working with polygons, you might find it useful to reduce their editing points.

**Snap to grid**

**Using Snap to Grid**

Use the **Snap to Grid** function to move an object exactly onto a grid point in your drawing. This function can be switched on and off using one of the following methods:

- Go to **View > Snap Guides > Snap to Grid** on the main menu bar.
- Right-click on your drawing and selecting **Snap Guides > Snap to Grid** from the context menu.
- Click on the **Snap to Grid** icon on the **Options** toolbar.

**Displaying grid**

Displaying or turning off the grid in your drawing can be done using one of the following methods:

- Go to **View > Grid and Helplines > Display Grid** on the main menu bar.
- Click on the **Display Grid** icon on the **Options** toolbar.
- Right-click on your drawing and select **Grid and Helplines > Display Grid** from the context menu.
- Selecting **Visible grid** option in the **LibreOffice Draw Grid** dialog (Figure 59 on page 50).
Changing color of grid points

By default and depending on your display and computer setup, the grid points are gray and are not always easy to see. To change the color of the grid points, go to Tools > Options > LibreOffice > Application Colors to open the Application Colors dialog (Figure 61). In the Drawing/Presentation section, select a more suitable color for the grid from the drop-down list.

Snap points and lines

Unlike the grid, snap lines and snap points are inserted by you when you want to position an object to a specific position on your drawing. Snap lines can either be horizontally or vertically and appear as dashed lines. Snap points appear as small crosses with dashed lines. Snap points and snap lines do not appear in printed output.

Inserting snap points and snap lines

To insert a snap point or snap line, go to Insert > Snap Guide on the main menu bar to open the New Snap Object dialog (Figure 62).

- **Position** – sets the position of a selected snap point or line relative to the top left corner of the page.
  - **X axis** – enter the amount of space you want between the snap point or line and the left edge of the page.
  - **Y axis** – enter the amount of space you want between the snap point or line and the top edge of the page.
• **Type** – specifies the type of snap object you want to insert.
  – *Point* – inserts a snap point.
  – *Vertical* – inserts a vertical snap line.
  – *Horizontal* – inserts a horizontal snap line.

**Displaying snap points and lines**

Displaying or turning off snap points and lines in your drawing can be done using one of these methods:

- Go to **View > Snap Guides > Display Snap Guides** on the main menu bar.
- Click on the **Display Snap Guides** icon on the **Options** toolbar (Figure 60 on page 51).
- Right-click on your drawing and select **Snap Guides > Display Snap Guides** from the context menu.

**Editing snap points and lines**

To edit a snap point, right-click on the snap point and select **Edit Snap Point** from the context menu to open the **Edit Snap Point** dialog (Figure 63). Enter new X and Y coordinate settings for the snap point and click **OK**. Alternatively, drag a snap point to a new position on your drawing.

To edit a snap line, right-click on the snap line and select **Edit Snap Line** from the context menu to open the **Edit Snap Line** dialog (Figure 64). Enter a new X coordinate setting for vertical snap...
lines or a new Y coordinate setting for horizontal snap lines and click **OK**. Alternatively, drag a snap line to a new position on your drawing.

**Deleting snap points and lines**
To delete a snap point, drag it back to a ruler or right-click on the snap point and select **Delete Snap Point** from the context menu.

To delete a snap line, drag it back to the ruler or right-click on the snap line and select **Delete Snap Line** from the context menu.

**Configuring snap range**
To configure the snap range of when an object snaps to position

1) Go to **Tools > Options > LibreOffice Draw > Grid** on the main menu bar to open the **Options LibreOffice Grid** dialog (Figure 59 on page 50).

2) Enter the number of pixels to set the proximity of when the object will snap into position in the **Snap range** box. The default setting is 5 pixels.

3) Click the **OK** button to set the new snap range and close the dialog.

**Using Helplines**
Helplines are a function in Draw to help you position objects. Helplines can be displayed while the object is being moved. They extend from the edges of the object to the rulers at the top and left side of your drawing and do not have a snap function (Figure 65).

![Figure 65: Helplines while moving](image)

To use guide lines, go to **Tools > Options > LibreOffice Draw > View** dialog (Figure 66) on the main menu bar and select **Helplines when moving** option or click the **Helplines While Moving** icon on the **Options** toolbar (Figure 60 on page 51).
Changing form of regular shapes

When drawing certain regular shapes, one or more dots are displayed in a different color to the selection handles when an object is selected. When the cursor hovers over one of these dots, it changes shape. Clicking and dragging on one of these dots modifies the shape of the object. For example, you can increase the corner radius of a rounded rectangle or square, change the angles of an arc, and so on.

These dots perform different functions according to the shape selected. The shapes with form changing dots and their functions are listed in the following sections.

Basic shapes

- *Rounded rectangles and squares* – use the dot to change the radius of the curve that replaces the angled corners of a rectangle or square.
- *Circle pie* – use the dots to change the size of the filled sector.
- *Isosceles triangle* – use the dot to modify the triangle type.
- *Trapezoid, parallelogram, hexagon, octagon* – use the dot to change the angle between the sides.
- *Cross* – use the dot to change the thickness of the four arms of the cross.
- *Ring* – use the dot to change the internal diameter of the ring.
- *Block arc* – use the dot to change both internal diameter and size of the filled area.
- *Cylinder, cube* – use the dot to change the perspective.
- *Folded corner* – use the dot to change the size of the folded corner.
- *Frame* – use the dot to change the thickness of the frame.

Symbol shapes

- *Smiley face* – use the dot to change the smile on the face.
- *Sun, moon, heart* – use the dot to change the shape of the symbol.
- *Prohibited* – use the dot to change the thickness of the ring and the diagonal bar.
- *Double bracket, left bracket, right bracket, double brace* – use the dot to change the curvature of the bracket.
- *Left brace, right brace* – use the dots to change the curvature of the brace and the position of the point.
- *Square bevel, octagon bevel, diamond bevel* – use the dot to change the thickness of the bevel.

Block arrows

- *Arrows* – use the dot to change the shape and thickness of the arrows.
- *Pentagon, chevron* – use the dot to change the angle between the sides.
- *Arrow callouts* – use the dots to change the shape and thickness of the callouts.
- *Circular arrow* – use the dots to change the thickness and area of the arrow.

Callouts

- *Callouts* – use the dots to change the length, position and angle of the pointer.
Stars

- 4-point star, 8-point star, 24-point star – use the dot to change the thickness and shape of the star points.
- Vertical scroll, horizontal scroll – use the dot to change the width and shape of the scroll.
- Doorplate – use the dot to change the inward curvature of the corners.

Curves and polygons

Bézier curves

The editing of curves depends on the mathematics of Bézier curves\(^1\). Explaining Bézier curves goes beyond this scope of this chapter. See *Chapter 11 Advanced Draw Techniques* for more information on drawing and manipulating Bézier curves.

The editing of a Bézier curve consists in principle of moving points or tangents passing through these points. Each tangent has one control point at each end and a junction point where it meets the curve. The relative angle and distance between the control points determine the shape of the curve. Figure 67 shows what happens starting from a basic square and changing only one point on the square.

You can create many different shapes by moving either the junction point itself, or one or both of the round handle points at either end of the tangent. Draw offers more possibilities when you use the functions on the **Edit Points** toolbar (Figure 68).

![Figure 67: Creating different shapes by changing the tangent](image)

Converting to curve or polygon

Before modifying the points on an object, you must convert the object to a curve or a polygon, depending on what kind of effect you want to produce using one of the following methods:

- After selecting an object, go to **Shape > Convert** on the main menu bar and select either **To Curve** or **To Polygon**.
- Right click on an object and select **Convert > To Curve** or **Convert > To Polygon** from the context menu.

\(^1\) Bézier curves were invented by Pierre Bézier, an engineer working with the Renault car manufacturer, who developed the technique in the 1960s. The technology was intended to make modeling the surface of vehicles easier.
After converting an object to a curve or polygon, use one of the following methods to edit points on the object:

- Go to View > Toolbars > Edit Points on the main menu bar click to open the Edit Points toolbar (Figure 68) and click on the Points icon.
- Right click on an object and select Points from the context menu to open the Edit Points toolbar.
- Select the object and press the F8 key to open the Edit Points toolbar.

You will notice that after the conversion, the handles located in the corners of the selection rectangle have disappeared. This behavior is normal because the handles used with the tools on the Edit Points toolbar are located along the outline or trace of the object.

**Edit Points toolbar**

After the Edit Points toolbar has been opened, each time you select an object that has been converted to a curve or polygon, the toolbar will appear. Each time you deselect an object that has been converted, the toolbar will close. Available tools on the Edit Points toolbar will depend on the object selected and which object point has been selected.

**Tangents**

Before you can use tangents on an object, you must convert the object to a curve. Go to Shape > Convert > To Curve on the main menu bar or right-click on the object and select Convert > To Curve from the context menu.

**Note**

Tangents are only used on curves. If an object has been converted to a polygon and a tangent is added, the object is automatically converted to a curve.

**Symmetric transition**

Symmetric Transition converts a corner point or a smooth point into a symmetrical point. Both control points of the corner point are aligned in parallel and have the same length. They can only be moved simultaneously and the degree of curvature is the same in both directions.
1) Convert the object to a curve and click on the selection handle where you want to place the tangent.

2) Click on the **Symmetric Transition** icon on the **Edit Points** toolbar (Figure 68).

3) Click and drag one of the tangent handles to change the shape of the object. Any movement of one tangent handle is carried over symmetrically to the other handle, as shown in Figure 69.

![Figure 69: Symmetric transition](image)

**Smooth transition**

**Smooth Transition** converts a corner point or symmetrical point into a smooth point. Both control points of the corner point are aligned in parallel, and can only be moved simultaneously. The control points may differentiate in length, allowing you to vary the degree of curvature.

1) Convert the object to a curve and click on the selection handle where you want to place the tangent.

2) Click on the **Smooth Transition** icon on the **Edit Points** toolbar (Figure 68 on page 58) so you can adjust separately the lengths on each side of a tangent to make a curve flatter or steeper.

3) Click and drag one of the tangent handles to change the shape of the object. This creates an asymmetric tangent with the curve flatter on the longest side of the tangent (Figure 70).

![Figure 70: Smooth transition](image)

**Corner point**

Use **Corner Point** to convert selected point or points into corner points. Corner points have two movable control points, which are independent from each other. A curved line, therefore, does not go straight through a corner point, but forms a corner.

It is possible to change independently the angle on each side of a tangent using the central point of the tangent as a corner point.
1) Convert the object to a curve and click on the selection handle where you want to place the corner point.

2) Click on the **Corner Point** icon on the **Edit Points** toolbar (Figure 68 on page 58) to create a corner point at the selected point (Figure 71).

3) Click and drag the end of one of the tangents to change its angle. Each tangent can be moved independently to create spikes and troughs in curves.

**Tangent rotation**
You can alter the angle by which a tangent relates to curve by clicking on one of the end points of the tangent and rotating it with the cursor. As you change the angle of the tangent, the shape of the curve changes in response (Figure 72).

**Points**

**Moving points**
**Move Points** activates a mode allowing you to move points. The mouse pointer displays a small empty square when resting on a point. Drag that point to another location. The curve on both sides of the point follows the movement and the section of the curve between points changes shape.

Point at the curve between two points or within a closed curve and drag the mouse to shift the entire curve without distorting the form.

1) Make sure the object is converted to a curve.

2) Click on the **Move Points** icon on the **Edit Points** toolbar to move any of the points when an object has been converted to a curve or polygon.
3) Hover over a point until the cursor changes shape, then drag the point to create a new shape. Figure 73 illustrates how a different shape can be created from a circle by dragging the left hand side point to the left.

**Inserting points**

Insert Points activates a mode in which you can insert points. You can also move points in this mode, just as in the move mode. If, however, you click on the curve between two points and move the cursor a little while holding down the mouse button, you insert a new point. The point is a smooth point and the lines to the control points are parallel and remain so when moved.

If you wish to create a corner point, you must first insert either a smooth or a symmetrical point which is then converted to a corner point by using Corner Point.

1) Make sure the object is converted to a curve.

2) Click on the Insert Points icon on the Edit Points toolbar (Figure 68 on page 58) to add an extra point to an existing curve or polygon.

3) Click on the object border at the spot where you want to insert a point. The tangent type associated with the new point depends on where the point has been added to the object border. Figure 74 shows a new point added to the right side of a circle then moved to create the shape illustrated.

**Deleting points**

Select a point on the border of the object, then use the Delete Points icon on the Edit Points toolbar (Figure 68 on page 58) to delete one or more selected points from the border of the object. To select several points, click on those points while holding down the Shift key. The resulting curve automatically changes shape around the remaining points. You can also delete selected points by pressing the Del key on the keyboard.

Figure 75 shows what happens when three points on the left were deleted from a circle. The left image is a curve. The right image is a curve where three points have been deleted and the result converted to a line (see “Converting curves or lines” on page 63). This forms a straight line is formed between the two points on either side of the deleted points.
Eliminating points

The Eliminate Points icon only functions on lines with multiple points. These lines are created when a curve is converted to a line using the Convert to Curve icon on the Edit Points toolbar. The process of eliminating points from a line to create a straight line is shown in Figure 76.

1) Select a curve with multiple points that has been converted to a line (see “Converting curves or lines” on page 63).
2) Use the mouse cursor to select the point on the line that you want to eliminate. The selected point will be emphasized.
3) Click on the Eliminate Points icon on the Edit Points toolbar (Figure 68 on page 58).
4) Accurately position the mouse cursor over the selected point, then click and start dragging the selected point. As you drag, a dotted line forms between the two neighboring points.
5) When this dotted line appears to be a straight line between the two neighboring points, release the mouse button. The selected point is eliminated and a straight line now exists between the two neighboring points.
Converting curves or lines

Curves and lines can be easily converted to each other using the **Convert to Curve** icon on the **Edit Points** toolbar. When a curve is converted to a line, a straight line is created between selected points on a curve. When a line is converted to a curve, a curve is created between selected points on a line.

1) Select a curve or line and then select the points on the curve or line where you want to do the conversion.
2) Click on the **Convert to Curve** icon on the **Edit Points** toolbar (Figure 68 on page 58) and a curve is converted into a line or a line is converted into a curve (Figure 77).

![Figure 77: Converting curves or lines](image)

Splitting curves

1) Select the point on the curve where you want to split it. To separate a curve at several points simultaneously, keep the **Shift** key pressed down and select all of the points where the cut will occur.
2) Click on the **Split Curve** icon on the **Edit Points** toolbar (Figure 68 on page 58) to split or cut a curve at the location of the selected point. If the object is filled, it will be emptied because the curve that represented the object border is no longer closed (Figure 78).
3) Deselect the curve, then drag and drop segments to move them away from the original curve.

![Figure 78: Splitting curves](image)

**Note**

The point where you split the curve is now larger than the remaining points visible on the curve, except for the curve start point which is also larger than the other points.
Closing curves

1) Select an open and existing curve (Figure 79).
2) Select a point of the curve. Note that the start point of a curve is larger than the other points visible on the curve.
3) Click on the Close Bézier icon on the Edit Points toolbar (Figure 68 on page 58) to close the curve. If the open curve was originally a closed and filled curve, then the original color will fill the curve when it is closed.

Rotating and distorting curves

1) Select the curve, then go to View > Toolbars > Transformations on the main menu bar to open the Transformations toolbar (Figure 52 on page 45) and select the Rotate icon (see "Rotating and slanting objects" on page 44 for more information on rotating objects).
2) Select one of the points on the curve and drag it to a new position to distort the curve (Figure 80).
3) Select one of the control points at the end of the tangent line and rotate the distorted curve by dragging the cursor. The distorted curve will rotate about the center of rotation.
Chapter 4
Changing Object Attributes
Formatting lines

In LibreOffice the term *line* indicates both a freestanding segment (line), the outer edge of a shape (border), or an arrow. In most cases the properties of the line you can modify are its style (solid, dashed, invisible, and so on), its width, its color and the type of arrowhead.

**Note**

When you hover the mouse cursor over an icon or tool on a toolbar or in the Sidebar, a pop up will indicate the purpose of the icon or tool.

**Line and Filling toolbar**

To format a line using the **Line and Filling** toolbar (Figure 81):

1) Make sure the line is selected in your drawing.
2) On the **Line and Filling** toolbar, select the line style you want to use from the **Line Style** drop-down list.
3) On the **Line and Filling** toolbar, either type the line width in the **Line Width** text box, or use the up and down arrows to change the line width.
4) On the **Line and Filling** toolbar, click on the small triangle to the right of the **Line Color** icon and select a color from the dialog that opens.

![Figure 81: Line and Filling toolbar](image)

**Sidebar**

To format a line using the **Line** section in the **Properties** deck on the Sidebar (Figure 82):

1) Make sure the line is selected in your drawing.
2) Click on the **Properties** icon on the Sidebar to open the **Properties** deck.
3) Click on the down arrowhead **V** on the left of the **Line** title bar to open the **Line** section.

![Figure 82: Line section In Properties on Sidebar](image)
4) Select from the drop-down lists the type of arrowhead for each end of the line and change the line into an arrow. The left drop-down list adds an arrow head to the beginning of the line. The right drop-down list adds an arrow head to the end of the line.

5) Select from the middle drop-down list the type of line from the options available.

6) Select the line width from the options in the Width drop-down list or enter a width in the text box.

7) Select the line color from the Line Color dialog that opens when you click on the small triangle to the right of the Color box.

8) Deselect the line to save your changes to the line.

**Line dialog**

If you want to fully change the appearance of a line, then you need to use the Line dialog.

1) Select the line in your drawing.

2) Go to Format > Line on the main menu bar, or right-click on the line and select Line from the context menu to open the Line dialog (Figure 83). This dialog consists of four pages: Line, Shadow, Line Styles and Arrow Styles and are explained in the following sections.

3) When you have made all your changes to the selected line, click OK to close the dialog and save your changes. The preview box at the bottom of the dialog shows the effect of your changes on a line.

![Figure 83: Line dialog - Line page](image)

**Line page**

The Line page in the Line dialog (Figure 83) is where you can set the basic parameters of the line and is divided into three sections as follows.

**Line properties**

Use Line Properties to set the following parameters:

- **Style** – select a line style from the drop-down list.
- **Color** – select a predefined color from the drop-down list or create a custom color.
- **Width** – specifies the thickness of the line.
- **Transparency** – sets the transparency of a line. Figure 84 shows the effects of different percentages in transparency levels to lines when placed over an object.

![Figure 84: Line transparency (0%, 25%, 50%, 75% left to right)](image)

**Arrow styles**

**Arrow Styles** page on the Line dialog are only applicable to individual lines and are not used for lines that form the borders of a shape.

- **Start style** and **End style** – sets the arrow style or arrowhead for the start and end of a line from the drop-down list.
- **Width** – specifies the thickness of the arrow endings

![Figure 85: Default arrow top; centered arrow bottom](image)

![Figure 86: Arrowheads drop down menu](image)
• **Center** – moves the center of the arrow endings to the end point of the line. Figure 85 shows the effects of selecting this option.

• **Synchronize ends** – makes the two line ends identical.

A quick way to set the arrowheads for a selected line is to click on the **Arrow Style** icon in the **Line and Filling** toolbar to open the **Arrowheads** menu (Figure 86). Here you can select one of the many predefined arrowhead styles for the start and ending of a selected line.

---

**Note**

Arrowheads are only applicable to lines. They have no effect on the border of an object.

---

**Corner and cap styles**

**Corner and Cap Styles** (Figure 83 on page 67) determine how the connection between two segments looks. To appreciate the difference between these styles, choose a thick line style and observe how the preview changes.

• **Corner style** – select the shape to be used at the corners of the line. In case of a small angle between lines, a mitered shape is replaced with a beveled shape.

• **Cap style** – select the style of the line end caps. The caps are added to inner dashes as well.

**Line shadows**

Use the **Shadow** page (Figure 87) of the **Line** dialog to add and format a shadow to a selected line. The settings on this page are the same as those for shadows applied to other objects and are described in “Shadows” on page 90.

A quicker way to apply a shadow to a line is using the **Shadow** icon on the **Line and Filling** toolbar. The main disadvantage of using the **Shadow** icon is that the shadow appearance will be constrained by the shadow settings of the default graphics style.

**Line styles**

Use the **Line Styles** page (Figure 88) of the **Line** dialog to change the line style from the options available from the drop menu in **Properties** or create a new line style. An example of the line style selected or created is displayed at the bottom of the dialog page.
Creating line styles

To create a new line style:

1) Choose **Format > Line** on the main menu bar, or right-click on the line and select **Line** from the context menu, or select the **Line** icon on the **Line and Filling** toolbar to open the Line dialog.

2) Click on the **Line Styles** tab to open the **Line Styles** page (Figure 88).

3) Select from the **Line style** drop-down menu a style similar to the style you want to create.

4) Click **Add** and type a name for the new line style in the dialog that opens, then click **OK**.

5) Now define the new style by selecting the line type for the new style. To alternate two line types (for example, dashes and dots) within a single line, select different types in the two **Type** boxes.

6) Specify the **Number** and **Length** (not available for dot style) of each **Type** of line selected.

7) Set the **Spacing** between the various elements.

8) If necessary, select **Fit to line width** so that the new style fits the width of the selected line.

9) The new line style created is available only in the current document. If you want to use the line style in other documents, click the **Save Line Styles** icon and type a unique filename in the **Save as** dialog that opens. Saved line styles have the file extension of **.sod**.

10) To use previously saved line style, click the **Load Line Styles** icon and select a style from the list of saved styles. Click **Open** to load the style into your document.

11) If necessary, click on the **Modify** button to change the name of the style.

12) Click **OK** to close the dialog and save any changes you have made.

Deleting line styles

To delete a line style:

1) Choose **Format > Line** on the main menu bar, or right-click on the line and select **Line** from the context menu, or select the **Line** icon on the **Line and Filling** toolbar to open the **Line** dialog.
2) Click on the Line Styles tab to open the Line Styles page (Figure 88).
3) Select the line style you want to delete from the Line style drop-down list.
4) Click on the Delete button, then confirm the deletion by clicking on the Yes button in the confirmation dialog that opens.
5) Click OK to close the Line dialog and save any changes you have made.

Note
When deleting line styles, make sure that the line style is not used in another drawing or document.

Arrow styles
Use the Arrow Styles page (Figure 89) in the Line dialog to create new arrow styles, or modify existing arrow styles, or load previously saved arrow styles.

Creating arrow styles
To create a new arrow style:

1) First draw a curve in the shape you want to use for the arrowhead, or create a shape and convert to a curve. The top of the shape must face upward (as shown in Figure 90) because this becomes the point of the arrow.
2) Select the shape and, if necessary, right-click and choose Convert > To Curve from the context menu to convert the shape to a curve. If the shape is already a curve, To Curve will not be available.
3) With the selection handles showing, select Format > Line from the main menu bar, or right-click and choose Line from the context menu.
4) Go to the Arrow Styles page, click the Add button, type a name for the new arrow style, and click OK. The new arrowhead style will be shown in the preview.
5) Now you can select the new style from the **Arrow style** list. The new style is shown at the bottom of the drop down list.

6) The new arrowhead style created is available only in the current document. If you want to use this arrowhead style in other documents, click the **Save Line Styles** icon and type a unique filename in the **Save as** dialog that opens. Saved styles have the file extension of `.sod`.

7) To use previously saved arrowhead styles, click the **Load Line Styles** icon and select the style from the saved list of styles. Click **Open** to load the style into your document.

8) If necessary, click on the **Modify** button to change the name of the style.

9) Click **OK** to close the dialog and save any changes you have made.

---

### Note

The arrowhead must be a curve, which is something you can draw without lifting a pencil from the paper. For example, a star can be a curve, but a smiley face cannot be a curve because you have to reposition the pencil on the paper to draw eyes and a mouth on the face.

---

#### Deleting arrow styles

To delete an arrow style:

1) Choose **Format > Line** on the main menu bar, or right-click on the line and select **Line** from the context menu, or select the **Line** icon on the **Line and Filling** toolbar to open the **Line** dialog.

2) Click on the **Arrow Styles** tab to open the **Arrow Styles** page (Figure 89 on page 71).

3) Select the arrow style you want to delete from the **Arrow style** drop-down list.

4) Click on the **Delete** button, then confirm the deletion by clicking on the **Yes** button in the confirmation dialog that opens.

5) Click **OK** to close the **Line** dialog and save any changes you have made.

---

### Note

When deleting arrow styles, make sure that the arrow style is not used in another drawing or document.
The term area fill refers to the inside of an object, which can be a uniform color, gradient, hatching, bitmap or pattern as shown in Figure 91. An area fill can be made partly or wholly transparent and can throw a shadow.

**Line and Filling toolbar**

Tools on the **Line and Filling** toolbar (Figure 81 on page 66) provide a wide number of default fillings readily available to quickly format graphic objects. If this toolbar is not showing, go to **View > Toolbars > Line and Filling** on the main menu bar. To format the area of an object:

1) Select an object so that the selection handles are displayed.
2) Click on **Area Style/Filling** on the **Line and Filling** toolbar and, from the drop-down list, select the type of fill required (None, Color, Gradient, Hatching, Bitmap, Pattern) (Figure 92).
3) Click on the right **Area Style/Filling** drop-down list and select one of the available options for the selected type of area. For more information on area fills, see “Area dialog” on Page 75.
   - Color options in Figure 93.
   - Gradient options in Figure 94.
   - Hatching options in Figure 95.
   - Bitmap options in Figure 96.
   - Pattern options, see Fill and Transparency in the **Area** section on the Sidebar (Figure 97) or the Pattern section in **Area** page of the **Area** dialog (Figure 102 on page 78).
4) Deselect the object to save your changes to the object.
To quickly format the area of an object using the Sidebar (Figure 97):

1) Make sure the object is selected in your drawing.

2) Click on the Properties icon on the Sidebar, then click on the down arrowhead \( \downarrow \) on the left of the Area titlebar to open the Area section.

3) Use the various options in the Fill and Transparency drop-down lists of the Area section to format the fill and transparency of an object. For more information on area fills, see “Area dialog” on Page 75.

4) Deselect the object to save your changes.
Area dialog

Use the Area dialog (Figure 98) to change existing area fills with greater control or create your own area fill.

1) Select the object you wish to edit.
2) Next format the area using one of the following methods:
   – Go to Format > Area on the main menu bar.
   – Click on the Area icon on the Line and Filling toolbar.
– Right-click on the object and select **Area** from the context menu to open the **Area** dialog.

3) Click on the **Area** tab to open the **Area** page and to apply an area fill. LibreOffice includes several area fills already defined, but you can create area fills yourself. See “**Working with area fills**” on page 79 for more information.

4) Select the type of area fill from the drop-down list: *None, Color, Bitmap, Gradient, Pattern, or Hatch*. The types of area fill are explained below.

5) Select the style of area fill from the options that become available. The number of available options will depend on the type of area fill selected above.

6) Click **OK** to close the dialog and save your changes. The area fill will then appear in the selected object.

**Types of area fill**

**Color fill**

1) Open the **Area** dialog and click on the **Area** tab to open the **Area** page.

2) Click on **Color** (Figure 98) to open the options available for a color fill.

3) In **Palette**, select your required palette from the drop down list and your required color from the available colors shown. All color fills available are solid colors.

4) **Active** shows the present color fill of your selected object. After selecting a new color, a preview of the selected color appears in **New** in the dialog.

5) Alternatively, enter the *RGB* or *Hex* values of a color in the appropriate text box.

6) Alternatively, click on **Pick** to open the **Pick a Color** dialog (Figure 99). Here you can pick a color from the color box or enter the *RGB*, *Hex*, *HSB* or *CMYK* values for your color.

7) If you have used a color before and would like to use it again, then select your color from those available in **Recent Colors**.

8) Click **OK** to close the dialog and save your changes. The area fill will then appear in the selected object.

![Figure 99: Pick a Color dialog](image-url)
Gradient fill

1) Open the Area dialog and click on the Area tab to open the Area page.
2) Click on Gradient (Figure 100) to open the options available for a gradient fill.
3) In Gradient, select your required gradient from the list of available gradients and it will appear in Preview.
4) To override the default gradient transition in your selection, deselect Automatic in Options and then enter the values for Type, Increment, Angle, Border, From Color and To Color in the available boxes.
5) Click OK to close the dialog and save your changes. The area fill will then appear in the selected object.

Bitmap fill

1) Open the Area dialog and click on the Area tab to open the Area page.
2) Click on Bitmap (Figure 101) to open the options available for a bitmap fill.
3) In Bitmap, select your required bitmap from the list of available bitmaps and it will appear in Preview.
4) To override the settings for the bitmap in your selection, enter the values for Style, Size, Position, Tiling Position, and Tiling Offset in the available boxes under Options.
5) Alternatively, click on Add/Import and select an image from the file selection box that opens to use as a bitmap fill.
6) Click OK to close the dialog and save your changes. The area fill will then appear in the selected object.

Pattern fill

1) Open the Area dialog and click on the Area tab to open the Area page.
2) Click on Pattern (Figure 102) to open the options available for a pattern fill.
3) In Pattern, select your required pattern from the list of available pattern and it will appear in Preview.
4) To override the settings for the pattern in your selection, enter a new pattern in Pattern Editor, then a new Foreground Color and Background Color in the available boxes under Options.

5) Click OK to close the dialog and save your changes. The area fill will then appear in the selected object.

**Hatch fill**

1) Open the Area dialog and click on the Area tab to open the Area page.
2) Click on Hatch (Figure 103) to open the options available for a hatch fill.
3) In Hatch, select your required hatching from the list of available hatchings and it will appear in Preview.
4) To override the settings for the hatching in your selection, enter a new values for Spacing, Angle, Line color and Background Color in the available text boxes under Options.

5) Click OK to close the dialog and save your changes. The area fill will then appear in the selected object.

Working with area fills

Color fills

Creating colors using Area dialog
Using the Area dialog (Figure 98 on page 75), you can create a new color as a combination of the three primary colors Red, Green, and Blue, (RGB notation) as follows:

1) Select the object you wish to edit.
2) Format the area using one of the following methods:
   – Go to Format > Area on the main menu bar.
   – Click on the Area icon on the Line and Filling toolbar (Figure 81 on page 66).
   – Right-click on the object and select Area from the context menu to open the Area dialog.
3) Click on the Colors button to open the Colors page.
4) Specify the red (R), green (G) and blue (B) values on a 0 to 255 scale to create a new color.
5) Click the Add button to open the Name box (Figure 104) and enter a name for the new color.
6) Click OK to close the Name box and add the new color to the Custom palette.
7) Click OK to save your changes and close the Area dialog. The new color will appear as a fill in the selected object.
Creating colors using Pick a Color dialog

You can create a new color using the Pick a Color dialog as follows:

1) Select the object you wish to edit.
2) Format the area using one of the following methods:
   – Go to Format > Area on the main menu bar.
   – Click on the Area icon on the Line and Filling toolbar (Figure 81 on page 66).
   – Right-click on the object and select Area from the context menu to open the Area dialog.
3) Click on the Colors button to open the Colors page (Figure 98 on page 75).
4) Click on the Pick button to open the Pick a Color dialog (Figure 99 on page 76).
5) Create a new color using one of the following methods. A preview of the color created is shown in the colored box next to the original color in the bottom left corner of the dialog.
   – Select a color range from the colored bar, then, using the mouse, move the target in the colored box until you are satisfied with the color selected.
   – Enter values for red (R), green (G) and blue (B) in the RGB text boxes.
   – Enter values for cyan (C), magenta (M), yellow (Y), and key (K) (black) in the CMYK text boxes.
   – Enter values for hue (H), saturation (S) and brightness (B) in the HSB text boxes. HSB values do not change the color, but how a color looks.
6) Click OK to close the Pick a Color dialog.
7) Click the Add button to open the Name box (Figure 104) and enter a name for the new color.
8) Click OK to close the Name box and add the new color to the Custom palette.
9) Click OK to save your changes and close the Area dialog. The new color will appear as a fill in the selected object.

Deleting custom colors

1) Select a filled object that uses the color fill you want to delete.
2) Format the area using one of the following methods:
   – Go to Format > Area on the main menu bar.
   – Click on the Area icon on the Line and Filling toolbar (Figure 81 on page 66).
   – Right-click on the object and select Area from the context menu to open the Area dialog.
3) Click on the Colors button to open the Colors page (Figure 98 on page 75).
4) Select Custom from the Palette drop-down list.
5) Select the color you want to delete and click on the Delete button (Figure 105). There is no confirmation given when deleting a color.

6) Click OK to save your changes and close the Area dialog.

**Note**

It is recommended to only delete colors that you have created from the custom palette. Deleting colors from the standard palettes that are available in LibreOffice, may cause problems in documents that use one of the standard colors.

**Gradient fills**

To create a new gradient or to modify an existing one, select the **Gradients** tab from the Area dialog. Several types of gradients are predefined and, in most cases, changing the colors will be sufficient to obtain the desired result.

**Note**

It is recommended, even if you just want to change the two colors, that you create a new gradient rather than modifying the predefined ones. Predefined gradients should only be used as starting points. Also predefined gradients may have been used in other objects in your drawing or in other documents.

**Creating new gradients**

1) Select the filled object you want to edit.
2) Format the area using one of the following methods:
   – Go to **Format > Area** on the main menu bar.
   – Click on the **Area** icon on the **Line and Filling** toolbar (Figure 81 on page 66).
   – Right-click on the object and select **Area** to open the Area dialog.
3) Click on the **Gradients** tab to open the **Gradients** page (Figure 100 on page 77).
4) In **Options**, select the **From Color** and **To Color** from the drop-down lists.
5) In Options, select the gradient type from the drop-down list: Linear, Axial, Radial, Ellipsoid, Quadratic or Square. A preview of the gradient type is shown in the dialog.

6) Set all the properties as desired. The properties used to create a gradient are summarized in Table 1. Depending on the type of gradient selected, some properties may be grayed out.

7) Click the Add button to open the Name box (Figure 106). Enter a name for the new gradient, then click OK to close the Name box.

8) Click OK to close the Area dialog and save the changes.

Table 1: Gradient properties.

<table>
<thead>
<tr>
<th>Gradient property</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Center X</td>
<td>For Radial, Ellipsoid, Square and Rectangular gradients, modify these values to set the horizontal offset of the gradient center.</td>
</tr>
<tr>
<td>Center Y</td>
<td>For Radial, Ellipsoid, Square and Rectangular gradients, modify these values to set the vertical offset of the gradient center.</td>
</tr>
<tr>
<td>Angle</td>
<td>For all the gradient types, specifies the angle of the gradient axis.</td>
</tr>
<tr>
<td>Border</td>
<td>Increase this value to make the gradient start further away from the border of the shape.</td>
</tr>
<tr>
<td>From Color</td>
<td>The start color for the gradient. In the edit box below enter the intensity of the color: 0% corresponds to black, 100% to the full color.</td>
</tr>
<tr>
<td>To Color</td>
<td>The end color for the gradient. In the edit box below enter the intensity of the color: 0% corresponds to black, 100% to the full color.</td>
</tr>
</tbody>
</table>

Modifying gradients

1) Select an object that contains the gradient as a fill and format the area using one of the following methods:
   – Go to Format > Area on the main menu bar.
   – Click on the Area icon on the Line and Filling toolbar (Figure 81 on page 66).
   – Right-click on the object and select Area to open the Area dialog.

2) Click on the Gradients tab to open the Gradients page (Figure 100 on page 77).

3) Select the gradient you have previously created and added to the Gradients displayed in the Area dialog.

4) Enter the new values for the gradient properties that you want to change. See Table 1 for more information on gradient properties. Depending on the type of gradient selected, some properties may be grayed out.

5) Click Modify to save your changes. There is no confirmation given when modifying a gradient.

6) Click OK to close the Area dialog and save the changes.
**Deleting gradients**

1) Select a filled object that uses the gradient fill you want to delete.
2) Format the area using one of the following methods:
   - Go to Format > Area on the main menu bar.
   - Click on the Area icon on the Line and Filling toolbar (Figure 81 on page 66).
   - Right-click on the object and select Area from the context menu to open the Area dialog.
3) Click on the Gradients tab to open the Gradients page (Figure 100 on page 77).
4) Select the gradient you want to delete.
5) Right click on the gradient and select Delete from the pop-up menu. Click on Yes to confirm the deletion.
6) Click OK to save your changes and close the Area dialog.

**Note**

It is recommended to only delete gradients that you have created. Deleting gradients that are installed with LibreOffice may cause problems in documents that use one of these gradients.

**Advanced gradient controls**

LibreOffice provides advanced controls for gradients as follows.

1) Select an object that contains the gradient as a fill.
2) Format the area using one of the following methods:
   - Go to Format > Area on the main menu bar.
   - Click on the Area icon on the Line and Filling toolbar (Figure 81 on page 66).
   - Right-click on the object and select Area to open the Area dialog.
3) Click on the Gradients tab to open the Gradients page in the Area dialog (Figure 100 on page 77).
4) Go to View > Toolbars > Transformations on the main menu bar or click on the Transformations icon on the Line and Filling toolbar to open the Transformations toolbar.

---

**Figure 107:** Interactive gradient tool on Transformations toolbar
5) Click on the **Interactive gradient tool** icon in the **Transformations** toolbar. This displays a dashed line connecting two colored squares. The colors show the **From Color** and **To Color** that are used for the selected gradient (Figure 107).

6) Select the type of gradient you want to use for the object from the **Type** drop-down list in **Options** on the **Gradients** page in the **Area** dialog. Properties you can adjust will depend on the gradient type you have selected and these are explained below.

   - **Linear gradients** – move the square corresponding to the **From Color** to change where the gradient starts (border value). Move the square corresponding to the **To Color** to change the orientation (angle value).
   
   - **Axial gradients** – move the **To Color** to change both the angle and border properties of the gradient. Only the square corresponding to the **To Color** can be moved.
   
   - **Radial gradients** – move the **From Color** to modify the border property to set the width of the gradient circle. Move the **To Color** to change the point where the gradient ends (**Center X** and **Center Y** values).
   
   - **Ellipsoid gradients** – move the **From Color** to modify the border property to set the size of the gradient ellipsoid. Move the **To Color** to change the angle of the ellipsoid axis and the axis itself.
   
   - **Square and rectangular gradients** – move the **From Color** to modify the border to set the size of the gradient square or rectangle and the angle of the gradient shape. Move the **To Color** to change the center of the gradient.

7) Click **OK** to save your changes and close the **Area** dialog.

---

**Note**

Moving the squares will have different effects depending on the type of gradient. For example, for a linear gradient, the start and end squares of the gradient will always be situated to either side of the center point of the object.

---

**Bitmap fills**

**Editing bitmaps**

1) Select an object that contains a bitmap as a fill or insert a bitmap into a selected object (see “Pattern fill” on page 77 for more information).

2) Go to **Format > Area** on the main menu bar, or click on the **Area** icon on the **Line and Filling** toolbar (Figure 81 on page 66), or right-click on the object and select **Area** to open the **Area** dialog.

3) Click on the **Bitmap** tab to open the **Bitmap** page (Figure 101 on page 78).

4) Select a bitmap from **Bitmap** that you want use and edit as a fill. Note that any imported bitmaps will also be available.

5) In **Options**, select the properties for **Style**, **Size**, **Position**, **Tiling Position** and **Tiling Offset**. See Table 2 for more information on bitmap properties. The best way to understand bitmap properties is to use them. Figure 108 shows examples of bitmap fills and the properties used.

6) Click **OK** to save your changes and close the **Area** dialog.
Table 2: Bitmap options.

<table>
<thead>
<tr>
<th>Bitmap option</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Style – Custom position/size</td>
<td>When this option is selected, the position of the bitmap in the object and the size of the bitmap can be determined.</td>
</tr>
<tr>
<td>Style – Tiled</td>
<td>When this option is selected, the bitmap will be tiled to fill the area. The size of the bitmap used for the tiling is determined by the Size settings.</td>
</tr>
<tr>
<td>Style – Stretched</td>
<td>When this option is selected, a bitmap will be stretched to fill object area.</td>
</tr>
<tr>
<td>Size – Width</td>
<td>Sets the width of the bitmap. For example, 100% means that the bitmap original width will be resized to occupy the whole fill area width, 50% means that the width of the bitmap will be half that of the fill area.</td>
</tr>
<tr>
<td>Size – Height</td>
<td>Sets the height of the bitmap. For example, 100% means that the bitmap original height will be resized to occupy the whole fill area height, 50% means that the height of the bitmap will be half that of the fill area.</td>
</tr>
<tr>
<td>Size – Scale</td>
<td>When selected, bitmap size is given as a percentage for Width and Height. When deselected, the actual size of the bitmap is given for Width and Height.</td>
</tr>
<tr>
<td>Position</td>
<td>When this option is selected, the anchoring point of the bitmap is determined.</td>
</tr>
<tr>
<td>Tiling Position – X-Offset</td>
<td>Sets the offset for the width of the bitmap in percentage values. 50% offset means that Draw will place the middle part of the bitmap at the anchor point and start tiling from there.</td>
</tr>
<tr>
<td>Tiling Position – Y-Offset</td>
<td>Sets the offset for the height of the bitmap in percentage values. 50% offset means that Draw will place the middle part of the bitmap at the anchor point and start tiling from there.</td>
</tr>
<tr>
<td>Tiling Offset</td>
<td>Offsets the columns of tiled bitmaps by the percentage entered in the box so that two subsequent columns of bitmaps are not aligned.</td>
</tr>
</tbody>
</table>

**Importing bitmaps**

To import a bitmap created in another program:

1) Select an object where you want to import a bitmap into.
Figure 109: Importing bitmaps

2) Format the area using one of the following methods:
   – Go to Format > Area on the main menu bar.
   – Click on the Area icon on the Line and Filling toolbar (Figure 81 on page 66).
   – Right-click on the object and select Area to open the Area dialog.

3) Click on the Bitmap tab to open the Bitmap page (Figure 101 on page 78).
4) Click on Add/Import and a file browser dialog opens.
5) Browse to the directory containing the bitmap file and select it, then click Open.
6) Enter a name for the new bitmap in the Name box (Figure 109), then click OK to close the Name box.
7) Click OK to save your changes and close the Area dialog.

Deleting bitmaps

1) Select a filled object that uses the bitmap fill you want to delete.
2) Format the area using one of the following methods:
   – Go to Format > Area on the main menu bar.
   – Click on the Area icon on the Line and Filling toolbar.
   – Right-click on the object and select Area from the context menu to open the Area dialog.
3) Click on the Bitmap tab to open the Bitmap page (Figure 101 on page 78).
4) Right-click on the bitmap and select Delete from the pop-up menu. Click on Yes to confirm the deletion.
5) Click OK to save your changes and close the Area dialog.

Note
It is recommended to only delete bitmaps that you have created or imported. Deleting bitmaps that are installed with LibreOffice may cause problems in documents that use one of these bitmaps.

Pattern fills

Creating or editing patterns

1) Select an object that contains a pattern as a fill or insert a pattern into a selected object (see “Pattern fill” on page 77 for more information).
2) Format the area using one of the following methods:
   - Go to Format > Area on the main menu bar.
   - Click on the Area icon on the Line and Filling toolbar (Figure 81 on page 66).
   - Right-click on the object and select Area to open the Area dialog.
3) Click on the Pattern tab to open the Pattern page (Figure 102 on page 78).
4) Select a pattern from the options available in Pattern. Note that any imported patterns will also be available.
5) In Options, select the color you want to use from the drop down lists for Foreground Color and Background Color (Figure 110).
6) In Options – Pattern Editor, start creating or editing the pattern by clicking with the left mouse button in the squares (pixels) that you want to fill with Foreground Color. Check the Preview window to see if the desired effect is being achieved.
7) If you have created a new pattern, click the Add button to open the Name box (Figure 111). Enter a name for the new pattern, then click OK to close the Name box.
8) If you have edited a pattern, click Modify to save your changes. There is no confirmation given when saving an edited pattern.
9) Click OK to save your changes and close the Area dialog.

Deleting patterns

1) Select a filled object that uses the pattern fill you want to delete.
2) Format the area using one of the following methods:
   - Go to Format > Area on the main menu bar.
   - Click on the Area icon on the Line and Filling toolbar (Figure 81 on page 66).
   - Right-click on the object and select Area from the context menu to open the Area dialog.

Figure 110: Creating or editing patterns

Figure 111: Naming new patterns
3) Click on the **Pattern** tab to open the **Pattern** page (Figure 102 on page 78).

4) Right click on the pattern and select **Delete** from the pop-up menu. Click on **Yes** to confirm the deletion.

5) Click **OK** to save your changes and close the **Area** dialog.

---

**Note**

It is recommended to only delete patterns that you have created. Deleting patterns that are installed with LibreOffice may cause problems in documents that use one of these patterns.

---

### Hatching fills

To create a new hatching fill or to modify an existing one, select the **Hatch** tab from the **Area** dialog. As with gradients and colors, it is better to create a new hatching fill rather than modify a predefined one. The properties that can be set for a hatching pattern are shown in Table 3.

**Table 3: Hatching options.**

<table>
<thead>
<tr>
<th>Hatching option</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>Spacing</td>
<td>Determines the spacing between two lines of the hatching fill. As the value is changed the preview window is updated.</td>
</tr>
<tr>
<td>Angle</td>
<td>Use the mini map below the numerical value to quickly set the angle formed by the line to multiples of 45 degrees. If the required angle is not a multiple of 45 degrees, just enter the desired value in the edit box.</td>
</tr>
<tr>
<td>Line type</td>
<td>Set single, double or triple line for the style of the hatching fill.</td>
</tr>
<tr>
<td>Line color</td>
<td>Use the list to select the color of the lines that will form the hatching fill.</td>
</tr>
<tr>
<td>Background color</td>
<td>When selected, adds a color fill behind the lines used for the hatching fill.</td>
</tr>
</tbody>
</table>

### Creating new hatching fills

1) Select the filled object you want to edit and format the area using one of the following methods:
   - Go to **Format > Area** on the main menu bar.
   - Click on the **Area** icon on the **Line and Filling** toolbar (Figure 81 on page 66).
   - Right-click on the object and select **Area** to open the **Area** dialog.

2) Click on the **Hatch** tab to open the **Hatch** page (Figure 103 on page 79).

3) As a starting point, select a hatching fill similar to the one that you want to create.

4) Modify the options of the lines forming the hatching fill. A preview is displayed in the window below the available patterns. See Table 3 for information on hatching options.

5) Click the **Add** button to open the **Name** box (Figure 112). Enter a name for the new hatching fill, then click **OK** to close the **Name** box. The new hatching appears at the bottom of the hatching fills displayed in **Hatch**.

6) Click **OK** to close the **Area** dialog and save the changes.
Modifying hatching fills

1) Select an object that contains the hatching as a fill.
2) Format the area using one of the following methods:
   – Go to Format > Area on the main menu bar.
   – Click on the Area icon on the Line and Filling toolbar (Figure 81 on page 66).
   – Right-click on the object and select Area to open the Area dialog.
3) Click on the Hatch tab to open the Hatch page (Figure 103 on page 79).
4) Select a hatching you have previously created and added to the Hatch displayed in the Area dialog.
5) Enter the new values for the Options that become available for change. See Table 3 for more information on hatch options.
6) Click Modify to save your changes. There is no confirmation given when modifying a hatching.
7) Click OK to save the Area dialog and save the changes.

Deleting hatching fills

1) Select a filled object that uses the hatching fill you want to delete.
2) Format the area using one of the following methods:
   – Go to Format > Area on the main menu bar.
   – Click on the Area icon on the Line and Filling toolbar (Figure 81 on page 66).
   – Right-click on the object and select Area from the context menu to open the Area dialog.
3) Click on the Hatch tab to open the Hatch page (Figure 103 on page 79).
4) Select the hatching you want to delete.
5) Right click on the hatching and select Delete from the pop-up menu. Click on Yes to confirm the deletion.
6) Click OK to save your changes and close the Area dialog.

Note

It is recommended to only delete hatchings that you have created. Deleting hatchings that are installed with LibreOffice may cause problems in documents that use one of these hatchings.
Shadows

Default shadows
To quickly apply a shadow to an object, select the object and click on the Shadow icon in the Line and Filling toolbar (Figure 81 on page 66). The shadow applied to an object using this method is set to default settings.

Formatting shadows
For a more control when adding shadows to an object, you have to use the Shadow page on the Area dialog as follows:

1) Select an object where you want to apply a shadow.
2) Format the area using one of the following methods:
   – Go to Format > Area on the main menu bar.
   – Click on the Area icon on the Line and Filling toolbar (Figure 81 on page 66).
   – Right-click on the object and select Area to open the Area dialog.
3) Click on the Shadow tab to open the Shadow page (Figure 113).
4) Select Use shadow in Properties for the shadow options to become active.
5) Select the anchor point for the direction of the shadow cast in relation to the object.
6) In Color, select the color palette and the color you require for the shadow.
7) In Distance, enter a distance in the text box to set spacing between the object and the shadow.
8) In Transparency, enter the percentage in the text box for the shadow transparency.
9) Click OK to close the Area dialog and save the changes.

Transparencies
Transparency can be applied to filled objects as well as shadows and lines.

- To apply transparency to lines, refer to “Formatting lines” on page 66.
- To apply a transparency to shadows, refer to “Formatting shadows” on page 90.

To apply transparency to filled objects using the Transparency page on the Area dialog:

1) Select an object where you want to apply a transparency.
2) Format the area using one of the following methods:
   – Go to **Format > Area** on the main menu bar.
   – Click on the **Area** icon on the **Line and Filling** toolbar (Figure 81 on page 66).
   – Right-click on the object and select **Area** to open the **Area** dialog.

3) Click on the **Transparency** tab to open the **Transparency** page (Figure 114).

4) To create a uniform transparency, select **Transparency** and enter a percentage in the text box.

5) To create a gradient transparency so that the area becomes gradually transparent, select **Gradient** and select the type of gradient transparency from the drop-down list: **Linear**, **Axial**, **Radial**, **Ellipsoid**, **Quadratic** or **Square**.

6) Set the parameters for the type of the gradient transparency you selected above. Refer to Table 4 for a description of the properties. The available parameters will depend on the type of gradient transparency selected above.

7) Click **OK** to close the **Area** dialog and save the changes.

### Table 4: Transparency parameters

<table>
<thead>
<tr>
<th><strong>Transparency parameters</strong></th>
<th><strong>Meaning</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Centre X</td>
<td>For <strong>Radial</strong>, <strong>Ellipsoid</strong>, <strong>Quadratic</strong> and <strong>Square</strong> gradients. The values to set the horizontal offset of the gradient center.</td>
</tr>
<tr>
<td>Center Y</td>
<td>For <strong>Radial</strong>, <strong>Ellipsoid</strong>, <strong>Quadratic</strong> and <strong>Square</strong> gradients. The values to set the vertical offset of the gradient center.</td>
</tr>
<tr>
<td>Angle</td>
<td>For <strong>Linear</strong>, <strong>Axial</strong>, <strong>Ellipsoid</strong>, <strong>Quadratic</strong> and <strong>Square</strong> gradients. Specifies the angle of the gradient axis.</td>
</tr>
<tr>
<td>Border</td>
<td>Increase this value to make the gradient start further away from the border of the object.</td>
</tr>
<tr>
<td>Start value</td>
<td>Value for the starting transparency gradient. 0% is fully opaque, 100% means fully transparent.</td>
</tr>
<tr>
<td>End value</td>
<td>Value for the ending transparency gradient. 0% is fully opaque, 100% means fully transparent.</td>
</tr>
</tbody>
</table>
Using drawing object styles

Note

In LibreOffice Draw, only drawing object styles are available in the Graphic Styles dialog and the Styles deck on the Sidebar.

Suppose that you want to apply the same area fill, line thickness, and border to a set of objects. This repetitive process can be greatly simplified by the use of styles. Styles allow you to define a formatting template (a style) and then to apply that style to multiple objects. For more information on styles, see the Chapter 6 Introduction to Styles in the Writer Guide.

Linked styles

Drawing object styles support inheritance. This means that a style can be linked to another (parent) style so that it inherits all the formatting settings of the parent. You can use this property to create families of styles.

For example, if you need multiple boxes that differ in color, but are otherwise identically formatted, it is recommended to create a generic style for the box including borders, area fill, font, and so on. You then create a number of hierarchically dependent styles which differ only in the fill color attribute. If you then need to change the font size or the thickness of the border, it is sufficient to change the parent style and all the other linked styles will change accordingly.

Note

When styles are linked, changing a color will change the color in all linked styles. Sometimes this is exactly what you want; at other times you do not want the changes to apply to all linked styles. It pays to plan ahead.

Creating new styles

After creating a new style, it will be placed in All Styles and Custom Styles in the Styles deck of the Sidebar. When the your new style is applied to an object, the new style will also appear in Applied Styles.

Using Styles deck

1) Click on the Styles icon on the Sidebar to open the Styles deck (Figure 115).
2) Right click on a style and select New from the context menu to open the Graphic Styles dialog (Figure116).
3) Click on the Organizer tab to open the Organizer page in the Graphic Styles dialog.
4) In the Name text box, type a memorable style name.
5) In Inherit from, select a style from the drop down list a style if you want your new style to inherit settings from a LibreOffice style.
6) Use the various pages and available options in the **Graphic Styles** dialog to format and categorize your new style.
   - **Organizer** – contains a summary of the style and its hierarchical position.
   - **Font, Font Effects, Indents & Spacing, Alignment, and Tabs** – set the properties of the text inserted in a text box or in a graphic object.
   - **Dimensioning** – used to set the style of dimension lines.
   - **Text, Text Animation, Connector, Line, Area, Shadowing, Highlighting and Transparency** – determine the formatting of an object.

7) Click **OK** when finished to save your new style and close the **Graphic Styles** dialog.

**New style from selection**

1) Select the object you want to use to create your new style, or create a new object in your drawing.

2) Use the various options in the pages of the **Graphic Styles** dialog (Figure 116), or the various tools on the **Line and Filling** toolbar (Figure 81 on page 66) to make your changes to the object.
3) Go to Format > Styles > New Style from Selection on the main menu bar or click on the New Style from Selection icon in the Styles deck on the Sidebar.

4) In the Create Style dialog (Figure 117) that opens, type a name for the new style. This dialog also shows existing custom styles that are available.

5) Click OK to save the new style and close the dialog.

Modifying or editing styles
It is recommended to only modify or edit styles that you have created. Modifying or editing styles that are installed with LibreOffice may cause problems in other documents that use one of these styles.

1) Select an object in your drawing.

2) Open the Graphic Styles dialog (Figure 116) using one of the following methods:
   – Go to Format > Styles > Edit Style on the main menu bar.
   – Right click on the object and select Edit Style from the context menu.
   – Right click on the object style in the Styles deck on the Sidebar and select Modify from the context menu.

3) Use the various pages and available options in the Graphic Styles dialog to modify and edit the object style.
   – Organizer – contains a summary of the style and its hierarchical position.
   – Font, Font Effects, Indents & Spacing, Alignment, and Tabs – set the properties of the text inserted in a text box or in a graphic object.
   – Dimensioning – used to set the style of dimension lines.
   – Text, Text Animation, Connector, Line, Area, Shadowing, Highlighting and Transparency – determine the formatting of an object.

4) Click OK when finished to save your changes and close the Graphic Styles dialog.

Editing linked styles
If you have an object in your document that uses linked styles then it is possible to edit the linked styles that have been applied to the object. This done using the Graphic Styles dialog as follows:

1) Select an object in your drawing that uses linked styles.

2) Go to Format > Styles > Edit Style on the main menu bar or right click on the object and select Edit Style from the context menu to open the Graphic Styles dialog (Figure 116 on page 93).
3) Click on the Organizer tab to open the Organizer page in the Graphic Styles dialog.

4) Check that the style name in the Inherit from text box is the linked style you want to edit.
   a) If the linked style is the one you want to edit, use the various pages in the Graphic Styles dialog to edit the style.
   b) If the linked style is NOT the one you want to edit, click on Edit Style to the right of the Inherit from text box until the name of the linked is displayed. Use the various pages in the Graphic Styles dialog to edit the style.

5) Click OK when finished to save your changes and close the Graphic Styles dialog.

**Note**

Updating linked styles that are part of the default installation of LibreOffice could cause problems in other documents that use LibreOffice default styles.

### Updating styles

To update a style from changes made to an object:

1) Select the object where you want to make changes to the style.

2) Use the various options in the pages of the Graphic Styles dialog (Figure 116 on page 93), or the various tools on the Line and Filling toolbar (Figure 81 on page 66) to make your changes to the object.

3) Use one of the following methods to update the style that has been applied to the object.
   - Click on the Update Style icon in the Styles deck on the Sidebar.
   - Click on Format > Styles > Update Selected Style on the main menu bar.

**Note**

There is no confirmation when you update a style. Make sure that you only update styles that you have created. Updating styles that are part of the default installation of LibreOffice could cause problems in other documents that use LibreOffice default styles.

### Applying styles

You can apply a drawing object style using the Styles deck on the Sidebar as follows:

1) Select the object where you want to apply a style.

2) To open a list of available styles, click on the Styles icon on the Line and Filling toolbar (Figure 81 on page 66), or click on the Styles icon on the Sidebar (Figure 115 on page 93).

3) Double click on the style name to apply the style to the selected object.

**Tip**

At the bottom of the Styles deck on the Sidebar there is a drop-down list. Here you can choose to show all styles or groups of styles such as Applied Styles or Custom Styles.
Deleting styles

You cannot delete any of the predefined styles in LibreOffice, even if you are not using them. You can only delete user-defined (custom) styles. However, before you delete a custom style, make sure the style is not in use. To see which styles are in use, choose Applied Styles from the drop-down list at the bottom of the Styles deck on the Sidebar (Figure 115 on page 93).

Delete a custom style as follows:

1) To open a list of available styles, click on the Styles icon on the Line and Filling toolbar (Figure 81 on page 66), or click on the Styles icon on the Sidebar (Figure 115 on page 93).
2) Select Applied Styles or Custom Styles from the drop down list at the bottom of the Styles deck on the Sidebar to display the styles in use.
3) Right click on the style name in the styles list and select Delete from the context menu.
4) If the style is in use, a warning message will appear. Click Yes to delete the style. If the style is not in use, no confirmation message appears.

Applying special effects

As well as the basic actions of moving and resizing an object, a number of special effects can also be applied to objects in Draw. Several of these effects are readily available in the Transformations toolbar (Figure 118). If the Transformations toolbar is not showing, select it from View > Toolbars > Transformations on the main menu bar.

The tools available on the Transformations toolbar are described in the following sections with the exception of the 3D rotation tool, which is described in Chapter 7 Working with 3D Objects.
Rotating objects
Rotation of an object can be carried out manually or using a dedicated dialog. This is similar to changing the position or size of an object.

Manual rotation
1) Click on an object you want to rotate and the selection handles will show.
2) To put the selected object into rotation mode, use one of the following methods. The selection handles will change shape and color when in rotation mode (Figure 119).
   – Click again on the selected object.
   – Click on the down arrow to the right the Transformations icon in the Line and Filling and select the Rotate icon from the context menu.
   – If the Transformations toolbar is displayed (Figure 118) click on the Rotate icon.
3) If necessary, click and drag the rotation pivot point to change the way the object is rotated. The pivot point is a circle and appears, by default, in the middle of the selected object. Normally the center of an object will be just fine, but on some occasions you may wish to rotate around a corner or even around a point outside the object.
4) Move the mouse cursor over one of the corner handles and the cursor changes shape.
5) Click and move the mouse in the direction in which you want to rotate the object. Only the corner selection handles are active for rotation.
6) To restrict the rotation angles to multiples of 15 degrees, press and hold the Shift key while rotating the object. This is very handy for rotating objects through a right angle, for example from portrait to landscape.
7) When satisfied release the mouse button.

Sidebar rotation
To rotate an object using the Position and Size section in the Properties deck on the Sidebar (Figure 120):
1) Click on an object you want to rotate and the selection handles will show.
2) Click on the Properties icon on the Sidebar to open the Properties deck, then click on the down arrowhead (˅) next to the Position and Size section to open this section.
3) Click on and then rotate the rotation indicator in Rotation or enter the rotation angle in the text box or select a predetermined rotation angle from the drop-down list. The object rotates as you move the rotation indicator or enter an angle in the text box.
4) When satisfied with the rotation of the object, click outside the object to fix rotation in place.

Rotation dialog
Instead of rotating an object manually or using the Sidebar, you can use the Rotation page in the Position and Size dialog (Figure 121) for a more precise control when rotating an object.
1) Click on an object you want to rotate and the selection handles will show.
2) Press the F4 key, or select Format > Position and Size on the main menu bar, or right-click on the object and select Position and Size from the context menu to open the Position and Size dialog.
3) Click the Rotation tab to open the Rotation page.
4) In the Pivot Point, enter a figure in Position X and/or Position Y text boxes to reposition the pivot point relative to the top left corner of the drawing, or select a position for the pivot point in Default settings. The default position for the pivot point is the center of the object.
5) In the Rotation Angle, enter an angle in the Angle text box by which to rotate the object, or click and drag the rotation indicator in Default settings until you reach the required angle. As you click and drag, the angle is shown in the Angle text box.

6) Click OK to save your changes, rotate the object and close the Position and Size dialog.

**Flipping objects**

**Quick flipping**
The quickest and easiest method to flip an object horizontally or vertically is as follows:

1) Select the object you want to flip and the selection handles will be displayed.
2) Use one of the following methods to flip the object vertically or horizontally:
   – Right click on the object and select **Flip > Horizontally** or **Flip > Vertically** from the context menu.
   – In the **Position and Size** section of the **Properties** deck on the Sidebar, click on one of the icons **Flip the selected object vertically** or **Flip the selected object horizontally**.
   – Click on the **Vertical** or **Horizontal** icon on the **Line and Filling** toolbar (Figure 81 on page 66).

**Flip tool**
Using the **Flip** tool on the **Transformations** toolbar (Figure 118 on page 96), you can also change the position and angle that the object flips over.

1) Select the object you want to flip and the selection handles will be displayed.
2) Click the **Flip** tool on the **Transformations** toolbar and the axis of symmetry appears as a dashed line through the middle of the object. The object will be flipped about this axis of symmetry (Figure 122).
3) Click and drag one or both ends of the axis of symmetry to set the orientation of the axis.
4) Place the cursor over one of the object selection handles until it changes shape.
5) Click and drag the object across to the other side of the axis of symmetry until the object appears flipped over. The angle and position of the flip will depend on the angle and position of the axis of symmetry.
6) Release the mouse button and the object is flipped.

*Figure 122: Using Flip tool on Transformations toolbar*
**Note**

If you press the *Shift* key while moving the axis of symmetry, it will rotate in 45 degree increments.

---

**Mirror copies**

At the moment there is no mirror command existing in Draw. However, mirroring an object can be emulated by using the *Flip* tool as follows:

1. Select the object you want to make a mirror copy of and copy the object to the clipboard.
2. Select the *Flip* tool on the *Transformations* or *Line and Filling* toolbars.
3. Move the axis of symmetry to the desired location of the mirror axis, then flip the object.
4. Click on an empty area of the page to deselect the object.
5. Paste from the clipboard to put a copy of the object back into its original location and now you have a mirror copy.
6. If necessary, select both objects and realign them by going to *Shape > Align* on the main menu bar, or right click and select *Align* from the context menu and then select the type of alignment.

---

**Distorting images**

Three tools on the Transformations toolbar let you drag the corners and edges of an object to distort the image.

- **Distort** distorts an object in perspective.
- **Set to Circle (slant)** creates a pseudo three-dimensional effect.
- **Set in Circle (perspective)** creates a pseudo three-dimensional effect.

In all three cases you are initially asked if you want to transform the object to a curve. This is a necessary first step, so click *Yes*. Then you can move the object handles to produce the desired effect. Examples of using these tools are shown in the following figures.

**Distorting**

Select an object and click on the **Distort** icon on the *Transformations* toolbar (Figure 118 on page 96). After converting to a curve as requested, move the handles to stretch the object. The corner handles distort the corners, the vertical midpoint handles distort the figure horizontally and the horizontal ones distort it vertically (Figure 123).

**Setting in circle (perspective)**

Select an object and click on the **Set in Circle (perspective)** icon in the *Transformations* toolbar (Figure 118 on page 96). After converting to a curve as requested, click and move one of the selection handles to give a pseudo three dimensional perspective) (Figure 124).

**Setting to circle (slant)**

Select an object and click on the **Set to Circle (slant)** icon in the *Transformations* toolbar (Figure 118 on page 96). After converting to a curve as requested, click and move one of the selection handles to give a pseudo three dimensional slant perspective (Figure 125).
Figure 123: Distorting an object

Figure 124: Setting an object to a circle with perspective

Figure 125: Setting an object to a circle with slant
Dynamic gradients

You can control transparency gradients in the same manner as color gradients and both types of gradient can be used together. With a transparency gradient, the direction and degree of object fill color changes from opaque to transparent. In a color gradient, the fill changes from one color to another, but the degree of transparency remains the same.

Two icons are present on the Transformations toolbar (Figure 118 on page 96) to dynamically control transparency and color gradients. Even if you have not assigned transparency to an object with a color fill, you can control the transparency by clicking on the Interactive transparency tool icon. This defines a transparency gradient and a dashed line connecting two squares appears on the object. Move the two squares to modify the gradient. You can define the direction of the gradient (vertical, horizontal, or at any angle) and the spot at which the transparency begins.

A regular color gradient is defined in the same manner. Select an object, then select a gradient fill from the Gradients page of the Area dialog (Figure 100 on page 77). The Interactive gradient tool icon is now active on the Transformations toolbar. When you click on the Interactive gradient tool, a dashed line connecting two squares appears on the object, just as it does for a transparency gradient.

In both transparency gradient and gradient fill, click outside the object to set the gradient.

In the example shown in Figure 126 there is a single color object and a transparency gradient, covering part of the underlying object. This gradient transparency can be dynamically adjusted. Direction of transparency is changed by moving the white square and the distance over which it is applied by moving the green square.

Note

Moving the squares will have different effects, depending on the type of gradient. For example, for a linear gradient, the start and end squares of the gradient will always be situated to either side of the center point of the object.
Chapter 5
Combining Multiple Objects
**Grouping objects**

Grouping of objects is similar to putting objects into a container. You can move the objects as a group and apply global changes to the objects within the group. A group can always be undone and the objects that make up the group can always be manipulated separately.

**Temporary grouping**

A temporary grouping is when several objects are selected. Any changes to object parameters that you carry out are applied to all of the objects within the temporary group. For example, you can rotate a temporary group of objects in its entirety.

To cancel a temporary grouping of objects, simply click outside of the selection handles displayed around the objects.

**Grouping**

To group objects together permanently:

1) Select the objects you want to group using one of the following methods. Selection handles will then appear around all the objects selected for the group (Figure 127).
   - Click on each object in turn while holding down the `Shift` key.
   - Use the Select tool on the Drawing toolbar and draw a selection rectangle around the objects using the cursor.

2) Group the selected objects using one of the following methods:
   - Right-click on the group and select Group from the context menu.
   - Go to Shape > Group > Group on the main menu bar.
   - Use the keyboard shortcut `Ctrl+Shift+G`.

When objects are grouped, any editing operations carried out on that group are applied to all objects within the group. If you click on one object in the group, the whole group is selected.

The objects within a group also retain their own individual properties and can be edited independently. See “Editing individual group objects” on page 105 for more information.

![Figure 127: Grouping objects](image-url)
**Ungrouping**

To undo or ungroup a group of objects:

1) Select the group of objects which is indicated by selection handles appearing around the group (Figure 127).

2) Ungroup the group of objects using one of the following methods:
   - Right-click on the group and select Ungroup from the context menu.
   - Go to **Shape > Group > Ungroup** on the main menu bar.
   - Use the keyboard shortcut **Ctrl+Alt+Shift+G**.

**Editing individual group objects**

You can individually edit an object within a group without ungrouping the group.

1) After selecting a group, enter the group using one of the following methods. When you enter a group, objects outside the group cannot be selected for editing (Figure 127).
   - Right-click on the group and select Enter Group from the context menu.
   - Go to **Shape > Group > Enter Group** on the main menu bar.
   - Press the **F3** key.
   - Double-click on the group.

2) Once inside the group, click on any object to individually edit it (Figure 128).

3) After making your changes to an individual object, exit the group using one of the following methods:
   - Right-click on the group and select Exit Group from the context menu.
   - Go to **Shape > Group > Exit Group** on the main menu bar
   - Use the keyboard combination **Ctrl+F3**.
   - Double-click outside the group.

![Figure 128: Editing in a group](image)

**Nesting groups**

You can create a group of groups, which are more commonly known as nesting groups. When you create nested groups, Draw retains the individual group hierarchy and remembers the order in which groups were selected. That is, the last individual group selected will be on top of all the other groups within a nested group.
Ungrouping and entering a nested group works in exactly the same way as for individual groups in “Grouping” on page 104, “Ungrouping” on page 105 and “Editing individual group objects” on page 105.

**Combining objects**

Combining objects is a permanent merging of objects that creates a new object. The original objects are no longer available as individual entities and cannot be edited as individual objects. Any editing of a combined object affects all the objects that were used when combination was carried out.

**Combining**

1) Select the objects you want to combine.
2) Combine the selected objects using one of the following methods:
   – Right-click on the selection and select **Shapes > Combine** from the context menu
   – Go to **Shape > Combine** on the main menu bar.
   – Use the keyboard combination **Ctrl+Shift+K**.

At first glance, the results can seem rather surprising, but once you understand the rules governing combination in Draw, combining objects will become clearer.

- The attributes (for example, area fill) of the resulting object are those of the object furthest back. In Figure 129, it is the circle and Figure 130 it is the yellow rectangle.
- Where the objects overlap, the overlapping zone is either filled or empty depending on whether the overlap is even numbered or odd numbered. Figure 130 shows that where the overlap number is even, you get an empty space and where the overlap number is odd, you get a filled area.

---

**Figure 129: Combining objects**

**Figure 130: Combining objects**
Tip

You can reorder objects so they are further back or further forward in the arrangement order. Right-click on the object and select **Arrangement** from the context menu and select one of the options available. For more information, see “Arranging objects” on page 113.

### Splitting combined objects

An object which has been combined from several objects can be split into individual objects using one of the following methods after selecting the combined object:

- Going to **Shape > Split** on the main menu bar
- Using the keyboard shortcut **Ctrl+Alt+Shift+K**.

However, the original objects will retain the formatting of the combined object and will not revert back to their original formatting.

In Figure 131, the left graphic is the original object, as shown on the left in Figure 130. The right graphic is the result of splitting and the individual objects have taken the formatting of the combined object, as shown on the right in Figure 130.

---

**Figure 130:** Area fill on overlapping objects

**Figure 131:** Splitting a combined object

**Figure 132:** Breaking a combined object

---

*Combining objects | 107*
Breaking combined objects

When an object is combined from several objects, the combined object can be broken into its constituent parts by going to Shape > Break on the main menu bar. This means that the original objects are broken into their constituent parts; for example, a rectangle will be broken into four separate lines and the area fill will be lost, as shown by the right graphic in Figure 132. The left graphic in Figure 132 is the original combined object.

Connecting lines

The constituent parts of an object can be connected together by selecting all the constituent parts of the object and going to Shape > Connect on the main menu bar. This connects the parts together and closes the object resulting in the area becoming filled with the area fill it had before the object was broken.

Merging, subtracting, or intersecting objects

After you have selected more than one object, the merge, subtract, and intersect functions become available. This allows you to create a new object with a new shape.

Merge

When you merge objects, a new object is created with a shape that follows the shape of the merged objects. The area fill of the merged object is determined by the area fill of the object that is at the rear of all the other objects, as shown in Figure 133.

After selecting several objects, use one of the following methods to merge the objects:

- Go to Shape > Merge on the main menu bar.
- Right-click on the selected objects and select Shapes > Merge from the context menu.
**Subtract**

When you subtract objects, the objects at the front are subtracted from the object behind. This leaves a blank space that the subtracted objects occupied creating a new shape, as shown in Figure 134.

After selecting several objects that overlap each other, use one of the following methods to subtract objects:

- Go to **Shape > Subtract** on the main menu bar.
- Right-click on the selected objects and select **Shapes > Subtract** from the context menu.

**Intersect**

When you intersect objects, the front objects and the exposed area of the object at the rear are removed. This creates a new object from the area of the object at the rear that was covered by the objects at the front, as shown in Figure 135.

After selecting several objects that overlap each other, use one of the following methods to intersect objects:

- Go to **Shape > Intersect** on the main menu bar.
- Right-click on the selected objects and select **Shapes > Intersect** from the context menu.

![Figure 135: Intersecting objects](image)

**Practical example**

The example in Table 5 shows how you can use the merge, subtract, and intersect functions to create a knife with a wooden handle.

Table 5: *Creating a knife*

| Draw an ellipse and then a rectangle overlapping half of its width. |
| Select both shapes, right-click, and select **Shapes > Subtract** from the context menu. |
| Draw another rectangle and put it over the top half of the ellipse. |
Select both shapes, right-click, and select **Shapes > Subtract** from the context menu.

Draw a small ellipse covering just the lower right corner.

Select both shapes, right-click, and select **Shapes > Subtract** from the context menu. The knife blade shape is now complete.

To make the handle, draw a rectangle and an ellipse.

Merge the shapes together.

Position the handle on the blade. Select the handle and blade, then group together to create a drawing of the knife.

**Duplication and cross fading**

**Duplication**

Duplication makes copies of an object while applying a set of changes (such as color or rotation) to the duplicates.

To duplicate an object or group of objects:

1) Select an object or group of objects, then duplicate the object(s) using one of the following methods to open the **Duplicate** dialog (Figure 136):
   - Go to **Edit > Duplicate** on the main menu bar.
   - Go to **Shape > Duplicate** on the main menu bar.
   - Use the keyboard shortcut `Shift+F3`.

2) Select the number of copies, placement, enlargement, and the start and end colors for your duplicate copies.

3) Click **OK** and your duplicate copies are created. An example of a duplication is shown in Figure 137. Each duplicate object is a separate object.

4) To group the duplicate objects into one group, see “Grouping objects” on page 104.

5) To combine the duplicate objects into one object, see “Combining objects” on page 106.

The **Duplicate** dialog (Figure 136) has the following options:

- **Number of copies** – enter the number of copies you want to make.
- **Placement** – sets the position and rotation of a duplicate object with respect to the selected object.
  - **X axis** – enter the horizontal distance between the centers of the selected object and the duplicate object. Positive values shift the duplicate object to the right and negative values shift the duplicate object to the left.
  - **Y axis** – enter the vertical distance between the centers of the selected object and the duplicate object. Positive values shift the duplicate object down and negative values shift the duplicate object up.
- **Angle** – enter the angle (0 to 359 degrees) by which you want to rotate the duplicate object. Positive values rotate the duplicate object in a clockwise direction and negative values in a counterclockwise direction.

- **Enlargement** – sets the size of a duplicate object.
  - **Width** – enter the amount by which you want to enlarge or reduce the width of the duplicate object.
  - **Height** – enter the amount by which you want to enlarge or reduce the height of the duplicate object.

- **Colors** – sets the colors for the selected object and the duplicate object. If you make more than one copy, these colors define the start and end points of a color gradient.
  - **Start** – choose a color for the selected object.
  - **End** – choose a color for the duplicate object. If you are making more than one copy, this color is applied to the last copy.
Cross fading

Cross-fading transforms one object shape into another object shape. The result is a new group of individual objects that includes the start and end objects. The intermediate steps show the transformation from one object shape to another object shape.

To cross-fade two objects:

1) Select two objects and go to **Shape > Cross-fading** on the main menu bar to open the **Cross-fading** dialog (Figure 138).
2) Select the number of **Increments** for the transformation.
3) If necessary, select **Cross-fade attributes** and **Same orientation**.
4) Click **OK** to perform the cross-fading and close the **Cross-fading** dialog. An example of cross-fading is shown in Figure 139 with **Same orientation** deselected. The object created is a group of objects.
5) To ungroup this group of objects so that you can use the individual objects, see “**Ungrouping**” on page 105.

The **Cross-fading** dialog has the following options:

- **Increments** – enter the number of shapes you want between the two selected objects.
- **Cross-fade attributes** – applies cross-fading to the line and fill properties of the selected objects. For example, if the selected objects are filled with different colors, a color transition between the two colors is applied.
- **Same orientation** – applies a smooth transition between the selected objects.
Positioning objects

Arranging objects

When you combine, merge, subtract, or intersect objects, the end result varies depending on which object is at the front and which object is at the back. Each new object that you place on a drawing automatically becomes the front object and all the other objects move backwards in positioning order. Arranging objects allows you to change the order in which objects are positioned.

First select one or more objects, then use one of the following methods to select a positioning arrangement:

- Click on small triangle to the right of the **Arrange** icon on the **Standard** toolbar to open a pop up toolbar.
- Click one of the positioning icons on the **Line and Filling** toolbar.
- Click on **Shape > Arrange** on the main menu bar and select one of the arrangement options.

The positioning tools available are as follows and shown in Figure 140:

- **Bring to Front** – brings the selected object to the front of the group.
- **Bring Forward** – brings the selected object forward one step.
- **Send Backward** – sends the selected object one step backward.
- **Send to Back** – sends the selected object to the back of the group.
- **In Front of Object** – moves the selected object in front of another selected object.
- **Behind Object** – moves the selected object behind another selected object.
- **Reverse** – reverses the order of the selected objects. This tool is grayed out if only one object is selected.

**Note**

The positioning tools can be turned into a floating toolbar by clicking at the top of the pop up toolbar and dragging it to a new position on your drawing workspace.

![Position toolbar](image-url)
Aligning objects

To make your drawing look more professional, you can align objects with each other. Select one or more objects and use one of the following methods to align objects:

- Click on small triangle to the right of the Align icon on the Line and Filling toolbar to open a pop up toolbar.
- Go to Shape > Align on the main menu bar and select the alignment required.

The alignment tools available are as follows and shown in Figure 141:

- **Left** – aligns the left edges of the selected objects. If only one object is selected, the left edge of the object is aligned to the left page margin.
- **Centered** – horizontally centers the selected objects. If only one object is selected, the center of the object is aligned to the horizontal center of the page.
- **Right** – aligns the right edges of the selected objects. If only one object is selected, the right edge of the object is aligned to the right page margin.
- **Top** – vertically aligns the top edges of the selected objects. If only one object is selected, the top edge of the object is aligned to the upper page margin.
- **Center** – vertically centers the selected objects. If only one object is selected, the center of the object is aligned to the vertical center of the page.
- **Bottom** – vertically aligns the bottom edges of the selected objects. If only one object is selected, the bottom edge of the object is aligned to the lower page margin.

**Note**

The alignment tools can be turned into a floating toolbar by clicking at the top of the pop up toolbar and dragging it to a new position on your drawing workspace.

Distributing objects

Distributing objects allows you to space three or more objects evenly along the horizontal axis or the vertical axis. Objects are distributed using the outermost objects in the selection as base points for spacing.
Select at least three objects, then use one of the following methods to open the Distribution dialog (Figure 142) and arrange the objects:

- Go to Shape > Distribution on the main menu bar.
- Right-click and select Distribution from the context menu to open.
- Click on the Distribution icon on the Line and Filling toolbar.

The options available in the Distribution dialog are explained as follow:

- **Horizontal** distribution specifies the horizontal distribution between the selected objects.
  - *None* – does not distribute the objects horizontally.
  - *Left* – distributes the selected objects so that the left edges of the objects are evenly spaced from one another.
  - *Center* – distributes the selected objects so that the horizontal centers of the objects are evenly spaced from one another.
  - *Spacing* – distributes the selected objects horizontally so that the objects are evenly spaced from one another.
  - *Right* – distributes the selected objects so that the right edges of the objects are evenly spaced from one another.

- **Vertical** distribution specifies the vertical distribution between the selected objects.
  - *None* – does not distribute the objects vertically.
  - *Top* – distributes the selected objects so that the top edges of the objects are evenly spaced from one another.
  - *Center* – distributes the selected objects so that the vertical centers of the objects are evenly spaced from one another.
  - *Spacing* – distributes the selected objects vertically so that the objects are evenly spaced from one another.
  - *Bottom* – distributes the selected objects so that the bottom edges of the objects are evenly spaced from one another.
Chapter 6
Editing Pictures
Raster Graphics
Introduction

Earlier chapters of the Draw Guide have dealt only with vector graphics. The most common types of vector graphics in use are as follows:

- **SVG** – Scalable Vector Graphics. An Extensible Markup Language (XML) based vector image format for two-dimensional graphics with support for interactivity and animation.
- **EPS** – Encapsulated PostScript. A PostScript document format usable as a graphics file format. EPS files are more-or-less self-contained, reasonably predictable PostScript documents that describe an image or drawing and can be placed within another PostScript document.
- **AI** – Adobe Illustrator. A proprietary file format developed by Adobe Systems for representing single-page vector-based drawings in either the EPS or PDF formats.

However, Draw also contains a number of functions for handling raster graphics (bitmaps) such as photographs and scanned pictures, including import, export, and conversion from one format to another.

Draw can read all the majority of graphic file formats. It has a subset of capabilities similar to raster graphics programs like Adobe Photoshop or Gimp. Raster graphics are generally images or pictures that use one of the following formats, which are the most common formats in use:

- **JPG/JPEG** – acronym for Joint Photographic Experts Group which created the format. It is the most common image format on World Wide Web and most digital cameras produce JPEG images as default.
- **GIF** – Graphics Interchange Format. GIF is a bitmap image format that is popular because of its wide support and portability.
- **PNG** – Portable Network Graphics. PNG is a raster image format which supports lossless data compression and also background transparency.
- **TIF/TIFF** – Tagged Image File Format. TIFF is flexible, adaptable, and capable of storing image data in a lossless format.
- **BMP** – BitMaP. It is also known as bitmap image file, which is a dot matrix data structure.

Importing graphics

Inserting

To import graphic files into your drawing, go to Insert > Image on the main menu bar or click on the Insert Image icon on the Standard toolbar to open the Insert Image dialog (Figure 143).

Draw contains import filters for the majority of graphic formats. If the file you want to import has a graphic format not covered by the import filters, then it is recommended to use one of the many free graphic conversion programs to convert the file into a format that Draw recognizes.

If you select the Preview option in the Insert Image dialog, a preview of the file is shown in the box on the right-hand side. This makes it much easier to select the file you want and also checks that Draw can import the file format used.
Embedding

Embedding a graphic into a drawing makes the graphic a permanent part of the drawing. Any changes you make to an embedded graphic will only appear in the drawing. The original graphic file will not be affected.

Embedding happens when you import a graphic into a drawing using the Insert Image dialog (Figure 143), copying and pasting, scanning a graphic, or dragging and dropping.

The main advantage of embedding graphics into your drawing is that the graphic is always available no matter what computer is used to open the drawing.

The main disadvantage of embedding graphics is that it creates large file sizes, which may not be desirable if you have limited capacity for storing computer files. Also, if the original graphic is altered, then your drawing will not have an up to date version each time you open your document.

Note

When you embed a graphic into a LibreOffice document or drawing, you must make sure that the Link option is not selected in the Insert Image dialog.

Linking

Linking a graphic to a drawing does not insert the graphic into the drawing, but a link is created to where the graphic file is located on your computer. Each time the drawing is opened, any linked graphics will be displayed in the drawing.

The main advantage of linking a graphic file to a drawing is if the original graphic file is altered or replaced by a new graphic with the same filename. The next time you open the drawing, the latest version of the graphic will also open in the drawing. Also the drawing file size is much smaller and the original graphic can easily be edited with specialized external applications.

The main disadvantage of linking graphics is that the link between the drawing and the graphic file must be maintained for linking to work correctly. If you move the drawing to another computer, then any linked files must also be moved to the same computer and the same folder on that computer.
To link a graphic file to your drawing, select the Link option in the Insert Image dialog (Figure 143) before selecting the file and clicking on the Open button. This opens a confirmation dialog to inform you that the graphic file will not be stored with your drawing, but only referenced as a link.

- Click on Link to link the file and close the confirmation dialog.
- Click on Embed Graphic if you do not want the file to be linked and embed the file. This will also close the confirmation dialog.

**Note**

When a graphic file is linked to a LibreOffice document or drawing, the format of the linked graphic is not changed.

Changes made in your LibreOffice drawing to a linked graphic will apply only to the linked graphic placed into your the drawing. The original graphic file will not be affected when it has been linked to your drawing.

Links can be updated, modified, or broken as follows:

1) Go to Edit > Links to External File on the main menu bar to open the Edit Links dialog (Figure 144).
2) Select the link to be edited.
3) Click on Modify, Break Link, or Update as appropriate.
   - Modify – changes the source file for the selected link.
   - Break Link – breaks the link between the source file and the current document. The most recently updated contents of the source file are kept in the current document.
   - Update – updates the selected link so that the most recently saved version of the linked file is displayed in the current document.
4) Click Close to close the Edit Links dialog when you have finished editing the link.

**Note**

If you click Break Link, then the linked graphic becomes embedded in your drawing.
Scanning

With most scanners you can directly insert a scanned image into a drawing or document. Scanned images are embedded using PNG format. Make sure that your scanner is configured for the computer and supported by the SANE system for a Linux operating system, or TWAIN for a Windows or Mac operating system.

To insert an image from the scanner:

1) Place a document, drawing, or photograph in the scanner and make sure that the scanner is switched on and ready.

2) If this is the first time the scanner has been used, go to Insert > Media > Scan > Select Source on the main menu bar to select the scanner. If the scanner has been used before, go to Insert > Image > Scan > Request on the main menu bar.

3) The rest of the procedure depends on the scanner driver, interface, and computer operating system. You will normally be required to specify scanning options such as resolution, scan window, and so on. Consult the documentation that came with the scanner for more information.

4) When the image has been scanned, Draw places it in the drawing. At this point it can be edited like any other graphic.

Note

If there is more than one scanning device connected to the computer, you will be able to select the device when you select the source. This selection will then become the default source when using scan requests until another device is used as the scanning source.

Copying and pasting

Copying a graphic and then pasting the graphic into another drawing is another way of embedding graphics into a drawing (this is also called using the clipboard). The copied graphic can be an image already embedded in another document or drawing, or it can be a graphic file such as a drawing, document or photograph.

After copying you can also choose the format when you paste a graphic into Draw using Edit > Paste Special > Paste Special on the main menu bar to open the Paste Special dialog (Figure 145). Available formats will depend on the type of image copied onto the clipboard.

<table>
<thead>
<tr>
<th>Paste Special</th>
</tr>
</thead>
</table>

<table>
<thead>
<tr>
<th>Selection</th>
</tr>
</thead>
<tbody>
<tr>
<td>StarView bitmap/animation (SVXB)</td>
</tr>
<tr>
<td>Bitmap Image (BMP)</td>
</tr>
<tr>
<td>Graphics Device Interface metafile (GDI)</td>
</tr>
</tbody>
</table>

Figure 145: Paste Special dialog

120 | Importing graphics
Note

When copying and pasting images into your drawing, please respect the copyright and license of the image you have copied.

Dragging and dropping

Dragging and dropping is another method of embedding graphics into a drawing and can be used on graphics that have been embedded or linked. The way that dragging and dropping works is determined by the computer operating system. Behavior of dragging and dropping is normally controlled using the Ctrl or Ctrl+Shift keys in combination with the mouse.

Objects and images which are used frequently can be stored in the Draw Gallery. From the Gallery, a copy of the object or image can be simply dragged onto the drawing. Working with the Gallery is dealt with in Chapter 10 Advanced Draw Techniques.

Figure 146: Export dialog

Importing graphics | 121
Exporting graphics

Exporting files
By default Draw saves drawings in the *.ODG format. Some software programs cannot open these files. To make your drawings available for other programs, you can export the file in various formats.

1) Open the ODG file you want to export.

2) Go to File > Export on the main menu bar and the Export dialog (Figure 146) opens.

3) If required, enter a new filename for the exported file in File name and navigate to the folder where you want to place the exported file.

4) Select the required format from the drop down list in File format.

5) Click Export and your file will be exported as a new file in its new format.

6) Depending on the format selected, another dialog may open allowing you to select the required options for the selected format. An example dialog for WMF export options is shown in Figure 147.

7) Depending on the additional dialog that may open, click on Export, Create, or OK and your file will be exported as a new file in its new format.

Exporting objects
Exporting individual objects from a drawing file is similar to “Exporting files” above. You have to open your drawing file and then select the object or objects you want to export from your drawing file.

Formatting raster objects
Raster graphics can be edited and formatted using one of the following methods to add or change filters and adjust the properties of color, lines, areas, and shadows:

- Go to Format > Image on the main menu bar and use one of the tools in the context menu that opens.
- Use the tools on the Image toolbar. See “Image toolbar” on page 123 for more information.
- Use the tools available in the Shadow and Image sections on the Properties deck of the Sidebar. See “Shadow and Images sections on Sidebar” on page 125 for more information.
• Some raster graphics may have a text element. For more information on formatting text see Chapter 9 Adding and Formatting Text.

Raster graphics included in a group behave like other objects when the properties of the group are edited and formatted.

**Naming raster graphics**

It is recommended to name any objects that are raster graphics in your drawing. This will make the named raster graphics visible and available in the LibreOffice Navigator. Use of one of the following methods to open the Name dialog (Figure 148) allowing you to enter a name for the selected raster graphic:

- Go to Format > Name on the main menu bar.
- Right click on the raster graphic and select Name from the context menu.

![Figure 148: Name dialog](image)

**Image toolbar**

The Image toolbar (Figure 149) normally appears when you select an image or picture that is a raster graphic. The Image toolbar can be fixed at the top of your drawing or as a floating toolbar. The default set of tools on the Image toolbar are as follows and are indicated by a tick mark in Figure 149:

- **Position and Size (F4)** – opens the Position and Size dialog. See Chapter 3 Working with Objects and Object Points for more information.
- **Align** – opens the Align Objects toolbar where you align an object in relation to other objects in the drawing. See Chapter 5 Combining Multiple Objects for more information.

![Figure 149: Image toolbar and Visible Buttons](image)
• **Arrange** tools – a set of seven tools that are used to move a selected object either forward or backward in relation to other objects in the drawing. See *Chapter 5 Combining Multiple Objects* for more information.

• **Line Style** – opens a drop down list with different line styles. In this context, line refers to the outline of the border. See *Chapter 4 Changing Object Attributes* for more information.

• **Line Width** – allows you to change the width of a line. See *Chapter 4 Changing Object Attributes* for more information.

• **Line Color** – allows you to change the color of a line. See *Chapter 4 Changing Object Attributes* for more information.

• **Area Style/Filling** – allows you to change the type of filling used in a shape. See *Chapter 4 Changing Object Attributes* for more information.

• **Shadow** – sets the default shadow effect around the picture. See *Chapter 4 Changing Object Attributes* for more information.

• **Filter** – opens the Image Filter toolbar which is described in “Image filter toolbar” on page 128.

• **Image mode** – changes the display of the graphic from color to grayscale, black and white, or a watermark. This setting affects only the display and printing of the picture; the original picture file remains unchanged.
  – **Default** – the graphic is displayed unaltered in color.
  – **Grayscale** – the graphic is displayed in 256 shades of gray.
  – **Black/White** – the graphic is displayed in black and white.
  – **Watermark** – the color, brightness, contrast and gamma settings are reduced so that the graphic can be used as a watermark (background). These default settings can be adjusted using the Color toolbar (Figure 150).

• **Crop Image** – crops or trims a picture. When you click on this tool, crop marks appear around the picture. Drag one or more of these marks to crop the picture to your desired size. For more information on cropping, see “Cropping” on page 125.

• **Vertically** – flips the selected object vertically. See *Chapter 4 Changing Object Attributes* for more information.

• **Horizontally** – flips the selected object horizontally. See *Chapter 4 Changing Object Attributes* for more information.

• **Transformations** – opens the Transformations toolbar. See *Chapter 4 Changing Object Attributes* for more information.

• **Transparency** – adjust the degree of transparency of the picture between 0% (opaque) and 100% (fully transparent).

• **Color** – opens the Color toolbar (Figure 150) so you can adjust the values of the RGB colors, brightness, contrast, and Gamma. These adjustments do not affect the original picture, but the values are stored in Draw as a separate formatting set.
  – **Red, Green, Blue** – select values between −100% (no color) to +100% (full intensity); 0% represents the original color value of the graphic.
  – **Brightness** – select a value between −100% (totally black) and +100% (totally white).
  – **Contrast** – select a value between −100% (minimum) and +100% (maximum).
– *Gamma* – this affects the brightness of the middle color tones. Select a value between 0.10 (minimum) to 10 (maximum) Try adjusting this value if changing brightness or contrast does not give you the required result.

### Shadow and Images sections on Sidebar

The **Shadow** and **Image** sections (Figure 151) in the **Properties** deck on the Sidebar are as follows:

- **Shadow** – sets the default shadow effect around a raster graphic. See *Chapter 4 Changing Object Attributes* for more information.
- **Image** – changes the display of a raster graphic from color to grayscale, black and white, or a watermark and also allows you to adjust the RGB color settings of a raster graphic. For more information see “*Image toolbar*” on page 123.

![Properties Deck Screenshot](image.png)

*Figure 151: Shadow and Image sections in Properties deck on the Sidebar*

### Cropping

Cropping is a method of hiding unwanted areas of an image or changing the size of an image in your drawing.

Changes made when cropping an image only change the display of the graphic in your drawing and not the original graphic file. If you want to use a cropped graphic in another drawing, you must use one of the following methods after selecting the cropped graphic:
Go to **File > Export** on the main menu bar to open the **Export** dialog. Navigate to the folder you want to use, then enter a filename and click on **Export**. See “Exporting graphics” on page 122 for more information.

Go to **Format > Image > Save** on the main menu bar or right click on the cropped graphic and select **Save** from the context menu. Click on **Yes** to save the modified image and open the **Image Export** dialog (Figure 152). Select the file format you want to use, navigate to the folder you want to use, then enter a filename and click on **Save**.

**Quick cropping**

After selecting an image, it can be cropped quickly using one of the following methods:

- Click on the **Crop** tool on the **Standard** toolbar.
- Click on the **Crop** tool on the **Image** toolbar (if displayed).
- Go to **Format > Image > Crop** on the main menu bar.
- Right-click on the image and select **Crop** from the context menu.

Selection handles will appear around the selected image and are used as follows:

- Top, bottom, left and right selection handles crop the image in one direction only.
- Corner selection handles crop the image in two directions. For example, top right corner will crop the image from the top and from the right.
Crop dialog

For more control and accuracy over the cropping functions, it is recommended to use the Crop dialog (Figure 153). After selecting an image, go to Format > Image > Crop Dialog on the main menu bar to open the Crop dialog.

- **Crop** – use this section to trim or scale the selected graphic, or to add white space around the graphic.
  - *Keep scale* – maintains the original scale of the graphic when cropping so that only the size of the graphic changes.
  - *Keep image size* – maintains the original size of the graphic when you crop so that only the scale of the graphic changes. To reduce the scale of the graphic, select this option and enter negative values in the cropping boxes. To increase the scale of the graphic, enter positive values in the cropping boxes.
  - *Left* and *Right* – if *Keep scale* is selected, enter a positive amount to trim the left or right edge of the graphic, or a negative amount to add white space to the left or right of the graphic. If *Keep image size* is selected, enter a positive amount to increase the horizontal scale of the graphic, or a negative amount to decrease the horizontal scale of the graphic.
  - *Top* and *Bottom* – if *Keep scale* is selected, enter a positive amount to trim the top or bottom of the graphic, or a negative amount to add white space above or below the graphic. If *Keep image size* is selected, enter a positive amount to increase the vertical scale of the graphic, or a negative amount to decrease the vertical scale of the graphic.

- **Scale** – this section is used to change the scale of the selected graphic as it appears in a drawing.
  - *Width* – enter a percentage value to change the width of a selected graphic.
  - *Height* – enter a percentage value to change the height of a selected graphic.

- **Image Size** – this section is used to change the size of the selected graphic.
  - *Width* – enter a value for the width of the selected graphic
  - *Height* – enter a value for the height of the selected graphic.
– **Original Size** – the original size of the graphic is displayed above the button. Clicking on this button and then clicking **OK** resets the selected graphic to its original size.

**Note**

In the **Crop** dialog, the **Width** and **Height** are treated as independent values. Changing one without the other can result in significant distortion of the image and this may not be what you want.

**Image filter toolbar**

Draw offers eleven filter effects that work on the current view of a graphic and they can be combined. Filters always apply to the entire graphic and it is not possible to use filters to edit only a part of the graphic.

Select a raster graphic to open the **Image** toolbar (Figure 149 on page 123), then click on the **Filter** icon to open the **Image Filter** toolbar (Figure 154).

![Image Filter toolbar](image_filter_toolbar.png)

**Figure 154: Image Filter toolbar**

**Note**

If your graphic is embedded, all graphic filters are applied directly to the graphic that is displayed in your drawing and cannot be undone in a subsequent session. The original graphic is not changed. Save your drawing to keep any filter effects applied to the graphic in your drawing.

After you save and close the drawing, the graphic filter effects become permanent. If you do not want to retain a graphic filter, you must use **Edit > Undo** on the main menu bar to cancel the filter effect before saving the file.

The filters available on the **Image Filter** toolbar are as follows:

- **Invert** image filter – inverts or reverses the color values of a color image (similar to a color negative), or the brightness values of a grayscale image. Apply the filter again to revert to the original graphic (Figure 155).
• **Smooth** image filter – softens or blurs the image by applying a low pass filter reducing the contrast between neighboring pixels and produces a slight lack of sharpness (Figure 156). Selecting this filter opens the **Smooth** dialog (Figure 157) where you can set and use the smooth radius parameter when you click **OK**.

• **Sharpen** image filter – sharpens the image by applying a high pass filter, increasing the contrast between neighboring pixels emphasizing the difference in brightness. This will accentuate the outlines and the effect will be strengthened if you apply the filter several times (Figure 158).

• **Remove Noise** image filter – removes noise by applying a median filter comparing every pixel with its neighbor. It then replaces any pixel with extreme values that deviate in color by a large amount from the mean value with a pixel that has a mean color value. The amount of picture information does not increase, but because there are fewer contrast changes resulting in an image that looks smoother (Figure 159).
• **Solarization** image filter – solarization is a phenomenon in photography where an image recorded on a negative or on a photographic print is wholly or partially reversed in tone. Dark areas appear light or light areas appear dark. Solarization was originally a photochemical effect used during photographic film development and is now used in the digital world of computing to create a change or reversal of color (Figure 160). Selecting the **Solarization** filter opens the **Solarization** dialog (Figure 161), where you can define the **Threshold value** for solarization. Entering a **Threshold value** above 70% reverses the color values. Selecting the **Invert** option causes all the colors to be inverted.

• **Aging** image filter – aging creates a look that resembles photographs developed in the early days of photography. All pixels are set to their gray values and then the green and blue color channels are reduced by the amount specified in **Aging degree** in the **Aging** dialog. Red color channel is not changed (Figure 162). Selecting the **Aging** image filter opens the **Aging** dialog(Figure 163), where you can define the **Aging degree** and create an old look for your graphic as shown in the right picture in Figure 162.
• **Posterize** image filter – posterizing reduces the number of colors in an image making it look flatter. When used on a photograph, posterizing can make the photograph look like a painting. Selecting the **Posterize** image filter opens the **Posterize** dialog, where you can define the number of poster colors to produce the effect you want (Figure 164 and Figure 165).
- **Pop Art** image filter – select the **Pop Art** image filter to change the colors of an image to a pop-art format (Figure 166).

- **Charcoal Sketch** image filter – selecting the **Charcoal Sketch** image filter displays an image as a charcoal sketch. The contours of the image are drawn in black and the original colors are suppressed (Figure 167).

- **Relief** image filter – this image filter calculates the edges of an image in relief as if the image is illuminated by a light source. Selecting the **Relief** image filter opens the **Emboss** dialog where you can select the position of the **Light source** producing shadows that differ in direction and magnitude (Figure 168 and Figure 169).
Mosaic image filter – this image filter joins groups of pixels and converts them into a rectangular tile in a single color creating an image that appears to be a mosaic. The larger the individual rectangles created, the fewer details the mosaic graphic has. Selecting this image filter opens the Mosaic dialog, where you can set the number of pixels used to create the Width and Height of each tile created. Selecting Enhanced edges will enhance the edges of each tile to create a sharper definition (Figure 170 and Figure 171).

Replacing colors

The Color Replacer only allows you to replace or change a color in embedded graphics for another color or set a color as transparent. Up to four colors can be replaced at once. The tool works on the entire graphic and you cannot select an area of the graphic for editing.

The selection list for replacement colors shows all the available colors in the current color palette of the drawing. You cannot define any new colors here, but you can add colors to the available palette before using the Replace Color tool. For more information, see Chapter 10 Advanced Draw Techniques.
Replacing colors

Replace colors in an embedded image as follows:

1) Go to **Tools > Color Replacer** on the main menu bar to open the **Color Replacer** dialog (Figure 172).

2) Select an embedded image to start using the **Color Replacer**.

3) Click on the **Pipette** icon at the top of the **Color Replacer** dialog to activate the color selection mode.

4) Move the cursor over the color you want to replace in the selected image and click on the color to be replaced. A check box is now marked and the selected color appears in **Source color**.

5) If necessary, select another three colors in the selected image. Only a maximum of four colors can be selected.

6) Enter the amount of tolerance required for replacing the color in the **Tolerance** box. The default selection is 10% tolerance.

7) In **Replace with**, select a color from the drop-down list for each color selected. Transparent is the default selection.

8) After selecting up to four colors for replacement, click **Replace** to replace the colors in the selected graphic.

9) There is no preview of the effect. If the result is not what you required, select **Edit > Undo** in the main menu bar and repeat the color replacement.

---

**Note**

The **Color Replacer** can only be used on embedded graphics. If you try to use the **Color Replacer** on a linked graphic, you will get the following error message “This image is linked to a document. Do you want to unlink the image in order to edit it?”
Replacing transparent areas

It is also possible to replace transparent areas in an embedded image with a color.

1) Go to **Tools > Color Replacer** on the main menu bar to open the **Color Replacer** dialog (Figure 172).
2) Make sure the embedded image is NOT selected.
3) Select **Transparency** in the **Color Replacer** dialog.
4) Select a color from the drop-down list next to **Transparency**.
5) Click **Replace** to replace the transparent areas with the selected color.
6) There is no preview of the effect. If the result is not what you required, select **Edit > Undo** in the main menu bar and repeat the transparency replacement.

Tolerance parameter

The **Tolerance** parameter is used to set how much of the source color in an embedded image is replaced by another color.

- Replacing colors that are similar to the color you are replacing, enter a low value for the tolerance parameter.
- Replacing a wider range of colors, enter a higher value for the tolerance parameter.

Conversion

Contour conversion

Contour conversion converts an image creating, from the original image, a polygon or group of polygons with four corner points with the image set as a background graphic. Any editing must be completed before carrying out a contour conversion because you can not carry out any further editing on the image.

1) Make sure that all editing has been completed to the image you are going to convert and it is selected in your drawing.
2) Go to **Shape > Convert > To Contour** on the main menu bar, or right-click on the image and select **Convert > To Contour**.

If the conversion creates a group of polygons (for example a text object), then you must enter the group using one of the following methods before selecting an individual polygon:

- Go to **Shape > Enter Group** on the main menu bar.
- Right-click on the converted image and select **Enter Group** from the context menu.
- Press the **F3** key.

Polygon conversion

Polygon conversion is used to convert a selected image to a group of polygons filled with color. The image is also converted to a vector graphic and can be resized with no loss of image quality or distortion of any text.

After conversion, you can break the graphic into groups of polygons and then split these groups into individual polygons. Breaking and splitting allows you to edit or delete individual colors within the graphic.
Converting

1) Select the image in your drawing.
2) Convert the image into a polygon using one of the following methods and the Convert to Polygon dialog opens (Figure 173):
   - Go to Shape > Convert > To Polygon on the main menu bar.
   - Right-click on the image and select Convert > To Polygon from the context menu that opens.
3) Select the Number of colors and Point reduction to be used in the conversion.
4) Select Fill holes to prevent any blank areas appearing in your image.
5) Enter the number of pixels to use for Tile size.
6) Click Preview to check how your converted graphic will look.
7) Make any necessary changes to the settings and check the preview again.
8) If you are satisfied, click OK to convert your image to a polygon and close the Convert to Polygon dialog.

Conversion options and controls

- **Number of colors** – enter the number of colors to be displayed in the converted image. LibreOffice generates a polygon for each occurrence of a color in the image. The range for the number of colors is between 8 and 32.
- **Point reduction** – removes color polygons that are smaller than the pixel value you enter. The range for point reduction is between 0 and 32 pixels.
- **Fill holes** – fills the blank areas in the graphic that can be created when applying a point reduction.
- **Tile size** – enter the size of the rectangle for the background fill. The range of tile sizes is between 8 and 128 pixels.
Breaking

After converting an image to polygons, you can break the vectorized image into groups of polygons. Each group of polygons consists of one color and becomes an object that can be used in another drawing.

1) Convert your image to polygons, see “Converting” above.
2) Select your image is selected, then use one of the following methods to break the image into a group of polygons:
   – Go to Shape > Break on the main menu bar.
   – Right-click on the image and select Break from the context menu.
3) Click on a color in your image then drag the group of polygons filled with that color out of your image to create a new image OR press the [Delete] key and delete the color from your image.

Splitting

After converting an image to polygons and breaking the image into groups of polygons, you can then split these polygon groups into individual polygons.

1) Convert your image to polygons, see “Converting” above.
2) Break your image into groups of polygons, see “Breaking” above.
3) Select your image, then use one of the following methods to split the groups of polygons into individual polygons:
   – Go to Shape > Split on the main menu bar.
   – Right-click on the image and select Shapes > Split from the context menu.
   – Use the keyboard combination [Ctrl+Alt+Shift+K].
4) Select an individual polygon (or several polygons) in your image and drag it out of your image to create new images in your drawing.
5) Alternatively, press the [Delete] key to delete the selected polygon(s) from your image.

Bitmap conversion

All drawing objects placed into a LibreOffice drawing are vector graphics and these vector graphics can be converted to a bitmap (raster graphic) in PNG format. Any transparency effects in the original vector graphic are lost during conversion even though the PNG format used LO Draw supports transparencies.

Use one of the following methods to convert a vector graphic to a bitmap:

- Go to Shape > Convert > To Bitmap on the main menu bar.
- Right-click on the graphic and select Convert > To Bitmap from the context menu.
Print options

If you have only a monochrome (single color) printer or are experiencing problems with printing, then the following settings may help with printing your drawing. You can set up printing so that all text and all graphics are printed either in grayscale or black and white.

The general settings are in Tools > Options > LibreOffice Draw > Print on the main menu bar to open the Options – LibreOffice Draw – Print dialog (Figure 174). These options apply to all drawings that you print using LibreOffice Draw.

To set printing options for the current document only, go to File > Print on the main menu bar or use the keyboard combination [Ctrl+P] and click on the LibreOffice Draw tab in the Print dialog (Figure 175).
To set printing options for all the modules in LibreOffice, go to **Tools > Options > LibreOffice > Print** (Figure 176). These printing options allow you to reduce the amount of print data sent to a printer or file. Also printer warnings can be given if the wrong paper size or orientation and transparency is used.
Chapter 7
Working with 3D Objects
Introduction

Although Draw does not match the functionality of leading drawing or picture editing programs, it is capable of producing and editing 3D drawings.

In Draw there are two different types of 3D objects available: 3D scenes and extruded 3D shapes. The Status Bar indicates when a 3D scene has been selected (Figure 177). However, the Status Bar only indicates a shape has been selected (Figure 178) when an extruded 3D shape is selected.

Depending on which type you choose, there are different possibilities for further editing of the object (rotation, illumination, perspective, and so on). Extruded 3D shapes are simpler to set up and edit, but 3D scenes allow for greater customization.

3D objects can be created using one of the following methods:

- **3D Objects** – these are ready made 3D objects, which are 3D scenes. Selected using one of the following methods:
  - Click on **3D Objects** in the **Drawing** toolbar (Figure 179 on page 142).
  - Select a 3D object in **3D Objects** in the **Shapes** deck on the Sidebar.
- Convert a 2D object into a 3D scene use one of the following tools on the **Drawing** toolbar (Figure 179 on page 142):
  - **To 3D** – creates a 3D scene containing an extrusion object.
  - **To 3D Rotation Object** – creates a 3D scene into a rotation object using a default rotation axis.
  - **In 3D Rotation Object** – creates a 3D scene into a rotation object using a user defined rotation axis
- **Toggle Extrusion** – creates a 3D shape by extruding a 2D object into 3D. Only 3D shapes that have been extruded can be converted back to a 2D object.

### 3D object types

#### 3D scenes

3D scenes are created from objects with dimensions using x, y, and z coordinates and can contain object types, such as cube, sphere, extrusion object and rotation object. These object types do not exist outside a 3D scene.

The Status Bar displays **3D scene selected** (Figure 177) when a 3D object is selected that has been created from a 2D object using body rotation or conversion, or it is a ready-made 3D object that has been inserted into your drawing.

A 3D scene acts similar to a group. Just like a group, you have to enter a 3D scene to edit an individual object in the 3D scene and then exit after you finished editing. See Chapter 5 Combining Multiple Objects for more information on entering, editing and exiting groups.
When you create a 3D scene from a selection of more than one 2D object, a group is automatically created as a single 3D scene. You can enter this 3D scene so that you can change, edit and rotate individual objects within the 3D scene.

**Note**

You cannot ungroup into individual objects a 3D scene that has been created from a selection of 2D objects.

### 3D shapes

3D shapes are solid objects that have three dimensions. These dimensions are length, width, and height. While 2D shapes are flat, 3D shapes that have depth to them.

A 3D shape is created when a 2D shape or an object from the Fontwork Gallery is turned into 3D using tool **Toggle Extrusion**. The Status Bar displays **Shape selected** (Figure 178) when this type of 3D object is selected.

A 3D shape can be viewed and edited in 3D or 2D mode. To edit in 2D mode, switch off extrusion, carry out your editing and switch back to 3D mode using extrusion.

**Note**

Extrusion can only be used when you select a 2D shape, or select a 3D object that has been extruded from a 2D shape or an object from the Fontwork Gallery by using the tool **Toggle Extrusion**. It is not available for text, lines, arrows, curves and polygons.

### Drawing toolbar

Before you begin creating 3D objects in your drawing, it is recommended that you add the 3D and extrusion tools to the **Drawing** toolbar (Figure 179) using **Visible Buttons** (Figure 180) or **Customize Dialog** (Figure 181).

![Figure 179: Drawing toolbar with 3D tools](image)

**Note**

The 3D icons are only available when you select a 2D object, text or Fontwork Gallery and are not included with the default set of icons on the **Drawing** toolbar.
Visible Buttons

1) Click on the down pointing triangle ▼, or right-click in an empty area on the Drawing toolbar and select Visible Buttons from the context menu.

2) Select the 3D buttons/tools you require from Visible Buttons (Figure 180). The 3D button selected will appear on the Drawing toolbar. A check mark (✓) against each name in Visible Buttons indicates which button is installed on the Drawing toolbar.
Customize Toolbar

1) Right-click in an empty area on the Drawing toolbar and select Customize Toolbar from the context menu opening the Customize dialog (Figure 181).
2) Make sure that Drawing is displayed in the Target text box.
3) In Available Commands scroll down until you have located the 3D button you require.
4) Alternatively, enter the name of the 3D button you require in the Search text box and the 3D button will appear in Available Commands.
5) Click on the right facing arrow ➡ and the 3D button will appear in Assigned Commands.
6) Click OK to save your changes and close the Customize dialog. The 3D button will appear on the Drawing toolbar.

Creating 3D objects

3D ready made objects

3D ready made objects are 3D scenes and are inserted into your drawing using one of the following methods:

- Click on the triangle to the right of the 3D Objects icon on the Drawing toolbar (Figure 179 on page 142) and select a 3D object from the pop up options. The 3D Objects icon displayed on the Drawing toolbar will depend on the 3D object that had been previously selected and used.
- Go to View > Toolbars > 3D-Objects on the main menu bar to open the 3D-Objects toolbar (Figure 182). The selection and drawing of 3D objects is the same as clicking on the 3D Objects icon on the Drawing toolbar.
- Go to Shapes > Insert > 3D Objects on the main menu bar.
- Go to Shapes > Default > 3D Objects on the Sidebar and select a 3D object. The selection and drawing of 3D objects is the same as the ones available on the Drawing and 3D-Objects toolbars.

![3D-Objects toolbar](image)

Figure 182: 3D-Objects toolbar

Note

Ready made 3D objects can be repositioned, resized and edited similar to 2D basic shapes. See Chapter 3 Working with Objects for more information.

Extrusion using To 3D

The To 3D tool converts a 2D object into a 3D scene by extruding the 2D object towards the observer. The scene is rotated by 20deg around the horizontal axis to make the 3D effect more visible. Examples of using the To 3D tool are shown in Figure 183.
A 2D object is converted into a 3D scene using one of the following methods:

- Right-click on a 2D object selected in your drawing, then select **Convert > To 3D** from the context menu.
- Select a 2D object in your drawing and click on the **To 3D** icon in the **Drawing** toolbar (Figure 179 on page 142).
- Select a 2D object in your drawing and click on the **To 3D** icon in the **3D Effects** dialog (Figure 189 on page 149).

### Rotation

**To 3D Rotation Object**

The **To 3D Rotation Object** tool converts a 2D object into a 3D scene by rotating the object using the left edge of the bounding box around the object as the axis of rotation. Examples of using **To 3D Rotation** are shown in Figure 184, where a thick line has been used as an example object. The actual 3D shape created also depends on the angle and shape of the object being rotated.

A 2D object is converted into a 3D scene using one of the following methods:

- Right-click on a 2D object selected in your drawing, then select **Convert > To 3D Object Rotation** from the context menu.
- Select a 2D object in your drawing and click on the **To 3D Object Rotation** icon in the **Drawing** toolbar (Figure 179 on page 142).

**In 3D Rotation Object**

The **In 3D Rotation Object** tool converts a 2D object into a 3D scene by rotating the object using a movable axis of rotation.

Examples of adjusting the rotation location and angle are shown in Figure 185 where a thick line has been used as an example object. The actual 3D scene created also depends on the angle and shape of the object being rotated.

1) Draw a 2D object and make sure it is selected.
2) Click on the **In 3D Rotation Object** icon in the **Drawing** toolbar (Figure 179 on page 142).
3) Adjust the position and angle of the rotation axis. This is shown as a dashed line with rotation points at each end.

4) Click anywhere outside the 2D object and it is converted into a 3D scene.

**Toggle Extrusion**

Extrusion is where parallel surfaces are moved to create a 3D shape. In Draw, the 2D surface is moved forwards out of the drawing level. At the same time the object is slightly tilted and central projection turned on creating the impression of a 3D shape. Draw uses a default value for this extrusion (body depth) based on the size of the 2D object. The value can be changed after the extrusion; see “Editing 3D objects” on page 147).

Extrusion conversion is carried out using **Toggle Extrusion** tool creating a 3D shape from a 2D object. Extrusion only works on basic shapes, symbol shapes, block arrows, flowcharts, callouts, and stars and banners that are included as a part of the default set of tools on the **Drawing** toolbar or in the **Shapes** deck on the Sidebar. Extrusion can also be used on any objects created using the Fontwork Gallery. Example extrusions are shown in Figure 186.

1) Draw the 2D object in your drawing and make sure it is selected.

2) Click on the **Toggle Extrusion** icon on the **Drawing** toolbar (Figure 179 on page 142) to convert the 2D object into a 3D shape.

3) To convert a 3D conversion back into a 2D object, select the 3D object and click on the **Toggle Extrusion** icon.

**Note**

Extrusion can not be used on text objects created using **Insert Text Box** or **Insert Vertical Text** on the **Standard** toolbar.
Editing 3D objects

Note
Where 3D scenes have been created from more than one 2D object, a 3D scene group is automatically created. You cannot ungroup this 3D scene group and any editing carried out will affect all 3D objects within the group. To edit an individual 3D object within this 3D scene group, you must enter the group. See Chapter 5 Combining Multiple Objects more information on working with groups.

Position, Size and Rotation
Editing the position, size and rotation of 3D objects is similar to 2D objects. See Chapter 3 Working with Objects and Object Points for more information.

3D settings
The 3D-Settings toolbar (Figure 187) is only used to edit a 3D shape that has been created from a 2D object using Toggle Extrusion (see “Toggle Extrusion” on page 146 for more information).

To open the 3D-Settings toolbar, go to View > Toolbars > 3D-Settings on the main menu bar. The 3D-Settings toolbar only becomes active when a 3D shape has been selected that has been created using Toggle Extrusion.

The tools available for editing 3D shapes are as follows and shown in Figure 187. The result of any changes made using these editing tools is applied to the selected 3D shape immediately and the 3D effect is displayed.

- **Toggle Extrusion** – used to create a 3D shape from a 2D object. If necessary, can also be used to switch off the 3D effects created by extrusion allowing you to edit the underlying 2D object.
- **Tilt Down** – tilts the selected object downward (horizontal axis rotation) by 5 degrees each time the icon is used.
- **Tilt Up** – tilts the selected object upward (horizontal axis rotation) by 5 degrees each time the icon is used.
- **Tilt Left** – tilts the selected object left (vertical axis rotation) by 5 degrees each time the icon is used.
• **Tilt Right** – tilts the selected object right (vertical axis rotation) by 5 degrees each time the icon is used.

• **Depth** – opens a pop-up menu where you can set the extrusion depth from an object by a fixed or custom amount.

• **Direction** – opens a pop-up menu where you can set the view direction to create an extrusion in either a perspective or parallel projection.

• **Lighting** – opens a pop-up menu where you can set the direction and intensity of the lighting when creating an extrusion.

• **Surface** – opens a pop-up menu where you can set the surface of the extrusion as matt, or wireframe display.

• **3D Color** – opens a pop-up menu where you can set the color used for the extrusion. This color does not have to be the same as the color used for the original 2D object.

Figure 188 shows an example of tilting left, increasing extrusion depth and changing 3D color using the **3D-Settings** toolbar.

**Note**

The **3D Effects** dialog described below cannot be used on 3D shapes created using **Toggle Extrusion** because the correct formatting results will not be achieved. If you use the **3D Effects** dialog in error, you can remove any incorrect formatting by going to **Format > Default Formatting** on the main menu bar.
3D effects

The 3D Effects dialog offers a wide range of possible settings for editing 3D ready made objects or 3D scenes. This dialog can also be used to convert a 2D object to 3D using the tools in the bottom left corner of the dialog.

To open the 3D Effects dialog (Figure 189), click on the 3D Effects icon on the Drawing toolbar (Figure 179 on page 142).

Any 3D effects that you apply to a 3D scene are not carried out until you click on Assign in the top right of the 3D Effects dialog. This allows you to make all the 3D effect changes before applying them to your 3D scene.

3D conversion

In the bottom left corner of the 3D Effects dialog are icons allowing you to convert a 2D object into a 3D scene and to change the projection used in a 3D scene.

- **Convert to 3D** – converts the selected object into a 3D scene. This tool works in the same way as “Extrusion using To 3D” on page 144.
- **Convert to Rotation Object** – converts a 2D object into a 3D scene using body rotation. This tool works in the same way as “To 3D Rotation Object” on page 145.
- **Perspective On/Off** – switches perspective projection on or off for a 3D scene. Perspective projection is a type of drawing that graphically approximates on a 2D surface (for example paper) the images of 3D objects so as to approximate actual visual perception. It is sometimes also called perspective view or perspective drawing or simply perspective.
3D Effects – Geometry

On the Geometry page of the 3D Effects dialog (Figure 189) you can make changes to the geometry of a 3D object.

- **Geometry** – defines the properties for an object in a 3D scene created from a 2D object.
  - **Rounded edges** – enter the amount by which you want to round the corners of a 3D shape as shown by the example in Figure 190. The default setting for rounded edges is 10%.

![10% rounded edges (default) 75% rounded edges](image)

*Figure 190: Rounded edges example*

- **Scaled depth** – enter the amount by which to increase or decrease the frontal area of the selected 3D object. Figure 191 shows an example where the scaled depth has been increased to 150% and then decreased to 50%. The default setting for scaled depth is 100%.

![100% scaled depth 50% scaled depth 150% scaled depth](image)

*Figure 191: Scaled depth example*

- **Rotation angle** – enter the angle in degrees to rotate a 2D object that has been converted to 3D using To 3D Rotation Object. Figure 192 shows an example of a 2D circle converted to 3D and the rotation angle changed to 150 degrees.

![2D Circle Converted using To 3D Rotation Object Rotation angle changed to 150 deg](image)

*Figure 192: Rotation angle example*

- **Depth** – enter the extrusion depth for the selected 3D object. This option is not available for 2D rotation objects converted to 3D using To 3D Rotation Object. Figure 193 shows an example of a 2D circle converted to a 3D cylinder with the extrusion depth increased to 3 cm.
• **Segments** – changes the number of segments that Draw uses to draw a 3D rotation object. The higher the number of segments, the smoother the object surface will be. However, a high segment number may increase the time it takes to generate the 3D object on your display. Figure 194 shows the difference on a 3D sphere when the segments have been increased from 10 to 30 segments horizontally and vertically.
  - **Horizontal** – enter the number of horizontal segments to use in the selected 3D rotation object.
  - **Vertical** – enter the number of vertical segments to use in the selected 3D rotation object.

• **Normals** – modifies the rendering style of the 3D surface (Figure 195 and Figure 196).
  - **Object-Specific** – renders the 3D surface according to the shape of the object. For example, a circular shape is rendered with a spherical surface.
  - **Flat** – renders the 3D surface as polygons.
  - **Spherical** – renders a smooth 3D surface regardless of the shape of the object.
  - **Invert Normals** – an inverted normal is a normal that is pointing in the wrong direction. This tells a computer that an outside face is actually an inside face when it is not. If you have a hollow design, an inverted normal can be indicated as you have both surfaces facing in and out in the same model.
- **Double-Sided Illumination** – lights the outside and the inside of the object. This has only an effect, if the inside is drawn at all, see double-sided. This is a setting for the whole of the 3D scene and not for a single object within the scene.

- **Double-Sided** – a 3D object has outside (front) and inside (back) faces. With **Double-Sided** switched off, only the outside face of the object is rendered. The effect, when looking from outside, is that the object solid, but, when looking from inside, the front face is transparent. If there is no view to the inside face, normally for an extruded 3D object with solid texture, the **Double-Sided** should be switched off to improve performance during rendering. Any 3D object created using rotation often allow an inside view and it is recommended that **Double-Sided** is switched on.
3D Effects – Shading

On the Shading page of the 3D Effects dialog (Figure 197) you can set the shading, shadow, and camera options for the selected 3D object.

- **Shading** – specifies the type of shading applied to a 3D object (Figure 198).
  - *Gouraud Mode* – estimates the surface normal of each vertex in a polygonal 3D model specified for each vertex or found by averaging the surface normals of the polygons that meet at each vertex.
  - *Phong Mode* – calculates the normal of a point in the polygon by interpolating the normals of the vertices. The angle between normal and lighting direction determines how much of the lighting is used to color the pixel.
  - *Flat Mode* – assigns a single color of shading to a single segment on the surface of the object.

![Gouraud, Phong, Flat](Figure 198: Shading mode examples)

- **Shadow** – adds or removes a shadow from a selected 3D object (Figure 199). A shadow will be generated only from the first light source.
  - *3D Shadowing On/Off* – switches the shadowing on or off.
  - *Surface angle* – enter an angle from the light source to the surface between 0 to 90 degrees to cast a shadow.

![0 deg shadow, 50 deg shadow](Figure 199: Shadow angle example)

- **Camera** – sets the camera options for a selected 3D scene as if you are actually using a camera to take a photograph (Figure 200). The settings affect only central perspective not parallel projection.
  - *Distance* – enter the distance to leave between the camera and the center of the selected 3D scene. The default setting for distance is 2.6cm.
  - *Focal length* – enter the focal length of the camera lens, where a small value corresponds to a fish-eye lens and a large value to a telephoto lens. The default setting for focal length is 10cm.
The **Illumination** page of the **Effects** dialog (Figure 201) defines how a 3D scene is lit and the settings apply to all 3D objects in a scene. You can specify the direction of the light source, color of the light source and the ambient light for the 3D scene.

By default one light source is already selected when you open the **Illumination** page. You can select another light source or use more than one light source for illumination. A maximum of eight sources can be used and each light source can use a different color. Figure 201 shows three light sources selected with each color having a different color.

1) Select a *Light source* icon to turn the light source on. The icon changes to an illuminated bulb.

2) Press the space bar or click again on the selected light source to adjust the color for the light source.
3) Select a color for the light from the drop-down list for Light source. A different color can be used for each light source selected.

4) Select a color from the drop-down list for Ambient light to set the color of the surrounding light.

5) To deselect a light source, select a Light source and click on it again.

The light source location and color are shown in the lower right corner of the Illumination page. The vertical slider bar adjusts the lighting angle and the horizontal slider bar rotates the light about the object. Alternatively you can click on the light point and drag the light source to where you want it.

To change the preview from a sphere to a cube, click on the small square to the right of the horizontal slider bar and below the vertical slider bar.

Each light source selected is shown as a small colored sphere in the color specified for it. The larger colored sphere indicates the active light source.

3D Effects – Textures

On the Textures page of the Effects dialog (Figure 202) you can set the properties of the surface texture for a selected 3D object. The Textures page is only available after you have set the area fill of a 3D object to Gradient, Hatching or Bitmap. For more information on changing area fill, see Chapter 4 Changing Object Attributes.

- **Type** – sets the color properties of the texture.
  - **Black & White** – converts the texture to black and white.
  - **Color** – converts the texture to color.

- **Mode** – shows or hides shading.
  - **Only Texture** – applies the texture without shading.
  - **Texture and Shading** – applies the texture with shading. To define the shading options for the texture, see “3D Effects – Shading” above.

![Figure 202: 3D Effects dialog - Textures page](image_url)
– **Texture, Shadow and Color** – applies the texture with a shadow and color. To define the shading options for the texture, see “3D Effects – Shading” above.

- **Projection X** – sets the options for displaying the texture along the X axis. Only one of the three following options can be selected.
  - **Object-Specific** – automatically adjusts the texture for best fit based on the shape and size of the object. This is the default setting for all but extrusion objects.
  - **Parallel** – applies the texture parallel to the horizontal axis and is mirrored on the rear side of the object. This is the default setting for extrusion objects.
  - **Circular** – wraps the horizontal axis of the texture pattern around an object.

- **Projection Y** – sets the options for displaying the texture along the Y axis. Only one of the three following options can be selected.
  - **Object-Specific** – automatically adjusts the texture for best fit based on the shape and size of the object. This is the default setting for all but extrusion objects.
  - **Parallel** – applies the texture parallel to the vertical axis and is mirrored on the rear side of the object. This is the default setting for extrusion objects.
  - **Circular** – wraps the vertical axis of the texture pattern around an object.

- **Filter** – filters out noise that can occur when you apply a texture to a 3D object.
  - **Filtering On/Off** – applies a soft focus filter blurring the texture slightly to remove unwanted speckles.

### 3D Effects – Material

On the **Materials** page of the **Effects** dialog (Figure 203) you can change the appearance of a 3D object to represent different materials. Materials and textures can be combined with each other and it is a matter of trial and error to achieve the desired result.

![Figure 203: 3D Effects dialog - Materials page](image-url)
Figure 204: Pick a Color dialog

- **Material** – assigns a predefined color from a color palette or lets you create your own color. Custom colors are stored in the custom palette, see *Chapter 11 Advanced Draw Techniques* for more information on color.
  - **Favorites** – select a color from a predefined color palette, or a predefined custom color from the custom palette. Only applicable, if the *Area* fill is set to *Color* and then the color selected in Favorites becomes the area fill color.
  - **Object color** – select a color from a predefined color palette, or a predefined custom color from the custom palette. Only applicable, if the *Area* fill is set to *Color* and then Object color becomes the area fill color.
  - **Illumination color** – select a color to illuminate the object and to brighten parts of the object which lie in shadow. This makes the object seem more illuminated.

- **Specular** – sets the light reflection properties for the selected object simulating the reflecting capacity of the surface. The position of the illuminated point is determined by the setting of the first light source.
  - **Color** – select the color that you want the object to reflect.
  - **Intensity** – enter the intensity of the specular effect.

- **Colors Dialog** icon – opens the Pick a Color dialog (Figure 204) where you define your own colors using the two-dimensional graphic and numerical gradient chart. Any colors created are stored in the custom palette. See *Chapter 11 Advanced Draw Techniques* for more information on color.

**Note**

Metallic and glass surfaces do not simulate well because the appearance of these materials is produced using reflection.
Tip

Do not use a very high brightness values for individual colors. These are all additive and it is easy to end up with a colored area that is white.

Combining objects

Multiple 3D objects cannot be combined using the Combine command (Shape > Combine on the main menu bar or Shift+Ctrl+K). You have to create multiple 2D objects first, then create a single 3D object as follows (see Chapter 5 Combining Multiple Objects for more information on combining objects):

1) Create multiple 2D objects and carry out all the necessary editing changes.
2) Make sure that all 2D objects are selected you want to use for a single 3D object.
3) Create a single 3D object combining the multiple 2D objects using one of the following methods (example conversions shown in Figure 205):
   - Click on To 3D or To 3D Rotation Object on the Drawing toolbar.
   - Right click on the selected multiple 2D objects and select Convert > To 3D or To 3D Rotation Object from the context menu.
   - Go to Shape > Convert > To 3D or To 3D Rotation Object on the main menu bar.

Figure 205: 3D object created from multiple 2D objects

Figure 206: Assembling 3D objects
Assembling 3D objects

3D objects that each form a separate 3D scene can be combined or assembled into a single 3D scene as follows and shown in Figure 206:

1) Insert a 3D object (for example, a cube) from 3D Objects on the Drawing toolbar or Shapes deck on the Sidebar.

2) Insert a second 3D object (for example, a sphere) from 3D Objects on the Drawing toolbar or Shapes deck on the Sidebar.

3) If necessary, set the area fill to None and the lines to Continuous to create wire frame objects (as shown in Figure 206). This will make it easier to position both objects in the assembled 3D scene.

4) Select the second 3D object (sphere) and go to Edit > Cut on the main menu bar or right-click on the object and select Cut from the context menu.

5) Double-click the first 3D object (cube) to enter its group or go Shape > Group > Enter Group on the main menu bar.

6) Go to Edit > Paste on the main menu bar or right-click on the first 3D object and select Paste from the context menu. The sphere now appears inside the cube and is now part of the same group. If you want, you can edit the individual objects or change their position within the group.

7) Double-click outside the 3D assembled scene to exit the group, or go to Shape > Group > Exit Group on the main menu bar.

Note

The second object will also reappear in its original position when you carry out the Paste command. This object is NOT part of the assembled 3D scene and can be deleted if necessary.
Chapter 8
Connections, Flowcharts, and Organization Charts
Introduction

Connectors and glue points were briefly introduced in Chapter 2 Drawing Basic Shapes. This section describes them in more detail and how to use them.

Connectors are lines or arrows whose ends automatically dock to a connection or glue point on an object. Connectors are useful when drawing, for example, flowcharts and organization charts. The connecting lines between objects remain intact even when objects are moved or rearranged. Also, if you copy an object with a connector, the connector is also copied.

Connectors and glue points

Connectors

Draw has a comprehensive selection of connectors to help you connect objects in, for example, a flowchart or organization chart. The default set of connectors can be accessed using one of the following methods:

• Click the small triangle to the right of the Connector icon on the Drawing toolbar (highlighted in Figure 207). The icon changes shape depending on the last connector used.

• Select a connector from Shapes > Default > Connectors on the Sidebar (Figure 208).

The connectors on the Drawing toolbar (Figure 207) can be displayed as a floating toolbar as follows:

1) Click on the small triangle on the right of the Connector icon on the Drawing toolbar.
2) Click at the top of the pop up toolbar and drag it on to the Workspace.
3) Release the mouse button and the pop up toolbar becomes a floating toolbar (Figure 209).

Figure 207: Drawing toolbar

Figure 208: Connectors section in Shapes deck on Sidebar
**Connector types**

The full range of predefined connectors can be accessed by clicking on the small downward facing triangle on the Connectors toolbar and selecting *Visible Buttons* (Figure 210). The connectors available on the toolbar are indicated by a check mark against the name.

Connectors fall into four type groups:

- **Standard connectors** – connector name starts with *Connector*. Line segments run vertically and horizontally. Draws a connector with one or more 90-degree angle bends. Click on an object glue point on an object, drag to a glue point on another object, then release.
• **Line connectors** – connector name starts with *Line*. Consists of a line segment with two smaller segments at the ends and draws a connector that bends near a glue point. Click on an object glue point, drag to a glue point on another object, then release. To adjust the length of the line segment between a bend point and a glue point, click the connector and drag the bend point.

• **Straight connectors** – connector name starts with *Straight*. Consists of a single line and draws a straight line connector. Click on an object glue point, drag to a glue point on another object, then release.

• **Curved connectors** – connector name starts with *Curved*. Based on Bézier curves and curve around objects. Draws a curved line connector. Click on an object glue point, drag to a glue point on another object, then release.

**Adding connectors**

When you select a connector and move the mouse pointer over a filled object or the edge of an unfilled object, glue points appear. A glue point is a fixed point where you can attach a connector line. You can also add custom glue points to an object, see "Glue points" on page 164 for more information.

To draw a connector, select the connector type and click on a glue point on an object. Drag the cursor to a glue point on another object and then release. Figure 211 shows a standard connector drawn between two objects. Remember not to drag the connector so that it overlaps or touches any objects and creates a confusing drawing. If this does happen, see "Modifying connectors" below on how to change the connector route to avoid any objects the connector crosses over.

You can also drag a connector to an empty part of your document. When you release the mouse button, the unattached end of the connector is locked into place until you drag the end to a different location.

![Figure 211: Connector between two objects](image)

**Modifying connectors**

To detach or reposition a connector, click and drag either end of the connector line to a different location.

To change the connector route between objects avoiding any objects on the route, click on a control point on the connector line and drag it to a new position. In Figure 211, the control points are shown as small red squares.

To modify a connector, right-click on the connector and select **Connector** from the context menu to open the **Connector** dialog (Figure 212). Use this dialog to change connector type and its properties.

• **Line skew** – defines the skew of the line and the dialog preview displays the result.

• **Line spacing** – sets the spacing for the connectors.
  – **Begin horizontal** – enter the amount of horizontal space you want at the beginning of the connector.
Figure 212: Connector dialog

- **Begin vertical** – enter the amount of vertical space you want at the beginning of the connector.
- **End horizontal** – enter the amount of horizontal space you want at the end of the connector.
- **End vertical** – enter the amount of vertical space you want at the end of the connector

- **Preview window** – a left click zooms in on the preview and a right click zooms out.

**Note**

You cannot swap the ends of the connector using the **Connector** dialog, that is start point becomes the end point and the end point becomes the start point. To swap the ends of a connector, you have to draw a new connector in the opposite direction.

**Glue points**

Glue points are not the same as the selection handles of an object. The selection handles are for moving or changing the shape of an object (see *Chapter 3 Working with Objects and Object Points* for more information). Glue points are used to fix or glue a connector to an object so that when the object moves, the connector stays fixed to that object.

All Draw objects have glue points, which normally are not displayed and only become visible when the **Connectors** icon on the **Drawing** toolbar (Figure 207 on page 161) is selected. Note that the **Connectors** icon changes shape depending on the last connector tool used.

To add, customize or delete glue points to an object, go to **View > Toolbars > Glue Points** on the main menu bar to activate the **Glue Points** toolbar (Figure 213). This toolbar only becomes visible after using one of the following methods:

- Click on the **Show Glue Point Functions** icon on the **Standard** or **Drawing** toolbars.
- Select **Edit > Glue Points** on the main menu bar.
Glue Points toolbar and Visible Buttons

Note

The Show Glue Point Functions icon on the Drawing toolbar is not part of the default set of tools for the Drawing toolbar. To add this icon, right click in an empty on the Drawing toolbar and select Visible Buttons > Glue Points from the context menu.

Glue point types

When the Glue Points toolbar (Figure 213) opens, only the six tools on the left of the toolbar are active. The remaining six tools on the right of the toolbar only become active when the Glue Point Relative icon is deselected.

The following briefly describes the function of each tool on the Glue Points toolbar (Figure 213).

- **Insert Glue Point** – inserts a glue point where you click in an object.
- **Exit Direction Left** – connector attaches to the left edge of the selected glue point.
- **Exit Direction Top** – connector attaches to the top edge of the selected glue point.
- **Exit Direction Right** – connector attaches to the right edge of the selected glue point.
- **Exit Direction Bottom** – connector attaches to the bottom edge of the selected glue point.
- **Glue Point Relative** – maintains the relative position of a selected glue point when you resize an object. This tool is selected by default when the Glue Point toolbar opens.

The following six tools only become active when the Glue Point Relative tool is deselected.

- **Glue Point Horizontal Left** – when the object is resized, the current glue point remains fixed at the left edge of the object.
- **Glue Point Horizontal Center** – when the object is resized, the current glue point remains fixed at the center of the object.
- **Glue Point Horizontal Right** – when the object is resized, the current glue point remains fixed at the right edge of the object.
- **Glue Point Vertical Top** – when the object is resized, the current glue point remains fixed at the top edge of the object.
• **Glue Point Vertical Center** – when the object is resized, the current glue point remains fixed at the vertical center of the object.

• **Glue Point Vertical Bottom** – when the object is resized, the current glue point remains fixed at the bottom edge of the object.

**Note**

Each glue point you have added can have only one horizontal position and one vertical position. Only one of the horizontal position tools and one of the vertical position tools can be selected and used at any one time.

**Adding glue points**

By default, most objects normally have four glue points. Add additional glue points to an object as follows:

1) Make sure no objects are selected and use one of the following methods to open the Glue Points toolbar:
   – Click on the Show Glue Point Functions icon on the Standard or Drawing toolbars.
   – Select Edit > Glue Points on the main menu bar.
2) If the Glue Points toolbar does not open, go to View > Toolbars > Glue Points on the main menu bar.
3) Select the object and then the Insert Glue Point icon, or right click on a glue point you have previously inserted and select Insert Glue Point from the context menu.
4) Move your cursor to a position where you want the glue point on an object and click to insert the glue point.
5) To move a glue point to another position, click on the glue point and drag it to its new position.

**Tip**

When adding, moving or customizing glue points, it is recommended to use the zoom function to make it easier to work with glue points. See Chapter 3 Working with Objects and Object Points for more information. Also, glue points snap to the grid making it easier to position a glue point.

**Customizing glue points**

Only glue points that have been added to an object can be customized. The default glue points included with an object cannot be customized.

Customize the exit direction for the added glue point as follow:

1) Make sure no objects are selected and use one of the following methods to activate glue points that have been added to an object:
   – Click on the Show Glue Point Functions icon on the Standard or Drawing toolbars.
   – Select Edit > Glue Points on the main menu bar
2) If the Glue Points toolbar does not open, go to View > Toolbars > Glue Points on the main menu bar.
3) Double-click on a glue point that you have added to select the glue point for customization.
4) Select an exit direction you want to use for the connector you will be attaching to the glue point from the **Glue Points** toolbar (Figure 213 on page 165), or right click on the glue point and select the exit direction from the context menu.

Customize the horizontal and vertical positioning for the added glue point as follow:

1) Make sure no objects are selected and use one of the following methods to activate glue points that have been added to an object:
   – Click on the **Show Glue Point Functions** icon on the **Standard** or **Drawing** toolbars.
   – Select **Edit > Glue Points** on the main menu bar.

2) If the **Glue Points** toolbar does not open, go to **View > Toolbars > Glue Points** on the main menu bar.

3) Double-click on a glue point that you have added to select the glue point for customization.

4) Click on the **Glue Point Relative** icon on the **Glue Points** toolbar (Figure 213 on page 165) to deselect this tool, or right-click on the glue point and deselect **Glue Point Relative** from the context menu.

5) Select the horizontal and vertical positioning tools you want to use for the glue point. Only one horizontal positioning tool and one vertical positioning tool can be used at any one time.

---

**Deleting glue points**

Only glue points that have been added to an object can be deleted. The default glue points included with an object cannot be deleted.

1) Select the glue point you have previously added and now want to delete.

2) Press the **Delete** key or go to **Edit > Cut** on the main menu bar.

---

**Connector text**

Text can be easily added to connectors, then formatted or edited to make, for example, your flowchart or organization chart easier to follow. See Chapter 2 Drawing Basic Shapes and Chapter 9 Adding and Formatting Text for more information on working with text.

---

**Adding text**

1) Select the connector and the control points become active.

2) Click on the **Text** icon or **Text Vertical** icon (if active) on the **Standard** toolbar. A flashing text cursor appears close to the connector and the **Text Formatting** toolbar (Figure 214) opens.

3) If necessary, use the tools available on the **Text Formatting** toolbar or go to **Format > Text** on the main menu bar to change the text format.

4) Type the text and, when you have finished typing your text, move the cursor away from the text and connector and click to end the text mode. This also closes the **Text Formatting** toolbar.

---

*Connectors and glue points* | 167
Formatting and editing text

1) Select the connector and the control points become active.
2) Click on the Text icon or Text Vertical icon (if active) on the Standard toolbar and the Text Formatting toolbar (Figure 214) opens.
3) Use the tools available on the Text Formatting toolbar or go to Format > Text on the main menu bar to change the text format.
4) Right-click on the connector text and select Text from the context menu to open the Text dialog (Figure 215) allowing you to change how the text appears next to the connector:
   - Drawing Object Text – allows you to fit the text to the connector rectangle (frame) or allow the text to follow the contour of the connector.
   - Spacing to Borders – creates margins around the text within the connector rectangle.
   - Text Anchor – positions the text within the connector rectangle.

Figure 215: Text dialog – Text page

Figure 216: Text dialog – Text Animation page
5) If required, click on the **Text Animation** tab (Figure 216) where you can select options to animate the text. However, this is not recommended unless you are going to display the drawing as part of a presentation. See the *Impress Guide* for more information on text animation.

6) When you have finished editing the text, move the cursor away from text and connector and click to end the text mode. This also closes the **Text Formatting** toolbar.

---

**Flowcharts**

For drawing flowcharts (also known as flow diagrams), Draw has a **Flowchart** toolbar (Figure 217) that includes a large selection of flowchart tools to help you to easily draw a flowchart. To open the **Flowchart** toolbar:

1) Click on the small triangle to the right of the **Flowchart** icon on the **Drawing** toolbar to open the **Flowchart** pop up menu. Note that this icon changes shape depending on the last flowchart tool used.

2) Click at the top of the **Flowchart** menu and drag it into your workspace.

3) Release the mouse button and the **Flowchart** menu becomes a floating **Flowchart** toolbar.

---

*Figure 217: Flowchart toolbar and Visible Buttons*
Recommended basic steps to follow when creating a flowchart:

1) When adding objects to your flowchart, see *Chapter 2 Drawing Basic Shapes* for information on how to draw and resize object shapes.

2) Add text to each flowchart shape to make it easily identified in the flowchart. See *Chapter 2 Drawing Basic Shapes* and *Chapter 11 Advanced Draw Techniques* for more information.

3) Use connections lines in your flowchart. This allows repositioning of an object in your chart while maintaining connections with the other objects in the chart. See “Connectors and glue points” on page 161 for more information.

4) Use the zoom, grid and snap functions to help in positioning objects in your flowchart. See *Chapter 3 Working with Objects and Object Points* for more information.

5) Use the alignment and distribution functions to give your flowchart a more professional look. See *Chapter 5 Combining Multiple Objects* for more information.

6) Duplicate objects when you require more than one of the same shape and size. See *Chapter 5 Combining Multiple Objects* for more information.

### Organization charts

Draw does not have a toolbar for organization charts, but these charts are easily created using basic shapes, flowchart shapes, connection points and connector lines. Hierarchy in an organization is easily indicated using shading and/or color. When using shading and color in an organization chart, make sure that your selection provides a good contrast between the text and the shading or color to make the chart easy to read on a computer display or in a printed document.

![Figure 218: Example organization chart](image)

An example of an organization chart is shown in Figure 218. This was drawn using the process shape from the **Flowchart** toolbar and connection lines.

1) When adding objects to your chart, see *Chapter 2 Drawing Basic Shapes* for information on how to draw and resize object shapes.

2) Add text to each object in the organization chart to make it easily identified in the chart. See *Chapter 2 Drawing Basic Shapes* and *Chapter 11 Advanced Draw Techniques* for more information.

3) Use connections lines in your organization chart. This allows repositioning of an object in your chart while maintaining connections with the other objects in the chart. See “Connectors and glue points” on page 161 for more information.

4) Use the zoom, grid and snap functions to help in positioning objects in your chart. See *Chapter 3 Working with Objects and Object Points* for more information.

5) Use the alignment and distribution functions to give your organization chart a more professional look. See *Chapter 5 Combining Multiple Objects* for more information.

6) Duplicate objects when you require more than one of the same shape and size. See *Chapter 5 Combining Multiple Objects* for more information.
Chapter 9
Adding and Formatting Text
Introduction

When text is used in drawings, it is placed inside an object or inside a text box. This chapter describes how to create, format, use, and delete text. It also discusses the various types of text that can be inserted into a drawing. Finally, it provides information on how to insert special forms of text such as numbered or bulleted lists, tables, fields, hyperlinks, and Fontwork.

Text

Text mode

Before any text can be typed in a drawing, text mode has to be activated. Click on the Insert Text icon for horizontal text or the Insert Vertical Text icon for vertical text on the Standard toolbar (Figure 219) or Drawing toolbar (Figure 220). The Text Formatting toolbar (Figure 221) automatically opens replacing the Line and Filling toolbar.

Figure 219: Standard toolbar - text tools highlighted

Figure 220: Drawing toolbar - text tools highlighted

Figure 221: Text Formatting toolbar

If the Insert Vertical Text icon is not visible on the Standard or Drawing toolbars, it can be activated as follows:

1) Go to Tools > Options > Language Settings > Languages on the main menu bar to open the Languages page in the Options dialog.
2) In Default Languages for Documents, select the Asian option and Default – Chinese (simplified) is displayed in the scroll box.
3) Click Apply then OK to close the Options dialog and save your changes.
4) Restart LibreOffice to activate vertical text.

Adding text

When you add text to a drawing, a text box is automatically created to contain the text. By default, the text box expands horizontally to accommodate a single line of text. To change the default setting, you have to format the text box, see “Error: Reference source not found” on page Error: Reference source not found for more information.

1) Activate text mode, see “Text mode” above for information.
2) Click in your drawing at the approximate position where you want to place the text. A text box is created containing a flashing cursor.
3) Start typing your text. As you type the text box automatically expands horizontally to accommodate a single line of text. Also, the left corner of the Status Bar indicates that you are in text edit mode and the position of your cursor (Figure 222).
4) To create multiple lines in the text box being created use one of the following methods:
   – Use the Enter key to create single line paragraphs inside the text box. The text box expands vertically to accommodate more lines of text.
   – Create a text box before typing text, see “ ” below for more information. As you reach the horizontal limit of the text box, the text will automatically word wrap inside the text box and the text box expands vertically as it fills.

5) When you have finished typing text, click outside the text box to exit text mode. The Text Formatting toolbar closes and the Line and Filling toolbar opens in its original position.

6) To format and/or reposition this text box, see “Moving, resizing, rotating and formatting text boxes” below and Chapter 3 Working with Objects and Object Points for more information.

7) If required, format the text, select the text using the various tools on the Text Formatting toolbar (Figure 219 on page 172) or in the Character and Paragraph sections in the Properties deck of the Sidebar (Figure 223). For more information on text formatting, see “Formatting text” on page 180.

Creating text boxes
It is recommended to create a text box before before entering any text in your drawing. This will give you an opportunity to create, for example, a caption for a shape, an explanatory note, or a drawing title block similar to those used in engineering drawings.
1) Activate text mode, see “Text mode” on page 172 for information.

2) Click and drag to create a text box on the drawing setting the width of the text box. The height of the text box automatically increases as you type or add text.

3) Release the mouse button when you have reached the desired width for your text box. A flashing cursor appears in the text box and the text box, depending on your computer system, has a border indicating edit mode.

4) Type or paste your text in the text box. The status bar at the bottom of the drawing workspace indicates that you are in text edit mode and the cursor position within the text box (Figure 222 on page 173).

5) Click outside the text box to deselect and cancel text mode. The **Text Formatting** toolbar closes and the default **Line and Filling** toolbar opens in its original position.

6) If required, format the text using the various tools on the **Text Formatting** toolbar (Figure 219 on page 172) or in the **Character** and **Paragraph** sections in the **Properties** deck of the Sidebar (Figure 223 on page 173). For more information on text formatting, see “Formatting text” on page 180.

---

**Note**

Text boxes use a simplified edit engine and are designed for text only. Text boxes cannot contain illustrations, inline pictures, formulas, tables or shapes.

---

**Moving, resizing, rotating and formatting text boxes**

You can format, move, resize and rotate a text box just like any other object in your drawing. For more information, see *Chapter 3 Working with Objects*.

**Moving text boxes**

1) Click on the text in a text box to switch the text into edit mode and the text box border is displayed.

2) Move the cursor over the border. The cursor changes shape to the move symbol for your computer setup (for example, a clenched hand).

3) Click and drag the text box to a new position in your drawing. A semi-transparent copy of the text box shows where your text box will be placed (Figure 224).

4) Release the mouse button when the text box is in the required position.

5) To accurately position a text box, use the **Position and Size** dialog or the **Position and Size** section on the Sidebar. See *Chapter 3 Working with Objects and Object Points* for more information on the **Position and Size** dialog or the **Position and Size** section on the Sidebar.

---

![Figure 224: Moving a text box](image-url)
Resizing text boxes

1) Click on the text in a text box to switch the text into edit mode. If the text box does not have a border defined, then a border is displayed depending on your computer setup.

2) Move the cursor over one of the selection handles and the cursor changes shape to the resizing symbol for your computer setup (for example, a double-headed arrow).

3) Click and drag the border to a new position to resize the text box. A semi-transparent copy of the text box shows as you resize (Figure 225).

4) Release the mouse button when the text box reaches the desired size.

5) If necessary, adjust the height or width of the text box using the selection handles.

6) To accurately resize a text box, use the Position and Size dialog or the Position and Size section on the Sidebar. See Chapter 3 Working with Objects and Object Points for more information on the Position and Size dialog or the Position and Size section on the Sidebar.

Rotating text boxes

1) Click on the text in a text box to switch the text into edit mode. If the text box does not have a border defined, then a border is displayed depending on your computer setup.

2) Click on the text box border so that the selection handles are visible indicating that the text box is now edit mode.

3) Click again on the text border or select the Rotation tool on the Transformations toolbar. The selection handles change shape and color.

4) Click and drag on a corner handle to rotate the text box. A ghosted outline of the text box being rotated appears and the current angle of rotation is shown in the status bar (Figure 226).

5) Release the mouse button when the text box is at the desired rotation angle.

6) To accurately rotate a text box, use the Rotation page in Position and Size dialog or the Position and Size section on the Sidebar. See Chapter 3 Working with Objects and Object Points for more information on the Position and Size dialog or the Position and Size section on the Sidebar.
Note

When in rotation mode, the top, bottom, and side handles though visible, are not available for use on a text box. Also, text boxes can not be sheared, slanted, flipped vertically or flipped horizontally.

Formatting text boxes

Text boxes can be treated just like other basic shapes in your drawing when you want to format the area or border (line) of a text box. See Chapter 3 Working with Objects and Object Points for more information on formatting text boxes.

Formatting how text appears inside a text box is as follows:

1) Select a text box and use one of the following methods to open the Text dialog (Figure 227).
   - Right click on the text box and select Text... from the context menu.
   - Go to Format > Text... on the main menu bar. The Text icon opens a context menu allowing you to format text and not the text box.

2) On the Text page (Figure 227), select the options required in Drawing Object Text and Spacing to Borders.

![Figure 227: Text dialog](image-url)
3) On the **Text Animation** page (Figure 228), select the options required in **Effect** and **Properties**. However, this is not recommended unless you are going to display the drawing as part of a presentation. See the *Impress Guide* for more information on text animation.

4) Click on **OK** to save your selected options and close the dialog.

### Deleting text boxes

1) Click on the text in a text box to switch the text into edit mode and the text box border is displayed.

2) Click on the text box border so that the selection handles are visible indicating that the text box is now edit mode.

3) Press the *Delete* key and the text box is deleted without any warning.

### Using text with Draw objects

Text can be added to most Draw objects. The exceptions are control elements like buttons, polygons, curves or 3D objects.

By default, a Draw object is not dynamic when it is first created and does not behave like a text box. Text does not word wrap and to keep text within the borders of the object, you have to use paragraphs, line breaks, smaller text size, increasing the object size, or a combination of all four methods.

To create text in a Draw object (Figure 229) and use word wrap in a Draw object is as follows:

1) Create an object in your drawing and make sure the object is selected with the selection handles displayed.

2) Click on the **Insert Text** icon for horizontal text or **Insert Vertical Text** icon for vertical text on the **Standard** or **Drawing** toolbar and a text cursor starts flashing in the center of the selected object. Also, the **Text Formatting** toolbar (Figure 219 on page 172) automatically opens replacing the **Line and Filling** toolbar.

3) Alternatively, double-click on an object to automatically enter horizontal text editing mode.
4) To change to vertical text after double clicking on an object, click on the Insert Vertical Text icon for vertical text on the Standard or Drawing toolbar.

5) Start typing your text. If your text goes outside the object borders, use paragraphs, line breaks, smaller text size, increasing the object size, or a combination of all four methods to keep the text within object borders.

6) Alternatively, to make sure your text word wraps staying within the borders of an object, proceed as follows:
   a) Right-click on the text inside the object and select Text... from the context menu to open the Text dialog (Figure 230).
   b) Click on the Text tab to open the Text page.
   c) In Custom Shape Text select the option Word wrap text in shape.
   d) Click OK to close the dialog and save your changes.
   e) When finished typing text, click outside of the object to cancel text mode and save your changes. The text inside the object will now word wrap, as shown in Figure 229.

7) To format how the text appears inside an object, see "Formatting text" on page 180.
Note
If double-clicking does not work, then go to View > Toolbars on the main menu bar and open the Options toolbar. Select the Double-click to edit Text option or press the F2 key.

Inserting text

Pasting text
Text may be inserted into a text box or object by copying text from another document and pasting into the text box or object on your drawing. However, pasted text may not match the formatting of the text that has already been included on your drawing. This may be what you want on some occasions, but in most cases it is better to make sure that text format is consistent throughout your drawing.

Note
If you paste copied text directly into a drawing and not into an object using Format > Paste on the main menu bar or the keyboard short cut [Ctrl+V], the text is pasted in as an OLE object and not as a Draw object. It is recommended to paste text into Draw as unformatted text to create a text object in Draw.

Pasting unformatted text
It is good practice to paste text without formatting and apply the formatting later so it matches the text already in your drawing.

1) Copy the text you want to use, then move your cursor into position on the drawing.
2) Paste your copied text using one of the following methods:
   – Go to Edit > Paste Special > Paste Unformatted Text on the main menu bar.
   – Go to Edit > Paste Special > Paste Special on the main menu bar and the Paste Special dialog (Figure 231) opens. Select Unformatted text and click OK to close the dialog.
   – Use the keyboard shortcut Control+Shift+V and the Paste Special dialog (Figure 231) opens. Select Unformatted text and click OK to close the dialog.

Figure 231: Paste Special dialog
- Click on the small triangle next on the right of the Paste icon on the Standard toolbar and select Unformatted text from the context menu.

3) The copied text will be pasted into a text box at the cursor position and formatted to the default paragraph style of the object.

**Pasting PDF text**

PDF text is pasted into a text box at the center of your drawing or into a selected object.

1) Select the text in a PDF file you want to use and copy to the clipboard.

2) Click in your LibreOffice drawing and paste the copied PDF text into your drawing using one of the following methods. The PDF text is copied into your drawing and the text retains some of the formatting from the PDF file.
   a) Go to Edit > Paste on the main menu bar.
   b) Use the keyboard shortcut \[Ctrl+V\].
   c) Right click in your drawing and select Paste from the context menu.

3) If required, see “Pasting unformatted text” above to paste unformatted text into your drawing. The PDF text is pasted using the default text formatting for your drawing.

**Formatting pasted text**

1) Select the text you have just pasted (see “Selecting text” below for more information). The Text Formatting toolbar (Figure 219 on page 172) automatically opens replacing the Line and Filling toolbar.

2) Use the formatting tools that are available on the Text Formatting toolbar, or go to Format on the main menu bar and select a formatting tool from the drop-down menu.

3) Alternatively, go to Format > Styles on the main menu bar and select an option from the context menu or use one of the options available on the Styles deck on the Sidebar. See “Using graphic styles” on page 185 for more information.

**Inserting special characters, non-breaking spaces and hyphens**

For information on how to insert special characters, non-breaking spaces and hyphens into a drawing, see the Getting Started Guide and the Writer Guide for information.

**Formatting text**

The appropriate use of text formatting can give text in a drawing a consistent look, making your drawing look more professional without any distracting elements. Formatting text may require some intervention in character attributes (for example, font color), paragraph attributes (for example, alignment) or list attributes (for example, type of bullet).

**Selecting text**

Before formatting any text, the text must be selected in a text box or object:

1) Make sure the text box or object is selected where you want to select text.

2) Click in the text you want to select to position the cursor.

3) Select the text to be formatted using one of the following methods:
   - Use the keyboard shortcut \[Ctrl+A\] to select all the text.
   - Click and drag the cursor over the text.
   - Press Shift then use the left or right arrow keys to select characters.
– Press Shift+Ctrl then use the left or right arrow keys to select whole words.
– Press Shift+Home to select text to the beginning of the line.
– Press Shift+End to select text to the end of the line.

**Direct text formatting**

Direct text formatting is normally carried out on text in LibreOffice Draw. However, in situations where you need to perform the same formatting to several paragraphs of text, then the use of paragraph styles is recommended.

### Tip

Sometimes it is very useful to re-apply the default style to a selection of text removing any manual formatting applied to it, especially if a mistake has been made and you are not sure how to undo it. To revert back to the default style, select the manually formatted text and select Format > Clear Direct Formatting on the main menu bar.

**Direct character formatting**

Characters can be formatted independently from the format used for a paragraph. This character formatting overrides any paragraph formatting applied directly or using a paragraph style. There are no character styles available for text in LibreOffice Draw. Any character formatting must be applied directly.

### Note

If a text box or object has been selected, but the text is NOT selected, any character formatting will be applied to all of the text contained within the text box or object.

1) Click on text where you want to format characters. The Text Formatting toolbar (Figure 219 on page 172) automatically opens replacing the Line and Filling toolbar.
2) Select the characters you want to format. See “Selecting text” above for information on how to select text.
3) Use one of the following methods to open the Character dialog (Figure 232):
   – Go to Format > Character on the main menu bar.
   – Right-click on the selected characters and select Character from the context menu.
4) Make your formatting changes to the selected characters using the options available in the tabbed pages of the Character dialog.
5) Click OK to save your changes and close the dialog.
6) Alternatively, use the tools available on the Text Formatting toolbar (Figure 219 on page 172) or the Character section in the Properties deck on the Sidebar to format the characters.
7) To cancel any changes you have made to the character format, click Reset in the Character dialog or go to Format > Clear Direct Formatting on the main menu bar and the characters revert back to the original paragraph formatting.
Character formatting options

The formatting options in the tabbed pages of the **Character** dialog (Figure 232) are used as follows:

- **Font** – select the desired font type, its base attributes (Italic, Bold, Language, and so on) as well as the size. A sample of the font is displayed in the lower part of the dialog. This font page is also available when creating or modifying a graphics style.

  If support for Asian language and Complex Text Layout (CTL) has been enabled (**Tools > Options > Language Settings > Languages**), then the **Font** page is divided into three parts for Western, Asian, and CTL text fonts allowing you to specify text fonts and their attributes for the majority of font families.

- **Font Effects** – apply special effects to the text (Font Color, Text Decoration and Effects). A sample of the text is displayed in the lower part of the dialog as a quick visual check of the effects applied. This page is also available when creating or modifying a graphics style.

- **Position** – select the type of position, scaling and spacing applied to text. This page is not available when creating or modifying a graphics style.
  - **Position** – sets the text position relative to the baseline when you need to insert subscripts or superscripts.
  - **Scaling** – specifies the percentage of the *Scale width* (font width) by which to compress or expand the individual characters of the selected text.
  - **Spacing** – sets the spacing between the characters of the font, which can be defined in number of points.
– **Pair kerning** – automatically adjusts the spacing between certain pairs of characters to visually improve the appearance.

- **Highlighting** – sets the color used when you highlight text.

**Direct paragraph formatting**

Any individual or direct paragraph formatting will override any formatting that has been applied using a drawing object style.

1) Click on text where you want to format paragraphs. The Text Formatting toolbar (Figure 219 on page 172) automatically opens replacing the Line and Filling toolbar.

2) Select the paragraph you want to format. For more information about selecting text, see “Selecting text” on page 180.

3) Use one of the following methods to open the **Paragraph** dialog (Figure 233):
   - Go to Format > Paragraph on the main menu bar.
   - Click the Paragraph icon on the Text Formatting toolbar (Figure 219 on page 172).
   - Right-click on the selected text and select Paragraph from the context menu.

4) Make your formatting changes to the selected paragraph using the options available in the tabbed pages of the **Paragraph** dialog.

5) Click OK to save your changes and close the dialog.

6) To cancel any changes you have made to the paragraph format, click Reset in the Paragraph dialog and the paragraph revert back to the original formatting.

7) Alternatively, use the tools available on the Text Formatting toolbar (Figure 219 on page 172) or the Paragraph section in the Properties deck on the Sidebar to format the paragraphs.

---

**Figure 233: Paragraph dialog - Indents & Spacing page**
**Paragraph formatting options**

The formatting options for the tabbed pages of the Paragraph dialog (Figure 233) are as follows:

- **Indents and Spacing** (Figure 233) – determines the indents and spacing used in a paragraph.
  - *Indent* – modifies the indentation of the text (before and after) as well as the indentation of the first line.
  - *Spacing* – defines the space before and after each paragraph formatted with the style.
  - *Line spacing* – determines the spacing between two lines formatted with the style. Note that selecting *Proportional* spacing requires specifying the percentage of a line to be used as spacing; 100% single line, 200% double line, 50% half a line. If *Leading* is selected, specify the amount of line spacing in your default unit of measurement.

**Tip**

You can change the default unit of measurement by going to **Tools > Options > LibreOffice Draw > General** on the main menu bar.

- **Asian Typography** (Figure 234) – sets the following properties relative to line changes and is only available if the *Asian* option is selected in **Tools > Options > Language Settings > Languages** on the main menu bar.
  - Apply list of forbidden characters to the beginning and end of lines.
  - Allow hanging punctuation.
  - Apply spacing between Asian and non-Asian text.

- **Tabs** (Figure 235) – determines the Position, Type and Fill Character of tab stops. This page is also available in the *Graphics Styles* dialog.

- **Alignment** (Figure 236) – determines paragraph alignment. A preview shows the effects of the changes. Paragraph alignment can also be carried out using the alignment icons on the Text Formatting toolbar and the Paragraph section on the Properties deck of the Sidebar.

- **Options** – sets the paragraph alignment depending on the option selected.

- **Text-to-text** – sets vertical alignment of text when there is a mix of font sizes on the same line of text. The options are Automatic, Base line, Top, Middle and Bottom.

- **Properties** – sets the text direction. Left-to-right (LTR) and Right-to-left (RTL) are only available if Complex text layout language has been selected.

---

**Figure 234: Paragraph dialog - Asian Typography page**
Using graphic styles

Applying the same format options to a Draw object or text is a repetitive process that can be greatly simplified by the use of styles. Graphic styles in Draw allow you to define a formatting template (a style) and then apply that style to several graphic or text objects.

For more information on graphic styles for graphic settings such as area or border lines, see Chapter 4 Changing Object Attributes in this guide. For more information on text styles see the Writer Guide.

Draw has several styles readily available for use with objects and text. These default styles cannot be deleted or renamed, but can be modified using the various options available in the Graphic Styles dialog (Figure 237).
Linked styles

The styles in Draw support inheritance. This means that a style can be linked to another (parent) style so that it inherits all the formatting settings of the parent. You can use this property to create hierarchical or families of styles. Figure 238 shows an example of linked or hierarchical styles used in Draw.

For example, if you need multiple blocks of text that differ in size, but are otherwise identically formatted, it is recommended to create a generic style for the type of font, style of font, and so on. You then create a number of hierarchically dependent styles which differ only in the font size. If you then need to change the font style, it is sufficient to change the parent style and all the other linked styles will change accordingly.
Creating new styles

After creating a new style, it will be placed All Styles and Custom Styles in the Styles deck of the Sidebar (Figure 238). When your new style is applied to an object or text, the new style will also appear in Applied Styles.

1) Carry out all the formatting changes to the selected text, then use one of the following methods to create a new style:
   – Go to Format > Styles > New Style from Selection on the main menu bar to open the Graphic Styles dialog (Figure 237 on page 186).
   – Right click on a style name in the Styles deck on the Sidebar (Figure 238) and select New from the context menu.
   – Click on the New Style from Selection icon on the Styles deck in the Sidebar (Figure 238) to open the Graphic Styles dialog (Figure 237 on page 186).

2) If using the Graphics Style dialog, proceed as follows:
   a) Click on the Organizer tab to open the Organizer page (Figure 237 on page 186).
   b) Enter a unique name for your style in Name.
   c) If you are NOT linking the new style to another style in your drawing, select None from the drop down list in Inherit from.
   d) If you are linking the new style already created in your drawing, select the style name from the drop down list in Inherit from.
   e) Click OK to save your changes and close the dialog.

3) If you have clicked on the New Style from Selection icon on the Styles deck in the Sidebar (Figure 238), enter a style name in the Create Style dialog (Figure 239) that has opened. Click OK to close this dialog and save your changes.

![Create Style dialog](Figure 239: Create Style dialog)
Modifying or editing styles

It is recommended to only modify or edit styles that you have created.

1) Select text or an object with text in your drawing. The **Text Formatting** toolbar (Figure 219 on page 172) automatically opens replacing the **Line and Filling** toolbar.

2) Open the **Graphic Styles** dialog (Figure 237 on page 186) using one of the following methods:
   - Go to **Format > Styles > Edit Style** on the main menu bar.
   - Right click on the object and select **Edit Style** from the context menu.
   - Right click on the object style in the **Styles** deck on the Sidebar (Figure 238 on page 186) and select **Modify** from the context menu.

3) Use the various pages and available options in the **Graphic Styles** dialog to modify and edit the style as follows:
   - **Organizer** – shows the style name, the style name where settings have been inherited from, style category and the settings for the style it contains.
   - **Font, Font Effects, Indents & Spacing, Alignment, and Tabs** – set the properties of the text inserted in a text box or in a graphic object.
   - **Dimensioning** – used to set the style of dimension lines.
   - **Text, Text Animation, Connector, Line, Area, Shadowing, Highlighting and Transparency** – determines the formatting of an object.

4) Click **OK** when finished to save your changes and close the **Graphic Styles** dialog.

5) Alternatively, select your text and perform all the formatting changes, then proceed as follows:
   a) Select a style in **Styles** deck on the Sidebar (Figure 238 on page 186).
   b) Click on the **Update Style** icon and the style is saved with the new format attributes.

Editing linked styles

If you have an object in your document that uses linked styles then it is possible to edit the linked styles that have been applied to the object using the **Graphic Styles** dialog as follows:

1) Select text or an object with text in your drawing that uses linked styles. The **Text Formatting** toolbar (Figure 219 on page 172) automatically opens replacing the **Line and Filling** toolbar.

2) Open the **Graphic Styles** dialog (Figure 237 on page 186) using one of the following methods:
   - Go to **Format > Styles > Edit Style** on the main menu bar.
   - Right click on the object and select **Edit Style** from the context menu.
   - Right click on the object style in the **Styles** deck on the Sidebar (Figure 238 on page 186) and select **Modify** from the context menu.

3) Click on the **Organizer** tab to open the **Organizer** page in the **Graphic Styles** dialog.

4) Check that the style name in the **Inherit from** text box is the linked style you want to edit.
   - If the linked style is the one you want to edit, use the various pages in the **Graphic Styles** dialog to edit the style.
   - If the linked style is NOT the one you want to edit, click on **Edit Style** to the right of the **Inherit from** text box until the name of the linked is displayed. Use the various pages in the **Graphic Styles** dialog to edit the style.

5) Click **OK** when finished to save your changes and close the **Graphic Styles** dialog.
Applying styles
You can apply a style to text in a text box or in an object as follows:

1) Select the text where you want to apply a style. The Text Formatting toolbar (Figure 219 on page 172) automatically opens replacing the Line and Filling toolbar.
2) Click on the Styles icon on the Sidebar to open the Styles deck (Figure 238 on page 186).
3) Select the style name you want to use in the Styles deck on the Sidebar.
4) Double click on the style name in the Styles deck on the Sidebar to apply the style to the selected object.

Tip
At the bottom of the Styles deck on the Sidebar there is a drop-down list. Choose to show all styles or groups of styles such as Applied Styles or Custom Styles.

Deleting styles
You cannot delete any of the predefined styles in LibreOffice, even if you are not using them. You can only delete user-defined (custom) styles. However, before you delete a custom style, make sure the style is not in use. To see which styles are in use, choose Applied Styles from the drop-down list at the bottom of the Styles deck on the Sidebar.

Delete a custom style as follows:

1) Click on the Styles icon on the Sidebar to open the Styles deck (Figure 238 on page 186).
2) Select Applied Styles or Custom Styles from the drop down list at the bottom of the Styles deck on the Sidebar to display the styles in use.
3) Right click on the style name in the styles list and select Delete from the context menu.
4) If the style is in use, a warning message will appear. Click Yes to delete the style. If the style is not in use, no confirmation message appears.

Creating bulleted and numbered lists
Bulleted and numbered lists can be created in text boxes, shapes, and objects. However, when creating lists in shapes and objects, remember that shapes and objects are not dynamic and do not automatically expand as you create a list.

Note
Creating bulleted or numbered lists in Draw is similar to LibreOffice Writer, but the functionality in Draw has been reduced.

Creating lists
Bulleted or numbered lists can be created using text boxes or Draw objects as follows:

1) Click on text where you want to create a bulleted list. The Text Formatting toolbar (Figure 219 on page 172) automatically opens replacing the Line and Filling toolbar.
2) Select all of the text you want to use in a bulleted or numbered list.
3) A bulleted or numbered list is created using one of the following methods and default settings for lists:
– Click on Toggle Bullet List or Toggle Numbered List icons on the Text Formatting toolbar.

– Click on Toggle Bullet List or Toggle Numbered List icons in the Lists section on the Properties deck of the Sidebar.

– Go to Format > Lists > Bulleted List or Numbered List on the main menu bar.

4) To change the format of the list as you create it, click on the small triangle on the right of the list icons and select a list style from an option in the pop up window (Figures 240 and 241).

Adjusting list item levels

Each list item in a bulleted or numbered list can have its level adjusted within a list as follows:

1) Click at the beginning of a list item to position the flashing cursor at the correct position. The flashing cursor must be at the beginning of the list item to demote or promote the list item in a list.

2) To demote the position of the list item, press the Tab key. Each press of the Tab key will demote the list item down one more level in the list.

3) To promote the position of the list item, press use the key combination Shift+Tab. Each press of the Shift+Tab key combination will promote the list item up one more level in the list.

Editing and customizing a list

You can edit and customize the appearance of a list by changing the bullet type or numbering for the entire list or a single entry or the outline level of a list item. All changes are made using the Bullets and Numbering dialog.

1) Select the list items you want to edit and customize. The Text Formatting toolbar (Figure 219 on page 172) automatically opens replacing the Line and Filling toolbar.

2) To open the Bullets and Numbering dialog (Figure 242), go to Format > Bullets and Numbering on the main menu bar, or right-click on the selected text and select Bullets and Numbering from the context menu.

3) Select the Level you want to edit and customize.

4) Change various options in Properties, Separator, Size, Position, and Scope to format the list style for each level in the list. The Preview box shows how your list will look as you make a selection.
5) To cancel any changes you have made, click Reset. The list reverts back to its original formatting.

6) When you are satisfied with your list, click on OK to save your changes and close the dialog.

**List format options**

The following options are available in the **Bullets and Numbering** dialog (Figure 242).

- **Level** – sets the outline level of list items from the left hand side of the page. Each level can be set to a different type of list. Select *Levels 1 – 10* to modify simultaneously all levels in a list.

- **Properties** – sets how each list item looks in the list.
  - **Type** – sets the type of list marker used (alpha, numeric or image).
  - **Color** – selects the color used for the list marker so that it stands out from the text in the list item.
  - **Start at** – enter the first value of the list marker (for example, you might want the list to start at 4 instead of 1).

- **Separator** – allows you to set what characters are used to separate the list marker from the text in the list item.
  - **Before** – enter any text to appear before the list marker (for example, Step)
  - **After** – enter any text to appear after the list marker (for example, a punctuation mark)
• **Size** – specifies the size (Rel. size) of the list marker relative to the size of the characters in the list item. This can be larger or smaller than the text size used for the list item. In case of a graphic as bullet, the size is the absolute size of the graphic. The checkbox “Keep ratio” connects width and height, so entering one value calculates the other automatically.

• **Position** – allows you to set the indentation and spacing of list markers and the list items.
  – *Indent* – sets the indentation of the list marker from the left side of the text box or object.
  – *Width* – sets the indentation distance of the text from the list marker creating a hanging indent, which is normal for bulleted or numbered lists.
  – *Relative* – if checked, the indent of the list item is measured relative to the settings of the parent level when linked styles are used.
  – *Alignment* – sets the alignment (left, center or right) of a list marker inside the area, which is defined by *Width*. This is useful when using a numeric list marker that will consist of two or more characters to maintain correct spacing between the list marker and list item.

• **Scope**
  – *Slide* – applies any changes to all items in your drawing.
  – *Selection* – applies any changes only to the selected items in your drawing.
  – *Apply to Master* – applies any changes to any items in the master page of your drawing, if you have created a master page.

**Adjusting list item levels**

Each list item in a bulleted or numbered list can have its level adjusted within a list as follows:

1) Click at the beginning of a list item to position the flashing cursor at the correct position. The flashing cursor must be at the beginning of the list item to demote or promote the list item in a list.

2) To demote the position of the list item, press the **Tab** key. Each press of the Tab key will demote the list item down one more level in the list.

3) To promote the position of the list item, press use the key combination **Shift+Tab**. Each press of the **Shift+Tab** key combination will promote the list item up one more level in the list.

**Using tables**

Tables are useful when you want to show structured information in your drawing, for example a specification list or drawing title block. You can create tables directly in Draw, eliminating any need to embed a Calc spreadsheet or a Writer text table in your drawing. The tables provided by Draw do have a limited functionality.

**Creating tables**

When working with tables, it is useful to know the number of rows and columns required as well as the appearance. Tables are placed at the center of a drawing and cannot be placed into objects or shapes. Also, unlike text boxes and other objects, tables cannot be rotated.

1) Go to **Insert > Table** on the main menu bar to open the **Insert Table** dialog (Figure 243).

2) Select the required number of columns and rows for the table.
3) Click **OK** to place a table in the center of your drawing and close the dialog.

4) Alternatively, click on the **Table** icon on the **Standard** toolbar to open the **Table** grid (Figure 244).

5) Click and drag the cursor until you have the required number of columns and rows, then click again. A table is placed at the center of your drawing and the **Table** grid closes.

6) Move the table into position by dragging it to its new position, see “Moving text boxes” on page 174 for more information.

**Table toolbar**

The **Table** toolbar (Figure 245) contains the majority of the tools you need to edit a table and is only active and visible when a table is selected. If the **Table** toolbar does not display when you select a table, go to **View > Toolbars > Table** on the main menu bar.

Normally, the **Table** toolbar is docked at the top or bottom of your workspace. To make the toolbar into a floating toolbar:

- If the toolbar is docked in a horizontal position, click at the left end of the toolbar and drag the toolbar onto the workspace.
- If the toolbar is docked in a vertical position, click at the top of the toolbar and drag the toolbar onto the workspace.
Modifying tables

Once the table is added to your drawing, you can control its appearance, size, position, and so on using a combination of the tools that are available in Draw.

- **Table** – creates a new table in a drawing. Opens the Insert Table dialog (Figure 243 on page 193) where you can select the required number of rows and columns. Alternatively, click on the small triangle next to the Table icon to open a graphic representation for creating a table (Figure 245). To use this tool, move the mouse to the right and down in the grid until you have the columns and rows you require and click the left mouse button. Clicking on More Options opens the Insert Table dialog.

- **Border Style** – changes the line style of the borders of selected cells. Click on the small triangle next to the Border Style icon to open a drop down list where you can choose from a range of predefined styles.

- **Border Color** – changes the color of the borders of selected cells. Click on the small triangle next to the Border Color icon to open a drop down list where you can choose a color from a range of predefined palettes or create a custom color.

- **Borders** – selects predefined border configurations of selected cells. Click on the small triangle next to the Borders icon to open a drop down list where you can choose the border configuration.

- **Area Style/Filling** – select the cells to be filled, then select the type of fill from the drop-down list: None, Color, Gradient, Hatching, or Bitmap. The fillings drop-down menu then shows the available fillings for the selected area fill type.
• **Merge Cells** – merges the selected cells into one cell. Note that the contents of the merged cells are also merged. You can also merge cells by right-clicking in the selected cells and selecting **Merge Cells** from the context menu that opens.

• **Split Cells** – make sure that the cursor is positioned on a cell you want to split, then click to open the **Split Cells** dialog (Figure 246). Select the number of cells required from the split as well as whether the cell should be split horizontally or vertically. When splitting horizontally, you can select the **Into equal proportions** option to get cells of equal size. The contents of the split cell remain in the original cell (the one on the left or top).

• **Optimize** – evenly distributes the selected cells either horizontally or vertically. Click on the small triangle next to the **Optimize** icon to open a drop down list where you can choose from a range of predefined options to optimize the selected cells.

• **Align Top, Center Vertically, Align Bottom** – you can select the vertical alignment of text in a cell by selecting the required cells and clicking on one of these tools.

![Figure 246: Split Cells dialog](image)

![Figure 247: Table Design section in Sidebar Properties](image)
• **Insert Row Above, Insert Row Below, Insert Column Before, Insert Column After** – select a row or column and use these four tools to insert a row or column.

• **Delete Row, Delete Column** – select rows or columns and use these tools to delete selected rows and columns from your table.

• **Select Table, Select Column, Select Row** – select a table, column, or row if you want to perform the same change to attributes for a table, column, or row.

• **Table Design** – opens the *Table Design* section (Figure 247) in the *Properties* deck on the Sidebar where you can select design and display options for your table.

• **Table Properties** – opens the *Table Properties* dialog, which contains the following tabbed pages. You can also open this dialog by right-clicking on the table and selecting *Table Properties* from the context menu.
  - **Font** (Figure 248) – select the desired font type and family, style (*Italic, Bold*, etc.), size, and language. A sample of the font is displayed in the lower part of the dialog.
  - **Font Effects** (Figure 249) – use to apply options in *Font Color, Text Decoration and Effects* to text.
  - **Borders** (Figure 250) – use to apply options in *Line Arrangement* (presets and user defined for borders), *Padding* (cell margins for contents) and *Line* (style, color and width of borders).
  - **Background** (Figure 251) – changes the background of selected cells and provides the same functions as the *Area* dialog (see *Chapter 4 Changing Object Attributes* for more information).
  - **Reset** – clicking this button resets the *Table Properties* dialog back to its original options.

*Figure 248: Table Properties dialog - Font page*
Using tables | 197
Position and size

On a drawing, you can change position and size of a table. However, the table cannot be rotated or sheared. See “Moving, resizing, rotating and formatting text boxes” on page 174 for more information.

Deleting tables

Whole table

Make sure the whole table is selected and the selection handles are visible, then delete the whole table using one of the following methods:

- Select Delete Row or Delete Column on the Table toolbar (Figure 245 on page 194).
- Right click and select Delete > Delete Row or Delete Column in the context menu.

Row or column

Click in a table cell, then delete the table row or column using one of the following methods. The table selection handles will not be displayed.

- Select Delete Row on the Table toolbar (Figure 245 on page 194) to delete the row that is selected.
- Right click and select Delete > Delete Row in the context menu to delete the row that is selected.
- Select Delete Column on the Table toolbar (Figure 245 on page 194) to delete the column that is selected.
- Right click and select Delete Column in the context menu to delete the column that is selected.

Cell contents

Delete cell contents in a table as follows:

1) Select the cell (or cells) contents.
2) Press the Delete or Backspace key on the keyboard.
Using fields

Fields allow the automatic insertion of text into a drawing. You can think of a field as a kind of formula which is calculated when the drawing is loaded or printed and the result is displayed in the drawing.

Inserting fields

A text box is created when you insert a field and can be repositioned just like any other text box. See “Text” on page 172 for more information.

1) Move the cursor where the field will be positioned.
2) Go to Insert > Field on the main menu bar.
3) Select a field from the options shown in the context menu.

The fields available in Draw are as follows:

- **Date (fixed)** – inserts the current date when the field was inserted.
- **Date (variable)** – inserts a field that is updated with the date each time the file is opened.
- **Time (fixed)** – inserts a field displaying the current time when the field was inserted.
- **Time (variable)** – inserts a field which is updated with the time each time the file is opened.
- **Author** – inserts the author of the drawing. This information is derived from the value recorded in the general options. To modify this information go to Tools > Options > LibreOffice > User Data on the main menu bar.
- **Page Number** – inserts the page number for each page in a multi page drawing.
- **Page Title** – inserts a page name for each page in a drawing.
- **Page Count** – inserts the total number of pages in a drawing.
- **File Name** – inserts a field that contains the name of the file.

Customizing fields

The appearance of fields can be customized as follows. **Page Number**, **Page Count** and **Page Title** fields cannot be customized.

1) Place the cursor at the start of the field data and go to Edit > Fields on the main menu bar to open the Edit Field dialog (Figure 252).
2) Select the desired format from the available options.
3) Click OK to save the changes and close the dialog.
4) Alternatively, right-click on the field and select the required options from the context menu.

![Edit Field dialog](image)

*Figure 252: Edit Field dialog*
Using hyperlinks

When inserting text that can be used as a hyperlink (for example website address or URL), Draw formats it automatically, creating the hyperlink and applying color and underlining.

Inserting hyperlinks

1) Click in the text box at the position where you want to insert a hyperlink.
2) Go to Insert > Hyperlink on the main menu bar, or use the keyboard shortcut Ctrl+K to open Hyperlink dialog (Figure 253).
3) Select the type of hyperlink you want to insert and the options you want to use.
4) Click Apply to insert the hyperlink and save your selections. If you are creating several hyperlinks, click Apply after each one.
5) Click Close or OK to save your changes and close the Hyperlink dialog.

On the left side, select one of the four types of hyperlinks. The dialog changes according to the type of hyperlink selected.

- **Internet** – select whether the link is Web or FTP. Enter the required web address (URL).
- **Mail** – enter the details for the email, also the subject.
- **Document** – creates a hyperlink to another document or to another place in the drawing, commonly referred to as a bookmark.
  - Enter the document path, or click on the Open File icon to open a file browser. Leave this blank if you want to link to a target in the same drawing.
  - Optionally, you can specify a target (for example. a specific slide). Click on the Target icon to open the Target in Document dialog, where you can select the target, or, if you know the name of the target, you can type it into the box.
- **New Document** – creates a hyperlink to a new document.
– Select **Edit now** to edit the newly created document immediately or Edit later to create a new document and edit it later.
– Choose the type of document to create (text, spreadsheet, etc.).
– The **Select path** icon opens a file browser so that you can choose the directory for the new document.

**Tips**

To prevent LibreOffice from automatically turning website addresses (URLs) into hyperlinks, go to **Tools > AutoCorrect > Options** and deselect the **URL Recognition** checkbox.

To change the color of hyperlinks, go to **Tools > Options > LibreOffice > Application Colors**. In **Custom Colors** scroll to **Unvisited links** and/or **Visited links**, select the checkboxes, pick the new colors and click **OK**. Caution: this will change the color for all hyperlinks in all components of LibreOffice which may not be what you want.

The **Further Settings** section on the **Hyperlink** dialog is common to all the hyperlink types, although some choices are more relevant to some types of links.

- **Frame** – determines how the hyperlink will open. This applies to documents that open in a Web browser.
- **Form** – specifies if the link is to be presented as text or as a button. See “Working with hyperlink buttons” on page 28 for more information.
- **Text** – specifies the text that will be visible to the user.
- **Name** – applicable to HTML documents. It specifies text that will be added as a NAME attribute in the HTML code behind the hyperlink.

**Editing text hyperlinks**

1) Select the hyperlink.
2) Go to **Edit > Hyperlink** on the main menu bar to open the **Insert Hyperlink** dialog (Figure 253).
3) Make your editing changes from the available options, then click **Apply** when done. If you need to edit several hyperlinks, click **Apply** after each one.
4) Click **Close** or **OK** to save your changes and close the dialog.

**Image maps**

An image map defines areas of an image (called hotspots) with hyperlinks to web addresses, other files on the computer, or parts of the same document. Hotspots are the graphic equivalent of text hyperlinks. Clicking on a hotspot causes LibreOffice to open the linked page in the appropriate program (for example, the default browser for an HTML page; LibreOffice Calc for a ODS file; a PDF viewer for a PDF file). You can create hotspots of various shapes and include several hotspots in the same image.

To use the **ImageMap Editor** (Figure 254):

1) In your Draw document, select an image in which you want to create a hotspot.
2) Go to **Tools > ImageMap** on the main menu bar to open the **ImageMap Editor**.
3) Select the type of hotspot area you want use from the icons at the top of the **ImageMap Editor** – **Rectangle**, **Ellipse**, **Polygon**, **Freeform Polygon**.
4) Draw the hotspot area onto the selected image.
5) Enter the address pointed by the hyperlink in the **Address**: text box using the address format: `file:///<path>/document_name#anchor_name`.
6) Click the **Apply** icon to apply the settings.
7) When done, click the **Save** icon to save the image map to a file, then close the *ImageMap Editor*.

The main part of the *ImageMap Editor* shows the image on which the hotspot is defined. A hotspot is indicated by an outline of the type of hotspot shape used. The *ImageMap Editor* contains the following tools:

- **Apply** icon – applies the changes.
- **Open**, **Save**, and **Select** icons.
- Hotspot shapes: *Rectangle*, *Ellipse*, *Polygon*, *Freeform Polygon*.
- **Edit Points**, **Move Points**, **Insert Points** and **Delete Points** icons: advanced editing tools to manipulate the shape of a polygon hotspot. Select **Edit Points** to activate the other icons.
- **Undo** and **Redo** icons
- **Active** icon – toggles the status of a selected hotspot between active and inactive.
- **Macro** icon – associates a macro with the hotspot instead of just associating a hyperlink.
- **Properties** icon – sets the hyperlink properties and adds the Name attribute to the hyperlink.
- **Address**: text box – address pointed to by the hyperlink. You can also point to an anchor in a document.
- **Text**: text box – type the text that you want to be displayed when the mouse pointer is moved over the hotspot.
- **Frame**: – where the target of the hyperlink will open and the option available is `_self` (opens in the active browser window).
Fontwork

With Fontwork you can create graphical text art objects to make your work more attractive. There are many different settings for text art objects (line, area, position, size, and more), so you have a large choice.

Fontwork is also available with the Writer, Calc, and Impress modules of LibreOffice, but you will notice small differences in the way that each component displays it.

Creating Fontwork

1) Click on the Fontwork icon on the Drawing or Standard toolbar or go to Insert > Fontwork on the main menu bar to open the Fontwork Gallery dialog (Figure 255).

2) Select a Fontwork style from the dialog and click OK. The selected Fontwork appears in your drawing and the dialog closes.

![Fontwork Gallery dialog](Figure 255: Fontwork Gallery dialog)

![Editing Fontwork text](Figure 256: Editing Fontwork text)
3) Double-click on the word Fontwork to switch on editing mode.
4) Type your own text to replace the word Fontwork and your text appears over the word Fontwork as shown in Figure 256.
5) Press the Esc key or click outside the selected area and your text replaces the word Fontwork.

Fontwork toolbar
The Fontwork toolbar (Figure 257) becomes visible and active on the workspace when you select a Fontwork object. If the toolbar is not visible, go to View > Toolbars > Fontwork on the main menu bar.

The Fontwork toolbar contains the following tools:

- **Fontwork Style** – opens the Fontwork Gallery dialog (Figure 255).
- **Fontwork Shape** – changes the shape of the selected object. Shapes available are shown in Figure 258.
- **Fontwork Same Letter Heights** – changes the height of characters in the selected Fontwork object. Toggles between normal height where the characters have different heights to where all characters have the same height.
- **Fontwork Alignment** – specifies the text alignment within the frame. Options available are left align, center, right align, word justify, and stretch justify. The effects of the text alignment can only be seen if the text spans over two or more lines. In the stretch justify mode, all lines are filled completely.
- **Fontwork Character Spacing** – selects the spacing between characters and whether kerning pairs should be used. Options available are very tight, tight, normal, loose, very loose and custom spacing. For custom spacing, input a percentage value: 100% is normal character spacing, less than 100% character spacing is tighter, and more than 100% character spacing is looser.
- **Toggle Extrusion** – converts the Fontwork object into a 3D shape using extrusion. See Chapter 7 – 3D Objects for more information.
Modifying Fontwork

A Fontwork object can be treated like any other object in Draw. It can be resized, rotated, skewed, slanted, flipped, and so on. For more information on modifying a Fontwork object, see Chapter 3 – Working With Objects, Chapter 4 – Changing Object Attributes and Chapter 5 – Combining Multiple Objects.

It is possible to treat Fontwork text as an object and apply all the formatting that has been described in this chapter. Assign line properties only to Fontwork which does not have a 3D effect, otherwise the changes will not be visible.

You can modify some of the Fontwork shapes just as you modify the angles of trapezoid and parallelogram basic shapes by moving the dot that is displayed along with the selection handles.
Chapter 10
Printing, Exporting and E-mailing
Quick printing

To quickly print a document or drawing, click on the Print Directly icon on the Standard toolbar (Figure 259) to send the entire document to the default printer that is defined for your computer.

![Standard toolbar](Figure 259: Standard toolbar)

**Note**

You can change the action of the Print Directly icon by sending a document to the printer defined for the document instead of the default printer for the computer. Go to Tools > Options > Load/Save > General and select the Load printer settings with the document option.

If the Print Directly icon is not visible on the Standard toolbar, right click in an empty area on the toolbar and select Visible Buttons from the context menu. Select Print Directly from the displayed list and the icon is added to the toolbar.

![Print dialog - General options](Figure 260: Print dialog - General options)
Due to different computer setups and different operating systems, the Print dialog (Figure 260) that appears on your monitor may differ from the one shown above. However, the printing options available for LibreOffice will remain the same.

**Controlled printing**

For more control over printing, open and use the Print dialog (Figure 260) using one of the following methods:

- Go to File > Print on the main menu bar.
- Use the keyboard `Ctrl+P`.
- Click on the Print icon on the Standard toolbar.

The options selected in the Print dialog only apply to the printing of the current document that is open in Draw. To specify default print settings for LibreOffice, go to Tools > Options > LibreOffice > Print on the main menu bar.

**General options**

The following general options are an example of what you may see on the Print dialog (Figure 260).

- **Printer** – select the printer to use from the printers available in the drop down list.
- **Range and Copies** – select from the following options:
  - **All Pages; Pages** (select page number); **Even pages; Odd pages; Selection**
  - **Paper sides**: Print on one side (simplex); Print on both sides (duplex long edge binding); Print on both sides (duplex short edge binding)
  - **Number of copies**: enter number of copies required for document
  - **Collate**: collates multiple copies into separate printed documents
  - **Order**: print pages of document in reverse order
- **Page Layout** – select from the following options:
  - **Paper size**: select from drop down list
  - **Orientation**: select automatic, portrait or landscape
  - **Pages per sheet**: select how many pages are printed on a sheet of paper
  - **Order**: printing order of multiple pages on a sheet of paper
  - **Draw a border around each page**
  - **Brochure**: prints the document so you can fold the pages like a booklet

**LibreOffice Draw options**

The following options are available LibreOffice Draw page of the Print dialog (Figure 261) where you can define settings that are specific to the current document type:

- **Contents** – prints the Page name and/or Date and time on the drawing
- **Colors** – print the drawing in Original colors, Grayscale, or Black & white.
Figure 261: Print dialog - LibreOffice Draw options

- **Size** – print the drawing using one of the following options:
  - Original size
  - Fit to printable page
  - Distribute on multiple sheets of paper: used if the drawing is too large for the paper size being used.
  - Tile sheet of paper with repeated pages: used to print multiple copies of a drawing on a page.

### Note

The following printing instructions are examples only. Actual method of printing depends on computer operating system, computer setup and the printer being used.

### Printing multiple pages on a single sheet

To print multiple pages of a document on one sheet of paper:

1) Open and use the **Print** dialog (Figure 260 on page 207) using one of the following methods:
   - Go to **File > Print** on the main menu bar.
   - Use the keyboard `Ctrl+P`.
   - Click on the **Print** icon on the **Standard** toolbar.
2) In the Page Layout section, select from the Pages per sheet drop-down list the number of pages to print per sheet. The preview panel on the right shows how the pages will look in the printed document.

3) In the Page Layout section, select from the Order: drop down list how you want the multiple pages printed on the sheet of paper.

4) To distinguish each page on a sheet, select Draw a border around each page.

5) Click OK to print the document and close the dialog.

Selecting pages to print
In addition to printing a full document, you can choose whether to print individual pages, a range of pages, or a highlighted selection within a document.

Individual page
1) Open and use the Print dialog (Figure 260 on page 207) using one of the following methods:
   – Go to File > Print on the main menu bar.
   – Use the keyboard Ctrl+P.
   – Click on the Print icon on the Standard toolbar.
2) In the Ranges and Copies section, select the Pages option.
3) Enter the page number of the page to print.
4) Click OK to print the document and close the dialog.

Range of pages
1) Open and use the Print dialog (Figure 260 on page 207) using one of the following methods:
   – Go to File > Print on the main menu bar.
   – Use the keyboard Ctrl+P.
   – Click on the Print icon on the Standard toolbar.
2) In the Ranges and Copies section, select the Pages option.
3) Enter the page number of the pages to print (for example 1-4 or 1,3,7,11), or any combination of the two (for example: 1-4,7-9,10).
4) Click OK to print the document and close the dialog.

Selection printing
1) Open and use the Print dialog (Figure 260 on page 207) using one of the following methods:
   – Go to File > Print on the main menu bar.
   – Use the keyboard Ctrl+P.
   – Click on the Print icon on the Standard toolbar.
2) In the Ranges and Copies section, select the Even pages, Odd pages or Selection options.
3) Click OK to print the document and close the dialog.
### Brochure or booklet printing

In Writer, Impress, and Draw, you can print a document with two pages on each side of a sheet of paper, arranged so that when the printed pages are folded in half, the pages are in the correct order to form a booklet or brochure.

---

**Tip**

Plan your document so it will look good when printed half size; choose appropriate margins, font sizes, and so on. You may need to experiment.

---

### Single-sided printer

To print a brochure or booklet on a printer only capable of single-sided or simplex printing:

1. Open and use the **Print** dialog (Figure 260 on page 207) using one of the following methods:
   - Go to **File > Print** on the main menu bar.
   - Use the keyboard `Ctrl+P`
   - Click on the **Print** icon on the **Standard** toolbar.
2. Select the printer you want to use if more than one printer is connected to your computer.
3. Click **Properties** to open the properties dialog for the selected printer.
4. Check the printer is set to the same orientation (portrait or landscape) as specified in the page setup for your document. Usually the orientation does not matter, but it does for brochures and booklets.
5. Click **OK** to return to the Print dialog.
6. Select the **Brochure** option in the **Page Layout** section.
7. Select **Even pages** or **Odd pages** in the **Range and Copies** section.
8. Click **OK** to print the even or odd pages.
9. Take the printed pages out of the printer, turn the pages over, and put them back into the printer in the correct orientation to print on the blank side. You may need to experiment a bit to find out what the correct arrangement is for your printer.
10. If you selected **Even pages**, now select **Odd pages** in the **Range and Copies** section. If you selected **Odd pages**, now select **Even pages** in the **Range and Copies** section.
11. Click **OK** to finish printing the document.

### Double-sided printer

To print a brochure or booklet on a printer that is capable of double-sided or duplex printing:

1. Open and use the **Print** dialog (Figure 260 on page 207) using one of the following methods:
   - Go to **File > Print** on the main menu bar.
   - Use the keyboard `Ctrl+P`
   - Click on the **Print** icon on the **Standard** toolbar.
2. Select the printer you want to use if more than one printer is connected to your computer.
3. Click **Properties** to open the properties dialog for the selected printer.
4. Check the printer is set to the same orientation (portrait or landscape) as specified in the page setup for your document. Usually the orientation does not matter, but it does for brochures and booklets.
5) Click **OK** to return to the Print dialog.

6) In the *Paper sides* option, select *Print on both sides (duplex long edge)* printing from the drop down list. Actual options available for duplex printing depend on the printer model and the computer system being used.

7) Select the *Brochure* option in the **Page Layout** section.

8) In the **Range and Copies** section, select the *All pages* option.

9) Click **OK** to print the document.

**Black and white or grayscale printing**

You may wish to print documents in black and white or grayscale on a color printer. However, some color printers may only allow you to print in color regardless of the settings you choose. More details can be found in the information that came with your printer.

**Printer settings**

To change the printer settings to print in black and white or grayscale:

1) Open and use the **Print** dialog (Figure 260 on page 207) using one of the following methods:
   - Go to **File > Print** on the main menu bar.
   - Use the keyboard **Ctrl+P**.
   - Click on the **Print** icon on the **Standard** toolbar.

2) Select the printer you want to use if more than one printer is connected to your computer.

![Image of printer properties dialog]

*Figure 262: Example printer properties dialog*
3) Click **Properties** to open the properties dialog for the printer. The available choices available depend on printer model and computer operating system, but you should easily find options for the Color settings. An example of what you may see is shown in Figure 262.

4) In **Color** or **Additional Features**, select either **Black & White** or **Grayscale** from the available options.

5) Click **OK** to close the properties dialog and return to the **Print** dialog.

6) Click **OK** to print the document and close the dialog.

---

**Tip**

Grayscale is the best option if you have any colored text or graphics in the document. Colors will print in shades of gray giving more detail. When printing color in black and white some of this detail maybe lost.

---

**LibreOffice settings**

To change the LibreOffice settings to print all colored text and graphics as grayscale:

1) Go to **Tools > Options > LibreOffice > Print** on the main menu bar.

2) In **Defaults**, select **Convert colors to grayscale** option.

3) Click **OK** to save the change and close the dialog.

4) Open and use the **Print** dialog (Figure 260 on page 207) using one of the following methods:
   - Go to **File > Print** on the main menu bar.
   - Use the keyboard **Ctrl+P**.
   - Click on the **Print** icon on the **Standard** toolbar.

5) Click **OK** to print the document and close the dialog.

---

**Draw settings**

To change the Draw settings to print all color text and graphics as either black and white or grayscale:

1) Go to **Tools > Options > LibreOffice > Draw > Print** on the main menu bar.

2) In the **Quality** section, select either **Grayscale** or **Black & white** option.

3) Click **OK** to save the change and close the dialog.

4) Open and use the **Print** dialog (Figure 260 on page 207) using one of the following methods:
   - Go to **File > Print** on the main menu bar.
   - Use the keyboard **Ctrl+P**.
   - Click on the **Print** icon on the **Standard** toolbar.

5) Click **OK** to print the document and close the dialog.

---

**Exporting**

LibreOffice can export documents to PDF (Portable Document Format). This industry-standard file format is ideal for sending a file for someone else to view using Adobe Reader or other PDF viewers. The process and dialogs are the same for Writer, Calc, Impress, and Draw, with a few minor differences mentioned in this section.
Directly as PDF

Click on the Export Directly as PDF icon on the Standard toolbar to export the entire document using your default PDF settings. You are asked to enter the file name and location for the PDF file, but you cannot choose page range, image compression, or other options.

Controlling PDF content and quality

For more control over the content and quality of the resulting PDF, you have to use the option Export as PDF. For more information on available options, see the Getting Started Guide.

1) Go to File > Export As > Export as PDF on the main menu bar to open the PDF Options dialog (Figure 263).
2) Use this dialog to select options in the General, Initial View, User Interface, Links, Security and Digital Signatures pages.
3) When you have selected the appropriate options, click Export.
4) In the dialog that opens, enter the location and file name of the PDF to be created.
5) Click Export to save the file in PDF format.

Other formats

LibreOffice uses the term "export" for some file operations involving a change of file type. If you cannot find what you want in File > Save As, look in File > Export. LibreOffice can export files in various formats, which are listed in the drop-down list for file format. See Chapter 6 Editing Pictures in this guide for more information on exporting graphics.

To export a file in another format:

1) Go to File > Export on the main menu bar to open the Export dialog (Figure 264).
2) Navigate to the directory where you want to export your drawing.
3) Specify a file name for the exported document in the **File name** text box.
4) Select the required format from the **File format** drop-down list.
5) Click **Export** to save the file and close the dialog.

**Note**

The content of the exported file will depend on the elements selected on the page. No selection results in the entire image being exported. For most export formats, only the image on the current page will be exported.

**Web pages**

To export a multi-page Draw document to a series of web pages, go to **File > Export** on the main menu bar and select HTML Document as the file type to open the **HTML Export** dialog. Follow the prompts to create the web pages. If required, a navigation aid can be generated to help in moving from page to page. For more information, see Chapter 12 Creating Web Pages in the Getting Started Guide.

**E-mailing documents**

LibreOffice provides several ways to send documents quickly and easily as an e-mail attachment in OpenDocument format (LibreOffice default format), or as a PDF. You can email a document to several recipients. For more information, see Chapter 10 Printing, Exporting, and E-mailing in the Getting Started Guide.

**Note**

Documents can only be sent from the LibreOffice menu if a mail profile has been set up.
OpenDocument format
To email the current document in OpenDocument format:

1) Go to File > Send > Email Document on the main menu bar. LibreOffice opens your default e-mail program with the document attached.

2) In your e-mail program, enter the recipient, subject, and any text you want to add, then send the e-mail.

PDF format
To email the current document as a PDF file:

1) Go to File > Send > E-mail as PDF on the main menu bar. LibreOffice creates a PDF using the default PDF settings and then opens your email program with the PDF file attached.

2) In your e-mail program, enter the recipient, subject, and any text you want to add, then send the e-mail.
Chapter 11
Advanced Draw Techniques
Multi-page documents

Draw documents, like Impress presentation documents, can consist of multiple pages. This allows you to create a drawing that has several sections and stored as one file on a computer.

When pages are inserted into a drawing, they are automatically named as Slide 1, Slide 2, and so on in the Navigator. As you change page order, the pages are automatically renumbered. However, if you want to easily identify each page, then it is recommended to give each page a memorable name.

Page pane

By default the Page Pane (Figure 265) appears docked on the left of the workspace when you open Draw and shows every page in the drawing as a thumbnail. If the Page Pane is not displayed, go to View > Page Pane on the main menu bar.

Note

The Page Pane is called Pages when it is in its docked position on the left of the workspace.

Figure 265: Draw main window showing Page Pane, Workspace and Sidebar
The **Page Pane** is used as follows to help you control pages in your drawing:

- Select a page using one of the following methods and the page will appear in the **Workspace** for editing:
  - Click on a page thumbnail in the **Page Pane**.
  - Press the **F5** key to open the **Navigator** dialog (Figure 266).
  - Go to **View > Navigator** on the main menu bar to open the **Navigator** dialog (Figure 266).
  - Click on the **Navigator** icon on the Sidebar to open the **Navigator** deck (Figure 267).
- Select a thumbnail in the **Page Pane**, then drag and drop the thumbnail to change the page order in the document.
- Click and drag on the separator line between the **Page Pane** and **Workspace** to change the width of the **Page Pane**.
- Click on the middle of the separator line to show or hide the **Page Pane**.
- Press and hold the **Ctrl** key, then double-click in the title bar of the **Page Pane** to undock it and turn it into a floating window.
- Click in the title bar and drag the **Page Pane** to turn it into a floating window.
- Press and hold the **Ctrl** key, then double-click in the title bar of the floating **Page Pane** to dock it back into its default position on the left of the workspace.
• Click in the title bar and drag the Page Pane to return it to its docked position on the left side of the Workspace.

• Right-click in the Page Pane and select New Page from the context menu to insert a page into your drawing.

• Go to Page on the main menu bar to carry out one of the following actions listed in the context menu:
  – Select New Page to insert a new page.
  – Select Duplicate Page to insert a duplicate page. The duplicate page will be a duplicate of the page selected in the Page Pane.
  – Select Insert Page from File and the Insert File dialog opens. Navigate to the folder where the file is located, select then click on Insert.
  – Select Rename Page and the selected page in the Page Pane is renamed.
  – Select Delete Page and the selected page in the Page Pane is deleted.

• Right-click on a page in the Page Pane and select New Page, Delete Page or Rename Page from the context menu.

• Select Page > Move on the main menu bar and select Page to Start, Page Up, Page Down and Page to End from the context menu to move a selected page in the page order.

• Select Page > Navigate on the main menu bar and select To First Page, To Previous Page, To Next Page and To Last Page from the context menu to select a page for editing.

Master pages
A master page is a page that is used as the starting point for other pages in your drawing. It is similar to a page style in Writer and controls the basic formatting of all pages based upon it. A drawing can have more than one master page so that you can assign a different look to pages in your drawing, for example title page, contents page, and drawing pages.

A master page has a defined set of characteristics, including the background color, graphic, or gradient; objects (such as logos, decorative lines, and other graphics) in the background, the formatting of text, blocks of standard text, and insert fields such as page numbering, date, and filename.

Note
LibreOffice uses interchangeable terms for one concept: slide master, master slide, and master page. All refer to a page which is used to create other pages. When searching for information in Draw Help, it may be necessary to use alternative search terms.

Master page view
To add text, objects and fields to a master page, go to View > Master on the main menu bar to open the master page view and open the Master View toolbar (Figure 268). If this toolbar does not open, go to View > Toolbars > Master View on the main menu bar.

To return to normal page mode, click on Close Master View in the Master View toolbar or go to View > Normal on the main menu bar.
Creating master pages

Each drawing you create already has a default master page, but you can create extra master pages to change the look of some of the pages in your multi-page drawing.

1) Go to View > Master on the main menu bar to open the master page view.
2) Click on the New Master icon in the Master View toolbar (Figure 268) to create a new master page. The new master page is automatically selected allowing you to add a new set of items to create a new look for your pages.

Renaming master pages

Each new master page created has the default name of Default 1, Default 2, and so on. It is recommended to rename your new master page with a more meaningful name. The default master page that was created when you first created your drawing can also be renamed.

1) Go to View > Master on the main menu bar to open the master page view.
2) Right-click on a master page in the Page Pane and select Rename Page from the context menu or click on the Rename Master icon on the Master View toolbar (Figure 268). This opens the Rename Master Slide dialog (Figure 269) where you can type a new name.
3) Click OK to save the master page with its new name and close the dialog.

Deleting master pages

The Delete option and Delete icon are only available when there is more than one master page in your drawing. You cannot delete the default master page that was created when you first created your drawing.

1) Go to View > Master on the main menu bar to open the master page view.
2) Select and right-click on a master page in the Page Pane and select Delete Page from the context menu or click on the Delete Master icon in the Master View toolbar (Figure 268).

Inserting fields

You can insert fields on each master page by going to Insert > Field on the main menu bar and selecting a field from the context menu. The following fields can be inserted into a master page.

---

Multi-page documents | 221
• **Date (fixed)** – inserts the current date into the master page as a fixed field. The date is not automatically updated.

• **Date (variable)** – inserts the current date into the master page as a variable field. The date is automatically updated when you open the file.

• **Time (fixed)** – inserts the current time into the master page as a fixed field. The time is not automatically updated.

• **Time (variable)** – inserts the current time into the master page as a variable field. The time is automatically updated when you open the file.

• **Author** – inserts the first and last names listed in the LibreOffice user data into the active page. Go to **Tools > Options > LibreOffice > User Data** on the main menu bar to enter your user data into LibreOffice.

• **Page Number** – inserts the page number into every page of the drawing. To change the number format, go to **Page > Properties** on the main menu bar to open the **Page Setup** dialog (Figure 270). Click on the **Page** tab and select a number format from the drop-down list in **Layout Settings**.

• **Page Title** – inserts the page title. A page title is created in **Normal** view by going to **Page > Rename Page** on the main menu bar and entering a title in **Name** text box in the **Rename Page** dialog (Figure 271) that opens.

• **Page Count** – inserts the total number of pages in your drawing.

• **File name** – inserts the name of the active file. The name only appears after you save the file.

---

![Page Setup dialog](image1)

**Figure 270: Page Setup dialog**

![Rename Page dialog](image2)

**Figure 271: Rename Page dialog**
Editing field format
The format of Date, Time, Author or File name fields is edited as follows on a master slide:

1) Click on the field to select it.
2) Select the field content.
3) Go to Edit > Fields... on the main menu bar to open the Edit Field dialog (Figure 272).
4) Select an option from the drop down lists for Language and Format.
5) Click OK to save your changes and close the dialog.

Assigning master pages
When your drawing has more than one master page, you can assign different master pages to different pages.

1) Go to View > Normal on the main menu bar and select the page in the Page Pane you want to assign a new master page to it.
2) Right-click on the page in the Workspace and select Change Slide Master from the context menu to open the Available Master Slides dialog (Figure 273).
Figure 274: Load Master Slide dialog

1) Select the master page design you want to use in Select a Slide Design.
2) If necessary, select the Exchange background page option to use the selected master page for all pages in the drawing.
3) If necessary, select the Delete unused backgrounds option to delete any master pages shown in Select a Slide Design that have not been assigned to a page.
4) Click OK to assign the selected master page to your page and close the dialog.

Master pages from templates
You can use master pages, which are defined in templates available in LibreOffice. Any master pages loaded into your drawing are adapted to the page size of your drawing. This may cause some images to be stretched when adapted to fit your drawing page size.

1) Go to View > Master on the main menu bar and open Master view in your drawing.
2) Right click on the master page displayed in your drawing and select Change Master Slide from the context menu to open the Available Master Slides dialog (Figure 273).
3) Click on Load... in the Available Master Slides dialog (Figure 273) to open the Load Master Slide dialog (Figure 274).
4) Chose a template category from list displayed in Categories.
5) Choose a template from the list displayed in Templates. A preview of the selected template is displayed in Preview.
6) Click OK to close the Load Master Slide dialog and the Available Master Slides dialog opens displaying the template in Select a Slide Design.
7) Select the master page design you want to use in Select a Slide Design.
8) If necessary, select the Exchange background page option to use the selected master page for all pages in the drawing.
9) If necessary, select the Delete unused backgrounds option to delete any master pages shown in Select a Slide Design that have not been assigned to a page.
10) Click OK to assign the selected master page to your page and close the dialog.
**Templates**

A template is a special type of document that you use as a basis for creating other documents. For example, you can create a template for company drawings so that any new drawing has your company logo and name on the first page and any remaining pages in your drawing only show the company name.

Templates can contain anything that regular documents can contain, such as text, graphics, a set of styles, and user-specific setup information such as measurement units, language, the default printer, and toolbar and menu customization.

- You can create a specific template for any document type (text, spreadsheet, drawing, or presentation).
- If you do not specify a template when you start a new drawing or document, then the drawing or document is based on a set of properties that are hard coded in LibreOffice.
- You can create a default template for your drawings. See “Default template” on page 228 for more information.
- For more information on templates and templates from other sources, see the *Getting Started Guide Chapter 3 Using Styles and Templates*.

**Note**

Draw does not have any predefined templates when it is installed on a computer. However, you can install templates from other sources or create your own templates; these methods are described in the following sections.

**Creating templates**

1) Open the drawing that you want to use for a template, or open and edit a template that you want to use as a basis for your new template.

2) Add any extra content and styles or edit the content and styles in your drawing.

![Save As Template dialog](Figure 275: Save As Template dialog)
3) Save your template using one of the following methods to open the Save As Template dialog (Figure 275):
   – Go to File > Templates > Save As Template on the main menu bar to open the Save As Template.
   – Click on the small triangle to the right of the Save icon on the Standard toolbar and select Save as Template on the context menu to open the Save As Template.

4) Enter a name for your template in the Template Name text box.

5) Select a category where you want to save your template in the Template Category box.

6) If you want the template to be used as the default template in Draw, then select the option Set as default template.

7) Click on Save to save your template and close the dialog.

8) Alternatively, go to File > Save As on the main menu bar to open the Save as dialog (Figure 276).

9) Navigate to the LibreOffice folder where templates are stored. Actual folder depends on your computer system and setup.

10) Enter a filename with the extension .otg in the File name: text box.

11) In the File type: drop down list, select ODF Drawing Template (.otg) as the file type.

12) Click on Save to save your template and close the dialog.

Note

When using the Save as dialog (Figure 276), you must use the LibreOffice templates folder for your template for the Template Manager to recognize and find your template.
Using templates

Quick Start Center
If LibreOffice is not open, create a new drawing using a template is as follows:

1) Start LibreOffice and click on Templates in the Quick Start Center to open a display of available templates for all LibreOffice applications.

2) Alternatively, if LibreOffice is not open, start LibreOffice and click on the small triangle to the right of Templates in the Quick Start Center, then select Draw Templates to open a display of available templates for Draw.

Templates dialog
Instead of using the default settings in LibreOffice to create a new drawing, use a template from the Templates dialog (Figure 277) as follows:

1) If Draw is already open, use one of the following methods to open the Templates dialog (Figure 277):
   – Go to File > New > Templates on the main menu bar.
   – Go to File > Templates > Manage Templates on the main menu bar.
   – Use the keyboard short cut Shift+Ctrl+N.

2) From the Filter drop down lists for applications and category, select the template you want to use for your new drawing.

3) Click on Open to create a new drawing in Draw and close the dialog.

Figure 277: Templates dialog
Open file dialog

If you know which folder contains the template you want to use for a new drawing, proceed as follows:

1) Go to File > Templates > Open Template on the main menu bar to open the Open dialog (Figure 278).
2) Navigate to the folder where the template is located.
3) Select the template you want to use.
4) Click on Open to open the template in Draw and close the dialog.
5) Go to File > Save As on the main menu bar to open the Save as dialog (Figure 276 on page 226).
6) Enter a filename using the extension .odg in the File name: text box.
7) In the File type: drop down list, select ODF Drawing (.odg) as the file type.
8) Click on Save to save your new drawing and close the dialog.

Default template

If you create a new drawing and do not select a template, LibreOffice creates the drawing using a set of properties that are hard coded in LibreOffice. However, you can set any drawing template to be the default template, even a template that you have created, so long as it is located in a category displayed in the Templates dialog (Figure 277 on page 227).

Setting template as default

Set a template as default for use with a new drawing is as follows:

1) Use one of the following methods to open the Templates dialog (Figure 277 on page 227):
– Go to **File > New > Templates** on the main menu bar.
– Go to **File > Templates > Manage Templates** on the main menu bar.
– Use the keyboard short cut `Shift+Ctrl+N`.

2) In the *Filter* drop down lists, select *Drawings* as the application and the template category where the template you want to use is located.

3) Select the template.

4) Right-click on the template and select *Set as default* from the context menu. There is no confirmation that the selected template has become the default template for new drawings. The default template is indicated by check mark at the top left corner of the template icon.

5) Click on **Cancel** to close the dialog. The next time you create a new drawing, it will be created using the default template.

---

### Note

If you have created a new drawing that you want to use as the default template, then you must save the drawing as a template first before you can use it as the default template. See “Creating templates” on page 225 for more information.

---

### Resetting default

To reset Draw back to the LibreOffice default properties for new drawings:

1) Use one of the following methods to open the **Templates** dialog (Figure 277 on page 227):
   – Go to **File > New > Templates** on the main menu bar.
   – Go to **File > Templates > Manage Templates** on the main menu bar.
   – Use the keyboard short cut `Shift+Ctrl+N`.

2) Right-click on the default template. The default template is indicated by check mark at the top left corner of the template icon.

3) Select **Reset Default** from the context menu. There is no confirmation that Draw has been reset to using LibreOffice default properties when a new drawing is created.

4) Click on **Cancel** to close the dialog. The next time you create a new drawing, it will be created using the LibreOffice default properties.

---

### Editing templates

You can edit template styles and content, and then, if you wish, reapply the template styles to drawings that were created from that template.

---

### Note

You can only reapply styles. You cannot reapply content.

---

### Editing

1) Use one of the following methods to open the **Templates** dialog (Figure 277 on page 227):
   – Go to **File > New > Templates** on the main menu bar.
   – Go to **File > Templates > Template Manager** on the main menu bar.
   – Use the keyboard short cut `Shift+Ctrl+N`.

2) Locate the template you want to edit and select it.
3) Right click on the selected template and select **Edit** from the context menu. The template opens in Draw.

4) Edit the template just as you would any other drawing.

5) Go to **File > Save** on the main menu bar or use the keyboard shortcut **Ctrl+S** to save the template.

6) To save the edited template as a new template, see “Creating templates” on page 225 for more information.

### Updating documents from modified template

The next time that you open a drawing that was created from the changed template, you will be asked to confirm whether you want to update the styles in your drawing to the formatting used in the modified template (Figure 279).

- Click **Update Styles** to update any styles in the document that have been changed in the template and close the confirmation dialog.
- Click **Keep Old Styles** if you do not want to update any styles in the document that have been changed in the template and close the confirmation dialog.

#### Note

If you select **Keep Old Styles**, then the confirmation dialog will not appear again the next time you open the document after changing the template it is based on. You will not get another chance to update the styles from the template.

### Organizing templates

LibreOffice can only use templates that are in LibreOffice template folders (categories). You can create new LibreOffice template folders (categories) and use them to organize your templates. For example, separate categories for different projects or clients. You can also import and export templates.

#### Tip

The location of LibreOffice template folders varies with your computer operating system. To learn where the template folders are stored on your computer, go to **Tools > Options > LibreOffice > Paths** on the main menu bar.
Creating template folders

1) Use one of the following methods to open the **Templates** dialog (Figure 277 on page 227):
   - Go to **File > New > Templates** on the main menu bar.
   - Go to **File > Templates > Manage Templates** on the main menu bar.
   - Use the keyboard short cut `Shift+Ctrl+N`.

2) In the **Filter** drop down lists, select *Drawing* as the application.

3) Click on the **Settings** icon and select **New Category** from the context menu.

4) Enter a name for the new category in the dialog that opens (Figure 280).

5) Click **OK** to save the new category as a new category (folder) in LibreOffice and close the dialog.

**Note**

You can not create a new sub-categories inside existing LibreOffice categories. Any template category created is added to the template category list in the **Templates** dialog.

Renaming template folders

It is recommended to ONLY rename template folders (categories) that you have created. Renaming LibreOffice template folders could cause problems with the other LibreOffice modules.

1) Use one of the following methods to open the **Templates** dialog (Figure 277 on page 227):
   - Go to **File > New > Templates** on the main menu bar.
   - Go to **File > Templates > Manage Templates** on the main menu bar.
   - Use the keyboard short cut `Shift+Ctrl+N`.

2) In the **Filter** drop down lists, select *Drawing* as the application and the category you want to rename.

3) Click on the **Settings** icon and select **Rename Category** from the context menu.

4) Enter a new name for the category in the name dialog that opens (Figure 280).

5) Click **OK** to save the renamed category as a category (folder) in LibreOffice and close the dialog.
Deleting template folders
You cannot delete the template folders supplied with LibreOffice or installed using the Extension Manager. You can only delete folders that you have created.

1) Use one of the following methods to open the Templates dialog (Figure 277 on page 227):
   - Go to File > New > Templates on the main menu bar.
   - Go to File > Templates > Manage Templates on the main menu bar.
   - Use the keyboard short cut \textit{Shift+Ctrl+N}.
2) In the Filter drop down lists, select \textit{Drawing} as the application and the category you want to delete.
3) Click on the Settings icon and select \textbf{Delete Category} from the context menu.
4) Select the category in the \textbf{Delete Category} dialog that opens (Figure 281).
5) Click \textbf{OK} to delete the category and close the dialog.
6) Click \textbf{Yes} to confirm the deletion of the folder.

Moving templates
To move a template from one template folder to another template folder:

1) Use one of the following methods to open the Templates dialog (Figure 277 on page 227):
   - Go to File > New > Templates on the main menu bar.
   - Go to File > Templates > Manage Templates on the main menu bar.
   - Use the keyboard short cut \textit{Shift+Ctrl+N}.
2) In the Filter drop down lists, select \textit{Drawing} as the application and the category where the template is located.
3) Click on the Move icon and the \textbf{Select Category} dialog (Figure 282) opens.
4) Select a category from \textbf{Select from Existing Category} or enter a name for a new category in \textbf{Create a New Category}.
5) Click \textbf{OK} to move the template and close the dialog.
Deleting templates
You cannot delete the templates supplied with LibreOffice or installed using the Extension Manager from inside LibreOffice. You can only delete templates that you have created or imported. Although system administrators can remove or add templates manually in the LibreOffice installation folder.

1) Use one of the following methods to open the Templates dialog (Figure 277 on page 227):
   – Go to File > New > Templates on the main menu bar.
   – Go to File > Templates > Manage Templates on the main menu bar.
   – Use the keyboard short cut \text{Shift+Ctrl+N}.
2) In the Filter drop down lists, select Drawing as the application and the category where the template is located.
3) Right click on the template you want to delete and select Delete from the context menu.
4) Click Yes to confirm the deletion of the template and close the dialog.
5) Click Cancel to close the Templates dialog.

Importing templates
If the template that you want to use is in a different location, you must import it into a LibreOffice template folder.

1) Use one of the following methods to open the Templates dialog (Figure 277 on page 227):
   – Go to File > New > Templates on the main menu bar.
   – Go to File > Templates > Manage Templates on the main menu bar.
   – Use the keyboard short cut \text{Shift+Ctrl+N}.
2) Click the Import icon and the Select Category dialog (Figure 282) opens.
3) Select a category from Select from Existing Category or enter a name for a new category in Create a New Category for the imported template.
4) Click OK and a standard file browser dialog opens.
5) Navigate to the folder containing the template you want to import, select it and click **Open**. The file browser closes and the template appears in the selected category.

6) Alternatively, click on the **Browse online templates** icon to open your browser at the LibreOffice template page and download the template you want to a folder on your computer.

7) Repeat Steps 1 thru 5 above to import the downloaded template into LibreOffice.

---

**Note**

The **Extension Manager** provides an easy way to import and install template collections that have been packaged as extensions. For more information about the **Extension Manager**, see the **Getting Started Guide**.

---

### Exporting templates

1) Use one of the following methods to open the **Templates** dialog (Figure 277 on page 227):
   - Go to **File > New > Templates** on the main menu bar.
   - Go to **File > Templates > Manage Templates** on the main menu bar.
   - Use the keyboard short cut **Shift+Ctrl+N**.

2) In the **Filter** drop down lists, select **Drawing** as the application and the **Category** where the template is located.

3) Select the template you want to export and click the **Export** icon to open a file browser window.

4) Navigate to the folder where you want to export the template to, select it and click **Select**. The file browser closes and the template appears in the selected folder.

5) Click **OK** to close the information dialog.

---

### Multiple layers

Layers in LibreOffice Draw allow you to assemble elements on a drawing page that are related. Think of layers as individual workspaces that you can hide from view, hide from printing, or lock.

Layers do not determine the stacking order of objects on your drawing page, except for the **Controls** layer which is always in front of all other layers. The stacking order of objects on your drawing page is determined by the sequence in which you add the objects. You can rearrange the stacking order by going to **Shape > Arrange** on the main menu bar.

Layers in a drawing are indicated by tabs located above the **Status** bar. Click on a tab to select a layer. Figure 283 shows the **Layout** layer has been selected.

---

**Note**

You can lock a layer to protect its contents, or hide a layer and its contents from view or from printing. When you add a new layer, the layer is added to all of the pages in your drawing. However, when you add an object to a layer, it is only added to the current drawing page.
Note

If you want the object to appear on all of the pages (for example, a company logo), add the object to the master page by going to View > Master on the main menu bar. To return to your drawing, go to View > Normal on the main menu bar.

Default layers

In Normal view, LibreOffice Draw provides three default layers that are visible to the user and these default layers cannot be deleted or renamed.

- **Layout** – is the default workspace where objects are normally placed.
- **Controls** – used for form controls that have been assigned an action. Objects on this layer are always in front of objects on other layers. Normally, form controls are not printed and the Printable setting has to be set deselected.
- **Dimension Lines** – is where the dimension lines are drawn. By switching the layer to show or hide, you can easily switch dimension lines on and off.

In Master view, the layer **Background objects** is where you can place objects that you want to appear on every page in your drawing, for example date, page number, drawing title and so on.

Inserting layers

1) Right-click the layer tab area at the bottom left of the Workspace area and select Insert Layer from the context menu, or go to Insert > Layer on the main menu bar to open the Insert Layer dialog (Figure 284) or click right from existing layers on the tab area.

2) Type a meaningful name for the layer in the Name and Title text boxes. If necessary, type a description for the layer in the Description text box.

3) Select Visible if you want the layer to be visible in your drawing. When Visible is not selected, the layer is hidden and its name in the layer tab changes color to blue.

![Insert Layer dialog](image)

*Figure 284: Insert Layer dialog*
4) Select **Printable** if you want the layer to print when you print your drawing. Not printing is useful if you want use a draft layer for guides or annotations that you use in making the drawing, but do not want to appear in the final output. The name of a layer is underlined in the layer tab bar when the **Printable** option is turned off.

5) Select **Locked** to prevent any objects on this layer from deletion, editing, or moving. No additional objects can be added to a locked layer. Locking a layer is useful, for example, when a base plan is to be protected while adding a new layer with other details. The name of a locked layer is written in italic in the layer tab bar.

6) Click **OK** to close the dialog and the new layer automatically becomes active.

**Modifying layers**

1) Right-click on the name tab of the layer and select **Modify Layer** from the context menu or double-click on the layer tab or use **Format > Layer...** on the main menu bar to open the **Modify Layer** dialog. This dialog is similar to the **Insert Layer** dialog in Figure 284.

2) Make your changes to the layer, then click **OK** to save the changes and close the dialog.

**Working with layers**

**Selecting a layer**

To select a layer, click on the name tab for the layer at the bottom of the drawing workspace. When a layer is selected, objects added to your drawing will only be added to that layer. Form controls are automatically added to the **Controls** layer and dimension lines added to the **Dimension Lines** layer.

If there are several layers in your drawing, a layer tab may not not be visible on the layer tab bar. Use the navigation icons on the left of the layer tab bar to navigate to the layer you want to use or modify.

**Hiding layers**

1) Right-click on the name tab of the layer and select **Modify Layer** from the context menu or double-click on the name tab to open the **Modify Layer** dialog.

2) Clear the **Visible** check box and click **OK**. The text on the layer name tab changes color to blue. Any objects placed on a hidden layer will no longer be visible on the other layers in your drawing.

3) Alternatively, hold down the **Shift** key and click on the name tab to hide the layer.

**Showing hidden layers**

1) Right-click on the name tab of the layer and select **Modify Layer** from the context menu or double-click on the name tab to open the **Modify Layer** dialog.

2) Check the **Visible** check box and click **OK**. The text for the layer name tab changes to the default color for text for your computer setup. Any objects placed on a hidden layer will now become visible on the other layers in your drawing.

3) Alternatively, hold down the **Shift** key and click on the name tab to make the layer visible.

**Locking layers**

1) Right-click on the name tab of the layer and select **Modify Layer** from the context menu or double-click on the name tab to open the **Modify Layer** dialog.

2) Check the **Locked** check box and click **OK**. The text on the layer name tab is underlined. Locking a layer prevents any modification of the layer.
3) Alternatively, hold down the \texttt{Ctrl} key and click on the name tab to lock the layer.

**Unlocking layers**

1) Right-click on the name tab of the layer and select \textit{Modify Layer} from the context menu or double-click on the name tab to open the \textit{Modify Layer} dialog.
2) Uncheck the \textbf{Locked} check box and click \textit{OK} to allow modification of the layer. The text on the layer name tab is no longer underlined.
3) Alternatively, hold down the \texttt{Ctrl} key and click on the name tab to lock the layer.

**Renaming layers**

1) Right-click on the name tab of the layer and select \textit{Rename Layer} from the context menu.
2) Type a new name for the layer and click outside the tab area to save the change.
3) Alternatively, follow the procedure in "Modifying layers" on page 236 to rename the layer.
4) Alternatively, hold down the \texttt{Alt} key and click on the name tab. The name becomes editable and is already selected. Enter the new name and press \textit{Enter} key.

**Deleting layers**

1) Right-click on the name tab of the layer and select \textit{Delete Layer} from the context menu.
2) Confirm the deletion and the layer and all its objects are deleted.

**Moving objects layer to layer**

If an object, or a group of objects, is selected, the layer where the object has been placed is shown at the left end of the \textbf{Status Bar}. Move an object, or a group of objects, from one layer to another layer using one of the following methods:

- Click and hold on the object until the cursor changes shape. While holding down mouse button, drag the cursor to the tab of the destination layer and release the mouse button. The position of the object will not change, but its new layer is displayed in the \textbf{Status Bar}.
- Go to \textit{Edit > Cut} on the main menu bar or right click on the object and select \textit{Cut} from the context menu. Click on the tab of the destination layer to make it the active layer. Then go to \textit{Edit > Paste} on the main menu bar or right click on the Workspace and select \textit{Paste} from the context menu. The position of the object will not change, but its new layer is displayed in the \textbf{Status Bar}.

**Note**

You can only rename or delete layers that you have added to a drawing. The default layers \textit{Layout}, \textit{Controls}, \textit{Dimension Lines} and \textit{Background objects}, cannot be renamed or deleted.

**Dimensioning**

Draw allows you to dimension objects and display these dimensions to make your drawing look more like an engineering drawing. When you create dimensions, they are automatically placed on the \textbf{Dimension Lines} layer (see "Default layers" on page 235 for more information).
Configuring dimensioning

Two ways are available to access the options to configure dimensioning. Both methods use a similar dialog where you can change the length, measurement, and guide properties of a dimension line.

**Drawing object styles**

1) Use one of the following methods to access your drawing styles to open the Graphics Styles dialog (Figure 285):
   - Go to **Format > Styles > Edit Styles** on the main menu bar.
   - Click on the **Styles and Formatting** icon on the Line and Filling toolbar to open the Styles deck on the Sidebar, then right click on a style and select **Modify** from the context menu.
   - Press the **F11** key on your keyboard to open the Styles deck on the Sidebar, then right click on a style and select **Modify** from the context menu.
   - Click on the **Styles** icon on the Sidebar to open Styles deck, then right click on a style and select **Modify** from the context menu.

2) Click on the Dimensioning tab to open the Dimensioning page in the dialog.

3) Make the changes you want for dimensioning using the various options in Line and Legend sections on the Dimensioning page.

4) Click **OK** to save your changes and close the dialog.

5) To reset the dimensioning options to the default properties of the template, open the Graphics Style dialog as given in Steps 1 and 2 above, then click on **Standard**.

![Figure 285: Graphic Styles dialog - Dimensioning page](image)

238 | Dimensioning
**Dimension Line dialog**

1) Draw a dimension line. See “Dimensioning objects” on page 241 for more information.

2) Right-click on the dimension line and select **Dimensions** from the context menu to open the **Dimension Line** dialog (Figure 286).

3) Make the changes you want to use for dimensioning using the various options in this dialog. These options are also available on the **Dimensions** page in the **Graphics Styles** dialog (Figure 285):

4) Click **OK** to save your changes and close the dialog.

**Dimensioning options**

With reference to the **Dimensions** page in the **Graphics Style** dialog (Figure 285) and the **Dimension Line** dialog (Figure 286), the dimensioning options are as follows. The preview in the dialog will change as you change the following options showing how the dimension line will appear in your drawing. An example dimension line is shown in Figure 286.

- **Line** – sets the distances between the dimension line and guides with respect to each other, dimension baseline and object. The baseline is not visible in a drawing, but is indicated by baseline points on each of the guides.
  - **Line distance** – specifies the distance between the dimension line and the object or the baseline. A minimum of -10mm to a maximum of 10mm can be entered in the text box. Lower the value, the closer the dimension line is to the object or baseline.
  - **Guide overhang** – is the distance the guide either extends above the dimension line or is below the dimension line. A minimum of -10mm to a maximum of 10mm can be entered in the text box. Using a positive value and the guide overhang extends above the dimension line. Using a negative value and the guide overhang is below the baseline.
– **Guide distance** – specifies the length of the right and left guides below the dimension line toward the object. A minimum of -10mm to a maximum of 10mm can be entered in the text box. Positive values extend the guides above the baseline and further away from the object. Negative values extend the guides below the object and closer to the object.

– **Left guide** – specifies the length of the left guide starting at the dimension line. A minimum of -10mm to a maximum of 10mm can be entered in the text box. Positive values extend the guide below the baseline toward the object. Negative values move the guide away from the object.

– **Right guide** – specifies the length of the right guide starting at the dimension line. A minimum of -10mm to a maximum of 10mm can be entered in the text box. Positive values extend the guide below the baseline toward the object. Negative values move the guide away from the object.

– **Measure below object** – reverses the positions and lengths of the dimension line and guides set in **Line** options.

– **Decimal places** – specifies the number of decimal places used for the display of line properties.

• **Legend** – sets the properties of the dimension text.

  – **Text position** – determines the position of the dimension text with respect to the dimension line and the guides. The AutoVertical and AutoHorizontal checkboxes must be cleared before you can assign a text position.

  – **AutoVertical** – determines the optimal vertical position for the dimension text.

  – **AutoHorizontal** – determines the optimal horizontal position for the dimension text.

  – **Parallel to line** – displays, when selected, the text parallel to the dimension line or, when deselected, at 90 degrees to the dimension line.

  – **Show measurement units** – shows or hides the dimension measurement units. You can also select a measurement unit you want to display from the drop down list.

---

**Note**

The dimensioning options are always linked and stored with the current work page. All the changes that you make apply only to this document. New documents are started with the standard properties of Draw. If you want to use the dimensioning options for future drawings, save your drawing as a template.

---

*Figure 287: Example dimension line*
Guide selection handles

The guide selection handles at the top and bottom of the guides are used to extend the guides more than the limits of -10mm to 10mm in the Dimensions page in the Graphics Style dialog (Figure 285) and the Dimension Line dialog (Figure 286).

With reference to the dimension example in Figure 287, the guide selection handles are used as follows:

- **Top guide selection handles** – select either selection handle and drag the handle to increase or decrease the guide overhang of both guides.
- **Lower left guide selection handle** – select the left guide selection and drag the handle to increase or decrease of the left guide distance.
- **Lower right guide selection handle** – select the right guide selection and drag the handle to increase or decrease of the right guide distance.

**Tip**

When dimensioning objects, it is recommended to use the zoom function, guide lines and snap functions so that you can accurately place dimension lines on an object. See Chapter 3 Working with Objects and Object Points for more information.

Dimensioning objects

1) Click on the small triangle next to the Lines and Arrows icon on the Drawing toolbar to open the Lines and Arrows pop-up toolbar (Figure 288).

**Note**

This icon changes depending on the last tool used for Lines and Arrows. Also, this toolbar can become a floating toolbar by clicking at the top of the pop-up toolbar and dragging it into the Workspace.

2) Click on the Dimension Line icon and the cursor normally changes to a cross. This depends on your computer setup.

Figure 289: Dimensioning objects
3) Position the cursor at one corner of the object, then click and drag the cursor to the other corner of the object to draw the dimension line. To restrict drawing the dimension line in the horizontal or vertical direction, press and hold the Shift key while dragging the cursor.

4) Release the mouse button when you reach the other corner of the object and the dimension line is drawn with the dimension automatically added (as shown in Figure 289). The dimension line is also placed automatically on the Dimension Lines layer. See “Default layers” on page 235 for more information.

5) To edit the text of the dimension, double-click on an unselected dimension line to enter text edit mode and make your changes. Click outside the dimension line to save the changes.

6) To configure the dimension line. See “Configuring dimensioning” on page 238 for more information.

---

**Note**

After editing the dimension text, entering your own text and then deleting your text, you have to save your drawing and reopen it to enable automatic measurements for dimensioning.

---

**Note**

If drawing to scale, the dimension configuration values in the Dimensions page in the Graphics Style dialog and the Dimension Line dialog will also be to scale. For example, a value of 10mm in the dialog will result in a dimension value of 300mm if the scale has been set to 1:30.

---

**Drawing to scale**

In Draw a drawing is made on a predefined drawing area. This is normally Letter or A4 page size depending on your locale, computer setup, and the default printer connected to your computer. However, depending on the actual size of the drawn objects, it is often convenient to reduce or enlarge the drawing by scaling (for example 1:10 or 2:1).

You can specify a scale value by going to Tools > Options > LibreOffice Draw > General (Figure 290) and selecting a value from the Drawing scale drop-down list. The default setting for this option is 1:1. When you make a change to the drawing scale, it is reflected in the rulers at the top and left side of your drawing.

Any change in the drawing scale has no effect on the basic drawing operations. Draw automatically calculates the necessary values (for example, dimension lines). The spacing of the grid points is independent of drawing scale as the grid is an optical drawing aid and not a drawing element.

An increase in scale (for example 1:4) allows you to draw objects that would not fit into the paper size for your drawing. A decrease in drawing scale (for example 4:1) allows you to draw small objects accurately at an increased size to make them easier to understand. An example of drawing to scale is shown in Figure 291. All three rectangles are the same size.

- The left rectangle was drawn at the default 1:1 scale and dimensioned.
- The drawing scale was then changed to 1:4 and the dimensions were automatically increased by Draw to reflect the decrease in scale for the center rectangle.
- The drawing scale was then changed to 4:1 and the dimensions were automatically decreased by Draw to reflect the increase in scale for the right rectangle.
Views

You can use several views of the same document. They can use different settings for visible, printable and locked for layers, different zoom factors, different origins, or even use master page and normal page at the same time. The document format can only contain one view. So make sure that the view you want to save is active when saving.

To get a new view, go to Window > New Window on the main menu bar to open a new window. Arrange the windows according to your operating system. The windows act on the same document. A change to the document in one window is immediately reflected in the other window.

Gallery

Draw includes several images in the Gallery. These images are grouped into themes (for example Arrows, Bullets, Computers, Diagrams, Environment and so on). The Gallery deck on the Sidebar (Figure 292) lists the available themes. Click on a theme and its images are displayed below the theme list.
You can create themes and add your images into the new theme to the **Gallery**. For more information on creating themes and adding images, see “Creating themes and adding images” on page 245.

You can also delete images and themes from the **Gallery**. For more information on deleting themes and images, see “Deleting gallery themes and images” on page 246.

**Note**

It is recommended NOT to delete themes or images that are part of the default installation of LibreOffice. Deletion could cause problems in other LibreOffice modules where the default **Gallery** themes and images have been used.

**Using the Gallery**

1) Use one of the following methods to open the **Gallery** deck on the Sidebar (Figure 292):
   - Click on the **Gallery** icon on the Sidebar.
   - Go to **Insert > Media > Gallery** on the main menu bar.
   - Click on the **Open Clip Art and Media Gallery** on the **Standard** toolbar.

2) Select a theme at the top of the **Gallery** deck.

3) Use one of the following methods to place an image into your drawing:
   - Click on an image in the **Gallery** deck and drag the image into your drawing.
   - Right-click on an image and select **Insert** from the context menu and the image is placed at the centre of your drawing.
   - Right-click on an image and select **Copy** from the context menu and then paste the image into your drawing. The image is placed at the center of your drawing.

4) Edit the gallery image to your preferences. For more information on editing pictures, see **Chapter 6 Editing Pictures**.
Creating themes and adding images

1) Use one of the following methods to open the Gallery deck on the Sidebar (Figure 292):
   – Click on the Gallery icon on the Sidebar.
   – Go to Insert > Media > Gallery on the main menu bar.
2) Click on New Theme at the top of the Gallery deck to open the Properties of New Theme dialog (Figure 293).
3) Type a memorable name for your theme in the text box.
4) Click OK to save the new theme and close the dialog.
5) Right-click on the new theme name that you have created and select Properties from the context menu to open the Properties of New Theme dialog (Figure 293).
6) Click on the Files tab to open the Files page of the Properties of New Theme dialog (Figure 294).
7) Click on Find Files to open the Select Path dialog (Figure 295).
8) Browse to the folder that contains the images you want to use.

Figure 293: Properties of New Theme dialog – General page

Figure 294: Properties of New Theme dialog - Files page
Click Select to select the files contained in the folder and the Select Path dialog closes. The list of files contained in the folder now appear in the Properties of New Theme dialog.

10) Select the files you want to use in for your new theme and click Add. The added files will disappear from the file list and the images will appear in the Gallery.

11) If you want to add all the files in the list, click Add All. All the files will disappear from the list and the images will appear in the Gallery.

12) Click OK when finished and close the Properties of New Theme dialog.

Deleting gallery themes and images

1) Right-click on a theme or image in the Gallery.
2) Select Delete from the context menu.
3) A confirmation message appears. Click Yes and the image or theme.

Note

The image is a linked file and only the link is deleted from the Gallery. The original image file is not deleted.

Updating the Gallery

All the images in the Gallery are linked files. Occasionally, it is beneficial to update a theme you have created to make sure that all the files are still there. To do so, right-click on a theme you have created and you have added at least one file and then select Update from the context menu.

Renaming themes

To rename a theme you have created, right-click on the theme name and select Rename from the context menu.
Note

It is recommended NOT to rename themes or images that are part of the default installation of LibreOffice. Renaming could cause problems in other LibreOffice modules where the default Gallery themes and images have been used.

Using drawing objects with Gallery

As well as adding images to the Gallery, you can also drawing objects as follows:

1) Select the theme where you want to add a drawing object or create a new theme.
2) Click on a drawing object you have created and drag the object to the selected theme and release mouse button. These objects are stored in a folder in your user directory.

After being added to the Gallery, the drawing object loses its connection to graphic styles and all properties are set as direct formatting. The drawing object can be in new Draw documents and also used in the other LibreOffice modules in the same way as any other object from the Gallery.

Adding complete themes

There are two ways to add a complete theme to the Gallery:

- If there is a folder with themes, you can add a path to that folder in Tools > Options > LibreOffice > Paths > Gallery. Click on Edit… and select the folder that contains the themes. Disadvantage of this method is you might get themes already installed. You cannot delete a single theme from that folder in your Gallery, but you have to remove the total set of themes by removing the path to the folder.
- Gallery themes can be installed as extensions. Search for themes at https://extensions.libreoffice.org/extensions.

Colors

Draw (like all LibreOffice components) uses color palettes for the representation of colors. You can create colors and color palettes to suit your own needs by modifying colors in a palette, adding other colors, or creating custom color palettes.

Note

LibreOffice uses the RGB (Red, Green, Blue) color model internally for printing in all of its software modules. The CMYK (Cyan, Magenta, Yellow, Key (Black)) controls are provided only to ease the input of color values using CMYK notation.

- RGB model – stands for Red, Green, Blue. It is based on the additive color model of light waves and is designed for electronic displays and computers. This means, the more color you add, the closer you get towards white. RGB is created using scales from 0 to 255. So, black would be R=0, G=0, and B=0. White would be R=255, G=255, and B=255.
- CMYK model – stands for Cyan, Magenta, Yellow, Key (Black). It is a subtractive color model where you have to subtract colors to get to white. It is mainly used in printing which is why the ink cartridges for your printer are labeled CMYK. CMYK works on a scale of 0 to 100. If C=100, M=100, Y=100, and K=100, you end up with a black color. But, if all four colors equal 0, you end up with true white.
• **HSB values** – stands for hue, saturation, brightness. HSB values are an alternative representation of the RGB color model and was designed to be more closely align with the way human vision perceives color-making attributes. You can use HSB values to fine tune any custom colors that you create.

**Tip**


**Changing colors**

Changing colors in objects you use color palettes to select colors. These color palettes are installed with LibreOffice and are used in all the LibreOffice modules. Using these color palettes is similar across all types of objects, but accessing the color palettes does vary according to the type of object selected.

**Color Bar**

Although LibreOffice includes tools that allow you to precisely specify a color, LibreOffice also includes a **Color Bar** that allows you to quickly change the color of an object in your drawing. By default, the colors available in the **Color Bar** are from the **Standard** palette.

**Note**

If you have changed the color palette in the **Area** or **Line** dialogs, the color palette used by the **Color Bar** also changes to the selected color palette.

1) Select the object in your drawing where you want to quickly change the color.
2) Go to **View > Color Bar** on the main menu bar to open the **Color Bar** (Figure 296).
3) Left-click on a color to change the area fill color or right-click on a color to change the line color of a selected object.
4) To remove a color from an object with a fill color, click on the X box in the bottom left corner of the **Color Bar**.
5) To close the **Color Bar**, go to **View > Color Bar** on the main menu bar and deselect **Color Bar**.

**Area fill colors**

Use the **Area** dialog as follows:

1) Select an object that has an area fill color, for example a colored square or triangle.
2) Open the **Area** dialog (Figure 297) using one of the following methods:
   - Go to **Format > Area** on the main menu bar.
   - Right click on the object and select **Area** from the context menu.
   - Click on the **Area** icon on the **Line and Filling** toolbar.
3) Click on the **Color** button to open the **Color** page.
4) Select the color palette to use from the drop down list in **Colors > Palette**.
5) Click on a color from the ones displayed, or select a color that has been previously used from *Recent Colors*.

6) Click **OK** to save your changes and close the dialog. The selected fill color will appear in the selected object.

Use the **Area** section in the **Properties** deck on the Sidebar (Figure 298) as follows:

1) Select an object that has an area fill color, for example a colored square or triangle.
2) Make sure the **Area** section in the **Properties** deck on the Sidebar is expanded.
3) In the **Fill** drop down list, make sure **Color** is selected.
4) Click on the small triangle to the right of **Select the color to apply** to open the **Fill Color** palette.
5) Select the color palette to use from the drop down list in the **Fill Color** palette.
6) Click on a color from the colors displayed, or select a color that has been previously used from *Recent Colors*.
7) The **Fill Color** palette will close and the selected fill color will be applied to the object.

Use the **Fill Color** palette available on the **Line and Filling** or **Drawing** toolbar as follows:

1) Select an object that has an area fill color, for example a colored square or triangle.
2) Click on the small triangle to the right of **Fill Color** on the **Line and Filling** or **Draw** toolbar to open the **Fill Color** palette.
3) Select the color palette to use from the drop down list in the Fill Color palette.
4) Click on a color from the colors displayed, or select a color that has been previously used from Recent Colors.
5) The Fill Color palette will close and the selected fill color will be applied to the object.

Figure 298: Properties deck on Sidebar - Area section

Figure 299: Line dialog - Color palette
**Lines or border colors**

The Line Color palettes for lines and borders are identical in appearance and use as the Fill Color palettes used for area fill colors.

Use the Line dialog (Figure 299) as follows:

1) Select a line or object in your drawing.
2) Open the Line dialog using one of the following methods:
   - Go to Format > Line on the main menu bar.
   - Right click on the line or object and select Line from the context menu.
   - Click the small triangle to the right of the Color drop down list.
3) Select the color palette to use from the drop down list in the Line Color palette.
4) Click on a color from the ones displayed, or select a color that has been previously used from Recent Colors.
5) The Line Color palette will close and the selected color will be applied to the line or border.
6) Click OK to save your changes and close the dialog.

Use the Line section in the Properties deck on the Sidebar (Figure 300) as follows:

1) Select a line or object in your drawing.
2) Make sure the Line section in the Properties deck on the Sidebar is expanded.
3) Click on the small triangle to the right of Select the color of the line to open the Line Color palette.
4) Alternatively, click on the small triangle to the right of the **Line Color** icon on the **Line and Filling** toolbar to open the **Line Color** palette.

5) Select the color palette to use from the drop down list in the **Line Color** palette.

6) Click on a color from the ones displayed, or select a color that has been previously used from **Recent Colors**.

7) The **Line Color** palette will close and the selected color will be applied to the line or border.

Use the **Line Color** palette available on the **Line and Filling** or **Drawing** toolbar as follows:

1) Select a line or object that in your drawing.

2) Click on the small triangle to the right of **Line Color** icon on the **Line and Filling** or **Drawing** toolbar to open the **Line Color** palette.

3) Select the color palette to use from the drop down list in the **Line Color** palette.

4) Click on a color from the colors displayed, or select a color that has been previously used from **Recent Colors**.

5) The **Line Color** palette will close and the selected color will be applied to the line or border.

**Object text**

The **Font Color** palette for text is accessed using the **Font Color** icon in the **Character** section in the **Properties** deck on the Sidebar (Figure 301), or the **Font Color** icon available on the **Text Formatting** toolbar.

The **Font Color** palette for text is identical in appearance and use as the **Fill Color** and **Line Color** palettes used for area fill, line and border colors.

![Figure 301: Properties deck on Sidebar - Character section](image)

---

252 | *Colors*
The **Text Formatting** toolbar automatically replaces the **Line and Filling** toolbar when text is selected in your drawing. If the **Text Formatting** toolbar does not appear, go to **View > Toolbars** on the main menu bar and select **Text Formatting**.

1) Select text in a text box or text contained in an object in your drawing.
2) Click on the small triangle to the right of the **Font Color** icon in the **Character** section in the **Properties** deck on the Sidebar (Figure 301), or the **Font Color** icon available on the **Text Formatting** toolbar to open the **Font Color** palette.
3) Select the color palette to use from the drop down list in the **Font Color** palette.
4) Click on a color from the colors displayed, or select a color that has been previously used from **Recent Colors**.
5) The **Font Color** palette will close and the selected color will be applied to the text.

**Creating colors**

Any custom colors created are automatically placed in the **Custom** palette. The **Custom** palette is available across all modules of LibreOffice.

LibreOffice uses only the RGB color model for printing in color. The RGB values of the selected color are displayed below the preview boxes.

To create a custom color using the **Area** dialog (Figure 297 on page 249) is as follows:

1) Go to **Format > Area** on the main bar to open the **Area** dialog.
2) Click on the **Color** button to open the **Color** page.

![Figure 302: Pick a Color dialog](image)
3) Select a predefined palette from the drop down list to open a color palette that contains a color similar to the one you want to create.

4) Select a color in the color palette that is similar to the one you want to create. The color appears in the New preview box.

5) If you know the RGB values of your custom color, enter these values in the RGB boxes under the New preview box. The color in the New preview box will change as you change the values.

6) If you do not know the RGB values, then create your custom color as follows:
   a) Click on the Pick button to open the Pick a Color dialog (Figure 302).
   b) Select the color range in the vertical bar, then click and drag the small target circle until you have a color that is close to the color you require. You will notice that the values for RGB, HSB and CMYK will change as you move the small target circle.
   c) Alternatively and if you know the CMYK percentage values, enter these percentage values in the CMYK boxes. You will notice that the RGB values will also change to match the CMYK percentage values.
   d) Click OK to close the Pick a Color dialog and your custom color appears in the New preview box on the Area dialog.

7) On the Area dialog, click Add in the Custom Palette option to open the Name dialog (Figure 303).

8) Enter a memorable name for your custom color in the text box in the Name dialog.

9) Click OK to save the name for your custom color and close the Name dialog. Your custom color will be added to the custom palette.

**Note**

When you select one of the RGB or HSB options, the main color display in the Pick a Color dialog (Figure 302) changes its color range to help you create a new color.

**Note**

It is important to use a memorable name for your custom color so that you can easily recognize it in the Custom palette. If you do not give the color a memorable name, the color will be given a hex number, which will make it difficult identifying colors when you have more than one custom color.

**Deleting colors**

Only colors that you have created and are available in the custom palette can be deleted as follows:
1) Go to Format > Area on the main menu bar to open the Area dialog (Figure 297 on page 249).

2) Click on the Color button to open the Color page.

3) Select the custom palette from the drop down list in Colors > Palette.

4) Select the color you want to delete.

5) In Custom Palette, click on Delete and the color is deleted without any confirmation.

6) Click OK to close the Area dialog.

Bézier curves

In LibreOffice you can use Bézier curves in your drawing. A curve is defined by means of a start point, an end point, and, where necessary, control points. For points on the curve the terms nodes or anchors are often used. For more information and an explanation of the mathematical background of Bézier curves, see http://en.wikipedia.org/wiki/Bezier_curve.

Bézier curves are very useful for experimenting with the shape and form of curves. In point mode you can change the curve alignment by dragging the points with the mouse. In the example shown in Figure 304, the curve leaves the start point P0 in the direction of the first control point P1 and arrives at the end point P3 from the direction of the second control point P2. The more distant a control point is from the start or end point the smaller the curvature at that point. If a control point lies directly on one of these points, it has no influence on the curve.

Drawing Bézier curves

1) Click on the Curve icon in the Curves and Polygons section of the Shapes deck on the Sidebar or in the Drawing toolbar.

2) Click at the start point where you want to draw the curve and, keeping the mouse button pressed, drag the cursor to the approximate position of the end point for the curve.

3) Release the mouse button, then drag the end point of the curve to its end position.

4) Double-click when you have reached the end position of the curve and a curve is drawn. The arc of the curve is determined by the distance you have dragged to create the end point.

5) Click on the Points icon on the Drawing toolbar or press the F8 key to open the Edit Points toolbar (Figure 305).

6) Click once on the curve to display the start and end points. The start point of the curve is larger than the end point.

Bézier curves were invented by Pierre Bézier, an engineer working with the Renault car manufacturer, who developed the technique in the 1960s. The technology was intended to make modeling the surface of vehicles easier.
7) Move the cursor over the start or end point and drag the control point to change the curve shape. As you drag a start or end point, a control point appears at the end of a dashed line connected to the point you have selected, as shown in Figure 306.

8) When you have the position for your start or end point, release the cursor and the control point remains active.

9) Click on the control point and drag it to also change the shape of the curve.

10) When you have finished editing the curve, click anywhere on the workspace to deselect the curve and stop editing points.

![Edit Points toolbar](image)

*Figure 305: Edit Points toolbar*

![Control points on a curve](image)

*Figure 306: Control points on a curve*

**Edit Points tools**

After the Edit Points toolbar has been opened, each time you select an object that has been converted to a curve or polygon, the toolbar will appear. Each time you deselect an object that has been converted, the toolbar will close. Available tools on the Edit Points toolbar will depend on the object selected and which object point has been selected.

With reference to Figure 305, the tools available on the Edit Points toolbar allow you to edit and change the shape of a Bézier curve and are explained as follows:

- **Points** – allows you to activate or deactivate the edit mode for Bézier objects. In the edit mode, individual points of the drawing object can be selected.
• **Move Points** – activates a mode in which you can move points. Click on a point and drag it to another location. The curve on both sides of the point follows the movement; the section of the curve between points changes shape. Point at the curve between two points or within a closed curve and drag the mouse to shift the entire curve without distorting the form.

• **Insert Points** – activates the insert mode and allows you to insert points. You can also move points, just as in the move mode. If, however, you click at the curve between two points and move the mouse a little while holding down the mouse button you insert a new point. The point is a smooth point, and the lines to the control points are parallel and remain so when moved. If you wish to create a corner point you must first insert either a smooth or a symmetrical point which is then converted to a corner point by using **Corner Point**.

• **Delete Points** – deletes one or several selected points. If you wish to select several points, click the appropriate points while holding down the **Shift** key. After selecting the points to be deleted, click this icon or press **Delete** key.

• **Convert To Curve** – converts a curve into a straight line or converts a straight line into a curve. If you select a single point, the curve segment after the point will be converted. If you convert the segment from straight to curve, the point itself and the other end point of the segment each gets a control point. If you convert from curve to straight these control points are removed. If you select more than two points, each time you click this icon, a different portion of the curve will be converted. If necessary, round points are converted into corner points. If a section of the curve is straight, the end points of the line have a maximum of one control point each.

• **Close Bézier** – closes or opens a poly line or a curve. A line is closed by connecting the last point with the first point. The first point is indicated by an enlarged square.

• **Split Curve** – splits a curve into two or more curves. Select the point or points where you want to split the curve, then click.

• **Corner Point** – converts the selected point or points into corner points (Figure 307). Corner points have two movable control points, which are independent from each other. A curved line, therefore, does not go straight through a corner point, but forms a corner.

![Figure 307: Corner point](image)

• **Smooth Transition** – converts a corner point or symmetrical point into a smooth point (Figure 308). Both control points of the corner point are aligned in parallel and can only be moved simultaneously. The control points may differ in length, allowing you to vary the degree of curvature.

![Figure 308: Smooth transition point](image)

• **Symmetric Transition** – converts a corner point or a smooth point into a symmetrical point (Figure 309). Both control points of the corner point are aligned in parallel and have the same length. They can only be moved simultaneously and the degree of curvature is the same in both directions.
Adding comments to a drawing

Draw supports comments similar to those in Writer and Calc.

1) Go to **Insert > Comment** the main menu bar. A comment box appears with a small marker box containing your initials in the upper left-hand corner of your drawing. Draw automatically adds your name and the date at the bottom of the comment (Figure 31).

2) Type or paste your comment into the text box.

3) To apply basic formatting to the text, right-click and select the formatting option from the context menu.

4) To delete a comment, right-click on the comment or marker box or click on the small triangle in the bottom right of the comment and select a delete option from the context menu.

5) To move a comment, click on the small marker box and drag it to a new position.

6) To show or hide the comments, go to **View > Comments** on the main menu bar.

![Figure 310: Comment in a drawing](image)

**Note**

For your initials and name to appear in a comment, you have to enter your user data. Go to **Tools > Options > LibreOffice > User Data** on the main menu bar and enter all the necessary data. If more than one person edits the document, each author is automatically allocated a different background color.
Connecting and breaking lines

It is possible in Draw to connect separate line elements together to make one line, or to break a line that is composed of separate elements.

- To connect lines, select the lines and go to **Shape > Connect** on the main menu bar. End points on the line are joined together. The resulting shape is a poly line, not a closed shape.
- To break a line that is composed of separate elements, select it and go to **Shape > Break** on the main menu bar. Deselect the object and then select each separate element. Each separate element is indicated with start and end points. Click on an element and drag it to a new position.

Coordinate system

**X and Y axes**

The x-axis is the horizontal position of an object and the y-axis is the vertical position of an object. The rulers do not show a minus sign if there are negative coordinates. However, the minus sign for negative coordinates is shown in the position field in the **Status Bar** and the **Position and Size** dialog.

**Workspace**

The Workspace is larger than the drawing page. The area outside the drawing page is one page width right and left and a half page above and below the drawing page. The size of the drawing page is indicated by highlighted portions in the horizontal and vertical rulers.

You can draw objects that are partly or wholly outside the drawing page. However, when the drawing is printed, any portion of an object or an object not on the drawing page is not printed, saved or exported. This allows the Workspace area around the drawing page to be used for drafts when creating objects.

**Object position**

The coordinates of objects and snap guides are shown relative to the origin. The default origin for coordinates (0.00/0.00 position) is the top-left corner of the drawing page without margins or the top left corner of the drawing page where the margins intersect. To change the default origin, click and drag the intersection of the rulers in the top left corner of the Workspace to the desired position. Guide lines will appear as you drag the default origin to its new position. This origin setting is only for the current view and is not saved in the document.

The area inside the default origin is the area used for the grid when the option Snap to Grid and Display Grid are selected. To reset the default origin back to its original setting at the top-left corner of the page, double click in the top-left corner on the Workspace where the horizontal and vertical rulers meet.

**Accuracy**

Draw uses internally integer values in 1/100 mm. Therefore it is not possible to get an exact position for 1/8 inch, for example. Also, many dialog fields are restricted to two decimals. To work in maximal possible accuracy, go to **Tools > Options > Draw > General** and set the option **Unit of measurement** to Millimeter. The rulers will also show metric units. However, to use your favorite measurement unit, right click on the ruler and select your favorite measurement unit from the context menu.
Appendix A
Keyboard Shortcuts
Introduction

You can use LibreOffice without requiring a pointing device, such as a mouse or trackball, by using its built-in keyboard shortcuts. Tasks as varied and complex as docking and undocking toolbars and windows, or changing the size or position of objects can all be accomplished with only a keyboard. Although LibreOffice has its own extensive set of keyboard shortcuts, each component provides others which are specific to its work.

For help with LibreOffice keyboard shortcuts, or using LibreOffice with a keyboard only, search the LibreOffice Help using the “shortcut” or “accessibility” keywords.

In addition to using the built-in keyboard shortcuts (listed in this Appendix), you can also define your own. You can assign shortcuts to standard Draw functions or your own macros and save them for use with Draw only, or with the entire LibreOffice suite.

To adapt shortcut keys to your needs, use the Customize dialog as described in this section.

Tips on using macOS

Some keystrokes and menu items are different on macOS from those used in Windows and Linux. The table below gives some common substitutions for the instructions in this book. For a more detailed list, see the application Help.

<table>
<thead>
<tr>
<th>Windows or Linux</th>
<th>macOS equivalent</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tools &gt; Options menu selection</td>
<td>LibreOffice &gt; Preferences</td>
<td>Access setup options</td>
</tr>
<tr>
<td>Right-click</td>
<td>Control+click and/or right-click depending on computer setup</td>
<td>Open a context menu</td>
</tr>
<tr>
<td>Ctrl (Control)</td>
<td>(Command)</td>
<td>Used with other keys</td>
</tr>
<tr>
<td>F5</td>
<td>Shift+(Command) +F5</td>
<td>Open the Navigator</td>
</tr>
<tr>
<td>F11</td>
<td>+T</td>
<td>Open the Styles deck in the Sidebar</td>
</tr>
</tbody>
</table>

Note

Some of the shortcut keys in this appendix may be assigned to your desktop system. Keys that are assigned to the desktop system are not available to LibreOffice. Try to assign different keys either for LibreOffice in Tools > Customize > Keyboard, or in your computer system. For more information on customizing LibreOffice, see the Getting Started Guide.
## Draw-specific function keys and keyboard shortcuts

### Function keys

<table>
<thead>
<tr>
<th>Shortcut keys</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>F1</td>
<td>Opens LibreOffice Draw Help</td>
</tr>
<tr>
<td>F2</td>
<td>Enters text mode, to add or edit text.</td>
</tr>
<tr>
<td>F3</td>
<td>Enters group to edit individual objects.</td>
</tr>
<tr>
<td>Shift+F3</td>
<td>Opens the Duplicate dialog.</td>
</tr>
<tr>
<td>Ctrl+F3</td>
<td>Exits a group.</td>
</tr>
<tr>
<td>F4</td>
<td>Opens the Position and Size dialog.</td>
</tr>
<tr>
<td>F5</td>
<td>Opens the Navigator.</td>
</tr>
<tr>
<td>F7</td>
<td>Check spelling.</td>
</tr>
<tr>
<td>Ctrl+F7</td>
<td>Opens the thesaurus.</td>
</tr>
<tr>
<td>F8</td>
<td>Turns Edit Points on/off.</td>
</tr>
<tr>
<td>Ctrl+Shift+F8</td>
<td>Fits text to frame.</td>
</tr>
<tr>
<td>Shift+F10</td>
<td>Opens context menu of a selected object.</td>
</tr>
<tr>
<td>F11</td>
<td>Opens the Styles and Formatting dialog.</td>
</tr>
</tbody>
</table>

### Shortcut keys for drawings

<table>
<thead>
<tr>
<th>Shortcut Keys</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Plus (+) key</td>
<td>Zooms in.</td>
</tr>
<tr>
<td>Minus (-) key</td>
<td>Zooms out.</td>
</tr>
<tr>
<td><strong>Multiple (×) Key</strong> (number pad)</td>
<td>Zooms to fit entire page in screen.</td>
</tr>
<tr>
<td><strong>Divide (÷) Key</strong> (number pad)</td>
<td>Zooms in on the current selection.</td>
</tr>
<tr>
<td>Ctrl+Shift+G</td>
<td>Groups selected objects.</td>
</tr>
<tr>
<td>Shift+Ctrl+Alt+A</td>
<td>Ungroups selected group.</td>
</tr>
<tr>
<td>Ctrl+Shift+K</td>
<td>Combines selected objects.</td>
</tr>
<tr>
<td>Ctrl+Alt+Shift+K</td>
<td>Un-combines selected objects.</td>
</tr>
<tr>
<td>Ctrl+Shift+Plus (+) key</td>
<td>Brings current selection to front.</td>
</tr>
<tr>
<td>Shortcut Keys</td>
<td>Effect</td>
</tr>
<tr>
<td>-------------------------------</td>
<td>------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Ctrl+Plus (+) key</td>
<td>Brings current selection forward.</td>
</tr>
<tr>
<td>Ctrl-Minus (-) key</td>
<td>Sends current selection backward.</td>
</tr>
<tr>
<td>Ctrl+Shift-Minus (-) key</td>
<td>Sends current selection to back.</td>
</tr>
<tr>
<td>Page Up</td>
<td>Switches to previous page.</td>
</tr>
<tr>
<td>Page Down</td>
<td>Switches to next page.</td>
</tr>
<tr>
<td>Ctrl+Page Up</td>
<td>Switches to previous layer.</td>
</tr>
<tr>
<td>Ctrl+Page Down</td>
<td>Switches to next layer.</td>
</tr>
<tr>
<td>Arrow Key</td>
<td>Moves the selected object in the direction of the arrow key.</td>
</tr>
<tr>
<td>Ctrl+Arrow Key</td>
<td>Moves the page view in the direction of the arrow key.</td>
</tr>
<tr>
<td>Ctrl+click while dragging an object</td>
<td>Creates a copy of the object being dragged when mouse button is released. Note that this shortcut key works only when the Copy when moving option in LibreOffice &gt; Preferences &gt; LibreOffice Draw &gt; General is enabled (this option is enabled by default).</td>
</tr>
<tr>
<td>Ctrl+Enter with keyboard focus (F6) on a drawing object icon on Tools bar</td>
<td>Inserts a drawing object of default size into the center of the current view.</td>
</tr>
<tr>
<td>Shift+F10</td>
<td>Opens the context menu for the selected object.</td>
</tr>
<tr>
<td>F2</td>
<td>Enters text mode.</td>
</tr>
<tr>
<td>Enter</td>
<td>Enters text mode if a text object is selected.</td>
</tr>
<tr>
<td>Ctrl+Enter</td>
<td>Enters text mode if a text object is selected. If there are no text objects or if you have cycled through all of the text objects on the page, a new page is inserted.</td>
</tr>
<tr>
<td>Alt</td>
<td>Press the Alt key and drag with the mouse to draw or resize an object from the center of the object outward.</td>
</tr>
<tr>
<td>Alt + click on an object</td>
<td>Selects the object behind the currently selected object.</td>
</tr>
<tr>
<td>Alt+Shift + click on an object</td>
<td>Selects the object in front of the currently selected object.</td>
</tr>
<tr>
<td>Shift key while selecting an object</td>
<td>Adds or removes object to or from the selection.</td>
</tr>
<tr>
<td>Shift key while moving an object</td>
<td>Constrains the movement of the selected object by multiples of 45 degrees.</td>
</tr>
<tr>
<td>Shift key while dragging to create or resize an object</td>
<td>Constrains the size to keep the object aspect ratio.</td>
</tr>
</tbody>
</table>
### Shortcut Keys

<table>
<thead>
<tr>
<th>Shortcut Keys</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tab</td>
<td>Cycles through the objects on the page in the order in which they were created.</td>
</tr>
<tr>
<td>Shift+Tab</td>
<td>Cycles through the objects on the page in the reverse-order in which they were created.</td>
</tr>
<tr>
<td>Esc</td>
<td>Exits current mode.</td>
</tr>
</tbody>
</table>

### Page Pane navigation

<table>
<thead>
<tr>
<th>Shortcut Keys</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Home/End</td>
<td>Sets the focus to the first/last page.</td>
</tr>
<tr>
<td>Left/Right arrow keys or Page Up/Page Down</td>
<td>Sets the focus to the next/previous page.</td>
</tr>
<tr>
<td>Enter</td>
<td>Creates a new page.</td>
</tr>
</tbody>
</table>

### General function keys and keyboard shortcuts

#### Opening menus and menu items

<table>
<thead>
<tr>
<th>Shortcut Keys</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alt+&lt;?&gt;</td>
<td>Opens a menu where <code>&lt;?&gt;</code> is the underlined character of the menu you want to open. For example, <code>Alt+F</code> opens the File menu. With the menu open, menu items have underlined characters. To access these menu items directly, press the underlined character key. Where two menu items have the same underlined character, press the character key again to move to the next item. If an item in a menu has no underlined character, you need to click it directly.</td>
</tr>
<tr>
<td>Esc</td>
<td>Closes an open menu.</td>
</tr>
<tr>
<td>F6</td>
<td>Repeatedly pressing <code>F6</code> switches the focus and circles through the following objects: Menu bar Every toolbar from top to bottom and from left to right Every free window from left to right Document</td>
</tr>
<tr>
<td>Shift+F6</td>
<td>Switches through objects in the opposite direction.</td>
</tr>
<tr>
<td>Ctrl+F6</td>
<td>Switches the focus to the document.</td>
</tr>
<tr>
<td>F10 or Alt</td>
<td>Switches to the Menu bar and back.</td>
</tr>
</tbody>
</table>
Accessing menu commands

Press **Alt** or **F6** or **F10** to select the first item on the menu bar (the File menu). With the **right-arrow**, the next menu to the right is selected; with the **left-arrow**, the previous menu. The **Home** and **End** keys select the first and the last item on the Menu bar.

The **down-arrow** opens a selected menu. An additional **down-arrow** or **up-arrow** moves the selection through the menu commands. The **right-arrow** opens any existing submenus.

Press **Enter** to execute the selected menu command.

Accessing toolbar commands

Press **F6** repeatedly until the first icon on the toolbar is selected. Use the **right** and **left arrows** to select an icon on a horizontal toolbar. Similarly, use the **up** and **down arrows** to select an icon on a vertical toolbar. The **Home** key selects the first icon on a toolbar and the **End** key, the last.

Press **Enter** to activate the selected icon. If the selected icon normally requires a consecutive mouse action, such as inserting a rectangle, then pressing the **Enter** key is not sufficient; in these cases, press **Ctrl+Enter**.

- Press **Ctrl+Enter** on an icon to create a draw object. The draw object will be placed into the middle of the view, with a predefined size.
- Press **Ctrl+Enter** on the Selection tool to select the first draw object in the document. If you want to edit, size, or move the selected draw object, first use **Ctrl+F6** to move the focus into the document.

Navigating and selecting with the keyboard

You can navigate through a document and make selections with the keyboard.

- To move the cursor, press the key or key combination given in the following table.
- To select the characters under the moving cursor, additionally hold down the **Shift** key when you move the cursor.

<table>
<thead>
<tr>
<th>Key</th>
<th>Function</th>
<th>Plus Ctrl key</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Right, left arrow keys</strong></td>
<td>Moves the cursor one character to the left or to the right.</td>
<td>Moves the cursor one word to the left or to the right.</td>
</tr>
<tr>
<td><strong>Up, down arrow keys</strong></td>
<td>Moves the cursor up or down one line.</td>
<td><strong>(Ctrl+Alt)</strong> Moves the current paragraph up or down.</td>
</tr>
<tr>
<td><strong>Home</strong></td>
<td>Moves the cursor to the beginning of the current line.</td>
<td>Moves the cursor to the beginning of the document.</td>
</tr>
<tr>
<td><strong>End</strong></td>
<td>Moves the cursor to the end of the current line.</td>
<td>Moves the cursor to the end of the document.</td>
</tr>
<tr>
<td><strong>PgUp</strong></td>
<td>Scrolls up one page.</td>
<td>Moves the cursor to the header.</td>
</tr>
<tr>
<td><strong>PgDn</strong></td>
<td>Scroll down one page.</td>
<td>Moves the cursor to the footer.</td>
</tr>
</tbody>
</table>

General function keys and keyboard shortcuts | 265
## Controlling dialogs

When you open any dialog, one element (such as a button, an option field, an entry in a list box, or a checkbox) is highlighted or indicated by a dotted box around the field or button name. This element is said to have the focus on it.

<table>
<thead>
<tr>
<th>Shortcut Keys</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Enter</strong></td>
<td>Activates selected button. In most cases where no button is selected, <strong>Enter</strong> is equivalent to clicking <strong>OK</strong>.</td>
</tr>
<tr>
<td><strong>Esc</strong></td>
<td>Closes dialog without saving any changes made while it was open. In most cases, <strong>Esc</strong> is equivalent to clicking <strong>Cancel</strong>. When an open drop-down list is selected, <strong>Esc</strong> closes the list.</td>
</tr>
<tr>
<td><strong>Spacebar</strong></td>
<td>Checks an empty checkbox. Clears a checked checkbox.</td>
</tr>
<tr>
<td><strong>Up, down arrow keys</strong></td>
<td>Moves focus up and down a list. Increases or decreases value of a variable. Moves focus vertically within a section of dialog.</td>
</tr>
<tr>
<td><strong>Left, right arrow keys</strong></td>
<td>Moves focus horizontally within a section of a dialog.</td>
</tr>
<tr>
<td><strong>Tab</strong></td>
<td>Advances focus to the next section or element of a dialog.</td>
</tr>
<tr>
<td><strong>Shift+Tab</strong></td>
<td>Returns focus to the previous section or element in a dialog.</td>
</tr>
<tr>
<td><strong>Alt+Down Arrow</strong></td>
<td>Shows items in a drop-down list.</td>
</tr>
</tbody>
</table>

## Getting help

<table>
<thead>
<tr>
<th>Shortcut Keys</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>F1</strong></td>
<td>Opens the LibreOffice Help dialog. In LibreOffice Help: jumps to the first help page of the selected tab.</td>
</tr>
<tr>
<td><strong>Shift+F1</strong></td>
<td>Turns the cursor into the <strong>What's This?</strong> question mark. Shows the tip for an item underneath the cursor.</td>
</tr>
<tr>
<td><strong>Shift+F2</strong></td>
<td>Shows tip for a selected item.</td>
</tr>
<tr>
<td><strong>Esc</strong></td>
<td>In LibreOffice Help: goes up one level.</td>
</tr>
</tbody>
</table>

## Managing documents

<table>
<thead>
<tr>
<th>Shortcut Keys</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Ctrl+F4 or Alt+F4</strong></td>
<td>Closes the current document. Closes LibreOffice when the last open document is closed.</td>
</tr>
<tr>
<td><strong>Ctrl+O</strong></td>
<td>Launches the <strong>Open</strong> dialog to open a document.</td>
</tr>
<tr>
<td><strong>Ctrl+S</strong></td>
<td>Saves the current document. If you are working on a previously unsaved file, the shortcut launches the <strong>Save As</strong> dialog.</td>
</tr>
<tr>
<td><strong>Ctrl+N</strong></td>
<td>Creates a new document.</td>
</tr>
</tbody>
</table>
## Shortcut Keys

<table>
<thead>
<tr>
<th>Shortcut Keys</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Shift+Ctrl+N</td>
<td>Opens the <strong>Templates and Documents</strong> dialog.</td>
</tr>
<tr>
<td>Ctrl+P</td>
<td>Opens the <strong>Print</strong> dialog to print the document.</td>
</tr>
<tr>
<td>Ctrl+Q</td>
<td>Closes the application.</td>
</tr>
<tr>
<td>Del</td>
<td>In the <strong>Save</strong> and <strong>Open</strong> dialogs, deletes the selected files or folders. Items can be retrieved from the Recycle Bin (Trash).</td>
</tr>
<tr>
<td>Shift+Del</td>
<td>In the <strong>Save</strong> and <strong>Open</strong> dialogs, deletes the selected files or folders. Items are permanently deleted: they can not be retrieved from the Recycle Bin (Trash).</td>
</tr>
<tr>
<td>Backspace</td>
<td>In the <strong>Save</strong> and <strong>Open</strong> dialogs, shows contents of the parent folder of the current directory.</td>
</tr>
</tbody>
</table>

### Editing

<table>
<thead>
<tr>
<th>Shortcut Keys</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl+X</td>
<td>Cuts selected items.</td>
</tr>
<tr>
<td>Ctrl+C</td>
<td>Copies selected items to the clipboard.</td>
</tr>
<tr>
<td>Ctrl+V</td>
<td>Pastes copied or cut items from the clipboard.</td>
</tr>
<tr>
<td>Ctrl+Shift+V</td>
<td>Opens the <strong>Paste Special</strong> dialog.</td>
</tr>
<tr>
<td>Ctrl+A</td>
<td>Selects all.</td>
</tr>
<tr>
<td>Ctrl+Z</td>
<td>Undoes last action.</td>
</tr>
<tr>
<td>Ctrl+Y</td>
<td>Redoes last action.</td>
</tr>
<tr>
<td>Ctrl+Shift+Y</td>
<td>Repeats last command.</td>
</tr>
<tr>
<td>Ctrl+F</td>
<td>Opens the <strong>Find</strong> dialog</td>
</tr>
<tr>
<td>Ctrl+H</td>
<td>Opens the <strong>Find &amp; Replace</strong> dialog.</td>
</tr>
<tr>
<td>Ctrl+Shift+F</td>
<td>Searches for the last entered search term.</td>
</tr>
<tr>
<td>Ctrl+Shift+R</td>
<td>Refreshes (redraws) the document view.</td>
</tr>
<tr>
<td>Ctrl+Shift+I</td>
<td>Shows or hides the cursor in read-only text.</td>
</tr>
</tbody>
</table>

### Selecting rows and columns in tables

<table>
<thead>
<tr>
<th>Shortcut keys</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>Spacebar</td>
<td>Toggles row selection, except when the row is in edit mode.</td>
</tr>
</tbody>
</table>
### Defining keyboard shortcuts

In addition to using the built-in keyboard shortcuts listed in this Appendix, you can define your own keyboard shortcuts. See the *Getting Started Guide* for more information on defining keyboard shortcuts.

### Further reading

For help with LibreOffice keyboard shortcuts, or using LibreOffice with a keyboard only, search the LibreOffice Help using the key words “shortcut keys” or “accessibility”.

---

<table>
<thead>
<tr>
<th><strong>Shortcut keys</strong></th>
<th><strong>Result</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Ctrl+Spacebar</strong></td>
<td>Toggles row selection.</td>
</tr>
<tr>
<td><strong>Shift+Spacebar</strong></td>
<td>Selects the current column.</td>
</tr>
<tr>
<td><strong>Ctrl+Page Up</strong></td>
<td>Moves pointer to the first row.</td>
</tr>
<tr>
<td><strong>Ctrl+Page Down</strong></td>
<td>Moves pointer to the last row.</td>
</tr>
</tbody>
</table>
Draw Guide

Working With Vector Graphics

About this book:

This book covers the main features of Draw, the vector graphics component of LibreOffice. Using Draw, you can quickly create a wide variety of graphical images.

Vector graphics store and display a picture as simple geometric elements such as lines, circles, and polygons rather than as a collection of pixels (point on the screen). This permits simpler storage and supports precise scaling of the picture elements.

Draw is fully integrated into LibreOffice. This simplifies exchanging graphics with Writer, Calc, and Impress. You can also export images in many formats for use in other programs.

About the authors:

This book was written by volunteers from the LibreOffice community. Profits from sales of the printed edition will be used to benefit the community.

A PDF version of this book can be downloaded free from: https://documentation.libreoffice.org/en/

About LibreOffice:

LibreOffice is the free, libre, and open source personal productivity suite from The Document Foundation. It runs on Windows, macOS, and GNU/Linux. Support and documentation is free from our large, dedicated community of users, contributors, and developers. You too can get involved with volunteer work in many areas: development, quality assurance, documentation, translation, user support, and more.

You can download LibreOffice free from https://libreoffice.org/download/