Calc Guide

6.4
Copyright

This document is Copyright © 2020 by the LibreOffice Documentation Team. Contributors are listed below. You may distribute it and/or modify it under the terms of either the GNU General Public License (http://www.gnu.org/licenses/gpl.html), version 3 or later, or the Creative Commons Attribution License (http://creativecommons.org/licenses/by/4.0/), version 4.0 or later.

All trademarks within this guide belong to their legitimate owners.

Contributors

This book is adapted and updated from the LibreOffice 6.2 Calc Guide.

To this edition

Steve Fanning                  Leo Moons                  Kees Kriek
Gordon Bates                  Drew Jensen                Randolph Gamo

To previous editions

John A Smith                   Jean Hollis Weber          Martin J Fox
Andrew Pitonyak               Simon Brydon               Gabriel Godoy
Barbara Duprey                Gabriel Godoy              Peter Schofield
John A Smith                   Christian Chenal           Laurent Balland-Poirier
Philippe Clément              Pierre-Yves Samyn           Shelagh Manton
Peter Kupfer                  Andy Brown                 Stephen Buck
Iain Roberts                  Hazel Russman              Barbara M. Tobias
Jared Kobos                   Martin Saffron             Dave Barton
Olivier Hallot                 Cathy Crumbley           Kees Kriek
Claire Wood                    Steve Fanning             Zachary Parliman

Feedback

Please direct any comments or suggestions about this document to the Documentation Team's mailing list: documentation@global.libreoffice.org.

Warning

Everything you send to a mailing list, including your email address and any other personal information that is written in the message, is publicly archived and cannot be deleted.

Publication date and software version

Published June 2020. Based on LibreOffice 6.4.
Contents

Copyright .......................................................................................................................... 2
Preface ............................................................................................................................. 7
  Who is this book for? ...................................................................................................... 8
  What's in this book? ...................................................................................................... 8
  Where to get more help ............................................................................................. 8
  What you see may be different .................................................................................... 10
  Using LibreOffice on macOS ..................................................................................... 11
  What are all these things called? ................................................................................. 11
  Frequently asked questions ......................................................................................... 12
  What's new in LibreOffice Calc 6.4? .......................................................................... 13
Chapter 1 Introduction ................................................................................................. 14
  What is Calc? .............................................................................................................. 15
  Spreadsheets, sheets, and cells .................................................................................. 15
  Calc main window ..................................................................................................... 15
  Creating, opening, and saving spreadsheets ............................................................... 21
  Password protection .................................................................................................. 25
  Navigating within spreadsheets ................................................................................ 25
  Selecting items in a spreadsheet ................................................................................. 28
  Working with columns and rows .............................................................................. 30
  Working with sheets ................................................................................................... 32
  Viewing Calc ............................................................................................................. 34
  Using the Navigator ................................................................................................... 36
  Using document properties ....................................................................................... 38
Chapter 2 Entering, Editing, and Formatting Data ....................................................... 41
  Introduction .............................................................................................................. 42
  Entering data ............................................................................................................ 42
  Speeding up data entry ............................................................................................. 47
  Merging and splitting cells ....................................................................................... 51
  Sharing content between sheets .............................................................................. 51
  Validating cell contents ............................................................................................ 52
  Editing data ............................................................................................................... 56
  Formatting data ........................................................................................................ 60
  AutoFormat of cells and sheets ............................................................................... 65
  Using themes ............................................................................................................ 66
  Value highlighting ..................................................................................................... 67
  Using conditional formatting .................................................................................... 68
  Hiding and showing data ......................................................................................... 72
  Sorting records .......................................................................................................... 79
  Find and replace ....................................................................................................... 82
Chapter 3 Creating Charts and Graphs ...................................................................... 86
  Introduction .............................................................................................................. 87
  Chart Wizard ............................................................................................................ 87
Chapter 4 Using Styles and Templates.................................................................159
  What are styles? Why use them?..................................................................160
  Calc style types............................................................................................160
  Applying cell styles.......................................................................................161
  Applying page styles.....................................................................................163
  Creating new (custom) styles.........................................................................163
  Managing styles............................................................................................173
  What is a template? Why use one?.................................................................174
  Using a template to create a spreadsheet......................................................175
  Creating a template.......................................................................................176
  Editing a template........................................................................................177
  Adding templates obtained from other sources............................................178
  Setting the default template.........................................................................179
  Organizing templates....................................................................................180

Chapter 5 Using Graphics..................................................................................183
  Introduction..................................................................................................184
  Adding graphics (images) to a spreadsheet..................................................184
  Modifying images........................................................................................188
  Positioning, resizing, and arranging images................................................190
  Using LibreOffice’s drawing tools.................................................................192
  Additional tools............................................................................................194
  Using Fontwork.............................................................................................195

Chapter 6 Printing, Exporting, E-mailing, and Signing.....................................197
  Printing.........................................................................................................198
Contents

Chapter 11 Sharing and Reviewing Spreadsheets ...................................................... 371

Chapter 10 Linking Data ......................................................................................... 334
Using multiple sheets .......................................................................................... 335
Referencing other documents ............................................................................. 342
Using hyperlinks and URLs ................................................................................. 343
Linking to external data ....................................................................................... 348
Linking to registered data sources ..................................................................... 355
Embedding spreadsheets ...................................................................................... 361
XML Source ........................................................................................................ 367

Chapter 9 Data Analysis ......................................................................................... 287
Introduction .......................................................................................................... 288
Consolidating data .............................................................................................. 288
Creating subtotals ............................................................................................... 291
Using scenarios .................................................................................................... 297
Using the Multiple Operations tool .................................................................. 301
Using Goal Seek ................................................................................................... 306
Using the Solver ................................................................................................. 308
Using Statistics tools .......................................................................................... 312

Chapter 8 Using Pivot Tables .................................................................................. 253
Introduction .......................................................................................................... 254
The Pivot Table Layout dialog ............................................................................ 256
Working with the results of the pivot table .......................................................... 267
Using pivot table results elsewhere ..................................................................... 280
Using pivot charts ............................................................................................... 283

Chapter 7 Using Formulas and Functions ............................................................... 221
Introduction .......................................................................................................... 222
Setting up a spreadsheet ...................................................................................... 223
Creating formulas ............................................................................................... 224
Understanding functions .................................................................................... 237
Strategies for creating formulas and functions .................................................... 243
Finding and fixing errors ..................................................................................... 245
Examples of functions ........................................................................................ 248
Using wildcards and regular expressions in functions ......................................... 250
Advanced functions ............................................................................................ 252

Chapter 6 Using Charts and Graphics ................................................................. 222
Using pivot charts ............................................................................................... 256
Using pivot table results elsewhere .................................................................... 282
Using pivot charts ............................................................................................... 283

Chapter 5 Using Statistics Tools ............................................................................ 243
Finding and fixing errors ..................................................................................... 245
Examples of functions ........................................................................................ 248
Using wildcards and regular expressions in functions ......................................... 250
Advanced functions ............................................................................................ 252

Chapter 4 Using the Solver and Goal Seek .............................................................. 259
Finding and fixing errors ..................................................................................... 245
Examples of functions ........................................................................................ 248
Using wildcards and regular expressions in functions ......................................... 250
Advanced functions ............................................................................................ 252

Chapter 3 Creating Subtotals ................................................................................ 261
Using pivot charts ............................................................................................... 256
Using pivot table results elsewhere .................................................................... 282
Using pivot charts ............................................................................................... 283

Chapter 2 Creating Subtotals ................................................................................ 261
Using pivot charts ............................................................................................... 256
Using pivot table results elsewhere .................................................................... 282
Using pivot charts ............................................................................................... 283

Chapter 1 Creating Subtotals ................................................................................. 261
Using pivot charts ............................................................................................... 256
Using pivot table results elsewhere .................................................................... 282
Using pivot charts ............................................................................................... 283

Chapter 1 Creating Subtotals ................................................................................. 261
Using pivot charts ............................................................................................... 256
Using pivot table results elsewhere .................................................................... 282
Using pivot charts ............................................................................................... 283
Introduction......................................................................................................................... 372
Sharing spreadsheets........................................................................................................ 372
Reviewing documents....................................................................................................... 374
Merging documents.......................................................................................................... 379
Comparing documents..................................................................................................... 380
Saving versions................................................................................................................ 380

Chapter 12 Macros............................................................................................................. 382
Introduction....................................................................................................................... 383
Using the macro recorder................................................................................................. 383
Write your own functions................................................................................................. 387
Accessing cells directly.................................................................................................... 396
Sorting............................................................................................................................... 398
Overview of BeanShell, JavaScript, and Python macros.................................................. 399
Conclusion......................................................................................................................... 405

Chapter 13 Calc as a Simple Database............................................................................. 406
Introduction....................................................................................................................... 407
Associating a range with a name...................................................................................... 408
Sorting............................................................................................................................... 417
Filtering............................................................................................................................. 421
Useful database-like functions........................................................................................ 429

Chapter 14 Setting up and Customizing......................................................................... 433
Introduction....................................................................................................................... 434
LibreOffice options.......................................................................................................... 434
Options for loading and saving documents...................................................................... 438
Calc-specific options........................................................................................................ 441
Default colors for charts................................................................................................. 452
AutoCorrect functions...................................................................................................... 453
Customizing the user interface......................................................................................... 454
Assigning macros to events.............................................................................................. 463
Adding functionality with extensions.............................................................................. 463
Adding custom colors...................................................................................................... 464

Appendix A Keyboard Shortcuts..................................................................................... 467
Introduction....................................................................................................................... 468
Windows / Linux keyboard shortcuts.............................................................................. 468
macOS keyboard shortcuts.............................................................................................. 476

Appendix B Error Codes................................................................................................. 484
Introduction to Calc error codes...................................................................................... 485
Error codes displayed within cells................................................................................... 486
General error codes.......................................................................................................... 486

Index................................................................................................................................. 489
Alphabetical index............................................................................................................ 490
Preface
Who is this book for?

This book is for beginner to advanced users of Calc, the spreadsheet component of LibreOffice. You may be new to spreadsheet software, or you may be familiar with another program. If you have never used LibreOffice before, or you want an introduction to all of its components, you might like to read Getting Started with LibreOffice first. If you have never used spreadsheets before, you might also like to read a book or find some tutorials about the use of spreadsheets.

What's in this book?

This book introduces the features and functions of LibreOffice Calc. It is not a tutorial on using spreadsheets. Some chapters assume familiarity with basic spreadsheet usage when describing how to use Calc.

You can enter data (usually numerical) in a spreadsheet and then manipulate this data to produce certain results. Alternatively, you can enter data and then use Calc in a ‘What if...’ manner by changing some of the data and observing the results without having to retype all of the data. Functions can be used to create formulas to perform complex calculations on data.

Some of the other features provided by Calc include:

- Database functions, to arrange, store, and filter data.
- Dynamic charts: a wide range of 2D and 3D charts.
- Macros, for recording and executing repetitive tasks; scripting languages supported include LibreOffice Basic, Python, BeanShell, and JavaScript.
- Ability to open, edit, and save Microsoft® Excel® and other spreadsheets.
- Import of spreadsheets from multiple formats, including HTML, CSV, and PostScript.
- Export of spreadsheets into multiple formats, including HTML, CSV, and PDF.

Where to get more help

This book, the other LibreOffice user guides, the built-in Help system, and user support systems assume that you are familiar with your computer and basic functions such as starting a program, opening and saving files.

Help system

LibreOffice comes with an extensive Help system. This is the first line of support for using LibreOffice. Windows and Linux users can choose to download and install the offline Help for use when not connected to the Internet; the offline Help is installed with the program on macOS.

To display the Help system, press F1 or select LibreOffice Help from the Help menu (Figure 1). If you do not have the offline help installed on your computer and you are connected to the Internet, your default browser will open the online Help pages on the LibreOffice website.

The Help menu includes links to other LibreOffice information and support facilities.

Note

The following options indicated by a ‡ sign are only accessible if your computer is connected to the Internet.

- What's This? – For quick tips when a toolbar is visible, place the mouse pointer over any of the icons to see a small box (“tooltip”) with a brief explanation of the icon’s function. For a more detailed explanation, select Help > What's This? and hold the pointer over the icon.
In addition, you can choose whether to activate Extended Tips using **Tools > Options > LibreOffice > General**.


- **Send Feedback**‡ – Opens your default browser at the Feedback page of the LibreOffice website [https://www.libreoffice.org/get-help/feedback/](https://www.libreoffice.org/get-help/feedback/). From there you can report bugs, suggest new features and communicate with others in the LibreOffice community.

- **Restart in Safe Mode** – Opens a dialog window where you will have the option to restart LibreOffice and reset the software to its default settings.

- **Donate to LibreOffice**‡ – Opens your default browser at the Donation page of the LibreOffice website [https://donate.libreoffice.org/](https://donate.libreoffice.org/). There you can choose to make a donation to support LibreOffice.

- **License Information** – outlining the licenses under which LibreOffice is made available.

- **Check for Updates**‡ – Opens a dialog window and checks the LibreOffice website for updates to your version of the software.

- **About LibreOffice** – Opens a dialog window and displays information about the version of LibreOffice and the operating system you are using. This information will often be requested if you ask the community for help or assistance with the software.

![Figure 1: The Help Menu](image)

---

**Other free online support**

The LibreOffice community not only develops software, but provides free, volunteer-based support. In addition to the Help menu links above, there are other online community support options available, see the table below.

<table>
<thead>
<tr>
<th><strong>Free LibreOffice support</strong></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>FAQs</td>
<td>Answers to frequently asked questions <a href="https://wiki.documentfoundation.org/Faq">https://wiki.documentfoundation.org/Faq</a></td>
</tr>
<tr>
<td>Mailing lists</td>
<td>Free community support is provided by a network of experienced users <a href="https://www.libreoffice.org/get-help/mailing-lists/">https://www.libreoffice.org/get-help/mailing-lists/</a></td>
</tr>
</tbody>
</table>
Free LibreOffice support

| Questions & Answers and Knowledge Base | Free community assistance is provided in a Question & Answer formatted web service. Search similar topics or open a new one in https://ask.libreoffice.org/en/questions The service is available in several other languages; just replace /en/ with de, es, fr, ja, ko, nl, pt, tr, and many others in the web address above. |
| Native language support | The LibreOffice website in various languages https://www.libreoffice.org/community/nlc/ Mailing lists for native languages https://wiki.documentfoundation.org/Local_Mailing_Lists Information about social networking https://wiki.documentfoundation.org/Website/Web_Sites_services |
| Accessibility options | Information about available accessibility options https://www.libreoffice.org/get-help/accessibility/ |
| OpenOffice Forum | Another forum that provides support for LibreOffice, among other open source office suites https://forum.openoffice.org/en/forum/ |

Paid support and training

You can also pay for support through service contracts from a vendor or consulting firm specializing in LibreOffice. For information about certified professional support, see The Document Foundation's website: https://www.documentfoundation.org/gethelp/support/

What you see may be different

Illustrations

LibreOffice runs on Windows, Linux, and macOS operating systems, each of which has several versions and can be customized by users (fonts, colors, themes, window managers). The illustrations in this guide were taken from a variety of computers and operating systems. Therefore, some illustrations will not look exactly like what you see on your computer display.

Also, some of the dialogs may be different because of the settings selected in LibreOffice. You can either use dialogs from your computer's operating system or from LibreOffice. The differences affect mainly Open, Save, and Print dialogs. To change which dialogs are used, go to Tools > Options > LibreOffice > General and select or deselect the option Use LibreOffice dialogs.

Icons

The LibreOffice community has created icons for several icon sets: Colibre (default set), Breeze, Breeze Dark, Elementary, Karasa Jaga, Sifr, Sifr Dark and Tango. Each user can select a preferred set. The icons in this guide have been taken from a variety of LibreOffice installations that use different sets of icons. The icons for some of the many tools available in LibreOffice may then differ from the ones used in this guide.

To change the icon set used, go to Tools > Options > LibreOffice > View. Choose from the drop-down lists under Icon style and Icon size.

10 | What you see may be different
Note

The Galaxy and Oxygen icon sets are no longer included as part of the standard installation package. They can be added back by downloading and installing the following extensions:
https://extensions.libreoffice.org/extensions/galaxy-icon-theme
https://extensions.libreoffice.org/extensions/oxygen-icon-theme
Some of the previously included gallery backgrounds are now only available as an extension from:
https://extensions.libreoffice.org/extensions/legacy-gallery-backgrounds

Using LibreOffice on macOS

Some keystrokes and menu items are different on macOS from those used in Windows and Linux. The table below gives some common substitutions for the instructions in this book. For a more detailed list, see the application Help and Appendix A (Keyboard Shortcuts) to this guide.

<table>
<thead>
<tr>
<th>Windows or Linux menu selection</th>
<th>macOS equivalent</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tools &gt; Options</td>
<td>LibreOffice &gt; Preferences</td>
<td>Access setup options</td>
</tr>
<tr>
<td>Right-click</td>
<td>Control+click and/or right-click depending on computer setup</td>
<td>Open a context menu</td>
</tr>
<tr>
<td>Ctrl (Control)</td>
<td> (Command)</td>
<td>Used with other keys</td>
</tr>
<tr>
<td>Ctrl+Q</td>
<td>+Q</td>
<td>Exit / quit LibreOffice</td>
</tr>
<tr>
<td>F11</td>
<td>+T</td>
<td>Open the Sidebar’s Styles deck</td>
</tr>
</tbody>
</table>

What are all these things called?

The terms used in LibreOffice for most parts of the user interface (the parts of the program you see and use, in contrast to the behind-the-scenes code that actually makes it work) are the same as for most other programs.

A dialog is a special type of window. Its purpose is to inform you of something, or request input from you, or both. It provides controls to use to specify how to carry out an action. The technical names for common controls are shown in Figure 2. In most cases the technical terms are not used in this book, but it is useful to know them because the Help and other sources of information often use them.

In most cases, you can interact only with the dialog (not the document itself) as long as the dialog remains open. When you close the dialog after use (usually, clicking OK or another button saves your changes and closes the dialog), then you can again work with your document.

Some dialogs can be left open as you work, so you can switch back and forth between the dialog and your document. An example of this type is the Find & Replace dialog.
Figure 2: Dialog showing common controls

1) Tabbed page (not strictly speaking a control).
2) Radio buttons (only one can be selected at a time).
3) Checkbox (more than one can be selected at a time).
4) Spin box (click the up and down arrows to change the number shown in the text box next to it, or type in the text box).
5) Thumbnail or preview.
6) Drop-down list from which to select an item.
7) Push buttons.

Frequently asked questions

How is LibreOffice Licensed?
LibreOffice is distributed under the Open Source Initiative (OSI) approved Mozilla Public License (MPL). See https://www.libreoffice.org/about-us/licenses/

It is based on code from Apache OpenOffice made available under the Apache License 2.0 but also includes software that differs from version to version under a variety of other Open Source licenses. New code is available under LGPL 3.0 and MPL 2.0.

May I distribute LibreOffice to anyone? May I sell it? May I use it in my business?
Yes.

How many computers may I install it on?
As many as you like.

Is LibreOffice available in my language?
LibreOffice has been translated (localized) into over 40 languages, so your language probably is supported. Additionally, there are over 70 spelling, hyphenation, and thesaurus dictionaries available for languages, and dialects that do not have a localized program.

How can you make it for free?
LibreOffice is developed and maintained by volunteers and has the backing of several organizations.

I am writing a software application. May I use programming code from LibreOffice in my program?
You may, within the parameters set out in the licenses: https://www.mozilla.org/MPL/2.0/ https://www.libreoffice.org/about-us/licenses/.

Why do I need Java to run LibreOffice? Is it written in Java?
LibreOffice is not written in Java; it is mostly written in the C++ language. Java is one of several languages that can be used to extend the software. The Java JRE (Java Runtime Environment) is only required for some features. The most notable one is the HSQLDB relational database engine.

Java is available at no cost. More information and download links to the appropriate edition for your operating system can be found at: https://java.com/en/download/manual.jsp

Note
If you want to use LibreOffice features that require Java it is important that the correct 32 bit or 64 bit edition matches the installed version of LibreOffice.

How can I contribute to LibreOffice?
You can help with the development and user support of LibreOffice in many ways, and you do not need to be a programmer. To start, check out this webpage: https://www.libreoffice.org/community/get-involved/

May I distribute the PDF of this book, or print and sell copies?
Yes, as long as you meet the requirements of one of the licenses in the copyright statement at the beginning of this book. You do not have to request special permission. We request that you share with the project some of the profits you make from sales of books, in consideration of all the work we have put into producing them.

Donate to LibreOffice: https://www.libreoffice.org/donate/

What’s new in LibreOffice Calc 6.4?
The LibreOffice 6.4 Release Notes are here:
https://wiki.documentfoundation.org/ReleaseNotes/6.4
Chapter 1
Introduction

Using spreadsheets in LibreOffice
What is Calc?

Calc is the spreadsheet component of LibreOffice. You can enter data (usually numerical) in a spreadsheet and then manipulate this data to produce certain results.

Alternatively, you can enter data and then use Calc in a ‘What if...’ manner by changing some of the data and observing the results without having to retype the entire spreadsheet or sheet.

Other features provided by Calc include:

• Functions, which can be used to create formulas to perform complex calculations on data.
• Database functions to arrange, store, and filter data.
• Dynamic charts, including a wide range of 2D and 3D charts.
• Macros for recording and executing repetitive tasks; scripting languages supported include LibreOffice Basic, Python, BeanShell, and JavaScript.
• Ability to open, edit, and save Microsoft Excel spreadsheets.
• Import and export of spreadsheets in multiple formats, including HTML, CSV, PDF, and PostScript.

Note

If you want to use macros written in Microsoft Excel using the VBA macro code in LibreOffice, you must first edit the code in the LibreOffice Basic IDE editor. For more information, see Chapter 12, Macros, in this guide or Chapter 13, Getting Started with Macros, in the Getting Started Guide.

Spreadsheets, sheets, and cells

Calc works with documents called spreadsheets. Spreadsheets consist of a number of individual sheets, each sheet containing cells arranged in rows and columns. A particular cell is identified by its row number and column letter.

Cells hold the individual elements – text, numbers, formulas, and so on – that make up the data to display and manipulate.

Each spreadsheet can have up to 10,000 sheets and each sheet can have a maximum of 1,048,576 rows and 1,024 columns. The maximum number of characters in one cell is 32,767.

Calc main window

When Calc is started, the main window opens (Figure 3). The various parts of this display are explained below.

Note

If any part of the Calc window in Figure 3 is not shown, you can display it using the View menu. For example, View > Status Bar on the Menu bar will toggle (show or hide) the Status Bar. It is not always necessary to display all of the parts shown; you can show or hide any of them as desired.

Title bar

The Title bar, located at the top, shows the name of the current spreadsheet. When the spreadsheet is newly created, its name is Untitled X, where X is a number. When you save a spreadsheet for the first time, you are prompted to enter a name of your choice.
Figure 3: Calc main window

Menu bar

Under the Title bar is the Menu bar. When you choose one of the menus, a list of options appears. You can also modify the Menu bar, as explained in Chapter 14, Setting Up and Customizing.

- **File** – contains commands that apply to the entire document, such as **Open**, **Save**, Wizards, **Export as PDF**, **Print**, Digital Signatures, **Templates**.
- **Edit** – contains commands for editing the document, such as **Undo**, **Copy**, **Find & Replace**, **Track Changes**.
- **View** – contains commands for modifying how the Calc user interface looks, such as **Toolbars**, **View Headers**, **Full Screen**, **Zoom**.
- **Insert** – contains commands for inserting elements into a spreadsheet, such as **Image**, **Text Box**, **Headers and Footers**.
- **Format** – contains commands for modifying the layout of a spreadsheet, such as **Cells**, **Page**, **AutoFormat Styles**, **Align**.
- **Styles** – contains options for applying and managing styles, such as **Heading 1**, **Footnote**, **Manage Styles**.
- **Sheet** – contains commands for inserting and deleting elements and modifying the entire sheet, such as **Delete Rows**, **Insert Sheet**, **Rename Sheet**, **Navigate**.
- **Data** – contains commands for manipulating data in your spreadsheet, such as **Define Range**, **Sort**, **AutoFilter**, **Consolidate**.
- **Tools** – contains functions to help check and customize a spreadsheet, for example **Spelling**, **Share Spreadsheet**, **Macros**, **Options**.
- **Window** – contains two commands; **New Window** and **Close Window**. Also shows all open windows in other LibreOffice applications.
• **Help** – contains links to **LibreOffice Help** (included with the software), **User Guides**, and other miscellaneous functions; for example **Restart in Safe Mode, License Information, Check for Updates**.

**Toolbars**

The default setting when Calc opens is for the Standard and Formatting toolbars to be docked at the top of the workspace (Figure 3).

Calc toolbars can be either docked (fixed in place), or floating, allowing you to move a toolbar to a more convenient location on your workspace. Docked toolbars can be undocked and moved to a different docked location or become floating toolbars. Likewise, floating toolbars can be docked.

You can choose the single-toolbar alternative to the default double toolbar arrangement. It contains the most-used commands. To activate it, enable **View > Toolbars > Standard (Single Mode)** and disable **View > Toolbars > Standard** and **View > Toolbars > Formatting**.

For additional information on toolbars, see Chapter 1, Introducing LibreOffice, of the **Getting Started Guide**.

The default set of icons (sometimes called buttons) on toolbars provides a wide range of common commands and functions. You can also remove or add icons to toolbars. See Chapter 14, Setting Up and Customizing, for more information.

Placing the mouse cursor over an icon, text box, or menu command displays a small box called a tooltip that shows the name of the item’s function. To close a tooltip, click once away from the icon or press the **Esc** key.

To see a more detailed explanation of an icon, textbox, or menu command, do one of the following to open extended tips:

- To activate extended tips just once: press **Shift+F1**.
- To activate extended tips from the Menu bar: go to **Help > What’s This?** and hover the mouse pointer over an icon.
- To turn extended tips on or off: go to **Tools > Options > LibreOffice > General** on the Menu bar.

**Formula Bar**

The Formula Bar is located at the top of the Calc workspace. It is permanently docked in this position and cannot be used as a floating toolbar. However, it can be hidden or made visible by going to **View > Formula Bar** on the Menu bar.

![Figure 4: Formula Bar](image)

From left to right in Figure 4, the Formula Bar consists of the following:

- **Name Box** – gives the current active cell reference using a combination of a letter and number, for example A1. The letter indicates the column and the number indicates the row of the selected cell. If you have selected a range of cells that is also a named range, the name of the range is shown in this box. You can also type a cell reference in the Name Box to jump to the referenced cell. If you type the name of a named range and press the Enter key, the named range is selected and displayed.

- **Function Wizard** – opens a dialog from which you can search through lists of available functions and formulas. This can be very useful because it also shows how the functions are formatted.

- **Select Function** – performs a calculation on the numbers in the cells above the selected cell and then places the result in the selected cell. If there are no numbers above
the selected cell, then the calculation operates on the cells to the left. The calculation to be
performed is selected from a drop-down menu containing options for Sum, Average, Min,
Max, and Count.

- **Formula** – inserts an equals (=) sign in the selected cell and the Input line, allowing a
  formula to be entered.
- **Input line** – displays the contents of the selected cell (data, formula, or function) and allows
  you to edit the cell contents. To turn the Input line into a multiline input area for very long
  formulas, click the drop down button on the right. To edit inside the Input line area, click in
  the area, then type your changes.

You can also directly edit inside the cell by double-clicking on the cell. When you enter new data
into a cell, the **Select Function** and **Formula** icons change to **Cancel** and **Accept** icons.

**Note**

In a spreadsheet, the term “function” covers much more than just mathematical
functions. See Chapter 7, Using Formulas and Functions, for more information.

**Status Bar**

The Calc Status Bar at the bottom of the workspace (Figure 5) provides information about the
spreadsheet and convenient ways to quickly change some of its features. Most of the fields are
similar to those in other components of LibreOffice. See Chapter 1, Introducing LibreOffice, in the
Getting Started Guide for more information.

![Figure 5: Calc Status Bar](image)

The fields on the Status Bar, from left to right, are as follows.

**Sheet number**

Shows the sequence number of the current sheet and the total number of sheets in the
spreadsheet. The sequence number may not be the same as the name on the sheet tab if
sheets have been moved. Double-click on this zone to open the Navigator.

**Number of selected rows and columns**

Shows how many rows and how many columns are selected.

**Page style**

Shows the page style of the current sheet. To edit the page style, double-click on this field
and the Page Style dialog opens.

**Language**

Shows current default language as selected at **Tools > Options > Language Settings >
Languages**.

**Insert / overwrite mode**

This field is blank if the program is in insert mode. Press the Ins key to change modes.
Overwrite shows when in overwrite mode.

**Selection mode**

Right-click to open a context menu and select **Standard selection**, **Extending selection**, or
**Adding selection**. The icon does not change when different selection modes are selected,
but the tooltip shows the current status. See Chapter 1, Introducing LibreOffice, in the
Getting Started Guide for more information.

Unsaved changes
This icon indicates the spreadsheet contains unsaved changes. Click this icon or use File >
Save to save the spreadsheet.

Digital signature
If the document has been digitally signed, an icon shows here. You can double-click the icon
to view the certificate. See Chapter 6, Printing, Exporting, E-mailing, and Signing for more
information about digital signatures.

Cell or object information
Displays information related to the position of the cursor or the selected element of the
spreadsheet. When a group of cells is selected, the sum of the contents is displayed by
default. Right-click in this field to select other functions, such as the average value, maximum
value, minimum value, or count (number of items selected).

Zoom slider
Drag the zoom slider, or click the + and – signs to change the view magnification.

Zoom percentage
Indicates the magnification level of the document. Right-click on the percentage to open a list
of magnification values from which to choose. Double-click on the percentage to open the
Zoom & View Layout dialog.

Sidebar
The Calc Sidebar (Figure 6) is a mixture of toolbar and dialog. When opened (View > Sidebar or
Ctrl+F5), it appears on the right side of the window and consists of five decks: Properties, Styles,
Gallery, Navigator, and Functions. Each deck has a corresponding icon on the Tab panel to the
right of the sidebar, allowing you to switch between them. The decks are described below.

Properties
This deck includes five content panels. These panels, with the exception of the Style panel,
have More Options buttons that open dialogs with additional options. These dialogs lock the
document for editing until they are closed.

Style: Options for applying, updating, or creating cell and page styles.

Character: Options for formatting the text, such as font family, size, and color. Some
controls, such as superscript, only become active when the text cursor is active in the Input
line of the Formula bar or the cell.

Number Format: Options for formatting numbers, including decimals, currency, dates, or
numeric text.

Alignment: Options for arranging the text in various ways, including horizontal and vertical
alignment, wrapping, indenting, merging, text orientation, and vertical stacking.

Cell Appearance: Options include background color, border formats including line color and
style, and grid lines.

Styles
This deck is the same as the dialog opened by selecting Styles > Manage Styles from the
Menu bar or F11.

Gallery
This deck is the same as the dialog opened by selecting View > Gallery from the Menu bar.

Navigator
This deck is the same as the Navigator window opened by selecting View > Navigator from
the Menu bar or F5. See “Using the Navigator” on page 36.
Functions
This deck contains a list of functions organized by category. It is a simpler version of the Function Wizard, which is opened by selecting Insert > Function on the Menu bar or Ctrl+F2.

To the right side of the title bar of each open deck is a Close button (X), which closes the deck to leave only the Tab bar open. Clicking on any Tab button reopens the deck.

To hide the Sidebar, or reveal it if already hidden, click on the left edge Hide/Show button. To adjust the deck width, drag on the left edge of the Sidebar.

Spreadsheet layout

Individual cells
The main section of the screen displays the cells in the form of a grid, with each cell located at the intersection of a column and a row.

At the tops of the columns and the left ends of the rows are a series of header boxes containing letters and numbers. The column headers use alpha characters that start with A and increase to the right. The row headers use numerical characters that start at 1 and increase down.

These column and row headers form the cell references that appear in the Name Box on the Formula Bar (Figure 4). If the headers are not visible on the spreadsheet, go to View > Headers on the Menu bar.
**Sheet tabs**

A spreadsheet file can contain many individual sheets. At the bottom of the grid of cells in a spreadsheet are sheet tabs (Figure 3). Each tab represents a sheet in a spreadsheet. Create a new sheet by clicking on the plus sign to the left of the sheet tabs.

Clicking on a tab enables access to an individual sheet. When a sheet is active, the tab is highlighted. Select multiple sheets by holding down the Ctrl key while clicking on the sheet tabs.

To change the default name for a sheet (Sheet1, Sheet2, and so on):

1) Right-click on the sheet tab and select **Rename Sheet** from the context menu. A dialog opens allowing you to type in a new name for the sheet.
2) Click **OK** when finished to close the dialog.

To change the color of a sheet tab:

1) Right-click on the sheet tab and select **Tab Color** from the context menu to open the Tab Color dialog (Figure 7).
2) Select a color and click **OK** when finished to close the dialog.

![Figure 7: Tab Color dialog](image)

To add new colors to this color palette, see “Adding Custom colors” in Chapter 14, Setting up and Customizing.

**Creating, opening, and saving spreadsheets**

**Creating and opening**

Creating and opening spreadsheets is identical to creating and opening documents in the other LibreOffice modules. For more information on creating and opening spreadsheets, see Chapter 1, Introducing LibreOffice, in the *Getting Started Guide*.

**Using templates**

Calc documents can also be created from templates. For information on how to create and use templates, see Chapter 4, Using Styles and Templates, in this guide.

**Opening a CSV file**

Comma-separated values (CSV) files are spreadsheet files in a text format where cell contents are separated by a character such as a comma or semi-colon. Each line in a CSV text file represents a
row in a spreadsheet. Text is entered between quotation marks; numbers are entered without quotation marks.

To open a CSV file in Calc:

1) Choose File > Open on the Menu bar and locate the CSV file that you want to open.
2) Select the file and click Open. By default, a CSV file has the extension .csv. However, some CSV files may have a .txt extension.
3) The Text Import dialog (Figure 8) opens. Here you can select options for importing a CSV file into a Calc spreadsheet.
4) Click OK to open and import the file.

![Text import dialog](Figure 8)

The options for importing CSV files into a Calc spreadsheet are as follows:

**Import**
- **Character set** – specifies the character set to be used in the imported file.
- **Language** – determines how the number strings are imported. If Language is set to Default, Calc will use the language selected at Tools > Options > Language Settings > Languages > Default Languages for Document. If another language is selected, that language will determine how numbers are treated.
- **From row** – specifies which row the import starts with. The initial rows are visible in the preview window at the bottom of the dialog.

**Separator Options**
- **Fixed width** – separates data into columns by a set number of characters. Click on the ruler that appears in the preview window to set the width.
- **Separated by** – separates data into columns based on the separator defined here. Select **Other** to specify another character used to separate data into columns. This custom separator must also be contained in the data.
- **Merge delimiters** – combines consecutive delimiters and removes blank data fields.
• **Trim spaces** – removes starting and trailing spaces from within fields.
• **String delimiter** – select a character to delimit text data.

**Other options**

• **Format quoted field as text** – when this option is enabled, fields or cells whose values are entirely within quotes are imported as text.
• **Detect special numbers** – when this option is enabled, Calc will automatically detect all number formats, including special number formats such as dates, time, and scientific notation. The selected language influences how such special numbers are detected, since different languages and regions many have different conventions for such special numbers. When this option is disabled, Calc will detect and convert only decimal numbers. The rest, including numbers formatted in scientific notation, will be imported as text. A decimal number string can have digits 0–9, thousands separators, and a decimal separator. Thousands separators and decimal separators may vary with the selected language and region.

**Fields** – shows how your data will look when it is separated into columns.

**Column type** – select a column in the preview window and select the data type to be applied to the imported data.

– **Standard** – Calc determines the type of data.
– **Text** – imported data are treated as text.
– **Date** – imported data are treated as dates.
– **US English** – numbers formatted in US English are searched for and included regardless of the system language. A number format is not applied. If there are no US English entries, the Standard format is applied.
– **Hide** – the data in the column are not imported.

**Saving spreadsheets**

For information on how to save files manually or automatically, see Chapter 1, Introducing LibreOffice, in the *Getting Started Guide*. Calc can save spreadsheets in a range of formats and also export spreadsheets to PDF, HTML and XHTML file formats; see Chapter 6 Printing, Exporting, Emailing, and Signing, for more information.

**Saving in other formats**

If you need to send files to users who are unable to receive spreadsheet files in Open Document Format (ODF) (*.ods), which Calc uses as default format, you can save a spreadsheet in another format.

1) Select **File > Save As** on the Menu bar or **Ctrl+Shift+S** to open the Save As dialog (Figure 9).
2) In **File name**, if you wish, enter a new file name for the spreadsheet and select the folder where you want to save the file.
3) In the **Save as type** field, select from the drop-down menu the type of spreadsheet format you want to use. If **Automatic file name extension** is selected, the correct file extension for the spreadsheet format you have selected will be added to the file name.
4) Click **Save**.
Each time a file is saved in a format other than ODF format, the Confirm File Format dialog opens (Figure 10). Click **Use [xxx] Format** to continue saving in the selected spreadsheet format or click **Use ODF Format** to save the spreadsheet in Calc ODS format. If you disable **Warn when not saving in ODF or default format** on **Tools > Options > Load/Save > General** on the Menu bar, the Confirm File Format dialog will no longer appear. You can also clear the checkbox **Ask when not saving in ODF or default format** on the dialog to stop the dialog appearing.

If you select Text CSV format (*.csv), the Export Text File dialog (Figure 11) opens. Here you can select the character set, field delimiter, text delimiter and so on to be used for the CSV file.

---

**Note**

Once you have saved a spreadsheet in another format, all changes you make to the spreadsheet will now occur only in the format you are using because you have changed the name and file type of your document. If you want to go back to working with an *.ods version, you must save the file as an *.ods file.

---

**Tip**

To have Calc save documents by default in a file format other than the default ODF format, go to **Tools > Options > Load/Save > General**. In the section named **Default File Format and ODF Settings**, next to **Document type**, select **Spreadsheet**, then next to **Always save as**, select your preferred file format, for example Microsoft Excel.
Password protection

To protect a spreadsheet and restrict who can open, read, and make changes to it, you have to use password protection. Password protection is common to all LibreOffice modules; for more information, see Chapter 1, Introducing LibreOffice, in the Getting Started Guide.

Navigating within spreadsheets

Calc provides many ways to navigate within a spreadsheet from cell to cell and sheet to sheet. You can generally use the method you prefer.

Cell navigation

When a cell is selected or in focus, the cell borders are emphasized. When a group of cells is selected, the cell area is colored. The color of the cell border emphasis and the color of a group of selected cells depends on the operating system being used and how you have set up LibreOffice.

- Using the mouse – place the mouse pointer over the cell and click the left mouse button. To move the focus to another cell using the mouse, move the mouse pointer to the cell and click the left mouse button.
- Using a cell reference – select or delete the existing cell reference in the Name Box on the Formula Bar (Figure 4 on page 17). Type the new cell reference of the cell you want to move to and press the Enter key. Cell references are case insensitive. Thus, typing a3 or A3 will move the focus to cell A3.
- Using the Navigator – go to View > Navigator or press the F5 key to open the Navigator dialog (Figure 12). Type the cell references into the Column and Row fields and press the Enter key.
- Using the Enter key – pressing Enter moves the cell focus down one cell (by default). You can change the direction of this focus movement as described in the “Customizing the Enter key” section on page 28.
- Pressing Shift+Enter moves the focus up one cell.
- Using the Tab key – pressing Tab moves the cell focus one cell to the right. Pressing Shift+Tab moves the focus one cell to the left.
- Using the arrow keys – pressing the arrow keys on the keyboard moves the cell focus in the direction of the arrow pressed.
Using Home, End, Page Up, and Page Down

- **Home** moves the cell focus to the start of a row. **Ctrl+Home** moves the cell focus to the first cell in the sheet, A1.
- **End** moves the cell focus to the last cell in the same row that contains data. **Ctrl+End** moves the cell focus to the last cell in the sheet that contains data.
- **Page Down** moves the cell focus down one complete screen display.
- **Page Up** moves the cell focus up one complete screen display.

### Sheet navigation

Each sheet in a spreadsheet is independent of the other sheets, though references can be linked from one sheet to another. There are three ways to navigate between different sheets in a spreadsheet.

- Using the Navigator – when the Navigator is open (Figure 12), double-clicking on any of the listed sheets selects the sheet.
- Using the keyboard – using key combinations **Ctrl+Page Down** moves one sheet to the right and **Ctrl+Page Up** moves one sheet to the left.
- Using the mouse – clicking on one of the sheet tabs at the bottom of the spreadsheet selects that sheet.

If there are many sheets in the spreadsheet, some of the sheet tabs may be hidden. If this is the case, use the four buttons to the left of the sheet tabs to move the tabs into view (Figure 13).

Note

The sheet tab arrows that appear on the left in Figure 13 are only active if there are more sheet tabs than can be displayed.
Note

When you insert a new sheet into a spreadsheet, Calc automatically uses the next number in the numeric sequence as a name. Depending on which sheet is open when you insert a new sheet, your new sheet may not be in numerical order. It is recommended to rename sheets in a spreadsheet to make them more recognizable.

Keyboard navigation

You can navigate a spreadsheet using the keyboard, by pressing a key or a combination of keys at the same time. For example, Ctrl+Home moves the focus to cell A1. Table 1 lists the keys and key combinations you can use for spreadsheet navigation in Calc.

Table 1. Keyboard cell navigation

<table>
<thead>
<tr>
<th>Keyboard shortcut</th>
<th>Cell navigation</th>
</tr>
</thead>
<tbody>
<tr>
<td>→/←</td>
<td>Moves cell focus right/left one cell.</td>
</tr>
<tr>
<td>↑/↓</td>
<td>Moves cell focus up/down one cell.</td>
</tr>
<tr>
<td>Ctrl+→ / Ctrl←</td>
<td>If focus is on a blank cell, moves focus to the first cell on the right/left that contains data.</td>
</tr>
<tr>
<td></td>
<td>If focus is on a cell containing data, moves focus to the last/first cell on the right/left containing data.</td>
</tr>
<tr>
<td></td>
<td>If there are no more cells containing data, moves focus to the last/first cell on the right/left in the spreadsheet.</td>
</tr>
<tr>
<td>Ctrl+↑ / Ctrl↓</td>
<td>If focus is on a blank cell, moves focus to the first cell above/below that contains data.</td>
</tr>
<tr>
<td></td>
<td>If focus is on a cell containing data, moves focus to the cell in Row 1/last cell containing data in the same column.</td>
</tr>
<tr>
<td></td>
<td>If there are no more cells below containing data in that column, moves focus to the cell in the same column in the last row of the spreadsheet.</td>
</tr>
<tr>
<td>Ctrl+Home / Ctrl+End</td>
<td>Moves focus from anywhere on the spreadsheet to Cell A1/the last cell in the lower right-hand corner of the rectangular area of cells containing data on the same sheet.</td>
</tr>
<tr>
<td>Alt+Page Down / Alt+Page Up</td>
<td>Moves focus one screen to the right/left (if possible).</td>
</tr>
<tr>
<td>Ctrl+Page Down / Ctrl+Page Up</td>
<td>Moves focus to the same cell on the next sheet to the right/left in sheet tabs if there are more sheets in that direction.</td>
</tr>
</tbody>
</table>
### Keyboard shortcut

<table>
<thead>
<tr>
<th>Keyboard shortcut</th>
<th>Cell navigation</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tab / Shift+Tab</td>
<td>Moves focus to the next cell on the right/left.</td>
</tr>
<tr>
<td>Enter/ Shift+Enter</td>
<td>Moves focus down/up one cell (unless changed by user).</td>
</tr>
</tbody>
</table>

### Customizing the Enter key

You can choose the direction in which the Enter key moves the cell focus by going to Tools > Options > LibreOffice Calc > General. Use the first two options under Input settings (Figure 14) to change the Enter key settings. Select the direction cell focus moves from the drop-down list. Depending on the file being used or the type of data being entered, setting a different direction can be useful. The Enter key can also be used to switch into and out of editing mode.

![Figure 14: Customizing the Enter key](image)

### Selecting items in a spreadsheet

#### Selecting cells

**Single cell**

Left-click in the cell. You can verify the selection by looking in the Name Box on the Formula Bar (Figure 4).

**Range of contiguous cells**

A range of cells can be selected using the keyboard or the mouse.

To select a range of cells by dragging the mouse cursor:

1) Click in a cell.
2) Press and hold down the left mouse button.
3) Move the mouse around the screen.
4) Once the desired block of cells is highlighted, release the left mouse button.

To select a range of cells without dragging the mouse:

1) Click in the cell which is to be one corner of the range of cells.
2) Move the mouse to the opposite corner of the range of cells.
3) Hold down the Shift key and click.

To select a range of cells using Extending selection mode:

1) Click in the cell which is to be one corner of the range of cells.
2) Right-click in the Selection mode field on the Status Bar (Figure 5 on page 18) and select **Extending selection**.

3) Click in the cell in the opposite corner of the range of cells.

**Tip**

Make sure to change back to *Standard selection* or you may find yourself extending a cell selection unintentionally.

To select a range of cells without using the mouse:

1) Select the cell that will be one of the corners in the range of cells.
2) While holding down the *Shift* key, use the cursor arrows to select the rest of the range.

To select a range of cells using the Name Box:

1) Click in the Name Box on the Formula Bar (Figure 4 on page 17).
2) Enter the cell reference for the upper left-hand cell, followed by a colon (:), and then the lower right-hand cell reference, then press the Enter key. For example, to select the range that would go from A3 to C6, enter A3:C6.

**Range of non-contiguous cells**

To select a range of non-contiguous cells using the mouse:

1) Select the first cell or range of cells using one of the methods above.
2) Move the mouse pointer to the start of the next range or single cell.
3) Hold down the *Ctrl* key and click or click-and-drag to select another range of cells to add to the first range.
4) Repeat as necessary.

To select a range of cells using **Adding selection** mode:

1) Click in the cell which is to be one corner of the range of cells.
2) Right-click in the **Selection mode** field on the Status Bar (Figure 5 on page 18) and select **Extending selection** before clicking in the opposite corner of the range of cells.

**Selecting columns and rows**

**Single column or row**

To select a single column, click on the column header (Figure 3 on page 16). To select a single row, click on the row header.

**Multiple columns or rows**

To select multiple columns or rows that are contiguous:

1) Click on the first column or row in the group.
2) Hold down the *Shift* key.
3) Click the last column or row in the group.

To select multiple columns or rows that are not contiguous:

1) Click on the first column or row in the group.
2) Hold down the *Ctrl* key.
3) Click on all of the subsequent columns or rows while holding down the *Ctrl* key.
Entire sheet
To select the entire sheet, click on the small box between the column headers and the row headers (Figure 15), or use the key combination Ctrl+A to select the entire sheet, or go to Edit on the Menu bar and select Select All.

Selecting sheets
You can select either one or multiple sheets in Calc. It can be advantageous to select multiple sheets, especially when you want to make changes to many sheets at once.

Single sheet
Click on the sheet tab for the sheet you want to select. The tab for the selected sheet becomes white (default Calc setup) or is otherwise highlighted.

Multiple contiguous sheets
To select multiple contiguous sheets:
1) Click on the sheet tab for the first desired sheet.
2) While holding down the Shift key, click on the sheet tab for the last desired sheet.
3) All tabs between these two selections will turn white (default Calc setup). Any actions that you perform will now affect all highlighted sheets.

Multiple non-contiguous sheets
To select multiple non-contiguous sheets:
1) Click on the sheet tab for the first desired sheet.
2) While holding down the Ctrl key, click on the sheet tabs for other desired sheets.
3) The selected tabs will turn white (default Calc setup). Any actions that you perform will now affect all highlighted sheets.

All sheets
Right-click a sheet tab and choose Select All Sheets from the context menu.

Working with columns and rows

Inserting columns and rows
When you insert columns or rows, the cells take the formatting of the corresponding cells in the column to the left or the row above.

Single column or row
Using the Sheet menu:
1) Select a cell, column, or row where you want the new column or row inserted.
2) Go to Sheet on the Menu bar. For columns, select Sheet > Insert Columns and then select Columns Before or Columns After. For rows, select Sheet > Insert Rows and then select Rows Above or Rows Below.
Using the context menu:

1) Select a column or row where you want the new column or row inserted.
2) Right-click the column or row header.
3) Select **Insert Columns Before / After** or **Insert Rows Above / Below** from the context menu.

**Multiple columns or rows**

Multiple columns or rows can be inserted at once rather than inserting them one at a time.

1) Highlight the required number of columns or rows by holding down the left mouse button on the first one and then dragging across the required number of identifiers.
2) Proceed as for inserting a single column or row above. The number of columns or rows highlighted will be inserted.

**Deleting columns and rows**

**Single column or row**

To delete a single column or row, do one of the following:

- Select a cell in the column or row you want to delete, right-click and select **Delete** in the context menu to open the Delete Cells dialog (Figure 16). Select **Delete entire column(s)** or **Delete entire row(s)** and press the **OK** button.
- Select a cell in the column or row you want to delete and select **Sheet > Delete Columns** or **Sheet > Delete Rows**.
- Right-click the header of the column or row that you want to delete and select **Delete Columns** or **Delete Rows** from the context menu.

**Multiple columns or rows**

To delete multiple columns or rows, do one of the following:

- Select a range of cells across the columns or rows you want to delete, right-click and select **Delete** in the context menu to open the Delete Cells dialog. Select **Delete entire column(s)** or **Delete entire row(s)** and press the **OK** button.
- Select a range of cells across the columns or rows you want to delete and select **Sheet > Delete Columns** or **Sheet > Delete Rows**.
- Highlight the required columns or rows by holding down the left mouse button on the header of the first one and then dragging across the required number of headers. Then right-click on one of the selected column or row headers and select **Delete Columns** or **Delete Rows** from the context menu.

**Deleting cells**

1) Select the cell or cells you want to delete.
2) Select **Sheet > Delete Cells**, or right-click on one of the selected cells and select **Delete** from the context menu.
3) Select the option you require from the Delete Cells dialog and press the **OK** button.
Working with sheets

Inserting new sheets

Click on the Add Sheet icon next to the sheet tabs to insert a new sheet after the last sheet in the spreadsheet without opening the Insert Sheet dialog. The following methods open the Insert Sheet dialog (Figure 17) where you can position the new sheet, create more than one sheet, name the new sheet, or select a sheet from a file.

- Select the sheet where you want to insert a new sheet, then go to Sheet > Insert Sheet on the Menu bar or click Alt+S+S.
- Right-click on the sheet tab where you want to insert a new sheet and select Insert Sheet from the context menu.
- Click in the empty space at the end of the sheet tabs.
- Right-click in the empty space at the end of the sheet tabs and select Insert Sheet from the context menu.

Moving and copying sheets

You can move or copy sheets within the same spreadsheet by dragging and dropping or using the Move/Copy Sheet dialog (Figure 18). To move or copy a sheet into a different spreadsheet, use the Move/Copy Sheet dialog.
**Dragging and dropping**

To move a sheet to a different position within the same spreadsheet, click on the sheet tab and drag it to its new position before releasing the mouse button.

To copy a sheet within the same spreadsheet, hold down the Ctrl key (Option key on Mac) then click on the sheet tab and drag it to its new position before releasing the mouse button. The mouse pointer may change to include a plus sign depending on the setup of your operating system.

**Using Move/Copy Sheet dialog**

The Move/Copy Sheet dialog allows you to specify exactly whether you want the sheet in the same or a different spreadsheet, its position within the spreadsheet, and the sheet name when it is moved or copied.

![Move/Copy Sheet dialog](image)

**Figure 18: Move/Copy Sheet dialog**

1) In the current document, right-click on the sheet tab you wish to move or copy and select **Move or Copy Sheet** from the context menu or go to **Sheet > Move or Copy Sheet** on the Menu bar.

2) Select **Move** to move the sheet or **Copy** to copy the sheet.

3) Select the spreadsheet where you want the sheet to be placed from the drop-down list in **To document**. This can be the same spreadsheet, another spreadsheet already open, or you can create a new spreadsheet.

4) Select the position in **Insert before** where you want to place the sheet.

5) Type a name in the **New name** text box if you want to rename the sheet when it is moved or copied. If you do not enter a name, Calc creates a default name (Sheet 2, Sheet 3, and so on).

6) Click **OK** to confirm the move or copy and close the dialog.

**Warning**

When you move or copy to another spreadsheet or to a new one, a conflict may occur if formulas are linked to sheets in the previous location.
**Deleting sheets**

To delete a single sheet, right-click on the sheet tab you want to delete and select **Delete Sheet** from the context menu, or go to **Sheet > Delete Sheet** on the Menu bar. Click **Yes** to confirm the deletion.

To delete multiple sheets, select the sheets (see “Selecting sheets” on page 30), then right-click one of the sheet tabs and select **Delete Sheet** from the context menu, or go to **Sheet > Delete Sheet** on the Menu bar. Click **Yes** to confirm the deletion.

**Renaming sheets**

By default, the name for each new sheet added is SheetX, where X is the number of the next sheet to be added. While this works for a spreadsheet with only a few sheets, it can become difficult to identify sheets when a spreadsheet contains many sheets.

You can rename a sheet using one of the following methods:

- Enter the name in the **Name** text box when you create the sheet using the Insert Sheet dialog (Figure 17 on page 32).
- Right-click on a sheet tab and select **Rename Sheet** from the context menu to replace the existing name with a different one.
- Double-click on a sheet tab to open the Rename Sheet dialog.

![Note](image)

Sheet names must start with either a letter or a number. Other characters, including spaces, are not allowed. Apart from the first character of the sheet name, permitted characters are letters, numbers, spaces, and the underscore character. Attempting to rename a sheet with an invalid name will produce an error message.

**Viewing Calc**

**Changing document view**

Use the zoom function to show more or fewer cells in the window when you are working on a spreadsheet. For more about zoom, see Chapter 1, Introducing LibreOffice, in the *Getting Started Guide*.

**Freezing rows and columns**

Freezing is used to lock rows across the top of a spreadsheet or to lock columns on the left of a spreadsheet. Then, when moving around within a sheet, the cells in frozen rows and columns always remain in view.

Figure 19 shows some frozen rows and columns. The heavier horizontal line between rows 3 and 23 and the heavier vertical line between columns F and Q indicate that rows 1 to 3 and columns A to F are frozen. The rows between 3 and 23 and the columns between F and Q have been scrolled off the page. To freeze rows or columns:

1) Click on the row header below the rows you want the freeze or click on the column header to the right of the columns where you want the freeze. To freeze both rows and columns, select the cell (not a row or column) that is below the row and to the right of the column that you want to freeze.

2) Go to **View** on the Menu bar and select **Freeze Rows and Columns**. Shortcut: Alt V+R. A heavier line appears between the rows or columns indicating where the freeze has been place.
Unfreezing
To unfreeze rows or columns, go to View on the Menu bar and click Freeze Rows and Columns to toggle it off. The heavier lines indicating freezing will disappear.

Splitting the screen
Another way to change the view is by splitting the screen displayed (also known as splitting the window). The screen can be split horizontally, vertically, or both, displaying up to four portions of the spreadsheet at the same time. An example of splitting the screen is shown in Figure 20 where a split is indicated by a gray line.

This could be useful for example, when a large spreadsheet has one cell with a number that is used by three formulas in other cells. Using the split-screen technique, the cell containing the number can be positioned in one section of the view and the cells with formulas can be seen in the other sections. This makes it easy to see how changing the number in one cell affects each of the formulas.

Splitting horizontally or vertically
There are two ways to split a screen horizontally or vertically:

Method One:
1) Click on the row header below the rows where you want to split the screen horizontally or click on the column header to the right of the columns where you want to split the screen vertically.
2) Go to View on the Menu bar and select Split Window. A thick line appears between the rows or columns indicating where the split has been placed. An example of a split line is shown below Row 2 in Figure 20.

Method Two:
For a horizontal split, click on the thick black line at the top of the vertical scroll bar (Figure 21) and drag the split line below the row where you want the horizontal split positioned.

Similarly, for a vertical split, click on the thick black line at the right of the horizontal scroll bar (Figure 21) and drag the split line to the right of the column where you want the vertical split positioned.
**Splitting both horizontally and vertically**

**Method One:**
Position both the black horizontal and the black vertical lines as described above and as shown in Figure 21.

**Method Two:**
1) Click the cell that is immediately below the rows where you want to split the screen horizontally and immediately to the right of the columns where you want to split the screen vertically.
2) Go to View on the Menu bar and select Split Window. Thick lines appear between the rows and columns indicating where the splits have been placed.

**Removing split views**
To remove a split view, do any of the following:
- Double-click on each split line.
- Click on and drag the split lines back to their places at the ends of the scroll bars.
- Go to View on the Menu bar and click Split Window to toggle it off.

**Using the Navigator**
The Navigator (Figure 22) is available in all LibreOffice modules. It provides tools and methods to move quickly through a spreadsheet and find specific items.

The Navigator categorizes and groups spreadsheet objects which you can click on to move quickly to that object. If an indicator (plus sign or triangle, dependent on computer setup) appears next to a category, at least one object in this category exists. To open a category and see the list of items,
click on the indicator. When a category is showing the list of objects in it, double-click on an object to jump directly to that object's location in the spreadsheet.

To open the Navigator, do one of the following:

- Press the F5 key.
- Go to View > Navigator on the Menu bar.
- Click the Navigator icon in the Sidebar.

By default, the Navigator opens in the Sidebar.

The controls and tools available in the Navigator are as follows:

- **Column** – type a column letter and press the Enter key to reposition the cell cursor to the specified column in the same row.
- **Row** – type a row number and press the Enter key to reposition the cell cursor to the specified row in the same column.
- **Data Range** – specifies the current data range denoted by the position of the cell cursor.
- **Start** – moves the cursor to the cell at the beginning of the current data range, which you can highlight using the Data Range icon.
- **End** – moves the cursor to the cell at the end of the current data range, which you can highlight using the Data Range icon.
- **Toggle** – toggles the contents view. Only the selected category and its objects are displayed. Click the icon again to restore all elements for viewing.
- **Scenarios** – displays all available scenarios. See Chapter 9, Data Analysis, for more information about scenarios. Double-click a name to apply that scenario and the result is shown in the sheet. If the Navigator displays scenarios, you can access the following commands when you right-click a scenario entry:
  - **Delete** – deletes the selected scenario.
  - **Properties** – opens the Edit scenario dialog, where you can edit the scenario properties.
- **Drag Mode** – opens a submenu for selecting which action is performed when dragging and dropping an object from the Navigator into a document. Depending on the mode you select, the icon indicates whether a hyperlink, a link, or a copy is created.
  - **Insert as Hyperlink** – hyperlinks the entire item.
  - **Insert as Link** – links the copied item to the original item so that when the original item is changed, that change will be reflected in the current document.
  - **Insert as Copy** – inserts a copy of the selected item.

Tip

Ranges, scenarios, pictures, and other objects are much easier to find if you have given them informative names when creating them, instead of keeping the default Calc names, for example Scenario 1, Image 1, Image 2, Object 1, and so on. These default names may not correspond to the position of the object in the document.
Using document properties

To open the Properties dialog for a document, go to File > Properties on the Menu bar. The Properties dialog provides information about the spreadsheet and allows you to set some of its properties. The dialog is shown in Figure 23 and its tabs are described below.

**Figure 23: Properties dialog, General tab**

### General
Contains basic information about the current file.

- The text box at the top of the dialog displays the file name.
- **Change Password** – opens a dialog to change the password. It is only active if a password has been set for the file.
- **Type** – displays the file type of the current document.
- **Location** – displays the path and the name of the directory where the file is stored.
- **Size** – displays the size of the current document in bytes.
- **Created** – displays the date, time, and author when the file was first saved.
- **Modified** – displays the date, time, and author when the file was last saved in a LibreOffice file format.
- **Template** – displays the template that was used to create the file.
- **Digitally signed** – displays the date and time when the file was last signed as well as the name of the author who signed the document.
• **Digital Signatures** – opens the Digital Signatures dialog where you can manage digital signatures for the current document.
• **Last printed** – displays the date, time, and user name when the file was last printed.
• **Total editing time** – displays the amount of time that the file has been open for editing since the file was created. The editing time is updated when you save the file.
• **Revision number** – displays the number of times that the file has been saved.
• **Apply user data** – saves the full name of the user with the file. You can edit the name by going to **Tools > Options > LibreOffice > User Data** on the Menu bar.
• **Save preview image with this document** – saves a thumbnail.png inside the document. These images may be used by a file manager under certain conditions.
• **Reset Properties** – resets the editing time to zero, the creation date to the current date and time, and the version number to 1. The modification and printing dates are also deleted.

**Description**
Contains optional editable descriptive information about the spreadsheet.

• **Title** – enter a title for the spreadsheet.
• **Subject** – enter a subject for the spreadsheet. You can use a subject to group documents with similar contents.
• **Keywords** – enter the words that you want to use to index the content of the spreadsheet. Keywords must be separated by commas. A keyword can contain white space characters or semicolons.
• **Comments** – enter comments to help identify the spreadsheet.

**Custom Properties**
Use this page to assign custom information fields to the spreadsheet. In a new spreadsheet, this page may be blank. If the new spreadsheet is based on a template, this page may contain fields. You can change the name, type, and contents of each row. The information in the fields will be exported as metadata to other file formats.

Click **Add Property** to add a new custom property. Click **Reset** to delete all custom properties.

**CMIS Properties**
Used for spreadsheets stored on remote servers. See the Help or the **Getting Started Guide** for more information.

**Security**
Enables two password-protected security options.

• **Open file read-only** – select to allow this document to be opened only in read-only mode. This file sharing option protects the document against accidental changes. It is still possible to edit a copy of the document and save that copy with the same name as the original.
• **Record changes** – select to require that all changes be recorded. To protect the recording state with a password, click **Protect** and enter a password. This is similar to **Edit > Track Changes > Record** on the Menu bar. However, while other users of this document can apply their changes, they cannot disable change recording without knowing the password.
• **Protect** or **Unprotect** – protects the change recording state with a password. If change recording is protected for the current document, the button is named **Unprotect**. Click **Unprotect** and type the correct password to disable the protection.
Font
When Embed fonts in the document is selected, any fonts used in the spreadsheet will be embedded into the document when it is saved. This may be useful if you are creating a PDF of the spreadsheet and want to control how it will look on other computer systems.

Only embed fonts that are used in documents – If fonts have been defined for the spreadsheet (for example, in the template), but have not been used, select this option to not embed them.

Font scripts to embed – You can choose which types of fonts are embedded: Latin, Asian, Complex. See the Getting Started Guide for more information.

Statistics
Displays statistics for the current file: the number of sheets, cells, pages, and formula groups.
Calc Guide

Chapter 2
Entering, Editing, and Formatting Data
Introduction

You can enter data into Calc in several ways: using the keyboard, dragging and dropping, the Fill tool, and selection lists. Calc also provides the ability to enter data into multiple sheets of the same spreadsheet at the same time. After entering data, you can format and display it in various ways.

Entering data

Most data entry in Calc can be done using the keyboard.

Numbers

Click in the cell and type the number using the number keys on either the main keyboard or the numeric keypad.

Negative numbers

To enter a negative number, either type a minus (–) sign in front of the number or enclose the number in parentheses (()), for example (1234). The result for both methods of entry is the same; for example, −1234.

Leading zeroes

If a number is entered with leading zeroes, for example 01481, by default Calc will automatically drop the leading zero. To retain a minimum number of characters in a cell when entering numbers and retain the number format, for example 1234 and 0012, use this method to add leading zeroes:

1) With the cell selected, right-click on the cell and select Format Cells from the context menu, or go to Format > Cells on the Menu bar, or use the keyboard shortcut Ctrl+1 to open the Format Cells dialog (Figure 24).

2) Make sure the Numbers tab is selected, then select Number in the Category list.

3) In Options > Leading zeroes, enter the minimum number of characters required. For example, for four characters, enter 4. Any number less than four characters will then have leading zeroes added, for example 12 becomes 0012.

4) Click OK. The number entered retains its number format and any formula used in the spreadsheet will treat the entry as a number in formula functions.

Tip

To format numbers with only decimal places, but without a leading zero, follow steps 1 and 2 above, then in the Format code box type a . (period or full stop) followed by ? (question marks) to represent the number of decimal places required. For example, for 3 decimal places, type .??? and click OK. Any number with only decimal places will then have no leading zero, for example 0.01856 becomes .019.
Numbers can also be converted into text as follows:

1) With the cell selected, open the Format Cells dialog (Figure 24).
2) Make sure the Numbers tab is selected, then select Text from the Category list.
3) Click OK. The number is converted to text and, by default, is left-aligned. You can change the formatting and alignment of any text numbers just as you would with normal text.

Text

Click in a cell and type the text. The text is left-aligned by default. Cells can contain several lines of text. If you want to use paragraphs, press Ctrl+Enter to create another paragraph.

On the Formula Bar, you can extend the Input line if you are entering several lines of text. Click on the Expand Formula Bar icon located on the right of the Formula Bar and the Input line becomes multi-line, as shown in Figure 25. Click the Expand Formula Bar icon again to return to a single input line.
Date and time

Select the cell and type the date or time. You can separate the date elements with a slash (/) or a hyphen (–) or use text, for example 10 Oct 2012. The date format automatically changes to the selected format used by Calc.

**Note**

Tools > Options > Language Settings > Languages > Language Of > Date acceptance patterns defines the date patterns that will be recognized by Calc. In addition, every locale accepts input in an ISO 8601 Y-M-D pattern.

When you enter a time, separate time elements with colons, for example 10:43:45. The time format automatically changes to the selected format used by Calc.

To change the date or time format used by Calc:

1) With the cell selected, open the Format Cells dialog (Figure 24).
2) Make sure the **Numbers** tab is selected, then select **Date** or **Time** from the **Category** list.
3) Select the date or time format you want to use from the **Format** list.
4) Click **OK** to save the changes and close the dialog.

**Note**

The date format will be influenced by the system or worksheet language settings.

Special characters

A special character is a character not normally found on a standard keyboard; for example, © ™ æ ç ŋ ø ç. To insert a special character:

1) Place the cursor where you want the character to appear.
2) Go to **Insert > Special Character** on the Menu bar to open the Special Characters dialog (Figure 26).
3) From the grid of characters, select the required character. The last character selected is shown on the right of the Special Characters dialog along with its numerical code.
4) Any recently inserted characters are shown below the grid of characters and can be selected in the same way as any other character in the dialog.
5) At the bottom of the dialog there is provision for building a small collection of **Favorite Characters**. To add a new character to the collection, select the required character and click the **Add to Favorites** button. To remove an existing character from the collection, select the character and click the **Remove from Favorites** button.
6) Click **Insert** to close the dialog and the special character is inserted into the selected cell.
Tip

You can quickly insert one of your recent or favorite special characters by clicking the **Insert Special Characters** icon on the Standard toolbar and selecting the required character from the drop-down. Click **More Characters** on this drop-down to open the Special Characters dialog (Figure 26).

Note

Different fonts include different special characters. If you do not find a particular special character you want, try changing the **Font** and **Subset** selections.

AutoCorrect options

Calc automatically applies many changes during data input using AutoCorrect, unless you have deactivated any AutoCorrect changes. You can also undo any AutoCorrect changes by using the keyboard shortcut Ctrl+Z or manually by going back to the change and replacing the autocorrection with what you want to actually see.

To change the AutoCorrect options, go to **Tools > AutoCorrect Options** on the Menu bar to open the AutoCorrect dialog (Figure 27).
Replace
Edit the replacement table for automatically correcting or replacing words or abbreviations.

Exceptions
Specify the abbreviations or letter combinations that you do not want corrected automatically.

Options
Select the options for automatically correcting errors as you type.

Localized Options
Specify the AutoCorrect options for quotation marks and for options that are specific to the language of the text.

Reset
Reset modified values back to their previous values.

Inserting dashes
Calc provides text shortcuts so that you can quickly insert dashes into a cell and these shortcuts are shown in Table 2.

Table 2: Inserting dashes

<table>
<thead>
<tr>
<th>Text that you type</th>
<th>Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>A - B (A, space, hyphen, space, B)</td>
<td>A – B (A, space, en-dash, space, B)</td>
</tr>
<tr>
<td>A -- B (A, space, hyphen, hyphen, space, B)</td>
<td>A – B (A, space, en-dash, space, B)</td>
</tr>
<tr>
<td>A--B (A, hyphen, hyphen, B)</td>
<td>A—B (A, em-dash, B)</td>
</tr>
<tr>
<td>A-B (A, hyphen, B)</td>
<td>A-B (unchanged)</td>
</tr>
<tr>
<td>A - B (A, space, hyphen, B)</td>
<td>A - B (unchanged)</td>
</tr>
<tr>
<td>A --B (A, space, hyphen, hyphen, B)</td>
<td>A –B (A, space, en-dash, B)</td>
</tr>
</tbody>
</table>
**Speeding up data entry**

Entering data into a spreadsheet can be very labor-intensive, but Calc provides tools for removing some of the drudgery from input. These tools include drag and drop to move or copy contents of one cell to another using a mouse, an AutoInput tool, the Fill tool, and selection lists.

The Fill tool and selection lists automate input of repetitive material into cells. Calc also has the ability to input information into multiple sheets of the same spreadsheet at the same time.

**AutoInput tool**

The AutoInput function in Calc automatically completes entries, based on other entries in the same column. The column is scanned up to a maximum of 2000 cells or 200 different strings.

When text is highlighted in a cell, AutoInput can be used as follows:

1) To accept the completion, press *Enter* or *F2* or click the mouse button.
2) To view more completions that start with the same letters, use the key combinations *Ctrl+Tab* to scroll forward, or *Ctrl+Shift+Tab* to scroll backward.
3) To see a list of all available AutoInput text items for the current column, use the keyboard combination *Alt+Down Arrow*.

When typing formulas using characters that match function names, a Help tip will appear listing the functions used in the Function Wizard that start with matching characters.

AutoInput ignores the case sensitivity of any data you enter. If, for example, you have written "Total" in a cell, you cannot then enter "total" in another cell of the same column without first deactivating AutoInput.

By default, AutoInput is activated in Calc. To turn it off, go to **Tools** on the **Menu** bar and deselect **AutoInput**.

**Fill tool**

You can use the Fill tool in Calc to duplicate existing content or create a series in a range of cells in the spreadsheet as shown by the examples in Figure 28.

![Figure 28: Examples of using the Fill tool](image)

1) Select the cell containing the contents you want to copy or start the series from.
2) Drag the cursor in any direction or hold down the *Shift* key and click in the last cell you want to fill.
3) Go to **Sheet** > **Fill Cells** on the Menu bar and select the direction in which you want to copy or create data (Down, Right, Up, Left, Sheets, Series, or Random Number). A menu option will be grayed out if it is not available.
Alternatively, you can use a shortcut to fill cells:

1) Select the cell containing the contents you want to copy or start the series from.
2) Move the cursor over the small selection handle in the bottom right corner of the selected cell. The cursor will change shape.
3) Click and drag in the direction you want the cells to be filled, vertical or horizontal. If the original cell contained text, then the text will automatically be copied. If the original cell contained a number, a series will be created.

**Caution**

When you are selecting cells so you can use the Fill tool, make sure that none of the cells contain data, except for the cell data you want to use. When you use the Fill tool, any data contained in selected cells is overwritten.

**Using a fill series**

When you select a series fill from Sheet > Fill Cells > Fill Series on the Menu bar, the Fill Series dialog (Figure 29) opens. Here you can select the type of series you want or create your own list.

**Direction**

Determines the direction of series creation.

- **Down** – creates a downward series in the selected cell range for the column using the defined increment to the end value.
- **Right** – creates a series running from left to right within the selected cell range using the defined increment to the end value.
- **Up** – creates an upward series in the selected cell range of the column using the defined increment to the end value.
- **Left** – creates a series running from right to left within the selected cell range using the defined increment to the end value.

![Fill Series dialog](image)

**Series Type**

Defines the series type. These are:

- **Linear** – creates a linear number series using the defined increment and end value.
- **Growth** – creates a growth series using the defined increment and end value.
– Date – creates a date series using the defined increment and end date.
– AutoFill – forms a series directly in the sheet. The AutoFill function takes account of customized lists. For example, by entering January in the first cell, the series is completed using the list defined in Tools > Options > LibreOffice Calc > Sort Lists. AutoFill tries to complete a value series by using a defined pattern. For example, a numerical series using 1,3,5 is automatically completed with 7,9,11,13; a date and time series using 01.01.99 and 15.01.99, an interval of fourteen days is used.

**Time Unit**
In this area you specify the desired unit of time. This area is only active if the Date option has been selected in Series Type. These are:

– Day – use the Date series type and this option to create a series using seven days.
– Weekday – use the Date series type and this option to create a series of five day sets.
– Month – use the Date series type and this option to form a series from the names or abbreviations of the months.
– Year – use the Date series type and this option to create a series of years.

**Start value**
Determines the start value for the series. Use numbers, dates or times.

**End value**
Determines the end value for the series. Use numbers, dates or times.

**Increment**
Determines the value by which the series of the selected type increases by each step. Entries can only be made if the linear, growth or date series types have been selected.

**Defining a fill series**
To define your own fill series:

1) Go to Tools > Options > LibreOffice Calc > Sort Lists to open the Sort Lists dialog (Figure 30). This dialog shows any previously defined series in the Lists box on the left and the contents of the highlighted list in the Entries box.
2) Click New and the Entries box is cleared.
3) Type the series for the new list in the Entries box (one entry per line) (Figure 31).
4) Click Add and the new list will now appear in the Lists box.
5) Click OK to save the new list and close the dialog.
Selection lists

Selection lists are available only for text and are limited to using only text that has already been entered in the same column.

1) Select a blank cell in a column that contains cells with text entries.
2) Right-click and select **Selection List** from the context menu, or use the keyboard shortcut `Alt+↓`. A drop-down list appears listing any cell in the same column that either has at least one text character or whose format is defined as text.
3) Click on the text entry you require and it is entered into the selected cell.
Merging and splitting cells

Merging
You can select contiguous cells and merge them into one as follows:

1) Select the range of contiguous cells you want merge.
2) Right-click on the selected cells and select **Merge Cells** from the context menu, or go to **Format > Merge Cells > Merge Cells** or **Merge and Center Cells** on the Menu bar, or click on the **Merge and Center Cells** icon on the Formatting toolbar. Using **Merge and Center Cells** will center align any contents in the cells.
3) If the cells contain any data, a small dialog (Figure 32) opens, showing choices for moving or hiding data in the hidden cells.
4) Make your selection and click **OK**.

![Merge Cells dialog](image)

*Figure 32: Merge choices for non-empty cells*

**Caution**

Merging cells can lead to calculation errors in formulas used in the spreadsheet.

Splitting
You can reverse or split only a cell that was created from several cells by merging.

1) Select a merged cell.
2) Go to **Format > Merge Cells > Split Cells** on the Menu bar, or right-click and select **Split Cells** from the context menu, or click on the **Merge and Center Cells** icon on the Formatting toolbar.
3) Any data in the cell will remain in the first cell. If the hidden cells did have any contents before the cells were merged, then you may have to manually move the contents into the correct cell.

Sharing content between sheets
You might want to enter the same information in the same cell on multiple sheets, for example to set up standard listings for a group of individuals or organizations. Instead of entering the list on each sheet individually, you can enter the information in several sheets at the same time.
Validating cell contents

When creating spreadsheets for other people to use, you may want to make sure they enter data that is valid or appropriate for the cell. You can also use validation in your own work as a guide to entering data that is either complex or rarely used.

Fill series and selection lists can handle some types of data, but are limited to predefined information. For example, a cell may require a date or a whole number with no alphabetic characters or decimal points, or a cell may not be left empty.

Depending on how validation is set up, it can also define the range of contents that can be entered, provide help messages explaining the content rules set up for the cell and what users should do when they enter invalid content. You can also set the cell to refuse invalid content, accept it with a warning, or start a macro when an error is entered.
Defining validation

To validate any new data entered into a cell:

1) Select a cell and go to **Data > Validity** on the Menu bar to open the Validity dialog.
2) Define the type of contents that can be entered in that cell using the options given on the tabbed pages for **Criteria**, **Input Help**, and **Error Alert**. The options are explained below Figure 34.

![Validity dialog – Criteria page](image)

**Figure 34: Validity dialog – Criteria page**

**Criteria options**

Specify the validation rules for the selected cells using the **Criteria** tab in the Validity dialog as shown in Figure 34. For example, you can define criteria such as numbers between 1 and 10, or texts that are no more than 20 characters.

The options available on the **Criteria** tab will depend on what has been selected in the **Allow** dropdown list.

- **Allow** – select a validation option for the selected cells from the drop-down list.
  - **All values** – no limitation.
  - **Whole Numbers** – only whole numbers allowed.
  - **Decimal** – all numbers correspond to decimal format.
  - **Date** – all numbers correspond to date format. The entered values are formatted the next time the dialog is called up.
  - **Time** – all numbers correspond to time format. The entered values are formatted the next time the dialog is called up.
  - **Cell range** – allow only values that are given in a cell range. The cell range can be specified explicitly, or as a named database range, or as a named range. The range may consist of one column or one row of cells. If you specify a range of columns and rows, only the first column is used.
  - **List** – allow only values or strings specified in a list. Strings and values can be mixed. Numbers evaluate to their value, so if you enter the number 1 in the list, the entry 100% is also valid.
  - **Text length** – allow entries whose length corresponds to the number of characters that have been set.
  - **Custom** – allow entries that correspond to a formula entered in the **Formula** box.
• **Allow empty cells** – in conjunction with **Tools > Detective > Mark Invalid Data**, this defines that blank cells are shown as invalid data (disabled) or not shown (enabled).

• **Show selection list** – shows a list of all valid strings or values to select from. The list can also be opened by selecting the cell and pressing `Ctrl+D`.

• **Sort entries ascending** – sorts the selection list in ascending order and filters duplicates from the list. If not checked, the order from the data source is taken.

• **Source** – enter the cell range that contains the valid values or text.

• **Entries** – enter the entries that will be valid values or text strings.

• **Data** – select the comparative operator that you want to use from the drop-down list. The available operators depend on what you have selected in the **Data** drop-down list. For example, if you select **valid range**, the **Minimum** and **Maximum** input boxes replace the **Value** box.

• **Value** – enter the value for the data validation option that you selected in the **Data** drop-down list.

• **Minimum** – enter the minimum value for the data validation option that you selected in the **Data** drop-down list.

• **Maximum** – enter the maximum value for the data validation option that you selected in the **Data** drop-down list.

**Input Help options**

Enter the message to be displayed when the cell or cell range is selected in the spreadsheet (Figure 35).

- **Show input help when cell is selected** – displays the message that you enter in the **Title** and **Input help** boxes when the cell or cell range is selected in the sheet. If you enter text in the **Title** and **Input help** boxes and then deselect this option, the text will be lost.

- **Title** – enter the title to be displayed when the cell or cell range is selected.

- **Input help** – enter the message to be displayed when the cell or cell range is selected.

![Validity dialog – Input Help tab](image)

**Error Alert options**

Define the error message that is displayed when invalid data is entered in a cell (Figure 36).
• **Show error message when invalid values are entered** – when selected, displays the error message that you enter in the *Contents* area when invalid data is entered in a cell.

• **Action** – select the action that you want to occur when invalid data is entered in a cell.
  – *Stop* – rejects the invalid entry and displays a dialog that you have to close by clicking *OK*.
  – *Warning* and *Information* – displays a dialog that can be closed by clicking *OK* or *Cancel*. The invalid entry is only rejected when you click *Cancel*.
  – *Macro* – activates the *Browse* button to open the Macro Selector dialog where you can select a macro that is executed when invalid data is entered in a cell. The macro is executed after the error message is displayed.

• **Title** – enter the title of the macro or the error message that you want to display when invalid data is entered in a cell.

• **Error message** – enter the message that you want to display when invalid data is entered in a cell.

**Calc Detective**

The Detective is a tool within Calc that you can use to locate any cells in a spreadsheet that contain invalid data if the cells are set to accept invalid data with a warning.

1) Go to **Tools > Detective > Mark Invalid Data** on the Menu bar to locate any cells containing invalid data. The Detective function marks any cells containing invalid data.

2) Correct the data so that it becomes valid.

3) Go to **Tools > Detective > Remove All Traces** on the Menu bar again and any cells that were previously marked as containing invalid data have the invalid data mark removed.

**Note**

A validity rule is considered part of the format for a cell. If you select **Delete all** from the Delete Contents dialog (Figure 38), then it is removed. If you want to copy a validity rule with the rest of the cell, use **Edit > Paste Special > Paste Special** to open the Paste Special dialog (Figure 39), then select **Paste All** or **Formats** and click **OK**.
Editing data

Deleting data

Deleting cell data only
Data can be deleted from a cell without deleting any of the cell formatting. Select a cell or a range of cells and then press the Delete key.

Delete Cells
This option completely deletes selected cells, columns, or rows. The cells below or to the right of the deleted cells will fill the space.

1) Select a cell or a range of cells.
2) Press the Ctrl+- keys, or select Sheet > Delete Cells on the Menu bar, or right-click inside the selected cells and choose Delete from the context menu.
3) The Delete Cells dialog (Figure 37) provides four options to specify how sheets are displayed after deleting cells:
   - **Shift cells up**
     Fills the space produced by the deleted cells with the cells underneath it.
   - **Shift cells left**
     Fills the resulting space by the cells to the right of the deleted cells.
   - **Delete entire row(s)**
     After selecting at least one cell, deletes the entire row from the sheet.
   - **Delete entire column(s)**
     After selecting at least one cell, deletes the entire column from the sheet.
4) To confirm the selection, click OK.

Note
The selected delete option is stored and reloaded when the dialog is next called.

Deleting data and formatting
Data and cell formatting can be deleted from a cell at the same time. To do this:

1) Select a cell or a range of cells.
2) Press the Backspace key, or right-click inside the selected cells and choose Clear Contents from the context menu, or select Sheet > Clear Cells on the Menu bar.
3) In the Delete Contents dialog (Figure 38), choose any of the options or choose **Delete All**. Click **OK**.

![Delete Contents dialog](image)

**Figure 38: Delete Contents dialog**

### Replacing data

To completely replace data in a cell and insert new data, select the cell and type in the new data. The new data will replace the data already contained in the cell and will retain the original formatting used in the cell.

Alternatively, click in the Input line on the Formula Bar, then double-click on the data to highlight it completely and type the new data.

### Editing data

Sometimes it is necessary to edit the contents of cell without removing all of the data from the cell. For example, changing the phrase “Sales in Qtr. 2” to “Sales rose in Qtr” can be done as follows.

**Using the keyboard**

1) Click in the cell to select it.
2) Press the **F2** key and the cursor is placed at the end of the cell.
3) Press the **Backspace** key to delete any data up to the point where you want to enter new data.
4) Alternatively, use the keyboard arrow keys to reposition the cursor where you want to start entering the new data in the cell, then press the **Delete** key or **Backspace** key to delete any unwanted data before typing the new data.
5) When you have finished editing, press the **Enter** key to save the changes.

**Note**

Each time you select a cell, the contents are displayed in the Input line on the Formula Bar. Using the Input line may be easier when editing data.

**Using the mouse**

1) Double-click on the cell to select it and place the cursor in the cell for editing.
2) Reposition the cursor to where you want to start editing the data in the cell.
3) Alternatively, single-click to select the cell, then move the cursor to the Input line on the Formula Bar and click at the position where you want to start editing the data in the cell.
4) When you have finished, click away from the cell to deselect it and the editing changes are saved.

**Paste Special function**

You can use the Paste Special function to paste into another cell selected parts of the data in the original cell or cell range, for example its format or the result of its formula.

**Paste Special dialog**

1) Select a cell or a cell range.
2) Go to **Edit > Copy** on the Menu bar, or right-click and select **Copy** from the context menu, or press **Ctrl+C**, or click the **Copy** icon on the Standard toolbar.
3) Select the target cell or cell range.
4) Go to **Edit > Paste Special > Paste Special** from the Menu bar, or use the keyboard shortcut **Ctrl+Shift+V**, or right-click and select **Paste Special > Paste Special** from the context menu to open the Paste Special dialog (Figure 39).
5) Select the options for **Selection, Operations, Options** and **Shift Cells**. The Paste Special options are explained below.
6) Click **OK** to paste the data into the target cell or range of cells and close the dialog.

---

**Paste Special options**

- **Selection** – select a format for the clipboard contents that you want to paste.
  - **Paste all** – pastes all cell contents, comments, formats, and objects into the current document.
  - **Text** – pastes cells containing text.

---

![Figure 39: Paste Special dialog](image-url)
– **Numbers** – pastes cells containing numbers.
– **Date & time** – pastes cells containing date and time values.
– **Formulas** – pastes cells containing formulas.
– **Comments** – pastes comments that are attached to cells. If you want to add the comments to the existing cell content, select the *Add* operation.
– **Formats** – pastes cell format attributes.
– **Objects** – pastes objects contained within the selected cell range. These can be OLE objects, chart objects, or drawing objects.

**Operations** – select the operation to apply when you paste cells into the sheet.
– **None** – does not apply an operation when you insert the cell range from the clipboard. The contents of the clipboard will replace existing cell contents.
– **Add** – adds the values in the clipboard cells to the values in the target cells. Also, if the clipboard only contains comments, adds the comments to the target cells.
– **Subtract** – subtracts the values in the clipboard cells from the values in the target cells.
– **Multiply** – multiplies the values in the clipboard cells with the values in the target cells.
– **Divide** – divides the values in the target cells by the values in the clipboard cells.

**Options** – sets the paste options for the clipboard contents.
– **Skip empty cells** – empty cells from the clipboard do not replace target cells. If you use this option in conjunction with the *Multiply* or the *Divide* operation, the operation is not applied to the target cell of an empty cell in the clipboard. If you select a mathematical operation and deselect the *Skip empty cells*, empty cells in the clipboard are treated as zeroes. For example, if you apply the *Multiply* operation, the target cells are filled with zeroes.
– **Transpose** – the rows of the range in the clipboard are pasted to become columns of the output range. The columns of the range in the clipboard are pasted to become rows.
– **Link** – inserts the cell range as a link, so that changes made to the cells in the source file are updated in the target file. To ensure that changes made to empty cells in the source file are updated in the target file, ensure that *Paste All* is also selected. You can also link sheets within the same spreadsheet. When you link to other files, a DDE link is automatically created. A DDE link is inserted as a matrix formula and can only be modified as a whole.

**Shift cells** – sets the shift options for the target cells when the clipboard content is inserted.
– **Don’t shift** – inserted cells replace the target cells.
– **Down** – target cells are shifted downward when you insert cells from the clipboard.
– **Right** – target cells are shifted to the right when you insert cells from the clipboard.

**Paste Only options**
If you only want to copy text, numbers, or formulas to the target cell or cell range:
1) Select the source cell or cell range and copy the data.
2) Select the target cell or cell range.
3) Right-click on the target cell or cell range and select **Paste Special** from the context menu, then select **Text**, **Number**, or **Formula**.

**Insert cell fields**
You can insert a field linked to the date, sheet name, or document name in a cell.
1) Select a cell and double-click to activate edit mode.
2) Right-click and select Insert Field > Date or Sheet Name or Document Title from the context menu.

**Note**

The Insert Field > Document Title command inserts the name of the spreadsheet and not the title defined in the Description tab in the Properties dialog for the file.

**Tip**

The fields are refreshed when the spreadsheet is saved or recalculated when using the Ctrl+Shift+F9 shortcut.

### Formatting data

**Note**

All the settings discussed in this section can also be set as a part of the cell style. See Chapter 4, Using Styles and Templates, for more information.

You can format the data in Calc in several ways, either defined as part of a cell style so that it is automatically applied, or applied manually to the cell. For more control and extra options, select a cell or cell range and use the Format Cells dialog. All of the format options are discussed below.

### Multiple lines of text

Multiple lines of text can be entered into a single cell using automatic wrapping or manual line breaks. Each method is useful for different situations.

**Automatic wrapping**

To automatically wrap multiple lines of text in a cell:

1) Select a cell or cell range.
2) Right-click and select Format Cells from the context menu, or go to Format > Cells on the Menu bar, or press Ctrl+1 to open the Format Cells dialog.
3) Click on the Alignment tab (Figure 40).
4) Under Properties, select Wrap text automatically and click OK.

**Manual line breaks**

To insert a manual line break while typing in a cell, press Ctrl+Enter. When editing text, double-click the cell, then reposition the cursor to where you want the line break.

When a manual line break is entered, the cell width does not change and the text may still overlap the end of the cell. You have to change the cell width manually or reposition the line break so that the text does not overlap the end of the cell.
Shrinking text to fit a cell

The font size of the data in a cell can automatically adjust to fit inside cell borders.

1) Select a cell or cell range.
2) Right-click on the selection and select **Format Cells** from the context menu, or go to **Format > Cells** on the Menu bar, or press Ctrl+1 to open the Format Cells dialog.
3) Click on the **Alignment** tab (Figure 40).
4) Under **Properties**, select **Shrink to fit cell size** and click **OK**.

Formatting numbers

Several different number formats can be applied to cells by using icons on the Formatting toolbar (highlighted in Figure 41). Select the cell, then click the relevant icon to change the number format.

For more control or to select other number formats, use the **Numbers** tab of the Format Cells dialog (Figure 24 on page 43):

- Apply any of the data types in the **Category** list to the data.
- Control the number of decimal places and leading zeroes in **Options**.
• Enter a custom format code. This is a very powerful facility that is detailed in the Number Format Codes page of the Help.
• The Language setting controls the local settings for the different formats such as the date format and currency symbol.

Figure 41: Number icons on Formatting toolbar

Formatting fonts
To select a font and format it for use in a cell:

1) Select a cell or cell range.
2) Click the small triangle on the right of the Font Name box on the Formatting toolbar (highlighted in Figure 42) and select a font from the drop-down list. The font can also be changed using the Font tab on the Format Cells dialog.
3) Click on the small triangle on the right of the Font Size box on the Formatting toolbar and select a font size from the drop-down list. The font size can also be changed using the Font tab on the Format Cells dialog.
4) To change the character format, click on the Bold, Italic, or Underline icons.
5) To change the paragraph alignment of the font, click on one of the alignment icons (Align Left, Align Center, and Align Right). The Format > Align menu also provides these options, along with a Justified option.

Figure 42: Font Name and Size on Formatting toolbar

Note
To specify the language used in the cell, open the Font tab on the Format Cells dialog. Changing language in a cell allows different languages to exist within the same document. For more changes to font characteristics, see “Font effects” below.

Tip
To choose whether to show the font names in their font or in plain text, go to Tools > Options > LibreOffice > View and select or deselect the Show preview of fonts option in the Font Lists section. For more information, see Chapter 14, Setting Up and Customizing.

Font effects
1) Select a cell or cell range.
2) Right-click and select Format Cells from the context menu, or go to Format > Cells on the Menu bar, or press Ctrl+1 to open the Format Cells dialog.
3) Click on the Font Effects tab (Figure 43).
4) Select the font effect you want to use from the options available. The options available are described in Chapter 4, Using Styles and Templates.
5) Click OK to apply the font effects and close the dialog.
Any font effect changes are applied to the current selection, or to the entire word that contains the cursor, or to any new text that you type.

**Text direction**

To change the text direction within a cell, use the Alignment tab on the Format Cells dialog (Figure 40 on page 61).

1) On the Alignment page of the Format Cells dialog, select the Reference edge from which to rotate the text as follows:
   - **Text Extension From Lower Cell Border** – writes the rotated text from the bottom cell edge outwards.
   - **Text Extension From Upper Cell Border** – writes the rotated text from the top cell edge outwards.
   - **Text Extension Inside Cell** – writes the rotated text only within the cell.
2) Click on the small indicator at the edge of the Text orientation dial and rotate it until you reach the required degrees.
3) Alternatively, enter the number of degrees to rotate the text in the Degrees box.
4) Select Vertically stacked to make the text appear vertically in the cell.

**Using the icons on the Formatting toolbar**

The icons on the Formatting toolbar can be used as follows after the cell has been selected:

- To change the text direction from horizontal (default direction) to vertical, click on the Text direction from top to bottom icon 🅰️.
To change text direction from vertical to horizontal (default), click on the **Text direction from left to right** icon.

To change text direction from left to right, which is the default direction for Western fonts, to a right to left direction used in some fonts, for example Arabic, then click on the **Right-To-Left** icon. This only works if a font has been used that requires a right to left direction.

To change text direction back to the default left to right direction used for Western fonts, click on the **Left-To-Right** icon.

**Note**

The text direction icons can only be made available if the **Asian and Complex text layout** options are checked under **Tools > Options > Language Settings > Languages > Default Language for Documents**. If it is necessary to make the buttons visible, right-click on the toolbar and select **Visible Buttons** from the context menu, then click on the icon you require and it will be placed on the Formatting toolbar.

### Formatting cell borders

To format the borders of a cell or a group of selected cells, you can use the border icons on the Formatting toolbar to apply the default styles to borders, or the Format Cells dialog for greater control. See Chapter 4, Using Styles and Templates, for more information on the options.

**Note**

Cell border properties apply only to the selected cells and can only be changed if you are editing those cells. For example, if cell C3 has a top border, that border can only be removed by selecting C3. It cannot be removed in C2, even though it appears to be the bottom border for cell C2.

1. Select a cell or a range of cells.
2. Right-click and select **Format Cells** from the context menu, or go to **Format > Cells** on the Menu bar, or press **Ctrl+1** to open the Format Cells dialog.
3. On the **Borders** tab (Figure 44), select the options required.
4. Click **OK** to close the dialog and save the changes.

Alternatively, use the icons on the Formatting toolbar to apply default styles to borders:

1. Click the **Borders** icon and select one of the options displayed in the **Borders** palette.
2. Click the **Border Style** icon and select one of the line styles from the **Border Style** palette.
3. Click the **Border Color** icon and select a color from **Border Color** palette.

**Note**

When entering borders with the border icons on the Formatting toolbar, you have two choices: click the required icon to add a border to the present borders or **Shift-click** to add a border and remove the present borders.
Formatting cell backgrounds

To format the background color for a cell or a group of cells (see Chapter 4, Using Styles and Templates, for more information):

1) Select a cell or a range of cells.
2) Right-click and select **Format Cells** from the context menu, or go to **Format > Cells** on the Menu bar, or press **Ctrl+1** to open the Format Cells dialog.
3) On the **Background** tab, click the **Color** button and select a color from the color palette.
4) Click **OK** to save the changes and close the dialog.

Alternatively, click on the **Background Color** icon on the Formatting toolbar and select a color from the **Background Color** palette.

AutoFormat of cells and sheets

Using AutoFormat

You can use AutoFormat to format a group of cells.

1) Select the cells in at least three columns and rows, including column and row headers, that you want to format.
2) Go to **Format > AutoFormat Styles** on the Menu bar to open the AutoFormat dialog (Figure 45).
3) Select the type of format and format color from the list.
4) Select the formatting properties to be included in the AutoFormat function.
5) Click **OK** to apply the changes and close the dialog.

![AutoFormat dialog]

**Figure 45: AutoFormat dialog**

### Defining a new AutoFormat

You can define a new AutoFormat so that it becomes available for use in all spreadsheets.

1) Format the data type, font, font size, cell borders, cell background, and so on for a group of cells.

2) Go to **Edit > Select All** on the Menu bar to select the whole spreadsheet.

3) Go to **Format > AutoFormat Styles** to open the AutoFormat dialog. The **Add** button is now active.

4) Click **Add**.

5) In the **Name** box of the Add AutoFormat dialog that opens, type a meaningful name for the new format and click **OK**.

6) The new AutoFormat is now available in the Format list in the AutoFormat dialog. Click **OK** to close the AutoFormat dialog.

### Using themes

Calc comes with a predefined set of formatting themes that you can apply to spreadsheets. It is not possible to add new themes to Calc and the predefined styles cannot be modified. You can modify styles after you apply them to a spreadsheet, but the modified styles are only available for use for that spreadsheet.

To apply a theme to a spreadsheet:

1) Go to **Format > Spreadsheet Theme** on the Menu bar or click the **Spreadsheet Theme** icon in the Tools toolbar to open the Theme Selection dialog (Figure 46), which lists the available themes for the whole spreadsheet.

2) Select the theme that you want to apply. As soon as you select a theme, the theme styles are applied to the spreadsheet and are immediately visible.

3) Click **OK**.
If you wish, you can now use the Styles deck on the Sidebar to modify specific styles. These modifications do not modify the theme; they only change the appearance of the style in the spreadsheet you are creating. For more about modifying styles, see Chapter 4, Using Styles and Templates.

**Value highlighting**

Value highlighting displays cell contents in different colors depending on the type of content. An example of value highlighting is shown in Figure 47.

- Text is shown in black.
- Formulas are shown in green.
- Numbers are shown in blue.

The value highlighting colors override any colors used in formatting. This color change applies only to the colors seen on a display. When a spreadsheet is printed, the original colors used for formatting are printed.

Go to View > Value Highlighting on the Menu bar, or use the keyboard shortcut Ctrl+F8 to turn the function on or off. When value highlighting is switched off, the original formatting colors are used for display.

You can make value highlighting the default when opening a spreadsheet in Calc, by selecting Tools > Options > LibreOffice Calc > View > Value highlighting. This default mode for value highlighting may not be what you want if you are going to format the cells for printing.
Using conditional formatting

You can set up cell formats to change depending on conditions that you specify. Conditional formatting is used to highlight data that is outside the specifications that you have set. It is recommended not to overuse conditional formatting as this could reduce the impact of data that falls outside those specifications.

See page 71 for an example of how to use conditional formatting.

**Note**

Conditional formatting depends upon the use of styles and the AutoCalculate feature must be enabled. If you are not familiar with styles, see Chapter 4, Using Styles and Templates, for more information.

**Setting up conditional formatting**

1) Ensure that AutoCalculate is enabled: **Data > Calculate > AutoCalculate**.
2) Select the cells where you want to apply conditional formatting.

3) Go to **Format > Conditional > Condition** (Figure 48), **Color Scale** (Figure 49), **Data Bar** (Figure 50), **Icon Set**, or **Date** on the Menu bar to open the Conditional Formatting dialog. Any conditions already defined are displayed.

4) Click **Add** to create and define a new condition. Repeat this step as necessary.

5) Select a style from the styles already defined in the **Apply Style** drop-down list. Repeat this step as necessary.

   Alternatively, select **New Style** to open the Cell Style dialog (Figure 51) and create a new cell style. Repeat this step as necessary.

6) Click **OK** to save the conditions and close the dialog. The selected cells are now set to apply a result using conditional formatting.
Figure 49: Conditional Formatting dialog – Color Scale

Figure 50: Conditional Formatting dialog – Data Bar
Types of conditional formatting

Condition
Condition is the starting point when using conditional formatting. Here you can define what formats to use to highlight any data in the spreadsheet that falls outside the specifications that you have defined.

Color Scale
Use color scale to set the background color of cells depending on the values of the data in those cells. Color scale can only be used when All Cells has been selected for the condition. You can use either two or three colors for the color scale.

Data Bars
Data bars provide a graphical representation of data in the spreadsheet. The graphical representation is based on the values of data in a selected range. Click on More Options in the Conditional Formatting dialog to define how the data bars will look. Data bars can only be used when All Cells has been selected for the condition.

Icon Sets
Icon sets display an icon next to the data in each selected cell to give a visual representation of where the cell data falls within the defined range that you set. The icon sets available include colored arrows, gray arrows, colored flags, colored signs, symbols, bar ratings and quarters. Icon sets can only be accessed when the Conditional Formatting dialog has been opened and All Cells has been selected for the condition.

Conditional formatting management
To see all the conditional formatting defined in the spreadsheet and any styles used:

1) Go to Format > Conditional > Manage on the Menu bar to open the Manage Conditional Formatting dialog (Figure 52).
2) Select a range from the Range list and click Edit to redefine the conditional formatting.
3) Select a range from the Range list and click Remove to delete the conditional formatting. The deletion is immediate with no confirmation.
4) Select Add to create a new definition of conditional formatting.
5) Click **OK** to save the changes and close the dialog.

![Manage Conditional Formatting dialog](image)

**Figure 52: Manage Conditional Formatting dialog**

### Copying cell styles

To apply the style used for conditional formatting to other cells later:

1. Click one of the cells that has been assigned conditional formatting and copy the cell to the clipboard.
2. Select the cells that are to receive the same formatting as the copied cell.
3. Go to **Edit > Paste Special > Paste Special** on the Menu bar to open the Paste Special dialog (Figure 39 on page 58).
4. Make sure that only **Formats** is selected and click **OK** to paste the conditional formatting into the cell.

### Conditional formatting example

With conditional formatting, you can, for example, highlight the totals that exceed the average value of all totals. If the totals change, the formatting changes correspondingly, without having to apply other styles manually. It is recommended that the Styles deck on the Sidebar is open and visible before proceeding.

### Defining conditions

1. Select the cells where you want to apply a conditional style.
2. Go to **Format > Conditional > Condition, Color Scale, or Data Bar** from the Menu bar to open the Conditional Formatting dialog.
3. Enter the conditions you want to use for conditional formatting.

### Generating number values

You may want to give certain values in your tables particular emphasis. For example, in a table of turnovers, you can show all the values above the average in green and all those below the average in red. This is possible with conditional formatting.

1. Create a table in which a few different values occur. For your test you can create tables with any random numbers. In one of the cells enter the formula =RAND(), and you will obtain a random number between 0 and 1. If you want integers of between 0 and 50, enter the formula =INT(RAND()*50).
2. Copy the formula to create a row of random numbers.
3) Click the bottom right corner of the selected cell, and drag to the right and downward until the desired cell range is selected.

Defining cell styles
The next step is to apply a cell style to all values that represent above-average turnover and one to cells that are below the average.

1) Right-click in a blank cell and select Format Cells in the context menu to open the Format Cells dialog.
2) Click the Background tab and select a background color, then click OK.
3) In the Conditional Formatting dialog, select New Style from the Apply Style drop-down list to open the Cell Style dialog.
4) Enter a name of the new style. For this example, name the style Above.
5) Define a second style, click again in a blank cell and proceed as described above. Assign a different background color to the cell and assign a name. For this example, name the style Below.

Calculating average
In our particular example, we are calculating the average of the random values. The result is placed in a cell:

1) Click in a blank cell, for example, J14, and go to Insert > Function on the Menu bar, or click the Function Wizard icon on the Formula bar to open the Function Wizard dialog.
2) Select AVERAGE from the Function list.
3) Use the cursor to select all your random numbers.
4) Click OK to close the Function Wizard.

Applying cell styles
Now you can apply the conditional formatting to the sheet:

1) Select all cells containing the random numbers.
2) Go to the Format > Conditional > Condition on the Menu bar to open the Conditional Formatting dialog.
3) Define the condition for each cell as follows: if cell value is less than J14, format with cell style Below OR if cell value is greater than or equal to J14, format with cell style Above.

Hiding and showing data
In Calc you can hide elements so that they are neither visible on a computer display nor printed when a spreadsheet is printed. However, hidden elements can still be selected for copying if you select the elements around them; for example, if column B is hidden, it is copied when you select columns A and C. When you require a hidden element again, you can reverse the process and show the element.

Hiding data

Sheets
Right-click on the sheet tab for the sheet to be hidden and select Hide Sheet from the context menu.

Rows and columns
1) Select a cell in the row or column you want to hide.
2) Go to **Format** on the Menu bar and select **Rows** or **Columns**.

3) Select **Hide** from the menu and the row or column can no longer viewed or printed. Alternatively, right-click on the row or column header and select **Hide Rows** or **Hide Columns** from the context menu.

**Cells**

Hiding individual cells is more complicated. First you need to define the cells as Protected and Hidden; then you need to protect the sheet.

1) Select the cells you want to hide.
2) Go to **Format > Cells** on the Menu bar, or right-click and select **Format Cells** from the context menu, or press `Ctrl+1`, to open the Format Cells dialog (Figure 53).
3) Click the **Cell Protection** tab and select an option for hiding and printing the cells.
4) Click **OK** to save the changes and close the dialog.
5) Go to **Tools > Protect Sheet** on the Menu bar to open the Protect Sheet dialog (Figure 54).
6) Select **Protect this sheet and the contents of protected cells**.
7) Create a password and then confirm the password.
8) Select or deselect the options for **Allow all users of this sheet to**: so users can select protected or unprotected cells.
9) Click **OK** to save the changes and close the dialog.

![Format Cells dialog – Cell Protection tab](image)

**Note**

When data in cells are hidden, it is only the data contained in the cells that are hidden and the protected cells cannot be modified. The blank cells remain visible in the spreadsheet.
Showing data

**Sheets**
Right-click on any sheet tab and select **Show Sheet** from the context menu. Choose which sheet from the list in the Show Sheet dialog. If there are no hidden sheets, the **Show Sheet** option will not appear in the context menu.

**Rows and columns**
1) Select the rows or columns on each side of the hidden row or column.
2) Go to **Format** on the Menu bar and select **Columns**.
3) Select **Show** from the context menu and the row or column will be displayed and can be printed.

Alternatively, right-click on a row or column header and select **Show Rows** or **Show Columns** from the context menu.

**Cells**
1) Go to **Tools > Protect Sheet** on the Menu bar to open the Protect Sheet dialog (Figure 54).
2) Enter the password to unprotect the sheet and click **OK**.
3) Go to **Format > Cells** on the Menu bar, or right-click and select **Format Cells** from the context menu, to open the Format Cells dialog (Figure 53).
4) Click the **Cell Protection** tab and deselect the hide options for the cells. Click **OK**.

**Group and outline**
If you are continually hiding and showing the same cells, you can create an outline of your data and group rows or columns together so that you can collapse a group to hide it or expand a group to show it using a single click.
The basic controls for grouping and outlining show plus (+) or minus (-) signs on the group indicator to show or hide rows or columns. However, if there are groups nested within each other, the basic controls have numbered buttons so you can hide the different levels of nested groups.

**Grouping**

To group rows or columns:

1) Select the cells you want to group in the spreadsheet.
2) Go to Data > Group and Outline > Group on the Menu bar, or press the F12 key.
3) In the Group dialog that opens, select either Rows or Columns and click OK. A group indicator appears to the left of any rows grouped or above any columns grouped. Figure 55 shows a group indicator on the left of the first two rows of the spreadsheet have been grouped.

![Figure 55: Group indicator](image)

**Hiding details**

To hide the details of any group of rows or columns:

1) Click on the minus (–) sign on the group indicator.
2) Alternatively, select a cell within the group and go to Data > Group and Outline > Hide Details on the Menu bar.
3) The rows or columns are hidden and the minus (–) sign becomes a plus (+) sign on the group indicator.

**Showing details**

To show the details of any hidden groups or rows or columns:

1) Click on the plus (+) sign on the group indicator.
2) Alternatively, select a cell on each side of the hidden group and go to Data > Group and Outline > Show Details on the Menu bar.
3) The hidden rows or columns are displayed and the plus (+) sign becomes a minus (–) sign on the group indicator.

**Ungrouping**

To ungroup any groups of rows or columns:

1) Make sure the grouped rows or columns are displayed.
2) Go to Data > Group and Outline > Ungroup on the Menu bar, or use the keyboard combination Ctrl+F12.
3) If only rows or only columns are grouped, they are ungrouped. If both rows and columns are grouped, select either Rows or Columns to ungroup and click OK.

**Caution**

Any hidden groups of rows or columns must be displayed. If they are hidden, then the grouped rows or columns are deleted from the spreadsheet.
Note

If there are nested groups, only the last group of rows or columns created is ungrouped.

AutoOutline

If a selected cell range contains formulas or references, Calc automatically outlines the selection. For example, in Figure 56 the cells for the 1st and 2nd quarters each contain a sum formula for the three cells to their left. If you apply the AutoOutline command, the columns are grouped into two quarters.

To apply the AutoOutline function, go to Data > Group and Outline > AutoOutline on the Menu bar. Calc will then check for cells that contain formulas or references and automatically group the cells as necessary.

![Figure 56: Example of AutoOutline](image)

Removing

To remove any cell groups of rows or columns, go to Data > Group and Outline > Remove Outline on the Menu bar and any groups are removed.

Any cell group of rows or columns that are hidden, the grouping is removed from the cells and the cells are displayed in the spreadsheet.

Filtering

A filter is a list of conditions that each entry has to meet to be displayed. Calc provides three types of filter:

- **Standard** – Specifies the logical conditions to filter the data.
- **AutoFilter** – Filters data according to a specific value or string. Automatically filters the selected cell range and creates one-row list boxes where you can choose the items that you want to display.
- **Advanced** – Uses filter criteria from specified cells.

Applying a standard filter

A standard filter is more complex than AutoFilter. You can set as many as eight conditions as a filter, combining them with the operators AND or OR. Standard filters are mostly useful for numbers, although a few of the conditional operators can also be used for text.

1) Select a cell range in the spreadsheet.
2) Go to Data > More Filters > Standard Filter on the Menu bar to open the Standard Filter dialog (Figure 57).
3) Specify the filter criteria and filtering options that you want to use.
4) Click OK to carry out standard filtering and close the dialog. Any records that match the filter criteria and options that you specified are shown.
The filter criteria used in standard filtering defines a filter by indicating the type of operator, the name of the field, a logical condition and a value or a combination of arguments.

- **Operator** – for the following arguments, you can choose between the logical operators AND / OR.

- **Field name** – specifies the field names from the current table to set them in the argument. You will see the column identifiers if no text is available for the field names.

- **Condition** – specifies the comparative operators through which the entries in the Field name and Value fields can be linked.

- **Value** – specifies a value to filter the field. The Value list box contains all possible values for the specified Field name. Select a value to be used in the filter, including Empty and Not Empty entries.

- **Case sensitive** – distinguishes between uppercase and lowercase letters when filtering the data.

- **Range contains column labels** – includes the column labels in the first row of a cell range.

- **Copy results to** – select the check box and then select the cell range where you want to display the filter results. You can also select a named range from the list.

- **Regular expressions** – select to use wildcards in the filter definition. See LibreOffice Help for a list of the regular expressions that LibreOffice supports. If selected, you can use regular expressions in the Value field if the Condition list box is set to ‘=’ EQUAL or ‘<>’ UNEQUAL. This also applies to the respective cells that you reference for an advanced filter.

- **No duplications** – excludes duplicate rows from the list of filtered data.

- **Keep filter criteria** – select Copy results to and then specify the destination range where you want to display the filtered data. If this box is checked, the destination range remains linked to the source range. You must have defined the source range under Data > Define.
**Range** as a database range. You can also reapply the defined filter at any time by clicking into the source range and then go to **Data > Refresh Range**.

**Applying an AutoFilter**

An AutoFilter adds a drop-down list to the top row of one or more data columns which lets you select the rows to be displayed. The list includes every unique entry in the selected cells sorted into lexical order (see [https://www.dictionary.com/browse/lexical-order](https://www.dictionary.com/browse/lexical-order) for an explanation of lexical order). AutoFilter can be used on multiple sheets without first defining a database range.

1) Click in a cell range on the spreadsheet. If you want to apply multiple AutoFilters to the same sheet, you must first define database ranges, then apply the AutoFilters to the database ranges.

2) Go to **Data > AutoFilter** on the Menu bar, or click the **AutoFilter** icon on the Standard toolbar. An arrow button is added to the head of each column in the database range.

3) Click the arrow or small triangle in the column that contains the value or string that you want to set as the filter criteria (shown in Figure 58).

4) Select the value or string that you want to use as the filter criteria. The records that match the filter criteria that you selected are then shown.

---

**Figure 58: AutoFilter example**
**Applying an advanced filter**

An advanced filter has a structure similar to a standard filter. The difference is that the advanced filter arguments are not entered in a dialog. Instead, filters can be entered in a blank area of a spreadsheet, then referenced by the filter dialog to apply the filters.

1) Select a cell range in the spreadsheet.
2) Go to **Data > More Filters > Advanced Filter** on the Menu bar to open the Advanced Filter dialog (Figure 59).
3) In **Read Filter Criteria From**, select the named range, or enter the cell range that contains the filter criteria that you want to use.
4) Click **OK** to carry out advanced filtering and close the dialog. Any records that match the filter criteria and options that you specified are shown.

---

**Note**

The options for advanced filtering are the same as those used for standard filtering, see “Applying a standard filter” on page 76 for more information.

---

**Figure 59: Advanced Filter dialog**

For an example of an advanced filter, see the Help page entitled “Filter: Applying Advanced Filters”.

---

**Sorting records**

Sorting within Calc arranges the cells in a sheet using the sort criteria that you specify. Several criteria can be used and a sort applies each criteria consecutively. Sorts are useful when you are searching for a particular item and become even more useful after you have filtered data.

Also, sorting is useful when you add new information to a spreadsheet. When a spreadsheet is long, it is usually easier to add new information at the bottom of the sheet, rather than adding rows in their correct place. After you have added information, you can then sort the records to update the spreadsheet.

**Sort dialog**

To sort cells in a spreadsheet using the Sort dialog:

1) Select the cells, rows, or columns to be sorted.
2) Go to **Data > Sort** on the Menu bar to open the Sort dialog.
3) On the Options tab (Figure 61), choose options including whether to sort on rows or columns. See “Sort options” on page 81 for details.

![Figure 60: Sort dialog – Sort Criteria tab](image)

4) On the Sort Criteria tab (Figure 60), select the criteria from the drop-down lists. The selection lists are populated from the selected cells.

5) Select either **Ascending** order (A-Z, 0-9) or **Descending** order (Z-A, 9-0).

6) Click **OK** and the sort is carried out on the spreadsheet.

![Figure 61: Sort dialog – Options tab](image)
Note

If any of the cells that you select for sorting are protected and the sheet is protected, then Calc cannot modify those cells and the sort will not be executed. An error message will be displayed to indicate that protected cells cannot be modified. However, it is possible to sort a range containing a row of column labels that are protected, since these are not modified by the sort.

Sort options

On the Options page of the Sort dialog (Figure 61), you can set these options:

- **Case sensitive** – sorts first by uppercase letters and then by lowercase letters. For Asian languages, special handling applies.

Note

For Asian languages, select **Case sensitive** to apply multi-level collation. With multi-level collation, entries are first compared in their primitive forms with their cases and diacritics ignored. If they evaluate as the same, their diacritics are taken into account for the second-level comparison. If they still evaluate as the same, their cases, character widths, and Japanese Kana difference are considered for the third-level comparison.

- **Range contains column/row labels** – omits the first column/row in the selection from the sort. The **Direction** setting at the bottom of the dialog defines the name and function of this check box: if top to bottom, then column labels; if left to right, then row labels.
- **Include formats** – preserves the current cell formatting.
- **Enable natural sort** – natural sorting is a sort algorithm that sorts string-prefixed numbers based on the value of the numerical element in each sorted number, instead of the traditional way of sorting them as ordinary strings. For instance, assume you have a series of values such as, A1, A2, A3, A4, A5, A6, ..., A19, A20, A21. When you put these values into a range of cells and run the sort, it will become A1, A11, A12, A13, ..., A19, A2, A20, A21, A3, A4, A5, ..., A9. With natural sorting selected, values such as these are sorted correctly.
- **Include boundary column(s) containing only comments** – keeps these cells associated with the cells being sorted.
- **Include boundary column(s) containing only images** – keeps these cells associated with the cells being sorted.
- **Copy sort results to** – copies the sorted list to the cell range that you specify. Select a named cell range where you want to display the sorted list, or enter a cell range in the input box.
- **Custom sort order** – select this option and then select the custom sort order that you want to apply. The available selections are defined as “fill series” in **Tools > Options > LibreOffice Calc > Sort Lists**. See “Defining a fill series” on page 49.
- **Language** – select the language for the sorting rules.
- **Options** – select a sorting option for the language. For example, select the **Phone book** option for German to include the umlaut special character in the sorting.
- **Top to bottom (sort rows)** – sorts rows by the values in the active columns of the selected range.
- **Left to right (sort columns)** – sorts columns by the values in the active rows of the selected range.
Quick sort
If the columns in the spreadsheet have a header with a text format, you can use a quick sort.

1) Select a cell or a cell range to be sorted.
2) Click the Sort Ascending or Sort Descending icon on the Standard toolbar.

Find and replace
Calc has two ways to find text within a document: the Find toolbar and the Find & Replace dialog. The toolbar is quick and easy to use, but its functions are more limited than using the dialog.

Find toolbar

1) Go to View > Toolbars > Find or Edit > Find on the Menu bar, or use the keyboard shortcut Ctrl+F to open the Find toolbar (Figure 62). By default this toolbar is docked in the lower left of the Calc window. You can undock the toolbar and move it.
2) Type a search term in the Find text box.
3) To refine the search, you can select the Match Case option. For example, if Owner is the search term, selecting Match Case will find Owner but not owner. You can also select the Find All or Formatted Display options.
4) Click the Find Next or Find Previous icon. To find other occurrences of the same term, continue clicking the icon.

Find & Replace dialog
To open the Find & Replace dialog (Figure 63), go to Edit > Find & Replace on the Menu bar, or use the keyboard shortcut Ctrl+H, or click the Find & Replace icon on the Standard toolbar, or click the Find & Replace icon on the Find toolbar.

Finding
1) In the Find & Replace dialog (Figure 63), enter the search criteria in the Find box.
2) If necessary, click on Other options to increase the number of search filters.
3) Click Find Next to locate the first instance of the search criteria.
4) Click Find Next again to locate the next instance of the search criteria. Repeat as needed.
5) Or, click Find All to locate all cells containing the search criteria. These cells will be highlighted in the spreadsheet. A small dialog will pop up, listing the cell locations.

Replacing
1) In the Find & Replace dialog (Figure 63), enter the search criteria in the Find box.
2) Enter the replacement contents in the Replace box.
3) If necessary, click on Other options to increase the number of search filters.
4) To step through the cells and choose whether to replace the contents:
5) Click Find Next to locate the first instance of the search criteria.
6) If necessary, click Replace to replace the search criteria with the contents of the Replace box.
7) Repeat as required.

8) Or, to locate and replace all instances of the search criteria without stopping at each one, click **Replace All**.

---

**Find & Replace dialog**

![Find & Replace dialog](image)

**Tip**

To replace the first instance of the search criteria you can simply press **Replace** without pressing **Find Next** first.

---

**Caution**

Use **Replace All** with caution; otherwise, you may end up with some highly embarrassing mistakes. A mistake with **Replace All** might require a manual, word-by-word search to fix, if it is not discovered in time to undo it.

---

**Find & Replace options**

The options available to refine your find and replace are as follows:

- **Find** – enter the text that you want to search for, or select a previous search from the list.
- **Match case** – distinguishes between uppercase and lowercase characters.
- **Formatted display** – searches for cell contents in a particular format. For example, if a cell has a currency value, say $123.45 and another has the same contents but default formatting (123.45), then searching for “$123.45” will find the currency cell but not the default-formatted cell.
- **Entire cells** – searches for cells with contents that are identical to the search text.
• **All sheets** – Searches through all of the sheets in the current spreadsheet file.

• **Replace** – enter the replacement text, or select a recent replacement text or style from the list.

• **Current selection only** – searches only the selected text or cells.

• **Replace backwards** – search starts at the current cursor position and goes backwards to the beginning of the file.

• **Regular expressions** – select to use wildcards in the search. See LibreOffice Help for more information on the use of regular expressions.

• **Cell Styles** – searches for cell content formatted with the style that you specify. Select this option and then select a style from the **Find** list. To specify a replacement style, select a style from the **Replace** list.

• **Similarity search** – find terms that are similar to the **Find** text. Select this option, and then click the **...** button to define the similarity options.

• **Wildcards** – search for a wildcard expression given in the **Find** text.

• **Diacritic-sensitive** – include diacritics and accents in the search.

• **Direction** – determines the **Rows** or **Columns** order for searching the cells.

• **Search in** – select either **Formulas**, **Values**, or **Notes** to search for the characters that you specify in values, in the results of formulas, or in notes.

**Search Results dialog**

![Search Results dialog](image)

After you select **Find All** on the Find toolbar, or **Find All** or **Replace All** on the Find & Replace dialog, Calc’s initial default behavior is to display the Search Results dialog (Figure 64) after it has completed the operation. This dialog summarizes the results. In addition affected cells are highlighted in the spreadsheet.
The Search Results dialog lists the affected cells and their current content (after any replacement). It also states the number of affected cells. If you deselect the Show this dialog checkbox on the Search Results dialog before pressing the Close button, then the dialog will not be displayed after future Find All or Replace All presses. The display of the Search Results dialog can also be controlled by enabling or disabling the Tools > Options > LibreOffice Calc > View > Window > Summary on search option.
Chapter 3
Creating Charts and Graphs

Presenting information visually
Introduction

Charts and graphs can be powerful ways to convey information and Calc offers a variety of ways to present data. They can be customized to a considerable extent, enabling information to be shown in the clearest manner.


Chart Wizard

Use Chart Wizard to create an initial chart using data in a spreadsheet. Then use the Chart Wizard options to change the type of chart, adjust data ranges, and edit some chart elements. Each change is immediately seen in the chart.

Overview of Chart Wizard

Use Chart Wizard to create an initial chart using data in a spreadsheet. Then use the Chart Wizard options to change the type of chart, adjust data ranges, and edit some chart elements. Each change is immediately seen in the chart.

To demonstrate the process of using Chart Wizard to create charts, the data shown in Figure 65 is used in the following sections. Here is an overview of the basic steps:

1) Select the cells containing all of the data — including names, categories, and labels — to be included in the chart. The selection can be a single block, individual cells, or groups of cells (columns or rows). In this example, it may be best to select the cell range A2:D8, which will intentionally omit the overall title “Equipment Rentals” from the chart.

2) Do one of the following. This will cause a chart to be placed on the spreadsheet as an object (Figure 66) and open the Chart Wizard dialog (Figure 67).
   - Go to Insert > Chart on the Menu bar.
   - Click the Insert Chart icon on the Standard toolbar.

3) Choose the chart type and make any other selections desired. The options are explained below.

4) Click Finish to save the selections and close the Chart Wizard.

---

Figure 65: Example data for creating a chart

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td><strong>Equipment Rentals</strong></td>
<td>Canoes</td>
<td>Boats</td>
</tr>
<tr>
<td>1</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>Jan</td>
<td>12</td>
<td>23</td>
</tr>
<tr>
<td>4</td>
<td>Feb</td>
<td>9</td>
<td>31</td>
</tr>
<tr>
<td>5</td>
<td>Mar</td>
<td>14</td>
<td>27</td>
</tr>
<tr>
<td>6</td>
<td>Apr</td>
<td>17</td>
<td>28</td>
</tr>
<tr>
<td>7</td>
<td>May</td>
<td>13</td>
<td>19</td>
</tr>
<tr>
<td>8</td>
<td>Jun</td>
<td>8</td>
<td>27</td>
</tr>
</tbody>
</table>

Tip

When the data is in one place, the Chart Wizard can guess the range and create an initial chart even if all of the data is not selected. Before opening the Chart Wizard, just place the cursor or select a cell anywhere in the area of the data.
The following sections provide further details about using the Chart Wizard.

**Selecting chart type**

Calc offers a choice of ten basic chart types. Further options vary according to the type of chart selected. For more information about the different chart types see “Gallery of chart types” on page 142.

The initial chart created using the Chart Wizard is a 2D column chart. A small preview of the selected variant is highlighted with a surrounding border, as shown in Figure 67. The name of the variant (*Normal* in Figure 67) is shown below the preview.

To change chart types and options:

1) Select the type of chart from the list under Choose a Chart Type.

2) If needed, select a chart variant in the preview box by clicking on it. The options available depend on the type of chart selected. The chart changes instantly to reflect the selection.

3) To use a 3D chart, select the checkbox **3D Look** and select the type of 3D view (**Realistic** or **Simple**). This option is available only for column, bar, pie, or area chart types.

4) Click **Next** to make changes to data range, data series, and chart elements, explained in greater detail below.

5) When satisfied with the chart, click **Finish** to close the Chart Wizard.
To recreate many of the charts shown in the following sections, select the Column chart type, Normal variant, with the 3D Look option unchecked.

Selecting data range

The data range contains all of the cells with data (including labels and categories) that should be included in the chart. In the Data Range step of the Chart Wizard (Figure 68), manually correct any mistakes in data selection for the chart.

Figure 68: Chart Wizard dialog – selecting data range

To use the Data Range page:

1) If necessary, change the rows and columns used as data for the chart by editing the cell references in the Data range text box. Edit the cell references in one of these two ways:
   – Directly modify the text in the Data range text box.
   – Click the Select data range button to the right of the Data range box. Then use the cursor to select the data range(s) on the spreadsheet.
2) Specify whether the data series are arranged in rows or in columns. In the example data, shown in Figure 65, the data series are in columns.
3) Select whether to use the first row, or first column, or both, as labels.
4) Click Next > to move to making changes to the data series (Figure 69).
5) When satisfied with the chart, click Finish to close the Chart Wizard.

Note

If the syntax for a data range is not correct, Calc shows the text in red.

Selecting non-adjacent data

To create a complete data range from multiple cells that are not next to each other, use a delimiter between individual ranges. For example, the English (USA) locale uses a comma as a delimiter and "$Sheet1.A1:A5,$Sheet1.D1:D5" is a valid data range. A semi-colon is another commonly used delimiter.

The appropriate delimiter depends on the locale selected at Tools > Options > Language Settings > Languages > Locale setting. See or change the default delimiter for a locale at Tools > Options > LibreOffice Calc > Formula. In the Separators section, Array column shows the default delimiter.
To select non-adjacent data, do one of the following in step 1 above:

- Manually enter the data ranges in the text box with delimiter(s) between them.
- Select the data with the cursor by first clicking the Select data range button to the right of the Data range box. Place the cursor at the end of the first data range in the text box (otherwise the first range is selected and then deleted) and enter the delimiter. Then drag the cursor in the spreadsheet to select the next data range.

When the data is in the same document as the chart, changes to the data are instantly reflected in the chart.

**Linking to external data**

Calc offers several options for linking data to external sources. This enables data (and the chart using the data) to automatically update when the external data changes. The following types of files can be linked: HTML, Calc, Base, CSV, Excel, and registered data sources. For further information, refer to Chapter 10, Linking Data, in this guide.

**Selecting data series**

The Data Series page of the Chart Wizard (Figure 69) enables fine tuning of the data. Each data series contains a set of data that have something in common, such as the types of rental equipment listed in Figure 65. Use the Data Series page to change the source range of each data series and to organize how the data is presented in the chart. This includes removing unnecessary data and specifying how data is plotted along the axes.

**Organizing data series**

The Chart Wizard makes initial assumptions about how the data should be displayed, but the assumptions could be incorrect. If a chart does not look as expected, the first thing to check is if all data series are defined correctly.

Also, check the settings on the Data Range page that define whether the data are in rows or columns and whether the first row or first column should be considered labels.

The names of each data series appear in the Data series list box (the middle box in Figure 69). To organize the data series, select an entry in the Data series list and do one or more of the following:

- To change the name of the data series, select Name in the Data ranges list on the right. Edit the cell references in the Range for Name text box that appears.
- To change the cell references for data series categories, edit the cell references in the Categories text box below the Data ranges box.
- Click Add to add another data series below the selected entry. The data ranges for the new data series will then need to be defined.
- Click Remove to remove the selected entry from the Data series list.
• Click the **Up** or **Down** button to move the selected entry up or down in the list. This does not change the order in the data source table, but changes only the arrangement in the chart.

**Note**

Different data series must be in separate columns or rows. Otherwise Calc will assume that they are the same data series.

**Setting data series ranges**

To understand how Calc treats data in charts, it is important to understand the distinction between values and categories. Values are numeric data that vary continuously. By contrast, categories have no mathematical relationship with each other. For example, the categories for the chart data referred to in Figure 69 and the chart shown in Figure 66 are months of the year.

Most Calc charts require both value and category data, with values plotted along the Y axis and categories plotted along the X axis. The exceptions are XY (scatter) charts and bubble charts, which use only value data along both axes.

**Figure 69: Chart Wizard dialog - selecting data series**

Data ranges that may be defined for a specific chart type appear in the **Data ranges** box on the right side of the Data Series page, shown in Figure 69. Not all data ranges may need to be filled in. The data ranges may include:

**Border Color and Fill Color**

Border and fill colors for each data point in the data series can be specified here using numeric values for the RGBA color system. If not specified here, Calc will use default colors. Conditional formatting can also be used. This enables data point colors to vary, depending on whether they meet certain conditions or values. For further information, refer to "Assigning colors" on page 109.

**Name**

When **Data series in columns** and **First row as label** are selected on the Data Range page, Calc assumes that the column labels of the selected data are the data series names. Thus, Calc assumes that the data series names of the data in Figure 65 are “Canoes”,

---

*Selecting data series* | 91
“Boats”, and “Motors”. Similarly, when **Data series in rows** and **First column as label** are selected, Calc assumes that the row labels of the selected data are the data series names.

The only way to change a data series name is by selecting **Name** in the **Data ranges** box in the upper right of Figure 69. Then enter a different cell range in the **Range for Name** box that appears below the **Data ranges** box. (Note that the data series name is often contained in a single cell, rather than a range of cells.)

**Y-Values**

These are numeric values that are often plotted along the vertical axis. However, this is not always the case. For example, while Y-values are plotted on the vertical axis in column charts, they are plotted along the horizontal axis in bar charts.

**Categories**

The range for category data is defined in a separate **Categories** box below the **Data ranges** box. Note the difference between categories and data series names. For the data in Figure 65, the categories are the row labels while the data series names are the column labels.

**Note**

Category data usually appears along the X axis (except for XY (scatter) and bubble charts, which require value data for the X axis).

Depending on the type of chart, other data ranges may need to be defined in addition to those shown in Figure 69.

**Selecting chart elements**

On the Chart Elements page of the Chart Wizard dialog (Figure 70), add or change the title, subtitle, axes names, and grids. Use titles that draw the attention of viewers to the purpose of the chart and describe what they should focus on.

The chart elements for 2D and 3D charts are illustrated in Figure 71.

- The chart wall contains the graphic displaying the data.
- The chart area is the background of the entire chart.
- The chart title and subtitle, chart legend, axes labels, and axes names are in the chart area.
- The chart floor is only available for 3D charts.
To add elements to a chart, do one or more of the following on the Chart Elements page (Figure 70):

- Enter a title and subtitle (if desired) in the Title and Subtitle text boxes.
- Enter names to be used in the X axis and Y axis text boxes. The Z axis text box is only active if creating a 3D chart.
- Select the Display legend checkbox (turned on by default) and choose where to display the legend – Left, Right, Top, or Bottom. The names in the legend are the data series names. Specify the names in the Range for Name field in the Data Series page.
- Under Display Grids, select the Y axis or X axis check boxes to display horizontal or vertical grid lines. For some charts, the axis grids are displayed by default. Grids are not available for pie charts. The Z axis checkbox is only active when creating a 3D chart. For further information about grids, refer to Grids on page 122.

**Note**

While clicking Finish closes the Chart Wizard, the chart is still in edit mode, indicated by gray borders, and can still be modified. Click outside the chart in any cell to exit the edit mode.

**Using the Sidebar to change chart settings**

The Properties deck of the Sidebar (Figure 72) makes some basic options readily available for specifying the appearance of charts. To open the Sidebar, first click outside the chart to deselect it, then go to View > Sidebar on the Menu bar or press Ctrl+F5. By default, the Sidebar opens on the right side of the screen.

**Tip**

If you follow the directions above and the Properties deck of the Sidebar does not appear, click the Properties icon on the upper right of the Sidebar. If the Properties deck still does not appear, click the chart again.
The contents of the Sidebar depend on whether the chart is selected or is in edit mode. The Sidebar on the left in Figure 72 shows the Properties deck when a chart is selected (by clicking on it once). When a chart is in edit mode (by clicking on it twice), the Properties deck on the right in Figure 72 appears.

The options available on the Properties deck of the Sidebar are also available elsewhere. They may be found in the Menu bar, the Formatting toolbar, or context menus (made available by right-clicking a chart element).

Note

The Sidebar can be quite useful. However, because the options are easy to see and are available elsewhere, further references to it are not included in this chapter.
Modifying charts

The Chart Wizard establishes basic features of a chart. After using it, you may want to change data ranges or modify the look of the chart. Calc provides many options for formatting and fine-tuning the appearance of charts. This includes tools for editing the chart type, chart elements, data ranges, fonts, colors, and many other options.

Modify charts in one of two ways, depending on what you want to change.

Edit object properties
Click a chart once to edit its object properties. These include size, position on the page, alignment, outer borders, copying, exporting, and more. See the sections starting with “Resizing, moving, and positioning charts” on page 135 for more information.

Use edit mode
Use edit mode to change data selection and chart type as well as elements such as axes, titles, backgrounds, grids, data series, data labels, trend lines, and more.

Overview of using edit mode
Here are some general ways to modify charts in edit mode. These are discussed in greater detail in the following sections.

- To add an element not already in the chart, use the Insert menu on the Menu bar. Insert titles, legends, axis labels, grids, data labels, trend lines, mean value lines, and error bars.
- To move or change the size of titles, axis names, chart walls, and legends, click on them once. The cursor changes to a move icon (appearance depends on the system). Drag the element to the new location. To change the size, drag the selection handles.
- Modify elements in a few basic ways. The following methods may open the appropriate dialog or menu. Not all of these methods will work for every element:
  - Double-click the element (see an exception below).
  - Select the element from the Insert menu (Figure 73) or Format menu (Figure 74) on the Menu bar.
  - Click the element once, then click on the Format Selection icon on the Formatting toolbar (Figure 75).
  - Select the element from the Select Chart Element drop-down list, then click the Format Selection icon next to it on the Formatting toolbar.
  - Right-click the element to open the context menu.
- Double-click titles and axis names to change their spelling. To modify the spelling of other text, such as categories, data labels, and legend entries, change the text in the data on the spreadsheet.
- Click once on a data point (such as a column or bar) to select and edit the associated data series.
  - With a data series selected, double-click a single data point to edit its properties (for example, a single column in a column chart).

Entering edit mode
To edit or format charts, double-click on the chart to place it in edit mode. The chart is now surrounded by a gray border. In edit mode, the Menu bar changes and the Formatting toolbar contains a number of formatting options and icons, as discussed in the following sections.
Note

The next several sections (until “Resizing, moving, and positioning charts” on page 135) require a chart to be in edit mode.

Insert menu

In edit mode, the Insert menu on the Menu bar displays the options shown in Figure 73 and discussed below:

![Insert menu](image)

**Figure 73: Insert menu when chart is in edit mode**

**Titles**

Provides spaces for entering chart title and subtitle as well as titles for X-, Y-, and Z- axes, including secondary axes. For more information, see “Titles, subtitles, and axis names” on page 100.

**Legend**

Specifies if a legend should be included and if so, where. For more information, see “Legends” on page 102.

**Axes**

Provides options for showing or not showing axis labels. The Chart Wizard automatically shows the labels. For more information, see “Axes” on page 111.

**Grids**

Provides options for showing or not showing major and minor grids for X-, Y-, and Z- axes. To format grids, see “Grids” on page 122.

**Data Labels**

Provides options for text attributes, whether to show categories, and the position and rotation of the labels. These labels appear on each data point. For more information, see “Data labels” on page 118.

**Trend Line**

Specifies the type of regression line to be used, options for extrapolation, where the axes should intersect, the name of the trend line, and whether and how the equation should be displayed. The option is grayed out until a data series is selected. For more information, see “Trend and mean value lines” on page 126.

**Mean Value Lines**

Displays mean value lines for selected or all data series. For more information, see “Mean value lines” on page 130.
X Error Bars and Y Error Bars
Specifies the error category to be used, parameters, and display options for positive and negative indicators. For more information, see “Error bars” on page 131.

Format menu
In edit mode, these settings appear on the Format menu (Figure 74) of the Menu bar. Descriptions of the options follow:

Format Selection
Opens a dialog with settings for whatever element is selected. Options may include area fill, borders, positioning, transparency, fonts, labels, scale, and other attributes.

Position and Size
Enables precise specification of the position and size of a selected element. The position is defined in relationship to the chart. See “Position and Size dialog” on page 136 for more information.

Arrangement
Provides two options: Bring Forward and Send Backward. Only one option may be active for some items. Use these options to arrange overlapping data series.

Title
Formats the title and subtitle for the chart as well as axis names. The text must first be entered on the Chart Elements page of the Chart Wizard or by going to Insert > Titles.

Legend
Formats legend appearance and position. The legend must first be turned on by using the Chart Elements page of the Chart Wizard or by going to Insert > Legend.

Axis
Formats properties such as where the axes cross each other, the scale of units, and formatting of the axis labels.
Grid
Formats the grid lines. Use the Chart Elements page of the Chart Wizard to turn on grids or go to Insert > Grids to turn grids on or off.

Chart Wall, Chart Floor, or Chart Area
Formats borders, area, and transparency of these elements. Note that the chart floor is available only for 3D charts. See “Formatting chart backgrounds” on page 103 for more information.

Chart Type
Changes the type of chart and whether it is a 2D or 3D chart. The various chart types are explained in “Gallery of chart types” starting on page 142.

Data Ranges
Sets ranges for all data in the chart and for individual data series, as explained in “Selecting data range” on page 89 and “Selecting data series” on page 90.

3D View
Formats 3D charts and is only available for 3D charts. Note that only column, bar, pie, and area charts can be displayed as 3D charts. See “3D charts” on page 123 for information.

**Formatting toolbar**

![Formatting toolbar when chart is in edit mode](image)

In edit mode, the Formatting bar appears as in Figure 75. Click one of the icons to open a dialog or turn an option on or off. The Insert and Format menus on the Menu bar, described above, contain the same options, with one exception.
The option *Select Chart Element* drop-down list does not appear elsewhere. Use it to easily select individual chart elements. It can be especially helpful when the chart is crowded or it is otherwise difficult to select elements using the cursor. Note that options such as *Data Labels* or *Trend Line* do not appear on this list unless they have already been inserted using the *Insert* menu.

**Note**

The next several sections (until “Resizing, moving, and positioning charts” on page 135) require a chart to be in edit mode.

### Selecting and moving chart elements

#### Selecting chart elements

After double-clicking on the chart to enter edit mode, select chart elements using one of the following methods:

- Click once on the element in the chart (to select individual data points, click twice — but not too quickly — after clicking once on the data series).
- Select the element from the *Select Chart Element* drop-down list that appears on the left of the Formatting toolbar, as shown in Figure 75.

When selected, the chart element will be highlighted with square selection handles.

**Tip**

When you hover the cursor over an element, Calc will display the element name, making it easier to select the correct element. The name of the selected element also appears in the Status Bar.

#### Moving chart elements

You may wish to move individual elements of a chart, independent of other chart elements. For example, you may wish to reposition the title or axis names. To do so:

1) Select the element as described above.
2) Keep holding down the mouse button. The cursor changes to the move icon (appearance depends on computer setup).
3) Drag the cursor to move the element.
4) Release the mouse button when the element is in the desired location.

Alternatively, use the Position and Size dialog for some elements, as described on page 136.

Individual points or data series cannot be moved, with the exception of pie charts. Individual wedges of a pie can be moved or the entire pie can be exploded. See “Pie charts” on page 144 for information.

To move axis labels, see “Positioning axis, labels, and interval marks” on page 114. To move data labels, see “Adding and formatting data labels for a data series” on page 118.

**Tip**

For some chart elements (such as title, subtitle, axis name, and legend), press the arrow keys to move the object in small steps.
Note

When a 3D chart element is selected, round selection handles may appear. These control the 3D angle of the element. You cannot resize or reposition the element while they are showing. Click again to obtain the square selection handles that allow you to resize and reposition the 3D chart graphic.

Changing chart type

To change the type of chart (bar, column, pie, line, and so on):

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be surrounded by a gray border.
2) Open the Chart Type dialog using one of these methods:
   – Go to Format > Chart Type on the Menu bar.
   – Click the Chart Type icon on the Formatting toolbar.
   – Right-click on the chart and select Chart Type from the context menu.

The dialog is the same as the first page of the Chart Wizard dialog shown in Figure 68 on page 89.

3) Select the chart type and variant desired.
4) Click OK to close the dialog. If desired, click outside the chart to leave edit mode.

For further information about the types of charts, please refer to the “Gallery of chart types” on page 142.

Titles, subtitles, and axis names

Creating or changing text

To create or change the text of a chart title, subtitle, or axis name:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be surrounded by a gray border.
2) Use one of these methods to open the Titles dialog (Figure 76):
   – Go to Insert > Titles on the Menu bar.
   – Click on the Titles icon on the Formatting toolbar.
   – Right-click in the chart area and select Insert Titles from the context menu.
3) Enter or edit the text in the appropriate text box(es).
4) Click OK to close the dialog. If desired, click outside the chart to leave edit mode.

Tip

The text of a title (but not formatting) can be modified directly. Click on it once in the chart (with the chart in edit mode). Click again inside the selection handles to directly change the text (it may take a few clicks to do this). Use Shift+Enter at the end of the line to create an additional line that splits the text.
Figure 76: Basic Titles dialog

Formatting text

Use a more extensive Titles dialog to format the appearance of a chart title, subtitle, or axis name. To access this dialog:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be surrounded by a gray border.
2) Do one of the following to open the Titles dialog for formatting (Figure 77):
   - Click Format > Title and select the desired type of title or the All Titles option.
   - Click on the element in the chart, right-click, and select Format Title (or appropriate element) from the context menu.
   - Click on the element in the chart or select it in the Select Chart Element drop-down list on the Formatting toolbar. Then select Format > Format Selection on the Menu bar or click on the Format Selection icon on the Formatting toolbar.
3) Format titles or names as needed. The options are self-explanatory or easily researched.
4) Click OK to close the dialog. If desired, click outside the chart to leave edit mode.
Legends

When a legend is displayed, it shows data series names along with their graphical representations, such as bars, lines, or points. It will also show trend lines when those are turned on, as shown in Figure 78.

![Figure 78: Example of a chart legend at the bottom of a chart.]

Positioning, inserting or deleting legends

**Inserting or deleting only**

To only insert or delete a legend:

1) Enter edit mode by double-clicking the chart. The chart should now be surrounded by a gray border.

2) Do one of the following:
   - Click on the Legend On/Off icon on the Formatting toolbar. The default position for inserting a legend is on the right side of the chart.
   - Right-click in the chart area and select Insert Legend or Delete Legend from the context menu.

3) If desired, click outside the chart to leave edit mode.

**Note**

The names in the legend are the data series names. They are taken from the Name data range, discussed in “Selecting data series” on page 90. Change a legend name by changing the text in the spreadsheet.

**Positioning, inserting, and deleting**

To position a legend using the basic Legend dialog (Figure 79) as well as insert or delete it, follow the same steps as above but do the following instead of step 2:

1) Go to Insert > Legend on the Menu bar to open the basic Legend dialog.

![Figure 79: Basic Legend dialog]

2) Select or deselect the Display legend checkbox to either display or not display the legend.

3) Select the desired location for the legend – Left, Right, Top, or Bottom.

4) Click OK to close the dialog. If desired, click outside the chart to leave edit mode.
Tip

For finer positioning of the Legend, use one of the methods described in “Moving chart elements” on page 99.

Formatting legends

For advanced editing of a legend’s appearance, a more extensive Legend dialog (Figure 80) has several options for formatting borders, fill, fonts, transparency, and position.

1) Enter edit mode by double-clicking the chart. The chart should now be surrounded by a gray border.
2) Do one of the following to open the Legend dialog (Figure 80):
   - Click on the Legend icon on the Formatting toolbar.
   - Select Format > Format Legend on the Menu bar.
   - Right-click on the legend and select Format Legend from the context menu.
   - Click on Legend in the Select Chart Element drop-down list on the Formatting toolbar or click the legend in the chart to select it. Then click on the Format Selection icon on the Formatting toolbar or select Format > Format Selection.

![Figure 80: Legend dialog with more extensive options](image)

3) Make any desired changes. The options are self-explanatory or easily researched.
4) Click OK to close the dialog. If desired, click outside the chart to leave edit mode.

Formatting chart backgrounds

The background of a chart is divided into chart area, chart wall, and chart floor, as shown in Figure 71 on page 93. Border, area, and transparency options for these areas are set in the following way:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be surrounded by a gray border.
2) Do one of the following to open the appropriate dialog (such as Figure 81):
   - Go to Format on the Menu bar and select Chart Area, Chart Wall, or Chart Floor.
– Right-click the chart wall, chart floor, or chart area in the chart and select **Format Wall**, **Format Floor**, or **Format Chart Area** from the context menu. (For help with selecting these areas, see “Selecting chart elements” on page 99.)

– On the Formatting toolbar, click on the icon for Chart Area 🎨 or Chart Wall 🎨 (there is no icon for chart floor).

– Click on **Chart Area**, **Chart Wall**, or **Chart Floor** in the **Select Chart Element** drop-down list on the Formatting toolbar. Then click the adjacent **Format Selection** icon or select **Format > Format Selection**.

![Chart Area dialog – Transparency tab](image)

Figure 81: Chart Area dialog – Transparency tab

3) Select the desired settings from the **Borders**, **Area**, and **Transparency** tabs.

4) Click **OK** to save the changes and close the dialog. If desired, click outside the chart to leave edit mode.

### Data range and series

The goal of making a chart is to clearly present one or more data series and Calc provides a number of ways to define and present those data. The following sections discuss topics such as defining and changing data ranges, aligning data to a secondary Y axis, and formatting the appearance of the data series.

#### Changing data ranges

When data ranges change in the spreadsheet, modify the chart settings to reflect those changes. Use one of the following methods.

**Note**

The chart automatically reflects changes in the spreadsheet data. Thus, changing a number from 5 to 50 in the data will instantly show the new number in the chart.

**Replacing data by dragging**

It is easy to manually replace one set of data with another set of data. Do this in the following way:

1) Use the mouse to select all of the new data.

2) Drag the data over the chart, then release the mouse. This opens the Change Source Data Range dialog shown in Figure 82.
3) Specify whether or not the first column or row contains labels, then click \textbf{OK}. If desired, click outside the chart to leave edit mode.

![Change Source Data Range dialog](image)

\textit{Figure 82: Change Source Data Range dialog}

**Modifying the data range and data series**

To change the data range or data series, do the following:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be surrounded by a gray border.

2) Open the Data Ranges dialog using one of these methods:
   – Go to \textit{Format > Data Ranges} on the Menu bar.
   – Click on the \textbf{Data Ranges} icon on the Formatting toolbar.
   – Right-click on the chart and select \textbf{Data Ranges} from the context menu.

3) Edit the data range on the \textit{Data Range} tab, which is the same as shown in Figure 68 on page 89.

4) Edit data series on the \textit{Data Series} tab, which is the same as shown in Figure 69 on page 91.

5) Click \textbf{OK} to save changes and close the dialog. If desired, click outside the chart to leave edit mode.

\textbf{Tip}

If Calc is taking a significant amount of time to process a large amount of data for a chart, try this: Select only limited data for each data series to initially organize the chart. Adjust the settings until the chart looks as desired, then select all of the data.

For further information, see “Selecting data range” on page 89 and “Selecting data series” on page 90.

**Opening the Data Series dialog**

The Data Series dialog offers several options for presenting data in the chart. Note that only one data series can be selected at a time.

To open the Data Series dialog (Figure 83):

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be surrounded by a gray border.

2) Do one of the following to select the data series:
   – Click on the data series in the chart.
   – Click the data series name in the \textit{Select Chart Element} drop-down list on the Formatting toolbar.
3) Do one of the following to open the Data Series dialog:
   – Go to **Format > Format Selection** on the Menu bar.
   – Click on the **Format Selection** icon on the Formatting toolbar.
   – Right-click on the data series and select **Format Data Series**.

4) Click the tab of the appropriate page to make the changes needed. The options for each page are explained below.

5) Click **OK** to save changes and close the dialog. If desired, click outside the chart to leave edit mode.

**Figure 83: Data Series dialog – Options tab**

**Note**

The tabs that appear on the Data Series dialog depend on the type of chart selected. Similarly, the controls that appear on each tab may differ depending on the type of chart.

**Alignment, spacing, and plot options**

**Aligning data to secondary Y axis**

A secondary axis may be helpful when data differ in units or scale, as in Figure 84. In this case, there are significantly more numbers of one data series (kayaks). To plot all three data series on the same chart, the kayak data series is aligned to a secondary Y axis, which has a wider scale. The color of the secondary Y axis and the axis titles help to show this relationship.

**Note**

A data series can be associated with a secondary Y axis only after Chart Wizard has finished creating the chart.
To align a data series to a secondary Y axis:

1) Select the data series and open the Data Series dialog as described in the previous section.

2) On the Options tab, under Align Data Series to, select Secondary Y axis.

3) Click OK to close the dialog. If desired, click outside the chart to leave edit mode.

Data can only be aligned to a secondary Y axis, not a secondary X axis. However, it is possible to create secondary X and Y axes that duplicate the primary axes on the opposite sides of a chart. This is described in “Add or remove axis labels” on page 111. It is also possible to show different units or scales on the secondary axis (with or without aligning data to it), as described under “Defining Scales” on page 113.

Spacing and plot options

The Options tab of the Data Series dialog (Figure 83) contains additional settings that depend on the type of chart. These include:

Spacing
Sets the spacing interval of columns or bars between category settings, such as time. Values above 100% increase the spacing while values below 100% decrease the spacing. Maximum spacing is 600%.

Overlap
Sets overlap of columns or bars within the same category setting, such as a specific time. The higher the percentage, the greater the overlap (maximum of 100%). Negative percentages increase the separation (minimum of -100%).

Show bars side by side
When checked, shows no gap in columns or bars in the interval between categories. When this option is not checked, data aligned to a secondary Y axis may hide other data. Enable the option to prevent this.

Plot missing values
Specifies handling of missing values, with options depending on the type of chart.

Include values from hidden cells
Enables data from hidden cells to be included or not included.

Hide legend entry
Enables the name of the selected data series to be included or removed from the legend.
Two additional options (not shown in Figure 83) appear for pie or donut charts:

**Orientation**
Specifies the order of the pie sections (data points) – clockwise or counter-clockwise. The default direction is counterclockwise.

**Starting Angle**
Specifies the starting angle of the first pie section (data point), in the range 0 to 359 degrees. Drag the small dot around the circle or enter a number for the degrees. Use 0 degrees to start the first section at the 3 o’clock position and 90 degrees to start the first section at 12 o’clock.

**Area, transparency, and borders**

![Data Series dialog – Area tab, Gradient page](image)

Figure 85: Data Series dialog – Area tab, Gradient page

For chart types other than line and scatter, the Data Series dialog (Figure 85) contains pages for formatting the fill and borders of graphical representations such as columns and bars. The Area tab offers options for selecting color by clicking directly on a color in a palette, adding a custom palette, or by specifying the RGB or Hex color codes. Other pages contain options for gradient, bitmap, pattern, hatch, transparency, and borders. The options are self-explanatory or can be readily researched.

**Tip**
If applying a gradient does not work as expected, do this: After selecting the desired options on the Gradient page, click **Add**, provide a name for the gradient (or accept the default), and click **OK**.
**Lines, areas, and data point icons**

For some chart types (such as line charts and xy (scatter) charts), the Data Series dialog contains only an **Options** tab and a **Line** tab (Figure 86).

Specify line style, color, width, and transparency of the line on the left side of the **Line** tab. In the **Icon** section, select an option for the symbol from the drop-down list: **No Symbol**, **Automatic**, **From file**, **Gallery**, or **Symbols**.

- **From file** opens a browser for selecting the file that contains the desired symbol.
- **Gallery** opens a list of available graphics that can be selected.
- **Symbols** opens a list showing available symbols that can be selected.

![Figure 86: Data Series dialog for line and scatter charts – Line tab](image)

A preview of the selection is shown in the preview box at the bottom of the dialog. Enter the desired width and height of the symbol. Select **Keep ratio** if the ratio of width to height of the symbol should be maintained.

**Assigning colors**

Colors for the display of data series can be specified in three ways: changing the default color scheme, using the Data Series dialog, or using data ranges to set colors for border and fill.

**Changing default color scheme**

To modify the default color scheme for data series, go to **Tools > Options > Charts > Default Colors** to specify colors for each data series. Changes made here affect the default colors for any future chart.

**Using Data Series dialog**

As discussed in the previous section, the Data Series dialog has options for assigning colors for lines, areas, and borders. Available options depend on the type of chart.

**Using data ranges to assign colors**

Use the **COLOR** function in the Function Wizard (described in Chapter 7, Using Formulas and Functions) to specify colors with numbers based on combined RGB values. Then assign the numbers to data ranges for border and fill colors in the **Data Series** page of the Chart Wizard (see...
“Selecting data series” on page 90) or in the Data Series tab of the Data Ranges dialog (see "Changing data ranges" on page 104).

For example, using the COLOR function in the Function Wizard, enter 255 for R (red), 0 for G (green), and 255 for B (blue). The COLOR function calculates a combined RGB value of 16711935. Then, when defining data ranges, enter the RGB value(s) in the cell range for border or fill color. Optionally, include a value for the alpha channel (A) in the COLOR function. The value of A can range from 0 (fully transparent) to 255 (fully opaque).

**Note**

Data ranges for border color and fill can only be specified for column, bar, pie, bubble, and column and line charts.

In addition to directly assigning colors, use conditional formatting to define criteria for when specific colors will be used. (Conditional formatting is described in Chapter 2, Entering, Editing, and Formatting Data.)

Figure 87 shows an example of using conditional formatting to specify colors. The COLOR function in the Formula Wizard was used to create the conditional formula

\[ \text{=IF(B2>100,COLOR(240,240, ,20),COLOR(150,0,150,20))} \]

This formula says that when the value in column B is over 100, the first RGB setting is used to color that data point in the chart. When the value in column B is 100 or less, the default color (150, 0, 150) is used. This formula is in all cells of column C. The numbers appearing in column C are the RGB values calculated using the conditional formula (with cell references changed accordingly).

![Figure 87: Using the COLOR function and a conditional formula to specify colors.](image)

The chart on the right in Figure 87 shows how the colors change to reflect the conditional formatting.

**Formatting Data Points**

Modify the appearance of an individual data point such as a column or bar using the Data Point dialog. For most chart types, the dialog contains the same Area, Transparency, and Borders pages as the Data Series dialog shown in Figure 85 on page 108. For line, scatter, net, and stock charts, the dialog contains the same options as the Line tab of the Data Series dialog shown in Figure 86 on page 109.

To format data points:

1) Enter edit mode by double-clicking the chart. The chart should now be surrounded by a gray border.
2) Click two times (but not too quickly) on the data point to be formatted. The data point will show square selection handles.

3) To open the Data Point dialog, do one of the following:
   - Go to **Format > Format Selection**.
   - Right-click on the data point and select **Format Data Point** from the context menu.
   - Click the **Format Selection** icon on the Formatting toolbar.

4) Apply formatting options as desired.

5) Click **OK** to close the dialog. If desired, click outside the chart to leave edit mode.

---

**Tip**

As shown in Figure 88, hover the cursor over a data point to show the number of the data point, the number of the series, and the X and Y values of the data point.

---

**Axes**

**Add or remove axis labels**

Use the basic Axes dialog shown in Figure 89 to add or remove axis labels, such as numbers or categories. (To change the name of an axis, see “Titles, subtitles, and axis names” on page 100).

---

To use the basic Axes dialog:

1) Enter edit mode by double-clicking the chart. The chart should now be surrounded by a gray border.

2) Open the basic Axes dialog by doing one of the following:
Go to **Insert > Axes** on the Menu bar.

Right-click on the chart and select **Insert/Delete Axes** from the context menu.

3) Select or deselect the check boxes for axis labels. The Z-axis checkbox is only active when a 3D chart has been created.

4) Click **OK** to close the dialog. If desired, click outside the chart to leave edit mode.

![Figure 90: Both secondary axes enabled.](image)

Selecting a secondary X axis or a secondary Y axis in this dialog creates duplicate labels on the opposite side of the chart, as shown in Figure 90. To specify different units or intervals for the secondary axis, use the **Scale** tab of the more extensive Axes dialog described in the following section.

It is also possible to align one or more data series to the secondary Y axis. Do this using the Data Series dialog, described in “Aligning data to secondary Y axis” on page 106.

**Edit and format axes**

In addition to the simple dialog above, a more extensive **Axis** dialog contains options for grid intervals, positioning the axis, formatting the axis line and axis labels, and defining the scale, among other settings. Use a dialog for a specific axis, or use a dialog that applies to all axes. The options in the dialog depend on which axis was selected, type of chart, and whether the chart is 2D or 3D.

To open the more extensive Axis dialog:

1) Enter edit mode by double-clicking the chart. The chart should now be surrounded by a gray border.

2) Open a specific axis dialog (Figure 91) by doing one of the following (some options do not allow choosing all axes):
   - Go to **Format > Axis** on the Menu bar and select the desired axis (**X Axis**, **Y Axis**, **Z Axis**, **Secondary X Axis**, **Secondary Y Axis**, or **All Axes**).
   - Right-click on the desired axis in the chart to open the context menu. Then select **Format Axis**.
   - Click the axis on the chart or select the axis in the **Select Chart Element** drop-down list on the Formatting toolbar and click the adjacent **Format Selection** icon.
   - Click on the icon for **X Axis**, **Y Axis**, or **Z Axis** on the Formatting toolbar. Or click on the **All Axes** option to the right of the other icons.

3) Click the tab of the appropriate page to make the changes needed. The options for each page are explained below.

---

112 | Axes
4) Click **OK** to save changes and close the dialog. If desired, click outside the chart to leave edit mode.

![Figure 91: Axis dialog – Scale tab](image)

**Defining Scales**

Use the **Scale** tab to modify the automatically generated scale for a primary axis. In addition, use the **Scale** tabs for secondary axes to specify scales that are different from the scales for primary axes. This can be quite useful for showing Celsius and Fahrenheit scales on the same chart, for example, or for when data are aligned to a secondary Y axis (see “Aligning data to secondary Y axis” on page 106).

The contents of the **Scale** tab (Figure 91) vary but may contain the following options:

**Reverse direction**

Defines the order of lower and higher values along the axis. When not selected, the X axis shows the lower values on the left and the Y axis shows the lower values at the bottom. When selected, the orientation of the data display is reversed, as in Figure 92.

![Figure 92: Result when direction is reversed on the Y axis](image)

**Logarithmic scale**

Specifies that the axis is to be subdivided logarithmically. Logarithmic scaling makes the grid lines of the axis equidistant from each other, but the values between the lines are not equal. Use this option when working with values that differ sharply from each other.

**Minimum/Maximum**

Sets the first/last value for the axis. **Automatic** must be deselected to set this option manually.
Major interval
Defines the intervals between major divisions of the axis. These intervals will be used for interval marks (specified on the Positioning tab of the Axis dialog) and gridlines. Automatic must be deselected to set this option manually.

Minor interval count
Defines the number of intervals (not the values between intervals) that subdivide the major intervals. The same as for major intervals, the interval count defined here will be used for interval marks (specified on the Positioning tab of the Axis dialog) and gridlines. Automatic must be deselected to set this option manually.

For some types of charts, additional options may be available:

Type
Specifies whether the labels are text, date, or should be detected automatically.

Resolution
For dates, specifies that the interval steps should be days, months, or years.

Tip
If the X axis is not displaying time as expected, manually entering the minimum and maximum times on the Scale tab may solve the problem.

Positioning axis, labels, and interval marks
The Positioning tab (Figure 93) controls the position of axis labels and interval marks.

Axis Line
Sets where the axis crosses the other axis, as shown in Figure 94. The options on the drop-down list are Start, End, or a specific value or category.
Labels
Sets where axis labels are placed, using the Place labels drop-down list. The Outside end and Outside start options are useful for positioning labels on axes with negative numbers, as shown in Figure 95.

![Figure 95: Axis label positions](image)

Interval Marks
- **Major/Minor** – specifies whether interval marks are displayed for major/minor intervals. These intervals are defined on the Scale tab, described above.
- **Inner/Outer** – specifies whether interval marks are placed on the inner or outer side of the axis. The interval marks in Figure 95 are on both sides.
- **Place marks** – specifies where to place the marks: At labels, At axis, or At axis and labels. (The top two charts in Figure 95 show the labels along the axes. The marks are thus both at axis and labels. The marks in the bottom two charts are located at the labels.)

**Line tab**
The Line tab has options for formatting the axis line style, color, width, and transparency. It has the same contents as the Line tab of the Data Series dialog shown in Figure 86 on page 109 but excluding the controls in the Icon area.

**Label tab**
On the Label tab (Figure 96), choose whether to show or hide the labels and specify how to handle them when they do not fit neatly in the chart. The options are described below.
Show labels
Sets whether to show or hide the axis labels.

Order
Defines the horizontal or vertical alignment of the labels on the X or Y axis. These options are available only for 2D charts.

- **Tile** – arranges labels on the axis side by side.
- **Stagger odd** – stagers labels on the axis, with even numbers lower than odd numbers (even numbers to the left on vertical axis).
- **Stagger even** – stagers labels, with odd numbers lower than even numbers (odd numbers to the left on vertical axis).
- **Automatic** – automatically arranges labels on the axis.

**Note**
Problems may arise in displaying labels if the chart is too small. Avoid this by either enlarging the chart or decreasing the font size.

Text flow
Determines how text flows in axis labels.

- **Overlap** – allows axis labels to overlap.
- **Break** – allows text breaks, enabling text to wrap into new lines in the available space.

Text Orientation
Defines the direction and orientation of label text.

Vertically stacked
Stacks characters vertically so that text is read from top to bottom.

ABCD wheel
Defines text orientation by clicking and dragging the indicator on the wheel. Orientation of the characters "ABCD" on the wheel corresponds to the new setting.

Degrees
Shows the orientation angle of the text as determined by the ABCD wheel or by manually entering the degrees in the spin box.
**Text direction**

Specifies the direction for any text that uses complex text layout (CTL). CTL is only available if enhanced language support is enabled in **Tools > Options > Language Settings > Languages**. Under **Enhanced Language Support**, check **Ignore system input language**.

**Numbers**

Use the **Numbers** tab (Figure 97) to set the attributes for any numbers used on the axis. When **Source format** is selected (as it is by default), numbers are formatted exactly as they are formatted on the spreadsheet. Deselect this option to change number formatting. For information about formatting numbers, see Chapter 2, Entering, Editing, and Formatting Data, in this guide as well as the online Help.

*Figure 97: Numbers tab of Axis dialog*

**Font and font effects**

Use the **Font** and **Font Effects** tabs to set the font and font effects for the axis labels. These pages are the same as the tabs for specifying fonts and font effects in cells. See Chapter 2, Entering, Editing, and Formatting Data for more information.

**Asian typography**

Sets the Asian typographic options for axis labels. It is only available if enhanced language support is enabled in **Tools > Options > Language Settings > Languages**. Under **Enhanced Language Support**, check **Ignore system input language**. Options on this page include:

- **Apply list of forbidden characters to the beginning and end of lines**
  Prevents the characters in the list from starting or ending a line. The characters are relocated to either the previous or the next line. To edit the list of restricted characters, go to **Tools > Options > Language Settings > Asian Layout**.
Allow hanging punctuation
Prevents commas and periods from breaking a line. Instead, these characters are added to the end of the line, even in the page margin.

Apply spacing between Asian and non-Asian text
Inserts a space between Asian and non-Asian text.

Hierarchical axis labels
Multiple levels of categories can be displayed in a hierarchical manner along the axis of a chart. Hierarchical axes labels are created automatically if the first column or row defined as data is text (as opposed to the first column or row defined as labels). An example of hierarchical labels is shown in Figure 98. In this case, Calc automatically defines the data range for categories as the first two columns in the spreadsheet. This is reflected in the chart, which shows the hierarchical relationship between quarters and months.

Data labels
Data labels display information next to data points on the chart. They can be quite useful for highlighting specific data when presenting detailed information, but be careful not to create a chart that is too cluttered to read easily.

Adding and formatting data labels for a data series
To add or format data labels for a data series:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be surrounded by a gray border.

2) Do one of the following to select a specific data series:
   – Click once somewhere in the data series.
   – In the Select Chart Element drop-down list of the Formatting toolbar, select the data series name.

   **Note**
   If no data series is selected, then all data series on the chart will be labeled.

3) To open the Data Labels dialog (Figure 99), do one of the following:
   – Go to Insert > Data Labels on the Formatting toolbar.
First right-click on the selected data series in the chart and select Insert Data Labels from the context menu. Calc displays data labels with default settings. Then right-click again and select Format Data Labels from the context menu.

4) Select the options as desired. The options are explained below.
5) Click OK to close the dialog. If desired, click outside the chart to leave edit mode.

Tip

Select a data series by clicking once on a column, bar, or other graphic representation of the data series. Select a single data point by pausing, then clicking again.

Most of the pages in the Data Labels dialog are used in other dialogs and can be readily understood or easily researched. The exception is the Data Labels tab (Figure 99), which contains the following options:

![Data Labels dialog](image)

**Figure 99: Data Labels tab of the Data Labels dialog**

**Show value as number**
- Displays the numeric value of a data point. When selected, this option activates the Number format button.

**Number format**
- Opens the Format Number dialog, which is the same as the Numbers tab of the Format Cells dialog discussed in Chapter 2, Entering, Editing, and Formatting Data. Deselect Source format to activate options on this page.

**Show value as percentage**
- Displays the percentage value of the data points in each data series. When selected, this option activates the Percentage format button. Note that the percentage referred to is a data point's Y value as a percent of total Y values for a specific X category or value. Thus, in Figure 100, the February canoe value 9 is 10% of the total February value of 94 (the sum of 9, 31, and 54).
Percentage format
Opens the Number Format for Percentage Value dialog. Deselect Source format to activate options on this page.

Figure 100: Examples of data label options

Show category
Displays the category next to each data point. This option is activated for all data labels in Figure 100. Thus, all data labels show the month. The text for data labels comes from the category data series and cannot be changed in the chart. It can only be changed in the spreadsheet data.

Show legend key
Displays the legend icon for the data series next to each data point. Figure 100 shows the legend keys for motors and boats, but not for canoes.

Auto text wrap
Wraps data label text if needed.

Separator
Selects what will be used to separate multiple text strings when at least two options above are selected. In Figure 100, the separator is Semicolon for the canoes data labels, New line for the motors data labels, and Comma for the boats data labels (with the exception of the June label, which was modified for better fit). A further option is Space.

Placement
Specifies the placement of data labels relative to the data point representation. In Figure 100, the placement of data labels is Below for canoes, Above for boats, and Right for motors. Other available options are Left and Center.

Rotate Text
Sets the text orientation of data labels by using the dial or entering the rotation angle.

Text Direction
Specifies the text direction when Complex Text Layout (CTL) is enabled. (CTL is needed when the shape or position of characters depends on the context, such as in Arabic script).

Data labels for individual data points
Sometimes it is appropriate to apply data labels to one or a few data points rather than all data points. This reduces clutter and highlights the most important data.
Adding a single data label
Insert a data label for a single data point in the following way:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be surrounded by a gray border.

2) Click the data point once, pause, then click again to select it. (Clicking too quickly opens the Data Series dialog.)

3) Right-click on the selected data point and select Insert Single Data Label from the context menu. The data label will have the default settings.

4) Click OK to close the dialog.

5) If desired, click outside the chart to leave edit mode.

Formatting the label for a single data point
To format an existing label for a single data point, follow the directions above but instead of step 3, do the following to open the Data Label dialog (Figure 99): right-click on the data point and select Format Single Data Label from the context menu.

The options in the Data Label dialog are described above.

You can also access the Data Label dialog by clicking on the data label, pausing, and then clicking on it again. Then right-click and select Format Single Data Label from the context menu.

Removing data labels
Remove labels from a single data point, a single data series, or all data points using one of the methods below.

Before doing any of the following, first select the chart by double-clicking on it to enter edit mode. The chart should now be surrounded by a gray border. When finished, click OK to close the dialog and remove the data labels. Then if desired, click outside the chart to leave edit mode.

Removing all data labels from a single data series

Method One
Right-click somewhere in the data series and select Delete Data Labels from the context menu.

Method Two
1) Do one of the following to open the Data Labels dialog (Figure 99):
   – Click somewhere in the data series to select it. Go to Insert > Data Labels on the Menu bar.
   – In the Select Chart Element drop-down list of the Formatting toolbar, select the data labels entry for the required series name and then click the adjacent Format Selection icon.
   – Right-click in the data series and select Format Data Labels from the context menu.

2) On the Data Labels tab, deselect all of the options.

Removing a data label from a single data point

1) Click once on the data point, pause, then click again to select it.

2) Right-click to open the context menu and select Delete Single Data Label.

Removing all data labels

1) Make sure that no data label or data series is selected.

2) Go to Insert > Data Labels on the Menu bar.
3) On the Data Labels dialog, deselect all of the options for the data labels to be removed, then click **OK**.

**Grids**

Grid lines or grids divide the intervals along axes to help estimate data point values. Major and minor grid lines are shown in Figure 101. The darker lines with numbers are major grid lines while the lighter lines between them are minor grid lines. Note that the Y-axis major grid line is activated by default.

![Figure 101: Major and minor gridlines for the X and Y axes](image)

Grids are available for all chart types with the exception of pie charts.

**Adding/removing grid lines**

1) First select the chart by double-clicking on it to enter edit mode. The chart should now be surrounded by a gray border.

2) Do one of the following:

   – Go to **Insert > Grids** on the Menu bar to open the basic Grids dialog (Figure 102). Select/deselect the check boxes as needed. The **Z axis** checkbox is only active for a 3D chart.

   ![Figure 102: Basic Grids dialog](image)

   – Click the **Horizontal Grids** icon or **Vertical Grids** icon, both located on the Formatting toolbar. Clicking once turns on the major grid lines. Clicking twice turns on the minor grid lines as well. Clicking again turns off the grids.

3) Click **OK** to close the dialog. If desired, click outside the chart to leave edit mode.

**Note**

In the Formatting toolbar, the **Horizontal Grids** icon and the **Vertical Grids** icon set grid lines for the Y axis and X axis, respectively. This can be misleading because both the Y axis and the X axis can be horizontal or vertical, depending on the type of chart. Thus, for a bar chart, click the **Horizontal Grids** icon to control the vertical grids.

**Formatting grids**

In addition to the basic Grids dialog shown in Figure 102, there is another dialog for formatting grids. To open the grid formatting dialog:
1) Select the chart by double-clicking on it to enter edit mode. The chart should now be surrounded by a gray border.

2) Go to Format > Grid on the Menu bar and click on the appropriate type of grid to open the Grid formatting dialog (Figure 103).

3) Set formatting options for line style, color, width, and transparency.

4) Click OK to close the dialog. If desired, click outside the chart to leave edit mode.

Note

Use the Scale tab of the Axis dialog to specify the intervals between grid lines. This is described in “Defining Scales” on page 113.

3D charts

Setting 3D look

Column, bar, pie, and area charts can be displayed as 3D charts. The setting to make a chart 3D is on the first page of the Chart Wizard. If the chart has already been created, do the following to give it a 3D look:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be surrounded by a gray border.

2) Do one of the following:
   – Go to Format > Chart Type.
   – Click on the Chart Type icon in the Formatting toolbar.
   – Right-click in the chart and select the Chart Type option in the context menu.

3) Select 3D Look in the Chart Type dialog.

4) Click OK to close the dialog. If desired, click outside the chart to leave edit mode.
Formatting 3D view

To make changes to a 3D chart, use the 3D View dialog (Figure 104).

Use the 3D View dialog to change the 3D appearance, including perspective, formatting scheme, and illumination. Note that the chart must already be set to show a 3D look, as described above. To open the 3D View dialog:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be surrounded by a gray border.

2) Do one of the following:
   – Right-click on the chart and select **3D View** from the context menu.
   – Go to **Format > 3D View**.
   – Click on the **3D View** icon in the Formatting toolbar.

3) Click **OK** to close the dialog. If desired, click outside the chart to leave edit mode.

This dialog has three tabs, which are explained below.

**Figure 104: 3D View dialog – Perspective tab**

**Rotation and perspective**

Some hints for using the **Perspective** tab (Figure 104) to rotate a 3D chart or change its perspective view:

- Set all angles to 0 for a front view of the chart. Pie charts and donut charts are shown as circles.
- With **Right-angled axes** enabled, the chart can be rotated only in the X and Y direction; that is, parallel to the chart borders.
- An X value of 90, with Y and Z set to 0, provides a view from the top of the chart. With X set to –90, the view is from the bottom of the chart.
- Rotation is applied in the following order: X axis first, then Y axis, and Z axis last.
- When shading is enabled and the chart is rotated, the lights are rotated as if they are fixed to the chart.
- The rotation axes always relate to the page, not to the axes of the chart. This is different from some other chart programs.
- Select the **Perspective** option to view the chart in central perspective as through a camera lens (as opposed to using a parallel projection). Set the focal length with the spin box or type a number in the box. With a 100% setting, a far edge in the chart looks approximately half as big as a near edge.
Rotating 3D charts interactively
In addition to using the Perspective tab of the 3D View dialog to rotate 3D charts, rotate 3D charts interactively in the following way:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be surrounded by a gray border.
2) Click once on the chart wall to select it, causing round selection handles to appear. The cursor changes to a rotation icon.
3) Press and hold the left mouse button while dragging in the direction desired. A dashed outline of the chart is visible to help see how the result will look.
4) Release the mouse button when satisfied.
5) Click outside the chart to exit edit mode.

Appearance
Use the Appearance tab of the 3D View dialog (Figure 105) to modify some aspects of the appearance of the data in a 3D chart.

First select a scheme from the Scheme drop-down list – Realistic (default) or Simple. The scheme selected sets the options and light sources. Depending on the scheme selected, not all options may be available. To create a custom scheme, select or deselect a combination of Shading, Object borders, and Rounded edges.

Some hints:
- Select Shading to use the Gouraud method for rendering the surface. Otherwise, a flat method is used. The flat method sets a single color and brightness for each polygon. The edges are visible but soft gradients and spotlights are not possible. The Gouraud method applies gradients for a smoother, more realistic look. See the Draw Guide for more information on the use of shading.
- Select Object borders to draw lines along the edges.
- Select Rounded edges to smooth the edges of boxy shapes.

Illumination
Use the Illumination tab (Figure 106) of the 3D View dialog to control light sources for the 3D view. Here are the options with some hints:

- Click any of the eight buttons to switch a directed light source on or off.
- The first light source projects a specular light with highlights.
- By default, the second light source is switched on. It is the first of seven normal, uniform light sources.
• For the selected light source, select a color from the first drop-down list below the eight light source buttons. Note that the brightness values of all lights are added together, so use dark colors when enabling multiple lights.

• The small preview in the dialog shows the effect of repositioning the light source.

• Each selected light source appears as a small colored sphere in the specified color. The sphere is larger when the light source is actively selected.

• Each light source always points at the middle of the object initially. Move the vertical slider to adjust the lighting angle. The horizontal slider rotates the light around the object. In addition, click the light source and drag it to the desired location.

• Click the button in the bottom right corner of the preview to switch the internal illumination model between a sphere and a cuboid.

• Use the Ambient light drop-down list to define the ambient light, which shines with a uniform intensity from all directions.

See the Draw Guide for more information on setting the illumination.

![Figure 106: 3D View dialog – Illumination tab](image)

### Trend and mean value lines

Trend lines help show the relationships among scattered data points of a data series. Calc has a good selection of regression types for creating trend lines: linear, logarithmic, exponential, power, polynomial, and moving average. Choose the type that comes closest to passing through all of the points in a data series.

Trend lines can be added to all 2D chart types except for pie, net, and stock charts. When inserted in the chart, representations of the trend lines are automatically shown in the chart legend.

**Note**

For chart types that use categories for the X axis, such as column, bar, or line charts, the numbers 1, 2, 3… are used as values for calculating trend lines. By contrast, XY (scatter) chart types (which include bubble charts) show data rather than categories along the X axis. Thus, only XY chart types can show meaningful regression equations.

### Adding and modifying trend lines

Trend lines can only be added to one data series at a time. To add a trend line to a data series:

---

126 | Trend and mean value lines
1) Double-click on the chart to enter edit mode. The chart should now be surrounded by a gray border.

2) Select the data series by doing one of the following:
   – Click once on a data series representation such as a bar, column, line, or point.
   – Select the data series from the Select Chart Element drop-down list on the Formatting toolbar.

3) Do one of the following to open the Trend Lines dialog (Figure 107):
   – Go to Insert > Trend Lines on the Menu bar.
   – Right-click on the data series and select Insert Trend Line from the context menu.

4) Select the type of regression and choose desired options. These are explained below.

5) Click OK to close the dialog and place the trend line in the chart. If desired, click outside the chart to leave edit mode.

**Regression types**

By default, \( x \) is used for the abscissa variable and \( f(x) \) for the ordinate variable. Change the names under X Variable Name and Y Variable Name on the Trend Line dialog.

**Linear trend line**
Regression through equation \( y = a \cdot x + b \). Intercept \( b \) can be forced and only positive \( x \) values are considered.

**Polynomial trend line**
Regression through equation \( y = \sum a_i \cdot x^i \). Intercept \( a \) can be forced. Degree of polynomial must be given (at least 2).

**Logarithmic trend line**
Regression through equation \( y = a \cdot \ln(x) + b \). Only positive \( x \) values are used.

**Exponential trend line**
Regression through equation \( y = b \cdot \exp(a \cdot x) \). This equation is equivalent to \( y = b \cdot m^x \), with \( m = \exp(a) \). Intercept \( b \) can be forced. Only positive \( y \) values are considered, except if all \( y \) values are negative. In that case, the equation used is \( y = -b \cdot \exp(a \cdot x) \).

**Power trend line**
Regression through equation \( y = b \cdot x^a \). Only positive \( y \) values are considered, except if all \( y \) values are negative. In that case, the equation used is \( y = -b \cdot x^a \).

**Moving Average trend line**
Simple moving average for \( n \) previous \( y \)-values, with \( n \) being the period. No equation is available for this trend line.

**Trend line options**

**Trendline Name**
Specifies the name to be used for labeling the equation in the legend; see Figure 108.

**Extrapolate Forward/Backward**
Specifies the number of units the trend line should be extended forward or back. This only works for charts that have numeric values along the X axis rather than categories.

**Force Intercept**
Forces the line to cross the Y axis at the specified value.

**Show Equation**
Displays the equation in the chart, as shown in Figure 108.
**Show Coefficient of Determination ($R^2$)**
Displays the coefficient of determination in the chart. Shown with the polynomial equation in Figure 108.

**X and Y Variable Names**
Enables changing the names of X or Y variables for displaying the equation in the chart. The **Show Equation** option must be checked for these options to be active.

---

**Figure 107: Trend Line dialog – Type page**

**Figure 108: Trend lines showing various equations**

128 | Trend and mean value lines
Select a trend line to display information about it in the Status bar, as shown in Figure 109. The Status bar is normally located at the bottom of the spreadsheet.

![Figure 109: Equation information displayed in the Status bar](image)

**Formatting trend lines**

When inserted, a trend line has the same color as the corresponding data series. To change the style, color, width, or transparency of a trend line, use the *Line* tab of the Trend Line dialog (Figure 110). The options are easily understood or researched.

![Figure 110: Trend Line dialog – Line tab](image)

**Formatting trend line equations**

Display the equation in the chart by selecting **Show Equation** in the Trend Line dialog (Figure 107). Options for the trend line equation include formatting the border around the equation, area fill, transparency, font, and alignment. The number style can also be specified — this may be quite useful, especially for specifying the number of decimal places.

To format trend line equations:

1. Select the chart by double-clicking on it to enter edit mode. The chart should now be surrounded by a gray border.
2. Do one of the following to open the Equation dialog:
   - Select the equation on the *Select Chart Element* drop-down list and then click the **Format Selection** icon next to it on the Formatting toolbar.
   - Click once on the equation to select it then click the **Format Selection** icon on the Formatting toolbar.
   - Right-click on the equation and select **Format Trend Line Equation** from the context menu.
3. Select the desired options on the dialog. The options are self-explanatory or easily researched. The *Numbers* tab has the same options as the *Numbers* tab of the *Axis* dialog, Figure 97 on page 117.
4. Click **OK** to close the dialog.
5. If desired, click outside the chart to leave edit mode.
Deleting trend lines

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be surrounded by a gray border.

2) Do one of the following:
   – Select the trend line and press the Delete key.
   – Right-click on the trend line and select Delete Trend Line from the context menu.

3) If desired, click outside the chart to leave edit mode.

Mean value lines

Mean value lines are a special type of trend line. To create one, Calc calculates the average of a data series and places a colored line at that value in the chart, as shown in Figure 111. They can only be created for 2D charts and cannot be created for pie, net, or stock charts.

![Figure 111: Mean value lines](image)

Inserting mean value lines

For all data series (if no data series is selected, mean value lines are inserted for all data series):

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be surrounded by a gray border.

2) Go to Insert > Mean Value Lines on the Menu bar.

3) If desired, click outside the chart to leave edit mode.

For a single data series:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be surrounded by a gray border.

2) Select a data series by doing one of the following:
   – Click once somewhere in the data series.
   – Select the data series from the Select Chart Element drop-down list on the Formatting toolbar.

3) Add the mean value line by doing one of the following:
   – Go to Insert > Mean Value Lines on the Menu bar.
   – Right-click on the data series and select Insert Mean Value Line from the context menu.

4) If desired, click outside the chart to leave edit mode.
**Modifying mean value lines**
When inserted, a mean value line has the same color as the corresponding data series. To modify the style, color, width, and transparency of a mean value line:

1) Double-click on the chart to enter edit mode. The chart should now be surrounded by a gray border.

2) Do one of the following to open the Mean Value Line dialog (the dialog has the same options as the Line tab of the Trend Line dialog in Figure 110):
   - Right-click on the mean value line and select **Format Mean Value Line** from the context menu.
   - Select the appropriate mean value line from the **Select Chart Element** drop-down list on the Formatting bar, then click the **Format Selection** icon in the Formatting toolbar, or select **Format > Format Selection**.

3) Make desired changes.

4) Click **OK** to close the dialog. If desired, click outside the chart to leave edit mode.

**Deleting mean value lines**

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be surrounded by a gray border.

2) Do one of the following:
   - Select the mean value line and press the **Delete** key.
   - Right-click on the data series and select **Delete Mean Value Line** from the context menu.

3) If desired, click outside the chart to leave edit mode.

**Error bars**

Error bars, shown in Figure 112, can be useful for presenting data that has a known possibility of error, such as social surveys using a particular sampling method, or for showing the measuring accuracy of the tool used. They can be created for 2D charts only and cannot be created for pie, net, or stock charts.

![Figure 112: Error bars showing variance (Canoes), standard deviation (Boats), and standard error (Motors)](image-url)
Inserting error bars

If no data series is selected, X or Y error bars are inserted for all data series. To add error bars for all data series:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be surrounded by a gray border.

2) Go to Insert > X Error Bars or Insert > Y Error Bars on the Menu bar to open the Error Bars dialog (Figure 113).

3) Select the desired options. See below for more information about the options.

4) Click OK to close the dialog and add the error bars to the chart. If desired, click outside the chart to leave edit mode.

To insert error bars for a single data series:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be surrounded by a gray border.

2) Do one of the following to select the data series:
   – Click once on a bar, column, line, or other graphical representation in the data series.
   – Select the data series from the Select Chart Element drop-down list on the Formatting Toolbar.

3) Do one of the following to open the Error Bars dialog (Figure 113):
   – Go to Insert > X Error Bars or Insert > Y Error Bars on the Menu bar.
   – Right-click on the data series and select Insert X Error Bars or Insert Y Error Bars from the context menu.

4) Select the desired options. See below for more information about these options.

5) Click OK to close the dialog and add the error bars to the chart. If desired, click outside the chart to leave edit mode.

Error bar dialog options

Under Error Category, only one of the following options can be selected at a time.

Constant Value – shows the error as constant positive and/or negative value(s). Specify these values in the Parameters section.
**Percentage** – shows the error as a percentage of the data points. Specify this in the *Parameters* section.

The drop-down list has four measures of the error value:
- **Standard Error**
- **Variance**
- **Standard Deviation**
- **Error Margin** – uses the value for the error margin that is specified in the *Parameters* section.

**Cell Range** – uses error values defined in a range of cells. Specify the range in the *Parameters* section.

Under *Parameters*, specify positive and negative values or ranges for the error bars. **Constant Value, Percentage, Error Margin, or Cell Range** must be checked for these options to be active.

Under *Error Indicator*, select whether the error graphic shows both positive and negative errors, or only positive errors, or only negative errors.

**Modifying error bars**

Error bars can only be changed one data series at a time, using the Error Bars dialog (Figure 113). Do one of the following to open the Error Bars dialog:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be surrounded by a gray border.

2) Do one of the following to open the Error Bars dialog:
   - Click once on the data series to select it, then go to **Insert > X Error Bars** or **Insert > Y Error Bars** on the Menu bar.
   - Select the error bars for the specific data series from the Select Chart Element drop-down list on the Formatting toolbar. Then go to **Format > Format Selection** or click the **Format Selection** icon on the Formatting toolbar.
   - Right-click on the data series and select **Format X Error Bars** or **Format Y Error Bars** from the context menu.

3) Select the desired options. See below for more information about these options.

4) Click **OK** to close the dialog and update the error bars for the selected series. If desired, click outside the chart to leave edit mode.

If needed, modify the appearance of the error bars on the *Line* tab of the Error Bars dialog.

**Deleting error bars**

To delete error bars for all data series:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be surrounded by a gray border.

2) Go to **Insert > X Error Bars** or **Insert > Y Error Bars** on the Menu bar to open the Error Bars dialog (Figure 113). When no data series has been selected, the dialog also includes the option **None** under *Error Category*.

3) Select **None**.

4) Click **OK** to close the dialog and delete the error bars. If desired, click outside the chart to leave edit mode.

To delete error bars for a single data series, follow the same steps as above but instead of steps 2 and 3, right-click on the data series and select **Delete X Error Bars** or **Delete Y Error Bars** from the context menu.
Adding drawing objects to charts

Use the Drawing toolbar to add shapes such as lines, rectangles, circles, text objects, or more complex shapes such as symbols or block arrows. Use additional shapes to add explanatory notes, highlight places on a chart, or even hide certain data or text.

Open the Drawing toolbar by going to View > Toolbars > Drawing. Note that it can be moved around the workspace as needed. For more information on using the Drawing toolbar and drawing shapes, see Chapter 5, Using Graphics, as well as the Draw Guide.

The Drawing toolbar appears as follows when the chart is in edit mode (by clicking on it twice).

<p>| | | | | | | | | | | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>2</td>
<td>3</td>
<td>4</td>
<td>5</td>
<td>6</td>
<td>7</td>
<td>8</td>
<td>9</td>
<td>10</td>
<td>11</td>
<td>12</td>
</tr>
<tr>
<td>Select</td>
<td>Insert Line</td>
<td>Line Ends with Arrow</td>
<td>Insert Rectangle</td>
<td>Insert Ellipse</td>
<td>Freeform Line</td>
<td>Insert Text Box</td>
<td>Callouts</td>
<td>Callouts</td>
<td>Symbol Shapes</td>
<td>Block Arrows</td>
<td>Flowchart</td>
</tr>
</tbody>
</table>

Figure 114: Drawing toolbar when chart is placed in edit mode (by clicking twice on the chart).

Most of these options are self-evident or can be readily researched, especially by referring to the Draw Guide. Clicking on the icon for an option changes the cursor’s appearance, depending on the option. Click and drag the cursor to create the desired drawing object in the chart. Information that may be helpful for charts follows.

**Insert Line**
Draws a straight line where dragged.

**Note**
If you draw a line in the spreadsheet (outside any chart), you can hold down Shift while dragging to constrain angles of the line to multiples of 45 degrees. This facility is not applicable when inserting a line on a chart.

Write on the line by double-clicking the line and typing or pasting text. If the text is too low, press Enter to raise it above the line.

**Insert Text Box**
Draws a text box with horizontal text direction. To place the text at an angle, click once on the text box to select it, right-click, and select **Position and Size** from the context menu. Specify the angle on the Rotation tab.
Callouts

Draws a line that ends in a graphic in which text can be placed. Use a callout to describe or draw attention to a specific point or area. Double-click the callout to write text in it. In Figure 114, Callouts option 8 creates a default callout while option 13 opens a tool palette of callout styles.

Clicking the down arrows next to the six options on the right in Figure 114 opens the tool palettes shown in Figure 115.

<table>
<thead>
<tr>
<th>Basic Shapes</th>
<th>Symbol Shapes</th>
<th>Block Arrows</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1" alt="Basic Shapes" /></td>
<td><img src="image2" alt="Symbol Shapes" /></td>
<td><img src="image3" alt="Block Arrows" /></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Flowcharts</th>
<th>Callouts</th>
<th>Stars and Banners</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image4" alt="Flowcharts" /></td>
<td><img src="image5" alt="Callouts" /></td>
<td><img src="image6" alt="Stars and Banners" /></td>
</tr>
</tbody>
</table>

Figure 115: Tool palettes that can be opened from the Drawing toolbar.

Resizing, moving, and positioning charts

To resize or move a chart, click it once to put it in selection mode. Resize or move a chart in two ways: interactively, or by using the Position and Size dialog. Combining both methods may be useful. Position a chart interactively for quick and easy changes, then use the Position and Size dialog for precise sizing and positioning.

Changing interactively

**Resizing**

To resize a chart interactively:

1) Click once on the chart to select it. Square selection handles appear around the border of the chart.

2) Click and drag one of the selection handles. The cursor indicates the direction to increase or decrease the chart size. Clicking and dragging a corner preserves the horizontal to vertical size ratio.
3) When finished, click outside the chart to leave selection mode.

**Moving**

Move a chart interactively using one of two methods:

**For small moves**
1) Click once on the chart to select it. Square selection handles appear around the border of the chart.
2) Press Alt + an arrow key to move the chart one pixel at a time.
3) When finished, click outside the chart to leave selection mode.

**For larger moves**
1) Click once on the chart to select it. Square selection handles appear around the border of the chart.
2) Hover the cursor anywhere over the chart until it changes to a move cursor (shape depends on computer setup).
3) Click and drag the chart to its new location.
4) Release the mouse button when the chart is in the required position.
5) When finished, click outside the chart to leave selection mode.

**Position and Size dialog**

![Position and Size dialog](image_url)

*Figure 116: Position and Size dialog — Position and Size tab*

The Position and Size dialog contains options for defining the position of the chart on the page, specifying its size, and rotating, slanting, or rounding the corners of a chart.

**Note**

In addition to charts, the Position and Size dialog can also be used to modify and position other graphic elements, such as those available on the Drawing toolbar.
To resize or move a chart using the Position and Size dialog:

1) Click once on the chart to select it. Square selection handles appear around the border of the chart.

2) Right-click and select **Position and Size** from the context menu to open the Position and Size dialog (Figure 116).

3) Select the desired options on the **Position and Size**, **Rotation**, and **Slant & Corner Radius** tabs on this dialog. See below for further information about the options on these tabs.

4) Click **OK** to close the dialog and save changes.

5) When finished, click outside the chart to leave selection mode.

Click one of the points in the **Base point** graphic corresponding to the location to use for anchoring either the position of the chart or its size.

Note that either the position or the size can be protected from unwanted changes by clicking the appropriate box in the **Protect** section. Either or both option(s) selected will remain active after the dialog is closed. By contrast, Calc resets the base point to the default position after the dialog is closed.

**Position and Size**
The options available on the **Position and Size** tab (Figure 116) are as follows:

**Position**
Determines the location of the chart on the page. The position of a chart is coordinated relative to a fixed point (the base point). By default, this base point is located at the upper left of a chart. To make positioning of a chart simpler, the base point can be temporarily changed.

- **Position X** – specifies the horizontal location of the chart relative to the base point.
- **Position Y** – specifies the vertical location of the chart relative to the base point.
- **Base point** – specifies a temporary base point for the chart.

**Size**
Specifies the amount by which to resize the selected chart with respect to the selected base point.

- **Width** – sets a width for the selected object.
- **Height** – sets a height for the selected object.
- **Keep ratio** – maintains proportions between width and height when resizing the chart.
- **Base point** – determines the directions in which the chart size will be increased or decreased.

**Protect**
Prevents unintended changes to the position or the size of the chart.

- **Position** – prevents unintentionally moving the chart.
- **Size** – prevents unintentionally resizing the chart.

**Adapt**
Specifies if the size should be adjusted to fit the size of entered text. Availability of these options depends on the context.

- **Fit width to text** – expands the width of the object to the width of the text, if the object is smaller than the text.
- **Fit height to text** – expands the height of the object to the height of the text, if the object is smaller than the text.
Rotation

The options for the Rotation tab (Figure 117) are as follows:

![Position and size dialog – Rotation tab](image)

**Pivot Point**

The chart can be rotated around a pivot point. The default pivot point is at the center of the chart. Note that if there is not enough room to rotate the chart, it could be rotated off of the page.

- *Position X* – specifies the horizontal distance from the left edge of the page to the pivot point.
- *Position Y* – specifies the vertical distance from the top edge of the page to the pivot point.
- *Default settings* – sets the location of the pivot point. The pivot point can be temporarily changed. But when the dialog is opened again, the pivot point will be the default location at the center of the chart and the X and Y positions will reflect the default location.

**Rotation Angle**

Specifies the number of degrees that the chart is rotated.

- *Angle* – shows the number of degrees of rotation (in the range 0 to 359 degrees). The number can be entered directly or it can be set using the indicator labeled *Default settings*.
- *Default settings* – graphically shows the rotation angle. The angle can be set by clicking and dragging the indicator. The number of degrees rotated is shown in the *Angle* box.

**Slant & Corner Radius**

The options for the Slant & Corner Radius tab (Figure 118) are as follows:

**Corner Radius**

This option is not available for charts.

**Slant**

Slants the chart along an axis. Specify the angle of the axis (in the range -89° to +89°).
Control Points
These options are not available for charts.

![Position and Size dialog – Slant and Corner Radius tab](image)

**Selecting multiple charts**
Select multiple charts by clicking once on the first chart then pressing Shift while clicking on additional charts. An invisible selection rectangle covers all of the selected charts and selection handles appear at the corners and midway between corners. The multiple charts are now treated as a single object and actions such as the following can be conducted.

- Cut and paste or drag them to new locations.
- Use the Position and Size dialog described in the previous section.
- Use the Drawing Object Properties toolbar to align all of the charts, format the outer borders, or anchor the charts to the same cell or page.

**Changing overall appearance of charts**
When a chart is selected (by clicking on it once) it can be formatted as an object. The Drawing Object Properties toolbar (Figure 119) usually appears below the Standard toolbar (but the location depends on setup) and shows tools available for all objects, including charts.

Most of the options are self-evident or can be easily researched. Please refer to Chapter 5, Using Graphics, in this guide and the Draw Guide for further information. Following are a few tips for using these tools with charts.

**Anchor**
Connects a chart to either remain in the same position on a page or to move with a cell (when rows and columns are inserted or deleted). When To cell (resize with cell) is chosen, the chart or object increases or decreases in size when the cell is made larger or smaller.

**Align**
Click the icon to open options for aligning multiple charts horizontally (left, centered, right) or vertically (top, center, or bottom). This option is only active when two or more charts (or other objects) are selected.

**Bring to Front/Forward One/Back One/Send to Back**
Stacks charts or other objects in front of or behind other objects.
1. Anchor
2. Align
3. Bring to Front
4. Forward One
5. Back One
6. Send to Back
7. To Foreground
8. To Background
9. Line Style
10. Line Width
11. Line Color
12. Area Style/Filling
13. Fill Color
14. Arrow Style
15. Rotate
16. Points
17. Group

*Figure 119: Drawing Object Properties toolbar that appears when chart is selected*

**To Foreground/To Background**
Places charts or stacks of objects in either the foreground or the background. In Calc, objects in the background are behind the cell grid and may be difficult to select. Use the **Select tool** (arrow icon) on the Drawing toolbar (Figure 114) to select them.

**Line Style/Line Width/Line Color**
Formats the outer borders of charts.

**Area Style/Filling and Fill Color**
Colors objects such as arrows, shapes, and callouts. For charts, use the fill options available in edit mode.

**Arrow Style**
Specifies the appearance of line arrows and lines. Does not apply to the block arrows shown in Figures 114 and 115.

**Rotate**
Rotates the chart around a base point. When selected, places round rotation handles at each corner. Move these to rotate the chart. Move the small circle in the center of the chart to change the base point. Move the handles midway between the corners to slant the chart or other object.

**Points**
Changes the shape of curved objects. Move the points to shape curves created with the **Curve tool** on the Drawing toolbar.

**Group**
Groups or ungroups two or more objects. When grouped, the objects can be moved together and global changes can be applied to them. From left to right, the four icons are **Group**, **Enter Group**, **Exit Group**, and **Ungroup**.

**Copying, exporting, and deleting charts**

**Copying charts in the same spreadsheet document**
When a chart is copied, it retains a connection to the source data it is built on as long as it is in the same document. This means that changes made to the source data will be reflected in the chart.

Copying and pasting the chart is easy. Just click the chart once to select it, then either press **Ctrl+C**, or right-click on the chart and select **Copy** from the context menu, or click the **Copy** icon on the Standard toolbar, or select **Edit > Copy**. To paste the chart in the desired location, press
Ctrl+V, or right-click and select Paste from the context menu, or click the Paste icon in the Standard toolbar, or select Edit > Paste.

**Copying to another LibreOffice document**

When a chart is copied and pasted into another LibreOffice document, any connection to the data it is based on is lost. The data is kept with the chart and is now called a data table rather than a data range. Figure 120 shows an example of this internal data table.

**Note**

A copied chart links to or retains its data only when pasted into a LibreOffice document. To retain data or links outside LibreOffice, use embedding or linking, as explained in Chapter 10, Linking Data.

**Keeping original data**

If the goal is to use the original data for the chart, follow the same procedure as above to copy and paste the chart to another document. Nothing more needs to be done.

**Modifying original data**

If the original data for the chart needs to be modified, do the following:

1) Select the chart by double-clicking on it to enter edit mode. The chart should now be surrounded by a gray border.

2) Right-click on the chart and select Data Table to open the data table shown in Figure 120.

3) Modify the data as desired. In addition to changing numbers in the data, use options to insert, move, or delete columns and rows.

4) Click OK to close the dialog.

5) If desired, click outside the chart to leave edit mode.

**Dragging replacement data**

If the chart is still in Calc and replacement data is in the same spreadsheet, select and drag the new data onto the chart. This is described in “Replacing data by dragging” on page 104.
Note
Calc does not provide a direct way to save chart settings for creating another chart in LibreOffice. Here are three options for using the same chart settings: 1) copy and paste the chart into another file; 2) save the file containing the chart as a new file; and 3) save the chart in a template. Depending on the method used, create a new chart by modifying either the data range or the data table.

Exporting chart images
Charts can be exported in a variety of image formats for use in other documents. File types include BMP, EMF, EPS, GIF, JPEG, PDF, PNG, SVG, SVM, TIFF, and WMF.

To export a chart in an image format:

1) Click once on the chart to select it. Square selection handles appear around the border of the chart.
2) Right-click on the selected chart and select Export as Image from the context menu to open the Save as Image dialog.
3) In the dialog, type a name for the graphic file, select the location for saving the file, and select the desired graphic format.
4) Click Save and an image of the chart will be exported to the location specified.

Deleting charts
To delete a chart, simply click it once to select it. Square selection handles appear on the borders of the chart. Then press Delete.

Gallery of chart types
While data can be presented using a variety of charts, focus on the message of the chart to determine which type of chart to use. The following sections present examples of the chart types that Calc provides, with some notes on the uses of each one.

Column charts
A column chart shows vertical bars, with the height of each bar proportional to its value. The X axis shows categories and the Y axis shows the value for each category.

Column charts are commonly used for data that show trends over time. They are best for a relatively small number of data points. It is the default chart type provided by Calc, as it is one of the most useful and easy to understand. For a larger time series, a line chart would be more appropriate.

The column chart type has three variants, with a preview pane for each variant as shown in Figure 121. When a preview is clicked, its borders are highlighted and the name appears below. The 2D variants are:

Normal
Shows all data values belonging to a category next to each other. The main focus is on the individual absolute values, compared to every other value.

Stacked
Shows the data values of each category on top of each other. The main focus is the overall category value and the individual contribution of each value within the category.
Percent stacked
Shows the relative percentage of each data value with regard to the total of its category. The main focus is the relative contribution of each value to the category total. (Contrary to the preview picture in Figure 121, the values are stacked, not next to each other.)

Figure 121: Chart Type dialog – Column

Additional options for creating column charts are:

3D Look
When this box is checked, two options become available in the drop-down list:
- **Realistic** – tries to give the best 3D look.
- **Simple** – tries to mimic the chart view of other products.

When you check the **3D Look** box, a fourth chart variant becomes available called **Deep**. This shows the data values of each category lined up, one behind the other.

Shape
Gives options for the shape of the columns in 3D charts. The choices are: **Bar**, **Cylinder**, **Cone**, and **Pyramid**.

Bar charts
A bar chart is like a column chart that has been shifted 90 degrees. It shows horizontal bars rather than vertical columns. In contrast to some other chart types, the Y axis is horizontal and the X axis is vertical. The Chart Type dialog for a bar chart is essentially the same as for a column chart, described above.

Bar charts can have an immediate visual impact when time is not an important factor — for example, when comparing the popularity of a few products in a marketplace. They may be preferred to column charts when the category names are long or there are a significant number of categories.

In the examples in Figure 122 below:

- To make the first chart after using the Chart Wizard, go to **Insert > Grids**, deselect **Y axis**, and choose **Insert > Mean Value Lines**. Right-click each mean value line and select **Format Mean Value Line** to increase the width of the lines. Create rectangles from the Drawing toolbar to cover the mean value line entries in the legend. Make them white by right-clicking and selecting **Line** and then **Area**.
- The second chart is a 3D chart created with a simple border and cylinder shape. The chart area is rotated (described under “Rotation and perspective” on page 124).
• The third chart eliminates the legend by using labels with the names of the companies on the Y axis. Whereas the first two charts treat the data as separate data series, this chart treats the data as one data series in order to have category labels for the X axis. Rather than colors, a colored horizontal hatch pattern is used for the bars.

Figure 122: Bar chart examples

**Pie charts**

A pie chart shows values as circular sections of a circle. The area of each section is proportional to its value.

Pie charts are excellent for comparing proportions — comparisons of departmental spending, for example. They work best with smaller numbers of values, up to about half a dozen; more than this and the visual impact begins to fade.

![Chart Type dialog - Pie](image)

Pie variant options, shown in Figure 123, are:

**Normal**

Shows values as sections of a complete pie, with the option of separating out individual pieces. Click the outer edge of a section to separate it from the remaining pie or to join it back.

**Exploded Pie**

Shows all of the sections separated from each other. Click and drag any section to move it along radial lines from the pie center.

**Donut**

Shows multiple data series. Each data series is shown as one donut shape with a hole inside, where the next data series can be shown. Click and drag an outer section to move it along radial lines from the donut center.
Exploded Donut

Shows the outer sections already separated from the remaining donut. Click and drag an outer section to move it along radial lines from the center.

The Chart Wizard initially guesses how the data should be presented in the chart. Adjust this on the Data Range and Data Series pages of the wizard or by using the Data Ranges dialog.

You can do some interesting things with a pie chart, especially if you make it into a 3D chart. It can be tilted, given shadows, and generally turned into a work of art. Just do not clutter it so much that the message is lost, and be careful that tilting does not distort the relative sizes of the segments.

You can choose in the Chart Wizard to use the exploded pie variant, but this option explodes all of the pieces (contrary to the preview graphic in Figure 123). If the aim is to accentuate just one piece of the pie, separate out a piece by carefully highlighting it and dragging it out of the group. After this, the chart area may need to be enlarged to regain the original size of the pieces.

Figure 124: Pie chart examples

The effects achieved in Figure 124 are explained below.

**2D pie chart with one section of the pie exploded**

Select Insert > Legend and deselect the Display legend box. Select Insert > Data Labels. Select Show value as number and also Show category. Click the edge of the section (the section will have highlight squares to mark it), and drag it out from the rest of the sections. The sections will decrease in size. If needed, highlight the chart wall and drag it at a corner to increase the size.

**3D pie chart, exploded variant, with realistic schema and various fill effects**

Go to Format > Chart Type and select 3D Look. Go to Insert > Data Labels and select Show value as percentage. Then carefully select each section so that it has a wire frame highlight. Right-click and select Format Data Point to get the Data Point dialog. Choose the Area tab. The illustration in Figure 124 shows one section formatted with bitmap, one with a radial gradient, one with 50% transparency, and one with a pattern.

Donut and exploded donut variants, shown in Figure 125, are used to display two set of related information, such as two years of financial data. This variant can be misleading for comparing numeric data, since inner circles are necessarily smaller. For more variety, use a 3D look.
Area charts

Like a line or column chart, an area chart shows values as points on the Y axis and categories on the X axis. The Y values of each data series are connected by lines and the areas below the lines are colored.

Area charts emphasize volumes of change from one category to the next. They have greater visual impact than line charts, but the data used will make a difference.

Area chart variants, shown in Figure 126, are:

**Normal**
Plots all data as absolute Y values. It first plots the area of the last data series in the data range, then the next to last, and so on. Finally the first data series is drawn over the other data. Thus, higher values in the first data series will hide lower values of later data series.

**Deep**
When 3D Look is selected, this variant shows the first data series in front, with subsequent data series behind.

**Stacked**
Stacks cumulative values on top of each other. This ensures that all values are visible, and no data set is hidden by others. However, the Y values no longer represent absolute values, except for the first data series, which is shown at the bottom of the stacked areas.

**Percent Stacked**
Stacks cumulative values on each other and also scales the values as percentages of the category total.
Normal area charts

Area charts are sometimes tricky to create. Using transparency values may be helpful. To create the charts in Figure 127, first set up the basic chart using the Chart Wizard. The chart on the left shows the result. Because of the data overlap, some of it is missing behind the first data series. This is probably not desirable. The other examples are better solutions.

To create the chart in the center:

After deselecting the Y axis grid, right-click on each data series in turn and select Format Data Series. On the Transparency tab, set Transparency to 50%. The transparency makes it easy to see the data hidden behind the first data series.

To create the chart on the right:

After doing the steps above, right-click and select Chart Type. Select the 3D Look option and select Realistic from the drop-down list. Rotate the chart area using the 3D View dialog. Instead of a legend, use labels on the Z axis.

Stacked area charts

Other ways of visualizing the same data series are the stacked area chart and the percentage stacked area chart (Figure 128). In the first example, each point in a data series is added to the other data series to show the total area. The second example shows a percentage stacked chart, showing each value in the series as a percentage of the whole.

Line charts

A line chart is useful for showing trends or changes over time when you want to emphasize continuity. Values are shown as points on the Y axis and the X axis shows categories — often time series data. The Y values of each data series may be connected by a line.
The difference between line charts, described in this section, and XY (scatter) charts, described in the next section, is this: line charts show categories along the X axis while XY (scatter) charts show values along the X axis.

As shown in Figure 129, four variants are available:

**Points Only**
Plots only points.

**Points and Lines**
Plots points and connects points of the same data series by a line.

**Lines Only**
Plots only lines.

**3D Lines**
Connects points of the same data series by a 3D line.

![Chart Type dialog – Line](image)

When **Stack series** is selected, it shows cumulative Y values above each other. The options are:

- **On top** – places the value of each data series above the others. The Y values no longer represent absolute values, except for the first data series, which appears at the bottom of the chart. This is the default setting.
- **Percent** – scales the Y values as percentages of the category total.

The **Line type** drop-down list has three options that determine how the data points are connected:

**Straight**
Draws straight lines between the points.

**Smooth**
Connects the points with curves instead of lines. When this option is selected, click **Properties** to open the Smooth Lines dialog (Figure 130) and further specify the curves.

For smooth lines, there are two line type options: **Cubic spline** or **B-spline**. These are mathematical models that join together segments of polynomials to display the curves. For B-spline lines, there is an option to set the degree of the polynomials. Select a higher resolution for smoother curves.
Stepped

Connects points with horizontal and vertical lines only. Click **Properties** to further specify the formatting of the lines (Figure 131). The options are self-explanatory.

![Stepped Lines dialog](image1)

**Figure 131: Stepped Lines dialog**

Things to do with lines: thicken them, smooth the contours, just use points, or make them 3D. However, 3D lines can confuse the viewer, so just using a thicker line often works better. Figure 132 shows some examples of line charts.

![Line chart examples](image2)

**Figure 132: Line chart examples**

**Scatter or XY charts**

In contrast to line, column, and bar charts, which contain numeric values on the Y axis and categories on the X axis, scatter or XY charts contain values along both axes. They are quite useful, especially for understanding relationships among data that are precise and complex. An XY chart may contain more than one data series and can perform many tasks, such as generating a parameter curve or drawing the graph of a function.
Tip

When plotting time on the X axis, make sure that it is not text and is written in the correct format for your locale. For example, instead of January, use a format such as 1/1/2022. Check locale formats at Tools > Options > Language Settings > Languages > Date acceptance patterns.

XY charts are most frequently used to explore the statistical associations among quantitative variables. There is often a constant value against which to compare the data — for example, weather data, reactions under different acidity levels, or conditions at various altitudes.

Tip

By custom, if one of the variables is either controlled by an experimenter or it changes consistently (such as time) it is considered an independent variable and plotted on the X axis.

**XY chart variants**

![Figure 133: Chart Type dialog – XY (Scatter)](image)

As shown in Figure 133, when the XY (Scatter) chart type is selected, the following variants are available:

- **Points Only**
  Shows an icon for each data point. Calc uses default icons with different forms and colors for each data series. The default colors are set in Tools > Options > Charts > Default Colors. Changing the colors and icons is discussed in “Lines, areas, and data point icons” on page 109.

- **Lines Only**
  Draws straight lines from one data point to the next. The data points are not indicated by icons. By default, the drawing order is the same as the order in the data series, but note the option to sort by X values.

- **Points and Lines**
  Shows both points and lines.

- **3D Lines**
  Makes the lines look like tapes. The data points are not shown by icons. In the finished chart, use the 3D View dialog to set properties like illumination and angle of view.
The following options may appear:

**Sort by X values**
Draws the lines in order of the X values. This can be helpful if the data series on the spreadsheet is not in numeric order.

**Line type – Straight**
Draws straight line segments.

**Line type – Smooth**
Draws curves instead of straight line segments. Click Properties to set details for the curves.
- **Cubic spline** interpolates the data points with polynomials of degree 3. The transitions between the polynomial pieces are smooth, having the same slope and curvature.
- **Resolution** determines how many line segments are calculated to draw a piece of polynomial between two data points. A value in the range 1 to 100. Click any data point to see the intermediate points.
- **B-spline** uses parametric, interpolating B-spline curves. The curves are built from polynomials. **Degree of polynomials** sets the degree of these polynomials. A value in the range 1 to 15.

**Line type – Stepped**
Uses only horizontal and vertical lines. Click Properties to set details for the stepped lines.

After a scatter chart is created, its default settings can be changed in ways such as the following. Be sure to first double-click the chart to enter edit mode. Depending on the option, a data point or data series may also need to be double-clicked.

- **Line styles and icons** – double-click or right-click on a data series in the chart to open the Data Series dialog. See “Lines, areas, and data point icons” on page 109 for further information.
- **Error bars** – For 2D charts, select Insert > Y Error Bars or X Error Bars to enable the display of error bars. See “Error bars” on page 131 for further information.
- **Mean Value Lines** and **Trend Line** – Enable the display of mean value lines and trend lines with commands on the Insert menu. See “Trend and mean value lines” on page 126 for further information.

**Examples of XY or scatter charts**
By default, the first column or row of data (depending on whether the data is arranged in columns or rows) is represented on the X axis. The rest of the rows of data are then compared against the first row of data.

Scatter charts may surprise those unfamiliar with how they work. This can be seen in examples using the following data (Figure 134), which is organized with data series in rows.

The data range for the chart on the left in Figure 134 includes the cells containing the months. However, the months do not appear on the chart because only values can be used in XY charts and Calc substitutes cardinal numbers for them.

The data range for the chart on the right does not include the cells containing the months. Calc assumes that the first row (or column) of data contains values for the X axis. The Y values of the other data series are paired with each of those X values. This means that there are no data points for the Japanese yen but each of the other currencies are shown in comparison to the yen, since it supplies the X values.
Bubble charts

A bubble chart is a variation of a scatter chart that can show three variables in two dimensions. The data points are shown with bubbles. Two variables are plotted along the X and Y axes, while the third variable is represented by the relative size of the bubbles. These charts are often used to present financial data or social/demographic data.

One or more data series can be included in a single chart. The data series dialog for a bubble chart has an entry to define the data range that determines the size of the bubbles.

It may be necessary to build a bubble chart manually in the data series page of the Chart Wizard. Figure 135 shows how the data ranges can be set for a bubble chart.

The chart in Figure 136 is based on the data in Figure 135. To format the chart, the data series are 50% transparent with a radial gradient. The data labels are formatted to be numbers in the center of the data points (bubbles).

Note

Remember that bubble charts require numeric data. If the data series for the X axis contains text (or dates not formatted as numbers) cardinal numbers will be used for axis labels.
Net charts are also known as spider, polar, or radar charts. They display data values as points on radial spokes, with each spoke representing a variable. They compare data that are not time series, but show different circumstances, such as variables in a scientific experiment. They are especially useful for displaying clusters and outliers.

Figure 137 shows an example of a simple net chart. The radial spokes of the net chart are equivalent to the Y-axes of other charts. All data values are shown with the same scale, so all data values should have about the same magnitude.

Generally, between three and eight axes are best; any more and this type of chart becomes confusing. Before and after values can be plotted on the same chart, or perhaps expected and real results, so that differences can be compared.
Figure 138 shows the options for creating a net chart. These are similar to those for area and line charts, described above. However, keep in mind that area increases as the square of the distance along the linear spokes. Therefore, net charts can distort the areas representing the data. Be especially careful about choosing to stack data series. In this case, successive data series show increasingly large areas that are not proportional to their values.

Figure 139 shows examples of two types of net charts.

- The example on the left is a filled net chart. The color of one of the data series is 50% transparent. Partial transparency is often best for showing all of the series.
- The example on the right is a net chart with lines and points. The data point icons are taken from the Gallery and have a 3D look.

![Figure 139: Filled net chart and net chart with 3D data point icons.](image)

**Stock charts**

A stock chart illustrates the market trends for stock and shares by giving opening price, bottom price, top price, and closing price. The transaction volume can also be shown and the X axis usually represents a time series.

When setting up a stock chart in the Chart Wizard, the data should be arranged as shown in Figure 140. It specifies which columns should be the opening, low, high, and closing prices of the stock as well as the transaction volume. However, manual adjustments may still be needed when defining the data series.

![Figure 140: Example data arrangement for stock charts](image)

A stock chart organizes data series in two basic ways. The first way is not used in other chart types. In this case, the open, low, high, and closing values of a row create one data unit in the chart and one data series consists of several rows containing such data units. The columns containing transaction volumes are the second way used to organize data series. This is the familiar way used in other chart types.

Thus, Figure 140 shows the data for four data series: 1) the price data for Acme, which contains columns for open, low, high, and closing prices, 2) the price data for Ajax, which contains columns for open, low, high, and closing prices, 3) the Acme transaction volume, which is one column, and 4) the Ajax transaction volume, which is one column.
**Stock chart variants**

The Chart Wizard offers four stock chart variants, as shown in Figure 141. Note that some of them do not use all of the data columns.

![Chart Type dialog - Stock](image)

*Figure 141: Chart Type dialog - Stock*

The data table in Figure 140 is used to illustrate the variants, which are as follows:

**Stock Chart 1**

When based only on data in the low and high columns, this variant shows the distance between bottom price (low) and top price (high) with a vertical line. When the closing column is also included (Figure 142), it shows an additional horizontal mark for the closing price.

![Stock Chart Variant 1](image)

*Figure 142: Stock chart variant 1 showing low, high, and closing prices*

**Stock Chart 2**

Based on the open, low, high, and close columns, this variant generates the traditional candlestick chart (Figure 143). It shows a vertical line between the bottom and top prices and adds a rectangle in front that shows the range between the opening and closing prices. For rising values (the opening price is lower than the closing price), the fill color is white. For falling values, the fill color is black.

---

*Stock charts | 155*
Stock Chart Variant 2

Using the low, high, and close columns, draws a chart similar to Stock Chart 1 but with additional columns for transaction volume. As shown in Figure 144, a secondary Y axis enables both transaction volume and price to be shown on vertical axes.

Stock Chart 3

Using the low, high, and close columns, draws a chart similar to Stock Chart 1 but with additional columns for transaction volume. As shown in Figure 144, a secondary Y axis enables both transaction volume and price to be shown on vertical axes.

Stock Chart 4

Based on all five data columns (volume, open, low, high, and close), this variant combines Stock Chart 2 with a column chart for the transaction volume (Figure 145).

Note

Variants 3 and 4 automatically align data to the secondary Y axis. For more information about a secondary Y axis, see “Aligning data to secondary Y axis” on page 106.
Figure 145: Stock chart variant 4 showing opening, low, high, and closing prices as well as transaction volumes.

**Column and line charts**

A column and line chart is useful for displaying two or more distinct but related data series, such as sales over time (columns) and profit margin trends (lines). It could also show constant minimum and maximum lines, such as used in medical testing or quality control.

Specify in the Chart Type dialog whether there will be 1 or 2 lines. By default, the first column or row of data is categories and the last columns or rows of data are lines.

Choose between two variants:

**Columns and Lines**

As seen in Figure 146, the columns are drawn side by side to easily compare their values.

**Stacked Columns and Lines**

The columns are stacked above each other, so that the height of a column shows the sum of the data values.

The charts in Figures 146 and 147 show sales and profit data for two firms over a period of time. Note that when first created, the lines were different colors than the columns for the same company. To reflect the company relationships, change the line colors individually by clicking on a line, right-clicking, selecting **Format Data Series**, and formatting the line color and size on the Line page.

![Column and line chart with secondary Y axis](image)

*Figure 146: Column and line chart with secondary Y axis*
For the background, right-click the chart wall, select **Format Wall**, and select desired options on the **Gradient** page of the **Area** tab. To align the two data series to the secondary Y axis, see “Aligning data to secondary Y axis” on page 106.

![Chart of Two Quarters of Profit Growth](image)

**Figure 147**: Column and line chart with stacked columns

**Pivot charts**

Pivot tables are special types of data tables that simplify the manipulation and analysis of data. They are widely used, especially for processing large amounts of data. Pivot charts are based on pivot tables and are created by selecting **Insert > Chart**, or clicking the **Insert Chart** icon in the Standard toolbar, after left-clicking a cell inside a pivot table. Pivot charts inherit many properties of the other chart types described in this chapter but also have other characteristics that are described in Chapter 8, Using Pivot Tables.
Chapter 4
Using Styles and Templates
Using consistent formatting in spreadsheets
What are styles? Why use them?

A style is a set of formats that you can apply to selected elements in a document to quickly change their appearance. Applying a style often means applying a group of formats at the same time.

Many people manually format spreadsheet cells and pages without paying any attention to styles and are accustomed to formatting documents according to physical attributes. For example, for the contents of a cell you might specify the font family, font size, and any character formatting such as **bold** or *italic*.

Styles are logical attributes. Using styles means that you stop applying attributes and characteristics individually (for example, *font size 14pt, Times New Roman, bold, centered*) and start using a style, for example Title. Applying attributes and characteristics is time-consuming and prone to errors. In contrast, using a style, which has been defined to include the attributes and characteristics you want, will save you time and give greater consistency in formatting.

Styles also make major formatting changes easy. For example, you may decide to change the appearance of all subtotals in a spreadsheet to be 10 pt Arial instead of 8 pt Times New Roman after you have created a 15-page spreadsheet. You can change all of the subtotals in the document by simply changing the properties for the subtotal style.

Calc also provides page styles, as described below.

You can modify the attributes of the supplied styles and define as many new styles as you require. Creating, modifying, and accessing styles is explained in the following sections.

Direct formatting and Style formatting

Direct formatting (also called *manual formatting*) overrides styles, and you cannot remove the direct formatting by applying a style to it.

To remove manual formatting, select the text, right-click, and choose **Format > Clear Direct Formatting** from the context menu, or select the text and press *Ctrl+M*, or select the text and click the **Clear Direct Formatting** icon in the Standard toolbar.

Calc style types

While some components of LibreOffice offer many style types, Calc offers only two: cell styles and page styles. These style types are explained in the following sections.

Cell styles

Cell styles are similar to paragraph styles used in LibreOffice Writer. They are the most basic type of style in Calc. Cell styles are used for applying fonts, alignment, borders, background, number formats (for example, currency, date, number), and cell protection to format the data in the cells.

A basic range of cell styles is supplied with Calc. These styles are shown on the **Styles** menu on the Menu bar and in the Styles deck of the Sidebar. When you create a new cell style, it is shown in the Sidebar. You can also add it to the **Styles** menu; see Chapter 14, Setting up and Customizing, for instructions.

Initially, the basic styles are configured so that if you change the font family of the Default style, then all of the other styles, inheriting from it, will change to match.

Page styles

Page styles in Calc are applied to sheets. Although one sheet may print on several pages, only one page style can be applied to a sheet. If a spreadsheet file contains more than one sheet, then a
different page style can be applied to each sheet. For example, a spreadsheet might contain some sheets to be printed in landscape orientation and other sheets to be printed in portrait orientation.

Two page styles are supplied with Calc: Default and Report. Page styles allow you to set page size and orientation, page margins, headers and footers, borders and backgrounds, and the sequence for printing sheets.

**Applying cell styles**

To apply cell styles in Calc, you can use the Styles menu on the Menu bar, the Styles deck in the Sidebar, Fill Format mode, the Apply Style list on the Formatting toolbar, and keyboard shortcuts.

**Styles menu**

The Styles menu (Figure 148) lists the cell styles supplied with Calc. To apply a cell style, select the cell or group of cells to be formatted, and then choose Styles and click on the required style.

![Figure 148: The Styles menu](image)

**Styles deck in Sidebar**

The Styles deck in the Sidebar lists and shows previews of the styles available. If the Sidebar is not open, choose View > Styles, or Styles > Manage Styles, or tap the F11 function key to open it.

1) Go to the Styles deck in the Sidebar.
2) Click the Cell Styles icon on top of the Styles deck to open the list of cell styles. Figure 149 shows the panel with cell styles visible.
3) In the spreadsheet, highlight the cell or group of cells where you want to apply a cell style.
4) Double-click on the cell style name in the Styles deck and the formatting attributes for that style are applied to the data contained in the highlighted cells.
Fill Format mode

Fill Format mode is useful when you want to apply the same style to many scattered cells.

1) Go to the Styles deck in the Sidebar (Figure 149).
2) Select the style you want to apply.
3) Click the Fill Format Mode icon in the top right of the Styles deck. The cursor changes shape.
4) Click in each cell where you want to apply the selected style.
5) When you have finished formatting cells, click the Fill Format Mode icon to disable it.

Note

When Fill Format mode is active, a right-click anywhere in the document cancels the last Fill Format action. Be careful not to accidentally right-click and thus cancel any formatting actions you want to keep.

Apply Style list

The Apply Style drop-down list is not included by default on the Formatting toolbar in Calc, but you can add it as follows:

1) Right-click on any icon in the Formatting toolbar and select Visible Buttons from the context menu (Figure 150).
2) Click Apply Style. The context menu closes and the Apply Style list appears at the left end of the Formatting toolbar.

Figure 150: Adding the Apply Style list to the Formatting toolbar
To apply a style using the *Apply Styles* list:

1) Select a cell or a group of cells in the spreadsheet.
2) Click the down arrow at the right of the *Apply Styles* list to open the drop-down menu (Figure 151).
3) Select the required style. The formatting attributes of that style are applied to the selected cells.

![Figure 151: Applying a style from the list](image)

Only the styles that are in use are shown on the list. Click **More Styles** to go to the Styles deck where all cell styles are available.

**Keyboard shortcuts**

You can create keyboard shortcuts to apply commonly-used cell or page styles, including any custom styles that you have created. See Chapter 14, Setting up and Customizing, for more information.

**Applying page styles**

The page style applied to a sheet within a spreadsheet is indicated on the Status Bar, as shown in Figure 152.

![Figure 152: Page style (Default) indicated on Status Bar](image)

To apply a different page style:

1) Select the sheet to be styled by clicking its sheet tab at the bottom of the window.
2) Go to the Styles deck in the Sidebar (Figure 149).
3) In the top of the Styles deck, click the **Page Styles** icon.
4) Double-click on the required page style.

**Creating new (custom) styles**

To create a new (custom) style, follow the procedure described in this section.
1) Go to the Styles deck in the Sidebar (Figure 149).
2) To create a new cell style, click the Cell Styles icon, or to create a new page style, click the Page Styles icon.
3) Right-click in the Styles deck and select New from the context menu to open either the Cell Style dialog or the Page Style dialog.
4) Use the various tabbed pages in the dialogs to set the attributes for the new style. See “Cell style attributes” on page 164 and “Page style attributes” on page 171 for more information.
5) Click OK to close the dialog and save the new style.

Cell style attributes

The following attributes are available on the tabbed pages of the Cell Style dialog (Figure 153).

Organizer tab

- **Name** – displays the name of the selected style. If you are creating or modifying a custom style, enter a name for the style. You cannot change the name of a predefined style.
- **Inherit from** – you can choose to link the new style to an existing style and then modify some of the attributes. If you do this, any change to the parent style’s attributes will affect the new style. For example, you could make the styles identical except for the font color; if you later change the font family of the parent style, the new style’s family will also change.
- **Category** – displays the category for the current style. If you are creating or modifying a new style, select Custom Styles from the list. You cannot change the category for a predefined style.
- **Contains** – describes the formatting used in the style.

**Numbers tab**

![Cell Style dialog – Numbers tab](image)

- **Category** – select a category from the list. Examples: Currency, Date, Number, Text, ...
- **Format** – select how you want the contents of the selected cell(s) to be displayed.
  
  When you select Currency as a category, you need to select a currency from the drop-down list and then select the format to use from the options available for that currency.

  The currency format is not dependent on the language that you select in the Language box. The default currency format for a cell is determined by the regional settings of your operating system.

- **Language** – specifies the language settings for the selected cells. With the language set to the default, Calc automatically applies the number formats associated with the system default language. The language setting ensures that date and currency formats are preserved even when the document is opened in an operating system that uses a different default language setting.

- **Options** – specify the options for the selected format.
  
  - _Decimal places_ – enter the number of decimal places that you want to display.
  
  - _Leading zeroes_ – enter the maximum number of zeroes to display in front of the decimal point.
  
  - _Negative numbers red_ – select to change the font color of negative numbers to red.

*Cell style attributes | 165*
– *Thousands separator* – select to insert a separator between thousands. The type of separator (for example, a comma or a space) depends on your language settings.

- **Format code** – displays the number format code for the selected format. You can also enter a custom format.
- **Preview field** – displays a preview of the current selection.

**Font tab**

![Cell Style dialog – Font tab](image)

- **Font** – select a font family from the list.
- **Style** – select the formatting you want to apply, for example **Bold** or **Italic**.
- **Size** – select or enter the font size that you want to apply. For scalable fonts, you can also enter decimal values. If you are creating a style that is based on another style, you can enter a percentage value or a point value (for example, 2pt or 5pt).
- **Language** – sets the language that the spelling checker is to use. The spelling checker works only when you have installed the corresponding language module. A language entry has a check mark in front of it if the spelling checker is activated for that language.
- **Features** – some fonts offer special features such as Discretionary Ligatures and Horizontal Kerning. Click this button to access the Font Features dialog (not shown) to select those features.
- **Preview** – displays a preview of the current selection.
**Font Effects tab**

![Cell Style dialog – Font Effects tab](image)

- **Font color** – sets the color for the text. If you select *Automatic*, the text color is set to black for light backgrounds and to white for dark backgrounds.
- **Relief** – select a relief effect to apply to the text. The *Embossed* relief makes the characters appear as if they are raised above the page. The *Engraved* relief makes the characters appear as if they are pressed into the page.
- **Outline** – displays the outline of the characters. This effect does not work with every font.
- **Shadow** – adds a shadow that casts below and to the right of the characters.
- **Overlining** – select the overlining style that you want to apply. To apply the overlining to words only (not the spaces between them), select *Individual words*.
- **Overline color** – select the color for the overlining. *Automatic* matches the font color.
- **Strikethrough** – select a strikethrough style for the selected text.
- **Underlining** – select the underlining style that you want to apply. To apply the underlining to words only (not the spaces between them), select *Individual words*.
  
  If you apply underlining to a superscript text, the underlining is raised to the level of the superscript. If the superscript is contained in a word with normal text, the underlining is not raised.
- **Underline color** – select the color for the underlining. *Automatic* matches the font color.
- **Individual words** – applies the selected effect only to words and ignores spaces.
- **Preview** – displays a preview of the current selection.
**Alignment tab**

![Alignment tab](image)

Figure 157: **Cell Style dialog – Alignment tab**

- **Text Alignment** – sets the alignment options for the contents of the current cell, or the selected cells.
  - **Horizontal** – select the horizontal alignment option that you want to apply to the cell contents.
    - *Default* – aligns numbers to the right and text to the left.
    - *Left* – aligns the contents of the cell to the left.
    - *Center* – horizontally centers the contents of the cell.
    - *Right* – aligns the contents of the cell to the right.
    - *Justified* – aligns the contents of the cell to the left and to the right cell borders.
    - *Filled* – repeats the cell contents (number and text) until the visible area of the cell is filled. This feature does not work on text that contains line breaks.
    - *Distributed* – aligns contents evenly across the whole cell. Unlike *Justified*, it also justifies the very last line of text.
  - **Indent** – indents from the left edge of the cell by the amount that you enter.
  - **Vertical** – select the vertical alignment option that you want to apply to the cell contents.
    - *Default* – aligns the cell contents to the bottom of the cell.
    - *Top* – aligns the contents of the cell to the upper edge of the cell.
    - *Bottom* – aligns the contents of the cell to the lower edge of the cell.
    - *Middle* – vertically centers the contents of the cell.
    - *Justified* – aligns the contents of the cell to the top and to the bottom cell borders.
    - *Distributed* – aligns contents evenly across the whole cell. Unlike *Justified*, it also justifies the very last line of text.

---

168 | Creating new (custom) styles
• **Text Orientation** – defines the text direction of cell contents.
  – *ABCD wheel* – click anywhere in the wheel to define the text orientation. The characters "ABCD" on the wheel correspond to the new setting.
  – *Vertically stacked* – assigns vertical text orientation for cell contents.
  – *Degrees* – allows you to manually enter the orientation angle.
  – *Reference edge* – specify the cell edge from which to write the rotated text.
    – *Text Extension From Lower Cell Border* – writes the rotated text from the bottom cell edge outwards.
    – *Text Extension From Upper Cell Border* – writes the rotated text from the top cell edge outwards.
    – *Text Extension Inside Cell* – writes the rotated text only within the cell.
• **Properties** – determine the text flow in a cell.
  – *Wrap text automatically* – wraps text onto another line at the cell border. The number of lines depends on the width of the cell. To enter a manual line break, press Ctrl+Enter in the cell.
  – *Hyphenation active* – enables word hyphenation for text wrapping to the next line.
  – *Shrink to fit cell size* – reduces the apparent size of the font so that the contents of the cell fit into the current cell width. You cannot apply this command to a cell that contains line breaks.
  – *Text direction* – choices are **Left-to-right**, **Right-to-left**, and **Use superordinate object settings** (the settings applied to the preceding cell).

**Borders tab**

![Borders tab](image)

*Figure 158: Cell Style dialog – Borders tab*
Sets the border attributes for the selected cells.

- **Line Arrangement** – select a preset border style or define your own combination by clicking in the diagram.
- **Line** – select the line style, width, and color that you want to apply. The style is applied to the borders selected in the preview.
- **Padding** – specify the amount of space that you want to leave between the border and the contents of the cell. You can set each distance (left, right, top, bottom) individually or select **Synchronize** to apply the same padding to all four borders when you enter a new distance.
- **Shadow Style** – applies a shadow effect to borders. You can specify the position of the shadow (top, bottom, right, or left side), the distance it extends, and its color.

**Background tab**

Click **Color** to select a color to use as a background for the formatted cells. You can choose from several palettes. To change the color, select another one. To remove the background color, select **None**.

![Figure 159: Cell Style dialog – Background tab](image)

**Cell Protection tab**

**Protection**

- **Hide all** – hides formulas and contents of the selected cells.
- **Protected** – prevents the selected cells from being modified. This cell protection only takes effect if you also protect the sheet.
- **Hide formula** – hides formulas in the selected cells.

**Print**

- **Hide when printing** – prevents the selected cells from being printed.
Resetting cell style attributes

The buttons at the bottom of the Cell Style dialog have the following functions:

- **Reset** – returns to last saved settings for all tabs of this dialog.
- **Standard** – returns to the settings in the template for the current dialog tab only.
- **Cancel** – cancels any changes made (to all tabs in the dialog) since the last save of this dialog (by clicking **OK**).
- **OK** – saves all changes made (to all tabs in the dialog).

Page style attributes

The following attributes are available on the tabs of the Page Style dialog (Figure 161).

**Organizer tab**

This tab is similar to the Organizer tab for the Cell Style dialog.

- **Name** – displays the name of the selected style. If you are creating or modifying a custom style, you can enter or change a name of the style. You cannot change the name of a predefined style.
- **Category** – displays the category of the current style. If you are creating a new style, select **Custom Styles** from the list. You cannot change the category for a predefined style.
- **Contains** – describes the formatting used in the current style.

**Page tab**

You can define page layouts for single and multiple-page spreadsheets, as well as page numbering and paper formats.

- **Paper Format** – select from a list of predefined paper sizes, or define a custom paper format.
  - **Format** – select a predefined paper size, or create a custom format by entering the dimensions for the paper in the **Height** and **Width** boxes.
  - **Width** – displays the width of the selected paper format. To define a custom (user) format, enter a width here.
  - **Height** – displays the height of the selected paper format. To define a custom (user) format, enter a height here.
  - **Orientation:**
    - **Portrait** – displays and prints the spreadsheet with the paper oriented vertically.
– **Landscape** – displays and prints the spreadsheet with the paper oriented horizontally.

**Figure 161: Page Style dialog**

– **Paper tray** – select the paper source for your printer. You can assign different paper trays to different page styles. For example, you can assign a different tray for the first page style in the spreadsheet and load the tray with your company letterhead paper.

- **Margins** – specify the amount of space to leave between the edges of the paper and the spreadsheet contents.
  - **Left/Inner** – the space between the left edge of the page and the spreadsheet. If you are using Mirrored page layout, the space between the inner edge of the paper and the spreadsheet. You may want to have a wider space as the Left/Inner margin if you will be punching or binding the pages.
  - **Right/Outer** – the space between the right edge of the paper and the spreadsheet. If you are using Mirrored page layout, the space between the outer edge of the paper and the spreadsheet.
  - **Top** – the space between the upper edge of the paper and the spreadsheet.
  - **Bottom** – the space between the lower edge of the paper and the spreadsheet.

- **Layout settings** – select the page layout style to use for the spreadsheet.
  - **Page layout:**
    - **Right and left** – both odd (right) and even (left) pages have the same margins on all four sides.
    - **Mirrored** – odd and even pages with inner and outer margins as specified. Use this layout if you want to bind the printed pages like a book. Enter the binding space as the Inner margin.
– Only right – To specify different (but not mirrored) layouts for odd and even pages, define separate page styles. This one is for right (odd) pages.
– Only left – To specify the layout for left (even) pages, choose this setting.
– Page numbers – select the page numbering format to use for the page style. Typically this will be 1,2,3 or a,b,c or i,i,ii,iii.
– Table alignment:
  – Horizontal – centers the cells horizontally on the printed page.
  – Vertical – centers the cells vertically on the printed page.

Borders and Background tabs
See “Borders tab” and “Background tab” in “Cell style attributes” above for information on how to set the borders and background for page styles. Page styles can have a bitmap background or a color.

Header and Footer tabs
Adds a header or footer to the page style. A header is an area in the top page margin where you can add text or graphics. A footer is a similar area in the bottom page margin. See Chapter 6, Printing, Exporting, and Emailing, for details.

Sheet tab
Specifies the elements to be included in the printout of all sheets with the page style. Additionally, you can set the print order, the first page number, and the page scale. See Chapter 6, Printing, Exporting, and Emailing, for details.

Managing styles
Modifying styles
1) Go to the Styles deck in the Sidebar and click the icon for the type of style you want to modify.
2) Right-click on the name of the style and select Modify from the context menu to open either the Cell Style dialog (Figure 153) or the Page Style dialog (Figure 161).
3) Make the necessary changes to the style attributes. For more information on style attributes, see “Cell style attributes” on page 164 and “Page style attributes” on page 171.
4) Click OK to save the changes and close the dialog.

Note
The Modify command is unavailable if one or more sheets are protected, even if the style to be modified is being used in an unprotected sheet.

Renaming styles
You can rename custom styles, but not the styles supplied with Calc.
1) Go to the Styles panel in the Sidebar (Figure 149) and click the icon for the type of style you want to rename.
2) Right-click on the style you want to rename and select Modify from the context menu. The Cell Styles or Page Styles dialog opens.
3) On the Organizer tab, rename the style and click OK.
Deleting styles
You can delete custom styles, but not the styles supplied with Calc.

1) Go to the Styles deck in the Sidebar (Figure 149) and click the icon for the type of style you want to delete.
2) Right-click on the style you want to delete and select Delete from the context menu.
3) Select Yes on the warning message, if displayed. Any data in a cell or a sheet in the spreadsheet that used the deleted style will revert to the Default style.

Hiding and showing cell styles
You can shorten the list of cell styles by hiding some of them. Only styles that are not being used in the spreadsheet can be hidden.

1) Go to the Styles deck in the Sidebar and click on the Cell Styles icon.
2) Right-click on an unused cell style and select Hide from the context menu. The style is then moved to the Hidden Styles category in the Styles deck.

To show hidden cell styles:
1) Go to the Styles deck in the Sidebar.
2) Click on the drop-down list at the bottom of the panel and select Hidden Styles from the list.
3) Right-click on the hidden style you want to show and select Show from the context menu.

Filtering the list of styles
You can filter the list of styles as follows:

1) Go to the Styles deck in the Sidebar.
2) Click on the drop-down list at the bottom of the panel.
3) Select the category of styles to display in the Styles deck:
   - Hierarchical – lists the styles in their hierarchical relationship, for example Heading 1 and Heading 2 under Heading, or Accent 1, Accent 2, Accent 3 under Accent.
   - All Styles – lists all the styles that are available in Calc and in the spreadsheet, except for hidden styles.
   - Hidden Styles – lists all the styles that have been hidden in the spreadsheet.
   - Applied Styles – lists only the styles that have been applied to the spreadsheet.
   - Custom Styles – lists only the user-defined styles defined for the spreadsheet.

What is a template? Why use one?
A template is a model that you use to create other documents in a standard format. For example, you can create a template for invoices that has your company logo and address at the top of the page. This means that any new spreadsheets (invoices) created from this template will then have the company logo and address on the first page of the spreadsheet.

Templates can contain anything that regular documents can contain, such as text, graphics, styles, and user-specific setup information such as measurement units, language, default printer, and toolbar and menu customization.

All documents in LibreOffice are based on templates. You can create, or download and install, as many templates as you wish. If you do not specify a template when you start a new spreadsheet, that new spreadsheet is then based on the default template for spreadsheets that is included with
Calc. This default template consists of a blank spreadsheet which you can customize to your needs and then, if you wish, use as a basis to create a custom default template.

**Using a template to create a spreadsheet**

A new installation of LibreOffice may not include any spreadsheet templates, but you can create your own (see “Creating a template” on page 176) or install templates obtained from other sources (see “Adding templates obtained from other sources” on page 178).

When you do have a spreadsheet template available, you can create a new spreadsheet from it using either the Templates dialog or the LibreOffice Start Center.

**Creating a spreadsheet from the Templates dialog**

To use a template to create a spreadsheet:

1) From the Menu bar, choose **File > New > Templates**, or click the small arrow next to the **New** icon and select **Templates**, or press **Ctrl+Shift+N**. The Templates dialog (Figure 162) opens.

2) From the **Filter** lists at the top of the Templates dialog, select **Spreadsheets** and the category of template you want to use. All the templates in that category are then listed on the page, as shown in Figure 162.

3) Select the required template and click **Open**, or double-click the selected template. A new spreadsheet based on the template opens in Calc.

In the spreadsheet, the template it is based upon is listed in **File > Properties > General**. The connection between the template and the spreadsheet remains until the template is modified and, the next time that the spreadsheet is opened, you choose not to update it to match the template.

**Creating a spreadsheet from a template in the Start Center**

You can create a spreadsheet from the Template view of the LibreOffice Start Center, which is visible when no other document is open. (See Chapter 1, Introduction.)

Click the **Templates** button in the left pane and icons are displayed in the Start Center for all available LibreOffice templates. The button also offers a drop-down list to select the templates of a
given type of document. If you select the **Calc Templates** option on the list, the available spreadsheet templates are displayed in the Start Center. Click on the required template to create a new document based on that template.

**Creating a template**

You can easily create a template from any spreadsheet:

1. Open a new or existing spreadsheet that you want to use as a base for the template.
2. Add any necessary pre-defined content that you want to appear in a spreadsheet each time you use the new template, for example company logo and name, company information, page numbers, and so on. Delete any information that you do not want in the template.
3. Create or modify the cell and page styles that you want to use in the template.
4. From the Menu bar, choose **File > Templates > Save as Template**, or press **Shift+F11**. The Save As Template dialog (Figure 164) opens, displaying the existing template categories and a name box.
5. Type a name for the new template and select the required template category. You can also choose to make this the default template (see “Setting the default template” on page 179 for more information).
6. Click **Save** to save the new template.

![Save As Template dialog](image)

*Figure 163: Save As Template dialog*

**Note**

Although the **Save as Template** dialog shows no document type when saving a new template of any type, the template will appear on the correct tab (Spreadsheets, in this case) when you return to the Templates dialog.

It is unnecessary to save or do anything further with the spreadsheet file you have been using to create the new template. It can be safely closed without saving.
**Editing a template**

You can edit a template’s styles and content, and then, if you wish, you can reapply the template’s styles to spreadsheets that were created from that template. You cannot reapply content.

**Figure 164: Templates dialog – Editing templates**

To edit a template:

1. From the Menu bar, choose **File > Templates > Manage Templates**, or press **Ctrl+Shift+N**, to open the Templates dialog.

2. Navigate to the template that you want to edit. Right-click to open the context menu and choose **Edit** (see Figure 164). The template opens in Calc.

3. Edit the template as you would edit any other spreadsheet. To save the changes, choose **File > Save** from the Menu bar, or choose **File > Save As Template** to save the edited template as a new template.

**Updating styles from a changed template**

If you make any changes to a template and its styles, the next time you open a spreadsheet that was created before you changed the template, a confirmation message is displayed.

1. Click **Update Styles** to apply the changed styles in the template to the spreadsheet.

2. Click **Keep Old Styles** if you do not want to apply the changed styles in the template to the spreadsheet.

**Caution**

If you select **Keep Old Styles**, the confirmation message will not appear again the next time you open the spreadsheet using the same changed template. Although the template is still listed under **File > Properties > General**, the spreadsheet is no longer connected to the template, so it will not update. You can still import styles manually from the template, but to reconnect the spreadsheet to the template, you will have to copy it into an empty document based on the template.
Adding templates obtained from other sources

You can get to the official LibreOffice template repository by using the **Browse online templates** button in the lower left of the Templates dialog, as shown in Figure 165, or by typing [https://extensions.libreoffice.org/templates](https://extensions.libreoffice.org/templates) in your browser’s address bar.

On other websites you may find collections of templates that have been packaged into extension (.OXT) files. These are installed a little differently, as described below.

![Figure 165: Getting more templates for LibreOffice](image)

### Installing individual templates

You can import and add templates to your collection as follows:

1. Find and download the template you want to use, as described in the previous section.
2. Open the Templates dialog and click the **Import** icon near the bottom right.
3. In the pop-up dialog, select the category where you want to store the template. (You can change this later, as described in “Moving a template” on page 181.)
4. A file browser opens. Navigate to the location of the downloaded template on your computer.
5. Select the template and click **Open**. After import, the template becomes available in the Templates dialog.

Tip

You can manually copy new templates into the template folders. The location varies with your computer’s operating system. To learn where the template folders are stored on your computer, go to **Tools > Options > LibreOffice > Paths**.

### Installing collections of templates

The Extension Manager provides an easy way to install collections of templates that have been packaged as extensions. Follow these steps:

1. Download the extension package (.OXT file) and save it anywhere on your computer.
2. In LibreOffice, select **Tools > Extension Manager** from the Menu bar, or press `Ctrl+Alt+E`. In the Extension Manager dialog, click **Add** to open a file browser window.
3. Find and select the package of templates you want to install and click **Open**. The package begins installing. You may be asked to accept a license agreement.
4. When the package installation is complete, restart LibreOffice. The templates are available for use through **File > Templates > Manage Templates** and **File > New > Templates** and the extension is listed in the Extension Manager.

See Chapter 14, Setting up and Customizing, for more about the Extension Manager.

Tip

Some extensions are packaged as .ZIP files.
Setting the default template

If you create a new spreadsheet using **File > New > Spreadsheet** on the Menu bar, Calc creates the document from the default template for spreadsheets. You can set any template as the default template. You can also reset the default template to the Calc default template.

Setting a template as the default

Most default settings, such as page size and page margins, can be changed but those changes normally apply only to the spreadsheet you are working on. To make those changes the default settings for spreadsheets, you need to replace the default Calc template with a new one.

You can set any template displayed in the Templates dialog to be the default for that document type:

1) From the Menu bar, choose **File > Templates > Manage Templates** or press Ctrl+Shift+N.
2) In the Templates dialog, open the category containing the template that you want to set as the default.
3) Right-click on the template and click the **Set As Default** option (see Figure 164). The template is now indicated by a green check mark in the upper left.

The next time you create a spreadsheet by choosing **File > New**, by clicking the **New** icon in the Standard toolbar, or by pressing Ctrl+N, it will be created from this template.

Resetting the default template

To set the default spreadsheet template back to the default template supplied with Calc:

1) In the Templates dialog, click the **Settings** icon on the bottom left (Figure ).
2) Point to **Reset Default Template** on the drop-down menu, and click **Spreadsheet**. The green check mark is removed from the template.

This choice does not appear unless a custom template has been set as the default, as described in the previous section.

![Figure 166: Resetting the default template for spreadsheets](image)

You can also reset the default template as follows:

1) Go to the Templates dialog and open the category containing the template you set as default. It is indicated by a green check mark.
2) Right-click on this template and select **Reset Default** from the context menu. The next time that you create a new spreadsheet, it will be created using the Calc default template.
Organizing templates

LibreOffice can manage only templates that are in its template folders (categories), although you can create a spreadsheet from a template that is not in one of these folders. You can create new template folders and use them to organize your templates and import templates into these folders. For example, you might have one template folder for sales templates and another for invoice templates. You can also export templates.

Tip

The location of template folders in LibreOffice depends on the operating system of your computer. If you want to know where the template folders are located, go to Tools > Options > LibreOffice > Paths.

To begin, choose File > Templates > Manage Templates, or press Ctrl+Shift+N, to open the Templates dialog.

Creating a template category

1) Click the Settings button in the lower left of the Templates dialog.
2) Click New Category on the context menu (see Figure 167).
3) In the pop-up dialog (not shown), type a name for the new category and click OK. The new category now appears in the list of categories.

Deleting a template category

You cannot delete template categories supplied with LibreOffice. Nor can you delete any categories added by the Extension Manager unless you first remove the extension that installed them.

However, you can delete a category that you created:

Note

You cannot create a sub-category inside a template category.
1) Click the **Settings** button on the Templates dialog and select **Delete Category** from the context menu (see Figure 167).

2) Select the category to be deleted in the Delete Category dialog (not shown) and click **OK**.

3) Select **Yes** in the confirmation dialog to confirm the deletion.

4) Calc displays a warning dialog if it is unable to delete the category.

### Moving a template

To move a template from one template category to another:

1) Open the Templates dialog and select the template you want to move.

2) Click the **Move** icon near the bottom of the dialog, select the destination category from the popup dialog (Figure 168), and click **OK**. The selected template is moved to the folder. You can also create a new category into which to move the template.

![Figure 168: Moving a template to another category](image)

### Deleting a template

You cannot delete templates supplied with LibreOffice. Nor can you delete any templates installed by the Extension Manager except by removing the extension that installed them. You can only delete templates that you have created or imported.

1) From the **Filter** drop-down lists at the top of the Templates dialog, select the category that contains the template you want to delete.

2) Right-click on the template that you want to delete to open the context menu and click **Delete** (Figure 164).

3) A message box appears and asks you to confirm the deletion. Click **Yes**.

### Exporting a template

The easiest way to send a template to someone else, or to store it on a network, is to export it:

1) Open the Templates dialog and find the template that you want to export.

2) Select the template and click the **Export** icon.

3) The Select Folder dialog opens. Navigate to the location where you want to export the template and click **Select Folder**. You can also rename the template.

---

*Exporting a template* | 181
Exporting a template does not remove it from the Templates dialog. The action places a copy of the template in the location you specify.
Chapter 5
Using Graphics
**Introduction**

Calc is used to present and analyze data and to make forecasts and predictions. Graphics can turn an average spreadsheet into a more memorable document. Calc can import various vector (line drawing) and raster (bitmap or photo) file formats. The most commonly used graphic formats are GIF, JPG, and PNG. See LibreOffice Help for a full list of the formats that Calc can import.

Graphics in Calc are of three basic types:

- Image files, such as photographs, drawings, and scanned images
- Diagrams created using LibreOffice’s drawing tools
- Charts and graphs created using LibreOffice’s Chart facility; see Chapter 3, Creating Charts and Graphs, for more information

Using graphics in Calc is similar to using graphics in other components of LibreOffice. For more detailed descriptions, please refer to the Getting Started Guide or the Draw Guide.

**Note**

In LibreOffice, the terms *graphics* and *images* refer to both pictures and drawing objects. Often the word images is used when referring to pictures and other graphics that are not drawing objects.

---

**Adding graphics (images) to a spreadsheet**

Graphics or images (sometimes called pictures in LibreOffice), such as corporate logos and photographs, are probably the most common types of graphics added to a spreadsheet. They may be downloaded from the Internet, scanned, created with a graphics program, photographs taken with a digital camera, or clip art in the Gallery.

**Inserting an image file**

When the image is in a file stored on the computer, you can insert it into a spreadsheet using one of the following methods.

**Drag and drop**

1) Open a file browser window and locate the image you want to insert.
2) Drag the image into the spreadsheet and drop it where you want it to appear.

This method embeds (saves a copy of) the image file in the document. To link the file instead of embedding it, hold down the Ctrl+Shift keys while dragging the image. See “Linking or embedding an image file” on page 185 for more information.

**Insert Image dialog**

1) Click in the spreadsheet where you want the image to appear.
2) Choose Insert > Image from the Menu bar.
3) On the Insert Image dialog (Figure 169), navigate to the file to be inserted, and select it.
4) At the bottom of the dialog is an **Insert as Link** option. Select it if you want to link the file.
5) Click Open. The file is inserted into the spreadsheet and is anchored to the cell in which the cursor was placed.
If you have selected to link the image, Calc may present a confirmation dialog with options to continue with the link or to embed the image instead. An option is provided on this dialog to prevent it being displayed in future.

**Figure 169: Insert Image dialog**

**Linking or embedding an image file**

Embedding an image into a spreadsheet makes the image a permanent part of the spreadsheet file. Any changes you make to an embedded image will appear only in that spreadsheet; the original image will not be affected.

If you select the Insert as Link option in the Insert Image dialog, or use Ctrl+Shift during the drag and drop method, Calc creates a link to the file containing the image instead of embedding it. The image is displayed in the document, but when the document is saved, it contains only a reference to the image file, not the image itself. The document and the image remain as two separate files, and they are merged together only when you open the document again.

Linking an image has two advantages and one disadvantage:

- **Advantage** – You can modify the image file separately. The modified image will appear when you next open the spreadsheet. This can be a big advantage if you (or someone else, perhaps a graphic artist) is updating images.

- **Advantage** – Linking can reduce the file size of the spreadsheet when it is saved, because the image file itself is not included. However, file size is usually not a problem on modern computers, and Calc can easily handle large files.

- **Disadvantage** – If you send the document to someone else, or move it to a different computer, you must also send the image files and keep the same file structure. For example, you might keep image files in a subfolder named Images inside the same folder containing the Calc document. Any recipient of the spreadsheet needs to put the image files in a subfolder with the same name in the same named folder as the spreadsheet.
Note

When inserting the same image several times in a document, it might appear beneficial to create links. However, this is not necessary, as LibreOffice embeds only one copy of the image file in the document. Deleting one or more of the copies does not affect the other copies of the same file.

Embedding linked images

If you originally linked the images, you can easily embed one or more of them later.

1) Open the spreadsheet in Calc.

2) Choose Edit > Links to External Files on the Menu bar to open the Edit Links dialog (Figure 170), which shows all the linked files.

3) Select the files you want to change from linked to embedded.

4) Click Break Link and confirm you want to remove the selected link. The file then becomes embedded into the spreadsheet.

Note

Going from embedded to linked images is not so easy. You must replace them one at a time, selecting the Insert as Link option when you reinsert each file.

Inserting an image from the clipboard

Using the clipboard, you can copy images into a Calc spreadsheet from another LibreOffice document and from other programs. To do this:

1) Open both the source document and the target document.

2) In the source document, copy the image to the clipboard – the exact interactions will vary from program to program.

3) Switch to the target document. Click to place the cursor in the cell where the image is to be anchored. Right-click and select Paste to insert the image, or select Edit > Paste, or click the Paste icon in the Standard toolbar, or press Ctrl+V.
If the application from which the image was copied is closed before the image is pasted into the target, the image stored on the clipboard could be lost.

Inserting an image using a scanner

If a scanner is connected to your computer, LibreOffice can call the scanning application and insert the scanned item into the LibreOffice document as an image. To start this procedure, choose Insert > Media > Scan > Select Source. After selecting the scanner, place the cursor where you want the image to be inserted, and choose Insert > Media > Scan > Request.

Although this practice is quick and easy, it is unlikely to result in a high-quality image of the correct size. You may get better results by passing scanned material into a graphics program and cleaning it up there before inserting the resulting image into LibreOffice.

Inserting an image from the Gallery

The Gallery (Figure 171) provides a convenient way to group reusable objects such as images and sounds that you can insert into your documents. The Gallery is available in all components of LibreOffice. You can add your own images as well as using the ones supplied with LibreOffice. For more information, see the Getting Started Guide Chapter 11, Images and Graphics.

To insert an image from the Gallery:

1) Click the Gallery icon in the Sidebar, or select View > Gallery.
2) Select a theme.
3) Select an object with a single click.
4) Drag and drop the image into the document.
   You can also right-click on the object and choose Insert, in which case the image will be positioned according to the cells selected in the spreadsheet.
Note

To insert an image as a link, hold down the Shift and Ctrl keys while dragging the object into the document.

Modifying images

When you insert a new image, you may need to modify it to suit the document. Any changes made in Calc do not affect the original image, whether it is an embedded or linked image file.

Calc provides several tools for working with images. These tools are sufficient for most requirements. However, for professional results it is generally better to use Draw or other software designed to modify image files, and then insert the result into Calc.

Using the Image toolbar

When you insert an image or select one already present in the spreadsheet, the Image toolbar replaces the Formatting toolbar. If it does not appear, go to View > Toolbars > Image on the Menu bar. The tools available on the Image toolbar are described below.

Note

Changes to image properties affect only the display and printing of the image. The original image file remains unchanged.

- **Anchor** – choose between anchoring the image to a cell (with or without resize) or to a page. See “Anchoring images” on page 191.
- **Align** – if two or more images are selected, you can adjust the horizontal and vertical alignment of the images in relation to each other. See “Aligning images” on page 192.
- Six buttons for arrangement (the position of images in the stacking order): Bring to Front, Forward One, Back One, Send to Back, To Foreground, To Background. See “Arranging images” on page 191.
- **Line Style**, **Line Width**, **Line Color** – set the attributes of the border around the image.
- **Area Style / Filling** – sets the color or other characteristics of the background area that contains the image, not the image itself. To see the background, you must set the transparency of the image to a suitably high value. See the Draw Guide for more information on how to modify areas.
- **Shadow** – sets the default shadow effect around the image. To adjust the shadow effect, open the Area dialog (Format > Object > Area) and choose the Shadow tab.
- **Filter** – opens the Image Filter toolbar. See the Draw Guide for details on image filters.
- **Image Mode** – changes the display of the image from color (Default) to grayscale, black and white, or a watermark. This setting affects only the display and printing of the image; the original image file remains unchanged.
- **Crop Image** – places cropping handles around the image. Drag a handle to crop (hide) the edges of the image.
- **Flip Horizontally** and **Flip Vertically** – changes the orientation of the image.
- **Rotate** – places rotation handles around the image.
- **Transparency** – adjusts the degree of transparency of the image between 0% (opaque) and 100% (fully transparent).
- **Color** – opens the Color toolbar (Figure 172) to adjust the values of the red, green, blue colors, brightness, contrast and gamma.
Using the Properties deck in the Sidebar

Some of the settings in the Image toolbar are also available in the Properties deck in the Sidebar when an image is selected. These include the **Color**, **Line**, and **Transparency** settings.

Adding text

You can add text to an image or drawing object. That text will move with the image when the image is repositioned. For more information on adding text to images, see the *Draw Guide*.

1) Double-click on the image. The text cursor flashes in the center of the image. The Text Formatting toolbar automatically opens at the top of the spreadsheet.

![Figure 173: Text Formatting toolbar for images](image)

2) Type your text and use the tools on the Text Formatting toolbar to format it. Most of the tools are the same as those for formatting text in cells.

3) To adjust the position of the text or how it appears in the image, right-click on the image (when the text cursor is flashing) and select **Text** from the context menu to open the Text dialog (Figure 174).

![Figure 174: Text dialog](image)

4) Make any necessary changes and click **OK** to close the dialog.
Positioning, resizing, and arranging images

Using the mouse
To move an image to a new position in your spreadsheet, click on the image and drag it to a new position. The image will still be anchored as it was originally (that is, To Cell, To Cell (resize with cell), or To Page).

To resize an image:
1) Click on the image to display the selection handles.
2) Position the cursor over one of the selection handles. The cursor changes shape, giving a graphical representation of the direction of the resizing. The corner handles resize both the width and the height of the image simultaneously. The top, bottom, left and right handles only resize one dimension at a time.
3) Click and drag to resize the image.

Tip
To retain the original proportions of the image, click and drag one of the corner handles. If you want to change the original proportions, Shift+click one of the corner handles, then drag.

Using the Position and Size dialog
To accurately position and size an image in your spreadsheet, click on the image and then go to Format > Object > Position and Size on the Menu bar, or right-click on the image and select Position and Size from the context menu.

On the Position and Size tab (Figure 175) of the Position and Size dialog, you can set these values:

- **Position** – the location of the selected image on the spreadsheet.
  - **Position X** – the horizontal distance from the base point selected in the grid.
  - **Position Y** – the vertical distance from the base point selected in the grid.
- **Size** – the width and height of the image with respect to the selected base point.
- **Protect** – to prevent accidental movement or resizing of the image, select the relevant option.

The units of measurement used for X / Y coordinates and the width and height of the image are set by going to Tools > Options > LibreOffice Calc > General > Measurement unit.

The default location of the base points for position and size is the upper left corner of the spreadsheet. You can temporarily change this base point to make positioning or dimensioning simpler by clicking on a position corresponding to the location of the base point you want to use. This change in base point is only valid for single use and the base point is reset to the standard position of top left corner when you close the Position and Size dialog.

You can also rotate or slant an image (using the Rotation or Slant & Corner Radius tabs of the Position and Size dialog). See the Draw Guide for details.
Arranging images

Each image that you place in a spreadsheet is successively stacked on the preceding image, whether or not they overlap. Use the arrange commands to change the stacking order of images. You cannot change the stacking order of text.

1) Select the image you want to change.
2) Go to Format > Arrange on the Menu bar, or right-click on the image, select Arrange from the context menu, and select one of the arrangement options described below.
3) Alternatively, click on one of the six arrangement icons on the Image toolbar to quickly move the image up or down the stacking order.

The arrangement options are as follows:

- **Bring to Front** – moves the selected image to the top of the stacking order, so that it is in front of other images.
- **Forward One** – moves the selected image up one level, so that it is closer to top of the stacking order.
- **Back One** – moves the selected image down one level, so that it is closer to the bottom of the stacking order.
- **Send to Back** – moves the selected image to the bottom of the stacking order, so that it is behind the other images.
- **To Foreground** – moves the selected image in front of text.
- **To Background** – moves the selected image behind text. To select a background image so that you can modify or replace it, you have to use the Navigator. Other methods of selection, such as clicking or double-clicking, do not work.

Anchoring images

Anchor images so they stay in their position in relation to other items.

- **To Page** – anchor an image to the page to position it in a specific place. The image does not move when cells are added or deleted; it will always stay in the same position on the page where it is placed.
**To Cell** – anchor an image to a cell to ensure that the image always stays with the content it is originally anchored to. If an image is anchored to cell B10, and a new row is inserted above row 10, the image will then be anchored to cell B11.

**To Cell (resize with cell)** – similar to **To Cell** but with the additional property that the image resizes as you resize the cell to which it is anchored.

To anchor an image or change the type of anchor used:

- Go to **Format > Anchor > To Page** or **To Cell** or **To Cell (resize with cell)** on the Menu bar, or right-click on the image and select **Anchor > To Page** or **To Cell** or **To Cell (resize with cell)** from the context menu.
- Alternatively, click on the **Anchor** icon on the Image toolbar and select **To Page** or **To Cell** or **To Cell (resize with cell)**.

**Aligning images**

When you have more than one image in your spreadsheet, you can align these images to give your spreadsheet a more professional look. The options include three for aligning the images horizontally (left, centered, right) and three for aligning the images vertically (top, center, bottom).

1) Select all of the images to be aligned (select one and hold down the *Shift* key while selecting others).

2) Go to **Format > Align** on the Menu bar, or right-click on one of the images and select **Align** from the context menu, or click on the **Align** icon on the Image toolbar.

3) Select one of the options available for alignment.

**Grouping and ungrouping images**

To group several images so that they become a single object in the spreadsheet:

1) Select the images you want to group (select one and hold down the *Shift* key while selecting others).

2) Go to **Format > Group > Group** on the Menu bar, or right-click on one of the selected images and select **Group** from the context menu.

To ungroup images:

1) Select the image group you want to ungroup.

2) Go to **Format > Group > Ungroup** on the Menu bar, or right-click on one of the selected images and select **Ungroup** from the context menu.

To edit an image in a group:

1) Select the image group where you want to edit an image within the group.

2) Go to **Format > Group > Enter Group** on the Menu bar, or right-click on one of the selected images and select **Enter Group** from the context menu.

3) Select the image you want to make changes to and make the changes.

4) Go to **Format > Group > Exit Group** on the Menu bar, or right-click on one of the selected images and select **Exit Group** from the context menu.

**Using LibreOffice’s drawing tools**

Calc, like all other components of LibreOffice, has a range of tools to create drawings such as simple diagrams, using rectangles, circles, lines, text, and other shapes. You can group several drawing objects to make sure they maintain their relative position and proportion if you move or resize them.
You can also use the drawing tools to annotate photographs, screen captures, or other illustrations produced by other programs, but this is not recommended. If you need to create complex drawings, it is recommended to use LibreOffice Draw and then insert the drawing into your spreadsheet. For a more detailed explanation, see the *Draw Guide*.

**Drawing toolbar**

To begin using the drawing tools, go to **View > Toolbars > Drawing** to open the Drawing toolbar, which appears in its default position at the bottom of the spreadsheet. You can make this toolbar a floating toolbar and move it to a convenient position.

When the Drawing toolbar opens, it opens with a default set of tools as shown in Figure 176. Hover the mouse pointer over a tool to see a tooltip describing its function. Icons with small arrows to the right side open with palettes of tools. To add tools to the Drawing toolbar, right-click in an empty area on the toolbar and select **Visible Buttons** from the context menu.

![Figure 176: Drawing toolbar](image)

**To use a drawing tool:**

1. Click on the tool in the Drawing toolbar (Figure 176). The mouse pointer changes to a drawing-functions pointer and the normal Formatting toolbar changes to the Drawing Object Properties toolbar, becoming a floating toolbar (Figure 177).

2. Move the cross-hair pointer to the place in the document where you want the drawing object to appear and then click and drag to create the object. Release the mouse button. The selected drawing function remains active, so that you can draw another object of the same type.

3. To cancel the selected drawing function, click on the tool's icon again, press the `Esc` key or click on the **Select** icon (the arrow) on the Drawing toolbar.

4. You can now change the properties (fill color, line type and weight, anchoring, and others) of the drawing object using the Drawing Object Properties toolbar (Figure 177), the Properties deck on the Sidebar, or the choices reached by right-clicking on the drawing object.

**Setting the properties of drawing objects**

For more information on the properties of drawing objects, see the *Draw Guide*.

You can set some default properties for a drawing object before you draw an object. These default properties are applied only to the current spreadsheet and are not retained when you close the spreadsheet. The properties apply only to drawing objects.

1. Click **Select** on the Drawing toolbar (Figure 176).

2. On the Drawing Object Properties toolbar (Figure 177), set the values you want to use for each property. When you select area or line properties, dialogs open where you can set the values used for area or line.

![Figure 177: Drawing Object Properties toolbar](image)

3. After you draw an object or group it with another object, more properties become active. These appear on the toolbar (Figure 178) and some are shown in the Properties deck of the Sidebar (Figure 179).

![Figure 178: Drawing Object Properties toolbar after inserting an object](image)
You can change the properties of an existing drawing object (fill color, line type and weight, anchoring, and so on) using the Drawing Object Properties toolbar (Figure 177), the Properties deck on the Sidebar, or the context menu when you right-click on the drawing object.

![Properties deck in Sidebar for drawing object](image)

### Resizing drawing objects

Select the object and click on one of the selection handles then drag the object to its new size. For a scaled resizing, select one of the corner handles and keep the Shift key pressed while dragging the handle. For more information, see “Positioning, resizing, and arranging images” on page 190.

### Grouping and ungrouping drawing objects

For grouping, ungrouping, and editing grouped drawing objects, see “Grouping and ungrouping images” on page 192.

### Additional tools

Some additional tools are available when you right-click on an image or drawing object and open the context menu.

**Description**

You can add metadata in the form of a title and description to an image. This information is used by accessibility tools (such as screen reader software) and as ALT (alternative text) attributes if you export the document to HTML.
**Name**
You can add a custom name to be assigned to an image; this will make the image easier to find in the Navigator. Also, assigning names to images helps identify them when teams of people are working on the same multi-page spreadsheet.

**Rotate or Flip**
You can rotate the image or flip it horizontally or vertically.

**Assign Macro**
Opens the Assign Macro dialog so you can add programmable functionality to the graphic. Calc has a very good macro functionality. For more information, see Chapter 12, Macros.

**Edit Hyperlink**
You can define a hyperlink from an image to another location in your spreadsheet, another document, or a web page. Select **Edit Hyperlink** from the context menu to open the Hyperlink dialog. See Chapter 10, Linking Data, for more information on hyperlinks.

**Compress**
You can compress images to reduce the file size of the spreadsheet. Select **Compress** from the context menu to open a Compress Image dialog where you can set the compression options. (Option not available for drawing objects.)

**Edit with External Tool**
You can edit an image with an external tool. The dialog that opens will depend on your computer setup. (Option not available for drawing objects.)

---

**Using Fontwork**
With Fontwork, you can create graphical text art objects to make your work more attractive. There are many different settings for text art objects (line, area, position, size, and more), so you have a large choice.

Fontwork is available with each component of LibreOffice, but you will notice small differences in the way that each component displays it.

**Creating a Fontwork object**

1) On the Fontwork toolbar (**View > Toolbars > Fontwork**) or the Drawing toolbar (**View > Toolbars > Drawing**), click the **Fontwork** icon.

2) In the Fontwork Gallery (Figure 180), select a Fontwork style, then click **OK**. The Fontwork object will appear in the document.

3) Double-click the object to edit the Fontwork text (see Figure 181). Select the text and type your own text in place of the black Fontwork text that appears over the object.

4) Click anywhere in a free space or press Esc to apply your changes.
Editing a Fontwork object

Now that the Fontwork object is created, you can edit some of its attributes. To do this, you can use the Fontwork toolbar, the Formatting toolbar, or menu options. For more information, see Chapter 11, Images and Graphics, in the Getting Started Guide.
Chapter 6
Printing, Exporting, E-mailing, and Signing
Quick printing
To quickly print a spreadsheet, click on the Print Directly icon on the Standard toolbar to send the entire spreadsheet to the default printer that is defined for your computer.

Note
You can change the action of the Print Directly icon to send a document to the printer defined for the document instead of the default printer for the computer. Go to Tools > Options > Load/Save > General and select the Load printer settings with the document option.

Tip
The initial default when you first install LibreOffice is for the Print Directly icon not to appear on Calc’s Standard toolbar. However, you can enable its display by following the instructions given in Chapter 14, Setting Up and Customizing.

Controlling printing
For more control over printing, select File > Print, press Ctrl+P, or click the Print icon on the Standard toolbar, to open the Print dialog (Figure 182).
The options selected on the Print dialog apply to this printing of this document only.

To specify default printing settings for LibreOffice, go to Tools > Options > LibreOffice > Print and Tools > Options > LibreOffice Calc > Print. For details, see Chapter 14, Setting up and Customizing Calc.

The Print dialog has multiple tabs where you can choose a range of options, as described in the following sections. Depending on your computer’s operating system, the number of tabs, and the layout of each tab, may be different from the illustrations shown in this chapter. On some, but not all, installations a More Options button is provided on the Print dialog.

The Print dialog includes a Preview checkbox which enables you to turn on/off a preview of how you data will appear on the printed page. The preview appears in the area above the checkbox, on the left hand side of the dialog. Adjacent controls allow you to navigate through the pages of a long spreadsheet.

**General tab**

On the General tab of the Print dialog (Figure 182), you can choose from the following options:

**Printer options**
- Select the printer to use from the list of those available.
- Press the Properties button to change any required settings of the selected printer. The options available through this interaction will depend on your printer and system.

**Range and Copies options**
- Select which sheets and pages to print, single or double sided printing, the number of copies to print, whether to collate multiple copies, and the page order for printing. (See “Selecting what to print” on page 200.)

**Page Layout options**
- Select page layout properties such as paper size, portrait or landscape orientation, how many pages are printed per sheet of paper, the order in which the pages are printed on a sheet of paper, and whether a border is drawn around each page.

**LibreOffice Calc tab**

On the LibreOffice Calc tab of the Print dialog (Figure 183), you can select whether to suppress the output of empty pages when you print the spreadsheet.

![Figure 183: Print dialog – LibreOffice Calc tab](image)

**More Options dialog**

Press the More Options button to access the More Printing Options dialog (Figure 184). On this dialog you can choose whether to create separate print jobs for collated output.
Printing multiple pages on a single piece of paper

To print multiple pages of a spreadsheet on one piece of paper:

1) Use File > Print on the Menu bar, or Ctrl+P, or the Print icon on the Standard toolbar, to open the Print dialog and then select the Page Layout tab (Figure 185).

2) In the Layout section, select from the Pages per sheet drop-down list the number of spreadsheet pages to print per sheet of paper. The preview panel on the right shows how the pages will look in the printed document.

3) When printing more than two pages per sheet, select the order in which the pages are printed on a sheet from the Order drop-down list.

4) To distinguish each page on a sheet, select Draw a border around each page.

5) Click OK.

Selecting what to print

In addition to printing a full spreadsheet document, you can choose single sheets, multiple sheets, and selections of cells for printing.

To print an individual sheet:

1) In the spreadsheet, click on the sheet tab to select the sheet you want to print.

2) Choose File > Print on the Menu bar, or press Ctrl+P, or click the Print icon on the Standard toolbar.

3) In the Range and Copies section of the Print dialog, choose Selected sheets.

4) Click OK.

To print a range of sheets:

1) In the spreadsheet, select the sheets to print.

2) Choose File > Print on the Menu bar, or press Ctrl+P, or click the Print icon on the Standard toolbar.

3) In the Range and Copies section of the Print dialog, choose Selected sheets.
4) Click **OK**.

To print a selection of cells:

1) In the spreadsheet, select the cells to print.
2) Choose **File > Print** on the Menu bar, or press **Ctrl+P**, or click the **Print** icon on the Standard toolbar.
3) In the **Ranges and Copies** section of the Print dialog, choose **Selected cells**.
4) In the sub-section **From which print**, choose **Pages** and type 1 in the box.
5) Click **OK**.

**Printing in grayscale on a color printer**

You may wish to print a spreadsheet in grayscale on a color printer. You can do this in two ways.

---

**Note**

Some color printers may print in color regardless of the settings you choose.

---

For an individual file, you can change the printer settings to print in black and white or grayscale:

1) Choose **File > Print** on the Menu bar, or press **Ctrl+P**, or click the **Print** icon on the Standard toolbar, to open the Print dialog.
2) Click **Properties** to open the Properties dialog for the printer. The available choices vary from one printer to another, but you should find options for the color settings. See your printer’s help or user manual for more information.
3) The choices for color might include black and white or grayscale. Choose grayscale.
4) Click **OK** to confirm your choice and return to the Print dialog,
5) Click **OK** to print the document.

You can change the LibreOffice settings to print all color text and graphics as grayscale:

1) Choose **Tools > Options > LibreOffice > Print**.
2) Select **Convert colors to grayscale**. Click **OK** to save the change.

---

**Caution**

This changes the print settings for all components of LibreOffice, not just Calc

---

**Previewing pages/sheets before printing**

To preview the sheets in Calc before printing:

1) Choose **File > Print Preview** or click the **Toggle Print Preview** icon on the Standard toolbar.

   The Calc window now displays the Print Preview toolbar instead of the Formatting toolbar.

   ![Figure 186: Print Preview toolbar (Calc)](image)

2) To print the document from this view, select **File > Print** on the Menu bar, or press **Ctrl+P**, or click the **Print** icon (on the Standard toolbar), to open the Print dialog.
3) Choose the print options and click the **OK** button.
4) Click the **Toggle Print Preview** icon again, or click the **Close Preview** icon on the right-hand side of the Print Preview toolbar, to return to the normal spreadsheet view.
Using print ranges

You can define which range of cells on a spreadsheet are to be printed or exported to a PDF. The cells on the sheet that are not part of the defined print range are not printed or exported. Also, any sheets without a defined print range are not printed or exported.

Defining and printing a print range

To set a user-defined print range, which will replace any existing defined print range:

1) Select the range of cells that are to be used in the print range.
2) Go to Format > Print Ranges > Define on the Menu bar. Automatic page break lines are then displayed on the screen, defining the cells that are included in the print range.
3) Click on the Print Directly icon on the Standard toolbar to print the defined print range, or open the Print dialog and click OK to print the defined print range.

Tip

You can check the print range by using Toggle Print Preview or the Preview pane in the Print dialog. Calc will display only the cells in the print range. See "Viewing print ranges" on page 203.

Editing a print range

At any time, you can edit the print range, for example to add or remove cells, or define rows and columns to repeat (such as column or row headings).

Figure 187: Edit Print Ranges dialog

1) Go to Format > Print Ranges > Edit on the Menu bar to open the Edit Print Ranges dialog (Figure 187).
2) If only a single range is defined, then clicking anywhere in the Print Range text box displays the defined print range bounded in blue, as shown in Figure 188.

Figure 188: Single print range marked by a bounding box
3) To add new cells to the defined print ranges, type a comma at the end of the displayed data in the Print Range text box as the separator for the print range to be added. Select the cell range using the cursor, or type in the cell references using the same format as the print ranges already defined in the Print Range text box. Remember to separate the cell references with a colon.

4) To remove a print range, select the print range in the Print Range text box and delete it. Make sure the remaining print ranges only have a single comma as a separator and that there is not a comma at the end of the sequence.

5) Click OK to save your changes and close the dialog.

Viewing print ranges

After print ranges have been defined, they are formatted with automatic page breaks. To view the page breaks, go to View > Page Break on the Menu bar to open the preview (Figure 189).

![Figure 189: Page break preview](image)

The print ranges are outlined by default with a blue border and contain a pale gray page number in the center of each page. The nonprinting area of the spreadsheet normally has a gray background.

To exit the page break preview, go to View > Normal on the Menu bar.

Named print ranges

![Figure 190: Define Name dialog](image)

In addition to defining a print range for each print job, you can also define a range of cells to be used repeatedly, without having to select a range of cells every time. This is useful if different areas
of a large spreadsheet have to be printed for different reports; several named print ranges can be defined to meet this need.

**Defining and naming**

1) Select the cells you want to define and name as a print range, then go to **Sheet > Named Ranges and Expressions > Define** on the Menu bar to open the Define Name dialog (Figure 190). The selected cells are displayed in the **Range or formula expression** box. Alternatively, open the Define Name dialog, then select the cells you want to define and name. The selected cells are then displayed in the **Range or formula expression** box.

2) Type a name for the range in the **Name** box. Use only letters, numbers, and underscores in the name; no spaces, hyphens, or other characters are allowed.

3) If necessary, you can edit or set the range of selected cells for the print range in the **Range or formula expression** box. See “Editing a print range” on page 202 for more information.

4) Make sure **Document (Global)** is selected from the **Scope** drop-down list.

5) Select **Print range** from **Range Options** to define the settings as a print range.

6) Click **Add** to accept the data and close the dialog.

**Printing a named range**

To select a named range for printing:

1) Go to **Format > Print Ranges > Edit** on the Menu bar to open the Edit Print Ranges dialog (Figure 191).

2) Select the defined and named print range from the **Print Range** drop-down list.

3) Click **OK** to close the dialog.

4) Open the Print dialog, which will show only the named range in the preview area. Click **OK**.

![Figure 191: Choosing a named range for printing](image)

**Deleting a named print range**

To delete a named print range if it is no longer required:

1) Go to **Sheet > Named Ranges and Expressions > Manage** on the Menu bar to open the Manage Names dialog (Figure 192).

2) Select the named print range you want to delete and confirm it is a print range by checking the options in **Range Options**.

3) Click **Delete** and then click **OK** to close the dialog.

**Removing print ranges**

It may become necessary to remove a defined print range, for example if the whole sheet needs to be printed later, or you no longer want to print some of the added ranges.
Go to **Format > Print Ranges > Clear** on the Menu bar to remove all of the defined print ranges in the spreadsheet, except for named print ranges. After the print range is removed, the default page break lines for the selected paper size will appear on the screen.

To remove named print ranges, see “Deleting a named print range” above.

Figure 192: Manage Names dialog

Repeat printing of rows or columns

If a spreadsheet is printed on multiple pages, you can define specific rows or columns (for example, headings) to repeat print on each printed page.

**Using print ranges**

Figure 193: Repeat printing of rows and columns
1) Go to Format > Print Ranges > Edit to open the Edit Print Ranges dialog (Figure 193).

2) In the Rows to repeat box, type the references for the rows to be repeat printed. For example, to repeat rows 1, 2 and 3, type $1:$3. This automatically changes the Rows to repeat drop-down from - none - to - user defined -.

   You can also place the cursor in the Rows to repeat box and then, using the mouse, select a cell in each row you want to be repeat printed. It is not necessary to select the whole row.

3) In the Columns to repeat box, type the references for the columns to be repeat printed. For example, to repeat column A, type $A$. This automatically changes the Columns to repeat drop-down from - none - to - user defined -.

   You can also place the cursor in the Columns to repeat box and then, using the mouse, select a cell in each column you want to be repeat printed.

4) Click OK to save your changes and close the dialog.

**Using named print ranges**

You can also define named print ranges to use for repeat printing of rows or columns as follows:

1) Define and name the rows and/or columns you want to repeat print. See “Named print ranges” on page 203 for more information.

2) Select Repeat column and / or Repeat row from Range Options to define the columns and / or rows for repeat printing in the Define Name dialog (Figure 190 on page 203).

3) Click Add to accept the data and close the dialog.

4) Go to Format > Print Ranges > Edit to open the Edit Print Ranges dialog (Figure 193).

5) Select the defined and named print ranges from the Rows to repeat and/or Columns to repeat drop-down lists.

6) Click OK to save your changes and close the dialog.

**Page breaks**

While defining a print range can be a powerful tool, you may sometimes need to manually adjust the page breaks to make sure the spreadsheet prints the way you want it to look. You can insert two types of page breaks into a spreadsheet:

- **Row break** – is a horizontal page break inserted above a selected cell in a row. For example, if the selected cell is H15, then a row break is created between rows 14 and 15.

- **Column break** – is a vertical page break inserted to the left of the selected cell in a column. For example, if the selected cell is H15, then a column break is created between columns G and H.

When a manual break is inserted, it appears as a blue line or as a bold line between the rows or columns on the display. The actual appearance depends on your computer setup. To see manual break lines more easily on your display, you can change their appearance. Go to Tools > Options > LibreOffice > Application Colors and scroll down to the Spreadsheet section where you can change how page breaks appear.

**Inserting page breaks**

1) Select the cell where you want to insert a manual break in the spreadsheet.

2) Go to Sheet > Insert Page Break on the Menu bar.

3) Select Row Break to insert a row break above the cell or Column Break to insert a column break to the left of the cell.
Alternatively, go to View > Page Break on the Menu bar, right-click in the spreadsheet and select Row Break or Column Break from the context menu. Remember to go to View > Normal on the Menu bar and return to the standard spreadsheet view.

Deleting page breaks

1) Select the cell where you want to delete a manual break from the spreadsheet.
2) Go to Sheet > Delete Page Break on the Menu bar.
3) Select Row Break to delete a row break from above the cell or Column Break to delete a column break from the left of the cell.

Deleting multiple page breaks

Multiple manual row and column breaks can exist in the same spreadsheet. If you want to remove all breaks from the spreadsheet:

1) Go to View > Page Break on the Menu bar.
2) Right-click in the spreadsheet and select Delete Page Breaks from the context menu to remove all manual breaks from your spreadsheet.
3) Go to View > Normal on the Menu bar to return to the standard spreadsheet view.

Printing options for page styles

When using page styles for your spreadsheets, you can include printing options within the page style; for example, page order, details, scale to be printed, and so on. Using page styles allows you to quickly set up and change the printing options of different sheets within your spreadsheet. See Chapter 4, Using Styles and Templates, for more information about page styles.

![Image of Page Style dialog – Sheet tab]

Figure 194. Page Style dialog – Sheet tab
Make sure you have selected the correct sheet within the spreadsheet before setting the print options. Go to **Format > Page** on the Menu bar to open the Page Style dialog, then click on the **Sheet** tab (Figure 194) to set the printing options for a page style. The dialog indicates which page style you are about to change.

- **Page order** – defines the order in which data in a sheet is numbered and printed when it does not fit on one printed page. A preview of the page order is shown in the graphic on the top right of the dialog in Figure 194.
  - **Top to bottom, then right** – prints vertically from the left column to the bottom of the sheet.
  - **Left to right, then down** – prints horizontally from the top row of the sheet to the right column.
  - **First page number** – select this option if you want the first page to start with a number other than 1. Enter the number of the first page in the box.

- **Print** – defines which elements of the spreadsheet are to be printed.
  - **Column and row headers** – prints the column and row headers.
  - **Grid** – prints the borders of the individual cells as a grid. For the view on screen, make your selection under **LibreOffice > Options > LibreOffice Calc > View > Grid lines**.
  - **Comments** – prints the comments defined in the spreadsheet. Comments will be printed on a separate page, along with the corresponding cell reference.
  - **Objects/Images** – includes all inserted objects (if printable) and graphics with the printed spreadsheet.
  - **Charts** – prints the charts that have been inserted into your spreadsheet.
  - **Drawing objects** – includes all drawing objects in the printed spreadsheet.
  - **Formulas** – prints the formulas contained in the cells, instead of the results of any formulas used in the spreadsheet.
  - **Zero values** – specifies that cells with a zero value are printed with a zero (0) in the cell.

- **Scale** – defines a page scale for the printed spreadsheet.
  - **Scaling mode** – select a scaling mode from the drop-down list. Appropriate controls for the scaling mode selected will be shown below the drop-down list box.
    i) **Reduce/enlarge printout** – specifies a scaling factor to scale all printed pages. Enter the scaling factor as a percentage in the box.
    ii) **Fit print range(s) to width/height** – specifies the maximum number of pages horizontally (width) and vertically (height) on which every sheet with the current page style is to be printed.
      
      The print ranges are always scaled proportionally, so the resulting number of pages may be less than specified. You may clear one of the boxes; then the unspecified dimension will use as many pages as necessary. If you clear both boxes, the scaling factor will be 100%.
    iii) **Fit print range(s) on number of pages** – specifies the maximum number of pages to be printed for each sheet that uses the same page style. The scale will be reduced as necessary to fit the defined number of pages.
Headers and footers

Headers and footers are predefined pieces of text that are printed at the top or bottom of a sheet outside of the sheet area. Headers and footers are set the same way and you can have different content on left and right pages that use the same page style.

Setting headers and footers

To turn the headers or footers on in your spreadsheet:

1) Select the sheet where you want to turn on the header or footer.
2) Go to Format > Page on the Menu bar to open the Page Style dialog and select the Header (or Footer) tab (Figure 195). The Header and Footer tabs in the Page Style dialog are identical.
3) Select the Header on or Footer on option.
4) Enter the values for the other options according to your requirements. These options are described below.
5) Click OK to save your changes and close the dialog.

![Figure 195: Page Style dialog – Header tab](image)

- **Header on** or **Footer on** – adds a header or footer to the current page style.
- **Same content on left and right pages** – causes left and right pages to share the same header or footer content. To assign a different header or footer to left and right pages, deselect this option and then click Edit. See “Header or footer contents” on page 210 for more information.
- **Left margin** – enter the amount of space to leave between the left page margin and the left edge of the header or footer.
- **Right margin** – enter the amount of space to leave between the right page margin and the right edge of the header or footer.
- **Spacing** – enter the amount of space to maintain between the bottom edge of the header and the top edge of the spreadsheet, or the top edge of the footer and the bottom edge of the spreadsheet.
- **Height** – enter the height for the header or footer.
- **AutoFit height** – automatically adjusts the height of the header or footer to fit the content.
• Preview box – shown on the right side of Figure 195, this area displays a preview of the current selection.
• **More** – opens the Border/Background dialog, where you can define the appearance of borders and background colors or images for headers or footers. See Chapter 4, Using Styles and Templates, for more information.
• **Edit** – opens the Header or Footer dialog where you can add, edit, or format text that is placed in the header or footer. See “Header or footer contents” below for more information.

![Figure 196: Header dialog](image)

**Header or footer contents**

The headers and footers in a Calc spreadsheet have three columns for text. Each column can either be empty or have different contents from the other columns.

1) Select the sheet where you want to turn on the header or footer.
2) Open the Page Style dialog (Figure 195), then select **Header on** or **Footer on** and the options for the header or footer. See “Setting headers and footers” above.
3) Click **Edit** to open the Header or Footer dialog (Figure 196). If **Same content on left and right pages** is deselected in the Page Style dialog, the Header or Footer dialog will have tabbed pages where you can set the header or footer contents for right and left pages.
4) To enter standard contents into the header or footer, select an option from the **Header** or **Footer** drop-down list.
5) To enter customized contents into the header or footer, click in one the area boxes and type your text, or click in one of the area boxes and click one of the **Custom header** or **Custom footer** icons. These icons are explained below.
6) To change the appearance of the text in the header or footer, click the **Text Attributes** icon to open the Text Attributes dialog, where you can set the font, font effects and font position.
7) Click **OK** to save the changes to text attributes and close the Text Attributes dialog.
8) Click **OK** to save the changes to the contents of the header or footer and close the Header or Footer dialog.
9) Click **OK** to save the changes to your header or footer and close the Page Style dialog.

The options available for a **Custom header** or **Custom footer** are as follows:
• **Text Attributes** – opens a Text Attributes dialog where you can assign formats to new or selected text. The Text Attributes dialog contains tabbed pages for Font, Font Effects, and Position.

• **Title** – inserts a file name placeholder in the selected area. Click and select either **Title**, **File Name**, or **Path/File Name** from the drop-down menu that opens. If a title has not be assigned to the spreadsheet, the file name for the spreadsheet will be inserted instead.

• **Sheet Name** – inserts a placeholder in the selected area for the sheet name of the selected sheet in the spreadsheet.

• **Page** – inserts a placeholder in the selected area for the page number. This allows continuous page numbering in a spreadsheet.

• **Pages** – inserts a placeholder in the selected area for the total number of pages in the spreadsheet.

• **Date** – inserts a placeholder in the selected area for the current date which will be repeated in the header/footer on each page of the spreadsheet.

• **Time** – inserts a placeholder in the selected area for the current time which will be repeated in the header/footer on each page of the spreadsheet.

**Exporting to PDF**

Calc can export documents to PDF (Portable Document Format). This industry-standard file format is ideal for sending a file for someone else to view using Adobe Reader or other PDF viewers.

**Warning**

A document in PDF format is not protected against contents tampering or editing by default. The PDF document contents can be edited by specialized software tools, including LibreOffice Draw.

**Tip**

Unlike **Save As**, the **Export** command writes a copy of the current document in a new file with the chosen format, but keeps the current document and format open in your session.

**Quick export to PDF**

Click the **Export Directly as PDF** icon on the Standard toolbar to export the entire spreadsheet using the PDF settings most recently selected on the PDF Options dialog (see below). You are asked to enter the file name and location for the PDF, but you do not get a chance to choose a page range, image compression, or other options.

**Controlling PDF content and quality**

For more control over the content and quality of the resulting PDF, use **File > Export as PDF**. The PDF Options dialog opens. This dialog has six tabs (**General**, **Initial View**, **User Interface**, **Links**, **Security**, and **Digital Signatures**). Select the appropriate settings, and then click **Export**. Then enter the location and file name of the PDF to be created, and click **Save** to export the file.

**General tab of PDF Options dialog**

On the General tab (Figure 193), you can choose which pages to include in the PDF, the type of compression to use for images (which affects the quality of images in the PDF), and other options.
For more information, see the Getting Started guide or the Help. In most cases, the defaults will be what you need.

### PDF Options

**General**

- **Range**
  - All: Exports the entire document to PDF.
  - Pages: To export a range of pages within a selected sheet, use the format 3-6 (pages 3 to 6). To export single pages, use the format 7;9;11 (pages 7, 9, and 11), or a combination of the two formats.
  - Selection/Selected sheet(s): Exports the selected material (a sheet or part of a sheet).
  - View PDF after export: If selected, your default PDF viewer will open and display the newly exported PDF.

- **Images**
  - Lossless compression: Images are stored without any loss of quality. Tends to make large files when used with photographs. Recommended for other kinds of images or graphics.
  - JPEG compression: Allows for varying degrees of quality, in the range 1 to 100%. A setting of 90% works well with photographs (small file size, little perceptible loss of quality).
  - Reduce image resolution: Select the required value from the options in the drop-down menu. Lower DPI (dots per inch) images have lower quality. Higher DPI settings can greatly increase the size of the exported file.

- **Watermark**
  - Sign with watermark: When this option is selected, a transparent overlay of the text you enter into the text box will appear on each page of the PDF.

- **Hybrid PDF (embed ODF file)**: Use this setting to export the document as a PDF file containing two file formats: PDF and ODF. In PDF viewers it behaves like a normal PDF file, and it remains fully editable in LibreOffice.

### Range section

- **All**: Exports the entire document to PDF.
- **Pages**: To export a range of pages within a selected sheet, use the format 3-6 (pages 3 to 6). To export single pages, use the format 7;9;11 (pages 7, 9, and 11), or a combination of the two formats.
- **Selection/Selected sheet(s)**: Exports the selected material (a sheet or part of a sheet).
- **View PDF after export**: If selected, your default PDF viewer will open and display the newly exported PDF.

### Images section

- **Lossless compression**: Images are stored without any loss of quality. Tends to make large files when used with photographs. Recommended for other kinds of images or graphics.
- **JPEG compression**: Allows for varying degrees of quality, in the range 1 to 100%. A setting of 90% works well with photographs (small file size, little perceptible loss of quality).
- **Reduce image resolution**: Select the required value from the options in the drop-down menu. Lower DPI (dots per inch) images have lower quality. Higher DPI settings can greatly increase the size of the exported file.

### Watermark section

- **Sign with watermark**: When this option is selected, a transparent overlay of the text you enter into the text box will appear on each page of the PDF.

### General section

- **Hybrid PDF (embed ODF file)**: Use this setting to export the document as a PDF file containing two file formats: PDF and ODF. In PDF viewers it behaves like a normal PDF file, and it remains fully editable in LibreOffice.
• **Archive (PDF/A, ISO 19005):** PDF/A is an ISO standard for long-term preservation of documents, by embedding all the information necessary for faithful reproduction (such as fonts) while forbidding other elements (including forms, security, and encryption). PDF tags are written. Also select which version of the standard to use, **PDF/A-1b** or **PDF/A-2b**.

• **Tagged PDF:** Tagged PDF contains information about the structure of the document’s contents. This can help to display the document on devices with different screens, and when using screen reader software. Some tags that are exported are table of contents, hyperlinks, and controls. This option can increase file sizes significantly.

• **Create PDF form – Submit format:** Use the drop-down menu to choose the format of submitting forms from within the PDF file.

• **Allow duplicate field names** – If enabled, the same field name can be used for multiple fields in the generated PDF file. If disabled, field names will be exported using generated unique names.

• **Export bookmarks:** Generally not used in Calc.

• **Comments as PDF annotations:** Exports comments as PDF notes. You may not want this!

• **Whole Sheet Export:** The setting allows you to export your Calc spreadsheet to PDF, with the content of a sheet exported as one page in the PDF. This facility is not intended for printing but allows you to easily see and review the full content of a spreadsheet document in a PDF form, without the usual slicing of the sheets into printable pages. Preview pages will have different sizes, as do the source sheets.

  **Note:**

  Selecting the **Whole Sheet Export** option causes Calc to disregard many of the other settings on the PDF Options dialog.

• **Export automatically inserted blank pages:** Not available in Calc.

• **Use reference XObjects:** Reference XObjects enable one PDF file to import content from another. More information can be found in section 8.10.4 of the PDF specification, ISO 32000-2:2017 ([https://www.iso.org/standard/63534.html](https://www.iso.org/standard/63534.html)). If you are not familiar with reference XObjects, leave this box unchecked.

**Initial View tab of PDF Options dialog**

On the Initial View tab (Figure 198), you can select how the PDF file opens by default in a PDF viewer. The options should be self-explanatory.
User Interface tab of PDF Options dialog

On the User Interface tab (Figure 199), you can select options to control how a PDF viewer displays the file. Some of these options are useful when you are creating a PDF to be used as a presentation or a kiosk-type display.

Figure 199: PDF Options dialog – User Interface tab

Window Options
- **Resize window to initial page**: the PDF reader window displays the whole first page.
- **Center window on screen**: the PDF is shown in a reader window centered on screen.
- **Open in full screen mode**: the PDF reader window is in front of all other windows.
- **Display document title**: the PDF is shown with the document title in the reader title bar.

Transitions – not used in Calc.

User Interface Options
- **Hide menu bar**: hides the reader menu bar when the document is active.
- **Hide toolbar**: hides the reader toolbar when the document is active.
- **Hide window controls**: hides the reader controls when the document is active.

Bookmarks
- **All bookmark levels**: shows all bookmark levels when the reader opens the PDF.
- **Visible bookmark levels**: shows bookmark levels down to the selected level (in the range 1 to 10) when the reader opens the PDF.

Links tab of PDF Options dialog

On the Links tab (Figure 200) you can select how bookmarks and hyperlinks are exported to PDF.

Figure 200: PDF Options dialog – Links tab

Export bookmarks as named destinations
If you have defined Calc sheet names, this option exports them as “named destinations” to which Web pages and PDF documents can link.
Convert document references to PDF targets
If you have defined links to other documents with OpenDocument extensions (such as .odt, .ods, and .odp), this option converts the files’ extensions to .pdf in the exported PDF document.

Export URLs relative to file system
If you have defined relative links in a document, this option exports those links to the PDF. See Relative hyperlinks in the Calc Help for more information.

Cross-document links
Defines the behavior of links clicked in PDF files. Select one among the following alternatives:
– Default mode: The PDF links will be handled as specified in your operating system.
– Open with PDF reader application: Use the same application used to display the PDF document to open linked PDF documents.
– Open with Internet browser: Use the default Internet browser to display linked PDF documents.

Security tab of PDF Options dialog
Use the Security tab (Figure 201) to encrypt and set passwords when you export your spreadsheet and create the PDF file. Setting encryption and passwords also allows you to apply restrictions on printing and if changes or copying can be carried out on the PDF file.

![Figure 201: PDF Options dialog – Security tab](image)

Click the Set Passwords button to open the Set Passwords dialog (Figure 202) where you enter the passwords. You can enter a password (Set open password) to open the file and an optional password (Set permission password) to restrict what readers can do with the PDF file.

- With an open password set, the PDF can only be opened with the password. Once opened, there are no restrictions on what the user can do with the document (for example, print, copy, or change it).
• With a permission password set, the PDF can be opened by anyone, but its permissions can be restricted. See Figure 201. After you set a password for permissions, the other choices on the Security tab become available.

• With both the open password and permission password set, the PDF can only be opened with the correct password, and its permissions can be restricted.

The options on the Security tab become available only when passwords have been set.

Note
Permissions settings are effective only if the user’s PDF viewer respects the settings.

Digital Signatures tab of PDF Options dialog
This tab contains the options related to exporting a digitally signed PDF.

Digital signatures are used to ensure that the PDF was really created by the original author (that is, you), and that the document has not been modified since it was signed.

The signed PDF export uses the keys and X.509 certificates already stored in your default key store location or on a smartcard. The key store to be used can be selected under Tools > Options > LibreOffice > Security > Certificate Path. (Not available on Microsoft Windows systems, where LibreOffice will access the system certificate storage.) When using a smartcard, it must already be configured for use by your key store. This is usually done during installation of the smartcard software. Details about using these features is outside the scope of this chapter.

Figure 203: PDF Options dialog – Digital Signatures tab

• Use this certificate to digitally sign PDF documents: Click Select to open the Select Certificate dialog, where all certificates found in your selected key store are displayed. If the
key store is protected by a password, you are prompted for it. When using a smartcard that is protected by a PIN, you are also prompted for that.

Select the certificate to use for digitally signing the exported PDF, then click **OK**.

All other fields on the *Digital Signatures* tab are accessible only after a certificate has been selected.

- **Certificate password**: Enter the password used for protecting the private key associated with the selected certificate. Usually this is the key store password. If the key store password has already been entered in the Select Certificate dialog, the key store may already be unlocked and not require the password again.

  When using a smartcard, enter the PIN here. Some smartcard software will prompt you for the PIN again before signing.

- **Location, Contact information, Reason**: Optionally enter additional information about the digital signature that will be applied to the PDF. This information will be embedded in the appropriate PDF fields and will be visible to anyone viewing the PDF. Each or all of the three fields may be left blank.

- **Time Stamp Authority**: Optionally select a Time Stamping Authority (TSA) URL. During the PDF signing process, the TSA will be used to obtain a digitally signed timestamp that is then embedded in the signature. Anyone viewing the PDF can use this timestamp to verify when the document was signed.

The list of TSA URLs that can be selected is maintained under **Tools > Options > LibreOffice > Security > TSAs**. If no TSA URL is selected (the default), the signature will not be timestamped, but will use the current time from your local computer.

### Exporting to other formats

LibreOffice uses the term “export” for some file operations involving a change of file type. If you want to use another spreadsheet file format (for example, Microsoft Excel), use **File > Save As**. If you want to create web pages from your spreadsheet, use **File > Export**.

### E-mailing spreadsheets

LibreOffice provides several ways to send documents quickly and easily as an e-mail attachment in OpenDocument format (LibreOffice default format), other spreadsheet formats, or as a PDF file. You can also email a document to several recipients. For more information, see the *Getting Started Guide*.

To send the spreadsheet as an email:

1) Go to **File > Send** on the Menu bar and select from the following options. LibreOffice opens your default e-mail program (if set) with the spreadsheet attached in the selected format.
   - **Email Document**: the spreadsheet is sent in its current format.
   - **E-mail as OpenDocument Spreadsheet**: the spreadsheet is sent in the ODF format.
   - **E-mail as Microsoft Excel**: the spreadsheet is sent in the Excel format (.xlsx).
   - **E-mail as PDF**: The PDF Options dialog opens. Select the parameters to be used for the PDF file. See “Controlling PDF content and quality” on page 211.

2) In your e-mail program, enter the recipient, subject, and any text you want to add, then send the e-mail.
Digital signing of documents

To sign a document digitally, you need a personal key, also known as a certificate. A personal key is stored on your computer as a combination of a private key, which must be kept secret, and a public key, which you add to your documents when you sign them. You can get a certificate from a certification authority, which may be a private company or a governmental institution.

When you apply a digital signature to a document, a checksum is computed from the document’s content plus your personal key. The checksum and your public key are stored together with the document.

When someone later opens the document on any computer with a recent version of LibreOffice, the program will compute the checksum again and compare it with the stored checksum. If both are the same, the program will signal that you see the original, unchanged document. In addition, the program can show you the public key information from the certificate. You can compare the public key with the public key that is published on the web site of the certificate authority.

Whenever someone changes something in the document, the change breaks the digital signature. On Windows operating systems, the Windows features for validating a signature are used. On Linux systems, files that are supplied by Mozilla Thunderbird or Firefox are used to validate the signature. For a more detailed description of how to get and manage a certificate, and signature validation, see About Digital Signatures in the LibreOffice Help.

Applying digital signatures

The following procedure is only an example of how to digitally sign a document. The actual procedure depends on how your computer is set up and the computer operating system.

1) Open the file that you want to digitally sign.

2) Go to File > Digital Signatures > Digital Signatures on the Menu bar.

   - If you have set LibreOffice to warn you when the document contains comments (see “Removing personal data” on page 220), you may see a message box asking whether you want to continue signing the document.

   - If the document contains comments, a warning dialog opens asking if you wish to continue. Click Yes to continue, or click No to exit and take appropriate action to remove the comments and restart this procedure.

   - If you have not saved the document since the last change, a message box appears. Click Yes to save the file. When you have saved the file, the Digital Signatures dialog opens (Figure 204).

3) Click Sign Document to open the Select Certificate dialog (Figure 205).

   Select the certificate you want to use and click OK to close the Select Certificate dialog.

   The certificate used is displayed in the Digital Certificates dialog with an icon next to its name. This icon indicates the status of the digital signature.

   - An icon with a red seal (🪤) indicates that the document was signed and the certificate was validated.

   - An icon with a yellow caution triangle overlaying the red seal (🪤) indicates that the document is signed but that the certificate could not be validated.

   - An icon with a yellow caution triangle by itself (⚠️) indicates an invalid digital signature.

4) Click Close to close the Digital Signatures dialog and digitally sign your file.

A signed document shows an icon in the status bar. You can double-click the icon to view the certificate. More than one signature can be added to a document.
Note

If you make any changes to the document after digitally signing, the digital signature is removed automatically and you have to repeat the above procedure to digitally sign it again.

Figure 204: Digital Signatures dialog

![Digital Signatures dialog]

Figure 205: Select Certificate dialog

![Select Certificate dialog]

Signing multiple times with same signature

In the past, LibreOffice prohibited creating multiple signatures by the same author on a document, because there was no semantic meaning of signing the same document multiple times. LibreOffice now provides a signature description, so multiple signatures from the same author are now allowed, because each signature can have a different meaning.

When you select File > Digital Signatures > Digital Signatures, the dialog (Figure 204) lists existing signatures together with their description (if they have any).

When you click the Sign Document button, the dialog (Figure 205) for certificate selection now also asks for an optional description.
Changing the value of an existing description invalidates the signature.

**Digitally signing macros**

Normally, macros are part of a document. If you sign a document, the macros inside the document are signed automatically. If you want to sign only the macros, but not the document, go to **Tools > Macros > Digital Signature** on the Menu bar and apply the signature as described above.

**Removing personal data**

You may wish to ensure that personal data, versions, notes, hidden information, or recorded changes are removed from files before you send them to other people or create PDFs from them.

- In **Tools > Options > LibreOffice > Security > Options**, you can set Calc to remind you when files contain certain information and to remove personal information automatically on saving.
- To remove personal and some other data from a file, go to **File > Properties**. On the **General** tab, deselect **Apply user data** and then click **Reset Properties**. This removes any names in the created and modified fields, deletes the modification and printing dates, and resets the **Total editing time** to zero, the creation date to the current date and time, and the **Revision number** to 1.

To remove version information, either go to **File > Versions** on the Menu bar, select the versions from the list and click **Delete**, or go to **File > Save As** and save the file with a different name.
Chapter 7
Using Formulas and Functions
Introduction

In previous chapters, we have been entering one of two basic types of data into each cell: numbers and text. However, we will not always know what the contents should be. Often the contents of one cell depends on the contents of other cells. To handle this situation, we use a third type of data: the formula. Formulas are equations using numbers and variables to get a result. In a spreadsheet, the variables are cell locations that hold the data needed for the equation to be completed.

A function is a predefined calculation entered in a cell to help you analyze or manipulate data. All you have to do is add the arguments, and the calculation is made automatically. Functions help you create the formulas needed to get the results that you are looking for.

Setting up a spreadsheet

If you are setting up more than a simple one-sheet system in Calc, it is worth planning ahead a little. Make sure to:

- Avoid typing fixed values into formulas
- Include documentation (notes and comments) describing what the system does, including what input is required and where the formulas come from (if not created from scratch)
- Incorporate a system of error-checking of formulas to verify that the formulas do what is intended

The trap of fixed values

Many users set up long and complex formulas with fixed values typed directly into the formula.

For example, conversion from one currency to another requires knowledge of the current conversion rate. If you input a formula in cell C1 of =0.75*B1 (for example to calculate the value in Euros of the USD dollar amount in cell B1), you will have to edit the formula when the exchange rate changes from 0.75 to some other value. It is much easier to set up an input cell with the exchange rate and reference that cell in any formula needing the exchange rate. What-if type calculations are also simplified: what if the exchange rate varies from 0.75 to 0.70 or 0.80? No formula editing is needed and it is clear what rate is used in the calculations. Breaking complex formulas down into more manageable parts, described below, also helps to minimize errors and aid troubleshooting.

Lack of documentation

Lack of documentation is a very common point of failure. Many users prepare a simple sheet which then develops into something much more complicated over time. Without documentation, the original purpose and methodology is often unclear and difficult to decipher. In this case it is usually easier to start again from the beginning, wasting the work done previously. If you insert comments in cells, and use labels and headings, a spreadsheet can later be modified by you or others and much time and effort will be saved.

Error-checking formulas

Adding up columns of data or selections of cells from a sheet often results in errors due to omitting cells, wrongly specifying a range, or double-counting cells. It is useful to institute checks in your spreadsheets. For example, set up a spreadsheet to calculate columns of figures, and use SUM to calculate the individual column totals. You can check the result by including (in a non-printing column) a set of row totals and adding these together. The two figures—row total and column total—must agree. If they do not, you have an error somewhere.

You can even set up a formula to calculate the difference between the two totals and report an error in case a non-zero result is returned (see Figure 206).
Creating formulas

You can enter formulas in two ways, either by using the Function Wizard, or by typing directly into the cell or into the input line. A formula must begin with an = symbol, so when typing in directly, you need to start a formula with one of the following symbols: =, + or –. Calc automatically adds the = symbol for the formula, when starting with the + or – character. Starting with anything else causes the formula to be treated as if it were text.

Operators in formulas

Each cell in the sheet can be used as a data holder or a place for data calculations. To enter data, simply type in the cell and move to the next cell or press Enter. With formulas, the equals sign indicates that the cell will be used for a calculation. An example of a mathematical calculation like 15 + 46 is shown in Figure 207.

While the calculation on the left used only one cell, the real power is shown on the right where the data is placed in cells and the calculation is performed using references to the cells. In this case, cells B3 and B4 were the data holders, with B5 the cell where the calculation was performed. Notice that the formula was shown as =B3+B4. The plus sign indicates that the contents of cells B3 and B4 are to be added together and then have the result in the cell holding the formula. All formulas build upon this concept. Other ways of using formulas are shown in Table 3.

These cell references allow formulas to use data from anywhere in the sheet being worked on, or from any other sheet in the document that is opened. If the data needed was in different sheets, they would be referenced by referring to the name of the sheet, for example =SUM($Sheet2.B12+$Sheet3.A11).

Note

To enter the = symbol for a purpose other than creating a formula as described in this chapter, type an apostrophe or single quotation mark before the =. For example, in the entry ‘= means different things to different people, Calc treats everything after the single quotation mark—including the = sign—as text.
### Simple Calculation in 1 Cell

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td></td>
<td>=A1+10</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

### Calculation by Reference

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>15</td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>46</td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td></td>
<td>=B3+B4</td>
<td></td>
</tr>
<tr>
<td>6</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>15</td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>46</td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>61</td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

#### Figure 207: A simple calculation

#### Table 3: Common ways to use formulas

<table>
<thead>
<tr>
<th><strong>Formula</strong></th>
<th><strong>Description</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>=A1+10</td>
<td>Displays the contents of cell A1 plus 10.</td>
</tr>
<tr>
<td>=A1*16%</td>
<td>Displays 16% of the contents of A1.</td>
</tr>
<tr>
<td>=A1*A2</td>
<td>Displays the result of multiplying the contents of A1 and A2.</td>
</tr>
<tr>
<td>=ROUND(A1,1)</td>
<td>Displays the contents of cell A1 rounded to one decimal place.</td>
</tr>
<tr>
<td>=EFFECT(5%,12)</td>
<td>Calculates the effective interest for 5% annual nominal interest with 12 payments a year.</td>
</tr>
<tr>
<td>=B8-SUM(B10:B14)</td>
<td>Calculates B8 minus the sum of the cells B10 to B14.</td>
</tr>
<tr>
<td>=SUM(B8, SUM(B10:B14))</td>
<td>Calculates the sum of cells B10 to B14 and adds the value to B8.</td>
</tr>
<tr>
<td>=SUM(B1:B1048576)</td>
<td>Sums all numbers in column B.</td>
</tr>
<tr>
<td>=AVERAGE(BloodSugar)</td>
<td>Displays the average of a named range defined under the name BloodSugar.</td>
</tr>
<tr>
<td>=IF(C31&gt;140, &quot;HIGH&quot;, &quot;OK&quot;)</td>
<td>Displays the results of a conditional analysis of data from two sources. If the contents of C31 is greater than 140, then HIGH is displayed, otherwise OK is displayed.</td>
</tr>
</tbody>
</table>
Functions in Table 3 are identified by a word, for example ROUND, followed by parentheses, which normally enclose references or numbers.

**Note**

Users of some other spreadsheet software may be familiar with formulas that begin with +, -, =, (, @, ., $, or #. A mathematical formula would look like +D2+C2 or +2*3. Functions begin with the @ symbol such as @SUM(D2..D7), @COS(@DEGTORAD(30)) and @IRR(GUESS,CASHFLOWS). Ranges are identified such as A1..D3.

It is also possible to establish ranges for inclusion by naming them using **Sheet > Named Ranges and Expressions > Define**, for example **BloodSugar** representing a range such as B3:B10. Logical functions can also be performed as represented by the IF statement which results in a conditional response based upon the data in the identified cell, for example

=IF(A2>=0, "Positive", "Negative")

A value of 3 in cell A2 would return the result Positive, a value of –9 the result Negative.

**Operator types**

You can use the following operator types in Calc: arithmetic, comparative, text, and reference.

**Arithmetic operators**

The addition, subtraction, multiplication, and division operators return numerical results. The negation and percent operators identify a characteristic of the number found in the cell, for example -37. The example for exponentiation illustrates how to enter a number that is being multiplied by itself a certain number of times, for example 2^3 = 2*2*2.

Table 4: Arithmetical operators

<table>
<thead>
<tr>
<th>Operator</th>
<th>Name</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>+ (Plus)</td>
<td>Addition</td>
<td>=1+1</td>
</tr>
<tr>
<td>– (Minus)</td>
<td>Subtraction</td>
<td>=2–1</td>
</tr>
<tr>
<td>– (Minus)</td>
<td>Negation</td>
<td>–5</td>
</tr>
<tr>
<td>* (Asterisk)</td>
<td>Multiplication</td>
<td>=2*2</td>
</tr>
<tr>
<td>/ (Slash)</td>
<td>Division</td>
<td>=10/5</td>
</tr>
<tr>
<td>% (Percent)</td>
<td>Percent</td>
<td>15%</td>
</tr>
<tr>
<td>^ (Caret)</td>
<td>Exponentiation</td>
<td>2^3</td>
</tr>
</tbody>
</table>

**Comparative operators**

Comparative operators are found in formulas that use the IF function and return either a true or false answer; for example, =IF(B6>G12, 127, 0) which, loosely translated, means if the contents of cell B6 are greater than the contents of cell G12, then return the number 127, otherwise return the number 0.

A direct answer of TRUE or FALSE can be obtained by entering a formula such as =B6>B12. If the numbers found in the referenced cells are accurately represented, the answer TRUE is returned, otherwise FALSE is returned.
Table 5: Comparative operators

<table>
<thead>
<tr>
<th>Operator</th>
<th>Name</th>
<th>Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>=</td>
<td>Equal</td>
<td>A1=B1</td>
</tr>
<tr>
<td>&gt;</td>
<td>Greater than</td>
<td>A1&gt;B1</td>
</tr>
<tr>
<td>&lt;</td>
<td>Less than</td>
<td>A1&lt;B1</td>
</tr>
<tr>
<td>&gt;=</td>
<td>Greater than or equal to</td>
<td>A1&gt;=B1</td>
</tr>
<tr>
<td>&lt;=</td>
<td>Less than or equal to</td>
<td>A1&lt;=B1</td>
</tr>
<tr>
<td>&lt;&gt;</td>
<td>Inequality</td>
<td>A1&lt;&gt;B1</td>
</tr>
</tbody>
</table>

If cell A1 contains the numerical value 4 and cell B1 contains the numerical value 5, the above examples would yield results of FALSE, FALSE, TRUE, FALSE, TRUE, and TRUE.

**Text operators**

It is common for users to place text in spreadsheets. To provide for variability in what and how this type of data is displayed, text can be joined together in pieces coming from different places on the spreadsheet. Figure 208 shows an example.

![Text concatenation](image)

Figure 208: Text concatenation

In this example, specific pieces of the text were found in three different cells. To join these segments together, the formula also adds required spaces and punctuation enclosed within quotation marks, resulting in a formula of =B2 & " " & C2 & " , " & D2. The result is the concatenation into a date formatted in a particular sequence.

Calc has a CONCATENATE function which performs the same operation.

**Reference operators**

An individual cell is identified by the column identifier (letter) located along the top of the columns and a row identifier (number) found along the left-hand side of the spreadsheet. On spreadsheets read from left to right, the reference for the upper left cell is A1.

Thus in its simplest form a reference refers to a single cell, but references can also refer to a rectangle or cuboid range or a reference in a list of references. To build such references you need reference operators.

**Reference range operator**

The range operator is written as a colon. An expression using the range operator has the following syntax:

reference upper left : reference lower right
The range operator builds a reference to the smallest range including both the cells referenced with the left reference and the cells referenced with the right reference.

In the upper left corner of Figure 209 the reference A1:D12 is shown, corresponding to the cells included in the drag operation with the mouse to highlight the range.

**Examples**

A2:B4  
Reference to a rectangle range with 6 cells, 2 column width × 3 row height. When you click on the reference in the formula in the input line, a border indicates the rectangle.

(A2:B4):C9  
Reference to a rectangle range with cell A2 top left and cell C9 bottom right. So the range contains 24 cells, 3 column width × 8 row height. This method of addressing extends the initial range from A2:B4 to A2:C9.

Sheet1.A3:Sheet3.D4  
Reference to a cuboid range with 24 cells, 4 column width × 2 row height × 3 sheets depth. (Assumes that sheets Sheet1, Sheet2, and Sheet3 appear in that order on the Sheet tabs area.)

B:B  
Reference to all cells of column B.

A:D  
Reference to all cells of columns A to D.

20:20  
Reference to all cells of row 20.

1:20  
Reference to all cell of rows 1 to 20.

When you enter B4:A2, B2:A4, or A4:B2 directly, then Calc will turn it to A2:B4. So the left top cell of the range is left of the colon and the bottom right cell is right of the colon. But if you name the cell B4 for example with _start and A2 with _end, you can use _start:_end without any error.

**Reference concatenation operator**

The concatenation operator is written as a tilde. An expression using the concatenation operator has the following syntax:

reference left ~ reference right

The result of such an expression is a reference list, which is an ordered list of references. Some functions can take a reference list as an argument, SUM, MAX, or INDEX for example.

The reference concatenation is sometimes called 'union'. But it is not the union of the two sets 'reference left' and 'reference right' as normally understood in set theory. COUNT(A1:C3~B2:D2) returns 12 (=9+3), but it has only 10 cells when considered as the union of the two sets of cells.
Notice that $\text{SUM}(A1:C3, B2:D2)$ is different from $\text{SUM}(A1:C3\sim B2:D2)$ although they give the same result. The first is a function call with 2 parameters, each of them is reference to a range. The second is a function call with 1 parameter, which is a reference list.

The reference concatenation also applies to whole rows and whole columns. For example $\text{SUM}(A:B\sim D:D)$ is the sum of all cells in columns A and B and the column D.

**Reference intersection operator**

The intersection operator is written as an exclamation mark. An expression using the intersection operator has the following syntax:

```
reference left ! reference right
```

If the references refer to single ranges, the result is a reference to a single range, containing all cells, which are both in the left reference and in the right reference.

If the references are reference lists, then each list item from the left is intersected with each one from the right and these results are concatenated to a reference list. The order is to first intersect the first item from the left with all items from the right, then intersect the second item from the left with all items from the right, and so on.

**Examples**

$A2:B4 \! B3:D6$

This results in a reference to the range B3:B4, because these cells are inside A2:B4 and inside B3:D6. This is illustrated in Figure 210, in which the cells in the range A2:B4 have orange backgrounds and the cells in the range B3:D6 have thick black borders. The cells that have both an orange background and a thick black border (B3:B4) form the intersection of the two ranges.

![Figure 210: Simple example of reference intersection operator](image)

$(A2:B4\sim B1:C2) \! (B2:C6\sim C1:D3)$


$A:B \! 10:10$

Calculates the intersection of columns A and B with line 10, thus selecting A10 and B10.

You can use the intersection operator to refer a cell in a cross tabulation in an understandable way. If you have columns labeled 'Temperature' and 'Precipitation' and the rows labeled 'January', 'February', 'March', and so on, then the following expression

'February' ! 'Temperature'

will reference the cell containing the temperature in February.

The intersection operator (!) has a higher precedence than the concatenation operator (~), but do not rely on precedence.
Relative and absolute references

References are the way that we refer to the location of a particular cell in Calc and can be either relative (to the current cell) or absolute (a fixed amount).

Relative referencing

An example of a relative reference will illustrate the difference between a relative reference and absolute reference using the spreadsheet from Figure 211.

1) Type the numbers 4 and 11 into cells C3 and C4 respectively of that spreadsheet.
2) Copy the formula in cell B5 (=B3+B4) to cell C5. You can do this by using a simple copy and paste or click and drag B5 to C5 as shown below. The formula in B5 calculates the sum of values in the two cells B3 and B4.
3) Click in cell C5. The formula bar shows =C3+C4 rather than =B3+B4 and the value in C5 is 15, the sum of 4 and 11 which are the values in C3 and C4.

In cell B5 the references to cells B3 and B4 are relative references. This means that Calc interprets the formula in B5, applies it to the cells in the B column, and puts the result in the cell holding the formula. When you copied the formula to another cell, the same procedure was used to calculate the value to put in that cell. This time the formula in cell C5 referred to cells C3 and C4.

Figure 211: Relative references

You can think of a relative address as a pair of offsets to the current cell. Cell B1 is 1 column to the left of cell C5 and 4 rows above. The address could be written as R[-1]C[-4]. In fact earlier spreadsheets allowed this notation method to be used in formulas.

Whenever you copy this formula from cell B5 to another cell, the result will always be the sum of the two numbers taken from the two cells one and two rows above the cell containing the formula.

Relative addressing is the default method of referring to addresses in Calc.
**Absolute referencing**

You may want to multiply a column of numbers by a fixed amount. A column of figures might show amounts in US Dollars. To convert these amounts to Euros it is necessary to multiply each dollar amount by the exchange rate. $US10.00 would be multiplied by 0.75 to convert to Euros, in this case Eur7.50. The following example shows how to input an exchange rate and use that rate to convert amounts in a column from USD to Euros.

1) Input the exchange rate Eur:USD (0.75) in cell D1. Enter amounts (in USD) into cells D2, D3 and D4, for example 10, 20, and 30.

2) In cell E2 type the formula =D2*D1. The result is 7.5, correctly shown.

3) Copy the formula in cell E2 to cell E3. The result is 200, clearly wrong! Calc has copied the formula using relative addressing: the formula in E3 is =D3*D2 and not what we want, which is =D3*D1.

4) In cell E2 edit the formula to be =D2*$D$1. Copy it to cells E3 and E4. The results are now 15 and 22.5 which are correct.

The $ signs before the D and the 1 convert the reference to cell D1 from relative to absolute or fixed. If the formula is copied to another cell the second part will always show $D$1. The interpretation of this formula is “take the value in the cell one column to the left in the same row and multiply it by the value in cell D1”.

![Image of Excel cells with formulas showing absolute referencing]

**Figure 212: Absolute references**

Cell references can be shown in four ways.
<table>
<thead>
<tr>
<th>Reference</th>
<th>Explanation</th>
</tr>
</thead>
<tbody>
<tr>
<td>D1</td>
<td>Relative, from cell E3 it is the cell one column to the left and two rows above</td>
</tr>
<tr>
<td>$D$1</td>
<td>Absolute, from cell E3 it is the cell D1</td>
</tr>
<tr>
<td>$D$1</td>
<td>Partially absolute, from cell E3 it is the cell in column D and two rows above</td>
</tr>
<tr>
<td>D$1</td>
<td>Partially absolute, from cell E3 it is the cell one column to the left and in row 1</td>
</tr>
</tbody>
</table>

**Tip**

To change references in formulas, highlight the cell and press **F4** to cycle through the four types of references. To cycle only part of the formula select the cells in the formula bar and cycle with **F4**. Selecting the menu option **Sheet > Cycle Cell Reference Types** is equivalent to pressing the **F4** shortcut.

Knowledge of the use of relative and absolute references is essential if you want to copy and paste formulas and to link spreadsheets.

**Named ranges**

Cells and cell ranges can have a name assigned to them. Naming cells and ranges enhances formula readability and document maintenance. A simple example would be naming a range of cells B1:B10 as “Weight” and sum all weights. The formula is =SUM(B1:B10).

When the range B1:B10 is named as **Weight**, you can transform the formula to =SUM(Weight). The advantage is clear in terms of readability of the formulas.

Another advantage is that all formulas that have the named range as argument are updated when the named range changes location or size. For example, if the range Weight is now in cells P10:P30, you do not need to review all the formulas that have Weight as an argument; you only need to update the named range **Weight** with the new size and location.

To define a named cell or range select the cell or range and use menu **Sheet > Named Ranges and Expressions > Define**. The dialog in Figure 213 appears with the selected range and you define the name and scope of the named range.

![Define Name dialog](Image)

**Figure 213: Define Name dialog**

You can also define a named range directly in the sheet by selecting the range and typing its name in the Name Box at the left of the Formula Bar (Figure 214).
To quickly access a named range, select the named range in the Name Box drop-down above. The named range is shown on the screen and selected.
To modify a named range, use the Manage Names dialog (Figure 215). This dialog is accessed by selecting **Sheet > Named Ranges and Expressions > Manage** from the Menu bar or pressing **Ctrl+F3**.

**Named expressions**

You also can give a long or complex formula a name. To name a formula, open the Define Name dialog (Figure 213) and enter the formula expression in the **Range or formula expression** box. Name the expression and click **Add**.

As an example, suppose you need to compute in cells C1 to C10 the circumference of a set of circles and you are given their radius in B1 to B10. Define a named expression CIRCUMFERENCE, with expression =2*PI()*B1 and click **Add** to close the dialog. In cell C1, type =CIRCUMFERENCE and press **Enter**. The formula is applied to cell C1. Copy cell C1 and paste in the remaining cells from C2 to C10 and you have the circumferences of all the circles. All cells in the range C1:C10 have the expression =CIRCUMFERENCE.

Note that the named expression uses the same rules for cell addressing, that is, absolute and relative references.

**Order of calculation**

Order of calculation refers to the sequence in which numerical operations are performed and the Wikipedia article at https://en.wikipedia.org/wiki/Order_of_operations provides useful general background information. Division and multiplication are performed before addition or subtraction. There is a common tendency to expect calculations to be made from left to right as the equation would be read in English. Calc evaluates the entire formula, then based upon programming precedence, breaks the formula down executing multiplication and division operations before other operations. Therefore, when creating formulas you should test your formula to make sure that the expected and correct result is being obtained. Following is an example of the order of calculation in operation.

*Table 6: Order of calculation*

<table>
<thead>
<tr>
<th><strong>Left To Right Calculation</strong></th>
<th><strong>Ordered Calculation</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>1+3*2+3 = 11</td>
<td>=1+3*2+3 result 10</td>
</tr>
<tr>
<td>1+3 = 4, then 4 x 2 = 8, then 8+3 = 11</td>
<td>3*2 = 6, then 1+6+3 = 10</td>
</tr>
<tr>
<td>Another possible intention could be:</td>
<td>The program resolves the multiplication of 3 x 2 before dealing with the numbers being added.</td>
</tr>
<tr>
<td>1+3*2+3 = 20</td>
<td></td>
</tr>
<tr>
<td>1+3 = 4, then 2+3 = 5, then 4 x 5=20</td>
<td></td>
</tr>
</tbody>
</table>

If you intend for the result to be either of the two possible solutions on the left, order the formula as:

- 

(1+3) * 2+3 = 11

(1+3) * (2+3) = 20

**Note**

Use parentheses to group operations in the order you intend; for example, =B4+G12*C4/M12 might become=((B4+G12)*C4)/M12.

**Calculations linking sheets**

Another powerful feature of Calc is the ability to link data through several sheets. The naming of sheets can be helpful to identify where specific data may be found. A name such as Payroll or Boise Sales is much more meaningful than Sheet1. The function named SHEET() returns the sheet number (position) in the collection of sheets. There may be several sheets in each document and they may be numbered from the left: Sheet1, Sheet2, and so forth. If you drag the sheets
around to different locations among the tabs, the function returns the number referring to the current position of this sheet. In a new instance of Calc, the default is a single sheet.

For example, if the formula =SHEET() is put into A1 on Sheet 1 it returns the value 1. If you drag Sheet 1 to be positioned between sheets 2 and 3 then the value changes to 2; it is now the second sheet in the order.

An example of calculations obtaining data from other work can be seen in a business setting where a business combines revenues and costs of each of its branch operations into a single combined sheet. See the four parts of Figure 216 below.

<table>
<thead>
<tr>
<th>A</th>
<th>K</th>
<th>L</th>
<th>M</th>
<th>N</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Flows</td>
<td>Abundantly, Ltd.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td></td>
<td>Combined Sales YTD</td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td></td>
<td>Oct</td>
<td>Nov</td>
<td>Dec</td>
</tr>
<tr>
<td>5</td>
<td>Revenue</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>Grocery Sales</td>
<td>30,251</td>
<td>14,686</td>
<td>49,006</td>
</tr>
<tr>
<td>7</td>
<td>Fertilizer Sales</td>
<td>6,120</td>
<td>2,984</td>
<td>7,934</td>
</tr>
<tr>
<td>8</td>
<td>Earth Sales</td>
<td>784</td>
<td>386</td>
<td>952</td>
</tr>
<tr>
<td>9</td>
<td>Sub-Total</td>
<td>45,106</td>
<td>17,969</td>
<td>50,474</td>
</tr>
<tr>
<td>10</td>
<td>Cost of Sales:</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>11</td>
<td>Wholesaler Purchases</td>
<td>15,306</td>
<td>5,273</td>
<td>19,081</td>
</tr>
<tr>
<td>12</td>
<td>Sales Tax</td>
<td>4,902</td>
<td>1,633</td>
<td>6,422</td>
</tr>
<tr>
<td>13</td>
<td>Sub-Total</td>
<td>20,208</td>
<td>7,865</td>
<td>25,493</td>
</tr>
<tr>
<td>14</td>
<td>Total Revenue:</td>
<td>24,808</td>
<td>9,663</td>
<td>32,161</td>
</tr>
</tbody>
</table>

Sheet containing data for Branch 1.

<table>
<thead>
<tr>
<th>A</th>
<th>K</th>
<th>L</th>
<th>M</th>
<th>N</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Flows</td>
<td>Abundantly, Ltd.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td></td>
<td>Combined Sales YTD</td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td></td>
<td>Oct</td>
<td>Nov</td>
<td>Dec</td>
</tr>
<tr>
<td>5</td>
<td>Revenue</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>Grocery Sales</td>
<td>85,801</td>
<td>50,357</td>
<td>101,179</td>
</tr>
<tr>
<td>7</td>
<td>Fertilizer Sales</td>
<td>54,833</td>
<td>17,630</td>
<td>6,782</td>
</tr>
<tr>
<td>8</td>
<td>Earth Sales</td>
<td>59,025</td>
<td>16,024</td>
<td>7,622</td>
</tr>
<tr>
<td>9</td>
<td>Sub-Total</td>
<td>179,659</td>
<td>92,701</td>
<td>116,583</td>
</tr>
<tr>
<td>10</td>
<td>Cost of Sales:</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>11</td>
<td>Wholesaler Purchases</td>
<td>61,084</td>
<td>31,618</td>
<td>40,718</td>
</tr>
<tr>
<td>12</td>
<td>Sales Tax</td>
<td>10,762</td>
<td>3,071</td>
<td>13,044</td>
</tr>
<tr>
<td>13</td>
<td>Sub-Total</td>
<td>71,846</td>
<td>34,689</td>
<td>53,762</td>
</tr>
<tr>
<td>14</td>
<td>Total Revenue:</td>
<td>98,812</td>
<td>50,980</td>
<td>65,224</td>
</tr>
</tbody>
</table>

Sheet containing data for Branch 2.

<table>
<thead>
<tr>
<th>A</th>
<th>K</th>
<th>L</th>
<th>M</th>
<th>N</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Flows</td>
<td>Abundantly, Ltd.</td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td></td>
<td>Combined Sales YTD</td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td></td>
<td>Oct</td>
<td>Nov</td>
<td>Dec</td>
</tr>
<tr>
<td>5</td>
<td>Revenue</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>Grocery Sales</td>
<td>30,251</td>
<td>14,686</td>
<td>49,006</td>
</tr>
<tr>
<td>7</td>
<td>Fertilizer Sales</td>
<td>6,120</td>
<td>2,984</td>
<td>7,934</td>
</tr>
<tr>
<td>8</td>
<td>Earth Sales</td>
<td>784</td>
<td>386</td>
<td>952</td>
</tr>
<tr>
<td>9</td>
<td>Sub-Total</td>
<td>45,106</td>
<td>17,969</td>
<td>50,474</td>
</tr>
<tr>
<td>10</td>
<td>Cost of Sales:</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>11</td>
<td>Wholesaler Purchases</td>
<td>15,306</td>
<td>5,273</td>
<td>19,081</td>
</tr>
<tr>
<td>12</td>
<td>Sales Tax</td>
<td>4,902</td>
<td>1,633</td>
<td>6,422</td>
</tr>
<tr>
<td>13</td>
<td>Sub-Total</td>
<td>20,208</td>
<td>7,865</td>
<td>25,493</td>
</tr>
<tr>
<td>14</td>
<td>Total Revenue:</td>
<td>24,808</td>
<td>9,663</td>
<td>32,161</td>
</tr>
</tbody>
</table>

Sheet containing data for Branch 3.

234 | Creating formulas
The sheets have been set up with identical structures. The easiest way to do this is to open a new spreadsheet, set up the first branch sheet, input data, format cells, and prepare the formulas for the various sums of rows and columns.

1) On the sheet tab, right-click and select Rename Sheet. Type Branch1. Right-click on the tab again and select Move or Copy Sheet.

2) In the Move/Copy Sheet dialog (Figure 217), select the Copy option (automatically selected if there is only one sheet in the spreadsheet) and select move to end position in the Insert before area. Change the entry in New name to Branch2. Click OK. Repeat to produce the Branch3 and Combined sheets.

3) Enter the data for Branch 2 and Branch 3 into the respective sheets. Each sheet stands alone and reports the results for the individual branches.

4) In the Combined sheet, click on cell K7. Type =, click on the tab Branch1, click on cell K7, press +, repeat for sheets Branch2 and Branch3, and press Enter. You now have a formula in cell K7 which adds the revenue from greenery sales for the three branches.
5) Copy the formula, highlight the range K7:N17, click Edit > Paste Special > Paste Special, uncheck the Paste all and Formats options in the Selection area of the dialog, check all other options in that area, and click OK. You will see the following message:

![Warning message](image)

Figure 219: Linking sheets: pasting a formula to a cell range

6) Click Yes. You have now copied the formulas into each cell while maintaining the format set up in the original sheet. Of course, in this example you would have to tidy up the sheet by removing the zeros in the non-formatted rows.

![Copy/Paste Special from K7:N17](image)

Figure 220: Linking sheets: Copy / Paste Special from K7:N17

### Note

LibreOffice default is to paste all the attributes of the original cells: formats, notes, objects, text strings, and numbers.
The Function Wizard can also be used to accomplish the linking. Use of this wizard is described in detail in "Using the Function Wizard" on page 239.

**Understanding functions**

Calc includes over 500 functions to help you analyze and reference data. Many of these functions are for use with numbers, but others are used with dates and times or even text. A function may be as simple as adding two numbers together or finding the average of a list of numbers, or it may be as complex as calculating the standard deviation of a sample or a hyperbolic tangent of a number.

Typically, the name of a function is an abbreviated description of what the function does. For instance, the FV function gives the future value of an investment, while BIN2HEX converts a binary number to a hexadecimal number. By tradition, functions are entered entirely in upper case letters, although Calc will read them correctly if they are in lower or mixed case, too.

A few basic functions are somewhat similar to operators. Examples:

+ This operator adds two numbers together for a result. SUM() on the other hand adds groups of contiguous ranges of numbers together.

* This operator multiplies two numbers together for a result. PRODUCT() does the same for multiplying that SUM() does for adding.

Each function has a number of arguments used in the calculations. These arguments may or may not have their own name. Your task is to enter the arguments needed to run the function. In some cases, the arguments have predefined choices, and you may need to refer to the text on the Function Wizard and the Function List deck, or the Help, to understand them. More often, however, an argument is a value that you enter manually, or one already entered in a cell or range of cells in the spreadsheet. In Calc, you can enter values from other cells by typing in their name or range, or —unlike the case in some spreadsheets—by selecting cells with the mouse. If the values in the cells change, then the result of the function is automatically updated.

**Compatibility with other spreadsheet applications**

For many functions, Calc follows the OpenFormula standard defined in Part 2 (Recalculated Formula (OpenFormula) Format) of the Open Document Format for Office Applications (OpenDocument) Version 1.2. This standard can be accessed at the OASIS website (https://www.oasis-open.org/) or the ISO website (https://www.iso.org/standard/66375.html). Calc's general support for OpenFormula leads to a level of inherent compatibility with the function set of any other spreadsheet application that follows the same standard. (There are some functions within Calc that are not in accordance with OpenFormula but many of these are included specifically to improve the exchange of files between Calc and Microsoft Excel.)

In order to improve interoperability, Calc is able to open spreadsheets created by many different applications and able to save spreadsheets in many different formats. In the case of Microsoft Office, it is extremely straightforward to exchange spreadsheet files between the two applications. When Calc opens a Microsoft Excel spreadsheet, it automatically takes steps to avoid incompatibilities that might otherwise be encountered with certain functions. For example, when Calc opens an Excel file that contains calls to Excel's CEILING function, these are automatically converted to reference Calc's CEILING.XCL function. Similarly when Calc saves a spreadsheet to Microsoft Excel format, it automatically takes steps to avoid potential incompatibilities. An example of this occurs when Calc saves a spreadsheet containing calls to its FLOOR function, as these are automatically converted to reference Excel’s FLOOR.MATH function.

The Document Foundation’s wiki provides a comparison of the features of LibreOffice and Microsoft Office, see https://wiki.documentfoundation.org/Feature_Comparison:_LibreOffice__Microsoft_Office. This comparison shows that Calc currently provides 506 discrete functions, with only 27 of those being unique to Calc, and the remainder having counterparts in Microsoft Excel. It
is clear that there is a high level of commonality between the function sets of Calc and Excel, and many functions can be used in both applications with no change, thus increasing interoperability.

There are cases where a Calc function produces a result in accordance with international standards but the result differs from that produced by the equivalent Excel function. In such cases Calc often has a similarly named function but with a suitable modifier added to its name (such as "_ADD" or "_EXCEL2003") which provides the same result as the Excel function.

Understanding the structure of functions

All functions have a similar structure. If you use the right tool for entering a function, you can escape learning this structure, but it is still worth knowing for troubleshooting.

As a typical example, the structure of a function to find cells that match entered search criteria is:

= DCOUNT(Database, Database field, Search criteria)

A function cannot exist on its own; it must always be part of a formula. Consequently, even if the function represents the entire formula, there must be an = sign at the start of the formula. Regardless of where in the formula a function is, the function will start with its name, such as DCOUNT in the example above. After the name of the function comes its arguments. All arguments are required, unless specifically listed as optional.

Arguments are added within the parentheses and are separated by commas. A Calc function can take up to 255 arguments. An argument can be not only a number or a single cell, but also an array or range of cells that contain several or even hundreds of cells.

Depending on the nature of the function, arguments may be entered as follows:

"text data"  The quotes indicate text or string data is being entered.
9  The number nine is being entered as a number.
"9"  The number nine is being entered as text.
A1  The address for whatever is in Cell A1 is being entered.
B2:D9  The range of cells is being entered.

Nested functions

Functions can also be used as arguments within other functions. These are called nested functions.

=SUM(2,PRODUCT(5,7))

To get an idea of what nested functions can do, imagine that you are designing a self-directed learning module. During the module, students do three quizzes, and enter the results in cells A1, A2, and A3. In A4, you can create a nested formula that begins by averaging the results of the quizzes with the formula =AVERAGE(A1:A3). The formula then uses the IF function to give the student feedback that depends upon the average grade on the quizzes. The entire formula would read:

=IF(AVERAGE(A1:A3) >85, "Congratulations! You are ready to advance to the next module", "Failed. Please review the material again. If necessary, contact your instructor for help")

Depending on the average, the student would receive the message for either congratulations or failure.

Notice that the nested formula for the average does not require its own equal sign. The one at the start of the equation is enough for both formulas.

238 | Understanding functions
If you are new to spreadsheets, the best way to think of functions is as a scripting language. We have used simple examples to explain the concept more clearly, but, through nesting of functions, a Calc formula can quickly become complex.

**Note**

Calc keeps the syntax of a formula displayed in a tool tip next to the cell as a handy memory aid as you type.

**Using the Functions List deck**

A more reliable method is to use the Functions List deck on the Sidebar (Figure 221), accessed by selecting **View > Function List**.

The Functions List deck includes a brief description of each function and its arguments. Highlight the function and look at the bottom of the pane to see the description. If necessary, hover the cursor over the division between the list and the description; when the cursor becomes a two-headed arrow, drag it upwards to increase the space for the description. Double-click on a function’s name to add it to the current cell, together with placeholders for each of the function’s arguments.

Using the Functions List deck is almost as fast as manual entry, and has the advantage of not requiring that you memorize a formula that you want to use. In theory, it should also be less error-prone. In practice, though, some users may fumble when replacing the placeholders with values. Another feature is the ability to display the last formulas used.

**Using the Function Wizard**

The most commonly used input method is the Function Wizard (Figure 222). To open it, choose **Insert > Function**, or click the Function Wizard icon on the Formula Bar, or press Ctrl+F2. The Function Wizard provides the same help features as the Functions List deck, but adds fields in which you can see the result of a completed function, as well as the result of any larger formula of which it is part.
Select a category of functions to shorten the list, then scroll down through the named functions and select the required one by double-clicking on it. When you select a function its description appears on the right-hand side of the dialog. Optionally you can type the function name in the search box and the search narrows on each character inserted (Figure 222).

The wizard now displays an area to the right where you can enter data manually in text boxes or click the Shrink button to shrink the wizard so you can select cells from the sheet.

![Figure 222: Functions tab of Function Wizard]

To select cells, either click directly on the cell or hold down the left mouse button and drag to select the required area.

When the area has been selected, click the Expand button to return to the wizard again.

If multiple arguments are needed click in the next text box and repeat the selection process for the next cell or range of cells. Repeat this process as often as required. The wizard will accept up to 255 ranges or arguments in the SUM function.

Click OK to accept the function, add it to the cell, and get the result.
Caution

If you select a function by double-clicking it in the list, and then change your mind and select a different one by double-clicking again, then the second choice formula is added into the first choice formula in the Formula text box. You must clear the Formula text box and then double-click the function to add it to the box.

This additive facility allows you to create complex formulas by building them up in the Formula box.

You can also select the Structure tab to see a tree view of the parts of the formula. The main advantage over the Functions List deck is that each argument is entered in its own field, making it easier to manage. The price of this reliability is slower input, but precision is generally more important than speed when creating a spreadsheet.

The structure view of the wizard is important for debugging and fixing very long, nested, and complex formulas. In this view, the formula is parsed, and each formula component is calculated by a simpler function call or arithmetic operation and then combined following the rules of calculation. It is possible to visualize each parsed element of the formula and check if the intermediate results are correct, until the mistake is found.

Functions can be entered into the Input line. After you enter a function on the Input line, press the Enter key or click the Accept button on the Formula Bar to add the function to the cell and get its result.

If you see the formula in the cell instead of the result, then Formulas are selected for display in Tools > Options > LibreOffice Calc > View > Display. Deselect Formulas, and the result will display. However, you can still see the formula in the Input line.

Tip

The menu option View > Show Formula and the shortcut Ctrl+` (grave accent) also toggle formulas on / off.

Array formulas

What is an array formula?

A formula in which the individual values in a cell range are evaluated is referred to as an array formula. The difference between an array formula and other formulas is that the array formula deals with several values simultaneously instead of just one.

Not only can an array formula process several values, but it can also return several values. The results of an array formula is also an array.

When Calc updates the formulas, each affected cell is read and its formula is recalculated. If you have a thousand cells in a column with the same formula (the formula expression only changes the data to compute), you end with one thousand identical formulas to interpret and execute.
Array formulas will evaluate the formula once and execute calculations as many times as the size of the array, thus saving the time used to interpret each cell formula. And because Calc stores only one formula for the entire array of data cells, it also save space in the spreadsheet file.

![Array formula example](image)

**Figure 225:** Source array in yellow and resulting array in green. The array formula is shown in the formula bar.

To multiply the values in the individual cells by 10 in the above array (Figure 225), you do not need to apply a formula to each individual cell or value. Instead you just need to use a single array formula. Select a range of 3 x 5 cells on another part of the spreadsheet, enter the formula =10*A1:C5 and confirm this entry using the key combination Ctrl+Shift+Enter. The result is a 3 x 5 array in which the individual values in the cell range (A1:C5) are multiplied by a factor of 10.

In addition to multiplication, you can also use other operators on the reference range (an array). With Calc, you can add (+), subtract (-), multiply (*), divide (/), use exponents (^), concatenation (&) and comparisons (=, <>, <>, <=, >=). The operators can be used on each individual value in the cell range and return the result as an array if the array formula was entered.

Comparison operators in an array formula treat empty cells in the same way as in a normal formula, that is, either as zero or as an empty string. For example, if cells A1 and A2 are empty the array formulas \{=A1:A2=""\} and \{=A1:A2=0\} will both return a 1 column 2 row array of cells containing TRUE.

**When do you use array formulas?**

Use array formulas if you have to repeat calculations using different values. If you decide to change the calculation method later, you only have to update the array formula. To add an array formula, select the entire array range and then make the required change to the array formula.

Arrays are an essential tool for carrying out complex calculations, because you can have several cell ranges included in your calculations. Calc has different math functions for arrays, such as the MMULT function for multiplying two arrays.

**Creating array formulas**

If you create an array formula using the Function Wizard, you must mark the Array check box each time so that the results are returned in an array (Figure 222). Otherwise, only the value in the upper-left cell of the array being calculated is returned.

If you enter the array formula directly into the cell, you must use the key combination Shift+Ctrl+Enter instead of the Enter key. Only then does the formula become an array formula.

**Note**

Array formulas appear in braces (curly brackets) in Calc. You cannot create array formulas by manually entering the braces.

**Warning**

The cells in a results array are automatically protected against changes. However, you can edit or copy the array formula by selecting the entire array cell range.
Strategies for creating formulas and functions

Formulas that do more than a simple calculation or summation of rows or columns of values usually take a number of arguments. For example, consider the following equation:

\[ x = x_i + v_i t + \frac{1}{2} a t^2 \]

This equation models the position of an object undergoing linear, translational motion, with constant acceleration. The position \( x \) depends on time \( t \), and the equation also contains constant values for initial position \( x_i \), initial velocity \( v_i \), and acceleration \( a \).

For ease of presentation, it is good practice to set up a spreadsheet in a manner similar to that shown in Figure 226. In this example, the individual variables are input into cells on the sheet and no editing of the formula (in cell B9) is required.

You can take several broad approaches when creating a formula. In deciding which approach to take, consider how many other people will need to use the sheets, the life of the sheets, and the variations that could be encountered in use of the formula.

If people other than yourself will use the spreadsheet, make sure that it is easy to see what input is required and where. Explanation of the purpose of the spreadsheet, basis of calculation, input required and output generated are often placed on the first sheet.

A spreadsheet that you build today, with many complicated formulas, may not be quite so obvious in its function and operation in 6 or 12 months. Use comments and notes liberally to document your work.

You might be aware that you cannot use negative values or zero values for a particular argument, but if someone else inputs such a value, will your formula be robust or simply return a standard (and often not too helpful) Error message? It is a good idea to trap errors using some form of logic statements or with conditional formatting.

You might be aware that you cannot use negative values or zero values for a particular argument, but if someone else inputs such a value, will your formula be robust or simply return a standard (and often not too helpful) Error message? It is a good idea to trap errors using some form of logic statements or with conditional formatting.

Place a unique formula in each cell

The most basic strategy is to view whatever formulas are needed as simple and with a limited useful life. The strategy is then to place a unique formula in each appropriate cell. This can be recommended only for very simple or “throw away” (single use) spreadsheets.

Break formulas into parts and combine the parts

The second strategy is similar to the first, but instead you break down longer formulas into smaller parts and then combine the parts into the whole. Many examples of this type exist in complex scientific and engineering calculations where interim results are used in a number of places in the sheet. The result of calculating the flow velocity of water in a pipe may be used in estimating losses.
due to friction, whether the pipe is flowing full or partially empty, and in optimizing the diameter for the given flow regime.

In all cases you should adopt the basic principles of formula creation described previously.

**Speeding up calculations**

Spreadsheets are often used to process raw data and produce meaningful summaries, consolidation and display of information for the decision maker or to be used as the source for reports. The raw data can be produced by physical measurements, business transactions, or various other means. Sheets with thousands or even hundreds of thousands of rows and several columns are frequently found in finance departments or laboratories. Computations carried out on these raw data sets can be time consuming and last for minutes, hours and perhaps, days.

A common mistake is to insert formulas for each cell and perform thousands of formulas interpretation and calculations. Here are some recommendation for speeding up calculations.

**Use array formulas on massive data**

Array formulas have one formula applied to the mass of data. Computation saving can be significant for large data sets.

**Use consolidation functions**

Consolidation functions perform calculations on data sets. SUM, SUMIF, SUMIFS, SUMPRODUCT are examples of consolidation functions. For example if you have a very long bill of materials, where quantity must be multiplied by unit price and then totaled to produce a cost figure, then instead of applying a formula on each entry of the BOM and then summing, you can use the formula SUMPRODUCT(quantity, unitprice), where quantity and unitprice are named ranges representing the BOM. SUMPRODUCT multiplies each cell of the quantity data set by its corresponding cell of unitprice and sums all the products.

Similar situations happen when you must sum a subset of the original data set, where you must apply a test on each entry to allow it to be part of the sum. For example, when the value is strictly positive. Use SUMIF(data_to_test;">0";data_to_sum), where data_to_test is the data set where you test the positive values, data_to_sum is the column where the values are to sum depending on the test, and "">0" is the test itself.

Other consolidation functions are AVERAGEIF, COUNTIF, MINIFS, MAXIFS, and more.

**Use macros to create functions**

Another strategy is to create your own functions and macros. This approach would be used where the result would greatly simplify the use of the spreadsheet by the end user and keep the formulas simple with a better chance of avoiding errors. This approach also can make the maintenance easier by having corrections or updates kept in one central location. The use of macros is described in Chapter 12, Macros, of this book and is a specialized topic in itself. The danger of overusing macros and custom functions is that the principles upon which the spreadsheet is based become much more difficult to see by a user other than the original author (and sometimes even by the author!).

**Multi-threading**

Many modern computers have multi-core processors and provide for multiple threads. A core is a physical hardware component within a CPU. Threads are virtual components that help to efficiently manage the workload and tasks of the CPU. A CPU can interact with more than one thread at a time and multi-threading makes CPUs more efficient, to give better overall performance.

Calc supports multi-threading to help your spreadsheets take advantage of whatever parallel processing is available within your computer. This facility is controlled by the Enable multi-
threaded calculation option in the CPU threading settings section of the Tools > Options > LibreOffice Calc > Calculate dialog. The initial default for this option to be enabled, and we do not recommend disabling it. This is the only control in the Calc user interface that relates to multi-threading; once initiated, the processing operates automatically.

If multi-threading is enabled, Calc automatically identifies where your spreadsheet could benefit from multi-threading and processes it accordingly. Threads are generally used for formula groups, where enough adjacent cells in a column use the same formula but get different results because of relative cell addressing. One implication of this approach is that the optimization is column-based and so a row-based layout could be less efficient.

There are other ways to control Calc’s multi-threading capability, such as adjusting the MAX_CONCURRENCY LibreOffice specific environment variable. However, these methods are beyond the scope of this document.

Finding and fixing errors

It is common to find situations where errors are displayed. Even with all the tools available in Calc to help you to enter formulas, making mistakes is easy. Many people find inputting numbers difficult and many may make a mistake about the kind of entry that a function’s argument needs. In addition to correcting errors, you may want to find the cells used in a formula to change their values or to check the answer.

Calc provides three tools for investigating formulas and the cells that they reference: error messages, color coding for input, and the Detective.

Error messages

The most basic tool is error messages. Error messages display in a formula’s cell or in the Function Wizard instead of the result.

An error message for a formula is usually a three-digit number from 501 to 532, or sometimes an unhelpful piece of text such as #NAME?, #REF!, or #VALUE!. The error message appears in the cell, and a brief explanation of the error is shown on the right side of the Status bar.

Most error messages indicate a problem with how the formula was input, although several indicate that you have run up against a limitation of either Calc or its current settings.

Error messages are not user-friendly, and may intimidate new users. However, they are valuable clues to correcting mistakes. You can find detailed explanations of them in Appendix B, Error Codes, and in the Help, by searching for “error codes” in Calc. A few of the most common are shown in Table 7.

Table 7: Common error messages

<table>
<thead>
<tr>
<th>Code</th>
<th>Meaning</th>
</tr>
</thead>
<tbody>
<tr>
<td>#REF!</td>
<td>Instead of displaying Err:524. The column, row, or sheet for the referenced cell is missing.</td>
</tr>
<tr>
<td>#VALUE!</td>
<td>Instead of displaying Err:519. The value for one of the arguments is not the type that the argument requires. The value may be entered incorrectly; for example, double-quotation marks may be missing around the value. At other times, a cell or range used may have the wrong format, such as text instead of numbers.</td>
</tr>
<tr>
<td>#DIV/0!</td>
<td>Instead of displaying Err:532. Division by zero.</td>
</tr>
<tr>
<td>#NUM!</td>
<td>Instead of displaying Err:503. A calculation results in an overflow of the defined value range.</td>
</tr>
<tr>
<td>509</td>
<td>An operator such as an equals sign is missing from the formula.</td>
</tr>
<tr>
<td>Code</td>
<td>Meaning</td>
</tr>
<tr>
<td>------</td>
<td>---------</td>
</tr>
<tr>
<td>510</td>
<td>A variable is missing from the formula.</td>
</tr>
</tbody>
</table>

### Examples of common errors

#### #DIV/0! division by zero

This error is the result of dividing a number by either the number zero (0) or a blank cell. There is an easy way to avoid this type of problem. When you have a zero or blank cell displayed, use a conditional function. Figure 227 depicts division of column B by column C yielding 2 errors arising from a zero and a blank cell showing in column C.

![Figure 227: Examples of #DIV/0!, division by zero error](image)

It is very common to find an error such as this arising from a situation where data was not reported or reported incorrectly. When such an occurrence is possible, an IF function can be used to display the data correctly. The formula =IF(C3>0, B3/C3, "No Report") can be entered. The formula is then copied over the remainder of column D. The meaning of this formula roughly would be: “If C3 is greater than 0, then compute B3 divided by C3, otherwise enter ‘No Report’.”

It is also possible for the last parameter to use double quotes for a blank (no value) to be entered, or a different formula with a standardized number being substituted for the lower number. An example is shown in Figure 228.

![Figure 228: Division by zero solution](image)

#### #VALUE! no result and #REF! incorrect references

The #VALUE! error is also very common.

A common occurrence of this error arises when a cell contains an incorrect value type. In the example of Figure 229, text “None” has been entered in C8, where our formula in column D is expecting a number.
The #REF! error is caused by a missing reference. In the example below, the formula references a sheet that has been deleted.

**Color coding for input**

Another useful tool when reviewing a formula is the color coding for input. When you select a formula that has already been entered, the cells or ranges used for each argument in the formula are outlined in color.

Calc uses eight colors for outlining referenced cells, starting with blue for the first cell, and continuing with red, magenta, green, dark blue, brown, purple, and yellow before cycling through the sequence again.

**Value highlighting**

There are situations where the display of cell contents is the same when the data type is different. For example a text contents and a numeric contents can look the same but can produce a mistake if both are used in some calculations. To illustrate, the string “10.35” right-aligned in a cell can be confused with the value 10.35. When the cell is used in a formula the string may take the value of zero and an error may be produced.

If you enable value highlighting (View > Value Highlighting or Ctrl+F8), Calc distinguishes the text and numeric data types by assigning different colors to the content's characters. By default, the text contents is in black characters and the numeric contents is in blue. See Chapter 2, Entering, Editing, and Formatting Data, for more information on value highlighting.

**The Detective**

In a long or complicated spreadsheet, color coding becomes less useful. In these cases, consider using the submenu under Tools > Detective. The Detective is a tool for checking which cells are used as arguments by a formula (precedents) and which other formulas it is nested in (dependents), and tracking errors. It can also be used for tracing errors, marking invalid data (that
is, information in cells that is not in the proper format for a function's argument), or even for removing precedents and dependents.

To use the Detective, select a cell with a formula, then select the required option from the Tools > Detective menu. On the spreadsheet, you will see lines ending in dots to indicate precedents, and lines ending in arrows for dependents. The lines show the flow of information.

Use the Detective to assist in following the precedents referred to in a formula in a cell. By tracing these precedents, you frequently can find the source of the errors. Place the cursor in the cell in question and then choose Tools > Detective > Trace Precedents from the Menu bar or press Shift+F9. Figure 231 shows a simple example of tracing precedents for cell B4.

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 Capital</td>
<td>$200,000</td>
</tr>
<tr>
<td>2 Years</td>
<td>1</td>
</tr>
<tr>
<td>3 Interest rate</td>
<td>7.5%</td>
</tr>
<tr>
<td>4 Annual return</td>
<td>$15,000</td>
</tr>
</tbody>
</table>

*Figure 231: Tracing precedents using the Detective*

This allows us to check the source cells (which may be a range) for any errors which have caused us to query the calculation result. If a source is a range, then that range is highlighted in blue.

In other instances we may have to trace an error. For this we use the Trace Error function, found under Tools > Detective > Trace Error, to find the cells that caused the error.

For more information search for “Detective” in the Help system's index.

**Examples of functions**

For novices, functions are one of the most intimidating features of LibreOffice Calc. New users quickly learn that functions are an important feature of spreadsheets, but there are hundreds, and many require input that assumes specialized knowledge. Fortunately, Calc includes dozens of functions that anyone can use.

**Basic arithmetic and statistics**

The most basic functions create formulas for basic arithmetic or for evaluating numbers in a range of cells.

**Basic arithmetic**

The simple arithmetic functions are addition, subtraction, multiplication, and division. Except for subtraction, each of these operations has its own function:

- SUM for addition
- PRODUCT for multiplication
- QUOTIENT for division

Traditionally, subtraction does not have a function.

SUM, PRODUCT, and QUOTIENT are useful for entering ranges of cells in the same way as any other function, with arguments in brackets after the function name.

However, for basic equations, many users prefer the time-honored computer symbols for these operations, using the plus sign (+) for addition, the hyphen (−) for subtraction, the asterisk (*) for multiplication and the forward slash (/) for division. These symbols are quick to enter without requiring your hands to stray from the keyboard.
A similar choice is also available if you want to raise a number by the power of another. Instead of entering =POWER(A1,2), you can enter =A1^2.

Moreover, they have the advantage that you enter formulas with them in an order that more closely approximates human readable format than the spreadsheet-readable format used by the equivalent function. For instance, instead of entering =SUM (A1:A2), or possibly =SUM (A1,A2), you enter =A1+A2. This almost-human readable format is especially useful for compound operations, where writing =A1*(A2+A3) is briefer and easier to read than =PRODUCT(A1,SUM(A2:A3)).

The main disadvantage of using arithmetical operators is that you cannot directly use a range of cells. In other words, to enter the equivalent of =SUM (A1:A3), you would need to type =A1+A2+A3.

Otherwise, whether you use a function or an operator is largely up to you—except, of course, when you are subtracting. However, if you use spreadsheets regularly in a group setting such as a class or an office, you might want to standardize on an entry format so that everyone who handles a spreadsheet becomes accustomed to a standard input.

**Simple statistics**

Another common use for spreadsheet functions is to pull useful information out of a list, such as a series of test scores in a class, or a summary of earnings per quarter for a company.

You can, of course, scan a list of figures if you want basic information such as the highest or lowest entry or the average. The only trouble is, the longer the list, the more time you waste and the more likely you are to miss what you are looking for. Instead, it is usually quicker and more efficient to enter a function. Such reasons explain the existence of a function like COUNT, which does no more than give the total number of entries in the designated cell range.

Similarly, to find the highest or lowest entry, you can use MIN or MAX. For each of these formulas, all arguments are either a range of cells, or a series of cells entered individually.

Each also has a related function, MINA or MAXA, which performs the same function, but also treats a cell formatted for text as having a value of 0. (The same treatment of text occurs in any variation of another function that adds an "A" to the end.) Either function gives the same result, and could be useful if you used a text notation to indicate, for example, if any students were absent when a test was written, and you wanted to check whether to schedule a makeup exam.

For more flexibility in similar operations, you could use LARGE or SMALL, both of which add a specialized argument of rank. If the rank is 1 used with LARGE, you get the same result as you would with MAX. However, if the rank is 2, then the result is the second largest result. Similarly, a rank of 2 used with SMALL gives you the second smallest number. Both LARGE and SMALL are handy as a permanent control, since, by changing the rank argument, you can quickly scan multiple results.

You would need to be an expert to want to find the Poisson distribution of a sample, or to find the skew or negative binomial of a distribution (and, if you are, you will find functions in Calc for such things). However, for the rest of us, there are simpler statistical functions that you can quickly learn to use.

In particular, if you need an average, you have a number of functions to choose from. You can find the arithmetical mean—that is, the result when you add all entries in a list then divided by the number of entries, by entering a range of numbers when using AVERAGE, or AVERAGE A to include text entries and to give them a value of zero.

In addition, you can get other information about the data set:

- **MEDIAN**: Logically ranks the numbers (lowest to highest) to evaluate the median value. In a set containing an uneven number of values, the median will be the number in the middle
of the ranked list. In a set containing an even number of values, the median will be the mean of the two values in the middle of the ranked list.

- **MODE:** The most common entry in a list of numbers.
- **QUARTILE:** The entry at a set position in the array of numbers. Besides the cell range, you enter the type of quartile: 0 for the lowest entry, 1 for the value of 25%, 2 for the value of 50%, 3 for 75%, and 4 for the highest entry. Note that the result for types 1 through 3 may not represent an actual item entered.
- **RANK:** The position of a given entry in the entire list, measured either from top to bottom or bottom to top. You need to enter the cell address for the entry, the range of entries, and the type of rank (0 for the rank from the highest, or 1 for the rank from the bottom).

Some of these functions overlap; for example, MIN and MAX are both covered by QUARTILE. In other cases, a custom sort or filter might give much the same result. Which you use depends on your temperament and your needs. Some might prefer to use MIN and MAX because they are easy to remember, while others might prefer QUARTILE because it is more versatile.

**Using these functions**

In some cases, you may be able to get similar results to some of these functions by setting up a filter or a custom sort. However, in general, functions are more easily adjusted than filters or sorts, and provide a wide range of possibilities.

At times, you may just want to enter one or more formulas temporarily in a convenient blank cell, and delete it once you have finished. However, if you find yourself using the same functions constantly, you should consider creating a template and including space for all the functions you use, with the cell to their left used as a label for them. Once you have created the template, you can easily update each formula as entries change, either automatically and on-the-fly or pressing the F9 key to update all selected cells.

No matter how you use these functions, you will probably find them simple to use and adaptable for many purposes. By the time you have mastered this handful, you will be ready to try more complex functions.

**Rounding off numbers**

For statistical and mathematical purposes, Calc includes a variety of ways to round off numbers. If you are a programmer, you may also be familiar with some of these methods. However, you do not need to be a specialist to find some of these methods useful. You may want to round off for billing purposes, or because decimal places do not translate well into the physical world—for instance, if the parts you need come in packages of 100, then the fact you only need 66 is irrelevant to you; you need to round up for ordering. By learning the options for rounding up or down, you can make your spreadsheets more immediately useful.

When you use a rounding function, you have two choices about how to set up your formulas. If you choose, you can nest a calculation within one of the rounding functions. For instance, the formula =ROUND((SUM(A1,A2)) adds the figures in cells A1 and A2, then rounds them off to the nearest whole number. However, even though you do not need to work with exact figures every day, you may still want to refer to them occasionally. If that is the case, then you are probably better off separating the two functions, placing =SUM(A1,A2) in cell A3, and =ROUND (A3) in A4, and clearly labeling each function.

For details on rounding methods, see the Help.

**Using wildcards and regular expressions in functions**

In computing, a *wildcard* refers to a character that can be substituted for zero or more characters in a string. Wildcards are commonly used in computer programming, search queries, and when navigating through directories using the command prompt. Wildcards are typically either an
asterisk (*), which represents one or more characters, or a question mark (?), which represents a single character.

A regular expression (regex or regexp) is a sequence of characters that define a search pattern. Usually this pattern is then used by string searching algorithms for “find” or “find and replace” operations on strings. Regular expressions are more powerful than wildcards for text extraction or replacement.

Calc uses wildcards or regular expressions to search in text arguments of many of its functions. Regular expressions are defined by the ICU project.

**Note**

Regular expressions and wildcards are mutually exclusive; that is, only one can have the value TRUE. Internally, if both are true then wildcards take precedence over regular expressions.

A number of functions in Calc allow the use of wildcards or regular expressions and these include: REGEX, SUMIF, COUNTIF, MATCH, SEARCH, LOOKUP, HLOOKUP, VLOOKUP, DCOUNT, DCOUNTA, DSUM, DPROMUL, DMAX, DMIN, DAVRG, DSTDEV, DSTDEVP, DVAR, DVARP, DGET.

Whether or not wildcards and regular expressions are used is selected on the **Tools > Options > LibreOffice Calc > Calculate** dialog (Figure 232). Wildcards are enabled in a default installation.

For example =COUNTIF(A1:A6,"r.d") with Enable regular expressions in formulas selected will count cells in A1:A6 which contain red and ROD (see Figure 233).

Additionally if Search criteria = and <> must apply to whole cells is not selected, then Fred, bride, and Ridge will also be counted. If that setting is selected, then it can be overcome by wrapping the expression thus: =COUNTIF(A1:A6,".*r.d.*").

Regular expression searches within functions are always case insensitive, irrespective of the setting of the Case sensitive checkbox on the dialog in Figure 232—so red and ROD will always be matched in the above example. This case-insensitivity also applies to the regular expression structures ([[:lower:]]) and ([[:upper:]]), which match characters irrespective of case.

Regular expressions will not work in simple comparisons. For example: A1="r.d" will always return FALSE if A1 contains red, even if regular expressions are enabled. It will only return TRUE if A1 contains r.d (r then a dot then d). If you wish to test using regular expressions, try the COUNTIF function: COUNTIF(A1,″.r.d.″) will return 1 or 0, interpreted as TRUE or FALSE in formulas like =IF(COUNTIF(A1,″.r.d.″),″hooray″,″boo″).

Activating the Enable regular expressions in formulas option means all the above functions will require any regular expression special characters (such as parentheses) used in strings within formulas, to be preceded by a backslash, despite not being part of a regular expression. These backslashes will need to be removed if the setting is later deactivated.

---

1  [http://userguide.icu-project.org/strings/regexp](http://userguide.icu-project.org/strings/regexp)
Advanced functions

As is common with other spreadsheet programs, Calc can be enhanced by user-defined functions or add-ins. Setting up user-defined functions can be done either by using macros or by writing separate add-ins or extensions.

The basics of writing and running macros is covered in Chapter 12, Macros. Macros can be linked to menus or toolbars for ease of operation or stored in template modules to make the functions available in other documents. Calc macros can be written in Basic, BeanShell, JavaScript, or Python.

Calc Add-ins are specialized office extensions which can extend the functionality of LibreOffice with new built-in Calc functions. A number of extensions for Calc have been written; these can be found on the extensions site at https://extensions.libreoffice.org/. Refer to Chapter 14, Setting Up and Customizing, for more details.
Chapter 8
Using Pivot Tables
Introduction

Many requests for spreadsheet support are the result of using complicated formulas and solutions to solve simple day-to-day problems. For more efficient and effective solutions, use the pivot table, a tool for combining, comparing, and analyzing large amounts of data easily. Using pivot tables, you can view different summaries of the source data, display the details of areas of interest, and create reports, whether you are a beginner, an intermediate user, or an advanced user. In addition you can create a pivot chart to view a graphical representation of the data in a pivot table.

Database preconditions

To work with a pivot table, you need a list of raw data, similar to a database table, consisting of rows (data sets) and columns (data fields). The field names are in the first row above the list.

The data source could be an external file or database. For the simplest case, where data is contained in a Calc spreadsheet, Calc offers sorting functions that do not require the pivot table.

For processing data in lists, Calc needs to know where in the spreadsheet the list is. The list can be anywhere in the sheet, in any position. A spreadsheet can contain several unrelated lists.

Calc recognizes your lists automatically. It uses the following logic: Starting from the cell you have selected (which must be within the list), Calc checks the surrounding cells in all four directions (left, right, above, below). The border is recognized if the program discovers an empty row or column, or if it hits the left or upper border of the spreadsheet. This means that the described functions can only work correctly if there are no empty rows or columns in the list. Avoid empty lines (for example for formatting). You can format the list by using cell formats.

Tip

For sorting, filtering, or using the pivot table, always select only one cell to allow Calc to determine the scope of the list.

A relatively common source of errors is to inadvertently declare a list by mistake and then to sort that list. If you select multiple cells—for example, a whole column—then the sorting mixes up the data that should be together in one row.

In addition to these formal aspects, the logical structure of the list is also very important.

Note

Calc lists must have the normal form; that is, they must have a simple linear structure.

When entering the data, do not add outlines, groups, or summaries. Here are some mistakes commonly made by inexperienced spreadsheet users:

- You made several unnecessary sheets; for example, a sheet for each group of articles. In this case, analyses are then possible only within each group.
- In a Sales list, instead of only one column for the amount, you made a column for the amounts for each employee. In this case, the system will have difficulty grouping data from
the various columns together. Thus, an analysis with the pivot table would no longer be possible. All data must be entered into the same column for the pivot table to be able to analyze it.

- You entered the amounts in chronological order. At the end of each month, you made a sum total. In this case, sorting the list for different criteria is not possible because the pivot table will treat the sum totals the same as any other value. Getting monthly results is one of the very fast and easy features of the pivot table.

Data sources

The possible data sources for the pivot table are a Calc spreadsheet or an external data source that is registered in LibreOffice.

Calc spreadsheet

Analyzing a list in a Calc spreadsheet is the simplest and most often used case. Lists might be updated regularly or the data might be imported from a different application.

The list data might be entered directly into the spreadsheet or copied from another file or application. You can also use a Web Page Query input filter to insert data from a HTML file, a CSV file, a Calc spreadsheet, or a Microsoft Excel spreadsheet. See Chapter 10, Linking Data, for more information.

The behavior of Calc while inserting data from a different application depends on the format of the data. If the data is in a common spreadsheet format, it is copied directly into Calc. However, if the data is in plain text format, the Text Import dialog appears after you select the file containing the data; see Chapter 1, Introduction, for more information about this dialog.

Registered data source

A registered data source is a connection to data held in a database outside of LibreOffice. When using a registered data source, the data to be analyzed will not be saved in Calc; Calc always uses the data from the original source. Calc is able to use many different data sources in addition to databases that are created and maintained with LibreOffice Base. For more information, see Chapter 10, Linking Data.

Using shortcuts

If you use pivot tables often in Calc, you might find the frequent use of the built-in menu paths inconvenient.

In some cases built-in keyboard shortcuts are already defined; see Appendix A, Keyboard Shortcuts. An example is the F12 function key, which groups a selected data range. In some other cases, the built-in toolbars already provide relevant icons. An example is the Insert or Edit Pivot Table icon on the Standard toolbar.

In addition to using the built-in keyboard shortcuts and toolbar icons, you can also define your own. See Chapter 14, Setting Up and Customizing, for instructions.

Creating a pivot table

If you want Calc to automatically determine the full extent of the raw data list, then select a single cell within this list. If you want to explicitly define the extent of the raw data list then select all relevant cells.

Create the pivot table by selecting Data > Pivot Table > Insert or Edit from the Menu bar, selecting Insert > Pivot Table from the Menu bar, or clicking the Insert or Edit Pivot Table icon in the Standard toolbar.
Calc displays the Select Source dialog (Figure 234), where you can choose between using the selected data cells, a range of cells that has already been named, or a data source that has already been registered with LibreOffice.

**Note**

See Chapter 13, Calc as a Simple Database, for more information about named ranges. See Chapter 10, Linking Data, for more information about linking to registered data sources.

![Select Source dialog](image)

Click **OK** on the Select Source dialog to display the Pivot Table Layout dialog, which is described in the next section.

### The Pivot Table Layout dialog

The function of the pivot table is managed in two places: first, in the Pivot Table Layout dialog; and second, through manipulations of the result in the spreadsheet. This section describes the Pivot Table Layout dialog in detail.

**Tip**

To access the Pivot Table Layout dialog again after initial creation of the pivot table, right-click in the results area of the pivot table and select the **Properties** option from the context menu. Alternatively, left-click in the results area and select the **Insert or Edit Pivot Table** icon in the Standard toolbar, or select **Data > Pivot Table > Insert or Edit**.
Basic layout

In the Pivot Table Layout dialog (Figure 235) are four areas that show the layout of the resulting pivot table:

- **Filters**
- **Column Fields**
- **Row Fields**
- **Data Fields**

Beside these four areas is another area labeled *Available Fields* that contains the names of the fields in the source data list. To choose a layout, drag and drop the fields from the *Available Fields* area to the other four areas.

The *Data Fields* area must contain at least one field. Advanced users can use more than one field here. For the fields in the *Data Fields* area, an aggregate function is used. For example, if you move the *Sales Value* field into the *Data Fields* area, it initially appears there as **Sum – Sales Value**.

![Figure 235: Pivot Table Layout dialog](image)

*Figure 235: Pivot Table Layout dialog*
Row and column fields indicate from which groups the result will be sorted. Often more than one field is used at a time to get partial sums for rows or columns. The order of the fields gives the order of the sums from overall to specific.

For example, if you drag Region and Employee into the Row Fields area, the sum will be divided into the regions. Within the regions will be the listing for the different employees (Figure 236).

Fields that are placed into the Filters area appear at the top of the resulting pivot table as a drop-down list. The summary in the result takes into account only that part of the base data that you have selected. For example, if you include Employee in the Filters area, you can filter the result shown for each employee.

To move a field from an area, just drag it to a new area. To remove a field from the Filters, Column Fields, Row Fields, or Data Fields areas, drag it to the Available Fields area.

**Tip**

To rapidly move a selected field from one area of the Pivot Table Layout dialog to another, press the Alt+letter on the keyboard that corresponds to the underlined letter in the target area’s label.

**More options**

To expand the Pivot Table Layout dialog and show more options, click the plus signs adjacent to the Options and Source and Destination labels (Figure 237).

**Ignore empty rows**

If the source data is not in the recommended form, this option tells the pivot table to ignore empty rows.
Identify categories

With this option selected, if the source data has missing entries in a list and does not meet the recommended data structure (as in Figure 238 for example), the pivot table adds it to the listed category above it. If this option is not chosen, then the pivot table inserts (empty) (Figure 240).

![Figure 238: Example of data with missing entries in Column A](image)

The option **Identify categories** ensures that in this example rows 3 and 4 are included for Apples and that row 6 is included for Pears (Figure 239).

![Figure 239: Pivot table result with Identify categories selected](image)

Without category recognition, the pivot table shows an (empty) category (Figure 240).

![Figure 240: Pivot table result without Identify categories selected](image)
Logically, the behavior with category recognition is better. A list showing missing entries is also less useful, because you cannot use functions such as sorting or filtering.

**Total columns, Total rows**
With these options you can decide if the pivot table shows an extra row with the sums of each column, or if it adds on the very right a column with the sums of each row. In some cases, an added total sum is meaningless, for example if the entries are accumulated or the result of comparisons.

**Add filter**
Use this option to add or hide the cell labeled **Filter** above the pivot table results. This conveniently provides additional filtering options within the pivot table. For more information, see “Filtering” on page 277.

---

**Note**
The filtering provided through the **Add filter** option is independent of the filtering provided by including fields in the **Filters** area of the Pivot Table Layout dialog.

---

**Enable drill to details**
With this option enabled, if you double-click on a single data cell in the pivot table result, including a cell produced from **Total columns** or **Total rows**, a new sheet opens giving a detailed listing of the individual entry. If you double-click on a cell in either a row or column field area, then the Show Detail dialog opens (Figure 272). If this function is disabled, the double-click will keep its usual edit function within a spreadsheet. For more information, see “Drilling (showing details)” on page 276.

**Source**
The **Selection** field in this area shows the sheet name and the range of cells containing the raw data for the pivot table. If the source spreadsheet contains any named ranges, these can be selected through the **Named range** option.

**Destination**
The controls in this area define where the result will be shown.

Selecting **New sheet** adds a new sheet to the spreadsheet file and places the results there. The new sheet is named using the format **Pivot Table_sheetname_X**; where X is the number of the table created, 1 for first, 2 for second, and so on. For a sheet named Sales List, the new sheet for the first pivot table produced would be named **Pivot Table_Sales List_1**. Each new sheet is inserted next to the source sheet.

If the target spreadsheet contains any named ranges, these can be selected with the **Named range** option.

The **Selection** field in this area shows the sheet name and the range of cells for the pivot table’s results.

---

**Tip**
To display the pivot table on the same sheet as the raw data, check the **Selection** option in the **Destination** area, click in the **Selection** field, click the **Shrink** button to the right of the **Selection** field, click at an appropriate cell in an empty area of the sheet, click the **Expand** button, and click **OK** on the Pivot Table Layout dialog.

---

**More settings for the fields: Field options**
The options discussed in the previous section are valid for the pivot table in general. You can also change settings for any field that is currently included in the pivot table layout (that is, fields within the **Filters**, **Column Fields**, **Row Fields**, and **Data Fields** areas). Change a field’s settings by
double-clicking that field within the Filters, Column Fields, Row Fields, or Data Fields areas of the Pivot Table Layout dialog. Double-clicking a field within the Available Fields area has no effect. The options available for fields in the Data Fields area differ from those for fields in the other three areas.

**Options for data fields**

Double-click a field in the Data Fields area of the Pivot Table Layout dialog to access the Data Field dialog shown in Figure 241.

In the Data Field dialog, you can select the function to be used to accumulate the values from the data source. While you often use the Sum function, other functions (like standard deviation or a counting function) are also available. For example, the counting function can be useful for non-numerical data fields.

Select the **Show items without data** option to include empty columns and rows in the results table.

Click the expansion symbol (plus sign or triangle) to expand the Displayed value section of the dialog.

![Data Field dialog](image)

*Figure 241: Expanded dialog for a data field*

In the Displayed value section, you can choose other possibilities for analysis using the aggregate function. Depending on the setting for Type, you may have to choose definitions for Base field and Base item.

---

More settings for the fields: Field options | 261
The table below lists the possible types of displayed value and associated base field and base item, together with a note on usage.

<table>
<thead>
<tr>
<th>Type</th>
<th>Base field</th>
<th>Base item</th>
<th>Analysis</th>
</tr>
</thead>
<tbody>
<tr>
<td>Normal</td>
<td>—</td>
<td>—</td>
<td>Simple use of the chosen aggregate function (for example, Sum).</td>
</tr>
<tr>
<td>Difference from</td>
<td>Selection of a field from the data source of the pivot table (for example, Employee).</td>
<td>Selection of an element from the selected base field (for example, Brigitte)</td>
<td>The result is the difference between the result of the base field and the base item (for example, sales volume of the other employees against the sales volume of Brigitte; see Figure 243). If previous item or next item is specified as the Base item, the reference value is the result for the next visible member of the base field, in the base field’s sort order.</td>
</tr>
<tr>
<td>% of</td>
<td>Selection of a field from the data source of the pivot table (for example, Employee)</td>
<td>Selection of an element from the selected base field (for example, Brigitte)</td>
<td>The result is a percentage ratio of the value of the base field to the base item (for example, sales result of the other employees relative to the sales result of Brigitte; see Figure 244). If previous item or next item is specified as the Base item, the reference value is the result for the next visible member of the base field, in the base field’s sort order.</td>
</tr>
<tr>
<td>% difference from</td>
<td>Selection of a field from the data source of the pivot table (for example, Employee)</td>
<td>Selection of an element from the selected base field (for example, Brigitte)</td>
<td>From each result, its reference value is subtracted, and the difference is divided by the reference value (for example, sales of the other employees as relative difference from the sales of Brigitte; see Figure 245). If previous item or next item is specified as the Base item, the reference value is the result for the next visible member of the base field, in the base field’s sort order.</td>
</tr>
</tbody>
</table>

![Figure 242: Example choices for Base field and Base item](image-url)
<table>
<thead>
<tr>
<th>Type</th>
<th>Base field</th>
<th>Base item</th>
<th>Analysis</th>
</tr>
</thead>
<tbody>
<tr>
<td>Running total in</td>
<td>Selection of a field from the data source of the pivot table (for example, Date)</td>
<td>—</td>
<td>Each result is added to the sum of the results for preceding items in the base field, in the base field’s sort order, and the total sum is shown. Results are always summed, even if a different summary function was used to get each result.</td>
</tr>
<tr>
<td>% of row</td>
<td>—</td>
<td>—</td>
<td>The result is a percentage of the value of the whole row (for example, the row sum).</td>
</tr>
<tr>
<td>% of column</td>
<td>—</td>
<td>—</td>
<td>The result is a percentage of the total column value (for example, the column sum).</td>
</tr>
<tr>
<td>% of total</td>
<td>—</td>
<td>—</td>
<td>The result is a percentage of the overall result (for example, the total sum).</td>
</tr>
<tr>
<td>Index</td>
<td>—</td>
<td>—</td>
<td>(Default result x total result) / (row total x column total)</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Sum - Sales Value</th>
<th>Data</th>
<th>Brigitte</th>
<th>Fritz</th>
<th>Hans</th>
<th>Kurt</th>
<th>Ute</th>
</tr>
</thead>
<tbody>
<tr>
<td>Category</td>
<td>Golf</td>
<td>$26,961</td>
<td>$46,839</td>
<td>$17,941</td>
<td>$28,346</td>
<td>$36,127</td>
</tr>
<tr>
<td></td>
<td>Sailing</td>
<td>$24,422</td>
<td>$19,976</td>
<td>$14,060</td>
<td>$20,814</td>
<td>$30,580</td>
</tr>
<tr>
<td></td>
<td>Tennis</td>
<td>$17,721</td>
<td>$38,638</td>
<td>$30,467</td>
<td>$27,675</td>
<td>$28,198</td>
</tr>
<tr>
<td></td>
<td>Total Result</td>
<td>$69,104</td>
<td>$105,453</td>
<td>$62,468</td>
<td>$76,835</td>
<td>$94,905</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Sum - Sales Value</th>
<th>Data</th>
<th>Brigitte</th>
<th>Fritz</th>
<th>Hans</th>
<th>Kurt</th>
<th>Ute</th>
</tr>
</thead>
<tbody>
<tr>
<td>Category</td>
<td>Golf</td>
<td>$19,878</td>
<td>-9,020</td>
<td>$1,385</td>
<td>$9,166</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Sailing</td>
<td>-4.446</td>
<td>-10,362</td>
<td>-3,608</td>
<td>$6,168</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Tennis</td>
<td>$20,917</td>
<td>$12,746</td>
<td>$9,954</td>
<td>$10,477</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Total Result</td>
<td>$36,349</td>
<td>-6,536</td>
<td>$7,731</td>
<td>$25,801</td>
<td></td>
</tr>
</tbody>
</table>

Figure 243: Original pivot table (top) and a Difference from example (bottom)

<table>
<thead>
<tr>
<th>Sum - Sales Value</th>
<th>Data</th>
<th>Brigitte</th>
<th>Fritz</th>
<th>Hans</th>
<th>Kurt</th>
<th>Ute</th>
</tr>
</thead>
<tbody>
<tr>
<td>Category</td>
<td>Golf</td>
<td>100.00%</td>
<td>173.73%</td>
<td>66.54%</td>
<td>105.14%</td>
<td>134.00%</td>
</tr>
<tr>
<td></td>
<td>Sailing</td>
<td>100.00%</td>
<td>81.80%</td>
<td>57.57%</td>
<td>85.23%</td>
<td>125.21%</td>
</tr>
<tr>
<td></td>
<td>Tennis</td>
<td>100.00%</td>
<td>218.04%</td>
<td>171.93%</td>
<td>156.17%</td>
<td>159.12%</td>
</tr>
<tr>
<td></td>
<td>Total Result</td>
<td>100.00%</td>
<td>152.60%</td>
<td>90.40%</td>
<td>111.19%</td>
<td>137.34%</td>
</tr>
</tbody>
</table>

Figure 244: Example of a % of analysis

<table>
<thead>
<tr>
<th>Sum - Sales Value</th>
<th>Data</th>
<th>Brigitte</th>
<th>Fritz</th>
<th>Hans</th>
<th>Kurt</th>
<th>Ute</th>
</tr>
</thead>
<tbody>
<tr>
<td>Category</td>
<td>Golf</td>
<td>73.73%</td>
<td>-33.46%</td>
<td>5.14%</td>
<td>34.00%</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Sailing</td>
<td>-18.20%</td>
<td>-42.43%</td>
<td>-14.77%</td>
<td>25.21%</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Tennis</td>
<td>118.04%</td>
<td>71.93%</td>
<td>56.17%</td>
<td>59.12%</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Total Result</td>
<td>52.60%</td>
<td>-9.60%</td>
<td>11.19%</td>
<td>37.34%</td>
<td></td>
</tr>
</tbody>
</table>

Figure 245: Example of % difference from analysis

More settings for the fields: Field options | 263
Options for row and column fields

Double-click a field in the Row or Column Fields areas of the Pivot Table Layout dialog to access the Data Field dialog shown in Figure 246.

In the Data Field dialog for a row or column field, you can choose to show subtotals for each category. Subtotals are deactivated by default. Subtotals are useful only if the values in one row or column field can be divided into subtotals for another (sub)field.

Some examples are shown in Figures 247, 248, and 249.
<table>
<thead>
<tr>
<th>Region</th>
<th>Employee</th>
<th>Golf</th>
<th>Sailing</th>
<th>Tennis</th>
<th>Total Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>East</td>
<td>Brigitte</td>
<td>$5,822</td>
<td>$2,135</td>
<td>$4,872</td>
<td>$12,829</td>
</tr>
<tr>
<td></td>
<td>Fritz</td>
<td>$15,172</td>
<td>$5,730</td>
<td>$12,456</td>
<td>$33,357</td>
</tr>
<tr>
<td></td>
<td>Hans</td>
<td>$5,316</td>
<td>$909</td>
<td>$12,220</td>
<td>$18,445</td>
</tr>
<tr>
<td></td>
<td>Kurt</td>
<td>$9,707</td>
<td>$6,475</td>
<td>$2,417</td>
<td>$18,599</td>
</tr>
<tr>
<td></td>
<td>Ute</td>
<td>$5,965</td>
<td>$7,235</td>
<td>$4,002</td>
<td>$17,202</td>
</tr>
<tr>
<td>North</td>
<td>Brigitte</td>
<td>$3,814</td>
<td>$10,161</td>
<td>$3,985</td>
<td>$17,950</td>
</tr>
<tr>
<td></td>
<td>Fritz</td>
<td>$3,443</td>
<td>$2,698</td>
<td>$9,115</td>
<td>$15,256</td>
</tr>
<tr>
<td></td>
<td>Hans</td>
<td>$3,049</td>
<td>$3,008</td>
<td>$5,361</td>
<td>$11,418</td>
</tr>
<tr>
<td></td>
<td>Kurt</td>
<td>$2,214</td>
<td>$3,485</td>
<td>$10,459</td>
<td>$16,198</td>
</tr>
<tr>
<td></td>
<td>Ute</td>
<td>$6,221</td>
<td>$3,126</td>
<td>$5,573</td>
<td>$14,920</td>
</tr>
<tr>
<td>South</td>
<td>Brigitte</td>
<td>$5,151</td>
<td>$4,432</td>
<td>$9,563</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Fritz</td>
<td>$23,290</td>
<td>$4,806</td>
<td>$15,641</td>
<td>$43,737</td>
</tr>
<tr>
<td></td>
<td>Hans</td>
<td>$4,196</td>
<td>$9,263</td>
<td>$3,868</td>
<td>$17,317</td>
</tr>
<tr>
<td></td>
<td>Kurt</td>
<td>$11,681</td>
<td>$7,270</td>
<td>$14,759</td>
<td>$33,710</td>
</tr>
<tr>
<td></td>
<td>Ute</td>
<td>$11,939</td>
<td>$19,030</td>
<td>$30,969</td>
<td></td>
</tr>
<tr>
<td>West</td>
<td>Brigitte</td>
<td>$12,174</td>
<td>$7,704</td>
<td>$8,864</td>
<td>$28,742</td>
</tr>
<tr>
<td></td>
<td>Fritz</td>
<td>$4,934</td>
<td>$5,742</td>
<td>$1,427</td>
<td>$13,103</td>
</tr>
<tr>
<td></td>
<td>Hans</td>
<td>$5,380</td>
<td>$880</td>
<td>$9,028</td>
<td>$15,288</td>
</tr>
<tr>
<td></td>
<td>Kurt</td>
<td>$4,744</td>
<td>$3,584</td>
<td>$8,328</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Ute</td>
<td>$12,013</td>
<td>$1,189</td>
<td>$18,623</td>
<td>$31,825</td>
</tr>
<tr>
<td>Total Result</td>
<td></td>
<td>$156,214</td>
<td>$109,852</td>
<td>$142,699</td>
<td>$408,765</td>
</tr>
</tbody>
</table>

Figure 248: Division of the regions for employees (two row fields) without subtotals

<table>
<thead>
<tr>
<th>Region</th>
<th>Employee</th>
<th>Golf</th>
<th>Sailing</th>
<th>Tennis</th>
<th>Total Result</th>
</tr>
</thead>
<tbody>
<tr>
<td>East</td>
<td>Brigitte</td>
<td>$6,822</td>
<td>$2,135</td>
<td>$4,872</td>
<td>$12,829</td>
</tr>
<tr>
<td></td>
<td>Fritz</td>
<td>$15,172</td>
<td>$5,730</td>
<td>$12,456</td>
<td>$33,357</td>
</tr>
<tr>
<td></td>
<td>Hans</td>
<td>$5,316</td>
<td>$909</td>
<td>$12,220</td>
<td>$18,445</td>
</tr>
<tr>
<td></td>
<td>Kurt</td>
<td>$9,707</td>
<td>$6,475</td>
<td>$2,417</td>
<td>$18,599</td>
</tr>
<tr>
<td></td>
<td>Ute</td>
<td>$5,954</td>
<td>$7,235</td>
<td>$4,002</td>
<td>$17,202</td>
</tr>
<tr>
<td>East Sum – Sales Value</td>
<td></td>
<td>$41,971</td>
<td>$22,484</td>
<td>$39,966</td>
<td>$100,421</td>
</tr>
<tr>
<td>North</td>
<td>Brigitte</td>
<td>$3,814</td>
<td>$10,161</td>
<td>$3,985</td>
<td>$17,950</td>
</tr>
<tr>
<td></td>
<td>Fritz</td>
<td>$3,443</td>
<td>$2,698</td>
<td>$9,115</td>
<td>$15,256</td>
</tr>
<tr>
<td></td>
<td>Hans</td>
<td>$3,049</td>
<td>$3,008</td>
<td>$5,361</td>
<td>$11,418</td>
</tr>
<tr>
<td></td>
<td>Kurt</td>
<td>$2,214</td>
<td>$3,485</td>
<td>$10,459</td>
<td>$16,198</td>
</tr>
<tr>
<td></td>
<td>Ute</td>
<td>$6,221</td>
<td>$3,126</td>
<td>$5,573</td>
<td>$14,920</td>
</tr>
<tr>
<td>North Sum – Sales Value</td>
<td></td>
<td>$18,741</td>
<td>$22,468</td>
<td>$34,533</td>
<td>$75,742</td>
</tr>
<tr>
<td>South</td>
<td>Brigitte</td>
<td>$5,151</td>
<td>$4,432</td>
<td>$9,563</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Fritz</td>
<td>$23,290</td>
<td>$4,806</td>
<td>$15,641</td>
<td>$43,737</td>
</tr>
<tr>
<td></td>
<td>Hans</td>
<td>$4,196</td>
<td>$9,263</td>
<td>$3,868</td>
<td>$17,317</td>
</tr>
<tr>
<td></td>
<td>Kurt</td>
<td>$11,681</td>
<td>$7,270</td>
<td>$14,759</td>
<td>$33,710</td>
</tr>
<tr>
<td></td>
<td>Ute</td>
<td>$11,939</td>
<td>$19,030</td>
<td>$30,969</td>
<td></td>
</tr>
<tr>
<td>South Sum – Sales Value</td>
<td></td>
<td>$56,257</td>
<td>$44,801</td>
<td>$34,258</td>
<td>$135,316</td>
</tr>
<tr>
<td>West</td>
<td>Brigitte</td>
<td>$12,174</td>
<td>$7,704</td>
<td>$8,864</td>
<td>$28,742</td>
</tr>
<tr>
<td></td>
<td>Fritz</td>
<td>$4,934</td>
<td>$5,742</td>
<td>$1,427</td>
<td>$13,103</td>
</tr>
<tr>
<td></td>
<td>Hans</td>
<td>$5,380</td>
<td>$880</td>
<td>$9,028</td>
<td>$15,288</td>
</tr>
<tr>
<td></td>
<td>Kurt</td>
<td>$4,744</td>
<td>$3,584</td>
<td>$8,328</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Ute</td>
<td>$12,013</td>
<td>$1,189</td>
<td>$18,623</td>
<td>$31,825</td>
</tr>
<tr>
<td>West Sum – Sales Value</td>
<td></td>
<td>$39,245</td>
<td>$20,099</td>
<td>$37,942</td>
<td>$97,286</td>
</tr>
<tr>
<td>Total Result</td>
<td></td>
<td>$156,214</td>
<td>$109,852</td>
<td>$142,699</td>
<td>$408,765</td>
</tr>
</tbody>
</table>

Figure 249: Division of the regions for employees with subtotals (by region)
To calculate subtotals that can also be used for the data fields (see above), select the Automatic option in the Subtotals section of the Data Field dialog.

You can choose the type of subtotal to use by selecting User-defined and then clicking the type of subtotal you want to calculate from the list. Functions in this list are only available when User-defined is selected.

Normally, the pivot table does not show a row or column for categories that have no entries in the underlying database. By choosing the Show items without data option, you can force these to be displayed.

For illustration purposes, the data was manipulated in such a way that the employee Brigitte has no sales values for the Golf category.

Click the Options button on the Data Field dialog to access the Data Field Options dialog (Figure 252). Use this dialog to specify additional options for fields in the Column and Row Fields areas of the Pivot Table Layout dialog.

The following options are provided:

- **Sort by.** Select the data field that you want to sort columns or rows by. Ascending sorts the values from the lowest value to the highest value. If the selected field is the field for which the dialog was opened, the items are sorted by name. If a data field was selected, the items are sorted by the resultant value of the selected data field. Similarly Descending sorts the values descending from the highest value to the lowest value. Manual sorts values alphabetically.

- **Display Options.** You can specify the display options for all row fields except for the last, innermost row field. Select from the Layout drop-down list to select the layout mode for the field in the list box. Select the Empty line after each item option to add an empty row after the data for each item in the pivot table. Select or deselect the Repeat item labels option as required.

- **Show Automatically.** This feature displays the top or bottom \( n \) items when you sort by a specified field. Click the Show option to turn on the automatic show feature and enter the maximum number of items that you want to show automatically. The From drop-down list.
selects to show the top or bottom items in the specified sort order. The *Using field* drop-down list selects the data field by which to sort the data.

- **Hide Items.** Use these options to select the items to hide from the calculations.
- **Hierarchy.** Select the hierarchy to use. The pivot table must be based on external source data that contains data hierarchies.

![Data Field Options dialog](image)

**Figure 252: Data Field Options dialog**

**Options for filter fields**

The Data Field dialog for fields in the *Filters* area is the same as for fields in the *Row* and *Column Fields* areas, even though it appears to be useless to have the same settings as described for the row and column fields. With the flexibility of the pivot table, you can switch the different fields between filters, columns, or rows. The fields keep the settings that you gave them. The filter field has the same properties as a row or column field. These settings only take effect when you use the field not as a filter field but as a row or column field.

**Working with the results of the pivot table**

The Pivot Table Layout dialog is very flexible and a pivot table can be totally restructured with only a few mouse clicks.

**Changing the layout**

The layout of the pivot table can be changed quickly and easily by using drag-and-drop. With the Pivot Table Layout dialog open, fields can be dragged around from *Row Fields*, *Column Fields*, *Filters*, and *Data Fields* areas to any position you want to put them, and then dropped. Unused fields can also be added, and fields removed in error can be replaced by dragging and dropping them into the positions required.
Some manipulation can also be carried out in the results view of the pivot table. Within the results of the pivot table, drag one of the filter, column, or row fields to a different position. The cursor will change shape from its starting shape (horizontal or vertical block on the arrow head) to the opposite if moving to a different field, such as from row to column, where it can be dropped.

<table>
<thead>
<tr>
<th>Sum - Sales Value</th>
<th>Employee</th>
</tr>
</thead>
<tbody>
<tr>
<td>Golf</td>
<td>Brigitte</td>
</tr>
<tr>
<td></td>
<td>Fritz</td>
</tr>
<tr>
<td>$26,961</td>
<td>$46,839</td>
</tr>
<tr>
<td>Sailing</td>
<td></td>
</tr>
<tr>
<td>$24,422</td>
<td>$19,976</td>
</tr>
<tr>
<td>Tennis</td>
<td></td>
</tr>
<tr>
<td>$17,721</td>
<td>$38,638</td>
</tr>
<tr>
<td><strong>Total Result</strong></td>
<td><strong>$69,104</strong></td>
</tr>
</tbody>
</table>

*Figure 253: Drag a column field - note the cursor shape*

<table>
<thead>
<tr>
<th>Employee</th>
<th>Category</th>
<th>Sum - Sales Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Brigitte</td>
<td>Golf</td>
<td>$26,961</td>
</tr>
<tr>
<td></td>
<td>Sailing</td>
<td>$24,422</td>
</tr>
<tr>
<td></td>
<td>Tennis</td>
<td>$17,721</td>
</tr>
<tr>
<td>Fritz</td>
<td>Golf</td>
<td>$46,839</td>
</tr>
<tr>
<td></td>
<td>Sailing</td>
<td>$19,976</td>
</tr>
<tr>
<td></td>
<td>Tennis</td>
<td>$38,638</td>
</tr>
<tr>
<td>Hans</td>
<td>Golf</td>
<td>$17,941</td>
</tr>
<tr>
<td></td>
<td>Sailing</td>
<td>$14,060</td>
</tr>
<tr>
<td></td>
<td>Tennis</td>
<td>$30,467</td>
</tr>
<tr>
<td>Kurt</td>
<td>Golf</td>
<td>$28,346</td>
</tr>
<tr>
<td></td>
<td>Sailing</td>
<td>$20,814</td>
</tr>
<tr>
<td></td>
<td>Tennis</td>
<td>$27,675</td>
</tr>
<tr>
<td>Ute</td>
<td>Golf</td>
<td>$36,127</td>
</tr>
<tr>
<td></td>
<td>Sailing</td>
<td>$30,580</td>
</tr>
<tr>
<td></td>
<td>Tennis</td>
<td>$28,198</td>
</tr>
<tr>
<td><strong>Total Result</strong></td>
<td></td>
<td><strong>$408,765</strong></td>
</tr>
</tbody>
</table>

*Figure 254: Result of dragging column field (see Figure 253)*

<table>
<thead>
<tr>
<th>Sum - Sales Value</th>
<th>Employee</th>
</tr>
</thead>
<tbody>
<tr>
<td>Golf</td>
<td>Brigitte</td>
</tr>
<tr>
<td></td>
<td>Fritz</td>
</tr>
<tr>
<td>$26,961</td>
<td>$46,839</td>
</tr>
<tr>
<td>Sailing</td>
<td></td>
</tr>
<tr>
<td>$24,422</td>
<td>$19,976</td>
</tr>
<tr>
<td>Tennis</td>
<td></td>
</tr>
<tr>
<td>$17,721</td>
<td>$38,638</td>
</tr>
<tr>
<td><strong>Total Result</strong></td>
<td><strong>$69,104</strong></td>
</tr>
</tbody>
</table>

*Figure 255: Drag a row field - note the cursor shape*

You can remove a column, row, or filter field from the pivot table by clicking on it and dragging it out of the table. The cursor changes to that shown in Figure 256. A field removed in error cannot be recovered, without returning to the Pivot Table Layout dialog to replace it.
Grouping rows or columns of a pivot table

For many analyses or summaries, the categories have to be grouped. You can merge the results in classes. You can only carry out grouping on an ungrouped pivot table.

After selecting the correct cell area, select Data > Group and Outline > Group from the Menu bar, or press F12 on the keyboard. The type of values to be grouped is what mainly determines how the grouping function works. You need to distinguish between scalar values, or other values, such as text, that you want grouped.

Note

Before you can group, you have to produce a pivot table with ungrouped data. The time needed for creating a pivot table depends mostly on the number of columns and rows and not on the size of the basic data. Through grouping you can produce the pivot table with a small number of rows and columns. The pivot table can contain a lot of categories, depending on your data source.

To remove grouping again, click inside the group, then choose Data > Group and Outline > Ungroup, or press Ctrl+F12.

Grouping of categories with scalar values

For grouping scalar values, select a single cell in the row or column of the category to be grouped. Choose Data > Group and Outline > Group from the Menu bar or press F12 on the keyboard; Calc displays the Grouping dialog shown in Figure 257.

You can define in which value range (Start / End) the grouping should take place. The default setting is the whole range, from the smallest to the largest value. In the field Group by, you can enter the class size, also known as the interval size.
Grouping of categories with scalar categories

Figure 258 shows part of a pivot table created from a list containing speed measurements as a function of time. This pivot table shows the count of km/h speed measurements in the raw data.

The pivot table in Figure 259 is based on the same raw data. However in this case the speed measurements are grouped into intervals of 10 km/h.

Grouping of categories with date / time values

For grouping date / time values, select a single cell in the row or column of the category to be grouped. Choose Data > Group and Outline > Group from the Menu bar or press F12 on the keyboard; Calc displays the Grouping dialog shown in Figure 260.
You can define in which value range (Start / End) the grouping should take place. The default setting is the whole range, from the smallest to the largest value. In the field Group by, you can enter the class size, also known as the interval size. In this case you can select one of the predefined time intervals (Seconds, Minutes, Hours, Days, Months, Quarters, or Years) as an alternative to explicitly specifying a time interval in days.

Figure 261 shows a pivot table configured to show the daily sales in the North region.
Figure 261: Pivot table without grouping

Figure 262: Pivot table with grouping

**Grouping without automatic creation of intervals**

It is not possible to create intervals for some categories (for example, those containing text fields). However, for such fields it is possible to define which values are put together in one group.

For grouping of these categories, select in the results of the pivot table all the individual field values that you want to put together in the group. With more than one cell selected, choose Data > Group and Outline > Group from the Menu bar, or press F12 on the keyboard, to group the selected cells.
Given the input data shown in Figure 263, create a pivot table with Department in the *Row Fields* area and Sum - Sick days in the *Data Fields* area. The result should be as shown in Figure 264.

In the results of the pivot table select Accounting, Purchasing, and Sales in the Department column. Select **Data > Group and Outline > Group** from the Menu bar or press *F12* on the keyboard. The pivot table result updates to reflect the new group, as shown in Figure 265.

In the updated pivot table result, select Assembly, Production, and Warehouse in the Department column. Select **Data > Group and Outline > Group** from the Menu bar or press *F12* on the keyboard. The pivot table updates again to reflect the new group, as shown in Figure 266.

You can change the default names for the groups and the newly created group field by editing the name in the input field (for example changing Group2 to Technical). The pivot table will remember these settings, even if you change the layout later on.
To add partial sums for the groups, right-click the results of the pivot table and select the Properties option. Double-click the Department2 entry in the Row Fields area and select the Automatic option on the Data Field dialog (Figure 246). Click the two OK buttons and the pivot table is updated to include the partial sums for the groups, as shown in Figure 267.

![Figure 266: Grouping finished](image)

**Figure 266: Grouping finished**

To add partial sums for the groups, right-click the results of the pivot table and select the Properties option. Double-click the Department2 entry in the Row Fields area and select the Automatic option on the Data Field dialog (Figure 246). Click the two OK buttons and the pivot table is updated to include the partial sums for the groups, as shown in Figure 267.

![Figure 267: Renamed group and partial results](image)

**Figure 267: Renamed group and partial results**

If it is not enabled already, select the Enable drill to details option on the Pivot Table Layout dialog. Double-click the Group 1 and Technical entries in the Department2 column to collapse/expand the group entries (for example, Figure 268 shows both groups collapsed).

![Figure 268: Reduced to the new groups](image)

**Figure 268: Reduced to the new groups**

A well-structured database makes manual sorting within the pivot table obsolete. In the example shown, you could add another column with the name Department, that has the correct entry for each person based on whether the employee’s department belongs to the group Office or Technical. The mapping for this (1:n relationship) can be done easily with the VLOOKUP() function from Calc.

**Note**

Sorting the result

The results of a pivot table are by default sorted so that categories in columns and rows are presented in ascending order. There are three ways to change the sorting order:

- Select a sort order from the drop-down menu on a column's heading.
- Sort manually by using drag and drop.
- Select a sort order through the Data Field Options dialog for the appropriate row or column field (Figure 252).
**Select sort order from drop-down menus on each column heading**

The simplest way to sort entries is to click the arrow on the right side of the column heading for a row or column field, and select one of the three sorting options (Figure 269):

- **Sort Ascending**
- **Sort Descending**
- **Custom Sort**

![Figure 269: Column sorting and filtering dialog](image)

Selecting the **Custom Sort** option sorts according to one of the predefined custom sorts defined in **Tools > Options > LibreOffice Calc > Sort Lists**. See Chapter 2, Entering, Editing, and Formatting Data for more information about creating and using sort lists.

This dialog also provides facilities for simple filtering of the data in the pivot table. Check the required individual boxes to select the data displayed in the results of the pivot table. Options are provided to show all, show only the current item, or hide only the current item. Click **OK** to activate the selected filtering. Once filtering has been carried out, the color of the arrow changes from black to blue, and a small square of matching color is added to the bottom right of the arrow button (Figure 270).

![Figure 270: Arrow color change and indicator square on column heading](image)

**Sort manually by using drag and drop**

You can change the order within the categories by moving the cells with the category values in the results of the pivot table. The dragged cell is inserted above the cell on which you drop it.
Be aware that in Calc, a cell must be selected, it is not enough that the cursor is in the cell. The background of a selected cell is marked with a different color. To mark a single cell do one of the following:

- Click, then *Shift*+click the cell.
- Press the mouse button, drag a range across two cells, do not release the mouse button, and then drag back to the first cell. Release the mouse button. You can now move the individual cell by drag and drop.

To select several cells, mark one cell with no extra key pressed, then press the *Shift* or *Ctrl* key while clicking in other cells.

**Sort automatically**

To sort automatically, right-click within the pivot table and choose *Properties*. This will open the Pivot Table Layout dialog (Figure 235). Double-click the row or column field you want to sort. In the Data Field dialog which opens (Figure 246), click *Options* to display the Data Field Options dialog (Figure 252).

For *Sort by*, choose either *Ascending*, *Descending*, or *Manual*. *Ascending* sorts the values from the lowest value to the highest value. If the selected field is the field for which the dialog was opened, the items are sorted by name. If a data field was selected, the items are sorted by the resultant value of the selected data field. Similarly *Descending* sorts the values descending from the highest value to the lowest value. *Manual* sorts values alphabetically.

**Drilling (showing details)**

Use drilling to show the related detailed data for a single, compressed value in the pivot table result. This facility is available only if you selected the *Enable drill to details* option on the Pivot Table Layout dialog.

To activate a drill, double-click on the cell or choose *Data > Group and Outline > Show Details*. There are two possibilities:

- The active cell is a row or column field. In this case, drill means an additional breakdown into the categories of another field. For example, double-click on the cell with the value *Golf*. In this instance the values that are aggregated within Golf can be subdivided using another field.

```
<table>
<thead>
<tr>
<th>Sum - Sales Value</th>
<th>Region</th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td>East</td>
<td>North</td>
<td>South</td>
</tr>
<tr>
<td><strong>Category</strong></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Golf</td>
<td>$41,971</td>
<td>$18,741</td>
<td>$56,257</td>
<td>$39,245</td>
</tr>
<tr>
<td>Sailing</td>
<td>$22,484</td>
<td>$22,468</td>
<td>$44,801</td>
<td>$20,099</td>
</tr>
<tr>
<td>Tennis</td>
<td>$35,966</td>
<td>$34,533</td>
<td>$34,258</td>
<td>$37,942</td>
</tr>
<tr>
<td><strong>Total Result</strong></td>
<td>$100,421</td>
<td>$75,742</td>
<td>$135,316</td>
<td>$97,286</td>
</tr>
</tbody>
</table>
```

*Figure 271: Before the drill down for Golf*

The Show Detail dialog appears allowing you to select the field to use for further subdivision. In this example, *Employee*.
To hide the details again, double-click on the cell Golf or choose Data > Group and Outline > Hide Details.

The pivot table remembers your selection (in our example the field Employee) by adding and hiding the selected field, so that for the next drill down for a field in the Category column the dialog does not appear. To remove the selection Employee, open the Pivot Table Layout dialog by right-clicking and choosing Properties, then delete the unwanted selection in the Row or Column Fields area.

- The active cell is a data field. In this case, drill down results in a listing of all data entries of the data source that aggregate to this value.

In our example, if we double-click on the cell with the value $18,741 from Figure 271, we would have a new list of all data sets that are included in this value. This list is displayed in a new sheet.

### Filtering

To limit the pivot table analysis to a subset of the information that is contained in the data basis, you can filter with the pivot table.
Note

An autofilter or default filter used on the sheet containing the raw data has no effect on the pivot table analysis process. The pivot table always uses the complete list that was selected when it was started.

To do this, click the **Filter** button at the top left above the results, or click in the results and select **Filter** from the context menu.

Note

The **Filter** button is available only if you selected the **Add filter** option on the Pivot Table Layout dialog.

![Figure 275: Filter button in the upper left area of the pivot table](image)

In the Filter dialog (Figure 276), you can define up to three filter options that are used in the same way as Calc's default filter.

![Figure 276: Dialog for defining the filter](image)

The data presented in a pivot table can also be filtered using the drop-downs on the right hand side of column headings or by using filter fields. Filtering through column headings is described in “Select sort order from drop-down menus on each column heading” on page 275.

Filter fields (that is, fields that you placed in the Filters area of the Pivot Table Layout dialog) are another practical way to filter the results of the pivot table. The advantage is that the filtering criteria used are clearly visible. Click the arrow on the right side of the filter field button to access the associated filtering dialog (Figure 277).
The text adjacent to a filter field button indicates the filtering status, that is “- all -” when nothing is filtered, "- multiple -" when multiple but not all items are filtered, or the value when only that value is not filtered.

**Updating (refreshing) changed values**

After you have created the pivot table, changes in the source data do not cause an automatic update in the resulting table. You must update (refresh) the pivot table manually after changing any of the underlying data values.

Changes in the source data could appear in two ways:

- The content of existing data sets has been changed.
  For example, you might have changed a sales value. To update the pivot table, click in the result area and choose **Refresh** from the context menu, or choose **Data > Pivot Table > Refresh** from the Menu bar.

- You have added or deleted data sets in the original list.
  In this case the change means that the pivot table has to use a different area of the spreadsheet for its analysis. Fundamental changes to the data set collection means you must redo the pivot table from the beginning.

**Cell formatting**

The cells in the results area of the pivot table are automatically formatted by Calc. You can change this formatting using all the tools in Calc. However if you make any change in the design of the pivot table using direct formatting, the formatting will return to that applied automatically by Calc when the table is next refreshed.

On creating a pivot table, six standard cell styles are added to the list of styles in the document if they are not included already. Each of these styles is applied to part of the pivot table. You can customize these pivot table styles. The pivot table styles are:

- Pivot Table Category
- Pivot Table Corner
- Pivot Table Field
- Pivot Table Result
- Pivot Table Title
- Pivot Table Value
Tip

Use the pivot table styles to make sure that the format of your pivot table is not unexpectedly changed during updates and that all pivot tables in your document have the same appearance.

Note

Direct formatting of pivot table cells is not retained during updates.

For the number format in the data field, Calc uses the number format that is used in the corresponding cell in the source list. In most cases, this is useful (for example, if the values are in the currency format, then the corresponding cell in the result area is also formatted as currency). However, if the result is a fraction or a percentage, the pivot table does not recognize that this might be a problem; such results must either be without a unit or be displayed as a percentage. Although you can correct the number format manually, the correction stays in effect only until the next update.

Deleting a pivot table

To delete a pivot table, right-click in the result area and choose Delete from the context menu, or choose Data > Pivot Table > Delete from the Menu bar.

Warning

If you delete a pivot table with an associated pivot chart, the pivot chart is also deleted. Calc opens a dialog box to confirm the pivot chart deletion.

Using pivot table results elsewhere

The problem

Normally, you create a reference to a value by entering the address of the cell that contains the value. For example, the formula =C6*2 creates a reference to cell C6 and returns the doubled value. If this cell is located in the results area of the pivot table, it contains the result that was calculated by referencing specific categories of the row and column fields. In Figure 278, the cell C6 contains the sum of the sales values of the employee Hans in the category Sailing. The formula in the cell C12 uses this value.

![Figure 278: Formula reference to a cell of the pivot table](image)
If the underlying data or the layout of the pivot table changes, then you must take into account that the sales value for Hans in the Sailing category might appear in a different cell. Your formula still references the cell C6 and therefore uses a wrong value. The correct value is in a different location. For example, in Figure 279, the location is now C7.

The solution: Function GETPIVOTDATA()

Use the function GETPIVOTDATA() to have a reference to a value inside the pivot table by using the specific identifying categories for this value. This function can be used with formulas in Calc if you want to reuse the results from the pivot table elsewhere in your spreadsheet.

Syntax

The syntax has two variations:

GETPIVOTDATA(TargetField; Pivot Table[; Field 1; Item 1][; ... [Field 126; Item 126]])

or

GETPIVOTDATA(Pivot Table; Constraints)

First syntax variation

The target field specifies which data field of the pivot table is used within the function. If your pivot table has only one data field, this entry is ignored, but you must enter it anyway.

If your pivot table has more than one data field, then you have to enter the field name from the underlying data source (for example “Sales Value”) or the field name of the data field itself (for example “Sum – Sales Value”).

The argument Pivot Table specifies the pivot table that you want to use. It is possible that your document contains more than one pivot table. Enter here a cell reference that is inside the area of your pivot table. It might be a good idea to always use the upper left corner cell of your pivot table, so that you can be sure that the cell will always be within your pivot table, even if the layout changes.

Example: GETPIVOTDATA("Sales Value", A1)

If you enter only the first two arguments, then the function returns the total result of the pivot table (“Sum – Sales Value” entered as the field, will return a value of 408,765).

You can add more arguments as pairs with Field name and Element to retrieve specific partial sums. In the example in Figure 280, where we want to get the partial sum of Hans for Sailing, the formula in cell C12 would look like this:
=GETPIVOTDATA("Sales Value",A1,"Employee","Hans","Category","Sailing")

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Filter</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>Sum - Sales Value</td>
<td>category</td>
<td>Sailing</td>
<td>Tennis</td>
<td>Total Result</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>Employee</td>
<td></td>
<td>Golf</td>
<td>Sailing</td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>Brigitt</td>
<td>$26,961</td>
<td>$24,422</td>
<td>$17,721</td>
<td>$69,104</td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>Fritz</td>
<td>$46,839</td>
<td>$19,976</td>
<td>$38,638</td>
<td>$105,453</td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>Hans</td>
<td>$17,941</td>
<td>$14,060</td>
<td>$30,467</td>
<td>$62,468</td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>Kurt</td>
<td>$28,346</td>
<td>$20,814</td>
<td>$27,675</td>
<td>$76,835</td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>Ute</td>
<td>$36,127</td>
<td>$30,580</td>
<td>$28,198</td>
<td>$94,905</td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>Total Result</td>
<td>$156,214</td>
<td>$109,852</td>
<td>$142,699</td>
<td>$408,765</td>
<td></td>
</tr>
<tr>
<td>11</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>14060</td>
</tr>
<tr>
<td>12</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Figure 280: First syntax variation**

**Second syntax variation**

The argument **Pivot Table** has to be given in the same way as for the first syntax variation.

For the **specification**, enter a list separated by spaces to specify the value you want from the pivot table. This list must contain the name of the data field, if there is more than one data field; otherwise it is not required. To select a specific partial result, add more entries in the form of Field name[Element].

In the example in Figure 281, where we want to get the partial sum of Hans for Sailing, the formula in cell C12 would look like this:

=GETPIVOTDATA(A1,"Sales Value Employee[Hans] Category[Sailing]")

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Filter</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>Sum - Sales Value</td>
<td>category</td>
<td>Sailing</td>
<td>Tennis</td>
<td>Total Result</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>Employee</td>
<td></td>
<td>Golf</td>
<td>Sailing</td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>Brigitt</td>
<td>$26,961</td>
<td>$24,422</td>
<td>$17,721</td>
<td>$69,104</td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>Fritz</td>
<td>$46,839</td>
<td>$19,976</td>
<td>$38,638</td>
<td>$105,453</td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>Hans</td>
<td>$17,941</td>
<td>$14,060</td>
<td>$30,467</td>
<td>$62,468</td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>Kurt</td>
<td>$28,346</td>
<td>$20,814</td>
<td>$27,675</td>
<td>$76,835</td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>Ute</td>
<td>$36,127</td>
<td>$30,580</td>
<td>$28,198</td>
<td>$94,905</td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>Total Result</td>
<td>$156,214</td>
<td>$109,852</td>
<td>$142,699</td>
<td>$408,765</td>
<td></td>
</tr>
<tr>
<td>11</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>14060</td>
</tr>
<tr>
<td>12</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Figure 281: Second syntax variation**

When working with data sets containing date information, you must take care if you use the date information in the GETPIVOTDATA() function. The function will only recognize the date entry if it is entered into the formula in exactly the same way that it appears in the data set from which the pivot table is produced. In the example of Figure 282, an error is returned when the date format does not match that of the data. Only with the correct format is the result returned.
Using pivot charts

Introduction

A pivot table is a powerful tool to reorganize, manipulate and summarize data. A pivot chart provides a visual representation of the information in a pivot table. You can create a pivot chart from the output of a pivot table and, if the pivot table gets changed, so does the pivot chart.

Pivot charts are a special case of the more general Calc charts described in Chapter 3, Creating Charts and Graphs. The main differences between pivot charts and other charts in Calc are as follows:

- A pivot chart tracks the changes in the data issued from a pivot table and Calc automatically adjusts the data series and data range of the pivot chart accordingly.
- Pivot chart buttons are provided on pivot charts. These buttons are unique to pivot charts and are not provided on Calc's normal charts. An important purpose of the buttons is to represent the layout of the underlying pivot table and they show the pivot table's fields. Buttons representing the filter fields (if present) are provided at the top of the pivot chart. Buttons representing the row fields are provided at the bottom of the pivot chart. Buttons representing the column fields are stacked in the legend at the right of the pivot chart. You can also use pivot chart buttons to filter the data displayed in the pivot chart.
Creating a pivot chart

To create a pivot chart, click inside the pivot table and select **Insert > Chart** on the Menu bar or click the **Insert Chart** icon on the Standard toolbar.

Calc automatically detects the pivot table and opens the Chart Wizard. Through the Chart Wizard you can select the chart type and chart elements for the pivot chart. The wizard is similar to the corresponding wizard for normal charts but for pivot charts, the steps to define data range and data series are disabled.

The first step in the wizard is to select the chart type and the same options are available as for a normal chart (Figure 284).

---

Figure 283: Sample pivot chart and associated pivot table

**Creating a pivot chart**

To create a pivot chart, click inside the pivot table and select **Insert > Chart** on the Menu bar or click the **Insert Chart** icon on the Standard toolbar.

Calc automatically detects the pivot table and opens the Chart Wizard. Through the Chart Wizard you can select the chart type and chart elements for the pivot chart. The wizard is similar to the corresponding wizard for normal charts but for pivot charts, the steps to define data range and data series are disabled.

The first step in the wizard is to select the chart type and the same options are available as for a normal chart (Figure 284).
The second step is to select the chart elements and these are similar to those for normal charts (Figure 285).

Click **Finish** to close the wizard and create the pivot chart.

**Editing a pivot chart**

After you have created a pivot chart, you may find that you would like to move it, change its size or improve its appearance. Calc provides tools for changing the chart type, chart elements, fonts, colors, and many other options. The facilities provided for pivot charts are the same as those available for normal charts; see Chapter 3, Creating Charts and Graphs.

**Updating a pivot chart**

If the source data of the pivot table changes, refresh the pivot table and the pivot chart is also updated accordingly. To refresh the pivot table (and thus the pivot chart), click in any cell within the
pivot table and select **Data > Pivot Table > Refresh** from the Menu bar or select **Refresh** from the context menu.

**Filtering a pivot chart**

Use filters to remove unwanted data from a pivot chart.

All filters applied to a pivot table affect any linked pivot chart equally, since the table and chart show exactly the same data. The various pivot table filtering mechanisms are described in “Filtering” on page 277.

Pivot chart buttons include a down arrow to indicate that there is an associated pop-up action. If any filtering is applied, then this arrow turns from black to blue.

Click a filter field button located at the top of a pivot chart to access a filtering dialog similar to that shown in Figure 277. Change the filtering applied to the pivot table and pivot chart through this dialog. The right-hand section of the button’s legend indicates the filtering status, that is "- all -" when nothing is filtered, "- multiple -" when multiple but not all items are filtered, or the value when only that value is not filtered.

Buttons located at the bottom and right of a pivot chart that include a downward pointing arrow provide access to a sorting and filtering dialog similar to the shown in Figure 269. Change the sorting and filtering applied to the pivot table and pivot chart through this dialog.

![Filtering applied to filter and row fields](image)

**Deleting a pivot chart**

To delete a pivot chart, select the chart and press **Del** on the keyboard.

**Note**

When you delete a pivot chart, the associated pivot table is not affected.

**Warning**

If you delete a pivot table with an associated pivot chart, the pivot chart is also deleted. Calc opens a dialog box to confirm the pivot chart deletion.
Chapter 9
Data Analysis

Using Scenarios, Goal Seek, Solver, Statistics, others
**Introduction**

Once you are familiar with functions and formulas, the next step is to learn how to use Calc’s automated processes to perform useful analysis of your data quickly.

In addition to formulas and functions, Calc includes several tools for processing your data. These tools include features for copying and reusing data, creating subtotals, running what-if analysis, and performing statistical analysis. They can be found under the **Tools** and **Data** menus in the Menu bar. While they are not necessary to using Calc, they can help you save time and effort with handling large data sets or preserving your work for future review.

**Note**

A related tool, the Pivot Table, is not mentioned here, as it is complex enough to require its own chapter. See Chapter 8, Using Pivot Tables, for more information.

**Consolidating data**

The Consolidate tool allows you to combine and aggregate data spread across one or more worksheets into one place. This tool is useful if you need to quickly summarize a large, scattered set of data for review. For example, you could use it to consolidate multiple department budgets from different worksheets into a single company-wide budget contained in a master worksheet.

To access the Consolidate tool dialog, select **Data > Consolidate** from the Menu bar (Figure 287).

![Consolidate tool dialog](Figure 287: Consolidate tool dialog)
**Consolidating data example**

To consolidate data:

1) Open the document containing the cell ranges to be consolidated.
2) Select **Data > Consolidate** from the Menu bar to open the Consolidate dialog (Figure 288).
3) Click on the **Source data ranges** field, then type a reference to a source data range, a named range or select it with the mouse. Use the associated **Shrink / Expand** button if you need to minimize the dialog while you select the range. Alternatively, select a named range from the drop-down list to the left of the field.
4) Click **Add**. The selected range is added to the **Consolidation ranges** list.
5) Repeat steps 3 and 4 to add additional source ranges.
6) To delete an entry in the **Consolidation ranges** list, select it and click **Delete**. The deletion is carried out without further confirmation.
7) Click on the **Copy results to** field, then type a reference to the first cell of the target range or select it with your mouse. You can also select a named range from the drop-down list to the left of the field.
8) Select a function to aggregate your data from the **Function** drop-down list. The default is **Sum**. Other available functions include **Count, Average, Max, Min, Product, Count (numbers only), StdDev (sample), StDevP (population), Var (sample), and VarP (population)**.
9) Click **OK** to consolidate the ranges. Calc runs the function from step 8 on your source data ranges and populates the target range with the results.

**Tip**

If you are consolidating the same cell ranges repeatedly, consider converting them into reusable named ranges to make the process easier. For more information about named ranges, see Chapter 13, Calc as a Simple Database.

**Consolidation settings**

In the Consolidate dialog, click on the ‘+’ sign next to **Options** to access the following settings (Figure 288):

- **Consolidate by**
  - **Row labels**
  - **Column labels**
- **Options**
  - **Link to source data**

**Figure 288: Consolidate tool options**

**Consolidate by**

In this section, choose whether to consolidate your source data ranges by their range position or by matching labels. Consolidation labels must be contained within each range, and the text of corresponding row or column labels must match for the rows or columns themselves to be combined.

- **Row labels** – Consolidates rows by matching label. If this option is unchecked, the tool will consolidate rows by position instead.
- **Column labels** – Works the same as **Row labels**, but with columns instead.
Options
In this section, select **Link to source data** to add formulas in the target range that link back to values in the source ranges. When you select this option, any changes you make in the source ranges will automatically update values in the target range.

**Note**

If you use the **Link to source data** option, each source link is inserted into the target range, then ordered and hidden from view. Only the final results of consolidation are displayed by default.

Consolidation example

Figures 289, 290, and 291 show a simple example of consolidation using a spreadsheet with the worksheets **Year 1**, **Year 2**, and **Consolidated Sales**. Figure 289 shows the contents of the **Year 1** worksheet, with sales figures by region for each of the four product colors.

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td>Red</td>
<td>Orange</td>
<td>Green</td>
<td>Blue</td>
</tr>
<tr>
<td>2</td>
<td>North</td>
<td>$84,213</td>
<td>$87,445</td>
<td>$5,039</td>
<td>$31,653</td>
</tr>
<tr>
<td>3</td>
<td>East</td>
<td>$92,609</td>
<td>$94,959</td>
<td>$44,486</td>
<td>$28,606</td>
</tr>
<tr>
<td>4</td>
<td>South</td>
<td>$67,987</td>
<td>$10,169</td>
<td>$62,682</td>
<td>$28,253</td>
</tr>
<tr>
<td>5</td>
<td>West</td>
<td>$29,628</td>
<td>$95,213</td>
<td>$74,889</td>
<td>$10,334</td>
</tr>
</tbody>
</table>

*Figure 289: Year 1 sales by region*

Figure 290 shows the **Year 2** worksheet, sales figures by region for each of four product colors. Note the different ordering of row and column labels between the two figures.

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td>Red</td>
<td>Green</td>
<td>Blue</td>
<td>Orange</td>
</tr>
<tr>
<td>2</td>
<td>North</td>
<td>$11,716</td>
<td>$94,801</td>
<td>$68,566</td>
<td>$71,129</td>
</tr>
<tr>
<td>3</td>
<td>South</td>
<td>$86,039</td>
<td>$20,239</td>
<td>$1,194</td>
<td>$83,642</td>
</tr>
<tr>
<td>4</td>
<td>East</td>
<td>$18,326</td>
<td>$69,337</td>
<td>$59,089</td>
<td>$48,803</td>
</tr>
<tr>
<td>5</td>
<td>West</td>
<td>$60,579</td>
<td>$25,280</td>
<td>$75,349</td>
<td>$47,605</td>
</tr>
</tbody>
</table>

*Figure 290: Year 2 sales by region*

Figure 291 shows the consolidated sales data, created by using the Consolidate dialog settings shown in Figure 288. Note that because the **Link to source data** option was selected, clicking on the plus sign (+) indicators to the left of the data will reveal formula links back to the source ranges.
Creating subtotals

Calc offers two methods of creating subtotals: the SUBTOTAL function and the Subtotals tool.

Using the SUBTOTAL function

The SUBTOTAL function is listed under the Mathematical category of the Function Wizard, and the Functions List deck of the Sidebar, which are described in Chapter 7, Using Formulas and Functions. SUBTOTAL is a relatively limited method for generating a subtotal, and works best if used with only a few categories.

A SUBTOTAL example

To illustrate how to use the SUBTOTAL function, we use the sales data worksheet shown in Figure 292. The AutoFilter function is already applied to the sales data, and are indicated by the down arrow buttons at the head of each column. AutoFilters are described in Chapter 2, Entering, Editing, and Formatting Data.

To create a summation subtotal for the Sales Value field:

1) Select the cell to contain a subtotal. Typically, this cell is at the bottom of the column being subtotaled, which, for our example, is the Sales Value column.

2) Use one of the following methods to open the Function Wizard dialog:
   – The Function Wizard icon from the Formula bar
   – Insert > Function from the Menu bar
   – Ctrl+F2 key combination
3) Select SUBTOTAL from the Function list in the Function Wizard dialog and click Next.

4) Enter the numeric code of a function into the Function field of the dialog. This code must be a value in the range 1 to 11 or 101 to 111, with the meaning of each value shown in Table 8.

**Note**

Values 1 to 11 include hidden values in the calculated subtotal, while values 101 to 111 do not. Hiding and showing data is described in Chapter 2, Entering, Editing, and Formatting Data. Filtered-out cells are always excluded by the SUBTOTAL function.

<table>
<thead>
<tr>
<th>Function index (includes hidden values)</th>
<th>Function index (ignores hidden values)</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>101</td>
<td>AVERAGE</td>
</tr>
<tr>
<td>2</td>
<td>102</td>
<td>COUNT</td>
</tr>
<tr>
<td>3</td>
<td>103</td>
<td>COUNTA</td>
</tr>
<tr>
<td>4</td>
<td>104</td>
<td>MAX</td>
</tr>
<tr>
<td>5</td>
<td>105</td>
<td>MIN</td>
</tr>
<tr>
<td>6</td>
<td>106</td>
<td>PRODUCT</td>
</tr>
<tr>
<td>7</td>
<td>107</td>
<td>STDEV</td>
</tr>
<tr>
<td>8</td>
<td>108</td>
<td>STDEVP</td>
</tr>
<tr>
<td>9</td>
<td>109</td>
<td>SUM</td>
</tr>
<tr>
<td>10</td>
<td>110</td>
<td>VAR</td>
</tr>
<tr>
<td>11</td>
<td>111</td>
<td>VARP</td>
</tr>
</tbody>
</table>

5) Click on the Range field, then type a reference to the Sales Value range or select the cells with your mouse (Figure 293). Use the Shrink / Expand button if you need to temporarily minimize the dialog while selecting the cells.

6) Click OK to close the Function Wizard dialog. The cell you selected in step 1 now contains the total sales value.

7) Click on the AutoFilter down arrow button at the top of the Employee column and remove all marks from the Standard Filter area except those next to Brigitte and (empty). The cell that you selected in step 1 should now reflect the sum of all of Brigitte’s sales (Figure 294).

**Note**

If the cell range used to calculate a subtotal contains other subtotals, these subtotals will not be counted in the final one. Similarly, if you use this function with AutoFilters, only the data satisfying the current filter selections will be displayed. Any filtered-out data is ignored.
Using Data > Subtotals

Calc offers the Subtotals tool as a more comprehensive alternative to the SUBTOTAL function. In contrast to SUBTOTAL, which only works on a single array, the Subtotals tool can create subtotals for up to three arrays arranged in labeled columns. It also groups subtotals by category and sorts them automatically, thereby eliminating the need to apply AutoFilters and filter categories by hand.

To use this tool, select **Data > Subtotals** from the Menu bar, which opens the Subtotals dialog.

---

**Figure 293: Function Wizard dialog**

**Figure 294: SUBTOTAL result for Brigitte's sales**
Using the Subtotals tool

To insert subtotal values into a worksheet:

1) Select the cell range for the subtotals that you want to calculate, and remember to include the column heading labels. Alternatively, click on a single cell within your data to allow Calc to automatically identify the range.

2) Select **Data > Subtotals** from the Menu bar to open the Subtotals dialog (Figure 295).

3) In the **Group by** drop-down list on the 1st Group tab, select a column by its label. Entries in the cell range from step 1 will be grouped and sorted by matching values in this column.

4) In the **Calculate subtotals for** box on the 1st Group tab, select a column containing values to be subtotaled. If you later change values in this column, Calc will automatically recalculate the subtotals.

5) In the **Use function** box on the 1st Group tab, select a function to calculate the subtotals for the column selected in step 4.

6) Repeat steps 4 and 5 to create subtotals for other columns on the 1st Group tab.

7) You can create two more subtotal categories by using the 2nd Group and 3rd Group tabs and repeating steps 3 to 6. If you do not want to add more groups, then leave the Group by list for each page set to "- none -".

8) Click **OK**. Calc will add subtotal and grand total rows to your cell range.

For our sales data example, a partial view of the results is shown in Figure 296. The group settings are identified in Table 9.
Table 9: Group settings used on Subtotals dialog for example sales data

<table>
<thead>
<tr>
<th>Tab</th>
<th>Group by</th>
<th>Calculate subtotals for</th>
<th>Use function</th>
</tr>
</thead>
<tbody>
<tr>
<td>1st Group</td>
<td>Employee</td>
<td>Sales Value</td>
<td>Sum</td>
</tr>
<tr>
<td>2nd Group</td>
<td>Category</td>
<td>Sales Value</td>
<td>Sum</td>
</tr>
<tr>
<td>3rd Group</td>
<td>- none -</td>
<td>-</td>
<td>-</td>
</tr>
</tbody>
</table>

**Subtotal outline**

When you use the Subtotals tool, Calc inserts an outline to the left of the row number column. This outline represents the hierarchical structure of your subtotals, and can be used to hide or show data at different levels in the hierarchy using the numbered column indicators at the top of the outline or the group indicators, denoted by plus (+) and minus (-) signs.

This feature is useful if you have many subtotals, as you can simply hide low-level details, such as individual entries, to produce a high-level summary of your data. For more information on how to use outlines, see Chapter 2, Entering, Editing, and Formatting Data.

To turn off outlines, select **Data > Group and Outline > Remove Outline** from the Menu bar. To reinstate them, select **Data > Group and Outline > AutoOutline**.

Figure 296 shows the outline for our sales data example.

![Figure 296: Partial outlined view of sales data example with subtotals](image)
Column 1 represents the highest group level, the grand total over all employees. Columns 2 to 5 show descending group levels as follows:

- Column 2 represents the grand total over all categories.
- Column 3 represents the total for each employee.
- Column 4 represents the total for each category for an individual employee.
- Column 5 shows individual entries.

**Subtotals tool options**

Click on the *Options* tab of the Subtotals dialog to access the following settings:

**Groups**

Defines how subtotal data is organized.

- **Page break between groups** – inserts page breaks between each subtotal group so that each group displays on a separate page when you print the data.
- **Case sensitive** – prevents the tool from grouping entries by data labels that differ by case. In our sales data example, entries with "Brigitte" and “brigitte” under the Employee column will not match if this option is selected.
- **Pre-sort area according to groups** – sorts entries by group before calculating subtotals. Disabling this option prevents the tool from grouping matching entries together. As a result, distinct subtotals will be created for matching entries if they do not appear on consecutive rows. For example, two entries under the “Golf” category will not count towards the same group subtotal if there is an entry for “Tennis” in between them.

![Subtotals Options dialog](image)

**Figure 297: Options page of the Subtotals dialog**

**Sort**

Defines how subtotal data is sorted. This section is disabled if **Pre-sort area according to groups** is unchecked.

- **Ascending** or **Descending** – sorts entries by value from lowest to highest and highest to lowest, respectively. You can modify these sort rules by using *Data > Sort* in the Menu bar. For more detail, see Chapter 2, Entering, Editing, and Formatting Data.
- **Include formats** – carries over formatting, such as the currency format, from the data to the corresponding subtotals.
– **Custom sort order** – sorts your data according to one of the predefined custom sorts defined in **Tools > Options > LibreOffice Calc > Sort Lists** in the Menu bar. For more details about custom sort lists, see Chapter 2, Entering, Editing, and Formatting Data.

**Reset and Remove**

In the Subtotals dialog, use the **Reset** button to undo any changes made on the current tab page. Use the **Remove** button to remove any subtotals that have already been created using the Subtotals tool. Use these features with care, as no confirmation dialogs will be displayed.

**Using scenarios**

Scenarios are saved, named cell ranges that you can use to answer “what-if” questions about your data. You can create multiple scenarios for the same calculation set, then quickly swap between them to view the outcomes of each. This feature is useful if you need to test the effects of different conditions on your calculations, but do not want to deal with repetitive manual data entry. For example, if you wanted to test different interest rates for an investment, you could create scenarios for each rate, then switch between them to find out which rates work the best for you.

To use the Scenarios tool, select **Tools > Scenarios** from the Menu bar to open the Create Scenario dialog (Figure 298).

![Create Scenario dialog](image)

**Figure 298: Create Scenario dialog**

**Creating scenarios**

To create a new scenario:

1) Select the cells that contain the values that will change between scenarios. To select multiple ranges, hold down the *Ctrl* key as you click. You must select at least two cells.

2) Choose **Tools > Scenarios** from the Menu bar to open the Create Scenario dialog.

3) Enter a name for the new scenario in the **Name of Scenario** field.
Tip

For each scenario you create, use a unique name that clearly identifies and distinguishes it. This practice will save you time and headache if you have to work with a large set of scenarios.

4) Optionally, add information to the Comment field. The example in Figure 298 shows the default comment.

5) Click OK to close the dialog. The new scenario is automatically activated upon creation.

6) Repeat steps 1 to 5 to create additional scenarios. Select the same cell range that you used for the first scenario to have multiple scenarios for the same calculations.

Tip

To keep track of what calculations are dependent on your scenarios, use Tools > Detective > Trace Dependents from the Menu bar on your scenario cells. Arrows will point from your scenario cells to the dependent formula cells. For more information about the Detective tool, see Chapter 7, Using Formulas and Functions.

Scenario settings

The Settings sections of the Create Scenario dialog contains the following options:

Display border

Places a colored border around the cell range that contains your scenario (Figure 300).

![Figure 300: Scenario cell range with border](image)

To choose the color of the border, use the drop-down field to the right of this option. The border has a title bar displaying the name of the active scenario and a down arrow button.
that opens a drop-down list of all the scenarios defined for the current cell range. You can swap to a scenario by selecting it from this list.

**Copy back**
Copies any changes made to a scenario's cell values back into the active scenario. If you uncheck this option, then the scenario's initial values cannot be overwritten. The actual behavior of the **Copy back** setting depends on the current cell and sheet protections and the **Prevent changes** setting (see Table 11 on page 300).

![Caution](image)

When creating a new scenario from the cells of a scenario with **Copy back** enabled, be careful not to overwrite the old scenario. To avoid this situation, create the new scenario with **Copy back** enabled first, then change its values only once it is active.

**Copy entire sheet**
Creates a copy of the sheet with the new active scenario. The sheet is named after this scenario. Note that changing scenario values in the copy sheet will not affect the active scenario, even if it has **Copy back** enabled.

**Prevent changes**
Prevents changes to a scenario with **Copy back** enabled when the sheet is protected but the cells are not. Also prevents changes to the scenario's settings while the sheet is protected. This option and its effects are more fully explained in the next section.

**Changing scenarios**
Scenarios have two aspects that can be altered independently:

- Scenario properties (that is, its settings)
- Scenario cell values

The extent to which these aspects can be changed depends on the active scenario's properties and the current sheet and cell protections. For more detail about sheet and cell protections, see Chapter 2, Entering, Editing, and Formatting Data.

**Changing scenario properties**
Table 10 summarizes how sheet protection and the **Prevent changes** option affect your ability to change scenario properties.

<table>
<thead>
<tr>
<th>Sheet protection</th>
<th>Prevent changes</th>
<th>Property changes</th>
</tr>
</thead>
<tbody>
<tr>
<td>On</td>
<td>On</td>
<td>No scenario properties can be changed.</td>
</tr>
<tr>
<td>On</td>
<td>Off</td>
<td><strong>Display border</strong> and <strong>Copy back</strong> can be changed. <strong>Prevent changes</strong> and <strong>Copy entire sheet</strong> cannot be changed.</td>
</tr>
<tr>
<td>Off</td>
<td>Any setting</td>
<td>All scenario parameters except for <strong>Copy entire sheet</strong> can be changed. In this case, the <strong>Prevent changes</strong> option has no effect.</td>
</tr>
</tbody>
</table>

**Changing scenario cell values**
Table 11 summarizes the interaction of various settings in making changes to scenario cell values.
Table 11: Changing scenario cell values

<table>
<thead>
<tr>
<th>Sheet protection</th>
<th>Scenario cell protection</th>
<th>Prevent changes</th>
<th>Copy back</th>
<th>Change allowed</th>
</tr>
</thead>
<tbody>
<tr>
<td>On</td>
<td>Off</td>
<td>On</td>
<td>On</td>
<td>Scenario cell values cannot be changed.</td>
</tr>
<tr>
<td>On</td>
<td>Off</td>
<td>Off</td>
<td>On</td>
<td>Scenario cell values can be changed, and the scenario is updated.</td>
</tr>
<tr>
<td>On</td>
<td>Off</td>
<td>Any setting</td>
<td>Off</td>
<td>Scenario cell values can be changed, but the scenario is not updated due to the Copy back setting.</td>
</tr>
<tr>
<td>On</td>
<td>On</td>
<td>Any setting</td>
<td>Any setting</td>
<td>Scenario cell values cannot be changed.</td>
</tr>
<tr>
<td>Off</td>
<td>Any setting</td>
<td>Any setting</td>
<td>Any setting</td>
<td>Scenario cell values can be changed and the scenario is updated or not, depending on the Copy back setting.</td>
</tr>
</tbody>
</table>

Working with scenarios using the Navigator

After you add scenarios to a spreadsheet, you can view a particular scenario by using the Navigator. Open it by selecting View > Navigator from the Menu bar, then click on the Scenarios icon in the Navigator and select a scenario from the list (Figure 301). Any defined scenarios are listed along with the comments that were entered when each scenario was created. For more information about the Navigator, see Chapter 1, Introduction.

![Navigator](image)

Figure 301: Scenarios in the Navigator

To apply a scenario to the current sheet, double-click the scenario name in the Navigator.

To delete a scenario, right-click the name in the Navigator and choose Delete. A confirmation dialog will be displayed.
To edit a scenario, right-click the name in the Navigator and choose Properties. Calc displays the Edit Scenario dialog, which is similar to the Create Scenario dialog (Figure 298).

**Using the Multiple Operations tool**

Like scenarios, the Multiple Operations tool performs what-if analysis on your calculations. Unlike scenarios, which represent individual sets of values for multiple formula variables, this tool uses a whole range of values for just one or two variables. It then uses one or more formulas to create a matching range of solutions. Since each solution corresponds to one or two variable values, both the variable and solution ranges can be easily arrayed in tabular format. As a result, the Multiple Operations tool is well-suited to generating data that easy to read and share or visualize using graphs.

**Tip**

Exercising good organization can make using this tool relatively painless. For example, we recommend keeping your data together on one sheet and using labels to identify your formulas, variables, and table ranges.

To use this tool, select Data > Multiple Operations from the Menu bar to open the Multiple Operations dialog (Figure 302).

![Multiple Operations dialog](image)

**Multiple Operations with one formula and one variable**

The easiest way to learn how to use the Multiple Operations tool is with one formula and one variable. To learn how to use the tool with multiple formulas or with two variables, see “Calculating with several formulas simultaneously” (page 303) and “Multiple operations with two variables” (page 305), respectively.

To use the Multiple Operations tool with one formula and one variable:

1) In the cells of a worksheet, enter a formula and at least one variable that it uses.

2) In the same worksheet, enter values into a cell range that occupies a single column or row. These values will be used for one of the variables of the formula that you defined in step 1.

3) With the mouse, select the range containing both the variable range that you defined in step 2 and the adjacent empty cells that follow it. Depending on how your variable range is arrayed, these empty cells will either be in the column to the right (if the range is in a column) or in the row immediately below (if it is in a row).

4) Select Data > Multiple Operations to open the Multiple Operations dialog.
5) Click on the Formulas field and type a cell reference to the formula you defined in step 1 or select the cell with the mouse. Use the associated Shrink / Expand button if you need to minimize the dialog while selecting the cell.

6) If the range from step 2 is arrayed in a column, then click on the Column input cell field and type a cell reference to the variable that you want to use or select the cell with the mouse. If the range is in a row, then use the Row input cell field instead.

7) Click OK to run the tool. The Multiple Operations tool will generate its results in the empty cells that you selected in step 3. Each result value corresponds to the variable value adjacent to it, and together they form the entries of a results table.

An example with one formula and one variable

Using the Multiple Operations tool is best explained by example. Suppose that you produce toys that you sell for $10 each (cell B1 of a worksheet). Each toy costs $2 to make (B2), and you have a fixed annual cost of $10,000 (B3). What is the minimum number of toys that you must sell to break even? Suppose that our initial estimate of quantity sold is 2,000 (B4).

To answer this question:

1) Enter the following formula into B5: =B4*(B1-B2)-B3. This formula represents the equation \( \text{Profit} = \text{Quantity} \times (\text{Selling price} - \text{Direct costs}) - \text{Fixed costs} \). With this equation, our initial quantity produces a $6,000 profit, which is higher than the break-even point.

2) In D2:D11, enter a range of alternate quantities from 500 to 5000 in steps of 500.

3) Select the range D2:E11 to define the results table. This range includes the alternate quantity values (column D) and the empty results cells (column E).

4) Select Data > Multiple Operations to open the Multiple Operations dialog.

5) Using the Formulas field, select the cell B5.

![Figure 303: Inputs to Multiple Operations tool for one formula, one variable](image)
6) Using the Column input cell field, select the cell B4 to set the quantity as the variable for our calculations. Figure 303 shows the worksheet and Multiple Operations dialog at this point.

7) Click OK. The profits for the different quantities are now shown in column E (Figure 304). We can see that the break-even point is between 1000 and 1500 toys sold – namely, 1250.

![Figure 304: Results of Multiple Operations tool for one formula and one variable](image)

Profit over quantity

![Figure 305: XY scatterplot of profit over quantity of toys sold (example of visualization)](image)

**Calculating with several formulas simultaneously**

Using the Multiple Operations tool with multiple formulas follows nearly the same process as with one formula, but with two important differences:

1) For each formula that you add, you must also add a corresponding column or row to the results table to contain the output of that formula.

2) How you initially arrange your formulas determines how their results will be displayed in the results table. For example, if you arrange the formulas A, B, and C in a single row in that order, then Calc will generate the results of A in the first results table column, the results of B in the second column, and the results of C in the third.
Note

The Multiple Operations tool only accepts formulas arranged in a single row or column, depending on how your results table is oriented. If the table is column-oriented – that is, the way it is in our sales data example – then your formulas must be arranged in a row. If the table is row-oriented, then your formulas must be in a column.

Caution

Be careful not to add empty cells between formulas, as they will create gaps in the results table and may cause some results not to appear if you don’t select enough rows or columns for the table.

An example with two formulas and one variable

Using our sales data example, suppose that we want to calculate the annual profit per item sold in addition to the annual overall profit. To calculate the results:

1) In the sheet from the previous example, delete the results in column E.
2) Enter the following formula in C5: =B5/B4. You are now calculating the annual profit per item sold.
3) Select the range D2:F11 for the results table. Column F will contain the results of the annual profit per item formula in C5.
4) Select Data > Multiple Operations from the Menu bar to open the Multiple Operations dialog.
5) Using the Formulas field, select the range B5:C5.
6) Using the Column input cell field, select the cell B4. Figure 306 shows the worksheet and the dialog at this point.
7) Click OK. Now the profits are listed in column E and the annual profit per item in column F.

\[
\text{F1} = \text{SUMIFS(C5,S84,S11)}
\]

![Figure 307: Results of Multiple Operations tool for one variable and two formulas](image)

**Multiple operations with two variables**

When you use the Multiple Operations tool with two variables, it creates a two-dimensional results table. Each variable defines one of the table’s dimensions such that the alternate values for both variables serve as the table’s row and column headings, respectively. Each cell in the table corresponds to a distinct pair of row and column heading values. In turn, the results in each cell are created from these values for both variables.

Since you are using two variables, you must use both the **Column input cell** and **Row input cell** dialog fields to define them. The order is important; the **Column input cell** field corresponds to the row heading values, while the **Row input cell** field corresponds to the column heading values.

**Tip**

A good guideline to remember is that since column headings are in a row at the top of the table, they correspond to the **Row input cell** field. Likewise, row headings are in a column, so they correspond to the **Column input cell** field.

**Note**

If you use two variables, the Multiple Operations tool will not work with multiple formulas. It will allow you to enter the extra formulas, but will not generate the expected results for any formula beyond the first.

**Calculating with two variables**

Using our sales example, suppose that in addition to varying the quantity of toys sold, you also want to vary the unit sale price as well. To calculate the results:

1) Expand the sales data table by entering $8, $10, $15 and $20 in the range E1:H1.

2) Select the range D1:H11 for the results table.

3) Select **Data > Multiple Operations** from the Menu bar to open the Multiple Operations dialog.

4) Using the **Formulas** field, select cell B5.

5) Using the **Row input cell** field, select cell B1. The column headings – $8, $10, $15 and $20 – are now linked to the unit sale price variable defined in cell B1.
6) Using the Column input cell field, select cell B4. The row headings – 500, 1000, ..., 5000 – are now linked to the quantity sold variable defined in cell B4. Figure 308 shows the worksheet and dialog at this point.

7) Click OK. The profits for the different sale prices and quantities are now shown in the range E2:H11 (Figure 306).

---

### Using Goal Seek

In addition to scenarios and the Multiple Operations tool, Calc has a third “what-if” analysis tool: Goal Seek. Usually, you use a formula to calculate a result from existing values. In contrast, with Goal Seek, you work backwards from a result to discover what values produce it. This feature is useful if you already know the outcome you want, but need to answer questions such as how to reach it or how it could be changed if you altered conditions.

To use this tool, select Tools > Goal Seek from the Menu bar to open the Goal Seek dialog (Figure 310).
Note

Only one argument can be altered at a time in a single goal seek. If you need to test multiple arguments, then you must run a separate goal seek on each one.

Goal Seek example

To illustrate how to use Goal Seek, suppose that we want to calculate the annual interest return for an account. To calculate annual interest ($I$), we must create a table with values for the capital ($C$), the interest period length in years ($n$), and the interest rate ($i$). The formula is $I = C \times n \times i$.

Suppose that the interest rate $i = 7.5\%$ (cell B3 of a worksheet) and the period length $n = 1$ (B2) remain constant. We want to know how much investment capital $C$ is needed to achieve a return of $I = 15,000$. Assume that our initial capital estimate is $C = 100,000$ (B1).

To calculate the return:

1) Enter the return formula (=B1*B2*B3) into B4 and select the cell with the mouse.
2) Select Tools > Goal Seek from the Menu bar to open the Goal Seek dialog.
3) B4 should already be entered in the Formula cell field. However, if you want to select a different cell, use the associated Shrink / Expand button to minimize the dialog while you select the required cell.
4) Click on the Variable cell field, then type a reference to cell B1 or select it with the mouse to make the capital the variable in the current Goal Seek.
5) Enter the desired formula result in the Target value field. In this example, the value is 15000. Figure 311 shows the cells and dialog fields at this point.
6) Click OK. A dialog appears informing you that the goal seek was successful (Figure 312).

![Goal seek result dialog](image)

Figure 312: Goal seek result dialog

7) Click Yes to enter the goal value into the variable cell. The result is shown in Figure 313, indicating that a capital requirement of $200,000 is needed to achieve a $15,000 return.

![Result of goal seek in worksheet](image)

Figure 313: Result of goal seek in worksheet

**Note**

Not every goal seek problem succeeds in returning a good result. It depends on the formula used, goal value, and initial value. The goal seek algorithm iterates internally several times converging to the goal.

### Using the Solver

The Solver amounts to a more elaborate form of goal seek, which allows you to solve mathematical programming or optimization problems. A mathematical programming problem is concerned with minimizing or maximizing a function subject to a set of constraints. Such problems arise in many scientific, engineering, business, and other disciplines. A full discussion of mathematical programming is beyond the scope of this guide and the interested reader is referred to the relevant Wikipedia page at [https://en.wikipedia.org/wiki/Mathematical_optimization](https://en.wikipedia.org/wiki/Mathematical_optimization), which provides high level information and references to more detailed materials.

Currently Calc offers the following selection of solver engines:

- DEPS (Differential Evolution & Particle Swarm Optimization) Evolutionary Algorithm.
- SCO (Social Cognitive Optimization) Evolutionary Algorithm.
- LibreOffice CoinMP Linear Solver.
- LibreOffice Linear Solver.
- LibreOffice Swarm Non-Linear Solver (experimental).

**Caution**

As the LibreOffice Swarm Non-Linear Solver is an experimental tool, it may not be supported in future versions of Calc, and we recommend that you do not use it unless you are familiar with non-linear programming concepts.

The DEPS and SCO Evolutionary Algorithms are intended for solving non-linear problems and are only available if you have selected **Tools > Options > LibreOffice > Advanced > Use a Java**
The DEPS Evolutionary Algorithm is the initial default if it is available, while LibreOffice CoinMP Linear Solver is the initial default otherwise.

The available options provide flexibility to choose the most suitable algorithm for a given problem, which may be linear or non-linear, and a given performance requirement.

In order to use the Solver to solve a mathematical programming problem, you must formulate the problem as follows:

- **Decision variables** – a set of $n$ non-negative variables $x_1, \ldots, x_n$. Decision variables may be real numbers, but generally tend to be integers in many real world problems.
- **Constraints** – a set of linear equalities or inequalities involving the decision variables.
- **Objective function** – a linear expression involving the decision variables.

The goal is usually to find values of the decision variables that satisfy the constraints and maximize or minimize the result of the objective function.

**Solver dialog**

After setting up the data for the problem in your Calc spreadsheet, select **Tools > Solver** from the Menu bar to open the Solver dialog (Figure 314).

![Solver dialog](image)
Note

Depending on the configuration of your computer, a message may be displayed the first time that you select Tools > Solver after starting Calc. The nature of this message will change dependent on the existence of a Java runtime environment (JRE) on your system. If no JRE is detected, the message will simply be a warning to that effect. In the case where a JRE is detected but the Tools > Options > LibreOffice > Advanced > Use a Java runtime environment option is disabled, then the message will include a button to enable that option.

Target cell
Type a cell reference to the objective function or select it with the mouse.

Optimize result to
Select Maximum to find the maximum result for the objective function, Minimum to find the minimum result, or Value of to set it to a specific value. If you select Value of, enter the required value or a reference to the cell containing that value.

By changing cells
Enter the locations of any cells that define your decision variables.

Limiting Conditions
Enter your constraints in the fields in this area:

- Cell reference – enter a cell reference to a decision variable.
- Operator – defines a parameter for a constraint. Available options include <= (less than or equal to), = (equal to), => (greater than or equal to), Integer (values without decimals), and Binary (only 0 or 1).
- Value – enter a value or a cell reference to a constraint formula.
- Remove button – deletes the currently-defined constraint.

Tip
Remember that for any of these options, you can minimize the Solver dialog using the associated Shrink / Expand buttons if you need to select cells with the mouse.

Once you have finished setting up the Solver, click the Solve button to begin the process of adjusting values and calculating results. Depending on the complexity of the task, this may take some time. On successful completion, Calc presents a Solving Result dialog (Figure 315). This dialog includes buttons to save (Keep Result) or discard (Restore Previous) your results.

Figure 315: Solving Result dialog
The Solver dialog also has an **Options** button, which opens the Options dialog shown in Figure 316.

**Solver options**

![Options dialog](image)

**Figure 316: Solver Options dialog**

### Solver engine

With the standard LibreOffice download, and an enabled Java runtime environment, the **Solver engine** drop-down list provides five options:

- **DEPS Evolutionary Algorithm**
- **SCO Evolutionary Algorithm**
- **LibreOffice CoinMP Linear Solver**
- **LibreOffice Linear Solver**
- **LibreOffice Swarm Non-Linear Solver (experimental)**

### Settings

This area enables the user to adjust the detailed processing parameters of the selected solver engine, and the options available vary between engines.

### Solver example

Suppose that you have $10,000 that you want to invest in two mutual funds for one year. Fund X is a low risk fund with an 8% interest rate and Fund Y is a higher risk fund with a 12% interest rate. How much money should be invested in each fund to earn a total interest of $1,000?

To find the answer using the Solver:

1) Enter the following labels and data into a worksheet:
   - Row labels: **Fund X**, **Fund Y**, and **Total** in cells A2, A3, and A4.
   - Column labels: **Interest earned**, **Amount invested**, **Interest rate**, and **Time period** in cells B1 thru E1.
   - Interest rates: 8% and 12% in cells D2 and D3.
   - Time period: 1 in cells E2 and E3.
   - Total amount invested: $10000 in cell C4.
   - Enter an arbitrary value ($0 or leave blank) in cell C2 as the amount invested in Fund X.
2) Enter the following formulas:
   – In cell C3, enter the formula =C4–C2 (total amount – amount invested in Fund X) as the amount invested in Fund Y.
   – In cells B2 and B3, enter the formulas =C2*D2*E2 (B2) and =C3*D3*E3 (B3).
   – In cell B4, enter the formula =B2+B3 as the total interest earned. Figure 317 shows the worksheet at this point.

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td>Interest earned</td>
<td>Amount invested</td>
<td>Interest rate</td>
<td>Time period</td>
</tr>
<tr>
<td>2</td>
<td>Fund X</td>
<td>$0</td>
<td>$0</td>
<td>8%</td>
<td>1</td>
</tr>
<tr>
<td>3</td>
<td>Fund Y</td>
<td>$1,200</td>
<td>$10,000</td>
<td>12%</td>
<td>1</td>
</tr>
<tr>
<td>4</td>
<td>Total</td>
<td>$1,200</td>
<td>$10,000</td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Figure 317: Solver example setup

3) Select Tools > Solver from the Menu bar to open the Solver dialog (Figure 314).

4) Using the Target cell field, select the cell that contains the target value. In this example, it is B4, which contains the total interest value.

5) Select Value of and enter 1000 in the field next to it. In this example, the target cell value is 1000 because your target is a total interest earned of $1,000.

6) Using the By changing cells field, select cell C2 in the sheet. In this example, you need to find the amount invested in Fund X (cell C2).

7) Enter the following limiting conditions for the variables by using the Cell reference, Operator, and Value fields:
   – C2 <= C4 – the amount invested in Fund X cannot exceed the total amount available.
   – C2 => 0 – the amount invested in Fund X cannot be negative.
   – C2 is an Integer – specified for convenience.

8) Click Solve. The result is shown in Figure 318.

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td>Interest earned</td>
<td>Amount invested</td>
<td>Interest rate</td>
<td>Time period</td>
</tr>
<tr>
<td>2</td>
<td>Fund X</td>
<td>$400</td>
<td>$5,000</td>
<td>8%</td>
<td>1</td>
</tr>
<tr>
<td>3</td>
<td>Fund Y</td>
<td>$500</td>
<td>$5,000</td>
<td>12%</td>
<td>1</td>
</tr>
<tr>
<td>4</td>
<td>Total</td>
<td>$1,000</td>
<td>$10,000</td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Figure 318: Solver example result

Using Statistics tools

Under Data > Statistics in the Menu bar, Calc features several tools for quick and easy statistical analysis of your data. These tools include:

- Sampling
- Descriptive Statistics
- Analysis of Variance (ANOVA)
- Correlation
- Covariance
- Exponential Smoothing
- Moving Average
- Regression
- Paired t-test
- F-test
- z-test
- Test of Independence (Chi-square)
- Fourier Analysis

**Sampling tool**

The Sampling tool creates a target table with data sampled from a source table. The sampling tool can pick samples randomly or on a periodic basis. Sampling is done row-wise, with whole rows of the source table copied into rows of the target table. To use this tool, select **Data > Statistics > Sampling** from the Menu bar to access the Sampling dialog (Figure 319).

![Sampling dialog](image)

**Figure 319: Sampling dialog**

**Input range**
- Specifies the cell range containing the source table.

**Results to**
- Specifies the top left cell of the target table. When you run the tool, it will fill out the rest of the target table starting from this cell.

**Random**
- Enables random sampling mode when selected.

**Sample size**
- Defines the number of lines to be sampled from the source table during random sampling. Only available if the **Random** option is selected. If **With replacement** is deselected, the maximum value that can be entered in this field is limited to the number of rows in the source table.
**With replacement**
If this option is selected, a sample drawn from the source table is effectively returned and so is eligible for re-sampling later. In this case, the sample size can be larger than the number of rows in the source table. If the option is deselected, a sample drawn from the source table is not eligible for re-sampling later. In this case, the sample size is limited to the number of rows in the source table. This option is automatically deselected for periodic sampling. It is not possible to have both **With replacement** and **Keep order** options selected simultaneously.

**Keep order**
If this option is selected, samples are drawn from the source table in order of the data in the source table. If deselected, samples are drawn in random order from the source table. This option is automatically selected for periodic sampling. It is not possible to have both **With replacement** and **Keep order** options selected simultaneously.

**Periodic**
Enables periodic sampling mode when selected.

**Period**
Defines the number of lines to skip between samples during periodic sampling. For example, a value of 2 will cause alternate lines to be sampled from the source table, starting with the second line. Only available if the **Periodic** option is selected. The maximum value that can be entered in this field is limited to the number of rows in the source table.

---

**Tip**
Use the **Shrink / Expand** buttons next to the **Input range** and **Results to** fields if you need to shrink the dialog while selecting cells with the mouse.

Figure 320 shows the source table (below the **Source Data** heading) and the corresponding target table (under the **Target Data** heading), sampled using the settings shown in Figure 319.

![Figure 320: Example data for the Sampling tool](image)

---

**Descriptive Statistics tool**
Given a set of data, the Descriptive Statistics tool creates a tabular report of a data set's primary statistical properties, such as information about its central tendency and variability. Select **Data > Statistics > Descriptive Statistics** in the Menu bar to access the Descriptive Statistics dialog (Figure 321).
Figure 321: Descriptive Statistics dialog

**Input range**
Specifies the cell range containing the source data.

**Results to**
Specifies the top left cell of the results area. When you run the tool, it will fill out the rest of the report table starting at this cell.

**Columns / Rows**
Specifies whether the data to be analyzed is organized in columns or rows.

**Tip**
Use the Shrink / Expand buttons next to the Input range and Results to fields if you need to shrink the dialog while selecting cells with the mouse.

Figure 322 shows a small data set comprising student examination results in three subjects.

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Maths</td>
<td>Physics</td>
<td>Biology</td>
</tr>
<tr>
<td>2</td>
<td>47</td>
<td>67</td>
<td>53</td>
</tr>
<tr>
<td>3</td>
<td>36</td>
<td>68</td>
<td>42</td>
</tr>
<tr>
<td>4</td>
<td>40</td>
<td>65</td>
<td>44</td>
</tr>
<tr>
<td>5</td>
<td>39</td>
<td>64</td>
<td>60</td>
</tr>
<tr>
<td>6</td>
<td>47</td>
<td>58</td>
<td>43</td>
</tr>
<tr>
<td>7</td>
<td>47</td>
<td>84</td>
<td>62</td>
</tr>
<tr>
<td>8</td>
<td>29</td>
<td>60</td>
<td>51</td>
</tr>
<tr>
<td>9</td>
<td>27</td>
<td>49</td>
<td>40</td>
</tr>
<tr>
<td>10</td>
<td>57</td>
<td>49</td>
<td>12</td>
</tr>
<tr>
<td>11</td>
<td>56</td>
<td>33</td>
<td>60</td>
</tr>
<tr>
<td>12</td>
<td>57</td>
<td></td>
<td></td>
</tr>
<tr>
<td>13</td>
<td>26</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

*Figure 322: Input data for descriptive statistics analysis*

Figure 323 shows the statistics report generated for this input data using the settings shown in Figure 321.
Analysis of Variance (ANOVA) tool

The Analysis of Variance (ANOVA) tool compares the means of two or more groups in a sample. Select Data > Statistics > Analysis of Variance (ANOVA) in the Menu bar to access the Analysis of Variance (ANOVA) dialog (Figure 324).

![Analysis of Variance (ANOVA) dialog](image)

**Figure 324: Analysis of Variance (ANOVA) dialog**
Input range
- Specifies the cell range containing the source data.

Results to
- Specifies the top left cell of the results area. When you run the tool, it will fill out the analysis of variance report table starting at this cell.

Single / Two factor
- Determines whether the analysis is for single factor or two factor ANOVA.

Columns / Rows
- Specifies whether the data to be analyzed is organized in columns or rows. Only available if Single factor is selected.

Alpha
- In this field, enter a significance level in the range 0.01 to 0.99. The default is 0.05.

Rows per sample
- Defines how many rows a sample has. This option is always set to 1 in this version of Calc.

To illustrate how to use this tool, we use the input data set from Figure 322. Figure 325 shows the analysis of variance results generated for this data using the settings shown in Figure 324.

![ANOVA - Single Factor](image)

Figure 325: Results from Analysis of Variance (ANOVA) tool

Tip

Correlation tool
The Correlation tool calculates the correlation of two sets of numeric data and generates the resulting correlation coefficient. This coefficient is a value between -1 and +1 that indicates how strongly two variables are related to each other. A correlation coefficient of +1 indicates a perfect positive correlation (the data sets match) and a coefficient of -1 indicates a perfect negative correlation (the data sets are inverse to each other). Select **Data > Statistics > Correlation** in the Menu bar to access the Correlation dialog (Figure 326).

Input range
- Specifies the cell range containing the source data.

Results to
- Specifies the top left cell of the results area. When you run the tool, it will fill out the correlation coefficient table starting at this cell.
Columns / Rows
Specifies whether the data to be analyzed is organized in columns or rows.

Figure 326: Correlation dialog

To illustrate how to use this tool, we again use the data set from Figure 322. Figure 327 shows the six correlation coefficients generated for this input data using the settings shown in Figure 326.

Figure 327: Correlation results

Tip
For more information on statistical correlation, refer to the corresponding Wikipedia article at https://en.wikipedia.org/wiki/Correlation_and_dependence.

Covariance tool
The Covariance tool measures how much two sets of numeric data vary together. Select Data > Statistics > Covariance in the Menu bar to access the Covariance dialog (Figure 328).

Figure 328: Covariance dialog
Input range
Specifies the cell range containing the source data.

Results to
Specifies the top left cell of the results area. When you run the tool, it will fill out the covariance table starting at this cell.

Columns / Rows
Specifies whether the data to be analyzed is organized in columns or rows.

To illustrate how to use this tool, we again use the data set from Figure 322. Figure 329 shows the six covariance values generated for this input data using the settings shown in Figure 328.

<table>
<thead>
<tr>
<th></th>
<th>E</th>
<th>F</th>
<th>G</th>
<th>H</th>
</tr>
</thead>
<tbody>
<tr>
<td>Covariances</td>
<td>Column 1</td>
<td>Column 2</td>
<td>Column 3</td>
<td></td>
</tr>
<tr>
<td>Column 1</td>
<td>126.80997</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Column 2</td>
<td>-61.444444</td>
<td>258.41</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Column 3</td>
<td>-32</td>
<td>53.11</td>
<td>204.61</td>
<td></td>
</tr>
</tbody>
</table>

Figure 329: Covariance results

Tip
For more information on statistical covariance, refer to the corresponding Wikipedia article at https://en.wikipedia.org/wiki/Covariance.

Exponential Smoothing tool
The Exponential Smoothing tool filters a data set to produce smoothed results. It is used in domains such as stock market analysis and in sampled measurements. Select Data > Statistics > Exponential Smoothing in the Menu bar to access the Exponential Smoothing dialog (Figure 330).

Exponential Smoothing

Data
Input range: $Sheet1!$A$1:$B$13
Results to: $D$1

Grouped by
- Columns
- Rows

Parameters
Smoothing factor: 0.50

Figure 330: Exponential Smoothing dialog

Input range
Specifies the cell range containing the source data.

Results to
Specifies the top left cell of the results area. When you run the tool, it will generate smoothed results starting at this cell.
Columns / Rows
Specifies whether the data to be analyzed is organized in columns or rows.

Smoothing factor
Enter a value here between 0 and 1 (default is 0.2) that represents the damping factor alpha in the smoothing equation.

To illustrate how to use this tool, we use the data set shown in Figure 331. The table has two time series representing impulse functions at times $t=0$ and $t=2$.

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1</td>
<td>0</td>
</tr>
<tr>
<td>2</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>3</td>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>4</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>5</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>6</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>7</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>8</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>9</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>10</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>11</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>12</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>13</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>

*Figure 331: Input data set for exponential smoothing example*

Figure 332 shows the smoothed results for this input data using the settings shown in Figure 330.

<table>
<thead>
<tr>
<th>D</th>
<th>E</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alpha</td>
<td>0.5</td>
</tr>
<tr>
<td>Column 1</td>
<td>Column 2</td>
</tr>
<tr>
<td>1</td>
<td>0</td>
</tr>
<tr>
<td>1</td>
<td>0</td>
</tr>
<tr>
<td>0.25</td>
<td>0.5</td>
</tr>
<tr>
<td>0.125</td>
<td>0.25</td>
</tr>
<tr>
<td>0.0625</td>
<td>0.125</td>
</tr>
<tr>
<td>0.03125</td>
<td>0.0625</td>
</tr>
<tr>
<td>0.015625</td>
<td>0.03125</td>
</tr>
<tr>
<td>0.0078125</td>
<td>0.015625</td>
</tr>
<tr>
<td>0.00390625</td>
<td>0.0078125</td>
</tr>
<tr>
<td>0.001953125</td>
<td>0.00390625</td>
</tr>
<tr>
<td>0.0009765625</td>
<td>0.001953125</td>
</tr>
<tr>
<td>0.00048828125</td>
<td>0.0009765625</td>
</tr>
<tr>
<td>0.000244140625</td>
<td>0.00048828125</td>
</tr>
</tbody>
</table>

*Figure 332: Results from Exponential Smoothing tool*

Tip
Moving Average tool

The Moving Average tool calculates the moving average of a time series data set. Select Data > Statistics > Moving Average in the Menu bar to access the Moving Average dialog (Figure 333).

![Moving Average dialog]

**Figure 333: Moving Average dialog**

- **Input range**
  Specifies the cell range containing the source data.

- **Results to**
  Specifies the top left cell of the results area. When you run the tool, it will generate the moving average results starting at this cell.

- **Trim input range to actual data content**
  Specifies whether to allow trimming of the input range to the actual data content before computing the moving average. Enabled by default to provide better performance.

- **Columns / Rows**
  Specifies whether the data to be analyzed is organized in columns or rows.

- **Interval**
  Specifies the number of samples used in the moving average calculation.

To illustrate how to use this tool, we again use the data set from Figure 331. Figure 334 shows the moving averages calculated for this input data using the settings shown in Figure 333.
Regression tool

The Regression tool analyzes the relationship in a data set between one or more independent variables and a dependent variable. Select Data > Statistics > Regression in the Menu bar to access the Regression dialog (Figure 335).

**Independent variable(s) (X) range**
Specifies the cell range containing the independent variables in the source data.

**Dependent variable (Y) range**
Specifies the cell range containing the dependent variable in the source data.

**Both X and Y ranges have labels**
Specifies whether the ranges above include data labels.

**Results to**
Specifies the top left cell of the results area. When you run the tool, it will generate the regression analysis table starting at this cell.

**Columns / Rows**
Specifies whether the data to be analyzed is organized in columns or rows.

**Linear Regression**
Select this option to use linear regression. Linear regression finds a straight line in the form of \( y = (a \times x) + b \) that best fits the data, where \( a \) is the slope and \( b \) is the intercept.

**Logarithmic Regression**
Select this option to use logarithmic regression. Logarithmic regression finds a logarithmic curve in the form of \( y = (a \times \ln(x)) + b \) that best fits the data, where \( a \) is the slope, \( b \) is the intercept and \( \ln(x) \) is the natural logarithm of \( x \).

**Power Regression**
Select this option to use power regression. Power regression finds a power curve in the form of \( y = (a \times x)^b \) that best fits the data, where \( a \) is the coefficient and \( b \) is the exponent.

---

Tip
For more information on the moving average, refer to the corresponding Wikipedia article at https://en.wikipedia.org/wiki/Moving_average.
Confidence level
Specifies the confidence level, which is a value between 0 and 1. The default value is 0.95.

Calculate residuals
Specifies whether to calculate residuals.

Force intercept to be zero
Specifies whether to force the regression intercept to be 0.

Tip
Use the Shrink / Expand buttons next to the Independent variable(s) (X) range, Dependent variable (Y) range, and Results to fields if you need to shrink the dialog while selecting cells with the mouse.

To illustrate how to use this tool, we use the data set shown in Figure 336. This table contains measurements taken at 1 second intervals.
Figure 336: Input data set for regression analysis

Figure 337 shows the regression outputs calculated for this input data using the settings shown in Figure 335.

Tip

For more information on regression analysis, refer to the corresponding Wikipedia article at https://en.wikipedia.org/wiki/Regression_analysis.
Paired T-test tool

The Paired T-test tool compares the population means of two related sample sets and determines the difference between the two. Select Data > Statistics > Paired t-test in the Menu bar to access the Paired t-test dialog (Figure 338).

**Variable 1 range**
Specifies the cell range containing the first set of input data.

**Variable 2 range**
 Specifies the cell range containing the second set of input data.

**Results to**
Specifies the top left cell of the results area. When you run the tool, it will generate the paired t-test table starting at this cell.
Columns / Rows
Specifies whether the data to be analyzed is organized in columns or rows.

![Paired t-test dialog](image)

**Figure 338: Paired t-test dialog**

To provide an example of using this tool, we make use of the input data set shown in Figure 339. The data sets in columns A and B represent two sets of paired values referred to as *Variable 1* and *Variable 2*.

![Input data for paired t-test example](image)

**Figure 339: Input data for paired t-test example**

Figure 340 shows the paired t-test results calculated for this input data using the settings shown in Figure 338.

Tip
For more information on paired t-tests, refer to the corresponding Wikipedia article at [https://en.wikipedia.org/wiki/Student's_t-test](https://en.wikipedia.org/wiki/Student's_t-test).
F-test tool

The F-test tool calculates the F-Test of two data samples. The tool is used to test the hypothesis that the variance of two populations are equal. Click **Data > Statistics > F-test** in the Menu bar to access the F-test dialog shown in Figure 341 and define the required inputs to the tool.

**Variable 1 range**
Specifies the cell range containing the first set of input data.

**Variable 2 range**
Specifies the cell range containing the second set of input data.

**Results to**
Specifies the top left cell of the results area. When you run the tool, it will generate the F-test table starting at this cell.

**Columns / Rows**
Specifies whether the data to be analyzed is organized in columns or rows.

---

**Figure 340: Results from Paired T-test tool**

<p>| | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Paired t-test</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Alpha</td>
<td>0.05</td>
<td></td>
</tr>
<tr>
<td>Hypothesised Mean Difference</td>
<td>0</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td><strong>Variable 1</strong></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Mean</td>
<td>16.923077</td>
<td>20.461538</td>
</tr>
<tr>
<td>Variance</td>
<td>125.076923</td>
<td>94.435897</td>
</tr>
<tr>
<td>Observations</td>
<td>13</td>
<td>13</td>
</tr>
<tr>
<td>Pearson Correlation</td>
<td>-0.061754</td>
<td></td>
</tr>
<tr>
<td>Observed Mean Difference</td>
<td>-3.538462</td>
<td></td>
</tr>
<tr>
<td>Variance of the Differences</td>
<td>232.935897</td>
<td></td>
</tr>
<tr>
<td>df</td>
<td>12</td>
<td></td>
</tr>
<tr>
<td>t Stat</td>
<td>-0.835926</td>
<td></td>
</tr>
<tr>
<td>P (T&lt;=t) one-tail</td>
<td>0.209765</td>
<td></td>
</tr>
<tr>
<td>t Critical one-tail</td>
<td>1.782288</td>
<td></td>
</tr>
<tr>
<td>P (T&lt;=t) two-tail</td>
<td>0.419530</td>
<td></td>
</tr>
<tr>
<td>t Critical two-tail</td>
<td>2.178813</td>
<td></td>
</tr>
</tbody>
</table>

**F-test tool**

<p>| | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**Figure 341: F-test dialog**
Tip

Use the **Shrink / Expand** buttons next to the **Variable 1 range**, **Variable 2 range**, and **Results to** fields if you need to shrink the dialog while selecting cells with the mouse.

To illustrate how to use this tool, we again use the data set from Figure 339. In this case, the data in columns A and B represent two independent sample sets, referred to as **Variable 1** and **Variable 2**. Figure 342 shows the F-test results calculated for this input data using the settings shown in Figure 341.

<table>
<thead>
<tr>
<th></th>
<th>F-test</th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>Alpha</td>
<td></td>
<td>0.05</td>
</tr>
<tr>
<td>Mean</td>
<td>Variable 1</td>
<td>16.923077</td>
<td></td>
</tr>
<tr>
<td>Variable 2</td>
<td>20.461538</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Variance</td>
<td>125.076023</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>04.435897</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Observations</td>
<td>13</td>
<td>13</td>
<td></td>
</tr>
<tr>
<td>df</td>
<td>12</td>
<td>12</td>
<td></td>
</tr>
<tr>
<td>F</td>
<td>1.324464</td>
<td></td>
<td></td>
</tr>
<tr>
<td>P (F&lt;=f) right-tail</td>
<td>0.317061</td>
<td></td>
<td></td>
</tr>
<tr>
<td>F Critical right-tail</td>
<td>2.686637</td>
<td></td>
<td></td>
</tr>
<tr>
<td>P (F&lt;=f) left-tail</td>
<td>0.682939</td>
<td></td>
<td></td>
</tr>
<tr>
<td>F Critical left-tail</td>
<td>0.372213</td>
<td></td>
<td></td>
</tr>
<tr>
<td>P two-tail</td>
<td>0.634123</td>
<td></td>
<td></td>
</tr>
<tr>
<td>F Critical two-tail</td>
<td>0.305131</td>
<td>3.277277</td>
<td></td>
</tr>
</tbody>
</table>

*Figure 342: Results from F-test tool*

Tip


**Z-test tool**

The Z-test tool calculates the Z-test of two data samples. The tool performs a two sample Z-test to test the null hypothesis that there is no difference between the means of the two data sets. Click **Data > Statistics > Z-test** in the Menu bar to access the z-test dialog shown in Figure 343 and define the required inputs to the tool.

**Variable 1 range**

Specifies the cell range containing the first set of input data.

**Variable 2 range**

Specifies the cell range containing the second set of input data.

**Results to**

Specifies the top left cell of the results area. When you run the tool, it will generate the Z-test table starting at this cell.

**Columns / Rows**

Specifies whether the data to be analyzed is organized in columns or rows.

Tip

Use the **Shrink / Expand** buttons next to the **Variable 1 range**, **Variable 2 range**, and **Results to** fields if you need to shrink the dialog while selecting cells with the mouse.
To provide an example of using this tool, we again make use of the input data set shown in Figure 339. In this case the data in columns A and B represent two data sets, referred to as Variable 1 and Variable 2. Figure 344 shows the Z-test results calculated for this input data using the settings shown in Figure 343.

<table>
<thead>
<tr>
<th>D</th>
<th>E</th>
<th>F</th>
</tr>
</thead>
<tbody>
<tr>
<td>z-test</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Alpha</td>
<td>0.05</td>
<td></td>
</tr>
<tr>
<td>Hypothesised Mean Difference</td>
<td>0</td>
<td></td>
</tr>
<tr>
<td>Known Variance</td>
<td>0.000000</td>
<td>0.000000</td>
</tr>
<tr>
<td>Mean</td>
<td>16.923077</td>
<td>20.461538</td>
</tr>
<tr>
<td>Observations</td>
<td>13</td>
<td>13</td>
</tr>
<tr>
<td>Observed Mean Difference</td>
<td>-3.538462</td>
<td>#DIV/01</td>
</tr>
<tr>
<td>z</td>
<td>#DIV/01</td>
<td></td>
</tr>
<tr>
<td>P (Z&lt;=z) one-tail</td>
<td>#DIV/01</td>
<td></td>
</tr>
<tr>
<td>z Critical one-tail</td>
<td>1.644854</td>
<td></td>
</tr>
<tr>
<td>P (Z&lt;=z) two-tail</td>
<td>#DIV/01</td>
<td></td>
</tr>
<tr>
<td>z Critical two-tail</td>
<td>1.959964</td>
<td></td>
</tr>
</tbody>
</table>


**Test of Independence (Chi-Square) tool**

The Test of Independence (Chi-Square) tool calculates the chi-square test of a data sample, which determines how well a set of measured values fit a corresponding set of expected values. Select **Data > Statistics > Chi-square Test** in the Menu bar to access the Test of Independence (Chi-Square) dialog (Figure 345).

**Input range**

- Specifies the cell range containing the source data.
Results to
Specifies the top left cell of the results area. When you run the tool, it will generate the Chi-square table starting at this cell.

Columns / Rows
Specifies whether the data to be analyzed is organized in columns or rows.

![Test of Independence (Chi-Square) dialog](image)

To provide an example of using this tool, we again make use of the input data set shown in Figure 339. In this case the data in column A is the observed data while the data in column B are the corresponding expected values. Figure 346 shows the chi-square results calculated for this input data using the settings shown in Figure 345.

![Results of chi-square test](image)

Tip
For more information on chi-square tests, refer to the corresponding Wikipedia article at https://en.wikipedia.org/wiki/Chi-squared_test.

Fourier Analysis tool
The Fourier Analysis tool performs the Fourier analysis of a data set by computing the Discrete Fourier Transform (DFT) of an input array of complex numbers, using Fast Fourier Transform (FFT) algorithms. Select Data > Statistics > Fourier Analysis in the Menu bar to access the Fourier Analysis dialog (Figure 347).
Input range
Specifies the cell range containing the source data. A 2 x N or N x 2 range representing an array of complex numbers to be transformed, where N is the length of the array. The array contains the real and imaginary parts of the data.

Results to
Specifies the top left cell of the results area. When you run the tool, it will generate the Fourier transform table starting at this cell.

Input range has label
Specifies whether the first row or column of the input array is a label and not part of the data to be analyzed.

Columns / Rows
Specifies whether the data to be analyzed is organized in columns or rows.

Inverse
If ticked, the tool calculates an inverse Discrete Fourier Transform.

Output in polar form
If ticked, the tool outputs the results in polar coordinates (that is, magnitude and phase).

Minimum magnitude for polar form output
This option is only relevant when you select to output results in polar form. All frequency components with magnitude less than the specified value in decibels will be suppressed with a zero magnitude-phase entry. This is useful when looking at the magnitude-phase spectrum of a signal because there is always some tiny rounding error when performing FFT algorithms, which results in incorrect non-zero phase for non-existent frequencies. By providing a suitable value to this parameter, these non-existent frequency components can be suppressed.

To provide an example of using this tool, we make use of the input data set shown in columns B (real values) and C (imaginary values) of the spreadsheet shown in Figure 348. The data shown in
columns E (real values) and F (imaginary values) of the spreadsheet are the Fourier transform results calculated by the tool for this input data, using the settings shown in Figure 347.

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>Source Array</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Real</td>
<td>Imaginary</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>0.392555412</td>
<td>0</td>
<td></td>
<td></td>
<td>17.17755787</td>
<td>4.77453E-15</td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>1.208437017</td>
<td>0</td>
<td></td>
<td></td>
<td>3.420690795</td>
<td>2.3716479</td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>0.851477677</td>
<td>0</td>
<td></td>
<td></td>
<td>-6.802716154</td>
<td>-15.13454393</td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>1.785346519</td>
<td>0</td>
<td></td>
<td></td>
<td>-1.605447357</td>
<td>-5.06530604</td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>1.779465061</td>
<td>0</td>
<td></td>
<td></td>
<td>0.395847917</td>
<td>-2.419267855</td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>1.518900602</td>
<td>0</td>
<td></td>
<td></td>
<td>-1.494103683</td>
<td>2.301480413</td>
<td></td>
</tr>
<tr>
<td>11</td>
<td>1.046946661</td>
<td>0</td>
<td></td>
<td></td>
<td>0.872235793</td>
<td>-1.143940862</td>
<td></td>
</tr>
<tr>
<td>12</td>
<td>0.831100884</td>
<td>0</td>
<td></td>
<td></td>
<td>1.533245851</td>
<td>0.678159169</td>
<td></td>
</tr>
<tr>
<td>13</td>
<td>1.230062285</td>
<td>0</td>
<td></td>
<td></td>
<td>0.450563708</td>
<td>0.22912468</td>
<td></td>
</tr>
<tr>
<td>14</td>
<td>0.133409796</td>
<td>0</td>
<td></td>
<td></td>
<td>0.545106617</td>
<td>0.411029828</td>
<td></td>
</tr>
<tr>
<td>15</td>
<td>0.130471656</td>
<td>0</td>
<td></td>
<td></td>
<td>2.226859964</td>
<td>-2.430922367</td>
<td></td>
</tr>
<tr>
<td>16</td>
<td>0.386478762</td>
<td>0</td>
<td></td>
<td></td>
<td>-1.615228591</td>
<td>-2.416826573</td>
<td></td>
</tr>
<tr>
<td>17</td>
<td>-0.703392828</td>
<td>0</td>
<td></td>
<td></td>
<td>1.302450708</td>
<td>1.454437575</td>
<td></td>
</tr>
<tr>
<td>18</td>
<td>-0.89911531</td>
<td>0</td>
<td></td>
<td></td>
<td>1.579306286</td>
<td>-1.336827366</td>
<td></td>
</tr>
<tr>
<td>19</td>
<td>-0.12404551</td>
<td>0</td>
<td></td>
<td></td>
<td>-1.075722274</td>
<td>-0.921557968</td>
<td></td>
</tr>
<tr>
<td>20</td>
<td>-0.51355313</td>
<td>0</td>
<td></td>
<td></td>
<td>-0.055782418</td>
<td>-1.813360295</td>
<td></td>
</tr>
<tr>
<td>21</td>
<td>-0.613509106</td>
<td>0</td>
<td></td>
<td></td>
<td>-0.577666044</td>
<td>1.388872439</td>
<td></td>
</tr>
<tr>
<td>22</td>
<td>0.326072595</td>
<td>0</td>
<td></td>
<td></td>
<td>-0.826878282</td>
<td>-0.16591001</td>
<td></td>
</tr>
<tr>
<td>23</td>
<td>0.031629781</td>
<td>0</td>
<td></td>
<td></td>
<td>-0.826878282</td>
<td>0.16591001</td>
<td></td>
</tr>
<tr>
<td>24</td>
<td>0.522967259</td>
<td>0</td>
<td></td>
<td></td>
<td>-0.577666044</td>
<td>-1.388872439</td>
<td></td>
</tr>
<tr>
<td>25</td>
<td>0.436798031</td>
<td>0</td>
<td></td>
<td></td>
<td>-0.055782418</td>
<td>1.813360295</td>
<td></td>
</tr>
<tr>
<td>26</td>
<td>0.846212627</td>
<td>0</td>
<td></td>
<td></td>
<td>-1.075722274</td>
<td>0.921557968</td>
<td></td>
</tr>
<tr>
<td>27</td>
<td>0.913061097</td>
<td>0</td>
<td></td>
<td></td>
<td>1.579306286</td>
<td>1.336827366</td>
<td></td>
</tr>
<tr>
<td>28</td>
<td>1.256620753</td>
<td>0</td>
<td></td>
<td></td>
<td>1.302450708</td>
<td>-1.454437575</td>
<td></td>
</tr>
<tr>
<td>29</td>
<td>1.665365048</td>
<td>0</td>
<td></td>
<td></td>
<td>-1.615228591</td>
<td>2.416826573</td>
<td></td>
</tr>
<tr>
<td>30</td>
<td>1.356826362</td>
<td>0</td>
<td></td>
<td></td>
<td>2.226859964</td>
<td>2.430922367</td>
<td></td>
</tr>
<tr>
<td>31</td>
<td>1.46721909</td>
<td>0</td>
<td></td>
<td></td>
<td>0.545106617</td>
<td>-0.411029828</td>
<td></td>
</tr>
<tr>
<td>32</td>
<td>0.561204807</td>
<td>0</td>
<td></td>
<td></td>
<td>0.450563708</td>
<td>-0.220112488</td>
<td></td>
</tr>
<tr>
<td>33</td>
<td>0.701534532</td>
<td>0</td>
<td></td>
<td></td>
<td>1.533245651</td>
<td>-0.678159169</td>
<td></td>
</tr>
<tr>
<td>34</td>
<td>0.658693682</td>
<td>0</td>
<td></td>
<td></td>
<td>0.872235793</td>
<td>1.143940862</td>
<td></td>
</tr>
<tr>
<td>35</td>
<td>0.237522458</td>
<td>0</td>
<td></td>
<td></td>
<td>-1.494103633</td>
<td>2.391480413</td>
<td></td>
</tr>
<tr>
<td>36</td>
<td>-0.499911361</td>
<td>0</td>
<td></td>
<td></td>
<td>0.395847917</td>
<td>2.419267855</td>
<td></td>
</tr>
<tr>
<td>37</td>
<td>-0.533168876</td>
<td>0</td>
<td></td>
<td></td>
<td>-1.605447357</td>
<td>5.06530604</td>
<td></td>
</tr>
<tr>
<td>38</td>
<td>-0.796848084</td>
<td>0</td>
<td></td>
<td></td>
<td>-6.802716154</td>
<td>15.13454393</td>
<td></td>
</tr>
<tr>
<td>39</td>
<td>-0.621417307</td>
<td>0</td>
<td></td>
<td></td>
<td>3.428868795</td>
<td>-2.3715479</td>
<td></td>
</tr>
</tbody>
</table>

Figure 348: Fourier analysis tool - example input data and results

**Note**

For those with a technical interest in the algorithms used by the Fourier Analysis tool, a radix-2 decimation-in-time FFT is used when the length of the input sequence is an even power of 2, while Bluestein's FFT algorithm is used when the length of the input sequence is not an even power of 2.
Tip

Chapter 10
Linking Data
Sharing data in and out of Calc
Using multiple sheets

Why use multiple sheets?
Chapter 1, Introduction, introduced the concept of multiple sheets (also called worksheets) in a spreadsheet. Multiple sheets help keep information organized; once you link those sheets together, you unleash the full power of Calc. Consider this case.

John is having trouble keeping track of his personal finances. He has several bank accounts and the information is scattered and disorganized. He can’t get a good grasp on his finances until he can see everything at once.

To resolve this, John decides to track his finances in LibreOffice Calc. John knows Calc can do simple mathematical computations to help him keep a running tab of his accounts, and he wants to set up a summary sheet so that he can see all of his account balances at once.

Note

For users with experience of using Microsoft Excel: what Excel calls a workbook, Calc calls a spreadsheet (the whole document). Both Excel and Calc use the terms sheet and worksheet.

Setting up multiple sheets
Chapter 1, Introduction, gives a detailed explanation of how to set up multiple sheets in a spreadsheet. Here is a quick review.

Identifying sheets
When you open a new spreadsheet it has, by default, one sheet named Sheet1. You can specify a different number of sheets to be created in a new document, or a different prefix name for new sheets, by using the Options – LibreOffice Calc – Defaults dialog (Figure 349). To access this dialog, select Tools > Options > LibreOffice Calc > Defaults from the Menu bar.

Figure 349: Options – LibreOffice Calc - Defaults dialog

Sheets in Calc are managed using tabs located at the bottom of the spreadsheet.
Inserting new sheets

There are several ways to insert a new sheet. The fastest method is to click on the Add Sheet button, which has a + icon and is located to the left of the sheet tabs at the bottom of the spreadsheet. This inserts one new sheet without opening any dialog, with a default name (Sheet2, for example) and with the new sheet's tab positioned at the right hand end of the sheet tabs.

Use one of these other methods to insert more than one sheet, to rename the sheet at the same time, or to insert the sheet somewhere else in the sequence.

- Left-click a sheet tab and then select Sheet > Insert Sheet from the Menu bar. Calc displays the Insert Sheet dialog with the Before current sheet and New sheet options preselected.
- Select Sheet > Insert Sheet at End from the Menu bar. Calc displays the Append Sheet dialog.
- Select Sheet > Insert Sheet from File from the Menu bar. Calc displays the Insert Sheet dialog with the Before current sheet and From file options preselected. It also displays a file browser dialog on top of the Insert Sheet dialog to enable you to first select the source file containing the sheet to be inserted.
- Right-click on a sheet tab and select Insert Sheet from the context menu (Figure 350). Calc displays the Insert Sheet dialog with the Before current sheet and New sheet options preselected.
- Left-click in the empty space at the right end of the line of sheet tabs (Figure 350). Calc displays the Insert Sheet dialog with the Before current sheet and New sheet options preselected.
- Right-click in the empty space at the right end of the line of sheet tabs and select Insert Sheet from the context menu (Figure 350). Calc displays the Insert Sheet dialog with the Before current sheet and New sheet options preselected.

![Figure 350: Creating a new sheet through the sheet tabs area](image)

The above methods use either the Insert Sheet dialog (Figure 351) or the Append Sheet dialog (Figure 352).

On the Insert Sheet dialog you can:

- Choose whether to put the new sheet before or after the currently selected sheet tab.
- Choose how many sheets to insert.
• Choose the name for a single sheet (the Name field is unavailable if more than one sheet is to be inserted).

Figure 351: Insert Sheet dialog

The From file option is described in “Inserting sheets from a different spreadsheet” (page 338).

Figure 352: Append Sheet dialog

For John’s spreadsheet we need six sheets, one for each of his five accounts and one as a summary sheet. We also want to name each of these sheets for the account they represent: Summary, Checking Account, Savings Account, Credit Card 1, Credit Card 2, and Car Loan.

After creating a new spreadsheet with one sheet, we could:

• Insert five new sheets and rename all six sheets afterwards; or
• Rename the existing sheet, then insert the five new sheets one at a time, renaming each new sheet during the insert step.

To insert sheets and rename them afterwards:

1) Make sure that the correct sheet tab is selected and open the Insert Sheet dialog.
2) Choose the position for the new sheets (in this example, we use After current sheet).
3) Choose **New sheet** and enter 5 as the **No. of sheets**. Because you are inserting more than one sheet, the **Name** box is not available.

4) Click **OK** to insert the sheets.

For the subsequent steps to rename the sheets, see “Renaming sheets” (page 338).

To insert sheets and name them at the same time:

1) Rename the existing sheet as **Summary**, as described in “Renaming sheets” (page 338).
2) Make sure that the correct sheet tab is selected and open the Insert Sheet dialog.
3) Choose the sheet tab position for the new sheet (**Before current sheet** or **After current sheet**, as applicable).
4) Choose **New sheet** and enter 1 in the **No. of sheets** field. The **Name** box is now available.
5) In the **Name** box, type a name for this new sheet, for example **Checking Account**.
6) Click **OK** to insert the sheet.
7) Repeat steps 2 to 6 for each new sheet, giving them the names **Savings Account**, **Credit Card 1**, **Credit Card 2**, and **Car Loan**.

**Inserting sheets from a different spreadsheet**

On the Insert Sheet dialog, you can also add a sheet from a different spreadsheet (for example, another Calc or Microsoft Excel file), by choosing the **From file** option. Click **Browse**, select the file using the file browser dialog, and click **Open**. A list of the available sheets in that file appears in the adjacent list box (Figure 353). Select the sheet to import. If, after you select the file, no sheets appear, you probably selected an invalid file type (not a spreadsheet, for example).

![Figure 353: From file area of Insert Sheet dialog showing file path and names of available sheets](image)

If you prefer, select the **Link** option to insert the external sheet as a link instead of as a copy. This is one of several ways to include “live” data from another spreadsheet; see also “Linking to external data” (page 348). The links can be updated manually to show the current contents of the external file using **Edit > Links to External Files** from the Menu bar. Alternatively the links can be updated automatically whenever the file is opened, depending on the options set on the dialog accessed by selecting **Tools > Options > LibreOffice Calc > General > Update links when opening** from the Menu bar. The three options available to update links automatically when opening are **Always (from trusted locations)**, **On request**, and **Never**.

To define trusted file locations, select **Tools > Options > LibreOffice > Security > Macro Security (Trusted Sources tab)** from the Menu bar.

**Renaming sheets**

Sheets can be renamed at any time. To give a sheet a more meaningful name:

- Enter the name in the **Name** box when you create the sheet, or
• Double-click on the relevant sheet tab and replace the existing name through the Rename Sheet dialog, or
• Right-click on the relevant sheet tab, select Rename Sheet from the context menu, and replace the existing name through the Rename Sheet dialog, or
• Left-click on the relevant sheet tab, select Sheet > Rename Sheet from the Menu bar, and replace the existing name through the Rename Sheet dialog.

![Figure 354: Rename Sheet dialog](image)

A sheet name cannot be empty and must not be a duplicate of an existing name.

**Note**

The following characters are not allowed in sheet names: colon (:) back slash (\), forward slash (/), question mark (?), asterisk (*), left square bracket ([), right square bracket (]), and apostrophe ('). as the first or last character of the name.

**Tip**

In some LibreOffice Calc installations you can hold down the Alt key, click on the sheet name, and enter the new name directly.

Your sheet tab area should now look like this.

![Figure 355: Six renamed sheets](image)

Now we will set up the account ledgers. This is just a simple summary that includes the previous balance plus the amount of the current transaction. For withdrawals, we enter the current transaction as a negative number so the balance gets smaller. A basic ledger is shown in Figure 356.

This ledger is set up in the sheet named Checking Account. The total balance is added up in cell F3. You can see the equation for it in the Formula bar. It is the summary of the opening balance, cell C3, and all of the subsequent transactions.
Referencing other sheets

On the Summary sheet we display the balance from each of the other sheets. If you copy the example in Figure 356 onto each of the five account sheets, the current balances will be in cell F3 of each sheet.

There are two ways to reference cells in other sheets: by entering the formula directly using the keyboard or by using the mouse. We will look at the mouse method first.

Creating the reference with the mouse

On the Summary sheet, set up a place for all five account balances, so we know where to put the cell reference. Figure 357 shows the Summary sheet with a blank Balance column. We want to place the reference for the Checking Account balance in cell B3.

To make the cell reference in cell B3, select the cell and follow these steps:

1) Click on the = icon next to the Input line in the Formula bar. The icons in the Formula bar change and an equals character appears in the Input line (Figure 358).
2) Now, click on the sheet tab for the sheet containing the cell to be referenced. In this case, that is the *Checking Account* sheet (Figure 359).

![Figure 359: Click on the Checking Account tab](image)

3) Click on cell F3 (where the balance is) in the *Checking Account* sheet. The phrase `$'Checking Account'.F3` should appear in the Input line (Figure 360) and the selected cell is surrounded by a colored border.

![Figure 360: Cell reference selected](image)

4) Click the **Accept** icon in the Input line of the Formula bar, or press the **Enter** key to finish.

5) The *Summary* sheet should now look like Figure 361.

![Figure 361: Finished Checking Account reference](image)

**Creating the reference with the keyboard**

From Figure 361, you can deduce how the cell reference is constructed. The reference has two parts: the sheet name prefixed by a dollar symbol (`$'Checking Account'`), and the cell reference (F3). Notice that they are separated by a period. The default behavior of Calc is to insert the dollar symbol to form an absolute sheet reference while giving a relative cell reference.

**Note**

The sheet name is in single quotation marks because it contains a space, and the mandatory period (.) always falls outside any quotation marks.

So, you can fill in the *Savings Account* cell reference by just typing it in. Assuming that the balance is in the same cell (F3) in the *Savings Account* sheet, the cell reference should be `=$'Savings Account'.F3` (Figure 362).
Referencing other documents

John decides to keep his family account information in a different spreadsheet file from his own summary. Fortunately Calc can link different files together. The process is the same as described for different sheets in a single spreadsheet, but we add one more step to indicate which file the sheet is in.

Creating the reference with the mouse

To create the reference with the mouse, both spreadsheets need to be open.

1) If necessary, switch to the spreadsheet containing the cell in which the formula is going to be entered.
2) Select the cell in which the formula is going to be entered.
3) Click the = icon next to the Input line in the Formula bar.
4) Switch to the other spreadsheet (the process to do this may vary depending on which operating system you are using).
5) Select the sheet (Savings Account) and then the reference cell (F3); see Figure 363. You can press the keyboard Enter key at this point, or continue with steps 6 and 7.

You will get a good feel for the format of the reference if you look closely at the Input line in the Formula bar. Based on the contents of this line, you can create the reference using the keyboard.
Creating the reference with the keyboard

Typing the reference is simple once you know the format the reference takes. The reference has three parts to it:

- Path and file name
- Sheet name
- Cell reference

From Figure 364, you can see that the general format for the reference is:

=\'file:///Path & File Name'#$SheetName.CellReference

Note

The reference for a file has three forward slashes ///, while the reference for a hyperlink has two forward slashes //. See “Using hyperlinks and URLs” below.

Using hyperlinks and URLs

Hyperlinks can be used in Calc to jump to a different location from within a spreadsheet and can lead to other parts of the current file, to different files, or even to web pages.

Relative and absolute hyperlinks

Hyperlinks stored within a file can be either relative or absolute.

A relative hyperlink says, Here is how to get there starting from where you are now (meaning from the folder in which your current document is saved), while an absolute hyperlink says, Here is how to get there no matter where you start from.

An absolute link will stop working if the target is moved. A relative link will stop working if the start and target locations change relative to each other. For instance, if you have two spreadsheets in the same folder linked to each other and you move the entire folder to a new location, an absolute hyperlink will break but a relative one will not.

To change the way that Calc stores the hyperlinks in your file, select Tools > Options > Load/Save > General and choose if you want URLs (Universal Resource Locators) saved relatively when referencing the file system, or the Internet, or both.

An absolute path such as c:\homepage\graphics\picture.gif would no longer function on a web server. Neither a web server nor the computer of a reader needs to have a c: hard drive, operating systems such as Unix or macOS do not recognize drive letters, and even if the folder homepage\ graphics existed, your picture would not be available. It is better to use relative linking for file links. Relative linking is only possible when the document you are working on is on the same drive as the link destination.

Calc will always display an absolute hyperlink. Do not be alarmed when it does this even when you have saved a relative hyperlink. This ‘absolute’ target address will be updated if you move the file.
Note

HTML (Hypertext Markup Language) files containing links as relative to the file system that are to be uploaded to a web server require the files be in a file structure matching that of the web server. Otherwise, the links will point to the wrong folder.

Tip

When you rest the mouse pointer on a hyperlink, a help tip displays the absolute reference, because Calc uses absolute path names internally. The complete path and address can only be seen when you view the result of the HTML export (saving a spreadsheet as an HTML file), by loading the HTML file as text, or by opening it with a text editor.

Creating hyperlinks

You can insert a hyperlink into a Calc spreadsheet using any of several methods:

- Place the text cursor at the point where you want to insert the hyperlink, or select the text that you want to put the hyperlink on. Select Insert > Hyperlink from the Menu bar, or click the Insert Hyperlink icon in the Standard toolbar, or press Ctrl+K to access the Hyperlink dialog; see "Hyperlink dialog" (page 345).
- Drag-and-drop an item from the Navigator to the point where you want to insert the hyperlink (for example, a sheet or cell name).
- Type the target web address or URL at the point where you want to insert the hyperlink. When you type text that can be used as a hyperlink (such as a website address or URL), Calc formats it automatically, creating the hyperlink and applying color to the text. If this does not happen, you can enable this feature using Tools > AutoCorrect Options > Options from the Menu bar and selecting URL Recognition.

When you use the Hyperlink dialog to insert a hyperlink, you can select either a text hyperlink (Figure 365) or a button hyperlink (Figure 366). In both cases, the visible text can be different from the linked URL.

![Figure 365: Example text hyperlink](image)

To change the color of text hyperlinks, go to Tools > Options > LibreOffice > Application Colors from the Menu bar, scroll to Unvisited links and/or Visited links, pick the new colors and click OK.
Note

This will change the color for all hyperlinks in all components of LibreOffice, which may not be what you want.

A button hyperlink is a type of form control. As with all form controls, it can be anchored or positioned by right-clicking on the button in design mode. More information about forms can be found in Chapter 18, Forms, of the Writer Guide.

Opening hyperlinks

To open a text hyperlink carry out one of the following actions:

- Ctrl-click with the cursor positioned over the hyperlink.
- Left-click with the cursor positioned over the hyperlink. This option is only available if the Tools > Options > LibreOffice > Security > Security Options and Warnings > Options > Ctrl-click required to open hyperlinks option is not selected.
- Right-click with the cursor positioned immediately in front of the hyperlink and select the Open Hyperlink option from the context menu.

To open a button hyperlink, left-click the button. This option is only available when the form design mode is deactivated; the status of this mode is controlled by pressing the Design Mode button in either the Form Controls toolbar or the Form Design toolbar.

Hyperlink dialog

You can insert and modify hyperlinks using the Hyperlink dialog. To display this dialog, click the Insert Hyperlink icon in the Standard toolbar, or choose Insert > Hyperlink from the Menu bar, or press Ctrl+K.

On the left side of the dialog, select one of the four categories of hyperlink:

- Internet. The hyperlink points to a WWW (World Wide Web) or FTP (File Transfer Protocol) address.
- Mail. The hyperlink points to an email address.
- Document. The hyperlink points to a location in either the current document or another existing document.
- New Document. Opening the hyperlink creates a new document.

Figure 367 shows the Hyperlink dialog with the Internet category and the Web hyperlink type selected.

The Further Settings area is provided for all four hyperlink categories. The controls above the Further Settings area vary dependent on which of the four hyperlink categories is selected on the left side of the dialog.

A full description of all the choices, and their interactions, is beyond the scope of this chapter. The following is a summary of the most common choices used in Calc spreadsheets.

Internet

- Web / FTP. Select the type of hyperlink. On selection of the FTP option, the controls above the Further Settings area change to those shown in Figure 368.
- URL. Enter the required web address.
- Login name. Only applicable for FTP hyperlinks.
- Password. Only applicable for FTP hyperlinks.
- Anonymous user. Only applicable for FTP hyperlinks.
Mail

For Mail hyperlinks, the controls above the *Further Settings* area change to those shown in Figure 369.

- **Recipient.** Enter the email address of the recipient, or select the address from an existing database accessed by pressing the *Data Sources* button.
– **Subject.** Enter the text to be used as the subject line of the message.

**Document**

For document hyperlinks, the controls above the *Further Settings* area change to those shown in Figure 370.

![Figure 370: Document controls on the Hyperlink dialog](image1)

– **Path.** Specify the path of the file to be opened. Leave this blank if you want to link to a target in the same spreadsheet. The **Open File** icon opens a file browser for you to locate the document to be opened.

– **Target.** Optionally specify the target in the document (for example a specific sheet). Click on the **Target in Document** icon to open a Navigator window where you can select the target, or if you know the name of the target, you can type it into the box.

**New Document**

For New Document hyperlinks, the controls above the *Further Settings* area change to those shown in Figure 371.

– **Edit now / Edit Later.** Specify whether to edit the newly created document immediately or just create it.

– **File.** Enter the name of the file to be created. The **Select Path** icon opens a directory picker dialog.

– **File type.** Select the type of document to be created (for example, text document, spreadsheet, or drawing).

![Figure 371: New Document controls on the Hyperlink dialog](image2)
The Further Settings area at the bottom of the right side of the Hyperlink dialog is common to all the hyperlink categories, although some choices are more relevant to some types of links.

- Set the value of Frame to determine how the hyperlink will open. This applies to documents that open in a web browser. Options are _top, _parent, _blank, and _self.
- Form specifies if the link is to be presented as text or as a button.
- Text specifies the text that will be visible to the user. If you do not enter anything here, Calc will use the full URL or path as the link text. Note that if the link is relative and you move the file, this text will not change, though the target will.
- Name is applicable to HTML documents. It specifies text that will be added as a NAME attribute in the HTML code behind the hyperlink.
- Events button: this button will be activated to allow Calc to react to events for which the user has written some code (macro). This function is not covered further in this chapter.

**Editing hyperlinks**

To edit an existing text hyperlink, double-click the cell containing the hyperlink and move the input cursor until it is directly in front of the hyperlink. Click the Insert Hyperlink icon in the Standard toolbar, or select Insert > Hyperlink from the Menu bar, or press Ctrl+K. Calc opens the Hyperlink dialog, enabling you to modify the characteristics of the hyperlink.

For a button hyperlink, the spreadsheet must have the form design mode enabled in order to edit the hyperlink. With the button selected, click the Insert Hyperlink icon in the Standard toolbar, or select Insert > Hyperlink from the Menu bar, or press Ctrl+K. Make your changes and click OK.

If you need to edit several hyperlinks, you can leave the Hyperlink dialog open until you have edited all of them. Be sure to click Apply after each one. When you are finished, click Close.

You can also edit a button hyperlink by selecting the button (with form design mode enabled), right-clicking, and selecting Control Properties from the context menu. Calc displays the Properties dialog. Modify the button text by editing the Label field and modify the link address by editing the URL field.

**Removing hyperlinks**

To remove a text or button hyperlink from the document completely, select it and use one of the many available deletion mechanisms (for example, press Backspace or Delete on the keyboard; right-click on the hyperlink and select Cut from the context menu; select Cut from the Standard toolbar or Edit > Cut from the Menu bar).

**Linking to external data**

You can insert data from another document into a Calc spreadsheet as a link.

Two methods are described in this section: using the External Data dialog and using the Navigator. If your file has named ranges, database ranges, or named tables, and you know the name of the range or table you want to link to, using the External Data dialog is quick and easy. However, if the file has several ranges and tables, and you want to pick only one of them, you may not be able to easily determine which is which; in that case, the Navigator method may be easier.

Calc provides other methods for including linked data from external sources, see for example “Linking to registered data sources” (page 355) and “Dynamic Data Exchange (DDE)” (page 364).
When you open a file that contains links to external data, depending on your settings you may be prompted to update the links or they may be updated automatically. Depending on where the linked files are stored, the update process can take several minutes to complete.

Using the External Data dialog

The External Data dialog inserts data from an HTML, Calc, CSV (Comma-Separated Values), or Microsoft Excel file into the current sheet as a link. Calc utilizes a Web Page Query import filter, enabling you to insert tables from HTML documents. The External Data dialog is accessed by selecting **Sheet > Link to External Data** from the Menu bar.

To insert a link to external data using the External Data dialog:

1) Open the Calc document where the external data is to be inserted. This is the target document.
2) Select the cell where the upper left cell of the external data is to be inserted.
3) Choose **Sheet > Link to External Data** from the Menu bar. Calc displays the External Data dialog (Figure 372).

4) Type the URL of a web resource that is to be used as a data source, or type the address of a source file, or type an entry in the drop-down list, or select a source file from the file selection dialog accessed through the **Browse** button. For entries typed in, press **Enter** on completion.

5) If you selected an HTML file as the data source at step 4, Calc displays the Import Options dialog (Figure 373). On this dialog you can choose the import language of the site. Select **Automatic** to let Calc import the data directly, or select **Custom** and choose from the drop-down list of languages available. You can also select the option to have Calc recognize special numbers, such as dates, on import.

   a) Click **OK** on the Import Options dialog. Calc loads the list of available tables/ranges into the **Available Tables/Ranges** area of the External Data dialog. The Web Page Query import filter can create names for cell ranges as they are imported. As much formatting as possible is retained while the filter intentionally does not import any images. The filter additionally creates two additional entries in the list: **HTML_all** to permit selection of the entire document and **HTML_tables** to permit selection of all the tables.

   b) In the **Available Tables/Ranges** area, select the named ranges or tables you want to insert (hold **Ctrl** to select multiple entries). The **OK** button then becomes available.
6) If you selected a CSV file as the data source at step 4, Calc displays the Text Import dialog (Figure 374). This dialog is described in detail in Chapter 1, Introduction. Click OK on the Text Import dialog and select CSV_all in the Available Tables/Ranges area of the External Data dialog. The OK button then becomes available.

7) If you selected a Calc or Microsoft Excel file as the data source at step 4, Calc populates the Available Tables/Ranges area of the External Data dialog with the list of range names and database ranges that are defined in the source file. Select the range names and
database ranges that you want to insert (hold Ctrl to select multiple entries) and the OK button then becomes available.

**Note**

If the source Calc or Microsoft Excel spreadsheet contains no range names or database ranges, then you cannot use that document as the source file in the External Data dialog.

8) For all external data source file types, you can also specify that the data is refreshed at a specific frequency, defined in seconds.

9) Click OK to close the External Data dialog and insert the linked data.

Calc adds the new entry to the Linked areas list in the Navigator (Figure 375). If you double-click this entry, Calc highlights the linked data within the sheet. When you hover the cursor over the entry, a tooltip indicates the file location of the linked data.

![Figure 375: Linked areas in the Navigator](image)

To view a list of all external data links in the spreadsheet, select Edit > Links to External Files from the Menu bar. Calc displays the Edit Links dialog (Figure 376).

**Note**

The Edit Links dialog can display information about other links that were not created using the External Data dialog.

For links that have been created using the External Data dialog, you can access that dialog again by selecting the link and clicking the Modify button, or double-clicking the link. If you click Break Link and confirm that you want to remove the selected link, the previously-linked data becomes embedded in the spreadsheet. Click Update to refresh the linked data in the target file so that it matches that in the source file.
Note

The Status column on the Edit Links dialog always shows the string Manual for a link created using the External Data dialog. The string in this column does not reflect the setting of the Update every ... seconds option on the External Data dialog.

Using the Navigator

You can also use the Navigator to link external data. Access the Navigator by selecting View > Navigator on the Menu bar, or pressing F5. See Chapter 1, Introduction, for more details about the Navigator.

To insert a link to external data using the Navigator:

1) Open the Calc spreadsheet in which the external data is to be inserted (target document).
2) Open the document from which the external data is to be taken (source document) in Calc. The source document does not need to be a Calc file; it could, for example, be a Microsoft Excel file, an HTML file, or a CSV file. In the case of an HTML file, Calc displays the Import Options dialog (Figure 373) before opening the file.
3) In the target document, open the Navigator (Figure 377). This illustration shows the Navigator for a new file called Untitled 1, which currently has no range names, database ranges, or linked areas.
4) At the bottom of the Navigator, select the source document from the drop-down menu (Figure 378). In this case the source is called summary-indices-constituents and the file contains three range names which are highlighted with a red box. You may need to click the + icon at the left of the Range names field to view the names. It would not be possible to use a file as the source for an external link if it contains no range names or database ranges.
5) In the Navigator, select the **Insert as Link** option from the **Drag Mode** menu, as shown in Figure 379.

You can also change the drag mode by right-clicking on a range name and selecting the required option from the context menu.

**Tip**

The graphic on the **Drag Mode** icon of the Navigator changes to reflect the currently selected drag mode.
6) Select the required *Range names* or *Database ranges* entry and drag it from the Navigator into the target document, to the cell where you want the upper left cell of the data range to be.

7) Re-select the target document in the drop-down menu at the bottom of the Navigator. Instead of a + icon next to *Range names*, it shows a + icon next to *Linked areas*. Click the + icon to see the entry dragged across from the source document, similar to Figure 375.

### How to find the required data range or table

Calc’s Web Page Query import filter gives names to the data ranges (tables) it finds in a web page, starting from *HTML_1*. It also creates two additional range names:

- *HTML_all* – designates the entire document
- *HTML_tables* – designates all HTML tables in the document

If any of the data tables in the source HTML document have been given meaningful names (using the *ID* attribute on the *TABLE* tag), those names appear in the *Range names* list, along with the ranges Calc has sequentially numbered.

If the data range or table you want is not meaningfully named, how can you tell which one to select?

Go to the source document, which you opened in Calc. In the Navigator, double-click on a range name: that range is highlighted on the sheet. The example in Figure 380 shows a table of best-selling albums of recorded music by year worldwide and was extracted from Wikipedia’s *List of best-selling albums* page ([https://en.wikipedia.org/wiki/List_of_best-selling_albums](https://en.wikipedia.org/wiki/List_of_best-selling_albums)).
If the Formula bar is visible, the range name is also displayed in the Name box at the left end (Figure 381). The range name can be selected from the drop-down list to highlight it on the page.

**Figure 381: Using the Name box to find a data range name**

**Linking to registered data sources**

You can access a variety of databases and other data sources and link them into Calc documents. First you need to register the data source with LibreOffice. To register means to tell LibreOffice what type of data source it is and where the file is located. The way to do this depends on whether or not the data source is a database in *.odb format.

To register a data source that is in *.odb format:

1. Choose **Tools > Options > LibreOffice Base > Databases**. Calc displays the Options – LibreOffice Base – Databases dialog (Figure 382).

![Figure 380: Using the Navigator to find a data range name](image)

![Figure 381: Using the Name box to find a data range name](image)
2) Click the **New** button to open the Create Database Link dialog (Figure 383).

![Create Database Link dialog](image)

*Figure 383: Create Database Link dialog*

3) Enter the location of the database file, select a database file from the drop-down list, or click **Browse** to open a file browser and select the database file.

4) Type a name to use as the registered name for the database and click **OK**. The database is added to the list of registered databases and LibreOffice uses the registered name to access the database.

**Note**

The **OK** button on the Create Database Link dialog is enabled only when both the *Database file* and *Registered name* fields are filled in.

To register a data source that is not in *.odb* format:

1) Choose **File > New > Database** from the Menu bar to open the Database Wizard (Figure 384). For more about the Database Wizard, see Chapter 2, Creating a Database, of the *Base Handbook*.

2) Select **Connect to an existing database** and select the appropriate database type from the drop-down menu. The choices for database type depend on your operating system. For example, Microsoft Access and other Microsoft products are not among the choices if you...
are using Linux. The example database type menu shown in Figure 384 relates to a Windows 10 installation.

**Note**

The exact interactions required to connect to a database vary depending on the type of database. Steps 3 and 4 assume that you selected a dBASE database type at step 2.

3) **Click Next >.** Type the path to the folder where the dBase files are stored or click **Browse** and use the folder selection dialog to navigate to the relevant folder before pressing the **Select Folder** button.

4) **Click Next >.** Select **Yes, register the database for me**, but clear the **Open the database for editing** checkbox.

5) **Click Finish.** Name and save the database in the location of your choice.

**Note**

The above steps create a *.odb format database based on the content of the original dBASE database. The original dBASE database remains unchanged.

---

Figure 384: Database Wizard

Once a data source has been registered, it can be used by any LibreOffice component (for example, Calc or Writer).
Viewing data sources

Open a document in Calc. To view the data sources available, select View > Data Sources on the Menu bar, or press Ctrl+Shift+F4. Calc opens the Data Source window above the spreadsheet.

The Data Source window has three main components:

- The Table Data toolbar (Figure 385), which is by default located at the top of the Data Source window.

![Figure 385: Table Data toolbar](image)

The Table Data toolbar provides the following icons, from left to right:

- Save current record
- Edit Data
- Cut
- Copy
- Paste
- Undo
- Find Record
- Refresh
- Sort
- Sort Ascending
- Sort Descending
- AutoFilter
- Apply Filter
- Standard Filter
- Reset Filter/Sort
- Data to Text
- Data to Fields
- Mail Merge
- Data Source of Current Document
- Explorer On/Off
- Close

- The Data Source Explorer (Figure 386), which by default is located on the left side of the Data Source window, below the Table Data toolbar.

The Data Source Explorer provides a list of the registered databases, which by default includes the built-in Bibliography database.

To view each database, click on the + icon to the left of the name of the database. This has already been done for the Automobiles database in Figure 386. Click on the + icon left of Tables to view the individual tables within the selected database; similarly you can click on the + icon left of Queries to view the individual queries within the selected database. Click on the name of a table to view all the records held in that table.

358 | Linking to registered data sources
The data records for the selected table are displayed in the area at the right side of the Data Source window, below the Table Data toolbar.

To see more columns in this area, you can click the Explorer On/Off icon in the Table Data toolbar to temporarily hide the Data Source Explorer.

Below the data records is a navigation bar, which shows which record is selected and the total number of records. This provides the following buttons, from left to right:

- First record
- Previous record
- Next record
- Last record
- Add new record

A horizontal scroll bar appears when the available columns do not all fit in the visible area. A vertical scroll bar appears when the available data records do not all fit in the visible area.

At the bottom center of the Data Source window is an additional control to temporarily hide the entire window. This control is highlighted with a red box in Figure 387.

**Editing data sources**

Some data sources (such as spreadsheets) cannot be edited in the Data Source window.

In editable data sources, records can be edited, added, or deleted. If you cannot save your edits, you need to open the database in Base and edit it there; see “Launching Base to work on data sources” (page 359). You can also hide columns and make other changes to the display.

**Launching Base to work on data sources**

You can launch LibreOffice Base at any time from the Data Source Explorer. Right-click on a database, Tables, a table name, Queries, or a query name, and then select Edit Database File from the context menu. Once in Base, you can edit, add, and delete tables, queries, forms, and reports.

For more about using Base, see Chapter 8, Getting Started with Base, in the Getting Started Guide, or the Base Handbook.
Using data sources in Calc spreadsheets

Data from a table displayed on the right side of the Data Source window can be placed into a Calc document in a variety of ways.

You can select a single cell, a single row, or multiple rows in the Data Source window and drag and drop the data into the spreadsheet. The data is inserted at the place where you release the mouse button. If you selected one or more rows, Calc will also include the column headings above the data you insert. To select the rows of data you want to add to the spreadsheet:

1) Click the gray box to the left of the first row you want to select. That row is highlighted.
2) To select multiple adjacent rows, hold down the Shift key while clicking the gray box of the last row you need.
3) To select multiple separate rows, hold down the Control key while selecting each row. The selected rows are highlighted.
4) To select all the rows, click the gray box in the upper left corner. All rows are highlighted.

An alternative method uses the Data to Text icon in the Table Data toolbar and will include the column headings above the data you insert:

1) Click the cell of the spreadsheet which you want to be the top left of your data, including the column names.
2) Select the rows of data you want to add to the spreadsheet, as described in the previous paragraph.
3) Click the Data to Text icon in the Table Data toolbar to insert the data into the spreadsheet cells.

You can also drag the data source column headings (field names) onto your spreadsheet to create a form for viewing and editing individual records one at a time. Follow these steps:

1) Drag and drop the gray box at the top of the column (containing the field name you wish to use) to where you want the record to appear in the spreadsheet.
2) Repeat step 1 until you have moved all of the fields you need to where you want them.
3) Close the Data Source window by selecting View > Data Sources from the Menu bar.
4) Save the spreadsheet and select Edit > Edit Mode from the Menu bar, to make the spreadsheet read-only.
5) Select File > Reload from the Menu bar. All of the fields will show the value for the data of the first record of the data source that you selected.
6) Select View > Toolbars > Form Navigation to show the Form Navigation toolbar. By default, this toolbar opens at the bottom of the Calc window, just above the Status bar.
7) Click the arrows on the Form Navigation toolbar to view the different records of the table. The toolbar indicates which record is currently displayed and the total number of records available. The current record number changes as you move through the records and the data in the spreadsheet fields updates to correspond to the data for that particular record number.

From left to right, the Form Navigation toolbar provides the following interactions:

- Find Record
- First Record
- Previous Record
- Next Record
- Last Record
- New Record
Embedding spreadsheets

Spreadsheets can be embedded in other LibreOffice files and vice versa. This is often used in Writer or Impress documents so that Calc data can be used in a text document. You can embed the spreadsheet as either an OLE (Object Linking and Embedding) or DDE (Dynamic Data Exchange) object. The difference between a DDE object and a Linked OLE object is that a linked OLE object can be edited from the document in which it is added as a link, but a DDE object cannot.

For example, if a Calc spreadsheet is pasted into a Writer document as a DDE object, then the spreadsheet cannot be edited in the Writer document. But if the original Calc spreadsheet is updated, the changes are automatically made in the Writer document. If the spreadsheet is inserted as a Linked OLE object into the Writer document, then the spreadsheet can be edited in Writer as well as in the Calc document and both documents are in sync with each other.

Object Linking and Embedding (OLE)

The major benefit of an OLE object is that it is quick and easy to edit its contents just by double-clicking on it. You can also insert a link to the object that will appear as an icon rather than an area showing the contents itself.

OLE objects can be linked to a target document or embedded in the target document. Linking inserts information which will be updated with any subsequent changes to the original file, while embedding inserts a static copy of the data. If you want to edit the embedded spreadsheet, double-click on the object.

Note

If your OLE object is empty, inactive, and not displayed as an icon, then it will be transparent.

To embed a spreadsheet as an OLE object in a presentation:

1) Place the cursor in the document at the location where you want the OLE object to be.
2) Select **Insert > Object > OLE Object** from the Menu bar. Impress opens the Insert OLE Object dialog shown in Figure 388, with the Create new option selected by default.
You can either create a new OLE object or create the OLE object from an existing file.

To create a new object:

1) Select the **Create new** option and select the required option from those available in the **Object Type** list. In this example, you would select *LibreOffice 6.4 Spreadsheet*.

2) Click the **OK** button.

3) LibreOffice places an empty container in the slide, ready for you to enter information. By default the Menu bar changes to reflect the Calc Menu bar; when you click on the slide, anywhere outside the spreadsheet area, the Menu bar reverts to the Impress Menu bar.

After clicking outside the spreadsheet area, double-click on the OLE object to re-enter the edit mode of the object. The application devoted to handling that type of file (Calc in our example) will open the object.

---

**Note**

If the object inserted is handled by LibreOffice, then the transition to the program to manipulate the object will be seamless; in other cases the object opens in a new window and an option in the **File** menu becomes available to update the object you inserted.

To insert an existing object:

1) To create an OLE object from an existing file, select the **Create from file** option. The format of the Insert OLE Object dialog changes to that shown in Figure 389.

2) Click **Search**, select the required file in the file browser dialog, and then click the **Open** button.

---

**Note**

This facility is not limited to LibreOffice files; you can create OLE objects using existing files from many other applications.
Figure 389: Insert OLE Object dialog with Create from file option selected

3) To insert the object as a link to the original file, select the Link to file option. Otherwise, the object will be embedded in your document.

4) If you want the object to appear as a selectable icon, rather than a section of your file, select the Display as icon option.

5) Click the OK button. A section of the inserted file is shown in the document.

Other OLE objects

Under Windows, when you select the Create new option on the Insert OLE Object dialog, there is an extra entry Further objects in the Object Type list.

1) Double-click on the entry Further objects to open the Insert Object dialog (Figure 390).

Figure 390: Inserting an OLE object under Windows

2) Select Create New to insert a new object of the type selected in the Object Type list, or select Create from File to create a new object from an existing file.

3) If you choose Create from File, the dialog shown in Figure 391 opens. Click Browse and choose the file to insert. The inserted file object is editable by the Windows program that created it.

If instead of inserting an object, you want to insert a link to an object, select the Display As Icon option.
4) Click the **OK** button.

**Non-linked OLE object**

If the OLE object is not linked, it can be edited in the new document. For instance, if you insert a spreadsheet into a Writer document, you can essentially treat it as a Writer table (with a little more power). To edit it, double-click on it.

**Linked OLE object**

When the spreadsheet OLE object is linked, if you change it in Writer it will change in Calc; if you change it in Calc, it will change in Writer. This can be a very powerful tool if you create reports in Writer using Calc data, and want to make a quick change without opening Calc.

**Note**

You can only edit one copy of a spreadsheet at a time. If you have a linked OLE spreadsheet object in an open Writer document and then open the same spreadsheet in Calc, the Calc spreadsheet will be a read-only copy.

**Dynamic Data Exchange (DDE)**

DDE is an acronym for Dynamic Data Exchange, a mechanism whereby selected data in document A can be pasted into document B as a linked, ‘live’ copy of the original. It would be used, for example, in a report written in Writer containing time-varying data, such as sales results sourced from a Calc spreadsheet. The DDE link ensures that, as the source spreadsheet is updated so is the report, thus reducing the scope for error and reducing the work involved in keeping the Writer document up to date.

DDE is a predecessor of OLE. With DDE, objects are linked through file reference, but not embedded. You can create DDE links either within Calc cells in a Calc sheet, or in Calc cells in another LibreOffice doc such as in Writer.

**DDE link in Calc**

Creating a DDE link in Calc is similar to creating a cell reference. The process is a little different, but the result is the same. Carry out the following steps to create a DDE link from one Calc spreadsheet to another:

1) In Calc, open the spreadsheet that contains the original data that you want to link to.
2) Select the cells that you want to make the DDE link to.
3) Copy the cells to the clipboard by, for example, selecting **Edit > Copy** from the Menu bar, clicking the **Copy** icon on the Standard toolbar, or right-clicking the selected area and selecting **Copy** from the context menu.

4) Open the second spreadsheet that will contain the linked data.

5) Click in the top left cell of the area in the second spreadsheet where you want the linked data to appear.

6) Select **Edit > Paste Special > Paste Special** from the Menu bar of the second spreadsheet, or press **Ctrl+Shift+V**.

7) Calc displays the Paste Special dialog (Figure 392).

![Paste Special dialog](image)

**Figure 392: Paste Special dialog**

8) Select the **Link** option on the Paste Special dialog (highlighted with a red box on Figure 392) and then click the **OK** button.

If you now click on one of the linked cells you will see that the Formula bar shows a reference beginning with the characters `{='. See Figure 393 for an example, highlighted with a red box.

9) Save and close both spreadsheets.

If you subsequently edit the original cells in their spreadsheet and save the changes, next time you open the spreadsheet containing the linked cells, the values in those linked cells will update to reflect the latest values of the original cells.
When you open a spreadsheet containing linked data, you may get a warning message indicating that automatic update of external links has been disabled. You will need to click the Enable Content button to update the linked cells. You can avoid this message and interaction by making sure that the spreadsheet containing the original data is in a trusted file location and that the option is selected to always update links from trusted locations when opening. Check these settings via Tools > Options > LibreOffice > Security > Macro Security (Trusted Sources tab) and Tools > Options > LibreOffice Calc > General > Update links when opening respectively.

**DDE link in Writer**

The process for creating a DDE link from Calc to Writer is similar to creating a link within Calc.

1) In Calc, select the cells to make the DDE link to. Copy them.
2) Go to the place in your Writer document where you want the DDE link. Select Edit > Paste Special > Paste Special.
3) Writer displays its Paste Special dialog (Figure 394).

4) Select the Dynamic Data Exchange (DDE link) option in the Selection list.
5) Click the **OK** button.
6) Now the link has been created in Writer. When the Calc spreadsheet is updated, the table in Writer is automatically updated.

**XML Source**

The XML Source feature allows a user to import data from arbitrarily structured XML content into cells in an existing spreadsheet document. It allows XML content to be imported either partially or in full, depending on the structure of the XML content and the map definitions that the user defines. The user can specify multiple non-overlapping sub-structures to be mapped to different cell positions within the same document, and can select to import either element contents, attribute values, or both.

---

**Note:**

The XML Source feature currently allows you to import XML data as a one-time event; it will not store the information about the data source once the data is imported.

Suppose that you have sales data in an XML file, such as the following:

```xml
<sales>
  <sale>
    <date>01/19/08</date>
    <value>$2,032</value>
    <category>Golf</category>
    <region>West</region>
    <employee>Brigitte</employee>
  </sale>
  <sale>
    <date>01/25/08</date>
    <value>$3,116</value>
    <category>Sailing</category>
    <region>East</region>
    <employee>Hans</employee>
  </sale>
  <sale>
    <date>01/26/08</date>
    <value>$2,811</value>
    <category>Tennis</category>
    <region>South</region>
    <employee>Fritz</employee>
  </sale>
</sales>
```

To import this data into your Calc spreadsheet, take the following steps:
1) Select **Data > XML Source**. Calc displays the XML Source dialog (Figure 395).

![XML Source dialog (on initial display)](image)

2) Press the icon in the Source File area at the top of the dialog. Calc displays the Open dialog, which lets you specify the path to the XML file that you wish to import into your document.

3) Navigate to the correct folder, select the required file, and press the **Open** button.

4) Calc reads the content of the specified file and then populates the Map to Document area on the XML Source dialog to show the structure of the XML, as can be seen in Figure 396. The Map to Document area is described further below.

5) In the case of our example data, select sale in the Map to Document area. This will import all `<sale>` entries within the XML content into the spreadsheet.

6) Click on the cell at the top left of the area where the data is to appear in your spreadsheet. In the case of our example, click cell A1. A tellback of the cell clicked appears in the Mapped cell text box.

7) The contents of the XML Source dialog should now look like that shown in Figure 396.

8) Click the **Import** button. Pressing the **Import** button starts the import process based on the link definitions that the user has provided. Once the import finishes, the dialog will close.
Calc will place the XML content into the specified position in the spreadsheet, as shown in Figure 397.

The Map to Document area of the XML Source dialog shows the structure of the source XML content as a tree. It is initially empty and gets populated when you specify the source file.

Each element in the tree can be one of three types:

- **Attribute**, represented by the symbol `@`. 
- **Single non-recurring element**, represented by the symbol `</>`. A non-recurring element is an element that can only occur once under the same parent. It is mapped to a single cell in the document.
- **Recurring element**, represented by the symbol `<//>`. A recurring element is an element that can appear multiple times under the same parent. It serves as an enclosing parent of a single record entry of multiple record entries. These entries are imported into a range whose height equals the number of entries plus one additional header row.

The Mapped cell field specifies the position of a cell in the document that an element or an attribute is linked to. If it is a non-recurring element or an attribute, it simply points to the cell where the
value of the linked element/attribute will get imported. If it is a recurring element, it points to the top-left cell of the range where the whole record entries plus header will get imported.
Chapter 11
Sharing and Reviewing Spreadsheets
Introduction

This chapter covers methods for collaboration through sharing and reviewing spreadsheets: simultaneous editing, recording changes, adding comments, reviewing changes, merging and comparing documents, saving, and using document versions.

Some menu commands are not available (grayed out) when sharing or change tracking are active.

Sharing spreadsheets

Sharing a spreadsheet allows several users to open the same file for editing at the same time. The spreadsheet needs to be on a shared drive, server, website, or similar. Some conditions must be met on operating systems with user permission management:

- The shared file needs to reside in a location which is accessible by all collaborators.
- The file permissions for both the document and the corresponding lock file need to be set so that all collaborators can create, delete, and change the files.

Consult your operating system’s documentation for details on setting file permissions. See also “Opening and saving files on remote servers” in Chapter 1, Introducing LibreOffice, in the Getting Started Guide.

Tip

Each collaborator should enter their name in Tools > Options > LibreOffice > User Data.

Setting up a spreadsheet for sharing

With the spreadsheet open, choose Tools > Share Spreadsheet to enable or disable sharing.

![Figure 398: Choosing to share a spreadsheet](image)

To enable sharing, select the checkbox at the top of the dialog (Figure 398) and click OK. If the spreadsheet has been saved previously, a message appears stating that you must save it to activate shared mode; click Yes to continue. If the spreadsheet has not been saved previously, the Save dialog opens. After saving, the text “(shared)” is shown on the Title bar, after the title.
Tools > Share Spreadsheet can also be used to switch a spreadsheet from shared to unshared. However, this means that other users can no longer edit it. Instead, you may wish to save a copy of the shared spreadsheet using another name or path, thus creating a copy of the shared spreadsheet, and then switch the copy to unshared.

Opening a shared spreadsheet

When you open a shared spreadsheet, a message appears stating that some features are not available in this mode. Click OK to open the document. You can select the option to not show the warning again.

The following features are disabled in a shared spreadsheet:

- Edit > Track Changes, except for Merge Document
- Insert > Media > Audio or Video
- Insert > Comment
- Insert > Object
- Insert > Chart
- Insert > Named Range or Expression
- Insert > Pivot Table
- Insert > Floating Frame
- Insert > Fontwork
- Insert > Signature Line
- Format > Merge Cells
- Format > Print Ranges
- Sheet > Move or Copy Sheet
- Sheet > Delete Sheet
- Sheet > Insert Sheet from File
- Sheet > Named Ranges and Expressions
- Sheet > Rename Sheet
- Sheet > Sheet Tab Color
- Data > Define Range
- Data > Sort
- Data > Sort Ascending
- Data > Sort Descending
- Data > Subtotals
- Data > Validity
- Data > Multiple Operations
- Data > Consolidate
- Data > Group and Outline
- Data > Pivot Table
- Tools > Protect Sheet
- Tools > Protect Spreadsheet Structure

Saving a shared spreadsheet

When you save a shared spreadsheet, if it has not been modified and saved by another user since you opened it, it is saved as usual.

If the spreadsheet has been modified and saved by another user since you opened it, one of the following will occur:

- If the changes do not conflict, the document is saved, the message “Your spreadsheet has been updated with changes saved by other users” appears, and any cells modified by the other user are shown with a red border.
• If the changes conflict, the Resolve Conflicts dialog (Figure 399) is shown. You must decide for each conflict which version to keep, yours or the other person’s. When all conflicts are resolved, the document is saved. While you are resolving the conflicts, no other user can save the shared document.

• If another user is trying to save the shared spreadsheet and resolve conflicts, they see a message that the file is locked due to a merge in progress. They can cancel the Save command and retry saving later.

When you successfully save a shared spreadsheet, the document shows the latest version of all changes saved by all users.

Reviewing documents

You can use several methods to review, edit, and comment on a spreadsheet. Each reviewer works on a separate copy of the document.

• You can use change marks to show added and deleted material. Later, you or another person can review the document and accept or reject each change.

• You can make changes to a copy of the document (stored in a different folder, under a different name, or both), then use Calc to compare the files and show the changes. See page 380.

• You can save versions that are stored as part of the original file. See page 380.

Reviewers can leave comments in the document, either attached to specific changes or standalone.

Preparing a document for review (optional)

Before you send a spreadsheet to someone else to review or edit, you may want to set it up so that the editor or reviewer does not have to remember to turn on the revision marks.

After you have turned on revision marks, you can optionally password protect the spreadsheet so that any user must enter the correct password in order to accept or reject changes.

1) Open the spreadsheet and select Edit > Track Changes > Record from the Menu bar. You can also use File > Properties > Security and select Record changes.

2) (Optional) Click Edit > Track Changes > Protect. On the Protect Records dialog, type a password (twice) and click OK. You can also use File > Properties > Security and click the Protect button to open the Enter Password dialog.
Recording changes

To record changes, open the spreadsheet and make sure that the Edit > Track Changes > Record menu item has a check mark next to it, indicating that change recording is active.

Caution

After making some changes, do not turn off change recording. Turning off change recording in Calc causes all the recorded changes to be accepted and no longer shown as changes. A message box will warn you if you try to do this.

When changes are made in a cell, a colored border with a dot in the upper left-hand corner appears around the cell (Figure 400). A deleted column or row is marked by a heavy colored bar.

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
</tr>
</thead>
<tbody>
<tr>
<td>2</td>
<td>Item Description</td>
<td>Quantity</td>
<td>Cost/Item</td>
<td>Total</td>
<td>Comments</td>
</tr>
<tr>
<td>3</td>
<td>Uniforms</td>
<td>10</td>
<td>$50.00</td>
<td>$500.00</td>
<td>Need to update the text</td>
</tr>
<tr>
<td>4</td>
<td>Baseballs</td>
<td>250</td>
<td>$2.00</td>
<td>$500.00</td>
<td>We need 10 per game</td>
</tr>
<tr>
<td>5</td>
<td>Umpire fees</td>
<td>25</td>
<td>$50.00</td>
<td>$1,250.00</td>
<td>1 umpire per game</td>
</tr>
<tr>
<td>6</td>
<td>Bats</td>
<td>5</td>
<td>$35.00</td>
<td>$175.00</td>
<td>We need bats of various types</td>
</tr>
<tr>
<td>7</td>
<td>Snacks</td>
<td>0</td>
<td>$15.00</td>
<td>$0.00</td>
<td>Max cost per game for snacks</td>
</tr>
<tr>
<td>8</td>
<td>Batting helmets</td>
<td>5</td>
<td>$40.00</td>
<td>$200.00</td>
<td>We need a minimum of 5 helmets</td>
</tr>
<tr>
<td>9</td>
<td>Catching gear</td>
<td>1</td>
<td>$300.00</td>
<td>$300.00</td>
<td>Need to protect catchers</td>
</tr>
<tr>
<td>10</td>
<td>Spare gloves</td>
<td>2</td>
<td>$45.00</td>
<td>$90.00</td>
<td>Just in case someone needs them</td>
</tr>
<tr>
<td>11</td>
<td></td>
<td></td>
<td></td>
<td>$3,015.00</td>
<td>Total</td>
</tr>
</tbody>
</table>

Figure 400: Edited document with red border on changed cells

To see the changed information, hover the mouse pointer over the changed cell. See Figure 401.

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
</tr>
</thead>
<tbody>
<tr>
<td>2</td>
<td>Item Description</td>
<td>Quantity</td>
<td>Cost/Item</td>
<td>Total</td>
<td>Comments</td>
</tr>
<tr>
<td>3</td>
<td>Uniforms</td>
<td>10</td>
<td>$50.00</td>
<td>$500.00</td>
<td>Need to update the text</td>
</tr>
<tr>
<td>4</td>
<td>Baseballs</td>
<td>250</td>
<td>$2.00</td>
<td>$500.00</td>
<td>We need 10 per game</td>
</tr>
<tr>
<td>5</td>
<td>Umpire fees</td>
<td>25</td>
<td>$50.00</td>
<td>$1,250.00</td>
<td>1 umpire per game</td>
</tr>
<tr>
<td>6</td>
<td>Bats</td>
<td>5</td>
<td>$35.00</td>
<td>$175.00</td>
<td>We need bats of various types</td>
</tr>
<tr>
<td>7</td>
<td>Snacks</td>
<td>0</td>
<td>$15.00</td>
<td>$0.00</td>
<td>Max cost per game for snacks</td>
</tr>
<tr>
<td>8</td>
<td>Batting helmets</td>
<td>5</td>
<td>$40.00</td>
<td>$200.00</td>
<td>We need a minimum of 5 helmets</td>
</tr>
<tr>
<td>9</td>
<td>Catching gear</td>
<td>1</td>
<td>$300.00</td>
<td>$300.00</td>
<td>Need to protect catchers</td>
</tr>
<tr>
<td>10</td>
<td>Spare gloves</td>
<td>2</td>
<td>$45.00</td>
<td>$90.00</td>
<td>Just in case someone needs them</td>
</tr>
<tr>
<td>11</td>
<td></td>
<td></td>
<td></td>
<td>$3,015.00</td>
<td>Total</td>
</tr>
</tbody>
</table>

Figure 401: Showing details of the change

Note

Some changes, for example cell formatting, are not recorded and marked.

Tip

To change the color that indicates a changed cell, select Tools > Options > LibreOffice Calc > Changes.

You may want to explain your rationale for the changes. You can do this by adding comments to the changes you made or by adding general comments to the spreadsheet.

Adding comments to changes

Calc automatically adds to any recorded change a comment that describes what was changed (for example, Cell B4 changed from ‘9’ to ‘4’). Reviewers and authors can add their own comments to explain their reasons for the changes.
To add a comment to a change:

1) Make the change to the spreadsheet.
2) Select the cell with the change.
3) Choose **Edit > Track Changes > Comment** from the Menu bar. A small dialog opens. Type your comment and click **OK**. See Figure 402.

**Note**

Do **not** use **Insert > Comment** from the Menu bar or the context menu for this purpose. Comments inserted using that method are handled differently (see page 377) and do not appear in the Manage Changes dialog.

![Figure 402: Entering a comment associated with a change](image)

After you have added a comment to a changed cell, you can see the change and the comment by hovering the mouse pointer over the cell, as shown in Figure 403.

![Figure 403: Comment added to cell B3](image)

The comment also appears in the dialog when you are accepting and rejecting changes, as shown in the first line of Figure 407 on page 379.

**Editing comments on changes**

1) Select the cell with the change comment that you want to edit.
2) Choose **Edit > Track Changes > Comment** from the Menu bar. The box shown in Figure 402 opens.
3) Edit the comment and click **OK**.

The automatically-added comment provided by Calc cannot be edited.

You can move through the comments by using the arrows at the bottom of the dialog.
Adding other (general) comments

Calc provides another type of comments, which authors and reviewers often use to exchange ideas or ask for suggestions.

To add a general comment:

1) Select the cell that the comment applies to.
2) Select Insert > Comment or right-click and select Insert Comment. The box shown in Figure 404 appears.

We need 10 per game
1 umpire per game
We need bats of various sizes
Max cost per game for after-game snacks
We need a minimum of 5
Need to protect catcher; old gear damaged

Figure 404: Inserting a comment

3) Type your comment in the box, then click outside the box to close it.

Now the cell to which you added the comment has a colored dot in the upper right-hand corner, as shown in Figure 405. It does not have a colored border, unless the cell was also changed.

Figure 405: Colored dot in cell containing a comment

Tip

You can change the colors Calc uses for comments by selecting Tools > Options > LibreOffice > Application Colors and adjusting the color for Notes background.

To view the comment you just added, hover the mouse pointer over the cell that has a comment; the comment appears, as shown below.

Figure 406: Viewing a comment

Editing general comments

You can edit and format the text of a general comment, just as you do for any other text.

1) Right-click on the cell containing the comment marker and choose Edit comment from the context menu.
2) Calc shows the cell’s comment. The cursor changes to the usual text-entry cursor, and the Formatting toolbar changes to show text attributes.
3) When editing is done, click outside the comment to deselect it.
Formatting general comments

You can change the background color, border style, transparency, and other attributes of a comment.

1) Right-click on the cell containing the comment marker, and choose Show comment from the context menu.

2) Click on the comment itself. The Formatting toolbar changes to show many of the comment formatting options. These are the same as the options for formatting graphics; see Chapter 5, Using Graphics, for more information.

You can also right-click on the comment to see a menu of choices, some of which lead to dialogs in which you can fine-tune the formatting; these dialogs are also discussed in Chapter 5.

3) When done, click outside the comment to deselect it. To hide the comment again, right-click on the cell and choose Hide Comment on the context menu.

Finding general comments

The small comment markers in the corners of cells can be difficult to see, so Calc provides two other ways to find them: by showing all comments and by using the Navigator. To show all general comments, choose View > Comments from the Menu bar. To hide all comments, choose View Comments again.

If any general comments are in the spreadsheet, the Navigator shows a symbol (usually a + or an arrow) next to the word Comments. Click on this symbol to display a list of comments. Double-click on a comment in the list to jump directly to the cell it is associated with.

Note

View > Comments and the Navigator show general comments but not the comments associated with tracked changes.

Accepting or rejecting changes

When you receive a document with changes, you can step through each change and decide how to proceed. To begin this process:

1) Open the edited document.

2) Select Edit > Track Changes > Manage. The Manage Changes dialog shown in Figure 407 appears.

3) You can step through the changes one at a time, choosing to accept or reject each change as you go through. You can also accept or reject all changes at one time.

The Comment column by default contains an explanation of the change that was made. If the reviewer added a comment to the change, it is displayed, followed by the description of the change.

If a change has been superseded by a later change (by either the same person or another person), the changes are hierarchically arranged with an expansion symbol for opening up the hierarchy.

Below the list of changes to be accepted or rejected are shown any changes that have previously been dealt with.

On the Filter tab of this dialog (Figure 408), you can choose how to filter the list of changes: by date, author, cell range, or comments containing specific terms. After selecting the filter criteria, switch back to the List tab to see the results. Filtering the changes affects only the contents of the List tab on the dialog, you will not see any filtered results in your spreadsheet.
The processes discussed to this point are effective when you have one reviewer at a time. Sometimes, however, multiple reviewers all return edited versions of a document at the same time. In this case, it may be faster to review all of the changes at once, rather than one review at a time. For this purpose, you can merge documents in Calc.

To merge documents, all of the edited documents need to have recorded changes in them.

1) Open the original document.
2) Select Edit > Track Changes > Merge Document.
3) A file selection dialog opens. Select a file you want to merge and click **Open**.

4) After the documents merge, the Manage Changes dialog opens, showing changes by more than one reviewer. If you want to merge more documents, close the dialog and then repeat steps 2 and 3.

Now all of the changes are combined into one document and you can accept or reject the changes. Changes from different authors appear in cells outlined in different colors.

### Comparing documents

Sometimes reviewers may not record the changes they make. Calc can find the changes by comparing documents.

In order to compare documents you need to have the original document and the one that is edited. To compare them:

1) Open the edited document that you want to compare with the original document.

2) Select **Edit > Track Changes > Compare Document**.

3) An open document dialog appears. Select the original document and click **Open**.

Calc finds and marks the changes as follows:

- All data that occurs in the edited document but not in the original is identified as inserted.
- All data in the original document that is not in the edited document is identified as deleted.
- All data that is changed is marked as changed.

From this point you can go through and accept or reject changes as described earlier.

### Saving versions

For auditing and other purposes, you may need to save new versions of a spreadsheet. You can do this by saving a copy of the spreadsheet (under a different name) after each revision, or by using Calc’s version feature.

**Caution**

If you select **File > Save As** for a document with different versions stored in it, the old versions are not saved in the new file.

To use version management in Calc:

1) Choose **File > Versions** from the Menu bar. A version management dialog (Figure 409) opens, showing a list of the existing versions saved in this file.

![Figure 409: Version management dialog](image)
2) Click the **Save New Version** button to save a new version. A dialog (Figure 410) opens where you can enter comments about this version.

![Figure 410: Insert Version Comment dialog](image)

3) After you enter your comment and click **OK**, the new version is included in the Existing Versions list (Figure 411).

![Figure 411: Updated version list](image)

4) Save the file. Both versions are now included in the same file.

From this point you can:

- View an old version – Select the version and click **Open**: a read-only copy of a previous version opens.
- Compare all versions – Clicking **Compare** performs an action similar to merging documents. A Manage Changes dialog opens, showing all of the changes through the different versions.
- Review the version comments – Select a version and click **Show** to display the full comments made by yourself or other reviewers.
- Delete a version – Select a version and click **Delete**.

---

*Saving versions | 381*
Chapter 12
Macros
Automating repetitive tasks
Introduction

Chapter 13 of the *Getting Started Guide* (entitled *Getting Started with Macros*) is an introduction to the macro facilities that are available in LibreOffice. The current chapter provides further introductory information about the use of macros within a Calc spreadsheet.

A macro is a set of commands or keystrokes that are stored for later use. An example of a simple macro is one that enters your address into the current cell of an open spreadsheet. You can use macros to automate both simple and complex tasks, and they enable you to introduce new features that are not built into Calc.

The simplest way to create a macro is to record a series of actions through Calc’s user interface. Calc saves recorded macros using the open source LibreOffice Basic scripting language, which is a dialect of the well-known BASIC programming language. Such macros can be edited and enhanced after recording using the built-in LibreOffice Basic Integrated Development Environment (IDE).

The most powerful macros in Calc are created by writing code using one of the four supported scripting languages (LibreOffice Basic, BeanShell, JavaScript, and Python). This chapter provides an overview of Calc’s macro facilities, mostly focused on its default macro scripting language, LibreOffice Basic. Some examples are included for the BeanShell, JavaScript and Python scripting languages but fuller descriptions of the facilities for these languages are beyond the scope of this document.

Using the macro recorder

Chapter 13 of the *Getting Started Guide* includes examples showing how to use the macro recorder and understand the generated LibreOffice Basic scripts. The following steps give a further example, specific to a Calc spreadsheet, without the more detailed explanations of the *Getting Started Guide*. A macro is created and saved which performs a paste special with multiply operation across a range of spreadsheet cells.

1) Use **Tools > Options > LibreOffice > Advanced** from the Menu bar and select the **Enable macro recording** option to enable the macro recorder.

2) Use **File > New > Spreadsheet** from the Menu bar to create a new spreadsheet.

3) Enter the numbers shown in Figure 412 into cells A1:C3 of the first sheet in the new spreadsheet.

   **Figure 412:** Enter numbers into cells A1:C3

4) Select cell A3, which contains the number 3, and use **Edit > Copy** from the Menu bar to copy the value to the clipboard.

5) Select all cells in the range A1:C3.

6) Use **Tools > Macros > Record Macro** from the Menu bar to start the macro recorder. Calc displays the Record Macro dialog, which includes a **Stop Recording** button (Figure 413).

   **Figure 413:** Record Macro dialog with Stop Recording button

Using the macro recorder | 383
7) Use **Edit > Paste Special > Paste Special** from the Menu bar to open the Paste Special dialog (Figure 414).

![Paste Special dialog](image)

**Figure 414: Paste Special dialog**

8) Select the **Paste all** option in the **Selection area** and the **Multiply** option in the **Operations area**, and click **OK**. The values in cells A1:C3 are now multiplied by 3 (Figure 415).

![Cells A1:C3 multiplied by 3](image)

**Figure 415: Cells A1:C3 multiplied by 3**

9) Click the **Stop Recording** button to stop the macro recorder. Calc displays a variant of the Basic Macros dialog (Figure 416).

![Basic Macros dialog](image)

**Figure 416: Basic Macros dialog**

**Note**

The **Save Macro In** area of the Basic Macros dialog shows the existing LibreOffice Basic macros, hierarchically structured into library containers, libraries, modules, and macros as described in Chapter 13 of the *Getting Started Guide*. Figure 416 shows the **My Macros** library container, the **LibreOffice Macros** library container, the library container for the open **Balance.ods** file, and the library container for the untitled file created at step 2. Use the expand / collapse icons to the left of each library container name to view the libraries, modules and macros within that container.
Select the entry for the current document in the `Save Macro In` area. As the current document in this example has not been saved, it is referred to by its default name `Untitled 1`.

Documents that have been saved include a macro library named `Standard`. This library is not created until the document is saved or the library is needed, so at this point in the example procedure your new document does not contain a library. You can create a new library to contain the macro you have just created, but this is not necessary.

Click the `New Module` button. Calc displays the New Module dialog (Figure 417). Type a name for the new module or leave the name as the default `Module1`. 
The libraries, modules and macro names must follow some strict rules. Following the main rules, the names must:

- Begin with a letter
- Comprise lower case letters (a..z), upper case letters (A..Z), digits (0..9), and underscore characters (_)
- Not contain any other spaces, punctuation symbols, or special characters (including accents)

12) Click the **OK** button to create a new module. As no macro libraries exist in our current document, Calc automatically creates and uses a *Standard* library.

13) On the Basic Macros dialog, select the entry for the newly created module in the **Save Macro In** area, type the text *PasteMultiply* in the **Macro Name** box, and click the **Save** button (Figure 418).

The macro is saved with the name *PasteMultiply* in the newly created module within the *Standard* library of the *Untitled 1* document. Listing 1 shows the contents of the macro.

**Listing 1. Paste special with multiply macro**

```
sub PasteMultiply
  rem --------------------------------------------------------------
  rem define variables
  dim document as object
  dim dispatcher as object
  rem --------------------------------------------------------------
  rem get access to the document
```
ThisComponent.CurrentController.Frame
dispatcher = createUnoService("com.sun.star.frame.DispatchHelper")

rem --------------------------------------------------------------
dim args1(5) as new com.sun.star.beans.PropertyValue
args1(0).Name = "Flags"
args1(0).Value = "A"
args1(1).Name = "FormulaCommand"
args1(1).Value = 3
args1(2).Name = "SkipEmptyCells"
args1(2).Value = false
args1(3).Name = "Transpose"
args1(3).Value = false
args1(4).Name = "AsLink"
args1(4).Value = false
args1(5).Name = "MoveMode"
args1(5).Value = 4

dispatcher.executeDispatch(document, ".uno:InsertContents", ",", 0, args1())

end sub

Write your own functions

Create function macro

You can write a macro and then call it as you would call a Calc function. Use the following steps to create a simple function macro:

1) Create a new spreadsheet, save it with the name CalcTestMacros.ods, and leave it open in Calc.

2) Use Tools > Macros > Organize Macros > Basic from the Menu bar to open the Basic Macros dialog (Figure 419). Note that the layout of the Basic Macros dialog in this circumstance is different from the version that Calc displays when the user clicks the Stop Recording button on the Record Macro dialog (see Figure 416).

   The Macro From area lists the available macro library containers, including those relating to any LibreOffice documents that are currently open. My Macros contains macros that you write or add to LibreOffice and are available to more than one document. LibreOffice Macros contains macros that were included with your LibreOffice installation and should not be changed.

3) Click Organizer to open the Basic Macro Organizer dialog (Figure 420).
Figure 419: Basic Macros dialog

Figure 420: Basic Macro Organizer

388 | Write your own functions
Click on the **Libraries** tab and, in the **Location:** area, select the entry for the name of the current document. The **Library:** area updates to show the name of the empty **Standard** library.

4) Click **New** to open the New Library dialog to create a new library for this document (Figure 421).

![New Library dialog](image)

**Figure 421**: New Library dialog

5) Enter a descriptive library name (such as **AuthorsCalcMacros**) and click **OK** to create the library. The **Library:** area of the Basic Macro Organizer dialog updates to include the name of the newly created library. A library name can comprise up to 30 characters. Note that in some cases, the dialog may show only a portion of the name.

![Basic Macro Organizer](image)

**Figure 422**: The new library is shown in the **Library:** area

Select the **AuthorsCalcMacros** entry in the **Library:** area and click **Edit** to edit the library. Calc automatically creates a module named **Module1** and a macro named **Main**. Calc displays the LibreOffice Basic Integrated Development Environment (IDE), shown in Figure 423.

![LibreOffice Basic IDE](image)

Select function macro | 389
Figure 423 shows the default configuration for the LibreOffice Basic IDE. This comprises:

- A menu bar.
- Two toolbars (Macro and Standard). The Macro toolbar provides various icons for editing and testing programs.
- The Object Catalog, enabling selection of the required library container, library, module, and macro.
- The Editor Window, in which you can edit the LibreOffice Basic program code. The column on the left side is used to set breakpoints in the program code.
- The Watch Window (located at the left, below the Object Catalog and Editor Window) displays the contents of variables or arrays during a single step process.
- The Call Stack Window (located to the right, below the Object Catalog and Editor Window) provides information about the call stack of procedures and functions when a program runs.
- A tab control area.
- A status bar.

The LibreOffice Basic IDE provides powerful facilities for the development and debugging of LibreOffice Basic macros. A fuller description of this facility is beyond the scope of this document.

6) In the Editor Window, modify the code so that it is the same as that shown in Listing 2. The important addition is the creation of the NumberFive function, which returns the value 5.
The Option Explicit statement forces all variables to be declared before they are used. If Option Explicit is omitted, variables are automatically defined at first use as type Variant.

Listing 2. Function that returns the value 5

REM ***** BASIC *****
Option Explicit

Sub Main

End Sub

Function NumberFive ()
    NumberFive = 5
End Function

7) Use the Save button of the Standard toolbar within the LibreOffice Basic IDE to save the modified Module1.

Using a macro as a function

Using your newly created CalcTestMacros.ods spreadsheet, select a cell and enter the formula =NumberFive() (Figure 424). Calc finds the macro, calls it, and displays the result (5) in that cell.

Function names are not case sensitive. In Figure 424, the function name was entered as NumberFive() but Calc displays it as NUMBERFIVE() in the Formula bar.

Macro security warnings

You should now save the Calc document, close it, and open it again. Depending on your settings in the Macro Security dialog accessed using Tools > Options > LibreOffice > Security > Macro Security from the Menu bar, Calc may display one of the warnings shown in Figures 425 and 426.

In the case of the warning shown in Figure 425, you will need to click Enable Macros, or Calc will not allow any macros to be run in the document. If you do not expect a document to contain a macro, it is safer to click Disable Macros in case the macro is a virus.

In the case of the warning shown in Figure 426, Calc will not allow any macros to be run in the document and you should click the OK button to remove the warning from the screen.

When the document loads with macros disabled, Calc will not be able to find any macro functions and will indicate an error in any affected cell by displaying the text #NAME? in that cell.
Loaded / unloaded libraries

When it opens a spreadsheet, Calc does not open all macro libraries that it can find in the available library containers because this would be a waste of resources. Instead Calc automatically loads just the Standard library within the My Macros library container and the document’s own Standard library. No other libraries are automatically loaded.

When you re-open your CalcTestMacros.ods spreadsheet, Calc does not contain a function named NumberFive(), so it checks all visible, loaded macro libraries for the function. Loaded libraries in LibreOffice Macros, My Macros, and the document are checked for an appropriately named function. In our initial implementation, the NumberFive() function is stored in the AuthorsCalcMacros library, which is not automatically loaded when the document is opened. Hence the NumberFive() function is not found and an error condition appears in the cell where it is called (Figure 427).

Use Tools > Macros > Organize Macros > Basic from the Menu bar to open the Basic Macros dialog (Figure 428). The icon for a loaded library (for example, Standard) has a different appearance to the icon for a library that is not loaded (for example, AuthorsCalcMacros).

Click the expand icon next to AuthorsCalcMacros to load the library. The icon changes appearance to indicate that the library is now loaded. Click Close to close the Basic Macros dialog.
Unfortunately, the cell containing =NumberFive() in our initial implementation is still in error. Calc does not recalculate cells in error unless you edit them or somehow change them. The usual solution is to store macros used as functions in the *Standard* library. If the macro is large or if there are many macros, a stub with the desired name is stored in the *Standard* library. The stub macro loads the library containing the implementation and then calls the implementation. The following steps illustrate this method.

1) Use **Tools > Macros > Organize Macros > Basic** in the Menu bar to open the Basic Macros dialog. Select the *NumberFive* macro and click **Edit** to open the macro for editing (Figure 429).

```
Listing 3. Change the name of NumberFive to NumberFive_Implementation

Function NumberFive_Implementation()
    NumberFive_Implementation = 5
End Function
```

2) Calc displays the LibreOffice Basic IDE (Figure 423), with the input cursor in the Editor Window at the line **Function NumberFive ()**. Change the name of **NumberFive** to **NumberFive_Implementation** so that the function's code matches Listing 3.

3) Click the **Select Macro** button in the Standard toolbar of the LibreOffice Basic IDE to open the Basic Macros dialog (Figure 429).
4) Select the Standard library in the CalcTestMacros.ods document and click the New button to create a new module. Enter a meaningful name such as CalcFunctions and click OK. Calc automatically creates a macro named Main and opens the module for editing.

5) Create a macro in the CalcFunctions module of the Standard library that loads the AuthorsCalcMacros library if it is not already loaded, and then calls the implementation function. See Listing 4.

Listing 4. Create a new NumberFive function to call the NumberFive_Implementation function

Function NumberFive()
  If NOT BasicLibraries.isLibraryLoaded("AuthorsCalcMacros") Then
    BasicLibraries.LoadLibrary("AuthorsCalcMacros")
  End If
  NumberFive = NumberFive_Implementation()
End Function

6) Save, close, and reopen the Calc document. This time, if macros are enabled, the NumberFive() function works as expected.

Passing arguments to a macro

To illustrate a function that accepts arguments, we will write a macro that calculates the sum of its arguments that are positive. It will ignore arguments that are less than zero (see Listing 5).

Listing 5. PositiveSum calculates the sum of its positive arguments

Function PositiveSum(Optional x)
  Dim TheSum As Double
  Dim iRow As Integer
  Dim iCol As Integer

  TheSum = 0.0
  If NOT IsMissing(x) Then
    If NOT IsArray(x) Then
      If x > 0 Then TheSum = x
    Else
      For iRow = LBound(x, 1) To UBound(x, 1)
        For iCol = LBound(x, 2) To UBound(x, 2)
          If x(iRow, iCol) > 0 Then TheSum = TheSum + x(iRow, iCol)
        Next
      Next
    End If
  Else
    PositiveSum = TheSum
End If
End Function

The macro in Listing 5 demonstrates some important techniques:

1) The argument x is Optional. When an argument is not Optional and the function is called without it, Calc outputs a warning message every time the macro is called. If Calc calls the function many times, then the error is displayed many times.

2) The function IsMissing checks that an argument was passed before it is used.

3) The function IsArray checks to see if the argument is a single value, or an array. For example, =PositiveSum(7) or =PositiveSum(A4). In the first case, the number 7 is
passed as an argument, and in the second case, the value of cell A4 is passed to the function. In both these cases, IsArray returns the value False.

4) If a range is passed to the function, it is passed as a two-dimensional array of values; for example, =PositiveSum(A2:B5). The functions LBound and UBound are used to determine the array bounds that are used. Although the lower bound is one, it is considered safer to use LBound in case it changes in the future.

Tip
The macro in Listing 5 is careful and checks to see if the argument is an array or a single argument. The macro does not verify that each value is numeric. You may be as careful as you like. The more things you check, the more robust the macro is, but the slower it runs.

Passing one argument is as easy as passing two: add another argument to the function definition (see Listing 6). When calling a function with two arguments, separate the arguments with a comma; for example, =TestMax(3, -4).

Listing 6. TestMax accepts two arguments and returns the larger

Function TestMax(x, y)
  If x >= y Then
    TestMax = x
  Else
    TestMax = y
  End If
End Function

Arguments are passed as values
Arguments passed to a macro from Calc are always values. It is not possible to know what cells, if any, are used. For example, =PositiveSum(A3) passes the value of cell A3, and PositiveSum has no way of knowing that cell A3 was used. If you must know which cells are referenced rather than the values in the cells, pass the range as a string, parse the string, and obtain the values in the referenced cells.

Writing macros that act like built-in functions
Although Calc finds and calls macros as normal functions, they do not really behave as built-in functions. For example, macros do not appear in the function lists. It is possible to write functions that behave as regular functions by writing an Add-In. However, this is an advanced topic that is for experienced programmers and is beyond the scope of this guide.

Deleting LibreOffice Basic macros
Use the following steps to delete an unwanted macro:

1) Use Tools > Macros > Organize Macros > Basic in the Menu bar to open the Basic Macros dialog (see Figure 429 on page 393).
2) Select the macro to be deleted and click the Delete button.
3) Calc displays a confirmation dialog. Click Yes to continue.
4) Click the Close button to remove the Basic Macros dialog from the screen.

Use the following steps to delete an unwanted module:

1) Use Tools > Macros > Organize Macros > Basic in the Menu bar to open the Basic Macros dialog (see Figure 429 on page 393).
2) Click the Organizer button to open the Basic Macro Organizer dialog (Figure 430).
3) Make sure that the Modules tab is selected.

![Figure 430: Basic Macro Organizer dialog, Modules tab](image)

4) Select the module to be deleted in the Module area.
5) Click the Delete button.
6) Calc displays a confirmation dialog. Click Yes to continue.
7) Click the Close button to remove the Basic Macro Organizer dialog from the screen.
8) Click the Close button to close the Basic Macros dialog.

**Accessing cells directly**

You can access the LibreOffice internal objects directly to manipulate a Calc document. For example, the macro in Listing 7 adds the values in cell A2 from every sheet in the current document. ThisComponent is automatically set to reference the current document when the macro starts. A Calc document contains sheets and the macro accesses these via a call to ThisComponent.getSheets(). Use getCellByPosition(col, row) to return a cell at a specific row and column.

*Listing 7. SumCellsAllSheets adds the values in cell A2 of every sheet*

```vba
Function SumCellsAllSheets()
    Dim TheSum As Double
    Dim i As Integer
    Dim oSheets
    Dim oSheet
    Dim oCell
```
TheSum = 0
oSheets = ThisComponent.getSheets()
For i = 0 To oSheets.getCount() - 1
    oSheet = oSheets.getByIndex(i)
oCell = oSheet.getCellByPosition(0, 1) ' GetCell A2
    TheSum = TheSum + oCell.getValue()
Next
SumCellsAllSheets = TheSum
End Function

Tip

A cell object supports the methods getValue(), getString(), and getFormula() to get the numerical value, the string value, or the formula used in a cell. Use the corresponding set functions to set appropriate values.

Use oSheet.getCellRangeByName("A2") to return a range of cells by name. If a single cell is referenced, then a cell object is returned. If a cell range is given, then an entire range of cells is returned (see Listing 8). Notice that a cell range returns data as an array of arrays, which is more cumbersome than treating it as an array with two dimensions as is done in Listing 5.

Listing 8. SumCellsAllSheets adds the values in cells A2:C5 of every sheet

Function SumCellsAllSheets()
    Dim TheSum As Double
    Dim iRow As Integer, iCol As Integer, i As Integer
    Dim oSheets, oSheet, oCells
    Dim oRow(), oRows()

    TheSum = 0
    oSheets = ThisComponent.getSheets()
    For i = 0 To oSheets.getCount() - 1
        oSheet = oSheets.getByIndex(i)
oCells = oSheet.getCellRangeByName("A2:C5")

        REM The getDataArray() method returns strings and numbers
        REM but is not used in this function.

        REM The getData() method returns only numbers and is applicable
        REM to this function.

        oRows() = oCells.getData()
        For iRow = LBound(oRows()) To UBound(oRows())
            oRow() = oRows(iRow)
            For iCol = LBound(oRow()) To UBound(oRow())
                TheSum = TheSum + oRow(iCol)
            Next
        Next

    SumCellsAllSheets = TheSum
End Function
When a macro is called as a Calc function, the macro cannot modify any value in the sheet from which the macro was called, except the value of the cell that contains the function.

### Sorting

Consider sorting the data shown in Figure 431. First, sort on column B descending and then on column A ascending.

![Figure 431: Sort column B descending and column A ascending](image)

The example in Listing 9 demonstrates how to sort on these two columns. Run the macro by clicking the Run icon in the Macro toolbar of the LibreOffice Basic IDE.

**Listing 9. SortRange sorts cells A1:C5 of Sheet 1**

```basic
Sub SortRange
    Dim oSheet        ' Calc sheet containing data to sort.
    Dim oCellRange    ' Data range to sort.

    REM An array of sort fields determines the columns that are sorted. This is an array with two elements, 0 and 1.
    REM To sort on only one column, use:
    REM Dim oSortFields(0) As New com.sun.star.util.SortField
    Dim oSortFields(1) As New com.sun.star.util.SortField

    REM The sort descriptor is an array of properties.
    REM The primary property contains the sort fields.
    Dim oSortDesc(0) As New com.sun.star.beans.PropertyValue

    REM Get the sheet named "Sheet1"
    oSheet = ThisComponent.Sheets.getByName("Sheet1")

    REM Get the cell range to sort
    oCellRange = oSheet.getCellRangeByName("A1:C5")

    REM Select the range to sort.
    REM The only purpose would be to emphasize the sorted data.
    'ThisComponent.getCurrentController.select(oCellRange)

    REM The columns are numbered starting with 0, so
    REM column A is 0, column B is 1, etc.
    REM Sort column B (column 1) descending.
    oSortFields(0).Field = 1
    oSortFields(0).SortAscending = FALSE
```

---

398 | Sorting
Overview of BeanShell, JavaScript, and Python macros

Introduction

Many programmers may not be familiar with LibreOffice Basic and so Calc supports macros written in three other languages that may be more familiar. These are BeanShell, JavaScript, and Python.

The primary macro scripting language for Calc is LibreOffice Basic and the standard LibreOffice installation provides a powerful integrated development environment (IDE) together with more options for this language.

Macros are organized in the same way for all four scripting languages. The LibreOffice Macros container holds all the macros that are supplied in the LibreOffice installation. The My Macros library container holds your macros that are available to any of your LibreOffice documents. Each document can also contain your macros that are not available to any other document.

When you use the macro recording facility, Calc creates the macro in LibreOffice Basic. To use the other available scripting languages you must write the code yourself.

When you select to run a macro using Tools > Macros > Run Macro from the Menu bar, Calc displays the Macro Selector dialog. This dialog enables selection and running of any available macro, coded in any of the available languages (Figure 432).

When you select to edit a macro using Tools > Macros > Edit Macros from the Menu bar, Calc displays the LibreOffice Basic IDE. This dialog enables selection and editing of any available LibreOffice Basic macro, but not macros in other languages.

The component model used in LibreOffice is known as Universal Network Objects or UNO. LibreOffice macros in any scripting language use a UNO runtime application programming interface (API). The XSCRIPTCONTEXT interface is provided to macro scripts in all four languages, and provides a means of access to the various interfaces which they might need to perform some action on a document.
BeanShell macros

BeanShell is a Java-like scripting language that was first released in 1999. When you select **Tools > Macros > Organize Macros > BeanShell** from the Menu bar, Calc displays the BeanShell Macros dialog (Figure 433).

Click the **Edit** button on the BeanShell Macros dialog to access the BeanShell Debug Window (Figure 434).
Listing 10 is an example of a BeanShell macro that inserts the text “Hello World from BeanShell” in cell A1 of the active Calc spreadsheet.
**Listing 10. Sample BeanShell macro**

```java
import com.sun.star.uno.UnoRuntime;
import com.sun.star.sheet.XSpreadsheetView;
import com.sun.star.text.XText;
model = XSCRIPTCONTEXT.getDocument();
controller = model.getCurrentController();
view = UnoRuntime.queryInterface(XSpreadsheetView.class, controller);
sheet = view.getActiveSheet();
cell = sheet.getCellByPosition(0, 0);
cellText = UnoRuntime.queryInterface(XText.class, cell);
textCursor = cellText.createTextCursor();
cellText.insertString(textCursor, "Hello World from BeanShell", true);
return 0;
```

**JavaScript macros**

JavaScript is a high-level scripting language that was first released in 1995. When you select **Tools > Macros > Organize Macros > JavaScript** from the Menu bar, Calc displays the JavaScript Macros dialog (Figure 435).

![JavaScript Macros dialog](image)

*Figure 435: JavaScript Macros dialog*
Click the **Edit** button on the JavaScript Macros dialog to access the Rhino JavaScript Debugger (Figure 436). Detailed instructions for using this tool can be found on Mozilla’s website at https://developer.mozilla.org/en-US/docs/Mozilla/Projects/Rhino/Debugger.

![Figure 436: Rhino JavaScript Debugger](image)

Listing 11 is an example of a JavaScript macro that inserts the text “Hello World from JavaScript” in cell A1 of the first sheet in a Calc spreadsheet.

**Listing 11. Sample JavaScript macro**

```javascript
importClass(Packages.com.sun.star.uno.UnoRuntime);
importClass(Packages.com.sun.star.sheet.XSpreadsheetDocument);
importClass(Packages.com.sun.star.container.XIndexAccess);
importClass(Packages.com.sun.star.table.XCellRange);
importClass(Packages.com.sun.star.table.XCell);

documentRef = XSCRIPTCONTEXT.getDocument();
```

spreadsheetInterface = UnoRuntime.queryInterface(XSpreadsheetDocument, documentRef);

allSheets = UnoRuntime.queryInterface(XIndexAccess, spreadsheetInterface.getSheets());

theSheet = allSheets.getByIndex(0);
Cells = UnoRuntime.queryInterface(XCellRange, theSheet);
cellA1 = Cells.getCellByPosition(0, 0);
theCell = UnoRuntime.queryInterface(XCell, cellA1);
theCell.setFormula("Hello World from JavaScript");

Python macros

Python is a high-level, general-purpose programming language that was first released in 1991. When you select Tools > Macros > Organize Macros > Python from the Menu bar, Calc displays the Python Macros dialog (Figure 437).

![Python Macros dialog]

Facilities to edit and debug Python scripts are not currently integrated into the standard LibreOffice user interface. However, you can edit Python scripts with your preferred text editor or an external IDE. The Alternative Python Script Organizer (APSO) extension eases the editing of Python scripts, in particular when embedded in a document. Using APSO, you can configure your preferred source code editor, start the integrated Python shell and debug Python scripts. For more information, search for Python in the LibreOffice Help system and visit the Designing & Developing Python Applications section of The Document Foundation’s wiki (https://wiki.documentfoundation.org/Macros/Python_Design_Guide).
Listing 12 is an example of a Python macro that sets cell A1 of the first sheet in a Calc spreadsheet to the text “Hello World from Python”.

Listing 12. Sample Python macro

```python
import uno
def HelloWorld():
    doc = XSCRIPTCONTEXT.getDocument()
    cell = doc.Sheets[0]['A1']
    cell.setString('Hello World from Python')
    return
```

Conclusion

This chapter provides an overview of how to create libraries and modules, using the macro recorder, using macros as Calc functions, and writing your own macros without the macro recorder. Each topic deserves at least one chapter, and writing your own macros for Calc could easily fill an entire book. In other words, this is just the beginning of what you can learn.

Additional detail about Calc's macro facilities can be obtained from the Help system, The Document Foundation's wiki pages (for example https://wiki.documentfoundation.org/Macros) and other Internet sources (for example the http://ask.libreoffice.org/ Q&A site).
Chapter 13
Calc as a Simple Database
A guide for users and macro programmers
Introduction

Though it is a spreadsheet program, Calc has sufficient functionality to act as a simple yet capable database-like platform. This chapter presents an overview of these capabilities and explains them using LibreOffice Basic macros and GUI (Graphical User Interface) examples.

Note

Though it was created for macro programmers, this guide is meant to be accessible for all users. If you do not want to use macros, simply skip the sections that deal with them. However, if you are interested in learning more about them, see Chapter 12, Macros, in this book, and Andrew Pitonyak’s book, OpenOffice.org Macros Explained (OOME).

All the macro information in this chapter is drawn or adapted from the OOME and LibreOffice’s API reference at https://api.libreoffice.org/docs/idl/ref/index.html.

A database primer

In a typical database, related data is organized into tables, which are arranged in a grid-like series of rows and columns similar to a spreadsheet. Each row of a table represents a data record, while each column represents a field within each record. Each cell in a field contains an individual data item or attribute, such as a name, while each record consists of related attributes that correspond to a single entity, like a person. A database table tends to have a fixed number of fields, but can have an indefinite number of records.

While a table may have hundreds or thousands of rows, individual records can be easily found, retrieved, and updated using information requests, called queries, that search for records that meet a specified set of criteria. It is this ease of access that makes a database table more useful than simply filing away information in an unordered spreadsheet.

To illustrate this concept of a database table, consider the example of a class grading sheet (Figure 438). In this sheet, each row represents individual students taking the class, while each column contains their names and grades. With this table, you can quickly look up individual students' grades simply by searching for their names, and you can determine which students are passing the class by filtering out records with failing average scores.

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
<th>H</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Student</td>
<td>HW #1</td>
<td>HW #2</td>
<td>HW #3</td>
<td>Quiz #1</td>
<td>Quiz #2</td>
<td>Test #1</td>
<td>Average</td>
</tr>
<tr>
<td>2</td>
<td>Andrew</td>
<td>90</td>
<td>100</td>
<td>82</td>
<td>90</td>
<td>88</td>
<td>92</td>
<td>90.33</td>
</tr>
<tr>
<td>3</td>
<td>Bethany</td>
<td>95</td>
<td>100</td>
<td>82</td>
<td>80</td>
<td>88</td>
<td>93</td>
<td>89.67</td>
</tr>
<tr>
<td>4</td>
<td>Charles</td>
<td>80</td>
<td>93</td>
<td>73</td>
<td>80</td>
<td>75</td>
<td>84</td>
<td>80.83</td>
</tr>
<tr>
<td>5</td>
<td>David</td>
<td>75</td>
<td>88</td>
<td>91</td>
<td>40</td>
<td>88</td>
<td>78</td>
<td>78.50</td>
</tr>
<tr>
<td>6</td>
<td>Emily</td>
<td>100</td>
<td>100</td>
<td>81</td>
<td>100</td>
<td>75</td>
<td>94</td>
<td>91.67</td>
</tr>
<tr>
<td>7</td>
<td>Ferdinand</td>
<td>85</td>
<td>93</td>
<td>73</td>
<td>60</td>
<td>50</td>
<td>72</td>
<td>72.17</td>
</tr>
<tr>
<td>8</td>
<td>Georgia</td>
<td>70</td>
<td>80</td>
<td>55</td>
<td>39</td>
<td>75</td>
<td>67</td>
<td>64.33</td>
</tr>
<tr>
<td>9</td>
<td>Haley</td>
<td>85</td>
<td>93</td>
<td>82</td>
<td>70</td>
<td>75</td>
<td>76</td>
<td>80.17</td>
</tr>
<tr>
<td>10</td>
<td>Ian</td>
<td>100</td>
<td>100</td>
<td>91</td>
<td>90</td>
<td>100</td>
<td>96</td>
<td>96.17</td>
</tr>
<tr>
<td>11</td>
<td>Jennifer</td>
<td>85</td>
<td>93</td>
<td>73</td>
<td>80</td>
<td>100</td>
<td>90</td>
<td>86.83</td>
</tr>
</tbody>
</table>

Figure 438: Grading sheet example

Note

This simple tabular design is based on the relational database model, which is one of the most common and well-known design models used in modern databases.
Calc as a database-like program

As mentioned, a database table is similar to a spreadsheet, and can even be contained within one. Additionally, as a spreadsheet program, Calc offers several features, particularly sorting and filtering, that allow users to search tables similar to how one would in a database program such as LibreOffice Base or Microsoft Access. While this does not make Calc a replacement for either of those programs, it is nevertheless still useful for managing data in a small-scale personal or professional context without having to learn how to use a dedicated database system.

Associating a range with a name

In order to set up a database table in a Calc sheet, you first need to set up an area for it to occupy. This is necessary since some of Calc's database-like features depend on accessing or modifying a table's location. Such an area is represented by a range, which is a contiguous group of one or more cells. To make the range for a table easy to access, you can assign a meaningful name to it. Doing this has four particular benefits:

- **Giving a range a name makes it easier to identify**, especially if you are working with multiple ranges in a document.
- **A named range can be referenced by its name rather than just by its address.** For example, if you have a range named Scores, you can simply reference it in a cell with an equation like =SUM(Scores).
- **References by name to a named range are automatically updated every time the range's address is changed.** This prevents the need to change individual references every time a range's location is modified.
- **All named ranges can be quickly viewed and accessed through the Navigator**, which is opened by selecting View > Navigator, pressing the F5 key, or clicking on the icon in the Sidebar panel.

Two types of named range exist in Calc: **database ranges**, which store settings for database-like operations, and standard **named ranges**, which do not.

Named ranges

Standard named ranges are created using the Define Names dialog (Figure 439), which is opened by selecting Sheet > Named Ranges and Expressions > Define from the Menu bar.

![Define Names dialog](image)

Figure 439: Define Names dialog
To create a named range, select a range of cells from a sheet, then open the dialog. Next, give the range a meaningful name, and click on **Add** to add it to the current document's list of named ranges. You can then access and modify these ranges using the Manage Names dialog, which is opened by selecting **Sheet > Named Ranges and Expressions > Manage** from the Menu bar, or pressing **Ctrl+F3** (Figure 440). For more detail about how to create and manage ranges, see Chapter 6, Printing, Exporting, E-mailing, and Signing, and Chapter 7, Using Formulas and Functions.

![Manage Names dialog](image)

**Creating named ranges with macros**

In a macro, a named range is accessed, created, and deleted using the `NamedRanges` service of a Calc document. This service has a number of methods associated with it, the following of which are particularly useful for creating named ranges:

- **getByName(Name)**
  Returns the range or expression with the specified name.

- **getElementNames()**
  Returns an array of all named ranges in the current document.

- **hasByName(Name)**
  Returns a boolean: TRUE if a range with this name is in the current document, and FALSE otherwise.

- **addNewByName(Name, Content, Position, Type)**
  Adds a new named range to the current document. This method has four arguments:
- **Name** – A string that contains the name of the new range
- **Content** – A string that contains the range address or formula expression being named
- **Position** – The base address for relative cell references
- **Type** – A combination of flags that specify the type of named range being defined. These flags are listed in Table 12. This parameter defaults to zero for any common named range.

Table 12: com.sun.star.sheet.NamedRangeFlag constant group reference

<table>
<thead>
<tr>
<th>Value</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>FILTER_CRITERIA</td>
<td>The range contains filter criteria.</td>
</tr>
<tr>
<td>2</td>
<td>PRINT_AREA</td>
<td>The range can be used as a print range.</td>
</tr>
<tr>
<td>4</td>
<td>COLUMN_HEADER</td>
<td>The range can be used as column headers for printing.</td>
</tr>
<tr>
<td>8</td>
<td>ROW_HEADER</td>
<td>The range can be used as row headers for printing.</td>
</tr>
</tbody>
</table>

As an example, the macro in Listing 13 uses the above methods to check if a range with a given name exists. If it does not exist, then the macro creates a range with the name and sets it to access the cell range B3:D6.

Listing 13: AddNamedRange creates a new named range that references $Sheet1.$B$3:$D$6

```vba
Sub AddNamedRange()
    Dim oRange     ' The created range.
    Dim oRanges    ' All named ranges.
    Dim sName$     ' Name of the named range to be created.
    Dim oCell      ' Cell object.
    Dim s$

    sName$ = "MyNRange"
    oRanges = ThisComponent.NamedRanges
    If NOT oRanges.hasByName(sName$) Then
        REM Setting the base address for relative cell references
        Dim oCellAddress As new com.sun.star.table.CellAddress
        oCellAddress.Sheet = 0     'The first sheet.
        oCellAddress.Column = 1    'Column B.
        oCellAddress.Row = 2       'Row 3.

        REM The first argument is the range name.
        REM The second argument is a string that defines the formula
        REM or expression to be used.
        REM The third argument specifies the base address for
        REM relative cell references.
        REM The fourth argument is a set of flags that define
```

410 | Associating a range with a name
REM how the range is used, but most ranges use 0.
REM The fourth argument uses values from the
REM NamedRangeFlag constants.
s$ = "$Sheet1.$B$3:$D$6"
oRanges.addNewByName(sName$, s$, oCellAddress, 0)
End If
REM Get the created named range.
oRange = ThisComponent.NamedRanges.getByName(sName$)

REM Print the string contained in cell $Sheet1.$B$3
oCell = oRange.getReferredCells().getCellByPosition(0,0)
Print oCell.getString()
End Sub

Using relative references with named expressions
If a named range uses any cell addresses that are not absolute, then these addresses will be
referenced relative to the range's base address, which is defined by the third argument of the
addNewByName method, Position. This behavior is illustrated in Listing 14, where the macro
AddNamedFunction creates the named expression AddLeft. This expression references the
equation A3+B3 with C3 as its base address. Because relative references are being used, AddLeft
sums the values of the two cells directly to the left of any cell containing the equation =AddLeft.
For example, if AddLeft is referenced in cell E5, then it will sum the values in C5 and D5 (Figure
441).

Note
For more information about absolute and relative references, see Chapter 7, Using
Formulas and Functions.

Listing 14: AddNamedFunction creates the AddLeft named formula expression

Sub AddNamedFunction()
Dim oSheet          'Sheet that contains the range oRange.
Dim oCellAddress    'Address for relative references.
Dim oRanges         'TheNamedRanges property.
Dim oRange          'Single cell range.
Dim sName As String 'Name of the equation to create.
sName = "AddLeft"
oRanges = ThisComponent.NamedRanges
If NOT oRanges.hasByName(sName) Then
    oSheet = ThisComponent.getSheets().getByIndex(0)
oRange = oSheet.getCellRangeByName("C3")
oCellAddress = oRange.getCellAddress()
Tip

Listing 14 illustrates another little-known attribute of Calc: named ranges are a subset of named expressions, which can include formulas as well.

Creating named ranges using row or column headers

With the Create Names tool, which is accessed by selecting Sheet > Named Ranges and Expressions > Create from the Menu bar (Figure 442), you can create multiple named ranges simultaneously from the headers of a table. These headers can be drawn from the table’s borders – top and bottom rows and left and right columns – and each row or column that corresponds to each header are used to create the named ranges themselves. For example, if you choose to create ranges from headers contained in the top row of a table, each range will be generated from the individual columns that correspond to each header label.

Note

Header cells are not included in the named ranges generated using the Create Names tool. This is because the labels in each of these cell are used to name the ranges.

To use the Create Names tool:

1) In a sheet, select the table from which to create the named ranges. Be sure to include the header rows or columns as part of your selection.
2) Open the Create Names From dialog by selecting Sheet > Named Ranges and Expressions > Create from the Menu bar.
3) Calc automatically identifies which rows or columns contain headers, and will mark the checkboxes – Top row, Left column, Bottom row, Right column – that apply. However, if you wish to change this selection, you can manually select any of the boxes at this point.
4) Click on OK to close the dialog and create the new named ranges.

Creating named ranges from labels using macros

In addition to the Create Names From dialog, named ranges can be generated from labels using the macro method addNewFromTitles:
addNewFromTitles(Source, Border)

Creates named ranges from column or row headers. This method has two arguments:

– **Source** – The cell range address of the named range to be created
– **Border** – Is an enumeration value that specifies the location of the header labels. This enumeration has one of four possible values (Table 13):

<table>
<thead>
<tr>
<th>Enumerator</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>TOP</td>
<td>Selects the top border row.</td>
</tr>
<tr>
<td>BOTTOM</td>
<td>Selects the bottom border row.</td>
</tr>
<tr>
<td>RIGHT</td>
<td>Selects the right border column.</td>
</tr>
<tr>
<td>LEFT</td>
<td>Selects the left border column.</td>
</tr>
</tbody>
</table>

**Tip**

To generate names from multiple borders, you must call `addNewFromTitles` for each header row or column that you wish to use.

The macro in Listing 15 creates three named ranges using headers from the top row of the range A1:C20 (Figure 443). Figure 444 shows the resulting ranges listed in the Manage Names dialog, which is accessed by selecting **Sheet > Named Ranges and Expressions > Manage**.

![Figure 443: Example range A1:C20](image)

**Listing 15: AddManyNamedRanges creates named ranges using labeled columns**

```vba
Sub AddManyNamedRanges()
    Dim oSheet    'Sheet that contains the named range.
    Dim oAddress  'Range address.
    Dim oRanges   'The NamedRanges property.
```
Dim oRange  'Single cell range.

oRanges = ThisComponent.NamedRanges
oSHEET = ThisComponent.getSheets().getByIndex(0)

oRange = oSHEET.getCellRangeByName("A1:C20")
oAddress = oRange_ADDRESS
oRanges.addNewFromTitles(oAddress, com.sun.star.sheet.Border.TOP)

End Sub

<table>
<thead>
<tr>
<th>Name</th>
<th>Range or formula expression</th>
<th>Scope</th>
</tr>
</thead>
<tbody>
<tr>
<td>X</td>
<td>$Sheet1!$A$1:$A$20</td>
<td>Document (Global)</td>
</tr>
<tr>
<td>X_2</td>
<td>$Sheet1!$B$2:$B$20</td>
<td>Document (Global)</td>
</tr>
<tr>
<td>X_3</td>
<td>$Sheet1!$C$2:$C$20</td>
<td>Document (Global)</td>
</tr>
</tbody>
</table>

Figure 444: Manage Names dialog with generated named ranges

Caution

Avoid giving multiple rows or columns the same label, as the ranges generated from them will likewise share the same name, and can end up being overwritten by Calc.

Database ranges

Although it can be used like a regular named range, a database range is, unsurprisingly, meant to be used like a database table, with each row representing a record and each cell as fields within each record. Specifically, a database range differs from a named range in the following ways:

- A database range cannot be a formula expression, only a cell range. This range can be formatted as a table, with the first row reserved for headings and the last row for subtotals. Cell formatting can also be preserved for each field in the table.
- Database ranges cannot be referenced relative to a base address within a sheet.
- Database ranges store sorting, filtering, subtotaling, and data import settings in data structures called descriptors, which can be retrieved and accessed using macros.
- A database range can be linked to an external database source, and can be refreshed by selecting Data > Refresh Range from the Menu bar. Registering and linking to external database sources are explained in more detail in Chapter 10, Linking Data.
- Database ranges can be created, modified, and deleted using the Define Database Range dialog, which is opened by selecting Data > Define Range from the Menu bar (Figure 445).
To create a database range:

1) Select a range of cells from a sheet.
2) Open the Define Database Range dialog by using Data > Define Range.
3) Type a name for the range in the Name field. Only use letters, numbers, and underscores; spaces, hyphens, and other characters are not allowed.
4) Click on the plus (+) sign next to the Options label to expand this section and view and select the following options:
   - Contains column labels – Denotes whether the top row is reserved for field headings.
   - Contains totals row – Denotes whether the bottom row is reserved for totals.
   - Insert or delete cells – If active, this option will insert new rows and columns into the database range when new records are added to its source. Only works if an external database source is linked to the range. To manually update the database range, use Data > Refresh Range.
   - Keep formatting – Applies the existing cell formats of the first data row to the whole database range.
   - Don’t save imported data – If selected, this option only saves a reference to the source database; the contents of the range’s cells are not preserved.
   - Source – Displays information about the current database source, if one exists.
   - Operations – Denotes what operations, such as sorting or filtering, have been applied to the database range.

Figure 445: Define Database Range dialog
5) Click **Add** to add a range to the database range list under the **Name** field.

To modify an existing database range:

1) Select a range from the range list under the **Name** field or type its name into the **Name** field. The **Add** button will change to **Modify** at this point.

2) Make any modifications in the **Range** field and the **Options** section.

3) Click **Modify** to update the range.

To delete an existing database range, select it from the range list, then click **Delete**.

To select an existing database range from the current document, open the Select Database Range dialog by choosing **Data > Select Range** from the Menu bar (Figure 446). Next, select a range from the **Ranges** list and click **OK**. Calc will automatically highlight the range’s position in the sheet in which it is located.

---

**Creating database ranges with macros**

In a macro, a database range is created, accessed, and deleted using the **DatabaseRanges** service. This service has many of the same methods as the **NamedRanges** service, but lacks the **addNewFromTitles** method. **DatabaseRanges** also uses a reduced version of the **addNewByName** method that lacks arguments for a relative base address and range type:

- **addNewByName**(Name, Range)
  - Adds a new database range to the current document.

As an example of creating a range using this method, the macro in Listing 16 creates a database range named **MyName** and automatically applies auto filters to each of the range’s columns:

**Listing 16: AddNewDatabaseRange creates a database range and applies an auto filter**

Sub AddNewDatabaseRange()
    Dim oRange 'DatabaseRange object.
    Dim oAddr  'Cell address range for the database range.
    Dim oSheet 'First sheet, which will contain the range.
    Dim oDoc   'Reference ThisComponent with a shorter name.

    oDoc = ThisComponent
    If NOT oDoc.DatabaseRanges.hasByName("MyName") Then
        oSheet = ThisComponent.getSheets().getByIndex(0)
Sorting

Sorting is the process of rearranging data in a range or a sheet according to a specified sort order. In Calc, sorting is commonly done using the Sort dialog, which is accessed by selecting Data > Sort from the Menu bar. How to use this dialog and its options is described in further detail in Chapter 2, Entering, Editing, and Formatting Data. Here, we present how to sort data in the context of macros.

Figure 447: Sort dialog

Sorting a table using one column with a macro

In a Calc macro, data within a range is sorted by calling the sort() method on the range object. When a sort operation is called on a range, an array of properties known as a sort descriptor, is passed to the sort routine. Contained within a descriptor’s properties are sort fields, which are structures that inform Calc how to sort a range according to the data contained within one of its rows or columns.

As an example, the macro in Listing 17 sorts the grade sheet from Figure 438 according to average grade in descending order. The results are shown in Figure 448.

Listing 17: SortAverageGrade sorts the grade sheet data range (A1:H11) using a single column

Sub SortAverageGrade
    Dim oSheet
    Dim oRange
    Dim oSortFields(0) as new com.sun.star.util.SortField
    Dim oSortDesc(0) as new com.sun.star.beans.PropertyValue
    oRange = oSheet.getCellRangeByName("A1:F10")
    oAddr = oRange.getRangeAddress()
    oDoc.DatabaseRanges.addNewByName("MyName", oAddr)
    End If
    oRange = oDoc.DatabaseRanges.getByName("MyName")
    oRange.AutoFilter = True
End Sub
oSheet = ThisComponent.Sheets(0)
REM Set the range on which to sort
oRange = oSheet.getCellRangeByName("A1:H11")

REM Sort by the Average grade field in the range in descending order
oSortFields(0).Field = 7
oSortFields(0).SortAscending = FALSE

REM Set the sort fields to use
oSortDesc(0).Name = "SortFields"
oSortDesc(0).Value = oSortFields()

REM Now sort the range!
oRange.Sort(oSortDesc())
End Sub

<p>| | | | | | | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Student</td>
<td>HW #1</td>
<td>HW #2</td>
<td>HW #3</td>
<td>Quiz #1</td>
<td>Quiz #2</td>
<td>Test #1</td>
</tr>
<tr>
<td>2</td>
<td>Ian</td>
<td>100</td>
<td>100</td>
<td>91</td>
<td>90</td>
<td>100</td>
<td>96</td>
</tr>
<tr>
<td>3</td>
<td>Emily</td>
<td>100</td>
<td>100</td>
<td>81</td>
<td>100</td>
<td>75</td>
<td>94</td>
</tr>
<tr>
<td>4</td>
<td>Andrew</td>
<td>90</td>
<td>100</td>
<td>82</td>
<td>90</td>
<td>88</td>
<td>92</td>
</tr>
<tr>
<td>5</td>
<td>Bethany</td>
<td>95</td>
<td>100</td>
<td>82</td>
<td>80</td>
<td>88</td>
<td>93</td>
</tr>
<tr>
<td>6</td>
<td>Jennifer</td>
<td>85</td>
<td>93</td>
<td>73</td>
<td>80</td>
<td>100</td>
<td>90</td>
</tr>
<tr>
<td>7</td>
<td>Charles</td>
<td>80</td>
<td>93</td>
<td>73</td>
<td>80</td>
<td>75</td>
<td>84</td>
</tr>
<tr>
<td>8</td>
<td>Haley</td>
<td>85</td>
<td>93</td>
<td>82</td>
<td>70</td>
<td>75</td>
<td>76</td>
</tr>
<tr>
<td>9</td>
<td>David</td>
<td>75</td>
<td>86</td>
<td>91</td>
<td>40</td>
<td>88</td>
<td>79</td>
</tr>
<tr>
<td>10</td>
<td>Ferdinand</td>
<td>85</td>
<td>93</td>
<td>73</td>
<td>60</td>
<td>50</td>
<td>72</td>
</tr>
<tr>
<td>11</td>
<td>Georgia</td>
<td>70</td>
<td>80</td>
<td>55</td>
<td>30</td>
<td>75</td>
<td>67</td>
</tr>
</tbody>
</table>

Figure 448: Grading sheet after sorting by average grade in descending order

**Sorting a table using multiple columns**

As with the Sort dialog, a range can be sorted using up to three columns or rows in a macro. Sorting with extra columns or rows is as easy as adding extra sort fields to a sort descriptor. The macro in Listing 18 again uses the grade sheet example from Figure 438 to illustrate how to sort by two columns. Figure 449 shows the results of this operation – note that records are sorted first by Quiz #1 scores, then Quiz #2 scores.

**Listing 18: SortByQuizScores sorts the grade sheet data range (A1:H11) using two columns**

Sub SortByQuizScores
    Dim oSheet
    Dim oRange
    Dim oSortFields(1) As new com.sun.star.util.SortField
    Dim oSortDesc(0) As new com.sun.star.beans.PropertyValue

    oSheet = ThisComponent.Sheets(0)
    REM Set the range on which to sort
    oRange = oSheet.getCellRangeByName("A1:H11")

    REM Sort by the Average grade field in the range in descending order
    oSortFields(0).Field = 7
    oSortFields(0).SortAscending = FALSE

    REM Set the sort fields to use
    oSortDesc(0).Name = "SortFields"
oSortDesc(0).Value = oSortFields()

    REM Now sort the range!
oRange.Sort(oSortDesc())
End Sub
REM Set the range on which to sort
oRange = oSheet.getCellRangeByName("A1:H11")

REM Sort by the Quiz #1 field in the range
oSortFields(0).Field = 4
oSortFields(0).SortAscending = True
oSortFields(0).FieldType = com.sun.star.util.SortFieldType.NUMERIC

REM Sort by the Quiz #2 field in the range
oSortFields(1).Field = 5
oSortFields(1).SortAscending = True
oSortFields(1).FieldType = com.sun.star.util.SortFieldType.ALPHANUMERIC

REM Set the sort fields to use
oSortDesc(0).Name = "SortFields"
oSortDesc(0).Value = oSortFields()

REM Now sort the range!
oRange.Sort(oSortDesc())

End Sub

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
<th>H</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Student</td>
<td>HW #1</td>
<td>HW #2</td>
<td>HW #3</td>
<td>Quiz #1</td>
<td>Quiz #2</td>
<td>Test #1</td>
<td>Average</td>
</tr>
<tr>
<td>2</td>
<td>Georgia</td>
<td>70</td>
<td>80</td>
<td>55</td>
<td>39</td>
<td>75</td>
<td>67</td>
<td>64.33</td>
</tr>
<tr>
<td>3</td>
<td>David</td>
<td>75</td>
<td>86</td>
<td>91</td>
<td>40</td>
<td>88</td>
<td>79</td>
<td>76.50</td>
</tr>
<tr>
<td>4</td>
<td>Ferdinand</td>
<td>85</td>
<td>93</td>
<td>73</td>
<td>60</td>
<td>50</td>
<td>72</td>
<td>72.17</td>
</tr>
<tr>
<td>5</td>
<td>Haley</td>
<td>85</td>
<td>93</td>
<td>82</td>
<td>70</td>
<td>75</td>
<td>76</td>
<td>80.17</td>
</tr>
<tr>
<td>6</td>
<td>Charles</td>
<td>80</td>
<td>93</td>
<td>73</td>
<td>80</td>
<td>75</td>
<td>84</td>
<td>80.83</td>
</tr>
<tr>
<td>7</td>
<td>Bethany</td>
<td>95</td>
<td>100</td>
<td>82</td>
<td>80</td>
<td>88</td>
<td>93</td>
<td>89.67</td>
</tr>
<tr>
<td>8</td>
<td>Jennifer</td>
<td>85</td>
<td>93</td>
<td>73</td>
<td>80</td>
<td>100</td>
<td>90</td>
<td>86.83</td>
</tr>
<tr>
<td>9</td>
<td>Andrew</td>
<td>90</td>
<td>100</td>
<td>82</td>
<td>90</td>
<td>88</td>
<td>92</td>
<td>90.33</td>
</tr>
<tr>
<td>10</td>
<td>Ian</td>
<td>100</td>
<td>100</td>
<td>91</td>
<td>90</td>
<td>100</td>
<td>96</td>
<td>96.17</td>
</tr>
<tr>
<td>11</td>
<td>Emily</td>
<td>100</td>
<td>100</td>
<td>81</td>
<td>100</td>
<td>75</td>
<td>94</td>
<td>91.67</td>
</tr>
</tbody>
</table>

Figure 449: Grading sheet sorted by quiz scores in ascending order

Retrieving sorting information from a range

You can use the method `createSortDescriptor()` to retrieve the sorting information for a given cell range. If this method is called on a database range, it will create a sort descriptor using the sorting information stored with that range. On the other hand, if `createSortDescriptor()` is called on a standard named range or an unnamed range, it will generate a sort descriptor with default
properties. In either case, the newly-generated sort descriptor can be modified and passed as an argument to a sort routine called on a given range.

The macro in Listing 19 demonstrates how to generate and display the sorting information associated with a range. The output of this macro is displayed in Figure 450.

**Listing 19: DisplaySortDescriptor displays sort descriptor properties in a dialog**

```vba
Sub DisplaySortDescriptor
    On Error Resume Next
    Dim oSheet
    Dim oRange   ' A range is needed to create the sort descriptor.
    Dim oSortDescript
    Dim i%
    Dim s$
    Dim oDoc    'Reference newly created calc document.

    oDoc = StarDesktop.loadComponentFromURL("private:factory/scalc", "_default", 0, Array())
    oSheet = oDoc.Sheets(0)
    oRange = oSheet.getCellRangeByName("B28:D33")
    oSortDescript = oRange.createSortDescriptor()
    For i = LBound(oSortDescript) To UBound(oSortDescript)
        s = s & oSortDescript(i).Name & " = "
        s = s & oSortDescript(i).Value
        s = s & CHR$(10)
    Next
    MsgBox s, 0, "Sort Descriptor"
End Sub
```

Figure 450: Sort descriptor info
Filtering

A filter is a tool that hides or displays records within a sheet based on a set of filtering criteria. Similar to sorting, filters are useful for narrowing down long lists of data in order to find particular data items. In Calc, three types of filter exist:

- AutoFilters
- Standard filters
- Advanced filters.

Filters are also described in Chapter 2, Entering, Editing, and Formatting Data.

AutoFilter

AutoFilters are the most straightforward of the three filter types, and work by inserting a combo box into one or more data columns (Figure 451). To add an AutoFilter to one or more columns, simply select the columns, then select Data > AutoFilter from the Menu bar. To access the AutoFilter combo box for a column, click on the down-arrow button in the first cell of that column.

![Figure 451: Auto filter combo box](image)

To remove an AutoFilter, select the columns again and click on Data > AutoFilter. Each combo box and down-arrow button will disappear. In this way, the menu option acts like a toggle for AutoFilters.

Each AutoFilter combo box has the following set up of criteria:

- A basic sort can be applied using the Sort Ascending or Sort Descending options.
- The Standard Filter option opens the Standard Filter dialog (Figure 452) and automatically sets the current field as the field for the first condition in the dialog.
- Selecting Empty hides all non-empty rows that contain a value in the current column. Likewise, selecting Not Empty hides all non-empty rows that lack a value in the current column. Entirely empty rows are ignored.
• Selecting the Top 10 filter causes the ten rows with the largest value to be displayed. More than ten rows may be displayed if there are more than ten instances of the largest value in a column. For example, if there are eleven students with a perfect score of 100, then the filter will display all eleven instances.

• Check the All box to display or hide all values in the current column.

• The auto filter creates entries for each unique value in the current column. These values can be filtered simply by checking off any of the check boxes next to each entry.

Toggling AutoFilters with a macro
Database ranges in Calc contain an AutoFilter boolean flag that allows you to toggle auto filters on or off. The macro from Listing 16 demonstrates how to do this.

Standard filters
Standard filters are more complex than AutoFilters, and allow for up to eight filter conditions. Also, unlike AutoFilters, standard filters use a dialog (Figure 452), which is accessed by selecting Data > More Filters > Standard Filter from the Menu bar.

Creating standard filters with macros
In a macro, filtering a data range is performed by calling the filter() routine either on the range or the sheet in which the range is contained. Like a sort descriptor, a filter descriptor contains the filter settings for the current sheet, such as whether the first row or column in the sheet contains headers which should not be filtered. A filter descriptor can be generated by calling the createFilterDescriptor() method on a sheet or on a cell range:

createFilterDescriptor(Empty)
Creates a filter descriptor. If the boolean flag Empty is set to TRUE, then an empty filter descriptor is created. If Empty is FALSE, then the descriptor is filled with the previous settings of the current object (such as a database range).

As with sort descriptors, filter descriptors can be created using this method, then modified and passed as an argument to the filter method. The macro in Listing 20 demonstrates this process by
creating a simple standard filter for the first sheet in a document. Figure 453 display the results of filtering the grading sheet example in Figure 438:

Listing 20: SimpleSheetFilter creates a simple standard filter

Sub SimpleSheetFilter()
    Dim oSheet       ' Sheet that will contain the filter.
    Dim oFilterDesc  ' Filter descriptor.
    Dim oFields(0) As New com.sun.star.sheet.TableFilterField

    oSheet = ThisComponent.getSheets().getByIndex(0)

    REM If argument is True, creates an empty filter
    REM descriptor. If argument is False, create a
    REM descriptor with the previous settings.
    oFilterDesc = oSheet.createFilterDescriptor(True)

    With oFields(0)
        REM You could use the Connection property to indicate
        REM how to connect to the previous field. This is
        REM the first field, so this is not required.
        '.Connection = com.sun.star.sheet.FilterConnection.AND
        '.Connection = com.sun.star.sheet.FilterConnection.OR

        REM The Field property is the zero based column
        REM number to filter. If you have the cell, you
        .Field = 5        ' The Quiz #2 grades field

        REM Compare using a numeric or a string?
        .IsNumeric = True

        REM The NumericValue property is used
        REM because .IsNumeric = True from above.
        .NumericValue = 80

        REM If IsNumeric was False, then the
        REM StringValue property would be used.
        REM .StringValue = "what ever"

        REM Valid operators include EMPTY, NOT_EMPTY, EQUAL,
        REM NOT_EQUAL, GREATER, GREATER_EQUAL, LESS,
REM LESS_EQUAL, TOP_VALUES, TOP_PERCENT,
REM BOTTOM_VALUES, and BOTTOM_PERCENT
End With

REM The filter descriptor supports the following
REM properties: IsCaseSensitive, SkipDuplicates,
REM UseRegularExpressions,
REM SaveOutputPosition, Orientation, ContainsHeader,
REM CopyOutputData, OutputPosition, and MaxFieldCount.
oFilterDesc.setFilterFields(oFields())
oFilterDesc.ContainsHeader = True
oSheet.filter(oFilterDesc)
End Sub

<p>| | | | | | | | |</p>
<table>
<thead>
<tr>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
<th></th>
</tr>
</thead>
<tbody>
<tr>
<td>A</td>
<td>B</td>
<td>C</td>
<td>D</td>
<td>E</td>
<td>F</td>
<td>G</td>
<td>H</td>
</tr>
<tr>
<td>-----</td>
<td>-----</td>
<td>-----</td>
<td>-----</td>
<td>-----</td>
<td>-----</td>
<td>-----</td>
<td>-----</td>
</tr>
<tr>
<td>1</td>
<td>Student</td>
<td>HW #1</td>
<td>HW #2</td>
<td>HW #3</td>
<td>Quiz #1</td>
<td>Quiz #2</td>
<td>Test #1</td>
</tr>
<tr>
<td>2</td>
<td>Andrew</td>
<td>90</td>
<td>100</td>
<td>82</td>
<td>90</td>
<td>88</td>
<td>92</td>
</tr>
<tr>
<td>3</td>
<td>Bethany</td>
<td>95</td>
<td>100</td>
<td>82</td>
<td>88</td>
<td>93</td>
<td>93</td>
</tr>
<tr>
<td>5</td>
<td>David</td>
<td>75</td>
<td>86</td>
<td>91</td>
<td>40</td>
<td>88</td>
<td>79</td>
</tr>
<tr>
<td>10</td>
<td>Ian</td>
<td>100</td>
<td>100</td>
<td>91</td>
<td>90</td>
<td>100</td>
<td>96</td>
</tr>
<tr>
<td>11</td>
<td>Jennifer</td>
<td>85</td>
<td>93</td>
<td>73</td>
<td>80</td>
<td>100</td>
<td>90</td>
</tr>
</tbody>
</table>

Figure 453: Grading sheet filtered by Quiz #2 values greater than 80

Note

When the filter method is called on a sheet, every empty row in the sheet is hidden. When filter is called on a range, only empty rows in the range itself are hidden.

Clearing all filters for a sheet

When a filter is applied to a sheet, it replaces any existing filter for that sheet. Therefore, to remove a filter in a sheet, simply create and set an empty filter for that sheet (Listing 21).

Listing 21: RemoveSheetFilter removes the current sheet filter by setting an empty filtered

Sub RemoveSheetFilter()
  Dim oSheet          ' Sheet to filter.
  Dim oFilterDesc     ' Filter descriptor.

  oSheet = ThisComponent.getSheets().getById(0)
oFilterDesc = oSheet.createFilterDescriptor(True)
oSheet.filter(oFilterDesc)
End Sub

424 | Filtering
Filtering multiple columns and filtering with regular expressions

The macro in Listing 22 demonstrates a filter that filters two columns and uses regular expressions. Note that the filter method is called on a range rather than its sheet in this example. Figure 454 displays the results of this macro on the grading sheet example in Figure 438.

Listing 22: SimpleRangeFilter uses two columns

Sub SimpleRangeFilter()
    Dim oSheet          ' Sheet to filter.
    Dim oRange          ' Range to be filtered.
    Dim oFilterDesc     ' Filter descriptor.
    Dim oFields(1) As New com.sun.star.sheet.TableFilterField

    oSheet = ThisComponent.getSheets().getByIndex(0)
    oRange = oSheet.getCellRangeByName("A1:H11")

    REM If argument is True, creates an
    REM empty filter descriptor.
    oFilterDesc = oRange.createFilterDescriptor(True)

    REM Setup a field to view cells with content that
    REM start with the letter B.
    With oFields(0)
        .Field = 0              ' Filter column A (Student names).
        .IsNumeric = False      ' Use a string, not a number.
        .StringValue = "b.*"    ' Every name starting with a B.
    End With

    REM Set up a field that requires at least one of the conditions.
    REM This new condition requires a value less than or
    REM equal to 90.
    With oFields(1)
        .Connection = com.sun.star.sheet.FilterConnection.OR
        .Field = 6              ' Filter column G (Test #1 grades).
        .IsNumeric = True       ' Use a number
        .NumericValue = 90      ' Scores less than 90
    End With

    oFilterDesc.setFilterFields(oFields())
    oFilterDesc.ContainsHeader = True
    oFilterDesc.UseRegularExpressions = True
End Sub
Advanced filters

In Calc, the criteria for an advanced filter are stored in a sheet rather than entered into a dialog. As a result, you must first set up a cell range that contains the criteria before you use the Advanced Filter dialog (Figure 455).

To set up a criteria range:

1) Copy the column headings of the range to be filtered to an empty space in a sheet. It does not need to be the same sheet as the one with the source range.

2) Enter filter criteria underneath the column headings in the criteria range. Each individual criterion in the same row is connected with AND, while the criteria groups from each row are connected with OR. Empty cells are ignored. Up to eight criteria rows may be defined for a filter.

After creating a criteria range, set up an advanced filter as follows:

1) Select the cell range that you wish to filter.

2) Go to Data > More Filters > Advanced Filter in the Menu bar to open the Advanced Filter dialog (Figure 455).

3) In the Read Filter Criteria From field, enter the address for a named range, either by selecting a named range from the drop-down box, typing in a reference, or selecting cells from a sheet. Remember to use the Shrink / Expand button if you need to temporarily minimize the dialog while selecting cells.
4) Click OK to apply the filter and close the dialog.

Advanced filter options are the same as standard filter options, and are described in further detail in Chapter 2, Entering, Editing, and Formatting Data.

**Advanced filter example**

Figure 456 demonstrates an example filter range for the grading sheet example in Figure 438:

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
<th>H</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Student</td>
<td>HW #1</td>
<td>HW #2</td>
<td>HW #3</td>
<td>Quiz #1</td>
<td>Quiz #2</td>
<td>Test #1</td>
</tr>
<tr>
<td>2</td>
<td>Ferdinand</td>
<td>&gt;75</td>
<td>&gt;75</td>
<td>&gt;75</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

*Figure 456: Advanced filter criteria range (in Sheet 2)*

In this range, there are two criteria groups: the first displays the records of students who scored above a 75% in every homework, and the second displays records of any student named Ferdinand. Figure 457 displays the result of this filter operation using these criteria:

<table>
<thead>
<tr>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
<th>H</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Student</td>
<td>HW #1</td>
<td>HW #2</td>
<td>HW #3</td>
<td>Quiz #1</td>
<td>Quiz #2</td>
<td>Test #1</td>
</tr>
<tr>
<td>2</td>
<td>Andrew</td>
<td>90</td>
<td>100</td>
<td>82</td>
<td>90</td>
<td>88</td>
<td>92</td>
</tr>
<tr>
<td>3</td>
<td>Bethany</td>
<td>95</td>
<td>100</td>
<td>82</td>
<td>80</td>
<td>88</td>
<td>93</td>
</tr>
<tr>
<td>6</td>
<td>Emily</td>
<td>100</td>
<td>100</td>
<td>81</td>
<td>100</td>
<td>75</td>
<td>94</td>
</tr>
<tr>
<td>7</td>
<td>Ferdinand</td>
<td>85</td>
<td>93</td>
<td>73</td>
<td>60</td>
<td>50</td>
<td>72</td>
</tr>
<tr>
<td>9</td>
<td>Haley</td>
<td>85</td>
<td>93</td>
<td>82</td>
<td>70</td>
<td>75</td>
<td>76</td>
</tr>
<tr>
<td>10</td>
<td>Ian</td>
<td>100</td>
<td>100</td>
<td>91</td>
<td>90</td>
<td>100</td>
<td>96</td>
</tr>
<tr>
<td>12</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

*Figure 457: Grading sheet example filtered using an advanced filter*

**Using an advanced filter with macros**

Applying an advanced filter with a macro works similarly to setting up a standard filter. The key difference is that the cell range containing the filter criteria is used to create the filter descriptor. The macro in Listing 23 demonstrates how this is done using the `createFilterDescriptorByObject` method. It uses the grading sheet example in Figure 438 as the data range and the range in Figure 456 as the criteria range. The results should be the same as those found in Figure 457:

**Listing 23: AdvancedRangeFilter creates a filter descriptor from the filter criteria range**

Sub AdvancedRangeFilter()
    Dim oSheet 'A sheet from the Calc document.
    Dim oRanges 'The NamedRanges property.
    Dim oCritRange 'Range that contains the filter criteria.
    Dim oDataRange 'Range that contains the data to filter.
    Dim oFiltDesc 'Filter descriptor.

    REM Range that contains the filter criteria
    oSheet = ThisComponent.getSheets().getByIdex(1)
    oCritRange = oSheet.getCellRangeByName("A1:H3")

    REM You can also obtain the range containing the
    REM filter criteria from a named range.

Advanced filters | 427
REM oRanges = ThisComponent.NamedRanges
REM oRange = oRanges.getByName("AverageLess80")
REM oCritRange = oRange.getReferredCells()

REM The data that you want to filter
oSHEET = ThisComponent.getSheets().getByIndex(0)
oDataRange = oSheet.getCellRangeByName("A1:H11")

oFiltDesc = oCritRange.createFilterDescriptorByObject(oDataRange)
oDataRange.filter(oFiltDesc)
End Sub

Table 14 contains a list of properties that correspond to advanced (and standard) filter settings:

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>ContainsHeader</td>
<td>Boolean (TRUE/FALSE) that specifies if the first row or column contains headers which should not be filtered.</td>
</tr>
<tr>
<td>CopyOutputData</td>
<td>Boolean that specifies if the filtered data should be copied to another position in the document.</td>
</tr>
<tr>
<td>IsCaseSensitive</td>
<td>Boolean that specifies if the case of letters is important when comparing entries.</td>
</tr>
<tr>
<td>Orientation</td>
<td>An enumeration that specifies if a range is filtered by column or row: Column – com.sun.star.table.TableOrientation.COLUMNS Row – com.sun.star.table.TableOrientation.ROWS</td>
</tr>
<tr>
<td>OutputPosition</td>
<td>If CopyOutputData is TRUE, this property specifies the position where filtered data are to be copied.</td>
</tr>
<tr>
<td>SaveOutputPosition</td>
<td>Boolean that specifies if the OutputPosition position is saved for future calls.</td>
</tr>
<tr>
<td>SkipDuplicates</td>
<td>Boolean that specifies if duplicate entries are left out of the result.</td>
</tr>
<tr>
<td>UseRegularExpressions</td>
<td>Boolean that specifies if the filter strings are interpreted as regular expressions.</td>
</tr>
</tbody>
</table>

**Copy advanced filter results to a different location**

The results of an advanced filter can be extracted to a different position using the OutputPosition property. Copying results in this way eliminates the need for Calc to hide rows that do not match search criteria, which it would normally do if you filter in-place.

The macro code snippet in Listing 24 demonstrates how to copy filter results to a different location, and Figure 458 shows the results when this snippet is applied to the macro in Listing 23 just before the filter method is called. Note that the filter descriptor must first be modified before these filter settings are applied.

Listing 24: A code snippet that copies filtered results to a different locations

```vbnet
REM Copy the output data rather than filter in place.
oFiltDesc.CopyOutputData = True
```

428 | Filtering
REM Create a CellAddress and set it for Sheet1
REM Column B, Row 13 (remember, start counting with 0)
Dim outputCell As New com.sun.star.table.CellAddress
outputCell.Sheet = 0
outputCell.Column = 1
outputCell.Row = 12
oFiltDesc.OutputPosition = outputCell

Note
The OutputPosition property returns a copy of a struct. As a result, it is not possible to set individual values, such as the row or column, directly through this property. For example, oFilterDesc.OutputPosition.Row = 2 will not work, since it is the Row property on the copy, not the original, that changes.

<table>
<thead>
<tr>
<th></th>
<th>A</th>
<th>B</th>
<th>C</th>
<th>D</th>
<th>E</th>
<th>F</th>
<th>G</th>
<th>H</th>
<th>I</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>Student</td>
<td>HW #1</td>
<td>HW #2</td>
<td>HW #3</td>
<td>Quiz #1</td>
<td>Quiz #2</td>
<td>Test #1</td>
<td>Average</td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>Andrew</td>
<td>90</td>
<td>100</td>
<td>82</td>
<td>90</td>
<td>88</td>
<td>92</td>
<td>90.33</td>
<td></td>
</tr>
<tr>
<td>4</td>
<td>Bethany</td>
<td>95</td>
<td>100</td>
<td>82</td>
<td>80</td>
<td>88</td>
<td>93</td>
<td>89.67</td>
<td></td>
</tr>
<tr>
<td>5</td>
<td>Charles</td>
<td>80</td>
<td>93</td>
<td>73</td>
<td>80</td>
<td>75</td>
<td>84</td>
<td>80.83</td>
<td></td>
</tr>
<tr>
<td>6</td>
<td>David</td>
<td>75</td>
<td>86</td>
<td>91</td>
<td>40</td>
<td>88</td>
<td>79</td>
<td>76.50</td>
<td></td>
</tr>
<tr>
<td>7</td>
<td>Emily</td>
<td>100</td>
<td>100</td>
<td>81</td>
<td>100</td>
<td>75</td>
<td>94</td>
<td>91.67</td>
<td></td>
</tr>
<tr>
<td>8</td>
<td>Ferdinand</td>
<td>85</td>
<td>93</td>
<td>73</td>
<td>60</td>
<td>50</td>
<td>72</td>
<td>72.17</td>
<td></td>
</tr>
<tr>
<td>9</td>
<td>Georgia</td>
<td>70</td>
<td>80</td>
<td>55</td>
<td>39</td>
<td>75</td>
<td>87</td>
<td>64.33</td>
<td></td>
</tr>
<tr>
<td>10</td>
<td>Haley</td>
<td>85</td>
<td>93</td>
<td>82</td>
<td>70</td>
<td>75</td>
<td>76</td>
<td>80.17</td>
<td></td>
</tr>
<tr>
<td>11</td>
<td>Ian</td>
<td>100</td>
<td>100</td>
<td>91</td>
<td>90</td>
<td>90</td>
<td>86</td>
<td>86.17</td>
<td></td>
</tr>
<tr>
<td>12</td>
<td>Jennifer</td>
<td>85</td>
<td>93</td>
<td>73</td>
<td>80</td>
<td>100</td>
<td>90</td>
<td>88.83</td>
<td></td>
</tr>
<tr>
<td>13</td>
<td>Student</td>
<td>HW #1</td>
<td>HW #2</td>
<td>HW #3</td>
<td>Quiz #1</td>
<td>Quiz #2</td>
<td>Test #1</td>
<td>Average</td>
<td></td>
</tr>
<tr>
<td>14</td>
<td>Andrew</td>
<td>90</td>
<td>100</td>
<td>82</td>
<td>90</td>
<td>88</td>
<td>92</td>
<td>90.33</td>
<td></td>
</tr>
<tr>
<td>15</td>
<td>Bethany</td>
<td>95</td>
<td>100</td>
<td>82</td>
<td>80</td>
<td>88</td>
<td>93</td>
<td>89.67</td>
<td></td>
</tr>
<tr>
<td>16</td>
<td>Emily</td>
<td>100</td>
<td>100</td>
<td>81</td>
<td>100</td>
<td>75</td>
<td>94</td>
<td>91.67</td>
<td></td>
</tr>
<tr>
<td>17</td>
<td>Ferdinand</td>
<td>85</td>
<td>93</td>
<td>73</td>
<td>60</td>
<td>50</td>
<td>72</td>
<td>72.17</td>
<td></td>
</tr>
<tr>
<td>18</td>
<td>Haley</td>
<td>85</td>
<td>93</td>
<td>82</td>
<td>70</td>
<td>75</td>
<td>76</td>
<td>80.17</td>
<td></td>
</tr>
<tr>
<td>19</td>
<td>Ian</td>
<td>100</td>
<td>100</td>
<td>91</td>
<td>90</td>
<td>100</td>
<td>98</td>
<td>96.17</td>
<td></td>
</tr>
<tr>
<td>20</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Figure 458: Advanced filter results copied to cell B13

Useful database-like functions

Calc has many functions that are often used in the context of databases. Some of these functions are straightforward to use (like SUM) or are familiar in the context in which they are typically used (like STDEV for statistics). A few, like the LOOKUP functions, are somewhat more infrequently used, but are nevertheless useful to know if you plan to use Calc for database tables. This section provides a condensed list of some of these functions. Further reference material for all Calc's functions can be found in the Help system.

Note
Functions with the suffix -A treat text values as a number with the value of zero. Blank cells are still ignored by these functions.
<table>
<thead>
<tr>
<th>Function</th>
<th>Category</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>AVERAGE</td>
<td>Statistical</td>
<td>Returns the average of its arguments. Ignores empty cells and cells that contain text.</td>
</tr>
<tr>
<td>AVERAGEA</td>
<td>Statistical</td>
<td>Returns the average of its arguments, but only ignores empty cells. The value of text is 0.</td>
</tr>
<tr>
<td>AVERAGEIF</td>
<td>Statistical</td>
<td>Returns the arithmetic mean of all cells in a range that satisfy a given condition.</td>
</tr>
<tr>
<td>AVERAGEIFS</td>
<td>Statistical</td>
<td>Returns the arithmetic mean of all cells in a range that satisfy given multiple criteria</td>
</tr>
<tr>
<td>COUNT</td>
<td>Statistical</td>
<td>Counts the number of numeric values in a list of arguments. Ignores empty cells and cells that contain text.</td>
</tr>
<tr>
<td>COUNTA</td>
<td>Statistical</td>
<td>Counts the number of values in a list of arguments, but counts both numeric and text arguments. Empty cells are still ignored.</td>
</tr>
<tr>
<td>COUNTBLANK</td>
<td>Statistical</td>
<td>Returns the number of empty cells within a range.</td>
</tr>
<tr>
<td>COUNTIF</td>
<td>Statistical</td>
<td>Returns the number of cells in a range that meet the specified search criteria.</td>
</tr>
<tr>
<td>COUNTIFS</td>
<td>Statistical</td>
<td>Returns the number of cells that meet criteria in multiple ranges.</td>
</tr>
<tr>
<td>HLOOKUP</td>
<td>Spreadsheet</td>
<td>Searches for a “look-up” value in the first row of an array and returns a value from a different row in the same column.</td>
</tr>
<tr>
<td>INDEX</td>
<td>Spreadsheet</td>
<td>Returns the contents of a cell at a specified index (denoted by row and column numbers) within a range.</td>
</tr>
<tr>
<td>INDIRECT</td>
<td>Spreadsheet</td>
<td>Returns the reference specified by a text string.</td>
</tr>
<tr>
<td>LOOKUP</td>
<td>Spreadsheet</td>
<td>Returns the contents of a cell contained within a single row or column of a range or from an array.</td>
</tr>
<tr>
<td>MATCH</td>
<td>Spreadsheet</td>
<td>Searches an array for an item and returns its relative position in the array.</td>
</tr>
<tr>
<td>MAX</td>
<td>Statistical</td>
<td>Returns the largest value in a list of arguments.</td>
</tr>
<tr>
<td>MAXA</td>
<td>Statistical</td>
<td>Returns the largest value in a list of arguments. The value of text is 0.</td>
</tr>
<tr>
<td>MAXIFS</td>
<td>Statistical</td>
<td>Returns the largest value in the cells of a range that meet multiple criteria in multiple ranges.</td>
</tr>
<tr>
<td>MEDIAN</td>
<td>Statistical</td>
<td>Returns the median of a list of numbers.</td>
</tr>
<tr>
<td>MIN</td>
<td>Statistical</td>
<td>Returns the smallest value in a list of arguments.</td>
</tr>
<tr>
<td>MINA</td>
<td>Statistical</td>
<td>Returns the smallest value in a list of arguments. The value of text is 0.</td>
</tr>
<tr>
<td>MINIFS</td>
<td>Statistical</td>
<td>Returns the smallest value in the cells of a range that meet multiple criteria in multiple ranges.</td>
</tr>
<tr>
<td>MODE</td>
<td>Statistical</td>
<td>Returns the most common value in a list of values.</td>
</tr>
<tr>
<td>OFFSET</td>
<td>Spreadsheet</td>
<td>Return the value of a cell offset by certain number of rows and columns from a given reference point.</td>
</tr>
<tr>
<td>PRODUCT</td>
<td>Mathematical</td>
<td>Multiples all the numbers in a list of arguments and returns the product.</td>
</tr>
<tr>
<td>STDEV</td>
<td>Statistical</td>
<td>Calculates the standard deviation of a population sample.</td>
</tr>
</tbody>
</table>

430 | Useful database-like functions
<table>
<thead>
<tr>
<th>Function</th>
<th>Category</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>STDEVA</td>
<td>Statistical</td>
<td>Calculates the standard deviation of a population sample. The value of text is 0.</td>
</tr>
<tr>
<td>STDEVP</td>
<td>Statistical</td>
<td>Calculates the standard deviation of an entire population.</td>
</tr>
<tr>
<td>STDEV.P</td>
<td>Statistical</td>
<td>Calculates the standard deviation of an entire population.</td>
</tr>
<tr>
<td>STDEVPA</td>
<td>Statistical</td>
<td>Calculates the standard deviation of an entire population. The value of text is 0.</td>
</tr>
<tr>
<td>SUBTOTAL</td>
<td>Mathematical</td>
<td>Calculates the total of a subset of an array.</td>
</tr>
<tr>
<td>SUM</td>
<td>Mathematical</td>
<td>Returns the sum of a list of values.</td>
</tr>
<tr>
<td>SUMIF</td>
<td>Mathematical</td>
<td>Calculates the sum of values from cells that meet the specified search criteria.</td>
</tr>
<tr>
<td>SUMIFS</td>
<td>Mathematical</td>
<td>Returns the sum of values from cells in a range that meet multiple criteria in multiple ranges.</td>
</tr>
<tr>
<td>VAR</td>
<td>Statistical</td>
<td>Calculates the variance of a population sample.</td>
</tr>
<tr>
<td>VAR.S</td>
<td>Statistical</td>
<td>Calculates the variance of a population sample. The value of text is 0.</td>
</tr>
<tr>
<td>VARA</td>
<td>Statistical</td>
<td>Calculates the variance of a population sample.</td>
</tr>
<tr>
<td>VARP</td>
<td>Statistical</td>
<td>Calculates the variance of an entire population.</td>
</tr>
<tr>
<td>VAR.P</td>
<td>Statistical</td>
<td>Calculates the variance of an entire population.</td>
</tr>
<tr>
<td>VARPA</td>
<td>Statistical</td>
<td>Calculates the variance of an entire population.</td>
</tr>
<tr>
<td>VLOOKUP</td>
<td>Spreadsheet</td>
<td>Searches for a “look-up” value in the first column of an array and returns a value from a different column in the same row.</td>
</tr>
</tbody>
</table>

**Database-specific functions**

Some Calc functions are specifically designed for use with a database table. With one exception (DGET), these functions are specialized forms of commonly-used functions such as COUNT, and all are denoted with the D- prefix (such as DAVERAGE). A brief list of these functions is given in Table 15, while more detailed descriptions of all Calc’s functions are presented in the Help system.

**Note**

Table 15 uses the following terms interchangeably: row and record; column and field.

**Table 15: Database functions in a Calc document**

<table>
<thead>
<tr>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DAVERAGE</td>
<td>Returns the average of all fields that match the search criteria.</td>
</tr>
<tr>
<td>DCOUNT</td>
<td>Counts the number of records containing numeric data that match the search criteria.</td>
</tr>
<tr>
<td>DCOUNTA</td>
<td>Counts the number of records containing numeric or alphanumeric data that match the search criteria.</td>
</tr>
<tr>
<td>DGET</td>
<td>Returns the contents of a field that matches the specified search criteria.</td>
</tr>
<tr>
<td>DMAX</td>
<td>Returns the maximum value in a field for every record that matches the specified search criteria.</td>
</tr>
<tr>
<td>DMIN</td>
<td>Returns the minimum value in a field for every record that matches the specified search criteria.</td>
</tr>
<tr>
<td><strong>Function</strong></td>
<td><strong>Description</strong></td>
</tr>
<tr>
<td>--------------</td>
<td>----------------</td>
</tr>
<tr>
<td>DPRODUCT</td>
<td>Returns the product of all values in a field that match the search criteria.</td>
</tr>
<tr>
<td>DSTDEV</td>
<td>Calculates the standard deviation of all values in a field that match the search criteria. The values are treated as a sample.</td>
</tr>
<tr>
<td>DSTDEVP</td>
<td>Calculates the standard deviation of all values in a field that match the search criteria. The values are treated as an entire population.</td>
</tr>
<tr>
<td>DSUM</td>
<td>Sums all values in a field that match the search criteria.</td>
</tr>
<tr>
<td>DVAR</td>
<td>Calculates the variance of all values in a field that match the search criteria. The values are treated as a sample.</td>
</tr>
<tr>
<td>DVARP</td>
<td>Calculates the variance of all values in a field that match the search criteria. The values are treated as an entire population.</td>
</tr>
</tbody>
</table>
Chapter 14
Setting up and Customizing
Introduction

This chapter briefly presents some of the setup options found under **Tools > Options** on the Menu bar. Additional options, and more details about the ones given here, are covered in the Help and in Chapters 2 (Setting up LibreOffice) and 14 (Customizing LibreOffice) in the *Getting Started Guide*. This chapter also describes some common customizations to menus, toolbars, and keyboard shortcuts. Other customizations are made easy by extensions that you can install from the LibreOffice website or from other providers.

LibreOffice options

This section covers some of the settings that apply to all the components of LibreOffice and are of particular interest to users of Calc. Other general options are discussed in Chapter 2, Setting Up LibreOffice, in the *Getting Started Guide*.

1) Choose **Tools > Options (LibreOffice > Preferences** on macOS) to open the Options dialog. The list on the left-hand side varies depending on which LibreOffice component is open. The illustrations in this chapter show the list as it appears when Calc is open.

2) Click the expansion symbol (+ or triangle) next to LibreOffice. A list of subsections drops down.

![Figure 459: LibreOffice options]

**Note**

The **Reset** button, located in the lower right of the full Options dialog, has the same effect on all pages of the dialog. It resets the options to the values that were in place when you opened the dialog.
User data
User data is used by templates and wizards in LibreOffice. For example, Calc uses the first and last name stored here to fill in the Created and Modified fields in the document properties, the optional Author field is often used in the footer of a printed spreadsheet and as the name associated with comments. If you want your name to appear, then fill in the form on the LibreOffice – User Data page.

View
The options on the LibreOffice – View page affect how the document window looks and behaves, including the size and style of toolbar and sidebar icons. Set these options to suit your personal preferences.

Print
On the LibreOffice – Print page, you can set the print options to suit your default printer and your most common printing method. You can change these settings at any time, either through this dialog or during the printing process (through the Print dialog).
Calc-specific print options are described in “Print options” on page 452.
See Chapter 6, Printing, Exporting, E-mailing, and Signing, for more about these options.

Paths
On the LibreOffice – Paths page, you can change the location of files associated with, or used by, LibreOffice to suit your needs. For example, you might want to store spreadsheets by default on a shared server. Some items can have at least two paths listed: one to a shared folder (which might be on a network) and one to a user-specific folder (normally on the user’s personal computer).

Security
Use the LibreOffice – Security page to choose security options for saving documents and for opening documents that contain macros.

Security Options and Warnings
Adjust security related options and define warnings for hidden information in documents.

Passwords for Web Connections
- Persistently save passwords for web connections
- Protected by a master password (recommended)

Macro Security
Adjust the security level for executing macros and specify trusted macro developers.

TSAs
Maintain a list of Time Stamping Authority (TSA) URLs to be used for digital signatures in PDF export.

Figure 460: Choosing security options for opening and saving documents
Security Options and Warnings

If you record changes, save multiple versions, or include hidden information or notes in your documents, and you do not want some of the recipients to see that information, you can set warnings to remind you to remove this information, or you can have LibreOffice remove some information automatically. Note that (unless removed) much of this information is retained in a file whether the file is in LibreOffice’s default OpenDocument Format, or has been saved to other formats, including PDF.

Click the Options button to open a separate dialog with specific choices (see Figure 461).

Passwords for Web Connections

You can enter a master password to enable easy access to websites that require a user name and password. If you select the Persistently save passwords for web connections option, the Set Master Password dialog (not shown here) opens. LibreOffice will securely store all passwords that you use to access files from web servers. You can retrieve the passwords from the list after you enter the master password.

Macro Security

Click the Macro Security button to open the Macro Security dialog (not shown here), where you can adjust the security level for executing macros and specify trusted sources.

Certificate Path

Users can digitally sign documents using LibreOffice. A digital signature requires a personal signing certificate. Most operating systems can generate a self-signed certificate. However, a personal certificate issued by an outside agency (after verifying an individual's identity) has a higher degree of trust associated with it than does a self-signed certificate. LibreOffice does not provide a secure method of storing these certificates, but it can access certificates that have been saved using other programs. Click the Certificate button and select which certificate store to use.

Note

The Certificate Path option appears only on Linux and macOS systems. On Windows, LibreOffice uses the default Windows location for storing and retrieving certificates.

TSAs – Time Stamping Authorities

Allows you to optionally select a Time Stamping Authority (TSA) URL for PDF documents created by LibreOffice. Adding a trusted timestamp to an electronic signature on a PDF provides a digital seal of data integrity and a trusted date and time of when the file was signed. Recipients of PDF documents with a trusted timestamp can verify when the document was digitally or electronically signed, as well as verify that the document was not altered after the date the timestamp vouches for.

Security Options and Warnings

The following options are on the Security Options and Warnings dialog (Figure 461).

Remove personal information on saving

Select this option to always remove user data from the file properties when saving the file. To manually remove personal information from specific documents, deselect this option and then use the Reset Properties button under File > Properties > General.

Ctrl-click required to open hyperlinks

The default behavior in most components of LibreOffice is to Ctrl+click on a hyperlink to open the linked document, but you can choose to open hyperlinks using a single click.

The other options on this dialog should be self-explanatory.
Application colors

On the LibreOffice – Application Colors page (Figure 462), you can specify which user interface elements are visible and the colors used to display them. Scroll down the list until you find the section headed Spreadsheet. To change the default color for Grid lines or other on-screen indicators, click the down-arrow by the color and select a new color from the drop-down list.
If you wish to save your color changes as a color scheme, click Save, type a name in the Name of color scheme box in the pop-up dialog, and then click OK.

**Advanced options**

Two items of interest on this page are found under Optional Features:

**Enable experimental features (may be unstable)**

Selecting this option enables features that are not yet complete or contain known bugs. The list of these features is different version by version.

**Enable macro recording (may be limited)**

This option enables macro recording, with some limitations. For more about macro recording, see Chapter 13, Getting Started with Macros, in the Getting Started Guide, and Chapter 12, Macros, in this book.

**Options for loading and saving documents**

You can set the Load/Save options to suit the way you work. This chapter describes only a few of the options, those most relevant to working with Calc. See Chapter 2, Setting Up LibreOffice, in the Getting Started Guide for a description of the other options.

If the Options dialog is not already open, click Tools > Options. Click the expansion symbol (+ or triangle) by Load/Save on the left-hand side to display the list of load/save options pages.

**General**

Many of the choices on the Load/Save – General page (Figure 463) are familiar to users of other office suites. Those of most interest to Calc users are in the Default File Format and ODF Settings section.

![Figure 463: Choosing Load and Save general options](image)

---

438 | Options for loading and saving documents
Default File Format and ODF Settings

**ODF format version:** LibreOffice by default saves documents in OpenDocument Format (ODF) version 1.2 Extended. You will rarely need to change this for compatibility when exchanging files with other people.

**Document type:** If you routinely share documents with users of Microsoft Excel, you might want to change the **Always save as** option to one of the Excel formats, including XLSX. However, you can choose an Excel format when you save any individual file.

We recommend that you always save a working copy in ODS format and only create an Excel version if necessary for sharing. Also, note that recent and current versions of Microsoft Excel can open ODS files, so this may no longer be needed.

VBA Properties

On the **Load/Save – VBA Properties** page (Figure 464), you can choose whether to keep any VBA (Visual Basic for Applications) macros in Microsoft Office documents that are opened in LibreOffice.

![Figure 464: Choosing Load/Save VBA Properties](image)

**Microsoft Word**
- [ ] Load Basic code
- [ ] Executable code
- [ ] Save original Basic code

**Microsoft Excel**
- [ ] Load Basic code
- [ ] Executable code
- [ ] Save original Basic code

**Microsoft PowerPoint**
- [ ] Load Basic code
- [ ] Save original Basic code

If you choose **Load Basic code**, you can edit the macros in LibreOffice. The changed code is saved in an ODF document but is not retained if you save into a Microsoft Office format.

If you choose **Save original Basic code**, the macros will not work in LibreOffice but are retained unchanged if you save the file into Microsoft Office format.

If you are importing a Microsoft Word or Excel file containing VBA code, you can select the option **Executable code**. Whereas normally the code is preserved but rendered inactive (if you inspect it with the Basic IDE you will notice that it is all commented), with this option the code is ready to be executed.

**Save original Basic code** takes precedence over **Load Basic code**. If both options are selected and you edit the disabled code in LibreOffice, the original Microsoft Basic code will be saved when saving in a Microsoft Office format.

To remove any possible macro viruses from the Microsoft Office document, deselect **Save original Basic code**. The document will be saved without the Microsoft Basic code.

Microsoft Office

On the **Load/Save – Microsoft Office** page (Figure 465), you can choose what to do when importing and exporting Microsoft Office OLE objects (linked or embedded objects or documents...
such as spreadsheets or equations): convert them into or from the corresponding LibreOffice OLE object or load and save them in their original format.

Select the [L] options to convert Microsoft OLE objects into the corresponding LibreOffice OLE objects when a Microsoft document is loaded into LibreOffice.

Select the [S] options to convert LibreOffice OLE objects into the corresponding Microsoft OLE objects when a document is saved in a Microsoft format.

<table>
<thead>
<tr>
<th>Embedded Objects</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1" alt="Checkboxes" /> MathType to LibreOffice Math or reverse</td>
</tr>
<tr>
<td><img src="image1" alt="Checkboxes" /> WinWord to LibreOffice Writer or reverse</td>
</tr>
<tr>
<td><img src="image1" alt="Checkboxes" /> Excel to LibreOffice Calc or reverse</td>
</tr>
<tr>
<td><img src="image1" alt="Checkboxes" /> PowerPoint to LibreOffice Impress or reverse</td>
</tr>
<tr>
<td><img src="image1" alt="Checkboxes" /> SmartArt to LibreOffice shapes or reverse</td>
</tr>
<tr>
<td><img src="image1" alt="Checkboxes" /> Visio to LibreOffice Draw or reverse</td>
</tr>
<tr>
<td><img src="image1" alt="Checkboxes" /> PDF to LibreOffice Draw or reverse</td>
</tr>
</tbody>
</table>

[L]: Load and convert the object  [S]: Convert and save the object

**Figure 465: Choosing Load/Save Microsoft Office options**

The Character Highlighting options enable a user to select between the two text highlighting (character background) attributes that Microsoft Office provides, **Highlighting** or **Shading**. **Highlighting** is the initial default.

The **Create MSO lock file** checkbox improves interoperability with Microsoft Office for shared spreadsheets. When enabled, Calc writes two lock files when opening a Microsoft Office format file, one LibreOffice lock file and one Microsoft Office lock file. This enables users of both suites to be made aware that the file is in use. The option is initially disabled by default.

**HTML Compatibility**

Choices made on the **Load/Save – HTML Compatibility** page (Figure 466) affect HTML pages imported into LibreOffice and those exported from LibreOffice. See Chapter 2, Setting up LibreOffice, in the Getting Started Guide, and HTML documents; importing/exporting in the Help, for more information.

The main items of interest for Calc users are in the **Export** section.

**Export – LibreOffice Basic**

Select this option to include LibreOffice Basic macros (scripts) when exporting to HTML format. You must activate this option before you create the LibreOffice Basic macro; otherwise the script will not be inserted. LibreOffice Basic macros must be located in the
header of the HTML document. Once you have created the macro in the LibreOffice Basic IDE, it appears in the source text of the HTML document in the header.

If you want the macro to run automatically when the HTML document is opened, choose **Tools > Customize > Events**. See Chapter 12, Macros, for more information.

**Export – Display warning**
When the **LibreOffice Basic** option (see above) is not selected, the **Display warning** option becomes available. If the **Display warning** option is selected, then when exporting to HTML a warning is shown that LibreOffice Basic macros will be lost.

**Export – Print layout**
Select this option to export the print layout of the current document as well. The HTML filter supports CSS2 (Cascading Style Sheets Level 2) for printing documents. These capabilities are only effective if print layout export is activated.

**Export – Copy local images to Internet**
Select this option to automatically upload the embedded pictures to the Internet server when uploading using FTP.

**Export – Character set**
Select the appropriate character set for the export.

**Calc-specific options**

Calc must be open in order for the LibreOffice Calc options to be displayed in the Options dialog. Click the expansion symbol (+ or triangle) by **LibreOffice Calc**. A list of subsections drops down (Figure 468).

**General**
The choices on the **LibreOffice Calc – General** page (Figure 468) affect the units used for rulers and other measurements, the default tab stop positions, the updating of links and fields, and various input settings.

**Metrics**
Choose the unit of measurement used in spreadsheets and the default tab stops distance.

**Update links when opening**
Choose whether to update links when opening a document: **Always**, **On request**, or **Never**. Spreadsheets that include many or large charts or graphics may load slowly if this option is set to **Always**.

![Figure 466: Choosing HTML compatibility options](image)

---

General | 441
Input Settings section

Press Enter to move selection
Specifies that pressing Enter moves the cursor to another cell. You can also choose the direction the cursor moves: Up, Down, Left, or Right. If this option is not selected, pressing Enter places the data into the cell but does not move the cursor.

Press Enter to switch to edit mode
Specifies that pressing Enter puts the selected cell into edit mode. To end edit mode and move the cursor in the desired direction, press Enter again.
Expand formatting
Specifies whether to automatically apply the formatting attributes of the selected cell to empty adjacent cells. If, for example, a selected cell has the bold attribute, this attribute will also apply to empty adjacent cells. However, cells that already have a special format will not be modified by this function. To see the affected range, press Ctrl+* (multiplication sign on the number pad). The format will also apply to all new values inserted within this range.

Expand references when new columns/rows are inserted
Specifies whether to expand references when inserting columns or rows adjacent to the reference range. This is only possible if the reference range, where the column or row is inserted, originally spanned at least two cells in the desired direction.

Example: If the range A1:B1 is referenced in a formula and you insert a new column after column B, the reference is expanded to A1:C1. If the range A1:B1 is referenced and a new row is inserted under row 1, the reference is not expanded, since there is only a single cell in the vertical direction.

If you insert rows or columns in the middle of a reference area, the reference is always expanded.

Update references when sorting range of cells
When selected, references to cells are updated when a range of cells is sorted. If not selected, the references are unchanged.

Highlight selection in column/row headers
Specifies whether to highlight column and row headers in the selected columns or rows.

Use printer metrics for text formatting
Select this option to use the properties of the default printer to format the display of a spreadsheet. Those properties can be found by choosing File > Printer Settings and then selecting the Properties button for the default printer. If the printer has options for page setup, those settings will be applied to Calc documents. If this option is not selected, pages will be configured for a generic printer.

Show overwrite warning when pasting data
Pasting contents of the clipboard into a cell will replace the contents of that cell with what is in the clipboard. Select this option to be alerted to a possible loss of data when pasting.

Position cell reference with selection
With this option set, expanding a selection (with Ctrl+Shift+Down/Up) jumps to the end of the range in the column that was added as last to the initial selection. When the option is not set, expanding a selection (with Ctrl+Shift+Down/Up) jumps to the end of the range in the column where selecting the cell range was started. The same applies when extending a selection on rows, with Ctrl+Shift+Left/Right.

Defaults
Enter the number of sheets to be opened by default when you start a new spreadsheet and either accept the default sheet prefix or type a new one. After a spreadsheet has been created, you can add new sheets and change the label of any tab; see Chapter 1, Introduction, for more information.

View
The options on the LibreOffice Calc – View page (Figure 469) affect the way the document window looks and behaves when viewed onscreen.
Display section
Select various options for the onscreen display.

Formulas
Display the content of a cell as a formula or as the results of that formula.

Zero values
Display a zero in a cell when the cell has a value of zero, or display an empty cell.

Comment indicator
Select this option to show a small symbol in the top right corner of a cell that contains a comment.

To always display a comment, right-click on the cell and select Show comment from the context menu.

Value highlighting
Select this option to highlight all values, or results of formulas, in the sheet. Text is highlighted in black; numbers in blue; and formulas, logical values, dates, and so on, in green. When this option is active, any colors assigned in the document are not displayed.

Anchor
If an inserted object, such as a picture, is anchored to a cell, an image of an anchor will appear in the cell to which the object is anchored.

Text overflow
If a cell contains text that is wider than the width of the cell, the text is displayed over empty neighboring cells in the same row. If there is no empty neighboring cell, a small triangle at the cell border indicates that the text continues. If this option is selected, text will wrap inside the cell and the height of the row will expand to accommodate the height of the expanded cell.

Show references in color
Select this option to provide a visual aid to assist the editing of a formula. Each reference is then highlighted in color in the formula, and the referenced cell range is enclosed by a colored border as soon as the cell containing the reference is selected for editing.
Figure 470: Formula references – visual aids

Window section

The following elements of the spreadsheet window can be made visible or invisible: column and row headers, horizontal and vertical scroll bars, sheet tabs, and, if an outline has been defined, outline symbols.

If the Sheet tabs option is not selected, you can only switch between the sheets by using the Navigator.

The Summary on search option controls the display of the Search Results dialog, which is described in detail in Chapter 2, Entering, Editing, and Formatting Data.

Visual Aids section

Grid lines

Grid lines are the borders around the cells of a spreadsheet when viewed onscreen. The options are: Show, Show on colored cells, or Hide. If grid lines are hidden, tables will be displayed on a solid background with no grid around cells. The color choice overrides the selection made in Tools > Options > LibreOffice > Application Colors > Spreadsheet > Grid lines.

Note

To print grid lines, choose Format > Page > Sheet > Print > Grid.

Page breaks

Specifies whether to view the page breaks within a defined print area.

Helplines while moving

Specifies whether to view helplines when moving drawings, frames, graphics, and other objects. These lines help you align objects.

In Figure 471, the graph with the dark background represents the image in its original location. The lighter area represents the position of the image as it is being moved. Helplines are the horizontal and vertical dotted lines at the corners of the lighter object.

Objects section

Choose whether to show or hide graphics, charts, and drawing objects.

Zoom section

Select the Synchronize sheets option to apply any selected zoom (magnification) factor to all sheets in the spreadsheet. If this option is not selected, separate zoom factors can be applied to individual sheets.
Calculate

Use the *LibreOffice Calc – Calculate* page (Figure 472) to define the calculation settings for spreadsheets.

<table>
<thead>
<tr>
<th>Formulas wildcards</th>
<th>Date</th>
</tr>
</thead>
<tbody>
<tr>
<td>Enable wildcards in formulas</td>
<td>12/30/1899 (default)</td>
</tr>
<tr>
<td>Enable regular expressions in formulas</td>
<td>01/01/1900 (StarCalc 1.0)</td>
</tr>
<tr>
<td>No wildcards or regular expressions in formulas</td>
<td>01/01/1904</td>
</tr>
</tbody>
</table>

**General Calculations**

- Case sensitive
- Precision as shown
- Search criteria = and <> must apply to whole cells
- Automatically find column and row labels
- Limit decimals for general number format
  - Decimal places: 2

**Iterative References**

- Iterations
  - Steps: 100
  - Minimum change: 0.001

**CPU threading settings**

- Enable multi-threaded calculation

*Figure 472: Calc calculation options*
Formulas wildcards section
The Enable wildcards in formulas, Enable regular expressions in formulas, and No wildcards or regular expressions in formulas are mutually exclusive.

Enable wildcards in formulas specifies that wildcards are enabled when searching and also for character string comparisons. This relates to the database functions, and to VLOOKUP, HLOOKUP, MATCH, AVERAGEIF, AVERAGEIFS, COUNTIF, COUNTIFS, SUMIF, SUMIFS, and SEARCH. Select this option for spreadsheets that need to be interoperable with Microsoft Excel.

Enable regular expressions in formulas specifies that regular expressions instead of simple wildcards are enabled when searching and also for character string comparisons. This relates to the database functions, and to VLOOKUP, HLOOKUP, MATCH, AVERAGEIF, AVERAGEIFS, COUNTIF, COUNTIFS, SUMIF, SUMIFS and SEARCH. Do not enable regular expressions in formulas for spreadsheets that need to be interoperable with Microsoft Excel.

No wildcards or regular expressions in formulas specifies that only literal strings are used when searching and also for character string comparisons. This relates to the database functions, and to VLOOKUP, HLOOKUP, MATCH, AVERAGEIF, AVERAGEIFS, COUNTIF, COUNTIFS, SUMIF, SUMIFS and SEARCH. Do not disable wildcards in formulas for spreadsheets that need to be interoperable with Microsoft Excel.

Date section
Select the start date for the internal conversion from days to numbers.
- 12/30/1899 (default) – Sets December 30, 1899 as day zero.
- 01/01/1900 (StarCalc 1.0) – Sets January 1, 1900 as day zero. Use this setting for StarCalc 1.0 spreadsheets containing date entries.
- 01/01/1904 – Sets January 1, 1904 as day zero. Use this setting for spreadsheets that are imported from foreign formats.

General Calculations section
Specify a variety of options relevant to spreadsheet calculation.

Case sensitive
Specifies whether to distinguish between upper and lower case in texts when comparing cell contents. For example: type 'Test' in cell A1; and 'test' in B1. Then type the formula "=A1=B1" in cell C1. If the Case sensitive option is checked, FALSE will appear in the cell; if the analysis was case insensitive, TRUE will appear in the cell. This option is not applied to the EXACT text function, which is always case-sensitive.

Precision as shown
Specifies whether to make calculations using the rounded values displayed in the sheet. Charts will be shown with the displayed values. If the Precision as shown option is not marked, the displayed numbers are rounded, but they are calculated internally using the non-rounded number.

Search criteria = and <> must apply to whole cells
The default search method in Calc is to search for any instance of the target regardless of the position of the target within a word. For example, when searching for day, Calc will match Friday, Sunday, and days. Select this option to search an exact occurrence of the target. Wild card symbols can be used to expand the search to match the default condition. That is, searching for *day* will match Friday, Sunday, and days.

Automatically find column and row labels
Calc will name the range of data, under a column heading or to the right of a row heading, using the text in those headings.
Example: Cell E5 contains the text Europe. Below, in cell E6, is the value 100 and in cell E7 the value 200. If the **Automatically find column and row labels** option is selected, you can write the following formula in cell A1: =SUM(Europe).

**Limit decimals for general number format**
Limits the number of decimals to be displayed for numbers with the general number format. This overrides the setting applied in **Format > Cells > Numbers > Number > General**. This setting refers to how numbers are displayed. When decimal places are limited, calculations are not affected because of rounding.

**CPU threading settings section**
**Enable multi-threaded calculation** controls the use of multi-threading / parallelism, which can be used to speed up LibreOffice Calc calculations on computers with multiple processing cores. See Chapter 7, Using Formulas and Functions for more information.

**Iterative References section**
Iterative references are formulas that are continuously repeated until the problem is solved. In this section you can choose the number of approximation steps carried out during iterative calculations and the degree of precision of the answer.

**Iterations**
Select this option to enable iterations. If this option is not selected, an iterative reference causes an error message.

**Steps**
Sets the maximum number of iteration steps.

**Minimum change**
Specifies the difference between two consecutive iteration step results. If the result of the iteration is lower than the minimum change value, then the iteration will stop.

**Caution**
When calculations involve a range that includes an empty cell, take note of the setting for **Zero values** in the **LibreOffice Calc > View** options. If this option is not selected, a value of zero will display as an empty cell. Empty cells and the value zero are treated differently by many functions. For example, COUNT would not include an empty cell as an item to be counted. The average of eight cells, one of which contains the value zero, is not the same as the average of seven cells (an empty cell is not included in determining the average).

**Formula**
Use the **LibreOffice Calc – Formula** page (Figure 473) to specify whether to use Calc or Excel syntax, as well as choosing which separators you prefer to use in formulas. The separators choices override the defaults in Calc and Excel syntax.

**Formula syntax**
Syntax is the format in which formulas are written. Choose the syntax most appropriate for your work. If you regularly open or save to Microsoft Excel formats, you may wish to use one of the Excel syntaxes.

To illustrate the differences between syntaxes, assume a spreadsheet contains two sheets. The cell C4 can be referenced in three ways:
- Calc A1 =Sheet2.C4 – the default syntax for Calc.
- Excel A1 =Sheet2!C4 – the default of Microsoft Excel.
Use English function names
The default names for functions in Calc are those for the user's locale. For English users, the localized names are the same as the English names. When the language set by locale is not English, you may wish to express functions in English; if so, select this option to change formula input and display, Function Wizard, and formula tips.

Separators
Separators are used in functions to distinguish points in the range used in the function: the symbols used between elements. Enter the separator character to be used for functions, row arrays, and column arrays. For example, a comma can be used as a separator in functions and instead of writing =SUM(A1;B1;C1) the function would be expressed as =SUM(A1,B1,C1).

Detailed calculation settings
Most users will not need to change the default setting. For custom settings, select Custom and click Details to choose reference syntax and whether to treat empty strings as zero.

Recalculation on File Load
Recalculating formulas can take significant time while loading very large files.

Excel 2007 and newer. Loading a large spreadsheet file can take a long time. If you don't need to update your large spreadsheet data immediately, you can postpone the recalculation to a better time. Calc allows you to defer recalculation of Excel 2007 (and more recent) spreadsheets to speed up loading time.

ODF spreadsheet (not saved by LibreOffice). Recent versions of Calc cache spreadsheet formula results in its ODF file. This feature helps Calc to recalculate a large ODF spreadsheet saved by Calc faster. For ODF spreadsheets saved by other programs, where such cached formula results may not exist, recalculation can be deferred to speed up file loading as with Excel 2007 files.
For each of these two options, the following choices are possible: *Never recalculate* (no formulas will be recalculated on loading the file), *Always recalculate* (all formulas will be recalculated on file load), and *Prompt user* (prompt user for action).

Calc saved ODF spreadsheets will honor *Never recalculate* and *Always recalculate* options.

**Sort lists**

Sort lists are used for more than sorting, for example filling a series of cells during data entry. They are lists that are sorted in a particular order but not alphabetically or numerically; for example, days of the week. In addition to the supplied lists, you can define and edit your own lists, as described in “Defining a fill series” in Chapter 2, Entering, Editing, and Formatting Data.

![Figure 474: Defining sorting lists in Calc](image)

**Changes**

In the Options dialog, choose **LibreOffice Calc > Changes**.

On this page you can specify options for highlighting recorded changes in spreadsheets. You can assign specific colors for insertions, deletions, and other changes, or you can let Calc assign colors based on the author of the change; in the latter case, one color will apply to all changes made by that author. The selections made here are applied when change recording is enabled under **Edit > Track Changes > Record**.
Compatibility

In the Options dialog, choose **LibreOffice Calc > Compatibility**. This page provides a quick way to switch between LibreOffice's default key bindings and OpenOffice.org's legacy default key bindings for Calc. Most of the defaults are identical, but there are some differences.

The actions associated with the two key binding choices are shown in the table below.

<table>
<thead>
<tr>
<th>Key Binding</th>
<th>Default</th>
<th>OpenOffice.org legacy</th>
</tr>
</thead>
<tbody>
<tr>
<td>Backspace</td>
<td>Opens Delete Contents dialog</td>
<td>Immediately deletes contents</td>
</tr>
<tr>
<td>Delete</td>
<td>Immediately deletes contents</td>
<td>Opens Delete Contents dialog</td>
</tr>
<tr>
<td>Control+D (Command+D on macOS)</td>
<td>Fills cell content down within selection</td>
<td>Opens the Selection List dialog</td>
</tr>
<tr>
<td>Alt+DownArrow (Option+DownArrow on macOS)</td>
<td>Select header of range; no action in empty cell</td>
<td>Increases row height</td>
</tr>
</tbody>
</table>

Grid options

The **LibreOffice Calc – Grid** page defines the grid settings for spreadsheets. Using a grid helps you determine the exact position of any charts or other objects you may add to a spreadsheet. You can also set this grid in line with the snap grid.

If you have activated the snap grid but wish to move or create individual objects without snap positions, you can press the **Ctrl** key to deactivate the snap grid for as long as needed.

In the Options dialog, choose **LibreOffice Calc > Grid**.
Grid section
Snap to grid activates the snap function.
Visible grid displays grid points on the screen. These points are not printed.

Resolution and subdivision sections
Here you can set the unit of distance for the spacing between horizontal and vertical grid points and subdivisions (intermediate points) of the grid.

Synchronize axes changes the current grid settings symmetrically.

Print options
In the Options dialog, choose LibreOffice Calc > Print to choose defaults for printing spreadsheets. You can override these for individual print jobs.

Default colors for charts
Use Tools > Options > Charts > Default Colors to change the default colors used for charts or to add new data series to the list provided.

To add new colors to the choices, see “Adding custom colors” on page 464.

To change the default color for a data series, select it in the left-hand column and then click on the required color in the color table.

To add another data series, click Add, then select the new series and click on the required color.
Click Default to restore the color settings that were defined when the program was installed.
AutoCorrect functions

Some people find some or all of the items in LibreOffice’s AutoCorrect function annoying because they change what you type when you do not want it changed. Many people find some of the AutoCorrect functions quite helpful; if you do, then select the relevant options. But if you find unexplained changes appearing in your document, this is a good place to look to find the cause.

To open the AutoCorrect dialog, click Tools > AutoCorrect Options. You need to have a document open for this menu item to appear.

In Calc, this dialog has four tabs, as shown in Figure 479. Options are described in the Help; many will be familiar to users of other office suites.
Customizing the user interface

You can customize menus, toolbars, and keyboard shortcuts in LibreOffice, add new menus and toolbars, and assign macros to events.

Tip

Changes to menus and toolbars can be saved in a template. First, save the document that was open when these changes were made. Then, save that document as a template, as described in Chapter 4, Using Styles and Templates.

Menu content

You can add and rearrange menus on the Menu bar or context (right-click) menus; add, rearrange, and remove commands on menus; and make other changes.

To customize menus, choose Tools > Customize. On the Customize dialog, go to the Menus tab (Figure 480) or the Context Menus tab. The following examples focus on the Menus tab but the Context Menus tab is similar in appearance and behavior.
Modifying an existing menu

1) In the Scope drop-down list in the upper right of the Customize dialog, choose whether to save this changed menu for Calc or for a selected document.

2) In the Target drop-down list, select the menu that you want to customize. The list includes all the sub-menus as well as the main menus. The commands on the selected menu are shown in the Assigned Commands list below.

3) To add a command to the selected menu, click on a command in the Available Commands list and then click the large right arrow. You can narrow the search by using the Search box on the top left or selecting the Category in the drop-down list. Use the up and down arrows on the far right-hand side to move the command into the place where you want it in the Assigned Commands list.

4) To remove a command from the selected menu, click on it in the Assigned Commands list and then click the large left arrow.

5) To insert a separator or submenu, use the commands in the Insert drop-down under Customize at the bottom right.
6) To rename a menu item, select it in the Assigned Commands list and choose Rename from the Modify drop-down below.

7) Use the Reset button to reset Calc’s menu configuration to the default settings.

8) When you have finished making all your changes, click OK to save them.

Creating a new menu
On the Menus tab of the Customize dialog, click the symbol next to Target and select Add from the drop-down list, to display the New Menu dialog shown in Figure 482.

![Figure 481: Location of command to add a new menu](image)

1) Type a name for the new menu in the Menu name box.

2) Use the up and down arrow buttons to move the new menu into the required position on the Menu bar. Click OK to save and return to the Customize dialog.

The new menu now appears on the list of menus in the Customize dialog. It will appear on the Menu bar itself after you save your customizations.

After creating a new menu, you need to add some commands to it, as described above for modifying a menu.
Creating an accelerator

You can allocate a letter in a custom menu’s name to be used as a keyboard shortcut. (That letter will become underlined.) When you press Alt+that letter, that menu or command will be invoked. Existing submenus can also be edited to change the letter which is used to select them using the keyboard when the menu is open.

To create an accelerator:

1) Select a menu item from the Assigned Commands list.
2) Click the Modify button and select Rename.
3) Add a tilde (~) in front of the letter to use as an accelerator.
4) Click OK to save the change.

If you enter “~Art”, the “A” in the menu item Art is now underlined. Press Alt+A and the Art menu will open.

Caution

When assigning an accelerator, be careful not to use a letter that is already assigned to a menu or command associated with a menu item. The same letter-key combinations can be used for commands associated with different menu items but not for those associated with the same menu or menu item.

Toolbars

You can customize toolbars in several ways, including choosing which icons are visible and locking the position of a docked toolbar, as described in Chapter 1, Introducing LibreOffice, of the Getting Started Guide. This section describes how to create new toolbars and add or delete icons (commands) on a toolbar.
To get to the toolbar customization dialog (Figure 483), do any of the following:

- On the toolbar, right-click in the toolbar and choose **Customize Toolbar**.
- Choose **View > Toolbars > Customize** on the Menu bar.
- Choose **Tools > Customize** on the Menu bar and go to the **Toolbars** tab.

To customize a toolbar:

1) In the **Scope** drop-down list on the upper right, choose whether to save this changed toolbar for Calc or for a selected document.
2) In the **Target** drop-down list, select the toolbar that you want to customize. The current toolbar content is displayed in the **Assigned Commands** list.
3) Select the command in the **Available Commands** list. You can narrow your search by using the **Search** box on the top left or choosing a category in the drop-down list just below.
4) Click on the large right arrow to add the command to the **Assigned Commands** list for the toolbar. Use the up and down arrows in the far right to position the command in the toolbar.
5) To remove a command from a toolbar, select it in the **Assigned Commands** list and click the large left arrow.
6) To show or hide a command assigned to a toolbar, select or clear the checkbox by its icon in the **Assigned Commands** list.
7) To insert a separator, use the command in the **Insert** drop-down under **Customize** at the bottom right.
8) To rename a toolbar item, select it in the **Assigned Commands** list and choose **Rename** from the **Modify** drop-down.
9) Use the **Reset** button to reset Calc’s toolbar configuration to the default settings.
10) When you have finished making all your changes, click **OK** to save them.

**Creating a new toolbar**

To create a new toolbar:

1) Choose **Tools > Customize** on the Menu bar.
2) On the Toolbars tab of the Customize dialog, click the symbol next to **Target** and select **Add** from the drop-down list, to display the Name dialog.
3) On the Name dialog, type the new toolbar’s name and choose from the **Save In** drop-down list where to save this new toolbar: for Calc or for the open document.

The new toolbar now appears on the list of toolbars in the Customize dialog.

To add commands to the new toolbar, follow the instructions earlier for modifying a toolbar.
Figure 483: The Toolbars tab of the Customize dialog

Choosing icons for toolbar commands

Toolbar buttons can be displayed with Icon only, Text only, or Icon and text. This selection is made through the menu that drops down from the button to the right of the Target field. However, not all of the commands have associated icons.

To choose an icon for a command, select the command and click Modify > Change Icon. On the Change Icon dialog (Figure 484), scroll through the available icons, select one, and click OK to assign it to the command.

To use a custom icon, create it in a graphics program and import it into LibreOffice by clicking the Import button on the Change Icon dialog. For best quality, custom icons should be 24 x 24 pixels in size; other sizes will be scaled automatically.

Select Modify > Reset Icon to revert to the option's default icon.
Notebook bar

By default, LibreOffice Calc’s commands are grouped in cascading menus and in toolbars filled with icons. The notebook bar provides a different way to organize controls and icons, displaying contextual groups of commands and contents. You can find more information about the notebook bar in the Help system, by searching for “notebook bar” in the index.

One of the available notebook bar modes is Tabbed – in this mode, the bar is divided into tabs, where each tab displays a set of icons grouped by context. The context can also change depending on the object selected in the document, for example a table or an image.

Checkboxes are provided on the Notebookbar tab of the Customize dialog (Figure 485) to show and hide the individual options on the various tabs that are provided in the Tabbed mode user interface.

Use the Reset button to reset the Tabbed mode of the notebook bar configuration to the default settings.

Note

In the LibreOffice 6.4 version of Calc, there are three notebook bar modes that can be selected through the View > User Interface menu – Tabbed, Tabbed Compact, and Groupedbar Compact. However, only the first of these can be modified using the Notebookbar tab of the Customize dialog. The arrow at the right of the Scope field gives the appearance of a drop-down menu but, in this build, it provides no other options.
Keyboard shortcuts

In addition to using the built-in keyboard shortcuts (listed in Appendix A), you can define your own. You can assign shortcuts to standard LibreOffice functions or your own macros and save them for use with the entire LibreOffice suite or only for Calc.

**Caution**

Avoid reassigning your operating system's predefined shortcut keys.

**Note**

Shortcut keys that are grayed out in the listing on the Customize dialog, such as F1 and F10, are not available for reassignment.

To adapt shortcut keys to your needs, use the Customize dialog, as described below.
1) Select **Tools > Customize** and select the **Keyboard** tab. (Figure 486).

2) To have the shortcut key assignment available only with Calc, select **Calc** in the upper right corner of the page; otherwise select **LibreOffice** to make it available to every component.

3) Next select the required function from the **Category** and **Function** lists.

4) Now select the desired shortcut keys in the **Shortcut Keys** list and click the **Modify** button at the upper right.

5) Click **OK** to accept the change. Now the chosen shortcut keys will execute the function chosen in step 3 above whenever they are pressed.

### Note

All existing shortcut keys for the currently selected **Function** are listed in the **Keys** selection box. If the **Keys** list is empty, it indicates that the chosen key combination is free for use. If it were not, and you wanted to reassign a shortcut key combination that is already in use, you must first delete the existing key.

![Figure 486: Customizing a keyboard shortcut](image-url)
Saving changes to a file
Changes to the shortcut key assignments can be saved in a keyboard configuration file for use at a later time, thus permitting you to create and apply different configurations as the need arises. To save keyboard shortcuts to a file:

1) After making your keyboard shortcut assignments, click the **Save** button on the right of the Customize dialog (Figure 486).
2) In the Save Keyboard Configuration dialog, enter a name for the keyboard configuration file in the *File name* box, or select an existing file (the file extension is .cfg for Configuration).
3) Click **Save**. A confirmation dialog appears if you are about to overwrite an existing file, otherwise there will be no feedback and the file will be saved.

Loading a saved keyboard configuration
To load a saved keyboard configuration file and replace your existing configuration, click the **Load** button on the right of the Customize dialog, and then select the configuration file from the Load Keyboard Configuration dialog.

Resetting the shortcut keys
To reset all of the keyboard shortcuts to their default values, click the **Reset** button on the right of the Customize dialog. Use this feature with care as no confirmation dialog will be displayed; the defaults will be set without any further notice or user input.

Running macros from key combinations
You can also define shortcut key combinations that will run macros. These shortcut keys are strictly user-defined; none are built in. For more information on macros, see Chapter 12, Macros.

Assigning macros to events
In LibreOffice, when something happens, we say that an event occurred. For example, a document was opened, a key was pressed, or the mouse moved. You can associate a macro with an event, so the macro is run when the event occurs. A common use is to assign the “open document” event to run a macro that performs certain setup tasks for the document.

To associate a macro with an event, use the *Events* tab of the Customize dialog. For more information, see Chapter 13, Getting Started with Macros, in the *Getting Started Guide*.

Adding functionality with extensions
An extension is a package that can be installed into LibreOffice to add new functionality.

Although individual extensions can be found in different places, the official LibreOffice extension repository is at [https://extensions.libreoffice.org/](https://extensions.libreoffice.org/). These extensions are free of charge. Extensions from other sources may be free or may be available for a fee. Check the descriptions to see what licenses and fees apply to the ones that interest you.

Installing extensions
To install an extension that is listed in the repository, follow these steps:

1) In LibreOffice, select **Tools > Extension Manager** on the Menu bar, or press *Ctrl+Alt+E*. In the Extension Manager dialog, click the **Get more extensions online** link.
2) A browser window will open. Find the extension you want and download it to your computer.
3) After the extension is downloaded and saved, return to the Extension Manager dialog and click **Add**. Find and select the extension you want to install and click **Open**. The extension begins installing. You may be asked to accept a license agreement.
4) When the installation is complete, the extension is listed in the Extension Manager dialog. To install an extension that is not listed in the repository, download the extension, then continue with step 3 above.

**Updating extensions**
Click the **Check for Updates** button on the Extension Manager dialog to check for updates to installed extensions.

**Removing and disabling extensions**
To remove (uninstall) an extension that you installed, select the extension in the main window of the Extension Manager dialog and click the **Remove** button.

To disable an extension without removing (uninstalling) it, select the extension in the main window of the Extension Manager dialog and click the **Disable** button, which then changes to **Enable**.

![Figure 487: The Extension Manager dialog](image)

**Adding custom colors**
The method for defining a custom color is as follows:

1) Insert any drawing object, such as a square, into any document.
2) Right-click on the object and choose **Area** from the context menu.
3) Go to the Color tab (Figure 488). From the Palette drop-down in the Colors area, choose which palette you wish to add the new color to. Under New, define the new color using RGB or Hex notation, or click the Pick button to select the color on the Pick a Color dialog (Figure 489).

4) Click Add in the lower left corner, enter a name for the new color in the pop-up dialog, and click OK to save.

5) Delete the drawing object from the document, if it is not needed.

![Figure 488: Defining a new color](image)
Figure 489: Defining a color by picking it from a color chart
Appendix A
Keyboard Shortcuts
**Introduction**

In this appendix you will find a set of keyboard shortcuts for Calc and these allow you to execute commands without using a pointing device, such as a mouse or a trackball. Shortcuts are identified for the Windows, Linux, and macOS operating systems.

When you first install LibreOffice, a default set of Calc keyboard shortcuts is available and these are described in this chapter, assuming no customization. When using Calc, you will discover shortcuts for your common interactions by observing the key sequences identified on the legends of relevant menu options, and in the tooltips of relevant icon buttons. You can also explore a more comprehensive list of available shortcuts by viewing the *Keyboard* tab of the **Tools > Customize** dialog.

The primary purpose of the material in the appendix is to provide a comprehensive reference list of the available keyboard shortcuts, which users can browse to find shortcuts that may be useful in their daily work. Further information about many individual key combinations can be found throughout the chapters of this guide and in the Help system.

You can define your own shortcuts or change existing shortcuts by going to **Tools > Customize > Keyboard** in the Menu bar. See Chapter 14, *Setting up and Customizing*, for further instructions. Some shortcuts cannot be re-assigned and these are identified in the *Keyboard shortcuts that cannot be modified* sections of this appendix.

**Caution**

Be careful when reassigning predefined shortcuts. Although you can reset shortcut keys back to LibreOffice defaults, changing common hotkeys, such as F1 for Help, can cause confusion and frustration, especially if other users share your computer.

The remainder of this chapter is split into two main sections, one listing the keyboard shortcuts available in the Windows and Linux environments, and the other listing the macOS keyboard shortcuts.

**Windows / Linux keyboard shortcuts**

**Note**

Many of the keyboard shortcuts in this section utilize the **Ctrl** key. Some keyboards have two **Ctrl** keys and in that case you may need to experiment to identify which of the two keys to use.

**Keyboard shortcuts associated with Menu bar options and toolbars**

Tables 16 to 19 provide lists of Calc keyboard shortcuts that can be used instead of the identified options in the Menu bar, the Standard toolbar, or the Formatting toolbar. In the latter two cases the toolbars are assumed to contain the initial default set of icons, without any user customizations.

<table>
<thead>
<tr>
<th>Windows / Linux</th>
<th>Equivalent Menu bar / toolbar option</th>
</tr>
</thead>
<tbody>
<tr>
<td>F1</td>
<td>Help &gt; LibreOffice Help.</td>
</tr>
<tr>
<td>F2</td>
<td>Edit &gt; Cell Edit Mode.</td>
</tr>
<tr>
<td>Ctrl+F2</td>
<td>Insert &gt; Function.</td>
</tr>
<tr>
<td>Ctrl+F3</td>
<td>Sheet &gt; Named Ranges and Expressions &gt; Manage.</td>
</tr>
<tr>
<td>Shift+F3</td>
<td>Format &gt; Text &gt; Cycle Case.</td>
</tr>
</tbody>
</table>

468 | Windows / Linux keyboard shortcuts
### Table 17: Number key shortcuts for menu and toolbar options

<table>
<thead>
<tr>
<th>Windows / Linux</th>
<th>Equivalent Menu bar / toolbar option</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl+1</td>
<td>Format &gt; Cells.</td>
</tr>
<tr>
<td>Ctrl+Shift+1</td>
<td>Format &gt; Number Format &gt; Number (use the “1” key on the main keyboard). Format as Number icon in Formatting toolbar.</td>
</tr>
<tr>
<td>Ctrl+Shift+2</td>
<td>Format &gt; Number Format &gt; Scientific (use the “2” key on the main keyboard).</td>
</tr>
<tr>
<td>Ctrl+Shift+3</td>
<td>Format &gt; Number Format &gt; Date (use the “3” key on the main keyboard). Format as Date icon in Formatting toolbar.</td>
</tr>
<tr>
<td>Ctrl+Shift+4</td>
<td>Format &gt; Number Format &gt; Currency (use the “4” key on the main keyboard). Format as Currency icon in Formatting toolbar.</td>
</tr>
<tr>
<td>Ctrl+Shift+5</td>
<td>Format &gt; Number Format &gt; Percent (use the “5” key on the main keyboard). Format as Percent icon in Formatting toolbar.</td>
</tr>
<tr>
<td>Ctrl+Shift+6</td>
<td>Format &gt; Number Format &gt; General (use the “6” key on the main keyboard).</td>
</tr>
</tbody>
</table>

#### Note

The **Format > Spacing** menu appears to provide shortcuts for **Line Spacing: 1.5** (Ctrl+5) and **Line Spacing: 2** (Ctrl+2). However these options are never active in Calc 6.4 and so the shortcuts are not included in Table 17.
Table 18: Letter key shortcuts for menu and toolbar options

<table>
<thead>
<tr>
<th>Windows / Linux</th>
<th>Equivalent Menu bar / toolbar option</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl+B</td>
<td>Format &gt; Text &gt; Bold. Bold icon in Formatting toolbar.</td>
</tr>
<tr>
<td>Ctrl+Shift+B</td>
<td>Format &gt; Text &gt; Subscript.</td>
</tr>
<tr>
<td>Ctrl+C</td>
<td>Edit &gt; Copy. Copy icon in Standard toolbar.</td>
</tr>
<tr>
<td>Ctrl+Alt+C</td>
<td>Insert &gt; Comment. Insert Comment icon in Standard toolbar.</td>
</tr>
<tr>
<td>Ctrl+D</td>
<td>Sheet &gt; Fill Cells &gt; Fill Down. Via Row and Column icons' drop-down menus in Standard toolbar.</td>
</tr>
<tr>
<td>Ctrl+E</td>
<td>Format &gt; Align &gt; Centered. Align Center icon in Formatting toolbar.</td>
</tr>
<tr>
<td>Ctrl+Alt+E</td>
<td>Tools &gt; Extension Manager.</td>
</tr>
<tr>
<td>Ctrl+F</td>
<td>Edit &gt; Find.</td>
</tr>
<tr>
<td>Ctrl+H</td>
<td>Edit &gt; Find &amp; Replace. Find &amp; Replace icon in Standard toolbar.</td>
</tr>
<tr>
<td>Ctrl+I</td>
<td>Format &gt; Text &gt; Italic. Italic icon in Formatting toolbar.</td>
</tr>
<tr>
<td>Ctrl+J</td>
<td>Format &gt; Align &gt; Justified.</td>
</tr>
<tr>
<td>Ctrl+Shift+J</td>
<td>View &gt; Full Screen.</td>
</tr>
<tr>
<td>Ctrl+K</td>
<td>Insert &gt; Hyperlink. Insert Hyperlink icon in Standard toolbar.</td>
</tr>
<tr>
<td>Ctrl+L</td>
<td>Format &gt; Align &gt; Left. Align Left icon in Formatting toolbar.</td>
</tr>
<tr>
<td>Ctrl+Shift+M</td>
<td>Edit &gt; Edit Mode.</td>
</tr>
<tr>
<td>Ctrl+O</td>
<td>File &gt; Open. Open icon in Standard toolbar.</td>
</tr>
<tr>
<td>Ctrl+Shift+P</td>
<td>Format &gt; Text &gt; Superscript.</td>
</tr>
<tr>
<td>Ctrl+Q</td>
<td>File &gt; Exit LibreOffice.</td>
</tr>
<tr>
<td>Ctrl+R</td>
<td>Format &gt; Align &gt; Right. Align Right icon in Formatting toolbar.</td>
</tr>
<tr>
<td>Windows / Linux</td>
<td>Equivalent Menu bar / toolbar option</td>
</tr>
<tr>
<td>----------------</td>
<td>--------------------------------------</td>
</tr>
<tr>
<td>Ctrl+S</td>
<td>File &gt; Save.</td>
</tr>
<tr>
<td></td>
<td>Save icon in Standard toolbar.</td>
</tr>
<tr>
<td>Ctrl+Shift+S</td>
<td>File &gt; Save As.</td>
</tr>
<tr>
<td></td>
<td>Via Save icon's drop-down menu in Standard toolbar.</td>
</tr>
<tr>
<td>Ctrl+U</td>
<td>Underline icon in Formatting toolbar.</td>
</tr>
<tr>
<td>Ctrl+V</td>
<td>Edit &gt; Paste.</td>
</tr>
<tr>
<td></td>
<td>Paste icon in Standard toolbar.</td>
</tr>
<tr>
<td>Ctrl+Shift+V</td>
<td>Edit &gt; Paste Special &gt; Paste Special.</td>
</tr>
<tr>
<td>Ctrl+Alt+Shift+V</td>
<td>Edit &gt; Paste Special &gt; Paste Unformatted Text.</td>
</tr>
<tr>
<td>Ctrl+W</td>
<td>Window &gt; Close Window.</td>
</tr>
<tr>
<td>Ctrl+X</td>
<td>Edit &gt; Cut.</td>
</tr>
<tr>
<td></td>
<td>Cut icon in Standard toolbar.</td>
</tr>
<tr>
<td>Ctrl+Y</td>
<td>Edit &gt; Redo.</td>
</tr>
<tr>
<td></td>
<td>Redo icon in Standard toolbar.</td>
</tr>
<tr>
<td>Ctrl+Shift+Y</td>
<td>Edit &gt; Repeat.</td>
</tr>
<tr>
<td>Ctrl+Z</td>
<td>Edit &gt; Undo.</td>
</tr>
<tr>
<td></td>
<td>Undo icon in Standard toolbar.</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Windows / Linux</th>
<th>Equivalent Menu bar / toolbar option</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl+Shift+Pg up</td>
<td>Edit &gt; Select &gt; Select to Previous Sheet.</td>
</tr>
<tr>
<td>Ctrl+Shift+Pg down</td>
<td>Edit &gt; Select &gt; Select to Next Sheet.</td>
</tr>
<tr>
<td>Backspace</td>
<td>Sheet &gt; Clear Cells.</td>
</tr>
<tr>
<td>Ctrl+Tab</td>
<td>Sheet &gt; Navigate &gt; To Next Sheet.</td>
</tr>
<tr>
<td>Ctrl+Shift+Tab</td>
<td>Sheet &gt; Navigate &gt; To Previous Sheet.</td>
</tr>
<tr>
<td>Ctrl+Space</td>
<td>Edit &gt; Select &gt; Select Column.</td>
</tr>
<tr>
<td>Shift+Space</td>
<td>Edit &gt; Select &gt; Select Row.</td>
</tr>
<tr>
<td>Ctrl+Shift+Space</td>
<td>Edit &gt; Select All.</td>
</tr>
<tr>
<td>Ctrl++</td>
<td>Sheet &gt; Insert Cells (use the + key on the numeric keypad).</td>
</tr>
<tr>
<td>Ctrl--</td>
<td>Sheet &gt; Delete Cells.</td>
</tr>
<tr>
<td>Ctrl+*</td>
<td>Edit &gt; Select &gt; Select Data Area (use the * key on the numeric keypad).</td>
</tr>
<tr>
<td>Ctrl++;</td>
<td>Insert &gt; Date.</td>
</tr>
<tr>
<td>Ctrl+Shift++;</td>
<td>Insert &gt; Time.</td>
</tr>
<tr>
<td>Ctrl+`</td>
<td>View &gt; Show Formula. The grave (‘) character can be found to the left of the “1” key on many English keyboards. In the Windows build of LibreOffice Calc 6.4, the grave character is omitted from the menu option.</td>
</tr>
</tbody>
</table>

### Other Calc keyboard shortcuts

Tables 20 to 25 provide lists of additional Calc keyboard shortcuts that may be less obvious to users because they are not indicated on Menu bar items or in tooltips associated with icons in the Standard and Formatting toolbars.
### Table 20: Other function key shortcuts

<table>
<thead>
<tr>
<th>Windows / Linux</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Shift+F1</td>
<td>Display context sensitive help.</td>
</tr>
<tr>
<td>Ctrl+F1</td>
<td>Display the comment attached to the current cell.</td>
</tr>
<tr>
<td>Ctrl+Shift+F2</td>
<td>Moves the cursor to the Input line where you can enter a formula for the current cell.</td>
</tr>
<tr>
<td>Ctrl+Shift+F5</td>
<td>Moves the cursor to the Name Box field in the Formula bar.</td>
</tr>
<tr>
<td>Ctrl+Shift+T</td>
<td></td>
</tr>
</tbody>
</table>

### Table 21: Other letter key shortcuts

<table>
<thead>
<tr>
<th>Windows / Linux</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl+A</td>
<td>Selects all cells in the current sheet.</td>
</tr>
<tr>
<td>Ctrl+Shift+R</td>
<td>Redraws the document view.</td>
</tr>
<tr>
<td>Ctrl+Shift+Z</td>
<td>Reverses the action of the last undo command.</td>
</tr>
</tbody>
</table>

### Table 22: Arrow key shortcuts

<table>
<thead>
<tr>
<th>Windows / Linux</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>⇧</td>
<td>Moves the cell focus up.</td>
</tr>
<tr>
<td>Ctrl+⇧</td>
<td>Moves the cursor in the up direction to the edge of the current data range (if the cell adjacent to the cursor is empty, the cursor moves to the next cell that contains data).</td>
</tr>
<tr>
<td>Shift+⇧</td>
<td>Selects the adjacent cell or cells located in the up direction.</td>
</tr>
<tr>
<td>Ctrl+Shift+⇧</td>
<td>Selects in the up direction to the edge of the current data range (if the cell adjacent to the cursor is empty, the cursor moves to the next cell that contains data).</td>
</tr>
<tr>
<td>Alt+Shift+⇧</td>
<td>Optimizes the row height based on the current cell.</td>
</tr>
<tr>
<td>→</td>
<td>Moves the cell focus right.</td>
</tr>
<tr>
<td>Ctrl+→</td>
<td>Moves the cursor in the right direction to the edge of the current data range (if the cell adjacent to the cursor is empty, the cursor moves to the next cell that contains data).</td>
</tr>
<tr>
<td>Shift+→</td>
<td>Selects the adjacent cell or cells located in the right direction.</td>
</tr>
<tr>
<td>Ctrl+Shift+→</td>
<td>Selects in the right direction to the edge of the current data range (if the cell adjacent to the cursor is empty, the cursor moves to the next cell that contains data).</td>
</tr>
<tr>
<td>Alt+→</td>
<td>Increases the width of the current column.</td>
</tr>
<tr>
<td>Alt+Shift+→</td>
<td>Optimizes the column width based on the current cell.</td>
</tr>
<tr>
<td>↓</td>
<td>Moves the cell focus down.</td>
</tr>
<tr>
<td>Ctrl+↓</td>
<td>Moves the cursor in the down direction to the edge of the current data range (if the cell adjacent to the cursor is empty, the cursor moves to the next cell that contains data).</td>
</tr>
<tr>
<td>Alt+↓</td>
<td>Opens a drop-down selection list of text items that have been previously typed into other cells in the same column.</td>
</tr>
<tr>
<td>Shift+↓</td>
<td>Selects the adjacent cell or cells located in the down direction.</td>
</tr>
<tr>
<td><strong>Windows / Linux</strong></td>
<td><strong>Description</strong></td>
</tr>
<tr>
<td>---------------------</td>
<td>----------------</td>
</tr>
<tr>
<td>Ctrl+Shift+↓</td>
<td>Selects in the down direction to the edge of the current data range (if the cell adjacent to the cursor is empty, the cursor moves to the next cell that contains data).</td>
</tr>
<tr>
<td>Alt+Shift+↓</td>
<td>Optimizes the row height based on the current cell.</td>
</tr>
<tr>
<td>←</td>
<td>Moves the cell focus left.</td>
</tr>
<tr>
<td>Ctrl←</td>
<td>Moves the cursor in the left direction the edge of the current data range (if the cell adjacent to the cursor is empty, the cursor moves to the next cell that contains data).</td>
</tr>
<tr>
<td>Shift+←</td>
<td>Selects the adjacent cell or cells located in the down direction.</td>
</tr>
<tr>
<td>Ctrl+Shift+←</td>
<td>Selects in the left direction to the edge of the current data range (if the cell adjacent to the cursor is empty, the cursor moves to the next cell that contains data).</td>
</tr>
<tr>
<td>Alt←</td>
<td>Decreases the width of the current column.</td>
</tr>
<tr>
<td>Alt+Shift←</td>
<td>Optimizes the column width based on the current cell.</td>
</tr>
</tbody>
</table>

**Table 23: Home and End key shortcuts**

<table>
<thead>
<tr>
<th><strong>Windows / Linux</strong></th>
<th><strong>Description</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Home</td>
<td>Moves the cursor to the first cell of the current row.</td>
</tr>
<tr>
<td>Ctrl+Home</td>
<td>Moves the cursor to the first cell (A1) in the current sheet.</td>
</tr>
<tr>
<td>Shift+Home</td>
<td>Selects cells from the cursor to the first cell of the current row.</td>
</tr>
<tr>
<td>Ctrl+Shift+Home</td>
<td>Selects all cells from the cursor to the first cell (A1) in the current sheet.</td>
</tr>
<tr>
<td>End</td>
<td>Moves the cursor along the current row to the cell in the last column containing data in the sheet.</td>
</tr>
<tr>
<td>Ctrl+End</td>
<td>Moves the cursor to the cell in the last column and row that contain data in the current sheet.</td>
</tr>
<tr>
<td>Shift+End</td>
<td>Selects cells along the current row from the cursor to the cell in the last column containing data in the sheet.</td>
</tr>
<tr>
<td>Ctrl+Shift+End</td>
<td>Selects all cells from the cursor to the cell in the last column and row that contain data in the current sheet.</td>
</tr>
</tbody>
</table>

**Table 24: Other Page Up and Down key shortcuts**

<table>
<thead>
<tr>
<th><strong>Windows / Linux</strong></th>
<th><strong>Description</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Pg up</td>
<td>Moves up one screen page.</td>
</tr>
<tr>
<td>Ctrl+Pg up</td>
<td>Moves to the previous sheet.</td>
</tr>
<tr>
<td>Shift+Pg up</td>
<td>Selects cells from the cursor to the row one page up.</td>
</tr>
<tr>
<td>Alt+Pg up</td>
<td>Moves one screen page to the left.</td>
</tr>
<tr>
<td>Alt+Shift+Pg up</td>
<td>Selects cells from the cursor to the column one page to the left.</td>
</tr>
<tr>
<td>Pg down</td>
<td>Moves down one screen page.</td>
</tr>
<tr>
<td>Ctrl+Pg down</td>
<td>Moves to the next sheet.</td>
</tr>
<tr>
<td>Shift+Pg down</td>
<td>Selects cells from the cursor to the row one page down.</td>
</tr>
<tr>
<td>Alt+Pg down</td>
<td>Moves one screen page to the right.</td>
</tr>
<tr>
<td>Alt+Shift+Pg down</td>
<td>Selects cells from the cursor to the column one page to the right.</td>
</tr>
</tbody>
</table>
### Table 25: Other miscellaneous key shortcuts

<table>
<thead>
<tr>
<th>Windows / Linux</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Escape</td>
<td>Cancels the current cell edit.</td>
</tr>
<tr>
<td>Insert</td>
<td>After making a selection, opens the Paste Special dialog.</td>
</tr>
<tr>
<td>Ctrl+Insert</td>
<td>Copies the selected cell or cell range to the clipboard in preparation for a later paste operation.</td>
</tr>
<tr>
<td>Shift+Insert</td>
<td>Pastes the contents of the clipboard into the selected cells.</td>
</tr>
<tr>
<td>Delete</td>
<td>Deletes cell contents without a dialog (does not remove formatting).</td>
</tr>
<tr>
<td>Shift+Delete</td>
<td>Removes and copies the selection to the clipboard.</td>
</tr>
<tr>
<td>Ctrl+Backspace</td>
<td>Refocuses the view back on the cursor if it is not currently in view.</td>
</tr>
<tr>
<td>Shift+Backspace</td>
<td>Deselects the current cell selection without deleting contents.</td>
</tr>
<tr>
<td>Alt+Backspace</td>
<td>Reverses the last command or the last entry you typed.</td>
</tr>
<tr>
<td>Ctrl+[</td>
<td>Selects the cells on which the current cell is dependent.</td>
</tr>
<tr>
<td>Ctrl+]</td>
<td>Selects the cells that are dependent on the current cell.</td>
</tr>
<tr>
<td>Ctrl+/</td>
<td>Use the forward slash key on the main keyboard or the numeric keypad. Selects the cells in the matrix formula range that contains the cursor.</td>
</tr>
<tr>
<td>Ctrl+/</td>
<td>Use the single apostrophe key. Copies the contents of the cell above the cursor into the current cell, but remains in cell edit mode so that you can make further changes.</td>
</tr>
<tr>
<td>Enter</td>
<td>Moves the cursor to the next cell in the selected range, from top to bottom, then left to right. To specify in which direction the cursor moves, go to <strong>Tools &gt; Options &gt; LibreOffice Calc &gt; General</strong> in the Menu bar.</td>
</tr>
<tr>
<td>Ctrl+Enter</td>
<td>Inserts a manual line break in the current cell while editing a cell.</td>
</tr>
<tr>
<td>Ctrl+Shift+Enter</td>
<td>Creates a matrix in the current range using the information entered on the input line.</td>
</tr>
<tr>
<td>Alt+Enter</td>
<td>Fills the selected cell range with the formula that you entered on the input line.</td>
</tr>
</tbody>
</table>

### Chart keyboard shortcuts

Table 26 lists some shortcuts that are available within a Calc chart.

**Tip**

You can use the **Alt** key with the arrow keys and plus (+) and minus (-) keys to move elements with a finer degree of movement for more accuracy.

<table>
<thead>
<tr>
<th>Windows / Linux</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tab</td>
<td>Selects the next chart element.</td>
</tr>
<tr>
<td>Shift+Tab</td>
<td>Selects the previous chart element.</td>
</tr>
<tr>
<td>Home</td>
<td>Selects the first chart element.</td>
</tr>
<tr>
<td>End</td>
<td>Selects the last chart element.</td>
</tr>
<tr>
<td>Esc</td>
<td>Cancels selection.</td>
</tr>
<tr>
<td>Arrow keys</td>
<td>Moves the element in the direction of the arrow.</td>
</tr>
<tr>
<td><strong>Windows / Linux</strong></td>
<td><strong>Effect</strong></td>
</tr>
<tr>
<td>---------------------</td>
<td>------------</td>
</tr>
<tr>
<td>Arrow keys in pie charts</td>
<td>Moves the selected pie segment in the direction of the arrow.</td>
</tr>
<tr>
<td>F2 in titles</td>
<td>Enters text input mode.</td>
</tr>
<tr>
<td>F3 in legends and data series</td>
<td>Opens groups so that you can edit the individual components.</td>
</tr>
<tr>
<td>Ctrl+F3 in legends and data series</td>
<td>Exits groups.</td>
</tr>
<tr>
<td>+/- in pie charts</td>
<td>Moves the selected pie segment off or into the pie chart (use the + / - keys in the numeric keypad).</td>
</tr>
</tbody>
</table>

### Outline keyboard shortcuts

Table 27 lists shortcuts that are available in an outline window. To use these shortcuts, press F6 or Shift+F6 until the vertical or horizontal outline window has the focus.

**Table 27: Outline shortcuts**

<table>
<thead>
<tr>
<th><strong>Windows / Linux</strong></th>
<th><strong>Effect</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Tab</td>
<td>Cycles through each outline indicator from top to bottom or left to right.</td>
</tr>
<tr>
<td>Shift+Tab</td>
<td>Cycles through each outline indicator in the opposite direction.</td>
</tr>
<tr>
<td>Ctrl+1 to Ctrl+8</td>
<td>Show all levels up to the specified number while hiding all higher-numbered levels in the outline.</td>
</tr>
<tr>
<td>+/-</td>
<td>Shows (+) or hides (-) the focused outline group (use the + / - keys in the numeric keypad).</td>
</tr>
<tr>
<td>Enter</td>
<td>Activates the focused indicator button.</td>
</tr>
<tr>
<td>Arrow keys</td>
<td>Cycles through indicator buttons in the direction of the arrow.</td>
</tr>
</tbody>
</table>

### Keyboard shortcuts that cannot be modified

Table 28 identifies the key combinations that are grayed out in the Shortcut Keys list on the Tools > Customize > Keyboard dialog with the Calc radio button selected.

**Table 28: Grayed Key Combinations in Tools > Customize > Keyboard**

<table>
<thead>
<tr>
<th>Operating System</th>
<th>Key Combinations Grayed in Customize Dialog</th>
</tr>
</thead>
<tbody>
<tr>
<td>Windows 10</td>
<td>F1, Ctrl+F1, Shift+F1, Ctrl+F4, Alt+F4, Ctrl+Alt+F4, F6, Ctrl+F6, Shift+F6, Ctrl+Shift+F6, F10</td>
</tr>
<tr>
<td>Linux</td>
<td>F1, Ctrl+F1, Shift+F1, Ctrl+F4, Alt+F4, Ctrl+Alt+F4, F6, Ctrl+F6, Shift+F6, Ctrl+Shift+F6, F10, Ctrl+Shift+0, Ctrl+Shift+1, Ctrl+Shift+2, Ctrl+Shift+3, Ctrl+Shift+4, Ctrl+Shift+5, Ctrl+Shift+6, Ctrl+Shift+7, Ctrl+Shift+8, Ctrl+Shift+9</td>
</tr>
</tbody>
</table>

*Keyboard shortcuts that cannot be modified* | 475
**macOS keyboard shortcuts**

**macOS keyboard symbols**

Keys on many macOS keyboards utilize symbols rather than text labels and Table 29 identifies many of the common macOS keyboard symbols with their meanings. To avoid confusion in the tables that follow, the key names are used rather than symbols, since the latter may not appear on all macOS keyboards.

*Table 29: Common macOS keyboard symbols*

<table>
<thead>
<tr>
<th>Key name</th>
<th>Symbol</th>
</tr>
</thead>
<tbody>
<tr>
<td>Command (shortened to “Cmd” in the tables that follow)</td>
<td>🔄��</td>
</tr>
<tr>
<td>Control (shorted to “Ctrl” in the tables that follow)</td>
<td>↑</td>
</tr>
<tr>
<td>Option</td>
<td>\</td>
</tr>
<tr>
<td>Shift</td>
<td>↑</td>
</tr>
<tr>
<td>Page Up (shortened to “Pg Up” in the tables that follow)</td>
<td>↑</td>
</tr>
<tr>
<td>Page Down (shortened to “Pg Dn” in the tables that follow)</td>
<td>↓</td>
</tr>
<tr>
<td>Home</td>
<td>\</td>
</tr>
<tr>
<td>End</td>
<td>↓</td>
</tr>
<tr>
<td>Delete</td>
<td>✖</td>
</tr>
<tr>
<td>Forward Delete (shortened to “Fwd Del” in the tables that follow)</td>
<td>✖</td>
</tr>
</tbody>
</table>

**Keyboard shortcuts associated with Menu bar options and toolbars**

Tables 30 to 33 provide lists of Calc keyboard shortcuts that can be used instead of the identified options in the Menu bar, the Standard toolbar, or the Formatting toolbar. In the latter two cases the toolbars are assumed to contain the initial default set of icons, without any user customizations.

*Table 30: Function key shortcuts for menu and toolbar options*

<table>
<thead>
<tr>
<th>macOS</th>
<th>Equivalent Menu bar / toolbar option</th>
</tr>
</thead>
<tbody>
<tr>
<td>F1</td>
<td>Help &gt; LibreOffice Help.</td>
</tr>
<tr>
<td>F2</td>
<td>Edit &gt; Cell Edit Mode.</td>
</tr>
<tr>
<td>Cmd+F2</td>
<td>Insert &gt; Function.</td>
</tr>
<tr>
<td>Cmd+F3</td>
<td>Sheet &gt; Named Ranges and Expressions &gt; Manage.</td>
</tr>
<tr>
<td>Shift+F3</td>
<td>Format &gt; Text &gt; Cycle Case.</td>
</tr>
<tr>
<td>F4</td>
<td>Sheet &gt; Cycle Cell Reference Types.</td>
</tr>
<tr>
<td>Shift+Cmd+F4</td>
<td>View &gt; Data Sources.</td>
</tr>
<tr>
<td>F5</td>
<td>View &gt; Navigator.</td>
</tr>
<tr>
<td>Cmd+F5</td>
<td>View &gt; Sidebar. Note: For some macOS versions, this key sequence is used by macOS to display its VoiceOver dialog and so cannot be used to control the display of Calc’s Sidebar.</td>
</tr>
<tr>
<td>Shift+F5</td>
<td>Tools &gt; Detective &gt; Trace Dependents.</td>
</tr>
<tr>
<td>macOS</td>
<td>Equivalent Menu bar / toolbar option</td>
</tr>
<tr>
<td>----------</td>
<td>-----------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Shift+Cmd+;</td>
<td>Tools &gt; Spelling.</td>
</tr>
<tr>
<td></td>
<td>Spelling icon in Standard toolbar.</td>
</tr>
<tr>
<td>Cmd+F7</td>
<td>Tools &gt; Thesaurus.</td>
</tr>
<tr>
<td>Shift+Cmd+F7</td>
<td>Tools &gt; Language &gt; Hangul / Hanja Conversion. The availability of this menu</td>
</tr>
<tr>
<td></td>
<td>option depends on selections in LibreOffice &gt; Preferences &gt; Language Setting &gt; Languages.</td>
</tr>
<tr>
<td>Shift+F7</td>
<td>Tools &gt; Automatic Spell Checking.</td>
</tr>
<tr>
<td>Cmd+F8</td>
<td>View &gt; Value Highlighting.</td>
</tr>
<tr>
<td>F9</td>
<td>Data &gt; Calculate &gt; Recalculate.</td>
</tr>
<tr>
<td>Shift+F9</td>
<td>Tools &gt; Detective &gt; Trace Precedents.</td>
</tr>
<tr>
<td>Shift+Cmd+F9</td>
<td>Data &gt; Calculate &gt; Recalculate Hard.</td>
</tr>
<tr>
<td>Cmd+T</td>
<td>View &gt; Styles.</td>
</tr>
<tr>
<td></td>
<td>Styles &gt; Manage Styles.</td>
</tr>
<tr>
<td>Shift+F11</td>
<td>File &gt; Templates &gt; Save as Template.</td>
</tr>
<tr>
<td></td>
<td>Via Save icon's drop-down menu in Standard toolbar.</td>
</tr>
<tr>
<td></td>
<td>Note: For some macOS versions, this key sequence is used by macOS to show its desktop and so cannot be used to access</td>
</tr>
<tr>
<td></td>
<td>Calc’s Save as Template dialog.</td>
</tr>
<tr>
<td>F12</td>
<td>Data &gt; Group and Outline &gt; Group.</td>
</tr>
<tr>
<td>Cmd+F12</td>
<td>Data &gt; Group and Outline &gt; Ungroup.</td>
</tr>
<tr>
<td>Cmd+</td>
<td>LibreOffice &gt; Preferences.</td>
</tr>
</tbody>
</table>

Table 31: Number key shortcuts for menu and toolbar options

<table>
<thead>
<tr>
<th>macOS</th>
<th>Equivalent Menu bar / toolbar option</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cmd+1</td>
<td>Format &gt; Cells.</td>
</tr>
<tr>
<td>Ctrl+Shift+1</td>
<td>Format &gt; Number Format &gt; Number (use the “1” key on the main keyboard).</td>
</tr>
<tr>
<td></td>
<td>Format as Number icon in Formatting toolbar.</td>
</tr>
<tr>
<td>Ctrl+Shift+2</td>
<td>Format &gt; Number Format &gt; Scientific (use the “2” key on the main keyboard).</td>
</tr>
<tr>
<td>Ctrl+Shift+3</td>
<td>Format &gt; Number Format &gt; Date (use the “3” key on the main keyboard).</td>
</tr>
<tr>
<td></td>
<td>Format as Date icon in Formatting toolbar.</td>
</tr>
<tr>
<td>Ctrl+Shift+4</td>
<td>Format &gt; Number Format &gt; Currency (use the “4” key on the main keyboard).</td>
</tr>
<tr>
<td></td>
<td>Format as Currency icon in Formatting toolbar.</td>
</tr>
<tr>
<td>Ctrl+Shift+5</td>
<td>Format &gt; Number Format &gt; Percent (use the “5” key on the main keyboard).</td>
</tr>
<tr>
<td></td>
<td>Format as Percent icon in Formatting toolbar.</td>
</tr>
<tr>
<td>Ctrl+Shift+6</td>
<td>Format &gt; Number Format &gt; General (use the “6” key on the main keyboard).</td>
</tr>
</tbody>
</table>

Note

The Format > Spacing menu appears to provide shortcuts for Line Spacing: 1.5 (Cmd+5) and Line Spacing: 2 (Cmd+2). However these options are never active in Calc 6.4 and so the shortcuts are not included in Table 31.
Table 32: Letter key shortcuts for menu and toolbar options

<table>
<thead>
<tr>
<th>macOS</th>
<th>Equivalent Menu bar / toolbar option</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cmd+B</td>
<td>Format &gt; Text &gt; Bold. Bold icon in Formatting toolbar.</td>
</tr>
<tr>
<td>Shift+Cmd+B</td>
<td>Format &gt; Text &gt; Subscript.</td>
</tr>
<tr>
<td>Cmd+C</td>
<td>Edit &gt; Copy. Copy icon in Standard toolbar.</td>
</tr>
<tr>
<td>Option+Cmd+C</td>
<td>Insert &gt; Comment. Insert Comment icon in Standard toolbar.</td>
</tr>
<tr>
<td>Cmd+D</td>
<td>Sheet &gt; Fill Cells &gt; Fill Down.</td>
</tr>
<tr>
<td>Cmd+E</td>
<td>Format &gt; Align &gt; Centered. Align Center icon in Formatting toolbar.</td>
</tr>
<tr>
<td>Option+Cmd+E</td>
<td>Tools &gt; Extension Manager.</td>
</tr>
<tr>
<td>Cmd+F</td>
<td>Edit &gt; Find.</td>
</tr>
<tr>
<td>Option+Cmd+F</td>
<td>Edit &gt; Find &amp; Replace. Find &amp; Replace icon in Standard toolbar.</td>
</tr>
<tr>
<td>Cmd+H</td>
<td>LibreOffice &gt; Hide LibreOffice.</td>
</tr>
<tr>
<td>Cmd+I</td>
<td>Format &gt; Text &gt; Italic. Italic icon in Formatting toolbar.</td>
</tr>
<tr>
<td>Cmd+J</td>
<td>Format &gt; Align &gt; Justified.</td>
</tr>
<tr>
<td>Ctrl+Cmd+F</td>
<td>View &gt; Full Screen.</td>
</tr>
<tr>
<td>Cmd+K</td>
<td>Insert &gt; Hyperlink. Insert Hyperlink icon in Standard toolbar.</td>
</tr>
<tr>
<td>Cmd+L</td>
<td>Format &gt; Align &gt; Left. Align Left icon in Formatting toolbar.</td>
</tr>
<tr>
<td>Shift+Cmd+M</td>
<td>Edit &gt; Edit Mode.</td>
</tr>
<tr>
<td>Cmd+O</td>
<td>File &gt; Open. Open icon in Standard toolbar.</td>
</tr>
<tr>
<td>Shift+Cmd+P</td>
<td>Format &gt; Text &gt; Superscript.</td>
</tr>
<tr>
<td>Cmd+Q</td>
<td>LibreOffice &gt; Quit LibreOffice.</td>
</tr>
<tr>
<td>Cmd+R</td>
<td>Format &gt; Align &gt; Right. Align Right icon in Formatting toolbar.</td>
</tr>
<tr>
<td>macOS</td>
<td>Equivalent Menu bar / toolbar option</td>
</tr>
<tr>
<td>-----------</td>
<td>--------------------------------------</td>
</tr>
<tr>
<td>Cmd+S</td>
<td>File &gt; Save.</td>
</tr>
<tr>
<td></td>
<td>Save icon in Standard toolbar.</td>
</tr>
<tr>
<td>Shift+Cmd+S</td>
<td>File &gt; Save As.</td>
</tr>
<tr>
<td>Cmd+U</td>
<td>Underline icon in Formatting toolbar.</td>
</tr>
<tr>
<td>Cmd+V</td>
<td>Edit &gt; Paste.</td>
</tr>
<tr>
<td></td>
<td>Paste icon in Standard toolbar.</td>
</tr>
<tr>
<td>Shift+Cmd+V</td>
<td>Edit &gt; Paste Special &gt; Paste Special.</td>
</tr>
<tr>
<td>Option+⌥+Cmd+V</td>
<td>Edit &gt; Paste Special &gt; Paste Unformatted Text.</td>
</tr>
<tr>
<td>Cmd+W</td>
<td>Window &gt; Close Window.</td>
</tr>
<tr>
<td>Cmd+X</td>
<td>Edit &gt; Cut.</td>
</tr>
<tr>
<td></td>
<td>Cut icon in Standard toolbar.</td>
</tr>
<tr>
<td>Cmd+Y</td>
<td>Edit &gt; Redo.</td>
</tr>
<tr>
<td></td>
<td>Redo icon in Standard toolbar.</td>
</tr>
<tr>
<td>Shift+Cmd+Y</td>
<td>Edit &gt; Repeat.</td>
</tr>
<tr>
<td>Cmd+Z</td>
<td>Edit &gt; Undo.</td>
</tr>
<tr>
<td></td>
<td>Undo icon in Standard toolbar.</td>
</tr>
</tbody>
</table>

**Table 33: Other shortcuts for menu and toolbar options**

<table>
<thead>
<tr>
<th>macOS</th>
<th>Equivalent Menu bar / toolbar option</th>
</tr>
</thead>
<tbody>
<tr>
<td>Shift+Cmd+Pg Up</td>
<td>Edit &gt; Select &gt; Select to Previous Sheet. (In Calc 6.4, the menu option indicates an up arrow symbol rather than a page up symbol).</td>
</tr>
<tr>
<td>Shift+Cmd+Pg Dn</td>
<td>Edit &gt; Select &gt; Select to Next Sheet. (In Calc 6.4, the menu option indicates a down arrow symbol rather than a page down symbol).</td>
</tr>
<tr>
<td>Delete</td>
<td>Sheet &gt; Clear Cells.</td>
</tr>
<tr>
<td>Ctrl+Space</td>
<td>Edit &gt; Select &gt; Select Column.</td>
</tr>
<tr>
<td>Shift+Space</td>
<td>Edit &gt; Select &gt; Select Row.</td>
</tr>
<tr>
<td>Ctrl+Shift+Space +Cmd+A</td>
<td>Edit &gt; Select All.</td>
</tr>
<tr>
<td>Cmd++</td>
<td>Sheet &gt; Insert Cells (use the + key on the numeric keypad).</td>
</tr>
<tr>
<td>Cmd+-</td>
<td>Sheet &gt; Delete Cells.</td>
</tr>
<tr>
<td>Cmd++</td>
<td>Edit &gt; Select &gt; Select Data Area.</td>
</tr>
<tr>
<td>Cmd++;</td>
<td>Insert &gt; Date.</td>
</tr>
</tbody>
</table>

**Other Calc keyboard shortcuts**

Tables 34 to 39 provide lists of additional Calc keyboard shortcuts that may be less obvious to users because they are not indicated on Menu bar items or in tooltips associated with icons in the Standard and Formatting toolbars.

**Table 34: Other function key shortcuts**

<table>
<thead>
<tr>
<th>macOS</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Shift+F1</td>
<td>Display context sensitive help.</td>
</tr>
<tr>
<td>Cmd+F1</td>
<td>Display the comment attached to the current cell.</td>
</tr>
</tbody>
</table>
### Table 35: Other letter key shortcuts

<table>
<thead>
<tr>
<th>macOS</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Shift+Cmd+C</td>
<td>Start / stop tracking changes.</td>
</tr>
<tr>
<td>Cmd+G</td>
<td>Repeat search forwards.</td>
</tr>
<tr>
<td>Shift+Cmd+R</td>
<td>Redraws the document view.</td>
</tr>
<tr>
<td>Shift+Cmd+Z</td>
<td>Reverses the action of the last undo command.</td>
</tr>
</tbody>
</table>

### Table 36: Arrow key shortcuts

<table>
<thead>
<tr>
<th>macOS</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>⤤</td>
<td>Moves the cell focus up.</td>
</tr>
<tr>
<td>Cmd+⤤</td>
<td>Moves the cursor in the up direction to the edge of the current data range (if the cell adjacent to the cursor is empty, the cursor moves to the next cell that contains data).</td>
</tr>
<tr>
<td>Shift+⤤</td>
<td>Selects the adjacent cell or cells located in the up direction.</td>
</tr>
<tr>
<td>Shift+Cmd+⤤</td>
<td>Selects in the up direction to the edge of the current data range (if the cell adjacent to the cursor is empty, the cursor moves to the next cell that contains data).</td>
</tr>
<tr>
<td>Option+Shift+⤤</td>
<td>Optimizes the row height based on the current cell.</td>
</tr>
<tr>
<td>⤣</td>
<td>Moves the cell focus right.</td>
</tr>
<tr>
<td>Cmd+⤣</td>
<td>Moves the cursor in the right direction to the edge of the current data range (if the cell adjacent to the cursor is empty, the cursor moves to the next cell that contains data).</td>
</tr>
<tr>
<td>Shift+⤣</td>
<td>Selects the adjacent cell or cells located in the right direction.</td>
</tr>
<tr>
<td>Shift+Cmd+⤣</td>
<td>Selects in the right direction to the edge of the current data range (if the cell adjacent to the cursor is empty, the cursor moves to the next cell that contains data).</td>
</tr>
<tr>
<td>Option+⤣</td>
<td>Increases the width of the current column.</td>
</tr>
<tr>
<td>Option+Shift+⤣</td>
<td>Optimizes the column width based on the current cell.</td>
</tr>
<tr>
<td>⤨</td>
<td>Moves the cell focus down.</td>
</tr>
<tr>
<td>Cmd+⤨</td>
<td>Moves the cursor in the down direction to the edge of the current data range (if the cell adjacent to the cursor is empty, the cursor moves to the next cell that contains data).</td>
</tr>
<tr>
<td>Option+⤨</td>
<td>Opens a drop-down selection list of text items that have been previously typed into other cells in the same column.</td>
</tr>
<tr>
<td>Shift+⤨</td>
<td>Selects the adjacent cell or cells located in the down direction.</td>
</tr>
</tbody>
</table>

480 | macOS keyboard shortcuts
### Table 37: Home and End key shortcuts

<table>
<thead>
<tr>
<th>macOS</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Home</td>
<td>Moves the cursor to the first cell of the current row.</td>
</tr>
<tr>
<td>Cmd+Home</td>
<td>Moves the cursor to the first cell (A1) in the current sheet.</td>
</tr>
<tr>
<td>Shift+Home</td>
<td>Selects cells from the cursor to the first cell of the current row.</td>
</tr>
<tr>
<td>Shift+Cmd+Home</td>
<td>Selects all cells from the cursor to the first cell (A1) in the current sheet.</td>
</tr>
<tr>
<td>End</td>
<td>Moves the cursor along the current row to the cell in the last column containing data in the sheet.</td>
</tr>
<tr>
<td>Cmd+End</td>
<td>Moves the cursor to the cell in the last column and row that contain data in the current sheet.</td>
</tr>
<tr>
<td>Shift+End</td>
<td>Selects cells along the current row from the cursor to the cell in the last column containing data in the sheet.</td>
</tr>
<tr>
<td>Shift+Cmd+End</td>
<td>Selects all cells from the cursor to the cell in the last column and row that contain data in the current sheet.</td>
</tr>
</tbody>
</table>

### Table 38: Other Page Up and Down key shortcuts

<table>
<thead>
<tr>
<th>macOS</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pg Up</td>
<td>Moves up one screen page.</td>
</tr>
<tr>
<td>Cmd+Pg Up</td>
<td>Moves to the previous sheet.</td>
</tr>
<tr>
<td>Shift+Pg Dn</td>
<td>Selects cells from the cursor to the row one page up.</td>
</tr>
<tr>
<td>Option+Pg Dn</td>
<td>Moves one screen page to the left.</td>
</tr>
<tr>
<td>Option+Shift+Pg Dn</td>
<td>Selects cells from the cursor to the column one page to the left.</td>
</tr>
<tr>
<td>Pg Dn</td>
<td>Moves down one screen page.</td>
</tr>
<tr>
<td>Cmd+Pg Dn</td>
<td>Moves to the next sheet.</td>
</tr>
<tr>
<td>Shift+Pg Dn</td>
<td>Selects cells from the cursor to the row one page down.</td>
</tr>
<tr>
<td>Option+Pg Up</td>
<td>Moves one screen page to the right.</td>
</tr>
<tr>
<td>macOS</td>
<td>Description</td>
</tr>
<tr>
<td>------------</td>
<td>-----------------------------------------------------------------------------</td>
</tr>
<tr>
<td>Option+Shift+Pg Up</td>
<td>Selects cells from the cursor to the column one page to the right.</td>
</tr>
</tbody>
</table>

**Table 39: Other miscellaneous key shortcuts**

<table>
<thead>
<tr>
<th>macOS</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>esc</td>
<td>Cancels the current cell edit.</td>
</tr>
<tr>
<td>Fwd Del</td>
<td>Deletes cell contents without a dialog (does not remove formatting).</td>
</tr>
<tr>
<td>Cmd+Delete</td>
<td>Refocuses the view back on the cursor if it is not currently in view.</td>
</tr>
<tr>
<td>Option+Delete</td>
<td>Reverses the last command or the last entry you typed.</td>
</tr>
<tr>
<td>Cmd+[</td>
<td>Selects the cells on which the current cell is dependent.</td>
</tr>
<tr>
<td>Cmd+]</td>
<td>Selects the cells that are dependent on the current cell.</td>
</tr>
<tr>
<td>Cmd+/</td>
<td>Use the forward slash key on the main keyboard or the numeric keypad.</td>
</tr>
<tr>
<td></td>
<td>Selects the cells in the matrix formula range that contains the cursor.</td>
</tr>
<tr>
<td>Cmd+'</td>
<td>Use the single apostrophe key.</td>
</tr>
<tr>
<td></td>
<td>Copies the contents of the cell above the cursor into the current cell, but remains in cell edit mode so that you can make further changes.</td>
</tr>
<tr>
<td>Enter</td>
<td>Moves the cursor to the next cell in the selected range, from top to bottom, then left to right. To specify in which direction the cursor moves, go to LibreOffice &gt; Preferences &gt; LibreOffice Calc &gt; General in the Menu bar.</td>
</tr>
<tr>
<td>Cmd+Enter</td>
<td>Inserts a manual line break in the current cell while editing a cell.</td>
</tr>
<tr>
<td>Shift+Cmd+Enter</td>
<td>Creates a matrix in the current range using the information entered on the input line.</td>
</tr>
<tr>
<td>Option+Enter</td>
<td>Fills the selected cell range with the formula that you entered on the input line.</td>
</tr>
</tbody>
</table>

**Chart keyboard shortcuts**

Table 40 lists some shortcuts that are available within a Calc chart.

---

### Tip

You can use the **Option** key with the arrow keys and plus (+) and minus (-) keys to move elements with a finer degree of movement for more accuracy.

---

<table>
<thead>
<tr>
<th>macOS</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>⇨</td>
<td>Selects the next chart element.</td>
</tr>
<tr>
<td>Shift+⇨</td>
<td>Selects the previous chart element.</td>
</tr>
<tr>
<td>Home</td>
<td>Selects the first chart element.</td>
</tr>
<tr>
<td>End</td>
<td>Selects the last chart element.</td>
</tr>
<tr>
<td>esc</td>
<td>Cancels selection.</td>
</tr>
<tr>
<td>Arrow keys</td>
<td>Moves the element in the direction of the arrow.</td>
</tr>
<tr>
<td>Arrow keys in pie charts</td>
<td>Moves the selected pie segment in the direction of the arrow.</td>
</tr>
<tr>
<td>F2 in titles</td>
<td>Enters text input mode.</td>
</tr>
</tbody>
</table>

---

482 | macOS keyboard shortcuts
### Outline keyboard shortcuts

Table 41 lists shortcuts that are available in an outline window. To use these shortcuts, press F6 or Shift+F6 until the vertical or horizontal outline window has the focus.

**Table 41: Outline shortcuts**

<table>
<thead>
<tr>
<th>macOS</th>
<th>Effect</th>
</tr>
</thead>
<tbody>
<tr>
<td>F3 in legends and data series</td>
<td>Opens groups so that you can edit the individual components.</td>
</tr>
<tr>
<td>Cmd+F3 in legends and data series</td>
<td>Exits groups.</td>
</tr>
</tbody>
</table>

### Keyboard shortcuts that cannot be modified

Table 42 identifies the key combinations that are grayed out in the Shortcut Keys list on the Tools > Customize > Keyboard dialog with the Calc radio button selected.

**Table 42: Grayed Key Combinations in Tools > Customize > Keyboard**

<table>
<thead>
<tr>
<th>Operating System</th>
<th>Key Combinations Grayed in Customize Dialog</th>
</tr>
</thead>
<tbody>
<tr>
<td>macOS</td>
<td>F1, Cmd+F1, Shift+F1</td>
</tr>
<tr>
<td></td>
<td>Shift+F2</td>
</tr>
<tr>
<td></td>
<td>Cmd+F4, Option+F4, Cmd+Option+F4</td>
</tr>
<tr>
<td></td>
<td>F6, Cmd+F6, Shift+F6, Shift+Cmd+F6</td>
</tr>
<tr>
<td></td>
<td>F10</td>
</tr>
<tr>
<td></td>
<td>Shift+Cmd+0, Shift+Cmd+1, Shift+Cmd+2, Shift+Cmd+3, Shift+Cmd+4, Shift+Cmd+5, Shift+Cmd+6, Shift+Cmd+7, Shift+Cmd+8, Shift+Cmd+9</td>
</tr>
</tbody>
</table>
Appendix B

Error Codes
### Introduction to Calc error codes

Calc provides feedback for errors of miscalculation, incorrect use of functions, invalid cell references and values, and other user-initiated mistakes. The feedback may be displayed within the cell that contains the error (Figure 490), or on the Status bar (Figure 491), or in both, depending on the type of error. Generally speaking, if the error occurs in the cell that is selected (or contains the cursor), the error message is displayed on the Status bar.

As an example, Figure 490 shows the error code returned when a column is too narrow to display the entire formatted date. The date displayed within the input line, 04/05/1998, would fit within the cell without a problem, but the format used by the cell produces the date value *Sunday, April 05, 1998*.

![Table 43](image)

**Figure 490: Error codes displayed within cells**

When the cell displaying the #REF error code in Figure 490 is selected, the Status bar displays the error message as shown in Figure 491. This message is more descriptive than the message displayed in the cell, but it still may not provide enough information to correctly diagnose the problem. For fuller explanations, consult the following tables and the Help topic, *Error Codes in LibreOffice Calc*.

![Status Bar Error Message](image)

**Figure 491: An error message displayed in the Status bar**

This appendix presents error codes in two tables.

1. Table 43 lists error strings which are displayed within the cell that actually contains the error. Except in the case of the #### error, they all correspond to a Calc error code number. Alphanumeric codes such as *Err502* and *Err511* can also appear in cells; these are not separately identified in the Table 43 but their meanings are given in Table 44.

2. Table 44 explains all of the error codes, listed by code number, including those error codes in the first table.

### Tip

You can use the ERRORTYPE() function to find the code number for an error occurring in a different cell. Refer to the Help system for more detail about this function.
### Error codes displayed within cells

**Table 43: Error codes in cells**

<table>
<thead>
<tr>
<th>Code</th>
<th>Message</th>
<th>Explanation of the error</th>
</tr>
</thead>
<tbody>
<tr>
<td>N/A</td>
<td>####</td>
<td>The column is too narrow to display the complete formatted contents of the cell. This is not really an error value, so there is no corresponding numerical error code. The solutions to this problem are to increase the width of the column, or select <strong>Format &gt; Cells &gt; Alignment</strong> and click either <em>Wrap text automatically</em> or <em>Shrink to fit cell size</em> to make the text match the current column width.</td>
</tr>
<tr>
<td>503</td>
<td>#NUM!</td>
<td>A calculation resulted in an overflow of the defined value range.</td>
</tr>
<tr>
<td>519</td>
<td>#VALUE!</td>
<td>The formula within the cell returns a value that does not correspond to the definition of the formula or functions used. This error could also mean that the cell referenced by the formula contains text instead of a number.</td>
</tr>
<tr>
<td>524</td>
<td>#REF!</td>
<td>The formula within the cell uses a reference that does not exist. Either a column or row description name could not be resolved, or the column, row, or sheet that contains a referenced cell is missing.</td>
</tr>
<tr>
<td>525</td>
<td>#NAME?</td>
<td>An identifier could not be evaluated: no valid reference, no valid domain name, no column/row label, no macro, incorrect decimal divider, add-in not found. For example, entering in a cell =sum(bob*5) where there is no cell named “bob” or containing the text “bob” generates this error.</td>
</tr>
<tr>
<td>532</td>
<td>#DIV/0!</td>
<td>Division operator / if the denominator is 0. Some more functions return this error; see next table for details.</td>
</tr>
</tbody>
</table>

### General error codes

The following table is an overview of the most common error messages for LibreOffice Calc.

**Note**

Errors described as *Internal errors* should not be encountered by users under normal conditions. Errors listed as *Not used* are not currently assigned to any error condition and will not occur.

**Table 44: List of error codes**

<table>
<thead>
<tr>
<th>Code</th>
<th>Message</th>
<th>Explanation of the error</th>
</tr>
</thead>
<tbody>
<tr>
<td>501</td>
<td>Invalid character</td>
<td>Character in a formula is not valid. This error is the same as the <em>Invalid Name</em> error (525) except that it occurs within a formula. The cell containing the error will display the #NAME? error reference.</td>
</tr>
<tr>
<td>502</td>
<td>Invalid argument</td>
<td>Function argument is not valid; for example, a negative number for the SQRT() function. This error also occurs if more than one matching cell is found by the DGET() function.</td>
</tr>
<tr>
<td>Code</td>
<td>Message</td>
<td>Explanation of the error</td>
</tr>
<tr>
<td>------</td>
<td>---------</td>
<td>-------------------------</td>
</tr>
<tr>
<td>503</td>
<td>Invalid floating point operation (cell displays #NUM!)</td>
<td>Division by 0, or another calculation that results in an overflow of the defined value range (a value too big or too small).</td>
</tr>
<tr>
<td>504</td>
<td>Parameter list error</td>
<td>Function parameter is not valid; for example, text instead of a number, or a domain reference instead of a cell reference.</td>
</tr>
<tr>
<td>505</td>
<td>Internal syntax error</td>
<td>Not used.</td>
</tr>
<tr>
<td>506</td>
<td>Invalid semicolon</td>
<td>Not used.</td>
</tr>
<tr>
<td>507</td>
<td>Pair missing</td>
<td>Not used.</td>
</tr>
<tr>
<td>508</td>
<td>Pair missing</td>
<td>Missing bracket or parenthesis; for example, closing brackets but no opening brackets.</td>
</tr>
<tr>
<td>509</td>
<td>Missing operator</td>
<td>Operator is missing; for example, “=2 (3+4) * ”, where the operator between “2” and “(” is missing.</td>
</tr>
<tr>
<td>510</td>
<td>Missing variable</td>
<td>Variable is missing; for example, when two operators are together “=1+2”.</td>
</tr>
<tr>
<td>511</td>
<td>Missing variable</td>
<td>Function requires more variables than are provided; for example, AND() and OR().</td>
</tr>
<tr>
<td>512</td>
<td>Formula overflow</td>
<td>The total number of internal tokens (that is, operators, variables, brackets) in the formula exceeds 8192, or the total number of matrices the formula creates exceeds 150. This includes basic functions that receive too large an array as a parameter.</td>
</tr>
<tr>
<td>513</td>
<td>String overflow</td>
<td>An identifier in the formula exceeds 64 KB in size, or a result of a string operation exceeds 64 KB in size.</td>
</tr>
<tr>
<td>514</td>
<td>Internal overflow</td>
<td>Sort operation attempted on too much numerical data (max. 100000) or a calculation stack overflow.</td>
</tr>
<tr>
<td>515</td>
<td>Internal syntax error</td>
<td>Not used.</td>
</tr>
<tr>
<td>516</td>
<td>Internal syntax error</td>
<td>Matrix is expected on the calculation stack, but is not available.</td>
</tr>
<tr>
<td>517</td>
<td>Internal syntax error</td>
<td>Unknown error; for example, a document with a newer function is loaded in an older version of Calc that does not contain the function.</td>
</tr>
<tr>
<td>518</td>
<td>Internal syntax error</td>
<td>Variable is not available.</td>
</tr>
<tr>
<td>519</td>
<td>No result (cell displays #VALUE!)</td>
<td>Formula yields a value that does not correspond to the definition, or a cell that is referenced in the formula contains text instead of a number.</td>
</tr>
<tr>
<td>520</td>
<td>Internal syntax error</td>
<td>Compiler creates an unknown compiler code.</td>
</tr>
<tr>
<td>521</td>
<td>Internal syntax error</td>
<td>No result.</td>
</tr>
<tr>
<td>Code</td>
<td>Message</td>
<td>Explanation of the error</td>
</tr>
<tr>
<td>-------</td>
<td>----------------------------------------------</td>
<td>------------------------------------------------------------------------------------------------------------------------------------------------------</td>
</tr>
<tr>
<td>522</td>
<td>Circular reference</td>
<td>Formula refers directly or indirectly to itself and the <strong>Iterations</strong> option is not selected under <strong>Tools &gt; Options &gt; LibreOffice Calc &gt; Calculate</strong>.</td>
</tr>
<tr>
<td>523</td>
<td>The calculation procedure does not converge</td>
<td>Financial statistics function missed a targeted value, or iterations of circular references do not reach the minimum change within the maximum steps that are set.</td>
</tr>
<tr>
<td>524</td>
<td>Invalid references (cell displays #REF!)</td>
<td>A column or row description name could not be resolved, or the column, row, or sheet that contains a referenced cell is missing.</td>
</tr>
<tr>
<td>525</td>
<td>Invalid names (cell displays #NAME?)</td>
<td>An identifier could not be evaluated; for example, no valid reference, no valid domain name, no column/row label, no macro, incorrect decimal divider, add-in not found.</td>
</tr>
<tr>
<td>526</td>
<td>Internal syntax error</td>
<td>Obsolete, no longer used, but could come from old documents if the result is a formula from a domain.</td>
</tr>
<tr>
<td>527</td>
<td>Internal overflow</td>
<td>References, such as when a cell references a cell, are too encapsulated or deeply nested. This is an internal error and should not be displayed in LibreOffice.</td>
</tr>
<tr>
<td>528–531</td>
<td>—</td>
<td>Not used.</td>
</tr>
<tr>
<td>532</td>
<td>Division by zero (cell displays #DIV/0!)</td>
<td>Division operator / if the denominator is 0. Some more functions return this error; for example: VARP with less than 1 argument</td>
</tr>
<tr>
<td></td>
<td></td>
<td>STDEVP with less than 1 argument</td>
</tr>
<tr>
<td></td>
<td></td>
<td>VAR with less than 2 arguments</td>
</tr>
<tr>
<td></td>
<td></td>
<td>STDEV with less than 2 arguments</td>
</tr>
<tr>
<td></td>
<td></td>
<td>STANDARDIZE with stdev=0</td>
</tr>
<tr>
<td></td>
<td></td>
<td>NORMDIST with stdev=0</td>
</tr>
<tr>
<td>533</td>
<td>Nested arrays are not supported</td>
<td>For example, “={1;{2}}”</td>
</tr>
<tr>
<td>538</td>
<td>Error: Array or matrix size</td>
<td>-</td>
</tr>
<tr>
<td>539</td>
<td>Unsupported inline array content</td>
<td>For example, “={1+2}”</td>
</tr>
<tr>
<td>540</td>
<td>External content disabled</td>
<td>Occurs when a function that requires (re)loading of external sources is encountered and the user hasn't confirmed reloading of external sources yet.</td>
</tr>
</tbody>
</table>
Alphabetical index

3
3D charts.................................................................123
3D View dialog......................................................124

A
absolute hyperlinks...........................................343
absolute referencing..........................................230
accepting changes.............................................378
advanced filters................................................79, 426
aligning images...............................................192
Alternative Python Script Organizer (APSO) extension..404
Analysis of Variance (ANOVA) dialog...................316
anchoring images.............................................191
Apply Style list..................................................162
area charts......................................................146
arguments, passing to macros.........................394
arithmetic operators..........................................225
arranging images.............................................191
array formulas...............................................241
AutoCorrect....................................................45, 453
AutoFilters......................................................78, 421
AutoFormat......................................................65
AutoInput........................................................47
AutoOutline....................................................76
axes of a chart................................................111
Axis dialog......................................................112

B
background, formatting for cell..........................65
bar charts........................................................143
Base, launching to edit data sources....................359
Basic macro programming................................383
BeanShell macro programming.........................400
borders, formatting for cell..............................64
bubble charts..................................................152
button hyperlinks...........................................344

calc options, setting..........................................446
calculate..........................................................446
changes.............................................................450
compatibility..................................................451
defaults..............................................................443
formula.............................................................448
general.............................................................441
grid.................................................................451
print.................................................................452
sort lists..........................................................450
view.................................................................443
Calc, list of main features..................................8, 15
Chart types............................................................................................................................. 123
3D............................................................................................................................................. 123
Area........................................................................................................................................... 146
Bar............................................................................................................................................. 143
Bubble......................................................................................................................................... 152
Changing..................................................................................................................................... 100
Column......................................................................................................................................... 142
Column and line......................................................................................................................... 157
Line............................................................................................................................................. 147
Net............................................................................................................................................... 153
Pie................................................................................................................................................ 144
Pivot............................................................................................................................................... 158
Scatter or XY................................................................................................................................. 149
Stock............................................................................................................................................ 154
Chart Wizard................................................................................................................................ 87
Overview..................................................................................................................................... 87
Selecting chart type...................................................................................................................... 88
Selecting data range..................................................................................................................... 89
Selecting data series...................................................................................................................... 90

Alphabetical index | 491
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>selecting elements charts.</td>
<td>92</td>
</tr>
<tr>
<td>adding drawing objects</td>
<td>134</td>
</tr>
<tr>
<td>axes</td>
<td>111</td>
</tr>
<tr>
<td>background</td>
<td>103</td>
</tr>
<tr>
<td>chart type</td>
<td>88, 100</td>
</tr>
<tr>
<td>copying</td>
<td>140</td>
</tr>
<tr>
<td>data labels</td>
<td>118</td>
</tr>
<tr>
<td>data range and data series</td>
<td>89, 104</td>
</tr>
<tr>
<td>default colors</td>
<td>452</td>
</tr>
<tr>
<td>deleting</td>
<td>140</td>
</tr>
<tr>
<td>edit mode</td>
<td>95</td>
</tr>
<tr>
<td>error bars</td>
<td>131</td>
</tr>
<tr>
<td>exporting images</td>
<td>142</td>
</tr>
<tr>
<td>grid lines</td>
<td>122</td>
</tr>
<tr>
<td>legend</td>
<td>102</td>
</tr>
<tr>
<td>mean value lines</td>
<td>130</td>
</tr>
<tr>
<td>moving</td>
<td>135</td>
</tr>
<tr>
<td>moving elements</td>
<td>99</td>
</tr>
<tr>
<td>overall appearance</td>
<td>139</td>
</tr>
<tr>
<td>pivot</td>
<td>283</td>
</tr>
<tr>
<td>resizing</td>
<td>135</td>
</tr>
<tr>
<td>selecting elements</td>
<td>99</td>
</tr>
<tr>
<td>selecting multiple</td>
<td>139</td>
</tr>
<tr>
<td>Sidebar, using to specify options</td>
<td>93</td>
</tr>
<tr>
<td>title and subtitle</td>
<td>100</td>
</tr>
<tr>
<td>trend lines</td>
<td>126</td>
</tr>
<tr>
<td>chi-square test of independence</td>
<td>329</td>
</tr>
<tr>
<td>clipboard, inserting image from</td>
<td>186</td>
</tr>
<tr>
<td>color coding for input</td>
<td>247</td>
</tr>
<tr>
<td>colors, adding custom</td>
<td>464</td>
</tr>
<tr>
<td>column and line charts</td>
<td>157</td>
</tr>
<tr>
<td>column charts</td>
<td>142</td>
</tr>
<tr>
<td>columns</td>
<td></td>
</tr>
<tr>
<td>deleting</td>
<td>31</td>
</tr>
<tr>
<td>freezing</td>
<td>34</td>
</tr>
<tr>
<td>inserting</td>
<td>30</td>
</tr>
<tr>
<td>maximum number of</td>
<td>15</td>
</tr>
<tr>
<td>repeat printing</td>
<td>205</td>
</tr>
<tr>
<td>selecting</td>
<td>29</td>
</tr>
<tr>
<td>comments</td>
<td>377</td>
</tr>
<tr>
<td>editing</td>
<td>378</td>
</tr>
<tr>
<td>finding</td>
<td>378</td>
</tr>
<tr>
<td>formatting</td>
<td>377</td>
</tr>
<tr>
<td>inserting</td>
<td>377</td>
</tr>
<tr>
<td>comparative operators</td>
<td>225</td>
</tr>
<tr>
<td>comparing spreadsheets</td>
<td>380</td>
</tr>
<tr>
<td>compatibility of functions with other applications</td>
<td>237</td>
</tr>
<tr>
<td>conditional formatting</td>
<td>71</td>
</tr>
</tbody>
</table>
managing..............................................................................................................................70
setting up..............................................................................................................................68
types of..............................................................................................................................70
Consolidate dialog...............................................................................................................288
copying charts......................................................................................................................140
copying sheets......................................................................................................................32
Correlation dialog...............................................................................................................317
Covariance dialog...............................................................................................................318
Create Scenario dialog.......................................................................................................297
creating..................................................................................................................................223
formulas..................................................................................................................................223
pivot charts............................................................................................................................284
pivot tables............................................................................................................................255
spreadsheet................................................................................................................................21
CSV file...................................................................................................................................349
importing.................................................................................................................................21
opening....................................................................................................................................21
custom colors, adding............................................................................................................464

D
dashes, inserting....................................................................................................................46
data.........................................................................................................................................56
editing and deleting.................................................................................................................56
entering...................................................................................................................................42
finding and replacing.............................................................................................................82
formatting...............................................................................................................................60
grouping and outlining...........................................................................................................74
hiding and showing..................................................................................................................72
Data Labels dialog...............................................................................................................118
Data Series dialog................................................................................................................105
data sources............................................................................................................................105
editing...................................................................................................................................359
launching Base.......................................................................................................................359
linking to when registered......................................................................................................355
registering.................................................................................................................................355
using in Calc spreadsheets....................................................................................................360
viewing......................................................................................................................................358
database functions...............................................................................................................429
database primer.......................................................................................................................407
database ranges......................................................................................................................407
creating and managing using the Define Database Range dialog......................................414
creating with macros...............................................................................................................416
overview..................................................................................................................................414
selecting using the Select Database Range dialog...............................................................416
date and time, formatting.......................................................................................................44
DDE (Dynamic Data Exchange) objects..............................................................................361
Define Database Range dialog............................................................................................414
deleting....................................................................................................................................31
cells.........................................................................................................................................31
charts......................................................................................................................................142
columns and rows...................................................................................................................31
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Oxygen icon set</td>
<td>34</td>
</tr>
<tr>
<td>removing</td>
<td>464</td>
</tr>
<tr>
<td>updating</td>
<td>464</td>
</tr>
<tr>
<td>External Data dialog</td>
<td>349</td>
</tr>
<tr>
<td>external data, linking to</td>
<td>349</td>
</tr>
<tr>
<td>F</td>
<td></td>
</tr>
<tr>
<td>F-test dialog</td>
<td>327</td>
</tr>
<tr>
<td>FAQs (frequently asked questions)</td>
<td>12</td>
</tr>
<tr>
<td>feedback, sending about LibreOffice</td>
<td>9</td>
</tr>
<tr>
<td>fields, inserting</td>
<td>59</td>
</tr>
<tr>
<td>fill format mode, using to apply cell styles</td>
<td>162</td>
</tr>
<tr>
<td>fill series</td>
<td>48</td>
</tr>
<tr>
<td>fill tool</td>
<td>47</td>
</tr>
<tr>
<td>filtering</td>
<td></td>
</tr>
<tr>
<td>advanced filters using a macro</td>
<td>427</td>
</tr>
<tr>
<td>advanced filters using the Advanced Filter dialog</td>
<td>426</td>
</tr>
<tr>
<td>AutoFilters</td>
<td>421</td>
</tr>
<tr>
<td>clearing all filters for a sheet using a macro</td>
<td>424</td>
</tr>
<tr>
<td>copying advanced filter results to a different location</td>
<td>428</td>
</tr>
<tr>
<td>data</td>
<td>76</td>
</tr>
<tr>
<td>multiple columns using a macro</td>
<td>425</td>
</tr>
<tr>
<td>standard filters using a macro</td>
<td>422</td>
</tr>
<tr>
<td>standard filters using the Standard Filter dialog</td>
<td>422</td>
</tr>
<tr>
<td>with regular expressions using a macro</td>
<td>425</td>
</tr>
<tr>
<td>Find &amp; Replace dialog</td>
<td>82</td>
</tr>
<tr>
<td>Find toolbar</td>
<td>82</td>
</tr>
<tr>
<td>finding and replacing data</td>
<td>82</td>
</tr>
<tr>
<td>font effects</td>
<td>62</td>
</tr>
<tr>
<td>Fontwork objects</td>
<td>195</td>
</tr>
<tr>
<td>footers and headers</td>
<td>209</td>
</tr>
<tr>
<td>Format menu, options when editing a chart</td>
<td>97</td>
</tr>
<tr>
<td>formatting</td>
<td></td>
</tr>
<tr>
<td>cell background and borders</td>
<td>64</td>
</tr>
<tr>
<td>conditional</td>
<td>68</td>
</tr>
<tr>
<td>data</td>
<td>60</td>
</tr>
<tr>
<td>fonts</td>
<td>62</td>
</tr>
<tr>
<td>numbers</td>
<td>61</td>
</tr>
<tr>
<td>Formatting toolbar</td>
<td>17</td>
</tr>
<tr>
<td>Formatting toolbar, options when editing a chart</td>
<td>98</td>
</tr>
<tr>
<td>Formula bar</td>
<td>17</td>
</tr>
<tr>
<td>formulas</td>
<td></td>
</tr>
<tr>
<td>array</td>
<td>241</td>
</tr>
<tr>
<td>color coding for input</td>
<td>247</td>
</tr>
<tr>
<td>creating</td>
<td>223</td>
</tr>
<tr>
<td>operators in</td>
<td>223</td>
</tr>
<tr>
<td>order of calculation</td>
<td>233</td>
</tr>
<tr>
<td>strategies for creating</td>
<td>243</td>
</tr>
<tr>
<td>value highlighting</td>
<td>247</td>
</tr>
<tr>
<td>Fourier Analysis dialog</td>
<td>330</td>
</tr>
<tr>
<td>freezing columns and rows</td>
<td>34</td>
</tr>
<tr>
<td>Wikipedia categories</td>
<td>Page numbers</td>
</tr>
<tr>
<td>----------------------</td>
<td>-------------</td>
</tr>
<tr>
<td>Functions deck</td>
<td>20, 239</td>
</tr>
<tr>
<td>Galaxy icon set</td>
<td>11</td>
</tr>
<tr>
<td>Goal Seek dialog</td>
<td>306</td>
</tr>
<tr>
<td>GETPIVOTDATA function</td>
<td>11, 19, 187</td>
</tr>
<tr>
<td>grouping and ungrouping</td>
<td>75</td>
</tr>
<tr>
<td>headers and footers</td>
<td>209</td>
</tr>
<tr>
<td>Help menu</td>
<td>8</td>
</tr>
<tr>
<td>hyperlinks</td>
<td>345</td>
</tr>
<tr>
<td>icon sets</td>
<td>10</td>
</tr>
<tr>
<td>illustrations, appearance of</td>
<td>10</td>
</tr>
<tr>
<td>Image toolbar</td>
<td>188</td>
</tr>
</tbody>
</table>

496 | Alphabetical index
images......................................................................................................................................
adding text to.................................................................................................................. 189
additional tools in context menu.................................................................................... 194
aligning............................................................................................................................. 192
anchoring......................................................................................................................... 191
arranging (stacking)........................................................................................................ 191
embedding and linking.................................................................................................... 185
grouping and ungrouping.............................................................................................. 192
inserting from clipboard................................................................................................. 186
inserting from file............................................................................................................ 184
inserting from Gallery deck........................................................................................... 187
inserting from scanner.................................................................................................... 187
modifying........................................................................................................................ 188
moving............................................................................................................................... 190
resizing............................................................................................................................... 190
importing XML source data............................................................................................ 367
independence test (chi-square)....................................................................................... 329
Input line............................................................................................................................ 43
overview........................................................................................................................... 18
Insert menu, options when editing a chart........................................................................ 96
inserting............................................................................................................................. ...
columns and rows............................................................................................................ 30
images............................................................................................................................... 184
page breaks....................................................................................................................... 206
sheets................................................................................................................................. 32, 336
sheets from another spreadsheet................................................................................... 338
special characters............................................................................................................ 44
Integrated Development Environment (IDE) for Basic macro programming................ 389

J
Java JRE (Java Runtime Environment)............................................................................ 13
JavaScript macro programming....................................................................................... 402

K
keyboard shortcuts............................................................................................................
customizing....................................................................................................................... 461
loading saved configuration............................................................................................ 463
macOS.............................................................................................................................. 476
resetting to defaults........................................................................................................ 463
saving to a file.................................................................................................................. 463
that cannot be modified (macOS).................................................................................. 483
that cannot be modified (Windows / Linux)................................................................ 475
using to run macros......................................................................................................... 463
Windows / Linux............................................................................................................ 468
keyboard, using to navigate spreadsheet........................................................................ 27

L
leading zeroes, entering................................................................................................. 42
LibreOffice....................................................................................................................... 12
licensing of....................................................................................................................... 9
restarting with default settings.........................................................................................

Alphabetical index | 497
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>LibreOffice Basic macro programming</td>
<td>383</td>
</tr>
<tr>
<td>LibreOffice options, setting</td>
<td></td>
</tr>
<tr>
<td>advanced</td>
<td>438</td>
</tr>
<tr>
<td>application colors</td>
<td>437</td>
</tr>
<tr>
<td>paths</td>
<td>435</td>
</tr>
<tr>
<td>print</td>
<td>435</td>
</tr>
<tr>
<td>security</td>
<td>435</td>
</tr>
<tr>
<td>user data</td>
<td>435</td>
</tr>
<tr>
<td>view</td>
<td>435</td>
</tr>
<tr>
<td>line breaks</td>
<td>60</td>
</tr>
<tr>
<td>line charts</td>
<td>147</td>
</tr>
<tr>
<td>linear programming, solving problems</td>
<td></td>
</tr>
<tr>
<td>linking images</td>
<td>184</td>
</tr>
<tr>
<td>linking to external data</td>
<td>348</td>
</tr>
<tr>
<td>Linux keyboard shortcuts</td>
<td>468</td>
</tr>
<tr>
<td>loading / unloading macro libraries</td>
<td>392</td>
</tr>
<tr>
<td>loading and saving options</td>
<td></td>
</tr>
<tr>
<td>general</td>
<td>438</td>
</tr>
<tr>
<td>HTML compatibility</td>
<td>440</td>
</tr>
<tr>
<td>Microsoft Office</td>
<td>439</td>
</tr>
<tr>
<td>VBA properties</td>
<td>439</td>
</tr>
<tr>
<td>M</td>
<td></td>
</tr>
<tr>
<td>macOS</td>
<td></td>
</tr>
<tr>
<td>keyboard shortcuts</td>
<td>476</td>
</tr>
<tr>
<td>using LibreOffice on</td>
<td>11</td>
</tr>
<tr>
<td>macro examples</td>
<td></td>
</tr>
<tr>
<td>accessing cells directly</td>
<td>396, 397</td>
</tr>
<tr>
<td>Beanshell</td>
<td>402</td>
</tr>
<tr>
<td>database ranges</td>
<td>416</td>
</tr>
<tr>
<td>filtering</td>
<td>423-425, 427, 428</td>
</tr>
<tr>
<td>JavaScript</td>
<td>403</td>
</tr>
<tr>
<td>named ranges</td>
<td>410, 411, 413</td>
</tr>
<tr>
<td>Python</td>
<td>405</td>
</tr>
<tr>
<td>recorded macro</td>
<td>386</td>
</tr>
<tr>
<td>sorting</td>
<td>398, 417, 418, 420</td>
</tr>
<tr>
<td>writing your own functions</td>
<td>391, 393-395</td>
</tr>
<tr>
<td>macros</td>
<td></td>
</tr>
<tr>
<td>accessing cells with</td>
<td>396</td>
</tr>
<tr>
<td>assigning to events</td>
<td>463</td>
</tr>
<tr>
<td>creating your own functions</td>
<td>387</td>
</tr>
<tr>
<td>deleting</td>
<td>395</td>
</tr>
<tr>
<td>loading and unloading libraries</td>
<td>392</td>
</tr>
<tr>
<td>passing arguments</td>
<td>394</td>
</tr>
<tr>
<td>recording</td>
<td>383</td>
</tr>
<tr>
<td>security warnings</td>
<td>391</td>
</tr>
<tr>
<td>sorting with</td>
<td>398</td>
</tr>
<tr>
<td>writing in Beanshell</td>
<td>400</td>
</tr>
<tr>
<td>writing in JavaScript</td>
<td>402</td>
</tr>
<tr>
<td>writing in LibreOffice Basic</td>
<td>383</td>
</tr>
</tbody>
</table>
writing in Python........................................................................................................404
main window, recognizing components of..............................................................15
manual formatting, removing.................................................................................160
mathematical optimization, solving problems.......................................................308
maximum numbers of sheets, rows, and columns...............................................15
Menu bar................................................................................................................16
menus......................................................................................................................454
Format, options when editing a chart.................................................................97
Help.......................................................................................................................8
Insert, options when editing a chart.................................................................96
Styles..................................................................................................................161
merging...............................................................................................................61
charts...............................................................................................................135
images..........................................................................................................190
sheets..............................................................................................................32
Moving Average dialog......................................................................................321
multi-threading.................................................................................................244
multiple lines of text.........................................................................................60
multiple operations............................................................................................301
one formula and one variable............................................................................301
overview..........................................................................................................301
several formulas simultaneously......................................................................303
two variables....................................................................................................305
Multiple Operations dialog............................................................................301
N
Name Box.............................................................................................................17
named expressions............................................................................................233
named ranges...................................................................................................233
creating and managing with the Define Names dialog....................................408
creating from labels using macros...................................................................412
creating using column or row headers.............................................................412
creating with macros.......................................................................................409
using relative references..................................................................................411
with functions..................................................................................................231
navigating..........................................................................................................231
between cells...................................................................................................25
between sheets.................................................................................................26
using the Enter key............................................................................................28
using the keyboard...........................................................................................27
Navigator...........................................................................................................352
using to link external data................................................................................352
working with scenarios....................................................................................300
Navigator deck..................................................................................................19
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Pivot Table Layout dialog</td>
<td>25</td>
</tr>
<tr>
<td>negative numbers, entering</td>
<td>42</td>
</tr>
<tr>
<td>net charts</td>
<td>153</td>
</tr>
<tr>
<td>non-linear programming, solving problems</td>
<td>308</td>
</tr>
<tr>
<td>notebookbar, customizing</td>
<td>460</td>
</tr>
<tr>
<td>numbers, formatting</td>
<td>61</td>
</tr>
<tr>
<td>ODF (Open Document Format)</td>
<td>23</td>
</tr>
<tr>
<td>OLE (Object Linking and Embedding) objects</td>
<td>361</td>
</tr>
<tr>
<td>opening</td>
<td></td>
</tr>
<tr>
<td>CSV file</td>
<td>21</td>
</tr>
<tr>
<td>spreadsheet</td>
<td>21</td>
</tr>
<tr>
<td>operators</td>
<td></td>
</tr>
<tr>
<td>arithmetic</td>
<td>225</td>
</tr>
<tr>
<td>comparative</td>
<td>225</td>
</tr>
<tr>
<td>in formulas</td>
<td>223</td>
</tr>
<tr>
<td>reference</td>
<td>226</td>
</tr>
<tr>
<td>text</td>
<td>226</td>
</tr>
<tr>
<td>order of calculation</td>
<td>233</td>
</tr>
<tr>
<td>outlining</td>
<td>74</td>
</tr>
<tr>
<td>Oxygen icon set</td>
<td>11</td>
</tr>
<tr>
<td>page breaks, inserting and deleting</td>
<td>206</td>
</tr>
<tr>
<td>Page Style dialog</td>
<td>171, 207</td>
</tr>
<tr>
<td>page styles</td>
<td></td>
</tr>
<tr>
<td>applying</td>
<td>163</td>
</tr>
<tr>
<td>overview</td>
<td>160</td>
</tr>
<tr>
<td>Page Style dialog</td>
<td>171</td>
</tr>
<tr>
<td>printing options</td>
<td>207</td>
</tr>
<tr>
<td>Paired t-test dialog</td>
<td>325</td>
</tr>
<tr>
<td>parallel processing</td>
<td>244</td>
</tr>
<tr>
<td>password protection</td>
<td>25</td>
</tr>
<tr>
<td>Paste Special dialog</td>
<td>58</td>
</tr>
<tr>
<td>PDF Options dialog</td>
<td>211</td>
</tr>
<tr>
<td>PDF, exporting to</td>
<td></td>
</tr>
<tr>
<td>using the Export Directly as PDF icon</td>
<td>211</td>
</tr>
<tr>
<td>using the PDF Options dialog</td>
<td>211</td>
</tr>
<tr>
<td>personal data, removing</td>
<td>220</td>
</tr>
<tr>
<td>pie charts</td>
<td>144</td>
</tr>
<tr>
<td>pivot charts</td>
<td>158</td>
</tr>
<tr>
<td>creating</td>
<td>284</td>
</tr>
<tr>
<td>deleting</td>
<td>286</td>
</tr>
<tr>
<td>differences from other charts</td>
<td>283</td>
</tr>
<tr>
<td>editing</td>
<td>285</td>
</tr>
<tr>
<td>filtering</td>
<td>286</td>
</tr>
<tr>
<td>overview</td>
<td>283</td>
</tr>
<tr>
<td>refreshing / updating changed data</td>
<td>285</td>
</tr>
<tr>
<td>Pivot Table Layout dialog</td>
<td></td>
</tr>
<tr>
<td>additional options</td>
<td>258</td>
</tr>
<tr>
<td>Topic</td>
<td>Page</td>
</tr>
<tr>
<td>----------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>column and row field options</td>
<td>264</td>
</tr>
<tr>
<td>data field options</td>
<td>261</td>
</tr>
<tr>
<td>defining the layout of the pivot table</td>
<td>257</td>
</tr>
<tr>
<td>filter field options</td>
<td>267</td>
</tr>
<tr>
<td>pivot tables</td>
<td>279</td>
</tr>
<tr>
<td>cell formatting of results</td>
<td>267</td>
</tr>
<tr>
<td>changing layout</td>
<td>267</td>
</tr>
<tr>
<td>creating</td>
<td>255</td>
</tr>
<tr>
<td>data sources</td>
<td>255</td>
</tr>
<tr>
<td>database preconditions</td>
<td>254</td>
</tr>
<tr>
<td>deleting</td>
<td>280</td>
</tr>
<tr>
<td>drilling</td>
<td>276</td>
</tr>
<tr>
<td>filtering</td>
<td>277</td>
</tr>
<tr>
<td>GETPIVOTDATA function</td>
<td>280</td>
</tr>
<tr>
<td>grouping columns or rows</td>
<td>269</td>
</tr>
<tr>
<td>grouping date / time values</td>
<td>270</td>
</tr>
<tr>
<td>grouping scalar values</td>
<td>269</td>
</tr>
<tr>
<td>grouping without intervals</td>
<td>272</td>
</tr>
<tr>
<td>refreshing / updating changed values</td>
<td>279</td>
</tr>
<tr>
<td>showing details (drilling)</td>
<td>276</td>
</tr>
<tr>
<td>sorting results</td>
<td>274</td>
</tr>
<tr>
<td>styles</td>
<td>279</td>
</tr>
<tr>
<td>...</td>
<td></td>
</tr>
<tr>
<td>Position and Size dialog</td>
<td></td>
</tr>
<tr>
<td>positioning images</td>
<td>136, 190</td>
</tr>
<tr>
<td>preview before printing</td>
<td>190</td>
</tr>
<tr>
<td>Print dialog</td>
<td>198</td>
</tr>
<tr>
<td>print ranges</td>
<td></td>
</tr>
<tr>
<td>defining</td>
<td>202</td>
</tr>
<tr>
<td>editing</td>
<td>202</td>
</tr>
<tr>
<td>named</td>
<td>203</td>
</tr>
<tr>
<td>removing</td>
<td>204</td>
</tr>
<tr>
<td>viewing</td>
<td>203</td>
</tr>
<tr>
<td>printing</td>
<td></td>
</tr>
<tr>
<td>default settings for LibreOffice</td>
<td>199</td>
</tr>
<tr>
<td>grayscale on a color printer</td>
<td>201</td>
</tr>
<tr>
<td>multiple pages per sheet of paper</td>
<td>200</td>
</tr>
<tr>
<td>options for page styles</td>
<td>207</td>
</tr>
<tr>
<td>repeat printing of rows or columns</td>
<td>205</td>
</tr>
<tr>
<td>selecting what to print</td>
<td>200</td>
</tr>
<tr>
<td>using print preview</td>
<td>201</td>
</tr>
<tr>
<td>using print ranges</td>
<td>202</td>
</tr>
<tr>
<td>using the Print dialog</td>
<td>198</td>
</tr>
<tr>
<td>using the Print Directly icon</td>
<td>198</td>
</tr>
<tr>
<td>Properties deck</td>
<td></td>
</tr>
<tr>
<td>overview</td>
<td>19</td>
</tr>
<tr>
<td>using to change chart properties</td>
<td>93</td>
</tr>
<tr>
<td>using with drawing objects</td>
<td>193</td>
</tr>
<tr>
<td>using with images</td>
<td>189</td>
</tr>
<tr>
<td>Properties dialog</td>
<td>38</td>
</tr>
<tr>
<td>Python macro programming</td>
<td>404</td>
</tr>
</tbody>
</table>
R
ranges.........................................................................................................................408
associating a name.................................................................................................408
database....................................................................................................................414
named.........................................................................................................................408
recording macros......................................................................................................383
reference operators...................................................................................................226
concatenation............................................................................................................227
intersection...............................................................................................................228
overview....................................................................................................................226
range.........................................................................................................................226
references, absolute and relative...............................................................................229
referencing................................................................................................................229
other documents.......................................................................................................342
other sheets...............................................................................................................340
registering data sources............................................................................................355
Regression dialog.....................................................................................................322
regular expressions...................................................................................................250
rejecting changes.......................................................................................................378
relative hyperlinks....................................................................................................343
relative referencing....................................................................................................229
removing personal data............................................................................................220
renaming sheets........................................................................................................34, 338
replacing data............................................................................................................57
resizing.......................................................................................................................135
charts.........................................................................................................................135
drawing objects........................................................................................................194
images.......................................................................................................................190
restarting LibreOffice with default settings.............................................................9
reviewing spreadsheets..............................................................................................9
accepting or rejecting changes..................................................................................378
adding comments to changes...................................................................................377
comparing spreadsheets............................................................................................380
editing comments on changes..................................................................................377
merging spreadsheets...............................................................................................379
preparing a document for review.............................................................................374
recording changes......................................................................................................375
using (general) comments.........................................................................................377
Rhino JavaScript debugger..........................................................................................403
rows..........................................................................................................................30
deleting.......................................................................................................................30
freezing.......................................................................................................................34
inserting......................................................................................................................30
maximum number of.................................................................................................15
repeat printing............................................................................................................205
selecting.....................................................................................................................29
S
Sampling dialog.......................................................................................................313
saving spreadsheet....................................................................................................23
scanner, using to insert image..................................................................................187

502 | Alphabetical index
scatter charts........................................................................................................ 149
scenarios............................................................................................................. 297
creating............................................................................................................. 297
modifying properties and cell values............................................................... 299
overview.......................................................................................................... 297
using the Navigator......................................................................................... 300
screen, splitting............................................................................................... 35
Search Results dialog...................................................................................... 84
security warnings for macros........................................................................... 391
Select Function icon......................................................................................... 17
selecting............................................................................................................ 50
  cells, columns, rows, and sheets................................................................ 28
  chart elements................................................................................................ 99
  multiple charts.............................................................................................. 139
selection lists..................................................................................................... 18
selection modes............................................................................................... 51
shared spreadsheets.......................................................................................... 21
  list of disabled features................................................................................ 373
  opening........................................................................................................... 373
  overview......................................................................................................... 372
  saving.............................................................................................................. 373
  setting up....................................................................................................... 372
sharing content between sheets......................................................................... 19
sheet tabs........................................................................................................... 21
sheets................................................................................................................ 335
  default settings for new sheets.................................................................. 335
  inserting as a link.......................................................................................... 338
  inserting from a different spreadsheet........................................................ 338
  inserting new................................................................................................ 336
  inserting, moving, copying, renaming, and deleting...................................... 32
  linking in calculations................................................................................... 233
  maximum number of..................................................................................... 15
  navigating between....................................................................................... 26
  referencing other sheets.............................................................................. 340
  renaming........................................................................................................ 338
  selecting........................................................................................................ 30
  sharing content between............................................................................... 51
showing hidden data........................................................................................ 74
shrinking text to fit........................................................................................... 61
Sidebar............................................................................................................. 20
  Functions deck.............................................................................................. 239
  Gallery deck................................................................................................. 239
  Navigator deck.............................................................................................. 19
  overview........................................................................................................ 19
Properties deck, overview............................................................................... 19
Properties deck, using to change chart properties.......................................... 93
Properties deck, using with drawing objects.................................................. 189
Properties deck, using with images.................................................................. 193
Styles deck...................................................................................................... 19
  signing documents digitally........................................................................ 161
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>applying signature</td>
<td>218</td>
</tr>
<tr>
<td>overview</td>
<td>218</td>
</tr>
<tr>
<td>signing macros</td>
<td>220</td>
</tr>
<tr>
<td>signing multiple times with same signature</td>
<td>219</td>
</tr>
<tr>
<td>smoothing, exponential</td>
<td>319</td>
</tr>
<tr>
<td>Solver dialog</td>
<td>309</td>
</tr>
<tr>
<td>Sort dialog</td>
<td>79</td>
</tr>
<tr>
<td>sorting</td>
<td>79</td>
</tr>
<tr>
<td>data</td>
<td>418</td>
</tr>
<tr>
<td>multiple columns using a macro</td>
<td>417</td>
</tr>
<tr>
<td>one column using a macro</td>
<td>418</td>
</tr>
<tr>
<td>retrieving sorting information from a range using a macro</td>
<td>419</td>
</tr>
<tr>
<td>using macros</td>
<td>398</td>
</tr>
<tr>
<td>special characters, inserting</td>
<td>44</td>
</tr>
<tr>
<td>splitting cells</td>
<td>51</td>
</tr>
<tr>
<td>splitting the screen (or &quot;window&quot;)</td>
<td>35</td>
</tr>
<tr>
<td>spreadsheets</td>
<td>35</td>
</tr>
<tr>
<td>advice to avoid common pitfalls</td>
<td>222</td>
</tr>
<tr>
<td>comparing</td>
<td>380</td>
</tr>
<tr>
<td>creating, opening, and saving</td>
<td>21</td>
</tr>
<tr>
<td>emailing</td>
<td>217</td>
</tr>
<tr>
<td>embedding</td>
<td>361</td>
</tr>
<tr>
<td>general layout</td>
<td>15, 20</td>
</tr>
<tr>
<td>merging</td>
<td>379</td>
</tr>
<tr>
<td>removing personal data</td>
<td>220</td>
</tr>
<tr>
<td>reviewing</td>
<td>374</td>
</tr>
<tr>
<td>saving versions</td>
<td>380</td>
</tr>
<tr>
<td>sharing with other users</td>
<td>372</td>
</tr>
<tr>
<td>signing digitally</td>
<td>218</td>
</tr>
<tr>
<td>stacking images</td>
<td>191</td>
</tr>
<tr>
<td>Standard (Single Mode) toolbar</td>
<td>17</td>
</tr>
<tr>
<td>standard filters</td>
<td>76, 422</td>
</tr>
<tr>
<td>Standard toolbar</td>
<td>17</td>
</tr>
<tr>
<td>statistics tools</td>
<td>17</td>
</tr>
<tr>
<td>analysis of variance (ANOVA)</td>
<td>316</td>
</tr>
<tr>
<td>correlation</td>
<td>317</td>
</tr>
<tr>
<td>covariance</td>
<td>318</td>
</tr>
<tr>
<td>descriptive statistics</td>
<td>314</td>
</tr>
<tr>
<td>exponential smoothing</td>
<td>319</td>
</tr>
<tr>
<td>F-test</td>
<td>327</td>
</tr>
<tr>
<td>Fourier analysis</td>
<td>330</td>
</tr>
<tr>
<td>moving average</td>
<td>321</td>
</tr>
<tr>
<td>paired t-test</td>
<td>325</td>
</tr>
<tr>
<td>regression</td>
<td>322</td>
</tr>
<tr>
<td>sampling</td>
<td>313</td>
</tr>
<tr>
<td>test of independence (chi-square)</td>
<td>329</td>
</tr>
<tr>
<td>z-test</td>
<td>328</td>
</tr>
<tr>
<td>Status bar</td>
<td>485</td>
</tr>
<tr>
<td>error codes and messages</td>
<td>18</td>
</tr>
</tbody>
</table>

504 | Alphabetical index
stock charts.................................................................154
styles..............................................................................
cell.............................................................................160
copying for cell...........................................................71
creating custom styles...............................................163
deleting........................................................................174
filtrating the list of.......................................................174
hiding and showing cell styles....................................174
modifying......................................................................173
page..............................................................................
pivot table cells.........................................................279
renaming......................................................................173
Styles deck..................................................................19, 161
Styles menu...................................................................161
subtotals.......................................................................291
using the SUBTOTAL function....................................291
using the Subtotals dialog..........................................293
T
t-test, paired...............................................................325
templates.....................................................................325
adding from other sources........................................178
categories....................................................................180
creating.......................................................................176
default, setting and resetting.....................................179
deleting.......................................................................181
editing.........................................................................177
exporting.....................................................................181
moving between categories....................................181
organizing....................................................................180
overview......................................................................174
Start Center, using to create a spreadsheet..............175
Templates dialog, using to create a spreadsheet........175
using to update styles...............................................177
Test of Independence (Chi-Square) dialog...............329
text.............................................................................
adding to drawing objects.......................................189
adding to images......................................................189
automatic wrapping................................................60
changing direction.....................................................63
hyperlinks....................................................................344
inserting manual line break......................................60
operators.....................................................................226
shrinking to fit..........................................................61
Text Import dialog..................................................22, 350
themes.........................................................................66
Title bar.......................................................................15
toolbars........................................................................
customizing...............................................................457
Drawing.......................................................................193
Drawing Object Properties, options when editing a chart...139
Drawing Object Properties, overview.................................................................193
Drawing, options when editing a chart.............................................................134
Find....................................................................................................................82
Formatting, options when editing a chart.........................................................98
Formatting, overview......................................................................................17
Image..................................................................................................................188
overview...........................................................................................................17
Standard.............................................................................................................17
Standard (Single Mode)..................................................................................17
tooltips..............................................................................................................17
tracking changes..............................................................................................375
Trend Line dialog..............................................................................................126

U
unfreezing columns and rows..........................................................................35
updating LibreOffice software...........................................................................9
URLs and hyperlinks..........................................................................................343
user interface, customizing..............................................................................454

V
validating cell contents.....................................................................................52
Validity dialog....................................................................................................53
value highlighting..............................................................................................67, 247
VBA (Visual Basic for Applications) loading and saving options.....................439
versions, saving.................................................................................................380

W
wildcards..........................................................................................................250
Windows keyboard shortcuts..........................................................................468
wrapping text....................................................................................................60

X
XML Source dialog..........................................................................................367
XML, importing source data from....................................................................367
XY charts...........................................................................................................149

Z
z-test dialog......................................................................................................328
zooming the Calc window................................................................................19

#
#error codes and messages............................................................................485
### displayed in cell..........................................................................................486
#DIV/0! error.....................................................................................................246, 486
#NAME? error..................................................................................................486
#NUM! error......................................................................................................486
#REF! error......................................................................................................246, 486
#VALUE! error..................................................................................................246, 486
Calc Guide
Working with spreadsheets

About this book:

This book is for beginners to advanced users of Calc, the spreadsheet component of LibreOffice. It covers the main features of Calc, including: - Entering, editing, and formatting data - Functions and formulas to perform complex calculations on data - Statistic analysis, pivot tables and goal seek for decision making - Database functions to arrange, store, and filter data - A wide range of 2D and 3D charts - Macros - And much more.

If you have never used LibreOffice before, or you want an introduction to all of its components, you might like to read Getting Started with LibreOffice first.

About the authors:

This book was written by volunteers from the LibreOffice community. Profits from sales of the printed edition will be used to benefit the community.

A PDF version of this book can be downloaded free from:

About LibreOffice:

LibreOffice is the free, libre, and open source personal productivity suite from The Document Foundation. It runs on Windows, macOS, and GNU/Linux. Support and documentation is free from our large, dedicated community of users, contributors, and developers. You too can get involved with volunteer work in many areas: development, quality assurance, documentation, translation, user support, and more.

You can download LibreOffice free from